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Chapter 1. Introduction

Trading Manager is client/server software for managing and processing electronic
commerce data. Partner Manager is a component of Trading Manager and is the
graphical user interface application used to create a comprehensive database of an
organization’s electronic commerce (e-commerce) information and to manage its
e-commerce activity.

Overview

This guide focuses on the Partner Manager graphical user interface portion of
Trading Manager. The Trading Manager Installation documentation describes the
Trading Manager software. For information about Partner Manager’s XML
Autoload Utility, refer to the XML Autoload Utility documentation.

What is Partner Manager?

Partner Manager is a data management system for defining and viewing electronic
commerce activity. Typically, an e-commerce administrator such as an EDI
coordinator uses Partner Manager. As part of Trading Manager, Partner Manager is
used to define your trading relationships with your e-commerce partners.
Information is maintained on each trading partner including address information,
contact persons, and the individual organizational entities with which you trade
business information.

Use Partner Manager to:

* Define post offices; direct links using FIP, Value Added Networks (VANSs), or
e-mail to enable you to communicate with your partners

* Define the trading relationships with your EDI partners, including details such
as the individual document level for its version, control numbering schemes,
tracking, error handling, status, and post office used

* Provide audit and control information collected in the Trading Manager
database, which you use to monitor your organization’s ongoing inbound and
outbound e-commerce transaction activity

* Be alerted to error conditions in e-commerce inbound or outbound processing

Theory of operation

Use Partner Manager to define:

* One or more internal trading partners

* One or more external trading partners

* Two or more post offices

* Trade links to associate internal trading partners with external trading partners

* Information the two trading partners exchange

The information from Partner Manager is shared with the Launcher component of
Trading Manager for validating, tracking, and routing e-commerce data.
Information about this e-commerce activity is then incorporated into the Partner
Manager database for monitoring and reporting.

© Copyright IBM Corp. 2006 1



Trade Links and Partner Manager

A primary Partner Manager function is the definition of trading relationships, also
known as trade links. A trade link consists of four fundamental components:

Internal Trading Partner
An internal trading partner is defined in the Address Book navigator. This
information identifies the EDI settings for an internal entity that sends and
receives e-commerce data to and from another organization. Internal
trading partners answer the question Who are we?

External Trading Partner
An external trading partner is also defined in the Address Book navigator.
This information identifies the EDI settings for an entity with which
internal trading partners exchange data. External trading partners answer
the question Who do we exchange data with?

Post Office
A post office identifies where data to be processed by Trading Manager is
located and the necessary configuration settings that Trading Manager
needs to access that data. Post offices are defined from the Post Offices
navigator. Post offices answer the question Where is the data retrieved and
routed when its processing is complete?

Application
An application identifies the type of messages or documents that are
exchanged between an internal and external trading partner. A minimum
of one application is defined as part of the Link Wizard from the Trade
Links navigator. Other applications can then be defined from the Trade
Links navigator. Applications answer the question What types of information
do we exchange with a particular trading partner?

Partner Manager interface

2

The Partner Manager interface, as shown below, includes navigators, forms, the
toolbar, the menu bar, command buttons, an Editor, reports, and right-click context
menus.

Partner Manager functions are available from the main menu, right-click
functionality, and toolbar.

Navigators

Partner Manager provides four navigators to help you define and view
e-commerce information:

* Address Book navigator enables you to define trading and application partners.
Use this navigator to store information about your internal organization’s set of
trading partners, your external trading partners, and their departments or
application groups

» Post Offices navigator enables you to specify routing instructions for inbound
data, outbound data, and error reporting. You can define the mail routes, FTP
connections, e-mail addresses, or value added networks that you use to
exchange data with your trading partners

* Trade Links navigator enables you to define trading partner relationships. Trade
links connect a trading relationship with specific instructions for routing, error
handling, and tracking. Partner Manager wizards help you construct and
maintain trade links quickly and easily. Trade links connect you to your trading
partner for each document that you trade with that partner.

IBM WebSphere Transformation Extender: Partner Manager



* Utilities navigator contains utilities that allow you to make configuration
changes, change database settings, organize trading partner subfolders and to
modify security information.

Toolbar

The toolbar is a part of the Partner Manager window that provides you with quick
access to various tools to invoke Partner Manager actions.

Form area

The form area displays dialog boxes and forms when you click a navigator folder.
You enter trade and application partner, post office, trade link, and other
information in the dialog boxes and forms that display here.

Audit Info button

Audit information is available throughout the Partner Manager; for example, when
you edit trading or application partners, the edit dialog box includes an Audit Info
button. The audit facility tracks the creation and creator of each entity by using a
date, time stamp, and the user ID of the person that originally created the entry.
This data is also stored in the database for providing of an audit trail of all
changes. All subsequent changes are logged in the audit database with the date,
time, and user ID of the party making the change.

To view audit information

1. Click Audit Info on forms where the button is available.
The Audit Information dialog box appears.

2. View the information.
Click OK to close the Audit Information dialog box.

Chapter 1. Introduction 3



4 1BM WebSphere Transformation Extender: Partner Manager



Chapter 2. Getting started

Procedures described in this chapter enable you to:

 Start Partner Manager from the Start menu

* Start Partner Manager from the Windows desktop using a database-specific icon
* Select a database different from the default Partner Manager database

* Create, edit, and delete a database profile

* Merge and copy databases

Starting Partner Manager

Note: Before you start Partner Manager, ensure that you are using the latest open
database connectivity (ODBC) drivers from your database vendor. For
example, if you are using the Microsoft ODBC Driver for Oracle, you must
also install the Oracle Client on the client machine.

* You start the Partner Manager interface from the Windows Start menu or from
an icon on your desktop.

* You can also customize the Partner Manager startup configuration to use
different database profiles.

Starting Partner Manager from the Start menu

The Partner Manager application may be started from the Start menu or a desktop
icon.

To start Partner Manager from the Start menu:

From the Start menu, select Programs > IBM WebSphere Transformation
Extender n.n > Trading Manager > Partner Manager.

Where n.n is the product version number.

Note: If user and group security are used, you must login with a valid user ID.
See|"Utilities"}

The Partner Manager window opens.

Starting Partner Manager using a database-specific desktop
icon

This technique is useful when you need to run multiple instances of Partner
Manager or want to create an icon for each database you use. Information about
the current profile in use is available by choosing About from the Help menu.

To start Partner Manager by using a database-specific desktop icon
1. Create a new database profile.

2. Open Windows Explorer.

3. Select Desktop in the folder navigator.

© Copyright IBM Corp. 2006 5



4. From the File menu, select New > Shortcut.

5. Enter the following in the Command Line field of the Create Shortcut dialog
box:

install_dir\tmgr_vn.n\pmgr\partnermanager.exe profile

where n.n represents the current Trading Manaier version, and profile is the

case-sensitive database profile you created. See |"Utilities”| more information.
6. Click Next and name the shortcut.
7. Click Finish.
8. To start Partner Manager, double-click the shortcut icon on the desktop.

Note: If the profile is incorrect or does not exist, the Partner Manager
application uses the most recent valid database connection.

System requirements

6

The minimum requirements to install and run Partner Manager are:
* Design Studio is required to use the EDI Wizard
* System data source name

Database configuration

A default Microsoft Access database named tmgrnn.mdb is installed in the
install_dir\tmgr_vnn\pmgr folder as part of the Partner Manager installation
program (where nn and n.n refer to the current Trading Manager version).

The Utilities enables you to select a different database. Other Partner Manager
utility procedures enable you to:

* Create, edit, and delete a database profile
* Merge databases
* Copy databases

Note: When entering data in Partner Manger be aware that case sensitivity can
vary by Database Vendor and even by database instance. For example,
Microsoft Access considers "Acme” to equal "ACME"; most other
databases consider these fields unequal. Consult your DBA to determine if
your database is case sensitive and plan your database entries accordingly,
especially if using Partner Manger’s copy and merge functionality
between database vendors.

System Data Source Name (DSN)

A system data source name (DSN) is a user-defined name that links a database
driver to a database. You must configure a DSN to access the default install_dir
\tmgr_vn.n\pmgr\tmgrnn.mdb database (where n.n and nn represent the current
Trading Manager version number). The Trading Manager Installation
documentation describes how to create and configure a system DSN.

The DSN enables direct access to the database using an application like Partner
Manager. When configuring open database connectivity (ODBC) DSN, you must
create a DSN for each database to which you connect.

IBM WebSphere Transformation Extender: Partner Manager



Chapter 3. Address books

The Address Book navigator is used to define the internal and external trading
partners at the corporate, application, departmental, or divisional levels.

Procedures described in this chapter enable you to define:
* Trading partners in your organization

* Trading partners in organizations you do business with

From the Address Book navigator, you define trading partners internal and
external to your organization. The Address Book navigator contains links for these
trading partners. Internal links represent how your company is organized to
manage your e-commerce relationships. Using these links, you define your
company’s internal partners, who represent your company as part of a trading
partner relationship. External links enable you to define your trading partners in
other companies or entities. These are the organizations that you do business with
and represent the external trading partnerships that you establish.

Trading partner and application partner relationships

The trading partner and application partner relationships define how the trading
partners and application partner associations are defined in Partner Manager.

One trading partner with one application partner

Your organization may choose to have a single window on the world in terms of
your EDI profile: that is, defining all EDI address envelopes with a single company
EDI address. Typically, companies with a centralized e-commerce function that
manages all relationships use this approach.

In Partner Manager, a single trading partner representing a company may be
defined with one application partner that represents the entire organization.

Many trading partners with one or more application partners

You can maintain multiple relationships with external trading partners. For
example, you may have autonomous divisions who wish to do business under
their own name but still share a single EDI system administered by an e-commerce
group. In this case, define a new trading partner for each internal entity that
requires its own address.

In Partner Manager, a trading partner may be defined for each division of a
company. For example, one for Domestic Operations and one for International
Operations. One application partner is defined for each trading partner.

One trading partner with many application partners

You may also want to maintain a single company address for the corporate level
and separate addresses for each department or division. Define a single internal
trading partner name and use the application partner entries to enable you to
connect a given department with its trading partners, yet have all mail processed
through the corporate partner relationship first. For example, you can define
specific trading relationships with your dealer/distributor chain, your suppliers,
and your customers. You may also configure relationships for each major

© Copyright IBM Corp. 2006 7



application: the Order Entry department as an entity receives all incoming orders;
the Billing department processes invoices; and Human Resources handles
healthcare enrollments and claims processing.

In this case, you configure a trading partner for the company and an application
partner for each division.

Trading partners and application partners

8

The partners with which your organization exchanges e-commerce data can also be
organized using the trading partner and application partner scenarios described in
the previous sections.

Internal address book

Use the Internal Address Book to specify address information for partners within
your organization.

¢ Admin - contains information about administrative contact persons associated
with your organization’s e-commerce programs, particular applications or
trading partners, Trading Manager, and so on.

* EDIFACT - contains the definition of entities within your organization that
maintain relationships with external trading partners, based on the Electronic
Data Interchange for Administration, Commerce, and Transport (EDIFACT)
standard.

* TRADACOMS - contains the definition of the entities within your organization
that maintain trading relationships with external trading partners, based on the
TRADACOMS UN/TDI Standard.

* X12 - contains the definition of the entities within your organization that
maintain trading relationships with external trading partners, based on the ANSI
ASC X12 standard.

The EDIFACT, TRADACOMS, and X12 folders can also contain information about
contact persons within these internal trading partner organizations. You may add
other subfolders to organize internal trading partners into logical groupings by
choosing Folder Utilities from the Tools menu.

External address book

Use the External Address Book to specify address information for partners outside
your organization. The External folder includes these subfolders:

* EDIFACT - contains the definition of entities outside your organization with
which your organization maintains relationships, based on the EDIFACT
standard. These entities are your trading partners. You may add other subfolders
to organize external trading partners into logical groupings.

* TRADACOMS - contains the definition of entities outside your organization
with which your organization maintains relationships, based on the
TRADACOMS UN/TDI Standard. These entities are your trading partners. You
may add other subfolders to organize external trading partners into logical
groupings.

¢ X12 - contains the definition of entities outside your organization with which
your organization maintains trading relationships, based on the ANSI ASC X12
standard. These are your trading partners. You may add other subfolders to
organize external trading partners into logical groupings.

IBM WebSphere Transformation Extender: Partner Manager



Internal trading partner and application partner

Select the Internal » EDIFACT, TRADACOMS, or X12 folder in the Address Book
navigator. A dialog box opens.

The Internal Address Book is displayed with two list boxes. The Trading Partner
list contains an entry for each trading partner within your organization. Select a
trading partner in the list and the Application Partner list shows each application
partner of the trading partner.

Trading partners that exchange e-commerce information can be organized for this
exchange in several ways. How each trading partner is organized determines the
trading partner and application partners that are defined in Partner Manager. The
following paragraphs describe certain scenarios.

Configuring internal and external address books

The Trading Partner list in the Address Book form shows existing trading
partners. The Address Book form enables you to add, edit, delete, or copy this
partner information. You can also access contact information for your trading
partners. Add or edit trading partners to define the trading partner EDI
information for your company at the corporate level.

The Application Partner list in the Address Book form shows the application
partners for the selected trading partner. The Address Book form enables you to
add, edit, or delete this partner information. You can also access contact
information. Use the Application Partner area of the form to add the information
for the departments or responsible parties for particular applications. This
information is used to create or validate the EDI data envelopes for the trading
partner. Define an application partner for each unique address or qualifier within a
given trading partner.

Note: An identical dialog box appears when you select the Internal or External
folders for EDIFACT, TRADACOMS, or X12. The following instructions
apply to maintaining internal and external trading partner information.
Differences between internal and external trading partners are identified.

Adding X12 internal trading partners

Use the following instructions to add an X12 Internal Trading Partner:

1. Select Address Book from the Partner Manager File menu.

2. Click Internal » X12.
The Address Book for Internal X12 window.

3. Click the Add button that is located to the right of the Trading Partner list box
(upper panel).
The Add X12 Trading/Application Partner In Internal Folder X12 window
opens.

The window contains the tabs listed below. Refer to the following sections for a
description of the fields displayed in each tab view:

. "’Trading Partner TM
- [1SA Options Tab”

« ["Application Partner Tab’|

4. Complete all required fields, then complete any optional fields.

Chapter 3. Address books 9



Note: The Trading Partner Name and Interchange ID field are required.
5. Click Save.

The window closes and the new Trading Partner is added to the listbox in the
Address Book for Internal X12 window.

Trading Partner tab

The following fields are contained in the Add X12 Trading/Application Partner In
Internal Folder X12 window, with the Trading Partner tab view displayed::

Trading Partner Name
Enter a name for this trading partner. This name appears in the Trading
Partner list, Trade Links dialog box, Traffic reports, and so on. This name
must be unique for each trading partner defined, even if they are in
different folders.

ISA Address
Select the unique two-character qualifier that identifies the coding structure
used to define the Interchange ID. This field corresponds to ANSI ASC X12
data element I05.

Interchange ID
Enter the unique identification code for this trading partner to be used to
route incoming and outgoing data. If the data is outbound from the
trading partner, this is the ISA Sender ID. For data inbound to the trading
partner, this is the ISA Receiver ID. This field corresponds to ANSI ASC
X12 data elements 106 and 107.

The combination of the ISA address and Interchange ID must be unique
across any implemented system of maps.

ISA Options tab

The following fields are contained in the Add X12 Trading/Application Partner In
Internal Folder X12 window, with the ISA Options tab view displayed:

Interchange Control Version ID
Select the version of the EDI standard that covers the interchange control
segments. A default value of 00305 is provided. This field corresponds to
ANSI ASC X12 data element I11.

You can add other versions using the X12 Standards Maintenance utility.

Interchange Standards ID or Repetition Character
This field takes on two meanings, depending upon the value selected in
the Interchange Control Version ID field. If the value in the Interchange
Control Version ID field is less than 00402, this field is called the
Interchange Standards ID field. If the value is equal to, or greater than
00402, then it changes to become the Repetition Character field. Both field
types are optional: the default value is """ (caret Hex 5E) if the field
denotes the Repetition Character; the default value is "U” for the
Interchange Standards ID.

Note The dual meaning of this field resulted when the X12 committee
stopped using the Interchange Standards ID and replaced it with the
Repetition Character starting with Interchange Control version 00402.

Separators
Element - Select the delimiter used to separate data elements within a
segment. A default value of * (asterisk) is provided.
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Sub Element - Select the delimiter used to separate component data
elements within a composite data structure. A default value of : (colon) is
provided. The value of this separator must be different than that of the
element separator and segment terminator. This field corresponds to ANSI
ASC X12 data element I15.

Segment Terminator - Select the character used to terminate a segment. A
default value of line feed is provided.

You can add other separators to these lists using the X12 Standards
Maintenance utility.

The Separators delimiters provided as the Element, Sub Element, and
Segment Terminator are used when generating outbound e-commerce
data, including functional acknowledgements.

Application Partner tab

The following fields are contained in the Add X12 Trading/Application Partner In
Internal Folder X12 window, with the Application Partner tab view displayed:

Application Partner Name
Enter a name for an application partner, such as a division, department or
function within the trading partner. This name appears in the Application
Partner List, Trade Links dialog box, Traffic reports, and so on. This name
must be unique within a trading partner.

GS Address
Enter a code identifying the application partner, used to route data to and
from it. If the data is outbound from the application partner, GS Address
is the GS Sender ID. For data inbound to this application partner, GS
Address is the GS Receiver ID. It corresponds to ANSI ASC X12 data
elements 142 and 124. This address must be unique within a trading
partner.

Alias Name
Enter an alias by which the application partner might be known, for
instance an abbreviation of the application partner name, and so on. This
alias is not used by Partner Manager or the Message Manager but is
available for user application maps. Trading Manager validates this
information to ensure that the alias name is unique.

See the Trading Manager Installation documentation for more information
about these files and the alias.mtt type tree.

User Defined 1 User Defined 2
Enter any user-defined information for this application partner; for
example, a department number, an internal customer number, and so on.
Partner Manager or the Message Manager does not use this data but it is
available for user application maps. See the Trading Manager Installation and
User Guide for more information about these files and the alias.mtt type
tree.

Adding X12 external trading partners

Use the following instructions to add an X12 Internal Trading Partner:
1. In the Address Book navigator, click External » X12.
The Address Book for External X12 opens.

Chapter 3. Address books 11
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2. Click the Add button that is located to the right of the Trading Partner list box
(upper panel).
The Add X12 Trading/Application Partner In External Folder X12 window
opens.

The window contains the tabs listed below. Refer to the following sections for a
description of the fields displayed in each tab view:

* |'Trading Partner Tab - External X12'|
+ ['ISA Options Tab’|

» |'TA1 Post Offices Tab’|

* ['Authorization /Security Tab’|

" Application Partner Tab’'|

3. Complete all required fields, then complete any optional fields.

Note: The Trading Partner Name and Interchange ID field are required.
4. Click Save.

The window closes and the new Trading Partner is added to the listbox in the
Address Book for External X12 window.

Trading Partner tab - External X12

The following fields are contained in the Add X12 Trading Partner In External X12
window, Trading Partner tab view:

Trading Partner Name
Enter a name for this trading partner. This name appears in the Trading
Partner list, Trade Links dialog box, Traffic reports, and so on. This name
must be unique for each trading partner defined, even if they are in
different folders.

ISA Address
Select the unique two-character qualifier that identifies the coding structure
used to define the Interchange ID. This field corresponds to ANSI ASC X12
data element I05.

Interchange ID
Enter the unique identification code for this trading partner to be used to
route data to and from it. If the data is outbound from the trading partner,
this is the ISA Sender ID. For data inbound to this trading partner, this is
the ISA Receiver ID. This field corresponds to ANSI ASC X12 data
elements 106 and 107.

The combination of the ISA address and Interchange ID must be unique
across any system of maps you implement.

Interchange
When checked, enables checking of duplicate interchange control numbers
for this Trading Partner. If a duplicate interchange is found it is rejected.

Functional Group within an Interchange
When checked enables checking of duplicate Functional Group control
numbers within the interchange for this partner. If a duplicate functional
group is found it is then rejected.

Transaction within a Functional Group
When checked, enables checking of duplicate transaction control numbers
within the functional group for this partner. If a duplicate transaction is
found it is then rejected.

IBM WebSphere Transformation Extender: Partner Manager



Last Interchange Control #
Resets the Interchange control number.

ISA Options tab

The fields in the Add X12 Trading Partner In External X12 window, ISA Options
tab view are described in ['ISA Options Tab'| .

TA1 Post Offices tab

The following fields are contained in the Add X12 Trading Partner In External X12
window, TA1 Post Offices tab view::

Get  Allows override of the TA1 Get Post Office that was set in Message
Manager Configuration.

Put Allows override of the TA1 Put Post Office that was set in Message
Manager Configuration.

Authorization/Security tab

The fields in the Add X12 Trading Partner In External X12 window,
Authorization/Security tab view are described in the following table:

Authorization Qualifier (Inbound and Outbound)
Enter the two-character qualifier that identifies the coding structure used to
define the inbound or outbound Authorization ID. The default value is 00,
indicating no authorization information present. This field corresponds to
ANSI/ASC/X12 data element 101.

Authorization ID (Inbound and Outbound)
Enter the inbound or outbound authorization information for this trading
partner to be used for additional identification or authorization of data
sent by this trading partner. By default, no authorization information is
defined. This field corresponds to ANSI ASC X12 data element 102.

Security Qualifier (Inbound and Outbound)
Select the two-character qualifier that identifies the type of information in
the Security ID. The default value is 00, indicating there is no security
information present. This field corresponds to ANSI ASC X12 data element
103.

Password (Inbound and Outbound)
Enter a password if you selected 01 in the inbound or outbound Security
Qualifier field.

Validate Authorization
Indicates whether or not ISA Authorization information is validated
against the Partner Manager database.

Validate Security
Indicates whether or not security elements are validated against the
Partner Manager database.

Application Partner tab

The following fields are contained in the Add X12 Trading Partner In External X12
window, Application Partner tab view:

Application Partner Name
Enter a name for an application partner, such as a division, department or
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function within the trading partner. This name appears in the Application
Partner List, Trade Links dialog box, Traffic reports, and so on. This name
must be unique within a trading partner.

GS Address
Enter a code identifying the application partner, used to route data to and
from it. If the data is outbound from the application partner, GS Address
is the GS Sender ID. For data inbound to this application partner, GS
Address is the GS Receiver ID. It corresponds to ANSI ASC X12 data
elements 142 and 124. This address must be unique within a trading
partner.

Alias Name
Enter an alias by which the application partner might be known, for
instance an abbreviation of the application partner name, and so on. This
alias is not used by Partner Manager or the Message Manager but is
available for user application maps. Trading Manager validates this
information to ensure that the alias name is unique.

See the Trading Manager Installation and User Guide for more information
about these files and the alias.mtt type tree.

User Defined 1 User Defined 2
Enter any user-defined information for this application partner; for
example, a department number, an internal customer number, and so on.
Partner Manager or the Message Manager does not use this data but it is
available for user application maps. See the Trading Manager Installation and
User Guide for more information about these files and the alias.mtt type
tree.

HIPAA Type 7 Institution
Allows selection of HIPAA Institution.

Adding Internal EDIFACT Trading Partners

Use the following instructions to add an internal EDIFACT Trading Partner:

1. In the Address Book navigator, click Internal > EDIFACT.
The Address Book for Internal EDIFACT opens.

2. Click the Add button that is located to the right of the Trading Partner list box
(upper panel).
The Add EDIFACT Trading/Application Partner In Internal Folder EDIFACT
window opens.

The window contains the tabs listed below. Refer to the following sections for a
description of the fields displayed in each tab view:

« ['Identification Tab’|

* |'Syntax/Separators Tab'|

» |"Application Partner Tab’|

3. Complete all required fields, then complete any optional fields.

Note: The Trading Partner Name and Interchange ID field are required.
4. Click Save.

The window closes and the new Trading Partner is added to the listbox in the
Address Book for Internal EDIFACT window.
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Identification tab

The following fields are contained in the Add EDIFACT Trading Partner In
Internal EDIFACT window, in the Identification tab view:

Trading Partner Name
Enter a name for this trading partner. This name appears in the Trading
Partner list, Trade Links dialog box, Traffic reports, and so on. This name
must be unique for each trading partner defined, even if they are in
different folders.

Interchange ID
Enter the unique identification code for this trading partner to be used to
route data to and from it. If the data is outbound from the trading partner,
this is the Sender ID. For data inbound to this trading partner, this is the
Receiver ID.

The combination of the Partner Code ID Qualifier and Interchange ID must
be unique across any system of maps you implement.

Partner ID Code Qualifier
Select the unique two-character qualifier that identifies the coding structure
used to define the Interchange ID.

Routing Address
Enter a code identifying the application partner, used to route data to and
from it.

Comm Agreement ID
Enter a code identifying the commercial agreement ID.

Enveloping Option (these buttons only appear when you are adding internal
partners)
Identify the format of the data that is provided by the application maps
that is sent to this trading partner.

Partially Enveloped - the version type and other information have limited
information and are to be completed by Trading Manager before routing
the EDI data to the trading partner.

Fully Enveloped - The fully enveloped option is provided to support
legacy translator support. It allows the user to use existing translators in
order to preserve existing interface code, while using Trading Manager for
communications and audit purposes.

Syntax/Separators tab

The following fields are contained in the Add EDIFACT Trading Partner In Internal
EDIFACT window, in the Syntax/Separators:

Use UNA Segment
Check box if you use the UNA Segment for this Trading Partner.

Syntax ID
Select the Syntax ID used for this Trading Partner. Values are: UNOA;
UNOB; UNOC; UNOD; UNOE; UNOF; UNOG; UNOH

Syntax Version
Enter a number greater than zero and less than 10 denoting the EDIFACT
version syntax in use with this Trading Partner. The default is 1.
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Component Data Element
Select the delimiter used to separate component data elements within a
composite data structure. A default value of : (colon) is provided.

Data Element
Select a delimiter used to separate data elements within a segment.

Segment Terminator
Select the character used to terminate a segment. A default value of line
feed is provided. You can add other separators to these lists using the
Standards Maintenance utility.

Release Indicator
Select the character used to restore separator and terminator signs within
the interchange. A default value of ? (question mark) is provided.

Decimal Notation
Select the character used for the decimal point within the interchange. A
default value of , (comma) is provided.

Reserved Character
Spare character reserved for future use. A space is provided as the default.

Application Partner tab

The following fields are contained in the Add EDIFACT Trading Partner In
Internal EDIFACT window, in the Application Partner tab view:

Field Description

Application Partner Name
[Optional] Enter a name for an application partner, such as a division,
department or function within the trading partner. This name appears in
the Application Partner List, Trade Links dialog box, Traffic reports, and
so on. This name must be unique within a trading partner.

UNG Application ID
Enter a UNG segment header application ID identifying the application
partner.

Application Partner ID Code Qualifier
[Optional] Identify the format of the data that is provided by the
application maps that is sent to this trading partner.

Alias Name
[Optional] Enter an alias by which the application partner might be
known. For example, an abbreviation of the application partner name, and
so on. This alias is not used by Partner Manager or the Message Manager
but is available for user application maps. Trading Manager validates this
information to ensure that the alias name is unique.

User Defined 1 User Defined 2
[Optional] Enter any user-defined information for this application partner;
for example, a department number, an internal customer number, and so
on. Partner Manager or the Message Manager does not use this data but it
is available for user application maps.

Adding External EDIFACT Trading Partners

Use the following instructions to add an external EDIFACT Trading Partner:
1. In the Address Book navigator, click External » EDIFACT.
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The Address Book for External EDIFACT opens.

2. Click the Add button that is located to the right of the Trading Partner list box
(upper panel).
The Add EDIFACT Trading/Application Partner In External Folder EDIFACT
window opens.

The window contains the tabs listed below. Refer to the following sections for a
description of the fields displayed in each tab view:

"Identification Tab'|
» |'Syntax/Separators Tab'|

» ["Application Partner Tab’|

3. Complete all required fields, then complete any optional fields.

Note: The Trading Partner Name and Interchange ID field are required.
4. Click Save.

The window closes and the new Trading Partner is added to the listbox in the
Address Book for External EDIFACT window.

Identification tab

The following fields are contained in the Add EDIFACT Trading/Application
Partner In External Folder EDIFACT window in the Identification tab view
selected:

Trading Partner Name
Enter a name for this trading partner. This name appears in the Trading
Partner list, Trade Links dialog box, Traffic reports, and so on. This name
must be unique for each trading partner defined, even if they are in
different folders.

Interchange ID
Enter the unique identification code for this trading partner to be used to
route data to and from it. If the data is outbound from the trading partner,
this is the Sender ID. For data inbound to this trading partner, this is the
Receiver ID.

The combination of the Partner Code ID Qualifier and Interchange ID must
be unique across any system of maps you implement.

Partner ID Code Qualifier
Select the unique two-character qualifier that identifies the coding structure
used to define the Interchange ID.

Routing Address
Enter a code identifying the application partner, used to route data to and
from it.

Comm Agreement ID
Enter a code identifying the commercial agreement ID.

Password
Allows you to enter a password for the Trading Partner.

Password Qualifier
Allows you to select a two character qualifier for the password.

Duplicate Control
Allows you to select either None, for no duplicate control, or Interchange
in order to have duplicate control conducted at the Interchange level.
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Last UNB Control #
Resets the last UNB Control number to a new value.

Syntax/Separators tab

The following fields are contained in the Add X12 Trading/Application Partner In
External Folder EDIFACT, Syntax/Separators tab view:

Field Description

Use UNA Segment
Check box if you use the UNA Segment for this Trading Partner.

Syntax ID
Select the Syntax ID used for this Trading Partner. Values are: UNOA;
UNOB; UNOC; UNOD; UNOE; UNOF; UNOG; UNOH

Syntax Version
Enter a number greater than zero and less than 10 denoting the EDIFACT
version syntax in use with this Trading Partner. The default is 1.

Component Data Element
Select the delimiter used to separate component data elements within a
composite data structure. A default value of : (colon) is provided.

Data Element
Select a delimiter used to separate data elements within a segment.

Segment Terminator
Select the character used to terminate a segment. A default value of line
feed is provided. You can add other separators to these lists using the
Standards Maintenance utility.

Release Indicator
Select the character used to restore separator and terminator signs within
the interchange. A default value of ? (question mark) is provided.

Decimal Notation
Select the character used for the decimal point within the interchange. A
default value of , (comma) is provided.

Reserved Character
Spare character reserved for future use. A space is provided as the default.

Application Partner tab

The following fields are contained in the Add X12 Trading/Application Partner In
External Folder EDIFACT, Application Partner tab view:

Field Description

Application Partner Name
[Optional] Enter a name for an application partner, such as a division,
department or function within the trading partner. This name appears in
the Application Partner List, Trade Links dialog box, Traffic reports, and
so on. This name must be unique within a trading partner.

UNG Application ID
Enter a UNG segment header application ID identifying the application
partner.
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Application Partner ID Code Qualifier
[Optional] Identify the format of the data that is provided by the
application maps that is sent to this trading partner.

Alias Name
[Optional] Enter an alias by which the application partner might be
known. For example, an abbreviation of the application partner name, and
so on. This alias is not used by Partner Manager or the Message Manager
but is available for user application maps. Trading Manager validates this
information to ensure that the alias name is unique.

User Defined 1 User Defined 2
[Optional] Enter any user-defined information for this application partner;
for example, a department number, an internal customer number, and so
on. Partner Manager or the Message Manager does not use this data but it
is available for user application maps.

Password
Allows you to enter a password for the Application Partner.

Adding Internal TRADACOMS Trading Partners

Use the following instructions to add an internal TRADACOMS Trading Partner:
1. In the Address Book navigator, click Internal > TRADACOMS.
The Address Book for Internal TRADACOMS opens.
2. Click the Add button that is located to the right of the Trading Partner list box
(upper panel).
The Add TRADACOMS Trading Partner In Internal Folder TRADACOMS
window opens.

The window contains the tabs listed below. Refer to the following sections for a
description of the fields displayed in each tab view:

+ |'Trading Partner Tab’|
« |"Application Partner Tab’|

3. Complete all required fields, then complete any optional fields.

Note: The Trading Partner Name and Trading Partner ID fields are required.
4. Click Save.

The window closes and the new Trading Partner is added to the listbox in the
Address Book for Internal TRADACOMS window.

Trading Partner tab

The following fields are contained in the Add X12 Trading Partner In Internal
Folder TRADACOMS window in the Trading Partner tab view:

Trading Partner Name
Enter a name for this trading partner. This name appears in the Trading
Partner list, Trade Links dialog box, Traffic reports, and so on. This name
must be unique for each trading partner defined, even if they are in
different folders.

Trading Partner ID
Enter the unique identification code for this trading partner to be used to
route data to and from it. If the data is outbound from the trading partner,
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this is the Sender Reference or Name. For data inbound to this trading
partner, this is the Receiver Reference or Sender Name.

Application Partner tab

The following fields are contained in the Add X12 Trading Partner In Internal
Folder TRADACOMS window in the Application Partner tab:

Application Partner Name
Enter a name for an application partner, such as a division, department, or
function within the trading partner. This name appears in the Application
Partner List, Trade Links dialog box, Traffic reports, and so on. This name
must be unique for each trading partner defined, even if they are in
different folders.

Application Partner ID
Determined form the SDT (supplier ID composite) and CDT (customer ID
composite).

Alias Name
Enter an alias by which the application partner might be known. For
example, an abbreviation of the application partner name, and so on. This
alias is not used by Partner Manager or the Message Manager but is
available for user application maps. Trading Manager validates this
information to ensure that the alias name is unique.

User Defined 1 User Defined 2
Enter any user-defined information for this application partner; for
example, a department number, an internal customer number, and so on.
Partner Manager or the Message Manager does not use this data but it is
available for user application maps.

Adding External TRADACOMS Trading Partners

Use the following instructions to add an external TRADACOMS Trading Partner:
1. In the Address Book navigator, click External > TRADACOMS.
The Address Book for External TRADACOMS opens.
2. Click the Add button that is located to the right of the Trading Partner list box
(upper panel).
The Add TRADACOMS Trading Partner In External Folder TRADACOMS
window opens.

The window contains the tabs listed below. Refer to the following sections for a
description of the fields displayed in each tab view:

"Trading Partner Tab’|
» |"Application Partner Tab’|

3. Complete all required fields, then complete any optional fields.

Note: The Trading Partner Name and Trading Partner ID field are required.
4. Click Save.

The window closes and the new Trading Partner is added to the listbox in the
Address Book for External TRADACOMS window.
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Trading Partner tab

The following fields are contained in the Add TRADACOMS Trading Partner In
External Folder TRADACOMS window in the Trading Partner tab view:

Trading Partner Name
Enter a name for this trading partner. This name appears in the Trading
Partner list, Trade Links dialog box, Traffic reports, and so on. This name
must be unique for each trading partner defined, even if they are in
different folders.

Trading Partner ID
Enter the unique identification code for this trading partner to be used to
route data to and from it. If the data is outbound from the trading partner,
this is the Sender Reference or Name. For data inbound to this trading
partner, this is the Receiver Reference or Sender Name.

Duplicate Control
Allow duplicate control checking to be set to None, or to be set to
Interchange when duplicate control checking is to be performed at the
interchange level.

Editing a Trading Partner

The Edit Trading Partner window enables you to edit the EDIFACT,
TRADACOMS, and X12 fields.

To edit a trading partner

1. In the Address Book navigator, click Internal > folder or External > folder to
display the Address Book form, where folder is EDIFACT, TRADACOMS, or
X12.

2. Select a trading partner from the Trading Partner list.
3. Click Edit.

Note: You can also double-click the trading partner name to display the Edit
Trading Partner dialog box.

The Edit Trading Partner dialog box appears. A typical Edit Trading Partner
window is shown below:

4. Edit any field for a trading partner.
5. Click Save.

Copying a Trading Partner

You can copy existing trading partner information to a new trading partner.

Enable the Copy Application Partners check box to copy associated application
partners information to the new trading partner.

The following information is not copied:

* Application partner Alias Name; this record is unique to each application
partner

* Contact information associated with the trading and application partners
* Trade links associated with the trading and application partners
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To copy a trading partner

1.

In the Address Book navigator, click Internal > folder or External > folder to
display the Address Book form, where folder is EDIFACT, TRADACOMS or
X12.

Select a trading partner from the Trading Partner list.
Click copy.
The Copy Trading Partner window opens. window opens.

Enter a new trading partner name in the Trading Partner Name field. The other
required fields vary depending upon whether you are copying X12, EDIFACT
or TRADACOMS.

¢ For X12 - You must select the new ISA Address

* For EDIFACT - You must change either the Interchange ID or the Routing
Address

* For TRADACOMS - You must change the Trading Partner 1D

Change any information in the remaining fields, if required.

Enable the Copy Application Partners check box if you want the existing
application partner information copied to the new trading partner.

Click Save.

The information is copied to a new trading partner and appears in the Address
Book.

Deleting a Trading Partner

The following procedures describe how to delete a trading partner.

To delete a trading partner

1.

In the Address Book navigator, click Internal > folder or External > folder to
display the Address Book form, where folder is EDIFACT, TRADACOMS, or
X12.

Select a trading partner from the Trading Partner list.
Click Delete.
The Trading Partner Delete form displays.

Note: This function may delete many records from the database and should be
used with care. The Trading Partner Delete form displays the impact of
this deletion, and after accepted, deletes all records associated with the
Trading Partner.

Click Delete to confirm the removal of the records.

A confirmation appears that asks if it is okay to remove the Trading Partner.
Click OK.

A message box opens that tells you the delete was performed successfully.
Click OK to close the message box.

The Trading Partner has been successfully deleted and is removed from the
Address Book.
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Application partners

Application partners are associated with a particular trading partner or application,
such as the Billing department. Application partners provide a means of grouping
transactions by functional area within an organization.

You can add, edit, and delete application partners.

Application partners are managed in the Internal and External address book for
the data type (EDIFACT, TRADACOMS, or X12).

For all application partner management, select the data type (EDIFACT,
TRADACOMS, or X12) in the Internal or External address book.

Note: Application partners are required for X12 but are optional for EDIFACT and
TRADACOMS.

Adding an X12 Application Partner

Use the following instructions to add an internal or external X12 Application
Partner

1. In the Address Book navigator:

* Click Internal » X12 to add an Application Partner to an Internal Trading
Partner.

* Click External » X12 to add an Application Partner to an Internal Trading
Partner.

2. Select a Trading Partner in the Trading Partner list box (upper panel).

3. Click the Add button that is located to the right of the Application Partner list
box (lower panel).

The Add Internal Application Partner for Trading Partner window opens.

4. Enter information in the fields of this window. See the next section, |"Add X12
[Application Partner Window Fields’| for field descriptions.

Note: The GS Address must be unique within the associated trading partner.

Note: The Application Partner Name and GS Address fields are required.
5. Click Save.

The new application partner is added and appears in the Application Partner
list in the Address Book.

Add X12 Application Partner Window fields

The following fields are contained in the X12 Add Internal Application Partner for
Trading Partner window:

Application Partner Name
Enter a name for an application partner, such as a division, department or
function within the trading partner. This name appears in the Application
Partner List, Trade Links dialog box, Traffic reports, and so on. This name
must be unique within a trading partner.

GS Address
Enter a code identifying the application partner, used to route data to and
from it. If the data is outbound from the application partner, GS Address
is the GS Sender ID. For data inbound to this application partner, GS
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Address is the GS Receiver ID. It corresponds to ANSI ASC X12 data
elements 142 and 124. This address must be unique within a trading
partner.

Alias Name
Enter an alias by which the application partner might be known, for
instance an abbreviation of the application partner name, and so on. This
alias is not used by Partner Manager or the Message Manager but is
available for user application maps. Trading Manager validates this
information to ensure that the alias name is unique.

See the Trading Manager Installation documentation for more information
about these files and the alias.mtt type tree.

User Defined 1 User Defined 2
Enter any user-defined information for this application partner; for
example, a department number, an internal customer number, and so on.
Partner Manager or the Message Manager does not use this data but it is
available for user application maps. See the Trading Manager Installation
documentation for more information about these files and the alias.mtt
type tree.

HIPAA Type 7 Institution
Note: This field only appears when you are adding an Application Partner
to an X12 External Trading Partner.

Allows you to select a type of Healthcare Institution to associate with the
Application Partner (for example Medicare).

Adding an EDIFACT Application Partner

Use the following instructions to add an internal or external EDIFACT
Application Partner
1. In the Address Book navigator:
* Click Internal » EDIFACT to add an Application Partner to an Internal
Trading Partner.

* Click External » EDIFACT to add an Application Partner to an Internal
Trading Partner.

2. Select a Trading Partner in the Trading Partner list box (upper panel).

3. Click the Add button that is located to the right of the Application Partner list
box (lower panel).
The Add Internal Application Partner for Trading Partner window opens.

4. Enter information in the fields of this window. See the next section,
[EDIFACT Application Partner Window Fields'| for field descriptions.

Note: The Application Partner Name and UNG Application ID fields are
required.

5. Click Save.

The new application partner is added and appears in the Application Partner
list in the Address Book.

Add EDIFACT Application Partner window fields

The following fields are contained in the Add Internal Application for Trading
Partner EDIFACT window in the Application Partner tab view:
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Application Partner Name
Enter a name for an application partner, such as a division, department or
function within the trading partner. This name appears in the Application
Partner List, Trade Links dialog box, Traffic reports, and so on. This name
must be unique within a trading partner.

UNG Application ID
Enter a UNG segment header application ID identifying the application
partner.

Application Partner ID Code Qualifier
Identify the format of the data that is provided by the application maps
that is sent to this trading partner.

Alias Name
Enter an alias by which the application partner might be known. For
example, an abbreviation of the application partner name, and so on. This
alias is not used by Partner Manager or the Message Manager but is
available for user application maps. Trading Manager validates this
information to ensure that the alias name is unique.

User Defined 1 User Defined 2
Enter any user-defined information for this application partner; for
example, a department number, an internal customer number, and so on.
Partner Manager or the Message Manager does not use this data but it is
available for user application maps

Password (external EDIFACT only)
Note: This field appears only when you are adding an Application Partner
to an external EDIFACT Trading Partner.

Allows you to enter a password for the Application Partner.

Adding TRADACOMS Application Partners

Use the following instructions to add an internal or external EDIFACT
Application Partner

1. In the Address Book navigator:

* Click Internal > TRADACOMS to add an Application Partner to an Internal
Trading Partner.

¢ Click External » TRADACOMS to add an Application Partner to an Internal
Trading Partner.

2. Select a Trading Partner in the Trading Partner list box (upper panel).

3. Click the Add button that is located to the right of the Application Partner list
box (lower panel).

The Add Internal Application Partner for Trading Partner window opens.

4. Enter information in the fields of this window. See the next section,
[TRADACOMS Application Partner Window Fields”|for field descriptions.

5. Click Save.

The new application partner is added and appears in the Application Partner
list in the Address Book.

Add TRADACOMS Application Partner window fields

The following fields are contained in the Add Internal Application for Trading
Partner TRADACOMS window in the Application Partner tab view:
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Application Partner Name

Enter a name for an application partner, such as a division, department, or
function within the trading partner. This name appears in the Application
Partner List, Trade Links dialog box, Traffic reports, and so on. This name
must be unique for each trading partner defined, even if they are in
different folders.

Application Partner ID

Determined form the SDT (supplier ID composite) and CDT (customer ID
composite).

Alias Name

Enter an alias by which the application partner might be known. For
example, an abbreviation of the application partner name, and so on. This
alias is not used by Partner Manager or the Message Manager but is
available for user application maps. Trading Manager validates this
information to ensure that the alias name is unique.

User Defined 1 User Defined 2

Enter any user-defined information for this application partner; for
example, a department number, an internal customer number, and so on.
Partner Manager or the Message Manager does not use this data but it is
available for user application maps.

Editing an Application Partner

You can edit application partner definitions.

To edit an application partner

1.

5.
6.

In the Address Book navigator, click Internal > folder or External > folder to
display the Address Book form, where folder is EDIFACT, TRADACOMS, or
X12.

Select a trading partner in the Trading Partner list to view the associated
application partners.

Select an application partner in the Application Partner list.
Next to the Application Partner list, click the Edit button.
The Edit Application Partner dialog box appears.

Edit any field for the application partner.

Click Save.

Deleting an Application Partner

Note: Associated trade links must be deleted from the trading partner Address

Book before the application partner can be deleted.

To delete an application partner

1.

In the Address Book navigator, click Internal > folder or External > folder to
display the Address Book form, where folder is EDIFACT, TRADACOMS, or
X12.

Select a trading partner from the Trading Partner list.
Select the application partner from the Application Partner list.
Click Delete and confirm the delete action when prompted.
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Managing Administrative Contacts

Use the Address Book to define contacts that are associated with a particular
trading partner or particular application partner. You can also define
administrative contacts that are not associated with a trading partner. Contact
information is useful for defining the person to contact in your organization or
your trading partner’s organization about issues involving EDI traffic.

Contact information includes identifying individuals or groups of individuals and
how to reach them. Providing contact information allows Trading Manager to send
error notifications.

These contact types are not associated with a trading or application partner;
therefore, the Alert Options are not available. Typically, they are people in your
organization to contact.

You can add, edit, and delete administrative contacts in the Admin address book.

To add an administrative contact

1. In the Address Book navigator, select the Internal » Admin folder.

The Contacts for Administration dialog box appears, listing any defined
administrative contacts.

2. Click Add.

The Add a Contact dialog box appears.
3. Enter the contact information.
4. Click Save.

To edit an administrative contact

1. In the Address Book navigator, click the Internal > Admin folder.
2. Select the contact from the Contacts list.

3. Click Edit in the Contact List dialog box. The Edit a Contact dialog box
appears.

4. Edit the contact information.

5. When your contact information is complete, click Save.

To delete an administrative contact

1. In the Address Book navigator, click the Internal Admin folder.
2. Select the contact from the list.
3. Click Delete.
A message box opens that prompts you to confirm the delete.
4. Click Yes.
The contact is deleted.

Adding a Contact

Use the following procedures to define contacts that are associated with a
particular trading partner or particular application partner. You can also define
administrative contacts that are not associated with a trading partner.
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This information is defined for your convenience and may be used to format
e-mail message headers, compose letters using your default word processor, or
route data to appropriate people when Alert conditions are detected.

To add a contact

1. In the Address Book navigator, click Internal > folder or External > folder to
display the Address Book form, where folder is EDIFACT, TRADACOMS, or
X12.

2. Select a partner from the Trading Partner list or Application Partner list.
3. Click Contacts in the area for the partner selected.
The Contact List appears, listing any contacts defined for the selected partner.
4. Click Add in the Contact List dialog box.
The Add a Contact dialog box appears.
5. Enter the contact information.

6. Select an alert option from the Alert Options group box. (This option is only
available for contacts associated with internal trading/application partners).

7. Click OK.
8. Click Save.

E-Mail Check box and Field

If the alert is to be sent by e-mail, enable the E-Mail check box and specify the
e-mail address to which the alert is to be sent. If you specified an e-mail address
on the Contact dialog box, that information is automatically displayed in this field.

Monitor Directory Check box and Field

If the alert is to be sent to a directory location, enable Monitor Directory, as shown
above, and specify the directory to which the alert is to be written.

Editing a Contact

Note: Alert Options are only available when editing information for a contact
associated with an internal trading or application partner.

To edit a contact

1. In the Address Book navigator, click Internal > folder or External > folder to
display the Address Book form, where folder is EDIFACT, TRADACOMS, or
X12.

2. Select a partner from the Trading Partner list or Application Partner list.
3. Click Contacts in the area for the partner selected.

The trading or application partner Contact form appears, listing the contacts
defined for the selected partner.

4. Select a contact in the contact list.
5. Click Edit in the Contacts dialog box.
The Edit Contact dialog box appears.
6. Edit the contact information including Alert Options.
7. Click Save.
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Deleting a Contact

Use the following procedure to delete a contact for a trading or application partner.

To delete a contact

1. In the Address Book navigator, click Internal > folder or External > folder to
display the Address Book form, where folder is EDIFACT, TRADACOMS, or
X12.

2. Select a partner from the Trading Partner list or Application Partner list.
3. Click Contacts in the area for the partner selected.

The trading or application partner Contacts form appears, listing the contacts
defined for the selected partner.

4. Select the contact from the Contacts list.

Click Delete and confirm the delete action when prompted
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Chapter 4. Post Offices

Use the Post Offices navigator to define and maintain the routing instructions for
inbound and outbound data for Trading Manager. The Post Offices navigator is
used to define post offices that represent sources and destinations for data flowing
to and from Trading Manager.

Overview

This chapter describes the Post Offices navigator and provides instructions for
creating and modifying post office information.

Procedures described in this chapter enable you to define:
* Where data from trading partner relationships is transferred
* How data is transferred to and from Trading Manager

A Get post office is the source for data that is processed by the Message Manager.
A Put post office is the destination for data from the Message Manager.

* A Get post office is always used to pick up data coming into the Message
Manager

* A Put post office is always used to drop off data coming out of the Message
Manager

File Post Offices

Use a File Post Office when data is transferred to or from local directory structures.
Configuring a file route post office requires only that you identify a local directory
where e-commerce data is Get or Put without specifying how the file is physically
transferred.

* Get Post Offices - The Message Manager is configured to execute automatically
based on new files created or existing files changed in the directory defined for
the File Post Office. This creation or change is known as a file event.

* Put Post Offices - The data resulting from Message Manager processing is
written to files in the directory defined for the File Post Office.

E-Mail post offices

Use an E-mail Post Office when the source of or destination for e-commerce data is
an e-mail message using a MAPI, cc:Mail, Lotus Notes, or Internet mail system.
When you define an e-mail post office, Trading Manager uses the e-mail adapter to
route mail into or out of the Message Manager. For more information about the
E-mail adapter, see the E-mail Adapter documentation.

* Get Post Offices - Message Manager is configured to execute at particular time
intervals to retrieve any available data from the mail system data using the
e-mail adapters and the settings defined for the e-mail post office.

* Put Post Offices - The data resulting from Message Manager processing is
routed using the e-mail adapters and the settings defined for the e-mail post
office.
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FTP Post Offices

Use File Transfer Protocol (FTP) Post Offices to get and put files in remote
directories using the Internet’s FTP communications support. Trading Manager
uses the FTP adapter to route files using FTP. For more information about the FTP
adapter, see the FTP Adapter documentation.

* Get Post Offices - The Message Manager is configured to execute at particular
time intervals to retrieve any available data from the remote directories using
the FTP adapters and the settings defined for the FTP post office

* Put Post Offices - The data resulting from Message Manager processing is
routed to the remote location using the FITP adapters and the settings defined
for the FTP post office.

VAN post offices

Use VAN Post Offices to send and receive mail asynchronously through a
commercial Value Added Network (VAN). VAN adapters must be used to send or
receive mail from a Value Added Network by using a scripted session. For more
information about the VAN adapter, see the VAN Adapter documentation.

* Get Post Offices - The Message Manager is configured to execute at particular
time intervals to retrieve any available data from the VAN using the VAN
adapters and the settings defined for the VAN post office

* Put Post Offices - The data resulting from Message Manager processing is

routed to the remote VAN using the VAN adapters and the settings defined for
the VAN post office.

HTTP post offices

Use HTTP Post Offices when e-commerce data is being transferred to and from an
HTTP(S) web server. If you have a Command Server, a Launcher, or Platform API
on one platform, you can use the HTTP adapter to transfer data to an HTTP(S)
web server on another platform. For more information about the HTTP adapter,
see the HTTP Adapter documentation.

JMS post offices

Use JMS Post Offices when e-commerce data is being transferred to a Java
Messaging Service (JMS) compliant system provider. JMS is part of the Java 2
Platform Enterprise Edition (J2EE) standards and defines a standard API for
accessing enterprise-messaging systems. Trading Manager uses the Java Message
Service Adapter to transfer data to and from JMS systems. For more information
about the JMS adapter, see the Java Message Service Adapter documentation.

MessageQ client post offices

Use MessageQ Client Post Offices when BEA MessageQ adapters are used to
perform message transformation in the MessageQ environment, including the
translation of data between different formats. The BEA MessageQ adapters also
control the flow of messages between MessageQ applications. For more
information about the BEA MessageQ adapter, see the BEA MessageQ Adapter
documentation.

MessageQ server post offices

Use Message Q Server Post Offices when BEA MessageQ adapters are used to
perform message transformation in the MessageQ environment, including the
translation of data between different formats. The BEA MessageQ adapters also
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control the flow of messages between MessageQ applications. For more
information about the BEA MessageQ adapter, see the BEA MessageQ Adapter
documentation.

MQSeries client post offices

Use MQSeries Client Post Offices when transferring e-commerce data between
applications using IBM WebSphere applications. IBM WebSphere MQ can move
data in heterogeneous computer networks, allowing systems of dissimilar
computers to move data to and from each other. The IBM WebSphere MQ client
adapter controls the data. For more information about the IBM WebSphere MQ
Adapter, see the IBM WebSphere MQ Adapter documentation.

MQSeries server post offices

Use MQ Series Server Post Offices when transferring e-commerce data between
applications using IBM WebSphere applications. IBM WebSphere MQ can move
data in heterogeneous computer networks, allowing systems of dissimilar
computers to move data to and from each other. The IBM WebSphere MQ client
adapter controls the data. For more information about the IBM WebSphere MQ
Adapter, see the IBM WebSphere MQ Adapter documentation.

MSMQ post offices

Use MSMQ Post Offices when transferring e-commerce data to and from Microsoft
Message Queue (MSMQ) servers. For more information about the MSMQ Adapter
see the MSMQ Adapter documentation.

OracleAQ post offices

Use OracleAQ Post Offices when e-commerce data is being transferred to and from
an Oracle database. See the OracleAQ Adapter documentation.

Viewing Post Offices

When you select a post office view from the Post Offices navigator, you can add,
copy, edit, and delete post offices of that type.

To view all post offices
1. Open Partner Manager.
2. From the File menu, select Post Offices.
The Post Offices navigator opens.
3. Click All Post Offices in the navigator.

The All Post Offices dialog box appears with both Get and Put post offices
displayed.

4. View Get or Put post offices only by clicking the associated option button in
Post Office Type.

To view specific post offices
Select one of the post office types displayed in the navigator.

For example, when you select E-Mail from the navigator, a list showing only the
e-mail post offices opens.
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Adding Post Offices

The following steps describe how to add a post office.

Note: The following instructions are not applicable to File and VAN post offices. If

you are adding a File post office, see|"Adding a File Post Office"|. For VAN
post offices see thel”Adding a VAN Post Office’|.

To add post offices

1.

Select one of the post office types displayed in the navigator.
The list of post offices for that adapter is displayed.

Click Add.

The Add Post Office dialog box appears.

Enter the following information:

Name Name for the post office; for example, X12 Data For Processing.

The name displays in the Post Offices list and in the drop-down list
boxes when maintaining trade links.

Nickname
A three-character nickname. A valid, unique nickname is automatically
generated based on the Name entry. You may use this nickname or
assign one of your own. The nickname is used to identify this post
office throughout the Trading Manager system.

Adapter Type
Select an adapter type.

Get/Put Indicator
Select the post office type option.

Adapter Command String
Enter an adapter command string; for example:

-PR MAPI -U mzipper -P srhwec9 -TO pbure -RCPT

4. Click Save.

The new post office appears in the Post Offices list.

Adding a File Post Office

To add a file post office

1.

Click File in the Post Offices navigator.

The File Post Offices dialog opens.

Click Add.

The Add Post Office dialog box opens.

Select File from the Adapter Type drop-down menu.

The Add Post Office dialog box for File adapters opens.

Enter information in this dialog box as described in the following table.

Field Information to Enter or Select

Name Name of the file route post office; for example, X12 Data For
Processing.
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5.

The name displays in the Post Offices list and in the Get File Post
Office and Put File Post Office lists in the Trade Links navigator.

Nickname
A three-character nickname. A valid, unique nickname is automatically
generated based on the Name entry. You may use this nickname or
assign one of your own. The nickname is used to identify this post
office throughout the Trading Manager system.

Get/Put Indicator
Select the post office type option.

Directory
Enter the path of the directory or folder where files for the file post
office are located. Specify a path relative to the directory where the
Launcher is installed.

It is recommended that you use the default directory
(install_dir\tmgr_n.n\mmgr\file) for all Get file post offices to
simplify Message Manager configuration and processing, instead of
creating different physical directories for each file route post office.

For Put file post offices, however, you may specify different physical
directories.
Click Save.

The new post office appears in the Post Offices list.

Copying Post Offices

You can copy post offices.

To copy a post office

1.

ook w0

From the File menu, select Post Offices.

The list of all post offices appears.

Select a post office from the Post Offices list.

Click Copy. The Copy Post Office dialog box appears.

Specify a new Name and Nickname for the copy of the existing post office.
Edit the other File post office settings as needed.

Click Save.

The additional post office appears in the Post Offices list.

Editing Post Offices

You can edit post offices.

To edit a post office

1.

Select one of the Post Office types displayed in the navigator.
The list of Post Offices for that adapter is displayed.

Select a post office from the list.

Click Edit.

The Edit Post Office dialog box opens.
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Note: When editing the File Post Office, be aware that changing the nickname
may cause a conflict with associated trade links. Also, if you change the
physical directory, you need to verify that all files have been moved to
the new directory.

4. Specify a new Name and Nickname for the copy of the existing post office.
5. Edit the other File post office settings as needed.
6. Click Save.

The additional post office appears in the Post Offices list.

Deleting Post Offices

Note: You cannot delete a post office that is associated with any trade links. You
must change the post office for each affected trade link prior to deleting the
post office.

To delete a post office

1. Select one of the Post Office types displayed in the navigator.
The list of Post Offices for that adapter is displayed.

2. Select the post office that you want to delete from the list.

3. Click Delete and confirm the delete action when prompted.
The post office is removed from the Post Offices list.

VAN Post Offices Overview

This section describes how to configure the VAN adapter as well as how to specify
options for the Monitor file, as well as how to add, copy, edit, and delete VAN
Post Offices.

Supported VAN Types

The following is a list of supported VAN types:

* Advantis (IBM) » Kleinschmidt

* Advantis (Sears) » EDINet

o AT&T * Sprint

* Commerce * Transettlements

* Compuserve * User-defined networks
* GE Information Systems (GEIS) .

Adding a VAN Post Office

For more information about the VAN adapter, see the VAN Adapter
documentation.

To add a VAN post office
1. Select VAN from the list of Post Office types displayed in the navigator.

The VAN Post Offices dialog box opens with all Post Offices associated with
the VAN adapter displayed.
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2. Click Add.
The Add Post Office form appears.
3. Select VAN from the Adapter Type drop-down menu.
The Add Post Office dialog box for the VAN adapter type opens.
4. Enter information in this dialog box as described in the following table.

VAN Post Office Field Information to Enter or Select

Name Name for the post office; for example, X12
Data For Processing. The name displays in
the Post Office list and in the Get Mail Post
Office and Put Mail Post Office drop-down
list box in the Trade Links navigator.

Nickname A three-character nickname. Partner
Manager automatically generates a valid,
unique nickname based on the Name entry.
You may use this nickname or assign one of
your own. The nickname is used to identify
this post office throughout the Trading
Manager system.

Adapter Type Select the VAN adapter type.

Get/Put Indicator Enable the option button for Get Post Office
or Put Post Office.

Adapter Command String The command string specified in the VAN
configuration setting automatically displays
here.

5. At this point you can either save the Post Office without configuring it, or
configure the Post Office before you save it.

* To save the Post Office without configuring it, click the Save button. A
confirmation box will open which will ask you to confirm your save. Click
OK to close this box and add the Post Office to the scroll list in the VAN
Post Offices dialog box.

 If you want to configure the Post Office, see the next section Configuring a
VAN Post Office.

Configuring a VAN Post Office

These steps describe how to configure a VAN Post Office.

To configure a VAN Post Office
1. Add a VAN Post Office and complete all fields as described in ['Adding a VAN|

-

2. Click Configure.
The VAN Source Configuration dialog box appears.

Note: All VANSs include the VAN Name, Phone, User ID, Password, and
Script fields; some VANs have additional fields to configure.

3. Select the VAN Name.

Each supported VAN destination is configured according to VAN requirements.
After you select the VAN Name from the drop-down list, the configuration
dialog box and required fields are customized for each VAN.

4. Enter a numeric Phone number for the modem to dial to connect to the VAN.
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The numeric phone number cannot contain any spaces, dashes, or parentheses.
Enter the User ID for the specific VAN account.
Enter the Password associated with the User ID.

Enter the Script file name or click Browse to navigate your file system and
select the Script file.

The script file contains all the commands and responses to send to the VAN to
satisfy the logon requirements of the specific network. You may want to add
your own script, create it, and save the file with a .job file name extension.

Scripts used as sources for input map cards have a *_g.job designation
(indicating a GET). Scripts used as targets (destinations) for output map cards
have a *_p.job designation (indicating a PUT).

Click OK.

The VAN adapter command string is built from the information in the VAN
Source Configuration dialog box and appears in the Adapter Command String
field.

Click Save.

The new VAN Post Office appears in the Post Offices list.

VAN source configuration
In addition to defining VAN source information, you can define configuration files,
trace file creation, and monitor options.

Click a tab on the VAN Source Configuration dialog box to define:

Options to specify a configuration file other than the default aplus.cfg. Leave
this field blank.

Trace to specify a trace file name and append option for a trace file containing
diagnostic information.

Diagnostics to specify a modem monitor file and overwrite options.

Specifying Options for the Monitor File

You can specify options for the monitor file that override the default settings. The
monitor file name is based on the prefix of the associated data file and the .mon
file extension.

To specify the options for the monitor file

1.

Add a VAN Post Office as described in|'Adding a VAN Post Office’| and click
the Configure button.

Complete all required fields in Connection tab on the VAN Source Connection
dialog box as described in |['VAN Source Configuration”|.

Select the Diagnostics tab.
Select a Monitor Mode:

NONE
No monitor file is produced.

APPEND
Information is added to the existing monitor file each time the adapter
is run.

OVERWRITE
Any existing monitor file is overwritten each time the adapter is run.
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5. Click OK.
6. Click Save.

Other VAN source configuration options
Two other tabs on the VAN Source Configuration dialog box allow you to set the
following options:

* Options - allows you to specify a configuration file other than the default
aplus.cfg. Leave this field blank.

* Trace - allows you to specify a trace file name and append option for a trace file
containing diagnostic information.
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Chapter 5. Trade links

Trade links contain the partner addresses, post offices used, standards information,
control and tracking information, and current test or production status for each
individual document that you exchange with that partner.

Trade Links Overview

Use the Trade Links navigator to define and maintain trading relationships. The
Trade Links navigator enables you to coordinate the trading partners, post offices,
and additional information to define a trading relationship. The navigator contains
Inbound and Outbound trade links.

This chapter describes how to use the Trade Links navigator to define EDIFACT,
TRADACOMS, and X12 trade links.

Establishing trade links

Establishing trade links is automated by two wizards that guide you through the
process, to ensure that the resulting link provides a logical connection. The Trade
Link Add Wizard helps you define the trade link in the database. The EDI Wizard
is used for X12 and EDIFACT trade links. This wizard operates on messages that
you define, to produce the correct type tree for the correct version and release of
the standard for the Message Manager. The EDI Wizard produces two copies of
the e-commerce type tree: one tree used by the Message Manager and another tree
that is available for your use in application maps.

Inbound trade links

Inbound indicates that your company (also known as an internal trading partner)
is receiving data from another entity (also known as an external trading partner). A
basic inbound trade link consists of the following information:

* The external trading partner from which you receive the data.
* Which internal trading partner receives the data.

* Where Trading Manager gets its data (Get post office) and puts its data (Put post
office).

* What type(s) of information the two trading partners are exchanging.

This section describes:

"X12 Inbound Trade Links'|

« |"EDIFACT Inbound Trade Links'|

+ ['TRADACOMS Inbound Trade Links'|

X12 Inbound Trade Links
The section describes how to add, edit, copy, and delete X12 Inbound Trade Links:
* To add X12 Inbound Trade Links see ['Adding an X12 Inbound Trade Link’|
* To edit X12 Inbound Trade Links sed"Editing an X12 Inbound Trade Link’|
¢ To copy X12 Trade Links see page |”COEXing an X12 Inbound Trade Link’
* To delete X12 Trade Links see page|”Deleting an X12 Inbound Trade Link'|
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Adding an X12 Inbound Trade Link

An inbound trade link is defined as one in which your (external) partner is
sending data to you (the internal partner). You are the receiver of the incoming
data.

To add an X12 inbound trade link

1.

10.

11.

12.

From the File menu, select Trade Links.

The Trade Links navigator appears.

Click Inbound > X12 in the Trade Links navigator.

The X12 Inbound Trade Links window opens.

Click Add Link.

The X12 Inbound Trade Links Add Wizard opens.

Follow the on-screen instructions in the Wizard to add an X12 Trade Link.

When you click Finish to complete adding an inbound trade link using the
Wizard, the X12 Trade Link: Add Application window opens.

Select a version and functional ID.
Click OK.
You are returned to the X12 Inbound Trade Links window.

Select either the Test or Production check box to activate the associated Test
Post Office or Production Post Office field.

Select a post office from the drop-down menu on the selected field.

Note: The Test Post Office field, and the Production Post Office field are
mandatory depending upon which Test/Production check boxes are
enabled. One of these fields must be completed before you can save the
Trade Link.

If you want to make changes to any of the fields in the window related to
acknowledgements and validation, click the Acknowledgements/Validate By
tab to display those fields.

If you are adding a HIPAA X12 document, click the HIPAA Validation Types
tab to display the HIPAA fields.

Note: In the preceding screen, it should be noted that the fields in the HIPAA
Validation Types area are active only when a HIPAA Version and a
Functional ID Code other than FA is selected. These fields display when
the HIPAA Validation Types tab is selected. These fields are described
in ['Editing a HIPAA X12 Document”|.

Click Save.
The Trade Link is saved.

Editing an X12 Inbound Trade Link

The following instructions describe how to edit existing trade links.

To edit an inbound trade link

1.
2.
3.

From the File menu, select Trade Links.
In the Trade Links navigator, expand Inbound > X12.

Find the desired trade link by using the search buttons at the top of the
window. See|'Searching for an X12 Trade Link’| for additional search
information.
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After making your selection, the Search dialog closes and you are returned to
the X12 Inbound Trade Links window.

4. Make your changes.
5. Click Save.

A message box opens that informs you that your updates have been made.
6. Click OK.

The Trade Link is updated.

Copying an X12 Inbound Trade Link

The following instructions describe how to copy existing trade links.

To copy an inbound trade link
1. From the File menu, select Trade Links.
2. In the Trade Links navigator, expand Inbound ~» X12.
The X12 Inbound Trade Links window opens.

3. Click the Copy button in the trading partner area of the window. The Copy
X12 Inbound Trade Link window opens.

4. Click Find All in the New “From’ Trading Partner area to open the X12
Partner Lookup window, or click Search for a more refined search.

5. Highlight a trading partner and click Select.

6. Click Find All in the New “To’ Trading Partner area, or click Search for a
more refined search.

7. Highlight a partner and click Select.
8. Click Begin Copy.

9. If the link being copied has no acknowledgement partners, a message box
opens that informs you that the copy was successful.

10. If the selected link contains an acknowledgement partner, the Select
Acknowledgement Partner dialog opens.

You have the following options:

* Set to Same as ‘From’ Partner - you can use the same Acknowledgement
partner as the new From partner

* Select a New Acknowledgement Partner - you select a different
Acknowledgement partner; the Partner Lookup dialog box appears if you
click this button

* Set This Application to "No Acknowledgement’ - you can set the
application so that it has no acknowledgement

11. Make your selection and click OK.

A message box opens that informs you that the copy was successful.
12. Click OK to close the message box.

The Trade Link is copied.

Deleting an X12 Inbound Trade Link
The following instructions describe how to delete existing trade links.

Note: Deleting a link deletes all applications and transactions associated with the
trade link. The delete operation cannot be reversed.

To delete an X12 inbound trade link
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8.

. From the File menu, select Trade Links.

In the Trade Links navigator, expand Inbound and X12.

Find the trade link that you want to delete by using the search buttons at the
top of the window. See |'Searching for an X12 Trade Link’| for additional search
information.

Highlight a link.
Click Select.
Click Delete.

The Trade Link Confirmation message box opens to ask if you really want to
delete the trade link.

Click Yes to delete the trade link, including all applications and transaction sets
associated with it.

A message box opens that informs you that the trade link was successfully
deleted.

Click OK to close the message box.

EDIFACT Inbound Trade Links

The section describes how to add, edit, copy, and delete EDIFACT Inbound Trade
Links.

Adding an EDIFACT Inbound Trade Link

An inbound trade link is defined as one in which your (external) partner is
sending data to you (the internal partner). You are the receiver of the incoming
data. To add an EDIFACT inbound trade link, you use the Link Wizard.

To add an EDIFACT Inbound Trade Link

1.

From the File menu, select Trade Links.

The Trade Links navigator opens.

Click Inbound > EDIFACT in the Trade Links navigator.
The EDIFACT Inbound Trade Links window opens.
Click Add Link.

The EDIFACT Inbound Trade Links Add Wizard opens.

Follow the on-screen instruction in the Wizard to add an EDIFACT Trade Link.
If the EDIFACT trading partners have an application partner, you will be
allowed to define whether a UNG should be absent, required, or optional, the
default no longer being NO UNG.

When you click Finish to complete adding an inbound trade link using the
Wizard, the EDIFACT Trade Link: Add Application window opens.

Add applications defining the message types you receive from the external
trading partner.

The Version/Message Type group box includes the four components of the
EDIFACT version that you defined for the EDIFACT Standard Version.

* Click Find Version/Message Types to select an existing EDIFACT version, or

* Select the components from the Version/Message Type lists that define the
version or message type.

Click OK. The EDIFACT Inbound Trade Links window is displayed with the
newly added trade link displayed.

Click Save.
The EDIFACT Trading Partner is added.
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Editing an EDIFACT Inbound Trade Link

The following instructions describe how to edit existing EDIFACT inbound trade
links.

To edit an EDIFACT inbound trade link
1. From the File menu, select Trade Links.
2. In the Trade Links navigator, expand Inbound and select EDIFACT.

3. Find the desired trade link by using the search buttons at the top of the
window. See|"Searching for an EDIFACT Trade Link'| for additional search
information.

After you have selected the trading partner that you want to edit, it appears in
the EDIFACT Inbound Trade Links window.

4. Make your changes.
5. Click Save.

A message box opens that informs you that your updates have been made.
6. Click OK.

The Trade Link is updated.

Copying an EDIFACT Inbound Trade Link
The following instructions describe how to copy existing trade links.

To copy an inbound trade link
1. From the File menu, select Trade Links.
2. In the Trade Links navigator, expand Inbound > EDIFACT.

3. Click the Copy button in the trading partner area of the window. The Copy
EDIFACT Inbound Trade Link window opens.

4. Click Find All in the New "From’ Trading Partner area to open the EDIFACT
Partner Lookup window, or click Search for a more refined search

5. Highlight a trading partner and click Select.

6. Click Find All in the New “To” Trading Partner area, or click Search for a more
refined search.

7. Highlight a partner and click Select.
8. Click Begin Copy.

A message box will open to inform you that your copy was successful.
9. Click OK.

The EDIFACT Trading Partner is copied.

Deleting an EDIFACT Inbound Trade Link
The following instructions describe how to delete existing trade links.

Note: Deleting a link deletes all applications and transactions associated with the
trade link. The delete operation cannot be reversed.

To delete an EDIFACT inbound trade link

1. From the File menu, select Trade Links.

2. In the Trade Links navigator, select Inbound > EDIFACT.
The EDIFACT Inbound Trade Link window opens.
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3. Find the trade link to be deleted by using the search buttons at the top of the
window. See|['Searching for an EDIFACT Trade Link'| for additional search
information.

After you select the link, the search window closes and you are returned to the
EDIFACT Inbound Trade Link window with the selected link displayed.

4. Click Delete.

The Trade Link Confirmation message box opens to ask if you really want to
delete the trade link.

5. Click Yes to delete the trade link, including all applications and transaction sets
associated with it.

A message box opens that informs you that the trade link was successfully
deleted.

6. Click OK to close the message box.

TRADACOMS Inbound Trade Links

The section describes how to add, edit, copy, and delete TRADACOMS Inbound
Trade Links:

« To add a TRADACOMS Inbound Trade Links, see|"Adding a TRADACOMS|
[[nbound Trade Link"|.

+ To edit a TRADACOMS Inbound Trade Links, see|'Editing TRADACOMS|
[[nbound Trade Links"|.

+ To copy a TRADACOMS Inbound Trade Links, see ['Editing TRADACOMS|
[[nbound Trade Links"].

+ To delete a TRADACOMS Inbound Trade Links, see ['Deleting TRADACOMSY
[[nbound Trade Links"|.

Adding a TRADACOMS Inbound Trade Link

An inbound trade link is defined as one in which your (external) partner is
sending data to you (the internal partner). You are the receiver of the incoming
data. The procedure uses the Link Wizard.

Note: Because application partners are optional in TRADACOMS, if SDT/CDT
segments are expected, select the trading partner that also has an application
partner associated with it.

To add a TRADACOMS inbound trade link
1. From the File menu, select Trade Links.
The Trade Links navigator opens.
2. Click Inbound > TRADACOMS in the Trade Links navigator.
The TRADACOMS Inbound Trade Links window opens.
3. Click Add Link.
The TRADACOMS Inbound Trade Links Add Wizard opens.

4. Follow the on-screen instruction in the Wizard to add a TRADACOMS Trade
Link.

5. When you click Finish to complete adding an inbound trade link using the
Wizard, the TRADACOMS Trade Link: Add Application window opens.

6. Select a Document Type by selecting a type from the Document Type field
drop-down menu.

You can access a list of all TRADACOMS document types by clicking the Find
button.
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10.

1.

12.

Click OK.

The TRADACOMS Trade Link: Add Application window closes and you are
returned to the TRADACOMS Inbound Trade Links window with the
Application tab displayed.

Select a Get Post Office using the Get Post Office field drop-down menu.

Note: The Get Post Office field is mandatory and must be entered before the
Trade Link can be saved.

Select a Put Post Office.

If the Test check box is enabled, you must enter a Post Office in the Test Put

Post Office field

If the Production check box is enabled, you must enter a Post Office in the
Production Put Post Office field.

Note: The Get Post Office and Production Put Post Office fields are
mandatory depending upon which Test/Production check boxes are
enabled. One of these fields must be completed before you can save the
Trade Link.

If you want to make changes to customer or supplier details, click the
SDT/CDT & VAT tab.

Click Save.

The Trade Link Saved message box opens to inform you that the trade link is
saved.

Click OK.
The message box closes and the Trade Link is saved.

Editing TRADACOMS Inbound Trade Links

The following instructions describe how to edit existing EDIFACT inbound trade
links.

To edit a TRADACOMS inbound trade link

1.
2.
3.

From the File menu, select Trade Links.
In the Trade Links navigator select Inbound >TRADACOMS.

Find the trade link to be edited by using the search buttons at the top of the
window. See['Searching for a TRADACOMS Trade Link’| for additional search

information.

After you have selected the trading partner that you want to edit, it appears in
the TRADACOMS Inbound Trade Links window.

Make your changes.

Click Save.

A message box opens that informs you that your updates have been made.
Click OK.

The Trade Link is updated.

Copying TRADACOMS Inbound Trade Links

The following instructions describe how to copy existing trade links.

To copy a TRADACOMS inbound trade link

1.

From the File menu, select Trade Links.
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2. In the Trade Links navigator, expand Inbound > TRADACOMS.
The TRADACOMS Inbound Trade Link window opens.

3. Click the Copy button in the trading partner area of the window.
The Copy TRADACOMS Inbound Trade Link window opens.

4. Click Find All in the New ‘From’ Trading Partner area to open the
TRADACOMS Partner Lookup window, or click Search for a more refined
search

5. Highlight a trading partner and click Select.

6. Click Find All in the New “To’ Trading Partner area, or click Search for a more
refined search).

7. Highlight a partner and click Select.
8. Click Begin Copy.

A message box will open to inform you that your copy was successful.
9. Click OK.

The TRADACOMS Trade Link is copied.

Deleting TRADACOMS Inbound Trade Links

The following instructions describe how to delete existing trade links.

Note: Deleting a link deletes all applications and transactions associated with the
trade link. The delete operation cannot be reversed.

To delete a TRADACOMS inbound trade link
1. From the File menu, select Trade Links.
2. In the Trade Links navigator, select Inbound > TRADACOMS.

3. Find the desired trade link by using the search buttons at the top of the
window. See|'Searching for a TRADACOMS Trade Link’| for additional search
information.

After you have selected the trade link to be deleted, the search window closes
and you are returned to the TRADACOMS Inbound Trade Link window with
the selected trade link displayed.

4. Click Delete.

The Trade Link Confirmation message box opens to ask if you really want to
delete the trade link.

5. Click Yes to delete the trade link, including all applications and transaction sets
associated with it.

A message box opens that informs you that the trade link was successfully
deleted.

6. Click OK to close the message box.

Inbound trade link applications

48

One or more business documents are exchanged between an internal and external
trading partner, with each business document defined as an application within the
trading relationship. The initial applications are added when you run the Inbound
Trade Links Wizard. You can add more applications for a given external and
internal trading partner from the Inbound Trade Links: Partner View dialog box.
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X12 Inbound Trade Link Applications

Refer to the following procedures to add, edit, and delete X12 Inbound Trade Link
Applications.

Adding an X12 Inbound Trade Link Application

One or more business documents are exchanged between an internal and external
trading partner, with each business document defined as an application within the
trading relationship.

The initial applications are added when you run the Inbound Trade Links Wizard.
You can add more applications for a given external and internal trading partner
from the Inbound Trade Links: Partner View dialog box.

Use the following instructions to add a new X12 application for a trade link.

To add a new X12 inbound trade link application

1. From the File menu, select Trade Links.

2. In the Trade Links navigator select Inbound > X12.
The X12 Inbound Trade Links window opens.

3. Click the Applications tab.
The Applications tab view opens.

4. Click Add Application.
The X12 Trade Link: Add Application window opens.

5. Select a Version and Functional ID then click OK.

6. Specify the data state to be exchanged. At least one of the two check boxes
must be checked

* Enable Test, if exchanging test data
* Enable Production, if exchanging production data

7. If you enabled the Test or Production indicators, choose the Put Post Office
where the application-ready EDI data received in Test or Production mode is
placed.

8. If desired you can click the Acknowledgements/Validate By tab and enter any

information. Refer to the X12 Functional Acknowledgement table following
these procedures for a description of the X12 FAs.

9. If you are adding a HIPAA Inbound Trade Link Application, click the HIPAA
Validation Types tab and set the fields as desired. Refer to ['Editing a HIPAA|
[X12 Document’| for more information.

10. If you do not want to perform data validation, but you want to route the data,
check the Route Only; No Validation check box.

11. Click Save.

The X12 Inbound Trade Links window displays the new trade link application
in the list.

Levels of X12 Functional Acknowledgement (FA):

The following are levels of X12 functional acknowledgements:

No Acknowledgement
No FA is sent
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Functional Group Level
An FA is sent acknowledging receipt of the functional group, providing
details of the inbound data to only the functional group (AK1) level.

Transaction Set Level
An FA is sent acknowledging receipt of the functional group, providing
details of the inbound data to the transaction set (AK2) level.

Segment Level
An FA is sent acknowledging receipt of the functional group, providing
details of the inbound data to the segment (AK3) level.

Data Element Level
An FA is sent acknowledging receipt of the functional group, providing
details of the inbound data to the data element (AK4) level.

If you select an FA to be sent, specify the receiving external trading partner. By
default, functional acknowledgements are sent to the X12 external trading partner
in the trade link.

To send acknowledgements to an address other than the external trading partner
1. In the X12 Inbound Trade Link window Application tab view

Click the Find Ack To button

TheX12 Partner Lookup in Folder window opens.

Enter search criteria in the window, then click Execute to display partners.

A

Click Select to close the Lookup window.
The X12 Inbound Trade Links window displays the new application.

Editing an X12 Inbound Trade Link Application

To edit an inbound X12 inbound trade link application

1. From the File menu, select Trade Links.

2. In the Trade Links navigator select Inbound > X12.
The X12 Inbound Trade Links window opens.

3. Click the Applications tab.

4. Select a trade link application from the list.

5. Make changes to any of the fields in Post Offices/Routing;
Acknowledgements/Validate By; and HIPAA Validation Types (HIPAA users
only) tab views.

6. When the information is complete, click Save.

The Trade Link Saved message box will open to tell you that your changes
have been saved.

7. Click OK to close the message box.

The following are Validate By group box options:

Interchange
If the transaction is bad, the whole interchange will be removed.

Message
EDIFACT only. If a transaction is bad, only that transaction will be
removed. All remaining good data will be processed.
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Transaction
X12 only. If a transaction is bad, only that transaction will be removed. All
remaining good data will be processed.

Functional Group
If a transaction is bad, the functional group that contained the bad
transaction will be removed and the remaining good data will be
processed.

Editing a HIPAA X12 document

The selections that you make in the HIPAA Validation Types area of the Edit X12
Inbound Trade Link window are used by Message Manager to determine the
validation level of incoming HIPAA data.

Note: These fields are enabled only when the Inbound Group is for a HIPAA
Version with a Functional ID code other than FA. Additionally, to enable
these drop-down menus, at least one Structure Validation record must be
imported, or manually added for levels 1 and 2 and at least one HIPAA
Type Qualifiers Import (hipaa_x12_4010_qualifier.dat), or maintenance must
be performed for levels 3; 4; 6; and 7, with one exception. In this exception,
type 5 will be enabled if type 2, 3, or 4 is enabled and a HIPAA Type
Qualifiers Import was run. For details related to the HIPAA Type Qualifiers
Import, see the Chapter 3 of the Trading Manager Installation and User Guide.

You may select one of the following values for these fields:
* Typel: Disabled; Enabled; or Reported in 997

e Type 2: Disabled; Enabled; Enabled, Reported in 997; or Enabled, Reported in
999

* Type 3: Disabled; Enabled; Enabled; Reported in 824; Enabled; Reported in
999; or Enabled, Execute Map

Note: If Enabled, Execute Map is specified in Type 3, the Type 3 Map field
must contain a value.

e Type 4: Disabled; Enabled; Enabled, Reported in 824; Enabled, Reported in 999
* Type 5: Disabled; Enabled; Enabled, Reported in 997; Enabled, Reported in 999
¢ Type 6: Disabled; Enabled; Enabled, Reported in 824; Enabled, Reported in 999
* Type 7: Disabled; Enabled; Enabled, Reported in 824; Enabled, Reported in 999

You can only specify Type 7 if the External Application Partner for this link has
a "HIPAA Institution” set.

If any 824 reporting was selected, a box will be enabled to allow you to specify
the version for the 824 transaction. The default version is 4050, but it can be
changed to a value in the drop down list (currently versions 4050 and 4010 are
available).

For tradelinks for HIPAA version V4050X151 and functional ID "PI”, if a type 4
824 or 999 report was selected, another check box in the HIPAA validation
window is enabled to allow you to define how to perform validation for the BIN
segments that might be present in those transactions. The default value is to
perform no validation (Value=NEVER), but you can also specify the values "X"
to perform only format validation, or "S” to perform validation against a Schema
for both version and content. It is important in the last two cases to have the
required schema file located in the same directory as the Message Manager
maps.
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Deleting an X12 Inbound Trade Link Application

The following instructions describe how to delete an existing X12 trade link
application.

To delete an X12 inbound trade link application

1. From the File menu, choose Trade Links.

2. In the Trade Links navigator select Inbound > X12.
The X12 Inbound Trade Links window opens.

3. Click the Applications tab.

4. Select a trade link application from the list.

5. Click the Delete Application button.

The Trade Links Application Removal Confirmation box opens. The box tells
you that you must Save after closing the box to complete removal.

6. Click OK.
The message box closes.
7. Click Save.
The trade link application is deleted.

EDIFACT Inbound Trade Link Applications

Refer to the following procedures to add, edit and delete EDIFACT Inbound Trade
Link Applications

Adding an EDIFACT Inbound Trade Link Application

One or more business documents are exchanged between an internal and external
trading partner, with each business document defined as an application within the
trading relationship.

The initial applications are added when you run the Inbound Trade Links Wizard.
You can add more applications for a given external and internal trading partner
from the Inbound Trade Links: Partner View dialog box.

Use the following instructions to add a new EDIFACT application for a trade link.

To add a new EDIFACT inbound trade link application
1. From the File menu, select Trade Links.
2. In the Trade Links navigator select Inbound > EDIFACT.
The EDIFACT Inbound Trade Links window opens.
3. Click the Applications tab.
4. Click the Add Application button.

The EDIFACT Trade Link: Add Application window opens. If the No UNG
option is set, the two fields in the Application Partners area will be grayed
out.

5. If this is an optional or mandatory UNG link, and an UNG segment is
expected for this application, select the Application Partners associated with
this UNG segment in the drop-down list.

6. Complete the Msg Version No, Msg Release No, and Controlling Agency
fields.

7. Click the Find Version Message Types button to open the Find All EDIFACT
Functional ID Message Types list box and select a message type from the list.
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10.

11.

12.

13.

Click OK.

With the Post Offices tab displayed select test or production data by enabling
one or both Test and/or Production check boxes.

Select a Test Post Office and/or Production Post Office. You must select a test
or production Post Office in order to save the trade link application.

If data is not to be validated, but is to be routed to the Post Office, enable the
Route Only; No Validation check box.

If validation is desired, click the Acknowledgements/Validate By tab and
make changes to any fields in this view.

Click Save.
The new Inbound Trade Link Application is now created.

Levels of EDIFACT Acknowledgement (CONTRL):

The following list identifies the levels of EDIFACT functional acknowledgements.
Please note that CONTRL, as used in this section, is not a typographical error.

Acknowledgement Description
No Acknowledgement No CONTRL is sent
Interchange Level A CONTRL is sent acknowledging receipt,

providing details of the inbound data to only
the interchange (UCI) level.

Functional Group Level This option is only available if this is a UNG

level document, that is, application partners are
specified. A CONTRL is sent acknowledging
receipt, providing details of the inbound data
to only the functional group (UCF) level.

Message Level A CONTRL is sent acknowledging receipt,

providing details of the inbound data to the
message (UCM) level.

Segment Level A CONTRL is sent acknowledging receipt,

providing details of the inbound data to the
segment (UCS) level.

Data Element Level A CONTRL is sent acknowledging receipt,

providing details of the inbound data to the
data element (UCD) level.

Editing an EDIFACT Inbound Trade Link Application

To edit an inbound EDIFACT trade link application

1.
2.

From the File menu, select Trade Links.

In the Trade Links navigator select Inbound > EDIFACT.
The EDIFACT Inbound Trade Links window opens.

Click the Applications tab.

Select a trade link application from the list.

Make changes to any of the fields in Post Offices/Routing;
Acknowledgements/Validate By; and Application Partners tab views.

When the information is complete, click Save.

The Trade Link Saved message box will open to tell you that your changes
have been saved.

Click OK to close the message box.
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Deleting an EDIFACT Inbound Trade Link Application

The following instructions describe how to delete an existing EDIFACT trade link
application.

To delete an EDIFACT inbound trade link application

1. From the File menu, choose Trade Links.

2. In the Trade Links navigator select Inbound > EDIFACT.
The EDIFACT Inbound Trade Links window opens.

3. Click the Applications tab.

4. Select a trade link application from the list.

5. Click the Delete Application button.

The Trade Links Application Removal Confirmation box opens. The box tells
you that you must Save after closing the box to complete removal.

6. Click OK.
The message box closes.
7. Click Save.
The trade link application is deleted.

TRADACOMS Inbound Trade Link Applications

Refer to the following procedures to add, edit, and delete TRADACOMS Inbound
Trade Link Applications.

Adding a TRADACOMS Inbound Trade Link Application

One or more business documents are exchanged between an internal and external
trading partner, with each business document defined as an application within the
trading relationship.

The initial applications are added when you run the Inbound Trade Links Wizard.
You can add more applications for a given external and internal trading partner
from the Inbound Trade Links: Partner View dialog box.

Use the following instructions to add a new EDIFACT application for a trade link.

To add a new TRADACOMS inbound trade link application
1. From the File menu, select Trade Links.
2. In the Trade Links navigator select Inbound > TRADACOMS.
The TRADACOMS Inbound Trade Links window opens.
3. Click the Application tab.
4. Click the Add Application button.
The TRADACOMS Trade Link: Add Application window opens.
Select a document type from the Document Type field.
Click OK.
Add data as desired in the fields in the SDT/CDT & VAT tab view

With the Post Offices tab displayed, select test or production data by enabling
one or both Test and/or Production check boxes.

Select a Test Post Office and/or Production Post Office.
10. Click Save.

© N O

©
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Editing a TRADACOMS Inbound Trade Link Application

To edit an inbound TRADACOMS trade link application

1. From the File menu, select Trade Links.

2. In the Trade Links navigator select Inbound >+ TRADACOMS.
The EDIFACT Inbound Trade Links window opens

3. Click the Applications tab.

4. Select a trade link application from the list.

5. Make changes to any of the fields in Post Offices and SDT/CDT & VAT tab
views.

6. When the information is complete, click Save.

7. The Trade Link Saved message box will open to tell you that your changes
have been saved.

8. Click OK to close the message box.
Deleting a TRADACOMS Inbound Trade Link Application

The following instructions describe how to delete an existing TRADACOMS trade
link application.

To delete a TRADACOMS inbound trade link application

1. From the File menu, choose Trade Links.

2. In the Trade Links navigator select Inbound > TRADACOMS.
The EDIFACT Inbound Trade Links window opens.

3. Click the Applications tab.

4. Select a trade link application from the list.

5. Click the Delete Application button.

The Trade Links Application Removal Confirmation box opens. The box tells
you that you must Save after closing the box to complete removal.

6. Click OK.
The message box closes.
7. Click Save.
The trade link application is deleted.

Outbound trade links

When you define Outbound Trade Links, outbound indicates that your company
(also known as an internal trading partner) is sending data to another entity (also
known as an external trading partner). A basic outbound trade link consists of the
following information:

* Which internal trading partner is sending the data
* Which external trading partner is receiving the data

* Where Trading Manager gets its data (Get post office) and puts its data (Put post
office)

* What type(s) of information the two trading partners are exchanging

X12 Outbound Trade Links
X12 Outbound Trade Links can be added, edited, copied, and deleted.
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Adding an X12 Outbound Trade Link

To add an X12 outbound trade link requires the following steps:

* Select the external and internal trading partners with associated application
partners.

* Select the Get and Put post offices:
e The Get post office is where Message Manager retrieves the EDI data.

* The Put post office provides the routing instructions for the EDI data produced
by Message Manager (or how Message Manager sends the data).

* Select the interchange control (ISA) and functional group (GS) numbering
schemes.

* Add applications defining the message types you receive from the external
trading partner.

To select external and internal X12 trading partners
1. From the File menu, select Trade Links.
2. In the Trade Links navigator select Outbound » X12.
3. Click Add Link.
The Add an X12 Outbound Link Wizard opens.
4. Follow the on-screen instructions in the Wizard to add an X12 Trade Link.

5. When you click Finish to complete adding an inbound trade link using the
Wizard, the X12 Trade Link: Add Application window opens.

6. Select a version and functional ID for the application partner.
7. Click OK.
You are returned to the X12 Inbound Trade Links window.
8. Select a version and functional ID.
9. Click OK.

You are returned to the X12 Inbound Trade Links window. The Application
tab view is displayed. The Application information that you entered is listed
in the scroll box.

10. If you want to add another application, click the Add Application button.
11. Perform steps 8 and 9.

12. When you are finished adding applications, select a Production Post Office
from the drop-down menu on the Production Post Office field.

Note: The Put Post Office field is mandatory. You must select a Put Post
Office before you can save the Trade Link.

13. In the X12 Outbound Trade Links window, click the Application tab, and then
click theFormat, GS/ST Control tab.

This tab view contains the Application Format options and the GS Time
Stamp Options.

You can choose one of the following Application Format enveloping options
by selecting the associated button:

* Fully Enveloped - This option indicates that the data passed to Trading
Manager for outbound processing is already fully enveloped with
terminators/delimiters, ISA envelope information, and Control numbers.
Trading Manager makes no updates, leaving this enveloping information as
is.
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14.

15.

16.

¢ Control Number Enveloped - This option indicates that terminator/
delimiter enveloping is set in the data, but Trading Manager should
generate a proper control number at the Interchange, Functional Group, and
Transaction level.

¢ Partially Enveloped - Trading Manager envelopes data with
terminators/delimiters as specified in Partner Manager, and generates a
proper control number at the Interchange level, Functional Group level, and
Transaction level. ISA control fields are also set based on information in
Partner Manager.
You can change the GS Time Stamp Option by selecting one of the
following buttons. HHMM; HHMMSS; HHMMSSD; HHMMSSDD.
Time is expressed in 24-hour clock time as follows: HHMM, or HHMMSS,
or HHMMSSD, or HHMMSSDD, where H = hours (00-23), M = minutes
(00- 59), S = integer seconds (00-59) and DD = decimal seconds; decimal
seconds are expressed as follows: D = tenths (0-9) and DD = hundredths
(00-99)

You can select the Format tab view and the Transactions tab view and modify

any of the default settings of fields in these tab views.

Select the Identification, GS Control, ISA Control and Applications tab and

make any desired changes to any of the fields.

Click Save.

Editing an X12 Outbound Trade Link

The following instructions describe how to edit existing X12 Outbound trade links.

To edit an X12 outbound trade link

1.
2.
3.

7.
8.

From the File menu, select Trade Links.
In the Trade Links navigator, expand Outbound and X12.

Find the desired trade link by using the search buttons at the top of the
window. See|’Searching for an X12 Trade Link”|for additional search
information.

After making your selection, the search window closes and you are returned to
the X12 Outbound Trade Links window.

Make any desired changes to the fields in the Edit windows, and click Save
when you are finished.

You are returned to the X12 Outbound Trade Links window.
Click any of the tab views in this window to modify any fields.
When you are satisfied that all of your changes have been made, click Save.

The Trade Link Saved message box opens to inform you that your changes
were successfully saved.

Click OK.

The message box closes and the edit is complete

Copying an X12 Outbound Trade Link

The following instructions explain how to copy an X12 outbound trade link.

To copy an X12 Outbound trade link

1.
2.

From the File menu, select Trade Links.
In the Trade Links navigator, select Outbound > X12.
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3. Click Copy Link in the trading partner area of the window. The Copy X12
Outbound Trade Link dialog box appears.

4. Click Find All in the New “From’ Trading Partner area (or click Advanced
Find for a more refined search).

5. Highlight a partner and click Select.

6. Click Find All in the New “To’ Trading Partner area (or click Advanced Find
for a more refined search).

7. Highlight a partner and click Select.
8. Click Begin Copy.
9. Click OK to confirm.

The changes to the trade link appear in the X12 Outbound Trade Links
window.

Deleting an X12 Outbound Trade Link

Note: Deleting a link deletes all partner relationships, applications, and
transactions associated with the trade link. The delete operation cannot be
reversed.

To delete an X12 outbound trade link

1. From the File menu, select Trade Links.

2. In the Trade Links navigator, select Outbound > X12.
TheX12 Outbound Trade Links window opens.

3. Find the trade link to be deleted by using the search buttons at the top of the
window. See|’Searching for an X12 Trade Link’|for additional search
information.

After making your selection, the search window closes and you are returned to
the X12 Outbound Trade Links window.

4. Click Delete.

5. When the confirmation dialog box appears, click Yes to delete the trade link,
including all applications and transaction sets associated with it.

EDIFACT Outbound Trade Links
EDIFACT Outbound Trade Links can be added, edited, copied, and deleted.

Adding an EDIFACT Outbound Trade Link

Refer to the following procedures to add an EDIFACT Outbound Trade Link

To add an EDIFACT outbound trade link
1. From the File menu, select Trade Links.
The Trade Links navigator opens.
2. Click Outbound > EDIFACT in the Trade Links navigator.
The EDIFACT Outbound Trade Links window opens.
3. Click Add Link.
The EDIFACT Outbound Trade Links Add Wizard opens.

4. Follow the on-screen instruction in the Wizard to add an EDIFACT Trade
Link.

5. When you click Finish to complete adding an inbound trade link using the
Wizard, the EDIFACT Trade Link: Add Application window opens.
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6. Add applications defining the message types you receive from the external
trading partner.

7. The Version/Message Type group box includes the four components of the
EDIFACT version that you defined for the EDIFACT Standard Version.

* Click Find Version/Message Types to select an existing EDIFACT version,
or

* Select the components from the Version/Message Type lists that define the
version or message type.

8. Click OK.

The EDIFACT Outbound Trade Links window is displayed with the newly
added trade link displayed.

9. In the Post Offices tab view, select the Test or Production check box. You can
also select both.

10. Select a Test Put Post Office and/or a Production Put Post Office (depending
upon which check boxes that you selected in the Test/Production Indicators
area.

11. If validation is not desired, enable the Route Only; no Validation check box.
12. Click Save.
The EDIFACT Trading Partner is added.

Editing an EDIFACT Outbound Trade Link

The following instructions describe how to edit an existing EDIFACT outbound
trade link.

To edit an EDIFACT inbound trade link
1. From the File menu, select Trade Links.
2. In the Trade Links navigator, expand Outbound and select EDIFACT.
3. Click the Edit From TP button.
The Edit EDIFACT Trading Partner window opens.
4. Make changes to the fields in this window as desired.
5. Select the Syntax/Separators tab and make any desired changes.
6. Click Save.

The Edit EDIFACT window closes and you are returned to the EDIFACT
Inbound Trade Links window.

7. Click the Edit To TP button.

The Edit EDIFACT Trading Partner in Internal folder EDIFACT window
opens.

8. Make changes to the fields in this window as desired.
9. Select the Syntax/Separators tab and make any desired changes.
10. Click Save.

The Edit EDIFACT window closes and you are returned to the EDIFACT
Outbound Trade Links window.

11. Click Save.

A message box opens that informs you that your updates have been made.
12. Click OK.

The EDIFACT Trade Link is updated.
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Copying an EDIFACT Trade Link

The following instructions describe how to copy existing trade links.

To copy an EDIFACT outbound trade link

1.
2.
3.

10.

From the File menu, select Trade Links.
In the Trade Links navigator, expand Outbound > EDIFACT.

Find the desired trade link by using the search buttons at the top of the
window. See ['Searching for an EDIFACT Trade Link’|for additional search
information. Highlight a link and click Select.

Click the Copy button in the trading partner area of the window. The Copy
EDIFACT Outbound Trade Link window opens.

Click Find All in the New "From’ Trading Partner area to open the EDIFACT
Partner Lookup window, or click Search for a more refined search

Highlight a trading partner and click Select.

Click Find All in the New “To’ Trading Partner area, or click Search for a
more refined search).

Highlight a partner and click Select.

Click Begin Copy.

A message box will open to inform you that your copy was successful.
Click OK.

The EDIFACT Trading Partner is copied.

Deleting an EDIFACT Outbound Trade Link

The following instructions describe how to delete existing trade links.

Note: Deleting a link deletes all applications and transactions associated with the

trade link. The delete operation cannot be reversed.

To delete an EDIFACT outbound trade link

1.
2.
3.

From the File menu, select Trade Links.
In the Trade Links navigator, select Outbound > EDIFACT.

Find the desired trade link by using the search buttons at the top of the
window. See['Searching for an EDIFACT Trade Link'| for additional search
information. Highlight a link and click Select.

The selected trade link is displayed in the EDIFACT Outbound Trade Links
window.

Click Delete.

The Trade Link Confirmation message box opens to ask if you really want to
delete the trade link.

Click Yes to delete the trade link, including all applications and transaction sets
associated with it.

A message box opens that informs you that the trade link was successfully
deleted.

Click OK to close the message box.
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Adding a TRADACOMS Outbound Trade Link

An inbound trade link is defined as one in which your (external) partner is
sending data to you (the internal partner). You are the receiver of the incoming
data. The procedure uses the Link Wizard.

Note: Because application partners are optional in TRADACOMS, if SDT/CDT

segments are expected, select the trading partner that also has an application
partner associated with it.

To add a TRADACOMS outbound trade link

1.

10.

1.

12.

From the File menu, select Trade Links.

The Trade Links navigator opens.

Click Inbound > TRADACOMS in the Trade Links navigator.
Click Add Link.

The TRADACOMS Outbound Trade Links Add Wizard opens.

Follow the on-screen instruction in the Wizard to add a TRADACOMS Trade
Link.

When you click Finish to complete adding an inbound trade link using the
Wizard, the TRADACOMS Trade Link: Add Application window opens.

Select a Document Type by selecting a type from the Document Type field
drop-down menu.

You can access a list of all TRADACOMS document types by clicking the Find
button.

Click OK.

The TRADACOMS Trade Link: Add Application window closes and you are
returned to the TRADACOMS Inbound Trade Links window with the
Application tab displayed.

Select a Get Post Office using the Get Post Office field drop-down menu.

Note: The Get Post Office field is mandatory and must be entered before the
Trade Link can be saved.

Select a Put Post Office.

If the Test check box is enabled, you must enter a Post Office in the Test Put
Post Office field

If the Production check box is enabled, you must enter a Post Office in the
Production Put Post Office field.

Note: The Get Post Office and Production Put Post Office fields are
mandatory depending upon which Test/Production check boxes are
enabled. One of these fields must be completed before you can save the
Trade Link.

If you want to make changes to customer or supplier details, click the
SDT/CDT & VAT tab.

Click Save.

The Trade Link Saved message box opens to inform you that the trade link is
saved.

Click OK.

The message box closes and the Trade Link is saved.
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Editing TRADACOMS Outbound Trade Links

The following instructions describe how to edit existing EDIFACT inbound trade
links.

To edit a TRADACOMS outbound trade link

1.
2.
3.

10.
11.
12.
13.

From the File menu, select Trade Links.
In the Trade Links navigator, expand Outbound and select TRADACOMS.

Find the desired trade link by using the search buttons at the top of the
window. See ['Searching for a TRADACOMS Trade Link"|for additional search
information. Highlight a link and click Select.

After you have selected the trading partner that you want to edit, it appears
in the TRADACOMS Inbound Trade Links window.

Click the Edit From TP button to edit "From" Trading Partner fields, or click
the Edit From AP button to edit "From” Application Partner fields.

The Edit TRADACOMS Trading Partner window opens.

Make changes to the fields in this window as desired.

When your changes are complete, click Save.

You are returned to the TRADACOMS Inbound Trade Links window.

Click the Edit To TP button to edit "To"” Trading Partner fields, or click the
Edit To AP button to edit "To" Application Partner fields.

Make any desired changes to the fields in these window(s) and save your
changes.

From the TRADACOMS Inbound Trade Links window, click the Applications
tab and make any desired changes to the Get Post Office, Test Post Office,
and/or Production Post Office by selecting the Edit button located to the right
of each field.

Select the STD/CDT & VAT tab and make any desired changes.

When your edits are complete, click Save.

A message box opens that informs you that your updates have been made.
Click OK.

The TRADACOMS Trade Link is updated.

Copying TRADACOMS Outbound Trade Links

The following instructions describe how to copy existing trade links.

To copy a TRADACOMS outbound trade link

1.
2.
3.

From the File menu, select Trade Links.
In the Trade Links navigator, expand Outbound > TRADACOMS.

Find the desired trade link by using the search buttons at the top of the
window. See |'Searching for a TRADACOMS Trade Link’|for additional search
information.

After you select a link it is displayed in the TRADACOMS Outbound Trade
Links window.

Click the Copy button in the trading partner area of the window. The Copy
TRADACOMS Outbound Trade Link window opens.

Click Find All in the New “From’ Trading Partner area to open the
TRADACOMS Partner Lookup window, or click Search for a more refined
search
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6. Highlight a trading partner and click Select.

7. Click Find All in the New “To’ Trading Partner area, or click Search for a
more refined search).

8. Highlight a partner and click Select.
9. Click Begin Copy.
A message box will open to inform you that your copy was successful.
10. Click OK.
The TRADACOMS Trade Link is copied.

Deleting TRADACOMS Trade Links
The following instructions describe how to delete existing trade links.

Note: Deleting a link deletes all applications and transactions associated with the
trade link. The delete operation cannot be reversed.

To delete a TRADACOMS outbound trade link
1. From the File menu, select Trade Links.
2. In the Trade Links navigator, select Inbound or Outbound > TRADACOMS.

3. Find the desired trade link by using the search buttons at the top of the
window. See|’Searching for a TRADACOMS Trade Link’| for additional search
information. Highlight a link and click Select.

You are returned to the TRADACOMS Outbound Trade Links window with the
link that you selected displayed.

4. Click Delete.

The Trade Link Confirmation message box opens to ask if you really want to
delete the trade link.

5. Click Yes to delete the trade link, including all applications and transaction sets
associated with it

A message box opens that informs you that the trade link was successfully
deleted.

6. Click OK to close the message box.
Adding an X12 Outbound Trade Links Application

To add a new outbound X12 trade link application
1. From the File menu, select Trade Links.
2. In the Trade Links navigator select Outbound > X12.
The X12 Outbound Trade Links window opens.
3. Click the Applications tab.
The Applications tab view opens.
4. Click Add Application.
The X12 Trade Link: Add Application window opens.
5. Select a Put Post Office.

6. Add details about the Application by selecting the Format, GS/ST Control tab
and the Transactions tab views.

7. Click Save.
The Trade Link Saved message box opens.
8. Click OK to close the message box.
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The X12 Outbound Trade Link Application is saved.

Editing an X12 Outbound Trade Link Application

To edit an X12 outbound trade link application

1. From the File menu, select Trade Links.

2. In the Trade Links navigator select Outbound > X12.
The X12 Outbound Trade Links window opens.

3. Click the Applications tab.

4. Select a trade link application from the list.

5. Make changes to any of the fields in PO/Validation/Ack; Format GS; and
Transactions tab views.

6. When the information is complete, click Save.

The Trade Link Saved message box will open to tell you that your changes
have been saved.

7. Click OK to close the message box.
Deleting an X12 Outbound Trade Link Application

To delete an X12 outbound trade link application

1. From the File menu, choose Trade Links.

2. In the Trade Links navigator select Outbound > X12.
The X12 Outbound Trade Links window opens.

3. Click the Applications tab.

4. Select a trade link application from the list.

5. Click the Delete Application button.

The Trade Links Application Removal Confirmation box opens. The box tells
you that you must Save after closing the box to complete removal.

6. Click OK.
The message box closes.
7. Click Save.
The trade link application is deleted.

EDIFACT Outbound Trade Links Applications
You can add, edit, and delete EDIFACT Outbound Trade Link Applications.
Adding an EDIFACT Outbound Trade Links Application

Use the following instructions to add an EDIFACT Outbound Trade Links
Application.

To add an EDIFACT outbound trade links application

From the File menu, select Trade Links.
1. In the Trade Links navigator select Outbound > EDIFACT.
The EDIFACT Outbound Trade Links window opens.
2. Click the Applications tab.
3. Click the Add Application button.
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10.

11.

The EDIFACT Trade Link: Add Application window opens. If the No UNG
option is set, the two fields in the Application Partners area will be grayed
out.

If this is an optional or mandatory UNG link, and an UNG segment is
expected for this application, select the Application Partners associated with
this UNG segment in the drop-down list.

Complete the Msg Version No, Msg Release No, and Controlling Agency
fields.

Click the Find Version Message Types button to open the Find All EDIFACT
Functional ID Message Types list box and select a message type from the list.

Click OK.

With the Post Offices tab displayed, select test or production data by enabling
one or both Test and/or Production check boxes.

Select a Test Post Office and/or Production Post Office. You must select a test
or production Post Office in order to save the trade link application.

Click the Msg Control No/Version Info and Application Partners tab and
make any changes to any fields in these views.

The Acknowledgements are set in the Ack Level field. See
[EDIFACT Acknowledgement (CONTRL)"].

Click Save.
The new Outbound Trade Link Application is now created.

Editing an EDIFACT Outbound Trade Link Application

To edit an inbound EDIFACT outbound trade link application

1.
2.

7.

From the File menu, select Trade Links.

In the Trade Links navigator select Outbound > EDIFACT.
The EDIFACT Outbound Trade Links window opens.

Click the Applications tab.

Select a trade link application from the list.

Make changes to any of the fields in Msg Control No/Version Info, Post
Offices and Application Partners tab views.

When your updates are complete click Save.

The Trade Link Saved message box will open to tell you that your changes
have been saved.

Click OK to close the message box.

Deleting an EDIFACT Outbound Trade Link Application

To delete an EDIFACT outbound trade link application

1.
2.

From the File menu, choose Trade Links.

In the Trade Links navigator select Inbound > EDIFACT.
The EDIFACT Inbound Trade Links window opens.

Click the Applications tab.

Select a trade link application from the list.

Click the Delete Application button.

The Trade Links Application Removal Confirmation box opens. The box tells
you that you must Save after closing the box to complete removal.

Click OK.
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7.

The message box closes.
Click Save.
The trade link application is deleted.

TRADACOMS Outbound Trade Link Applications
You can add, edit, and delete TRADACOMS Trade Link Applications.

Adding a TRADACOMS Outbound Trade Link Application:

To add a new TRADACOMS outbound trade link application

1.
2.

9.
10.

From the File menu, select Trade Links.

In the Trade Links navigator select Outbound > TRADACOMS.
The TRADACOMS Outbound Trade Links window opens.

Click the Application tab.

Click the Add Application button.

The TRADACOMS Trade Link: Add Application window opens.
Select a Document Type.

Click OK.

Add data as desired in the fields in the SDT/CDT Control No VAT RSG tab
View.

With the Post Offices tab displayed, select test or production data by enabling
one or both Test and/or Production check boxes.

Select a Test Post Office and/or Production Post Office.
Click Save.

Editing a TRADACOMS Outbound Trade Link Application:

To edit an outbound TRADACOMS trade link application

1.
2.

8.

From the File menu, select Trade Links.

In the Trade Links navigator select Outbound > TRADACOMS.
The TRADACOMS Outbound Trade Links window opens
Click the Applications tab.

Select a trade link application from the list.

Make changes to any of the fields in Post Offices and SDT/CDT Control No
VAT RSG tab views.

When the information is complete, click Save.

The Trade Link Saved message box will open to tell you that your changes
have been saved.

Click OK to close the message box.

Deleting a TRADACOMS Outbound Trade Link Application:

To delete a TRADACOMS outbound trade link application

1.
2.

From the File menu, choose Trade Links.

In the Trade Links navigator select Outbound > TRADACOMS.
The TRADACOMS Outbound Trade Links window opens.

Click the Applications tab.

Select a trade link application from the list.

Click the Delete Application button.
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The Trade Links Application Removal Confirmation box opens. The box tells
you that you must Save after closing the box to complete removal.

6. Click OK.
The message box closes.
7. Click Save.
The TRADACOMS Outbound Trade Link Application is deleted.

ISA and GS Numbering Schemes

The functional group control number reset does not occur until after the next
refresh (the next time the Message Manager’s Export map is executed). See the
Trading Manager documentation for information on scheduling the execution of
the Export map.

The following list defines the ISA and GS Numbering Schemes.

Increment
This numbering scheme is the default. A perpetually-incrementing
interchange control number is used.

The first interchange sent for this relationship has a control number of 1,
the second has a control number of 2, and so on.

If you select Increment, you can also reset the number to your preference
by enabling Reset and specifying a control number.

User Defined
Use a user-defined numbering scheme. Enter the full name and path to a
compiled map file (.mmc) that provides this custom control number.

The compiled map file is required when you select this option. The full file
name and path of the compiled map file must be specified relative to the
path of the Launcher.

You can also reset the number to your preference by enabling Reset and
specifying a control number.

Increment by Trading Partner
A perpetually incrementing GS number within this partner link (internal
application partner to external trading partner) is used.

The first interchange sent for this relationship has a control number of 1
the second has a control number of 2, and so on.

You can also reset the number to your preference by enabling Reset and
specifying a control number.

Increment by Application Partner
A perpetually incrementing functional group control number within this
partner link (application partner and application partner) is used.

The first functional group sent for this application partner within this
trading partner has a control number of 1, the second has a control number
of 2, and so on.

You can also reset the number to your preference by enabling Reset and
specifying a control number.

Increment by Functional ID Code
A perpetually incrementing functional group control number within the
functional ID code, regardless of trading partner is used.
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The first PO functional group sent has a control number of 1; the second
has a control number of 2 (regardless of its partner link), and so on.

Relative
This selection is the default.

A functional group control number that is relative to the functional group’s
sequence within its interchange.

The first functional group in the first interchange has a control number of
1, the second has a control number of 2, the first functional group in the
second interchange has a control number of 1, and so on.

Searching for a trade link

68

When entering search criteria, case sensitivity for the search depends on the
database. By default, Microsoft Access and Microsoft SQL Server are not case
sensitive (for example, Acme is the same as ACME), while Oracle is case sensitive.
For more information, contact your database administrator to determine if SQL
LIKE searches are case sensitive.

Searching for an X12 Trade Link

Refer to the following steps to search for an X12 Trade Link.

To search all X12 trade links

1. Click the File menu and select Trade Links.
The Trade Links navigator opens.

2. Select Inbound or Outbound > X12.

The Inbound or Outbound X12 Trade Links window opens. The Search buttons
are located at the top of the window. These buttons allow you to search for
Trade Links based upon various search criteria.

3. To search all available trade links, click the All Links button.
The X12 Inbound Trade Link Lookup: All Links window opens.
4. Sort the names in the list box by selecting one of two Display buttons.

* Select Names to sort the list by Trading Partner name. This causes names to
be sorted in alphanumeric order.

e Select ISA/GS to sort in ISA order:
5. Select the desired Trade Link from the list and click Select.

To search X12 trade links by partner
1. Click the File menu and select Trade Links.

The Trade Links navigator opens.
2. Select Inbound or Outbound > X12.
3. Click the Search by Partner button at the top of the window.
The X12 Inbound Trade Link Lookup: Search By Partner window opens.

4. Define your search criteria by enabling or disabling (checking or unchecking)
the check boxes in the Search the following window area and by selecting and
deselecting a button in the ISA/GS Search (Exact) window area.

5. When you are satisfied that your search criteria are properly defined, click the
Begin Search button to populate the list box with trade links that match your
search criteria

6. Select the desired trade link from the list box and click Select.
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To select an X12 trade link by document type

1. Click theFile menu and select Trade Links.

2. Select Inbound or Outbound > X12.

3. Click the Search by Document button at the top of the window.
The X12 Inbound Trade Link Document Search window opens.

4. Select a document from the top list box. When you click on the document, the
trade links associated with that document display in the bottom list box.

5. Click on the desired trade link then click Select.

Searching for an EDIFACT Trade Link

Refer to the following steps to search for an EDIFACT Trade Link.

To search all EDIFACT trade links

1. Click the File menu and select Trade Links.

2. Select Inbound or Outbound > EDIFACT

3. Click the Search All button at the top of the window.

The EDIFACT Inbound or Outbound Trade Link Lookup: All Files window
opens.

4. Scroll through the files in the list until you locate the desired file.
5. Click Select.

To select EDIFACT trade links by partner

1. From the File menu select Trade Links.

2. Select Inbound or Outbound > EDIFACT

3. Click the Search By Partner button at the top of the window.

The EDIFACT Inbound or Outbound Trade Link Lookup: Search By Partner
window opens (an Inbound window is shown below for example purposes).

GRAPHIC

4. Define your search criteria by enabling or disabling (checking or unchecking)
the check boxes in the Search the following window area and by selecting and
deselecting a button in the Interchange ID Search (Exact) window area.

* Search for a specific Folder or Trading Partner by entering specific data into
the Search For field.

* Search for a specific Interchange ID by entering specific data into the
Interchange ID field.

5. When you are satisfied that your search criteria are properly defined, click the
Begin Search button to populate the list box with trade links that match your
search criteria

6. Select the desired trade link from the list box and click Select

To select an EDIFACT trade link by document

1. From the File menu select Trade Links.
2. Select Inbound or Outbound > EDIFACT
3. Click the Search by Document button at the top of the window.

The EDIFACT Inbound or Outbound Trade Link Document Search window
opens.

4. Select a document from the top list box. When you click on the document, the
trade links associated with that document display in the bottom list box.
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5. Click on the desired trade link then click Select.

Searching for a TRADACOMS Trade Link

Refer to the following steps to search for an EDIFACT Trade Link.
To search all TRADACOMS trade links

1.

6.

Click the File menu and select Trade Links.

2. Select Inbound or Outbound > TRADACOMS
3.
4. The TRADACOMS Inbound or Outbound Trade Link Lookup: All Files

Click the Search All button at the top of the window.

window opens.

Sort the files in the list by selecting one of two buttons in the Display area at
the top of the window.

* Select the Names button to sort the list by Trading Partner name.
* Select ID to sort by Trading Partner ID.
Click Select.

To select TRADACOMS trade links by partner

1.
2.
3.

6.

From the File menu select Trade Links.

Select Inbound or Outbound > TRADACOMS

Click the Search By Partner button at the top of the window.

The TRADACOMS Inbound or Outbound Trade Link Lookup: Search By
Partner window opens.

Define your search criteria by entering starting letters for a trading partner,
application partner or from application partner ID in the fields in the Enter
Starting Letters window area. You can also select whether or not you want to
sort using names, or IDs by selecting one of the two Display buttons.

When you are satisfied that your search criteria are properly defined, click the
Begin Search button to populate the list box with trade links that match your
search criteria

Select the desired trade link from the list box and click Select.

To select a TRADACOMS trade link by document

1.
2.
3.

5.

From the File menu select Trade Links.
Select Inbound or Outbound > TRADACOMS
Click the Search by Document button at the top of the window.

The TRADACOMS Inbound or Outbound Trade Link Document Search
window opens.

Select a document from the top list box. When you click on the document, the
trade links associated with that document display in the bottom list box.

Click on the desired trade link then click Select.

Outbound 999/997/824 trade link

Partner Manager displays the Automatic Acknowledgement Creation dialog box
when you:

* Add a trade link
¢ Copy a trade link

* Add an application to an existing trade link
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* The trading partner link requires an outbound functional acknowledgement (an
outbound acknowledgement does not already exist for that trading/application
partner and version)

Note: TheAutomatic Acknowledgement Creation dialog box appears only when
you are creating X12 trade links. If you select No Acknowledgement in
the Ack Level drop-down list, this dialog box does not appear.

Note: If an 824 is being processed, the default will be to create a 4050 824
transaction. You have the option to change the version with one of the

options in a drop-down box enabled for this purpose (currently versions
4050 and 4010 are available).

If you want to create an outbound functional acknowledgement, select a Put Post
Office from the drop-down list and click Create.

Outbound CONTRL trade link

Please note that CONTRL, as used in this section, is not a typographical error.

Partner Manager displays the Automatic Outbound CONTRL Creation dialog box
when you:

* Add a trade link
* Copy a trade link
e Add an application to an existing trade link

* The trading partner link requires an outbound CONTRL acknowledgement (an
outbound acknowledgement does not already exist for that trading/application
partner and version)

TheAutomatic Outbound CONTRL Creation dialog box appears only when you
are creating EDIFACT trade links.

If you select No Acknowledgement in the Ack Level drop-down list, this dialog
box does not appear.

If you want to create an outbound CONTRL acknowledgement, select the Put and
Get Post Offices from the drop-down list and click Create. This dialog box may
appear more than once if the link contains multiple versions and/or
acknowledgement partners. In this case, the version appears in the dialog box.

The Control Message Type will default to : Version=4, Release=1, Controlling
Agency=UN; the sole CONTRL Message Type provided by IBM in the EDIFACT
Standards (see Utilities > Standards). This section of the form will remain disabled
until you create additional CONTRL Message Types in the EDIFACT Standards
definitions. At such a time, this section will be enabled and you can select which
CONTRL Message Type to use.

The UNG Options (No UNG vs. Mandatory UNG) is disabled if an Outbound
Trade Link already exists for this CONTRL creation, or if the Inbound Trade Link
does not contain an UNG-level definition. If an Outbound Trade Link already
exists, the UNG Option of that link will be used for the CONTRL document. Note
Optional UNG CONTRL Trade Links are not supported.

Note: The Automatic CONTRL form will not be displayed if an Outbound Trade
Link already exists, and contains a CONTRL Message Type.
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Creating a control number map

72

Trading Manager supports user-defined numbering schemes in maps for
interchange, functional group, and transaction set control numbers. This section
describes the requirements for your maps that provide a number and are executed
from the Message Manager using the RUN function.

Exchanging information with Message Manager

You implement user-defined control numbering schemes through control number
maps. When building envelopes for those application partners that provide
partially wrapped X12 data, the compiled map providing the control number level
and specified in the Partner Manager is executed by the RUN function.

The Message Manager passes input card 1 to the control number map the last used
control number for this particular trading partner, application partner, or
transaction set. The control number map returns the control number value to be
used as output card 1 to the Message Manager; this value is placed in the
appropriate EDI envelope.

This control number returned by the control number map is used to update the
last used control number within the Message Manager for the appropriate trading
partner, application partner, and transaction set.

Map requirements and features

The control number map must have at least one input card and one output card.
You must define input card 1 and output card 1 to accommodate a control number
character size of 1-9 characters. For example, define a text or number item with a
minimum length of 1 and a maximum length of 9.

Alternately, you could define a control number Group in a type tree with Items
that recognize component parts of the one- to nine-character control number.
Include an Item where the control number is defined as YYMMDD.

Note: Although the string that is transferred to and from the control number map
can be defined as text, the interchange and functional group control
numbers must be numeric.

Example: increments other than 1

The map may include other input cards and output cards as needed. For example,
you may have established an increment other than one for the ISA control number
that you exchange with your partner:

* Input card 1 represents the most recently used control number (LastUsedControl
Number)

* Input card 2 represents data from a Customer Master Database
(CustomerMasterDB)

* Output card 1 contains a rule with the SEARCHUP function to find the increment
for the ABC Rock customer; the increment is added to the most recently used
control number and the result is returned to the Message Manager. The map rule
is:
=LastUsedControlNumber + SEARCHUP ( Increment Column:.:CustomerMasterDB , CustID Column
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Example of Transaction Set Control Number by Date

For example, a map may concatenate a sequence number with other information
such as the current date:

e Input card 1 represents the most recently used control number (LastUsedControl
Number)

¢ Output card 1 contains a rule with the CURRENTDATE function. In this example,
the first six characters of the control number are the current date in YYMMDD
format. The last three characters represent the sequence number of the current
data set. If the date from the most recently used control number is the same date
as the current date, the sequence number is incremented by one. If the date is
not the same as the current date, the sequence number is reset to The map rule
is:

=IF Shift 9 =( RENTDATE() = YYMMDD:LastUsedControlNumber ,
SegNum:LastUsedControlNumber +1 , 1)
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Chapter 6. Reports

Use the Reports window to viewClose Message Manager transmission and audit
report information. The Reports window enables you to view and generate
detailed information about transmissions and transactions.

To access the Reports window

Click on Reports the toolbar. Or, select Reports from the File menu.

The Reports window displays.

The following four types of reports are available from the Report Type drop-down
box:

+ |'Traffic Reports’|

¢ |"Alerts Report”

+ |"Additional Reports Overview”|

* ["Partner Manager Log Report’|

You can run Partner Manager reports on the current or archive database. After
reports are run, they can be printed or exported.

Reports are presented in views, which provide different levels of detail and enable
resend interchange capability. Each report has a default view.

Note: If you do not have any traffic for a data type, that data type will not be
displayed in the data type’s drop-down box. For example, if you do not
have X12 traffic, X12 will not be listed in the data type’s drop-down box.

Traffic reports

Traffic reports contain information on transmissions that have been processed by
the Message Manager system in the specified date range.

e Traffic reports can be refreshed at any time.

* The default date selection for traffic reports is configured in the Display Options
utility.

* Traffic reports can be run on inbound and outbound directions on a selected
report level.

¢ Traffic reports can be exported to file formats for viewing and printing.

* Traffic reports allow you to edit and resend interchanges.

¢ Traffic Reports allow you to optionally view X12 997 content, and to jump
between X12 997 transmissions and the corresponding Functional Group.

¢ Traffic Reports allow you to review your X12 Acknowledgement activity. For
example, displaying Overdue Acknowledgements, All Unacknowledged,
Acknowledged Only, or manually Acknowledged traffic.

Navigate in traffic reports with right-click command access or by clicking the
buttons on the toolbar.

Icon  Description
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Back to Prior Report

Report Drilldown

Display Report Detail

Refresh Report

Edit/Resend Interchange

Resend Interchange Immediately
Export Report

Report Info

Manual Acknowledgement Override
Jump to Corresponding Functional Group
Jump to Corresponding 997 Group
Last Report

Clear Report Parameters

Close All and Restart Reports

Close All Reports

Drill down for details

You can "drill down” to view finer levels of detail from the default report view in
traffic reports. The "drill down"” options include:

View Type Drill Down To

All Display Detail
Transmission Display Data Type

Data Type View Interchanges
Interchange View Functional Groups

Resend the interchange immediately
Edit/Resend the interchange

Functional Group Display Transactions

Transaction Display Segment Errors

Icon colors in the reports provide visual status indicators for each transmission.

For EDIFACT reporting, the drill down may skip functional group views if there
are no functional groups in the data.

View Interchanges in Reports

In a data type report view, you can view interchanges for the selected
transmission.

To view interchanges
1. In a report, select a single transmission.
2. Click the Interchanges button.

The Interchanges View appears.
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From the Interchanges View, you can view Functional Groups, resend that
interchange immediately, and edit/resend the interchange. If X12 TA1 records exist,
a drill-down from Interchange to Functional Groups will also display those X12
TA1 records in a separate window.

View Functional Groups in Reports

In an interchange report view, you can view functional groups for the selected
interchange.

To view functional groups of a specific interchange
1. In a report, select a single functional group.
2. Click the Functional Groups button.

The Functional Groups View appears.

Display detail in reports
For each report view, the Display Detail screen provides detailed information on
the selected interchange, transmission, functional group, transaction, alert, or log.

Display Transactions in Reports
In a functional group view report, you can view transaction details.

To view transaction details
1. Select a single transmission.
2. Click the Display Transactions button.
The Transactions View of that transaction is displayed.

Display Segment Errors in Reports

For each transmission in a transactions view report, you can display segment
errors if they exist.

To view segment errors of a transmission
1. Select a single transmission in a transaction view of a report.

2. If segment errors exist for the selected transmission, click the Display Segment
Errors button.

Note: The Display Segment Errors button is available only if the selected
transmission contains segment errors. If no segment errors exist, the
button is not available.

Display Data Types

In a report Transmission View, you can view data type details in the Interchanges
View.

To view data type details
1. Select a single transmission.
2. Click the Display Data Type View button.

Double-click a transmission in the Data Type View to display functional group
details, and then transaction details.
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Report specific search
The Report Specific Search field is specific to each report level.

Report levels in traffic reports include:

e Transmission * Message/Transaction
* Interchange * Traffic Alert
* Functional Group e Partner Manager Log

Specify a date range

For traffic reports, the Date Range can be adjusted as required. Click the option
button to choose your date range.

Option Description
All dates All dates are reported.
Date Range When enabled, the From Date and To Date fields

can be populated.

Click Calendar to choose your From Date and Tg Date.
For Traffic Alerts, the From Time and To Time cpn be entered in

Today Data with today’s date reported.

Report status icon colors and codes

The colors of the icons in the Partner Manager traffic reports provide visual
indicators of status. The status description, Red, Yellow, Green or Blue can also be
included in the exported the traffic reports by enabling the Include Traffic Status
Color check box).

Color Description

Red Indicates an error in transmission at that level

Red (TA1 reports only) Rejected

Yellow Error at a level below displayed transmission
level

Green Transmission completed without errors

Green/ Yellow X12 Functional Acknowledgement is in error

Green (TA1 reports only) Accepted

Yellow (TA1 reports only) Partially accepted

Blue In process

The following table describes each code and its icon color.

Code Description Icon Color
2 Syntax version or level not supported Red
7 Interchange recipient not actual recipient Red
12 Invalid value Red
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Code Description Icon Color
13 Missing Red
14 Value not supported in this position Red
15 Not supported in this position Red
16 Too many constituents Red
17 No agreement Red
18 Unspecified error Red
20 Character invalid as service indicator Red
21 Service character(s) Red
22 Invalid service character(s) Red
23 Unknown Interchange sender Red
24 Too old Red
25 Test indicator not supported Red
26 Duplicate detected Red
28 References do not match Red
29 Control count does not match number of instances Red
received
30 Groups and messages/packages mixed Red
32 Lower level empty Red
33 Invalid occurrence outside message, package, or group Red
35 Too many data element or segment repetitions Red
36 Too many segment group repetitions Red
37 Invalid type of character(s) Red
39 Data element too long Red
40 Data element too short Red
45 Trailing separator Red
46 Character set not supported Red
47 Envelope functionality not supported Red
48 Dependency condition violated Red
D01 Mandatory element missing Red
D02 Data element has incorrect size Red
D03 Invalid code for identifier Red
D04 Invalid date format Red
D05 Invalid time format Red
E00 Unknown data element Red
E01 Code list error Red
E02 Data element has incorrect format Red
E03 Data element has incorrect size Red
E04 Missing segment Red
E05 Missing segment terminator Red
E06 Mandatory element missing Red
E07 Error in data Red
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Code Description Icon Color

E08 Unknown element found Red
E09 Failed business rule Red
E10 Missing element Red
E11 ISA/IEA format or content error Red
E12 GS/GE format or content error Red
E13 Invalid because of errors elsewhere Red
El4 Missing tradelink Red
E15 Unknown transaction/Version release Red
El6 Failed to route to PUT post office Red
E17 Valid but not delivered because of errors elsewhere Red
E18 Functional group does not contain any transaction Red
E19 Contains transaction(s) that do not belong in this Red
functional group

E20 Duplicate transaction Red
E21 Duplicate functional group Red
E22 UNB/UNZ format content error Red
E23 UNH/UNT format content error Red
FO1 FA in error Green/ Yellow
F02 Rejected via TA1 Green/ Yellow
S01 Segment out of sequence or unknown Red
S02 Missing mandatory segment/loop Red
S03 Loop exceeded limit Red
S04 Segment exceeded limit Red
S05 Segment has element error Red
Voo Data valid Green
Vo1 Error data fount Yellow
V02 Contains functional group with unknown tradelink Yellow
V03 Duplicate interchange Red
V04 Failed to deliver some or all functional groups (inbound) | Yellow
V05 In process Blue
V06 Failed to deliver some or all interchanges (outbound) Yellow
Vo7 Accepted with errors via TA1 Red
Vo8 Failed Interchange Authorization Check Red
Vo9 Failed Interchange Security Check Red

Partner Manager log report

Access to the Partner Manager Log report is granted or denied in the Security
Groups utility. The Partner Manager Log report identifies error messages and
reports Resend requests/processing. In addition, if Partner Manager security is
enabled and then later disabled, a warning will appear in the log. This report is
run for a specified date range. You can export the report. For information on how
to purge the log, see the "Purge” section in Chapter 8.
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Alerts

Click an options button in the Reports Options to dynamically populate the report
for All Messages, Errors Only, Warnings Only, and Information Only.

Information in the Partner Manager Log report includes:

Field Description

Source Source of the log message.

User The current User ID if Security Groups are being
used. If Partner Manager security is not used, User
defaults to the database user name that user or the
current user.

Date Time The date and time of the log event in the
YYYYMMDD HH:MM:SS format.

Message Log message that describes the log event.

Note: The Partner Manager Log report replaces the Resend Requests report.
Source of Parther Manager log message

The source of the log message includes incident type and status level.

Possible log message sources include:

Log Message Type | Description Status Type |Icon

Program Error Run-time errors generated by the Error Red
Partner Manager application.

SQL Errors Errors generated by the database Error Red
system you are using.

User Maintenance  |In the event security is disabled (by | Warning Yellow
deleting the last user).

Login In the event the user with the Warning Yellow
password overwrote the
database-version check.

Resend When a resend request is made. Also |Information |Green
when the resend item is processed
by Message Manager.

Program and SQL errors are useful for communicating with IBM Software

Customer Support if problems arise.

report

The Alert report shows a history of e-mail traffic alert notifications of rejected data
for the specified date range and database (current or archive). The dates specified
are for the Message Manager map execution dates (when traffic occurs in Partner
Manager).

You can specify reporting on traffic alerts that match the following selection
requirements:

* Specified Date Range
* Specified Database (Current or Archive)
All traffic in the Message Manager system is reported, regardless of data type.

Chapter 6. Reports 81



Information in the Traffic Alert report includes:

Field Description

PO Nickname Post office nickname as defined in Partner Manager.

Transmission ID Unique Transmission ID assigned by Message
Manager to the interchange.

Data Type EDIFACT, X12, or TRADACOMS.

Contact The e-mail address specified in the Address Book for
the trading partner.

Start Time Time when the traffic alert was sent.

Resend requests

The Resend Requests report has been replaced with the Partner Manager Log
Report, which logs resend requests.

Transmission report

The Transmission report is a standard-independent report that displays a
summary of inbound or outbound transmissions.

Note: All transmissions are reported (EDIFACT, TRADACOMS, X12, and any other
standards).

You can specify reporting on transmissions that match the specified selection
requirements.

Information is displayed for the specified transmission direction (inbound or
outbound). The information displayed includes:

Field Description

Transmission ID A component of the ThreadID assigned by Message
Manager system to the transmission.

Date Date when the Message Manager transmission
processing began.

Time Time when the Message Manager transmission
processing began.

Size Size (in bytes) of the transmission data.

Return Code Report status code.

O/R Original or Resend indicator. An O indicates an original

transmission. An R indicates a resent transmission.

Input Thread Source of the transmission data. If the data source is a
file, this column shows the file name. Otherwise, it
shows the resource adapter (FTP, E-mail, VAN)
command string.

Original Transmission If this is a resent transmission, the Original Transmission
ID is displayed. Blank if this is not a resent
transmission.

PO Nickname Post Office associated with the transmission.
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Note: Double-click a transmission, or select a single transmission and click the
Data Type View button, to the display the Data Type View.

Interchange report

The Interchange report displays trading partner interchange information for the
specified interchange date range.

The Inbound or Outbound Interchanges View displays information for
interchanges and allows you to:

* Resend that interchange immediately
* Edit/Resend the interchange

You can specify reporting on interchanges that match the following selection
requirements:

* Data Type (select EDIFACT, TRADACOMS, or X12, or other standard from the

drop-down list)
* Specific Post Office Nickname
* Specified Date Range
* Direction (Inbound or Outbound)
* Database (Current or Archive)

* Record Status of All Records, No Errors, records with Errors Only, or a Specific

Status Code
* A specific Trading Partner
* A Report Specific Search (enter a Control Number)

The information displayed includes:

Field Description

Transmission 1D Unique Transmission ID assigned by Message
Manager to the interchange.

Sender Ichg ID/ Qual ISA Sender ID qualifier and address of the
trading partner that sent the interchange.

Sender Name Trading partner name as defined in the Address
Book.
Receiver Ichg ID/Qual ISA Receiver ID qualifier and address of the

trading partner that received the interchange.

IC Ctrl No. ISA Control number of the interchange.

IC Date YYYYMMDD format of the date the interchange
was created by the sender. (UNB/ISA Envelope)

IC Time HHMM format of the time the interchange was
created by the sender. (UNB/ISA Envelope)
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Drill down tips

* Double-click a transmission in the interchange view-to-view functional group
information.

* Double-click a transmission in the functional group view to display transaction
information.

* Double-click a transmission in the transaction view to display segment errors (if
any).

Specific trading partner for the interchange report
In the Interchange report, you can specify a specific trading partner.

To specify a specific trading partner
1. In the Trading Partner area, enable the Sending or Receiving option button.
2. Click the Find button.
The specified data type Trading Partners dialog box appears.
3. Select a trading partner.
4. Click Select.
The selected trading partner appears in the Name field.

Specific status codes for the interchange report

In the Interchange report, you can specify a specific status code.
1. To specify a specific status code
2. For the Specific Status Code field, enter the status code.

Or click the Status Codes button and select a status code from the Find All
Status Codes dialog box. Click Select.

3. Click the Run Report button to run the Interchange report for the specific
status code.

Edit and/or resend an interchange

In the Interchange report, you can select a single interchange and edit and resend
that interchange immediately.

Note: The Display Options » Editor/Viewer setting controls which text editor is
used to edit the interchange.

To edit and resend an interchange

1. Select a single interchange in the Interchange report.

2. Click the Edit/Resend Interchange button in the toolbar.
The Partner Manager Editor window appears.

3. Edit the interchange as desired.

4. 1If using a text editor other than the Partner Manager Editor:
 Save the file and close that editor.

* Click Revert on the Partner Manager Editor toolbar to view the interchange
in the Partner Manager Editor window.

5. Click Resend on the Partner Manager Editor toolbar.
A confirmation dialog box appears.
6. Click OK to resend the data as displayed.
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A resend status confirmation dialog box appears. The location of the resend
data and the interchange file name is displayed.

The resend, user, date and time stamp, and message appear in the Partner
Manager Log report.

Note: The Security Group Maintenance » Transmission Data setting controls edit
and resend capability.

Resend an interchange limmediately

In the Interchange report, you can select a single interchange and resend that
interchange immediately.

To resend an interchange immediately

1. Select a single interchange.

2. Click Resend Interchange Immediately button on the toolbar.
A resend confirmation dialog box appears.

3. Click OK to send the interchange.
A sent confirmation dialog box appears.

4. Click OK.

The resend, user, date and time stamp, and message appear in the Partner
Manager Log report.

Note: The Security Group Maintenance » Transmission Data setting controls edit
and resend capability.

Functional group report

The Functional Group report displays a summary of functional groups received
(Direction = Inbound) or sent (Direction = Outbound) for sending or receiving
trading partners.

For a complete description of all fields in the report display, see the section
['Functional Group View”|.

Jumping to X12 997

The X12 Functional Group Report allows you to jump directly to the
corresponding 997 from a functional group.

To jump to a X12 997
1. Select a functional group.
2. Click the Jump to Corresponding 997 group icon in the toolbar.
The display "jumps” to the corresponding 997 from the functional group.
3. Use the report’s Back button to return to the original report.

Note: Two conditions must exist for this function to be available. The selected
functional group must have had its Functional Acknowledgment
Received (that is, the FG Reconciliation has processed this record), and if
user security is in force, the user’s Security Group setting for "X12 997
Data: View Data” must be checked.
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X12 acknowledgement reporting options

When an Outbound X12 Functional Group report is selected in the Reports dialog
box, five options become available in the Report Specific Search area on the
Acknowledgement Reporting drop-down menu:

Option Description

All Records The default; displays all data regardless of
Acknowledgement Status.

Overdue Acknowledgements Only functional groups that have not been
acknowledged within the time frame specified on
the trade link will be included. See "Specifying
Acknowledgement Timeframe”. This time
calculation is based on the number of hours
specified on the trade link, the map execution date
and time, and current date and time of the PC
running Partner Manager.

All Unacknowledged Only Unacknowledged Functions Groups will be
included.
Acknowledged Only Opposite of "All Unacknowledged”; only those

functional groups that have been acknowledged
will be included.

Manual Acknowledged Only Only those functional groups that have been
manually acknowledged will be included. See
Manual Override of Acknowledgement Settings
for additional information.

Note: Functional groups that have a Functional Acknowledgement in Error will
display a green and yellow arrow pointing right in this report. This arrow
and unique color is used to distinguish between a good functional group
(green circle), a Functional Group containing an error at a lower level
(yellow diamond), and a Bad Functional Group (red stop sign).

Manual override of acknowledgement settings

The X12 Outbound Functional Group report allows you to manually set the
acknowledgement flag. Normally, the maps set this acknowledgement flag
automatically during functional group reconciliation when the 997 is received.
However, there may be times where you want to set this flag yourself, perhaps
after manual intervention with your trading partner.

To manually set the Acknowledgement flag

1. Select the functional group record you wish to change in this report.

2. Click the Manual Acknowledgement Override icon in the toolbar.
The Manual Acknowledgement Override dialog box appears.

The Manual Acknowledgement Override dialog box displays a summary of the
Functional Group you selected and two areas:

¢ FA Received. Select Yes or No

* FA Status Code. Select one of the four options presented from the FA Status
Code drop-down menu Accepted, Partial, Rejected, or Error.

3. Click the Save button to save your changes, or click Cancel to bypass.
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Changes are recorded in the Partner Manager Log report for auditing
purposes. Additionally, the last manual override change is displayed in the
Acknowledgements section of the X12 Functional Group Detail report.

Note: Partner Manager Security can be used to restrict access to the manual
override function. The Allow Override check box in the Manual FA
Override parameter in Security Groups controls this function. See

"Utilities”] for more information.

Functional group view

The Functional Group View displays information about functional groups that
meet the specified report selection requirements. The information displayed

includes:

Field

Description

Transmission ID

A component of the ThreadID assigned by
Message Manager system to the transmission.

Funct’l ID Code

Functional ID code for the functional group
from the GS.

GS Sender 1D

GS address of the trading partner that sent the
functional group.

Sender TP Name

Name of sending trading partner.

Sender AP Name

Name of sending application partner.

GS Receiver ID

GS address of the trading partner that received
the functional group.

Receiver TP Name

Name of receiving trading partner.

Receiver AP Name

Name of receiving application partner.

FG Control No.

GS Control number of the functional group.

FG Version Functional group version number.

FG Date YYYYMMDD format of the date the functional
group was created by the sender. (GS/UNG
Envelope)

FG Time HHMMSS format of the time the functional

group was created by the sender. (GS/UNG
Envelope)

Ack Status Cd

Functional acknowledgement status code.

Ack Recvd Flag

Flag that indicates receipt (Y or N) of a
functional acknowledgement for the functional
group sent.

1. To report on functional acknowledgements

2. Specify a Functional Group Code of FA in the Report Specific Search field.

Message/transaction report

The Message/Transaction report displays information on transactions. You can
specify reporting on messages or transactions that match the following selection

requirements:

* Data Type (select EDIFACT, TRADACOMS, or X12, or other standard from the

drop-down list)
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* Specific Post Office Nickname

* Specified Date Range
 Direction (Inbound or Outbound)
* Database (Current or Archive)

* Record Status of All Records, No Errors, records with Errors Only, or a Specific
Status Code

* A Report Specific Search (enter a Message/Transaction Number)

The information displayed includes:

Field

Description

Transmission ID

A component of the ThreadID assigned by
Message Manager system to the transmission.

TS ID Transaction set code of the transaction.
TS Control No ST control number of the transaction.
Status Status code of the transaction set: V indicates

Valid, E indicates Error.

Sender TP Name

Name of sending trading partner.

Sender AP Name

Name of sending application partner.

Receiver TP Name

Name of receiving trading partner.

Receiver AP Name

Name of receiving application partner.

The information displayed for TRADACOMS includes:

Field

Description

Transmission ID

A component of the ThreadID assigned by the
Message Manager system to the transmission.

Message Type

The name of the message in this document, for
example INVHD.

Doc Body Index

The index of the body in this document.

STX Sender Info

The identifier specified in this message for the
STX Sender.

STX Sender Name

The STX Sender’s name, as found in Trading
Manager database via the STX Sender Info
field, above.

STX Receiver Info

The identifier specified in this message for the
STX Receiver.

STX Receiver Name

The STX Receiver name, as found in Trading
Manager database via the STX Receiver Info
field, above.

SDT Info The identifier specified in this message for the
SDT Partner.

SDT Name The SDT name, as found in Trading Manager
database by way of the SDT Info field, above.

CDT Info The identifier specified in this message for the
CDT Partner.

CDT Name The CDT name, as found in Trading Manager

database by way of the CDT Info field, above.
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Field Description

Body Ref The index of the body in this interchange.

Doc Type The Document Type of this message, for
example INVOIC.

Map Date The date the map created this traffic record.

Viewing 997 content

The X12 Transaction Report allows you to view the content of the selected 997
transaction. This is useful to see how your partner responded to your transmission.

To view 997 content
1. Select a 997 transaction.
2. Click on the Display Report Detail icon on the toolbar.

If 997 content exists, it will be displayed in the right hand side of the X12
Transaction Detail window.

Note: The following conditions must be true in order to view 997 content. If user
security is in force, the user’s Security Group setting for X12 997 Data: View
Data must be checked. Additionally, to have 997 content written to a
database so it can be viewed here, the Store 997 Content in Database check
box, found in Utilities ~ Message Manager Configuration, must be enabled.

Jumping to a functional group

The X12 Transaction report allows you to jump directly to the corresponding
Functional Group from a 997 transaction.

To jump to a functional group from a 997 transaction

1. Select a 997 transaction.

2. Click on the Jump to Corresponding Functional Group icon on the toolbar.
The display "jumps” to the functional group from the 997 transaction.

3. Use the report’s Back button to return to the original report.

Note: Any traffic data converted from releases prior to Trading Manager V7.0
will not have this option available.

X12 TA1 status reports

The X12 TA1 Status reports TA1 status information for the specified date range.

The information displayed includes:

Field Description

Transmission 1D A component of the ThreadID assigned by the
Message Manager system to the transmission.

Sender Ichg ID/Qual ISA sender ID qualifier and address of the
trading partner that sent the interchange.

Receiver Ichg ID/Qual ISA sender ID qualifier and address of the
trading partner that received the interchange.
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Field Description

Orig IC Ctrl No Original ISA control number

Original IC Time Original HHMM format of the time the
interchange was created by the sender

IC Ack Code ISA control number acknowledgement code.

IC Note Code ISA control number note code

Additional reports overview

The Additional Reports view enables you to generate detailed reports that you can
print or export.

Additional reports include:

* Application Partner Detail Report

* EDIFACT Inbound Trade Link Application Report

* EDIFACT Outbound Trade Link Application Report
* Post Office Report

* TRADACOMS Inbound Trade Link

* TRADACOMS Outbound Trade Link

* Trading Partner Detail Report

* X12 Inbound Trade Link Application Report

* X12 Outbound Trade Link Application Report

Running additional reports

Additional reports are selected from the File menu.

To run additional reports
1. Click on the Reports button on the toolbar.
The Reports window displays.
2. Select Additional Reports from the Report Type drop-down box.

w

Select a report from the Reports drop-down box.
4. Click the Run Report button.
The report-specific form appears.
5. Make your selections.
6. Click the Run Report button.

Printing Partner Manager reports

Traffic reports must be exported to xml, html, or text formats prior to being
printed. You can then print the exported file from a browser, the Partner Manager
Editor, or any text editor.

Exporting reports

Traffic reports use the Traffic Report Export feature.

Additional reports use the export feature.
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Exporting traffic reports

The Traffic Report Export feature enables you to export traffic reports to html,
xml, and plain text formats.

You can specify the action to take place after the export is completed:

Action Description
Launch Browser The default browser is launched.
Launch Editor The Partner Manager editor or the

user-specified editor (defined in the Display
Options utility) is launched.

Exit without Launching File No editor or browser is launched.

You can specify the number of rows to export and whether to include the traffic
status color in the exported file.

If reports are exported to an existing file, the existing file is overwritten.

Note: The file that was overwritten is moved to the recycle bin.

To export a traffic report

1.

oo kw0

N

Click the Export button.

The Traffic Report Export dialog box appears.

In the Report Column, select the columns to export.
Select the Export Method.

Select the After Export Completes action.

Select the Number of Rows to Export.

Enter the full path and filename of the export file or click Browse to navigate
your file system to Select/Enter Export File Destination.

The File name defaults to the reportview.reporttype name.
Specify the File name.
Click Save.

If the export file already exists, an overwrite confirmation dialog box appears.
Files that are overwritten are moved to the recycle bin.

Click Begin Export.
The report is exported.

Default traffic report export settings

All report columns are selected for export by default.

Where applicable, the Include Traffic Status Color check box is enabled by
default.

The default export method is HTML Page.
The default behavior to occur after export is Launch Browser.
The default number of Rows to Export is AlL
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Value Added Tax (VAT) reports

The TRADACOMS subsystem (inbound and outbound) will create VAT reports for
any invoice type messages. For example: INVOIC, CREDIT, and UTLBIL. The VAT
report will automatically be created in the default install_dir\tmgr_vn.n\mmgr\
VAT _Reports\ directory.

If you wish to change the default directory, you can change the location in the Edit
Resource dialog box in the Resource Registry.

To change the default directory
1. Open the Resource Registry.

2. Select Open from the File menu and navigate to the install_dir\tmgr_vn.n\
mmgr\mmgr.mrm

3. Expand the mmgr file.
4. Expand the Resources file.
5. Double-click the mmgr_trc_VatReport file.
The Edit Resource dialog box appears.
6. Edit the Resource Value to the desired location.
7. Click OK.

Partner Manager editor

This editor extracts data from the archives and presents the data to enable access
to the original EDI data as presented to Trading Manager.

The Partner Manager Editor is used to:
 Edit and resend interchanges
* View reports exported in html or xml format.

* The Editor can be used to print the exported reports. Other features of the
Editor enable you to:

* Save the exported file

* Save the exported file in a different format

* Revert to the saved file (brings in the user-specified editor changes)
* Launch a user specified editor

* Find/Replace/Highlight text in the exported file

* Format the exported file

Note: If you use the Find/Replace/Highlight feature and then resize the Editor
window, the color changes are not saved.

Note: Use care when using the Editor as the user-specified editor may have
multiple files open.
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Chapter 7. Resending E-commerce data

Inbound and outbound data that has been processed by Trading Manager can be
viewed and edited. Run the Interchange traffic report to resend the interchange
immediately or edit/resend the interchange data. The resend interchange data
feature extracts data from the Message Manager archive folder.

¢ The resend immediately feature allows you to resend a message immediately,
without viewing or editing the original e-commerce data, inbound or outbound.

* The edit/resend interchange feature allows you to edit the interchange, and then
resend it.

You must run the Interchange traffic report to access these features.

Note: The Security Group Maintenance » Transmission Data setting controls
view, edit, and resend capability.

The ability to resend inbound or outbound data allows you to resubmit
e-commerce data that had previously been transformed correctly, but may have
encountered transmission errors during processing by the receiving application.

You can view and edit the original e-commerce data prior to resending to your
trading partner or internal application. This allows you to update a code that did
not pass EDI validation, or create a file containing only a single transaction set that
for resubmission.

The Message Manager picks up and reprocesses the file that was resent. A new
ThreadlD reflects this resend activity.

The Server Directory Configuration Maintenance utility configures the location of
the archived transmission data and the location where resent data is placed.

Note: For more information on the Update and Resend components of the
Message Manager, see the Trading Manager documentation.

Resend ThreadID

The Message Manager System Resend map creates a new ThreadID for the data,
changing the origin indicator from original (o) to resend (r). For example:

* Original ThreadID - edi000011998091500010i.app
* Resent ThreadID - edi00002199809150001ri.app

Partner Manager maintains a complete audit trail of the resent data based on its
new ThreadID.
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Chapter 8. Utilities

This chapter describes Partner Manager options that are set using the Ultilities
navigator.

The navigator can be opened by clicking the Utilities icon on the Partner Manager
toolbar, or by selecting Utilities from the File menu.

Options that can be set using the Utilities navigator include the following:
* Configuration

 Database Utilities

 Folders

* Security

Configuration

The Configuration utilities contains the following:
* Database Settings

* Display Options

* Message Manager Configuration

 Post Office Search and Replace

* Post Office Types

* Server Directory Configuration

* Standards

Database settings
In the Database Settings utility, you can:

+ Change the database you are currently using; see | Importing a Database Profile’|

+ Create a new database profile; see|'Creating a New Database Profile’|

+ Import a database profile; see |'Importing a Database Profile’|

* Export a database profile; see['Exporting a Database Profile’|

+ Edit an existing profile; see|'Editing an Existing Database Profile’|

* Delete an existing profile; see ['Deleting an Existing Database Profile’|

Database selection

Partner Manager lets you change the current database through the Database
Selection dialog box.

To change the current database
1. From the File menu, select Database Settings.
The Partner Manager Database Selection window opens:
2. Select the database vendor from the drop-down menu.
3. Select the Data Source Name (DSN) from the drop-down menu.

Note: You create DSNs from the ODBC applet in the Windows Control
Panel.
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4. Enter a user ID and password, if required.
5. Enter the database file name.

Note: For Access and Oracle databases, you can leave the Database field
blank. For all other database types, enter the name of the database, as it
exists on the server.

6. (Optional) Enter a description of the database (as it will appear in the title
bar).

7. Click Test Connection.

The Connection Test OK message box opens to inform you that the test has
been satisfactorily completed.

8. Click OK.
The Text Connection message box closes.
9. Click OK in the Partner Manager Database Selection window.

A message box opens that informs you that Partner Manager parameters are
being updated.

10. Click OK.
Partner Manager closes.
11. Restart Partner Manager to use the new database.

Creating a new database profile

To create a new database profile
1. From the File menu, select Database Settings.
The Partner Manager Database Selection dialog box appears.
2. C(lick Profile Maintenance.
The Back-End Profile Maintenance dialog box opens.
3. Enter a name for the new profile and press Tab or Enter.
A dialog box appears asking you to confirm the creation of the new profile.
Click Yes to create the new database profile.
(Optional) Enter a description for the profile.
Select the Data Source Name (DSN) from the drop-down menu.

Enter a user name and password, if required.

© N o ok

Enter the database file name.

For Access and Oracle databases, leave the Database field blank. For all other
database types, enter the name of the database, as it exists on the server.

9. Select a database vendor from the drop-down list.
10. Click Test Connection to confirm the database connection.
11. Click Save and OK to confirm the new profile.
12. Click Cancel to close the dialog box.

You can now select the profile from the Profile drop-down list.
Importing a database profile

To import a database profile

1. Open the Back-End Profile Maintenance window as described in
[New Database Profile’| .

2. Click the Import button.
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3.

4.

5.

The Profile Import window opens.
Select an Import Source:

* If you are importing from a file, click the Browse button and navigate to the
file that you want to import. The path will be displayed in the File to import
field.

 If you are pasting XML from an existing file, select the Paste from Clipboard
button to activate the Paste Export File Here text entry box. Click in the
Paste Export File Here field and use the windows copy feature to copy the
XML from the clipboard.

Select an Import Option:

* If you want over-write the existing profile, select the Over-write Existing
button.

* If you do not want to over-write the existing profile (skip it), select the Skip
Existing button.

Click the Import button.

Exporting a database profile

To export a database profile

1.

Open the Back-End Profile Maintenance window as described in
[New Database Profile’|.

Click the Export button.

The Profile Export window opens.

Select a Profile ID by placing a check beside the desired profile in the list, or if
you want to select all of the profiles, click the Select All button.

Choose the export method:

* If you want to export the profile to a file, click the Export to File checkbox,
then use the Browse button to navigate to the file you want.

 If you want to export to clipboard, check the Export to Clipboard checkbox.
Click the Export button.

* If you selected Export to File, the profile is copied to the file that you
selected.

* If you selected Export to Clipboard, the profile is copied to the clipboard.

Editing an existing database profile

To edit an existing database profile.

1.

From the File menu, select Database Settings.

The Partner Manager Database Selection dialog box appears.
Click Profile Maintenance.

The Back-End Profile Maintenance dialog box appears.
Select an existing profile from the Profile drop-down list.
Edit the settings.

Note: For Access and Oracle databases, leave the Database field blank. For all
other database types, enter the name of the database, as it exists on the
server.

Click Test Connection to confirm the database connection.
Click Save.

A dialog box opens that confirms successful database connection.
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7. Click OK.
8. Close Partner Manager.

9. Restart Partner Manager.
Deleting an existing database profile

To delete an existing database profile
1. From the File menu, select Database Settings.
2. The Partner Manager Database Selection dialog box appears.
3. Click Profile Maintenance.
The Back-End Profile Maintenance dialog box appears.
4. Select a profile from the Profile drop-down list.
5. Click Delete.
A confirmation box opens that asks you to confirm the delete.
Click Yes to delete the profile.
Click Cancel to close the Back-End Profile Maintenance dialog box.
Click OK to close the Partner Manager.
Restart Partner Manager.
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Selecting a different database profile

To select a different database profile

1. From the File menu, select Database Settings.

The Partner Manager Database Selection dialog box appears.
Select an existing profile from the Profile drop-down list.
Click OK to close the Partner Manager.

Restart Partner Manager.
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Display options

The Display Options utility allows you to modify the display according to your
personal preferences. Display options are set using the Display Options dialog.

Opening the Display Options dialog
1. From the Tools menu, select Display Options.
The Display Options dialog box opens.
2. Refer to the following sections to specify display options.

Specifying processing options
The following procedures describe how to set processing options for your display.

To specify processing options

1. Open the Display Options dialog as described in the Display Options section.
Make certain that the Processing Options tab is selected.

2. Select the most recently used trade links to display when you open Partner
Manager by enabling or disabling the Display Last Inbound Trade Link check
box, and/or the Display Last Outbound Trade Link check box.

3. Specify the default date selection for all traffic reports. Select Today, or All
Dates.
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4.

5.

Select Standards (X12, EDIFACT or TRADACOM).

Note: The Standards check boxes allow you to restrict display of EDI
Standard-Specific options. For example, if your company does not use
EDIFACT or TRADACOMS, you can disable these options and the
screens specific to these two standards will not appear. You can always
restore access to these standards by enabling the check box. This setting
only applies to the PC running Partner Manager; it does not affect other
users

When you are satisfied with your selections, click Save.

Specifying transmission data options

The following procedures describe how to specify the editor and temporary
directory to be used for viewing and editing transmission data in the traffic reports
and during the traffic export.

To specify the default editor/viewer

1.
2.
3.

6.

Open the Display Options dialog as described in the Display Options section.
Select the Transmission Options tab.

For the Editor/Viewer, enable an option button:

Default to Built-in Editor or

Default to User-Specified Editor

If you choose to default to a user-specified editor, enter the full path of that
editor application executable program file in the User Specified Editor field.

(For example, C:\WINNT\notepad.exe).

Note: The user-specified editor must accept a file name as a parameter. The
user-specified editor can be launched by default or launched from the
Partner Manager Editor.

Specify the Temporary Directory.

Note: While an interchange is being edited, it is placed in this temporary
directory until the editing/resend operation is complete.

When you are satisfied with your selections, click Save.

Change the look and feel of the display

The following procedures describe how to make changes to the look and feel of the
display based upon your personal viewing preferences.

To make changes to the Display

1.
2.
3.

Open the Display Options dialog as described in the Display Options section.
Select the Look and Feel tab.

If you want to hide the IBM banner that appears at the top of the Partner
Manager application, disable the Display IBM Banner check box.

Select Startup Options:

If you want Partner Manager Windows to display in standard Windows default
mode, enable the Windows Default check box.

If you would prefer the active window always be displayed on top of all
others, enable the Display at Top check box.
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Note: You may find that the Display at Top mode of operation is useful if you
are using a lower resolution screen display (for example 800 x 600).

5. When you are satisfied with your selections, click Save.

Message Manager configuration maintenance

The Message Manager Configuration Maintenance window is used to specify the
run-time parameters used by the system of maps in the Message Manager portion
of Trading Manager.

These settings apply to all users of the current database (the current database is
displayed in Help > About). If you have multiple Trading Manager databases (for
example, Test or Production), you may want to set these parameters to all of them.

To specify Message Manager parameters
1. From the Tools menu, select Message Manager Configuration.
The Message Manager Configuration Maintenance window opens.
2. Make changes to the fields in this window by selecting one of six tab views.

For a detailed description of fields contained in the tab views, refer to the tab
view discussed in the following sections:

+ |'Optimization Tab’|

+ |"Mapping Options Tab’|

.

* |"X12 Acknowledgements Tab'|

* |"Archive Options Tab'|

s |'Traffic Batch Archiving Tab’|
3. Click Save.

The information that you have entered using this form is saved.

Optimization tab

The Message Manager Configuration Maintenance window with the Optimization
tab selected is shown below. Open the window as described previously in this
section. Refer to the table following the figure for field descriptions.

Optimization Tab Field Descriptions

The Message Manager Configuration Maintenance window, shown above, displays
the following fields when the Optimization tab is selected:

Field Description
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Maximum Validation Size

The value entered represents the maximum size
of a functional group that will be validated in a
single pass. If a functional group is larger than
this size, then each transaction will be validated
individually. Best performance is achieved when
validating the functional group in a single pass,
but it will consume that much more memory
and might exceed the capacity of the server and
cause Trading Manager to fail. Setting this value
allows for smaller functional groups to be
processed as fast as possible while larger
functional groups will not cause undue crashes
or performance degradation.

Work File Options

The options available from this drop-down
menu are used by Message Manger to determine
the work file setting for all RUN maps used in
the system. These options are:

-WM - places all work files in memory, which
increases performance, but uses memory.

-W - places work files as physical files on the
disk, using default work file names, which
results in slower performance but reduces
memory usage.

Note This option should only be used in specific
debugging cases as it forces all RUN maps to be
single threaded. If work files on disk are desired,
use option -WU (see below).

-WD - indicates default work files on disk,
delete when done.

-WU - indicates uniquely named work files on
disk, delete when done.

One File per Put PO

For outbound files, creates one file containing all
the interchanges destined for that specific put
Post Office. This eliminates the need to develop
a custom system to append all the data into a
single file for delivery.

One File per Put PO per Interchange

For outbound files, this option allows this
version of Trading Manager to run as it did in
previous versions and creates one output file for
each interchange.

Mapping Options tab

The Message Manager Configuration Maintenance window with the Mapping
Options tab selected is shown below. Open the window as described previously in
this section. Refer to the table following the figure for field descriptions.
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Mapping Options Tab Field Descriptions

The Message Manager Configuration Maintenance window, shown above, displays
the following fields when the Mapping Options tab is selected.

Field

Description

Maximum Reject File Size

This text entry field allows you to enter a
value that restricts the amount of EDI data
that can be shown in the reject cards. The
Message Manager subsystems produce error
reports for any EDI data content that fails
validation. If the size of the reject data is
greater than the value shown, then data will
not be present in the error report. The data
will still be archived and can be re-sent. A
value of ‘0" means that the Reject data will
always be shown in the Error Report.

Minimum Reject Data Size

This text entry field allows you to set a value
that will cause Message Manager to ignore
meaningless EDI data between interchanges or
attached at the end, such as extra "new line”
characters or messages from a VAN. The value
should be set to less than the smallest size of
an interchange, or data in general, that you
expect to receive.

Optional X12/EDIFACT Validation

When enabled, this check box performs: For
X12: IEA/GE segment count comparisons;
IEA/ISA and GE/GS control number
comparison and ST01/GS01 Validation. For
EDIFACT: UNB/UNZ and UNG/UNE control
number comparison and segment count
comparison.

Database tab

The Message Manage Configuration Maintenance window with the Database tab
selected is shown below. Open the window as described previously in this section.
Refer to the table following the figure for field descriptions.

This tab view also provides the Run Export button. For details see the

[Export” on page 103l

Database Tab Field Descriptions

The Message Manager Configuration Maintenance window, shown above, displays
the following fields when the Database tab is selected..

Field

Description

Use Stored Procedures

When checked, stored procedures will be used
for outbound control number generation and
thread id generation on Oracle, SQL Server,
Sybase, and DB2 (Non-USS). Not applicable for
Access or DB2 running on USS.
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Sort TSV Files During Extract If this check box is enabled, Message Manager
will re-sort the tables as they are being created
in the export process. This is required when
non-alphanumeric or lower/uppercase
characters are used to uniquely identify
Trading or Application Partners, and your
database sort order does not match IBM’s sort
order.

Current DB Vendor This is a read-only field used by Message
Manager to generate SQL statements when
they are database dependent.

Run Export

The Run Export button allows you to trigger the Export process on demand,
without having to cycle the Launcher. By default, this version of Trading Manager
is configured to run Export to synchronize the tsv files with the database at
Launcher startup and every day at midnight. You can use the Run Export button if
you want the tsv files to be synchronized immediately without having to wait for
the scheduled time.

Note: Running unnecessary Exports adds overhead to Message Manager and can
interfere with the processing of EDI data.

You can review the results of a successful export by viewing the Partner Manager
log file.

X12 acknowledgements tab

The Message Manager Configuration Maintenance window with the X12
Acknowledgements tab selected is shown below. Open the window as described
previously in this section. Refer to the table following the figure for field
descriptions.

X12 acknowledgements tab field descriptions

The Message Manager Configuration Maintenance window, shown above, displays
the following fields when the X12 Acknowledgements tab is selected.

Field Description

Store 997 Content in Database When enabled, this check box allows the content
of all 997’s received to be stored in the database so
they can be viewed in traffic reports. Storing 997
data in the database increases the size of the
database and can have an impact on Message
Manager performance.

Ignore Missing Trade Links for If you do not want to custom process inbound
Inbound 997’s 997s, you can skip entering Trade Links for them
and thus prevent Message Manager from
generating Trade Link errors. Message Manager
will still reconcile Inbound 997s against the
outbound transactions recorded in the Partner
Manager database regardless of this setting.
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Field

Description

Create one FG for each 997 Transaction

By default Trading Manager will wrap as many
997 transactions in a single functional group as
possible. When enabled, this option forces each
997 transaction to be wrapped in its own
functional group.

No TAls

Disables Trading Manager TA1 processing.

Create TA1 in TA1 Folder

Enables creating error TAls and places them in the
x12\TA1 folder.

Create TA1 and Route to Partner

Enables creating error TAls and routes them to the
external partner.

Create TA1 in TA1 Folder and Route
to Partner

Enables creating error TAls and places them in the
x12\TA1 folder as in previous releases of CM and
also routes them to the external partner.

Create 000 TAl’s

When enabled, this check box allows Message
Manager to build TAls for interchanges that do
not fail the TA1 envelope check., as Message
Manager, by default, only creates TAls for
interchanges that fail the check. These TA1ls have a
code of 000.

Default TA1 Post Offices

If TA1 routing is selected, these options have to be
entered to properly route TA1. They define the
default GET and PUT PO for any TA1 created.
These default POs can be overridden for each
partner in the Address Book.

Archive Options tab

The Message Manager Configuration Maintenance window with the Archive
Options tab selected is shown below. Open the window as described previously in
this section. Refer to the table following the figure for field descriptions.

Archive Options tab field descriptions

The Message Manager Configuration Maintenance window, shown above, displays
the following fields when the Archive Options tab is selected.

Field

Description

Inbound Transmission as delivered to
Trading Manager (zip/tar)

Archive all inbound transmissions into
Trading Manager in a zip or tar format. The
archived files are located in
install_dir\tmgr_n.n\mmgr\archive\
stampfil folder and are not used by Trading
Manager. Users that already have archiving
processes somewhere else can disable this
feature for better performance.

Outbound Transmission as delivered to
Trading Manager (zip/tar)

Archive all outbound transmissions into
Trading Manager in a zip or tar format. The
archived files are located in
install_dir\tmgr_n.n\mmgr\archive\
stampfil folder and are not used by Trading
Manager. Users that already have archiving
processes somewhere else can disable this
feature for better performance.
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Field

Description

Inbound Interchange (Text)

Archives all inbound interchanges in text
format. These files are used by Partner
Manager’s edit/resend feature. Feature can
be disabled if Edit/Resend is not used.

Outbound Interchange before Trading
Manager re-enveloping (Text)

Archives all outbound interchanges before
re-enveloping in text format. These files are
used by Partner Manager’s edit/resend
feature. Feature can be disables if the
Edit/Resend features are not used or not
required.

Outbound Interchange after Trading
Manager re-enveloping (Text)

Archives all outbound interchanges after
re-enveloping in text format. These files are
used by Partner Manager’s edit/resend
feature. Feature can be disables if the
Edit/Resend features are not used or not
required.

Outbound Transmission after Trading
Manager re-enveloping (zip/tar)

Archive all outbound transmissions out from
Trading Manager in a zip or tar format. The
archived files are located in the
install_dir\tmgr_n.n\mmgr\archive\
sendx12, install_dir\tmgr_n.n\mmgr\
archive\sendedf, or install_dir\tmgr_n.n\
mmgr\archive\sendtrc folder (based on the
data format) and are not used by Trading
Manager. Users that already have archiving
processes somewhere else can disable this
feature for better performance.

Traffic batch archiving tab

The Traffic Batch Archiving option automatically moves traffic to the on-line
archive using Message Manager. Data will be kept for the number of days
specified. The results of this archiving is reported in the Partner Manager log.

The Message Manager Configuration Maintenance window with the Traffic Batch
Archiving tab selected is shown below. Open the window as described previously
in this section. Refer to the table following the figure for field descriptions.

Traffic batch archiving tab field descriptions

The Message Manager Configuration Maintenance window, shown above, displays
the following fields when the Traffic Batch Archiving tab is selected.

Field

Description

Enable Batch Traffic Archiving

This flag enables the batch traffic archiving.

Days to Keep

Specifies how many days worth of traffic is to be
left in the traffic tables. If you enter a 0 in this
field, all traffic will be moved to the online archive.
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Post Office search and replace

The Post Office Search and Replace function is used to replace Post Office
Directory/Adapter command strings when deploying Message Manager on a
different system.

To search and replace Post Offices

1. Click the Utilities icon on the toolbar.
The Utilities navigator opens.

2. Click Configuration > Post Office Search and Replace.
The Post Office Search and Replace window opens.

3. Select a Post Office Type to be replace. You can choose to replace File Post
Offices, All Post Offices, or you can choose a specific Post Office Type from the
drop-down list.

4. Enter the existing Post Office Directory/Adapter Command string in the Find
What text entry field.

5. Enter the string that you want to replace the existing string with in the Replace
With field.

6. Click Replace.

Post Office types

The Post Office types window allows you to mark post offices that are not used by
your organization as inactive. This window also allows you to add and delete post
offices.

Marking a Post Office type inactive/active

You can mark any post office type in the list as inactive as long as there are no
post offices assigned to it. After the post office is marked as inactive, it will not
appear in the list of post offices in the Post Office navigator.

To inactivate/activate Post Offices

1. Click the Utilities icon on the toolbar.
The Utilities navigator opens.

2. Click Configuration > Post Office Types.
The Post Office Types dialog opens.

3. Select the Post Office that you want to make inactive and click Edit.
The Post Office Types Maintenance dialog opens.

Note: You cannot mark any post offices types as inactive if they currently have
post offices assigned to them.

4. Enable the Inactive check box.
5. Click Save.
You are returned to the Post Office Types form. Notice that a Y (Yes) now

appears in the Inactive column of the form on the line associated with the post
office that you deactivated.

6. To make the Post Office active again, perform steps 1 - 3 of this procedure.
When the Post Office Types Maintenance window opens, deactivate the Inactive
check box and click Save.

An N (No) is displayed in the Inactive column of the Post Office Types dialog
on the line associated with the post office that you activated.

IBM WebSphere Transformation Extender: Partner Manager



Adding a Post Office type

You can add a Post Office Type.

To add a post office type

1.

o

Click Utilities icon on the toolbar.

The Utilities menu opens.

Click Configuration > Post Office Types.

The Post Office Types dialog opens.

Click Add.

The Post Office Types Maintenance dialog opens.

Enter the post office type in the Post Office Type field.

Enter a description of the post office type in the Description field.
Click Save.

You are returned to the Post Office Types window. The new post office is
displayed in the list.

Deleting a Post Office type

You can delete a Post Office Type.

Note: Supplied Post Offices cannot be deleted. These post offices include:

OracleAQ; MessageQ Client; MessageQ Server; E-mail; File; FTP; HTTP;
JMS; MQSeries Client; MQSeries Server; MSMQ; and VAN.

To delete a post office type

1.

Click the Utilities icon on the toolbar.

The Utilities menu opens.

Click Configuration > Post Office Types.

The Post Office Types dialog opens.

Select the post office to be deleted.

Click Delete.

A message box opens that asks you to confirm the delete.
Click Yes.

You are returned to the Post Office Types dialog. The post office is removed
from the list.

Server directory configuration

The Server Directory Configuration Maintenance utility is used to:

Specify the archive access method

Specify FIP Connection Information

Specify the Archive and Resend transmission data folder locations
Specify the archive audit information

Allow you to test the archive access and folder configuration

To access the Server Directory Configuration Maintenance utility

1.

From the Tools menu, select Server Directory Configuration.
The Server Directory Configuration Maintenance window opens.
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2. Select the access method as either FTP or Mapped Drive by enabling the check
box.

If FTP is selected, enter information in the fields in the FTP Connection
Information area of the form.
3. Define the location of the archive and resend data folders.

4. Define the location of the share data folders. This initialization is needed for
specifying the location of alias files and for use of the manual export function
in the Message Manager Configuration utility.

See [Managing Traffic Data’| for detailed information.

Standards

Note: Incorrect use of this feature may result in invalidation of your trade links.
Ensure that you back up your Partner Manager database files before
attempting the procedures described in this section.

The Standards Maintenance utility enables you to maintain X12, EDIFACT, and
TRADACOMS standards such as versions, ID codes, and related standards
components. You can add, edit, and delete versions.

The following procedures describe how to perform maintenance on X12, EDIFACT
and TRADACOMS Standards.

Adding an X12 standard version

When you add a new X12 standard version, you must also add a functional ID
and transaction set associated with that version. Partner Manager enables you to
copy functional ID and transaction sets from an existing version. For example, you
can create copies of versions with new version names.

To perform maintenance on X12 standards

Note: To exit from the Standards Maintenance window without adding a version
or completing an add task, you must click Cancel. If you attempt to exit the
dialog box by closing Partner Manager or the Partner Manager process, you
may damage your Partner Manager database.

1. From the Tools menu, select Standards.
The Standards Maintenance window opens.
2. Select X12 Versions from the X12 Standards drop-down menu.
3. Enter a version number in the Version field.
4. Click Save.
The Copy Transactions/Func ID’s? dialog box appears.
5. Perform one of the following:

* To copy functional IDs and transaction sets from another version, enter that
version number and click OK.

e To search for and select a functional ID, click Cancel.
6. Select X12 Functional ID from the X12 Standards drop-down menu.
The Standards Maintenance X12 Functional ID window appears.
7. Perform one of the following:
* Enter a functional ID code in the Functional ID Code field.
* Click Display Functional ID’s to select a functional ID from the list box.

IBM WebSphere Transformation Extender: Partner Manager



10.

11.
12.

Click Save.

Select X12 Transaction Set from the X12 Standards drop-down menu.
The Standards Maintenance X12 Transaction Set window opens.
Perform one of the following:

e Enter a transaction set ID in the Transaction Set ID field, or

* Click Display Transaction Sets to select a transaction set from the scroll
box.

Complete the Transaction Set Description field.
Click Save.

Deleting an X12 standard version

To delete an X12 standard version with associated transaction sets and functional
IDs, delete its associated transactions sets and functional IDs first.

To delete an X12 standard version

1.

- o 0 No O
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12.

From the Tools menu, select Standards.

The Standards Maintenance form opens.

Select X12 Transaction Set from the X12 Standards drop-down menu.
The Standards Maintenance X12 Transaction Set window appears.
Click the Display Transaction Sets button.

The Find All Transaction Sets window opens.

Choose the transaction set associated with the version and functional ID and
click Select.

You are returned to the Standards Maintenance X12 Transaction Set window.
Click Delete.

Select X12 Functional ID from the X12 Standards drop-down menu.

Click the Display Functional IDs button.

Select the functional ID associated with the version and click Select.

Click the Delete button.

Select X12 Versions from the X12 Standards drop-down menu.

Enter a version number in the Version field or click Display Versions to select
a version number.

Click Delete.

Adding X12 interchange standards or ID qualifiers

You can add standards and ID qualifiers.

To add an interchange standard or ID qualifier

1.
2.

From the Tools menu, select Standards

Select one of the following from the X12 Standards drop-down menu:
* X12 Interchange Standards

* X12 Interchange ID Qualifiers

The Standards Display X12 Interchange Standards, or the Standards Display
X12 Interchange ID Qualifiers window opens.

Enter a qualifier number in the Qualifier field.

Or click Display Interchange Standards or Display Interchange ID Qualifiers
to select a number.
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5. Click Save.
6. Click Cancel.

Adding an X12 hex value

Each X12 hexadecimal value supports up to two individual values, for example,
0D 0A (which is CR LF).

To add an X12 hex value

1. From the Tools menu, select Standards.

2. Select X12 Hex Values from the X12 Standards drop-down menu.
The Standards Maintenance X12 Hex Values window appears.

3. Enter a hexadecimal value in the Hex Value field.

4. Enter a description in the Description field.

5. Click Save.

X12 Structure Validation:Import

Imports a file that is used by Message Manager to validate X12 Structure. This is a
required step in the installation process for all databases other than Access.

To import an X12 Structure Validation file

From the Tools menu, select Standards.

1. Select X12 Structure Validation:Import from the X12 Standards drop-down list.
The Standards Maintenance X12 Structure Validation: Import window appears.

2. Click the Find File button to browse for the file you wish to import.

The StructureValidation.detl file, located in the install_dir\tmgr_vn.n\pmgr
directory, must be imported during installation.

3. Click Begin Import.

X12 Structure Validation:Maintenance

Allows additions, updates, and deletions of X12 Structure information.
Note: This is useful when new/custom standards are used.

To maintain X12 Structure Validation data
1. From the Tools menu, select Standards.

2. Select X12 Structure Validation:Maintenance from the X12 Standards
drop-down list.

The Standards Maintenance X12 Strucure Validation: Maintenance window
appears.

3. Enter information in the Version, Transaction Set ID and Structure Text fields.
4. Click Save.
Clicking Save will add or update the structure text.

Note: When you click the Delete button to delete a version, a dialog box
appears instructing you to first delete the transaction set.
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Deleting X12 interchange standards or ID qualifiers

You can delete standards and qualifiers.

To delete an interchange standard or ID qualifier

1. From the Tools menu, select Standards.

2. Select one of the following from the X12 Standards drop-down list:
* X12 Interchange Standards
* X12 Interchange ID Qualifiers

The Standards Maintenance X12 Interchange Standards window, or the
Standards Maintenance X12 Interchange Qualifiers window opens.

3. Enter a qualifier number in the Qualifier field.

* Or click Display Interchange Standards (if you opened the Standards
Maintenance X12 Interchange Standards window) or

* Display Interchange ID Qualifiers (if you opened the Standards
Maintenance X12 Interchange Qualifiers window) to select a number.

4. Click Delete.
Selecting HIPAA institutions

The HIPAA Institutions option allows you to populate the HIPAA Type 7
Institutions field in the X12 External Application Partners window.

To select HIPAA Institutions
1. From the Tools menu, select Standards.
2. Select HIPAA Institutions from the X12 Standards drop-down menu.
3. Click the Display Institutions button.
The Find All HIPAA Institutions window opens.
4. Click on the Medicare option and click the Select button.
You are returned to the Standards Maintenance window.
5. Click Save.

Importing HIPAA type qualifiers
The HIPAA Type Qualifiers: Import menu item is available from the X12 Standa
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menu in the Standards Maintenance window. The use of this option is described in

the Trading Manager Installation documentation.
Adding an EDIFACT standard version

An EDIFACT version label consists of three required fields and one optional fiel
* Message Version Number

* Message Release Number

* Controlling Agency

* Association Assigned Code (optional)

To add an EDIFACT standard version
1. From the Tools menu, select Standards.

2. Select EDIFACT Message Version Numbers from the EDIFACT Standards
menu.

The Standards Maintenance EDIFACT Message Version Numbers window
opens.
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7.
8.
9.
10.
11.

12.
13.
14.

15.

16.
17.

Enter a version number in the Message Version No. field.
Enter a description in the Description field.
Click Save.

Select EDIFACT Message Version Numbers from the EDIFACT Standards
menu.

Enter a release number in the Message Release No. field.

Enter a description in the Description field.

Click Save.

Select EDIFACT Controlling Agency from the EDIFACT Standards menu.

Enter an abbreviation representing the version agency (such as the UN) in the
Controlling Agency field.

Enter a description in the Description field.
Click Save.

(Optional) Select EDIFACT Association Assigned Code from the EDIFACT
Standards menu.

Enter an abbreviation representing the association in the Assoc Assign Cd
field.

Enter a description in the Description field.
Click Save.

Adding an EDIFACT partner ID code qualifier

You can add partner ID code qualifiers.

To add an EDIFACT partner ID code qualifier

1.
2.

4.
5.
6.

From the Tools menu, select Standards.

Select EDIFACT Partner ID Code Qualifiers from the EDIFACT Standards
menu.

The Standards Maintenance EDIFACT Partner ID Code Qualifiers window
opens.

Enter a code in the ID Code Qualifier field.
Enter a description of the partner in the Description field.
Click Save.

Adding an EDIFACT functional ID or message type

Adding an EDIFACT Functional ID/Message Type requires that you first add an
EDIFACT standard version, as described in ['Adding an EDIFACT Standard|

-

To add an EDIFACT functional ID or message type

1.
2.
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From the Tools menu, select Standards.
Select EDIFACT FuncIDMsgType from the EDIFACT Standards menu.

TheStandards Maintenance EDIFACT Functional ID and Message Types
window appears.

Select a message version number from the Msg Version No. list.
Select a message release number from the Msg Release No. list.
Select a controlling agency number from the Controlling Agency list.

(Optional) Select an associate assigned code from the Assoc Assign Code
drop-down list.
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7. Enter an abbreviation representing a functional ID or message type in the
FuncID/MsgType field.

8. Enter a description in the FuncID/MsgType Description field.
9. Click Save.

Adding an EDIFACT hex value

Each EDIFACT hex value supports up to three individual values, for example, 27
0D 0A, as shown in the following table. The EDIFACT hex values delivered with

Partner Manager are as follows:

Hex Value

1C IS4 (File separator)

1D IS3 (Group separator)

1E IS2 (Record separator)

1F IS1 (Unit separator)

20 Space character

27 Single quote character ()

27 0D 0A Single quote-carriage return-line feed (* CR
LF)

2B Plus sign (+)

2C Comma character (,)

3A Colon character (:)

3F Question mark character (?)

To add an EDIFACT hex value

1. From the Tools menu, select Standards.

2. Select EDIFACT Hex Values from the EDIFACT Standards drop-down menu.

The Standards Maintenance EDIFACT Hex Values window opens.
3. Enter a hexadecimal value in the Hex Value field.
4. Enter a description in the Description field.
5. Click Save.

Deleting an EDIFACT standard

The following procedure describes how to delete the EDIFACT standards:
¢ Version
 Partner ID code qualifier

* Functional ID or message type

To delete EDIFACT standards
1. From the Tools menu, select Standards.
2. Select a standard type from the EDIFACT Standards drop-down menu.

3. Enter the standard type information or click the display button to select a
standard.

For example, to delete a message version number:
* Click the Display Message Version Numbers button.
* Choose a version number and click Select.
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4. Click the Delete button.

Adding and deleting TRADACOMS standards

This section describes how to add and delete X12 Standards.
Adding a TRADACOMS document type

The following procedure describes how to add a TRADACOMS document type.

To add a TRADACOMS document type

1. From the Tools menu, select Standards.

2. Select Document Types from the TRADACOMS Standards drop-down menu.
The Standards Maintenance window displays the TRADACOM information.

3. In the Document Type field, enter the document type you wish to add.

4. In the Segment Versions group box, enter the Header, Trailer, and TAXCON
Version information assigned to this Document Type.

Note: The TAXCON Version is only enabled for Invoice, Credit, and Utility
Bill types.

5. Enter the description in the Description field.
6. Click Save.

Editing a TRADACOMS document type

The following procedure describes how to edit an existing TRADACOMS
document type.

To edit a TRADACOMS document type

1. From the Tools menu, select Standards.
The Standards Maintenance window appears.

2. Select Document Types from the TRADACOMS Standards drop-down menu.
The Standards Maintenance window displays TRADACOM fields.

3. Click the Display Document Types button.
The Find All TRADACOMS Document Types window appears.

4. Choose a document type, and then click Select.

5. Edit the data fields as needed.

Note: The TAXCON Version is only enabled for Invoice, Credit, and Utility
Bill types.

6. Click Save.
Deleting a TRADACOMS document type

The following procedure describes how to delete a TRADACOMS document type.

To delete a TRDAOCOMS document type

1. From the Tools menu, select Standards.

Select Document Types from the TRADACOMS Standards drop-down menu.
Click Display Document Types.

The Find All TRADACOMS Document Types dialog box displays.

Choose a document type and click Select.

ok~ wd
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6. Your selection appears in the Document Type field.

Note: The remaining fields will automatically fill in after selecting the
document type.

7. Click Delete.

Database utilities

Merge

The Database Utilities contains the following:
* Merge
e Purge

Note: If user security is enabled, the user must have the following privileges to
run the merge: Folder Maintenance, Create Trading Partner, Create
Application Partner, Create Folders, Create Inbound and Outbound Links
and Create Post Offices.

Partner Manager enables you to merge one database to another database. For
example, this feature enables you to merge selected objects in a source test
database into a destination production database.

The source database is the database currently open in Partner Manager and
specified in the Data Source Name (DSN) profile. The information you can merge
into the destination database includes Trading Partners, Trade Links, and Post
Offices.

Note: To verify the current profile information, including DSN information, select
About Partner Manager from theHelp menu.

To merge a database into another database
1. From the Tools menu, select Merge to Another DB.

The Merge: Select Destination Database window is displayed.
2. Select an existing profile or DSN.

Note: If you have not entered a profile to select, then enter the User ID,
Password, Database (if not Oracle), and Database Vendor.

Click Next.
Select an option from the Merge Option dialog box:
Click Begin Merge.

ook w

Follow the merge wizard instructions and click Finish.

The wizard varies slightly different depending on the item you select to merge. A
message appears upon successful completion.

Note: The next time you perform a database merge, Partner Manager keeps the
most-recently selected destination database as the default destination
database.

Details on merging trade links
The merge function is useful for transferring information from a test environment
to a production environment.
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Purge

The Inbound Trade Link and Outbound Trade Link merge functions for X12 and
EDIFACT transfer all Trade Link data to another database.

The functions also merge dependent information, such as Folders, Trading Partners
and Application Partners (From, To, and Acknowledgement Partners), Post Offices,
Contacts, and any Standards needed (EDIFACT, X12, Functional IDs, and
Transaction Sets). Carefully review the initial and final analysis messages to ensure
the Trade Link merged as you expected.

* The merge functions do not overwrite existing information; information is
appended to destination databases. If the destination database has information
in it that is identical to the source database, that information is not included in
the merge from the source database. This feature allows you to transfer test
Trade Links and related information before implementing them.

* Because the merge functions never overwrite information, you can add
information to a copy of a production database, test it, and then merge the new
information only to the production database.

* Review the initial and final analysis messages carefully on the Select to Merge
dialog box to insure the accuracy of the merging databases; this dialog box
provides Merge Analysis information about what specifically is to be merged.

e The EDIFACT Trade Link merge does not have the ability to merge a trade link
that exists in the destination database.

Post Office and Trading Partner merge details

* Partner Manager does not complete a Post Office merge if the destination
database contains a Post Office with the same Name or Nickname.

* Trading Partners merge their associated Application Partner information in the
destination database.

e If the Trading Partner exists in the destination database but the associated
Application Partner does not, the Application Partner is merged in the
destination database.

* Partner Manager also creates any folders or subfolders you have created in the
source database in the destination database. If the folder name exists in the
destination database but is a different folder type than the source, Partner
Manager merges the folder data in the appropriate folder. For example, data in a
source X12 internal folder named Track is not merged into the destination X12
external folder named Track. Instead, Partner Manager merges the data into the
default destination X12 internal folder Internal X12.

Use the following instructions to purge traffic and/or Partner Manager Log data.
To purge data, open the Purge/Archive Traffic Reports window as follows

To open the Purge/Archive Traffic Reports window
1. Click the Utilities icon in the Partner Manager toolbar.

2. Select Database > Purge in the Utilities navigator to open the window.
Purging traffic or transmission data

To purge traffic or transmission data

1. With the Purge/Archive Traffic Reports window open, select the Purge
(Permanent Delete) Current Tables button.

2. Select the type of data to be permanently deleted.
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3.

4.

5.

¢ To permanently delete traffic data, continue with the next step.
* To permanently delete transmission data, select the Purge Transmission Data
check box.

All records will be purged before the date displayed in the Purge/Move All
Before this Date field. If you want to choose a different date than the one
displayed, open the calendar by clicking the arrow to the right of the field and
select a new date.

Note: All records dated before this date will be purged.

Click Begin Purge/Archive. A message box opens that informs you that the
purge is permanent and asks if you want to continue.

Click Yes.

Archiving batch traffic

To archive batch traffic

1.

With the Purge/Archive Traffic Reports window open, click the Configure
button located in the Batch Traffic Archive area of the window.

The Message Manager Configuration window opens with the Traffic Batch
Archiving tab view displayed.

Check the Enable Batch Traffic Archiving check box.

Enter the number of days that the archive is to be kept. You can enter any
integer between 1 and 365 (inclusive).

If you want to move all traffic to the online archive, enter 0 in the Days to
Keep field. If you do not want to do this, continue with the next step. If you
enter 0 the Days to Keep Warning will open which asks you to confirm your
selection.

Click Save to close the Message Manager Configuration window and return to
the Purge/Archive Traffic Reports window.

The number of days that the archive is to be kept is displayed in the window.

Folders

The Folder Utilities facility enables you to organize trading partners in subfolders
under the main Address Book Internal and External folders.

Partner Manager enables you to add, rename, move, and delete internal and
external X12 subfolders.

You may not delete or rename main folders. When you delete a subfolder, it
deletes all objects (trading and application partners, contacts, transaction sets, and
so on) in the subfolder.

Adding a subfolder

To add a subfolder to a main folder

1.

From the Tools menu, select Folder Utilities.
The Folder Utilities window opens.

Select a folder.

Click Add Sub Folder.

The Folder Maintenance dialog box opens.
Enter a name in the Folder Name field.
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Note: The name can be a maximum of 32 characters.
Click Save.

The new subfolder appears in the Folder Utilities list and the Address Book
navigator.

Renaming a subfolder

To rename a subfolder

1.

From the Tools menu, select Folder Utilities.
The Folder Utilities dialog box appears.
Select a subfolder.

Click Rename.

The Rename Folder dialog box appears.

Note: The name can be a maximum of 32 characters.
Change the folder name in the Folder Name field.
Click Save.

The folder is renamed.

Moving a subfolder

Moving a subfolder moves all objects (trading and application partners, contacts,
transaction sets, and so on) in the subfolder.

Note: If the subfolder does not contain any trading partners, it cannot be moved.

To move the contents of one subfolder to another

1.

5.

From the Tools menu, select Folder Utilities.

The Folder Utilities dialog box appears.

Select a subfolder.

Click Move. The Move Folder dialog box appears.

Enter an existing subfolder name in the text box and click OK.
A message informs you that the move was successful.

Click OK.

Deleting a Subfolder

When you delete a subfolder, it deletes all objects (trading and application
partners, contacts, transaction sets, and so on) in the subfolder.

To delete a subfolder

1.

2.
3.

From the Tools menu, select Folder Utilities.

The Folder Utilities dialog box appears.

Select a subfolder.

Click Delete and confirm the delete action when prompted.

118 1BM WebSphere Transformation Extender: Partner Manager



Security

The Security utility contains the following:

* |"Security Groups'|

* |"Security Parameters”l

e |"User Maintenance”

* |"Prior Version Password Remover”|

Changing passwords

You can change the password of the current user. This option is only available if
security is in force; it is disabled until a valid user logs into Partner Manager.

Preventing easily guessed passwords

Passwords containing the user name and the words secret and password, pass and
word will be not be accepted as valid passwords. For example, if the user name
were Fred, a password of 123Fred123 would be rejected as it contains the user
name. This check will only be performed on newly entered passwords. Passwords
converted from prior versions will not be subject to this restriction.

Changing your password
The following steps describe how to change passwords

To change your password
1. From the Tools menu, select Security > Change Password.
The Partner Manager Change Password dialog box opens.

2. Complete the fields in the dialog box. See ['Preventing Easily Guessed|
before changing a password.

3. Click OK.
A message box opens that tells you that the password has been changed.
4. Click OK.

The password is changed.
Security groups

Partner Manager enables you to define groups with security permission attributes
and assign users to those groups. Assigned users log into Partner Manager.

Note: From the Help menu, select About Partner Manager to view the current
User ID and Security Group.

Defining security groups enables you to configure default sets of permissions that
you can then assign to one or more Partner Manager users. You can use the
security profiles provided, or adjust the access selections to fit your needs.

You can add, edit, and delete security groups. You then define and add users to
security groups.

Partner Manager provides three suggested levels of group permissions. You can
use the following as a template for your security needs:

* Administrator - Provides full permission to security, purge and archive, EDI
wizard, access, create, edit, and resend functions
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* Power User - Provides Administrator permissions, except for security and
purge/archive functions

* Read Only - Provides access-only permissions for Trading Partner, Application
Partner, Post Offices, Inbound Trade Links, and Outbound Trade Links
information

Adding a new security group

Adding a security group defines permissions for users that belong to that security
group. At least one user must be added to a new security group before the security
group can be used.

To add a new security group
1. From the Tools menu, select Security » Security Groups.
The Security Group Maintenance window appears.
2. In the Group ID field, enter the new security group name (up to 10 characters).
3. Press Enter.
A confirmation dialog box appears.
4. Click Yes to create the new security group.
5. (Optional) In the Group Desc. field, enter a description for the group.

6. Define the security group permissions by clicking a Security Profiles button:
Administrator, Power User, or Read Only.

7. The default settings for the category are enabled.

Note: Click Clear All to clear all permissions currently enabled.

8. To customize the permissions, enable or disable the check boxes for access
settings.

9. Click Save to create the group.
Editing security group settings
Existing security groups can be modified.

To edit security settings for an existing group

1. From the Tools menu, select Security » Security Groups.
The Security Group Maintenance dialog box appears.

2. Select the group ID for the existing group from the Group ID drop-down list.
Edit the permissions for this security group.

3. Click Save.

Deleting a security group

All users assigned to the security group must be deleted prior to deleting the
security group.

To delete an existing security group
1. From the Tools menu, select Security » Security Groups.
The Security Group Maintenance dialog box appears.
2. Select the security group from the Group ID drop-down list.
3. Click Delete.
A delete confirmation dialog box appears.
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4. Click Yes.

Security parameters

This section describes how to set the various Partner Manager security parameters
using the Security Parameters window.

To set security parameters

1.

From the Tools menu, select Security > Security Parameters.
The Security Parameters window opens.

If you want to enforce use of a password that consists of a minimum number
of characters, enable the Enforce Minimum Password Length check box.

The Minimum Length field will become active and a default value will be
displayed in the field. You can change the default value. The system will then
detect existing passwords that do not meet the minimum length requirement.

Note: If you leave the field blank (check box disabled) any password length,
including zero, will be valid. (See|"Preventing Easily Guessed|
before selecting a password.)
If you want to force a user to be locked out after a number of invalid logon
attempts, enable the Enforce Maximum Invalid Logins check box.

The Maximum Invalid Attempts field will become active and a default value
will be displayed in the field.

* You can change the default value. The system will then lock out any user
entering invalid logons for the specified number of times.

* When the Enforce Maximum Invalid Logins check box is enabled, the Log
Accounts Locked Out check box is active (not grayed out). When enabled,
this check box will cause accounts logged out data to be written to the
Partner Manager Log File. If you do not want the accounts logged out to be
logged, disable this check box.

If you want to log all security procedures in the Partner Manager log, enable
the Log All Security Maintenance check box.

Note: The security procedures logged include: creating and maintaining user

ids, security groups, security parameters, and changing password.

If you want to log all user logon activity in the Partner Manager log, enable the

Log All Logon Activity check box.

When this option is selected the Partner Manager log will record all user logon

and logoffs, as well as record whenever invalid logon attempts occur.

If you want to activate the Password History option, enable the Enforce

Password History check box.

The By user, prevent the following number of passwords from being used field

will be enabled.

e Enter a value in the field. The default value of the field is 4, and must be a
value greater than 1. When a user changes his or her password, the system
will prevent the new password from being the same as the last number of
passwords specified in this field.

Click Save.

A message box opens that informs you that Security Parameters have been
successfully updated

Click Ok.
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The message box closes and the parameters are saved.

User maintenance

User permissions are defined in the security group permissions. Selecting the
Group ID on the User Information dialog box assigns the user to a specific
security group.

A user definition consists of:

* User ID (for logon)

* User Name (optional description)
» Password

* Confirm Password

* Group ID

* Password options

You can add, edit, and delete users. The Change Password feature allows users to
change their password.

Adding a user to a security group

To create a user, enter his/her name, password, password expiration rules, and
select the Security Group to define the user’s permissions.

Note: From the Help menu, select About Partner Manager to view the current
User ID and Security Group.

To add a user to a security group
1. From the Tools menu, select Security » User Maintenance.
The Security Users window opens.
2. Click Add.
The User Maintenance: Add window opens.
3. Enter the User ID for the new user.
4. Enter a Group ID.

Note: The User ID and Group ID fields are required fields. All others are
optional. Complete the following steps if desired. If not continue with
step 10.

5. In the User Name field, enter a description for the user.

6. In the Password field, enter a password for the user. (See [ Preventing Easily]|
[Guessed Passwords'| before selecting a password.)

7. If you entered an optional password, enter the password again in the Confirm
Password field.

8. Select a Group ID to assign this user to a security group.
9. Select any desired password options.

 If you want to force the user to change their password at the next logon,
enable the User Must Change Password at Next Logon check box.

 If you want to disable the user’s ability to change passwords, enable the
User Cannot Change Password check box.

 If you want to disable the account, enable the Account is Disabled check
box.
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 If you want to select a number of days for password expiration, click
Password expires every: and enter a number of days in the days field.

10. Click Save.

You are returned to the Security Users dialog box and the new user is added
to the list.

Editing a user

You can edit information about a user.

To edit an existing user

1. From the Tools menu, select Security » User Maintenance.
The User Information dialog box appears.

2. Select a User ID from the User ID drop-down list.

3. You can edit the password for this user or select a different security group from
the Group ID drop-down list.

4. Click Save.
Deleting a user

You can delete users. You must delete users before deleting the security group they
belong to.

To delete an existing user

Note: Deleting the last user in Partner Manager disables all user and group
security.

1. From the Tools menu, select Security » User Maintenance.
The User Information dialog box appears.

2. Select a User ID from the User ID drop-down list.

3. Click the Delete button.
A confirmation dialog box appears.

4. Click Yes to confirm the delete of the user.

User login with security

After you configure security groups and add users, exit Partner Manager. When
the Partner Manager application is restarted, the Partner Manager User Login
dialog box appears.

To start Partner Manager with security:
1. Start the Partner Manager application.

The Partner Manager User Login dialog box appears.
2. Enter a valid User ID.

Note: The next step is valid only if you configured a Password with the User

1D.
3. Enter a valid Password.
4. Click OK.

To log in as another user from within Partner Manager:

1. From the File menu, select Login as another User.
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The Partner Manager Login dialog box appears.
2. Enter a valid User ID.
3. (Option) Enter a valid Password.
4. Click OK.

Prior version password remover

You can remove prior Trading Manager passwords from the Windows registry by
using the Prior Version Password Remover.

To remove old passwords

1. Choose the Utilities icon from the Partner Manager toolbar, then select Utilities
> Prior Version Password Remover from the Utilities navigator.

The Prior Version Password Remover window opens.

2. Click Begin to start the Windows registry search for prior passwords.

Note: This process may take several minutes.
When the process completes, passwords are cleared.
3. Click Cancel.
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Chapter 9. EDI Wizard

The EDI Wizard creates type trees used by the Message Manager during the
processing of your inbound and outbound data, therefore, it must be run before
the Message Manager is built the first time. After you have defined your inbound
and outbound trade links in your initial implementation, run the EDI Wizard to
create the type trees.

Whenever a new transaction set or an existing transaction set for a new version of
the standard is added, run the EDI Wizard again to update the definitions of the
data to be recognized by the Message Manager.

EDI standard type trees
The EDI Wizard creates the following EDI standard type trees:

x12user.mtt (X12 and EDIFACT): You can use the type tree in your application
maps. If you have both X12 and EDIFACT data, two trees will be generated:
x12user.mtt and edifuser.mtt. These type trees contain all the definitions for the
EDI data processed by the Message Manager for all transaction sets for all
versions of the standard required for the trade links that are defined.

x12mail.mtt (X12) and edifmail.mtt (EDIFACT): Message Manager uses these
type trees. They are referenced by a series of the Message Manager maps. When
the EDI Wizard generates these type trees, they are placed in the same directory
as the Message Manager maps and trees.

EDI Mail Trees: The EDI Wizard will create both x12mail.mtt (X12) and
edifmail.mtt (EDIFACT) trees if you have the trees for these standards. Message
Manager uses these type trees. They are referenced by a series of Message
Manager maps. When the EDI Wizard generates the type trees, it is placed in the
same directory as the Message Manager maps and trees.

EDI User Trees: You can use the type tree in your application maps. The EDI
Wizard will create both X12(x12user.mtt) and EDIFACT (edifuser.mtt) trees if the
“Create User Trees’ option is selected. This type tree contains all the definitions
for the EDI data processed by the Message Manager for all transaction sets for
all versions of the standard required for the trade links that are defined. These
trees are created in the same directory as the Message Manager maps and trees.

Note: The EDI Wizard will not create TRADACOMS trees.

Running the EDI Wizard

The EDI Wizard creates type trees from Trade Link definitions.

To run the EDI Wizard

1.

w
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Select EDI Wizard from the Wizard menu on the toolbar.
The Type Tree Wizard dialog box appears.

Click Next.

Click Next to begin to create the customized EDI type trees.
Follow the wizard instructions to create your type tree.
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Where the Type Trees are located

The wizard prompts you to:
* Search the trading relationships defined in the Partner Manager.

 Enter the location of the type trees used to create the standard EDI type trees
and searches for these trees.

* Enter the location and file name for the new type trees. When you first run the
wizard, accept the default type tree names.

When prompted to specify a directory for new Message Manager Standard type
trees, choose the directory where the Message Manager source maps and type trees
are located. If you choose a different directory and attempt to create the type tree,
a dialog box displays alerting you to this fact and asking you to confirm that you
want to create this type tree in the specified directory.

If you have X12 trade links, the EDI Wizard will create the x12mail.mtt type tree in
the specified directory.

If you have EDIFACT trade links, the EDI Wizard will create the edifmail.mtt type
tree in the specified directory.

Note: if you are using a message version 90 (release 1), which contains the
INVOICE and ORDERS messages, you must select the edif90_1_contrl.mtt
type tree when using the EDI Wizard to create the edifmail tree. Users who
do not have message version 90 (release 1) messages need to use the
edifis09735-4.mtt when using the EDI Wizard to create the edifmail tree.

After the Wizard is finished, it displays a message that the customized type trees
have been created.

After a new x12mail.mtt (X12) and/or edifmail.mtt (EDIFACT) type tree is created,
you must redeploy both Trading Manager and Message Manager run maps. See
Step 13 in Chapter 5 of the Trading Manager Installation and User Guide for
instructions on this procedure.

When the EDI Wizard cannot locate a type tree

126

When the EDI Wizard cannot locate a type tree for a version that is needed, it
displays a dialog box showing the type trees that it could not find. It is
recommended that you cancel the wizard, install or re-locate the requested type
trees, and then restart the wizard.

However, you can generate an incomplete type tree and add the other types
manually. It is highly recommended that expert users perform the type tree
modification only when a version of the requested type tree is not available. If you
do select to continue to generate the type tree, a dialog box appears asking you to
confirm creation of an incomplete type tree.

It should be noted that if you generate an incomplete type tree, you must
manually add the types representing the transaction sets for the versions of the
standard type trees that could not be found, before building the Message Manager
maps.
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When more than one type tree is found for a version

When the wizard locates more than one type tree for a particular version of the
standard, it displays a dialog box listing those trees.

How to continue
1. Select the appropriate type tree.
2. Click Next.

When possible, use the original version of the standard trees that are installed
for the type trees.
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Chapter 10. Database copy utility

The Database Copy Utility copies an existing Partner Manager Database to an
empty (newly created) database. The newly created database can be a copy of
M4EC_Empty.mdb, or a database created by *inst.sql scripts that ship with
Partner Manager. This copy can be run with a transaction or without a transaction.

It should be noted that the default setting is within a transaction.

The Run Copy Without Transaction Control check box should only be enabled if
the source database is very large and is causing LogFile full errors. If an error
occurs when running without a transaction, no rollbacks occur. You must start over
with an empty database.

The Database Copy Utility is accessed from the Start menu.

To start the Database Copy Utility

1. From the Start menu, click Programs IBM WebSphere Transformation
Extender n.n » Trading Manager then Database Copy Utility.

The Partner Manager Copy Utility dialog box opens.

Copying databases

The Database Copy Utility enables you to copy an existing Partner Manager
database to another empty database.

The empty database can be the m4ec_empty.mdb file or a newly created database
created by the *inst.sql script files (both files are installed as part of Trading
Manager).

This copy may be run without transaction control enabled if the source database is
very large. If an error occurs when executing the database copy, and transaction
control is not enabled, and no rollbacks occur; you must start over and create a
new empty database (using the database drop, inst, and load scripts) or copy the
m4éec_empty.mdb file (this file is valid for Microsoft Access database files only).

Database scripts

Run the *drop, *inst, and *load scripts on the database or for Access make another
copy of MAEC_Empty.mdb.

*drop scripts

These .sql files are installed in the install_dir\tmgr_vn.n\pmgr\sql\ directory:
* db2dropnn.sql

* oradropnn.sql

* sqldropnn.sql

* sybasedropnn.sql
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*inst scripts

These .sql files are installed in the install_dir \tmgr_vn.n\pmgr\sql\ directory:
* db2instnn.sql

* orainstnn.sql

* sqlinstnn.sql

* sybaseinstnn.sql

*load scripts

These .sql files are installed in the install_dir \tmgr_vn.n\pmgr\sql\ directory:
* db2loadnn.sql

e orainstnn.sql

* sqlinstnn.sql

* sybaseinstnn.sql

* sybaseinstnn_2.sql
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Chapter 11. Managing traffic data

Partner Manager enables you to archive and purge the traffic record data in your
Partner Manager database. (These records represent the Partner Manager
e-commerce traffic.) Larger databases may slow down processing and result in
unmanageable numbers of entries in each traffic report.

Partner Manager provides the following information management options that

enable you to:

* Purge data from the Current traffic tables

¢ Purge data from the Online Archive traffic tables

e Archive data from the Current traffic tables to the Online Archive tables

* Archive data from the Current traffic tables to the zip file archives

* Archive data from the Online Archive tables to the zip file archives

* Restore data from a zip file archive

Partner Manager provides the following information management options:

Option

Description

Purge (Permanent Delete) Current Tables

Permanently deletes traffic records before a
specified date from the Partner manager
database. These records cannot be restored.

Move to On-Line Archive

Places traffic records before a specified date
in the Archive tables in the Partner Manager
database. The records are then purged from
the current Traffic tables.

Move to Current to Off-Line Zip File

Stores traffic records before a specified date
in a zip file. These records are then purged
from the current Traffic tables.

Move On-Line Archive to Off-Line Zip File

Stores traffic records before a specified date
from the Archive tables in the Partner
Manager database in a zip file. These
records are then purged from the Archive
tables.

Purge (Permanent Delete) of On-Line
Archive

Permanently deletes traffic records before a
specified date from the Archive tables in the
Partner Manager database. These records
cannot be restored.

Restore Zip File

Restore files archived in a compressed zip
fileusint the Move to Current to Off-Line
Zip File or Move On-Line Archive to
Off-Line Zip File features.

Purging current traffic or online archive data

This procedure permanently deletes traffic data from the Current traffic database

tables.

Note: If the Purge (Permanent Delete) Current Tables or the Purge (Permanent
Delete) of Online Archives purge option is enabled, a Purge Transmission
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Data check box is available. Enable the Purge Transmission Data check box
to permanently delete the transmission archive of interchange data. This
transmission archive folder is defined in the Directories » Archive field of
the Server Directory Configuration Maintenance utility.

Before purging data, see the Check the Traffic Table Report Count section for
information about traffic table counts.

To permanently delete current traffic information

1.
2.
3.

© 0o N

10.

From the Tools menu, select Purge.

The Purge/Archive Traffic Reports dialog box appears.
Enable one of the following options:

* Purge (Permanent Delete) Current Tables

¢ Purge (Permanent Delete) of Online Archives

Click the Calendar button to select a date.

Click a date in the Calendar dialog box.

All traffic records before but not including this date are permanently deleted
from the Partner Manager tables.

Note: To quickly purge all records, add a future date.
Click Select.

Click Begin Purge/Archive.

Click Yes to confirm the purge action.

As the traffic records are being deleted from the Partner Manager database,
the current task displays in the Purge Status area. After the purge process is
completed, a dialog box appears identifying the number of records purged.

Click Cancel to close the Purge dialog box.

Check the traffic table report count

This procedure enables you to check the number of traffic reports to determine
whether you need to purge data. The Traffic Report Counts window shows the
current number of reports by type using the actual database table name.

The following lists the database table name to the report name available from the
Reports navigator. Any table name that includes the word Archive (such as
ECAlertArchive) shows the number of traffic reports in the traffic data archive.

Database Table Name View in Traffic Reports

ECAlert Traffic Alert

ECICStatus Data Type View

EDF_Status_IC EDIFACT Interchanges

EDEF_Status_FG EDIFACT Functional Groups

EDF_Status_Msg EDIFACT Messages

EDEF_Status_SegErr EDIFACT Segment Errors

EDEF_Status_DEErr EDIFACT Data Element Errors

X12DEError X12 Data Element errors; if these errors exist,
they are shown in the traffic reports segment
error views. See Traffic Reports.
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Database Table Name View in Traffic Reports

X12FGStatus X12 Functional Groups
X12ICStatus X12 Interchanges
X12SegError X12 Segment errors; if these errors exist, they

are shown in the Reports navigator under
Transmissions. See Reports Navigator

Overview.
X12TSStatus X12 Transactions
MapStatus Transmissions
TRCICStatus TRADACOMS interchanges
TRCDocHeader TRADACOMS document header
TRCDocBody TRADACOMS document body
TRCSegError TRADACOMS document segment errors
TRCDEError TRADACOMS document data element errors

To check the traffic table report count
1. From the Tools menu, select Purge.
The Purge/Archive Traffic Reports dialog box appears.
2. Click the Traffic Counts button.
The Traffic Report Counts window appears.
3. Use the scroll bar to show the archived report information.

Click Copy to move the information to your Windows clipboard. You can paste
this data into any Windows application that accepts clipboard text.

4. Click OK to close the window.

Archiving traffic data

The following sections describe how to archive Partner Manager traffic data.
Partner Manager enables you to:

* Archive data from the Current traffic tables to the Online Archive tables
* Archive data from the Current traffic tables to the zip file archives
* Archive data from the Online Archive tables to the zip file archives

Archiving data from the current traffic tables to the online
archive tables

To move current traffic information to an online archive
1. From the Tools menu, select Purge.

The Purge/Archive Traffic Reports dialog box appears.
2. Enable Move to On-Line Archive.

3. Enter a date in any valid date format in the Purge/Move All Before This Date
field or click Calendar to select a date.

All traffic records before but not including this date are moved to the online
archive tables.

4. Click Begin Purge/Archive.
5. Click Yes to confirm the move action.
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6.

As the traffic records are being archived into the archive tables and purged
from the current tables, the current task is displayed in the Purge Status. After
the process is completed, a dialog box appears identifying the number of
records archived.

Click Cancel to close the Purge dialog box.

Moving data from the current traffic tables to a zip file

To move current traffic information to a zip file

1.

9.

From the Tools menu, select Purge.
The Purge/Archive Traffic Reports dialog box appears.
Enable the Move to Current to Off-Line Zip File option button.

Enter a date in any valid date format in the Purge/Move All Before This Date
field or click Calendar to select a date.

All traffic records before but not including this date are moved to the online
archive tables.

Click Begin Purge/Archive.

Click Yes to confirm.

The Select/Enter Zip File Destination dialog box appears.
Enter a zip file archive file name and click Open.

The default name is PartnerMgrCCYYMMDD.zip, where CCYYMMDD
represents the date you selected in Step 3.

As the traffic records are being archived into the zip files and purged from the
current tables, the current task is displayed in the Purge Status. After the
process is completed, a dialog box appears identifying the number of records
archived.

Click Cancel to close the Purge dialog box.

Moving data from the online archive tables to a zip file

To move archived traffic information to a zip file

1.

9.

From the Tools menu, select Purge.

2. The Purge/Archive Traffic Reports dialog box appears.
3.
4. Enter a date in any valid date format in the Purge/Move All Before This Date

Enable Move On-Line Archive to Off-Line Zip File.

field or click Calendar to select a date.

All traffic records before but not including this date are moved to the online
archive tables.

Click Begin Purge/Archive.

Click Yes to confirm.

The Select/Enter Zip File Destination dialog box appears.
Enter a zip file archive file name and click Open.

The default name is PartnerMgrCCYYMMDD.zip, where CCYYMMDD
represents the date you selected in Step 3.

As the traffic records are being archived into the zip files and purged from the
current tables, the current task is displayed in the Purge Status. After the
process is completed, a dialog box appears identifying the number of records
archived.

Click Cancel to close the Purge dialog box.
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Restoring traffic data from a zip file

To restore traffic data from a zip file

1.

From the Tools menu, select Purge.
The Purge/Archive Traffic Reports dialog box appears.
Enable Restore Zip File.

Enter the name of the zip file containing the traffic information to be restored.
Click Find Zip to browse for the full file name and path of the zip file.

The default zip file name when files are archived is
PartnerMgrCCYYMMDD.zip, where CCYYMMDD represents the date.

Click Begin Restoration of Zip File to begin restoring the data.

The Purge/Archive Traffic Reports dialog box shows the records being restored.
After the process is completed, a dialog box shows that the restore was
completed successfully and the number of database tables that were processed.

Click Yes to delete the zip file from which the traffic records were restored or
click No to keep the file and return to the Purge/Archive Traffic Reports dialog
box.

If you selected to delete the zip file, a dialog box appears confirming the
deletion of that file.

Click OK to return to the Purge/Archive Traffic Reports dialog box.
Click Cancel to close the Purge dialog box.
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Notices

This information was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user’s responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not grant you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation

North Castle Drive
Armonk, NY 10504-1785
US.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM
Intellectual Property Department in your country or send inquiries, in writing, to:

IBM World Trade Asia Corporation Licensing
2-31 Roppongi 3-chome, Minato-ku
Tokyo 106-0032, Japan

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law:

INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION "AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS
FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement may not apply
to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.
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Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

IBM Corporation

577 Airport Blvd., Suite 800
Burlingame, CA 94010
US.A.

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this document and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement or any equivalent agreement
between us.

Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments may
vary significantly. Some measurements may have been made on development-level
systems and there is no guarantee that these measurements will be the same on
generally available systems. Furthermore, some measurements may have been
estimated through extrapolation. Actual results may vary. Users of this document
should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

All statements regarding IBM’s future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

This information contains examples of data and reports used in daily business
operations. To illustrate them as completely as possible, the examples include the
names of individuals, companies, brands, and products. All of these names are
fictitious and any similarity to the names and addresses used by an actual business
enterprise is entirely coincidental.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which
illustrate programming techniques on various operating platforms. You may copy,
modify, and distribute these sample programs in any form without payment to
IBM, for the purposes of developing, using, marketing or distributing application
programs conforming to the application programming interface for the operating
platform for which the sample programs are written. These examples have not
been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or
imply reliability, serviceability, or function of these programs.

If you are viewing this information softcopy, the photographs and color
illustrations may not appear.
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Programming interface information

Programming interface information, if provided, is intended to help you create
application software using this program.

General-use programming interfaces allow you to write application software that
obtain the services of this program’s tools.

However, this information may also contain diagnosis, modification, and tuning
information. Diagnosis, modification and tuning information is provided to help
you debug your application software.

Warning: Do not use this diagnosis, modification, and tuning information as a
programming interface because it is subject to change.

Trademarks and service marks

The following terms are trademarks or registered trademarks of International
Business Machines Corporation in the United States or other countries, or both:

AIX

AIX 5L

AS/400

Ascential

Ascential DataStage
Ascential Enterprise Integration Suite
Ascential QualityStage
Ascential RTI
Ascential Software
Ascential

CICS

DataStage

DB2

DB2 Universal Database
developerWorks
Footprint
Hiperspace

IBM

the IBM logo
ibm.com

IMS

Informix

Lotus

Lotus Notes
MQSeries

MVS

0S5/390

0S/400

Passport Advantage
Redbooks

RISC System /6000
Roma

S/390

System z

Trading Partner
Tivoli
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WebSphere
z/ Architecture
z/0S

zSeries

Java and all Java-based trademarks are trademarks of Sun Microsystems, Inc. in the
United States, other countries, or both.

Microsoft, Windows, Windows NT, and the Windows logo are trademarks of
Microsoft Corporation in the United States, other countries, or both.

Intel, Intel logo, Intel Inside, Intel Inside logo, Intel Centrino, Intel Centrino logo,
Celeron, Intel Xeon, Intel SpeedStep, Itanium, and Pentium are trademarks or
registered trademarks of Intel Corporation or its subsidiaries in the United States
and other countries.

UNIX is a registered trademark of The Open Group in the United States and other
countries.

Linux is a trademark of Linus Torvalds in the United States, other countries, or
both.

Other company, product, or service names may be trademarks or service marks of
others.

This product includes software developed by the Eclipse Project
(http:/ /www.eclipse.org/).

JAVA

TowmTEE @
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