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About this document

The products IBM®™ WebSphere™® Business Integration Express for Item
Synchronization and IBM®™ WebSphere™® Business Integration Express Plus for
Item Synchronization are made up of the following components--InterChange
Server Express, the associated Toolset Express product, the Item Synchronization
collaboration, and a set of software integration adapters. Together, the components
provide business process integration and connectivity among leading e-business
technologies and enterprise applications as well as integration with the UCCnet
GLOBALregistry.

This document provide an overview of the configuration procedures required after
you have installed WebSphere Business Integration Express for Item
Synchronization. Except where noted, all the information in this guide applies to
both IBM® WebSphere®™ Business Integration Express for Item Synchronization
and IBM® WebSphere™ Business Integration Express Plus for Item
Synchronization. The term WebSphere Business Integration Express for Item
Synchronization and its variants refer to both products.

Audience

This document is for anyone who implements components for WebSphere Business
Integration Express for Item Synchronization.

Related documents

The complete set of documentation available with this product describes the
features and components common to all WebSphere Business Integration Express
for Item Synchronization and WebSphere Business Integration Express Plus for
Item Synchronization installations, and includes reference material on specific
components.

You can install the documentation or read it directly online at the following site:

http://www.ibm.com/websphere/wbhiitemsync/express/infocenter

The site contains simple directions for downloading, installing, and viewing the
documentation.

Conventions used in this guide

This guide contains some instructions that vary according to which of the
supported platforms you are using. Such platform-specific instructions are noted
where they occur. The notations are:

* For Windows
The instruction is specific to the Microsoft Windows 2000 operating system.
* For Linux

The instruction is specific to Red Hat Enterprise Linux WS/ES/AS for Intel 2.1,
2.4 Kernel and SuSE Linux Enterprise Server 7.3, 2.4 Kernel

e For OS/400
The instruction is specific to OS/400 V5R2 (5722-551)
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This document uses these abbreviations and style conventions:

* Abbreviations are used for some words and some variables in syntax statements.
These abbreviations are used:

App = name of application Gen = generic

Attr = name of attribute ICS = InterChange Server Express

BO* = business object (prefix to a BO file) ObjectName* = variable name for business
object

Collab = collaboration Src = source

Dest = destination application

* B0 is the prefix to a BO file; the term BO generally refers to the business object
definition text files. ObjectName refers to the variables used to represent business
objects.

* The term “camelcase,” used in this document, refers to a style of capitalization
whereby the spaces between words are eliminated, and the first letter of each
word (or more than one letter if using acronyms) is capitalized. For example, the
collaboration template name DemandForecastVer? is in camelcase.

In addition, this document uses the following typographical conventions:

courier font Indicates a literal value, such as a command name, filename,
information that you type, or information that the system
prints on the screen.

italic Indicates a variable name or a cross-reference.

blue outline A blue outline, which is visible only when you view the
manual online, indicates a cross-reference hyperlink. Click
inside the outline to jump to the object of the reference.




Quick Start Guide

This document provides a roadmap of the required procedures for configuring
your WebSphere Business Integration Express for Item Synchronization system.
This document assumes that you have successfully installed the WebSphere
Business Integration Express for Item Synchronization product. If you have not yet
installed the WebSphere Business Integration Express for Item Synchronization
product, see Installing WebSphere Business Integration Express and Express Plus for
Item Synchronization.

This chapter includes the following sections:

« |“Contacting IBM WebSphere Business Integration Express for Item|
Synchronization Support”|

* |“Finding help”]

+ |[“Configuration required after installation” on page 3|

+ |“Administration” on page 44|

Contacting IBM WebSphere Business Integration Express for ltem
Synchronization Support

For support issues relating to the WebSphere Business Integration Express for Item
Synchronization product, you can contact IBM Customer Support in one of the
following ways:

* Visit the IBM WebSphere Business Integration Express for Item Synchronization
technical support Web site at:
http://www.ibm.com/software/integration/wbiitemsync/express/support/.

* To contact IBM WebSphere Business Integration Express for Item
Synchronization support via phone, call: 1-800-IBM-SERV (USA /Canada) or (for
non-USA) refer to http://techsupport.services.ibm.com/guides/contacts.html for
number in your geographic area.

Finding help

If you need more information regarding your WebSphere Business Integration
Express for Item Synchronization system, refer to:

e [“Tools help,”| or

* |“WebSphere Business Integration Express for Item Synchronization|
documentation’]

Tools help

To access context sensitive help for any of the Express tools, click F1.

WebSphere Business Integration Express for Item
Synchronization documentation

To access both the documentation and the content-sensitive help for WebSphere
Business Integration Express for Item Synchronization, you must download the
document viewer, and the documentation files, and the help from the IBM
InfoCenter. If you have not already done so, go and download that documentation
from the following Web site:

© Copyright IBM Corp. 2003, 2004 1



http://www.ibm.com/websphere/wbiitemsync/express/infocenter

The IBM WebSphere Business Integration Express for Item Synchronization
documentation set includes:

Table 1. WebSphere Business Integration Express for Item Synchronization documentation set

Title

Description

Map Development Guide

Business Object Development Guide

User Guide for WebSphere Business
Integration Express and Express Plus
for Item Synchronization

Installing WebSphere Business
Integration Express and Express Pluss
for Item Synchronization

Quick Start Guide

Adapter for JDBC User Guide
Adapter for JText User Guide
Adapter for JMS User Guide
Adapter for WebSphere MQ User
Guide

Adapter for XML User Guide
Adapter for Web Services User Guide
Adapter for iSoft/MQ User Guide
Adapter for e-Mail User Guide
Adapter for mySAP R/3 V.3.x
(Express Plus only)

Adapter for mySAP R/3 V.4.x
(Express Plus only)

Describes how to use Map Designer Express and Relationship Designer
Express for creating and modifying maps and relationships.

Describes how to use Business Object Designer Express to create business
object definitions, both manually and using an Object Discovery Agent
(ODA).

Provides an overview of the product and describes how to monitor and
operate WebSphere Business Integration Express for Item Synchronization.

Describes the installation process for WebSphere Business Integration Express
for Item Synchronization.

Describes the required procedures for configuring your WebSphere Business
Integration Express for Item Synchronization system.

Describes the configuration and business object development for the adapter
for JDBC.

Describes the configuration and business object development for the adapter
for JText.

Describes the configuration and business object development for the adapter
for JMS.

Describes the configuration and business object development for the adapter
for WebSphere MQ.

Describes the configuration and business object development for the adapter
for XML.

Describes the configuration and business object development for the adapter
for Web Services.

Describes the configuration and business object development for the adapter
for iSoft.

Describes the configuration and business object development for the adapter
for e-Mail.

Describes the configuration and business object development for the adapter
for mySAP R/3 V.3.x

Describes the configuration and business object development for the adapter
for mySAP R/3 V.4.x

Using the components

WebSphere Business Integration Express for Item Synchronization utilizes the
following types of components:

¢ Connectors

A connector provides the interface for interacting with an application that is
involved in data exchange. Your implementation will include a connector for
interacting with your UCCnet trading partner, and one or more connectors for
interacting with your ERP application, as well as a connector that enables email
for message handling.

Connectors are the primary component of adapters. Adapters are copied to your
system when you run the Installer. However, adapters do not become functional
until you configure the connector object for each adapter, as described later in
this guide. Where appropriate, adapters also include components called object
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discovery agents (ODAs). ODAs are used for creating business objects that are
used with the connector objects of each specific adapter.

Note: WebSphere Business Integration Express for Item Synchronization allows
you to use a maximum of four different adapters. One of these is the
eMail adapter, and the other three are the adapters you choose for
exchanging data with your UCCnet trading partner and for exchanging
data with your ERP application. You may configure and use a maximum
of three connector objects from any single adapter. For all adapters
together, a total of seven connectorobjects can be configured. See your
licensing agreement for details.

Business objects

Business objects are the message units that contain the data that is exchanged by
connectors. There are application-specific business objects, which carry data to
and from applications, and generic business objects, which are used in the
business processes performed by collaborations.

Collaboration objects

A collaboration object contains the business logic for performing operations
using the data contained in the business objects. You will create collaboration
objects from the provided collaboration templates, as described later in this
Guide.

Note: If you are using the Express Plus version of this product, the Process
Designer Express tool provides the optional capability to create additional
collaboration templates, as described in the Collaboration Development
Guide.

Maps
Maps are used to move data between the application-specific business objects

handled by connectors and their applications, and the generic business objects
used by the collaboration.

Configuration required after installation

This section provides a high-level overview of the configuration procedures
required after you have successfully installed WebSphere Business Integration
Express for Item Synchronization software:

[“Starting InterChange Server Express” on page 4

[“Starting System Manager” on page 5|

[Viewing delivered components” on page 6|

[“Creating the logging table” on page 7]

“Configuring the XML data handler and meta-objects” on page 9

“Configuring other business objects” on page 12|

“Developing business objects” on page 15|

“Modifying an existing business object” on page 17

“Configuring the connectors” on page 18

“Creating collaboration objects” on page 28|

“Deploying the solution” on page 40|

“Populating the relationships after deployment” on page 42|

[“Restarting ICS Express and starting your Adapter” on page 43
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Starting InterChange Server Express

InterChange Server Express can be started in either Design mode or Production
mode. Production mode is the default setting. You should change this setting before
you start InterChange Server Express the first time:

* In Production mode, InterChange Server Express validates the integration
component objects that you have imported into it as it starts, and it reports error
messages if any dependent objects are missing. Production mode is typically
used only after you have completely configured your implementation with all of
its required objects and are ready to deploy it.

* In Design mode, InterChange Server Express starts without validating
integration component objects or the dependencies between them. This allows
you to add additional components gradually, as you complete the configuration
of your system. You typically use Design mode until you believe your system is
ready for deployment.

Before you start InterChange Server Express the first time, you should set it to start
in Design mode, so that you can incrementally assemble your integration
components. To set the InterChange Server Express to start in Design mode, do
this:

* On a Windows system:

Add the -design parameter in the Target field of the Windows shortcut property
for InterChange Server Express before starting the server. For example:
C:\IBM\WebSphereltemSyncl\bin\start_server.bat -design

¢ On Linux:

At the command line, append the -design parameter to
ProductDir/bin/ics_manager

* On an 0S/400 system:

Add the -design parameter to the script that you use for starting InterChange
Server Express. On OS/400, add the parameter to the CL command that calls the
/QIBM/UserData/WebBIICS/bin/start_server.sh script.

To do so, edit the QWEBBISTR member in file QWEBBIICS in library
QWEBBIICS. Change this line:

DCL VAR(&DESIGN) TYPE(*CHAR) LEN(10) VALUE(' ')

to:
DCL VAR(&DESIGN) TYPE(*CHAR) LEN(10) VALUE('-design ')

Exit and Save. Then run the following CL Commands:

CRTCLPGM PGM(QWEBBIICS/QWEBBISTR) SRCFILE(QWEBBIICS/QWEBBIICS)
SRCMBR(QWEBBISTR) TEXT('WebSphere Business Integration Interchange
Server') OPTION(*GEN *NOSRC *NOXREF *NOSECLVL *NOSRCDBG *NOLSTDBG)
GENOPT (*NOLIST *NOXREF *NOPATCH) LOG(*JOB) ALWRTVSRC(*YES) REPLACE(*YES)
TGTRLS (*CURRENT) AUT(*EXCLUDE) SRTSEQ(*JOBRUN)LANGID(*JOBRUN)

And:

CHGOBJOWN OBJ (QWEBBIICS/QWEBBISTR) OBJTYPE(*PGM) NEWOWN(QWEBBIICS)
CUROWNAUT (*REVOKE)

After you have set the InterChange Server Express mode, do this to start
InterChange Server Express:

* On a Windows system:
Choose Start>Programs>IBM WebSphere Business Integration Express for Item
Sync>InterChange Server Express>InterChange Server Express.
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* On a Linux system:
First start the name server:
ProductDir/bin/PersistentNameServer.sh
Then start InterChange Server Express itself, in Design mode:
ProductDir/bin/ics_manager -start -design

* On an 0S/400 system:
From the command line, issue the CL command STRSBS QWEBBIICS/QWEBBIICS.
Alternatively, you can start it from an OS/400 shortcut on the Windows client,
by choosing Start>Programs>IBM WebSphere Business Integration Express for

Item Sync >iSeries Remote>InterChange Server Express>InterChange Server
Express.

When you are ready to deploy your implementation, you should return the mode
to Production mode. To do so, remove the -design parameter from the shortcut or
script or CL program that you use for starting InterChange Server Express.

Note: To do this on OS\400, follow the same procedure as you did for setting the
-design parameter, but use this value: DCL VAR(&DESIGN) TYPE(*CHAR)
LEN(10) VALUE(" ")

Starting System Manager

After you have finished running the Installer, you are ready to perform the final
tasks for setting up your business integration system.

1. Start System Manager

The System Manager interface is the starting point for most of the tasks needed
to complete the setup of your business integration system.

System Manager runs only on Windows. System Manager must be able to
connect to InterChange Server Express in order to deploy a project. For System
Manager to be able to connect to the InterChange Server Express running on
Linux or OS/400, you must modify the ORB properties in the file
ProductDir\bin\CWSharedEnv.bat

on Windows to specify the name server that InterChange Server Express uses
on your platform.

For OS/400, edit the CWSharedEnv file such that ORB_HOST points to the
0S/400 host on which InterChange Server Express is running, and ORB_PORT
specifies the port on which it is listening. Modify the CWSharedEnv file as
follows:

set ORB_PORT=PortNumber
set ORB_HOST=HostName or IP address

If a port number is not specified for the ORB_PORT, the port number defaults
to 14500.

For Linux, modify the CWSharedEnv file as follows:

set ORB_PORT=PortNumber
set ORB_HOST=HostName or IP address

Where HostName and PortNumber together specify which host the name
server is running on and which port it is listening on.

To begin using System Manager, do this:

a. If your InterChange Server Express platform is Windows or Linux, choose
Start > Programs > IBM WebSphere Business Integration for Item Sync
v4.3.1 > InterChange Server Express>InterChange Server Express.
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If your InterChange Server Express platform is OS/400, choose Start >
Programs > IBM WebSphere Business Integration for Item Sync v4.3.1
>iSeries remote> InterChange Server Express>IBM WebSphere InterChange
Server to start InterChange Server Express.

b. After InterChange Server Express has started, choose Start > Programs >
IBM WebSphere Business Integration for Item Sync Express. v4.3 > Tools >
Administrative > System Manager.

The System Manager environment displays.

Note: The first time you start up, you might see the Resource environment
displayed, instead of System Manager. If this happens, in the
Resource menu choose Window > Open Perspective > Other, and
choose System Manager from the Select Perspective dropdown list.

In the InterChange Server Express panel at the lower left portion of the
display, right-click on the displayed InterChange Server Express to verify
that it is connected. If it is not connected, you may need to register the
server (by choosing Server > Register Servers from the menu) and then
connect to it. By default, the server you are using is named WebSpherelCS
(QWEBBIICS on OS/400), and the username/password combination for
registering and connecting to it is:

admin/null

For more information regarding System Manager, see the following: User Guide
for WebSphere Business Integration Express and Express Plus for Item Synchronization,
and context-sensitive help for System Manager (activated when you press F1
within System Manager).

Viewing delivered components
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Most of the components necessary for implementing the ItemSync solution have
already been created for you and are imported into System Manager when you run
the Installer. You must configure some components, and you must create some
from templates that are provided.

After you have System Manager, you can view the integration components that the
Installer has already made available to you. To do so, in the upper left panel of
System Manager, expand the icon for the ItemSyncLibrary integration component
library, which resides under the Integration Component Libraries folder.

Three general types of content are provided for you in ItemSyncLibrary: business
objects, collaboration templates, and maps. To complete the setup of your business
integration system, you will modify or create some additional components, save
them in ItemSyncLibrary, and then create a System Manager user project that
contains the components. Then you will deploy that user project to InterChange
Server Express.

In addition to the components already visible in ItemSyncLibrary, several
connector configuration templates are provided to you. There is one template for
each of the adapters that you selected when you ran the Installer. Before you begin
the configuration steps that follow in this section, you should be certain that you
have run the Installer to copy to your system all the adapters that you will be
using. For a description of the roles that different adapters perform in an
implementation, see [Table 8 on page 18

To view the connector configuration templates that have been copied to your
system, do the following:



1. Open System Manager (for further information, see [“Starting System Manager”|
ﬁon page 5|)

2. In the System Manager window, expand the Integration Component Libraries
icon and highlight Connectors.

3. From the System Manager menu bar, click Tools > Connector Configurator
Express. The Connector Configurator Express window opens and displays a
New Connector dialog box.

4. The names of the connector templates that have been copied to your system
appear in the Template Name field. Because each connector template is
provided as a component of an adapter, you will see one template for each of
the adapters that you selected when you ran the Installer.

To use the connectors, you will need to configure and create connector
configuration objects. These tasks, and the configuration of some other necessary
components, are described in the steps that follow in this guide.

Importing additional components (optional)

If you are doing a non-default implementation, and have available to you
additional components in the form of .jar files, you will need to import the
components into System Manager in order to use them. Instructions for importing
files into System Manager are provided in the User Guide.

Creating the logging table

The WebSphere Business Integration Express for Item Sync system uses a database
table called audit_log to track events associated with UCCnet activities. For more
information on the use of this table, see the documentation forthe Collaboration for
UCCnet Item Synchronization.

To create the audit_log table, complete the following steps:
1. Create the audit_log table in the ICS repository.
For OS/400: Run the CL command CALL QWEBBIICS/QWEBBIIAL
For Windows and Linux: Use the script appropriate for your database server:
e DB2 Database Server
a. Move to the following directory:
ProductDir\collaborations\dependencies\UCCnet\db2
b. Start a DB2 session by entering the following command:
db2
C. At the prompt, enter the following comment
— On Windows:
db2 connect to SMB_DB
— On Linux:
db2 connect to SMB_DB user smbadmin using smbP4§$word

d. After you are connected, enter the following command to run the script
that creates the audit_log table:

db2 -f audit_log.sql
* Microsoft SQL Server

a. Start the Query Analyzer with Start > Programs > Microsoft SQL Server >
Query Analyzer. Query Analyzer displays the Connect to SQL Server
dialog.
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b. Make sure that the SQL Server authentication radio button is selected and
log into the ICS database server with the following default account
information:

Account: smbadmin

Password: smbP4$$word

Note: This account information is the default database user account that
the WebSphere Business Integration Express for Item Sync Installer
creates. If you have modified this account since it was created, use
the current account information.

C. Select the ICS repository database by selecting the SMB_DB database
from the dropdown menu in the Query Analyzer toolbar.

d. Load the audit_log.sql SQL script into the Query Analyzer with File >
Open. This script is located in the following directory:

ProductDir\collaborations\dependencies\UCCnet\mss
e. Run the audit_log.sql script with Query > Execute.
f. Leave Query Analyzer open for use in a later step.

2. Add the UCCnet property to the ICS configuration file, InterchangeSystem.cfg.
The audit_Tog feature requires that these properties exist and have values for it
to execute correctly.

a.

—h

Table 2. UCCnet subproperties

Create a backup copy of your InterchangeSystem.cfg file, which resides in
the ProductDir directory. A suggested name for the backup copy is:

InterchangeSystem orig.cfg
Bring up the following file in an editor:
ProductDir\samples\UCCnet\InterchangeSystem.UCCnet

Note: You can use a text editor or an XML editor to edit this file. However,
do not use the Notepad editor.

Copy the entire contents of this InterchangeSystem.UCCnet file into an

editor buffer. This file contains the XML definition of the UCCnet property

and its subproperties.

Bring up the InterchangeSystem.cfg file into the editor.

Move to the bottom of the InterchangeSystem.cfg file and paste the contents
of the editor buffer (the definition of the UCCnet property) into this file, just
before the </cw:ServerConfig> tag near the end of the file.

Modify the values for the UCCnet subproperties as shown in to
identify your InterChange Server Express repository.

UCCnet subproperty

Value

USER_NAME

PASSWORD

For a DB2 database on Windows or Linux: smbadmin

For OS/400, leave this value blank.
For a DB2 database on Windows or Linux: smbP4§$word

For OS/400, leave this value blank.
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Table 2. UCCnet subproperties (continued)

UCCnet subproperty

Value

DRIVER

DATA_SOURCE_NAME

TARGETHLQ

For a DB2 database on Windows:
database:COM.ibm.db2. jdbc.app.DB2Driver

For a DB2 database on OS/400:
com.ibm.db2.jdbc.app.DB2Driver

For a MicrosoftSQL Server database:

com.ibm.jdbc.sqlserver.SQLServerDriver
For a DB2 database on Windows:

jdbc:db2:SMB_DB
For OS/400 DB2UDB, use the following URL: jdbc:db2:MyHost/QWEBBIICSD

where MyHost is the name of the OS/400 host on which InterChange Server
Express is running

For a Microsoft SQL Server database:

jdbc_ibm.crossworlds:sqlserver://machine_name:1433;
DatabaseName=SMB_DB

(where machine_name is the name of the host machine on which your ICS
repository resides)

On OS/400 systems, set this value to a directory in the root file system on the
0S/400. Recommended: /QIBM/UserData/WebBIICS/

g. Save the InterchangeSystem.cfg file and exit the editor.

Note: The new UCCnet properties do not take effect until you reboot your
InterChange Server.

Configuring the XML data handler and meta-objects

Processing of UCCnet XML messages requires meta-objects for the Data Handler
for XML (the XML data handler). This data handler uses a meta-object, which is a
kind of business object, to hold its configuration information. In addition, each of
the connectors that interacts with UCCnet requires a meta-object.

Default configuration files for these meta-objects are provided for you in System
Manager. The default meta-objects are pre-set with default settings for use with a
typical implementation. However, you must complete the configuration of the
meta-objects by reviewing or setting certain values that are specific to your
implementation, as described in the following steps.

The following steps describe how to complete configuration of the meta-objects.
For each of these, you will launch Business Object Designer and open the business
object definition for the meta object that you are viewing or configuring. (If the
New Business Object Definition dialog appears when you launch Business
Designer, click Cancel.):

1. Configure the meta-object for the UCCnet version of the XML data handler,
MO_DataHandler_UCCnetXMLConfig, by modifying the meta-object to specify
either DTD -support or schema-document support for communication with
UCCnet, as described in the attributes inTable 3 on page 10| :
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Table 3. Default values for properties in MO_DataHandler_UCCnetXMLConfig

Attribute name

Default value

BOPrefix

DTDPath

For DTD support:
UCCnetDTD

For schema-document support:

UCCnetXSD

Full path to the XML-structure document: For DTD XML
definition type:

Envelope.dtd

For schema-document support XML definition type:
Envelope.xsd

The Envelope structure document is available from the UCCnet
web site. To download these files, you must have a valid
UCCnet user ID and password.

After you have set the values, close the MO_DataHandler_UCCnetXMLConfig
meta-object with File > Close. However do not exit Business Object Designer.

Optionally, open the meta-object for the UCCnet XML configuration,
MO_DataHandler_UCCnet_envelope, and view the values, which have been
pre-set.

Open the meta-object for JTextRWL XML configuration,
MO_JTextRWLConnector_Default, and view the values, which have been
pre-set. Verify that the values set for OutputDir, ArchiveDir, and EventDir are
the directories that you are using in your implementation. The following table
describes the directory values:

Table 4. Default property values for MO_JTextRWLConnector_Default

Attribute name

Default value

QutputDir

ArchiveDir

Name of the directory where the JTextRWLConnector is to write the XML files it
generates. For example:

C:\IBM\WebSphereltemSync\UCCnet\JTextRWL\out

For OS/400, use the path to the directories on the OS/400 host on which InterChange
Server Express is running. For example,

/QIBM/UserData/Webbiics/UCCNet/JTextRWL/out

If the output directory you specify does not already exist, create it.
Name of the directory where the JTextRWLConnector archives events (XML files). For
example:

C:\IBM\WebSphereltemSync\UCCnet\JTextRWL\archive

For OS/400, use the path to the directories on the OS/400 host on which InterChange
Server Express is running. For example,

/QIBM/UserData/Webbiics/UCCNet/JTextRWL/archive

If the archive directory you specify does not already exist, create it.
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Table 4. Default property values for MO_JTextRWLConnector_Default (continued)

Attribute name

Default value

EventDir

Name of the directory from which the JTextRWLConnector obtains input events (XML
files). For example:

C:\IBM\WebSphereItemSync\UCCnet\JTextRWL\event

For OS/400, use the path to the directories on the OS/400 host on which InterChange
Server Express is running. For example,

/QIBM/UserData/Webbiics/UCCNet/JTextRWL/event

If the event directory you specify does not already exist, create it.

4. If you are using the JTextISoftconnector, your implementation must also include

the MO_]JTextISoftConnector_Default meta-object. This meta-object is not
necessary if you are using the iSoftconnector (see [Table 8 on page 18for a
description of the roles of the connectors). If you are using the
JTextISoftconnector, open the meta-object, and view the values, which have
been pre-set. Verify that the values set for OutputDir, ArchiveDir, and EventDir
are the directories that you are using in your implementation. The following
table describes the directory values:

Table 5. Default property values for MO_JTextlSoftConnector

Attribute name

Default value

QutputDir

QutputExt
ArchiveDir

EventDir

EventExt
EndBODelimiter

Name of the directory where the JTextISoftConnector is to write the XML files it
generates. For example:

C:\IBM\WebSphereltemSync\UCCnet\JTextISoft\out

For OS/400:
/QIBM/UserData/Webbiics/UCCnet/JTextISoft/out

If the output directory you specify does not already exist, create it.
xml

Name of the directory where the JTextISoftConnector archives events (XML files). For
example:

C:\IBM\WebSphereItemSync\UCCnet\JTextISoft\archive

For OS/400:
/QIBM/UserData/Webbiics/UCCnet/JTextISoft/archive

If the archive directory you specify does not already exist, create it.
Name of the directory from which the JTextISoftConnector obtains input events (XML
files). For example:

C:\IBM\WebSphereltemSync\UCCnet\JTextISoft\event

For OS/400:
/QIBM/UserData/Webbiics/UCCnet/JTextISoft/event

If the event directory you specify does not already exist, create it.
xml

EOF
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Configuring other business objects

In addition to the creation and configuration of business objects for the XML

data-handler meta-objects, you also need to configure business objects for the

following components:

* iSoftConnector (only if you are using the Windows platform and exchanging
messages with UCCnet through an AS2/EDIINT interface protocol)

¢ EMailConnector

Configuring a business object for iSoftConnector

If you are exchanging messages with UCCnet through an AS2/EDIINT interface
protocol (using the Windows platform), you must use a meta-object called
MO_ISoftAdapterConfig for the iSoft connector.

A default sample of this meta-object is copied to your system during installation.
Open the meta-object in Business Object Designer to verify that it has the correct
attributes for your implementation. Review the attributes described in

Table 6. Attributes in MO_ISoftAdapter_Config

Attribute name Type Key Application-specific information

Default String Yes The output queue, where messages derived from the business
object definitions listed in this meta-object are delivered. For
example:

UCCnet_envelope_
Create

OutputQueue=queue://crossworlds. queue.manager/
outbox_queue_name; DataEncoding=Text

(where outbox_queue_name identifies where these messages
are delivered)

The output queue specified in this Default attribute applies to
all business-object conversions.

String No If the application-specific information that you provided for
the Default attribute (above) is insufficient to identify the
business-object configuration properties for the
UCCnet_envelope business object, you can provide any
additional information that might be required here. For more
information about the format of this application-specific
information, see the Adapter Guide for iSoft.
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Configuring a business object for EMailConnector

The EmailConnector handles messages for events that occur during the execution
of the Item Sync collaboration. It uses a business object definition called
EmailNotification to hold its configuration information.

To configure the EmailConnector, complete the following steps:

1. Bring up the EmailNotification business object definition in Business Object
Designer. For information on how to edit an existing business object definition,
see [“Developing business objects” on page 15/

2. Set the Default Values for the following attributes to identify where the Item
Sync collaboration directs email messages during its execution.



Table 7. Default property values for EmailNotification

Attribute name Default value Required
RecipientName Email address of recipient Yes. For information on how to specify the
message recipients, see the Adapter Guide for
e-Mail.
FromAddress Email address of undelivered No
messages

3. Save the business object definition to the ItemSyncLibrary project with the File
> Save menu option.

4. Close the EmailNotification business object definition with File > Close.
However, do not exit Business Object Designer.

Creating the ERP-source components

Your item information originates from your Enterprise Resource Planning (ERP)
application. As the first step to sending this item information to UCCnet, an
ERP-source connector receives information from your ERP application and takes
the following steps:

1. It formats this information into the appropriate application-specific business
object. For this step to be possible, a business object definition for this
application-specific business object must exist and must define the item
information that the ERP-source connector receives.

2. It converts the data in the application-specific business object to its equivalent
format in the generic business object, ItemBasic. For this step to be possible, a
map must exist to define the data transformations necessary.

Note: As part of creating ERP-source components, you must also create an
ERP-source connector. For more information, see [Configuring the|
[ERP-source connector” on page 25.|

Creating ERP-source business objects

The ERP-source business object is an application-specific business object that
contains the item information your ERP application needs sent to UCCnet. For the
ERP-source connector to create such a business object, it must be able to locate an
associated business object definition, which the connector uses as a template for
the business object creation. Therefore, as part of the Item Sync configuration
process, you must create business object definitions to represent the item
information that your ERP application must send to UCCnet.

To create a business object definition, use the Business Object Designer tool. This
tool provides a graphical interface that assists you in naming the business object
definition and defining its attributes. When you design your ERP-source business
object definition, you must determine which item information needs to be sent to
UCCnet. To assist in this determination, you can examine the information in the
generic item-information business object, ItemBasic.

The basic steps to creating the business object definition for your

application-specific business object are as follows:

1. Launch Business Object Designer to create a new business object definition. In
System Manager, you can right-click on the Business Objects folder under the
ItemSyncLibrary project. Alternatively, you can select the Tools > Business
Object Designer menu option.
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2. Specify the name of the business object definition in Business Object Name
field and click OK. Business Object Designer displays a template for you to
define the attributes of the business object definition.

3. Define the required attributes, including their names, types, and any
application-specific information. One attribute with the business object
definition must be designated as the key, whose value contains information to
uniquely identify one business object of this type from another.

4. Save the business object definition with File > Save.

5. If your business object definition requires child business objects, repeat these
steps to define each of the child business objects.

For a more complete description of Business Object Designer and how to create a
business object definition, see [“Developing business objects” on page 15.]

Creating ERP-source maps

Once the ERP-source connector has created the application-specific business object,
the item information is ready to be sent to InterChange Server Express. There, any
application-specific formats of data in this business object are converted to the data
format used by the associated generic business object, ItemBasic. It is the generic
business object that InterChange Server Express routes to various components of
the Item Sync system. To provide this data conversion, you must create a map that
describes the data transformations necessary to convert the data from any
application-specific formats to their generic equivalents.

To create a map, use the Map Designer tool. This tool provides a graphical
interface that assists you in naming the map and defining its transformation. When
you design your ERP-source map, you must determine which item information is
currently in an application-specific format; that is, which data is in a format
different from its equivalent in the generic business object. To assist in this
determination, you can examine the information in the generic item-information
business object, ItemBasic.

The basic steps to creating the map from your application-specific business object
to the ItemBasic generic business object are as follows:

1. Launch Map Designer to create a new map. In System Manager, you can
right-click on the Maps folder under the ItemSyncLibrary project. Alternatively,
you can select the Tools > Map Designer menu option.

2. Select ItemSyncLibrary as the project in which to store the map and click Next.

3. Choose the name of the business object definition that is the source for the map
and Click Next. This source business object definition is the name of the
application-specific business object that holds your ERP item information.

4. Choose the name of the business object definition that is the destination for the
map and Click Next. For the top-level ERP-source map, the destination
business object definition is ItemBasic.

5. In the Save map dialog, take the following steps:

a. Specify a name for the map in the Name field. Map names usually identify
both the source and destination business objects in the following format:
CwSource_to_CwDestination

where Source and Destination are the names of your source and destination
business object definitions, respectively. For example, if your
application-specific business object was named JDBC_ERPItem, the
associated ERP-source map name could be:



CwJDBC_ERPItem to_CwItemBasic

b. Make sure that the Mapping Direction box has the Application-Specific to
Generic radio button selected.

c. Click Finish. Map Designer displays the working area, with your source
business object definition on the left and your destination business object
definition (ItemBasic) on the right.

d. To define the data transformations between attributes in the source and
destination business objects, you can use the basic transformations (such as
Move, Split, and Join). You can also perform transformations on dates and
times. If you need to perform a transformation for which there is no
existing transformation, you can define a custom transformation.

e. When you have completed the definition of transformations, save the map
to the ItemSyncLibrary project with File > Save > To Project.

—h

Answer Yes to the prompt that asks if you want to compile the map.

g. If your application-specific business object definition contains child business
objects, you must create a map for each of the child business objects. Repeat
these steps to define maps for each of the child business objects. Map
names for child business objects usually start with the "Sub” prefix to
indicate a submap.

For a more complete description of Map Designer and how to create a map, see
the Map Development Guide.

Developing business objects

This section provides a roadmap of the basic steps for creating a business object
definition. For complete details about developing a business object definition, see
the Business Object Development Guide.

Creating a business object definition

In the WebSphere business integration system, information sent or received
between components is packaged in the form of a business object. For data that is
transferred between a connector and an integration broker, you design
application-specific business objects that model the appropriate application entities.
Application-specific business objects are modeled during design-time as business
object definitions, which are stored in the business integration system, specifically in
the System Manager Integration Component Library (ICL). At runtime, data is
populated in a business object instance (often just called a “business object”) that is
based on the proper definition, and is moved through the business integration
system as dictated by its routing and business logic rules.

For details about the business object requirements of your specific adapter, refer to
your adapter’s user guide.

There are two ways to create a business object definition:

¢ Manually—Useful when creating a simple business object, or when modifying a
definition generated by an Object Discovery Agent. Business Object Designer
Express provides a graphic interface for manually creating a business object
definition.

* Using an Object Discovery Agent—Useful when creating an application-specific
business object. The Object Discovery Agent examines specified entities in the
application, “discovers” the elements of those objects that correspond to business
object attributes and the properties of each attribute, and generates the business
object definition.
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Creating a business object manually

1. Launch Business Object Designer Express from System Manager, using a
Windows shortcut, or from another development tool. For details, see Business
Object Development Guide.

2. From the File menu, select New. Business Object Designer Express displays the
New Business Object dialog.

3. Enter the name for the new business object definition.

4. Click OK. Business Object Designer Express displays the business object
definition dialog.

5. Add attributes for each piece of information in the business object.

6. Click the General tab of the business object definition dialog to display the
screen in which you specify the verbs.

7. Specify the verbs that this business object will support. These verbs represent
the triggering events that the business object sends to the integration broker.

8. When you finish defining the business object, click File > Save from the menu
bar to save your changes to the ICL.

Using an Object Discovery Agent to create a business object
definition

An Object Discovery Agent (ODA) is an optional component of an adapter. When
you install a pre-defined adapter that has an ODA, its ODA is installed
automatically. Business Object Designer Express provides a graphical interface in
the form of a wizard, called Business Object Wizard, to interact with the ODA. The
purpose of Business Object Wizard is to display a series of dialogs to the user.
These dialogs obtain information from the user that the ODA needs to generate the
business object content. The ODA is the component that “discovers” objects in the
data source and generates the content. The ODA receives information that the user
provides in the dialogs of Business Object Wizard. It then sends information (such
as the generated content) to the ODA runtime, the intermediary component
between Business Object Wizard and the ODA.

Before using an ODA: Before you run an ODA, verify that the following steps
have occurred (for details, see Business Object Development Guide):

* The system startup files are available and correct.
* The ODA has been launched.
— On Windows: Run start_srcDataNameODA.bat.
— On Linux: Run start_srcDataNameODA.sh.

— On OS/400: Use the short cuts provided on the Windows client. Click the
ODA shortcut to start the ODA, Start>Programs>IBM WebSphere Business
Integration Express for Item Sync v4.3.1 >iSeries
remote>Adapters>0Object Discovery Agents>0DAname. Alternatively on OS/400,
you can use the start_srcDataNameODA.sh script in a QShell environment.

* Business Object Designer Express has been launched.

Using the ODA to create business object definitions:
1. Open Business Object Designer Express.
2. From the File menu, click the “New Using ODA” menu item.

Business Object Designer Express invokes Business Object Wizard, which
displays the first dialog in the wizard, Select Agent.

3. Select the ODA to which Business Object Wizard connects.
4. Click Next. Business Object Wizard attempts to connect to the specified ODA.



5. Once Business Object Wizard is connected to the ODA, it displays the second
wizard dialog, Configure Agent.

6. Specify ODA configuration values or select a profile to display previously
saved values.

7. Click Next. Business Object Wizard displays the third wizard dialog, Select
Source.

8. Select objects in the source-code hierarchy for which you want the ODA to
generate business object definitions.

9. After you select the source nodes for which business object definitions are to
be generated, click Next. Business Object Wizard displays the fourth wizard
dialog, which allows you to confirm your selection of source nodes.

10. After confirming your selection, click Next. Business Object Wizard displays
the wizard’s fifth screen, Generating Business Objects.

After the ODA completes the generation of business object definitions,
Business Object Wizard displays the final dialog in the wizard, Save Business
Objects.

11. Click Finish to save the business object definitions to the ICL-based project

For more detailed information, see the following:WebSphere Business Integration
Express for Item Synchronization Business Object Development Guide.

Modifying an existing business object

Some application-specific business objects are provided to you. In some
implementations, you may need to modify them.

You can open a business object definition provided by the adapter and modify it as
needed using Business Object Designer Express. You can also modify any business
object definition you have created. New objects are created in Business Object
Designer Express, with or without the assistance of the ODA. To modify an
existing object, use Business Object Designer Express directly (the ODA cannot be
used to modify an existing business object).

To modify a business object definition:

1. From the list of business object definitions in the project, highlight the name of
the definition you want to open.

2. To select multiple business object definitions in the project, do one of the
following:

* When selecting consecutive names, select the first name and, while pressing
the Shift key, click the last name.

* When selecting non-consecutive names, press the Ctrl key and click as you
select each name.

3. After selecting the definitions to be opened, right-click and then click Open.

Business Object Designer Express displays a window for each selected
definition.

4. Edit the business object definition as needed. For details about the business
object definitions provided with your adapter and the modifications you make
to each, see the documentation of the specific adapter.

5. Save the business object definition:

e If the project is ICL-based, the business object definition is saved in the
project where it originated.
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* If the project is local, the business object definition is saved to its existing file
(where it was saved when it was created).

Configuring the connectors

Connector Configurator Express allows you to configure the connector component
of your adapter for use with InterChange Server Express.
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You use Connector Configurator Express to:

* Create a connector configuration file -- you must create one configuration file for
each required connector.

* Set properties in a configuration file -- you may need to modify the default
values that are set for properties in this file. You must also specify supported
business object definitions and, optionally, maps for use with the Item
Synchronization Collaboration.

Use Connector Configurator Express to create this configuration file and to modify

its settings.

Creating required connector configuration files

Note: WebSphere Business Integration Express for Item Synchronization allows
you to use a maximum of four different adapters. One of these is the eMail
adapter, and the other three are the adapters you choose for exchanging
data with your UCCnet trading partner and for exchanging data with your
ERP application. You may configure and use a maximum of three connector
objects from any single adapter. For all adapters together, a total of seven
connectorobjects can be configured. See your licensing agreement for details.

The following table describes the required connector configuration files for a
typical implementation of WebSphere Business Integration Express for Item

Synchronization:

Table 8. Connectors in the Item Sync solution

Connector object that you
configure

Required Installer component
selections

Role of the configured
connector

JTextRWLConnector,
based on the JText
connector template

Adapter for JText (installed by
default when you choose the
Typical package)

Inputs a worklist request to
UCCnet. This connector is
required for all
implementations.

iSoftConnector, based on
the iSoft connector
template

Adapter for iSoft

Exchanges messages with
UCCnet . Use this connector
only if you are on the
Windows platform and you
intend to use an AS2/EDIINT
interface protocol to exchange
messages with UCCnet. This
connector can be used on
Windows platforms only. For
0S/400 and Linux platforms,
use the JTextISoftConnector.




Table 8. Connectors in the Item Sync solution (continued)

Connector object that you
configure

Required Installer component
selections

Role of the configured
connector

JTextISoftConnector, based
on the JText connector
template

Adapter for JText

Exchanges messages with
UCCnet. Use this connector if
you intend to use UCCNet
Command Line Utility (CLU)
to communicate with the iSoft
Peer-to-Peer Agent. This
connector can be used on
Windows, Linux, and OS/400
platforms.

JText, JMS, JDBC, XML,
Web Services, WebSphere
MQ, or mySAP

One of the following adapters:

* Adapter for JText

* Adapter for J]MS

* Adapter for JDBC

* Adapter for XML

» Adapter for Web Services

* Adapter for WebSphere MQ

* Adapter for mySAP mySAP
R/3 V.3.x

* Adapter for mySAP mySAP
R/3 V.4.x

Exchanges messages with your
ERP application. You must
configure at least one of these
connectors.

EmailConnector Adapter for e-Mail Yes, if your UCCnet Item
Synchronization collaboration
uses the "notify by email”
feature

PortConnector None Yes

Use Connector Configurator Express, launched from System Manager, to create
these files. For information on how to launch, run, and use this tool, see the
Connector Configurator Express appendix in your adapter user guide.

Configuring the JTextRWLConnector
The JTextRWLConnector is the input connector for a UCCnet_requestWorklist
collaboration object. The UCCnet_requestWorklist collaboration object passes a
UCCnet worklist request to UCCnet from a filesystem folder. To poll for the
worklist, a scheduler operation (which the operating system performs) must be
configured to periodically drop a fresh copy of the request XML file into the event
file-system folder for the JTextRWLConnector.

1. To create the JTextRWLConnector, complete the following steps:
a. In the Windows taskbar, right-click Start and select Open All Users

b. Navigate to the folder on your system that contains the installed adapters:
Programs > IBM WebSphere Business Integration Express for Item Sync
v4.3 > Adapters > Connectors.

On OS5/400: Programs > IBM WebSphere Business Integration Express for
Item Sync v4.3.1 > iSeries remote > Adapters > Connectors.

c. Copy the startup shortcut for the JText connector (JText Connector) and
rename it to: JTextRWL Connector

d. Right-click the new JTextRWL connector’s startup shortcut and select

Properties
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e.

Click the Shortcut tab, edit the Target field to set the first command-line
argument to JTextRWL. The following line shows the JText target before you
edit the argument:

ProductDir\connectors\JText\start JText.bat JText WebSphereICS

For example, if WebSphere Business Express for Item Sync is installed in
your C: partition, then the initial text for the new startup shortcut would be:
C:\IBM\WebSphereItemSync\connectors\JText\start_JText.bat JText WebSphereICS
For OS/400:

C:\IBM\WebSphereItemSync\scripts\runCommand.bat start_adapter
JText/start_JText.sh JText QWEBBIICS QWEBBIJTC

In this case, you would change the shortcut so it reads:

C:\IBM\WebSphereItemSync\connectors\JText\
start_JText.bat JTextRWL WebSphereICS

For OS/400:

C:\IBM\WebSphereItemSync\scripts\runCommand.bat start_adapter
JText/start_JText.sh JTextRWL QWEBBIICS QWEBBIJTC

f. Click OK.

2. Create the connector configuration file for the JTextRWLConnector, using
Connector Configurator Express, as described below. (For more information on
using Connector ConfiguratorExpress, see the Connector Configurator Express
appendix in your adapter user guide.)

a. Open System Manager (for further information, see |“Starting System|

b.

[Manager” on page 5)

In the System Manager window, expand the Integration Component
Libraries icon and highlight Connectors.

From the System Manager menu bar, click Tools > Connector Configurator
Express. The Connector Configurator Express window opens and displays a
New Connector dialog box.

In the New Connector dialog, specify JTextRWLConnector in the Name
field. To select the JText connector template, highlight the entry for JText in
the displayed list of available templates. The properties from the JText
connector template willdisplay in the Property Template Preview section.
When you click OK, Connector Configurator Express displays the
configuration tabs.

In the Standard Properties tab, verify that the ApplicationName property is
set to JTextRWLConnector.

f. In the Supported Business Objects tab, add the business object definitions

listed in

Table 9. Supported business objects for JTextRWLConnector

Agent support

Business object definition required?
MO_JTextRWLConnector_Default Yes
MO_DataHandler_UCCnet_envelope Yes
The UCCnet envelope: Yes

* For DTD XML definition type: UCCnetDTD_envelope

* For schema-document support XML definition type:
UCCnetXSD_envelope

UCCnetGBO_envelope No

g.

Save the connector configuration file to the ItemSyncLibrary project, using
the File > Save > To Project menu option.



h. In the Associated Maps tab, add the maps listed in [Table 10| to the specified
business object definitions.

Table 10. Associated maps for JTextRWLConnector

Business object definition Name of map
UCCnetDTD_envelope UCCnetDTD_envelope_to_UCCnetGBO_envelope
UCCnetXSD_envelope UCCnetXSD_envelope_to_UCCnetGBO_envelope
UCCnetGBO_envelope For DTD XML definition type:
RouterMap_UCCnetGBO_envelope_to_UCCnetDTD_
envelope
For schema-document XML definition type:
UCCnetGBO_envelope_to_UCCnetXSD_envelope

3. Save the connector configuration file to the ItemSyncLibrary ICL project with
File > Save > To Project. Close Connector Configurator Express.

Configuring the iSoft Connector

The iSoftConnector can be used only on the Windows platform. On OS/400 and
Linux platforms, the JTextISoft connector is used instead. The instructions that
follow for configuring the iSoft Connector assume that you included the iSoft
connector among your selections when you ran the Installer.

The iSoft Connector connector exchanges messages with UCCnet through an
AS2/EDIINT interface protocol. You need to create or modify a connector
configuration file for the iSoftConnector, using Connector Configurator Express,
and configure it to include the appropriate business objects.

To create the iSoftConnector, complete the following steps:

1. Create the connector configuration file for the iSoftConnector, using Connector
Configurator Express, as described below (for more information about using
this tool, see the Connector Configurator Express appendix in your adapter
guide).

a. Start System Manager, and choose Tools>Connector Configurator Express.

b. In the Connector Configurator Express dialog, choose File>New>Connector
Configuration.

C. In the New Connector dialog, specify iSoftConnector in the Name field. To
select the iSoft connector template, highlight the entry for iSoft in the
Template Name table. The properties from the iSoft connector template
display in the Property Template Preview section. When you click OK,
Connector Configurator Express displays the configuration tabs.

2. In the Connector-Specific Properties tab of Connector Configurator Express,
verify that the connector-specific properties are set as shown in [Table 11

Table 11. Connector-specific properties for iSoftConnector

Connector-specific property Value

ArchiveQueue Queue to which copies of successfully processed
messages are sent. For example:

queue://crossworlds.queue.manager/
MQCONN.ARCHIVE

Channel WebSphere MQ server connector channel for
your iSoft Peer-to-Peer Agent queue manager
ConfigurationMetaObject MO_ISoftAdapterConfig
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Table 11. Connector-specific properties for iSoftConnector (continued)

Connector-specific property

Value

DataHandlerConfigMO
DefaultVerb

ErrorQueue

HostName

InputQueue

InProgressQueue

Port

ReplyToQueue

UnsubscribedQueue

UseDefaults

MO_DataHandler_UCCnet_envelope

Create

Note: If this connector-specific property does not
appear in the list, add it.

Queue to which messages that could not be
processed are sent. For example:
queue://crossworlds.queue.manager/

MQCONN. ERROR

The name of the host on which the iSoft
Peer-to-Peer Agent WebSphere MQ queue
manager is running

List of queues that the connector polls for new
messages. Queue names are delimited with a
semicolon (;). For example:
queue://crossworlds.queue.manager/
MQCONN.IN1;
queue://crossworlds.queue.manager/MQCONN. IN2
Queue where messages are held during
processing. For example:
queue://crossworlds.queue.manager/
MQCONN.IN_PROGRESS

The port established for the WebSphere MQ
Listener of the iSoft Peer-to-Peer Agent’s queue
manager

Queue to which replies are sent. For example:
queue://crossworlds.queue.manager/
MQCONN.REPLY

Queue to which messages that are not
subscribed are sent. For example:
queue://crossworlds.queue.manager/
MQCONN.UNSUBSCRIBED

True

Note: If this connector-specific property does not
appear in the list, add it.

3. In the Supported Business Objects tab, add the business object definitions

listed in [Table 12

Table 12. Supported business objects for iSoftConnector

Business object definition

Agent support
required?

The UCCnet envelope:

* For DTD XML definition type: UCCnetDTD_envelope
* For schema-document support XML definition type:

UCCnetXSD_envelope

Yes

4. Save the connector configuration file to the ItemSyncLibrary project with the
File > Save > To Project menu option.

5. In the Associated Maps tab, add the maps listed in [Table 13 on page 23| to the
specified business object definitions.




Table 13. Associated maps for iSoftConnector

Business object definition

Name of map

UCCnetGBO_envelope

ItemBasic

For DTD XML definition type:

RouterMap_UCCnetGBO_envelope_to_
UCCnetDTD_envelope

For schema-document XML definition type:

UCCnetGBO_envelope_to
_UCCnetXSD_envelope

For DTD XML definition type:

RouterMap_CwItemBasic_to_
UCCnetDTD_envelope

For schema-document XML definition type:

CwItemBasic_to_UCCnetXSD_envelope_
registerCommand_itemAddChange

6. Save the connector configuration file to the ItemSyncLibrary ICL project with
File > Save > To Project. Close Connector Configurator Express.

For further information, see the Adapter for iSoft Peer-to-Peer Agent User Guide.

Configuring the JTextlSoftConnector

The JTextISoft connector is used for exchanging messages with UCCnet. The
JTextISoft connector is required for the OS/400 and Linux platforms. For Windows
platforms, either the JTextISoft connector or the ISoft connector can be used. The
JTextISoft connector uses the UCCnet Command Line Utility (CLU) to

communicate with UCCnet.

To configure and use the JTextISoftConnector, complete the following steps:

1. Create the Windows shortcut to start up this connector, as follows:
a. In the Windows taskbar, right-click Start and select Open All Users
b. Navigate to the folder on your system that contains the installed adapters:
Programs > IBM WebSphere Business Integration Express for Item Sync

v4.3 > Adapters > Connectors. On OS/400: Programs > IBM WebSphere
Business Integration Express for Item Sync v4.3 > iSeries remote >

Adapters > Connectors

c. Copy the startup shortcut for the JText connector (JText Connector) and
rename it to: JTextISoftConnector

d. Right-click the new JTextISoft connector’s startup shortcut and select

Properties

e. Click the Shortcut tab, edit the Target field to set the first command-line
argument to JTextISoft. The following line shows the JText target before you

edit the argument:

ProductDir\connectors\JText\start_JText.bat JText WebSphereICS

For OS/400:

ProductDir\scripts\runCommand.bat

start_adapter JText/start_JText.sh JText QWEBBIICS QWEBBIJTC

where ProductDir is the name of the directory in which WebSphere Business
Integration Express for Item Sync is installed. For example, if WebSphere
Business Express for Item Sync is installed in your C: partition, then the
initial text for the new startup shortcut would be:
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f.

C:\IBM\WebSphereItemSync\connectors\JText\
start_JText.bat JText WebSphereICS

For OS/400:

C:\IBM\WebSphereItemSync\scripts\runCommand.bat
start_adapter JText/start_JText.sh JText QWEBBIICS QWEBBIJTC

In this case, you would change the shortcut so it reads:

C:\IBM\WebSphereItemSync\connectors\JText\
start_JText.bat JTextISoft WebSphereICS

For OS/400:

C:\IBM\WebSphereItemSync\scripts\runCommand.bat
start_adapter JText/start JText.sh JTextISoft QWEBBIICS QWEBBIJTC

Click OK.

2. Create the connector configuration file for JTextISoftConnector, as described
below. (For more information on using Connector ConfiguratorExpress, see the
Connector Configurator Express appendix in your adapter user guide.)

a. Open System Manager (for further information, see [“Starting System|

b.

f.

[Manager” on page 5)

In the System Manager window, expand the Integration Component
Libraries icon and highlight Connectors.

From the System Manager menu bar, click Tools > Connector Configurator
Express. The Connector Configurator Express window opens and displays a
New Connector dialog box.

In the New Connector dialog, specify JTextISoftConnector in the Name
field. To select the JText connector template, highlight the entry for JText in
the displayed list of available templates. The properties from the JText
connector template willdisplay in the Property Template Preview section.
When you click OK, Connector Configurator Express displays the
configuration tabs.

In the Standard Properties tab, verify that the ApplicationName property is
set to JTextISoftConnector.

In the Supported Business Objects tab, specify a value for the UCCnet
envelope, to indicate support for either DTD or schema-document definition
type: [Table 14

Table 14. Specifying definition type in business objects for JTextlSoftConnector

Agent support

Business object definition required?

The UCCnet envelope: Yes

* For DTD XML definition type: UCCnetDTD_envelope

* For schema-document support XML definition type:
UCCnetXSD_envelope

g.

Save the connector configuration file to the ItemSyncLibrary project with the
File > Save > To Project menu option.

In the Associated Maps tab, add the maps listed in [Table 15 on page 25|to
the specified business object definitions.




Table 15. Specifying definition type in associated maps for JTextlSoftConnector

Business object definition Name of map

UCCnetGBO_envelope For DTD XML definition type:

RouterMap_UCCnetGBO_envelope_to_
UCCnetDTD_envelope

For schema-document XML definition type:

UCCnetGBO_envelope_to_UCCnetXSD_envelope
ItemBasic For DTD XML definition type:

RouterMap_CwItemBasic_to_
UCCnetDTD_envelope

For schema-document XML definition type:

CwItemBasic_to_UCCnetXSD_envelope_
registerCommand_itemAddChange

i. Save the connector configuration file to the ItemSyncLibrary ICL project with
File > Save > To Project. Close Connector Configurator Express.

Configuring the ERP-source connector

The ERP-source connector is the input connector for the UCCnet_ItemSync
collaboration object. This connector receives information from your Enterprise
Resource Planning (ERP) application and formats this information in the
appropriate application-specific business object. It converts this application-specific
business object to an ItemBasic business object, passing the ItemBasic business
object to the UCCnet_ItemSync collaboration. The UCCnet_ItemSync collaboration
delivers the ItemBasic business object to UCCnet through either the iSoftConnector
or JTextISoftConnector.

You choose the ERP-source connector based on the format that application-specific
information can be obtained from your ERP application. WebSphere Business
Integration Express for Item Sync provides the following adapters for use as
possible ERP-source connectors:

Adapter Purpose

Adapter for JDBC Handles application-specific information
using the Java Database Connectivity (JDBC)
and converts between this format and an
application-specific business object

Adapter for JMS Handles application-specific information
using the Java Message Service (JMS) and
converts between this format and an
application-specific business object

Adapter for JText Handles application-specific information in
file-system files and converts between this
format and an application-specific business
object

Adapter for WebSphere MQ Handles application-specific information
using WebSphere MQ queues and converts
between this format and an
application-specific business object

Adapter for XML Handles application-specific information in
XML and converts between this format and
an application-specific business object
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Adapter Purpose

Adapter for Web Services Handles application-specific information in
SOAP and converts between this format and
an application-specific business object

Once you have selected the appropriate ERP-source connector, you must create and

configure it with the following steps:

Note: These steps assume that you have already created the application-specific
business object definition and map for your ERP-source item information, as

described in|“Creating the ERP-source components” on page 13/If you have

not yet completed these steps, you must do so before continuing with the

creation of the ERP-source connector.

1. Create the connector configuration file for the ERP-source connector using
Connector Configurator Express. For general information on how to use this
tool to create a connector configuration file, see the Connector Configurator

Express appendix in your adapter guide.

a. In the New Connector dialog, specify the name of your ERP-source
connector in the Name field in the form ERPSourceConnector, where
ERPSource can either be the literal string "ERPSource” or a string that
identifies the format or source application of your ERP-source information.
For example, if your ERP item information is obtained using the JDBC
interface, you could use the JDBC connector and name this connector

JDBCsourceERPConnector.

b. In the New Connector dialog, select the appropriate connector template
from the Template Name table. For example, if your ERP-source connector
is the Adapter for JDBC, highlight the entry for JDBC in the Template Name
table. The properties from the JDBC connector template display in the
Property Template Preview section. When you click OK, Connector

Configurator Express displays the configuration tabs.

c. For the Standard Properties and Connector-Specific Properties tabs, provide
the necessary values for the configuration properties. For information on the
configuration properties for your ERP-source connector, see the associated

adapter guide.

listed in

d. In the Supported Business Objects tab, add the business object definitions
able 16

Table 16. Supported business objects for ERP-source connector

Business object definition

Agent support
required?

ERP-source application-specific business object definition (This is the
business object definition that you created for the ERP-source connector.
For more information, see [“Creating ERP-source business objects” on|
-ae 13.)

ItemBasic

Yes

No

e. Save the connector configuration file to the ItemSyncLibrary project with the

File > Save > To Project menu option.

f. In the Associated Maps tab, add the maps listed in [Table 17 on page 27| to

the specified business object definitions.



Table 17. Associated maps for ERP-source connector

Business object definition Name of map

ERP-source application-specific UCCnet_CwERPsource_to_CwItemBasic
business object (This is the map

that you created for the ERP-source
connector. For more
information)‘Creating ERP-source|

[maps” on page 14))

UCCnet_CwItemBasic_to_CwERPsource

2. Save the connector configuration file to the ItemSyncLibrary ICL project with
File > Save > To Project. Close Connector Configurator Express.

Configuring the PortConnector

The PortConnector is a “dummy” connector to bind to collaboration ports that do

not send a business object to a connector during the Item Sync business process. To

create the PortConnector, you create a connector configuration file using Connector

Configurator Express. For general information on how to use this tool to create a

connector configuration file, see the Connector Configurator Express appendix in

your adapter guide.

1. In the Name field of the New Connector dialog, specify PortConnector. To
select the Port connector template, highlight the entry for Port in the Template
Name table. When you click OK, Connector Configurator Express displays the
configuration tabs.

2. For the Standard Properties and Connector-Specific Properties tabs, you need
not set any properties.

3. In the Supported Business Objects tab, add the required business object
definitions. You will need the following for the collaboration templates that are
supplied with the solution:

Table 18. Supported business objects for PortConnector

Agent support
Business object definition required?
ItemBasic Yes
UCCnetGBO_envelope Yes

4. In the Associated Maps tab, you need not add any maps.

5. Save the connector configuration file to the ItemSyncLibrary ICL project with
File > Save > To Project. Do not close Connector Configurator Express.

Configuring the EmailConnector

You create the connector configuration file for the EmailConnector using Connector
Configurator Express. For general information on how to use this tool to create a
connector configuration file, see the Connector Configurator Express appendix in
your adapter user guide.

1. In the New Connector dialog, specify EmailConnector in the Name field. To
select the e-Mail connector template, highlight the entry for eMail in the
Template Name table. The properties from the e-Mail connector template
display in the Property Template Preview section. When you click OK,
Connector Configurator Express displays the configuration tabs.

2. In the Connector-Specific Properties tab, set the SMTP_MailHost property to
the hostname (or IP address) of the SMTP server in your system.

3. Save the connector configuration file to the ItemSyncLibrary project with the
File > Save > To Project menu option.
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Creating collaboration objects

The WebSphere Business Integration Express for Item Sync system requires
runtime objects, called collaboration objects, which are created from collaboration
templates. The following table lists the collaboration objects you must create, based
on their associated collaboration template.

Table 19. Collaboration objects for Item Sync

Collaboration template Collaboration object

UCCnet_ItemSync UCCnet_ItemSyncObject

For schema-document XML definition type: UCCnetXSD_CIN_DISPATCHER_forICR_Obj
e TtemCommandRouter UCCnetXSD_CIN_DISPATCHER_forPWL_Obj
» CIN_CIP_DISPATCHER

UCCnet_requestWorklist UCCnet_requestWorklistObject
UCCnet_processWorklist UCCnet_processWorklistObject
Notify_by_eMail UCCnet_processWorklist_

UNKNOWN_RESPONSEODbject

UCCnet_processWorklist_
AUTHORIZATION_RESPONSEODbject

UCCnet_processWorklist_
DEAD_LETTER_PUB_RECEIPTODbject

UCCnet_processWorklist_
CATEGORY_ADD_CHANGEODbject

UCCnet_processWorklist_
UNKNOWN_MESSAGESObject

UCCnet_processWorklist_
SIMPLE_RESPONSEODbject

UCCnet_processWorklist_FAILURE_RESPONSEODbject

UCCnet_processWorklist_
CATALOGUE_ITEM_CONFIRMATIONObject
(for schema-document support only)

UCCnet_processWorklist_ RCIR_QUERY_RESPONSEODbject
(for schema-document support only)

UCCnet_processWorklist__CI_RESPONSEODbject
(for schema-document support only, CIP operation)

UCCnet_processWorklist_CIP_RESPONSEObject
(for schema-document support only, CIP operation)

ItemCommandRouter_DE_LIST_WITHDRAWObject
(for schema-document support only, CIP operation)

UCCnet_processWorklist_ CIN_RESPONSEObject
(for schema-document support only, CIN operation)

You create collaboration objects in the System Manager tool. Before beginning the
steps in the subsequent sections, start up System Manager and connect to the
WebSpherelCS instance of InterChange Server Express. For information on how to
start up System Manager, see [“Starting System Manager” on page 5.
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Creating the collaboration for UCCnet_ltemSync
The collaboration object for the UCCnet_ItemSync collaboration template is called
UCCnet_ItemSyncObject. You create a collaboration object from System Manager.

To configure this collaboration object, complete the following steps:

1.

Right-click on the Collaboration objects folder of the ItemSyncLibrary project
(in System Manager). From the context menu, choose Create New Collaboration
Object. System Manager displays the Create New Collaboration dialog.

In the Create New Collaboration dialog, enter the following information:

a.
b.

Highlight UCCnet_ItemSync in the Template name column of the table.

In the Collaboration object name field at the bottom of the dialog, enter the
name of this collaboration object: UCCnet_ItemSyncObject

Click Next to display the Bind ports dialog. Bind the ports of this
collaboration object as shown in the following table.

Table 20. Port Bindings for UCCnet_ItemSync

Collaboration port Type Bind to

DestinationAppRetrieve | Connector PortConnector

From Connector Your ERP-source connector (for
example, JDBCsourceERPConnector)

To (For DTD XML Connector The connector that sends the

definition type) ItemBasic business object to UCCnet

(though the iSoft Peer-to-Peer Agent):
* If you are using the iSoft
connector: specify iSoftConnector

* If you are using UCCnet CLU:
specify JTextISoftConnector

To (For schema-document | Collaboration ItemCommandRouter_Obj.
XML definition type) From

d.

Note: If you are configuring the ItemSync collaboration to work with
schema-document XML definitions, you cannot bind the To port of
this UCCnet_ItemSync collaboration object at this time. The
collaboration object that contains the port to which this port is bound
has not yet been created. You can bind this port later, once the
ItemCommandRouter_Obj collaboration object exists. Continue with
the steps outlined in this section. When you reach [“Creating the]
[collaboration objects for schema-based XML” on page 30| ",
instructions are provided for finishing the port binding for the
UCCnet_ItemSyncObject collaboration object.

Click Next to display the Collaboration General Properties dialog. Set any
general properties for this collaboration object. If you want to set a tracing
level, specify a value for the system trace level or the collaboration trace
level in this dialog.

Click Next again to display the Properties dialog, which shows the
collaboration-specific properties. Set the collaboration-specific properties for
this collaboration object as shown in the following table.
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Table 21. Collaboration-specific properties for UCCnet_ItemSync

Property name Property description Required?
GtinDB_User For Windows and Linux: smbadmin Yes

For OS/400, leave this value blank.
GtinDB_PASSWORD For Windows and Linux: smbP4$$word Yes

JDBC_DRIVER

JDBC_URL

SEND_EMAIL

SEND_EMAIL_TO

AUDITLOG_INSTANCE_
NAME

SUPPLIER_NAME

For OS/400, leave this value blank.

The name of the JDBC driver used to
connect to the ICS repository database.
For more information, see the description
of the DRIVER property in |"Creating tha
[logeing table” on page 7.

The JDBC URL that corresponds to the
driver that JDBC_DRIVER specifies. For
more information, see the description of

the DATA_SOURCE_NAME property in
|“Creating the logging table” on page 7.|

Determines whether the Item Sync
collaboration sends email when it
generates certain messages To send
email, set this property to the value "all”.
Otherwise, set it to "none”.

Specifies the email address where the
Item Sync sends email messages,
assuming that the SEND_EMAIL
property is set.

UCCnet
Specifies the name of the partner that is

synchronizing item information with
UCCnet. This value is logged in audit

entries.

Yes, if InterChange Server Express does
not register the driver in the Java Virtual
Machine (JVM). The Microsoft SQL
driver, for example, is already registered
in the JVM.

Yes

Yes, if you want the Item Sync
collaboration to send email

No. Requires:
* the EmailConnector

e The SEND_EMAIL property set to
//alll/
Yes

No

Click Finish to complete the definition of this collaboration object. System
Manager displays the Graphical View of this collaboration object. Do not
close this Graphical View of the UCCnet_ItemSyncObject collaboration

object.

Creating the collaboration objects for schema-based XML

If your Item Sync solution uses the UCCnet Envelope that is based on the
schema-document XML definition type (Envelope.xsd), you must create special
collaboration objects to handle routing of information:

* One collaboration object from the ItemCommandRouter collaboration template
* Two collaboration objects from the CIN_CIP_DISPATCHER collaboration

template

Note: If your Item Sync collaboration uses the UCCnet Envelope that is based on
the DTD XML definition type (Envelope.dtd), you do not have to create the
collaboration objects described in this section. You can skip this section and
continue to the creation of the collaboration object for the
UCCnet_processWorklist collaboration template.

Creating the collaboration object for ItemCommandRouter: The collaboration
object for the ItemCommandRouter collaboration template is called
ItemCommandRouter_Ob;.
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You create a collaboration object from System Manager.

To configure this collaboration object, complete the following steps:

1. Right-click on the Collaboration objects folder of the ItemSyncLibrary project
(in System Manager). From the context menu, choose Create New Collaboration
Object. System Manager displays the Create New Collaboration dialog.

2. In the Create New Collaboration dialog, enter the following information:
a. Highlight ItemCommandRounter in the Template name column of the table.

b. In the Collaboration object name field at the bottom of the dialog, enter the
name of this collaboration object: ItemCommandRouter_Obj

3. Click Next to display the Bind ports dialog. Bind the ports of this collaboration
object as shown in the following table. The bindings you used depend in part
on whether you implement your own data pool (CIN operation) or use UCCnet
as a data pool (CIP operation).

Table 22. Port bindings for ltemCommandRouter

Collaboration port Type Bind to

From Collaboration UCCnet_ItemSyncObject.To
TO_RCIR Connector iSoftConnector

ToCIN_CI Collaboration For CIN operation:

UCCnetXSD_CIN_CIP_DISPATCHER_forICR_Obj.From

For CIP operation:
ItemCommandRouter_DE_LIST_WITHDRAWODbject:FromltemBasic
(Note: For CIP operation, the ToCin_CI port is configured to send
an email indicating that delist and withdrawal actions are not
supported.)

Note: You cannot bind the TO_CIN port of this ItemRouterCommand_Obj
collaboration object for CIN operation at this time. The collaboration
object that contains the port to which this port is bound has not yet been
created. You can bind this port later, once the
UCCnetXSD_CIN_DISPATCHER_forICR_Obj collaboration object exists.
Continue with the steps outlined in this section. When you reach
“Creating collaboration objects from CIN_CIP_DISPATCHER” on page]
32,|instructions are provided for finishing the port binding for the
ItemCommandRouter_ODbj collaboration object.

4. Click Next to display the Collaboration General Properties dialog. Set any
general properties for this collaboration object. If you want to set a tracing
level, specify a value for the system trace level or the collaboration trace level
in this dialog.

5. Click Finish to complete the definition of this collaboration object. The
ItemCommandRouter collaboration template does not have any
collaboration-specific properties. Therefore, you can skip the Properties dialog.

6. System Manager displays in the Graphical View tab the
ItemCommandRouter_ODbj collaboration object. Do not close this collaboration
object so you can return to it later.

7. Complete the binding for the UCCnet_ItemSyncObject with the following steps:

a. Open the collaboration object for UCCnet_ItemSyncObject in the Graphical
View tab by clicking on its name in the heading of the tab. If you have
already closed UCCnet_ItemSyncObject, double-click on its name in the
Collaboration objects folder of System Manager to display it in the
Graphical View tab.

Quick Start Guide 31



b. Switch to the Tree View for the collaboration object and right-click on the To
port. From the context menu, select Bind Port.
c. From the Configure Port dialog:
1) Select Collaboration for BindWith
2) Select ItemCommandRouter_Obj.From from the list of collaboration
object ports.
Click OK to save the new binding.
Close the UCCnet_ItemSyncObject collaboration object.

Creating collaboration objects from CIN_CIP_DISPATCHER: When you are
using the schema-document XML definition type, you need to create two
collaboration objects from the CIN_CIP_DISPATCHER collaboration template.

Complete the following steps:

1. Right-click on the Collaboration objects folder of the ItemSyncLibrary project
(in System Manager). From the context menu, choose Create New
Collaboration Object. System Manager displays the Create New Collaboration
dialog.

2. In the Create New Collaboration dialog, enter the following information:

a. Highlight CIN_CIP_DISPATCHER in the Template name column of the
table.

b. In the Collaboration object name field at the bottom of the dialog, enter
the name of this collaboration object:
UCCnetXSD_CIN_DISPATCHER_forICR_Obj

3. Click Next to display the Bind ports dialog. Bind the ports of this
collaboration object as shown in [Table 23

Table 23. Port bindings for UCCnetXSD_CIN_DISPATCHER_forICR_Obj

Collaboration port Type Bind to

DestinationAppReceive Connector PortConnector

From Collaboration ItemCommandRouter_Obj. TO_CIN
To Connector iSoftConnector

4. Click Next to display the Collaboration General Properties dialog. Set any
general properties for this collaboration object. If you want to set a tracing
level, specify a value for the system trace level or the collaboration trace level
in this dialog.

5. Click Next again to display the Properties dialog, which shows the
collaboration-specific properties. Set the collaboration-specific properties for
this collaboration object as shown in the following table.

Table 24. Collaboration-specific properties for UCCnetXSD_CIN_DISPATCHER_forlCR_Obj

Property name Property description Required?
CIN_DISPATCHER_GLN_FILE The fully qualified name of the file that holds the Yes

GLNs subscribed to each category code.
TO_UCCNETGBO_PROCESSING_MAP By the UCCnet_CIN_DISPATCHER object to map Yes

incoming ItemBasic objects to the outgoing
CATALOGUE_ITEM_NOTIFICATIONMessage.
SUPPLIER_NAME The name of the partner responsible for No
synchronizing item information with UCCnet. This
value is included in audit log entries.
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6. Click Finish to complete the definition of this collaboration object. System
Manager displays this collaboration object in the Graphical View. You can
close the UCCnetXSD_CIN_DISPATCHER_forICR_Obj collaboration object in
the Graphical View.

7. Complete the binding for the [temCommandRouter_Obj with the following
steps:

a. Open the collaboration object for ItemCommandRouter_Obj in the
Graphical View tab by clicking on its name in the heading of the tab. If
you have already closed ItemCommandRouter_Obj, double-click on its
name in the Collaboration objects folder of System Manager to display it
in the Graphical View tab.

b. Switch to the Tree View for the collaboration object and right-click on the
TO_CIN port. From the context menu, select Bind Port.

c. From the Configure Port dialog:
1) Select Collaboration for BindWith.

2) Select UCCnetXSD_CIN_DISPATCHER_forICR_Obj.From from the list
of collaboration object ports.

d. Click OK to save the new binding.
e. Close the ItemCommandRouter_Obj collaboration object.

8. Repeat steps 1 and 2 to begin creation of the second collaboration object from
the CIN_CIP_DISPATCHER template,
UCCnetXSD_CIN_DISPATCHER_forPWL_Obj:

a. Select CIN_CIP_DISPATCHER as the collaboration template to use.

b. Name the collaboration object
UCCnetXSD_CIN_DISPATCHER_forPWL_Obj.

9. Click Next to display the Bind ports dialog. Bind the ports of this
collaboration object as shown in the following table.

Table 25. Port bindings for UCCnetXSD_CIN_DISPATCHER_forPWL_Obj

Collaboration port Type Bind to
DestinationAppReceive Connector PortConnector
From Collaboration For CIN operation:

UCCnet_processWorklist: RCIR_RESPONSE
For CIP operation
UCCnet_processWorklist: PUBLICATION_CMD_RESPONSE

To Connector iSoftConnector
DestinationAppRetrieve Connector PortConnector

Note: You cannot bind the From port of this
UCCnetXSD_CIN_DISPATCHER_forPWL_Obj collaboration object at
this time. The collaboration object that contains the port to which this
port is bound has not yet been created. You can bind this port later,
once the UCCnet_processWorklistObject collaboration object exists.
Continue with the steps outlined in this section. When you reach

‘Creating the collaboration object for UCCnet_processWorklist” on page]

B4, instructions are provided for finishing the port binding for the

UCCnetXSD_CIN_DISPATCHER_forPWL_Obj collaboration object.

10. Click Next to display the Collaboration General Properties dialog. Set any
general properties for this collaboration object. If you want to set a tracing
level, specify a value for the system trace level or the collaboration trace level
in this dialog.
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11. Click Next again to display the Properties dialog, which shows the
collaboration-specific properties. Set the collaboration-specific properties for
this collaboration object the same as those shown in the table for
UCCnetXSD_CIN_DISPATCHER_forICR_Obj.

12. Click Finish to complete the definition of this collaboration object. System
Manager displays this collaboration object in the Graphical View. Do not close
this Graphical View of the UCCnetXSD_CIN_DISPATCHER_forPWL_Obj
collaboration object so you can return to it later.

Creating the collaboration object for UCCnet_processWorklist
The collaboration object for the UCCnet_processWorklist collaboration template is
called UCCnet_processWorklistObject.

To configure this collaboration object, complete the following steps:

1. Right-click on the Collaboration objects folder of the ItemSyncLibrary project
(in System Manager). From the context menu, choose Create New Collaboration
Object. System Manager displays the Create New Collaboration dialog.

2. In the Create New Collaboration dialog, enter the following information:

a. Highlight UCCnet_processWorklist in the Template name column of the

table.

b. In the Collaboration object name field at the bottom of the dialog, enter the
name of this collaboration object: UCCnet_processWorklistObject

3. Click Next to display the Bind ports dialog. Bind only the ports of this
collaboration object that are shown in the following table.

Table 26. Initial port bindings for UCCnet_processWorklist

Collaboration port Type Bind to

From Connector iSoftConnector or JTextISoftConnector
ITEM_ADD_CHANGE Connector iSoftConnector or JTextISoftConnector
NEW_ITEM_PUBLICATION_REQUEST Connector iSoftConnector or JTextISoftConnector
INITIAL_ITEM_LOAD_REQUEST Connector iSoftConnector or JTextISoftConnector

PUBLICATION_CMD_RESPONSE

DestinationAppReceive
CIN_RESPONSE

CIP_RESPONSE

DTD support

Connector XSD support, CIN
operation

Connector XSD support, CIP
operation

Collaboration object
Connector

DTD support

Connector

XSD support, CIN operation
Collaboration object

XSD support, CIP operation
Connector

DTD support

Connector

XSD support, CIN operation
Connector

XSD support, CIP operation
Collaboration object

DTD support

PortConnector

XSD support, CIN operation
PortConnector

XSD support, CIP operation
CIN_CIP_Dispatcher_forPWL_Obj:From
PortConnector

DTD support

PortConnector

XSD support, CIN operation
UCCnet_processWorklist_
CIN_RESPONSEODbject:From
XSD support, CIP operation
PortConnector

DTD support

PortConnector

XSD support, CIN operation
PortConnector

XSD support, CIP operation
UCCnet_processWorklist_
CIP_RESPONSEODbject:From
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Table 26. Initial port bindings for UCCnet_processWorklist (continued)

Collaboration port

Type

Bind to

CI_RESPONSE

RCIR_RESPONSE

RCIR_QUERY_RESPONSE

DTD support

Connector

XSD support, CIN operation
Connector

XSD support, CIP operation
Collaboration object

DTD support

Connector

XSD support, CIN operation
Collaboration object

XSD support, CIP operation
Connector

DTD support
Connector

XSD support
Collaboration object

DTD support

PortConnector

XSD support, CIN operation
PortConnector

XSD support, CIP operation
UCCnet_processWorklist_
CI_RESPONSEObject:From

DTD support

PortConnector

XSD support, CIN operation
UCCnetXSD_CIN_DISPATCHER _
forPWL_Obj:From

XSD support, CIP operation
Second instrance of iSoftConnector or
JTextISoftConnector

DTD support

PortConnector

XSD support
UCCnet_processWorklist_
RCIR_QUERY_RESPONSEODbject

Note: The table above lists only those ports of the
UCCnet_processWorklistObject collaboration object that you can bind at
this stage of the process. You cannot bind the following ports of this
collaboration object at this stage:

CATEGORY_ADD_CHANGE
DEAD_LETTER_PUB_RECEIPT
AUTHORIZATION_RESPONSES
UNKNOWN_RESPONSE
UNKNOWN_MESSAGE
SIMPLE_RESPONSE
CATALOGUE_ITEM_CONFIRMATION
FAILURE

All of these ports must be bound to a collaboration object based on the
Notify_by_eMail collaboration template. You can bind these ports later,
once these Notify_by_eMail collaboration objects exist. Continue with the
steps outlined in this section. When you reach |”Creating thgl

[collaboration objects for Notify_by_eMail” on page 37] instructions are

provided for finishing the port binding for the
UCCnet_processWorklistObject collaboration object.

4. Click Next to display the Collaboration General Properties dialog. Set any
general properties for this collaboration object. If you want to set a tracing
level, specify a value for the system trace level or the collaboration trace level
in this dialog.

Click Next again to display the Properties dialog, which shows the
collaboration-specific properties. Set the collaboration-specific properties for this
collaboration object as shown in [Table 27 on page 36|
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Table 27. Collaboration-specific properties for UCCnet_processWorklistObject

Property name

Property description Required?

DB_USER

DB_PASSWORD

JDBC_DRIVER

JDBC_URL

SEND_EMAIL_TO

SEND_EMAIL

AUDITLOG_INSTANCE_
NAME
SUPPLIER_NAME

DTD_URL

AUTO_RESPOND

For Windows and Linux: smbadmin Yes

For OS/400, leave this value blank.
For Windows and Linux: smbP4$$word Yes

For OS/400, leave this value blank.
The name of the JDBC driver used to connect | Yes, if InterChange Server Express

to the ICS repository database. For more does not register the driver in the
information, see the description of the Java Virtual Machine (JVM). The
DRIVER property in|“Creating the logging] Microsoft SQL driver, for example,
[table” on page 7| is already registered in the JVM.

The JDBC URL that corresponds to the driver | Yes
that JDBC_DRIVER specifies. For more
information, see the description of the

DATA_SOURCE_NAME property in
[the logging table” on page 7

Specifies the email address where the Item No.Requires: the EmailConnector
Sync sends email messages, assuming that the | The SEND_EMAIL property set to
SEND_EMAIL property is set. "all”

Determines whether the Item Sync Yes, if you want the Item Sync
collaboration sends email when it generates collaboration to send email

certain messages To send email, set this
property to the value "all”. Otherwise, set it to

"none”.
UCCnet Yes
The name of the partner responsible for No

synchronizing item information with UCCnet.
This value is included in audit log entries.
Specifies the value for the DOCTYPE line in No, unless the default value is
outgoing XML. The default value is: incorrect for the environment
DOCTYPE envelope SYSTEM

http://www.uccnet.net/xmlschema/2.2/
envelope_file

For the DTD XML definition type, replace
envelope_file with: Envelope.dtd

For the schema-document XML definition

type, replace envelope_file with: Envelope.xsd
Controls whether an automatic response is set | Yes
to UCCnet
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Click Finish to complete the definition of this collaboration object. System

Manager displays the collaboration object in the Graphical View. Do not close

this Graphical View of the UCCnet_processWorklistObject collaboration object

SO you can return to it later.

If you are using the schema-document XML definition type for your UCCnet

Envelope, complete the binding for the

UCCnetXSD_CIN_DISPATCHER_forPWL_Obj with the following steps:

a. Open the collaboration object for
UCCnetXSD_CIN_DISPATCHER_forPWL_Obj in the Graphical View tab by
clicking on its name in the heading of the tab. If you have already closed



UCCnetXSD_CIN_DISPATCHER_forPWL_Obj, double-click on its name in
the Collaboration objects folder of System Manager to display it in the
Graphical View tab.

Switch to the Tree View for the collaboration object and right-click on the
From port. From the context menu, select Bind Port.

From the Configure Port dialog;:
1) Select Collaboration for BindWith.

2) Select UCCnet_processWorklistObject. CIN_DISPATCHER from the list of
collaboration object ports.

Click OK to save the new binding.
Close the UCCnetXSD_CIN_DISPATCHER_forPWL_Obj collaboration object.

Creating the collaboration objects for Notify_by_eMail

The Item Sync collaboration requires several collaboration objects for the
Notify_by_eMail collaboration template.

To configure these collaboration objects, complete the following steps:

1. Right-click on the Collaboration objects folder of the ItemSyncLibrary project

(in System Manager). From the context menu, choose Create New Collaboration
Object. System Manager displays the Create New Collaboration dialog.

2. In the Create New Collaboration dialog, enter the following information:

a. Highlight Notify_by_eMail in the Template name column of the table.

b. In the Collaboration object name field at the bottom of the dialog, enter the
name of the collaboration object you are creating and click Next. The
following table lists the names of all collaboration objects that need to be
created based on the Notify_by_eMail collaboration template.

3. In the Bind ports dialog, bind the From port of each Notify_by_eMail
collaboration object to a Collaboration, as shown in the following table.

Table 28. Port bindings for Notify_by_eMail

Collaboration object

Bind to collaboration object port

UCCnet_processWorklist_
CATEGORY_ADD_CHANGEODbject
UCCnet_processWorklist_
DEAD_LETTER_PUB_RECEIPT
UCCnet_processWorklist_
AUTHORIZATION_

RESPONSES
UCCnet_processWorklist_
UNKNOWN_RESPONSE
UCCnet_processWorklist_
UNKNOWN_MESSAGES
UCCnet_processWorklist_
SIMPLE_RESPONSE
UCCnet_processWorklist_
CATALOGUE_ITEM_
CONFIRMATION

Used for schema-document support
only (CIN and CIP operation)
UCCnet_processWorklist_
RCIR_QUERY_RESPONSEODbject
Used for schema-document support
only (CIN and CIP operation)

UCCnet_processWorklistObject:
CATEGORY_ADD_CHANGE
UCCnet_processWorklistObject.
DEAD_LETTER_PUB_RECEIPT
UCCnet_processWorklistObject.
AUTHORIZATION_RESPONSES

UCCnet_processWorklistObject.
UNKNOWN_RESPONSE
UCCnet_processWorklistObject.
UNKNOWN_MESSAGES
UCCnet_processWorklistObject.
SIMPLE_RESPONSE
UCCnet_processWorklistObject.
CATALOGUE_ITEM_CONFIRMATION

UCCnet_processWorklistObject:
RCIR_QUERY_RESPONSE
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Table 28. Port bindings for Notify_by_eMail (continued)

Collaboration object

Bind to collaboration object port

UCCnet_processWorklistObject:CI_
RESPONSE

Used for schema-document support
only (CIP operation)
UCCnet_processWorklist
_CIP_RESPONSEODbject

Used for schema-document support
only (CIP operation)
ItemCommandRouter_
DE_LIST_WITHDRAWObject

Used for schema-document support
only (CIP operation)
UCCnet_processWorklist_
CIN_RESPONSEObject

Used for schema-document support
only (CIN operation)
UCCnet_processWorklist_
FAILURE_RESPONSEODbject

UCCnet_processWorklistObject:

CI_RESPONSE

UCCnet_processWorklist_CIP_RESPONSEObject

Port Connector

UCCnet_processWorklist_ CIN_RESPONSEObject

UCCnet_processWorklistObject:
FAILURE

4. Click Next to display the Collaboration General Properties dialog. Set any
general properties for this collaboration object. If you want to set a tracing
level, specify a value for the system trace level or the collaboration trace level

in this dialog.

5. Click Next again to display the Properties dialog, which shows the
collaboration-specific properties. For each of the Notify_by_eMail collaboration
objects, set the collaboration-specific properties for this collaboration object as

shown in the following table.

Table 29. Collaboration-specific properties for Notify_by_eMail

Property name Property description Required
EMAIL_NOTIFICATION_RCPTS Lists the email address of the message recipient Yes
EMAIL_SUBJECT Specifies the format of the subject line of the email Yes

EMAIL_MESSAGE

DOCTYPE

Collaboration.

envelope_file

Envelope.xsd

message. For more information on the syntax that this
property supports, see the description of this property
in the reference page for the UCCnet Item
Synchronization Collaboration.

Specifies the format body of the email message. For Yes
more information on the syntax that this property
supports, see the description of this property in the
reference page for the UCCnet Item Synchronization

For the DTD XML definition type, replace envelope_file
with: Envelope.dtd For the schema-document XML
definition type, replace envelope_file with:

Specifies the value for the DOCTYPE line in outgoing | Yes
XML. The default value is:

DOCTYPE envelope SYSTEM
http://www.uccnet.net/xmlschema/2.2/
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6.

Click Finish to complete the definition of the collaboration object. System
Manager displays the Graphical View of this collaboration object. Close the
Graphical View for each of the Notify_by_eMail collaboration objects.

Complete the binding for the UCCnet_processWorklistObject with the following

steps:

a. Open the collaboration object for UCCnet_processWorklistObject in the
Graphical View tab by clicking on its name in the heading of the Graphical
View tab. If you have already closed UCCnet_processWorklistObject,
double-click on its name in the Collaboration objects folder of System
Manager to display it in the Graphical View tab.

b. Switch to the Tree View for the collaboration object. For each of the ports
listed in the following table, right-click on the port and select Bind Port
from the context menu. Provide the information in the Configure Port
dialog as listed in the following table.

Table 30. Additional port bindings for UCCnet_processWorklist

Collaboration object port

Bind to collaboration object port

CATEGORY_ADD_CHANGE UCCnet_processWorklist_

CATEGORY_ADD_CHANGEODbject.From

DEAD_LETTER_PUB_RECEIPT UCCnet_processWorklist_

DEAD_LETTER_PUB_RECEIPTObject.From

AUTHORIZATION_RESPONSES UCCnet_processWorklist_

UNKNOWN_RESPONSE

UNKNOWN_MESSAGES

SIMPLE_RESPONSE

CATALOGUE_ITEM_
CONFIRMATION

FAILURE

AUTHORIZATION_RESPONSESObject.From
UCCnet_processWorklist_
UNKNOWN_RESPONSEODbject.From
UCCnet_processWorklist_
UNKNOWN_MESSAGESObject.From
UCCnet_processWorklist_
SIMPLE_RESPONSEODbject.From
UCCnet_processWorklist_
CATALOGUE_ITEM_
CONFIRMATIONODbject.From
UCCnet_processWorklist FAILURE_RESPONSEODbject:From

€. Once you have completed the port bindings for all the collaboration objects
in the preceding table, you can close the UCCnet_processWorklistObject
collaboration object.

Creating the collaboration object for UCCnet_requestWorklist
The collaboration object for the UCCnet_requestWorklist collaboration template is
called UCCnet_requestWorklistObject. You create a collaboration object from
System Manager.

To configure this collaboration object, complete the following steps:

1.

Right-click on the Collaboration objects folder of the ItemSyncLibrary project
(in System Manager). From the context menu, choose Create New Collaboration
Object. System Manager displays the Create New Collaboration dialog.

In the Create New Collaboration dialog, enter the following information:

a. Highlight UCCnet_requestWorklist in the Template name column of the
table.

b. In the Collaboration object name field at the bottom of the dialog, enter the
name of this collaboration object: UCCnet_requestWorklistObject

Click Next to display the Bind ports dialog. Bind the ports of this collaboration
object as shown in the following table.
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Table 31. Port bindings for UCCnet_requestWorklist

Collaboration port Type Bind to
From Connector JTextRWLConnector
To Connector iSoftConnector or JTextISoftConnector

4. Click Next again to display the Properties dialog, which shows the
collaboration-specific properties. Set the collaboration-specific properties for this
collaboration object as shown in the following table.

Table 32. Collaboration-specific properties for UCCnet_requestWorklist

Property name Property description Required
DTD_URL Specifies the value for the DOCTYPE line in No, unless the default value is
outgoing XML. The default value is: incorrect for the environment

DOCTYPE envelope SYSTEM
http://www.uccnet.net/xmlschema/2.2/
envelope_file

For the DTD XML definition type, replace
envelope_file with: Envelope.dtd For the
schema-document XML definition type, replace
envelope_file with: Envelope.xsd
SET_UNIQUE_IDS Controls whether unique IDs (messageldentifier No
and uniqueCreateorldentification) are set in the
output XML messages. Possible values are:

* ALL: set all three unique IDs (default)

* NONE

* BLANK: set unique ID only if it is blank in the
input

5. Click Finish to complete the definition of this collaboration object. System
Manager displays this collaboration object in the Graphical View. You can close
the UCCnet_requestWorklistObject collaboration object in the Graphical View.

Deploying the solution

Once you have created all the components in the ItemSyncLibrary ICL project, you
are ready to create a user project and deploy this project to the WebSpherelCS
instance of InterChange Server Express.

Note: Before any adapter that uses WebSphere MQ Queues in its configuration (for
example iSoftConnector) can be started (after deployment), the queues must
be created. For OS/400 queue creation, use: Start>Programs>IBM WebSphere
Business Integration Express for Item Sync v4.3.1>iSeries
remote>InterChange Server Express> Configure Queue Manager. This will
open crossworlds_mgq.tst (on OS/400) in NotePad on your PC. From
NotePad you can edit the file to contain the Queues you need to create (see
samples in your installed files directory). When you close NotePad, the
0S/400 tools will create your Queue definitions in the Queue Manager
listed in InterchangeSystem.cfg.

To deploy the solution, complete these steps:
1. Create a user project from System Manager:
a. Right-click on the User Projects folder and select New User Project.
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b. From the New User Project dialog, enter the name of your user project in
the Project name field and click in the box next to the ItemSyncLibrary in
the Available Integration Component Libraries box.

c. Click Finish. Once System Manager creates your user project, you will see a
plus sign ("+") appear next to the User Projects folder. Under this folder you
will find a folder called InterChange Server Projects, and under that folder
will be the folder for your new user project.

2. Make sure your InterChange Server instance is in Design mode. You can check
the InterChange Server view in System Manager to determine the mode of your
ICS instance. If your instance does not list "Design” in its Mode column, you
must bring down the ICS instance and bring it back up in Design mode.

3. Deploy the user project to the WebSpherelCS instance with the Deploy wizard.

a. Right-click on the WebSpherelCS instance and select Add user project. Click
on the new user project that you created.

b. The newly added user project appears under the WebSpherelCS instance.
Right-click on the WebSpherelCS instance and select Deploy Project. The
Deploy Wizard dialog displays.

c. Expand the user project that you are deploying, to see a list of project
components.

d. Deploy the business object definitions by clicking in the box beside the
Business Objects folder. Click Next and then click Finish to start the
deployment of business object definitions.

e. Start the Deploy wizard again and deploy the maps by clicking in the box
beside the Maps folder and checking the Compile option. Click Next, then
click Finish to start the deployment of maps.

f. Start the Deploy wizard again and deploy the relationships by clicking in
the box beside the Relationships folder and checking the Create schema
option. Click Next, then click Finish to start the deployment of relationships.

g. Start the Deploy wizard again and deploy the connectors by clicking in the
box beside the Connectors folder. Click Next, then click Finish to start the

deployment of connectors.

h. Start the Deploy wizard again and deploy the collaboration templates by
clicking in the box beside the Collaboration Templates folder. Click Finish to
start the deployment of collaboration templates.

4. At this point, all components of the Item Sync solution except the collaboration
objects should be deployed to your WebSpherelCS instance. Before you deploy
collaboration objects, you must restart InterChange Server:

a. Right-click on your WebSpherelCS instance in the InterChange Server view
of System Manager. Select the Shutdown > Gracefully option.

b. Restart your ICS instance with Start > Programs > IBM WebSphere Business
Integration Item Sync Express v4.3 > InterChange Server Express >
InterChange Server.

On OS/400: Start > Programs > IBM WebSphere Business Integration Item
Sync Express v4.3 > iSeries remote > InterChange Server Express >
InterChange Server.

€. Reconnect to your WebSpherelCS instance in System Manager.
5. Launch System Monitor and start the relationships.

6. Start the Deploy wizard again and deploy the collaboration objects by clicking
in the box beside the Collaboration Objects folder. Click Finish to start the
deployment of collaboration objects.
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Populating the relationships after deployment
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After the relationships have been deployed, you must then populate them with
default values and make any necessary modifications to the default schemas. To
populate the relationships, complete the steps appropriate for your database server.

On 0S/400:

* Run the appropriate CL command, and then start InterChange Server Express
and your adapters. Use one of these CL commands:

For DTD XML definition type: CALL QWEBBIICS/QWEBBIIREL
For the schema-document XML definition type:CALL QWEBBIICS/QWEBBIIRELX

On Windows and Linux: DB2 Database Server

1. Move to the following directory:
ProductDir\collaborations\dependencies\UCCnet\db2

2. Start a DB2 session, as follows:
¢ On Windows:
Start > Programs > IBMDB2 > Command Line Tools > Command Window.
* On Linux:
Enter the following command in a terminal window:
db2

3. At the prompt: On Windows, enter the following comment: db2 connect to
SMB_DB USER smbadmin USING smbP4$$word. On Linux, enter the following
command:connect to SMB DB user smbadmin using smbP4$$word

4. After you are connected, enter the following command to run the script that
creates the audit_log table: audit_log.sql

5. After you are connected, run one of the following SQL scripts:

* For solutions that use the DTD XML definition type, enter the command:
InitializeRelationshipTables.sql

* For solutions that use the schema-document XML definition type, enter the
command: InitializeRelationshipTablesForXSD.sql

Windows and Linux: Microsoft SQL Server

1. If you have not left the Query Analyzer open from earlier configuration steps,
start the Query Analyzer with Start > Programs > Microsoft SQL Server >
Query Analyzer and enter the following information in the Connect to SQL
Server dialog:

a. Make sure that the SQL Server authentication radio button is selected.

b. Log into the ICS database server with the following default account
information:

Account: smbadmin
Password: smbP4$$word

Note: This account information is the default database user account that the

WebSphere Business Integration Express for Item Sync Installer
creates. If you have modified this account since it was created, use
the current account information.

C. Select the ICS repository database by selecting the SMB_DB database from
the dropdown menu in the Query Analyzer toolbar.

2. Load the appropriate relationship-table script into the Query Analyzer with File
> Open.



* For solutions that use the DTD XML definition type, enter the command:
InitializeRelationshipTables.sql

¢ For solutions that use the schema-document XML definition type, enter the
command: InitializeRelationshipTablesForXSD.sql
This script is located in the following directory:
ProductDir\collaborations\dependencies\UCCnet\mss
3. Run the relationship-table script with Query > Execute.
4. Exit Query Analyzer.

Populating the trading_partner tables
After running the InitialiseRelationshipTables or InitialiseRelationshipTablesForXSD

script, you must manually populate the trading_partner table with the correct GLN
SOURCE and TARGET information.

The following example adds a SOURCE row to the trading_partner table. Since the
SOURCE entry indicates your own GLN, the table should have only one SOURCE
record.

insert into trading_partner (gin_code, trading_partner_name,
trading_partner_contact,
trading_partner_group, trading_partner_type, initial_load flag)

values ('0000000000001',"'ACME Inc.','Mr. Acme', 'Group 1','SOURCE','Y")

The next example adds a TARGET entry to the table. Since the TARGET entries
record your trading partners’ GLNSs, the table can have multiple TARGET records.

insert into trading_partner (gin_code, trading_partner_name,
trading_partner_contact,trading_partner_group, trading_partner_type,
initial_load_flag)

values ('0000000000002','Green Co.','Ms. Green','Group 1','TARGET','N")

Restarting ICS Express and starting your Adapter

After you have deployed the project, you must shutdown ICS Express, then restart
ICS Express, and then start your adapter.

1. To stop ICS Express, right-click on your WebSpherelCS instance in the
InterChange Server view of System Manager. Select the Shutdown > Gracefully
option. Alternatively, on OS/400, you can use the CL command ENDSBS
SBS(QWEBBIICS) OPTION(*IMMED) to shut down ICS Express.

2. To start ICS Express:
* On Windows:

Choose Start > Programs > IBM WebSphere Business Integration for Item
Sync Express v4.3 > InterChange Server Express.

* On Linux:
Enter the following command in a terminal window
:ProductDir/bin/ics_manager -start.

* On 0S/400: On the Windows machine where you installed System Manager
and the toolset, choose the shortcut Start > Programs > IBM WebSphere
Business Integration Express for Item Sync v4.3.1 > iSeries remote >
InterChange Server Express. Or, on your OS/400 system, do the CL
command, STRSBS QWEBBIICS/QWEBBIICS

3. To start the adapter
* On Windows:

Choose Start > Programs > IBM WebSphere Business Integration for Item
Sync Express v4.3 >Adapters > Connectors > name of your adapter.
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* On Linux:
Enter following command in a terminal window:
ProductDir/connectors/Connector/start_Connector.sh Connector ICS

* On OS/400: On the Windows machine where you installed System Manager
and the toolset, choose Start > Programs > IBM WebSphere Business
Integration Express for Item Sync v4.3.1 > iSeries remote > Adapters >

Connectors > name of your adapter. V4.3>iSeries>Adapters>Connectors>name
of your adapter

For more information, see the following: User Guide for WebSphere Business
Integration Express for Item Synchronization.

Administration

Administration tasks for WebSphere Business Integration Express for Item
Synchronization includes the following:

* Monitoring the system
* Operating ICS Express
* Operating connectors

* Operating maps

* Operating relationships

For detailed information regarding Administration, see the following: User Guide
for WebSphere Business Integration Express for Item Synchronization.
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Notices

IBM may not offer the products, services, or features discussed in this document in
all countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user’s responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not give you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation

North Castle Drive
Armonk, NY 10504-1785
US.A.

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law:

INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS
FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement may not apply
to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or program(s) described in this publication
at any time without notice.

Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

IBM Burlingame Laboratory Director
IBM Burlingame Laboratory
577 Airport Blvd., Suite 800
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Burlingame, CA 94010
US.A

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this document and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement, or any equivalent agreement
between us.

Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments may
vary significantly. Some measurements may have been made on development-level
systems and there is no guarantee that these measurements will be the same on
generally available systems. Furthermore, some measurement may have been
estimated through extrapolation. Actual results may vary. Users of this document
should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not necessarily tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

This information may contain examples of data and reports used in daily business

operations. To illustrate them as completely as possible, the examples may include

the names of individuals, companies, brands, and products. All of these names are

fictitious and any similarity to the names and addresses used by an actual business
enterprise is entirely coincidental.

All statements regarding IBM’s future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

Programming interface information

Programming interface information, if provided, is intended to help you create
application software using this program.

General-use programming interfaces allow you to write application software that
obtain the services of this program’s tools.

However, this information may also contain diagnosis, modification, and tuning
information. Diagnosis, modification and tuning information is provided to help
you debug your application software.

Warning: Do not use this diagnosis, modification, and tuning information as a
programming interface because it is subject to change.

Trademarks and service marks

The following terms are trademarks or registered trademarks of International
Business Machines Corporation in the United States or other countries, or both:
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IBM

the IBM logo
AIX
CrossWorlds
DB2

DB2 Universal Database
Domino
Lotus

Lotus Notes
MQIntegrator
MQSeries
Tivoli
WebSphere

Microsoft, Windows, Windows NT, and the Windows logo are trademarks of
Microsoft Corporation in the United States, other countries, or both.

MMX, Pentium, and ProShare are trademarks or registered trademarks of Intel
Corporation in the United States, other countries, or both.

Java and all Java-based trademarks are trademarks of Sun Microsystems, Inc. in the
United States, other countries, or both.

Other company, product or service names may be trademarks or service marks of
others.

£

JAVA.

WebSphere Business Integration Express for Item Synchronization V4.3.1

WebSphere Business Integration Express Plus for Item Synchronization V4.3.1
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