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What this lab is about 

This lab is provided AS-IS, with no formal IBM support. 

In this lab you will use IBM Support Assistant 5 Beta (ISA 5) to diagnose JVM issues experienced by a 
WebSphere Application Server 8.5.   

A badly implemented web application will be used to simulate a hung thread scenario.  Diagnostic data 
such as Javadumps (javacore.txt files) and system dumps will be used to determine the code causing the 
issue, and inspect the Java objects associated with the hung thread.  The lab will also explain how to 
correlate thread id between the various logs and dumps. 

The lab demonstrates how ISA 5 facilitates team team-based collaboration, and provides server-level 
diagnostic tools to carry out analysis.  The ISA tools “Thread and Monitor Dump Analyzer (TMDA)” and 
“Memory Analyzer” will be used. 
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Lab requirements 

List of system and software required for the attendee to complete the lab. 

• WebSphere Application Server V8.5.0.1 

• IBM Support Assistant V5 (Beta 2) with the following tools installed: 

► WebSphere Application Server Configuration Visualizer 

► Thread Dump and Monitor Analyzer – (ISA 5 desktop tool, and report) 

► IBM Monitoring and Diagnostic Tools for Java™ - Memory Analyzer – (ISA 5 desktop tool, and 
report tool) 

► IBM Extensions for Memory Analyzer (Packaged with the Memory Analyzer ISA 5 desktop 
tool) 

What you should be able to do 

At the end of this lab you should be able to:- 

• Use ISA 5 to manage Java diagnostic data and utilize problem determination tools 

• Diagnose a hung WebSphere thread using Thread and Monitor Dump Analyzer for Java 

• Correlate thread information between WebSphere log, traces, Javadumps and system dumps 
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Part 1: Lab Set Up 

_____ Login to the VMWare image with the username/password below: 

Username :Administrator 

Password : Impact2013AVP 

 

NOTE:  

Due to the physical memory on the VMware image being used for this lab please understand that certain 
operations may take time to perform – please be patient.  The expected duration of this lab is 55 minutes 
and each part has an estimated duration.  The final lab section is marked as optional so you can attempt 
this if there is sufficient time. 
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Part 2: IBM Support Assistant 5 Beta  

 

Note: 

 

The IBM® Support Assistant (ISA) is a free application that provides features for problem determination, 
and a platform for obtaining diagnostic tools. The most recent release of ISA (version 5.0), which is 
currently in beta, brings these capabilities into a server environment.  This enables an administrator to 
install a single instance of ISA that can be used by a group of users and accessed via a web browser.  
Therefore resources, files, information, and server-level tools can be shared.  This facilitates team based 
collaboration and avoids the need for each team member to install diagnostic tools on their local 
workstation. 

ISA v5.0 can be installed from an EAR file into an existing WebSphere Application Server, or using a 
simple “all-in-one” unzip install which contains everything required, including a lightweight application 
server and Java runtime.  This lab uses the latter approach. 

In this part of the lab, you will use ISA to understand its key concepts, and test some of the core functions. 

 

_____ Validate that ISA is fully started. ISA was started in a command prompt window. Check that window and 
look for “IBM Support Assistant is ready to run”. If this is not displayed wait for the startup to complete. 
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_____ Launch the browser and use the bookmarks to load the ISA web interface. 

 

 

 

Note: 

Like previous releases of ISA, the tool can be used to find problems, analyze data, and send information to 
IBM support.  As it is a multi-user installation, ISA provides a case management component to help  
manage various problem determination activities that a team might require.  A case is simply a container 
for a logical grouping of files and information. A typical practice would be to group artifacts pertaining to a 
single issue.  

 

_____  Create a new case by clicking the Cases button, and then Add. 
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_____ Complete the summary and description, and click the green tick. 

 

 

 

_____ Shrink the cases dialog by clicking Cases. 
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_____ Having made a new case, diagnostic data can be added.  This lab provides a sample WebSphere 
Application Server SystemOut log file that contains some error messages.  Open the file on from the desktop, 
and note that it contains various WebSphere errors and Java stack traces. 

 

 

 

_____ Close the text editor. 
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_____ Add this sample SystemOut log to the ISA case by dragging it from the desktop to the ISA file list in the 
browser. 

 

 

 

 

 

 

 

 

 

_____ Click the yellow box to dismiss the notification. 

 

 

 

_____ Click the refresh icon in the Navigator to see the files in the case. 

 

 

 

 

_____ Click the Status button.  Notice the “Ticket” (case) has not been scanned. 
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_____ Click the Scan this Case button. 

 

 

 

 

 

 

_____ Click Submit to start the Scan. 
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Note: 

Scanning the case may take up to 5 minutes.  In the meantime, let's investigate the tools that are installed 
into ISA 5. 

 

 

_____ Click the Tools tab.  Note that only the tools that will be used in this lab have already installed, more 
tools are available.   

 

 

Note:  

There are three key types of tools provided in ISA and each type has its benefits and compromises.  

Report generator tools -  process input data (e.g. log files or Java dumps) and generate a simple output 
file, usually in the form of an HTML or .txt report.  These tools are not interactive but they are simple to run 
and have the benefit of consuming no local resources. 

Web-based tools - run most of their analysis processing on the ISA server and provide a rich, interactive 
experience in the browser based user interface.  These types of tools are ideal for activities where you 
want to off-load heavy processing of files to a more powerful server. 

Desktop tools - typical desktop client-side applications that are launched via the ISA browser UI.  By 
leveraging Java WebStart, the entire tool will be installed and run locally on your desktop.  This type of tool 
has a few drawbacks - a Java plugin is required for your browser, local system resources are required to 
run the client tool, and you must have local access to the files you wish to analyze.  However, some ISA 
tools are only available as desktop tools. 
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Note: 

By now the scanning of the case should be finished, let's check the results.   

 

 

_____ Click the Overview tab.  It shows useful system information determined from the log file(s) in the case.  
(If the scan is not completed nothing will display and you will have to repeat this step until data is ready). 
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_____ Click the Symptoms tab.  It shows a list of the errors encountered in the log file(s). 

 

 

 

_____ Click the Global Knowledge Base tab.  This compares the symptoms to a local database (XML file) to 
suggest possible resolutions including APARs (IBM fix references) and Technotes.  Click on a suggestion to 
see a detailed description below. 

 

 

 



 

 

  14 

http://www-01.ibm.com/software/support/acceleratedvalue/ 

IBM Software Accelerated Value Program 

 

 

_____ To demonstrate one of the report generator tools, first switch to the “PlantsByWebSphere” case that has 
been prepared for this lab by selecting it from the dropdown. 
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Note: 

The case contains file “Collector tool output impact2013Cell.jar”.  This is output from the WebSphere 
collector tool which collects information about the WebSphere Application Server configuration – it is 
frequently requested by IBM support when investigating PMRs. 

 

 

_____ To demonstrate one of the report generator tools, return to the Tools tab and select WebSphere 
Application Server Visualizer.  Then press the launch button. 
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_____ Navigate to the file Collector tool output impact2013Cell.jar  select it and press OK. 
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_____ Click Submit 

 

_____ Click on the Reports tab, then click the Refresh icon a few times until the report is complete, as 
indicated by a green tick icon. 
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_____ Select the completed report. 

 

 

 

Note: 

Take a look at the report in the right hand window.  This visualizes the topology of WebSphere Application 
Server.  For example, in this lab the topology consists of a single cell containing two nodes – one 
containing the deployment manager, and the second containing two application servers.  Those servers 
are part of a cluster called “PlantsByWebSphereCluster”.  In addition, there are several datasources 
defined in the configuration.   

 

_____  Try clicking on any of the topology components, the report is interactive and will pop up dialogues with 
more detailed information. 
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Part 3: Advanced Javacore Analysis with IBM Thread and Monitor 
Dump Analyzer Tool  

 

Note: 

Java dumps (ala javacore files or thread dumps) are useful for analyzing hung thread scenarios.  In this 
section, you will use a javacore file help debug a “Possible Hung Thread” warning in the WebSphere log 
file.  The following ISA 5 tools will be used: 

IBM Thread and Monitor Dump Analyzer – used to interpret Javacore files 

Memory Analyzer – used to inspect the Java objects associated with the hung thread 

IBM Extensions to Memory Analyzer– provides addition functions to correlate thread Ids in Javacore 
files with other WebSphere traces 

 

_____ Launch the browser and use the bookmarks to load the WebSphere Integrated Solutions Console 
(admin console) in a new tab. 

 

_____ Login using a blank user name. 

 

_____  Navigate to Servers->Server Type->WebSphere Application Servers.  Select server1. 

 

 

 

 

 

_____ Press the Start button and wait for the admin console to report the server has started. 
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Note: 

Next you will use the Jmeter load generating tool to simulate some user requests to the Plants web 
application.  Some of these user requests will trigger a deliberate error which you will diagnose using ISA 5 
tools. 

 

_____ Double click the Jmeter shortcut on the desktop. 

 

_____ Click File->Open and navigate to E:\Impact lab files\Jmeter scripts\Impact 2013-2.jmx.  Click 
Open. 
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_____ Click Run->Start.  Wait a few moments until the number of threads has reached 6, as indicated in 
the right hand corner of the Jmeter window. 

 

 

_____ From the desktop, double click the Tail icon. 

 

 

_____ Close any open files in Tail. 

_____ Use Tail to monitor the SystemOut.log of the server1.  The file is located at: 

 

C:\IBM\WebSphere\AppServer\profiles\AppSrv01\logs\server1 

 

_____ Monitor the file for a hung thread warning message similar to that shown below.  It may take up to 3 
minutes to appear (you may read the “Note:” section below while you wait).  Make a note of the thread title, 
e.g. “WebContainer : n” – the actual value of “n” may very with the screenshots in this lab document. 

Note: Be sure to watch the tail carefully as the error will scroll off the screen. 
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Note: 

WebSphere Application Server has a built in heuristic for detecting threads that could be potentially hung.  
To speed up this lab, some custom properties have been set to influence the behavior of the hung thread 
detection with the goal of making it trigger more quickly than normal.  In addition, automatic generation of 
Javadumps on hung thread detection has been configured.  The properties configured for the lab are 
summarized in the table below.  No action is required. 

 

Custom WebSphere Property Description Default Lab Setting 

com.ibm.websphere.threadmonitor.interval The frequency, 
in seconds, at 
which managed 
threads in the 
selected 
application 
server will be 
interrogated 

180 
seconds 

60 seconds 

com.ibm.websphere.threadmonitor.threshold The length of 
time, in 
seconds, in 
which a thread 
can be active 
before it is 
considered 
hung. Any 
thread that is 
detected as 
active for longer 
than this length 
of time is 
reported as 
hung 

600 
seconds 

120 seconds 

com.ibm.websphere.threadmonitor.false.alarm.threshold The number of 
times that false 
alarms can 
occur before 
automatically 
increasing the 
threshold 

100 0 (disabled) 

com.ibm.websphere.threadmonitor.dump.java Set to true to 
cause a 
javacore to be 
created when a 
hung thread is 
detected and a 
WSVR0605W 
message is 
printed 

false True 
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_____ After the hung thread warning has been made in the SystemOut log, switch to directory 
“C:\IBM\WebSphere\AppServer\profiles\AppSrv01”.  Verify that a Javacore.txt file has been 
automatically written by WebSphere Application Server in response to the hung thread notification. 

 

_____ Stop the Jmeter script by clicking Run->Stop.  Close the Jmeter window. 

 

Note: 

When analyzing hung threads or other performance problems, it is often useful to have several Javadumps 
over a period of a few minutes.  This can show that while a thread has been active for a long time, its 
current stack frame is changing meaning it is still busy processing its work, and actually not hung at all. 

In the next steps you will request the JVM to write a 2
nd

 Javadump, and a system dump.  There are several 
ways to do this including: 

1. wsadmin scripting interface 

2. Health Center tool 

3. WebSphere Administration Console (for WebSphere Application Server 8.0 and above) 

In this lab, you will use the WebSphere Administration Console. 

 

 

_____ Launch the browser and use the bookmarks to load the WebSphere Integrated Solutions Console 
(admin console). 

 

_____  Navigate to Troubleshooting->Java dumps and cores. 

 

 

_____  Select server1 and press Java core.  Wait a few minutes for the response. 
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_____  Select server1 and press System dump.  Wait a few minutes for the response.  A system dump takes 
longer than the Java dump in the previous step. 

 

 

Note: 

In previous versions of the IBM SDK shipped with WebSphere Application Server, it was necessary to 
post-process a system core file using a command called jextract before the system core could be used by 
tools such as Memory Analyzer.  However, newer SDKs do not require this jextract step. 

For reference, the IBM SDKs 1.6.0 SR9 or later, or any version of Java 1.7, no longer require jextract to be 
run.  A technote in the references sections correlates the WebSphere Application Server versions to the 
SDK shipped. 

This shows the SDKs which do not require jextract were shipped with WebSphere Application Server 
7.0.0.15 and above. 
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_____ Navigate to Servers->Server Type->WebSphere application servers.  Select the running server. and 
press the Stop button. 
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_____ Launch the browser and use the bookmarks to load the ISA web interface. 

 

 

_____  Create a new case by clicking the Cases button, and then Add. 
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_____ Complete the summary and description, and click the green tick. 

 

 

 

_____ Shrink the cases dialog by clicking Cases. 

 

 

 

 

_____ Add the two javacore.txt files, and one system dump file to the case by dragging the files from Windows 
Explorer into the ISA files list.  The location of the files is: 

 

C:\IBM\WebSphere\AppServer\profiles\AppSrv01 
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_____ Wait for the file add progress bar to read 100%, and for the yellow message box to appear. 

 

 

 

 



 

 

  30 

http://www-01.ibm.com/software/support/acceleratedvalue/ 

IBM Software Accelerated Value Program 

 

_____ Cick the yellow box to dismiss the message 

 

Note: 

The files are now safely stored in the ISA folder where they can be accessed by a team of people. 

The information in a Javadump is human readable, but the TDMA tool helps interpret the data.  The 
primary benefits this tool provides are: 

1. Summary of the Javadump, including any warnings, thread histogram by type and state, memory 
segment information, etc. 

2. User interface for navigating thread stacks and monitors. 

3. User interface for comparing multiple Javadumps and their respective thread stacks and monitors. 

To make an initial assessment of the files, it can be convenient to run a TMDA report on the ISA server.  
This avoids the need to download the files & TMDA tool to a local workstation.  More detailed analysis can 
be performed later using the desktop version of TMDA if required. 

In the next steps you will generate a basic TMDA report to see high level details contained in the 
Javadump file. 

 

_____ Ensure the relevant case is selected, then choose Thread and Monitor Dump Analyzer (TMDA) Report 
from the tools tab.  Click Launch. 
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_____ Click Browse and select one of the Javacore,txt files. 

_____ Click OK 
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_______ Click Submit. 

 

_______ Click the yellow box (not the link) to dismiss it, then click the reports tab. 

 

_______ Click the refresh icon until the report's status shows a green tick.  Then select the report. 

 

 

_______ Take a brief look at the report on the right hand side.  You should be able to find the following 
general information: 
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Cause of thread dump – This helps determine if the JVM experienced a crash or out of memory.  In 
this case, the dump was triggered by a user signal, i.e. WebSphere’s hung thread detection and/or the 
Health Center tool. 

Java Version – The exact java version is displayed making finding IBM fixes easier. 

System Classpath & User Arguments – Gives information about the Java environment and its 
configuration. 

Free & Allocated Java Heap Size – Learn if the heap is fully expanded, and what percentage 
occupied it is. 

Thread Status Analysis – Shows the status and number of running threads.  In TDMA, the different 
states are color coded.  The meaning of each state is explained later in this lab. 

Thread Method Analysis – Shows what code is being executed by each thread at the time of the 
Javacore 

 

 

 

Note: 

To diagnose the hung thread problem presented in this lab, the more advanced and interactive features of 
the desktop TDMA tool are required. 

 

 

 

 

 

 

_____ Choose Thread and Monitor Dump Analyzer (TMDA) Desktop from the tools tab.  Click Launch. 
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_____ Click Submit.  The TMDA desktop tool will be downloaded and launched using Java Web Start – 
this will take a few moments.  In the meantime, read the note below in preparation for using the TMDA 
desktop tool. 

 



 

 

  37 

http://www-01.ibm.com/software/support/acceleratedvalue/ 

IBM Software Accelerated Value Program 

 

Note: 

The SystemOut log file reported a “possible hung thread” warning, i.e. a thread that has been active for a 
period of time longer than considered normal by the hung thread detection heuristic.  The log file also 
showed the name of the thread (something like “WebContainer : 5”) and a stack trace of the currently 
executing code. 

 

You can learn the naming convention of common WebSphere and JVM threads by referring to a technote 
in the the references section.  Threads starting with “WebContainer” are WebSphere threads dealing with 
incoming HTTP requests that come from the client.   
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The Java stacktrace showed that a ShoppingBean object in the PlantsByWebSphere application had 
executed a Thread.sleep, meaning the thread did not end in a timely manner.  However, it is likely that the 
WebSphere Application Server will have many “WebContainer” threads that are handling incoming HTTP 
requests, and many would be executing the ShoppingBean code.  The remaining steps of this lab will 
investigate why that particular thread encountered a (deliberate) problem. 

 

_____ In the TMDA tool. Select File->Open thread dumps 

 

_____ Navigate to C:\ISA5Beta2\ISA5\isa\cases\0002 

 

 

 

_____ Select the first Javacore.txt file, and click Open (look at the last few characters of the filename to 
determine which was created first). 
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_____ Select the Javacore.txt file in the Thread Dump List.  Below you will see the general overview 
information that you saw in the previous TMDA report.   

 

_____ Right click the file and choose Thread Detail from the popup menu. 

 

 

_____ Maximize the tool's windows and expand the columns in the TDMA “Thread Details” window to see 
more information.   
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_____  Click the Name column heading to sort the threads by name.  As we already know there is a problem 
with a WebSphere web application, it seems reasonable to only investigate WebSphere threads, specifically 
the “WebContainer” threads. 

 

 

_____ The exact states of the “WebContainer” threads in your Javacore may vary.  In the screenshot above, 
the majority of thread states are purple in color and one is green.  Purple threads are threads in state 
“Condition Wait” and green threads are “Runnable”.  An explanation of these states follows in the note below: 

 

 

 

 

Note: Definition of Thread States 
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State Name TDMA 
Default 
Colour 

Description Tips and Tricks 

R Runnable Green The thread is able to 
run when given the 
chance 

Many threads that you may 
expect to be “runnable” are 
actually shown as “condition wait” 
in Javacores from JDK 5 and 
above.  This is actually by design 
as the JVM sets many threads to 
“Condition Wait” as it writes the 
Javacore.   

See “Unexpected Conditional 
Wait thread states in IBM 
Javacore” in the references for 
more details. 

CW Condition Wait Purple The thread is waiting. 
For example, 
because: 

A sleep() call is made 

The thread has been 
blocked for I/O 

A wait() method is 
called to wait on a 
monitor being notified 

The thread is 
synchronizing with 
another thread with a 
join() call 

Common methods at the top of 
the stack trace for threads in this 
state include: 

Object.wait: Waiting for a notify 
from another thread 

Thread.sleep: Operating system 
call to sleep for X ms 

AsyncLibrary.aio_getioev2: Async 
I/O waiting on new work 

SocketInputStream.socketRead0: 
Socket established, processing or 
waiting for data 

S Suspended Salmon The thread has been 
suspended by 
another thread 

 

Z Zombie  The thread has been 
killed 

 

P Parked Cyan The thread has been 
parked by the Java 
concurrency API 
(java.util.concurrent). 

 

 

 

_____ Select the web container thread that caused the hung thread warning in the WebSphere log file (refer 
to your SystemOut.log to confirm the exact title which may vary from the one shown in this lab document).   
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_____ Verify the state of the thread and confirm it is not deadlocked.  Deadlocking would be a possible cause 
of a hung thread and the JVM has automatic detection of this which would be reported in both the Javadump, 
and by TDMA.  If the thread was in deadlock it would be colored grey in TDMA, and be entitled “deadlocked”.  
In this lab, the hung thread is actually in state “Condition Wait” (purple).  In addition, note that the first line of 
the Java stack shows “java/lang/Thread.sleep” which matches the stack trace shown in the SystemOut log file.   

 

_____ Note the information in the panels on the right hand side.  This shows “Waiting Threads”, i.e. if the 
currently highlighted thread held a Java monitor and other threads were waiting for it, they would be displayed 
in this section.  In this lab, no threads are blocked by the hung thread under investigation.  In addition, the full 
Java and native stack traces are shown in the rightmost panel. 

 

 

Note: 

It is clear that the when the Javadump was generated, the suspected hung thread was performing a 
Thread.sleep.  However, this might be part of its design and perhaps after a short Thread.sleep it would 
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continue and finish its work, ending normally.  A good way to see if a thread is actually progressing (albeit 
slowly) is to use multiple Javacores over a period of time.  If the stack trace for this thread never shows a 
Java stack associated with incoming HTTP requests and only ever shows Thread.sleep, it will be 
increasing likely that the thread will not complete in a timely manner, meaning an application defect has 
been found. 

 

_____ Click File->Close all thread dumps, and close the “Thread Detail” window. 

 

_____ “File->Open thread dumps” and select both Javacore.txt files and click Open.  TDMA will compare the 
Javacore file written by WebSphere’s hung thread detection, and the other triggered manually a few minutes 
later via the WebSphere administration console. 

 

 

 

 

 

 

_____ Highlight both Javacores and right click.  Select Compare Threads from the popup menu. 
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_____ As before, maximize the windows and expand out the columns.   Order the first column by name to 
locate the “WebContainer” threads.   

_____  The two columns show the state of the threads a few minutes apart.  You will probably find that some 
or all of the “WebContainer” threads show a different stack in each column indicating the threads were 
executing different code at each point in time.  However, the thread that has been identified as a hang suspect 
will definitely be highlighted in red meaning that TDMA also considers it a hang suspect.  This is because it is 
showing exactly the same Java stack in both Javadumps.  Therefore the thread is still paused in a 
Thread.sleep, confirming the suspicion that it really is hung and not just proceeding slowly. 

 

 

 

 

 

 

 

 

 

 

 

Note: 
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To find more detail about this hung thread, it can often be useful to relate the thread to a system dump.  In 
addition this provides a correlation between the thread name seen in the Javadump, and the thread Ids 
that would be traced by WebSphere’s logging and tracing mechanism.  The technique to achieve this 
mapping will be demonstrated later in this lab. 

A system dump contains information about the Java threads whereas an IBM heap dump (.phd) does not.  
The Memory Analyzer can present the same thread information when inspecting an IBM heap dump if both 
the heap dump and a Javacore from the same point in time are loaded into the tool simultaneously. 

However a system dump is the only format that includes the full details about Java field names and values.  
Therefore this type of dump is the most useful for debugging Java issues, especially hung threads or other 
performance issues as demonstrated in this lab. 

 

 

_____ Close the TDMA windows, pressing the Yes button to exit. 

 

 _____ Return to the ISA 5 tab in the browser. 

 

 _____ From the Tools tab, select Memory Analyzer (Desktop) and click Launch. 
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_____ Click Submit and wait for the Memory Analyzer tool to download and launch.  Note that the window 
does not take focus, so click the program on the taskbar. 

 

 

_____ Click File->Open Heap Dump.   

 

_____ Navigate to path below and and open the system dump you previously triggered via the WebSphere 
admin console.  The system dump file will end “.dmp”. 

 

C:\ISA5Beta2\ISA5\isa\cases\0002 

 

 

Note: 
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Please be patient while Memory Analyzer parses the dump, approximately 3-5 minutes may pass with little 
nothing reported by the progress bar. 

 

_____ A warning may be displayed about a missing snapshot. Dismiss this warning by pressing OK 

 

_____ Click Cancel on the Getting Started Wizard. 
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_____ Click the Open Query Browser icon  and select Java Basics->Thread Overview and Stacks 
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_____ Click Finish to show all Threads 

 

_____ In the table, locate the ThreadPoolWorker thread with name “WebContainer” that was reported as hung.  
Remember, the exact Id may differ from the screenshots in this lab.   

 

_____ Highlight the thread and right click it.  Try launching  Java Basics->Thread Details to inspect all details 
about the thread.  
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Note:  

 Key point to note here is that the thread stack that is hung as shown above points to the method 
“ShoppingBean.performProductDetail” which in turn calls the method 
“ShoppingBean.deliberateHungThread” as being responsible for calling Thread.sleep.   

_____ Next, return to the “thread_stacks” window or tab and ensure the hang suspect thread is still 
highlighted as shown below.  Look at the information in the “Inspector” panel on the left hand side and note 
that the thread has an attribute “isHung” which is set to true.  The IBM Extensions for Memory Analyzer 
have also annotated the Thread Stacks report with the text [Hung] to further emphasize this.  This 
confirms that the thread was still considered hung by WebSphere Application Server at the time the 
system dump was triggered. 

 

 

 

 

 



 

 

  51 

http://www-01.ibm.com/software/support/acceleratedvalue/ 

IBM Software Accelerated Value Program 

 

 

 

 

_____ In the “thread_stacks” window, expand the thread by clicking on the “+” next to it and look for the 
method “ShoppingBean.performProductDetail” as seen in the stack earlier since it was responsible for calling 
Thread.sleep.  Inspect the local variables and their values – in this case an instance of ShoppingBean and a 
RequestParameterMap as shown below.   
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This technique normally gives a lot of information about what the thread was processing. For example if it 
has opened a socket, the values will show the destination IP.  Similarly, if the thread is performing a 
database query, the internal structures will reveal the SQL.  This is the reason a system dump is 
recommended for debugging performance related issues such as hung threads. 

_____  In this scenario, looking for the HTTP request values could be of interest.  Take a look at the 
screenshot and expand your stack frame to find the request parameters, specifically the “key” itemID.  Select 
“value” below to see the value in the Inspector window on the left hand side. 
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The sequence of references may look quite complicated, but to someone familiar with the JSF framework 
they would probably be quite familiar.  You can see that by looking at JSF references relating to the 
request, eventually you find a “_parameters” Hashtable that has an “itemID” with value “V0006”. 

 

This may relate to a product Id in the ShoppingBean, and could determine the exact HTTP request that 
caused this particular thread to become hung while other “WebContainer” threads did not. 

 

_____ Collapse the “ShoppingBean.performProductDetail” stack frame you were inspecting. 
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_____ In the stack frame of the same thread, scroll down and double click the 25 out of 51 entries (your 
values may vary) 

 

 

 

 

_____ Scroll down to a method earlier in the servlet lifecyle.  Highlight the method 
“com.ibm.ws.WebContainer.handleRequest”.  Note that there are similar methods above and below, so be 
sure to locate the correct method.  In this method we should be able to find the HTTP request object, which 
can help to determine the URI that was being processed by the Web Container thread. 

 

 

 

_____ Expand the references until the variable “request” of type 
“com.ibm.ws.channel.imp.HttpRequestMessageImpl” is located.  Of course it takes some experience to locate 
the right data structures. 
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_____ Refer to the Inspector window on the left hand side.  The request parameter includes the URI 
“/PlantsByWebSphere/shopping.jsf” 

 

 

 

_____ Optionally. inspect some of the other “WebContainer” threads.  They may have completely different 
thread stacks to the hung thread.  If you find one that has a similar stack, i.e. with 
ShoppingBean.performProduct detail() close to the top, repeat the previous steps to locate the HTTP 
request information again.  You will find that no other threads are dealing with requests where the item id 
is “V0006”.  It is becoming increasing clear that the HTTP request that caused the hung thread was for a 
PlantsByWebSphere item with an id of “V0006”.   

Optional Steps: 

_____ Double click the desktop shortcut to ShoppingBean.java to inspect the programming error. 

 

 

_____ Click Edit->Find and search for “V0006”.   
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The deliberate error is indeed related to a product with Id “V0006”.  When a request for this product is 
received, the method “deliberateHungThread” is called which puts the thread to sleep for an hour. 
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Part 4: (Optional) Mapping a Thread Id in a Javadump to the output of 
WebSphere logging or trace (10 minutes) 

Note: 

If you need to correlate a thread Id from a Javadump to the output of WebSphere logging or trace file, 
there are different options according to the version of WebSphere Application Server being used.  In a 
default configuration, WAS logging and tracing both print out a "thread identifier" with each log entry. This 
identifier has no relationship to the internal or native thread identifiers for that Java thread. Therefore, this 
identifier by itself is only useful to correlate messages on the same thread within logs and trace, but not to 
Javadumps.  This behavior is by design, but thread identifiers may be aligned in future versions.  

Correlation between Javadumps and WebSphere logging or trace can be achieved using one of these 
methods: 

Method #1  

Thread identifiers may be correlated at any one point in time using a system dump, like the one used in the 
previous section of this lab.  The IBM Extensions for Memory Analyzer can be used to display an 
additional column, the “WAS Thread ID”.  You will try out this method in this part of the lab. 

Method #2  

You can also configure a server's trace output with the "Advanced" file formatting option to see more 
detailed trace information for use in troubleshooting and problem determination.  Below is an example of 
the advanced format which prints the thread name with each trace entry: 

[9/21/11 12:22:44:507 PDT] 00000022 I UOW=null source=com.ibm.ws.webcontainer.servlet 
class=com.ibm.ws.webcontainer.servlet.ServletWrapper method=init org=null prod=null component=null 
thread=[WebContainer : 0] 

Method #3 

Beginning in WebSphere Application Server Version 8.0 you can configure the server to use the High 
Performance Extensible Logging (HPEL) log and trace infrastructure instead of using SystemOut.log , 
SystemErr.log, trace.log, and activity.log files.  If you are using HPEL, you can access all of your log and 
trace information using the LogViewer command-line tool from your server profile bin directory.  

With HPEL enabled on a server, the logViewer command can be used to print both log and trace entries in 
the advanced format. In method #2, we had to explicitly change to advanced format. With HPEL, that 
information is always recorded, but we use different formatting options with the logViewer command to 
display the advanced format. For example: 

<WAS_PROFILE_ROOT>/bin/logViewer -format advanced 

Prints: 

[9/26/11 14:37:06:493 PDT] 00000026 I UOW= source=com.ibm.ws.webcontainer.servlet 
class=com.ibm.ws.webcontainer.servlet.ServletWrapper method=init org= prod= component= 
thread=[WebContainer : 0] 

SRVE0242I: [WasSwat] [/swat] [/index.jsp]: Initialization successful. 
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Note: Methods 2 and 3 assume that thread names are unique and unchanging, which is not always the 
case.  Method 3 is only available for WebSphere Application Server 8.0 and above. 

For more information on these methods, see the references. 

 

_____ In the Memory Analyzer window, return to the “Thread Overview and Stacks” window.  (If you have 
closed this, open the report again with Query Browser (button) -> Java Basics -> Thread Overview and Stacks, 
then click Finish) 

 

_____ Locate the ThreadPoolWorker thread with the thread name that was previously reported as hung in the 
WebSphere logs, for example “WebContainer : 7”.   
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_____ Scroll to the right to reveal the “WAS Thread ID” column.  This additional column has been added to this 
default report by the IBM Extensions for Memory Analyzer.  (Note the column order has been rearranged in the 
screenshot below) 

 

 

 

The system dump shows the hung thread uses WAS Thread ID 0x00000097. 

 

This can be correlated to any log statements in the SystemOut.log, e.g.: 

 

[2/13/13 6:54:11:343 PST] 00000097 SystemOut     O ==> STARTING LONG SLEEP 

 

The same id would be present in a WebSphere trace file. 
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Finally, to link the WebSphere logs to a thread in the Javadump, again you need the system dump to tie 
this together.  Either use the thread name, “WebContainer : 7” or the Native Id.  Note that the thread name 
is not necessarily constant and could be changed by the code.  To use the Native Id, convert the Native Id 
column from Memory Analyzer to Hex, and locate this in the Javadump.  In this case, the value 7892 is 
1ED4 in hex, and can be located in the Javadump: 

 

3XMTHREADINFO      "WebContainer : 7" J9VMThread:0x15358400, j9thread_t:0x08EE1D40, 
java/lang/Thread:0x03131050, state:CW, prio=5 

3XMTHREADINFO1            (native thread ID:0x1ED4, native priority:0x5, native policy:UNKNOWN) 

3XMTHREADINFO3           Java callstack: 

4XESTACKTRACE                at java/lang/Thread.sleep(Native Method) 

4XESTACKTRACE                at java/lang/Thread.sleep(Thread.java:896) 

4XESTACKTRACE                at 
com/ibm/websphere/samples/pbw/war/ShoppingBean.deliberateHungThread(ShoppingBean.java:415) 

 

 

_____ Optionally try to link together output from your hung thread in SystemOut.log with the Javadump, using 
the system dump as described above. 
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Reference Links 

• IBM Support Assistant Information and Downloads: 

http://www-01.ibm.com/software/support/isa/ 

• Verify Java SDK version shipped with IBM WebSphere Application Server fix packs 

http://www-01.ibm.com/support/docview.wss?uid=swg27005002 

• Problem determination for javacore files from WebSphere Application Server 

http://www-01.ibm.com/support/docview.wss?uid=swg21181068 

 

• Mapping Underlying Java Thread Identifiers to those in Logging and Trace 

http://www-01.ibm.com/support/docview.wss?uid=swg21418557 

 


