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What this lab is about 
 

This lab is provided AS-IS, with no formal IBM support. 

 

In this lab you will use IBM Support Assistant 5 Beta (ISA 5) to diagnose JVM issues experienced by a 
running WebSphere Application Server 8.5.   

 

A badly implemented web application will be used to simulate common problems such as memory leaks, 
unexpected garbage collection cycles triggered by System.gc(), large application objects and large 
HTTP session sizes. 

 

The lab demonstrates how ISA 5 facilitates team team-based collaboration, and provides server-level 
diagnostic tools to carry out analysis.  It also describes the data needed to debug the issues, and 
introduces the Java problem determination tools available as part of the IBM Support Assistant including 
Health Center, and Memory Analyzer. 

 

The lab also uses the new health management self protecting and self healing features of WebSphere 
Application Server 8.5 to dynamically monitor and manage servers, helping to preserve service even if 
something is about to go wrong. 
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Lab requirements 
 

List of system and software required for the attendee to complete the lab. 

• WebSphere Application Server V8.5.0.1 

• IBM Support Assistant V5 (Beta 2) with the following tools installed: 

► WebSphere Application Server Configuration Visualizer 

► IBM Monitoring and Diagnostic Tools for Java™ - Health Center (ISA 5 desktop tool) 

► IBM Monitoring and Diagnostic Tools for Java™ - Memory Analyzer (ISA 5 desktop tool, web 
edition tool, and report tool) 

► IBM Extensions for Memory Analyzer (Packaged with the Memory Analyzer ISA 5 desktop 
tool) 

 

What you should be able to do 
 

At the end of this lab you should be able to:- 

• Launch and configure Health Center to monitor a running WebSphere JVM 

• Identify bugs in running code such as unnecessary calls to System.gc(), large object allocations and 
memory leaks 

• Define a WebSphere Application Server health policy to automatically restart a server if a memory leak 
is detected 

• Understand the basic techniques for debugging Java™ memory issues with Memory Analyzer, using 
desktop, web and report editions 

• Analyze a heap dump to determine those objects consuming the most heap space 

• Use IBM extensions for Memory Analyzer to perform product specific memory analysis of a system 
dump 

 



 

 

 
4 http://www-01.ibm.com/software/support/acceleratedvalue/ 

 

IBM Software Accelerated Value Program 
 

Part 1: Lab Set Up 
 

_____ Login to the VMWare image with the username/password below: 

 

Username :Administrator 

Password : Impact2013 

 

Note:  

Due to the physical memory on the VMware image being used for this lab please understand that certain 
operations may take time to perform – please be patient.  The expected duration of this lab is 55 minutes 
and each part has an estimated duration.  The final lab section is marked as optional so you can attempt 
this if there is sufficient time, or skip other sections according to your interests. 
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Part 2: IBM Support Assistant 5 Beta  
 

 

Note: 

 

The IBM® Support Assistant (ISA) is a free application that provides features for problem determination, 
and a platform for obtaining diagnostic tools. The most recent release of ISA (version 5.0), which is 
currently in beta, brings these capabilities into a server environment.  This enables an administrator to 
install a single instance of ISA that can be used by a group of users and accessed via a web browser.  
Therefore resources, files, information, and server-level tools can be shared.  This facilitates team based 
collaboration and avoids the need for each team member to install diagnostic tools on their local 
workstation. 

 

ISA v5.0 can be installed from an EAR file into an existing WebSphere Application Server, or using a 
simple “all-in-one” unzip install which contains everything required, including a lightweight application 
server and Java runtime.  This lab uses the latter approach. 

 

In this part of the lab, you will use ISA to understand its key concepts, and test some of the core functions. 

 

 

 

_____ Launch the browser (Mozilla Firefox) and then use the bookmarks to load the ISA web interface as 
shown below. 
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Note: 

 

Like previous releases of ISA, the tool can be used to find problems, analyze data, and send information to 
IBM support.  As it is a multi-user installation, ISA provides a case management component to help  
manage various problem determination activities that a team might require.  A case is simply a container 
for a logical grouping of files and information. A typical practice would be to group artifacts pertaining to a 
single issue.  

 

_____  Create a new case by clicking the Cases button, and then Add. 
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_____ Complete the summary and description, and click the green tick as shown below. 

 

 

 

 

_____ Shrink the cases dialog by clicking Cases. 
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_____ Having made a new case, diagnostic data can be added.  This lab provides a sample WebSphere 
Application Server SystemOut log file as shown below on the Windows desktop.  Open this file from the 
desktop, and note that it contains various WebSphere error messages and Java stack traces. 

 

 

 

_____ Close the text editor. 
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_____ Add this sample SystemOut log to the ISA case by dragging it from the desktop to the ISA file list in the 
browser. 

 

 

 

 

 

 

 

 

_____ Click the yellow box to dismiss the notification. 

 

 

 

 

_____ Click the refresh icon in the Navigator to see the files in the case. 

 

 

 

 

_____ Click the Status button.  Notice the “Ticket” (case) has not been scanned. 
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_____ Click the Scan this Case button as shown above. 

 

 

 

 

 

_____ Click Submit to start the Scan. 
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Note: 

 

Scanning the case takes a few minutes.  In the meantime, let's investigate the tools that are installed into 
ISA 5. 

 

 

_____ Click the Tools tab.  Note that only the tools that will be used in this lab have already installed, more 
tools are available.   

 

 

Note:  

 

There are three key types of tools provided in ISA and each type has its benefits and compromises.  

 

Report generator tools -  process input data (e.g. log files or Java dumps) and generate a simple output 
file, usually in the form of an HTML or .txt report.  These tools are not interactive but they are simple to run 
and have the benefit of consuming no local resources. 

 

Web-based tools - run most of their analysis processing on the ISA server and provide a rich, interactive 
experience in the browser based user interface.  These types of tools are ideal for activities where you 
want to off-load heavy processing of files to a more powerful server. 

 

Desktop tools - typical desktop client-side applications that are launched via the ISA browser UI.  By 
leveraging Java WebStart, the entire tool will be installed and run locally on your desktop.  This type of tool 
has a few drawbacks - a Java plugin is required for your browser, local system resources are required to 
run the client tool, and you must have local access to the files you wish to analyze.  However, some ISA 
tools are only available as desktop tools. 
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Note: 

 

By now the scanning of the case should be finished, let's check the results. You can confirm this by clicking 
the status button as shown below.  

 

 

 

_____ Click the Overview tab.  It shows useful system information determined from the log file(s) in the case. 
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_____ Click the Symptoms tab.  It shows a list of the errors encountered in the log file(s). 

 

 

 

 

_____ Click the Global Knowledge Base tab.  This compares the symptoms to a local database (XML file) to 
suggest possible resolutions including APARs (IBM fix references) and Technotes.  Click on a suggestion to 
see a detailed description below. 

 

 



 

 

 
14 http://www-01.ibm.com/software/support/acceleratedvalue/ 

 

IBM Software Accelerated Value Program 
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Part 3: Setup Health Center to Monitor a running WebSphere JVM 
 

Note: 

 

In this section the Health Center tool will be used to profile the code.  Health Center is a free low-overhead 
diagnostic tool for monitoring applications running on an IBM Java Virtual Machines.  It consists of a 
workstation client and a JVM agent. The agent uses a small amount of processor time (less than 3%) and 
memory on the server.  It is installed by default in an IBM JVMs at Java 5 SR8 or IBM Java 6 SR1 and 
above. 

 

The easiest way to attach the Health Center client to the agent is to configure the JVM to run the agent at 
start up with JVM “-Xhealthcenter” generic argument.  In this lab, that argument has already been 
configured for both application server JVMs. 

 

It is also possible to use a feature called “late attach” to connect the Health Center client to an already 
running JVM “on the fly”, without having pre-configured any command line properties.  This lab does not 
demonstrate this technique, but more information can be found in the Health Center InfoCenter. 

 

_____ If not launched already, launch the browser and use the bookmarks to load the ISA web interface. 

 

_____ Switch to the Tools tab, select Health Center and click the Launch button. 
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_____ Click Submit.  The Health Center client will be downloaded and launched using Java Web Start – this 
will take a few minutes, then a new connection dialogue will appear.  In the meantime, continue with the next 
steps. 
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Note: 

 

In this lab, the Plants by WebSphere application will be accessed via the IBM HTTP Server.  It is 
configured to load balance requests between the application servers, and maintain session affinity once a 
HTTP session has been established.  Multiple instances of Health Center can be started to monitor 
multiple JVMs if necessary.  However, for now, to keep things simple only one JVM will be monitored, and 
the other JVM will be stopped. 

 

 

_____ Launch the browser and use the bookmarks to load the WebSphere Integrated Solutions Console 
(admin console) in a new tab. 

 

_____ Login using a blank user name. 

 

_____  Navigate to Servers->Server Types →WebSphere Application Servers.   

 

 

_____  Select server1. 
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_____ Press the Start button and wait for the admin console to report the server has started. 

 

 

 

 

 

_____  Return to the Health Center client window.  Click Next on the connection wizard. 
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_____  The JVMs in this lab have been configured to run the Health Center agent on ports 1990 (server 1) and 
1991 (server 2).  Change the port to 1990 and Click Next to scan for these ports. 

 

_____  Highlight the Heath Center agent on port 1990 as soon as it appears and click Finish as shown below. 
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_____ Switch to the connection tab and verify the connection status shows an active connection as shown 
below. 
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Part 4: Use Health Center to Investigate Application Errors 

Note: 

 

WebSphere Application Server is running the Plants by WebSphere sample web application which has 
been modified with some deliberate programming errors. 

 

_____ First verify the Plants by WebSphere sample is running.  Launch the browser and use the bookmarks to 
visit the Plants by WebSphere site in a new tab.   

 

_____ Feel free to have a look around, but to avoid some deliberate mistakes do not click any products on the 
Accessories tab. 
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Note: 

 

Next you will use the Jmeter load generating tool to simulate some user requests to the Plants web 
application.  Some of these user requests will trigger deliberate errors which you will diagnose using 
Health Center. 

 

_____ Double click the Jmeter shortcut on the desktop. 

 

_____ Click File->Open and navigate to “E:\Impact lab files\Jmeter scripts\Impact 2013-1.jmx”.  Click 
Open. 
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_____ Click Run->Start.  Wait a few moments until the number of threads has reached 2, as indicated in the 
right hand corner of the Jmeter window. 

 

 

 

 

_____ Switch to the Health Center window which should already be monitoring the WebSphere JVM (if not 
make a new connection with File->New Connection).  Click the Status tab. 
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Note: 

 

The Health Center status panel summarizes the main categories of data that Health Center is monitoring, 
and also summarizes current recommendations.  Note that the data categories to be collected can also be 
customized from the Monitored JVM menu. 

 

 

 

_____ Start by analyzing where the WebSphere JVM is spending most of its time to see if any optimizations 
can be made.  Click the Profiling link. 

 

Note: 

 

Health Center uses a “sampling based” method profiler.  This means it takes a periodic sample of the 
methods running and reports which are consuming the most time in the JVM.   

 

_____ Sort the table of data by “Tree %” by clicking the Tree % column heading.   
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Note: 

 

Within the Health Center, collections of methods are organized into structures called trees.  You should 
see that in this case, a “ThreadPool$Worker.run()” method represents the top of a tree which is 
consuming a very high percentage of the JVM’s time. 

 

However, also note the value in the “Self (%)” column, which indicates that the method 
“ThreadPool$Worker.run()” is actually using a low percentage of the JVM’s time.  Therefore the problem 
must be in some code called by the “ThreadPool$Worker.run()” method, i.e. further down the tree / method 
call stack. 

 

As incoming HTTP requests are handled by WebSphere using the “ThreadPool$Worker” class, this gives a 
clue that there could be something wrong in a running web application.   

 

 

 

 

_____ Reorder the table to see results for individual methods by clicking Self %.   

 

 

Note: 

 

Now you can see the individual method “deliberateSlowMethod” in the ShoppingBean class is using a 
high percentage of the JVM’s time.  Note, the “Self” and “Tree” columns (without the % symbol) are a 
graphical indication of the same data. 

 

_____ Select the expensive method in the table by clicking it once. 
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Note: 

 

The “Invocation paths” tab shows what is calling the “deliberateSlowMethod”.  The “timeline” tab shows 
when the “deliberateSlowMethod” was invoked. 

 

Also notice that Health Center has automatically identified the time consuming method and has highlighted 
this fact in the “Analysis and Recommendations” section. 

 

 

_____ As the Plants sample is clearly suffering with at least one slow method, type 
“com.ibm.websphere.samples” in the “Filter Methods” box and click Apply. 

 

 

 

Note: 

 

You can see only the “ShoppingBean.deliberateSlowMethod” in the Plants sample has a high value for 
the “Self (%)”. 
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_____ Press the Clear button. 

 

Optional Steps: 

_____ Double click the desktop shortcut as shown below to ShoppingBean.java to inspect the 
programming error. 

 

_____ Click Edit->Find and search for “deliberateSlowMethod”.  Click Find Next to find the second 
occurrence of the search string. 

Note: 

The “deliberateSlowMethod” is invoked every time the user clicks on the tulips.  The 
“deliberateSlowMethod” executes a tight loop which does not end until a 10 second wait time has passed.  
You have found the first deliberate mistake. 
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_____ Return to the Health Center window and select the Garbage Collection link to monitor the performance 
of garbage collection and memory usage 

 

 

 

_____  Observe the current JVM heap size and used heap size after collection.  After starting the load 
generator, you will notice the heap size and heap usage has increased but by now should have leveled out.  
There is currently no evidence of a memory leak. 
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Note: 

Garbage Collection (GC) affects the entire application and tuning GC correctly can potentially deliver 
significant performance gains. Health Center identifies where garbage collection is causing performance 
problems and suggests more appropriate command line options. 

 

_____  Observe the Analysis and Recommendations window.  It warns of large object allocations which of 
course are likely to trigger frequent garbage collections and may indicate the application code can be 
optimized. 

 

 

 

 

Note: 

 

Health Center allows you to view the size, time and code location of a large object allocation request that 
meets specific threshold criteria. 

 

_____ To investigate this further, select Monitored JVM->Garbage Collection and allocation data collection 
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_____ Select the box Enable collection of object allocation events within thresholds, and set a threshold 
to focus on the biggest objects.  The threshold values can be entered in bytes, kilobytes or megabytes.  Enter 
2m for the low threshold and 10m for the high threshold. 

 

_____ Click Finish.   

 

_____ Select the Object Allocations tab.  Wait a few moments until large object allocation data is parsed by 
the Health Center client – this could take up to 1 minute. 
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Note: 

 

Some large object allocations met the defined size threshold.  They are associated with creating a very 
large String.   

 

_____Select the Call Hierarchy tab, then the java.lang.StringBuilder row in the table to see the stack trace 
leading to this large String allocation. 

 

 

 

Note: 

 

Once again you will see the ShoppingBean class seems to be responsible, specifically a method named 
“deliberateLargeObjectAllocation”.  You have identified another deliberate error in the plants sample. 

 

Optional Steps: 

 

_____ Double click the desktop shortcut for ShoppingBean.java to inspect the programming error. 

 

_____ Click Edit->Find and search for “deliberateLargeObjectAllocation”.  Click Find Next to find the 
second occurrence of the search string. 
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Note: 

The “deliberateLargeObjectAllocation” is invoked every time the user clicks on the grapes.  The 
“deliberateLargeObjectAllocation” creates a large Array and fills it with a String of characters.   

The variables used are local to the method so once the request has finished; the large objects are eligible 
for garbage collection.  Therefore this is not a memory leak, but the creation of this large object makes 
unnecessary work for the JVM’s garbage collector.   

 

 

 

 

_____ Return to the Heath Center window and click the Summary tab.  This shows that System (forced) 
garbage collection is being called by some application code running in the JVM.  There may also be a warning 
in the Analysis and Recommendations window, depending on how many times System (forced) garbage 
collection has been called. 

 

 

 

Note: 

 

The Java code “System.gc()” forces a full garbage collection cycle.  This is generally not recommended as 
the garbage collector should manage its own schedule of garbage collection, and does not always need to 
execute the compaction phase of GC which is the most CPU intensive.  An application calling System.gc() 
will always trigger the most expensive compaction phase.   
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Health Center can be used to filter method innovations (for example, looking for System.gc).  However, the    
method profiling works on a sampling basis, so infrequent method calls might not appear in Health 
Center's profiling results.  Therefore, the best way to achieve this goal is to set a JVM trace, and use 
Health Center to extract this information from the JVM. 

 

The JVM has been pre-configured with the following command line property: 

 

-Xtrace:print=mt,methods={java/lang/System.gc},trigger=method{java/lang/System.gc,jstacktrace}  

 

This causes the JVM to print a stack trace each time the  java/lang/System.gc is executed.  Normally, this 
output goes to the native_stderr.log.  However, if the Health Center agent is also configured on the JVM 
(with -Xhealthcenter, like in this lab), then the output is instead directed to the Health Center Client. 

 

_____ In the Health Center window, click File->Export JVM Trace 

 

 

_____ Export the trace to “E:\trace.trc” 

 

_____ Open a command prompt, and issue command:  E: ( to change to the E: drive). 

 

_____ Then issue the following command: 

 

java com.ibm.jvm.format.TraceFormat trace.trc 
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Note: This may take a few minutes. 

_____ Open the resulting trace.trc.fmt in an editor such as Notepad++ 

 

_____ Search for java.lang.System.gc 
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Note: 

 

The formatted Java trace contains a stack trace for each time the java.lang.System.gc method was called. 

 

Once again the source of the problem is ShoppingBean which calls a method “deliberateSystemGC”.  
You have found another deliberate mistake in the plants sample. 

 

 

 

Optional Steps: 

_____ Double click the desktop shortcut for ShoppingBean.java to inspect the programming error. 

 

_____ Click Edit->Find and search for “deliberateSystemGC”.  Click Find Next to find the second 
occurrence of the search string.This “deliberateSystemGC” method is invoked every time the user clicks 
on the gloves.  The “deliberateSystemGC” method calls System.gc(). 

 

 
_____ Switch to the Jmeter load generator window.  Stop the load test by clicking File->Exit. 

 

 

 

Note: 

 

In subsequent parts of this lab, you will manually trigger the final deliberate error in the plants sample, but 
first you will set up a WebSphere Application Server Health Policy to help minimize the business impact of 
the error. 
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Part 5: WebSphere Application Server Health Management 
 

 

 

Note: 

 

WebSphere Application Server 8.5 provides significant new features for administration and operations 
staff.  This includes incorporating the Intelligent Management functions from IBM WebSphere Virtual 
Enterprise which can minimize end-user outages, and use operational monitoring to control the production 
environment.  One such feature is health management which monitors the status of the application 
servers, as well as sense and respond to problem areas before an outage occurs.  

 

The health of an application server can be managed with a policy-driven approach that enables specific 
actions to occur when monitored criteria are met.  In this section of the lab, a health policy will be defined 
which is triggered when memory usage exceeds a percentage of the heap size for a specified time, and 
health actions will be defined to correct the situation. 

 

_____ Launch the browser and use the bookmarks to load the WebSphere Integrated Solutions Console 
(admin console). 

 

_____ Navigate to Operational Policies->Autonomic Managers->Health Controller 
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Note: 

 

Note that health monitoring is already enabled.  The Control cycle length specifies the time between 
consecutive health checks, it has been set to the lowest possible value for this lab. 

 

_____ Navigate to Operational Policies->Health Policies. 

 

 

_____ Click New and name the policy “plantsHealthPolicy”.  Select the pre-defined health condition Memory 
condition: excessive memory usage as shown below and then click Next. 
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_____ First set the condition which should trigger the policy.  Set the JVM heap size % to 75%, and the 
offending time period to 1 second (this is very aggressive, but we want the policy to be triggered quickly in this 
lab environment). 

 

 
 

 

_____ Next specify the actions the Health Manager should take if the policy is triggered.  Select a Reaction 
Mode of Automatic.   
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_____ Press the Add Action button.  Select the predefined action Take JVM heap dumps.   

 

 

 

 

 

_____ Click Next 
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_____ To ensure heap dumps are triggered before the server is restarted, select  Take JVM heap dumps and 
press the Move Up button. 
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_____ Click Next 
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_____ Select Filter by Clusters, and highlight PlantsByWebSphereCluster 

 

 

 

 

_____ To add all members of the PlantsByWebSphereCluster to the health policy, click Add 
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_____ Click Next, then Finish 

 

_____ Click the Save link to save the changes to the Deployment Manager master repository. 

 

_____ Select System Administration->Nodes 
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_____ Select impact2013Node, and press Synchronize.  (The Nodes may have already synchronized 
automatically). 

 

_____ Navigate to Servers->Server Types ->WebSphere application servers.  Select the running server 
and press the Stop button. 

 

 

 

 

 

 

_____ Wait for the server to stop, then Click OK 
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Note: 

 

In the next section of the lab, you will cause a memory leak which triggers the health policy and its 
associated actions.  To demonstrate how diagnostic data (heap dumps) can be collected, without a 
significant impact to the application's users, all cluster members should be running. 

 

_____ Select Servers->Clusters->WebSphere Application Server Clusters. 

 

_____ Select PlantsByWebSphereCluster, and press Start.  This starts both servers in parallel. 

 

_____ Wait for the servers to start which will take a few minutes.    You may read ahead, but you must wait for 
the servers to start before attempting any actions in the lab.  You can check the status on the Servers->Server 
Types->Application Servers page, by pressing the refresh icon. 
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Part 6: Trigger a the Memory Leak to activate the Heath Policy 
 

 

 

Note: 

In this section you will trigger a deliberate error in the application which leaks memory.  This will trigger the 
Health Policy defined in the previous section, causing heap dumps to be written, before the JVM exhausts 
all the available heap space.  As the application runs in a cluster of two application servers, the corrective 
actions of the health policy (heap dumps followed by JVM restart) will have minimal impact to the user 
experience.  Having the health policy action restart the application server is more desirable than letting the 
application server run completely out of memory, causing an out of memory exception.  For example, when 
stopping the application server in a controlled way, it will be 'quiesced' meaning current requests will be 
completed before the server is stopped. 

 

The heap dumps produced should be adequate to diagnose the memory leak in the next section. 

 

_____ Return to the existing Health Center window and click the connection tab - the connection will have 
been dropped when server1 was restarted in the previous section.   
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_____ Click File->New Connection to re-establish a connection. 

 

_____ Click Next 
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_____  Click Next 

 

_____  Highlight the Heath Center agent on port 1990 (server1) and click Finish. 

 

 

 

Note: 

 

The goal of this section is to monitor the memory footprint, and see the health policy trigger its actions.  
However, with two JVMs it is more difficult to know which one serviced the client request, and therefore 
which JVM could be leaking memory. 

 

To determine this, you will use two instances of Health Center, and connect to each JVM on different port 
numbers.  After further clicks on the Wheelbarrow, it should become obvious which JVM is experiencing 
the memory leak.  Note the IBM HTTP Server is configured with session persistence, so all requests in the 
current session will be serviced by the same JVM. 
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_____ Return to the ISA tab in the browser.  Launch a second instance of Health Center by selecting the Tools 
tab, choosing Health Center and clicking the launch button. 

 

_____ Click Submit 

 

_____ A second Health Center client will be launched using Java Web Start.  This will take a few moments, 
wait for the new connection dialogue to appear. 
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_____ Click Next. 
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_____  Highlight the Heath Center agent on port 1991 (server2) and click finish. 

 

 

 

_____  Ensure that the Plants by WebSphere application can be accessed through the browser as 
follows.(Use the bookmark to access it if needed) 
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_____ Align the windows so both Health Center clients, and the browser can be viewed simultaneously. 

 

 

_____ In both Health Center client windows, click the status tab, click the Garbage Collector link, and select 
the Heap and Pause Time tab on the right hand side (if necessary). 

 

_____ Use the browser to access the Accessories tab and then click the Wheelbarrow product on the 
Accessories page of the Plants by WebSphere application as shown below.  This action triggers a deliberate 
error which causes the application's memory footprint to increase. 
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_____ In the browser window, click the Accessories tab.  Click the Wheelbarrow to view the product, then 
return to the accessories page by clicking the Accessories tab.  Repeat this step a further 3 times, giving a 
total of 4 wheelbarrow views in this step.  There is no need to add the item to the cart, just selecting it from 
the tools menu will trigger the memory leak. 
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_____ Return to the Health Center windows and wait for them to refresh their data a couple of times (there is a 
10 second pause between each refresh).  Take a look at the Garbage Collection statistics, you should see the 
used heap has increased significantly for one of the JVMs.  It seems there is a large memory leak over a short 
period of time in that JVM. 
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Note: 

Health Center can also be used to trigger a heap dump which is useful for analyzing memory leaks.  
However in general it is often beneficial to let the memory leak grow as large as possible, making the 
problem as easy to diagnose as possible,  

 

_____ In the health center window where the memory increase was observed, click the status summary and 
make a note of the port number and therefore server.  Recall port 1990 is server1 and 1991 is server2. 

 

 

_____ Close both Health Center windows, disconnecting them from the JVMs. 

 

_____ From the desktop, double click the Tail icon. 
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_____ Close any open files in Tail. 

_____ Use Tail to monitor the SystemOut.log of the deployment manager and either server1 or server2 (the 
one you have identified as having a memory leak).  The files are located at: 

 

C:\IBM\WebSphere\AppServer\profiles\Dmgr\logs\dmgr 

C:\IBM\WebSphere\AppServer\profiles\AppSrv01\logs\server1 

C:\IBM\WebSphere\AppServer\profiles\AppSrv01\logs\server2 

 

 

 

_____ In the browser, return to the Accessories tab and click the Wheelbarrow product one more time.  This 
should be sufficient to trigger the health policy actions as the JVM occupancy (after a garbage collection cycle) 
will have exceeded 85%.   

 

_____ In the tail window, monitor the Dmgr log and wait for up to up to 60 seconds until the logs similar to 
these are seen indicating that the Health Management controller has detected the condition as entered for the 
policy earlier and will be taking the appropriate actions: 

JVMMemorySubS W   WXDH3004W: The memory consumption limit specified by policy 
plantsMemoryHealthPolicy was exceeded by server server2 on node impact2013Node. The limit is 85 % and 
the current heap size is 90 % of the maximum of 131072 KB. 

HeapDumpTask  I   WXDH1014I: Heap dumps for server impact2013Cell/impact2013Node/server2 are being 
issued automatically. 

 

Note: 

The health management controller is managed by the WebSphere High Availability Manager which means 
it could typically be running on any node agent, or deployment manager.  For this lab, the health 
management controller has been configured to always start on the deployment manager, meaning it is 
easier to locate its logging output.  For details of how to configure where such controllers start, see the 
references. 
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Note: 

The logs indicate the JVM has occupied more than 85% of the available heap space and the health policy 
has been triggered.  At this time, heap dumps are triggered and then the application server JVM is 
restarted. 

 

When the heapdumps are generated, you may notice that Health Center pops up three dialog boxes to 
alert you.  You can ignore these. 

 

 

_____ In the tail window, monitor the SystemOut log for the server identified previously (i.e. server1 or 
server2). 

 

Note: 

If you timed it correctly, you will see the logs show the application server is busy restarting – you may have 
to wait a few moments until the restart process begins.  When it does, continue with the steps to see what 
happens to further application requests from the browser client. 

 

_____ In the browser, click a product – preferably not the wheelbarrow!  You can expect to see the warning 
below: 

 

 

 

Note: 

The IBM HTTP Server plugin has detected that one of the application servers is unavailable, and has 
routed the request to the other server in the cluster.   

 

In this lab environment, HTTP session objects are not shared between the JVMs as session persistence 
has not been configured, although this is possible using either memory to memory replication or database 
persistence. 

 

For this reason, the plants application displays a warning that the session data is unavailable, and to 
continue the user should start a new session. 
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_____ Start a new session by returning to the plants application homepage using browser favorites or typing 
URL http://localhost/PlantsByWebSphere 

_____ Click a few links to satisfy yourself that you can continue to use the application even though one of the 
application servers is being restarted. 

 

_____  At the admin console for the Application Server, refresh the status of the servers as shown below to  
ensure that the stopped server has restarted. 

 

_____  Use Windows explorer to verify that the health policy actions triggered some heap dumps.  By default 
they are written to the JVM’s working directory as shown below: 

 

 “C:\IBM\WebSphere\AppServer\profiles\AppSrv01”. 
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Note: 

In the next section, these heap dumps will be used to diagnose the memory leak.  While they represent a 
Java heap that was only 85% occupied, this should be sufficient to identify the objects that have 
contributed to the memory leak. 
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Part 7: Using ISA and the Memory Analyzer to Analyze a Heapdump  
 

 

Note: 

 

IBM Memory Analyzer is a powerful and flexible tool for analyzing Java heap memory, using heap dumps 
or system dumps. 

 

ISA 5.0 provides three ways to use this tool – HTML report, web interface and desktop tool.  This lab will 
demonstrate all three. 

 

You will use the heap dumps generated in the previous section.  However, as every heap dump is different, 
you may see some slight variation from the screenshots in this lab document, e.g. exact number of bytes 
for the object size or number of objects in a data structure etc. 

 

If you prefer, use the ready made heap dump in “E:\Impact lab files\heap dumps” – this files has 
previously been opened by Memory Analyzer which creates “index files”.  Using these files will slightly 
reduce the amount of time required to complete the lab – it’s up to you. 

 

 

_____ Launch the browser and use the bookmarks to load the ISA web interface. 

 

_____  Create a new case by clicking the Cases button, and then Add. 
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_____ Complete the summary and description, click the green tick. 

 

_____ Shrink the cases dialog by clicking Cases. 
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_____ Add one of the heap dumps to the case by dragging the file from Windows Explorer to the ISA case.  
The location of the heapdump file is: 

 

C:\IBM\WebSphere\AppServer\profiles\AppSrv01 

 

 

 

 

 

_____ Cick the yellow box to dismiss the message 
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Note: 

 

To make an initial assessment of a heap dump, it can be convenient to run a report on the ISA server.  This 
avoids the need to download the heap dump or system dump to a local workstation.  In the next steps you 
will generate a HTML leak suspects report. 

 

 
_____ Ensure the relevant case is selected, then choose Memory Analyzer Report from the tools tab.  Click 
Launch. 
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_____ Click Browse and select the heap dump in this ISA case.   
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_____ Click OK (but don't press Submit yet) 

 

 

Note: 

 

The reports to run are already selected.   

 

The leak suspects report is a key feature of Memory Analyzer.  It has capabilities to look for probable 
memory leak suspects including large objects or collections of objects that contribute significantly to the 
Java heap usage, and displays this information in the form of a pie chart. 

 

The top components report outlines the top memory consumers, i.e. the object at the top of the 'tree' which 
is responsible for keeping other objects alive in the heap.  Top consumers are not necessarily the cause of 
memory leaks, but could provide information on potential memory inefficiencies in the components. 
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_______ The Top Components Report is not required for this lab, so de-select it. 

 

 

 

_______ Click Submit. 

 

 

 

_______ Click the yellow box (not the link) to dismiss it, then click the reports tab. 

 



 

 

 
67 http://www-01.ibm.com/software/support/acceleratedvalue/ 

 

IBM Software Accelerated Value Program 
 

 

 

 

 

Note: 

 

The Memory Analyzer tool running on the ISA server will parse the heap dump, and generate the 
requested reports.  This takes a few moments so please be patient. 

 

 

_______ Click refresh icon until the report is listed and the green tick appears.  This can takes around three or 
four minutes so please be patient. 

 

 

 

_______ Select the report, then click the Leak Suspects Link as shown below. 

 



 

 

 
68 http://www-01.ibm.com/software/support/acceleratedvalue/ 

 

IBM Software Accelerated Value Program 
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_______ Examine the overview pie chart.  It indicates that a problem suspect occupies around 40Mb of the  
total heap occupancy. The exact statistics in your heap dump may vary. 

 

 

 

_______ Scroll down to examine the detailed description.  It identifies an object called ShoppingBean which 
responsible for a large percentage of memory, and that a single HashMap$Entry[] is involved. 
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Note: 

 

The object syntax “HashMap$Entry[]” refers to a HashMap object that contains an array of type Entry.  The 
dollar symbol indicates that Entry is an inner class of HashMap.  This appears to be the JVM's internal 
representation of a data structure used in the Plants application code. 

 

_____ Click on the Details link to display the shortest paths to an accumulation point.   

 

Note: 

 

An accumulation point is simply a reference in the chain that is suddenly responsible for keeping lots of 
heap space alive.  In this case, the single HashMap at the top of the table has been identified as the single 
object that is responsible for the large accumulation of further objects. 

 

The shortest path to this accumulation point shows what is responsible for keeping that accumulation 
object alive.  In this case an instance of the ShoppingBean class references the HashMap$Entry[]. 

 

 

_____ Scroll down to view the accumulated objects.   
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Note: 

 

This view shows the objects referred to by the HashMap$Entry[] accumulation point.  You will see the 
HashMap$Entry[] contains entries that total approximately 40Mb or 44% of the occupied heap space.  
Each object is around 4Mb or more in size.  Only the first 20 entries from the HashMap$Entry[] are shown 
in this report. 

 

Shallow heap refers to the size of an individual object in isolation, and retained heap includes all the 
objects that are referenced (and kept alive) by that object. 

 

 

_____ Scroll down to view the “Accumulated Object by Class” table.   
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Note: 

 

This shows the total number of objects referred to by the HashMap$Entry[] accumulation point, in this case 
over 37,000 objects with a retained size of over 40Mb.  The exact statistics in your heap dump may vary. 

 

Diagnosing the memory leak would require further analysis of the HashMap$Entry[], to determine exactly 
what is stored in that data structure.  However, the Memory Analyzer Report is static and it is not possible 
to follow the links to examine the chain of references between the objects.  To facilitate this, either the 
desktop or web version of Memory Analyzer could be used.  In the remainder of this lab section the web 
version will be used.  In the final section of the lab, the desktop edition will be used. 

 

 

_____ Click the ISA Tools tab.  Select the Memory Analyzer Web Edition.  Click Launch. 
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_____  On the “Problem Analysis” window that pops up as shown above, Click Browse and select the same 
heap dump in the ISA case as shown below.  Then, Click OK. 

 

 

 

 

_____ Click Submit.  The browser window may remain blank for a few moments. 
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_____ Wait for the heap dump to be parsed, this time the operation will be quicker as Memory Analyzer 'index 
files' already exist on the filesystem from the previous analysis. 
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_____ Select the Leak Suspects Report to generate the same report you generated previously with the 
Memory Analyzer Report tool.  Click Finish. 
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_____  Click the details link and scroll down to the “Accumulated Objects” table. 

 

_____  To determine what is stored in each of these HashMap entries, click the accumulation point link, i.e. 

the HashMapEntry with the array icon  
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Note: 

 

The left Inspector panel show details for the HashMap, including its attributes as shown below.   

 

 

 

_____ Right click the object reference in the Inspector tab, and select List Objects->with outgoing 
references to display all references from the selected HashMap object. 

 

Note: 

 

There are other more advanced ways to view outgoing references such as “Immediate Dominators” which 
can help simplify the chain of references by showing only the most significant references, i.e. only those 
that keep an object alive in the heap. 
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_____ Expand the top level HashMap object to show the thousands of entries that compose this HashMap. 
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_____ Scroll down and display some further entries by right clicking the “Total” and selecting “Next 25”.  The 
“Expand All” option is likely to take some time so avoid clicking that. 
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_____ Expand one of the HashMap entries.  Notice that the HashMap entry refers to a ShoppingContainer 
class in the plants sample (you will need to adjust the column widths). 

 

 

 

 

Note: 

 

The class name “ShoppingBean$ShoppingContainer” means the “ShoppingContainer“ class is an inner 
class of “ShoppingBean”.   

 

This ShoppingContainer object is responsible for keeping 784 bytes alive in the heap.  The HashMapEntry 
actually keeps 1616 bytes alive in total, including the ShoppingContainer.  All the other HashMapEntry 
objects in the list follow an identical pattern. The exact statistics in your heap dump may vary. 

 

_____ Try expanding another HashMap entry.  Their retained heap may vary, but they always contain a 
ShoppingContainer of the same size. 

 

 

 

 

Note: 

 

You have established that objects from the plants sample seem to be involved with the memory leak - a 
ShoppingBean is referring to a large HashMap that contains many instances of ShoppingContainer.  Let’s 
look at the overall footprint of the entire plants sample. 

 

_____ Click on the  icon on the Memory Analyzer toolbar to open a histogram. 
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_____ Type “com.ibm.websphere.samples.pbw.*” in the “Regex” filter box and press the Enter key.  The 

Regex filter box is the first line of the table, starting with the icon . 
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_____ Click the Retained Heap column heading to order the table by the largest retained heap. 
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Note: 

 

In this heap dump there are 60,000 instances of ShoppingContainer with a shallow heap of 9Mb and a 
retained heap of 47Mb.  The cause of this memory leak is becoming increasingly clear, and it seems only 
the ShoppingContainer and ShoppingBean classes are involved. The exact statistics in your heap 
dump may vary. 

 

 

Optional Steps: 

_____ Double click the desktop shortcut for ShoppingBean.java to inspect the programming error. 

 

 

 

_____ Click “Edit->Find” and search for “ShoppingContainer” to locate the definition of the inner class. 

 

_____ Click “Edit->Find” and search for method “deliberateMemoryLeak”, click “Find Again”. 

 

 

Note: 

 

You will find method “deliberateMemoryLeak” adds 10000 instances of the ShoppingContainer inner class 
to a static HashMap every time the wheelbarrow image is clicked.  The constructor of the 
ShoppingContainer class fills a pointless array of size 750 bytes.  This is the source of the memory leak. 
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Part 8: (Optional) Using the IBM Extensions to Memory Analyzer for 
Further Memory Analysis 

 

This part of the lab as the title indicates is optional. However, this is available for you to do as time 
permits. 

 

Note: 

 

 “IBM Extensions for Memory Analyzer” have been installed into ISA.  These were initially released by 
IBM via the IBM Alphaworks site.  They are now integrated with ISA 5 and have become a very useful 
extension to the Memory Analyzer tool.  They provide IBM product specific analysis of heap dumps by 
applying knowledge of the internal data structures of the IBM products into useful reports.  For example, 
there is a WebSphere Application Server report to view the size and other details of the WebSphere 
objects in the heap dump that hold the HTTP sessions.  This enables the Memory Analyzer tool to be used 
for more than just diagnosing memory leaks.   Most of the IBM extensions require the additional data 
only available in a full system dump, as opposed to a Java heap dump. 

 

A heap dump is a dump of the state of the Java heap memory. This is very useful for analyzing the use of 
memory by a Java application, and therefore very useful for diagnosing out of memory issues.  A system 
dump consists of all the memory that is being used by the JVM process; this includes the Java heap, 
along with all JVM and user libraries (native memory).  System dumps also contain field values of Java 
objects.  System dumps are often used in the diagnosis of other Java problem scenarios such as crashes, 
as they show detailed information about the state of the JVM.  Because a system dump contains all of the 
memory allocated by the JVM process, system dump files can be very large.  

 

In previous versions of the IBM SDK shipped with WebSphere Application Server, it was necessary to post-
process a system core file using a command called jextract before the system core could be used by tools 
such as Memory Analyzer.  However, newer SDKs do not require this jextract step.  For reference, the IBM 
SDKs 1.6.0 SR9 or later, or any version of SDK 1.7, no longer require jextract to be run.  A technote in the 
references sections correlates the WebSphere Application Server versions to the SDK shipped. This 
shows the SDKs which do not require jextract were shipped with WebSphere Application Server 7.0.0.15 
and above. 

 

To save time, for this section of the lab, a system dump is provided in “E:\Impact Lab Files\IBM 
Extensions”.  The dump was generated as a result of an out of memory condition. 

 

_____ Close the browser tab showing the Memory Analyzer web edition, where you analyzed the IBM heap 
dump. 

 

_____ In the ISA tab, click Tools, then select Memory Analyzer (Desktop) 
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_____ Click Launch, and then at the Run Memory Analyzer[Desktop] version pop window as shown below 
Click  Submit.   
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_____  Wait a few minutes for the Memory Analyzer Desktop tool to launch. Once launched you will see the 
following window. (If the window is not visible, select the IBM Monitoring and Diagnostic Tool  on the taskbar 
at the bottom of the windows desktop to bring up the tool.) 
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_____ Click File->Open heap dump.   

 

             
 

_____ Navigate to the system dump in E:\Impact Lab Files\IBM Extensions\. 

 

 

_____ Select the dump file labeled core.20130303.050212.7744.0001.dmp  and click Open.  Please be 
patient, parsing a system dump can take some time.  Approximately 3-5 minutes may pass with little 
nothing reported by the progress bar. 
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_____ On the “Getting Started Wizard” box, click Cancel to avoid generating the standard reports. 
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_____ Next, Click the reports icon   and select IBM Extensions->WebSphere Application Server-
>Class Loaders->Path to Leaking Application Class loader as shown below.   

 

 

_____ On the “Path to leaking Application Class Loaders” window, expand the classloader below by clicking on 
the “+” as shown below. 

 

_____ Left click any of the class loader identified as leaking and select List Objects->with outgoing 
references 
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_____ Expand the class loader references by clicking on the “+” as shown below. 

 

_____ The resulting objects loaded by this class loader relates to the plants sample class 
(com.ibm.websphere.samples.*) which gives a clear indication of the application that is leaking memory as 
shown below. 
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_____ Next, Click the reports icon   again and select IBM Extensions->WebSphere Application 
Server->WAS Cache Analysis.   
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This illustrates the contents of the WebSphere caches such as dynacache.  These types of caches reside 
in memory.  If the WAS cache report shows a high memory footprint, the size of the caches can be limited 
with WebSphere administration, or the cache contents can be automatically off loaded to disk.  For this lab, 
there is no action required. 

 

 

 

_____ Click the reports icon   and select IBM Extensions->WebSphere Application Server->Web 
Container Analysis.   
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_____  This shows details of all the configured web applications.  Observe that in this case only the Plants by 
WebSphere application has any active sessions.  In the next step, we will check the memory size of these 
sessions. 
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_____ Click the reports icon  , select IBM Extensions->WebSphere Application Server->HTTP 
Sessions->HTTP Sessions List.  This shows details of all HTTP sessions including the size, session 
attributes, timeout, user ID and session ID. 

 

 

 

 

_____ Ensure the table of sessions is ordered by “Retained Heap”.  (Click on the Retained Heap Column to 
order it as shown below) Notice how some or most sessions for PlantsByWebSphere are around 23k.   
while others are ranging from 9K to 24k. 
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_____ Let's Highlight and then expand one of the 23k session objects. (For this example, the first 23k in the 
ordered list was picked as shown below) 
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_____  The session attributes have been automatically extracted from the WebSphere objects and presented 
by the IBM Memory Analyzer extensions.  Notice there is a key called “deliberateLargeSession” which 
contains a very long String of letter “C”’s.  This looks like another deliberate mistake in the Plants 
application. 

 

 
 

_____ Make a note of the “_sessionId” for the object.  This can be seen on the “Attributes” tab as shown below 
on the left under the Inspector tab.   

 

 

 

 

_____  Right click it and choose Copy->Value, as shown below. 
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A possible way to relate this unusually large session to the application code is to search the log files for the 
session ID.  If the application uses this in its logging, it may be possible to determine what the user did to 
cause the large session.   

 

Note: 

This lab provides a SystemOut.log file that correlates with the time the system dump was generated.  This 
will be used to search for more details about the large session size. 

 

 

_____ Launch Windows Explorer.  Navigate to and right click file: E:\Impact Lab Files\IBM 
Extensions\SystemOut.log, then select Edit with Notepad++ as shown below. 
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_____ After Notepad++ opens the systemOut.log file. Select “Ctrl + F” or Click Search >Find and search the 
file for the Session ID you identified or copied earlier from the core dump. You should be able to copy the id 
from your clipboard into the search window.  It should then reveal a log statement that gives a clue about the 
application’s actions as shown below. 

 

 
 

 

Optional Steps: 

 

 

_____ Double click the desktop shortcut as shown below for ShoppingBean.java 

 

_____ Click Edit->Find and and search for “STARTING DELIBERATE LARGE SESSION”. 

 

 

 

The deliberate mistake is clear – for any user that clicks on the white poinsettia image, their session is loaded 
with an attribute containing a 10k string of “C”’s (ASCII code 67).  Congratulations, you have successfully 
located the final deliberate mistake in the plants sample. 
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Part 9: (Optional) Using the WebSphere Application Server 
Configuration Visualizer  

 

This part of the lab as the title indicates is optional. However, this is available for you to do as time 
permits. 

 

_____ Launch the browser and use the bookmarks to load the ISA web interface. 

 

 

_____ To demonstrate one of the report generator tools, first switch to the “PlantsByWebSphere” case that 
has been prepared for this lab, and click the Files tab. 

 

 

 

Note: 

 

The case contains file “Collector tool output impact2013Cell.jar” as shown below.  This is the output 
from the WebSphere collector tool which collects information about the WebSphere Application Server 
configuration – it is frequently requested by IBM support when investigating PMRs. 
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_____ To demonstrate one of the report generator tools, return to the Tools tab and select WebSphere 
Application Server Configuration Visualizer as shown below.  Then press the launch button. 

 

 

 

_____ Press the Browse button from the above window to select the input files. 
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_____ Select the file Collector tool output impact2013Cell.jar as shown above and press OK. 

 

 

 

_____ Click Submit 
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_____ Click on the Reports tab, then click the Refresh icon a few times until the report is complete, as 
indicated by a green tick icon. 

 

 

 

 

_____ Select the completed report. 

 

 

 

Note: 

 

Take a look at the report in the right hand window.  This visualizes the topology of WebSphere Application 
Server.  For example, in this lab the topology consists of a single cell containing two nodes – one 
containing the deployment manager, and the second containing two application servers.  Those servers 
are part of a cluster called “PlantsByWebSphereCluster”.  In addition, there are several datasources 
defined in the configuration.   
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_____  Try clicking on any of the topology components, the report is interactive and will pop up dialogues with 
more detailed information. 
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Reference Links 
 

• IBM Support Assistant Information and Downloads: 

o http://www-01.ibm.com/software/support/isa/ 

o ISA 5:   http://www-01.ibm.com/software/support/isa/teamserver.html 

• Health Center 

o http://www.ibm.com/developerworks/java/jdk/tools/healthcenter/  

• Configuring a controller to start on a specific node or deployment manager 

o http://www-01.ibm.com/support/docview.wss?uid=swg21425281  

• Verify Java SDK version shipped with IBM WebSphere Application Server fix packs: 

o http://www-01.ibm.com/support/docview.wss?uid=swg27005002 

• WAS 8.5 Infocenter: 

o http://www14.software.ibm.com/webapp/wsbroker/redirect?version=phil&product=was-nd-

dist&topic=welcome_nd 

• What’s new in WebSphere Application Server 8.0 & 8.5 

o http://www.ibm.com/developerworks/websphere/techjournal/1106_alcott/1106_alcott.html 

o http://www.ibm.com/developerworks/websphere/techjournal/1206_alcott/1206_alcott.html 

 

 


