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Introduction 

The IBM Integrated Runtime (IR) product contains DB2 Express Edition. Some of the larger 
Independent Software Vendors (ISV), Solution Developers (SD), and Solution Integrators 
(SI) want a mechanism to use the IBM IR deployment framework to deliver DB2 Workgroup 
Server Edition (WSE) and to take advantage of the increased capability of the DB2 product 
or its licensing terms. 

This document is targeted at the ISV or other developer who wants to create a wrapper for 
the DB2 WSE product for use in a solution for the Linux platform. 

The instructions provided in this document assume that the developer is logged in as the 
root user.  

Methodology 

This paper is separated into several sections to assist with the following tasks: 

o Generating a response file 

o Building the wrapper 

o Testing the wrapper 

Each section might include the following components: 

o Description – A general description of the section or exercise. 

o Interactions – The dependencies of the component in the solution, and the products 
that are depending on the component. Descriptions of interactions between other 
components within the solution and the subject component. 

o Control – How to start and stop the component, and the methods that you use to 
determine if the component is running. 

o Configuration – A description of the methods that you use to configure the 
component. 

o Problem Determination – How to determine the causes of problems with the 
component. 

o Additional Information – Where to find additional information about the component. 
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o Exercises – Hands-on exercises with the component. Exercises are separated into 
four types: 

o Installation Exercises – The components are installed in these exercises. 

o Configuration Exercises – The components are configured in these exercises. 

o Control Exercises – The components are controlled in some way in these 
exercises. 

o Optional Exercises – Some additional features or functions of the components 
are used in these exercises. 

Conventions 

This document uses the following conventions to illustrate various types of information. 

o All exercises are numbered, and each step within the exercise is numbered. It is 
important to complete the steps and exercises in the order they are provided. If an 
exercise or step is not required, it is indicated as optional. 

o Throughout the exercises, informational text is formatted like this current paragraph. 

o Commands are shown in the following font and format and should be typed exactly 
as shown, including letter case: 

Type this exactly – This command should be typed as though on a single command line. If part 
of the line is already present, do not type it. For example the drive d:\> may already be 

displayed in the command prompt and there is no need to type it again. 
 
install.bat d:\ 

o Code samples are shown in the following font and format. 

<html> 
<body> 

<p>This is sample code.</p> 
</body> 

</html> 
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DB2 WSE CD 

The source for creating the DB2 WSE application is on a DB2 WSE product CD that you can 
purchase from IBM through the Partner World O.E.M. sales channel. You must purchase an 
appropriate license to  bundle  DB2 WSE with a solution. Please contact a channel sales 
representative for licensing issues. 

CD Contents 

The DB2 WSE CD could have a tar file named DB2WSE8.1.tar or have contents similar to the 
following directory structure: 

 

Figure 1 Directory structure of the installation image or CD 

If the CD has the directory structure, create a TAR file using the following command: 

tar cvf DB2WSE8.1.tar /mnt/cdrom 



DB2 WORKGROUP SERVER EDITION 

7  

If you have the TAR file on CD and it is not named DB2WSE8.1.tar, rename it to DB2WSE8.1.tar. 
For the remainder of this document this product image file is refrerred to as DB2WSE8.1.tar. 

A TAR file is used for this application because of the presence of symbolic links in the 
installation image or CD. 

Response file 

A DB2 response file installation helps you install DB2 without interactive user input. 
Response files contain installation choices and configuration data that are otherwise 
provided by the user interactively on the installation Graphical User Interface (GUI). This is 
useful because it automates the process and helps you  embed the DB2 installation process 
transparently inside the installation program. The response file installation is one of the ways 
DB2 provides a complete solution for your embedded database needs. 

A sample response file named db2wse.rsp is available on the DB2 WSE installation CD in the 
db2/linux/samples/ directory. 
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Figure 2  Partial content of a generated response file 

*----------------------------------------------------- 

* Generated response file used by the DB2 Setup wizard 

* generation time: 2/26/04 10:01 AM 

*----------------------------------------------------- 

*  Product Installation  

LIC_AGREEMENT       = ACCEPT 

PROD       = WORKGROUP_SERVER_EDITION 

INSTALL_TYPE       = CUSTOM 

COMP       = DB2_CONTROL_CENTER 

COMP       = SQL_PROCEDURES 

COMP       = FIRST_STEPS 

COMP       = INSTANCE_SETUP_SUPPORT 

COMP       = RELATIONAL_CONNECT_FOR_DB2 

COMP       = CONFIGURATION_ASSISTANT 

COMP       = DB2_SAMPLE_DATABASE_SOURCE 

COMP       = CLIENT_APPLICATION_ENABLER 

COMP       = REPLICATION 

COMP       = JAVA_SUPPORT 

COMP       = DB2_ENGINE 

COMP       = COMMUNICATION_SUPPORT_TCPIP 

*----------------------------------------------- 

*  Das properties  

*----------------------------------------------- 

DAS_CONTACT_LIST       = LOCAL 

*  DAS user 

DAS_USERNAME       = dasusr1 

DAS_GROUP_NAME       = dasadm1 

DAS_HOME_DIRECTORY       = /home/dasusr1 

DAS_PASSWORD       = 245255342353326231349 

ENCRYPTED       = DAS_PASSWORD 

* ---------------------------------------------- 

*  Instance properties            

* ---------------------------------------------- 

INSTANCE       = inst1 

inst1.TYPE       = wse 

inst1.WORDWIDTH       = 32 

*  Instance-owning user 

inst1.NAME       = db2inst1 

inst1.GROUP_NAME       = db2grp1 

inst1.HOME_DIRECTORY       = /home/db2inst1 

inst1.PASSWORD       = 245255342353326231349 

ENCRYPTED       = inst1.PASSWORD 

inst1.AUTOSTART       = YES 

inst1.AUTHENTICATION       = SERVER 

inst1.SVCENAME       = db2c_db2inst1 

inst1.PORT_NUMBER       = 50000 

*  Fenced user 

inst1.FENCED_USERNAME       = db2inst1 

inst1.FENCED_GROUP_NAME       = db2grp1 

inst1.FENCED_HOME_DIRECTORY       = /home/db2inst1 

inst1.FENCED_PASSWORD       =  

 

* Contact  properties  

CONTACT       = contact1 

contact1.CONTACT_NAME       = db2inst1 

contact1.EMAIL       = db2inst1@spz.rchland.ibm.com 

contact1.PAGER       = false 

contact1.INSTANCE       = inst1 

*----------------------------------------------- 
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The first step of the response file installation process is to create a response file. When 
installing DB2 using the interactive setup utility, you are prompted to make installation 
choices and provide necessary configuration data before installation takes place. Using the 
following instructions,you can configure DB2 to create a response file that contains the 
choices you make. Later, during the application development, you can encode a process to 
replace the response file variables (for example, DB2 user id) with text that you can use to 
prompt the user during the deployment of the solution. 

Create the response file 

1. In Nautilus, double-click db2setup to start the DB2 WSE installation program. 
Alternatively, execute db2setup from the command line.  

2. Choose the custom installation option. Then check the response file generation 
option. 

 

 
 

Figure 3 Select the checkbox to generate the option file 

3. Select the desired options and complete the installation of DB2 WSE. 
4. Examine the installed copy of DB2 WSE and verify that it is setup the way you want 

it. 
5. This process leaves the response file db2wse.rsp in the root directory. 
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6. Modify the response file as illustrated in the following steps:  
 a.   Delete the following line from Instance Properties: 
       ENCRYPTED=isnt1.FENCED_PASSWORD   
 b.   Remove the password value for inst1.FENCED_PASSWORD from Instance Properties.  

 7. Verify that the values of inst1.NAME, inst1.GROUP_NAME, and inst1.HOME_DIRECTORY are the 
same as inst1.FENCED_USERNAME, inst1.FENCED_GROUP_NAME, and 
inst1.FENCED_HOME_DIRECTORY,respectively. For the purpose of this white paper an assumption is 
made that the user runs stored procedures and user functions under the normal db2 user id. 
Hence, a separate fenced user id is not required. This installation does not set up a fenced 
user in the default deployment parameter.  
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Creating the DB2 WSE application 
In IBM Integrated Runtime terminology, an application is one of the components of a 
solution. Examples of applications include DB2 or the actual application program package 
written by a developer. Applications are contained in application wrappers, and one or more 
application wrappers combine within a solution wrapper to make a complete solution. 

You must create an application wrapper for DB2 WSE and then package it into a test 
solution. Since the wrapper for the DB2 Express Edition is similar to the DB2 Workgroup 
Server Edition, it makes a good starting point. In this project, you modify a copy to create a 
wrapper for DB2 WSE. 

Copy the DB2 EE project 

1. Start the Solution Developer by clicking Menu > Extras > Other > Solution 
Developer. 

  

 
 

Figure 4 Solution developer 

2. Right-click IRU_DB2Express8_1Lnx and select Copy. 
3. Right-click and select Paste. 
4. Enter the new name for the application in the dialog box. For the remainder of this 

document, IRU_DB2WSE8_1Lnx is the name of the application. 
5. The following tree structure appears in Solution Developer: 
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Figure 5 Structure of the new project after the copy operation 

Modify the IRU_DB2WSE8_1Lnx project 

Modify the copied files to fit in the new project. The following operations need to be done: 
1. Delete the response file db2exp.rsp from src/IRU_DB2Express8_1Lnx. Copy db2wse.rsp 

from the root directory to the same location of deleted response file, db2exp.rsp. You 
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can select File > Import > File System to import the file instead of using the copy 
and paste method.  

2.  Open applicationdef.axml in an editor and make the following changes: 
a. Search for and replace all occurrences of db2exp.rsp with db2wse.rsp. 
b. Search for and replace the string Express (ignore case) with the string WSE. 
c. The previous search and replace renames the Java packages incorrectly.  

Convert all occurrences of an uppercase WSE to lowercase in any package or 
path name (for example, change com.ibm.iru.iru_db2WSE8_1lnx to 
com.ibm.iru.iru_db2wse8_1lnx.  
 Do not change the program names. Leave them as uppercase 
DB2WSE8_1LnxMain and DB2WSE8_1LnxVC. 

d. Change <file>DB2WSE8.1Pruned.tar</file> to 
<file>DB2WSE8.1.tar</file>. This sets the image file name to 
DB2WSE8.1.tar as shown in the following example:    

      <fileList id="media" includeAllFilesInSoftwareImageRoot="false"> 

        <file>DB2WSE8.1.tar</file> 
    </fileList> 

e. Check that the application id is successfully changed from 
IRU_DB2Express8_1Lnx to IRU_DB2WSE8_1Lnx. 

f. Modify the value of tag <defaultData> under <stringVariable> elements in 
the application according to db2wse.rsp setting as indicated in the following 
table. You might have different values in the db2wse.rsp file. If so, please 
substitute values in the “Changed to” column of the following table according 
to your db2wse.rsp. For example, value of inst1.PORT_NUMBER is set to 50000 
in the response file used in this document, if you have different value for 
inst1.PORT_NUMBER use that value instead of 50000 
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3. Rename the packages 

a. Expand the src/IRU_DB2Express8_1Lnx/userPrograms folder, right-click the 
com.ibm.iru.iru_db2express8_1lnx package and select Refactor > Rename. 
Enter com.ibm.iru.iru_db2wse8_1lnx for the new name and click OK. 

b. Expand the com.ibm.iru.iru_db2wse8_1lnx folder. Using the process in 3a, 
rename DB2Express8_1LnxMain to DB2WSE8_1LnxMain and  
DB2Express8_1LnxVC to DB2WSE8_1LnxVC.  

Keyword Original Change to 
( according to db2wse.rsp file) 

DAS_USERNAME <defaultData>db2admin</defaultData> <defaultData>dasusr1</defaultData> 

DAS_GROUP_NAME <defaultData>db2admin</defaultData> <defaultData>dasadm1</defaultData> 

DAS_HOME_DIRECTORY <defaultData>/home/db2admin</defaultData> <defaultData>home/dasusr1</defaultData> 

Db2inst1.FENCED_USERNAME 

Db2inst1.NAME 

<defaultData>db2inst</defaultData> 

<cidFileAssociation 

responseFileName=”db2wse.rsp 

keyword=”db2inst.FENCED_USERNAME”/> 

<cidFileAssociation 

responseFileName=”db2wse.rsp 

keyword=”db2inst.NAME”/> 

 

<defaultData>db2inst1</defaultData> 

<cidFileAssociation 

responseFileName=”db2wse.rsp 

keyword=”inst1.FENCED_USERNAME”/> 

<cidFileAssociation 

responseFileName=”db2wse.rsp 

keyword=”inst1.NAME”/> 

Db2inst1.FENCED_PASSWORD 

Db2inst1.PASSWORD 

<cidFileAssociation 

responseFileName=”db2wse.rsp 

keyword=”db2inst.FENCED_PASSWORD”/> 

<cidFileAssociation 

responseFileName=”db2wse.rsp 

keyword=”db2inst.PASSWORD”/> 

 

<cidFileAssociation 

responseFileName=”db2wse.rsp 

keyword=”inst1.FENCED_PASSWORD”/> 

<cidFileAssociation 

responseFileName=”db2wse.rsp 

keyword=”inst1.PASSWORD”/> 

 

Db2inst1.FENCED_GROUP_NAME 

Db2inst1.GROUP_NAME 

<defaultData>db2inst</defaultData> 

<cidFileAssociation 

responseFileName=”db2wse.rsp 

keyword=”db2inst.FENCED_GROUP_NAME”/> 

<cidFileAssociation 

responseFileName=”db2wse.rsp 

keyword=”db2inst.GROUP_NAME”/> 

 

<defaultData>db2grp1</defaultData> 

<cidFileAssociation 

responseFileName=”db2wse.rsp 

keyword=”inst1.FENCED_GROUP_NAME”/> 

<cidFileAssociation 

responseFileName=”db2wse.rsp 

keyword=”inst1.GROUP_NAME”/> 

 

Db2inst1.FENCED_HOME_DIRECT

ORY 

Db2inst1.HOME_DIRECTORY 

 

<defaultData>/home/db2inst</defaultData> 

<cidFileAssociation 

responseFileName=”db2wse.rsp 

keyword=”db2inst.FENCED_HOME_DIRECTORY”/> 

<cidFileAssociation 

responseFileName=”db2wse.rsp 

keyword=”db2inst.HOME_DIRECTORY”/> 

 

<defaultData>/home/db2inst1</defaultData> 

<cidFileAssociation 

responseFileName=”db2wse.rsp 

keyword=”inst1.FENCED_HOME_DIRECTORY”/> 

<cidFileAssociation 

responseFileName=”db2wse.rsp 

keyword=”inst1.HOME_DIRECTORY”/> 

Contact1.CONTACT_NAME <defaultData>db2admin</defaultData> <defaultData>db2inst1</defaultData> 

Contact1.EMAIL <defaultData>db2admin@linux</defaultData> <defaultData>db2inst1@linux</defaultData> 

Db2inst1.SVCNAME <defaultData>db2cdbinst1</defaultData> 

<cidFileAssociation 

responseFileName=”db2wse.rsp 

keyword=”db2inst1.SVCNAME”/> 

 

<defaultData>db2c_db2inst1</defaultDat> 

<cidFileAssociation 

responseFileName=”db2wse.rsp 

keyword=”inst1.SVCNAME”/> 

 

db2inst1.PORT_NUMBER <defaultData>50001</defaultData> 

<cidFileAssociation 

responseFileName=”db2wse.rsp 

keyword=”db2inst1.PORT_NUMBER”/> 

 

<defaultData>50000</defaultData> 

<cidFileAssociation 

responseFileName=”db2wse.rsp 

keyword=”inst1.PORT_NUMBER”/> 
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c. Click the Navigator tab, navigate to the src/IRU_DB2Express8_1Lnx 
directory, right-click  the src/IRU_DB2Express8_1Lnx directory and rename it 
to IRU_DB2WSE8_1Lnx.  

d. Select the Package Explorer tab to return to the Package Explorer view. 
4. Modify the project build path 

a. Right-click the IRU_DB2WSE8_1Lnx project, select Properties > Java Build 
Path. The properties editor window appears. Click the Source tab. Click the 
folder with a caution sign next to it and click the Edit button to edit the path. 

 

 

 
Figure 6 Edit the properties for the project 

b. Edit the path, replacing Express with WSE so that the source folder is 
src/IRU_DB2WSE8_1Lnx/userPrograms. Click OK. 

 

 
       
 

Figure 7 Edit the source folder location 
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c. Highlight the exclusion filter for IRU_DB2WSE8_1Lnx/src and click Edit. Click 
Edit again, browse to and select the userPrograms folder, and click OK, on the 
next three windows that appear. IRU_DB2Express8_1Lnx/userPrograms 
changes to IRU_DB2WSE8_1Lnx/userPrograms. Click OK. 

5. Modify the Entry and Main programs 
a. In the Package Explorer panel of the Solution Developer perspective, expand 

the src/IRU_DB2WSE8_1Lnx/userPrograms folder and then expand the 
com.ibm.iru.iru_db2wse8_1lnx package. 

b. Double-click DB2WSE8_1LnxVC.java and change  
 setRpmPackage(“IBM_db2das81-8.1.0”); 

 to  

 setRpmPackage(“IBM_db2wssg81-8.1.0”); 

c. Double-click DB2WSE8_1LnxMain.java and change the following entries as 
specified: 
1. setLogFileName("DB2Express8_1LnxMain.log"); 
to  
  setLogFileName("DB2WSE8_1LnxMain.log"); 

   2. setRpmPackage(“IBM_db2das81-8.1.0”); 

   to  
 setRpmPackage(“IBM_db2wssg81-8.1.0”); 

3. String command = "tar xf + …..+ “DB2Express8.1.tar” –C  + ………."; 

to  
String command = " tar xf + …..+ “DB2WSE8.1.tar” –C  + ………………."; 

4. command = “/bin/bash” + ……….”exp/db2setup –r “ + ……………”; 
to 
 command = “/bin/bash” + ……….”wse/db2setup –r” + …………...”; 

5. command = “mkdir –p …….” + …+ “exp/db2/linux/db2_deinstall…”; 
to 
 command = “mkdir –p …….” + …+ “wse/db2/linux/db2_deinstall…”; 

6. Define the software image root 
a. In the Package Explorer panel of the Solution Developer perspective, expand 

the src and IRU_DB2WSE8_1Lnx folders. 
b. Right-click applicationdef.axml and select properties > Application Software 

Image Root. 
c. Browse to and select the directory that contains the DB2WSE8.1.tar file for 

DB2 WSE. Click OK. 
7. Open the applicationdef_english.xml file in an editor. Change the root element 

<IRU_DB2Express8_1Lnx> to <IRU_DB2WSE8_1Lnx>. , You can also change the name field in 
this file from DB2 Universal Database Express Edition – Runtime to DB2 Universal Database 
Workgroup Server Edition – Runtime. This string is appears in multiple locations by the 
Deployer. 

8. Build the application  
a. Right-click the application project and select Solution Enabler Tools > Build 

Application Definition. 
9. Verify that no error messages appear on the console during the build. 
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Create a test solution 

1. Right-click in the Package Explorer panel of the Solution Developer perspective. 
Select New-> Default Solution Project Template. 

2. Name the project,for example, DB2WSE_TestMarch1,and click Next. 
3. Enter values for the rest of the attributes as shown in figure 8: 
 

 
 

Figure 8 Creating a test solution 

4. Click Next. 
5. For the export destination, click Browse and select 

/opt/IBM/Runtime/SolutionEnabler. Click Next. 
6. Select the IRU_DB2WSE8_1Lnx application to include in the solution and click 

Finish. 
7. The solution.sxml file opens in an editor. Find the <description> tag and replace “Put 

your description here” with “A Test wrapper for DB2 WSE”. Modify the value of the 
<operating system> tag from Windows to Linux and change the application file 
name under the <tasks> element from IRU_DB2WSE8_1Lnx_win.ser to 
IRU_DB2WSE8_1Lnx_linux.ser.  

8. Build the solution  
a. Right-click the solution project and select Solution Enabler Tools -> Build 

Solution. 
9. Verify that no error messages appear on the console during the build. 
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Deploy the solution 

1. Export the solution 
a. Right-click the solution project and select Export. 
b. Select Solution Developer and click Next. 
c. Accept the default settings. 

  
 

 
 

Figure 9 Solution export dialog box 

d. Click Finish. 
 
When you click finish, the DB2WSE.ser file shows up in /opt/IBM/Runtime/SolutionEnabler and 
the user jar file is placed in the installed location of the IBM Integrated Runtime. You can 
now deploy the solution. 
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2. Start Solution Deployer from the Start menu. 
3. Click File > Open. 
4. Navigate to the DB2WSE.ser file and click OK. 
  

 
 

Figure 10 Solution deployer interface 

5. Configure the deployment task 
a. Right-click task 1 and select Configure Task 1. 
b. In the Task 1 configuration window, click Target Hostnames. 
c. Enter localhost in the New Target Hostname field and click Add. 
d. Click DB2 on the Deployment Parameters panel and enter the passwords. 
e. Click DB2 under the Deployment Packages and click Create Package. 
f. Browse to the location of the DB2 WSE installation image (DB2WSE8.1.tar) or 

CD and click OK. 
g. This operation takes some time because the entire installation image is 

archived into a JAR file and placed in the installed location of the IBM 
Integrated Runtime. 
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Figure 11 Deployment package completion 

6. When the previous step is complete, click OK and then OK again. The Start 
Deployment button is now active and the “Ready to deploy” state for the task 
changes to Yes. Click Start Deployment. 

The DB2 WSE deployment starts. 
 
When deployment is complete, the icon stops moving and the following message is 
displayed:.  

DJT03000: The deployment was successful for IBM DB2 Universal Database Workgroup Server 

Edition - Runtime 8.1. 
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Figure 12 Successful deployment 

In addition, the entry in the Status column of the task table changes to Deployment 
successful. 
 
You now have a complete DB2 WSE installation. 
 
 If you installed DB2 WSE and chose to generate a response file on the same computer you 
were attempting this deployment, the following message appears:  
DJT03066: IBM DB2 Universal Database Workgroup Server Edition - Runtime 8.1 is already 
installed on the target computer.  

 
If your intention was to test deployment, uninstall DB2 WSE and retry the deployment. 
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Troubleshooting 

 
Here are some activities that you could perform to debug any problems. 
 

• Test the version checker entry program by running it in the Solution Developer. You 
might have to configure the JRE to get it to work. Perform the following steps: 

1. Click Window > Preferences to open the preferences editor.  
2. Expand Java > Installed JRE > Search. 
3. Browse to the installation location of IBM Integrated Runtime. 
4. Select DJTJRE and click OK. Wait for the workspace to recompile. 
5. Run the Version Checker as a regular Java program. 

• Use the command /opt/IBM/Runtime/SolutionEnabler/DJT_Deployer –leavefiles to do 
the deployment. The log files and intermediate files are left on the machine. You can 
then examine them for clues for the failure. 

• Important file are /opt/IBM/Runtime/SolutionEnabler/DJT_IIAtrace.log and         
/opt/IBM/Runtime/SolutionEnabler/DJT_SolutionEnabler.log. 

• If you used the -leavefiles option, additional logs are located in the 
/opt/IBM/Runtime/SolutionEnabler/logs directory. Notice the edited response file in 
that directory. It is created from the options entered during the Deployer task 
configuration. Check the file and ensure that the responses are correct. 

• If you make any changes to the application wrapper or any of the XML files, 
remember to rebuild and export the solution. 
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Summary 

This document illustrates how easy it is to package a new application into the delivery 
structure of the IBM Integrated Runtime product. IBM Integrated Runtime is a middleware 
solution that pays for itself through productivity gains alone. It truly takes care of deployment 
issues and helps you concentrate on your application. Buy it now by visiting  http://www-
306.ibm.com/software/smb and selecting your geography.

Appendix A 

To verify that the installation of DB2 WSE is successful, perform the following test: 

1. Log on to the system as a user with SYSADM authority. Use the same user id that 
was set up during the installation of DB2 (for example, db2admin or db2inst1).  

2. Enter the db2sampl command to create the SAMPLE database. This command might 
take few minutes to process. There is no completion message; when the command 
prompt returns, the process is complete. 

3. The SAMPLE database is automatically cataloged with the database alias SAMPLE 
when it is created. 

4. Start the database manager by entering the db2start command.  
5. Enter the following DB2 commands from a DB2 command window to connect to the 

SAMPLE database, retrieve a list of all the employees that work in department 20, 
and reset the database connection:  

a. db2 connect to sample 

b. db2 "select * from staff where dept = 20" 
c. db2 connect reset 

6. When you have verified the installation, you can remove the SAMPLE database to 
free up disk space. Enter the db2 drop database sample command to drop the SAMPLE 
database. 
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