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1 About this Documentation

1.1 About this guide

This guide provides the technical specifications and fixes for Lucent UMTS WMS CM Snapshoot version
v1.0.1.0 mediation package.

1.2 Audience

This guide contains information that is useful to workflow developers and administrator of the Lucent
UMTS vendor mediation packages.

1.3 Required Skills and Knowledge
This guide assumes you are familiar with the following:
® Sun Microsystems Solaris operating system
® Oracle database software
e  Microsoft Windows operating systems

This guide also assumes that you are familiar with your company’s network and with procedures for
configuring, monitoring, and solving problems on your network.
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2 Product Information

2.1 Package Contents

This mediation pack has the following name:

1.0.1.0-TIV-VM-Lucent_UMTS_CM_Snapshoot_WMS_UA6-FP0001l.tar

This mediation pack is made up of the following files:

1. The Mediation Pack Workflow
1.0.1.0-TIV-VM-Lucent_UMTS_CM_Snapshoot_WMS_UA6-FP0001l.zip
2. The extraction script

remote_Lucent_UMTS_Snapshoot_ext.sh

This package will supersedes the previous release :

1.0.0.0-TIV-VM-Lucent_UMTS_CM_Snapshoot_WMS_UA6-LAQ0001

2.2 New Features
None.

2.3 Defects Fixed

No ID Headline

1. 1744067 FWD WF ABORTS IN FILTER AGENT WHEN
NO FILE TO PROCESS

2. 1744070 DOCUMENTATION
NO UNINSTALL MENTIONED IN RELEASE
NOTES FOR THIS WF

3. 1744071 DOCUMENTATION

SEC 3.2.1 PRE INSTALL DOESN'T STATE TO
MAKE THE SCRIPT EXECUTABLE

4. 1744073 DOCUMENTATION/SCRIPT
THE SCRIPT CONTAINS DIFFERENT
VARIABLES THAN DOCUMENTATION
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2.4 Known Problems

2.4.1

2.4.2

2.4.3

Error message is shown twice for SFTP Distribution agents (SEAde62417).

Description : If the SFTP Distribution Agent encounters situation where it cannot connect to the target
server, it will abort the workflow execution and the error message will be shown twice. This error can
only be seen in Workflow Monitoring Mode.

Impact : Virtuo Mediation administrators might get confusing error message.

Workaround: None.

Restriction on the length of file and directory name in Archiving Forwarding
Agent (SEAde62832).

Description : If the combination of the file name and the directory name (as defined in an Archive Profile)
exceeds 256 characters in length, the Archiving Forwarding Agent of an instance workflow will be
aborted during execution.

Impact : Workflow instance will abort and files will fail to be transferred.

Workaround: Decrease the Base Directory length of the Archive profile or increase the size of the
FINAL_FILENAME column of the ARCHIVE_ENTRIES table in the database.

Incorrect percentage calculation for file distribution is produced in the reporting
html (SEAde67441).

Description : The file distribution percentage is wrongly calculated in the report
generation script. Currently, files with status codes 0 and 4 are categorized as ‘Files
Successfully Distributed to Destination” while files with status codes 1, 2, 3, 5 and 6 are
categorized as ‘Files Unsuccessfully Distributed to Destination’.

The correct categorization is supposed to be; 0, 2, 3 = ‘Successfully Distributed’” and 1, 4, 5 and 6 =
‘Unsuccessfully Distributed’.

The list of status codes can be viewed here:
CODE DESCRIPTION

Successful collection and distribution

Missing expected file

Filesize exceeds expected filesize limits
Filesize less then expected filesize limits
Filesize is ZERO

Invalid filename or unresolved file identifier

Collected file too old to be distributed (MAX_AGE)

AN N R WD = O

Impact : The html report will produce incorrect percentage values.

Workaround: None.
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3 Installation

3.1 Pre-requisite Requirements
Prior to the installation of this mediation package, the following must be installed on the system:
1. APL Code
a. apl.Cingular.CW_Generic_Constants
b. apl.Cingular.CW_Generic_Helper
c. apl.Cingular.CW_Audit_Lucent_ UMTS_Helper

2. Audit Profiles
a. Cingular.Lucent_UMTS_TRX

3. Archive Profiles
a. Cingular.Archive_Lucent_UMTS_Files

4. Wrapper script

a. wrapper.sh

3.2 Installing the Package

3.2.1 Pre Installation

Preparing extraction script

1. Login into the Virtuo Mediation Platform server as mzadmin user.
2. Change the directory to the Virtuo Mediation Platform Server’s scripts path, and duplicate the
wrapper.sh and name it as Lucent_UMTS_Snapshoot_ext.sh.
$ cd /home/mzadmin/scripts
) cp wrapper.sh Lucent_ UMTS_Snapshoot_ext.sh
3. Copy the remote_Lucent_UMTS_Snapshoot_ext.sh into Virtuo Mediation Execution Context Server’s
scripts path. Make sure that the script has permission to be executed. For example; to change the
permission, please do the following:
$ cd /home/mzadmin/scripts
$ chmod 744 remote_Lucent_UMTS_Snapshoot_ext.sh
4. Configure the following settings accordingly and make sure that the directories specified exist:
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BASE_DIR

INPUT_DIR

OUTPUT_DIR

TEMP_DIR

LOG_DIR

3.2.2 Installation

Base directory where the CM Snapshoot data is processed. e.g.
/home/mzadmin/spool/Lucent_UMTS/CM_Snapshoot
Directory where input files are going to be placed. e.g.
$0OSS_DIR/in
where $OSS_DIR is consists of SBASE_DIR/$1 ($1 is a parameter passed to the
script, to identify the unique instance ID, which is normally the IP of the OSS)
Therefore, the full path name should be :
/home/mzadmin/spool/Lucent_UMTS/CM_Snapshoot/10.110.10.10/in
Directory where output files are going to be placed. e.g.
$0OSS_DIR/out
where
$OSS_DIR is consists of SBASE_DIR/$1 ($1 is a parameter passed to
the script, to identify the unique instance ID, which is normally the IP of
the OSS)
Therefore, the full path name should be :
/home/mzadmin/spool/Lucent_UMTS/CM_Snapshoot/10.110.10.10/out
Temporary directory for internal script processing

Directory where all log files are going to be placed

Installing Mediation Pack

1. Ensure that the Virtuo Mediation platform is up and running. Otherwise, run the following:

a. Logon to the server where Virtuo Mediation 4.0 is installed.

b. Issue the command mzsh startup platform to start the platform.

c. Issue the command mzsh desktop to start the GUIL

d. Log into the GUI as mzadmin.

2. Import workflow template.

a. Untar the mediation pack, run;

tar -xvf 1.0.1.0-TIV-VM-Lucent_UMTS_CM_Snapshoot_WMS_UA6-FP000l.tar

Note: If you’re using X Windows client, untar it onto VM server. If you’re using Windows
client, untar it onto your Windows desktop.

b. Select Tool — System Importer

c. Select ‘Browse’ and locate the file 1.0.1.0-TIV-VM-Lucent_ UMTS_CM_Snapshoot_ WMS_UA6-
FP0001.zip un-tarred from step 2a.

d. Select Open — OK

e. Select ‘Import’

f.  Select ‘View Log’ button to view the result of the import.
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3.2.3 Post Installation

There are 2 workflow templates, 1 Collection Strategy Profile, 1 Archive Profile and 1 Audit
Profile.

The Templates are:
¢ Templates.Lucent_UMTS_Snapshoot_Collection
¢ Templates.Lucent_UMTS_Snapshoot_Forwarding

The Collection Strategy Profile is:
¢ Cingular.Lucent_UMTS_Snapshoot

Lucent UMTS CM Snapshoot (Collection WF) New Instance Configurations

This section specifies the steps required to configure the workflow required to process Lucent UMTS WMS CM
Snapshoot data.

To create a new processing workflow instance for the Lucent UMTS WMS CM Snapshoot, follow these steps
1. Login to Virtuo Mediation Desktop as mzadmin user.
2. Go to Configuration > Workflow = File > New Template Instance.

3. On the “‘Workflow Selection’ screen, click on the ‘Templates’ tree listing. Select
‘Templates.Lucent_UMTS_Snapshoot_Collection’. Click ‘OK’.

4. Double click and configure the Input Disk Collection Agent according to the specification of your environment.
5. Double click on the InstanceData processing agent. Modify these values to match your environment.

a. WMS_Name (normally the IP of the OSS)

b. market

c. region
6. Double click on the Disk_1 disk forwarding agent and change the configuration to reflect your environment.
7. In order to schedule the WF, please follow these steps:

a. Open the instance workflow that you have just created and click on the ‘Preferences’ icon.

b. Go to the ‘Day Plans’ tab under the ‘Schedule Criteria’ area and click on the ‘Add’ icon.

c. Schedule the workflow instance accordingly.

d. Click on the ‘OK’ button, save and exit the workflow preferences.
8. Click on the ‘Save As’ button and enter the correct workflow name together with the folder location.

9. Go to Inspection 2> Workflow Manager, select the WF you just scheduled > Edit > Activate.

Lucent UMTS CM Snapshoot Extraction Script New Task Configurations

This section specifies the steps required to configure the workflow required to extract Lucent UMTS WMS CM
Snapshoot data.

1. Login to Virtuo Mediation Desktop as mzadmin user.
2. Go to Tools > Task Manager > Add....

3. Populate the ‘Task Name’ with appropriate name.
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At Configuration Tab, specify the ‘Script Name’ as the full path to the Lucent_UMTS_Snapshoot_ext.sh
created during Pre Installation. The ‘Parameters’ should be set to the OSS_DIR without the BASE_DIR portion
(e.g. 10.10.10.10).

At Schedule Tab, choose ‘Event Triggers’ Tab and click on ‘Add’ icon. At Add Event Chain Trigger, click ‘Add’
icon. At Add Event Selection, choose ‘Workflow State Event’ as event type.

Double click the ‘WorkflowName’ to add a match value; for this case, it should be the name of the Lucent UMTS
CM Snapshoot (Collection WF) instance that was created during previous steps.

Double click ‘WorkflowState’ to add a match value as ‘Stopped’.

Lucent UMTS CM Snapshoot FWD (Forwarding WF) New Instance Configurations

This section specifies the steps required to configure the workflow required to forward Lucent UMTS WMS
CM Snapshoot data to Prospect.

To create a new forwarding workflow instance for the Lucent UMTS WMS CM Snapshoot, follow these steps

1.
2.

et

Nk

Log in to Virtuo Mediation Desktop as mzadmin user.
Go to Configuration - Workflow = File - New Template Instance.

On the “Workflow Selection’ screen, click on the ‘Templates’ tree listing. Select
‘Templates.Lucent_UMTS_Snapshoot_Forwarding’. Click ‘OK’.

Double click and configure the Input collection agent according to the specification of your environment.
Make sure that the Filename regular expression is defined correctly to match your input file.
‘After Collection’ should be set to ‘Remove’. Click OK when you are done.
Double click on the InstanceData processing agent. Modify these values to match your environment.
a. WMS_Name (normally the IP of the OSS)
b. market
c. region

Double click on the Prospect forwarding agent and change the configuration to reflect your environment. Please
refer to Appendix A, SFTP_Vallent Forwarding Agent for default configurations. Click OK when you are done.

In order to schedule the WF, please follow these steps:
a. Open the instance workflow that you have just created and click on the ‘Preferences’ icon.
b. Go to the ‘Event Triggers’ tab under the ‘Schedule Criteria’ area and click on the ‘Add’ icon.

c. At Add Event Chain Trigger, click ‘Add’ icon. At Add Event Selection, choose ‘Task State Event’ as
event type.

d. Double click the ‘TaskName’ to add a match value; for this case, it should be the name of the Lucent
UMTS CM Snapshoot Extraction Script Task that was created during previous steps.

e. Double click ‘TaskState’ to add a match value as ‘Stopped’.

f.  Click on the ‘OK’ button, save and exit the workflow preference.

10. Click on the ‘Save As’ button and enter the correct workflow name together with the folder location.

11. Go to Inspection > Workflow Manager, select the WF you just scheduled - Edit > Activate.
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3.3 Un-install Procedure

Steps 1 — 6 specified in this section is for backup and can only be performed if the installation has been
completed. For complete deletion of the package, go straight to step 7.

1. Log in to Virtuo Mediation Desktop as mzadmin user.

2. Go to Inspection > Workflow Manager and deactivate all workflow instances that have State = ‘Scheduled’
(either by time of by trigger) for template Templates.Lucent_ UMTS_Snapshoot_Collection and
Templates.Lucent_UMTS_Snapshoot_Forwarding

3. Go to Tools > System Exporter
4. Click on the browse button, select the preferred backup filename and destination directory

At the ‘Available Entries’, choose both templates Templates.Lucent_ UMTS_Snapshoot_Collection and
Templates.Lucent_ UMTS_Snapshoot_Forwarding and all relevant workflow instances (if any)

6. Click Export and view the log for any errors.

The following steps are required for complete deletion of the whole package
7. Login to Virtuo Mediation Desktop as mzadmin user.
8. Click on the “Inspection ->Configuration Browser”” menu option.

9. Delete all workflow instances for workflow templates Templates.Lucent_ UMTS_Snapshoot_Collection and
Templates.Lucent_UMTS_Snapshoot_Forwarding

10. Delete templates Templates.Lucent_ UMTS_Snapshoot_Collection and
Templates.Lucent_ UMTS_Snapshoot_Forwarding from the Templates folder.
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Appendix A

This section explains about the default configuration values for ESFTP Collection Agents, and SFTP_Vallent
Forwarding Agents. Take not that these are default values and should be configured accordingly if they do not
suit your environment.

ESFTP Collection Agents

‘Source’ tab
Duplicate Collection Filter
e ‘Block Older’ check box is ticked.
New File Check

e ‘Timeout (minutes)’ text area should be populated with value 5

‘Advanced’ tab
Collection Strategy set to Cingular.Lucent_UMTS_Snapshoot
Advanced Settings
e ‘Port’ text area should be populated with value 22
e ‘Time out (secs)’ text area should be populated with value 600

e ‘Accept New Host Keys’ check box is ticked.

SFTP_Vallent Forwarding Agents
‘Advanced’ tab
e ‘Port’ text area should be populated with value 22
e ‘Timeout (sec)’ text area should be populated with value 600 (secs)

o ‘Accept New Host Keys’ check box is ticked.

‘Backlog tab
e ‘Enable Backlog’ check box is ticked
e ‘Max Size’; ‘Type’ is set to Files; ‘Size’ text area populated with value 10000.
® ‘Processing Order’ is set to FIFO

e Duplicate File Handling is set to Overwriting.
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