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Chapter 1

Introduction

1.1 Installation Overview

To be able to use the IBM® Cúram Social Program Management it is ne-
cessary it is necessary to install and configure software from third parties.
This document describes how to install the third-party products and carry
out the post-installation setup tasks.

To be able to use Cúram Portlets it is necessary to install and configure
Portal Server Software. The installation of Portal Server Software is de-
scribed in Installing Third-Party Software Products chapter

1.2 Third-Party Products Overview

The following document outlines the products that are needed and, for each
product, whether post-installation configuration is required. A comprehens-
ive list of supported versions is contained in a separate document, Cúram
Supported Prerequisites document.

If you are absolutely happy that you have installed all of the third-party
products correctly and performed the necessary post-installation tasks, per-
haps because you are working in an environment where your computer has
been ghosted, you can skip this document.

1



Chapter 2

Installing Third-Party Software Products

2.1 Overview

This chapter describes the software products you need to install before in-
stalling IBM Cúram Social Program Management.

Important

IBM Cúram Social Program Management will definitely not run un-
less you follow the instructions; also, in some cases there is inform-
ation in this document about product configuration that you will not
find anywhere else (including the product documentation).

For each product it tells you:

• Briefly what the product is and why it is used;

• Installation instructions (in most cases, this involves simply following
the defaults provided by the product installer); and

• Any post-installation tasks required.

This document does not provide specific instructions for installing fix packs
unless the fix pack installation has some product or application-specific
steps involved.

2.2 Before Installing

To install all of the products for an installation based on IBM® DB2® you
need disk space of approximately:

• 1 GB based on IBM® WebSphere Application Server®;

• 1 GB based on WebSphere Application Server Network Deployment;

• 1 GB based on Oracle® WebLogic Server.
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Approximately 2.5 GB extra is required for an installation based on
Oracle® Database.

Look out for products that install to your C: drive by default - you may
need to change the default installation location. If you have the luxury of a
free drive or partition, you may want to dedicate this to IBM Cúram Social
Program Management installs.

Installation Sequence

The order in which you install the third-party products is not import-
ant. Also you can, if you wish, perform all the basic product installa-
tions and then do all of the post-installation tasks together.

2.3 Operating System Software

Please refer to the Cúram Supported Prerequisites document for a compre-
hensive list of supported versions of operating systems and third party soft-
ware.

2.4 DBMS Installation

Both DB2 and Oracle are supported as database servers. DB2 is the name
used on Microsoft® Windows and UNIX platforms; on IBM® z/OS® the
name is IBM® DB2® for z/OS®. Both DB2 and Oracle may be installed on
a given machine but typically it is necessary to install only one of the data-
bases.

The H2 database is supported as a development database.

Please refer to the Cúram Supported Prerequisites document for a compre-
hensive list of supported versions of database management systems
(DBMS).

Note

No particular character set is recommended for installation and
setup of the DBMS. The character set configured should be appro-
priate for the character range that will be used in the application.
Please refer to the product sections below for further details.

2.4.1 IBM DB2

This section outlines how to install DB2 as a database server.

Note

It is possible to use IBM Cúram Social Program Management
against a remote database via the DB2 Universal Type 4 Driver sup-
plied with the Server Development Environment for Java® (SDEJ).

Cúram Third-Party Tools Installation Guide for Windows
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Supported Versions

Please refer to the Cúram Supported Prerequisites document for the exact
version of DB2 to be installed.

DB2 Database Encoding

This section provides important information about issues with DB2 and DB2
for z/OS database encoding, related sizing information, and action you need
to consider taking.

What is the Issue?

When using a multi-byte character set (MBCS) and/or encoding DB2 pro-
cesses columns with respect to their byte size, not their character length.
This means that a CHAR, VARCHAR, or CLOB column, when using
multi-byte characters, may store fewer characters, depending on the actual
character length(s), than the column length specification indicates.

Consider the following illustration:

• A CHAR or VARCHAR column modeled with a length of 16.

• The sixteen-character string, "Marge says hello", (without accented
characters) requires 16 bytes for storage in a single-byte character set
(SBCS).

• A similar sixteen-character string, but with accented characters, "Márge
says héllo", requires 18 bytes for storage in UTF-8, a multi-byte charac-
ter set (MBCS).

In the case of the single-byte data the string will fit and processing will be
successful; but, in the case of the multi-byte data the string will not fit, res-
ulting in overflow errors at run time. That is, normally an IBM Cúram So-
cial Program Management web client will capture and report field size er-
rors in a user-friendly manner. But, in a case as above, because it checks the
number of characters and not the byte length, the client will not capture this
size mismatch, causing the user to receive an "un-handled server exception"
error, which is an underlying SQL Code -302 error.

How Cúram Addresses the Issue

Cúram provides modeling and build-time capabilities to resize its database
columns to address the issue above. These capabilities are described further
in the Cúram Modeling Reference Guide and Cúram Server Developer's
Guide.

Because Cúram provides support for multiple languages out-of-the-box its
support for MBCS data is enabled by default with the maximum expansion
set. These expansion settings are appropriate to ensure that new users, test-
ing environments, etc. do not encounter any errors due to their language, en-
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coding, and database sizing. Also, users may find they require MBCS data
when they import or copy/paste data from other applications into their
Cúram system. However, these defaults may not be appropriate for all en-
vironments. The following section describes some considerations for chan-
ging these expansion settings.

What You Need to Consider

It is very important to carefully consider your data encoding requirements
with respect to DB2 and Cúram in order to avoid unexpected behavior with
how the database stores characters.

The preceding illustration represents a boundary case in that the data length
matches the maximum column width. In many cases it's unlikely that even
with MBCS characters that an overflow situation will occur since most data
doesn't reach the maximum defined size; however, you do need to be pre-
pared for the possibility of these error situations.

You should use the database character set encoding appropriate to your ap-
plication and environment. If possible, you should consider using an SBCS
and encoding that supports your requirements. For example, CP1252 sup-
ports most Western European characters. However, CP1252 (or other SBCS
encodings) may not support characters coming from different or "broader"
character sets/encodings (e.g. UTF-8) that users may be used to copying and
pasting into their browser for Cúram.

At the point of installing your DB2 (or DB2 for z/OS) database you only
need to identify your requirement for SBCS or MBCS data and be prepared
to take appropriate action before building your Cúram database:

• If you require characters that use multiple bytes then you need to con-
sider whether the default Cúram settings are appropriate. The necessary
database space is dependent on various factors including:

• The specific character sizes - in DB2 (and DB2 for z/OS) MBCS data
can range from 1 to 4 bytes.

• The frequency of MBCS characters, which can depend on the applic-
ation, language, locale, column usage within the application, etc.

• The information density of the language and locale. For instance,
while some languages may require more bytes per character, each
character may represent more information than, for instance, an al-
phabetic character and may fit into a field without any size adjust-
ment.

See the Cúram Server Developer's Guide section, Planning for DB2
MBCS Data, for more information on MBCS data sizing considerations.

• If an SBCS is adequate then you should plan to disable database expan-
sion as described in the Cúram Server Developer's Guide section: Plan-
ning for DB2 MBCS Data.

Cúram Third-Party Tools Installation Guide for Windows
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Installation

Ensure that your account has administrative privileges and then follow the
installer’s instructions to perform a default installation. Very few options are
presented during a default installation apart from the following:

• Name and Password of the administrator account - db2admin should
be used as the user name for the sake of simplicity, along with any
chosen password not longer than eight characters. Any other user name
can be chosen. If it is an existing user, that user should be a member of
the Administrator group. The informational dialog about “OLE DB sup-
port component” can be safely ignored.

• Certain editions of the DB2 installer support federated databases - If the
installer presents an option which is defaulted to This machine
will be the instance-owning database partition
server, then change this to This machine will be a
single-partition database server.

Post-installation

Creating and configuring a database

1. Go into the General Administration Tools/Control Center.

2. Select the Databases folder (All Systems...
<Hostname>... Instances... DB2... Databases).

3. Right click the mouse.

4. Select “Create Database... Standard”.

5. There are six pages and a summary to the wizard:

6. On page one, fill in the database name (alias should be the same as the
name);

After creating the database additional parameters need to be configured.
There is no command line to perform this so the Configuration Assistant
and the Control Center must be used:

1. Go into the General Administration Tools/Control Center.

2. Select the Databases folder (All Systems...
<Hostname>... Instances... DB2... Databases).

3. Select the database that was created in the previous step.

4. Right click the mouse.

5. Select “Configure Parameters”.

Cúram Third-Party Tools Installation Guide for Windows
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6. Update the LOCKTIMEOUT - Set Lock timeout (in the Ap-
plications section) to at least 1 second, or any desired higher
value.

7. Reboot the PC or cycle all DB2 services. To cycle all DB2 services,
please do the following from within a DB2 command prompt:

• connect reset

• force application all

• db2stop

• db2start

After configuring the database you must create the tablespaces required for
the storage and running of the application.

This can be done using the provided Apache Ant scripts by invoking:

ant -f %CURAMSDEJ%\util\db2_postconfig.xml -Ddb2.dir=
<DB2_directory>

where <DB2_directory> is the DB2 installation path (e.g.
<drive>:\IBM\SQLLIB). Otherwise, complete the following steps:

1. Start a db2cmd window by running the db2cmd command at the com-
mand prompt.

2. Enter the following at the command prompt:

db2 connect to <database_name> user <user_name> using
<password>

db2 CREATE BUFFERPOOL highmem SIZE 50 PAGESIZE 32K

db2 connect reset

3. Reboot the PC or cycle all DB2 services. Please see above for details
on how to cycle all DB2 services.

4. Start a db2cmd window.

5. Enter the following at the command prompt:

db2 connect to <database_name> user <user_name> using
<password>

db2 create tablespace Curam_L PAGESIZE 32K MANAGED BY
SYSTEM using (’<dir_name_A>’) BUFFERPOOL highmem

db2 create temporary tablespace Curam_T PAGESIZE 32K
MANAGED BY SYSTEM using (’<dir_name_B>’) BUFFER-
POOL highmem

db2 connect reset

6. Reboot the PC or cycle all DB2 services. Please see above for details

Cúram Third-Party Tools Installation Guide for Windows
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on how to cycle all DB2 services.

NOTE

- <dir_name_A> and <dir_name_B> should be non-existent
directories, i.e. directories that don’t exist before the command is
run - on a drive with a significant amount of space.

- All DB2 commands above are one-line commands, i.e. no line
breaks.

- If the username used to connect to the database when executing the
commands is not the same as the username which will be used to ac-
cess the database, the following command should also be executed,
where <user_name> is the name of the user that will be used to ac-
cess the database:

db2 grant use of tablespace Curam_L to user <user_name> with
grant option

Providing a DB2 License File

This post-installation step is required for all users of IBM DB2 for Linux,
Unix and Windows for the IBM Cúram Social Program Management Plat-
form development or runtime environments.

An empty db2jcc_license_cu.jar file exists in the
%CURAMSDEJ%\drivers directory to allow for Eclipse classpath de-
pendencies in the CuramSDEJ project. This empty jar should be overwritten
with a real license for accessing IBM DB2 for Linux, Unix and Windows.

The IBM DB2 db2jcc_license_cu.jar file should be copied from
<DB2_directory>\java\db2jcc_license_cu.jar (where
<DB2_directory> is the DB2 installation path; e.g. C:\IBM\SQLLIB) to
%CURAMSDEJ%\drivers (where %CURAMSDEJ% points to the root
CuramSDEJ location).

Please refer to the Cúram Supported Prerequisites document for further in-
formation regarding the supported versions of third party database software.

Replacing the Packaged DB2 Drivers

Usually the latest JDBC drivers available at the time of release are packaged
with IBM Cúram Social Program Management. However, if you wish to re-
place the drivers shipped in %CURAMSDEJ%\drivers, copy the following
files from <DB2_directory>\java.

(where <DB2_directory> is the DB2 installation path e.g.
<drive>:\IBM\SQLLIB)

• db2jcc.jar

• db2jcc_license_cu.jar

Cúram Third-Party Tools Installation Guide for Windows
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• sqlj4.zip

Replace the drivers db2jcc.jar, db2jcc_license_cu.jar, and
sqlj4.zip in %CURAMSDEJ%\drivers directory.

Please refer to the Cúram Supported Prerequisites document for details of
the supported versions of third party products.

2.4.2 Remote DB2 for z/OS Connectivity

Before the connection can be established to the remote database it must be
configured. The full details of installation of DB2 for z/OS are beyond the
scope of this document set. However the following are the main post-
installation steps to note:

1. A database can be configured for EBCDIC, ASCII, or UNICODE
mode for use by the application. This can be done when creating the
database using the CCSID keyword. For ASCII or UNICODE data-
bases see the Cúram Server Developer's Guide for information about
required property curam.db.zos.encoding.

CREATE DATABASE <database_name> BUFFERPOOL BP0 IN-
DEXBP BP0 STOGROUP <storage_group> CCSID <EBCDIC,
ASCII or UNICODE>;

2. An environment variable called DB2JCC_LICENSE_CISUZ_JAR
must be created that points to the installed DB2 for z/OS license jar file
used for connectivity to the remote database server. This is normally
named db2jcc_license_cisuz.jar and is provided with DB2
for z/OS or DB2 Connect.

2.4.3 Oracle

This section outlines how to install Oracle as a database server.

Note

It is possible to use a remote database via the Oracle Type 4 Driver
supplied with the SDEJ.

Supported Versions

Please refer to the Cúram Supported Prerequisites document for the exact
version of Oracle to be installed.

Installation

Assuming that there have been no previous versions of Oracle installed, the
installer’s instructions can be followed to perform a typical server installa-
tion.

Cúram Third-Party Tools Installation Guide for Windows
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Oracle Database Encoding

It is important to consider the character set for data that will be stored on
your database when configuring your database for use with IBM Cúram So-
cial Program Management. For Oracle, there are 2 parameters to consider:
NLS_CHARACTERSET and NLS_LENGTH_SEMANTICS.

• The NLS_CHARACTERSET parameter details the allowable character
set of any data loaded to the database, generally AL32UTF8 is recom-
mended by Oracle here.

• The NLS_LENGTH_SEMANTICS determines how Oracle interprets
length specifiers on CHAR and VARCHAR columns. To handle supple-
mentary characters, e.g. ß in German, where the storage of the character
would be two bytes and could overrun the length of a defined column;
the NLS_LENGTH_SEMANTICS parameter should be set to CHAR as
this directs the database to size columns with a character length rather
than byte length.

Replacing the Packaged Oracle JDBC Drivers

Usually the latest JDBC drivers available at the time of release are packaged
with IBM Cúram Social Program Management. However, if you wish to re-
place the drivers shipped in %CURAMSDEJ%\drivers, please follow the
sample steps below:

• Copy
<ORA_directory>\product\11.1.x\db_1\jdbc\lib\ojd
bc6.jar to a <temp> location.

where <ORA_directory> is the Oracle installation path (e.g.
<drive>:\oracle11g1)

• Rename ojdbc6.jar to ojdbc.jar (to match the name of the
driver shipped).

• Copy
<ORA_directory>\product\11.1.x\db_1\oc4j\sqlj\li
b\translator.jar to a <temp>> location.

• Copy
<ORA_directory>\product\11.1.x\db_1\oc4j\sqlj\li
b\runtime12.jar to a <temp> location.

• Replace the drivers ojdbc.jar, runtime12.jar, and trans-
lator.jar in %CURAMSDEJ%\drivers with the drivers in your
temp location.

Please note, the renaming of the ojdbc6.jar is necessary due to the fact that
the SDEJ expects the driver file to be named ojdbc.jar.

Please refer to the Cúram Supported Prerequisites document for details of

Cúram Third-Party Tools Installation Guide for Windows
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the supported versions of third party products.

Post-installation

There are a number of post-installation tasks which must be performed:

• Create an Oracle role for the application server(s).

NOTE

The post-installation tasks require connecting to Oracle as the priv-
ileged 'sys' user. Immediately after installing Oracle, the password
for this user is 'change_on_install'. Oracle requires that this
be changed.

Create an Oracle role for Application Servers

The application needs certain privileges in order to use the Oracle XA inter-
face. Later, when configuring the application, the username under which the
server connects to Oracle is specified. The appropriate privileges must be
assigned to this username for the server to work successfully.

An easy way to bundle together the various privileges required is to create
an Oracle Role. Privileges can be granted to this role. Later this role can be
granted to your users, thereby granting all the privileges associated with that
role.

The following commands create a role called CURAM_SERVER and give it
the necessary privileges. A user named CURAM_USER is then assigned that
role and given the password PASSWORD. The commands should be run in-
side an Oracle SQLPlus window.

Note

To run the commands from SQLPlus type the following at a com-
mand prompt sqlplus “?/? as SYSDBA”.

CREATE ROLE "CURAM_SERVER";

GRANT RESOURCE TO "CURAM_SERVER";

@%ORACLE_HOME%\RDBMS\ADMIN\xaview.sql

GRANT SELECT ON V$XATRANS$ TO PUBLIC;

GRANT SELECT ON PENDING_TRANS$ TO PUBLIC;

GRANT SELECT ON DBA_2PC_PENDING TO PUBLIC;

GRANT SELECT ON DBA_PENDING_TRANSACTIONS TO PUB-
LIC;

GRANT EXECUTE ON DBMS_SYSTEM TO CURAM_SERVER;

CREATE USER <CURAM_USER> IDENTIFIED BY <PASSWORD>
DEFAULT TABLESPACE "USERS" TEMPORARY TABLESPACE

Cúram Third-Party Tools Installation Guide for Windows
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"TEMP";

GRANT "CONNECT", "CURAM_SERVER", UNLIMITED TA-
BLESPACE TO <CURAM_USER>;

Example 2.1 Oracle Configuration

Note

Replace <CURAM_USER> and <PASSWORD> in the CREATE
USER command with the username and password you wish to use
for the database user.

2.4.4 H2

Overview

H2 is an SQL database engine written in Java® that implements the JDBC
API. A browser-based console application is included.

Limitations in the support of H2: 1

• Usage of this database is only for development.

• It is not supported at runtime.

• EAR files cannot be built for this database.

• The configure target which automatically configures the application
server cannot be run while this database is in use.

Installation

H2 does not require any specific installation steps. The database is self con-
tained within the delivered file: %CURAMSDEJ%\drivers\h2.jar.

Configuration

To use an H2 database you must set the Bootstrap.properties2 file
to specify the set of properties relevant to H2 for obtaining a connection to
the database; e.g.:

curam.db.type=h2
curam.db.name=curamdb
curam.db.username=curam
curam.db.password=qqnscP4c4+s=
# H2 directory.
# Default is home directory
# (i.e. C:/Documents and Settings/<username>). (Optional)
curam.db.h2.directory=C:/H2
# Mode remote|embedded
curam.db.h2.mode=embedded
# For remote mode also specify:
curam.db.serverport=9092
curam.db.servername=localhost

Cúram Third-Party Tools Installation Guide for Windows
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# Lock Time Out in ms. Default is 1000, i.e. 1 second. (Optional)
curam.db.h2.locktimeout=20000
# Property to disable MVCC. Default: true. (Optional)
curam.db.h2.mvcc=true

Example 2.2 Bootstrap.properties

Once you have updated Bootstrap.properties and rebuilt the server
and database you can develop in exactly the same way as you would with
Oracle or DB2.

H2 Modes

The following H2 modes are supported for application development:

• Embedded - in embedded mode, an application opens a database from
within the same JVM using JDBC. This is the fastest and easiest connec-
tion mode. The disadvantage is that a database may only be open in one
virtual machine (and class loader) at any time.

• Remote - in remote mode (sometimes called client/server mode), an ap-
plication opens a database remotely using the JDBC or ODBC API.
Many applications can connect to the same database at the same time.
The remote mode is slower than the embedded mode, because all data is
transferred over TCP/IP.

You can specify the required mode by using the following property in
Bootstrap.properties file:

# Mode remote|embedded
curam.db.h2.mode=embedded

Multi-Version Concurrency Control (MVCC)

The MVCC feature allows higher concurrency than using exclusive table
level or row level locks. When using MVCC in this database, delete, insert
and update operations will only issue a shared lock on the table. An exclus-
ive lock is still used when adding or removing columns, when dropping the
table, and when using SELECT ... FOR UPDATE. Connections only
'see' committed data, and their own changes. That means, if connection A
updates a row but hasn't committed the change, connection B will see the
old value. Only when the change from connection A is committed, the new
value is visible to other connections (read committed). If multiple connec-
tions concurrently try to update the same row, the database waits until it can
apply the change, but at most until the lock timeout expires.

By default, MVCC is set to true.

You can switch off MVCC by using the following property in Boot-
strap.properties file:

Cúram Third-Party Tools Installation Guide for Windows
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# Property to disable MVCC. Default: true. (Optional)
curam.db.h2.mvcc=false

H2 Web Console

When you start H2 by running the org.h2.tools.Server class in
h2.jar its web console is started and can be accessed at the URL:

http://localhost:8082/

The JDBC connection URL you specify in the login screen is based on the
curam.db.name, curam.db.username, and
curam.db.h2.directory values in Bootstrap.properties,
which define the database name, SCHEMA name, and the database location
in the file system. So, if your database name is curamdb, your username is
curam and curam.db.h2.directory is defaulting to your home dir-
ectory, your JDBC string would look like this:

jd-
bc:h2:tcp://localhost/~/curamdb;schema=curam;FILE_L
OCK=SOCKET

Note, if, for example, curam.db.h2.directory is C:/H2, then your
JDBC string would look like this:

jd-
bc:h2:tcp://localhost/file:C:/H2/curamdb;schema=cur
am;FILE_LOCK=SOCKET

Specify the values for User Name and Password as in your Boot-
strap.properties and then click the Connect (or Test Connect) but-
ton. Once connected you'll have an SQL text control, etc. available.

Further Reading

Useful web-sites for information on H2 are:

• H2 manual: http://www.h2database.com/h2.pdf/.

• H2-specific error codes: ht-
tp://www.h2database.com/javadoc/org/h2/constant/ErrorCode.html/.

2.5 Apache Ant

2.5.1 Overview

Apache Ant from the Apache Jakarta project is a Java-based build tool. For
those familiar with tools used in other environments it can be viewed as be-
ing similar to the make tool.

Cúram Third-Party Tools Installation Guide for Windows
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2.5.2 Supported Versions

Please refer to the Cúram Supported Prerequisites document for the exact
version of Ant to be installed.

2.5.3 Installation

The Ant zip file can be obtained from Apache and extracted to a folder on
your machine. For example, unzip apache-
ant-<version>-bin.zip into a location of your choice. When unzip-
ping this file, it is worth remembering that it installs everything under
apache-ant-<version>. There is no need to unzip into a directory
named ‘ant’.

Installation is now complete.

2.5.4 Post-installation

The following steps need to be followed:

1. Create a system environment variable, ANT_HOME, which points to the
installation directory chosen above;

2. Add %ANT_HOME%\bin to the PATH environment variable.

3. Create a system environment variable, ANT_OPTS, which should be
set to be -Xmx756m.

2.6 Rational Software Architect

2.6.1 Overview

IBM® Rational® Software Architect is an Eclipse-based UML modeling
tool that is required to do server development. More details on the use of
Rational Software Architect can be found in the Working with the Cúram
Model in Rational Software Architect document and more information on
modeling can be found in the Cúram Modeling Reference Guide.

2.6.2 Supported Versions

Please refer to the Cúram Supported Prerequisites document for the exact
version of Rational Software Architect to be installed.

2.6.3 Installation

The exact installation steps may vary by the edition and/or version of your
software and the relevant IBM documentation should be consulted in addi-
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tion to the information in this guide.

The IBM Installation Manager must be installed before installing Rational
Software Architect and can be installed taking the default options.

Install Rational Software Architect:

1. Start the IBM Installation Manager (Start > Programs > IBM Installa-
tion Manager > IBM Installation Manager);

2. From the File menu select Preferences and on the Repositories page
add a new entry appropriate to your site that points to your Rational
Software Architect installation location and initial installation file and
make this the only selected repository;

3. Click OK to go back to the main screen;

4. Select Install and you should see the appropriate version as an avail-
able install package. Select this and click Next;

5. Accept licenses, which is dependent on your local license configura-
tion;

6. Choose a location for the Shared Resources;

7. Choose a Package installation location;

8. Choose not to extend an Eclipse version; (If you wish to use Rational
Software Architect in an existing Eclipse instance see the product docu-
mentation; i.e. ht-
tps://www.ibm.com/developerworks/wikis/display/rationalinstall/Instal
l+into+an+existing+Eclipse+instance);

9. On the "Install Packages - select features to install" panel, you need to
additionally install: 'Rational Rose Model Import' in order to install the
IBM® Rational Rose® profile required by migrated models in Eclipse;

10. Continue and choose the defaults for the rest of the installation.

2.6.4 Post-installation

You must install the shipped plugins to enable modeling support:

1. Create a dropins directory in your Rational Software Architect in-
stall location; e.g., C:\Rational\SDP\dropins;

2. Create an rsa_plugin.link file that has the contents referencing
the location where the plugin for Rational Software Architect is de-
livered to (note: use forward slashes); e.g.:

path=C:/Curam/CuramSDEJ/rsa

3. Edit the shortcut that starts Rational Software Architect to pass the -
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clean option so that the plugins are picked up e.g.

...\eclipse.exe -clean -product com.ibm.rational....

4. Start or restart Rational Software Architect.

The configuration of your Rational Software Architect license is dependent
on your local site configuration.

2.7 Application Server

The supported application servers on Windows are WebSphere Application
Server and WebLogic Server. An application server must be installed on a
machine that builds applications for deployment as well as on machines
which host the deployed application.

Note

None of the application servers should be installed on a machine
which has an underscore in the machine name.

2.7.1 WebSphere Application Server

Supported Versions

Please refer to the Cúram Supported Prerequisites document for the exact
version of WebSphere Application Server to be installed.

Installation

Install WebSphere Application Server from the IBM installation media. The
default installation is used, without any configuration changes.

If installing WebSphere Application Server as a service, a user account
should be created in advance so that it can be used as the credentials for the
service. This user account must have administrator privileges.

You should not install WebSphere Application Server to a directory that
contains spaces in the name, in other words do not use the default
‘Program Files’ directory.

Note

Please avoid installing the WebSphere Application Server sample
applications. This is because the sample application Apache Derby
DataSource will result in a classpath conflict with the application
web client's use of Derby.

Post-installation

Cúram Third-Party Tools Installation Guide for Windows

17



The WAS_HOME environment variable must be setup. It should be set to the
server directory of the WebSphere Application Server installation (e.g.
<drive>:\WebSphere\AppServer).

2.7.2 WebSphere Application Server Network Deployment

Overview

IBM’s WebSphere Application Server Network Deployment is an optional
component that manages one or many IBM WebSphere Application Server
editions and offers advanced deployment services, including clustering,
edge services and high availability for distributed configurations.

Supported Versions

Please refer to the Cúram Supported Prerequisites document for the exact
version of WebSphere Application Server Network Deployment to be in-
stalled.

Installation

Install WebSphere Application Server Network Deployment from the install-
ation media. The default installation is used, without any configuration
changes.

If installing the Deployment Manager as a service a user account should be
created in advance so that it can be used as the credentials for the service.
This user account must have administrator privileges.

You should not install WebSphere Application Server Network Deployment
to a directory that contains spaces in the name, in other words do not use the
default ‘Program Files’ directory.

Note

Please avoid installing the WebSphere Application Server sample
applications. This is because the sample application Apache Derby
DataSource will result in a classpath conflict with the application
web client's use of Derby.

Post-installation

The WAS_HOME environment variable must be setup. It should be set to the
server directory of the WebSphere Application Server Network Deployment
installation (e.g. <drive>:\WebSphere\AppServer).

2.7.3 WebLogic Server

Supported Versions
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Please refer to the Cúram Supported Prerequisites document for the exact
version of Oracle® WebLogic Server to be installed.

Installation

When installing WebLogic Server:

1. Click Next on the initial welcome screen.

2. Specify the home directory where you wish to install WebLogic Server
and click Next.

3. Choose a custom installation and click Next.

4. De-select all options except the WebLogic Server branch and click
Next;

5. Select the JDK(s) you require and click Next;

6. Specify the Product Directory based on the WebLogic Server home dir-
ectory you specified above and click Next;

7. Accept the default to not install as a Windows service and click Next;

8. Choose the shortcut location and click Next;

9. Review the installation summary and click Next;

Once the installation is complete uncheck Run Quickstart and click Done to
exit the installer.

Post-installation

The WLS_HOME environment variable must be setup. It should be set to the
server directory of the WebLogic Server installation (e.g.
<drive>:\wls\weblogic<version>\server or
<drive>:\wls\weblogic<version>\wlserver_10.3).

2.8 Portal Server

The supported portal server is IBM® WebSphere®Portal Server. A portal
server must be installed on a machine which will host the deployed Cúram
Portlets.

Note

None of the portal servers should be installed on a machine which
has an underscore in the machine name.

2.8.1 WebSphere Portal Server

Supported Versions
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Please refer to the Cúram v6 Supported Prerequisites document for the ex-
act version of WebSphere Portal Server to be installed.

Installation

Install WebSphere Portal Server from the IBM installation media. The de-
fault installation is used, without any configuration changes. There is a link
to the Websphere Portal Server documentation on the first screen of the in-
staller, follow that link to find out more information about installation re-
quirements and instructions.

Note

Cúram Portlets are not yet supported within a clustered environment
so the Portal Server should be installed as a stand alone server.

On one of the installation screens there is an option to enable ser-
vices to stop, start, and perform recovery actions for your server.
This is an optional step but is not recommended as this has not been
tested.

You should not install WebSphere Portal Server to a directory that contains
spaces in the name, i.e. the ‘Program Files’ directory.

2.9 Java SE/Java EE

2.9.1 Overview

Both a Java SE and a Java EE are necessary.

2.9.2 Supported Versions

Please refer to the Cúram Supported Prerequisites document for the exact
version of Java SE and Java EE to be installed.

2.9.3 Installation

Specific installation instructions are not provided for the Java SE or Java
EE as each application server ships with a Java SE and Java EE which can
be used.

Note

Irrespective of which Java SE and Java EE are used the post-
installation steps listed below must be followed.

2.9.4 Post-installation

1. An environment variable called JAVA_HOME must be created that
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points to the installed Java SE. %JAVA_HOME%\bin should be placed
at the beginning of the PATH environment variable. On a number of
sites, it may be necessary to have multiple Java SE’s installed on any
given machine. For this reason, the choice of scope for these environ-
ment variables (system wide, through a script file or symbolic links) is
left up to you.

2. An environment variable called J2EE_JAR must be created that points
to the installed Java EE jar file. For WebSphere Application Server this
should point at %WAS_HOME%\lib\j2ee.jar. For WebLogic Serv-
er this should point at %WLS_HOME%\lib\weblogic.jar;
however, note the specific post-install step for using WebLogic Server
with Eclipse in Section 2.10.4.4, Using a Server Project in Eclipse.

On a number of sites, it may be necessary to have multiple Java EE’s
installed on any given machine. For this reason, the choice of scope for
these environment variables (system wide, through a script file or sym-
bolic links) is left up to you.

2.10 Eclipse & Tomcat

2.10.1 Overview

This section describes the steps necessary to setup a machine for develop-
ment of an application in Eclipse and Apache Tomcat.

2.10.2 Supported Versions

Please refer to the Cúram Supported Prerequisites document for the exact
version of Tomcat and Eclipse to be installed.

2.10.3 Installation

To run in an Eclipse-based development environment the following soft-
ware is required which can be found on the development installation CD in
a folder called TPS (Third Party Software).

• Eclipse: The IDE used to develop an application.

• Tomcat: The servlet container used to run the client web application.
Note a read-me file is provided with details of customizations that have
been made to the Tomcat configuration for the development environ-
ment.

• Sysdeo Eclipse Tomcat Launcher: An open source Eclipse plug-in which
integrates with a Tomcat installation. Install the plug-in by extracting the
plug-in zip file to the Eclipse plugins directory. The default ec-
lipse/plugins) directory is assumed.
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• Java SE/Java EE: Oracle's Java SE and Java EE are used when running
in Eclipse.

2.10.4 Post-installation

Eclipse - Default Java SE

Eclipse should be launched with the Java SE installed from the product in-
stallation CD. Because many products are Java-based, multiple Java SE in-
stallations may already exist on your system. The following steps ensure the
correct Java SE is used.

1. Eclipse is launched from the eclipse.exe executable. Ensure the
Java SE installed from the development CD is the first one on the Win-
dows system path when launching Eclipse.3

2. Once Eclipse is launched, select Window→Preferences.

3. On the preferences dialog select Java, Installed JREs from the tree.
The correct Java SE should be selected as the default.

4. Click the Edit button.

5. In Default VM Arguments enter -Xmx512M.

Update Boot Class Path When Using the IBM WebSphere
Java SDK

The following XML API jar files (shipped with the SDEJ) should be
added to the boot class path if the IBM WebSphere Java SDK is be-
ing used.

• %CURAMSDEJ%\lib\xalan-2.7.1.jar

• %CURAMSDEJ%\lib\serializer-2.7.1.jar

• %CURAMSDEJ%\lib\xerces-2.9.1.jar

The boot class path can be set as a JVM parameter. For example:

-Xbootclasspath/p:
%CURAMSDEJ%\lib\xalan-2.7.1.jar;
%CURAMSDEJ%\lib\serializer-2.7.1.jar;%CURAMSD
EJ%\lib\xerces-2.9.1.jar

Tomcat

Tomcat with the default configuration incorrectly assumes requests are en-
coded using ISO-8859-1 instead of UTF-8. This would break string hand-
ling in IBM Cúram Social Program Management if request parameters con-
tained UTF-8 extended characters. To avoid this add the useBodyEncod-
ingForURI="true" parameter to the <Connector> element of the
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server.xml configuration file.

Alter POST limit when using Rules Sets

By default Tomcat limits POST data to 2 MB. This can cause an is-
sue when using Rules Sets, which need to POST data greater than
this limit. Although this step is optional, it is recommended for users
intending to use Rules Sets functionality. To disable the POST limit
in Tomcat add the maxPostSize="0" attribute to the
<Connector> element of the server.xml configuration file.
For example:

<Connector port="9080" maxThreads="150" min-
SpareThreads="25" maxSpareThreads="75" en-
ableLookups="false" redirectPort="8443" ac-
ceptCount="100" connectionTimeout="20000"
disableUploadTimeout="true" useBodyEncoding-
ForURI="true" maxPostSize="0"/>

Tomcat Plug-in

To use Tomcat from Eclipse the Sysdeo Eclipse Tomcat Launcher requires
some configuration:

1. From the menu, select Window→Preferences.

2. On the preferences dialog select Tomcat from the tree.

3. Set the Tomcat version to 6.x.

4. Set Tomcat home to the location of the tomcat installation.

5. Under Tomcat select JVM Settings.

6. In Append to JVM Parameters enter -Xmx512m.

Using a Server Project in Eclipse

The server project needs to be imported and configured for use in Eclipse.

1. Import the project (.project) located in the CuramSDEJ folder in
the development installation.

2. Import the project (.project) located in the EJBServer folder in
the development installation.

3. Once the projects are imported there are a number of Classpath vari-
ables errors. To resolve these navigate to Windows -> Preferences,
then Java -> Build Path -> Classpath Variables and set the following
variables.

• J2EE_JAR - jar file of your Java EE implementation. In the case
of WebLogic Server you can generate the wlfullclient.jar
and set J2EE_JAR to point to it: Run the WebLogic Server Jar-
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Builder tool, by going to the server\lib directory (e.g. cd
%WLS_HOME%\lib) and use the java command to create the
wlfullclient.jar (e.g. java -jar wljarbuilder.jar); see the
WebLogic Server product documentation for more information on
the WebLogic Server JarBuilder tool.

• JAVAMAIL_HOME - this should point at the folder containing
mail.jar and activation.jar of your Java EE implement-
ation.

The server is launched as a Java process which launches three threads:

• tnameserv: the Transient Name (tname) Server. This facilitates a JNDI
look up service for finding resources such as Java classes;

• RMI Server: Server application process;

• JMSLite: JMS Message Engine. See the Workflow Reference Guide for
more information on JMSLite.

From the components/core/source default package in your project,
select the StartServer class and select the Run as Application option
from the Run button.

VM Arguments

The Run Configuration option can be used to manage VM ar-
guments to the process e.g. to pass a higher heap size setting -
Xmx756M.

Using a Client Project in Eclipse

The client project needs to be imported and configured to run on Tomcat.

1. Import the project (.project) located in the CuramCDEJ folder in
the development installation.

2. Import the project (.project) located in the webclient folder in
the development installation.

3. Once the projects are imported right-click the project and select Prop-
erties, then Tomcat on the next dialog. Set the following properties:

• Context Name: Should be set to “/Curam”

• Can update server.xml file: Selected

• Mark this context as reloadable: Selected

• Redirect context logger to Eclipse console: Se-
lected

• Subdirectory to set as application root: Should
be set to “WebContent”
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4. Right-click the project again and select Tomcat Project, Update Con-
text Definition. This updates Tomcat's server.xml with an entry for
the client application.

The Sysdeo plug-in adds a toolbar to Eclipse for starting and stopping Tom-
cat. Once it is started, the client application is available at the following
URL: http://localhost:9080/Curam/AppController.do

Using the Cúram Business Intelligence and Analytics Viewer
project in Eclipse

This section will guide you through the process of configuring the Eclipse
environment to view Cúram Business Intelligence and Analytics™ content.
If you have further questions please see the BIRT Developers Guide for
more details.

1. Import the project into Eclipse by going to File→Import.... Select Gen-
eral→Existing Projects into Workspace and click Next. Select the root
directory to be %CURAM_DIR%\BIApp\CuramBIRTViewer and
click Finish.

2. Select the CuramBIRTViewer project in Eclipse, then open the pref-
erences dialog by selecting Window→Preferences and expand
Java→Compiler and set Compiler compliance level: to 1.5.

3. Select the CuramBIRTViewer project in Eclipse, right-click and se-
lect Tomcat Project→Update context definition.

4. Open the preferences dialog by selecting Window→Preferences and ex-
pand Tomcat→JVM Settings and for the Classpath text box select the
Directory button and add in the full path to the
%CURAM_DIR%\EJBServer\project\properties.

5. If you are viewing licensed content via the Reports tab (ignore this sec-
tion if you do not have a Reports tab), then Open the preferences dialog
by selecting Window→Preferences and expand Tomcat→JVM Settings
and for the Classpath text box select the Directory button and add in
the full path to the
%CURAM_DIR%\Reporting\project\properties. See the
BIRT Developers Guide for more details.

6. You must now publish all Cúram Business Intelligence and Analytics
content to the BIRT Viewer. From the directory
%CURAM_DIR%\BIContent execute the command build
client.birt.

7. Start Tomcat, to verify your viewer is open for business, check ht-
tp://localhost:9080/CuramBIRTViewer.

If you are developing new Cúram Business Intelligence and Analytics con-
tent, please see the BIRT Developers Guide for more details on how to set
up a development environment.
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Using Eclipse to Validate the Tabbed Configuration Artifacts

To setup Eclipse to validate the tabbed configuration files with the correct
schema open the Eclipse Preferences dialog by selecting Window→Prefer-
ences and do the following:

• Select XML→XML Catalog;

• Click Add... to add a new entry;

• For the Location, point at the schema file (e.g. tab.xsd) in the
%CURAMSDEJ%\lib directory;

• Leave the rest as defaults and click OK;

• Repeat for each of the schema files for the tabbed configuration arti-
facts. Please refer to the Cúram Client Developer's Guide for the full list
of schema files. Click OK to exit the XML Catalog dialog.

• Select General→Editors→File Associations;

• Click Add... to add a new entry: *.tab;

• Select the new *.tab entry and use the Add... button to add the XML
Editor as the Associated Editor;

• Repeat for all the tabbed configuration artifact file extensions. Please
refer to the Cúram Client Developer's Guide for the full list of exten-
sions.

• Select General→Content Types;

• Expand Text and select XML;

• Click Add... to enter a file association for XML content and click OK.
Do this for each of the file extensions.

• Click OK to save the preference changes.

Default Text File Encoding

Eclipse allows you to set the default text file encoding at the project level.
Changing this from the default is currently unsupported for IBM Cúram So-
cial Program Management projects within Eclipse. This does not effect
your ability to save files in various encodings on a file by file basis. Consult
the Cúram Server Developer's Guide and the Cúram Web Client Reference
Manual for details on file encoding.

2.11 Rational Application Developer

2.11.1 Overview
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This section describes the steps necessary to setup a machine for develop-
ment of an application in IBM® Rational® Application Developer.

2.11.2 Supported Versions

Please refer to the Cúram Supported Prerequisites document for the exact
version of Rational Application Developer to be installed.

2.11.3 Installation

Perform a standard installation of Rational Application Developer.

2.11.4 Post-Installation

Configuration

The following post installation steps are required to ensure that Rational Ap-
plication Developer will work with the application.

Set the following Rational Application Developer preferences:

• Switch off build automatically: Project -> Build Automatically, and
clicking on it, ensuring it is no longer ticked.

• Switch off validation: Go to Window -> Preferences -> Validation, and
hit the Disable All button and click Ok.

• Select Windows -> Preferences and then Java -> Installed JREs and set
the installed JRE to be “Websphere v7.0 JRE”.

• Set the following file associations via Windows -> Preferences ->
Workbench -> File Associations:

• Add *.uim to the file types

• Add the XML Editor as the associated editor for *.uim.

• Add the schema to the XML catalog. In Windows -> Preferences, select
Web and Xml -> Xml Catalog and then select “User Specified Entries”.
Click Add and set the following values:

• Location: <CuramCDEJ>/lib/curam/xml/schema/uim.xsd

• Key Type: Schema Location

• Key: file://Curam/UIMSchema.xsd

Update to Boot Class Path

The following XML API jar files (shipped with the SDEJ) should be
added to the boot class path if the IBM Websphere Java SDK is be-
ing used.
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• %CURAMSDEJ%\lib\xalan-2.7.1.jar

• %CURAMSDEJ%\lib\serializer-2.7.1.jar

• %CURAMSDEJ%\lib\xerces-2.9.1.jar

The boot class path can be set as a JVM parameter. For example:

-Xbootclasspath/p:
%CURAMSDEJ%\lib\xalan-2.7.1.jar;
%CURAMSDEJ%\lib\serializer-2.7.1.jar;%CURAMSD
EJ%\lib\xerces-2.9.1.jar

Using a Server Project in Rational Application Developer

The EJBServer server project and CuramSDEJ project needs to be imported
and configured for use in Rational Application Developer.

1. Import the project (.project) located in the CuramSDEJ folder in
the development installation.

2. Import the project (.project) located in the EJBServer folder in
the development installation.

• Create a EJBServer\patch directory to match the required
source directory in the project classpath, if it is not present already.

Using a Client Project in Rational Application Developer

The webclient client project needs to be imported and configured to run the
embedded WebSphere server.

1. Unzip the %CURAM_DIR%\CURAMCDEJ\doc\RAD\RAD.zip file
into the %CURAM_DIR% directory; i.e., project base directory. Over-
write the existing files if requested. These default files are for use with
Rational Application Developer only.

2. Add the following to the
%CURAM_DIR%\webclient\.classpath file.

<classpathentry kind="con"
path="org.eclipse.jst.server.core.container/
com.ibm.ws.ast.st.runtime.runtimeTarget.v70/was.base.v7">
<attributes>
<attribute name="owner.project.facets" value="jst.web"/>
</attributes>
</classpathentry>
<classpathentry kind="con"
path="org.eclipse.jst.j2ee.internal.web.container"/>
<classpathentry kind="con"
path="org.eclipse.jst.j2ee.internal.module.container"/>

3. Add the following to the %CURAM_DIR%\webclient\.project
file to replace the current buildSpec and natures nodes:
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<buildSpec>
<buildCommand>
<name>org.eclipse.wst.jsdt.core.javascriptValidator</name>
<arguments>
</arguments>
</buildCommand>
<buildCommand>
<name>org.eclipse.jdt.core.javabuilder</name>
<arguments>
</arguments>
</buildCommand>
<buildCommand>
<name>org.eclipse.wst.common.project.facet.core.builder</name>
<arguments>
</arguments>
</buildCommand>
<buildCommand>
<name>org.eclipse.wst.validation.validationbuilder</name>
<arguments>
</arguments>
</buildCommand>
</buildSpec>
<natures>
<nature>

org.eclipse.jem.workbench.JavaEMFNature
</nature>
<nature>

org.eclipse.wst.common.modulecore.ModuleCoreNature
</nature>
<nature>

org.eclipse.wst.common.project.facet.core.nature
</nature>
<nature>org.eclipse.jdt.core.javanature</nature>
<nature>org.eclipse.wst.jsdt.core.jsNature</nature>
</natures>

4. Import the project (.project) located in the CuramCDEJ folder in
the development installation.

5. Import the project (.project) located in the webclient folder in
the development installation.

• Create a webclient\work directory to match the required
source directory in the project classpath, if it is not present already.

6. Import the project (.project) located in the CuramEAR folder in
the development installation.

Running the Application in Rational Application Developer

To run IBM Cúram Social Program Management on Rational Application
Developer, the relevant servers must be started. Complete the following
steps in Rational Application Developer:

1. The server is launched as an RMI Application by executing StartServer
class. Select the StartServer class by navigating to compon-
ents/core/source default package in your project. Then select
the Run as Application option from the Run button.
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2. Enable the server view, by navigating to Window -> Show View ->
Other -> Server -> Servers.

3. Add CuramEAR to the WebSphere Application Server and start the
server. To do this right click on the Websphere Server v7.0 and click
Add and Remove Projects. Select CuramEAR from Available Projects
into Configured Projects and click Finish. Both Websphere v7.0 Server
and CuramEAR should now have a status of started and Websphere
v7.0 Server should have state synchronized.

4. From the components/core/source default package in your
project, select the RMILoginClient class and then select the Run as
Application option from the Run button.

5. The application is now ready for use. Login using the URL: ht-
tp://localhost:9081/Curam/AppController.do
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Notes
1For more information on build files and their targets consult the Cúram
Server Developers Guide.
2For more information on Bootstrap.properties consult the Cúram
Server Developers Guide.
3An alternative is to use the -vm command line argument to the ec-
lipse.exe executable. Consult the Eclipse documentation for further de-
tails on its command line arguments.
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Notices
This information was developed for products and services offered in
the U.S.A. IBM may not offer the products, services, or features dis-
cussed in this document in other countries. Consult your local IBM
representative for information on the products and services currently
available in your area. Any reference to an IBM product, program,
or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equival-
ent product, program, or service that does not infringe any IBM in-
tellectual property right may be used instead. However, it is the
user's responsibility to evaluate and verify the operation of any non-
IBM product, program, or service. IBM may have patents or pending
patent applications covering subject matter described in this docu-
ment. The furnishing of this document does not grant you any li-
cense to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing

IBM Corporation

North Castle Drive

Armonk, NY 10504-1785

U.S.A.

For license inquiries regarding double-byte (DBCS) information,
contact the IBM Intellectual Property Department in your country or
send inquiries, in writing, to:

Intellectual Property Licensing

Legal and Intellectual Property Law.

IBM Japan Ltd.

1623-14, Shimotsuruma, Yamato-shi

Kanagawa 242-8502 Japan

The following paragraph does not apply to the United Kingdom or
any other country where such provisions are inconsistent with local
law: INTERNATIONAL BUSINESS MACHINES CORPORA-
TION PROVIDES THIS PUBLICATION "AS IS" WITHOUT
WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WAR-
RANTIES OF NON-INFRINGEMENT, MERCHANTABILITY
OR FITNESS FOR A PARTICULAR PURPOSE. Some states do
not allow disclaimer of express or implied warranties in certain
transactions, therefore, this statement may not apply to you.

This information could include technical inaccuracies or typograph-

32



ical errors. Changes are periodically made to the information herein;
these changes will be incorporated in new editions of the publica-
tion. IBM may make improvements and/or changes in the product(s)
and/or the program(s) described in this publication at any time
without notice.

Any references in this information to non-IBM Web sites are
provided for convenience only and do not in any manner serve as an
endorsement of those Web sites. The materials at those Web sites are
not part of the materials for this IBM product and use of those Web
sites is at your own risk.

IBM may use or distribute any of the information you supply in any
way it believes appropriate without incurring any obligation to you.
Licensees of this program who wish to have information about it for
the purpose of enabling: (i) the exchange of information between in-
dependently created programs and other programs (including this
one) and (ii) the mutual use of the information which has been ex-
changed, should contact:

IBM Corporation

Dept F6, Bldg 1

294 Route 100

Somers NY 10589-3216

U.S.A.

Such information may be available, subject to appropriate terms and
conditions, including in some cases, payment of a fee.

The licensed program described in this document and all licensed
material available for it are provided by IBM under terms of the
IBM Customer Agreement, IBM International Program License
Agreement or any equivalent agreement between us.

Any performance data contained herein was determined in a con-
trolled environment. Therefore, the results obtained in other operat-
ing environments may vary significantly. Some measurements may
have been made on development-level systems and there is no guar-
antee that these measurements will be the same on generally avail-
able systems. Furthermore, some measurements may have been es-
timated through extrapolation. Actual results may vary. Users of this
document should verify the applicable data for their specific envir-
onment.

Information concerning non-IBM products was obtained from the
suppliers of those products, their published announcements or other
publicly available sources.

IBM has not tested those products and cannot confirm the accuracy
of performance, compatibility or any other claims related to non-
IBM products. Questions on the capabilities of non-IBM products
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should be addressed to the suppliers of those products.

All statements regarding IBM's future direction or intent are subject
to change or withdrawal without notice, and represent goals and ob-
jectives only

All IBM prices shown are IBM's suggested retail prices, are current
and are subject to change without notice. Dealer prices may vary.

This information is for planning purposes only. The information
herein is subject to change before the products described become
available.

This information contains examples of data and reports used in daily
business operations. To illustrate them as completely as possible, the
examples include the names of individuals, companies, brands, and
products. All of these names are fictitious and any similarity to the
names and addresses used by an actual business enterprise is entirely
coincidental.

COPYRIGHT LICENSE:

This information contains sample application programs in source
language, which illustrate programming techniques on various oper-
ating platforms. You may copy, modify, and distribute these sample
programs in any form without payment to IBM, for the purposes of
developing, using, marketing or distributing application programs
conforming to the application programming interface for the operat-
ing platform for which the sample programs are written. These ex-
amples have not been thoroughly tested under all conditions. IBM,
therefore, cannot guarantee or imply reliability, serviceability, or
function of these programs. The sample programs are provided "AS
IS", without warranty of any kind. IBM shall not be liable for any
damages arising out of your use of the sample programs.

Each copy or any portion of these sample programs or any derivative
work, must include a copyright notice as follows:

© (your company name) (year). Portions of this code are derived
from IBM Corp. Sample Programs.

© Copyright IBM Corp. _enter the year or years_. All rights re-
served.

If you are viewing this information softcopy, the photographs and
color illustrations may not appear.

Programming Interface Information
This publication documents intended programming interfaces that al-
low the customer to write programs to obtain the services of IBM
Cúram Social Pogram Management.
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Trademarks
IBM, the IBM logo, and ibm.com are trademarks or registered trade-
marks of International Business Machines Corp., registered in many
jurisdictions worldwide. Other product and service names might be
trademarks of IBM or other companies. A current list of IBM trade-
marks is available on the Web at "Copyright and trademark informa-
tion" at http://www.ibm.com/legal/us/en/copytrade.shtml.

Apache is a trademark of Apache Software Foundation.

BIRT is a registered trademark of Eclipse Foundation.

Microsoft, Windows, and Word are trademarks of Microsoft Corpor-
ation in the United States, other countries, or both.

UNIX is a registered trademark of the Open Group in the United
States and other countries.

Oracle, WebLogic Server, Java and all Java-based trademarks and
logos are registered trademarks of Oracle and/or its affiliates.

Other names may be trademarks of their respective owners. Other
company, product, and service names may be trademarks or service
marks of others.
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