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Creating a Vehicle Rear Defogger System
This tutorial teaches the Statemate design fundamentals as you follow the steps to design and 
validate a Vehicle Rear Defogger system based on the following requirements. 

Tutorial Project Definition
These descriptions and requirements describe the rear defogger being designed in Statemate.

Basic System Description

When the system is activated, it needs to time out automatically and shut its on-vehicle speed and 
load management. The system must provide the vehicle operator with an indictator of the current 
state of the system. The operator may request a change in the state of the system. 

The system provides a safe temperature for defogging the rear window without overloading the 
electrical system nor depriving critical resources of power. Since the system performs some 
automatic operations, the vehicle operator needs to know if the system is on or off.

To trigger the system, the vehicle operator requests a change in state of the rear defog control 
system.

Non-Functional Requirements

The system must respond to user requests and changes in load within 100 milliseconds. Vehicle 
speed must be checked at least every 10 seconds. The indicator must reflect the current state of the 
rear defog control system within 100 milliseconds of a user request.

Exception Notes

A service technician can recalibrate the timing parameters. The rear defogger system may become 
nonfunctioning.
Statemate  1 



Creating a Vehicle Rear Defogger System
Lab Setup
Prior to starting the exercises it is necessary to set up your system and create a project within 
Statemate using these steps:

1.    Create a folder/directory called “stm_projects” on your system in which to store your 
project.

2.    Start Statemate using the appropriate method:

� From Windows: 

Select Start > All Programs > Telelogic > Statemate > Statemate <version>.
� From UNIX:

$STM_ROOT/run_stmm.bat
The Statemate Main Window opens without a project.

Statemate Main Window (Without a Project)
2 Statemate Tutorial



Lab Setup
3.    Select File > New Project from the Statemate window. The Create New Project window 
opens.

Creat New Project

4.    Enter the following information in the Create New Project window.

� Name: REAR_DEFOG_<your_initials>
� Databank: <path>\stm_projects\rear_defog_<your_initials>.db

Note:  

� Blank spaces are not allowed within the form.
� Leave all other entries with their default values.

Clicking on the 
'…' opens an 
Explorer 
window for 
browsing.

The Explorer 
window may 
become 
minimized.
Statemate 3



Creating a Vehicle Rear Defogger System
Create New Project (Information Entered)

5.    Click OK to create the project. The Open Project window opens.

Open Project 
4 Statemate Tutorial



Lab Setup
6.    Select the project that you just created, REAR_DEFOG_<your_initials>.

7.    Enter the following information to create a Workarea for the project that you just created.

Workarea: <path>\stm_projects\rear_defog_<your_initials>.wa

8.    Click OK to open the project. The Statemate Main Window (Project Open) opens.

Statemate Main Window (Project Open)
Statemate 5



Creating a Vehicle Rear Defogger System
Exercise 1 - Constructing a Use Case Diagram
This exercise provides a walk-through the process to create a Use Case Diagram. The following 
example depicts the completed diagram for this exercise.

Use Case Diagram 'REAR_DEFOG_UCD' 
6 Statemate Tutorial



Exercise 1 - Constructing a Use Case Diagram
1.    Click Graphic Editors from the main Statemate window.

Statemate Main Window (Graphics Editor Icon)

Note:  The Graphics Editor window allows you to open any available charts as well as 
create new charts. 

2.    Enter the following information to create a Use Case diagram (chart) called 
REAR_DEFOG_UCD. Refer to the following figure.

Note:  Do not use spaces in the chart names.

� Type: Use-Case Diagram
� Usage: Regular - It defaults to this value based upon Type.
� Name Pattern: REAR_DEFOG_UCD
Statemate 7



Creating a Vehicle Rear Defogger System
Open/Create Chart
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Exercise 1 - Constructing a Use Case Diagram
3.    Click New from the Open Chart window. The use-case diagram displays and is available 
for editing (see the following figure).

Use-Case Daigram Icons

Use-Case
Drawing
Icons

Create Boundary Box
Create Actor

Create Use-Case

Create Extend Relation

Create Include Relation
Create Generalization Relation

Create Textual Note

Put GE Into Select Mode

Create AssociationCreate Association

Create Generalization Relation
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Creating a Vehicle Rear Defogger System
4.    Click Create Boundary Box .

5.    To draw the Boundary Box for the REAR_DEFOG_UCD, place the cursor at the desired 
location for the upper, left-hand corner of the boundary box and click and drag to the 
desired location of the lower, right-hand corner of the boundary box.

Note:  The boundary box is named by default.

6.    With the Create Boundary Box icon selected, enter REAR_DEFOG_UCD. 

Note:  

� Click the location you want the text to reside within the boundary box. If a name 
already exists, double-click on the text to rename the item.

� Enter the names for boxes using lowercase letters only! Statemate, where 
appropriate, automatically performs the conversion to uppercase letters. Do not 
select the CAPS LOCK key before typing. Doing so may prevent you from 
making further selections within the tool.

7.    Click Create Use-Case .

8.    Draw two use-cases as shown in the Use Case Diagram 'REAR_DEFOG_UCD' figure.

9.    Name one use-case DEFOG_REAR_WINDOW and the other 
CUSTOMER_INDICATION.

10.    Click Create Actor .

11.    Draw four actors as shown in the Use Case Diagram 'REAR_DEFOG_UCD' figure.

12.    Name the actors: 

� 'LOAD_MONITOR'
� 'SPEED_SENSOR'
� 'OPERATOR'
� 'REAR_DEFOG_RELAY'.

Note:  When an actor is added to a diagram, it is given a default name. To change the 
name of an actor, double-click on the text and enter the new information.

13.    Select Create Association .
10 Statemate Tutorial



Exercise 1 - Constructing a Use Case Diagram
14.    Draw the associations between the Actors and the Use-Cases as shown in the Use Case 
Diagram 'REAR_DEFOG_UCD' figure.

a.    Locate an actor and place the cursor on the edge of the actor.

b.    Click and release the left mouse button to enter the tail of the arrow. 

c.    Locate the use-case and place the cursor on the edge of the use-case

d.    Click the middle mouse button to enter the arrowhead.

15.    Select File > Save from the diagram and then File > Exit.
Statemate 11



Creating a Vehicle Rear Defogger System
Exercise 2 - Constructing a Sequence Diagram
In this exercise, you will create two Sequence Diagrams. The 'Sequence Diagram 
'REAR_DEFOG_LO_SPEED_NO_LOAD' and Sequence Diagram 'REAR_DEFOG_2HI_SPEED_2LOAD1 
figures depict what the diagrams will look like at completion of this exercise.

Sequence Diagram 'REAR_DEFOG_LO_SPEED_NO_LOAD

'

12 Statemate Tutorial



Exercise 2 - Constructing a Sequence Diagram
Sequence Diagram 'REAR_DEFOG_2HI_SPEED_2LOAD1
'

Statemate 13



Creating a Vehicle Rear Defogger System
1.    Click Graphic Editors (refer to the following figure) from the main Statemate window.

Statemate Graphic Editors Icon Selection

2.    Create a Sequence Diagram called REAR_DEFOG_LO_SPEED_NO_LOAD based 
upon the selections shown in the following figure. 

Note:  Do not use spaces in chart names.

� Type: Sequence Diagram
� Usage: Regular (will default to this value based upon Type)
� Name Pattern: REAR_DEFOG_LO_SPEED_NO_LOAD
14 Statemate Tutorial



Exercise 2 - Constructing a Sequence Diagram
Open/Create Chart
Statemate 15



Creating a Vehicle Rear Defogger System
3.    Click New from the Open Chart window to create and open a new diagram (refer to the 
following figure). The chart is now available for editing.

New Sequence Diagram

4.    Click Create Partition Line .

5.    Draw a Partition Line within the Sequence Diagram.

Place the cursor at the desired location and drag the mouse slightly to the right and release 
the mouse. This line extends “infinitely.”

Sequence
Diagram
Drawing
16 Statemate Tutorial



Exercise 2 - Constructing a Sequence Diagram
Partition Line

6.    Click Create External Life Line .

7.    Draw two external lifelines in the Sequence Diagram.

Place the cursor at the desired location and double-click the mouse. A vertical line 
extends 'infinitely'. When a lifeline is added to a diagram it is given a default name. To 
change the names of lifeline, double-click on the text and enter the new name.

8.    Name the external lifelines REAR_DEFOG_RELAY and OPERATOR.

9.    Click Create Life Line .

10.    Draw a lifeline called 'REAR_DEFOG_SS'. This is done the same way as the external 
lifelines. See the Sequence Diagram - Life Lines figure.
Statemate 17



Creating a Vehicle Rear Defogger System
Sequence Diagram - Life Lines

11.    Click Create Simple Message .

Note:  Simple messages have to be drawn between the various lifelines. The following 
table shows the source and target of each lifeline.

12.    Locate a lifeline and place the cursor on the edge of the lifeline and click to enter the tail 
of the arrow. 

13.    Locate the targeted lifeline and place the cursor on the edge of the targeted lifeline, and 
click to enter the arrowhead.
18 Statemate Tutorial



Exercise 2 - Constructing a Sequence Diagram
Simple Message

14.    With the Create Simple Message icon still selected, label the messages as shown in the 
following table - Simple Message Labels.

Simple Message Labels

15.    Click Create Message Note  to add message notes to the diagram.

16.    Select and add the flowing notes to the messages as shown in the following table. The 
message notes are free text that is associated to particular message lines. Attach the text to 
the message by clicking on the message line. 

Simple Message Notes

Source Target

OPERATOR REAR_DEFOG_SS

REAR_DEFOG_SS OPERATOR

REAR_DEFOG_SS REAR_DEFOG_RELAY

REAR_DEFOG_SS REAR_DEFOG_RELAY

REAR_DEFOG_SS OPERATOR

Source Target Label

OPERATOR REAR_DEFOG_SS RDEFOG_SW_STATUS

REAR_DEFOG_SS OPERATOR [RDEFOG_LED= =true]

REAR_DEFOG_SS REAR_DEFOG_RELAY [DEFOG_DRIVE_OUT= = 0b0]

REAR_DEFOG_SS REAR_DEFOG_RELAY [DEFOG_DRIVE_OUT= = 0b1]

REAR_DEFOG_SS OPERATOR [RDEFOG_LED= =false]

Source Target Message Note

OPERATOR REAR_DEFOG_SS 1. Customer requests the rear defog 
system on.

REAR_DEFOG_SS OPERATOR 2. The rear defog led is turned on.

REAR_DEFOG_SS REAR_DEFOG_RELAY 3. The rear defog relay is enabled.

REAR_DEFOG_SS REAR_DEFOG_RELAY 4. After being enabled for Low Speed 
Max On Time seconds, the rear defog 
relay is disabled.

REAR_DEFOG_SS OPERATOR 5. The rear defog relay led is turned off.
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Creating a Vehicle Rear Defogger System
17.    Click Create Order Insignificant Line  and place this between two of the messages. 
Between messages 2 and 3, and messages 4 and 5. See the Sequence Diagram 
'REAR_DEFOG_LO_SPEED_NO_LOAD figure.

18.    Click Create Timing Constraint  and add this between message 3 and 4. See the 
Sequence Diagram 'REAR_DEFOG_LO_SPEED_NO_LOAD figure.

19.    Select File > Save from the diagram and then File > Exit.

20.    Repeat steps 1-3 to create another sequence diagram called 
'REAR_DEFOG_2HI_SPEED_2LOAD1'.

21.    Create a partition line and four (4) external lifelines with the following names:

� 'LOAD_MONITOR'
� 'SPEED_SENSOR'
� 'OPERATOR'
� 'REAR_DEFOG_RELAY'.

22.    Draw a lifeline in the called 'REAR_DEFOG_SS'. This is done in the same manner as 
was done with the external lifelines.

23.    Create simple messages between the various lifelines, based upon the information in the 
following table, Simple Messages, that show the source and target of each lifeline.

Simple Messages

24.    Add message notes to the messages within the diagram. Refer to the following table, 
Message Notes, for the messages that need to be added. 

Source Target

LOAD_MONITOR REAR_DEFOG_SS

OPERATOR REAR_DEFOG_SS

REAR_DEFOG_SS OPERATOR

REAR_DEFOG_SS REAR_DEFOG_RELAY

SPEED_SENSOR REAR_DEFOG_SS

OPERATOR REAR_DEFOG_SS

REAR_DEFOG_SS REAR_DEFOG_RELAY

REAR_DEFOG_SS REAR_DEFOG_RELAY

REAR_DEFOG_SS REAR_DEFOG_RELAY
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Exercise 2 - Constructing a Sequence Diagram
Note
Labels are not be added to the diagram yet.

Message Notes

25.    Select File > Save from the diagram and then File > Exit.

Source Target Message Note

LOAD_MONITOR REAR_DEFOG_SS 1. Charging subsystem indicates electrical 
system load.

OPERATOR REAR_DEFOG_SS 2. Customer requests the rear defog system 
to turn on.

REAR_DEFOG_SS REAR_DEFOG_RELAY 3. The rear defog LED is illuminated.

REAR_DEFOG_SS REAR_DEFOG_RELAY 4. The rear defog relay is enabled.

SPEED_SENSOR REAR_DEFOG_SS 5. Vehicle speed increases past the high-
speed threshold - the relay can be enabled 
indefinitely.

OPERATOR REAR_DEFOG_SS 6. Load condition one exists, the system 
starts modulation of the rear defog relay.

REAR_DEFOG_SS REAR_DEFOG_RELAY 7. Modulation starts at the calibrated duty 
cycle; the relay is disabled.

REAR_DEFOG_SS REAR_DEFOG_RELAY 8. Modulation continues; the relay is enabled.

REAR_DEFOG_SS REAR_DEFOG_RELAY 9. Modulation continues; the relay is disabled.
Statemate 21



Creating a Vehicle Rear Defogger System
Exercise 3 - Linking Use-Cases to Scenarios
In this exercise, you will use use-cases to create possible scenarios utilizing elements properties.

1.    Select the Charts tab from the main Statemate window.

Charts Tab
22 Statemate Tutorial



Exercise 3 - Linking Use-Cases to Scenarios
2.    Select the REAR_DEFOG_UCD diagram from within the Chart View (refer to the 
following figure). This provides a list all of the diagram elements associated within the 
diagram in the Element Matrix.

Element Matrix
Statemate 23



Creating a Vehicle Rear Defogger System
3.    Select the use-case within the Use Case Diagram called 'DEFOG_REAR_WINDOW' 
and then select Edit > Properties… (refer to the following figure).

Properties for DEFOG_REAR_WINDOW

Note:  Double-clicking on the item within the Element Matrix also opens the 
Properties window. Selecting a diagram within the chart view displays all 
elements within the diagram in the Element Matrix.

4.    Select the Description tab and enter the following text in the Use-Case Long Description 
field:

'The customer may request a change in state of the rear defog control 
system. Once the system has been activated, it shall automatically time 
out and turns itself off without any customer interaction. The timing 
function can be modified by vehicle speed and load management.'

5.    Select the Definition tab and then click   to invoke the Scenario List, (refer to the 
following figure) to create the mapping between the use-case and the scenario(s). The 

Scenario List is invoked by clicking  at the bottom of the Properties form.
24 Statemate Tutorial



Exercise 3 - Linking Use-Cases to Scenarios
Scenario List

6.    Fill out the Scenario List with the following data (refer to the following figure) to create 
the necessary links.

Scenario List Mapping

7.    Select Save from the Properties window and then Exit.
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Creating a Vehicle Rear Defogger System
Exercise 4 - Constructing an Activity-Chart
In this exercise,  you will develop the top-level system diagram for the rear defog system, as 
shown in the following figure.

Activity-Chart - REAR_DEFOG_SS
26 Statemate Tutorial



Exercise 4 - Constructing an Activity-Chart
1.    Click Graphic Editors from the main Statemate window.

Graphics Editor Icon

2.    Create an Activity-chart called 'REAR_DEFOG_SS' based on the selections shown in the 
following figure.

Note:  Do not use spaces in chart names.

� Type: Activity
� Usage: Regular 
� Name Pattern: REAR_DEFOG_SS
Statemate 27



Creating a Vehicle Rear Defogger System
Open/Create Chart
t

3.    Click New from the Open Chart window to create and open a new diagram. The chart is 
now available for editing.
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Exercise 4 - Constructing an Activity-Chart
New Activity-Chart 

4.    Click Create Internal Activity . 

5.    Draw the internal activity called 'REAR_DEFOG_SS'.

Place the cursor at the desired location for the upper, left-hand corner of the activity and 
drag to the desired location of the lower, right-hand corner of the activity and release the 
mouse. A ghost image shows the activity outline.

6.    Click Create Internal Activity or Name Existing Activity and start entering the name of 
the activity. Click and release tat the location in which you want the text to reside within 
the activity.

7.    Enter the names for boxes using lowercase letters.

Note:  Statemate, where appropriate, automatically performs the conversion to 
uppercase letters. Do not select the CAPS LOCK key before typing. Doing so 
may prevent you from making further selections.

8.    Using the Activity-Chart - REAR_DEFOG_SS figure and the previous instructions as a 
guide, create and name two internal activities called 'REAR_DEFOG_FEATURES' and 
'REAR_DEFOG_OUTPUT_FCTS'.

Activity-
Chart
Drawing 
Icons
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Creating a Vehicle Rear Defogger System
9.    Click Create External Activity .

10.    Draw the external activities for the REAR_DEFOG_SS. The same drawing rules apply 
for drawing and naming external activities Use the following figure as a guide as to which 
external activities should be on the left and which external activities should be on the 
right.

Partial Chart Design

11.    Click Create Data-Flow .

12.    Draw a flow line from the external activity called 'SPEED_SENSOR' to the internal 
activity called 'REAR_DEFOG_FEATURES'.

13.    Locate the external activity called 'SPEED_SENSOR'. This is the source activity. Place 
the cursor on the edge of the box and click and drag to enter the tail of the arrow. 
30 Statemate Tutorial



Exercise 4 - Constructing an Activity-Chart
14.    Locate the internal activity called 'REAR_DEFOG_FEATURES'. This is the target 
activity. Place the cursor on the edge of the box and click and drag to enter the arrowhead.

Note:  In order to create flow lines with angles, you may click/release the left mouse 
button at each location. 

15.    Label the flow line 'VEHICLE_SPEED_IN’.

With the Create Data-Flow or the Label Existing Flow-Line icon selected, start entering 
the desired name for the label. Click the flow line that you want to label.

16.    Draw a flow line from the external activity called 'OPERATOR' to the internal activity 
'REAR_DEFOG_FEATURES' and label the flow 'RDEFOG_SW_STATUS'.

17.    Draw a flow line from the external activity called 'LOAD_MONITOR' to the internal 
activity 'REAR_DEFOG_FEATURES' and label the flow 'LOAD_SHED_IN'.

18.    Draw a flow line from the internal activity called 'REAR_DEFOG_FEATURES' to the 
internal activity 'REAR_DEFOG_OUTPUT_FCTS' and label the flow 
'DEFOG_DRIVE_SIG'.

19.    Draw a flow line from the internal activity called 'REAR_DEFOG_FEATURES' to the 
external activity 'OPERATOR' and label the flow 'RDEFOG_LED'.

20.    Draw a flow line from the internal activity called 'REAR_DEFOG_OUTPUT_FCTS' to 
the external activity 'REAR_DEFOG_RELAY' and label the flow 
'DEFOG_DRIVE_OUT'.

21.    Select File > Save from the chart and then File > Exit.
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Creating a Vehicle Rear Defogger System
Exercise 5 - Defining Textual Elements
In this exercise. you will formally define the textual elements that were entered into the activity-
chart 'REAR_DEFOG_SS'.

1.    Select the chart called 'REAR_DEFOG_SS' from right panel of the Chart Tab. Refer to 
the following figure.

Element Matrix for Chart REAR_DEFOG_SS
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Exercise 5 - Defining Textual Elements
2.    Select the element called 'VEHICLE_SPEED_IN'. 

3.    Select Edit > Properties. This opens the Properties window for this element (refer to the 
following figure). Double-clicking on the element name also opens the properties window 
for this element.

Properties - Vehicle Speed In
Statemate 33



Creating a Vehicle Rear Defogger System
4.    You now need to define the textual element 'VEHICLE_SPEED_IN'.

a.    Change the type from Information Flow to Data-Item from the pull-down menu. 
See the following figure.

Unresolved Element - Vehicle Speed In

b.    Change the Data Type from None to Integer from the pull-down menu.

c.    Enter a Min Value of 0. See the following figure.

Property Form - Data Item Vehicle Speed In
34 Statemate Tutorial



Exercise 5 - Defining Textual Elements
d.    Enter a Max Value of 150.

e.    Enter a Default Value of 50.

f.    Enter the following text in the Description field: 'Vehicle Speed from Powertrain 
(KPH).'

g.    Click Save.

h.    Exit.

5.    Select the flow line and define the textual element called 'RDEFOG_SW_STATUS'. 

6.    Change the Data Type from Information Flow to Event.

7.    Enter the following text in the Description field: 

'Rear Defog switch status from Operator'

8.    Click Save.

9.    Exit.

10.    Select the flow line and define the textual element called 'DEFOG_DRIVE_SIG'. 

11.    Change the Type from Information Flow to Condition.

12.    Enter the following text in the Description field: 

'Logical output to turn on/off relay.'

13.    Click Save.

14.    Exit.

15.    Select the flow line and define the textual element called 'DEFOG_DRIVE_OUT'. 

16.    Change the Type from Information Flow to Data-Item.

17.    Change the Data Type from None to Bit.

18.    Enter the following text in the Description field: 

'Low side drive to relay.'

19.    Click Save.

20.    Exit.

21.    Select the flow line and define the textual element called 'RDEFOG_LED'. 
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Creating a Vehicle Rear Defogger System
22.    Change the Type from Information Flow to Condition.

23.    Enter the following text in the Description field: 

'Rear defog light output to Operator.'

24.    Click Save.

25.    Exit.

Note:  The final element that needs to be defined is the element 'LOAD_SHED_IN'. 
This element can be one of four possible values. To accomplish this, an 
enumerated type will be created. 

26.    From the main Statemate window, click GDS Editor (refer to the following figure). 

GDS Editor Icon

Note:  An Open GDS window (refer to the following figure) becomes invoked. 

27.    Enter the name 'REAR_DEFOG_GDS' for the GDS name and click OK.
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Exercise 5 - Defining Textual Elements
Open GDS

28.    Click New from the Properties window.

29.    Create the new element type using the values shown in the following figure.

� Element Name: LOAD_MGMT_CMD_TYPE
� Chart Name: REAR_DEFOG_GDS
� Element Type: User-Defined Type

New GDS Element

Note:  You now need to define the User-Defined Type called 
'LOAD_MGMT_CMD_TYPE' (refer to the following figure). 
Statemate 37



Creating a Vehicle Rear Defogger System
User-Defined Type

30.    Change the Change the Data Type from None to Enum Type from the pull-down menu. 

31.    Enter the following text in the Definition field: 

{LM_LEVEL0, LM_LEVEL1, LM_LEVEL2, LM_LEVEL3}

32.    Enter the following text in the Description field: 

'Load Management Types.'

33.    Click Save.

34.    Exit.

Note:  You can now return to the Chart Tab view and select the activity-chart 
“REAR_DEFOG_SS” and define the textual element called 
'LOAD_SHED_IN'. 

35.    Double-click on the element called “LOAD_SHED_IN” to bring up the properties 
window (refer to the following figure). 

36.    Change the Type from Information Flow to Data-Item from the pull-down menu.

37.    Change the Data Type from None to User Type.

38.    Select 'LOAD_MGMT_CMD_TYPE' from the drop down selection window next to the 
Data Type.
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39.    Enter the following text in the Description field:

'Load management levels (0-3)'

40.    Click Save.

41.    Exit.

Property Window - User Type
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Exercise 6 - System Decomposition
In this exercise, you will create three activity-charts that show the decomposition of the top-level 
activity-chart that was developed in Exercise 4 - Constructing an Activity-Chart. The same modeling 
techniques should be used in this exercise as in Exercise 4. The following three figures show the 
three activity-charts that need to be created.

� Activity-chart REAR_DEFOG_FEATURES

� Activity-chart CALC_REAR_DEFOG_STATE

� Activity-Chart REAR_DEFOG_RELAY_MGMT

Activity-chart REAR_DEFOG_FEATURES
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Activity-chart CALC_REAR_DEFOG_STATE
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Activity-Chart REAR_DEFOG_RELAY_MGMT
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Exercise 6 - System Decomposition
1.    Create and design the above three activity-charts based upon the modeling techniques 
used in Exercise 4 - Constructing an Activity-Chart.

Note:  During the following step, you need to create the relationship between the 
activity-charts that have been created within the exercises. 

2.    Open the chart called 'REAR_DEFOG_SS' and modify the name of the activity called 
'REAR_DEFOG_FEATURES' by adding a '@' symbol to the beginning of the name. 
Refer to the following figure.

Creating System Decomposition

3.    Once the '@' symbol has been added to the activities name, select the activity and then 
select File > Open Sub-Chart. 

4.    From within the activity-chart REAR_DEFOG_FEATURES, edit the names of the 
activities CALC_REAR_DEFOG_STATE and REAR_DEFOG_RELAY_MGMT by 
adding a '@' symbol to the beginning of their names.

Note:  You also need to define the textual element added to the activity-chart 
REAR_DEFOG_FEATURES called 'RDEFOG_ON_STATUS'. 
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5.    Open the Properties window for the element by selecting the flow line and then selecting 
Edit > Properties.

6.    Change the Type from Information Flow to Condition.

7.    Enter the following text in the Description field:

'Indicates that the rear defog is on or off.'

8.    Select Save.

9.    Exit.

10.    Select View > Refresh from the main Statemate window. You can see how the charts are 
now decomposed within the model (refer to the following figure).

11.    Select File > Save from the charts and then File > Exit.
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Chart View of Static Structure
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Exercise 7 - Defining Environment Activities
In this exercise, you will formally define the external activities within the root chart 
'REAR_DEFOG_SS'.

1.    Double-click the chart called 'REAR_DEFOG_SS' from the workarea. This opens the 
chart.

2.    Select all of the external activities within the chart.

3.    Select Tools > Properties. This invokes the Properties window for these elements (refer 
to the following figure). 

External Activity Properties Window

Note:  You need to define the external activities within the chart. Modify the activities 
within the Properties window with the following settings:

4.    Change the Type from External to Environment.

5.    Select Save and Next.

6.    Exit after the last element is saved.
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Exercise 8 - Constructing Statecharts
In this exercise, you will construct two statecharts that describe behavioral aspects of the rear 
defog system. The Statechart CALC_REAR_DEFOG_STATE_BHVR and Statechart 
REAR_DEFOG_RELAY_MGMT_BHVR figures show the two intended statecharts.

Statechart CALC_REAR_DEFOG_STATE_BHVR
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Statechart REAR_DEFOG_RELAY_MGMT_BHVR
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Exercise 8 - Constructing Statecharts
1.    Click Graphic Editor from the main Statemate window.

Graphics Editor Icon

2.    Create a statechart called 'CALC_REAR_DEFOG_STATE_BHVR' based on the 
selections shown in the following figure.

Note:  Do not use spaces in chart names.

� Type: Statechart
� Usage: Regular 
� Name Pattern: CALC_REAR_DEFOG_STATE_BHVR
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Open/Create Chart
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Exercise 8 - Constructing Statecharts
3.    Select New from the Open Chart window to create and open a new diagram. The chart is 
now available for editing. Refer to the following figure.

New Statechart

4.    Click Create State drawing .

5.    Draw a state called CALC_REAR_DEFOG_STATE_BHVR.

Place the cursor at the desired location for the upper, left-hand corner of the state and drag 
to the desired location of the lower, right-hand corner of the state. A ghost image shows 
the state outline.

6.    With the Create State or the Name Existing State icon selected, start enter the name of the 
state. 

Statechart
Drawing 
Icon
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7.    Click at the location you want the text to reside within the state.

Note:  Enter the names for boxes using lowercase letters. Statemate, where 
appropriate, will automatically perform the conversion to uppercase letters. Do 
not select the CAPS LOCK key before typing.

8.    Using the Statechart CALC_REAR_DEFOG_STATE_BHVR figure as a guideline, create and 
name the other states within your chart.

9.    Click Create Transition .

10.    Draw a transition from the state called 'CALC_REAR_DEFOG_DISABLED' to the 
state called 'CALC_REAR_DEFOG_ENABLED'.

Locate the state called 'CALC_REAR_DEFOG_DISABLED'. This is the source state. 
Place the cursor on the edge of the box and click to enter the tail of the arrow. 

11.    Locate the state called 'CALC_REAR_DEFOG_ENABLED'. This is the target state. 
Place the cursor on the edge of the state and click to enter the arrowhead.

12.    With the Create Transition icon still selected, label the transition 
'RDEFOG_SW_STATUS and [LOAD_SHED_IN!=LM_LEVEL3]/ 
RDEFOG_LED=true; RDEFOG_ON_STATUS=true;

13.    With the Create Transition or the Label Existing Transition icon selected, enter the 
desired transition label. Click the location you want the text to reside.

14.    Click Create Default Transition .

15.    Draw a Default Transition into the state 'CALC_REAR_DEFOG_DISABLED'. 

Note:  Default transitions do not have a source state and may not have triggers. Use 
the Statechart CALC_REAR_DEFOG_STATE_BHVR figure as a guide as where to 
draw the default transition.

16.    With Create Default Transition still selected, label the transition 
'RDEFOG_LED=false; RDEFOG_ON_STATUS=false; RD_TIMER=KTIMER1;'

17.    Using the techniques in the previous steps, complete the design of the statechart based on 
the Statechart CALC_REAR_DEFOG_STATE_BHVR figure.

18.    Select File > Save from the chart and then File > Exit.
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19.    Using the steps outlined above, create and design the statechart called 
'REAR_DEFOG_RELAY_MGMT_BHVR' as shown in the Statechart 
REAR_DEFOG_RELAY_MGMT_BHVR figure.

Note:  The statecharts that were developed for this tutorial were used to describe the 
behavior for the activities, 'CALC_REAR_DEFOG_STATE' and 
'REAR_DEFOG_RELAY_MGMT'. To associate the statecharts with the 
activities, complete the following steps:

20.    Open the activity-chart called 'CALC_REAR_DEFOG_STATE'.

21.    Click Create Control Activity  in the activity-chart.

22.    Draw and name the control activity ('@CALC_REAR_DEFOG_STATE') as shown in 
the following figure.

23.    Select File > Save from the chart and then File > Exit.

24.    Repeat the above 4 steps and create the association between activity 
'REAR_DEFOG_RELAY_MGMT' and the statechart 
'REAR_DEFOG_RELAY_MGMT_BHVR'.
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Control Activity CALC_REAR_DEFOG_STATE_BHVR
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Exercise 9 - Describing Behavior
In this exercise, you will learn two new methods for describing behavior within Statemate - Mini-
Specs and Truth Tables.

1.    Select the activity-chart called 'REAR_DEFOG_SS' from the Chart View.

2.    Select the activity called 'REAR_DEFOG_OUTPUT_FCTS' and then select Edit > 
Properties (refer to the following figure).

Properties for Activity

3.    Change the Selected Implementation from None to Mini-Spec.
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4.    Within the Mini-Spec section of the Properties window, enter in the following logic:

started/

DEFOG_DRIVE_OUT=0b1;;       /* initialize to off*/

ch(DEFOG_DRIVE_SIG)/REAR_DEFOG_OUTPUT_TT;;

// The following is an alternative behavior if you did not want to use

// a truth table.

//

//   ch(DEFOG_DRIVE_SIG)/

//   if DEFOG_DRIVE_SIG then 

//       DEFOG_DRIVE_OUT=0b1;

//   else

//       DEFOG_DRIVE_OUT=0b0;

//   end if;;

5.    Click Save.

6.    Click Open References (refer to the following figure).
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Open References

7.    Select the textual element within the reference list called 
'REAR_DEFOG_OUTPUT_TT'.

8.    Change the element Type from Event to Action and the Selected Implementation should 
be defined as Truth Table.

9.    Click Save. This enables the Truth Table Editor for this element. Selection is near the 
bottom of the form. Refer to the following figure.

Open
References
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Truth Table Implementation

10.    For the action statement 'REAR_DEFOG_OUTPUT_TT', click Edit to invoke a truth 
table editor. Refer to the following figure.

Truth Table Editor
58 Statemate Tutorial
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11.    Select Worksheet > Redefine Table from the truth table editor window and input the 
settings as shown in the following figure.

Redefine Worksheet

12.    Fill out the new truth table with the entries as shown in the following figure.

Truth Table Settings
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Exercise 10 - Check Model
In this exercise, you will use the Check Model facility to verify that the model is syntactically 
correct and complete. 

1.    Click Check Model from the main Statemate window. Refer to the following figure.

Check Model Icon

2.    Select File > New Profile from the profile window (refer to the following figure) and 
enter “REAR_DEFOG_CHK” for the profile name that you are creating. If no profile 
exists, a New Profile window automatically opens.
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Check Model Profile
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3.    Click Add Selected Chart with Descendents to Profile . This opens a Chart Tree 
View of your current design (see the following figure).

Chart Tree View

4.    Select the chart called “REAR_DEFOG_SS” from the Chart Tree View (see the previous 
figure) then click OK.

5.    Click Execute Current Check Model Profile  from the Check Model profile window.

6.    Fix any warnings and/or errors within your design. Refer to the following figure. 

Note:  If the previous exercises were done without any mistakes, you should receive 
13 completeness warnings. The only warnings that we are concerned with are 
the unresolved elements warnings. The next few steps take you through 
resolving a number of known warnings that you should have received during 
the modeling. 
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Check Model Results

7.    Right-click on one of the textual elements and select Properties to fix the unresolved 
elements. Refer to the following figure.
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Resolve Warnings

8.    Define the textual element 'K_SPEED1'. Refer to the following figure. 

a.    Define the Type to Data-Item.

b.    Change the Data Type from None to Integer.

c.    Enter a Min Value of 0.

d.    Enter a Max Value of 100.

e.    Enter a Default Value of 80.

f.    Click Save.

9.    Exit.
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Textual Element 'K_SPEED1'

10.    Define the textual element 'K_RTIMER1'. 

a.    Define the Type to Data-Item.

b.    Change the Data Type from None to Integer.

c.    Enter a Min Value of 10.

d.    Enter a Max Value of 100.

e.    Enter a Default Value of 12.

f.    Click Save.

g.    Exit.
Statemate 65



Creating a Vehicle Rear Defogger System
11.    Define the textual element 'K_RTIMER2'. 

a.    Define the Type to Data-Item.

b.    Change the Data Type from None to Integer.

c.    Enter a Min Value of 5.

d.    Enter a Max Value of 10.

e.    Enter a Default Value of 6.

f.    Click Save button.

g.    Exit.

12.    Define the textual element 'RD_TIMER'. 

a.    Define the Type to Data-Item.

b.    Change the Data Type from None to Integer.

c.    Enter a Min Value of 0.

d.    Enter a Max Value of 100.

e.    Click Save.

f.    Exit.

13.    Define the textual element 'K_DUTY_CYCLE'. 

a.    Define the Type to Data-Item.

b.    Change the Data Type from None to Integer.

c.    Enter a Min Value of 0.

d.    Enter a Max Value of 100.

e.    Enter a Default Value of 50

f.    Click Save.

g.    Exit.
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14.    Define the textual element 'K_PERIOD'. 

a.    Define the Type to Data-Item.

b.    Change the Data Type from None to Integer.

c.    Enter a Min Value of 0.

d.    Enter a Max Value of 100.

e.    Enter a Default Value of 2

f.    Click 'Save'.

g.    Exit.

15.    Define the textual element 'OFF_TIME'. 

a.    Define the Type to Data-Item.

b.    Change the Data Type from None to Integer.

c.    Enter a Min Value of 0.

d.    Enter a Max Value of 100.

e.    Click Save.

f.    Exit.

16.    Define the textual element 'ON_TIME'. 

a.    Define the Type to Data-Item.

b.    Change the Data Type from None to Integer.

c.    Enter a Min Value of 0.

d.    Enter a Max Value of 100.

e.    Click Save.

f.    Exit.

17.    Select File > Exit from the Check Model profile window.
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Finishing and Managing the Project
This section demonstrates the techniques used to simulate the model and other project completion 
and management processes. 

Exercise 11 - Simulation
You use the Simulator to validate the dynamic behavior for part of the design.

1.    Open the statechart 'REAR_DEFOG_RELAY_MGMT_BHVR' and select Tools > 
Simulation. The Simulation Execution window opens. Refer to the following figure. 

Simulation Execution

2.    Select Displays > Monitors from the Simulation Execution window. The Monitor 
window (refer to the following figure) allows you to add model elements into the form to 
edit and/or view their value.
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Simulation Monitor

3.    Select Edit > Add from the Simulation Monitor window. The Element Selection for 
Monitor window opens (refer to the following figure). 

4.    Click All for the element type and then click Filter. 

5.    Click Select All and then the OK button to add these elements to the Simulation Monitor 
Window.
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Element Selection for Monitor

Note:  Arrange the statechart, Simulation Monitor, and Simulation Execution windows 
within your system monitor so that they are all assessable. Minimize any other 
open windows.

6.    Click GoStep  from the Simulation Execution window. The default transition within 
the statechart is highlighted. Select GoStep again. You should notice that you are now 
only in the default state. If you continue to select GoStep, no steps are taken.

7.    Click on the Value field for the Name 'RDEFOG_ON_STATUS' in the Simulation 
Monitor window. You should see (refer to the following figure) that the value changes 
from FALSE to TRUE. 
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Simulation Monitor Value

8.    Click GoStep again and view the changes within the statechart.

9.    Click on the value for 'LOAD_SHED_IN' and change the value. Click GoStep again. This 
should place you into the 'RD_RELAY_OFF' state.

10.    The trigger that takes you from the 'RD_RELAY_OFF' state to the 'RD_RELAY_ON' 

state is based upon the passage of time. Click AutoRun  to start simulating as in real-
time mode.

11.    The model should now be transitioning to and from the states 'RD_RELAY_OFF' state to 

the 'RD_RELAY_ON'. Click Pause icon  to temporarily halt the simulation execution. 

12.    Select File > Restart Simulation to restart the simulation from the Simulation Execution 
window. 

13.    Using the previous methods, simulate and study the model using different scenarios of the 
simulation. Also try using the various Step Operations provided by Statemate and notice 
the effect on the simulation.
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Exercise 12 - Constructing a Panel
In this exercise, you will construct the panel as shown in the following figure.

Rear Defog Panel
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1.    Click Panel Editor from the main Statemate window (refer to the following figure).

Panel Editor Icon

2.    Enter the name 'REAR_DEFOG_PNL' for the Panel Name (refer to the following 
figure).
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Open/Create Panel

Note:  The first part of the panel design is to add some graphical elements that are used 
as a background and to separate a number of the input and output elements. 

3.    Click Create Filled Box  from the Panel Graphic Editor (PGE) and stretch this to fill 
most of the panel canvas (refer to the following figure).

Create Filled Box
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4.    Select the Filled Box that you just created

5.    Select Tools > Properties. Change the Fill color to BLUE 3 (or any color that you may 
wish) and the Line Width to 3 (refer to the following figure).

Filled Box Properties

6.    Select Create Line Graphic and draw the lines as shown in the following figure.

7.    Change the properties for the lines so the Line Width is 3.
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Line Graphics

8.    Click Create Free Text' and enter the text as shown in the following figure. Select all of 
the text within the panel and then select Edit > Properties > Color and change the text 
color.
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Free Text

9.    Click Create Textual Display Interactor . Create five of them as shown in the 
following figure.
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Display Interactors

10.    Click Label Existing Interactor  and label each of the Display Interactors. To attach 
a label, enter the name of the particular interactor and then click the mouse on the object.

11.    Select the Display Interactor labeled 'Duty Cycle' and then select Tools > Bind to invoke 
the objects Bindings/Properties window (refer to the following figure).
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Bindings/Properties Window

12.    Enter the following for the binding values for the object labeled 'Duty Cycle':

� Bind Method: Input Output
� Controlled by: K_DUTY_CYCLE
� Element type: Integer
� Format: Decimal
� Field length: 6
� Fraction part: 0

13.    Click Apply.

14.    Select Bindings and change it to 'Properties' from the Bindings/Properties window. 

15.    Change the Text Color value to BLACK (refer to the following figure). Click OK.
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Properties Window

16.    Enter the following for the binding values for the object labeled 'Period':

� Bind Method: Input Output
� Controlled by: K_Period
� Element type: Integer
� Format: Decimal
� Field length: 6
� Fraction part: 0

17.    Click Apply.

18.    Change the Text Color value to BLACK and click OK.

19.    Enter the following for the binding values for the object labeled 'Timer 1':

� Bind Method: Input Output
� Controlled by: K_RTIMER1
� Element type: Integer
� Format: Decimal
� Field length: 6
� Fraction part: 0

20.    Click Apply.
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21.    Change the Text Color value to BLACK and click OK.

22.    Enter the following for the binding values for the object labeled 'Timer 2':

� Bind Method: Input Output
� Controlled by: K_RTIMER2
� Element type: Integer
� Format: Decimal
� Field length: 6
� Fraction part: 0

23.    Click Apply.

24.    Change the Text Color value to BLACK and click OK.

25.    Enter the following for the binding values for the object labeled 'Speed':

� Bind Method: Input Output
� Controlled by: K_SPEED1
� Element type: Integer
� Format: Decimal
� Field length: 6
� Fraction part: 0

26.    Click Apply.

27.    Change the Text Color value to BLACK and click OK.

28.    Click Create Push Button Interactor and create a push button labeled 'Rear Defog 
Switch', as shown in the following figure.
82 Statemate Tutorial



Exercise 12 - Constructing a Panel
Push Button Interactor

29.    Select the Push Button Interactor labeled 'Rear Defog Switch' and then select Tools > 
Bind to open the object's Bindings/Properties window.

30.    Enter the following for the binding values for the object labeled 'Rear Defog Switch':

� Bind Method: Input Output
� Controlled by: RDEFOG_SW_STATUS
� Element type: Event
� Button type:     Flash

31.    Select Create Slider Interactor icon and create a slider labeled 'Vehicle Speed' as shown 
in the following figure.
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Vehicle Speed Interactor

32.    Select the Slider Interactor labeled 'Vehicle Speed' and then select Tools > Bind to open 
the object's Bindings/Properties window. See the previous figure.

33.    Enter the following for the binding values for the object labeled 'Vehicle Speed':

� Bind Method: Input Output
� Controlled by: VEHICLE_SPEED_IN
� Element type: Integer

34.    Click Apply.
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35.    Select the 'Bindings' button and change it to 'Properties' in the Bindings/Properties 
window. Enter the following values for the properties settings:

� Minimum Value: 0.0
� Maximum Value: 150.0
� Primary Scale Step: 10.0
� No. of Secondary Partitions: 1

All other values can remain unchanged.

36.    Click OK.

37.    Select Create Vertical Multi-Choice Interactor and place it below the Vehicle Speed 
object as shown in the following figure. For the number of buttons, enter 4. 

Vertical Multi-Choice Interactor
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38.    Select the Create Label Interactor and label each button of the interactor as shown in the 
previous figure.

39.    Select the Vertical Multi-Choice Interactor and then select Tools > Bind to invoke the 
object's Bindings/Properties window.

40.    Enter the following for the binding values for the object labeled 'Vehicle Speed':

� Bind Method: Input Output
� Controlled by: LOAD_SHED_IN
� Element type: Enum Type
� Load Shed Level 0: LM_LEVEL0
� Load Shed Level 1: LM_LEVEL1
� Load Shed Level 2: LM_LEVEL2
� Load Shed Level 3: LM_LEVEL3
� Click OK.

41.    Select Create Lamp Interactor and create a lamp labeled 'Rear Defog Lite' as shown in 
the following figure.
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Lamp Interactor

42.    Select the Lamp Interactor and then select Tools > Bind to invoke the object's Bindings/
Properties window.

43.    Enter the following for the binding values for the object labeled 'Rear Defog Lite':

� Bind Method: Output
� Controlled by: RDEFOG_LED
� Element type: Condition
� Button type: Toggle

44.    Click OK.

45.    Select Create Box Graphic and create a box under the Rear Defog Lite'.
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46.    Select the Create Line Graphic and draw horizontal lines in the box that you just created 
(refer to the following figure).

User Drawing

47.    Select the box and all of the lines that were just drawn. Then, select Group > Make 
Group. This combines the elements into a single object.

48.    Select the group and then select Tools > Bind to open the object's Bindings/Properties 
window.

49.    Select Group: Group Color (refer to the following figure) from the Bindings window. 
88 Statemate Tutorial



Exercise 12 - Constructing a Panel
Group Bindings

50.    Enter the following for the binding values for the object labeled 'Rear Defog Lite':

� Controlled by: DEFOG_DRIVE_OUT
� Element type: Bit
� Select Add Color and choose Red with a value of 0.
� Select Add Color and choose Black with a value of 1.

51.    Click OK.
Statemate 89



Finishing and Managing the Project
Group Color

52.    Select Create Free Text and enter Rear Defogger. Place it under the Rear Defogger 
object. 

Note
Groups cannot be labeled.

53.    Select File > Save from the PGE and then File > Exit.
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Exercise 13 - System Analysis - Part 1
In this exercise, you will simulate the entire Rear Defog System. A simulation profile is created to 
capture the environment for analysis.

1.    Click Simulation from the main Statemate window.

Simulation Icon

2.    Select File > New Profile from the profile window and enter “REAR_DEFOG_SIM” for 
the profile name that you are creating. Refer to the following figure.
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Simulation Profile

3.    Click Add Selected Chart with Descendents to Profile . This opens a Chart Tree 
View of your current design (refer to the following figure).
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Exercise 13 - System Analysis - Part 1
Chart Tree View

4.    Select the chart named 'REAR_DEFOG_SS' from the Chart Tree view and then click 
OK.

5.    Click Add Selected Panel to Profile  from the Simulation profile window and add the 
panel to the profile that was created in the earlier exercise. Refer to the following figure.
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Add Panel to Profil
e

6.    Select File > Save from the Simulation window.

7.    Click Invoke Simulation Based on the Current Profile  from the simulation window.

Note
The simulation execution (Simulation Execution) window opens, as well as an executable 
model of the panel (Executable Panel). The panel allows you to make inputs and view 
outputs of the system design. 

Simulation Execution
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Executable Panel

8.    Click AutoRun  to start simulating as in real-time mode.

9.    Use the panel to input changes into the system and view the effects on the activity-charts 
and statecharts, and verify that all transitions can be taken.
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Finishing and Managing the Project
Exercise 14 - System Analysis - Part 2
In Exercise 13 - System Analysis - Part 1, you validated the model to ensure it behaved as designed. 
In this exercise, you will simulate the model and verify that the requirements are being met.

1.    Open the simulation profile named 'REAR_DEFOG_SIM'.

2.    Click Add Selected Chart with Descendents to Profile . This opens a Chart Tree 
View of your current design

3.    Select the sequence diagram named 'REAR_DEFOG_LO_SPEED_NO_LOAD' from 
the Chart Tree View and then click OK.

4.    Open the sequence diagram named 'REAR_DEFOG_LO_SPEED_NO_LOAD'.

5.    Select File > Save from the Simulation window.

6.    Click Invoke Simulation Based on the Current Profile .

7.    Click AutoRun  to start simulating as in real-time mode.

8.    Use the panel to input changes into the system and view the effects on the sequence 
diagram to verify that all transitions are taken.
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Exercise 15 - Iterative Design
Exercise 15 - Iterative Design
In the process of system development, all of the requirements may not be available or defined in 
the early stages. Some requirements may not be formalized and only later in the design process 
completely captured.

1.    Open the simulation profile named 'REAR_DEFOG_SIM'. Refer to the following figure.

Simulation Profile: REAR_DEFOG_SIM
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Finishing and Managing the Project
2.    Select Options > Sequence-diagram Generation…from the Simulation Profile window. 
Refer to the following figure.

Sequence-Diagram Generation Settings
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Exercise 15 - Iterative Design
3.    Click Generate Sequence-Diagram from within the Sequence Diagram Generation 
Settings window. Refer to the following figure.

Active Sequence Diagram Generation

4.    Click Input Elements to Record… to select the input elements to record within the 
simulation (refer to the following figure). 

Input Elements to Record
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Finishing and Managing the Project
5.    Click 'Choose...' within the Input Elements to Record window to add elements to record. 
This invokes the Element Selection window for the test settings. Refer to the following 
figure.

Element Selection Window
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Exercise 15 - Iterative Design
6.    Within the element selection window click 'All' under the Type and then select Filter to 
create a list of elements. Refer to the following figure.

Filtered Element List

7.    Select the following three elements within the Element Selection List - 
LOAD_SHED_IN, RDEFOG_SW_STATUS, and VEHICLE_SPEED_IN and then 
click OK.

8.    Click OK within the Input Elements to Record window (refer to the following figure).
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Finishing and Managing the Project
Selected Input Elements

9.    Select Output Elements to Record… to select the output elements to record within the 
simulation (refer to the following figure).

Output Elements to Record
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Exercise 15 - Iterative Design
10.    Using the steps outlined above, add the following two output elements to record - 
DEFOG_DRIVE_OUT and DEFOG_DRIVE_SIG. Refer to the following figure.

Selected Output Elements

11.    Select Lifeline Entities to Record within the activities lifeline section of the Sequence 
Diagram Generation Settings window (refer to the following figure). These lifelines will 
be used within the generated diagram.

Lifeline Entities Window

12.    Click 'Add…' within the Lifelines Entities window to invoke the Lifeline Entities and 
select the items as shown in the following figure. 
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Finishing and Managing the Project
Selected Lifelines

13.    Click OK within the selected Lifeline Entity window.

14.    Click OK within the Lifeline Entities window.

15.    Click OK within the Sequence Diagram Generation Settings window.

16.    Select File > Save from the simulation profile window.

17.    Select Invoke Simulation Based on the Current Profile from the simulation profile 
window.

Note:  The simulation window and an executable model of the panel open. The panel 
allows you to make inputs and view outputs of the system design. 

18.    Click AutoRun  to start simulating as in real-time mode.

19.    Use the panel to input changes into the system. 

20.    Once the simulation is complete and you exit the simulation execution window, you are 
prompted to save the recorded sequence diagram (refer to the following figure). Click 
Yes.
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Exercise 15 - Iterative Design
Save a Sequence Diagram

21.    Enter the name of the recorded Sequence Diagram and click OK. Refer to the following 
figure.

Sequence Diagram Name

22.    Open and review the sequence diagram that was generated from the simulation (refer to 
the following figure). The diagram can be found within the Workarea.
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Finishing and Managing the Project
Generated Sequence Diagram
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Exercise 16 - Project Management
Exercise 16 - Project Management
Now that the project has been designed and validated, a released version of the design may need to 
be produced. This exercise creates a configuration file that captures the charts and files within the 
workarea.

1.    Select Configuration > Create Configuration (refer to the following figure) from the 
main Statemate window.

Create Configuration
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Finishing and Managing the Project
2.    The Create Configuration window opens (refer to the following figure).

Create Configuration Window

3.    Make the following selections within the Create Configuration window.

� Configuration File Name - Rename it or leave default name.
� Files In Workarea - Change the selection to All.
� Check In to Data Bank - All Files in Configuration and New Configuration File 

should be selected.
� File Mode - select All Update.

4.    Click OK.

Note:  These selections check all of the charts and files within the workarea into the 
databank, as well as creating a configuration file and checking it into the 
databank.

5.    Select the DataBank Tab from the main Statemate window.

6.    Select View > View Filter in the DataBank View. The Show Files window opens. 

Note:  This window allows you to select which files to show within the DataBank. 

7.    Select “All Charts” and “All Files” and then select OK.
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Exercise 16 - Project Management
View Filter

Note:  The DataBank lists the files that are within the databank with their current 
status. Refer to the following figure.

DataBank View
Statemate 109



Finishing and Managing the Project
8.    Select Edit > Select All From in the Charts Tab. 

9.    Select Edit > Delete from the Charts.

10.    Select View > Show… from the Databank. Make the same selections as in step 3 and 
click OK. The 'Locked By' field within the Databank should now be empty.

11.    Select the configuration file from the Databank that was created in step 3 and then select 
Configuration > Execute Configuration (refer to the following figure). This checks all 
of the files back into the users’ workarea. Review and check the workarea to ensure all 
files have been checked into the workarea.

Databank Configuration
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