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1 About this manual
Welcome to IBM® Rational® DOORS® 9.2, a powerful tool that helps you to 
capture, track and manage your user requirements.
This book describes how to set up and manage Rational DOORS. It is for 
Rational DOORS Project Managers and Database Managers. It assumes that 
you’ve read Getting Started with Rational DOORS.

Typographical conventions
The following typographical conventions are used in this manual:

Related documentation
The following table describes where to find information in the documentation 
set:

Typeface or 
Symbol

Meaning

Bold Important items, and items that you can select, including 
buttons and menus: “Click Yes to continue”.

Italics Book titles.

Courier Commands, files, and directories; computer output: “Edit your 
.properties file”.

> A menu choice: “Select File > Open”. This means select the 
File menu, and then select the Open option.

For information on See

What’s new in version 9.2 of Rational 
DOORS

The Rational DOORS readme file

How to install Rational DOORS Rational DOORS Installation Guide

How to set up licenses to use Rational 
DOORS

Rational Lifecycle Solutions Licensing 
Guide



About this manual

2    Managing Rational DOORS

These documents are on the Rational Information Center at 
http://publib.boulder.ibm.com/infocenter/rsdp/v1r0m0/index.jsp.

How to use Rational DOORS Getting Started with Rational DOORS
Using Rational DOORS

How to write requirements Get It Right the First Time

How to set up and manage Rational 
DOORS

Managing Rational DOORS

The DXL programming language DXL Reference Manual

How to integrate Rational DOORS with 
other applications

Rational DOORS API manual

For information on See
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2 Planning
This chapter contains the following topics:

• Planning how to organize your data

• Planning connections

• Planning users

• Types of user

• The Administrator user account

• Planning groups

• Controlling how users log in

• Using passwords

• Using system user names

• Dealing with login failures

Note  Take time to plan before you set up your system. The time 
you spend planning saves you time later.

Planning how to organize your data
Think about what hierarchical structure you want for your data. Draw a sketch of 
the structure before you create any projects, folders or modules.
Bear these points in mind:

• Although you can rearrange the structure of your data by using 
drag-and-drop or cut and paste in the Database Explorer, you cannot do that 
when users are accessing the data.

• You use access controls to specify who can see what.

For information about controlling who has access to the database root, see 
“Changing the access rights for the database root,” on page 63.

• To be able to see a module in the Database Explorer, a user must have read 
access from a root node in the left pane of the Database Explorer right 
down to the module itself.

In Database view, the user must have read access from the database root, 
right down to the module itself.
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In Project view, the user must have read access from the project that 
contains the module right down to the module itself. 

• You cannot create modules at the top level of the database, immediately 
below the database root.

At the top level of the database, you can only have folders and projects.

• You can archive modules and projects, but you cannot archive folders.

For information about archive and restore, see “Archiving and restoring 
data,” on page 77.

• When you restore an archived module, you lose all the links to and from the 
restored module, including internal links between objects within the module.

• If you want to be able to archive and restore a project, make sure the project 
does not have any links to other projects.

When you restore a project, links that are entirely contained within the 
restored project are preserved. Other links are lost.

If you have links between projects A and B, you might want to create a 
dummy project that contains A and B. When you archive and restore the 
dummy project, the links between projects A and B are preserved.

• Each project has a unique name in the database.

The location of any data in the project is uniquely identified by a path that 
starts at the project.

• When you use Project view in the Database Explorer, every project is 
displayed at the top-level in the left pane. This means that if you have nested 
projects, any subprojects are displayed in the left pane as top-level projects. 

Make sure users understand that they are seeing multiple views of the same 
data.

• You can partition projects, but you cannot partition folders. 

For information about partitions, see “Managing partitions,” on page 137.

If you want to be able to create a partition that contains modules in different 
projects, again you could consider creating a dummy project that contains 
the two projects.

Users at the away database can see any links that are contained entirely 
within the partition. 
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Planning connections

Planning connections
There are upper limits to the number of client connections you can have to your 
database server. The number varies depending on the operating system you are 
running the Rational DOORS database server on:

If you exceed these upper limits, you run the risk of data corruption.

Setting up your Solaris 10 environment

To take full advantage of the maximum number of concurrent users on Solaris 
10, you must set up your environment to make 65536 file descriptors available to 
the Rational DOORS server. This allows you to have a maximum of 32000 
concurrent users.
To make 65536 file descriptors available, set up extended FILE support on the 
Solaris 10 server. From release 07/2007 onwards, this comes as standard. Turn it 
on by entering the following commands:

% ulimit -n 65536
% export LD_PRELOAD_32=/usr/lib/extendedFILE.so.1
% cd $DOORSHOME/bin
% ./doorsd -port

For users with an earlier version of Solaris 10, you must install the following 
three server patches (all are for the SPARC platform):

• 125100-04 Kernel Update Patch 

• 120473-05 libc nss ldap PAM zfs Patch 

• 125800-01 Fault Manager Patch 

Operating system Maximum number of connections

Windows 1024

Solaris 9 128

Solaris 10 32000

Linux 900

HP-UX 360
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Planning users
You can use the IBM® Rational® Directory Server (RDS) to manage users. For 
more information, see “Configuring RDS,” on page 45.
Generally, it is good practise to set up a separate user account for each user of 
your Rational DOORS database. Do not let different people share the same user 
name, or you will lose traceability—you will not know who made what changes 
to your data.
An exception to this rule is if you want to set up a general purpose guest account 
for visitors and other people who need short-term, read-only access to your data.

Note  If someone needs to modify data, create an account for 
them, even if they only need it for a few days.

Naming conventions

Take time to plan what conventions you want to use for user names. Although 
you can change a user name at any time, Rational DOORS does not record this 
information in the database history. For example, if you change a user name 
from John to John Smith, you cannot tell from the database history whether 
John Smith is a brand new user or an existing user whose user name has 
changed.
When planning user names, bear these points in mind:

• Each user name must be unique. 

No two users can have the same user name. And user names and group 
names must be different; you cannot have a user and a group with the same 
name.

• User names can contain alphanumeric characters (letters of the alphabet and 
numbers), space characters, and punctuation characters.

• User names are case-sensitive. The names John Smith and John SMITH 
are different.

• Use the person’s real name as their user name, for example, John Smith or 
John J. Smith, or Smith J J or Smith, John (UK Sales).

• Use clear and unambiguous user names, like John Smith, not JS or John. 
When users are setting up access rights, they see a list of user names. Clear 
and unambiguous user names ensure that your users do not accidentally 
assign access rights to the wrong person. 
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Types of user

Also, Rational DOORS uses the user name in its history of changes to the 
database. Clear and unambiguous user names help you to see who has been 
doing what by looking at the database history.

• All Rational DOORS screens that list user names list them in alphabetical 
order. Think about whether you want to see all the Johns together in the list, 
or all the Smiths. Would you prefer John J Smith or Smith John J?

• Bear in mind that the user has to remember their user name and type it when 
they log in to Rational DOORS, unless you are using system user names (see 
“Using system user names,” on page 11).

Types of user
Before you create a user account, decide what type you want the user to be. The 
type of a user controls what operations they can perform, for example, whether 
they can create projects or archive data.
The following table shows the types you can choose from:

This type of user Can do this

Standard user Work with Rational DOORS data.

Project Manager Everything a Standard user can do, plus management 
tasks normally associated with managing projects:

• Partitioning data

• Archiving data

• Creating and managing groups

Database Manager Everything a Project Manager can do, plus:

• Creating projects

• Creating and managing users

• Managing the database
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Note  You can change a user’s type at any time.

In addition to user types, you can use access rights to control what users can do. 
For example, a user who has the power to create projects can only create a 
project in a folder or project that they have create access to. 
The ability to delete and purge projects is controlled entirely through access 
rights, as is the ability to create, delete and purge folders and modules.

The Administrator user account
Each Rational DOORS database has one user who can do anything—their user 
name is Administrator, and their user type is Database Manager.
The Administrator account bypasses all access rights checks.
You should only use the Administrator account in emergencies, for example, if 
no other users can log in, or if other users cannot access part of your database.
Because the Administrator account bypasses all access rights checks:

• Be careful who has access to the Administrator account.

• Choose a good password for it, not one that someone else can easily guess.

• Change the password regularly.

• Take care not to lose the password.

You can only change the Administrator’s password when you are logged on 
as the Administrator. If you lose the Administrator’s password, you must 
contact Rational DOORS customer support, who will talk you through a 
recovery procedure.

Custom user Everything a Standard user can do, plus any of the 
following as defined for that user:

• Creating projects

• Partitioning data

• Archiving data

• Creating and managing groups

• Creating and managing users

• Managing the database

This type of user Can do this
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Planning groups

The screens that list user names do not show the Administrator user, because it 
is a special user account, and you should not use it like a normal user account.
To change the user options for the Administrator, for example, the minimum 
password length:

1. Log in to Rational DOORS as the Administrator user.

2. Click Tools, and then the Options tab to change your user options. 

You cannot use Tools > Manage Users because the Administrator user is 
not included in the list of users.

Planning groups
This topic looks at things you should think about before you create any groups. 
For information about how to create groups, see “Creating a group,” on page 38. 
You use RDS to manage users and groups. For more information, see 
“Configuring RDS,” on page 45.
For information on groups and access rights, see Getting Started with DOORS.
Setting up access rights for individual users can be very time-consuming. Use 
groups to save time when you set up access rights for your data.
Remember that each user can be in several groups. There’s no limit to the 
number of groups you can have, or the number of groups that each user can be 
in.

Naming conventions
When planning group names, bear these points in mind:

• Each group must have a unique name.

No two groups can have the same name, and group names and user names 
must be different. You cannot have a group and a user with the same name.

• Group names can contain alphanumeric characters (letters of the alphabet 
and numbers), space characters, and punctuation characters.

• Group names are case-sensitive. The names Test Boston and TEST 
Boston are different.

• Avoid generic names like Test and Engineering if there’s any possibility 
that you might need more than one test or engineering group in the future.

• Use clear and unambiguous names, like Boston Test and Boston 
Engineering. When users are setting up access rights, they see a list of 
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group names. Clear and unambiguous names ensure that your users do not 
accidentally assign access rights to the wrong group.

• All Rational DOORS screens that list group names list them in alphabetical 
order. Think about whether you want to see all the Boston groups together 
in the list, or all the test groups. Would you prefer Boston Test or Test 
Boston?

Controlling how users log in
By default, your Rational DOORS database is configured so that all users see the 
Rational DOORS login screen when they start Rational DOORS. 
By default, you have to type your Rational DOORS user name and password to 
log in to Rational DOORS.
Database Managers can change the default behavior. They can control:

• Whether users have to type a password (see “Using passwords,” on page 10)

• Whether users always have to type their Rational DOORS user name (see 
“Using system user names,” on page 11)

For instructions on how to change the default behavior, see “Changing the login 
policy,” on page 53.

Using passwords
By default, your Rational DOORS database is configured to use passwords. This 
means that when someone tries to start Rational DOORS, they see the Rational 
DOORS login screen and have to type their password.
You can control the minimum password length:

• You can specify the minimum password length for the database.

By default, it is 6 characters, which means that every user must have a 
password that is at least 6 characters long.

• You can also specify a minimum password length for each user. 

For example, you might have a minimum length of 6 characters for the 
database and 14 characters for John Smith. Whenever John Smith changes 
his password, he must choose a password that is 14 characters or longer.

Note  A user with the powers to change another user’s 
password can specify a new password that is shorter than 
the minimum password length.
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Using system user names

If you do not want users to type in a password to log in to Rational DOORS, 
you can configure your database not to use passwords.

Using system user names
One of the pieces of information you can store in a user’s account record is their 
system user name. This is the user name they use to log in to their computer, 
for example, their Windows® user name.

Caution  For security reasons, you should use passwords along with 
system user names.

If you enable system user names, a user might not need to type in their Rational 
DOORS user name. Instead, Rational DOORS might be able to work out who 
they are from their system user name.
When system user names are enabled, if you are the only Rational DOORS user 
with a particular system user name:

• You do not need to type your Rational DOORS user name.

• If your database is not using passwords, you will not see the Rational 
DOORS login screen. When you start Rational DOORS, you go straight to 
the Database Explorer.

When system user names aren't unique
If there’s any possibility that your users might not have unique system user 
names, make sure that you either disable system user names, or enable system 
user names and use passwords.
All system user names are unique within a single Windows 2003 domain.
Warning: Your system user names might not be unique if:

• Your users are in two or more Windows 2003 domains

• You have both UNIX® users and Windows users
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Do you need to type your Rational DOORS user name?

Let’s look at what can happen if you enable system user names and your users do 
not have unique system user names.
Judy Brown is using Windows XP. Her system user name is Judy, and this is 
recorded in her Rational DOORS user account record. No other Rational 
DOORS user has the same system user name, so when she starts Rational 
DOORS, she does not have to type her Rational DOORS user name.
Now imagine you create an account for Judy Smith, who is using Windows 2003, 
and whose system user name is also Judy. You enter her system user name in her 
account record. 
From now on, when either Judy Brown or Judy Smith start Rational DOORS, 
they have to type their Rational DOORS user name on the Rational DOORS 
login screen, because there are now two users with the system user name Judy 
and Rational DOORS cannot tell which is which.
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Dealing with login failures

But what if you forgot to enter Judy Smith’s system user name in her account 
record? A warning message is displayed when you create her account, but what if 
you ignore it? In this case, when Judy Smith starts Rational DOORS, Rational 
DOORS sees that her system user name is Judy, and assumes that she is Judy 
Brown:

• If the Rational DOORS database is not using passwords, Judy Smith does 
not even see the Rational DOORS login screen and is logged straight into 
Rational DOORS as Judy Brown.

• If the database is using passwords, Judy Smith has to type a password. What 
she types does not match what Rational DOORS is expecting (it is expecting 
Judy Brown’s password). So Judy Smith cannot log in to Rational DOORS.

She contacts her Database Manager, who can fix the problem by either 
disabling system user names or entering her system user name in her account 
record.

If there’s any possibility that your users might not have unique system user 
names, and you want to enable system user names:

• Make sure your Rational DOORS database uses passwords. 

• Make sure that every Rational DOORS user’s account record has its System 
Username field filled in.

• If warning messages are displayed telling you that a user account record does 
not have its System Username field filled in, do not ignore these messages.

Dealing with login failures
Database Managers can control:

• How many times users can make typing mistakes when they try to log in to 
Rational DOORS.

• Whether the Rational DOORS database server sends an e-mail whenever 
there is a failed login attempt.
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Two limits control when an attempted login is rejected. For instructions on how 
to change these limits, see “Changing the login policy,” on page 53. 

Limit Description

Maximum attempts per 
session

This is the maximum number of times that someone can 
try to log in with any user name.
For example, if you set this value to 4, users are allowed 
four attempts to log in before the Rational DOORS login 
screen is closed.
The number must be in the range 0 to 10. 0 means there is 
no limit. The default value is 4.
Note If you have session timeouts configured, and a user 

session times out, only an Administrator can log in 
to unlock the session if the maximum attempts per 
session is reached. See “Reconfirm password 
session timeouts,” on page 57 for more 
information.

Maximum attempts per 
user name

This is the maximum number of consecutive times that 
users can try to log in with their own user name.
This is to ensure that if a hacker has stumbled on a valid 
user name, they cannot keep bypassing the other limit by 
trying to log in from different computers.
For example, if you set this value to 3, users are allowed 
three attempts to get their password right before their 
account is disabled.
The number must be in the range 0 to 20. 0 means there is 
no limit. The default value is 20.
For each user name, Rational DOORS keeps track of the 
number of failed passwords submitted since the last 
successful login.
Note If you have session timeouts configured, and a user 

session times out, only an Administrator can log in 
to unlock the session if the maximum attempts per 
user name is reached. See “Reconfirm password 
session timeouts,” on page 57 for more 
information.
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Dealing with login failures

If you are using a Rational DOORS database server, the server can send an 
e-mail to one or more Rational DOORS users whenever there’s a login failure. 
For more information, see “Changing the login policy,” on page 53.
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3 Locales and unicode options
• Locales

• How date and time are recorded

• Supported locales and formats

• Updating user options for locales

• Changing the locale for textual attributes

• Legacy data handling

• Display schemes

Locales
The locale of your computer is your local language and the geographical location 
of your computer. For example, the locales French (France) and French (Canada) 
are distinct. Your locale determines how certain elements are displayed on your 
computer, for example the date format used by programmes on your computer 
is derived from your locale.
Rational DOORS derives its default locale from the locale of your computer, and 
the display of formatted data is updated whenever the User Locale setting is 
changed on your computer. However, you can override the locale to which 
Rational DOORS defaults by changing settings within Rational DOORS. These 
settings are saved on a per locale basis, so that each time you change your locale, 
your user options are updated to match your previous settings for that locale.
For further information about language settings, please refer to the user 
documentation associated with your operating system.

How date and time are recorded
Rational DOORS date values between 1970 and 2036 are stored in the Rational 
DOORS database in terms of Universal Coordinated Time (UTC). UTC was 
developed as the international time standard. It is similar to Greenwich Mean 
Time (GMT) except that it observes no daylight saving time (DST) and is based 
on a 24-hour clock. Zero (0) hours UTC is midnight GMT. The local 24-hour 
time convention is converted to UTC by adding or subtracting hours based on 
your location with respect to the prime meridian as well as local daylight saving 
time considerations.
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If you are in one time zone and edit data, the timestamp for the edit is displayed 
at different local times on each Rational DOORS client but is stored at the same 
absolute time in UTC on the database server.
For example, a user in the Atlantic Time zone in Canada signs a baseline at 11:00 
local time. A user in the Pacific Time zone then views the signature. The time 
that the user in the Pacific Time zone sees for the signature is 7:00. The signature 
time is stored on the server in UTC (15:00).
The time that is recorded is the time on the database server, not the time on the 
client, and is stored in UTC regardless of the time zone of the client or the 
server.
In pre-8.0 versions of Rational DOORS, date attribute values did not include the 
information to make time zone adjustments, so date attribute values in migrated 
data might not display as expected. For example, if clients in multiple time zones 
were working on data, suspect links might not operate as you would expect.
When migrated data is opened and saved in 9.2, migrated date and time values 
are given a UTC timestamp. These timestamps assume that the migrated data 
was created in the saving client’s time zone. Subsequently, migrated data that has 
been saved in Rational DOORS 9.2 will work in the same way as data that 
originates in Rational DOORS 9.2.

Supported locales and formats
We support the following locales and formats:

• All data formats, except those that use a column format (for example, some 
Japanese) and those where the text flows from right to left (for example, 
Hebrew).

• Arabic number format only.

• Gregorian calendars only.

• Any Windows locale

• Double Byte Character System (DBCS) operating systems are not supported 
on UNIX or Linux®

For further information about Unicode, refer to http://www.unicode.org.
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Updating user options for locales

Updating user options for locales
You can use the Options dialog box (click Tools > Options from the Database 
Explorer), to change the display of the elements described in the following table:

Changing the locale for textual attributes
When you create a text, string or enumerated attribute value, you can select the 
locale for the attribute. The default locale is the current locale of the user 
creating the attribute. 
The font and line spacing used when entering and displaying textual attributes is 
derived from the locale setting for the attribute. Any user with Modify access to 
the attribute definition can change the locale setting.

Legacy data handling
Data from previous versions of Rational DOORS might not have a locale 
property, so you can set a Legacy Data Locale, which will be the default locale for 
any legacy data that does not have a locale property. The Legacy Data Locale can 
be set by Database Managers in the Database Properties. 

Locale setting Description

Line spacing This applies to textual attributes and text elements in dialog 
boxes that are defined using DXL.
The default line spacing for locales in the Korean, Simplified 
Chinese and Traditional Chinese language groups is 1.5.
The default for all other locales is single.

Text font The default font for your database depends on the default 
display scheme for the database. For more information about 
the display schemes used by Rational DOORS, see “Display 
schemes,” on page 20.
You can select any of the fonts that are available on your client 
computer to be the default font for your locale.

Date display and 
input format

The default date format used by Rational DOORS is derived 
from the short date and time format used by Windows in your 
current locale.
You can select from any of the date and time input formats 
and display formats that are available in your current locale.
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Legacy textual attributes that do not have a locale property inherit their locale 
property from the Legacy Data Locale. If the Legacy Data Locale has not been 
set, the locale is derived from the current client session.
Legacy module names and descriptions, and user and group information that 
include, for example, accented characters must be interpreted according to a 
code page to be displayed correctly. 

• Data that has been saved by Rational DOORS 6.0a is interpreted as UTF-8 
Unicode data.

• Data that has been saved by other previous versions of Rational DOORS is 
interpreted using the default code page for the Legacy Data Locale. If the 
Legacy Data Locale has not been set, the Latin-1 code page is used.

Display schemes
Rational DOORS is supplied with a number of standard display schemes:

• modern

• classic

• international modern

• international classic

• high contrast #1

• high contrast #2

• high contrast black

• high contrast white

The default display scheme depends on the origin of your database, and is 
explained in the following table:

Database origin Default display scheme

New database created 
after Rational DOORS 
8.0

International modern.

Database migrated 
from Rational DOORS 
7.x

The same as it was before the database was migrated, so 
either modern or classic.
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Display schemes

Database migrated 
from Rational DOORS 
6.0a

If the 6.0a database display scheme was modern, the 
migrated database display scheme is international modern.
If the 6.0a database display scheme was classic, the 
migrated database display scheme is international classic.

Database origin Default display scheme
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4 Managing users and groups
This chapter is for Database Managers, Project Managers and users who have the 
power to change the access rights of users or groups. It contains the following 
topics:

• Options for managing users and groups

• Showing information about users

• Creating a user

• Editing a user

• Editing a user when using RDS

• Deleting a user

• Disabling and enabling users

• Showing information about groups

• Creating a group

• Editing a group

• Access controls on groups

• Deleting a group

• Disabling and enabling a group

Options for managing users and groups
The information about Rational DOORS users and groups can be managed 
locally or using the Rational Directory Server (RDS).
If you are using RDS, you can only manage a limited amount of information 
about users and groups using the Manage Users menu option.
For information about setting up RDS to manage Rational DOORS users and 
groups, see “Configuring RDS,” on page 45.

Showing information about users
To show information about users:
1. Log in to Rational DOORS as a Project Manager, a Database Manager, or a 

Custom user who has the power to create users.
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2. In the Database Explorer, click Tools > Manage Users.
3. Select the Users tab.

The list of users is displayed.

A disabled user account looks like this: .

A user account that requires additional authentication when logging in looks 
like this: .

If RDS is being used to manage users, you need to enter a filter and click 
Refresh to see a list of users. To display a list of all users, use an asterisk (*) 
as the filter. 

Creating a user
Note  You cannot create a user in Rational DOORS if the 

information about Rational DOORS users and groups is 
being managed using RDS.

To create a user:
1. Log in to Rational DOORS as a Database Manager or a Custom user who 

has the power to create users.

2. In the Database Explorer, click Tools > Manage Users.
3. On the Users tab, either click New to set up the new user from scratch, or 

select the user you want to copy then click Copy.

Note  Copying an existing user saves time because you do not 
have to type in so much information. And you do not 
have to set up the group membership information from 
scratch. The new user starts off in the same groups as 
the existing user.

4. Use the General tab to specify the user name and type for the new user:

a. Enter the new user’s user name.

This must not be the same as any existing user name or group name.

For more information, and advice on what conventions to use, see 
“Planning users,” on page 6.

b. Select Disable User if you do not want the new user to be able to log in 
yet, for example, if you want to set up access rights for them before they 
can log in. For more information, see “Disabling and enabling users,” on 
page 37.
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Creating a user

c. Select the new user’s type: Standard, Project Manager, Database 
Manager, or Custom user.

If you select Custom user, use the check boxes to specify which powers 
you want the new user to have:

Select... If you want the user to be able to...

Create projects Create projects.

Archive data Create Rational DOORS archives.

Partition data Create and manage partitions.

Create groups Create and manage groups.

Create users Create and manage users.
Note A user must have both Create users powers 

and Manage database powers to allow or deny 
Manage database powers to any user, 
including themselves.

Manage database See and edit the database properties sheet. The user 
can:

• Change the name and default display scheme for 
the database.

• Configure the database login policy.

• Configure the SMTP mail server that the database 
uses. 

• See the access rights for the database root, which 
control who can see the Database view in the 
Database Explorer. 

• Manage locks.

• Delete baselines.

• Allow or deny Manage database powers to 
themselves and other users.

Note A user must have both Create users powers 
and Manage database powers to allow or deny 
Manage database powers to any user, 
including themselves.
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d. The Edit DXL option is only displayed if the Rational DOORS 
Administrator has selected the Only users with Edit DXL power may 
edit and run DXL check box in the Database Properties.

Select this option to allow the user to edit and run DXL in the DXL 
Interaction window (Tools > Edit DXL), and from the DXL Library. 

If this option is not selected, the Run and Edit buttons on these 
windows are unavailable. The user can still create DXL attributes and 
run layout DXL.

5. Use the Security tab to specify the password for the new user. 

The following table describes the Security tab on the New User window:

Security tab Description

Change Password Specify the new user’s initial password. 
You do not have to provide an initial password. The user 
is asked to change their password when they log in for the 
first time, regardless of whether you have set a password 
for them or not, and regardless of what has been set in the 
Expires after box. 
If you set a password, you must give this to the user, as 
they will not be able to log in to Rational DOORS 
without it. If you do not set a password, the user should 
leave the Password box empty on the Rational DOORS 
Login screen, and then on the Change Password screen 
they should leave the Old password box blank.

User might change 
password

Select this box if you want the new user to be able to 
change their password. If you clear this box, and their 
password expires, they must ask a Database Manager (or a 
Custom user who has the power to create users) to change 
their password.
Note Ensure that the new user has logged on to Rational 

DOORS at least once before you clear this box. If 
you clear it before the user has logged on for the 
first time, they will be unable to log in.
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Creating a user

6. Use the Details tab to specify details such as the user’s e-mail address.

The following table describes the Details tab on the New User window:

Minimum password 
length

This is used to determine the minimum number of 
characters the user must type when they change their 
password.
If it is less than the minimum password length for the 
database, the database value is used instead of the value in 
this box. For information about the database value, see 
“Changing the login policy,” on page 53.

Expires after This is how long the user’s passwords last before they 
expire. It is measured in days, starting from when the 
password was last changed (see the Last changed box). 
Once the user’s password has expired, the next time they 
log in, they will be asked to change their password.
By default, the value is 0 days, which means that once the 
user has logged on for the first time, they are never asked 
to change their password again.
Note The first time a user logs into Rational DOORS, 

they are asked to change their password, even if the 
value is set to 0 days.

Last changed When the user’s password last changed. This value is 
Never, because the user does not exist yet.

May use the 
password 
command line 
switch

The database can be set up to allow or not allow the use 
of the -password or -P password command line switch. 
If you want the user’s login policy to match the database 
default, leave this check box cleared. If you want the user 
to be able to use the password command line switch 
regardless of the database setting, select this check box.

Details tab Description

Full Name The new user’s full name. The full name does not have to 
be unique, and can be left blank. The user’s Full Name is 
displayed as part of their electronic signature.

Security tab Description
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Use the Groups tab to specify which groups you want the new user to be in.

If you want to add the user to a group, select the group in the Not a 
member of list and click the left arrow to move it into the Member of list. 
If you want to remove the user from a group, select the group in the 
Member of list and click the right arrow to move it into the Not a member 
of list. Use the SHIFT or CTRL keys to select multiple groups.

Note  If you click anywhere in a list and then start typing, the 
highlight moves to the name you type. For example, if 
you type test, the first group whose name starts with test 
is highlighted. 

7. Click OK.

8. Click OK to close the Manage Users window. The new user account is 
created.

Email The new user’s e-mail address.

System username The user name the user logs into their computer with, for 
example, their Windows 2003 user name. For more 
information about system user names, see “Controlling 
how users log in,” on page 10.
Note Leave this field blank for Database Managers. Your 

system is more secure if you always force Database 
Managers to type in their Rational DOORS user 
names.

Telephone The new user’s telephone number.

Location The new user’s location.

Additional 
information

Additional information about the new user.

E-mail updates to 
change proposals

If the new user is going to use the Change Proposal 
System to submit proposals, select this box if you want 
them to be notified by e-mail when the status of their 
proposals changes, for example, when one of their 
proposals is accepted or rejected, or when their proposals 
are added to or removed from a group.

Details tab Description
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Editing a user

Editing a user
Note  If the information about Rational DOORS users and groups 

is being managed using RDS, see “Editing a user when using 
RDS,” on page 33.

To edit a user:
1. Log in to Rational DOORS as a Database Manager or a Custom user who 

has the power to create users.

2. In the Database Explorer, click Tools > Manage Users.
3. On the Users tab, select the user you want to edit, and then click Edit.
4. Use the General tab to edit the user name and type for the user:

a. Change the user’s Rational DOORS user name.

This must not be the same as any other user name or group name.

For more information, and advice on what conventions to use, see 
“Planning users,” on page 6.

b. Change the user’s type: Standard, Project Manager, Database Manager, 
or Custom user.

If you select Custom user, use the check boxes to specify which powers 
you want the user to have:

Select... If you want the user to be able to...

Create projects Create projects.

Archive data Create Rational DOORS archives.

Partition data Create and manage partitions.

Create groups Create and manage groups.
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c. The Edit DXL option is only displayed if the Rational DOORS 
Administrator has selected the Only users with Edit DXL power may 
edit and run DXL check box in the Database Properties.

Select this option to allow the user to edit and run DXL in the DXL 
Interaction window (Tools > Edit DXL), and from the DXL Library. 

Create users Create and manage users.
A user who has Create users powers, but does not 
have Manage database powers cannot allow or deny 
Manage database powers to any user, including 
themselves.
Note A user must have both Create users powers 

and Manage database powers to allow or deny 
Manage database powers to any user, 
including themselves.

Manage database See and edit the database properties sheet. The user 
can:

• Change the name and default display scheme for 
the database.

• Configure the database login policy.

• Configure the SMTP mail server that the database 
uses. 

• See the access rights for the database root, which 
control who can see the Database view in the 
Database Explorer.

• Manage locks.

• Delete baselines.

• Allow or deny Manage database powers to 
themselves and other users.

Note A user must have both Create users powers 
and Manage database powers to allow or deny 
Manage database powers to any user, 
including themselves.

Select... If you want the user to be able to...



Managing Rational DOORS           31

Editing a user

If this option is not selected, the Run and Edit buttons on these 
windows are unavailable. The user can still create DXL attributes and 
run layout DXL.

5. Use the Security tab to change the password or security settings for the 
user.

The following table describes the Security tab on the Edit User window:

Security tab Description

Change Password To change the user’s password:
a. Click Change Password.

b. Type the password in the New password box, and 
then type it again in the Confirm new password 
box. 

c. Click OK.

User may change 
password

Clear this box if you do not want the user to be able to 
change their password. If their password expires, they 
must ask a Database Manager (or a Custom user who has 
the power to create users) to change their password.

Minimum password 
length

This is used to determine the minimum number of 
characters the user must type when they change their 
password.
If it is less than the minimum password length for the 
database, the database value is used instead of the value in 
this box. For information about the database value, see 
“Changing the login policy,” on page 53.

Expires after This is how long the user’s password lasts before it 
expires. It is measured in days. Once the user’s password 
has expired, the next time they log in, they will be asked to 
change their password.
If the value is 0, the user’s password never expires.

Last changed When the user’s password last changed.
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6. Use the Details tab to change the user’s details.

The following table describes the Details tab on the Edit User window:

May use the 
password 
command line 
switch

The database can be set up to allow or not allow the use 
of the -password or -P password command line switch. 
If you want the user’s login policy to match the database 
default, leave this check box cleared. If you want the user 
to be able to use the password command line switch 
regardless of the database setting, select this check box.

Details tab Description

Full Name The new user’s full name. The full name does not have to 
be unique, and can be left blank. The user’s Full Name is 
displayed as part of their electronic signature.

E-mail address The user’s e-mail address.

System username The user name the user logs into their computer with, for 
example, their Windows 2003 user name. For more 
information about system user names, see “Controlling 
how users log in,” on page 10.
Note Leave this field blank for Database Managers. Your 

system is more secure if you always force Database 
Managers to type in their Rational DOORS user 
names.

Telephone The user’s telephone number.

Location The user’s location.

Additional 
information

Additional information about the user.

E-mail updates to 
change proposals

If the user uses the Change Proposal System to submit 
proposals, select this box if you want them to be notified 
by e-mail when the status of their proposals changes, for 
example, when one of their proposals is accepted or 
rejected.

Security tab Description
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Editing a user when using RDS

7. Use the Groups tab to change which groups the user is in.

If you want to add the user to a group, select the group in the Not a 
member of list and click the left arrow to move it into the Member of list. 
If you want to remove the user from a group, select the group in the 
Member of list and click the right arrow to move it into the Not a member 
of list. Use the SHIFT or CTRL keys to select multiple groups.

Note  If you click anywhere in a list and then start typing, the 
highlight moves to the name you type. For example, if 
you type test, the first group whose name starts with test 
is highlighted.

8. Click OK.

9. Click OK to close the Manage Users window. The user account is updated. 

Note  Other users might not see the changes you made until 
the next time they start Rational DOORS.

Editing a user when using RDS
If the information about Rational DOORS users and groups is being managed 
using RDS, you can only edit the following in Rational DOORS:

• The user type (on the General tab)

• Whether a user can edit and run DXL (on the General tab)

• If the user uses the Change Proposal System to submit proposals, whether 
they are notified by e-mail when the status of their proposals changes (on 
the Details tab)

The Security and Groups tabs are read-only.
To edit a user when using RDS:
1. Log in to Rational DOORS as a Database Manager or a Custom user who 

has the power to create users.

2. In the Database Explorer, click Tools > Manage Users.
3. On the Users tab, select the user you want to edit, and then click Edit.
4. Use the General tab to change the user type of the user:

a. Change the user type: Standard, Project Manager, Database Manager, or 
Custom user.
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If you select Custom user, use the check boxes to specify which powers 
you want the user to have:

Select... If you want the user to be able to...

Create projects Create projects.

Archive data Create Rational DOORS archives.

Partition data Create and manage partitions.

Create groups Create and manage groups.

Create users Create and manage users.
A user who has Create users powers, but does not 
have Manage database powers cannot allow or deny 
Manage database powers to any user, including 
themselves.
Note A user must have both Create users powers 

and Manage database powers to allow or deny 
Manage database powers to any user, 
including themselves.
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b. The Edit DXL option is only displayed if the Rational DOORS 
Administrator has selected the Only users with Edit DXL power may 
edit and run DXL check box in the Database Properties.

Select this option to allow the user to edit and run DXL in the DXL 
Interaction window (Tools > Edit DXL), and from the DXL Library. 

If this option is not selected, the Run and Edit buttons on these 
windows are unavailable. The user can still create DXL attributes and 
run layout DXL.

5. Select the Details tab.

On this tab you can only select or clear the E-mail updates to change 
proposals check box.

If the user uses the Change Proposal System to submit proposals, select this 
box if you want them to be notified by e-mail when the status of their 
proposals changes, for example, when one of their proposals is accepted or 
rejected.

Manage database See and edit the database properties sheet. The user 
can:

• Change the name and default display scheme for 
the database.

• Configure the database login policy.

• Configure the SMTP mail server that the database 
uses. 

• See the access rights for the database root, which 
control who can see the Database view in the 
Database Explorer. 

• Manage locks.

• Delete baselines.

• Allow or deny Manage database powers to 
themselves and other users.

Note A user must have both Create users powers 
and Manage database powers to allow or deny 
Manage database powers to any user, 
including themselves.

Select... If you want the user to be able to...
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6. Click OK.

7. Click OK to close the Manage Users window. The user account is updated.

Note  Other users might not see the changes you made until 
the next time they start Rational DOORS.

Deleting a user
Note  You cannot delete a user in Rational DOORS if the 

information about Rational DOORS users and groups is 
being managed using RDS.

If you want to temporarily stop a user logging on, disable their account (see 
“Disabling and enabling users,” on page 37). If the person has left the company 
and you are sure you no longer want their account, go ahead and delete it.

Note  You cannot undelete a deleted user.

To delete a user:
1. Log in to Rational DOORS as a Database Manager or a Custom user who 

has the power to create users.

2. In the Database Explorer, click Tools > Manage Users.
3. On the Users tab, select the user you want to delete, and then click Delete.

4. A message is displayed asking if you really want to delete the user. Click Yes.

5. Click OK.

6. Click OK to close the Manage Users window.

The selected user account is deleted. The user is removed from all the groups 
they were in and their access rights entries are deleted. To preserve traceability, 
the history of actions performed by the user is not deleted from the module 
history.
If the user is currently logged on to Rational DOORS, they can continue 
working, but once they exit Rational DOORS they will not be able to log in to 
Rational DOORS again. 
If you subsequently create a user account with the same user name as the one 
you have just deleted, the new user is treated as a brand new user. The new user 
cannot access the deleted user’s data.

Note  Other users currently logged on to Rational DOORS might 
see the deleted user when they look at access rights screens. 
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They might not see the changes you made until the next time 
they log in to Rational DOORS.

Disabling and enabling users
You might want to stop a user from logging on because you want to edit their 
account or their access rights, and you do not want them to be able to log in 
again until you have finished making the changes.
Or you might want to a stop a user logging on because you think a hacker is 
trying to break into your system using their user name.
You can disable a single user or all users. Disabling all users stops all users except 
Database Managers from logging on.

Note  Rational DOORS can automatically disable a user account if 
someone tries to log in using the right user name but the 
wrong password. For more information, see “Dealing with 
login failures,” on page 13.

Disabling and enabling a single user

To disable or enable a particular user:
1. Log in to Rational DOORS as a Database Manager or a Custom user who 

has the power to create users.

2. In the Database Explorer, click Tools > Manage Users.
3. On the Users tab, select the user, and then click Edit.
4. To disable the user, select the Disable user box. To enable them, clear the 

box.

5. Click OK.

6. Click OK to close the Manage Users window.

When you disable a user, it takes effect the next time they try to log in. If they are 
logged on now, they do not get thrown out.

Disabling and enabling all users
When you disable all users, only Database Managers can log in to Rational 
DOORS.
To disable or enable all users:
1. Log in to Rational DOORS as a Database Manager or a Custom user who 

has the power to manage the database.
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2. In the Database Explorer, make sure the Database view is selected.

If necessary, click View > Database View.

3. In the left pane, click Database , and then right-click Properties.
4. Click the Login Policy tab.

5. To disable all users, select the Disable user logins box. To enable them, 
clear the box.

6. Click OK.

Showing information about groups
To show information about groups:
1. Log in to Rational DOORS as a Project Manager, a Database Manager, or a 

Custom user who has the power to create groups.

2. In the Database Explorer, click Tools > Manage Users.
3. Select the Group tab.

To help with performance, the list of groups is not displayed automatically.

4. Enter a filter and click Refresh.

A list of groups that fulfil the filter criteria is displayed. If you want to display 
a list of all groups, use an asterisk (*) as the filter.

A disabled group looks like this: .

Creating a group
Note  You cannot create a group in Rational DOORS if the 

information about Rational DOORS users and groups is 
being managed using RDS.

Groups let you quickly set up access rights for multiple users. You can create a 
group that consists of any number of users. When you want to set up the access 
to some data (for example to a project or module), you can assign access rights to 
the group in a single operation, instead of assigning access rights to each user, 
one by one.
To create a group:
1. Log in to Rational DOORS as a Project Manager, a Database Manager, or a 

Custom user who has the power to create groups.

2. In the Database Explorer, click Tools > Manage Users.
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3. Click the Groups tab.

4. Either click New to set up the new group from scratch, or select the group 
you want to copy then click Copy.

Note  Copying an existing group saves time because you do not 
have to set up the group membership information from 
scratch. The new group starts off with the same 
members as the existing group.

5. In the Group name box, type the name of the new group.

The new group cannot have the same name as any existing group or user. 
For advice on what conventions to use for group names, see “Planning 
groups,” on page 9.

6. Use the arrow buttons to select the users you want to include in the new 
group.

Note  Use the SHIFT or CTRL keys to select multiple users. 
If you click anywhere in any list of user names and then 
type, the highlight moves to the name you type. For 
example, if you type john, the first user name that starts 
with john is highlighted.

• The Members box lists all the users in the group.
• The Non-members box lists all the users who are not in the group.
• To move users from one box to the other, select the users, and then click 

the arrow buttons.

7. Click OK.

8. Click OK to close the Manage Users window. The new group is created.

Editing a group
Note  You cannot edit a group in Rational DOORS if the 

information about Rational DOORS users and groups is 
being managed using RDS.

To edit a group:
1. Log in to Rational DOORS as a Project Manager, a Database Manager, or a 

Custom user who has the power to create groups.

2. In the Database Explorer, click Tools > Manage Users.
3. Click the Groups tab.
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4. Select the group you want to edit, and then click Edit.
5. If you want to disable the group, check the Disable group box. For more 

information, see “Disabling and enabling a group,” on page 43.

6. To change the name of the group, type the new name in the Group name 
box.

The group cannot have the same name as any existing group or user. For 
advice on what conventions to use for group names, see “Planning groups,” 
on page 9.

7. Use the arrow buttons to add users to or remove users from the group.

Note  Use the SHIFT or CTRL keys to select multiple users. 
If you click anywhere in any list of user names and then 
type, the highlight moves to the name you type. For 
example, if you type john, the first user name that starts 
with john is highlighted.

• The Members box lists all the users in the group.
• The Non-members box lists all the users who are not in the group.
• To move users from one box to the other, select the users, and then click 

the arrow buttons.

8. Click OK.

9. Click OK to close the Manage Users window. The group is updated with 
your changes.

Note  Other users might not see the changes you made until 
the next time they start Rational DOORS.

Access controls on groups
Note  You cannot configure access controls on a group in Rational 

DOORS if the information about Rational DOORS users 
and groups is being managed using RDS.

Access controls regulate exactly who can read or alter the contents of individual 
projects, modules or attributes. Rational DOORS allows you to specify which 
users have access to read and modify information about groups and their 
members. 
By setting a user to have no access to a group, you prevent that user from being 
aware of the group’s existence. They can still be a member of the group and gain 
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the rights that come with that membership but they will never know that the 
group exists.
To use access controls on groups, you must have Create Group rights.
To configure access controls on groups:
1. In the Database Explorer, click Tools > Manage Users.

The Manage Users dialog box is displayed.

2. Click the Groups tab, and then select a group from the list.

3. Click Edit.
The Edit Group dialog box opens.

4. Click the Access tab, and then select a name in the list.

If you have not configured access controls on groups before, the Access 
Rights list will only contain the group Everyone. By default, Everyone has 
full (RMDA) access.

5. Select a user or group and click Edit to change their access rights to the 
group.

The Edit Access dialog box is displayed.

6. Choose the access rights for the user or group.

The following table describes the access rights you can choose.

These access rights are accumulative and not exclusive.

Access Right The user/group can The user/group cannot

None N/A View the group or make any 
alterations to the group

Read (R) See the group name and 
membership details

Add and delete members or 
alter access rights

Modify (M) Add or delete members and 
rename group

Delete group or alter access 
rights

Delete (D) Alter membership and delete 
group

Alter access rights

Admin (A) Delete the group and alter 
group’s access controls

N/A
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Note  There is no Create access right on groups.

7. Click OK.

Note  You can define new access rights on an individual or group 
basis by clicking Add instead of Edit and you can delete 
access rights by choosing a name from the list and clicking 
Remove. 

For a detailed explanation of access rights, please refer to “About access rights” 
in Using Rational DOORS, or in the online help.

Deleting a group
Note  You cannot delete a group in Rational DOORS if the 

information about Rational DOORS users and groups is 
being managed using RDS.

If you want to temporarily stop users in a group being able to access data using 
access rights assigned to the group, disable the group (see “Disabling and 
enabling a group,” on page 43). If you are sure you no longer want a group, go 
ahead and delete it.

Note  Deleting a group does not delete any of the users in the 
group. 
You cannot undelete a deleted group.

To delete a group:
1. Log in to Rational DOORS as a Project Manager, a Database Manager, or a 

Custom user who has the power to create groups.

2. In the Database Explorer, click Tools > Manage Users.
3. Click the Groups tab.

4. Select the group you want to delete, and then click Delete.

5. A message is displayed asking if you really want to delete the group. Click 
Yes.

6. Click OK to close the Manage Users window.

The selected group is deleted.

Note  Other users currently logged on to Rational DOORS might 
see the deleted group when they look at access rights screens. 
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They might not see the changes you made until the next time 
they log in to Rational DOORS.

Disabling and enabling a group
Disabling a group does not disable the individual users in the group. It just 
disables the access rights entries for the group.
It stops users in the group being able to access data using the access right entries 
for the group. A user might still be able to access the data using other access 
rights entries, for example, if they are in another group that can access the data.
To disable or enable a group:
1. Log in to Rational DOORS as a Project Manager, a Database Manager, or a 

Custom user who has the power to create groups.

2. In the Database Explorer, click Tools > Manage Users.
3. Click the Groups tab.

4. Select the group, and then click Edit.
5. To disable the group, select the Disable group check box. To enable the 

group, clear the check box.

6. Click OK.

7. Click OK.
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5 Configuring RDS
This chapter is for Database Managers and users who have the power to manage 
the database. 
It contains the following topics:

• About the Rational Directory Server

• Configuring Rational DOORS to use the Rational Directory Server

• Exporting users to the Rational Directory Server

About the Rational Directory Server
Rational DOORS uses the IBM® Rational® Directory Server (RDS). 
RDS is a single enterprise directory solution designed for user authentication and 
administration for Rational Lifecycle Solution (RLS) tools. RDS is based on 
Lightweight Directory Access Protocol (LDAP version 3).
RDS allows you to define and administer user information at one place. In this 
way you do not need to authenticate the user information for the same users 
more than once.
RDS comes with the GUI-based client application, the Rational Directory 
Administration (RDA). The RDA can be installed along with RDS or installed 
separately. 
The RDA allows you to perform day-to-day administrative tasks such as creating 
users and groups, enabling and disabling users, performing user and group 
searches, migrating groups and users, and so on with greater ease. For more 
information about these tasks, refer to the RDS documentation set.

RDS modes

Rational DOORS can use the following modes of RDS:

• Standalone mode

User names and group names are stored in the Rational DOORS database. 
These user names are not shared with other applications.

• Corporate mode

Corporate mode enables you to configure RDS to integrate with your 
external corporate LDAP repositories. This enables your corporate 
backbone to serve as the user and group read-only repository for Rational 
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Lifecycle Solution tools. The corporate mode enables you to access the 
corporate user and group information locally from the corporate partition.

When you are using RDS, you can add, edit, and delete users and groups in the 
Rational Directory Server and through the Manage Users dialog box in 
Rational DOORS. RDS is updated with changes made through the Manage 
Users dialog box, and vice versa. You can control how often users have to 
change their passwords using the Passwords expire after option on the 
Password tab.

Configuring Rational DOORS to use the Rational Directory Server
1. Log in to Rational DOORS as the Administrator user.

2. In the Database Explorer, click Database .

3. Right-click and select Properties.
The Database Properties dialog box is displayed with the General tab 
selected.

4. Click Change in the Directory Configuration area.

The Change Directory Configuration dialog box is displayed with 
Rational DOORS Local Directory selected.

5. Select Rational Directory Service.

6. In the Server Host field, type the name of the Rational Directory server 
machine.

7. In the Server Port field, select the port number that the Rational Directory 
server is using.

8. Click Test Connection to check that Rational DOORS can connect to the 
server.

A message stating whether or not the connection was successful is displayed.

9. Click OK.

A confirmation screen is displayed.

10. Click OK.

11. Click OK in the Change Directory Configuration dialog box.

Exporting users to the Rational Directory Server
1. Log in to Rational DOORS as the Administrator user.
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2. In the Database Explorer, click Database .

3. Right-click and select Properties.
The Database Properties dialog box is displayed with the General tab 
selected.

4. Click Export User/Group Lists in the Directory Configuration area.

The Export User/Group Lists dialog box is displayed.

5. Select Standalone or Corporate.

6. If you want to export a user list, type the name of the folder you want to 
export the list to in the Export User list field and select Export Users.

7. If you want to export a group list, type the name of the folder you want to 
export the list to in the Export Group list field and select Export Groups.

8. When you have finished exporting users and groups, click Close.
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6 Managing the database
This chapter is for Database Managers and users who have permission to 
manage the database. 
It contains the following topics:

• Showing the properties of the database

• Changing the name of the database

• Changing the default display scheme

• Changing the login policy

• Password control

• Managing the dictionary

• The login history file

• Broadcasting a message

• Setting up a message of the day

• Setting up e-mail

• Changing the access rights for the database root

• Allowing and disallowing discussions

Showing the properties of the database
To show the properties of your database:
1. Log in to Rational DOORS as a Database Manager or a Custom user who 

has the power to manage the database.

2. In the Database Explorer, make sure the Database view is selected.

If necessary, click View > Database View.

3. In the left pane, click Database , and then right-click Properties.
4. The General tab on the Database Properties window is described in the 

following table

General tab Description

Name The name of the database.
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Type The type of item whose properties are being displayed. This 
is Rational DOORS Database, and cannot be edited.

Default display 
scheme

The default display scheme for the database.
For more information, see “Changing the default display 
scheme,” on page 52.

Legacy data 
locale

You can set a locale for legacy attributes that do not have a 
locale.
This is set to (none) by default, and attributes in legacy data 
are displayed according to the current user locale on the 
client system. 

URL The URL of the database.

Copy URL Copies the URL to the system clipboard. 
For more information about DOORS URLs see 
Understanding DOORS URLs in Using Rational DOORS.

SMTP mail 
server

The SMTP mail server that you want the Rational DOORS 
database server to use.
For more information, see “Setting up e-mail,” on page 62.

Mail account The mail account that you want the SMTP mail server to use.
For more information, see “Setting up e-mail,” on page 62.

Prefix e-mails 
with text

The prefix text of e-mail messages that are sent automatically 
by Rational DOORS.
For more information, see “Setting up e-mail,” on page 62.

Directory 
Configuration

Rational DOORS uses the Rational Directory Server (RDS) 
for user information and authentication. This is selected by 
default.
You can configure RDS. For information, see “Configuring 
RDS,” on page 45.

General tab Description
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Record failed 
logins

Select this check box if you want to record every login failure 
in the login history file.
For information about what constitutes a login failure, see 
“Dealing with login failures,” on page 13.
For information about the login history file, see “The login 
history file,” on page 60.

Record 
successful logins

Select this check box if you want to record every successful 
login.
For information about the login history file, see “The login 
history file,” on page 60.

Save OLE 
objects in 
attribute history

Select this check box if you want details of changes to OLE 
objects to be stored in the objects history.
If a change is made to an OLE object and this check box is 
selected, the OLE object will be displayed in the details pane 
of the object history when the history item is selected. If it is 
not selected and a change is made to an OLE object, 
Rational DOORS will record a change to the attribute in the 
object history but will not indicate the details of the change 
in the details pane.

Allow deletion 
of module 
baselines

Select this check box if you want users with the appropriate 
access to be able to delete module baselines. The database 
default is to not allow baseline deletion.
You must be logged on as the Rational DOORS 
Administrator to change this setting.

General tab Description
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Changing the name of the database
The name of your database is shown:

• On the title bar of the Database Explorer. 

• To the right of Database  in the left pane of the Database Explorer 
when you are in Database view.

To change the name of your database:
1. Log in to Rational DOORS as a Database Manager or a Custom user who 

has the power to manage the database.

2. In the Database Explorer, make sure the Database view is selected.

If necessary, click View > Database View.

3. In the left pane, click Database , and then right-click Properties.
4. Type the new name in the Name box, and then click OK.

Changing the default display scheme
The display scheme controls the colors and fonts that are used in the Rational 
DOORS module windows. The database’s default display scheme is the one that 
all users see by default, unless they explicitly select a different scheme.
There are a number of standard schemes:

Only users with 
Edit DXL 
power may edit 
and run DXL

Select this option to prevent users editing and running DXL.
When this option is selected you can control whether 
individual users can edit and run DXL. An Edit DXL check 
box is displayed on the New user and Edit user dialog 
boxes. Select the Edit DXL check box to allow the user to 
edit and run DXL.
By default, the Only users with Edit DXL power may edit 
and run DXL is not selected, so any user can edit and run 
DXL.
Users can still run DXL from the DXL library, but they 
cannot edit that DXL.
You must be logged on as the Rational DOORS 
Administrator to change this setting.

General tab Description
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• modern

• classic

• international modern

• international classic

• high contrast #1

• high contrast #2

• high contrast black

• high contrast white

When you first install Rational DOORS, the default display scheme is modern.
To change the default display scheme for your database:
1. Log in to Rational DOORS as a Database Manager or a Custom user who 

has the power to manage the database.

2. In the Database Explorer, make sure the Database view is selected.

If necessary, click View > Database View.

3. In the left pane, click Database , and then right-click Properties.
4. On the General tab, select the Default display scheme you want.

5. Click OK.

Changing the login policy
To change the login policy of your database:
1. Log in to Rational DOORS as a Database Manager or a Custom user who 

has the power to manage the database.

2. In the Database Explorer, make sure the Database view is selected.

If necessary, click View > Database View.

3. In the left pane, click Database , and then right-click Properties.
4. Click the Login Policy tab.

5. Select the options you want:

Login Policy tab Description

Disable user logins Select this check box if you want to stop all users except 
Database Managers from logging on.
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Use passwords Select this check box if you want users to type in a 
password to log in to Rational DOORS.

Use additional 
authentication

This is a read-only check box and is only displayed if the 
Rational DOORS database is configured to use RDS for 
user authentication. If the check box is selected, the 
database has additional authentication enabled in RDS.

Use system 
usernames

This is unavailable if you are not logged on as the 
Administrator user.
Select this check box to enable system user names. For 
more information, see “Controlling how users log in,” on 
page 10.
You cannot enable system user names if you have not 
defined a system user name for your own (Administrator) 
account. To define a system user name for your own 
account:
a. Click Tools > Options.

b. Click the General tab.

c. Enter your system user name, and then click OK.

Minimum client 
version

Type the minimum client version that you want to be able 
to connect to the Rational DOORS database server, in the 
format n.n.n.n. For example, type 9.2.0.0
To check your client version click Help > About 
Rational DOORS.
You cannot enter a minimum client version that would 
prevent your current client from connecting to the 
database.
These restrictions do not apply to the dbadmin tool.

Login Policy tab Description
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Maximum client 
version

Type the maximum client version that you want to be able 
to connect to the Rational DOORS database server, in the 
format n.n.n.n. For example, type 9.2.0.0
To check your client version click Help > About 
Rational DOORS.
You cannot enter a maximum client version that would 
prevent your current client from connecting to the 
database.
These restrictions do not apply to the dbadmin tool.

Minimum password 
length

This is the minimum length of passwords for the 
database.

Maximum attempts 
per session

Select the maximum number of times that users can try to 
log in with any user name.
For example, if this value is 4, users are allowed four 
attempts to log in before the Rational DOORS login 
screen is closed.
The number must be in the range 0 to 10. 0 means there is 
no limit. The default value is 4.
Note If you have session timeouts configured, and a user 

session times out, only an Administrator can log in 
to unlock the session if the maximum attempts per 
session is reached. See “Reconfirm password 
session timeouts,” on page 57 for more 
information.

Login Policy tab Description



Managing the database

56    Managing Rational DOORS

Maximum attempts 
per username

Select the maximum number of consecutive times that 
users can try to log in with their own user name.
For example, if this value is 3, users are allowed three 
attempts to get their password right and log in before their 
account is disabled.
The number must be in the range 0 to 20. 0 means there is 
no limit. The default value is 20.
For more information see “Dealing with login failures,” 
on page 13.
Note If you have session timeouts configured, and a user 

session times out, only an Administrator can log in 
to unlock the session if the maximum attempts per 
user name is reached. See “Reconfirm password 
session timeouts,” on page 57 for more 
information.

E-mail message for 
failed logins

By default, the e-mail sent by Rational DOORS when 
there is a failed login attempt is prefixed with the text:
The following is a notification message from 
Rational DOORS - please do not reply as it was sent 
from an unattended mailbox. 
If you want to prefix e-mails with a different message, you 
can enter it here.

Notify failed logins 
by email to

This lists the users who receive an e-mail if there is a failed 
login attempt. The Rational DOORS client sends the 
e-mails.
Note Make sure the users have the e-mail address box 

filled in on the General tabs of their user options 
screens.

Add If you want to add an entry to the list of users who are 
e-mailed:
a. Click Add
b. Select the user from the list of Rational DOORS 

user names

c. Click OK

Login Policy tab Description
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6. Click OK.

Password control
You can impose rules on what passwords users can choose and how often they 
must be changed.
You can specify the types of characters in a password by making letters, numbers 
and/or symbols mandatory. You can also prevent users from reusing a password 
within a specified time period or reusing a password within a specified number 
of password iterations.
By default, passwords must have a minimum of six characters. You must be a 
database manager to configure password controls.
The password restrictions that you set are not enforced when a database 
manager or a custom user with the power to create users is creating or editing 
user passwords through the Manage Users dialog box. However, if a user of 
any type opens the Options dialog box (Tools > Options) and changes their 
password, the password must conform to the database restrictions.
To configure password controls:
1. In the Database view, click Database , and then right-click Properties. 

The Database Properties dialog box is displayed.

2. Click the Password tab.

There are three areas that can be configured: 

• Reconfirm Password
• Password Restrictions
• Password Repetition

Reconfirm password session timeouts

As a security feature, Rational DOORS allows you to lock Rational DOORS 
sessions after a specified period of inactivity. 

Remove If you want to remove an entry from the list of users who 
are e-mailed:
a. Select the entry you want to remove

b. Click Remove

Login Policy tab Description
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Note  You must be a database manager to configure session 
timeouts.

To configure session timeouts:
1. Select the Password required to login check box.

2. Under Reconfirm Password, select the Password reconfirmation 
required check box. 

3. Type the time-out period, in minutes, in the text box. The default setting is 
five minutes. You can type a value between 5 and 60 minutes.

4. Click Apply, and then click OK.

The new time-out settings are applied to all future login sessions. 

Re-entering the user’s password unlocks the Rational DOORS session.

Note  If the user account becomes disabled after a session times 
out, or the user reaches the limit for failed login attempts, 
only the Administrator can unlock the session. 

Password restrictions

To restrict the types of passwords that users can use, select the following 
option(s):

• If you select Letters, at least one letter must be in the password.

• If you select Numbers, at least one number must be in the password.

• If you select Symbols, at least one symbol must be in the password. 

• In the text box, type the minimum number of characters for passwords.

• The Passwords expire after option is only available if you have selected 
Use Rational Directory for user information and authentication on the 
General tab.

Password repetition
You can restrict how frequently a password is reused in terms of generations, 
days, or both, as follows:

1. For generations, type a whole number between 1 and 12.

If you type 1, the current password will not be available to that user again 
until they choose a different password at least once. If you type 12, twelve 
other unique passwords must be used before the current password can be 
reused.
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2. For days, type a whole number between 1 and 180.

If you type 10, the password cannot be reused for 10 days since it was last 
used as a password.

If both generations and days are used, both requirements must be met 
before the password becomes available to the user.

3. Click Apply, and then OK.

Command Line Login Restriction

If your database is configured to use RDS for authentication, you can set the 
database to allow or not allow the use of the -password or -P password 
command line switch. This setting can be overridden by editing the access rights 
of individual users.
By default, the database is set to allow users to use the -password or -P 
password command line switch. To restrict this use, select the Disable the 
password command line switch by default check box.

Managing the dictionary
Rational DOORS provides a client dictionary and a database dictionary for each 
installed language:

• Client dictionary

The client dictionary is stored on the machine on which the Rational 
DOORS client is installed. This is not a personal dictionary, it can be 
accessed by any user of that client, including Citrix clients that access the 
client remotely, and remote access clients. Access controls cannot be set on 
the client dictionary.

The default location of the client dictionary is:
C:\Program Files\IBM\Rational\DOORS\9.2\dictionary\us.dic

• Database dictionary

This dictionary is available to all the users of the database. You can set access 
rights to control who can add and remove words, and who can change user’s 
access rights.

The default location of the database dictionary is  
$Rational DOORSHOME/Data/v6data/spelling
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The access rights for the database dictionary are as follows:

By default, all users have full access to the database dictionary. 
To add a user or group:
1. Click Tools > Manage Dictionaries.

2. Select Database from the Dictionary list, and select the Access tab.

3. Click Add.

4. Select the user or group you want to add, the access rights you want them to 
have, and click OK.

To edit a user or group:
1. Click Tools > Manage Dictionaries.

2. Select Database from the Dictionary list, and click the Access tab.

3. Select the user or group whose access you want to change, and click Edit.
4. Assign the required access rights, and click OK.

The login history file
The Rational DOORS database server can keep a record of every:

• Login failure

• Successful login

By default, the database server only records login failures. To control what 
information is logged, see “Changing the login policy,” on page 53.
The database server logs the information in a text file called 
login_history.txt. This file is stored in 
<server_data_folder>\v6data\logs. 
On Windows, the ServerData entry in the registry (default location 
HKEY_LOCAL_MACHINE\SOFTWARE\Telelogic\DOORS_Server\9.2\Config) 
points to the location of the server data.
On Solaris, the login_history.txt file is stored in 
$SERVERDATA/v6data/logs.

Access Description

Modify User can add and remove words from the database dictionary.

Admin User can change the access rights to the database dictionary.
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Broadcasting a message

To show the login history, open the login_history.txt file in a text editor, 
such as Notepad, WordPad, or Emacs.

Note  The login history file can get quite big. You should regularly 
monitor its size and, if necessary, delete it (first copy it to 
another location, if you want to preserve the information). 
Rational DOORS automatically creates a new login history 
file in the logs folder.

Broadcasting a message
Database managers can broadcast a message to all the users that are connected 
to the Rational DOORS database server. For example, if you need to restart the 
Rational DOORS database server, you can broadcast a message to all the 
connected users warning them to save their work and log out of the database.
When the message is displayed, it is prefixed with the date and time, and the 
following text:
Broadcast Message from username@database_server_name

The time is displayed in the time zone of the Rational DOORS client.
To broadcast a message:
1. In the Database Explorer, click Tools > Broadcast Message.

The Broadcast Message dialog box is displayed.

2. Type the message you want to broadcast and click Send.

The message is sent to the database server, and is broadcast from there to all 
connected clients.

3. Click OK in the Message Sent dialog box.

Setting up a message of the day
You can set up Rational DOORS to display a message of the day, which is 
displayed on the Login dialog box. If you do not set up a message of the day, the 
standard Login dialog box is displayed.
To set up the message of the day:
1. Log in to Rational DOORS as a Database Manager or a Custom user who 

has the power to manage the database.

2. In the Database Explorer, make sure the Database view is selected.

If necessary, click View > Database View.
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3. In the left pane, click Database , and then right-click Properties.
4. Click the Message of the Day tab.

5. Select the Show message at startup check box and type the message you 
want to display to users in the Message of the Day box.

6. Click Apply or OK.

If you want to stop displaying the message of the day you can either:

• Delete the text

• Clear the Show message at startup check box

Setting up e-mail
The Rational DOORS client can send e-mails:

• Whenever there is a failed attempt to log in to Rational DOORS.

• When users submit proposals using the Change Proposal System, and the 
status of one of their proposals changes. For example, an e-mail can be sent 
to a user when one of their proposals is accepted or rejected.

E-mails sent by Rational DOORS always include the database name and the 
database URL.
To set up the client so that it can send e-mail messages:
1. Log in to Rational DOORS as a Database Manager or a Custom user who 

has the power to manage the database.

2. In the Database Explorer, make sure the Database view is selected.

If necessary, click View > Database View.

3. In the left pane, click Database , and then right-click Properties.
4. On the General tab, select the options you want.

The following table lists the options available:

Option Description

SMTP mail server The SMTP mail server that you want the Rational 
DOORS client to use.
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Changing the access rights for the database root

5. Click OK.

Changing the access rights for the database root
To change the access rights for the database root, you must have admin access to 
the database root.
To change the access rights for the database root:
1. Log in to Rational DOORS as a Database Manager or a Custom user who 

has the power to manage the database.

2. In the Database Explorer, make sure the Database view is selected.

If necessary, click View > Database View.

3. In the left pane, click Database , and then right-click Properties.
4. Click the Access tab.

Mail account The mail account that you want the SMTP mail server to 
use. This field is optional. 
If you leave this field blank, Rational DOORS will use a 
non-existent default mail account, smtp@doors, as some 
SMTP servers require user account authentication.
The default mail account assigned by Rational DOORS is 
not in a valid e-mail format. If the SMTP server has 
security controls that require a user account in a valid 
format, it can be entered here.
E-mail messages sent by the Rational DOORS client will 
display “change proposal system for <projectname>” in 
the From field.

Prefix e-mails with 
text

The prefix text of e-mail messages that are sent 
automatically by Rational DOORS. 
By default, automatic e-mails have the prefix:
The following is a notification message from 
Rational DOORS - please do not reply as it was sent 
from an unattended mailbox. 
If you want to prefix e-mails with a different message, you 
can enter it here.

Option Description
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5. The current access rights for the database root are displayed.

By default, these access rights are inherited by all top-level folders and 
projects you create in the database.

The following table describes the access rights you need to do different 
tasks:

6. Set up the access rights you want.

The following table describes how to do this:

You need this access right To

Read (R) This has no meaning for the database root as you 
cannot deny an existing user Read access. To 
remove read access at the database root level you 
must either disable the user account or delete the 
user from the user list.

Create (C) Create top-level projects and folders in the 
database.

Modify (M) This has no meaning for the database root itself, 
but can be inherited by items in the database, 
such as folders and projects.

Delete (D) This has no meaning for the database root itself, 
but can be inherited by items in the database, 
such as folders and projects.

Admin (A) Change the access rights for the database root.

To Do this

Add a new entry Click Add. The Add Access dialog box is displayed.
In the Name box, select the name of the user or group 
that you want to add an entry for.
Select the access rights you want to give them, and then 
click OK.

Remove an entry Select the entry, and then click Remove.
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Allowing and disallowing discussions

7. Click OK.

Allowing and disallowing discussions
You can control how discussions work in the database. You can:

• Allow all users to participate in all discussions

• Allow the Database Manager or a user with admin access to a module to 
control who can participate in discussions in a module

• Disable all discussions for the database

You need to be using a Rational DOORS 9.2 or later Database Server, and the 
server must be configured to exclude Rational DOORS 9.0 and 9.1 clients to 
make the discussions functionality fully available.
To allow or disallow discussions in a database:
1. Log in to Rational DOORS as a Database Manager or a Custom user who 

has the power to manage the database.

2. In the Database Explorer, make sure the Database view is selected.

If necessary, click View > Database View.

3. In the left pane, click Database , and then right-click Properties.
4. Click the Discussions Access tab.

5. The current access for the database is displayed.

Edit an existing 
entry

Select the entry, and then click Edit. 
The Edit Access dialog box is displayed. Select the access 
rights you want to give them, and then click OK.

Additional access Select the additional access rights that you want to 
propagate with create access.
The additional rights are propagated to the items in the 
tree below the database root that inherit their access rights 
from it

To Do this
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The following table describes the radio buttons:

6. Click OK.

Radio button Controls

Allow Discussions Allows all users to participate in all discussions.

Allow Discussions (access 
restrictions can be set on 
modules)

Allows the Database Manager or a user with 
admin access to a module to control who can 
participate in discussions in a module.

Do not allow Discussions Disables all discussions for the database.
Note If you disable discussions, and a module 

already has an open discussion, the 
discussion will stay open until you stop and 
restart the Rational DOORS client.
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7 Managing projects
This chapter describes:

• Creating a project

• Using the Project Startup Wizard

• Converting a folder to a project

• Converting a project to a folder

• Editing project properties

• Changing the access rights for a project

• Deleting, undeleting and purging a project

Creating a project
You can either create a brand new project, or convert an existing folder to a 
project (see “Converting a folder to a project,” on page 70).

Note  For information about using a wizard to create a project, see 
“Using the Project Startup Wizard,” on page 68.

To create a brand new project:
1. Log in to Rational DOORS as a Database Manager, or a Custom user who 

has the power to create projects.

2. In the Database Explorer select the folder or project in which you want to 
create the new project. This is the project’s parent.

You must have create access to the parent. To create a top-level project, you 
must have create access to the database root (see “Changing the access rights 
for the database root,” on page 63).

3. Click File > New > Project.
4. In the Name box, type in the name of the new project.

The name is case-sensitive. For example, the names Myproject and 
MyPROJECT are different. 

Project names must be unique throughout the Rational DOORS database. 
You cannot have two projects with the same name.

The name can contain the following characters:
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• Alphanumeric characters (letters of the alphabet and numbers)
• Space characters
• Periods (.)
• Underscores (_)
• Hyphens (-)

5. If you want to enter additional information about the new project, type it in 
the Description box.

6. Click OK.

The new project inherits its access rights from its parent. If you want to 
change its access rights, follow the instructions in “Changing the access 
rights for a project,” on page 72.

Note  If you receive the error Cannot create this Project: 
Lock request timed out when you try to create the 
project, wait a moment, and then try again. This error is 
generated if another Rational DOORS user is 
performing a paste operation when you click OK to 
create the project.

Using the Project Startup Wizard
Use the Project Startup Wizard to create a project that is already populated with 
modules, attributes and views. The wizard provides various defaults to help you 
quickly set up a new project.
To use the Project Startup Wizard:
1. Log in to Rational DOORS as a Database Manager, or a Custom user who 

has the power to create projects.

2. In the Database Explorer select the folder or project in which you want to 
create the new project. This is the project’s parent.

You must have create access to the parent. To create a top-level project, you 
must have create access to the database root (see “Changing the access rights 
for the database root,” on page 63).

3. Click File > New > Project Startup Wizard.

If you want to create a project from scratch, go to Step 4.

If you want to use an existing project definition:

a. Click Re-use, and then select the definition from the list.
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Using the Project Startup Wizard

b. In the Name box, type the name of the new project, and enter 
additional information about the project in the Description box. 

c. Click Next to display the final wizard screen.

d. Click Finish.

The project is created, using the specified definition. It inherits its access 
rights from its parent. If you want to change its access rights, follow the 
instructions in “Changing the access rights for a project,” on page 72.

4. If you want to create a project from scratch:

a. Click New.

b. In the Name box, type the name of the new project.

c. In the Description box, enter additional information about the project.

d. Click Next.
5. Select the project type (System or Software) and the approach (Formal, 

Informal, or Very Informal) that you want to adopt.

6. Click Add Typical Modules. 

Default modules for the specified project type and approach are listed in the 
Modules box.

7. The Modules box lists all the modules that are created in the project.

If you do not want a module listed in the Modules box, select it then click 
Remove selected module. 

If you want to add another module, type the name of the module in the 
Module Name box, and then click Insert custom module.

8. Click Next.
9. Specify what attributes you want for each module:

a. Select the module in the Add attributes to module box.

b. In the Attributes typical for drop-down list, select the type of the 
module, and then click Insert typical attributes.
Default attributes for the specified type of module appear in the 
Attributes in selected module box.

c. If you do not want an attribute in your module, select it then click 
Remove selected attribute. 
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d. If you want to add another attribute, type the name of the attribute in 
the Attribute Name box, select the type in the and type box, and then 
click Insert custom attribute.

10. Click Next to display the next wizard screen.

11. Specify what views you want for each module:

a. Select the module in the View onto module box.

b. In Typical views, select a view, and then click Insert typical view. 

The name of the view is displayed in the Views box, and the Columns 
available box shows the columns you could have in that view. Use the 
arrow keys to select which of these columns you want in the view.

c. If you do not want a view shown in the Views box, select it then click 
Remove selected view. 

d. If you want to use a custom view name, type the name in the Custom 
view name box, select the columns you want in the view, and then click 
Insert custom view.

12. Click Next.
13. In the Definition name box, type a name for your project definition. 

You can re-use this definition next time you use the wizard to create a 
project.

14. Click Next to display the final wizard screen.

15. Click Finish to create the new project.

Note  The new project inherits its access rights from its parent. If 
you want to change its access rights, follow the instructions 
in “Changing the access rights for a project,” on page 72.

Converting a folder to a project
The differences between projects and folders are:

• Projects have unique names within the database, so that the location of any 
data in the project is uniquely identified by a path that starts at the project. 

• When you use Project view in the Database Explorer, every project is 
displayed at the top level. A subproject is displayed in the tree below its 
parent project, as well as at the top level.

• You can partition and archive projects, but not folders.

• You can create a Change Proposal System for a project but not for a folder.
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Converting a project to a folder

You cannot convert a folder to a project if either:

• The folder contains a module that is configured for review in the Change 
Proposal System.

• The folder or anything in it is open. When a module, folder or project is 
open, all the folders above it in the database tree are also open.

To convert a folder to a project:
1. Log in to Rational DOORS as a Database Manager, or a Custom user who 

has the power to create projects.

2. In the right pane of the Database Explorer, select the folder that you want to 
convert, and then click File > Convert to Project.
You must have admin access to the folder.

Converting a project to a folder
The differences between projects and folders are:

• Projects have unique names within the database, so that the location of any 
data in the project is uniquely identified by a path that starts at the project.

• When you use Project view in the Database Explorer, every project is 
displayed at the top level. A subproject is displayed in the tree below its 
parent project, as well as at the top level.

• You can partition and archive projects, but not folders.

• You can create a Change Proposal System for a project but not for a folder.

You cannot convert a project to a folder if:

• The project has a Change Proposal System.

• The project has any exported or imported partitions.

• The project or anything in it is open. When a module, folder or project is 
open, all the projects above it in the database tree are also open.

To convert a project to a folder:
1. Log in to Rational DOORS as a Database Manager, or a Custom user who 

has the power to create projects.

2. In the right pane of the Database Explorer, select the project that you want 
to convert, and then click File > Convert to Folder.
You must have admin access to the project.
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3. A message is displayed asking if you really want to convert the project to a 
folder. Click Yes.

Editing project properties
To edit the properties of a project, you must have modify access to the project.
To edit the properties of a project:
1. In the Database Explorer, select the project then right-click Properties.

The following table lists the available options on the General tab:

2. Click OK.

Changing the access rights for a project 
To change the access rights for a project, you must have Admin access to the 
project.
To change the access rights for a project:
1. In the Database Explorer, select the project then right-click Properties.
2. Click the Access tab.

3. The current access rights for the project are displayed.

General tab Description

Name The name of the project.
You cannot change the name of a project if any user has a 
folder, project or module in the tree below it open.
If the project contains a link module, and the link module is 
named in any formal module filter that has been saved as a 
view, no objects will be displayed in the view if the project 
name is changed.

Description Additional information about the project.

Type The type of item whose properties are being displayed. This is 
Project, and cannot be edited.

URL The URL of the project.

Copy URL Copies the URL to the system clipboard.
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Changing the access rights for a project

The following table lists the available access rights:

4. Set up the access rights you want.

The following table lists the boxes and buttons on the Access tab:

You need this access 
right

To

Read (R) See the project. If you do not have read access, the 
project is not displayed in your Database Explorer.

Create (C) Create new modules, folders and projects inside the 
project.
Paste existing modules, folders and projects into the 
project.
Create partition definitions for the project.
Create a Change Proposal System for the project.

Modify (M) Change the name or description of the project.
Edit partition definitions.

Delete (D) Delete, undelete and purge the project.
Cut the project to the Database Explorer clipboard.
Delete partition definitions.
Delete the project’s Change Proposal System.

Admin (A) Change the access rights for the project.
Change the default linkset pairings for links from 
top-level modules within the project.

Access tab Description

Inherit from parent Select this check box if you want the project to inherit 
its parent’s access rights. If it is a top-level project, it 
inherits its access rights from the database root.
When this check box is selected, the list of access 
rights is unavailable, and shows what access rights the 
project is inheriting from its parent.
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5. Click OK.

Deleting, undeleting and purging a project
Deleting a project does not destroy any of the project data. It simply marks the 
project as deleted, and stops users from being able to access its data. To destroy 
the data, you must purge the project once you have deleted it.
Purging deleted projects removes them permanently from the database.
You cannot delete a project if the project or anything in it is open.

Note  In the Database Explorer, the folder or project selected in 
the left pane is open and has an open folder icon  or an 
open project icon . Its parent folder or project is also 
open, and so are all the folders and projects above it in the 
database tree, although they do not have open folder or open 
project icons. 

Add To add a new entry to the list of access rights, click 
Add. The Add Access dialog box is displayed.
In the Name box, select the name of the user or 
group that you want to add an entry for.
Select the access rights you want to give them, and 
then click OK.

Remove To remove an entry from the list of access rights, 
select the entry then click Remove.

Edit To edit an entry in the list of access rights, select the 
entry then click Edit.
The Edit Access dialog box is displayed. Select the 
access rights you want to give them, and then click 
OK.

Additional access Select the additional access rights that you want to 
propagate with create access.
The additional rights are propagated to the items in 
the tree below the folder that inherit their access 
rights from it.

Access tab Description
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Deleting, undeleting and purging a project

When a module is open, all the folders and projects above it 
in the database tree are also open.

To delete, undelete or purge a project, you must have delete access to the project 
and to all the folders and modules in it. 
To delete a project:
• In the right pane of the Database Explorer, select the project you want to 

delete , and then click File > Delete.

To undelete a project:
1. In the Database Explorer, make sure that deleted items are being displayed. 

If necessary, click View > Show Deleted.

2. In the right pane of the Database Explorer, select the project you want to 
undelete , and click File > Undelete.

To purge a project:
1. In the Database Explorer, make sure that deleted items are being displayed. 

If necessary, click View > Show Deleted.

2. In the right pane of the Database Explorer, select the project you want to 
purge , and then click File > Purge.

A message is displayed asking if you really want to purge the project.

3. Click Yes.

The project and all the data in it is permanently removed from the database.
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8 Archiving and restoring data
This chapter contains the following topics:

• Disk backups

• Rational DOORS archives

• Enabling server archives

• Archiving a module or project

• Restoring a module

• Restoring a project

• Archiving and restoring user information

• Restoring the entire database

Disk backups
To protect the data in your Rational DOORS database against the failure of the 
disk on which it is stored, take regular backups of the disk. Use standard file 
system backup tools to backup the disk.
In the event of a disk hardware error, you can restore the entire disk from your 
backups.
When you backup your disk:

• Only do full and differential backups. Do not do incremental backups.

Because of the structure of the Rational DOORS database, incremental 
backups might capture inconsistent data.

• If you do differential backups, make sure you do a full backup at least once a 
week.

• Before you start the backup, make sure that all users are logged out of 
Rational DOORS.

Most backup tools do not backup files that are open. If files are skipped 
because users are accessing the database, your backup might capture 
inconsistent data.
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Rational DOORS archives
Use Rational DOORS archives to make a backup of a particular module or 
project to protect against accidents. For example, if a user accidentally deletes 
and purges a project, you can restore the project from your archive.
You can archive the following parts of your Rational DOORS database:

You can create Rational DOORS archives on the Rational DOORS client 
machine, or on the Rational DOORS database server machine. 

Enabling server archives
Instead of saving archives on your local machine, you can save them to the 
Rational DOORS database server machine, where they are stored in a folder 
inside the data folder. This means that they can be restored to a Rational 
DOORS client on any machine, instead of only being available on your local 
machine.
If you want users to be able to create and restore archives on the Rational 
DOORS database server machine, follow the steps below.
On Windows machines:
1. Navigate to your Rational DOORS 9.2 data folder on the Rational DOORS 

database server machine. In the data folder create a folder, for example 
serverarchive. All server archives for the database will be created in this 
folder.

2. Open the Registry Editor, and navigate to 
HKEY_LOCAL_MACHINE\SOFTWARE\Telelogic\DOORS_Server\9.2\Config.

3. Create a string called DOORS_Archive_Location.

4. Right-click the string, select Modify, and type the name of the folder you 
created in the Value data box. For example, type serverarchive

5. Stop and start the Rational DOORS 9.2 Database Server.

Rational DOORS archive File type

An entire project .dpa

A single module .dma

Information about all the users 
and groups in the database

.dua
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Archiving a module or project

Check that server archives are enabled:

1. Run Rational DOORS and log in as a user with the power to archive and 
restore data.

2. Select a project in the right pane of the Database Explorer and click File > 
Archive. The Archive Project dialog box has an Archive on server check 
box. This check box is also available on the Archive Module check box. A 
Restore from server check box is displayed on the Restore Project and 
Restore Module dialog boxes.

On UNIX machines:
Include the following environment variable as part of the profile or startup script 
for the user who runs the Rational DOORS database server:

DOORS_ARCHIVE_LOCATION=<directoryname>

The directory <directoryname> will be created relative to $SERVERDATA.

Archiving a module or project 
You cannot archive a module if any user has the module open in either shareable 
or exclusive edit mode.
You cannot archive a project if the project or anything in it is open.
You should make sure that any baseline sets that include modules you are going 
to archive are closed before you create the archive.

Note  In the Database Explorer, the folder or project selected in 
the left pane is open and has an open folder icon  or an 
open project icon . Its parent folder or project is also 
open, and so are all the folders and projects above it in the 
database tree, although they do not have open folder or open 
project icons. 
When a module is open, all the folders and projects above it 
in the database tree are also open.

To archive a module or project:
1. Log in to Rational DOORS as a Project Manager, a Database Manager, or a 

Custom user who has the power to archive data.

2. In the right pane of the Database Explorer, select the module or project you 
want to archive.

You need read access to the module or project in order to see it in the 
Database Explorer, but you do not need any other access to it. The archive 
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includes all the module or project data, including data that you do not have 
any access to. 

If you want to create the archive file on the server machine, go to Step 4. 
You can only create archive files on the server machine if your database 
manager has set up Rational DOORS to allow server archives. For more 
information, see “Enabling server archives,” on page 78.

3. If you want to create the archive file on the client machine:

a. Click File > Archive.

b. In the File name box, type a path and filename for the archive file, or 
use browse to select a location. Go to Step 5.

4. If you want to create the archive file on your server machine:

a. Click File > Archive.

b. Select Archive on server. The Browse button is removed from the 
dialog box.

Note  This option is only visible if your database manager 
has set up Rational DOORS to allow server archives. 
For more information, see “Enabling server 
archives,” on page 78.

c. Type a name for your archive file. If you want it to be created in a 
subfolder on the server, type a path then the archive name. For example, 
type myarchives/project.dpa.

A folder called myarchives is created on the server, and project.dpa is 
stored inside it. 

Keep a record of your archive names and locations, as you cannot 
browse to the archive folder on the server. You must type the path and 
file name when you want to restore an archive.

5. By default, Rational DOORS includes all baselines in the archive. If you do 
not want to include baselines in the archive, select do not archive any 
baselines.

6. Select the Span disks check box if you want the archive file to span more 
than one disk. This is useful if you are creating the archive on floppy disks.

Make sure you label the floppy disks to record the order in which you feed 
them into the computer when the archive is created. For example, label the 
first 1, the second 2 and so on.
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Restoring a module

7. Select Include Rational DOORS backup system files (not needed for 
day-to-day archiving) if you have been asked to do so by Customer 
Support. Otherwise, you do not have to select this check box when you 
archive data.

8. Click OK. 

An archive file is created in the location specified on the client or server 
machine.

Note  Keep the archive file on a different disk to the one on 
which your database is stored, so that you can access it in 
the event that your database disk is damaged. 
If the archive fails because something you want to 
archive is locked, follow the instructions in “Managing 
locks,” on page 226.

Restoring a module
You should restore an archived module to the database where you created the 
archive. If you restore it to another database, you lose information about all the 
module’s access rights, because the access rights are specific to the users and 
groups in the original database.

Note  If you want to transfer data between Rational DOORS 
databases, use partitions, not archives. For information about 
partitions, see “Managing partitions,” on page 137.

To restore a module:

If you restore a module to This information is lost

The same database All the links to and from the restored module, 
including internal links between objects within the 
module.

A different database All the links to and from the restored module, 
including internal links between objects within the 
module.
All the information about access rights for the 
restored module. The restored module and all the 
data in it only has default access rights. This means 
they inherit their access rights from the project or 
folder in which you restore the module.
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1. If you are restoring from an archive that spans multiple floppy disks, put the 
last floppy disk into your floppy disk drive. The last floppy disk contains 
information about the total number of disks in the archive.

2. In the Database Explorer, select the project or folder to which you want to 
restore the module.

You must have create access to this project or folder.

If you want to restore a module archive from the server machine, go to Step 
4. 

3. If you want to restore a module archive from your client machine:

a. Click File > Restore > Module.

b. In the File name box, type the name of the archive file that contains the 
module you want to restore, or use Browse to locate it. Go to Step 5.

4. If you want to restore a module archive from the server machine:

a. Click File > Restore > Module.

b. Select Archive on server. The Browse button is removed from the 
dialog box.

Note  This option is only visible if your database manager 
has set up Rational DOORS to allow server archives. 
For more information, see “Enabling server 
archives,” on page 78.

c. In the Server file name box, type the name of the module archive you 
want to restore. You cannot browse to files on the server, so you must 
know the name of the archive and the path, if it was created in a 
subdirectory on the server.

5. Click OK.

The Restore Module dialog box is displayed.

6. In the New name box, type the name you want to give to the restored 
module.

The name is case-sensitive. For example, the names Mymodule and 
MyMODULE are different.

The name must be unique within the parent project or folder. All the 
projects, folders and modules in the parent must have different names.

The name can contain the following characters:

• Alphanumeric characters (letters of the alphabet and numbers)
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• Space characters
• Periods (.)
• Underscores (_)
• Hyphens (-)

7. Click OK.

Restoring a project
When you restore an archived project, you can choose which parts of the project 
you want to restore. You can restore the whole project, or you can restore 
selected sub-projects, folders and modules.
Links that are entirely contained within the restored modules are preserved.
A link is preserved if the set of restored modules includes the link’s source and 
target module, and its link module.
You should restore a project to the database where you created the archive. If 
you restore it to another database, you lose information about the project’s 
change proposal system (if it had one), and access rights, because they are 
specific to the users and groups in the original database. 

Note  If you want to transfer data between Rational DOORS 
databases, use partitions, not archives. For information about 
partitions, see “Managing partitions,” on page 137.

If you restore a project 
to

This information is 
preserved

This information is lost

The same database All links that are entirely 
contained within the 
restored modules.

Any links that are not 
entirely contained within 
the restored modules.
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To restore a project:
1. If you are restoring from an archive that spans multiple floppy disks, put the 

last floppy disk into your floppy disk drive. The last floppy disk contains 
information about the total number of disks in the archive.

2. Log in to Rational DOORS as a Project Manager, a Database Manager, or a 
Custom user who has the power to create projects.

3. In the left pane of the Database Explorer, select the project or folder that 
you want to restore the archived project to.

You must have create access to this project or folder.

If you want to restore a project archive from the server machine, go to Step 
5.

4. If you want to restore a project archive from your client machine:

a. Click File > Restore > Project.
b. In the File name box, type the name of the file that contains the 

archived project, or use Browse to locate the file. Go to Step 6

5. If you want to restore a project archive from the server machine:

a. Click File > Restore > Project. 

A different database All links that are entirely 
contained within the 
restored modules.

Any links that are not 
entirely contained within 
the restored modules.
All the information about 
access rights for the 
restored project. The 
restored project and all the 
data in it only has default 
access rights. This means 
they inherit their access 
rights from the project or 
folder in which you restore 
the project.
All change proposal 
system information.

If you restore a project 
to

This information is 
preserved

This information is lost
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b. Select Restore from server. The Browse button is removed from the 
dialog box.

Note  This option is only visible if your database manager 
has set up Rational DOORS to allow server archives. 
For more information, see “Enabling server 
archives,” on page 78.

c. In the Server file name box, type the name of the project archive you 
want to restore. You cannot browse to files on the server, so you must 
know the name of the archive, and the path if it was created in a 
subdirectory on the server.

6. Click OK.

7. In the New name box, type the name you want to give to the restored 
project.

The name is case-sensitive. For example, the names Myproject and 
MyPROJECT are different.

Project names must be unique throughout the Rational DOORS database. 
You cannot have two projects with the same name.

The name can contain the following characters:

• Alphanumeric characters (letters of the alphabet and numbers)
• Space characters
• Periods (.)
• Underscores (_)
• Hyphens (-)

8. By default, the entire project is restored. If you do not want to restore a 
particular folder, project or module in the archive, clear the box at the left.

9. Click OK.

Archiving and restoring user information
You should regularly archive your user information. A user archive contains 
information about all the users and groups for the database.
If your Rational DOORS database is configured to use the Rational Directory 
Server, you cannot archive users and groups through Rational DOORS.
To archive user information:
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1. Log in to Rational DOORS as a Project Manager, a Database Manager, or a 
Custom user who has the power to archive data.

2. In the Database Explorer, click Tools > Manage Users.
3. Click the Archives tab.

4. In the Archive users and groups section, type the name of the file that you 
want to archive the data to in the File name box, or use Browse to locate it.

5. Select the Span disks check box if you want the archive file to span more 
than one disk. This is useful if you are creating the archive on floppy disks.

Make sure you label the floppy disks to record the order in which you feed 
them into the computer when the archive is created. For example, label the 
first 1, the second 2 and so on.

6. Click Archive.

7. Click OK.

When you restore a user archive, you replace all the current user information 
with the information in the archive. For example:

• Users who were deleted after you created the archive now exist again.

• Access rights for users who were created after you created the archive no 
longer match any existing users or groups. Rational DOORS automatically 
deletes these access rights when it comes across them.

• If you are restoring a user list archived from a different database the 
Administrator password in the current database will be overwritten with the 
Administrator password from the other database.

To restore user information:
1. If you are restoring from an archive that spans multiple floppy disks, put the 

last floppy disk into your floppy disk drive. The last floppy disk contains 
information about the total number of disks in the archive.

1. Log in to Rational DOORS as the Administrator user.

2. In the Database Explorer, click Tools > Manage Users.
3. Click the Archives tab.

4. In the Restore users and groups section, type the name of the file that 
contains the archived user information in the File name box, or use 
Browse to locate it.

5. Click Restore.

6. Click OK.



Managing Rational DOORS           87

Restoring the entire database

Restoring the entire database
If your entire Rational DOORS database becomes corrupt, restore the disk that 
it is stored on. Use your disk backups to restore the entire disk.
If you cannot restore the disk, for example, because you have lost your backup 
tapes, contact the Rational DOORS customer support team, who will talk you 
through a procedure to restore the database using your Rational DOORS 
archives. They will help you salvage as much of your data as possible.
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9 Administering electronic signatures
This chapter contains the following topics:

• About electronic signatures

• How do electronic signatures work?

• What information is stored with a signature?

• Creating a Label Specifier Type

• Configuring electronic signatures

About electronic signatures
An important part of any project’s lifecycle is the review process. This can be 
complicated and time consuming, requiring numerous paper copies of the 
document to be distributed to various users for review and approval. These must 
then be collected, consolidated and filed. As all these activities are performed 
outside Rational DOORS, there is no traceability or history and you have little 
control over who has access to the document.
The introduction of electronic signatures to Rational DOORS means that you 
can automate this entire process, and the document need never be removed from 
the database. When your document reaches a point where it must be reviewed, 
you can configure it so that the users you need to review it can do so 
electronically.
You have complete control over who can review your document, and all the 
signatures are stored in the same place and with the module. This means that the 
process is secure, easy to administer, and the signature information can be easily 
retrieved and reviewed.
As well as defining the users you want to review your document, you can also 
define a list from which those users must select a value when they sign. This 
reduces the risk of misinterpretation when the time comes to review the 
signature information. Users can also add their own comments when they sign 
the baseline.
The electronic signature capability in Rational DOORS records the sort of 
information that would be impossible to capture when reviewing documents in 
the traditional way. Rational DOORS timestamps each signature to the nearest 
second and it records any access restrictions so that it is clear what information 
the user was able to review. If you set a list of values for users to choose from, 
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the values that were available to the user are listed. Users cannot alter any part of 
their signature once it has been submitted.
The rest of this chapter describes in detail how electronic signatures work, and 
what you need to do to set up your document to use electronic signatures.

How do electronic signatures work?
When you put your document out to users for review, you need to be sure that all 
those users have the same version of the document. Traditionally, you would do 
this by printing numerous paper copies and distributing them to the users.
You can achieve this electronically, using Rational DOORS’s baselining 
functionality. A baseline is a read-only snapshot of a module at a given time. 
When a document reaches the stage when it needs to be reviewed, baseline it. 
Users can then access the baseline, review the information and sign it off. As all 
the users are accessing and signing the same baseline, all the users signatures are 
stored in the same place, so it is easy to access and cross-reference them.
As the project progresses you build up a series of baselines each containing the 
time-stamped signatures of your reviewers. This means you have a complete 
history of each stage of the modules development, and of every user that was 
involved in the review process from beginning to end.
Because all baselines are stored with the module, and all signatures are stored 
with the baseline that they pertain to, it is very easy to retrieve and review them. 
Rational DOORS provides access controls so that you can control which users 
can sign the baseline, and which users can read the signatures that have been 
made.

What information is stored with a signature?
When a user signs a baseline, the following information is stored with the 
signature:

• The user’s Rational DOORS user name.

• The user’s Full Name. 

The Full Name can be provided when the Rational DOORS user is created, 
however it is not a required field. If the Rational DOORS user does not have 
a Full Name, the Full Name is left blank in the signature.

• The date and time that the user signed the baseline. This is the date and time 
on the Rational DOORS database server, not the Rational DOORS client.

For more information, see “How date and time are recorded,” on page 17.
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Creating a Label Specifier Type

• When you configure electronic signatures you can choose to provide the 
users that are reviewing and signing each baseline with a list from which they 
must choose a value. In Rational DOORS this list is called the Label 
Specifier, and the values contained in the list are called the Signature 
Labels. The signature labels can be edited throughout the lifecycle of the 
module, so Rational DOORS records what signature labels were available to 
the user when signing the baseline.

• If you have provided users with a label specifier from which they must 
choose a signature label, the label they choose is recorded with their 
signature.

• A comments field is available to each user who signs the baseline. Any 
comments that they added are recorded with their signature.

• If the database is set up to use passwords, users must reconfirm both their 
Rational DOORS user name and password before their signature is added. If 
the database is not set up to use passwords then they need only reconfirm 
their user name. As the password policy for the database might change 
during a module’s lifecycle, this information is stored with the signature.

• Rational DOORS access controls might prevent users from accessing all the 
information that is stored in a module. What is more, users might be 
unaware that they are not able to see all the information in the module. 
When a user signs a baseline, Rational DOORS records whether their access 
to the module was restricted. This means that users are not held accountable 
for information that they were unable to review.

Creating a Label Specifier Type
If you want to provide your users with a list from which they must select a value 
when they sign the baseline, you must create the Label Specifier Type. Label 
Specifiers are enumerated attributes, and are created in the same way as any other 
enumerated attribute. You assign a series of values to the enumerated attribute, 
and these are the values from which your users must choose when they sign the 
baseline.
Your module might contain a large number of enumerated attributes, so you 
must ensure that the name of the enumerated attribute that you create for use as 
a Label Specifier Type has an easily recognizable name.
If you do not want users to be able to add values to the Label Specifier Type, set 
access restrictions on the enumerated attribute type.
For information on how to create an enumerated attribute type, see the chapter 
entitled “Using attributes” in Using Rational DOORS.
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Configuring electronic signatures
As electronic signatures are tied to your module’s baselines, you have to baseline 
the module before you can configure electronic signatures.

1. In the module, click File > Baseline > View.

The View Baseline dialog box is displayed, and all the baselines that have 
been made are displayed.

2. Select a baseline and click Signatures. It does not matter which baseline you 
select. Your configuration applies to all the baselines of the module. You can 
change the configuration at any time.

The Baseline Signatures dialog box is displayed.

3. Click Configure.

The Signatures Configuration dialog box is displayed.

4. Select Include Signature Labels if you want to provide users with a list of 
values. The Label Specifier Type list becomes available.

Note  If you have not created an enumerated type to use as the 
Label Specifier, you must do that before you can 
continue. For more information, see “Creating a Label 
Specifier Type,” on page 91.

5. Select a Label Specifier Type from the list.

Setting access controls

The Signatures Configuration dialog box has two tabs for setting access 
controls for electronic signatures. These are Access (Signatories) and Access 
(Label Specifier).
• Access (Signatories)

The access controls on this tab govern who can read signatures, sign 
baselines and administer the signatures list.

This access right Allows you to

R Read signatures

M Sign a baseline

A Administer signatures list
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To give a user access to electronic signatures:
a. Click Add.

The Add Access dialog box is displayed.

b. Select the user or group you want to add in the upper pane and assign 
access rights in the lower pane, by selecting or clearing the check boxes.

c. Click OK.

The Add Access dialog box closes and the user is added.

• Access (Label Specifier)
The access controls on this tab govern who can change the Label Specifier 
Type.

Note  Access controls for the values of the Label Specifier 
Type (the options in the drop down list presented to 
signatories adding their signature to a baseline) are held 
with the attribute type definition. For more information, 
see Controlling access to an attribute type in Using 
Rational DOORS.

To give a user access to the label specifier:
a. Click Add.

The Add Access dialog box is displayed.

b. Select the user or group you want to add in the upper pane and assign 
access rights in the lower pane, by selecting or clearing the check boxes.

c. Click OK.

The Add Access dialog box closes and the user is added.

This access right Allows you to

M Set the module to Include Signature Labels and 
change the Label Specifier Type.

A Change the Label Specifier access rights.
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10 Managing incremental development using 
Intelligent Traceability

This chapter contains the following topics:

• Incremental development and Intelligent Traceability

• Intelligent Traceability and baseline sets

• Link behavior in baseline sets

• Link behavior outside baseline sets

• What is a baseline set definition?

• Creating a baseline set definition

• Copying a baseline set definition

• Renaming a baseline set definition

• Access controls for baseline set definitions

• Showing baseline set definitions

• Creating a baseline set

• Baselining a module to a baseline set

• Closing a baseline set

• Removing a baseline set definition

Incremental development and Intelligent Traceability

Incremental development
In complex projects it is often the case that various teams work in parallel on a 
set of data. For example, you might have a user requirements document, a system 
requirements document and test documents, all which are interdependent. 
Ideally in a projects life cycle, documents pass through several incremental 
phases, each phase being completed and signed off before the next phase begins. 
So the analysts create user requirements for phase one, the engineers base system 
requirements on them, and the test engineers develop tests for them. Once this 
process is complete and the results have been approved and signed off, the 
project moves on to the next incremental phase, and the process starts again.
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In real life projects, however, it is unlikely that the process will run this smoothly. 
Inevitably, analysts complete phase one before engineers, and engineers before 
test. This leaves project managers with a dilemma: either hold back those teams 
that are ready to move forward to the next incremental phase until other teams 
have caught up, or allow the project to progress to the next phase before work is 
completed. In most projects, time is a deciding factor and the project must 
progress, but this leaves room for error and makes project planning and 
management difficult.
Rational DOORS solves this problem by allowing those teams that have 
completed a phase to carry on to the next one, leaving a frozen, read-only record 
of the completed phase for other teams to access and link to. As the various 
teams complete the documents associated with that phase, they can add them to 
the set.

Intelligent Traceability
The most powerful features of Rational DOORS as a requirements management 
tool are linking and traceability. You can build up relationships between the 
requirements in your project using links, and then easily trace these links to keep 
track of changes to the project, and how the changes affect the requirements to 
which they are linked.
Usually, when you take a snapshot at a milestone, you are able to make a record 
of the requirements. However, you are unable to record the relationships 
between requirements. So when the project is completed, you have a file for each 
of the documents within the project at the various key stages of the 
development, but little idea of what the relationships between the documents 
were at those key stages. 
Intelligent traceability™ means you can record the relationships between 
requirements at each key stage in the development. You do not take a snapshot 
of individual documents. You take a group shot of all the relevant documents, 
with the relationships intact.
Rational DOORS combines the ability to sign off documents that are part of the 
same incremental phase at different times, with intelligent traceability. This 
makes project planning and management easier, and enhances the clarity of your 
project history.

Intelligent Traceability and baseline sets 
A baseline is a read-only snapshot of a module. You can baseline a module 
individually or you can baseline a group of modules as a baseline set.
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Link behavior in baseline sets

To maintain intelligent traceability in your project you must use baseline sets 
when you baseline modules. A baseline set is a group of baselines that you want 
to treat as a single unit for project planning and management purposes. You 
create a baseline set for each phase in your projects development. Once a phase 
is complete and all the necessary modules have been baselined to the baseline 
set, you close the baseline set, and then create one for the next phase. Rational 
DOORS maintains a complete record of requirements, and the relationships 
between them, for each phase in your project’s development.

Note  You can also use baseline sets to reduce the administrative 
overhead of baselining a large group of modules at the same 
time. 

Link behavior in baseline sets
All the links that are made between modules that are to be baselined in a baseline 
set, whether between current module versions, or from a current version to a 
baseline that is already part of the set, are maintained within that set. When the 
phase is completed and all the modules in the set have been baselined, you can 
follow the links between the baselined versions of the modules. This means that 
at any point in the future you can open a baseline of a module at a particular 
stage in your project’s history, and follow the links between the modules in the 
baseline set. This gives you complete traceability at every stage in your project, 
allowing you to see the text of linked requirements as they were at the time they 
were made.

Note  Only links created between modules and/or module 
baselines that are part of a baseline set behave in the way 
described in these diagrams. For information about links 
between modules and/or module baselines that are not part 
of a baseline set, see “Link behavior outside baseline sets,” 
on page 101.

This is best explained with the use of some diagrams that show how links work 
when modules are baselined as part of a baseline set.

1. You have three modules: User Requirements, System Requirements and 
Tests, that you want to baseline in a baseline set. 

There are links 

• From System Requirements to User Requirements
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• From Tests to System Requirements.

2. When you baseline User Requirements the in-link from System 
Requirements is copied to the baseline. At this point, System Requirements 
has two outlinks: one to User Requirements, and one to User Requirements 
(baseline).

3. When you baseline System Requirements:

• The out-link from System Requirements to User Requirements moves 
down into the baseline set.
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Link behavior in baseline sets

• The in-link from Tests to System Requirements is copied to System 
Requirements (baseline).

4. When you baseline Tests in the baseline set, the out-link from Tests to 
System Requirements (baseline) moves down to the baseline set.
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5. The resulting baseline set is a self contained group of baselines. All the 
relationships that existed between the modules at the time they were 
baselined are intact. 
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Link behavior outside baseline sets

6. As your project progresses through the various development phases, you 
build up a series of baseline sets, that show the requirements and their 
relationships when each phase was completed.

Note  You can create links from current modules to module 
baselines. For example, after you baseline the System 
Requirements module in the example above, you can create 
links to that baseline from the Tests module. When you 
baseline the Tests module in the baseline set, the links you 
have made to System Requirements (baseline) are moved 
down into the baseline set. To maintain traceability through 
all the incremental phases of your project, you should ensure 
that when you create a link to a baseline, you create an 
identical link to the current version of that module baseline.

Link behavior outside baseline sets
Not all modules in a project are related in such a crucial way that they require 
sophisticated traceability over time. For links that are only meaningful while they 
are being used in the current version, baseline sets can be an unnecessary 
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overhead. Putting such loosely related documents into a baseline set can detract 
from the importance of documents that are crucially related.
When modules that are linked are baselined outside a baseline set, the links are 
copied to the baseline. These links an only be followed from the baseline to the 
current version of the source or target module. There is no corresponding link 
from the current version to the baseline. Taking the example given in the 
previous section, the links behave as illustrated in the following diagram if the 
modules are not baselined in baseline sets.
For example, the following modules have links to User Requirements:

• System Requirements (baseline 1)

• System Requirements (baseline 2)

• System Requirements

However, User Requirements has just one link, to the current version of System 
Requirements. Having followed a link from System Requirements (baseline x) to 
User Requirements, you cannot then follow that link back to the baseline.
As these links behave differently, the link arrows representing them are different. 
The link arrow for an in-link looks like this: , and for an out-link like this: .
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What is a baseline set definition?

What is a baseline set definition?
A Baseline Set Definition is a template for the Baseline Sets that you create 
during your project’s life cycle. A baseline set is a group of module baselines that 
you want to treat as a unit for project management purposes. You create a 
baseline set definition for each group of modules for which you want to maintain 
intelligent traceability. You can then create incremental baseline sets for each 
phase of the project. The baseline sets are stored together with the baseline set 
definition, so they can be easily accessed and compared at any stage. 

Note  Before you create a baseline set you must ensure that all the 
modules you want to baseline as part of that set are listed in 
the baseline set definition. Only modules that are listed in the 
baseline set definition at the time the baseline set is created 
can be baselined to it. Once the baseline set is closed, you can 
add modules to the definition for the next baseline set.

Creating a baseline set definition
To create a baseline set definition:
1. Select the project or folder that you want to use to manage the baseline set 

definition. You must have modify and create access to the project or folder.

The modules that you want to add to the baseline set definition do not have 
to be contained within this project or folder. You can select them from 
anywhere in the database.

2. Right-click and select Properties.
3. Select the Baseline Set Definitions tab, and then click New.

The New Baseline Set Definition dialog box is displayed.

4. Type a name and, optionally, a description for your baseline set definition. 

5. Click OK.

The Baseline Set Definition dialog is displayed.

6. Click Edit.
The Edit Baseline Set Definition dialog is displayed.

Use this dialog to:

• Add the modules you want to be able to baseline to a baseline set 
contained within this baseline set definition.

• Set access controls for the baseline set definition.
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7. Navigate through your database structure, select the module that you want 
to add to your baseline set definition, and then click Add to add it.

Note  Before you create a baseline set you must ensure that all 
the modules you want to baseline as part of that set are 
listed in the baseline set definition. Only modules that 
are listed in the baseline set definition at the time the 
baseline set is created can be baselined to it. Once the 
baseline set is closed, you can add modules to the 
definition for the next baseline set. 

8. If you do not want your baseline set definition to inherit its access controls 
from the parent project or folder:

a. Select the Access tab.

b. Clear the Inherit from parent box.

c. Click Add to add a new user or group. You can then select the user or 
group, assign access and click OK.

d. Select the user or group, and click Edit to edit its access. Change the 
access as required, and then click OK.

For information about the access controls that apply to baseline sets, see 
“Access controls for baseline set definitions,” on page 106.

9. When you have finished adding modules, and setting access rights, click OK.

The Edit Baseline Set Definition dialog is closed and the 
modules you added to the definition are displayed on the 
Baseline Set Definition dialog box.

Note  You cannot use the Access tab of the View Baseline Set 
Definition dialog to edit the access rights for the baseline set 
definition. To change the access rights you must click the 
Edit button on the Definition tab of the View Baseline Set 
Definition dialog box.

Copying a baseline set definition
When you copy a baseline set definition, you copy the modules that are included 
in the definition and the access controls for the definition. You do not copy any 
baseline sets that have been created from that baseline set definition.
To copy a baseline set definition:
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Renaming a baseline set definition

1. Select the project or folder containing the baseline set definition you want to 
copy.

2. Right-click and select Properties.
3. Select the Baseline Set Definitions tab.

The baseline set definitions are listed.

4. Select the baseline set definition that you want to copy and click Copy.

The Copy Baseline Set Definition dialog box is displayed.

5. Type a new name for the definition in the To box, and optionally a 
description in the New description box.

6. Click OK.

The copy is listed on the Baseline Set Definitions tab of the project or 
folder properties.

Renaming a baseline set definition
To rename a baseline set definition:

1. Select the project or folder containing the baseline set definition you want to 
rename.

2. Right-click and select Properties.
3. Select the Baseline Set Definitions tab.

The baseline set definitions are listed.

4. Select the baseline set definition that you want to rename and click Rename.

The Rename Baseline Set Definition dialog box is displayed.

5. Edit the name or description.

6. Click OK.

The updated name and description are displayed on the Baseline Set 
Definitions tab.
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Access controls for baseline set definitions
The access controls that apply to baseline set definitions are described in the 
following table:

Showing baseline set definitions
1. In the Database Explorer, select the project or folder whose baseline set 

definitions you want to show.

2. Right-click and select Properties.
3. Select the Baseline Set Definitions Tab.

A list of all the baseline set definitions for the project or folder is displayed.

Creating a baseline set
Once you have created your baseline set definition, you create a baseline set. The 
baseline set provides the baseline version number, baseline suffix and baseline 
description for each of the modules that you baseline to the set.

You need this access to a baseline set 
definition

To

Read (R) See the baseline set definition.

Modify (M) Rename the baseline set definition
Change the baseline set definition’s 
description
Add modules to the baseline set 
definition
Remove modules from the baseline set 
definition

Create (C) Create a baseline set definition
Create a baseline set from the baseline 
set definition

Delete (D) Delete the baseline set definition

Admin (A) Change a user or groups access to the 
baseline set definition
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Creating a baseline set

You cannot create a baseline set until you have created the baseline set definition 
upon which it is based. For more information, see “What is a baseline set 
definition?,” on page 103 and “Creating a baseline set definition,” on page 103.

Note  Ensure that all the modules that you want to include in the 
baseline set are listed in the baseline set definition before you 
create the baseline set. You cannot add any more modules to 
the baseline set definition when a baseline set is open. You 
can add more modules when the set is closed.

1. Select the project or folder in which you have created the Baseline Set 
Definition.

2. Right-click and select Properties.
3. Select the Baseline Set Definitions tab.

A list of the baseline set definitions that have been created in the project or 
folder is displayed.

4. Select the baseline set definition from which you want to create a baseline 
set.

5. Click Create Set.
Note  Each baseline set definition can have one open baseline 

set at any one time. If a baseline set is open, you cannot 
create a baseline set, and the Create Set button is 
unavailable.

The View Baseline Set Definition and New Baseline Set dialog boxes are 
displayed.

6. Select the Version for the baseline set, and then type a Suffix and 
Description. 

Note  It is good practise to give your baseline set a suffix. This 
is because modules can belong to more than one baseline 
set, and can be baselined outside the baseline set, so the 
version numbers are not always the same for all the 
baselines in the set. The suffix provides an easy identifier 
for baselines that are part of a particular set.

7. Click OK.

8. The New Baseline Set dialog box is closed and your baseline set is listed on 
the Baseline Sets tab.
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Baselining a module to a baseline set
If a module is included in a baseline set definition, you can choose whether or 
not to baseline the module as part of that baseline set definition.
You can baseline a module to a baseline set in two different ways:

• Using the Baseline Set Definition dialog box

• Creating a new baseline in the module

Using the Baseline Set Definition dialog
1. Select the project or folder in which the baseline set definition containing 

the baseline set you want to baseline to is held.

2. Right-click and select Properties.
3. Select the Baseline Set Definition tab.

The baseline set definitions that have been created in this project are listed.

4. Select the baseline set definition that contains the baseline set you want to 
baseline the module to, and click View.

The Baseline Set Definition dialog box is displayed, and the modules that 
are included in the definition are listed.

Note  The module that you want to baseline to the baseline set 
must be included in this list. If it is not you cannot 
baseline it to the baseline set.

5. Select the Baseline Sets tab. 

All the baseline sets that have been created in this baseline set definition are 
listed. You can only baseline a module to a baseline set if that baseline set is 
open. An open baseline set is denoted by an asterisk (*) in the Open 
column. 

6. Select the open baseline set in the list, and then click the Baselines subtab.

The modules that are available for baselining as part of the baseline set are 
listed.

7. Click Add to Set.
The Extend Baseline Set dialog box is displayed.

8. Select the check boxes of the module or modules that you want to baseline 
as part of the baseline set.

9. Click OK.
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Closing a baseline set

The selected module or modules are baselined. The baseline version number 
and the baseline set suffix are displayed in the Version column next to the 
module that has been baselined.

Note  The version number is the baseline version of the module 
not of the set. This means that modules in the same set 
might have different version numbers. This is because 
modules can be baselined outside the baseline set. They can 
also be included in, and baselined as part of, more than one 
baseline set. The baseline set suffix is the same for all 
baselines in the set and can be used to distinguish baselines in 
this set from baselines in other sets.

Creating a new baseline in the module
1. Click File > Baseline > New in the formal module that you want to 

baseline as part of the baseline set.

The New Baseline dialog box is displayed. Any baselines that have already 
been made of the module are listed in the Existing baselines pane. 

2. Make sure that the correct Baseline Set is selected.

Note  All the options in the dialog are unavailable because the 
module baseline that you create takes its version type 
(major or minor), suffix and description from the 
baseline set to which it is being added. 

3. Click OK.

A confirmation message is displayed showing the baseline set to which the 
baseline will be added. 

4. Click Confirm.

The module is baselined to the baseline set.

Closing a baseline set
When you have baselined all the modules you want to include in the baseline set, 
you close the baseline set. The set is closed automatically by Rational DOORS 
when all the modules that are available in the baseline set definition have been 
baselined to the set.
Once the set is closed, you cannot baseline any more modules to it.
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Note  Links that exist between a baseline in a baseline set and the 
current version of a module that is not part of the baseline 
set are lost when the baseline set is closed.

1. Select the project or folder in which the baseline set definition containing 
the baseline set you want to close is held.

2. Right-click and select Properties.
3. Select the Baseline Set Definition tab.

The baseline set definitions that have been created in this project are listed.

4. Select the baseline set definition that contains the baseline set you want to 
close, and click View.

The Baseline Set Definition dialog box is displayed, and the modules that 
are included in the definition are listed.

5. Select the Baseline Sets tab. 

All the baseline sets that have been created in this baseline set definition are 
listed. The open baseline set is denoted by an asterisk (*) in the Open 
column. 

6. Select the open baseline set.

If you want to check which of the modules that are listed in the baseline set 
definition have actually been baselined to the set, select the Baselines 
subtab

The modules that have been baselined as part of the set have the version 
number and baseline set suffix displayed next to them in the Version 
column.

Note  You can close a baseline set before all the available 
modules have been baselined.

7. Click Close.

If there are modules in the baseline set definition that have not been 
baselined as part of the baseline set, a message is displayed asking if you 
want to close the baseline set anyway.

8. Click Yes.

The baseline set is closed.
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Removing a baseline set definition

Removing a baseline set definition
Removing a baseline set definition does not delete any baselines that have been 
made to baselines sets stored with that baseline set definition. It does remove the 
definition from the project or folder, and with that the record of the baseline sets 
that have been created. You can still open a baseline that is part of a baseline set 
associated with that definition from the current version of the module. However, 
as the baseline set definition is removed you can no longer access the baseline set 
and open all the baselines that have been made to that set from the same place.
To remove a baseline set definition:

1. Select the project or folder containing the baseline set definition you want to 
remove.

2. Right-click and select Properties.
3. Select the Baseline Set Definitions tab.

The baseline set definitions are listed.

4. Select the baseline set definition that you want to remove and click Remove.

5. Click Yes.

The baseline set definition is removed.
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11 Managing Change Proposal Systems
This chapter is for Project Managers and Database Managers.
It describes the tasks carried out by change proposal managers, and contains the 
following topics:

• Creating a Change Proposal System

• Configuring modules for review

• Showing change proposal users

• Adding a new change proposal user

• Changing the role of a change proposal user

• Removing a change proposal user

• Deleting a change proposal system

For information on tasks done by Standard change proposal users and change 
proposal reviewers, see Using Rational DOORS.

Creating a Change Proposal System
Note  When you create a Change Proposal System (CPS), you 

automatically become a change proposal manager for it. 

To create a change proposal system:
1. Log in to Rational DOORS as a Database Manager or a Custom user who 

has the power to create users.

Note  The Administrator user cannot create a CPS.

2. In the left pane of the Database Explorer, select the project you want to 
create a CPS for. You must have full access (RMCDA) to the project.

3. Click Tools > Change Proposal System > Setup > New.

Rational DOORS creates a folder called Change Proposal System under 
the project. This is where all the information about the CPS is stored, 
including the Suggestions and Proposals modules.

Note  Use the procedures described in this chapter and in 
Using Rational DOORS to manage the modules in the 
Change Proposal System folder. Never edit these 
modules directly.
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4. Rational DOORS gives users the option to configure the CPS immediately 
or later.

5. If you do not want to configure the CPS immediately, click No. Users will 
not be able to submit change proposals against the project until it has been 
configured.

6. Click Yes to configure the CPS.

An empty Change Proposal System for <projectname> window is 
displayed.

The rest of this chapter describes how to configure modules and users for the 
change proposal system.

Configuring modules for review
Change proposal managers control which modules are configured for review, 
and which attributes within these modules are included in the review.
Note that by including attributes in a review, you can indirectly let them be seen 
by Rational DOORS users who do not have read access to the attribute value. 
For example, Jim does not have read access to an attribute called Confidential, 
but Sue does. Jim cannot see this attribute when he submits change proposals. 
But when Jim looks at a change proposal submitted by Sue, Jim sees its current 
value, because it is included in Sue’s proposal. If Jim does not have read access to 
the attribute definition, the attribute is not displayed, and he cannot review 
change proposals for it.
To configure modules for review:
1. Log in to Rational DOORS as a Database Manager or a Custom user who 

has the power to create users.

2. In the Database Explorer, select the project whose CPS you want to 
configure.

You must be a change proposal manager for the CPS.

3. Click Tools > Change Proposal System > Setup > Configure.

On the Module tab, a list is displayed of all the modules currently 
configured for review.

4. To add a module to the list:

a. Click Add.

A mini-explorer is displayed.

b. Navigate to and select the module you want to add, and then click OK.
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Showing change proposal users

5. By default, the Object Heading and Object Text attributes are made 
available for review.

To check or change the attributes that are configured for review:

a. Select a module, and then click Attributes.

A list of the attributes you can include in the review is displayed. You 
can include user defined attributes and the following system attributes: 
Object Heading, Object Short Text, and Object Text.

b. Select the check boxes for the attributes you want to include.

c. Click OK.

6. To remove a module from the list:

a. Select the module, and then click Remove.

A message is displayed asking if you really want to remove the module.

b. Click Yes.

7. When you have finished, click OK.

The changes you made to the configuration are applied. This might take 
some time.

If you added a new module:

• A Proposals module is created in the Change Proposal System folder. It 
has a section for each existing change proposal user.

• A linkset is created for links from the new Proposals module to the 
original module.

If you removed a module:

• The Proposals module is deleted and purged from the Change Proposal 
System folder. This does not affect any proposals previously applied to 
the source module, but you lose all the data stored in the Proposals 
module, including history information. 

• The linkset for links from the Proposals module to the original module 
is deleted.

Showing change proposal users
To show change proposal users:
1. Log in to Rational DOORS as a Database Manager or a Custom user who 

has the power to create users.

2. In the Database Explorer, select the project whose CPS you want to look at.
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You must be a change proposal manager for the CPS.

3. Click Tools > Change Proposal System > Setup > Configure.

4. Click the Users tab.

A list of all the users who are currently configured to take part in the review 
is displayed.

5. Use the SHIFT or CTRL keys to select multiple users.

If you click anywhere in the list of users and then type, the highlight moves 
to the name you type. For example, if you type john, the first user whose 
name starts with john is highlighted.

6. Clear the Notify updates by email check box if you do not want any users 
of this CPS to be notified when the status of their proposals changes, or 
when their proposals are added to or removed from a group.

7. Select Reviewer can edit CPs if you want reviewers to be able to modify 
change proposals during the review process.

Adding a new change proposal user
To add a new change proposal user:
1. Log in to Rational DOORS as a Database Manager or a Custom user who 

has the power to create users.

2. In the Database Explorer, select the project whose CPS you want to manage.

You must be a change proposal manager for the CPS.

3. Click Tools > Change Proposal System > Setup > Configure.

4. Click the Users tab.

5. Click Add.

A message telling you that adding new change proposal users does not affect 
any existing change proposal users is displayed. If you add a change proposal 
user who already exists, their change proposal role is not changed.

6. Click OK to continue.

A list of all the users and groups for the database is displayed.

7. Select the users and groups you want to add.

If you want to check which users are in a group, select the group, and then 
click Members. A list of all the users in the group is displayed.

8. In the CP Role box, select the change proposal role for the users.
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Changing the role of a change proposal user

Note  Make sure that every change proposal manager has the 
power to create users. You need this power to manage a 
CPS.

9. Click OK.

10. The list of members on the Users tab now includes the users you selected in 
Step 7.

Notice that if you selected a group, the names of all the users in the group 
are displayed, not the name of the group. Selecting a group provides a quick 
way of selecting all the users who are currently in the group.

Note  If the members of a group change and you want to 
update your change proposal users to reflect the changes, 
simply add the group again. The new members become 
new change proposal users. No changes are made to 
existing users, so users who are no longer in the group 
remain as change proposal users.

11. Click OK.

The new users are added. This might take some time.

For each new user that you added, a new section is created in the 
Suggestions module and in each of the Proposals modules in the Change 
Proposal System folder.

Changing the role of a change proposal user
To change a change proposal user's role:
1. Log in to Rational DOORS as a Database Manager or a Custom user who 

has the power to create users.

2. In the Database Explorer, select the project whose CPS you want to manage.

You must be a change proposal manager for the CPS.

3. Click Tools > Change Proposal System > Setup > Configure.

4. Click the Users tab.

5. Select the user whose role you want to change, and then click Edit.
Note  You cannot change your own role. If you want to change 

your role, get another change proposal manager to do it. 
Make sure that every change proposal manager has the 
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power to create users. You need this power to manage a 
CPS.

6. In the CP Role box, select the role you want.

7. Click OK.

8. Click OK.

Removing a change proposal user
Removing a change proposal user does not affect any existing modules in the 
Change Proposal System folder. The user still has a section in the Suggestions 
module and Proposals modules.
Removing a user only affects Proposals modules created from now on. Next 
time you add a module to the review, the user will not get a section in it.
To remove a change proposal user:
1. Log in to Rational DOORS as a Database Manager or a Custom user who 

has the power to create users.

2. In the Database Explorer, select the project whose CPS you want to manage.

You must be a change proposal manager for the CPS.

3. Click Tools > Change Proposal System > Setup > Configure.

4. Click the Users tab.

5. Select the user you want to remove, and then click Remove.

Note  You cannot remove yourself. If you want to remove 
yourself, get another change proposal manager to do it.

6. Click OK.

7. Click OK.

Deleting a change proposal system
To delete a change proposal system:
1. Log in to Rational DOORS as a Database Manager or a Custom user who 

has the power to create users.

2. In the Database Explorer, select the project whose CPS you want to delete.

You must be a change proposal manager for the CPS, and you must have 
delete access to the project.
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Deleting a change proposal system

3. Click Tools > Change Proposal System > Setup > Delete.

A message is displayed asking if you really want to delete the CPS.

4. Click Yes.

The Change Proposal System folder of the project is deleted and purged.
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12 Managing the database server
This chapter is for Database Managers and users who have the power to manage 
the database.
It contains the following topics:

• Changing the password for the server

• Starting the server

• Stopping the server

• Removing or reinstalling the server on Windows

• Installing and removing additional database server services

• Checking what database server services are running on the machine

• Changing the port the server uses

• Checking which users are connected to the server

• Cleaning up unwanted connections and locked files

• Summary of dbadmin command switches

Changing the password for the server
When you use the server manager or dbadmin command to manage the Rational 
DOORS database server, you need to supply the server’s password.
When you first install the server, its password is blank, which means that anyone 
can manage it. Change the server’s password to make sure that ordinary users 
cannot manage the server.
The way that you change the server’s password depends on which computer the 
server is running.

• Changing the password on Windows

• Changing the password on UNIX

Note  If you forget the Rational DOORS database server’s 
password, contact Rational DOORS customer support, who 
will talk you through a recovery procedure to reset the 
password. 
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Changing the password on Windows

1. Click Start > Programs > IBM Rational > IBM Rational Lifecycle 
Solutions Tools > IBM Rational DOORS 9.2 > DOORS Database 
Server Admin.

This runs the Server Manager.

2. Connect to the server whose password you want to change:

a. In the Database box, specify the location of the server, using the 
format port@computer:

b. In the Password box, type the server’s current password.

c. Click Refresh List.
3. Click Change password.

4. Type the new password into both the New password and the Confirm 
new password boxes, and then click OK.

5. Click Close to exit the Server Manager.

Changing the password on UNIX

Note  In a mixed architecture network, you can run the Server 
Manager on a Windows computer to change the password of 
your UNIX server. 

To change the password on a UNIX computer:
1. Change your working directory to $Rational DOORSHOME/bin.

2. Enter the following command:
dbadmin -data port@computer [-password oldpassword] 
-newpassword newpassword

Where Is

port The port the server is using (by default, 36677).

computer The name of the computer the server is running on.

Where Is

port The port the server is using (by default, 36677).
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Starting the server

Starting the server
The way that you start the Rational DOORS database server depends on which 
computer it is running on:

• Windows

• UNIX

Starting the server on Windows

On Windows, the Rational DOORS database server runs as a service. Like all 
services, you can start and stop it using the Control Panel.
The server is automatically started when the computer that it is running on is 
started.
When the server starts up, it reads the following configuration information from 
the registry. 

computer The name of the computer the server is running on.

oldpassword The current password (omit the -password switch if the 
password is currently blank).

newpassword The new password.

Value in registry Description

portnumber The port number that the server uses. By default, it is 36677.
Do not use a port number less than 1000, or the server must 
run in privileged mode. Do not run the server in privileged 
mode.

serverdata Where the Rational DOORS data is. This is the full path to 
the folder in which all the database files are stored.

home The Rational DOORS home directory. This is the full path to 
the folder that Rational DOORS was installed into.

Where Is
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When you start the Rational DOORS database server, you can optionally set it to 
log database activity. To enable logging on Windows, you must create the 
following registry values:

To start the server on Windows:
1. Open Administrative Tools in the Control Panel, and then select 

Services.

2. In the list of services, select DOORS Database Server 9.2, and then click 
Start.

When the server starts up, it reads configuration information from the registry, 
unless you use switches on the doorsd command to override the settings in the 
registry. 

Value in registry Description

logfile The path to the file in which the server logging will be 
contained.

loglevel The level of logging, 1 being the lowest and 6 being the most 
verbose.

Value in 
registry

Switch 
(abbreviation)

Description

portnumber -portnumber

(-p)

The port number that the server uses. By 
default, it is 36677.
Do not use a port number less than 1000, or 
the server must run in privileged mode. Do 
not run the server in privileged mode.

serverdata -serverdata

(-s)

Where the Rational DOORS data is. This is 
the full path to the folder in which all the 
database files are stored.

home -home

(-h)

The Rational DOORS home directory. This 
is the full path to the folder that Rational 
DOORS was installed into (the folder that 
has a bin folder which contains the 
doorsd.exe file).
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Starting the server

You can also set the server to log database activity using the -logfile and 
-loglevel arguments on the doorsd command.

Starting the server on UNIX
When the Rational DOORS database server starts up, it reads configuration 
information from environment variables, unless you use command line switches 
on the doorsd command to override them.

Value in 
registry

Switch 
(abbreviation)

Description

logfile -logfile (-l) The path to the file in which the server 
logging will be contained

loglevel -loglevel (-L) The level of logging, 1 being the lowest and 6 
being the most verbose.

Environment 
variable

Switch 
(abbreviation)

Description

PORTNUMBER -portnumber

(-p)

The port number that the server uses. By 
default, it is 36677.
Do not use a port number less than 
1000, or the server must run in 
privileged mode (as root). Do not run 
the server in privileged mode.

SERVERDATA -serverdata

(-s)

Where the Rational DOORS data is. 
This is the full path to the folder in 
which all the database files are stored.

Rational 

DOORSHOME

-home

(-h)

The Rational DOORS home directory. 
This is the full path to the folder that 
Rational DOORS was installed into (the 
folder that has a bin folder which 
contains the doorsd file).
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When you start the Rational DOORS database server, you can set it to log 
database activity. On UNIX, these are arguments to the doorsd command, as 
described in the following table.

To start the server from a UNIX computer:
1. Log in as the Rational DOORS owner user.

You specify the Rational DOORS owner when you install Rational DOORS. 
This user owns the data directory and all the files in it.

2. Change your working directory to $Rational DOORSHOME/bin.

3. Enter the following command, using switches if you want to override the 
environment variable settings:
./doorsd

Stopping the server
You might need to stop the Rational DOORS database server because you want 
to reinstall or upgrade your Rational DOORS software.

Caution  If anyone is using Rational DOORS when you stop the 
server, they might lose data. 

Before you stop the server, give your users adequate notice that you are about to 
stop the server, and ask them to exit Rational DOORS. Use the Server Manager 
to check that there are no user connections to the server (see “Checking which 
users are connected to the server,” on page 131). If a client is disconnected from 
the server, and is not reconnected within two minutes, the client session is 
considered invalid and any unsaved work is lost.
The way that you stop the Rational DOORS database server depends on which 
computer it is running on:

• Windows

• UNIX

Switch 
(abbreviation)

Parameter Description

-logfile (-l) Path to a file The path to the file in which the server 
logging will be contained

-loglevel (-L) Integers 1 to 6 The level of logging. 1 being the lowest 
and 6 being the most verbose.



Managing Rational DOORS           127

Stopping the server

Stopping the server on Windows

On Windows, the Rational DOORS database server service is automatically 
stopped when the computer is shut down. To stop the Rational DOORS 
database server service without shutting down the computer, use either the 
Control Panel or the Server Manager.

Note  You can create a shortcut that stops the server (see 
“Summary of dbadmin command switches,” on page 135).

Stopping the server using the Control Panel

The Control Panel can be used to stop the Rational DOORS database server 
service on Windows.
To stop the server on Windows:
1. Open Administrative Tools in the Control Panel, and then select 

Services.

2. In the list of services, select DOORS Database Server 9.2, and then 
right-click Stop.

Stopping the server using the server manager

The Server Manager can be used to stop the Rational DOORS database server 
on Windows.

1. Click Start > Programs > IBM Rational > IBM Rational Lifecycle 
Solutions Tools > IBM Rational DOORS 9.2 > DOORS Database 
Server Admin.

2. This runs the Rational DOORS Database Server Administration Tool.

3. Connect to the server you want to stop:

a. In the Database server box, specify the location of the server, using the 
format port@computer:

b. In the Password box, type the server’s password.

c. Click Refresh List.
4. Click Shutdown Server.

Where Is

port The port the server is using (by default, 36677).

computer The name of the computer the server is running on.
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A message is displayed asking you to confirm that you really want to stop the 
server. 

5. Click Yes.

6. Click Close to exit the Server Manager.

Stopping the server on UNIX
Note  In a mixed architecture network, you can run the Server 

Manager on a Windows computer to stop your UNIX server.

To stop the server from a UNIX computer: 
1. Change your working directory to $Rational DOORSHOME/bin.

2. Enter the following command:
dbadmin -data port@computer -killserver [-password password]

Removing or reinstalling the server on Windows
To remove or reinstall the Rational DOORS database server service on 
Windows:
1. Get a DOS command prompt:

a. Click Start > Run.

b. In the Open box, type cmd.

c. Click OK.

2. Use the cd (change directory) command to change your directory to the 
Rational\DOORS\9.2\bin folder. For example, type:
cd "c:\program files\IBM\Rational\DOORS\9.2\bin"

3. Type this command to remove the Rational DOORS database server 
service:
doorsd -remove

Where Is

port The port the server is using (by default, 36677).

computer The name of the computer the server is running on.

password The server’s password (omit the -password switch if the 
password is currently blank).
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Installing and removing additional database server services

4. Type this command to reinstall the Rational DOORS database server 
service:
doorsd -install

The service starts automatically whenever your computer restarts, and stops 
whenever it shuts down.

Installing and removing additional database server services
You can install and run multiple Rational DOORS database server services on 
one machine.
To install another Rational DOORS database server service on a Windows 
machine:

1. Open a command prompt.

2. Type the following command:
doorsd -minstall -p portnumber -s server data path

where portnumber is the port the new service uses and server data path 
is the servdata path. 

Note  The new service must use a different port number than 
existing services.

For example:
doorsd -minstall -p 36666 -s  
“C:\Program Files\IBM\Rational\DOORS\9.2\newdoorsdata”

3. Press RETURN.

The new service is installed, and a new Config folder is created in the 
registry, with a unique ID number. The service is also displayed in the 
Services window with the same unique ID number.

4. Start the service by highlighting it in the Services window and selecting 
Start from the Action menu, or by clicking Start Service on the toolbar.

To remove a database server service, other than the default service:

1. Open a command prompt.

2. Type the following command:
doorsd -mremove -i unique ID

where unique ID is the ID number that was assigned to the service when it 
was created.
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The service is removed.

Checking what database server services are running on the machine
To see a list of the Rational DOORS database server services that are running on 
your Windows machine:

1. Open a command prompt.

2. Type the following command:
doorsd -list

The services that are running are listed in the window.

Changing the port the server uses
By default, the Rational DOORS database server uses port number 36677. This 
port is not normally used by other software. However, if you want to install 
software that needs to use this port, you can configure Rational DOORS to use a 
different port.

Note  Do not use a port number less than 1000, or the server must 
run in privileged mode. Do not run the server in privileged 
mode.

To change the port on Do this

Windows Edit the PortNumber line in the registry. For 
example, to get the server to use port number 44889, 
right-click on PortNumber and select Modify then 
type 44889 into the Value data field. The next time 
the server starts up it uses the new port.
Alternatively, if you are starting the server from the 
command line or a shortcut and you want to 
temporarily use a different port, use the 
-portnumber switch. You can abbreviate this switch 
to -p.

UNIX Change the value of the PORTNUMBER environment 
variable or use the -portnumber switch on the 
command line. You can abbreviate this switch to -p.
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Checking which users are connected to the server
The Rational DOORS client only makes a connection to the server when it 
needs to read data from disk or write data to disk. It closes the connection as 
soon as the data transfer is completed.
The way that you check which users currently have a connection to the server 
depends on which computer the server is running on:

• Windows

• UNIX

Checking user connections on Windows
To check which users currently have a connection to a server running on 
Windows:
1. Click Start > Programs > IBM Rational > IBM Rational Lifecycle 

Solutions Tools > IBM Rational DOORS 9.2 > DOORS Database 
Server Admin.

This runs the Server Manager.

2. Connect to the server whose connections you want to check:

a. In the Database box, specify the location of the server, using the 
format port@computer:

b. In the Password box, type the server’s password.

c. Click Refresh List.
d. In the Users and locked files box, a list is displayed of all the users 

who currently have a connection, in the form user_name@computer.

Indented below the user name is a list of all the files the user currently has 
locked.

3. Click Refresh List to refresh the list of users and locked files.

4. Click Close to exit the Server Manager.

Where Is

port The port the server is using (by default, 36677).

computer The name of the computer the server is running on.
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Checking user connections on UNIX

Note  In a mixed architecture network, you can run the Server 
Manager on a Windows computer to check connections to 
your UNIX server and vice versa. 

To check user connections from a UNIX computer:
1. Change your working directory to $Rational DOORSHOME/bin.

2. Type the following command to list all the user connections:
dbadmin -data port@computer [-password password] -userlist

For example:
marg$ dbadmin -data 36677@homer -userlist 
-I- DBADMIN 6823:ptfrint@bart 
-I- DBADMIN 8978*admin@marg
marg$ dbadmin -data 36677@hog -killprocess 6823

A list is displayed of all the users who currently have a connection, in the form 
channel-id:user_name@computer.
The connection made by the dbadmin command has the user name admin, and 
an asterisk before the user name, instead of a colon.

Cleaning up unwanted connections and locked files
If a user’s computer crashes or hangs, the Rational DOORS database server 
might have an unwanted connection for the user and locked files associated with 
that connection.

Note  Stopping and then restarting the server automatically gets rid 
of all unwanted connections and locked files.

The way that you cleanup unwanted connections and locks depends on which 
computer the server is running on:

• Windows

Where Is

port The port the server is using (by default, 36677).

computer The name of the computer the server is running on.

password The server’s password (omit the -password switch if the 
password is currently blank).
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Cleaning up unwanted connections and locked files

• UNIX

Cleaning up on Windows 
To cleanup unwanted connections and locks when the server is on a 
Windows computer:
1. Click Start > Programs > IBM Rational> IBM Rational Lifecycle 

Solutions Tools > IBM Rational DOORS 9.2 > DOORS Database 
Server Admin.

This runs the Server Manager.

2. Connect to the server you want to cleanup.

a. In the Database box, specify the location of the server, using the 
format port@computer:

b. In the Password box, type the server’s current password.

c. Click Refresh List.
3. To delete a connection, select it in the Users and locked files box, and then 

click Disconnect User.
Note  Be careful not to disconnect a user who is currently 

connected or unlock a file a user is currently accessing, 
or you could corrupt your database.

4. To unlock a file, select it in the Users and locked files box, and then click 
Unlock File.

5. Click Close to exit the Server Manager.

Cleaning up on UNIX
Note  In a mixed architecture network, you can run the Server 

Manager on a Windows computer to cleanup connections to 
your UNIX server.

To cleanup unwanted connections and locks from a UNIX computer:

Where Is

port The port the server is using (by default, 36677).

computer The name of the computer the server is running on.
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1. Change your working directory to $Rational DOORSHOME/bin.

2. Type this command to list all the user connections:
dbadmin -data port@computer [-password password] -userlist

and this command to delete a connection:
dbadmin -data port@computer [-password password] -killprocess 
channel_identifier

For example:
marg$ dbadmin -data 36677@homer -userlist 
-I- DBADMIN 6823:ptfrint@bart 
-I- DBADMIN 8978*admin@marg
marg$ dbadmin -data 36677@hog -killprocess 6823

Notice that the connection made by the dbadmin command has the user 
name admin, and an asterisk before the user name, instead of a colon.

3. Type this command to list all the locked files:
dbadmin -data port@computer [-password password] -locklist

and this command to unlock a file:
dbadmin -data port@computer [-password password] -unlock 
channel_identifier

where channel_identifier is the channel identifier displayed by the 
-userlist switch.

Note  Be careful not to disconnect a user who is currently 
connected or unlock a file a user is currently accessing, 
or you could corrupt your database.

Where Is

port The port the server is using (by default, 36677).

computer The name of the computer the server is running on.

password The password (omit the -password switch if the 
password is currently blank).

channel_identifier The channel identifier displayed by the -userlist 
switch.
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Summary of dbadmin command switches
You can use the dbadmin command to manage the Rational DOORS database 
server:

dbadmin -data port@computer [switches]

The following table shows the switches and any abbreviations:

Switch 
(abbreviation)

Parameter Description

-data

(-d)

port@computer Where the Rational DOORS 
data is. This specifies the port 
number that the server is using 
and the name of the computer 
that it is running on.

-killprocess

(-k)

channel_identifier Deletes a user connection.

-killserver

(-K)

Stops the server.

-locklist

(-l)

Lists all the files that are 
currently locked. The 
channel_identifier is 
displayed by -locklist.

-outfile

(-o)

filename Sends output to a file (use with 
the -locklist and -userlist 
switches).

-password

(-P)

password The server’s current password.

-newpassword

(-p)

newpassword The server’s new password.

-unlock

(-U)

channel_identifier Unlocks a locked file. The 
channel_identifier is 
displayed by -locklist.

-userlist

(-u)

Lists all the user connections.
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For example, you could create a shortcut that shuts down the server:

• Create a shortcut to dbadmin.exe, in the Rational DOORS\9.2\bin 
folder. 

• Use the -killserver switch, which stops the server.

-serverLogging loglevel 1 - 6 Allows the user to change the 
level of logging on the server 
without having to restart it first. 
Assumes that doorsd has 
already been started with the 
loglevel and logfile 
parameter in place. For more 
information about these 
parameters, see “Starting the 
server,” on page 123.

-tdsUserFilterLimit string Allows limits to be set on RDS 
user searches.

-tdsGroupFilterLimit string Allows limits to be set on RDS 
group searches.

Switch 
(abbreviation)

Parameter Description
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13 Managing partitions
For an introduction to partitions, see About partitions, which is in the online help 
and Getting Started with Rational DOORS.
This chapter is for Database Managers, Project Managers, and users who have 
the power to partition data. It contains the following topics:

• Partitions

• Synchronization

• The three files

• Creating a partition definition

• Showing partition definitions

• Editing a partition definition

• Removing a partition definition

• Exporting a partition

• Showing exported partitions

• Importing a partition

• Showing imported partitions

• Showing imported partition details

• Adding data to an imported partition

• Synchronizing an imported partition

• Synchronizing an exported partition

• Returning an imported partition

• Rejoining a partition

• Recovering a partition

Partitions
Partitions let you import modules from another database, and edit them locally.
The database where the modules came from is called the home database. Your 
database is the away database.
This is the sequence of events at the home and away databases:
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1. A user at the home database creates a partition definition.

The definition describes what data is in the partition, and what access rights 
users at the away database can have to the data.

2. The user at the home database exports the partition.

This creates a partition file and copies the data described by the partition 
definition to the file.

For any module that can be edited at the away database, Rational DOORS 
locks the local copy, making it read-only.

Each module in the partition is either read-only at the home database or 
read-only at the away database. You cannot edit the same module at both 
databases.

3. The user at the home database sends the partition file to the user at the away 
database.

4. The user at the away database imports the partition.

This copies the data from the partition file into the away database.

5. Users at the away database edit the data. Note that partitioned in modules 
cannot be set up for shareable edit. This is because users in the away 
database do not have administrative access to objects in partitioned in 
modules.

6. When they have finished, they return the imported partition.

This creates a return file and copies the partition data to the file. You can 
choose to either:

• Remove all the partition data from the away database.
• Keep the partition data in the away database, but reset its status to make 

it look like normal local data.

7. The user at the away database sends the return file to the user at the home 
database.

8. The user at the home database rejoins the partition, using the return file.

Rational DOORS copies the data from the return file and removes the locks 
applied in Step 2, so that the data is no longer read-only at the home 
database.

Caution  Although it is possible to create a partition definition in the 
away database that includes modules that are part of an 
imported partition, this is not supported. You might find that 
you cannot rejoin or recover data to either partition.
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Synchronization

Synchronization
Any module that can be edited at the away database remains read-only at the 
home database until the partition is rejoined. Meanwhile, as users at the away 
database edit the module, the read-only copy at the home database becomes 
out-of-date.
So you should regularly synchronize the two databases to feed the changes 
made at the away database back into the home database:

• A user at the away database creates a synch file, which contains the updates 
made at the away database.

• The away user sends the synch file to the user at the home database.

• The home user synchronizes their database using the synch file. The data is 
copied from the synch file back into the home database, so that both 
databases are now synchronized.

The three files
You use three different files to partition, synchronize and return data. They all 
have the .par file type.

Creating a partition definition
Make sure there are no active change proposals against objects in any of the 
modules you plan to include in the partition definition. If modules included in 
the partition definition have active change proposals against them in the home 

File Description

Partition file Used to transfer data from the home database to the away 
database.
Read-only locks at the home database stop users at the home 
database from editing any modules that can be edited at the away 
database.

Synch file Used to transfer updates from the away database to the home 
database, to synchronize both databases.

Return file Used to transfer the final updates from the away database back to 
the home database. The read-only locks at the home database are 
removed, allowing users at the home database to edit the data.
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database, the project will be locked in the away database, even if the modules are 
partitioned with read-only access.
To create a partition definition:
1. At the home database, log in to Rational DOORS as a project manager, 

database manager, or custom user who has the power to partition data. 

2. In the Database Explorer, select the project that you want to create a 
partition definition for, and then click File > Properties. 
You must have create access to the project.

3. Click the Partition Definitions tab.

4. Either click New to create the new partition definition from scratch, or 
select the partition definition you want to copy then click Copy.

Note  Copying an existing definition saves time because you do 
not have to type in so much information.

5. In the Name box, type the name of the new partition definition.

6. If you want to enter additional information about the partition definition, 
type it in the Description box.

7. Click OK.

The Edit Partition Definition window is displayed.

8. The top of the screen is like the Database Explorer. Select the modules you 
want to include in the partition definition in the right pane. You can only 
select modules that are in the project you selected in Step 2.

9. Use the with access rights check boxes to specify the maximum access 
rights you want users to have at the away database. These limit the access 
rights that can be set at the away database.

For example, if you only select the Read and Modify check boxes:

• No-one at the away database has create or delete access.

A user with admin access at the away database can specify create and 
delete access, but these access rights are ignored.

• A user with admin access at the away database can restrict the access for 
particular users or groups further. For example, they might let the QA 
group have read and modify access and give everyone else read access.

10. Click Add Selected Modules to add the modules to the partition with the 
access rights specified.
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The selected modules are listed in the box at the bottom of the screen. This 
shows all the data included in the partition. The attributes in each module 
inherit the access rights that you set when you add the module to the 
partition list. 

Note  If you add a module to the partition with a certain set of 
access rights, for example Read, and then change your 
mind and add the module again allowing Read and 
Modify access, the attributes in the module will still have 
Read access. If you want the attributes to inherit new 
access rights, you must remove the module from the 
partition definition and add it again with the correct 
access rights.

11. By default, the partition includes all the module’s attributes. 

If you do not want to include all the attributes for a particular module:

a. Select the module in the list of modules at the bottom of the screen, and 
then click Edit Attributes.

b. Clear the attributes that you do not want to include in the partition.

The Access column shows the maximum access rights at the away 
database.

c. If you want to change the maximum access rights at the away database 
for a particular attribute, select the attribute, and then click Edit Access.

d. Select the boxes for the access rights you want, and then click OK.

e. In the Edit Partition Attributes dialog box, click OK.

12. By default, the partition includes all the views for each of the modules you 
add to the partition. 

If you do not want to include all the views for a particular module:

a. Select the module in the list of modules at the bottom of the screen, and 
then click Edit Views.

b. Clear the views that you do not want to include in the partition.

The Access column shows the maximum access rights at the away 
database.

c. If you want to change the maximum access rights at the away database 
for a particular view, select the view, and then click Edit Access.

d. Select the boxes for the access rights you want, and then click OK.
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e. In the Edit Partition Views dialog box, click OK.

13. In the Edit Partition Definition window, click OK.

The Select Linksets dialog box is displayed if you selected link modules and 
the set of modules you selected included the source and target modules for 
their linksets.

The Select Linksets dialog box shows all the linksets you could include in 
the partition. For each linkset, it shows the source module, the target module 
and the link module. It only shows a linkset if you selected all three modules 
in the Edit Partition Definition window.

Note  Any links that are made suspect as a result of changes 
made to source or target objects in the away database are 
not marked as suspect when the partition is 
synchronized or rejoined.

14. Select the check boxes for the linksets you want to include, and then click 
OK.

Showing partition definitions
To show partition definitions:
1. In the Database Explorer, select the project whose partition definitions you 

want to show, and then right-click Properties.
2. Click the Partition Definitions tab.

A list of all the partition definitions for the project is displayed.

Editing a partition definition
To edit a partition definition:
1. At the home database, log in to Rational DOORS as a project manager, 

database manager, or custom user who has the power to partition data. 

2. In the Database Explorer, select the project whose partition definition you 
want to edit, and then right-click Properties. 

You must have modify access to the project.

3. Click the Partition Definitions tab.

4. Select the partition definition you want to edit, and then click Edit.
The Edit Partition Definition window is displayed. At the bottom of the 
screen is a list of all the modules in the partition.
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Editing a partition definition

5. To remove a module from the partition definition, select the module, and 
then click Remove.

6. To add a module to the partition definition, use the explorer in the top half 
of the screen. Select the module in the right pane, and then click Add 
Selected Modules.

Notice that the explorer panel only lets you select modules in the project you 
selected in Step 2. You cannot add modules from other projects.

Note  If you want to change the access rights for a module that 
has already been included in the partition, you should 
remove the module and add it again with the new access 
rights. If you overwrite a module that is already included 
in the partition definition, the module’s access rights are 
updated, but the access rights for the attributes in the 
module are not.

7. If the Attributes column says All attributes for a module, the partition 
includes all the module’s attributes.

To control which attributes are included in the partition definition for 
a particular module:
a. Select the module in the list of modules at the bottom of the screen, and 

then click Edit Attributes.

b. Select the attributes that you want to include in the partition.

The Access column shows the maximum access rights at the away 
database.

c. If you want to change the maximum access rights at the away database 
for a particular attribute, select the attribute, and then click Edit Access.

d. Select the check boxes for the access rights you want, and then click OK.

e. In the Edit Partition Attributes dialog box, click Close.

8. If the Views column says All views for a module, the partition includes all 
the module’s views.

To control which views are included in the partition definition for a 
particular module:
a. Select the module in the list of modules at the bottom of the screen, and 

then click Edit Views.

b. Select the views that you want to include in the partition.
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The Access column shows the maximum access rights at the away 
database.

c. If you want to change the maximum access rights at the away database 
for a particular view, select the view, and then click Edit Access.

d. Select the boxes for the access rights you want, and then click OK.

e. In the Edit Partition Views dialog box, click OK.

9. In the Edit Partition Definition window, click OK.

The Select Linksets dialog box is displayed if you selected link modules and 
the set of modules you selected included the source and target modules for 
their linksets.

The Select Linksets dialog box shows all the linksets you could include in 
the partition. For each linkset, it shows the source module, the target module 
and the link module. It only shows a linkset if you selected all three modules 
in the Edit Partition Definition window.

10. Select the check boxes for the linksets you want to include, and then click 
OK.

Removing a partition definition
To remove a partition definition:
1. At the home database, log in to Rational DOORS as a project manager, 

database manager, or custom user who has the power to partition data. 

2. In the Database Explorer, select the project whose partition definition you 
want to remove, and then right-click Properties. 
You must have delete access to the project.

3. Click the Partition Definitions tab.

4. Select the partition definition you want to remove, and then click Remove.

5. A message is displayed asking if you really want to remove the partition 
definition. Click Confirm.

6. On the project properties sheet, click OK.

Exporting a partition
You cannot export a partition if either the project or any of the modules in the 
partition are open.
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Exporting a partition

Note  In the Database Explorer, the folder or project selected in 
the left pane is open and has an open folder icon  or an 
open project icon . Its parent folder or project is also 
open, and so are all the folders and projects above it in the 
database tree, although they do not have open folder or open 
project icons. 
When a module is open, all the folders and projects above it 
in the database tree are also open.

To export a partition:
1. At the home database, log in to Rational DOORS as a project manager, 

database manager, or custom user who has the power to partition data. 

2. In the Database Explorer, select the project whose partition you want to 
export, and then right-click Properties. 
You must have modify access to the project.

3. Click the Partition Definitions tab.

4. Select the partition definition that describes the data you want to export, and 
then click Export.
You must have admin access to all the modules in the partition.

5. In the Partition file name box, type the name of the partition file that you 
want to write the data to, or use Browse to locate it.

6. In the Partition name box, type the name you want to give the exported 
partition.

This name is used for the partition folder at the away database.

7. If you want to include a comment for the users at the away database, type it 
in the Comment box.

8. Click OK.

Rational DOORS creates the partition file and copies the data described by 
the partition definition to it. 

Rational DOORS places a read-only lock on any modules in the home 
database that were not read-only in the partition. Each module in the 
partition is either read-only at the home database or read-only at the away 
database. You cannot edit the same module at both databases.

9. Send the partition file to a user at the away database, so that they can import 
the partition.
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Showing exported partitions
To show exported partitions:
1. In the Database Explorer, select the project whose exported partitions you 

want to show, and then right-click Properties.
2. Click the Exported Partitions tab.

A list of all the exported partitions for the project is displayed.

Note  If you export a partition and set all its away database 
access rights to read-only, it does not appear on this list. 
This list only shows partitions that were exported with 
some modules not set to read-only.

Access rights for imported partitions
When a partition definition is created, access rights are assigned to each module 
in the partition. The access rights that are assigned for each module are the 
maximum rights that any user has to the data in the away database. 
The access rights of users and groups in the away database can be further 
restricted by setting access rights on the project into which the partition will be 
imported. When the data is initially imported into the project it inherits the 
restricted access rights, so if the modules are partitioned with full access, but a 
user or group has read-only access to the parent project, they will have read-only 
access to the data in the partition. 
You should make sure that the access rights that users and groups have to the 
parent project are sufficient before you import a partition. Once the partition is 
imported, you cannot give existing users increased access to existing attributes. 
Any users who do not have specific access rights for the parent project assigned 
before the partition is imported will have the access rights of the Everyone else 
group.

Importing a partition
To import a partition:
1. At the away database, log in to Rational DOORS as a project manager, 

database manager, or custom user who has the power to partition data. 

2. In the right pane of the Database Explorer, select the folder or project that 
you want to import the data into.

You must have create access to this folder or project.
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Showing imported partitions

You cannot import a partition into a folder that is not in a project. The 
project does not have to be an immediate parent, but there must be a project 
at some point above the folder in the hierarchy.

3. Click File > Import Partition.

4. In the Partition file name box, type the name of the partition file that 
contains the data you want to import, or use Browse to locate it.

5. Click OK.

A screen that shows the following information about the partition is 
displayed:

• The name of the partition file
• The name of the partition
• Any comment made by the user at the home database who created the 

partition
• The target project or folder that the partition is to be imported under, 

that you selected in Step 2

6. Click Import.
Rational DOORS creates a partition folder underneath the target project or 
folder. The partition folder has the same name as the partition.

Rational DOORS copies all the partition data into the partition folder. If 
necessary, it creates folders within the partition folder to retain the hierarchy 
of the modules at the home database.

Note  If you create a partition definition that contains modules with 
traceability columns, and restore it to another database, the 
traceability columns will not display any information. To 
display the traceability information in the restored project, 
you must add the traceability column again.

Caution  If your partition contains subfolders, and you move a 
subfolder to another part of the away database, you will 
be unable to edit the partition definition, or rejoin, or 
recover the partition.

Showing imported partitions
To show imported partitions:
1. In the Database Explorer, select the project whose imported partitions you 

want to show, and then right-click Properties.
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2. Click the Imported Partitions tab.

A list of all the partitions that are currently imported into the project and 
that have not yet been returned is displayed.

Showing imported partition details
To show imported partition details:
1. In the Database Explorer, select the project that contains the partition 

whose details you want to show, and then right-click Properties.
2. Click the Imported Partitions tab.

3. Select the partition, and then click Details.

Details about the partition are displayed.

The available details are listed in the following table:

Item Description

Partition name The name of the partition. This is the same as the name of 
the partition folder at the local (away) database.

Description Additional information added by the person who created 
the partition file at the home database.

Definition name The name of the partition definition.

Exported by The user name of the person who created the partition 
file at the home database.

Date exported When the partition file was created at the home database.

Date imported When the partition was imported into the local (away) 
database.

Date synchronized When the partition was last synchronized. This is when 
someone at the local (away) database last created a synch 
file.

Synchronized by The user name of the person at the local (away) database 
who created the last synch file.

Type Whether the partition is read-only or not.
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Adding data to an imported partition

For more information about how Rational DOORS handles dates, see 
“How date and time are recorded,” on page 17.

4. Click Close.

Adding data to an imported partition
Before you synchronize or return an imported partition, you might want to add 
data to it.
You can add formal modules and link modules. They must be in the partition 
folder. Once you have added the modules to the partition, they look like they 
were imported from another database, just like the other modules in the 
partition. You cannot subsequently remove them from the partition.

Note  You cannot add data to a read-only imported partition.

If you have added new linksets to link modules that were included in the original 
partition from the home database, you must add the new linksets to the partition, 
or they will not be included when it is returned to the home database.
You can also add child folders and projects to the imported partition, which can 
contain new formal modules and link modules. The new folders and projects 
must also be in the partition folder. If you have created links between the new 
modules in the child directory, the directory must be a folder. If you have created 
a child project, links between modules that are held in that project are lost when 
the partition is rejoined. This is a limitation of the software, and only affects 
projects that are added to imported partitions in the away database.
To add data to an imported partition:
1. At the away database, log in to Rational DOORS as a project manager, 

database manager, or custom user who has the power to partition data. 

2. In the Database Explorer, select the project that contains the partition, and 
then right-click Properties.

3. Click the Imported Partitions tab.

4. Select the partition that you want to add the data to, and then click Add 
Data.

5. Select the modules you want to add to the partition.

The top of the screen is like the Database Explorer. Use it to select the 
modules you want to add in the right pane, and then click Add Selected 
Modules.
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The selected modules are added to the box at the bottom of the screen, 
which shows all the data in the partition. 

Notice that the explorer panel only lets you select modules in the partition 
folder.

The maximum access rights at the other database are always read, modify, 
create and delete. The with access rights check boxes are unavailable.

6. By default, the partition includes all the attributes for each module you add 
to the partition.

If you do not want to include all the attributes for a particular module:

a. Select the module in the list of modules at the bottom of the screen, and 
then click Edit Attributes.

b. Clear the attributes that you do not want to include in the partition.

7. By default, the partition includes all the views for each of the selected 
modules. 

If you do not want to include all the views for a particular module:

a. Select the module in the list of modules at the bottom of the screen, and 
then click Edit Views.

b. Clear the views that you do not want to include in the partition.

c. In the Edit Partition Views dialog box, click OK.

8. In the Add Data to Partition dialog box, click OK.

The Select Linksets dialog box is displayed if you added link modules and 
the partition includes the source and target modules for their linksets.

The Select Linksets dialog box shows all the linksets you could add to the 
partition. For each linkset, it shows the source module, the target module 
and the link module. It only shows a linkset if all three modules are in the 
partition.

9. Select the check boxes for the linksets you want to add, and then click OK.

Synchronizing an imported partition
Synchronize an imported partition when you want to update the home database 
to reflect the changes you have made so far.
Synchronizing does not remove the read-only locks at the home database. So 
users at the home database can still only read the data, while users at your (away) 
database can continue editing it.
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Synchronizing an exported partition

To synchronize an imported partition:
1. At the away database, log in to Rational DOORS as a project manager, 

database manager, or custom user who has the power to partition data. 

2. In the Database Explorer, select the project that contains the partition, and 
then right-click Properties.

3. Click the Imported Partitions tab.

4. Select the partition you want to synchronize, and then click Synchronize.

You must have admin access to all the modules in the partition.

5. In the Synch file name box, type the name of the synch file that you want 
to write the data to, or use Browse to locate it.

6. If you want to include a comment for the people at the home database, type 
it in the Comment box.

7. Click OK.

Rational DOORS creates the synch file and copies the data to it.

8. Send the synch file to a user at the home database, so that they can use it to 
synchronize their database.

Synchronizing an exported partition
Synchronizing an exported partition updates the home database with the 
changes made at the away database.
It does not remove the read-only locks at the home database. So for any data that 
was not exported with read-only access rights, users at the home database can 
still only read it, and users at the away database can continue editing it.
You cannot synchronize an exported partition if either the project or any of the 
modules in the partition are open.

Note  In the Database Explorer, the folder or project selected in 
the left pane is open and has an open folder icon  or an 
open project icon . Its parent folder or project is also 
open, and so are all the folders and projects above it in the 
database tree, although they do not have open folder or open 
project icons. 
When a module is open, all the folders and projects above it 
in the database tree are also open.

To synchronize an exported partition:
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1. At the home database, log in to Rational DOORS as a project manager, 
database manager, or custom user who has the power to partition data. 

2. In the Database Explorer, select the project whose data you want to 
synchronize, and then right-click Properties. 

You must have modify and create access to the project.

3. Click the Exported Partitions tab.

4. Select the partition you want to synchronize, and then click Synchronize.

You must have admin and delete access to all the modules in the partition.

5. In the Synch file name box, type the name of the synch file, or use Browse 
to locate it.

6. Click OK.

A screen that shows the following information about the partition is 
displayed:

• The name of the synch file
• The name of the partition
• Any comment the user made at the away database when they created the 

synch file

Returning an imported partition
When you have finished editing the modules in an imported partition, you return 
the partition to its home database.
You cannot return a partition if any user has a module in the partition open.
To return an imported partition:

Click To

Details See more information about the partition and synch 
file.

Report Open a new window that contains full information 
about the partition, including all the modules in it.
Note To print the report, cut and paste from this 

window into a text editor then print the text 
file.

Synchronize Synchronize your database with the away database.
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Rejoining a partition

1. At the away database, log in to Rational DOORS as a project manager, 
database manager, or custom user who has the power to partition data. 

2. In the Database Explorer, select the project whose partition you want to 
return, and then right-click Properties.

3. Click the Imported Partitions tab.

4. Select the partition you want to return, and then click Return.

You must have admin and delete access to all the modules in the partition.

5. In the Return file name box, type the name of the file that you want to 
write the data to, or use Browse to locate it.

6. If you want to include a comment for the users at the home database, type it 
in the Comment box.

7. Use the After returning radio buttons to specify whether you want to delete 
the data from your database:

• Click Delete the imported data to delete and purge all the partition 
data from your database. 

• Click Keep the imported data to keep all the partition data in your 
database. The data no longer looks like it was imported from another 
database; it looks like local data and users at the local database can 
continue to edit it. Its partition access rights no longer limit access rights 
defined locally.

8. Click OK.

Rational DOORS creates the return file and copies the updated data to it.

9. Send the return file to a user at the home database, so that they can rejoin 
the partition back into their database.

Rejoining a partition
Rejoining an exported partition updates the home database with the changes 
made at the away database. As changes in the away database might have been 
made by users who do not exist in the home database, the history record shows 
the user in the home database who rejoins the partition as being the user who 
made the changes.
The following system attributes are automatically created when you rejoin a 
partition:

• Remote Created By

• Remote Created On
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• Remote Last Modified By

• Remote Last Modified On

Rejoining an exported partition also removes the read-only locks at the home 
database. So users at the home database can now edit the data again.
You cannot rejoin a partition if either the project or any of the modules in the 
partition are open.

Note  In the Database Explorer, the folder or project selected in 
the left pane is open and has an open folder icon  or an 
open project icon . Its parent folder or project is also 
open, and so are all the folders and projects above it in the 
database tree, although they do not have open folder or open 
project icons. 
When a module is open, all the folders and projects above it 
in the database tree are also open.

To rejoin a partition:
1. At the home database, log in to Rational DOORS as a project manager, 

database manager, or custom user who has the power to partition data. 

2. In the Database Explorer, select the project whose partition you want to 
rejoin, and then right-click Properties.
You must have modify and create access to the project.

3. Click the Exported Partitions tab.

4. Select the partition you want to rejoin, and then click Rejoin.

You must have admin and delete access to all the modules in the partition.

5. In the Return file name box, type the name of the return file, or use 
Browse to locate it.

6. Click OK.

A screen that shows the following information about the partition is 
displayed:

• The name of the return file
• The name of the partition
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• Any comment the user made at the away database when they created the 
return file.

Recovering a partition
If you have a partition that can never be rejoined because the away database was 
corrupted or lost (for example, if it was damaged in a fire), you can recover the 
original data. This removes the read-only locks associated with the partition, so 
that users at the home database can edit the data.

Note  If you recover a partition, you can never feed the changes 
made at the away database back to your database.

You cannot recover a partition if either the project or any of the modules in the 
partition are open.

Note  In the Database Explorer, the folder or project selected in 
the left pane is open and has an open folder icon  or an 
open project icon . Its parent folder or project is also 
open, and so are all the folders and projects above it in the 
database tree, although they do not have open folder or open 
project icons. 
When a module is open, all the folders and projects above it 
in the database tree are also open.

To recover a partition:
1. At the home database, log in to Rational DOORS as a project manager, 

database manager, or custom user who has the power to partition data. 

Click To

Details See more information about the partition and return file.

Report Open a new window that contains full information about 
the partition, including all the modules in it.
Note To print the report, cut and paste from this window 

into a text editor then print the text file.

Rejoin Rejoin the partition to your database.
Rational DOORS updates the data in your database and 
removes all read-only locks associated with the partition.
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2. In the Database Explorer, select the project whose partition you want to 
recover, and then right-click Properties. 

You must have modify access to the project.

3. Click the Exported Partitions tab.

4. Select the partition you want to recover, and then click Recover.
You must have admin and delete access to all the modules in the partition.

A message is displayed asking if you really want to recover the partition.

5. Click Confirm.
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14 Requirements Interchange Format
This chapter is for Database Managers, Project Managers, and users who have 
the power to partition data. It contains the following topics:

• RIF

• Creating a RIF definition

• Editing a RIF definition

• Deleting a RIF definition

• Exporting a RIF package

• Importing a RIF package

• Merging a RIF package

• Recovering RIF locks

RIF
The Requirements Interchange Format (RIF) is a standardized format that you 
can use to exchange requirement information between requirements databases 
and requirements tools.
You can send Rational DOORS data for editing to another Rational DOORS 
database or another requirements tool. After the data has been edited, it is 
returned to the originating Rational DOORS database, and, if appropriate, 
merged with the original data. Returning the data and merging it is a two-step 
process.
You need to be using a Rational DOORS 9.2.0.1 or later Database Server, and 
the server must be configured to use a minimum client version of 9.2.0.1 to make 
the RIF functionality fully available.
If you are transferring Rational DOORS data between two Rational DOORS 
clients, both clients need to be the same version.
How you use the RIF functionality depends on which task you need to complete:

• Sending data for review or edit

• Receiving and editing Rational DOORS data in a RIF file

Sending data for review or edit
If you are sending data for review or edit, you must perform the following tasks:
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• Packaging the data

• Exporting the data

• Importing the data

• Merging the data

Packaging the data

The first step in packaging the data is to identify the modules that contain the 
data that you want to send to a third party.
You can send a whole module, or a subset of the data in the module. If you want 
to send only a subset of the data in a module, use Rational DOORS views to 
determine the data that is sent.
After you have set up your data, you must create a RIF definition.
A RIF definition is comprised of the following items:

• One or more formal modules

• A view of the data in each module

• The locks to apply to the data

If you are sending data to be edited by a third party, you need to lock the 
local copy, to make it read-only.

Similarly, if you are sending data to the third-party to be viewed and not 
edited, you need to lock the exported copy.

Each piece of data in the RIF definition is either locked in the local Rational 
DOORS database or locked in the exported copy. You cannot edit the same 
data in both places.

Exporting the data

The RIF definition is exported as a RIF package, which copies the data 
determined by the RIF definition to an xml file.
The RIF package can contain data from formal modules and link modules from 
the same Rational DOORS project. It can also contain baselined data.
Links are only included in the RIF package if both ends of the link and its link 
module are included in the RIF package. External links are not included.
Linkset parings are also included in the RIF package.
Layout DXL is included in the RIF package as read-only text.
The absolute numbers of the objects in the RIF package may be different in the 
third-party’s database.
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RIF

Importing the data

After the third party has edited the data, they return the file and you import it 
into the local database.
When you import the xml file, Rational DOORS recognizes that the data in the 
file is associated with the RIF definition that you originally created, and imports 
it under that definition.

Merging the data

You merge the returned data with the original data, and any locks are removed.

Receiving and editing Rational DOORS data in a RIF file

If you are receiving RIF data, and need to edit it with Rational DOORS, you 
must perform the following tasks:

• Receiving and importing the data

• Exporting the data

Receiving and importing the data

You receive the RIF data in an xml file, which you need to import.
When you import the xml file, you must create a RIF definition, which you will 
use when you are ready to return the data. The first time you import the data, a 
folder is created for you. On subsequent imports, you must create a new folder 
to contain the imported RIF data.
After the RIF data is imported, it is displayed as modules. It is probable that 
some of the data in the modules will be editable, and some will be read-only.

Exporting the data

When you have completed your review or your edits, you select the RIF 
definition that you created for the import and export the data.

Note  If you delete an object as part of your edits, do not purge it 
before you export the data. 
 
Also, do not delete links before you export the data.

You can choose to return the edit locks, so that you cannot make any further 
updates to the data.
The data is exported to an xml file, which you can return to the original Rational 
DOORS database.
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Creating a RIF definition
A RIF definition is composed of one or more formal modules, a view of the data 
in each module, and the locks to apply to the data.
To create a RIF definition:
1. Log in to Rational DOORS as a project manager, database manager, or 

custom user who has the power to partition data and modify access to the 
project.

2. In the Database Explorer, select the project where you want to create a RIF 
definition, and then click File > Properties. 

3. Click the RIF Definitions tab.

4. Click New.

The New RIF Definition window is displayed.

5. Enter a name in the RIF Definition Name box.

6. If you want to enter additional information about the RIF definition, type it 
in the Description box.

7. Click OK.

The Add RIF Definition window is displayed.

8. Open the project and select the first module you want to add to the RIF 
definition.

9. Select the version of the module that contains the data you want to export.

If the module has been baselined, you can select the current version of the 
module, or one of the baselines.
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Creating a RIF definition

10. Select the data to lock in the local module:

List item Description

Lock all data All the data in the module in the local database is 
locked.
Users in the remote database can edit all the data 
in the module.
Any updates in the remote database can be 
imported and merged with the local module.
Note If you select this option, the Include data 

in view field is unavailable. 
 
Do not use this option if the module 
contains any sensitive information. You 
cannot prevent it from being included in 
the RIF definition. 
 
If you select this option, you cannot 
include any layout DXL in the RIF 
definition.

Lock objects The selected objects in the module in the local 
database are locked.
Users in the remote database can modify the 
specified objects and add new objects.
Updates to the specified objects in the remote 
database can be imported and merged with the 
local module.
Note Updates to any other objects are not 

merged with the local module.
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11. Select the view that displays the data that you want to export.

If you want to include only the data in a specific view of the module, select 
Include data in view, and then select a view from the drop-down list.

12. If you have selected either Lock objects or Lock attributes, you must 
select a second view in the Apply locks to objects in view field.

Note  If you selected Lock attributes, the label changes to 
Apply locks to attributes in view.

This view displays the objects or attributes that you want to be editable in 
the exported data.

13. Click Add or Update Module to add the module to the RIF definition.

Continue adding modules until your RIF definition is complete.

Lock attributes The selected attributes in the module in the local 
database are locked.
Users in the remote database can modify the 
specified attributes.
Updates to the specified attributes in the remote 
database can be imported and merged with the 
local module.
Note Updates to any other attributes are not 

merged with the local module.

No locks None of the data in the module in the local 
database is locked.
Users in the remote database can edit all the data 
in the module.
Any updates in the remote database cannot be 
imported and merged with the local module.

No locks. Exported data 
is read-only

None of the data in the module in the local 
database is locked.
Users in the remote database can only view the 
data in the module.
Any updates to the data in the remote database 
cannot be merged with the local module.

List item Description
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Editing a RIF definition

14. Click OK.

Editing a RIF definition
You can change the contents of a RIF definition by adding or removing modules, 
or changing the data and locks you have included.

Note  If the RIF definition has already been exported, you cannot 
change or remove the modules that are already contained in 
the definition. You can only add new modules, or, in the case 
of baselined modules, add a different version of the baseline. 
For example, if the RIF definition contains the current 
version of a module that has been baselined, you can select a 
baseline of the module, and add it to the definition.

To edit a RIF definition:
1. Log in to Rational DOORS as a project manager, database manager, or 

custom user who has the power to partition data and modify access to the 
project.

2. In the Database Explorer, select the project where you want to change a RIF 
definition, and then click File > Properties. 

3. Click the RIF Definitions tab.

4. Select the RIF definition you want to edit, and then click Edit.
The Edit RIF Definition window is displayed with the current contents of 
the RIF definition.

5. Open the project and select the first module you want to change.

6. Make your changes, and click Add or Update Module. The properties for 
the module displayed in the RIF Definition Contents pane are updated.

You can continue selecting and changing modules until you have made all 
the changes you want to make.

7. If you want to add a module to the RIF package, follow Step 8 to Step 13 in 
“Creating a RIF definition,” on page 160.

8. If you want to remove a module from the RIF definition, select it in the RIF 
Definition Contents pane, and click Remove.

9. Click OK.
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Deleting a RIF definition
To delete a RIF definition:
1. Log in to Rational DOORS as a project manager, database manager, or 

custom user who has the power to partition data and modify access to the 
project.

2. In the Database Explorer, select the project where you want to delete a RIF 
definition, and then click File > Properties.

3. Click the RIF Definitions tab.

4. Select the RIF definition you want to delete, and click Remove.

5. Click Yes.

Exporting a RIF package
To export a RIF package:
1. Log in to Rational DOORS as a project manager, database manager, or 

custom user who has the power to partition data and modify access to the 
project.

2. Make sure the project and the modules in the RIF definition you want to 
export are not open.

3. In the Database Explorer, select the project containing the RIF definition 
you want to export, and then click File > Properties.

4. Click the RIF Definitions tab.

5. Click Export.
The Export RIF Definition window is displayed.

6. Accept the file name in the RIF Package File Name box or browse to a 
new file name.

The RIF Definition Name is read-only.

7. Click OK.

The RIF package is exported.

Importing a RIF package
To import a RIF package:
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Importing a RIF package

1. Log in to Rational DOORS as a project manager, database manager, or 
custom user who has the power to partition data and modify access to the 
project.

2. In the Database Explorer, select the project or folder where you want to 
import the RIF package, and then click File > Import RIF Package.

The Import RIF Package File window is displayed.

3. Browse to the .xml file that you want to import.

4. Click OK.

The Import RIF Package window is displayed.

5. Select or clear the Use existing RIF definition check box.

This check box is only available if it is the first time the RIF package has 
been imported, and it is not a Rational DOORS package.

If you want to use an existing RIF definition, select the check box. The 
definitions are displayed in the RIF Definition Name box. Select one from 
the drop-down list.

If you want to enter a new RIF definition, clear the check box, enter a name 
in the RIF Definition Name box, and then enter a description in the RIF 
Definition Description box.

6. Enter a description in the RIF Import Package Description box.

7. Enter the name of the folder you want to import the RIF package into.

You cannot enter the name of an already existing folder.

If you have not imported this RIF package before, this field is read only. By 
default, the RIF package is imported into the root folder of the project.

8. Click Import.
The RIF package is imported into the specified folder and is ready to be 
merged.

Note  Opening the folder before the import is complete can 
corrupt the imported data.

Only the person who imported the RIF package can access the folder that 
the RIF package was imported into unless access rights for the folder are 
changed.
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Merging a RIF package
When you have imported the RIF package, you can merge the modules in it with 
the modules in the local database.
To perform merge, you select a RIF definition. The RIF packages based on the 
RIF definition that have been imported into your Rational DOORS system are 
listed. Select the RIF package you want to merge.
To merge a RIF package:
1. Log in to Rational DOORS as a project manager, database manager, or 

custom user who has the power to partition data and modify access to the 
project.

2. In the Database Explorer, select the project containing the RIF package you 
want to merge, and then click File > Properties.

3. Click the RIF Definitions tab.

4. Select the RIF definition that the RIF package you want to merge was based 
on, and click Imports.

The RIF Definition Imports window is displayed, listing the RIF packages 
based on the RIF definition.

If you want to list only the RIF packages that need to be merged, select 
Show only imports requiring merge.

5. Select the RIF package you want to merge.

If you want to display more information about the RIF package, click 
Details.

The Details of RIF Import window is displayed, listing the details of the 
RIF package.

6. Click Merge.

The RIF package is merged.

You can continue to select RIF packages and merge them.

7. Click Close.

Recovering RIF locks
There are occasions when you need to recover the locks on objects in a local 
module.
For example, if you need to resend a RIF package, you need to recover the locks 
in the local module before resending the package.
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Recovering RIF locks

Note  If you recover all the locks in a module, you cannot 
subsequently merge the RIF package that is associated with 
the recovered locks.

To recover locks:
1. Log in to Rational DOORS as a project manager, database manager, or 

custom user who has the power to partition data and modify access to the 
project.

2. In the Database Explorer, select the project where the RIF package was 
exported from, and then click File > Properties.

3. Click the RIF Definitions tab.

4. Select the RIF definition that the RIF package was exported from, and click 
Recover Locks.

The Recover Locks window is displayed, listing the exported packages.

5. Select the RIF package or packages you want to recover.

You can also click Select All or Clear All.
6. Click Recover Locks.

A message is displayed.

7. Click Yes.

The locks are recovered.

8. Click OK.
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15 Maintaining the integrity of your Rational 
DOORS database

This chapter is divided into the following sections:

• About the Rational DOORS database

• How does the Database Integrity Checker work?

• Running the Database Integrity Checker

• The log file

About the Rational DOORS database
Rational DOORS relies on the underlying integrity of the network on which it is 
running to complete certain database operations. Rational DOORS can usually 
recover from temporary interruptions to the contact between Rational DOORS 
clients and the database server. However, if it is processing particular operations 
at the moment of failure it might not be able to recover, and database integrity 
might be lost. If this happens, you can use the Database Integrity Checker to 
identify and repair any problems.
The Rational DOORS Database consists of a hierarchy of projects, folders and 
modules. Depending on where they exist in the hierarchy, these items are either 
parent items, child items or both. For example in a simple database you might 
have a project (Project A) that contains a single folder (Folder B).

• Project A is the parent of Folder B

• Folder B is the child of Project A

Each item in the Rational DOORS database is represented internally in Rational 
DOORS by files that contain information about the item, about the item’s 
parent, and about the item’s children, if it has any. As folder and module names 
in Rational DOORS do not have to be unique in the database, each item is 
identified by a unique reference number. For example, Project A might have a 
reference number of 00000001, and Folder B a reference number of 00000002.

Note  This is the number that is returned by the DXL perm, 
uniqueID.

Each item contains the reference number of its parent and the reference 
numbers of any children it contains. So in the above example, 00000001 (Project 
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A) contains the reference number of its child, 00000002 (Folder B). 00000002 
(Folder B) contains the reference number of its parent, 00000001 (Folder A). 
As long as each parent contains a reference to each of its children and each of 
the children has a corresponding reference to its parent, the database integrity is 
intact and all the data is represented in the Database Explorer as expected. 
However, the database integrity can be affected if a failure in your computer 
system causes a database operation to fail when partially completed. Typically, an 
error message stating Item is not in expected folder is displayed if you try to 
delete or view an item that has been affected in this way.
If you moved Folder B in the above example to Folder C, the following changes 
are made to the files:

• The reference to Folder B is removed from its original parent, Project A

Folder B is no longer referenced as a child of Project A.

• A reference to Folder B is added to its new parent, Folder C

Folder C now contains a reference to its new child, Folder B.

• The reference to Project A is removed from Folder B and a reference to 
Folder C is added to Folder B

Project A is no longer referenced as the parent of Folder B. Folder B now 
contains a reference to its new parent, Folder C.
A failure in your computer system during this operation could result in some of 
the changes not being made to the files. This can cause problems with the 
integrity of the Rational DOORS database.
The other main causes of database integrity problems are losing contact with the 
database server while you are:

• Deleting an item

• Converting a project to a folder, or a folder to a project

How does the Database Integrity Checker work?
When you run the database integrity checker it checks to make sure that:

• Each reference from a parent item to a child item has a corresponding 
reference back from the child to the parent.

• No child item is referenced as a child of two different parent items.

• Every item in the database is referenced as the child of another item. If an 
item is not referenced by a parent, it (and any children it has) is not displayed 
in the Database Explorer. This data is recovered to a Lost and Found folder. 
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• Every project in the database has an entry in the Project View list, which is 
the list Rational DOORS uses to generate the Project View in the Database 
Explorer.

Once the database integrity check is complete, you can use the wizard to repair 
any inconsistencies in the database and move or restore any recovered data.
You can also run a restricted integrity check on the contents of a selected folder 
or project. An integrity check on a project or folder cannot check for data that is 
not referenced by any other item. It can check for: 

• Missing data

• Items that are referenced by more than one parent

• Projects that are not included in the project list

Running the Database Integrity Checker
To run the integrity checker:
1. Log in to Rational DOORS as the Administrator user. The Check Integrity 

function is not available to any other Rational DOORS users.

2. In the Database Explorer, click Database , or a project or folder, and 
click File > Check Integrity. 

The Database Integrity Check wizard is displayed.

Note  If the Rational DOORS database server your client is 
connecting to is version 7.0 SP1 or earlier, an error 
message is displayed and you will be unable to run the 
Database Integrity Checker.

The path to the item to be checked is displayed in the Folder box. If you 
selected the database, / is displayed. You can change the item that is checked 
by clicking Browse, and navigating to the project or folder you want to 
check.

By default, items that are not referenced in the database are recovered to the 
Lost and Found folder. These items are not displayed in the Database 
Explorer until they are recovered by the integrity checker and placed in this 
folder. If the Lost and Found folder does not exist, it is created by the 
integrity checker. You can recover the data to a different folder by clicking 
Browse and navigating to the project or folder you want to use.

The results of the integrity check can be recorded in a log file. The following 
information is logged on the file:
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• The start and finish times for the checking of each item
• A list of all the problems that were detected
• A log of the repairs that were made using the wizard

If you want to create a log file, ensure the Log results to file check box is 
selected and type a path and filename for the file, for example 
C:\integrity check\log.txt. Subsequent database integrity checks 
overwrite this file, unless a new log file is specified.

If you want to repair database integrity problems that are detected by the 
integrity checker, leave the Prompt for repair actions when completed 
check box selected. 

If you clear the Prompt for repair actions when completed check box, 
the Finish button becomes available and the Next button is unavailable. 
When you click Finish, data that is not referenced in the database is 
recovered to the Lost and Found folder and the integrity checker results are 
logged to a log file, if you choose to create one.

Note  If you are only checking the contents of a project or 
folder, the integrity checker cannot check for items that 
are not referenced by any parent, so if you clear the 
Prompt for repair actions when complete check box 
you must select the Log results to file check box.

3. Click Next or Finish.

Progress bars are displayed as the data is checked. If a folder or project is 
being checked, one progress bar is displayed. If the entire database is being 
checked, three progress bars are displayed in succession.

If you cleared the Prompt for repair actions when complete check box, a 
Database verification completed message is displayed when the integrity 
check is complete.

Otherwise, the first step of the Database Integrity Check wizard is displayed. 
The Finish button is unavailable until you reach the last screen in the 
wizard.



Managing Rational DOORS           173

Running the Database Integrity Checker

A list of items that are referenced by a parent, but do not exist in the 
database is displayed. 

If you leave any items in this list, their references are not updated and they 
will appear on subsequent integrity checks of this database.

If you are only checking a folder or project, go to Step 5. The screen 
described in Step 4 is not displayed.

4. Click Next.
If you are checking the whole database, a list of items that are not referenced 
by any parent is displayed, similar to the following screen:

These items were not previously displayed in the database, and are moved to 
the Lost and Found folder you specified in Step 2 until you update their 
references.

The Item column gives the name or unique reference number of the 
unreferenced item. The Referenced Location column gives the name of 
the folder or project that the item references as its parent.

Each item in the database has information stored about the item, its parent 
and its children, and has a unique reference number. The files that contain 
information about projects and folders do not contain the project or folder 
name; this information is stored in the item’s parent, and in the Project View 

Click To

Remove reference Remove the reference to the child item from the 
parent. The item is removed from the list in the 
wizard.

Create Folder Create an empty folder with the same name and 
unique reference number as the one referenced by the 
parent. The item is removed from the list in the 
wizard.
Note If the item is referencing a missing project, the 

Create Folder button changes to a Create 
Project button. 
If the item is a module, the button is 
unavailable.

Close Close the Database Integrity Check wizard and return 
to the module. 
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list. As the folders that are listed on this screen are not referenced by a 
parent, they do not have a name and description. The projects listed on this 
screen only have a name and description if they are included on the Project 
View list. If the integrity checker cannot find a name and description for the 
item, it is called Folder or Project, followed by its unique file reference 
number, for example Folder 00000003. Once the item is restored and you 
have closed the Database Integrity Check wizard you can locate it using the 
Database Explorer and rename it.

The following table describes the options available for the recovered items.

Click To

Delete Delete the item (the icon has a red cross in the 
corner). Once an item is deleted, the only option 
available from the wizard is Purge.

Purge Purge the item from the database. The item is 
removed from the list in the wizard.

Move Open a mini-explorer. Navigate to and select the 
folder or project to which you want to restore the 
item and click OK. The item is moved to the new 
location, and is removed from the list in the wizard.

Restore Restore the item to the parent that it references. This 
is the folder or project whose path is displayed in the 
Referenced Location column. The item is removed 
from the list in the wizard.
If the Referenced Location path has (Data not 
found) appended, this means that the project or 
folder does not exist in the database. These items 
were listed in the previous screen. If you restore to 
this location, the folder or project that does not exist 
is created as detailed in Step 3, and the item is 
restored to that location.

View Open a module in read-only mode or display a project 
or folder in a mini-explorer.
You can use the explorer to view the contents of the 
folder or project.
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Any items that you do not restore, move, delete or purge are stored in the 
Lost and Found folder. They do not appear on subsequent integrity checks 
of this database.

5. Click Next.
The Items with conflicting parent references screen is displayed.

Each reference from a parent item to a child item should have a 
corresponding reference back from the child to the parent. Occasionally a 
child item is referenced as a child of two different parent items, or references 
a different item as its parent, resulting in integrity problems in the database. 

If one of the items in the lower pane has its name appended with 
(referenced as parent), this means that the child item in the top pane 
references that item as its parent.

If you want to look at the contents of an item before you update its 
references, select it and click View. If a module is selected, it is opened in 
read-only mode. If a folder or project is selected, it is displayed in a 
mini-explorer. You can use the explorer to view the contents of the folder or 
project.

In the lower pane, select the parent item to which you want the child to refer, 
and click Select. The references are updated, and the item is removed from 
the list in the wizard.

If you leave any items in this list, their references are not updated and they 
will appear on subsequent integrity checks of this database.

6. Click Next.
The final step of the Database Integrity Check wizard is displayed.

The Project View list is the list that Rational DOORS uses to generate the 
Project View of the Database Explorer. A reference to each project in the 
database should be contained in the Project View list. If a project is not 
referenced in the Project View list, it is not displayed in the Database 
Explorer when Project view is selected.

Close Close the Database Integrity Check wizard and return 
to the module. 

Click To
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If the database integrity checker finds a project that is not referenced in the 
Project View list it is displayed here. The following table describes the 
options available for the items that are listed.

If you leave any items in this list, their references are not updated and they 
will appear on subsequent integrity checks of this database.

7. Click Finish.

The Database Integrity Check wizard is closed. 

The log file
When you run the database integrity checker you can create a log file. The results 
of the integrity check are recorded in this file. 
The log file is created in the directory you specified when you ran the Database 
Integrity Check wizard. It contains three sections:

• The first section contains a list of all the items that were checked.

Click To

View See the contents of the project.
A mini explorer is opened, with the project displayed 
in its current location in the database. You can use the 
explorer to see the contents of the project.

Convert to Folder Convert the project to a folder. 
The reference to the project is removed from the 
Project View list, and the item is removed from the 
list in the wizard.

Add entry Add a reference for the project to the Project View 
list. The project will now be displayed in the Database 
Explorer when Project View is selected.
Project names must be unique in the database. If 
another project of the same name is already included 
in the project list, a number is appended to the project 
name, and a message is displayed giving the new 
project name. 

Close Close the Database Integrity Check wizard and return 
to the module. 
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Each item that was checked is listed along with the date and time of the 
check. Items that have integrity problems are marked with ***, and a brief 
description of the problem is given.

• The second section contains a summary of each problem that was detected 
and provides details of the parent and child references that existed for each 
item.

• The final section contains details of the repairs you made to the database 
using the Database Integrity Check wizard. Any repair that failed is marked 
with ***.
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16 Troubleshooting
This chapter describes how to troubleshoot Rational DOORS:

• If you cannot start the FLEXnet License Manager (lmgrd) on Solaris 9

• If a restored data directory is locked

• If you are not receiving email notifications

• If you cannot import a Word document to Rational DOORS

Note  For the latest information about known problems with 
Rational DOORS and how to work around them, visit the 
support center on our web site at 
http://www.ibm.com/software/awdtools/doors/support/d
oc.html

If you cannot start the FLEXnet License Manager (lmgrd) on Solaris 
9

If you get the error message:
Vendor daemon can't talk to lmgrd (Cannot read data from license 
server (-16,287:22 "Invalid argument")) 

when you try to start the FLEXnet License Manager on Solaris 9, run the 
command

ulimit -H -n 1024 

before you run lmgrd.

If a restored data directory is locked
If you copy the data directory to create a backup while the Rational DOORS 
database server service is running, a server data lock will be present. If you 
restore this copy you will have to remove the lock before the database can be 
accessed. To do this, delete the servdata.dtc file from the data directory.

If you are not receiving email notifications
If Rational DOORS is configured to send email notifications but you are not 
receiving those emails, your virus scanning or firewall software might be blocking 
the Rational DOORS executable, which uses Port 25 to send email 
notifications. Check your virus scanning or firewall software, and if necessary 
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modify them to allow this access. For example, with McAfee VirusScan 
Enterprise v8.0:

1. Open the VirusScan Console.

2. Right-click Access Protection, and select Properties.

3. On the Port Blocking tab, select the rule Prevent mass mailing worms 
from sending mail.

4. Click on <Edit...>.

5. Add doors.exe to the Excluded Processes list.

If you cannot import a Word document to Rational DOORS
When a Standard user with no Administrative access to the local machine 
attempts to export a document from Word to Rational DOORS they might 
receive the error Unable to communicate to Rational DOORS.
The first time a Word document is exported to Rational DOORS, registry entries 
are created for the Rational DOORS.Application object and its COM or 
DCOM components. If the user who attempts the export for the first time does 
not have Administrative access to the computer, the registry entries cannot be 
created and the export fails.
To register the required components, log in to the local machine as an 
Administrator and export a Word document to Rational DOORS. This registers 
the required components in the registry, so a user without administrative access 
to the machine can now export Word documents to Rational DOORS.
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17 Contacting support
This chapter contains the following topics:

• Contacting IBM Rational Software Support

• Prerequisites

• Submitting problems

• Other information

Contacting IBM Rational Software Support
If the self-help resources have not provided a resolution to your problem, you 
can contact IBM Rational Software Support for assistance in resolving product 
issues.

Note  If you are a heritage Telelogic customer, you can go to 
http://support.telelogic.com/toolbar and download the 
IBM Rational Telelogic Software Support browser toolbar. 
This toolbar helps simplify the transition to the IBM Rational 
Telelogic product online resources. Also, a single reference 
site for all IBM Rational Telelogic support resources is 
located at 
http://www.ibm.com/software/rational/support/telelogic/

Prerequisites
To submit your problem to IBM Rational Software Support, you must have an 
active Passport Advantage® software maintenance agreement. Passport 
Advantage is the IBM comprehensive software licensing and software 
maintenance (product upgrades and technical support) offering. You can enroll 
online in Passport Advantage from 
http://www.ibm.com/software/lotus/passportadvantage/howtoenroll.html.

• To learn more about Passport Advantage, visit the Passport Advantage 
FAQs at 
http://www.ibm.com/software/lotus/passportadvantage/brochures_faqs_
quickguides.html.

• For further assistance, contact your IBM representative.

To submit your problem online (from the IBM Web site) to IBM Rational 
Software Support, you must additionally:



Contacting support

182    Managing Rational DOORS

• Be a registered user on the IBM Rational Software Support Web site. For 
details about registering, go to 
http://www-01.ibm.com/software/support/.

• Be listed as an authorized caller in the service request tool.

Submitting problems
To submit your problem to IBM Rational Software Support:

1. Determine the business impact of your problem. When you report a 
problem to IBM, you are asked to supply a severity level. Therefore, you 
need to understand and assess the business impact of the problem that you 
are reporting.

Use the following table to determine the severity level.

2. Describe your problem and gather background information, When 
describing a problem to IBM, be as specific as possible. Include all relevant 
background information so that IBM Rational Software Support specialists 
can help you solve the problem efficiently. To save time, know the answers 
to these questions:

• What software versions were you running when the problem occurred?

To determine the exact product name and version, use the option 
applicable to you: 

Severity Description

1 The problem has a critical business impact: You are unable to 
use the program, resulting in a critical impact on operations. 
This condition requires an immediate solution.

2 This problem has a significant business impact: The program 
is usable, but it is severely limited.

3 The problem has some business impact: The program is 
usable, but less significant features (not critical to 
operations) are unavailable.

 4 The problem has minimal business impact: The problem 
causes little impact on operations or a reasonable 
circumvention to the problem was implemented.
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• Start the IBM Installation Manager and click File > View Installed 
Packages. Expand a package group and select a package to see the 
package name and version number. 

• Start your product, and click Help > About to see the offering 
name and version number. 

• What is your operating system and version number (including any 
service packs or patches)? 

• Do you have logs, traces, and messages that are related to the problem 
symptoms? 

• Can you recreate the problem? If so, what steps do you perform to 
recreate the problem? 

• Did you make any changes to the system? For example, did you make 
changes to the hardware, operating system, networking software, or 
other system components? 

• Are you currently using a workaround for the problem? If so, be 
prepared to describe the workaround when you report the problem.

3. Submit your problem to IBM Rational Software Support. You can submit 
your problem to IBM Rational Software Support in the following ways:

• Online: Go to the IBM Rational Software Support Web site at 
https://www.ibm.com/software/rational/support/ and in the Rational 
support task navigator, click Open Service Request. Select the 
electronic problem reporting tool, and open a Problem Management 
Record (PMR), describing the problem accurately in your own words.

For more information about opening a service request, go to 
http://www.ibm.com/software/support/help.html

You can also open an online service request using the IBM Support 
Assistant. For more information, go to 
http://www-01.ibm.com/software/support/isa/faq.html.

• By phone: For the phone number to call in your country or region, go 
to the IBM directory of worldwide contacts at 
http://www.ibm.com/planetwide/ and click the name of your country 
or geographic region. 

• Through your IBM Representative: If you cannot access IBM 
Rational Software Support online or by phone, contact your IBM 
Representative. If necessary, your IBM Representative can open a 
service request for you. You can find complete contact information for 
each country at http://www.ibm.com/planetwide/.
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If the problem you submit is for a software defect or for missing or inaccurate 
documentation, IBM Rational Software Support creates an Authorized Program 
Analysis Report (APAR). The APAR describes the problem in detail. Whenever 
possible, IBM Rational Software Support provides a workaround that you can 
implement until the APAR is resolved and a fix is delivered. IBM publishes 
resolved APARs on the IBM Rational Software Support Web site daily, so that 
other users who experience the same problem can benefit from the same 
resolution.

Other information
For Rational software product news, events, and other information, visit the 
IBM Rational Software Web site on http://www.ibm.com/software/rational/.
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18 Notices
© Copyright IBM Corporation 1993, 2010
US Government Users Restricted Rights - Use, duplication, or disclosure 
restricted by GSA ADP Schedule Contract with IBM Corp.
This information was developed for products and services offered in the U.S.A. 
IBM may not offer the products, services, or features discussed in this document 
in other countries. Consult your local IBM representative for information on the 
products and services currently available in your area. Any reference to an IBM 
product, program, or service is not intended to state or imply that only that IBM 
product, program, or service may be used. Any functionally equivalent product, 
program, or service that does not infringe any IBM intellectual property right 
may be used instead. However, it is the user’s responsibility to evaluate and verify 
the operation of any non-IBM product, program, or service. 
IBM may have patents or pending patent applications covering subject matter 
described in this document. The furnishing of this document does not grant you 
any license to these patents. You can send written license inquiries to:  
 
IBM Director of Licensing 
IBM Corporation 
North Castle Drive 
Armonk, NY 10504-1785 
U.S.A.  
 
For license inquiries regarding double-byte character set (DBCS) information, 
contact the IBM Intellectual Property Department in your country or send 
written inquiries to:  
 
Intellectual Property Licensing 
Legal and Intellectual Property Law 
IBM Japan Ltd. 
1623-14, Shimotsuruma, Yamato-sh 
Kanagawa 242-8502 Japan 
 
The following paragraph does not apply to the United Kingdom or any 
other country where such provisions are inconsistent with local law: 
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES 
THIS PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, 
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EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, 
THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, 
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. 
Some states do not allow disclaimer of express or implied warranties in certain 
transactions. Therefore, this statement may not apply to you. 
This information could include technical inaccuracies or typographical errors. 
Changes are periodically made to the information herein; these changes will be 
incorporated in new editions of the publication. IBM may make improvements 
and/or changes in the product(s) and/or the program(s) described in this 
publication at any time without notice. 
Any references in this information to non-IBM Web sites are provided for 
convenience only and do not in any manner serve as an endorsement of those 
Web sites. The materials at those Web sites are not part of the materials for this 
IBM product and use of those Web sites is at your own risk. 
IBM may use or distribute any of the information you supply in any way it 
believes appropriate without incurring any obligation to you. 
Licensees of this program who wish to have information about it for the 
purpose of enabling: (i) the exchange of information between independently 
created programs and other programs (including this one) and (ii) the mutual use 
of the information which has been exchanged, should contact:  
 
Intellectual Property Dept. for Rational Software 
IBM Corporation 
1 Rogers Street 
Cambridge, Massachusetts 02142 
U.S.A. 
 
Such information may be available, subject to appropriate terms and conditions, 
including in some cases, payment of a fee. 
The licensed program described in this document and all licensed material 
available for it are provided by IBM under terms of the IBM Customer 
Agreement, IBM International Program License Agreement or any equivalent 
agreement between us. 
Any performance data contained herein was determined in a controlled 
environment. Therefore, the results obtained in other operating environments 
may vary significantly. Some measurements may have been made on 
development-level systems and there is no guarantee that these measurements 
will be the same on generally available systems. Furthermore, some 
measurements may have been estimated through extrapolation. Actual results 
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Trademarks

may vary. Users of this document should verify the applicable data for their 
specific environment. 
Information concerning non-IBM products was obtained from the suppliers of 
those products, their published announcements or other publicly available 
sources. IBM has not tested those products and cannot confirm the accuracy of 
performance, compatibility or any other claims related to non-IBM products. 
Questions on the capabilities of non-IBM products should be addressed to the 
suppliers of those products.
This information contains examples of data and reports used in daily business 
operations. To illustrate them as completely as possible, the examples include the 
names of individuals, companies, brands, and products. All of these names are 
fictitious and any similarity to the names and addresses used by an actual 
business enterprise is entirely coincidental. 
If you are viewing this information softcopy, the photographs and color 
illustrations may not appear. 
Additional legal notices are described in the legal_information.html file that is 
included in your software installation.

Trademarks

IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of 
International Business Machines Corp., registered in many jurisdictions 
worldwide. Other product and service names might be trademarks of IBM or 
other companies. A current list of IBM trademarks is available on the Web at 
www.ibm.com/legal/copytrade.html.
Linux is a trademark of Linus Torvalds in the United States, other countries, or 
both.
Windows is a trademark of Microsoft Corporation in the United States, other 
countries, or both.
UNIX is a registered trademark of The Open Group in the United States and 
other countries.

Text proofing system copyrights

International Proofreader ™ English (US and UK) text proofing system © 2003 
by Vantage Technology Holdings, Inc. All rights reserved. Reproduction or 
disassembly of embodied algorithms or database prohibited. 



Notices

188    Managing Rational DOORS

International Proofreader ™ French text proofing system © 2003 by Vantage 
Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of 
embodied algorithms or database prohibited. 
International Proofreader ™ German text proofing system © 2003 by Vantage 
Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of 
embodied algorithms or database prohibited. 
International Proofreader ™ Afrikaans text proofing system © 2003 by Vantage 
Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of 
embodied algorithms or database prohibited. 
International Proofreader ™ Catalan text proofing system © 2003 by Vantage 
Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of 
embodied algorithms or database prohibited. 
International Proofreader ™ Czech text proofing system © 2003 by Vantage 
Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of 
embodied algorithms or database prohibited. 
International Proofreader ™ Danish text proofing system © 2003 by Vantage 
Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of 
embodied algorithms or database prohibited. 
International Proofreader ™ Dutch text proofing system © 2003 by Vantage 
Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of 
embodied algorithms or database prohibited. 
International Proofreader ™ Finnish text proofing system © 2003 by Vantage 
Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of 
embodied algorithms or database prohibited. 
International Proofreader ™ Greek text proofing system © 2003 by Vantage 
Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of 
embodied algorithms or database prohibited. 
International Proofreader ™ Italian text proofing system © 2003 by Vantage 
Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of 
embodied algorithms or database prohibited. 
International Proofreader ™ Norwegian, text proofing system © 2003 by 
Vantage Technology Holdings, Inc. All rights reserved. Reproduction or 
disassembly of embodied algorithms or database prohibited.
International Proofreader ™ Portuguese, text proofing system © 2003 by 
Vantage Technology Holdings, Inc. All rights reserved. Reproduction or 
disassembly of embodied algorithms or database prohibited.
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International Proofreader ™ Russian, text proofing system © 2003 by Vantage 
Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of 
embodied algorithms or database prohibited.
International Proofreader ™ Spanish, text proofing system © 2003 by Vantage 
Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of 
embodied algorithms or database prohibited.
International Proofreader ™ Swedish, text proofing system © 2003 by Vantage 
Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of 
embodied algorithms or database prohibited.
Other company, product or service names may be trademarks or service marks 
of others.
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