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1 About this manual
Welcome to IBM® Rational® DOORS® 9.2, the world’s leading requirements 
management application.
This manual introduces you to IBM Rational DOORS (Rational DOORS) 
concepts to help you get started with Rational DOORS.

Typographical Conventions
The following typographical conventions are used in this manual:

Related Documentation
The following table describes where to find information in the Rational DOORS 
documentation set:

Typeface or 
Symbol

Meaning

Bold Important items, and items that you can select, including 
buttons and menus: “Click Yes to continue”.

Italics Book titles.

Courier Commands, files, and directories; computer output: “Edit your 
.properties file”.

> A menu choice: “Select File > Open”. This means select the 
File menu, and then select the Open option.

For information on See

What’s new in version 9.2 of Rational 
DOORS

The Rational DOORS readme file

How to install Rational DOORS Rational DOORS Installation Guide

How to set up licenses to use Rational 
DOORS

Rational License TL Guide
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These documents are on the Rational Information Center at 
http://publib.boulder.ibm.com/infocenter/rsdp/v1r0m0/index.jsp.

How to use Rational DOORS Getting Started with Rational DOORS
Using Rational DOORS

How to write requirements Get It Right the First Time

How to set up and manage Rational 
DOORS

Managing Rational DOORS

The DXL programming language DXL Reference Manual

How to integrate Rational DOORS with 
other applications

Rational DOORS API manual

For information on See



Getting Started with Rational DOORS     3

2 Introducing Rational DOORS
This chapter describes the concepts you need to understand before you use 
Rational DOORS:

• About Rational DOORS

• About requirements

• About modules

• About objects and attributes

• About traceability

• About views

• About folders and projects

• About tracking changes

• About baselines

• About edit modes

• About the Change Proposal System

• About partitions

• About user types

• About discussions

About Rational DOORS
Rational DOORS is a requirements management application that contains 
features for capturing, tracking, and managing user requirements.
Use the word processor style interface to manually enter your requirements. You 
can also import your requirements into Rational DOORS from the following file 
formats:

• Microsoft® applications, including Word, Excel, and PowerPoint

• Plain (ASCII) text

• Rich Text Format (RTF)

• FrameMaker
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After you have captured your requirements, you can track and manage them 
throughout the project life cycle by using various features such as views, links, 
and traceability analyses.

About requirements
Requirements describe what users want from a product or service.
For example, if you are planning to buy a new car for your family, you might 
make a list of the things that you need from the car. Your list might include the 
following features:

• Must be able to carry at least five people

• Must have fuel consumption of over 35 miles per gallon

• Must cost no more than X

Less important features that you would like, such as a particular color, would be 
further down your list. At the end of the exercise, you have a list of user 
requirements, which specify the car you want to buy.
The exercise of listing requirements for buying a car is fairly straightforward. 
However, the designers of that car need more.
The designers need system requirements, which describe the features the car 
must provide. From the requirements, they can prepare detailed design 
documents. Each part of the design must be tested; therefore, tests are specified 
in a separate document.
well-defined requirements ensure that your customers get what they want and 
show you what product you have to build or what service you have to provide. 
For information about writing requirements, see Get it Right the First Time.

About modules
In Rational DOORS databases, information is stored in modules.
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About objects and attributes

For example, a vehicle manufacturer is building a car and a truck.

The information for the car project is stored in the following modules:

• A user requirements module, which contains information about the features 
that users want in the car.

• A design module, which describes the engineering design of the car.

• A safety tests module, which describes the safety tests that must be carried 
out on the car.

About objects and attributes
Information in each module is divided into objects and attributes. 
There are default attributes, such as Created By and Modified On, and you can 
create your own attributes to store other information, such as priority and status.
The objects are organized with numbered headings in a hierarchical structure. 
You can use the Module Explorer pane on the left to quickly navigate the 
structure by clicking the plus (+) and minus (-) signs.
The heading numbers work in the same way as automatic heading numbers in a 
word processor, like Microsoft Word. They let you see the structure of the 
information in the module, and they automatically change if you change the 
structure of the information, for example, if you insert or delete objects.
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Object Heading and Object Text attributes

The main column is displayed in the standard view of the module. Unlike other 
columns, which contain only one attribute, the main column can display two 
attributes, Object Heading and Object Text.
The following table describes the main column attributes.

About traceability
Rational DOORS lets you link together related information.
For example, you can link a user requirement to the design features that fulfill 
that requirement. You can also link the design features to the verification tests 
for the feature.
Links give you traceability. You can check that what you are building satisfies 
your user requirements.
You can follow links in both directions. For example, if a test fails, you can find 
out which requirements are affected by tracing the links from the test back to the 
design features, and from the design features back to the requirements.
Links allow you to manage change. You can quickly trace the impact of a change 
to a single piece of data on the rest of your system.
For example, the engineering department tells you that they cannot deliver the 
solar-powered battery that you were expecting. You can trace the links from the 
battery object back to the requirements that depend on it, and forward to the 
other features of the car that depend on having a solar-powered battery. You can 
quickly see the full impact of not having a solar-powered battery. You can make 

Attributes in the main 
column

Description

Object Heading This attribute is shown in bold, and has a heading number 
that is automatically generated by Rational DOORS.
For example, look at the object at the top of the previous 
picture. Its Object Heading attribute is Fuel economy, 
and its heading number is 4.1.4.

Object Text This attribute is shown in normal font.
For example, look at the object at the bottom of the 
previous picture. Its Object Text attribute starts with 
Users shall be able to travel at the same level.
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About views

an informed decision about whether to use a conventional battery or whether to 
invest more money, time, and resources to help deliver a solar-powered battery.

About views
Different people need to see different information. Consider the following 
examples:

• Managers are interested in scheduling and cost information.

• Engineers are interested in technical design information.

So you can create different views of modules for different users. Each view 
contains a subset of the objects or attributes in the module.

This picture shows two views of the design module for the car project.
The Management view contains only high priority items and shows priority and 
cost attributes, and the Engineering view contains all items and shows the design 
attribute.
Views let you see exactly what you need without being overwhelmed by too 
much information. You can filter out the data that you do not want to see. Views 
can filter out objects or attributes or both.

About folders and projects
Use folders  to organize the modules in your Rational DOORS database in 
the same way that you use folders to organize the files on your computer.
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A project  is a special kind of folder that contains all the data for a particular 
project. For example, all the information for the new car is in the project called 
Sports utility vehicle 4x2.
Navigate the database hierarchy by clicking the plus and minus signs in the 
Database Explorer, in the same way as you navigate the explorer on Windows®.

Note  Projects can contain folders and folders can contain projects.

Both folders and projects can contain modules. 

About tracking changes
Rational DOORS tracks the changes that are made to the database.
It records the history of changes to the database. For example, when you edit the 
attributes of an object, it records both the old value and the new value.
You can see who has made what changes and when they made them. You can 
look at the history of a module, a particular object, or the user sessions for a 
module. 
Rational DOORS also provides change bars so you can see at a glance what has 
changed.
The color of the change bar, a symbol, and Hover Help tell you the status of an 
object.

Change bar Example Hover Help Description

You have created the object 
during the current session and 
have not yet saved the changes.

You have edited the object 
during the current session and 
have not yet saved the changes.

The object has been changed 
since the module was last 
baselined, and the changes 
have been saved.

The object has not been 
changed since the module was 
last baselined.
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About baselines

Note  You can control what edits are tracked with change bars and 
recorded in the database history. If you do not want to know 
when users edit a particular attribute, you can turn off change 
bars for that attribute.

About baselines
A baseline is a read-only version of a module. It captures and preserves a 
moment in time. 
When you create a baseline of a module, you create a copy of the module that 
nobody can edit.
The baseline includes the following history about the module:

• All the attribute definitions and types that have been created, deleted, or 
edited since the most recent baseline of the module.

• All the objects that have been created, deleted, or edited since the most 
recent baseline of the module.

• Every module session (every time the module has been opened) since it was 
first created.

About edit modes
When you work with modules, you can use one of three edit modes, described 
in the following table:

Either the object was deleted 
before the module was last 
baselined or history has not 
been loaded.

The object was deleted after 
the module was last baselined 
and history has been loaded.

Edit mode Description

Read-only You can view the module, but you cannot edit it.

Exclusive You can edit the module, but other users can only view it.

Change bar Example Hover Help Description
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The status bar at the bottom of the module window displays the edit mode that 
you are currently using.
After you open a module, you can change its edit mode.
For more information, see the online help and Using Rational DOORS.

About the Change Proposal System
The Change Proposal System lets people review modules and suggest changes 
to them. It lets you obtain feedback and change the data in a controlled way.
Users throughout your organization can look at the information that is stored in 
Rational DOORS and make comments about it, but they cannot edit it.
Change proposal managers set up the Change Proposal System and they control 
which data is made available for review and who can review it.
The reviewers can make two types of comments. We use the term proposal for 
both.

A team of change proposal reviewers (sometimes called a Change Control 
Board, or CCB) looks at each proposal and decides on the appropriate course of 
action. They decide whether to accept, reject, or defer the proposal.
Rational DOORS will automatically e-mail you if the status of one of your 
proposals changes, for example, if one of your proposals is accepted.

Shareable You and other users can edit the module at the same time.
While you are editing one section, another user can edit another 
section of the module.

Proposal Description

Suggestion A high-level comment. For example, the suggestion that a 
project needs a test plan.

Change proposal A detailed comment about a particular object in a particular 
module. For example, the proposal that you change the value 
of the Estimated Duration attribute for a particular object 
from 20 days to 30 days.

Edit mode Description
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About partitions

About partitions
Partitions are a means of allowing modules to be edited away from their normal 
location in the home database. The following example describes how to edit 
modules in partitions.
A company uses Rational DOORS to manage its projects. A subcontractor is 
designing part of a project, but does not have access to the home database.
The company creates a partition, which contains the modules that the 
subcontractor needs, and sends it to the subcontractor for editing. All the 
modules that were sent to the subcontractor in the away database are set to 
read-only in the home database.
Each module in the partition is either read-only at the home database or 
read-only at the away database. You cannot edit the same module at both 
databases.
The subcontractor edits the modules, and when they are finished, returns them 
to the home database. Now users at the home database can see the changes 
made at the away database, and the modules are no longer read-only at the home 
database.
Partitions do not include baselines or any history data.
For more information on partitions, see the Rational DOORS online help or 
Managing Rational DOORS.

About user types
Rational DOORS divides users into different types depending on what type of 
management tasks they can do.
Most Rational DOORS users are Standard users; they can work with data, but 
they cannot do any management tasks such as archiving data or creating new 
users.
Project Managers can perform a limited set of management tasks. They can 
partition and archive data, and create and manage groups. They cannot create 
new users, but they can create new groups, add users to groups, remove users 
from groups, and so on.
Database Managers can do every management task. They can do everything 
that Project Managers can do and they can create projects and users, and manage 
the database.
Finally, there are Custom users, who can have any combination of powers. For 
example, a Custom user might have the power to partition data. This user would 
have more power than a Standard user but less power than a Project Manager.
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Database Managers and Custom users who have the power to create users can 
change the type of any user. If you are a Standard user today, it does not mean 
that you will always be a Standard user. For example, if you start to manage a new 
project, you can ask a Database Manager to change your user type from Standard 
user to Project Manager.

About discussions
Discussions is a mechanism for reviewers to exchange views about the content 
of a module or an object within the module.
Instead of setting up linked review documents, or adding new text attributes to 
the module under review, Rational DOORS allows you to maintain running 
discussions about objects and modules. The discussions are presented to you as 
part of the properties of the object or module.
You need to be using a Rational DOORS 9.2 or later Database Server, and the 
server must be configured to exclude Rational DOORS 9.0 clients to make the 
discussions functionality fully available.
You can create, view, and modify discussions for modules and for objects in 
modules.
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3 Quick tour
This chapter contains the following topics:

• About this tour

• Getting ready to start the tour

• Editing a module

• Changing your view

• Making a link

• Creating an attribute

• Sorting and filtering the data

• Finishing the tour

About this tour
This tour gives an overview of Rational DOORS. It should take about 15 
minutes. If you want, you can follow the steps on your computer. Or you might 
prefer just to read through the tour without following the steps yourself.

Getting ready to start the tour
In this part of the tour, you install the Example Database, run Rational DOORS 
and then make a copy of an example project.
Throughout the rest of the tour you use the copy of the example project, so it 
does not matter if you make any mistakes during the tour. You still have the 
original copy.
Before you install the Example Database, you must install a Rational DOORS 
client. For instructions on how to install a Rational DOORS client, see the 
Rational DOORS Installation Guide, which is available from our website at 
http://www.ibm.com/software/awdtools/doors/support/doc.html.

Install and run the Example Database

To install and run the Example Database:
1. Install the Example Data:
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a. Get the Rational DOORS Example Data software from your system 
administrator. The file is called IBM Rational DOORS 9.2 Example 
Data.msi. Copy it to your machine.

b. Navigate to the file, and double-click it.

The Welcome screen is displayed.

c. Click Next.
The License Agreement screen is displayed.

d. If you accept the terms of the license agreement, select the I accept... 
option and click Next.
The Ready to Install the Program screen is displayed. 

e. Click Install.
When all the files are copied, the Finish screen is displayed.

f. Click Finish.

2. Start the Example Database.

Click Start > All Programs > IBM Rational > IBM Rational DOORS 
9.2 Example Data.

Rational DOORS opens with a Login window, prompting you for a user 
name and password.

3. Type the user name Eric McCall and the password Training, with 
capitalization just as it appears here. User names and passwords are 
case-sensitive in Rational DOORS.

4. Click OK.

5. If you see the Welcome Screen, close it.

The Database Explorer is displayed.

You can now copy a Rational DOORS project.

6. In the right pane, double-click the Example Data folder.

7. Still in the right pane, double-click Company Programs, and then Vehicle 
projects, and then Light Trucks. 

You see the Sports utility vehicle 4x2 project in the right pane.

8. Select the Sports utility vehicle 4x2 project in the right pane then press 
CTRL+C to copy it to the Database Explorer clipboard.

9. Double-click the Prototypes folder to open it. 
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Editing a module

The Prototypes folder is now displayed in the left pane with an open folder 
icon . 

10. Press CTRL+V to paste the example project into the Prototypes folder.

Rational DOORS creates a project called Copy of Sports utility vehicle 
4x2. This takes about 30 seconds.

Editing a module
In this part of the tour you edit the text in a module and create objects in the 
module:

1. Double-click first the copy of the project, and then the Requirements 
folder in it.

You see the User Requirements module in the right pane.

2. Double-click the User Requirements module to open it.

3. Double-click the requirement under the User types heading, and change 
proposed vehicle to new vehicle. 

Double-clicking puts you in edit mode; you get a cursor at the start of the 
object. The cursor is a thin vertical bar that does not flash. Move the cursor 
by using the arrow keys or clicking your mouse, and then delete proposed 
and type new.

Notice the thin line above and below the object, which shows that it is the 
current object.

4. Scroll to the object with the pale gray background after the table, and try to 
edit it. You cannot; nothing happens when you type. The pale gray 
background indicates that you only have read access to the object. You are 
not allowed to edit it.

5. Now scroll to the end of the module, so that you can see the last object, 
Expected further costs.

Single-click this object (do not double-click it), and type None. Your text is 
added to the end of the object.

As soon as you start typing, Rational DOORS automatically puts you into 
edit mode and moves the cursor to the end of the object. This is a quick way 
to edit objects.

6. Now press CTRL+RETURN to create an object, and type some text into 
it.
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7. Press CTRL+RETURN twice without typing anything, and notice that 
Rational DOORS gives the first new object a heading number (7.1). This is 
because you did not type any text, so Rational DOORS assumed it was a 
heading.

Pressing CTRL+RETURN creates an object at the same level in the 
hierarchy as the current object.

8. Now create an object one level below the current object by clicking New 
object below  on the Object toolbar.

Note  If you start typing after you click the icon, the heading 
number disappears and the object is no longer a heading. 
If you want to type a heading, click Edit Object 
Heading  on the Object Edit toolbar before you 
start typing.

9. Delete the objects you created. Either click the right mouse button and 
select Delete from the pop-up menu, or press DELETE.

10. Scroll back to the top of the module and turn change bars on. Click View > 
Show > Change Bars.

You see colored change bars on the left.

• The red Unsaved Changes change bar shows you have edited the 
object during the current session but have not yet saved the module, so 
the changes are in memory. The changes are saved to the database when 
you save the module.

• The yellow Saved Changes change bar shows the object has been 
edited since the module was baselined, and the changes have been saved.

11. Double-click the red Unsaved Changes change bar by the object you 
edited at the start of the tour to see the history of changes to the object.

Select the last entry to display details of your change.

You are looking at the properties sheet for the object, which you can use to 
find out information about access rights, attribute values, and links.

12. Click Next or Previous to display the next or previous object. Notice that 
as you do this, the current object changes in the module window to match 
the one you are looking at on the properties sheet.

13. Click Cancel to close the properties sheet.
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Changing your view

Changing your view
In this part of the tour you look at different views of the module.

1. Select Basic view with explorer from the drop-down list of available views 
and scroll to the top of the module.

This view shows the Module Explorer, which shows you the structure of the 
object hierarchy and lets you quickly navigate it. 

2. Click the plus signs in the left pane to display 4.1.4 Fuel economy. 

3. Click this object in the left pane to make it the current object in the right 
pane.

4. Turn the Module Explorer off. Click View > Module Explorer.
5. Look at another view. Select the Budget view.

This view has five columns. The column on the left shows the unique object 
identifier that Rational DOORS generates for each object. It has a prefix 
(SOW) and an object number (for example, 11).

The next column is the main column, and displays the Object Heading 
and Object Text attributes.

Notice that the current object is not the first object in the module. When 
you create a view you can control every aspect of what the screen looks like 
when the view is first loaded, including which object is the current object.

6. Use the drop-down list of views to select other views and see how views can 
totally alter your view of the same data. Views let you hide or show whatever 
information you want.

7. Now turn off the display of change bars. Click View > Show > Change 
Bars.

8. Use the Display to level drop-down list, which you will find to the right of 
the View drop-down list, to select Level 1.

Now you see only the seven top-level objects in the module. The > symbol 
shows that lower level objects are hidden.

9. Select All levels in the drop-down list to display all the objects again.

10. Click View > Outline.

Outlining is turned on. Now you see only objects that have headings.

11. Click the Requirements heading to make it the current object, as shown in 
the previous example. Now compress it by clicking View > Compress.

The plus sign shows that section 4 is compressed.
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12. Decompress section 4. 

Make sure it is the current object, and then click View > Compress.

13. Turn outlining off.

Click View > Outline.

Making a link
In this part of the tour you follow and create links:

1. Use the drop-down list of available views to select the Basic view again. 

2. Scroll to the top of the module.

3. Turn the display of link arrows on by clicking View > Show > Link 
Arrows.

Red and yellow link arrows are displayed.

Roll over the red arrow to see how many out-links the object has. For the 
second object in the module, there is one out-link:

4. Right-click the red link arrow to display a pop-up menu that shows 
information about the target object.

The target object is in the Functional Requirements module. The module 
is not open, so you see <unloaded> preceded by the object number, 145.

5. Select 145 <unloaded> from the pop-up menu to open the module, with 
that object as the current object.

The target object has an yellow in-link arrow. Right-click it and use the 
pop-up menu to go back to the User Requirements module.

6. Now make a link. In the User Requirements module:

a. Scroll to the top of the module and single-click the second object to 
make it the current object.

Note  Make sure you single-click the object to select it. If 
you double-click, you go into edit mode and see the 
edit mode pop-up menu.

b. Right-click Link > Start Link. 

The object turns pink showing it is the link start.

7. Now select any object in the Functional Requirements module, and 
right-click Link > Make Link from Start.
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Making a link

If you see messages asking if you want to create link modules and linksets, 
click Yes.

The link is created. In the User Requirements module, the red link arrow 
now says the object has two out-links.

8. The object is still pink so you can repeat Step 7 to create more links that 
have that object as the source.

When you have finished, clear the link start by clicking Link > Clear Start. 
The object is no longer pink.

Notice that the right-click link options you used earlier are also on the Link 
menu.

9. Finally, look at the Traceability Explorer, which provides another way of 
showing and navigating links. 

In the User Requirements module window, click Analysis > Traceability 
Explorer.
The Traceability Explorer is displayed, showing a flat list of all the objects 
in the module.

10. Click View > Out-links to see which objects have out-links.

Objects that have links have a plus sign (+) beside them.

Note  If you do not see any plus signs in the Traceability 
Explorer, it could be because the target modules are not 
open. Click View > All Modules to show information 
about all links, regardless of whether the target modules 
are open. 

11. Click the plus sign beside object 1.0-1 to show information about its links.

12. Select the linked object 1.0-1, and notice that the status bar shows which 
module it is in (Object FR-145 in /Copy of Sports utility vehicle 
4x2/Requirements/Functional Requirements).

13. Right-click the linked object and select Show Object to open the target 
module with the object as the current object.

14. Go back to the Traceability Explorer, and click View > In-links. Click View 
> All Modules to display in-links from all modules, instead of only modules 
that are currently open.

Now you can see which objects have in-links.

Notice that there is now an in-link arrow. The direction of the arrows in the 
Traceability Explorer shows whether you are looking at in-links or out-links.
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15. In the Traceability Explorer window, click File > Exit.

Creating an attribute
In this part of the tour you create an attribute, add a column to display it, and 
then change the position of the column.

1. In the User Requirements module, click Edit > Attributes.

The Columns and Attributes dialog box is displayed, with the Attributes 
tab selected.

2. Click New to create an attribute.

3. Fill in the following details for the new attribute:

a. In the Name box, type Approved.

b. In the Description box, type An attribute to record whether an 
object is approved.

c. In the Type box, select Yes or No.

d. Select the Default value box, and then select No as the default value.

e. At the bottom left of the window, select the Add new attribute to 
current view box.

f. Click OK.

g. Click Close to close the Columns and Attributes dialog box.

The module now has an Approved column. You set the default value to be 
No, so every object has the value No.

4. Change the value to Yes for the second object:

a. Double-click the current value (No).

You see a drop-down list of the values the attribute can have (Yes, No, 
or Reset to Default). In this case the default is No.

b. Pick Yes from this list.

c. Either click Accept changes  on the Commit toolbar, or click any 
other object to accept the new value.

5. Now center the text in the Approved column. Right-click the column title 
then select Center from the pop-up menu.

Notice that the background color of the column title turns a paler shade of 
gray, showing that it is selected.
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Sorting and filtering the data

6. Drag the column title to the left. The whole column moves when you release 
the mouse button.

Sorting and filtering the data
In this part of the tour you sort the data and then apply a filter to it:

1. Sort the data using the Approved attribute. Click Tools > Sort.
2. Select Approved and Ascending, and then click Add. The sort is added to 

the Sort list.

3. Click OK.

You see all the approved items, followed by all the items that have not yet 
been approved.

4. Scroll down to where the table was. Notice that it is replaced by a single 
object with >> Table. This is a table marker object.

Tables are hidden when you apply a sort.

5. Click Turn sorting on or off  on the Display toolbar. The sort is turned 
off and the table is no longer hidden. Scroll to the table to check you can see 
it.

6. Now filter the view and display only the objects that contains the word 
safety. Click Tools > Filter > Define and type safety in the third box.

7. Click OK.

You see only objects that contain the word safety. 

This is a simple filter. You can set up advanced filters that let you define 
much more complex filtering criteria.

8. Turn the filter off. Click Turn filtering on or off  on the Display 
toolbar.

Finishing the tour
In the final part of the tour you go back to the Database Explorer, look at 
Project view, delete then purge the copied project you have been using, and then 
exit Rational DOORS.

1. Close the modules you opened. In each module window, click File > Close.

2. If you see messages asking if you want to save the changes you made to the 
modules, click No.
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3. In the Database Explorer, you see the database  at the top level in the left 
pane. You are in Database view.

4. Switch to Project view by clicking View > Project View.

Now the top-level items are projects. You see all the projects you are allowed 
to access. Project view is useful if you have a deep database hierarchy, 
because in Project view you do not have to navigate the hierarchy to find the 
projects you work on.

5. Switch back to Database view. Click View > Database View.

6. Double-click the Prototypes folder in the left pane to make it your current 
folder. It has an open folder icon .

7. In the right pane, select the copied project you created at the start of the tour 
then click File > Delete. The project disappears.

8. Turn on the display of deleted items. Click View > Show Deleted Items.
You see the deleted project . It has a red cross in the corner of the icon.

9. Select the deleted project , and then click File > Purge.

You see a message asking if you really want to purge the project. 

10. Click Yes.

The project is permanently removed from the database.

11. Exit Rational DOORS. Click File > Exit.
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4 Contacting support
This chapter contains the following topics:

• Contacting IBM Rational Software Support

• Prerequisites

• Submitting problems

• Other information

Contacting IBM Rational Software Support
If the self-help resources have not provided a resolution to your problem, you 
can contact IBM Rational Software Support for assistance in resolving product 
issues.

Note  If you are a heritage Telelogic customer, you can go to 
http://support.telelogic.com/toolbar and download the 
IBM Rational Telelogic Software Support browser toolbar. 
This toolbar helps simplify the transition to the IBM Rational 
Telelogic product online resources. Also, a single reference 
site for all IBM Rational Telelogic support resources is 
located at 
http://www.ibm.com/software/rational/support/telelogic/

Prerequisites
To submit your problem to IBM Rational Software Support, you must have an 
active Passport Advantage® software maintenance agreement. Passport 
Advantage is the IBM comprehensive software licensing and software 
maintenance (product upgrades and technical support) offering. You can enroll 
online in Passport Advantage from 
http://www.ibm.com/software/lotus/passportadvantage/howtoenroll.html.

• To learn more about Passport Advantage, visit the Passport Advantage 
FAQs at 
http://www.ibm.com/software/lotus/passportadvantage/brochures_faqs_
quickguides.html.

• For further assistance, contact your IBM representative.

To submit your problem online (from the IBM Web site) to IBM Rational 
Software Support, you must additionally:
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• Be a registered user on the IBM Rational Software Support Web site. For 
details about registering, go to 
http://www-01.ibm.com/software/support/.

• Be listed as an authorized caller in the service request tool.

Submitting problems
To submit your problem to IBM Rational Software Support:

1. Determine the business impact of your problem. When you report a 
problem to IBM, you are asked to supply a severity level. Therefore, you 
need to understand and assess the business impact of the problem that you 
are reporting.

Use the following table to determine the severity level.

2. Describe your problem and gather background information, When 
describing a problem to IBM, be as specific as possible. Include all relevant 
background information so that IBM Rational Software Support specialists 
can help you solve the problem efficiently. To save time, know the answers 
to these questions:

• What software versions were you running when the problem occurred?

To determine the exact product name and version, use the option 
applicable to you: 

Severity Description

1 The problem has a critical business impact: You are unable to 
use the program, resulting in a critical impact on operations. 
This condition requires an immediate solution.

2 This problem has a significant business impact: The program 
is usable, but it is severely limited.

3 The problem has some business impact: The program is 
usable, but less significant features (not critical to 
operations) are unavailable.

 4 The problem has minimal business impact: The problem 
causes little impact on operations or a reasonable 
circumvention to the problem was implemented.
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Submitting problems

• Start the IBM Installation Manager and select File > View 
Installed Packages. Expand a package group and select a package 
to see the package name and version number. 

• Start your product, and click Help > About to see the offering 
name and version number. 

• What is your operating system and version number (including any 
service packs or patches)? 

• Do you have logs, traces, and messages that are related to the problem 
symptoms? 

• Can you recreate the problem? If so, what steps do you perform to 
recreate the problem? 

• Did you make any changes to the system? For example, did you make 
changes to the hardware, operating system, networking software, or 
other system components? 

• Are you currently using a workaround for the problem? If so, be 
prepared to describe the workaround when you report the problem.

3. Submit your problem to IBM Rational Software Support. You can submit 
your problem to IBM Rational Software Support in the following ways:

• Online: Go to the IBM Rational Software Support Web site at 
https://www.ibm.com/software/rational/support/ and in the Rational 
support task navigator, click Open Service Request. Select the 
electronic problem reporting tool, and open a Problem Management 
Record (PMR), describing the problem accurately in your own words.

For more information about opening a service request, go to 
http://www.ibm.com/software/support/help.html

You can also open an online service request using the IBM Support 
Assistant. For more information, go to 
http://www-01.ibm.com/software/support/isa/faq.html.

• By phone: For the phone number to call in your country or region, go 
to the IBM directory of worldwide contacts at 
http://www.ibm.com/planetwide/ and click the name of your country 
or geographic region. 

• Through your IBM Representative: If you cannot access IBM 
Rational Software Support online or by phone, contact your IBM 
Representative. If necessary, your IBM Representative can open a 
service request for you. You can find complete contact information for 
each country at http://www.ibm.com/planetwide/.
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If the problem you submit is for a software defect or for missing or inaccurate 
documentation, IBM Rational Software Support creates an Authorized Program 
Analysis Report (APAR). The APAR describes the problem in detail. Whenever 
possible, IBM Rational Software Support provides a workaround that you can 
implement until the APAR is resolved and a fix is delivered. IBM publishes 
resolved APARs on the IBM Rational Software Support Web site daily, so that 
other users who experience the same problem can benefit from the same 
resolution.

Other information
For Rational software product news, events, and other information, visit the 
IBM Rational Software Web site on http://www.ibm.com/software/rational/.
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5 Notices
© Copyright IBM Corporation 1993, 2010
US Government Users Restricted Rights - Use, duplication, or disclosure 
restricted by GSA ADP Schedule Contract with IBM Corp.
This information was developed for products and services offered in the U.S.A. 
IBM may not offer the products, services, or features discussed in this document 
in other countries. Consult your local IBM representative for information on the 
products and services currently available in your area. Any reference to an IBM 
product, program, or service is not intended to state or imply that only that IBM 
product, program, or service may be used. Any functionally equivalent product, 
program, or service that does not infringe any IBM intellectual property right 
may be used instead. However, it is the user’s responsibility to evaluate and verify 
the operation of any non-IBM product, program, or service. 
IBM may have patents or pending patent applications covering subject matter 
described in this document. The furnishing of this document does not grant you 
any license to these patents. You can send written license inquiries to:  
 
IBM Director of Licensing 
IBM Corporation 
North Castle Drive 
Armonk, NY 10504-1785 
U.S.A.  
 
For license inquiries regarding double-byte character set (DBCS) information, 
contact the IBM Intellectual Property Department in your country or send 
written inquiries to:  
 
Intellectual Property Licensing 
Legal and Intellectual Property Law 
IBM Japan Ltd. 
1623-14, Shimotsuruma, Yamato-sh 
Kanagawa 242-8502 Japan 
 
The following paragraph does not apply to the United Kingdom or any 
other country where such provisions are inconsistent with local law: 
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES 
THIS PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, 
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EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, 
THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, 
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. 
Some states do not allow disclaimer of express or implied warranties in certain 
transactions. Therefore, this statement may not apply to you. 
This information could include technical inaccuracies or typographical errors. 
Changes are periodically made to the information herein; these changes will be 
incorporated in new editions of the publication. IBM may make improvements 
and/or changes in the product(s) and/or the program(s) described in this 
publication at any time without notice. 
Any references in this information to non-IBM Web sites are provided for 
convenience only and do not in any manner serve as an endorsement of those 
Web sites. The materials at those Web sites are not part of the materials for this 
IBM product and use of those Web sites is at your own risk. 
IBM may use or distribute any of the information you supply in any way it 
believes appropriate without incurring any obligation to you. 
Licensees of this program who wish to have information about it for the 
purpose of enabling: (i) the exchange of information between independently 
created programs and other programs (including this one) and (ii) the mutual use 
of the information which has been exchanged, should contact:  
 
Intellectual Property Dept. for Rational Software 
IBM Corporation 
1 Rogers Street 
Cambridge, Massachusetts 02142 
U.S.A. 
 
Such information may be available, subject to appropriate terms and conditions, 
including in some cases, payment of a fee. 
The licensed program described in this document and all licensed material 
available for it are provided by IBM under terms of the IBM Customer 
Agreement, IBM International Program License Agreement or any equivalent 
agreement between us. 
Any performance data contained herein was determined in a controlled 
environment. Therefore, the results obtained in other operating environments 
may vary significantly. Some measurements may have been made on 
development-level systems and there is no guarantee that these measurements 
will be the same on generally available systems. Furthermore, some 
measurements may have been estimated through extrapolation. Actual results 
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Trademarks

may vary. Users of this document should verify the applicable data for their 
specific environment. 
Information concerning non-IBM products was obtained from the suppliers of 
those products, their published announcements or other publicly available 
sources. IBM has not tested those products and cannot confirm the accuracy of 
performance, compatibility or any other claims related to non-IBM products. 
Questions on the capabilities of non-IBM products should be addressed to the 
suppliers of those products.
This information contains examples of data and reports used in daily business 
operations. To illustrate them as completely as possible, the examples include the 
names of individuals, companies, brands, and products. All of these names are 
fictitious and any similarity to the names and addresses used by an actual 
business enterprise is entirely coincidental. 
If you are viewing this information softcopy, the photographs and color 
illustrations may not appear. 
Additional legal notices are described in the legal_information.html file that is 
included in your software installation.

Trademarks

IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of 
International Business Machines Corp., registered in many jurisdictions 
worldwide. Other product and service names might be trademarks of IBM or 
other companies. A current list of IBM trademarks is available on the Web at 
www.ibm.com/legal/copytrade.html.
Microsoft and Windows are trademarks of Microsoft Corporation in the United 
States, other countries, or both.
Other company, product or service names may be trademarks or service marks 
of others.
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