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Exercise 5.a - Your first Node.js application
In this exercise we switch from Java to Node, which uses javascript on the server.

A typical “hello world” application is :

var http = require('http');

http.createServer (function (req, res) {
res.writeHead (200, {'Content-Type': 'text/plain'});
res.end ('Hello World\n');

}) .1listen(3000) ;

Create this file using a text editor installed on your system' in a clean directory and call it

app.js. If you have a local install of Node, you could run this using node app.js

This will start a web server and every request will respond with Hello World. To run this on
Bluemix we need to make a couple of changes. The first change is to get the application
to listen on the port Bluemix has assigned for the application. Environment variables are
used by Bluemix to communicate configuration to the application:

var http = require('http');

var appport = process.env.VCAP_APP PORT || 3000;
http.createServer (function (req, res) {
res.writeHead (200, {'Content-Type': 'text/plain'});

res.end ('Hello World\n') ;
}) .listen (appport) ;

The next is to add a step is to create a package.json — this is required to run a node
application on Bluemix.

{

"name": "BINodeTest",

"version": "0.0.1",

"description": "Sample Node application”
}

Create a new text file called package.json in the same directory as app.js and enter the
content above.

To deploy the application on Bluemix we will initially use the CLI. Open a
command/terminal window and change to the directory containing app.js and

package.json then enter the command
cf push BINodeTest -c 'node app.]js'

If you navigate to the Bluemix Web Ul you should see the application running — with “Hello
World” displayed in the browser when you launch the application.

! notepad on windows or TextEdit on Mac — please use text mode with smart features turned off, such as
smart quotes
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Exercise 5.b — Working with Node using Eclipse
In this exercise you will use Eclipse to create a Node.js application then deploy it to

Bluemix.
Launch Eclipse. If using a fresh workspace you need to create the Bluemix server

configuration — we did this in section 3.
Create a new javascript project File -> New -> Other

When the Select a wizard dialog is displayed select Javascript -> JavaScript Project.

Select a wizard

Create a JavaScript project

Wizards:

| d=19"

P (= Database Web Services
P (= Eclipse Modeling Framework
»(=E8B

» (= Enterprise Extensions
» (=Git

> (= Java

P (= Java EE

P (= Java Emitter Templates
¥ (= JavaScript

& JavaScript Project

%\ JavaScript Source File
» (= JAXB
P (=Jazz Source Control

Next > | Cancel

When the Create a JavaScript project dialog appears. Give the project a name and remove
the Web Page Support option.

Create a JavaScript project J
Create a JavaScript project in the workspace or in an external location. —

Project name: | NodeEclipseApplicatior|

Contents

(@) Create new project in workspace

Create project from existing source

Directory: /Use:

Web Page Support

Include Web Browser Library

Project layout

(2) Use project folder as root for the JavaScript global context

Create a separate root folder Configure default.

Working sets
Add project to working sets

Working sets:

click Finish — will switch to JavaScipt perspective — accept this recommendation.
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[ Project Explorer 88 = a8 = B8 5= outline 2 =8
= —F{‘ E - v A
b e Local Filesystem An outline is not available.
& NodeEclipseApplication
b = JavaScript Resources
@Connections
-

[:_ Problems 23 Documentation Declaration = B8
0items
Description 4 Resource Path Location Type

To add Bluemix support to the project you need to add a Facet to the project. Right-click
the project name and select Project Facets — select ‘Convert to faceted form...’

type filter text Project Facets =l vw
P Resource
Android This project is not configured to use project facets. Converting this project to faceted form will allow you
Builders to easily control the available technologies.

Convert to faceted form...

Content Assist
File Transfer
Formatter

P JavaScript

P JSHint
Preview Settings

Project Facets

Project Natures
Project References
Run/Debug Settings
» Task Repository
Task Tags
P Validation
WikiText

then select ‘Node.js Application’

Project Facet o

T L e
|=| Default synchronization policy for CVS repag
() Dynamic Web Module
[ EAR
(& E)B Module
|~ E)BDoclet (XDoclet)
[1) Java
\=] JavaScript
|=) JavaServer Faces
|1 JAX-RS (REST Web Services)
<+ JAXB
JCA Module
©JPA
‘zt Liberty Feature
v | Node.js Application
(4 OSGi Application
&5 0SGi Bundle
4B 0sGi Composite Bundle
4 OSGi Fragment
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You will see that app.js and package.json are added to the project and the contents of the
file will look similar.

= 50 Qv Qv oS v 0 b oo ay R Quick Access J 75 | ¢9Java EE | 8}*Javascript
L[ Project Explorer 23 =" ml [2) app.js =2 =8 0% Outline & =g
= s
== e 1 S laz}\\ ox @ ¥
VL_;gNndeEchpseAppllcauon * Generated Node.js application that can run on IBM Bluemix © http-any
P =) JavaScript Resources */ © appport : Number
|5 package.json 6 var http = require("http");

# wvar appport = process.env.VCAP_APP_PORT || 8888;

10 http.createServer(function(request, response) {

12 response.writeHead(200, {"Content-Type": "text/plain"});

13 response.write("Generated Node.js application that runs on IBM Bluemix");

response.end();

}).listen(appport);

To deploy the application you need to open the Servers view Window -> Show View ->
Other. Then in the dialog that opens select Server -> Servers.

6. .06 Show View

type filter text
)
» (= Git
» (= Help
»(>Java
» (= Java Browsing
» (= JavaScript
> (> JavaServer Faces
»JPA
» (= Make
» (= Maven
» (= Mylyn
» (= Plug-in Development
» (= Remote Systems
¥ (= Server
(@ Runtime Explorer

b (= Team

Cancel | oK |

Right-click Bluemix then select your Node application and move it to the Configured
column.

Add and Remove “ ‘

Modify the resources that are configured on the server

Move resources to the right to configure them on the server

Available: Configured:
. NodeEclipseApplication
( Add >
Ren
Add All >>
<< Remove Al
®@ < Back Next > [ cancel Finish

The Bluemix deploy wizard will start. Eclipse does not use the manifest file, but you can
select to generate a file as a result of the Eclipse deploy:
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Application details
Specify application details. «

| &%

Name: | NodeEclipseApplication

Buildpack URL (opticnal):

@ Save to manifest ﬁie b

@ < Back | Next> | | Cancel | Finish

Give the application a unique name, modify the memory requirement to 128M and select
to deploy 2 instances. Complete the deployment — there are no services needed for this
deployment.

Once the application is running open the generated manifest.yml file and verify the options

to selected are in the manifest file.

Once deployed you can run the Node application by right-clicking the application in the
Servers view then selecting to open home page.

[2] Problems (@ Documentation [, Declaration ) Console i Server:

v &ff 1BM Bluemix - binnes( ng.bluemix.ne
 Bigocf - Deployed as Bl )
5 BllavaCloudantDBApp tDBApp [Startec

New >
Start

Stop

“ Restart

% Remove ®

Show Console
Update and Restart

Open Home Page

Properties

Once you have tested the application right click the application under the Bluemix server
definition and select to remove the application

|2/ problems @ Documentation [} Declaration ) Console 4 Servers 53
v & 1BM Bluemix - binnes@uk.ibm.com - test - https://api.ng.bluemix.net [Started]
% Blgocf - Deployed as Blgocf [Started, Synchronized]
2 BUavaCloudantDBApp - Deployed as BlJavaCloudantDBApp [Started, Synchronized|

# NodeEclipseApplication - Deployed as NodeEclips Now >
Start
Stop
“, Restart
"~ Remove ®

Show Console
Update and Restart
Open Home Page

Properties
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Exercise 5.c - Working with Node using DevOps Services
In Bluemix deploy the Node.js Cache Web Starter from the Catalog view in the Bluemix Ul.

Node.js Cache Web St...
IBM

Once the application has started from the application overview page select ‘ADD GIT’

¥ BINodeWebStarter

Ensure the “Populate the repository with the starter application package ...” is selected

Press Continue to create a Git repository associated with the BINodeWebStarter
application. Pushing changes to this repository will trigger automatic deployment to the
application.

« Populate the repository with the starter application package and deploy it to the
application.

Select ‘EDIT CODE’ to be taken to the DevOps Services project

N\ BINodeWebStarter

VIEW GUIDE ROUTES: GIT URL:

The Node.js Web Starter project uses the express framework. If you open the
package.json in the DevOps editor you will see the project dependencies.

Node applications do not need to be compiled before they are deployed, so the simple
Build & Deploy option within DevOps Services can be used. If you select the BUILD &
DEPLOY tab , you will see the project is already configured.

Copyright IBM Corporation 2013-2014. All rights reserved.
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OFF SIMFP ADVANCED REQUEST DEPLOY

Warning: Your git project has outgoing changes. Go to the Git Repository View to commit and push if you want to include them in your application.

Git URL https://hub.jazz.net/git/binnes/BINodeWebStarter
Deploy from: refs/heads/master +
Deploy to: BINodeWebStarter BINodeWebStarter. mybluemix.net

Status Result Comment Committer Started Logs

(V] OK Add starter application package Brian Innes 13 minutes ago Log

To test the configuration, select REQUEST DEPLQY. After a short while you will see the
deploy result

Status Result Comment Committer Started Logs
(V] OK Add starter application package Brian Innes 1 minute ago Log
(V] OK Add starter application package Brian Innes 36 minutes ago Log

The Simple automatic deployment works the same way as the Advanced that we used in
section 4. Select EDIT CODE and open file routes/cache.js in the editor. Scroll to the
bottom of the file and locate the putCache and removeCache functions. Change the
strings that are displayed on the web Ul when a cache operation stores or removes a key:

Put successfully. => Stored it
Remove successfully. => deleted it

exports.getCache = (req, res) {
key = req.params.key;
console.log("get key:" + key);
wxsclient.get(key, (wxsres) {
res.json({
value : wxsres
1
}s
};

exports.putCache = (req, res) {
key = req.query.key;
value = req.query.value;
wxsclient.put(key, value, () {
res.json({
value : "Stored it"
})s
}s
};

exports.removeCache = (req, res) {
key = req.params.key;
wxsclient.remove(key, () {
res.json({
value : “"deleted it"
})s
console.log('finished remove');
1
};

Copyright IBM Corporation 2013-2014. All rights reserved.
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Make sure you save the file

select all changed files, enter a comment for the commit

Working Directory Changes

I+
I+

mfll commIT

Modified cache operation confirmation strings

(CJAmend previous commit (_JAdd Change-ID to message more ..

Select All 4 files selected

.cfignore
.gitignore

project.json

routes/cache.js

then select COMMIT. Once you committed the changes push them to the remote branch
by selecting Push -> Push All.
Active Branch (master) Y ok Worki

D Working Directory Changes o
Nothing to commit.

v OUTGOING (1) PUSH

Push All

Force Push All
Push Branch
Force Push Branch

Quickly switch to the BUILD & DEPLOY tab and you will see that a deploy has been
initiated.

o Pending

Modified cache operation col

2

~ Brian Innes on 6 October 2014
BST

more ...

After a short while the deploy will complete and you should see a success status with the
commit message displayed in the comment.
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orf  [EIE Abvanced REQUEST DEPLOY

Git URL https://hub.jazz.net/git/binnes/BINodeWebStarter
Deploy from: | refs/heads/master |
Deploy to: BINodeWebStarter BiNodeWebStarter. mybluemix.net

Status Result Comment Committer Started Logs
[ OK Modified the cache operation strings Innes Less than one minute Log
ago
(V] OK Add starter application package Brian Innes 35 minutes ago Log
(V] OK Add starter application package Brian Innes 1 hour ago Log

You can launch the application by selecting the link on the ‘Deploy to:"line.

Add a value to the cache and you will see the modified message displayed
Grid Operations:

Key: ‘ test ‘
Value: ‘ key ‘
Stored it

B T
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Exercise 5.d — Selecting files to include in your application
The .cfignore file controls what files are pushed to Bluemix.

In the Bluemix Web Ul open the Node.js Web Starter app that was deployed in previous
sections of this section. Navigate to the Files and Logs section and open the app

directory
|

bluemix
buildpack-diagnostics
.cfignere

.gitignore

npmrc

.profile.d

License.txt

Procfile

README.md
README.txt

app.s

PDDrPrPrRPDDIDD DD

manifest.ym

¢

node medules

you will see the files that are deployed, including a file named instructions.md. This is a file
that explains what the starter application is and is not part of the application. We want to
stop this file from being deployed to Bluemix.

In DevOps Services open the ‘.cfignore’ file in the editor and add instructions.md to the
end of the file on a new line.

launchConfigurations/
.git/
ipstructions.md

Save the file then commit and push the changes to the remote repository. This will force
the project to be redeployed.

Switch back to the Bluemix Ul and open the Files and Logs section of the application. You
should now see that the ‘instructions.md’ file is no longer included with the application
deployed to Bluemix.
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