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Chapter 1. Introduction

This sample shows you how to use IBM Integration Designer to create a map for an XML Firewall. You
also learn how to transfer the files that you created to the DataPower appliance, and test the service.

In the sample, you learn how to complete the following activities:
v Enable DataPower function in Integration Designer.
v Create a DataPower library.
v Create business objects.
v Create a simple XML map.
v Transfer files to a DataPower Appliance.
v Create an XML firewall service..
v Test the service from Integration Designer.

Prerequisite:

To run this sample, you must have access to a WebSphere DataPower Appliance.

Overview
In this sample, your goal is to create two simple business objects as input and output, and to map the
input business object to the output business object by using an XML map. You then transfer the files that
you created to a DataPower appliance and create and test an XML firewall service.

In this sample, you will map an input business object called fullname to an output business object called
title_firstname_lastname by using an XML map.

The input business object fullname has three fields of type string, as shown below:

The output business object title_firstname_lastname has a single field name of type string, as shown
below:

Your goal is to take input data from the three fields of fullname, concatenate the strings, and populate
the resulting string in the name field of title_firstname_lastname.
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Chapter 2. Build it yourself

You can use the Business Object editor and the XML map editor in IBM Integration Designer to build the
sample.

To build the sample, you will complete the following steps:
1. Set the DataPower capability.
2. Create a DataPower library.
3. Create the input and output business objects.
4. Map the business objects.
5. Transfer the XML map to a WebSphere DataPower Appliance.
6. Create an XML firewall service on a WebSphere DataPower Appliance.
7. Test the service using the Generic Service Client in Integration Designer.

Set the DataPower Capability
Integration Designer is the development environment for many different runtimes. If all of the tooling is
shown the business integration view can get cluttered. In order to make it easy for users to find the tools
that they need, Integration Designer provides a filtering function known as capabilities.

With capabilities, you can choose to hide the tools that you do not use. At any time, you can choose to
show those tools again. To use tools for the DataPower Appliance, you must enable the DataPower
capability.

To enable the DataPower capability follow these steps:
1. Go to the Getting Started page by clicking Help > Getting Started with IBM® Integration Designer.
2. If the section What environment do you want to use? shows that WebSphere DataPower function is

enabled as shown below, you can proceed to the next task.

3. Otherwise, click the Change Environment button.

4. In the Environment Capabilities dialog, select the WebSphere DataPower option.
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5. Click OK.

Create a DataPower library
You must use a special type of library called a DataPower library to create and store artifacts for
deployment to the DataPower Appliance.

To create a DataPower library, follow these steps:
1. Click File > New > Project.
2. In the list of projects, select DataPower Library and click Next.
3. Name the library HelloWorldDataPowerLibrary.
4. Click Finish.

The library appears in the Business Integration view.

Create business objects
A business object is a container for application data, such as a customer or an invoice. The underlying
structure of a business object is an XML schema definition (XSD).

If you want to use existing XSDs you can import them into the workspace using File > Import. Business
objects are automatically created for the XSDs and you can map them in the XML map editor. In this
sample, you create the business objects.

To create the business objects for this sample, follow these steps:

4 Integration Designer: Hello World for WebSphere DataPower Appliance



1. In the Business Integration view, within the HelloWorldDataPowerLibrary, right-click the Data
category and select New > Business Object. The New Business Object wizard opens.

2. In the Name field, enter fullname.
3. Select the option Create the business object as an element.

4. Click Finish. The Business Object editor opens.
5. Add a source business object by clicking the Add a field to a business object icon in the local

toolbar (or right-click the fullname box and select Add Field):

6. Type over the generated field's name of field1 and replace it with title. If the name is not selected,
then first click on it to select it.

7. Repeat the previous step to create two more fields; one named firstName and the other named
lastName. The final business object should look like this:
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Optional: Select one of the string cells in the Type column. A list of types appears. Although you
only need fields of type string for this sample, this is where you can specify other types. Press the
Esc key to close the list.
Optional: Select a field and look at the Properties view below the editor. Although you do not need
to set any of these fields for this sample, this is where you can specify certain properties for fields,
such as specifying field repetition or maximum length.

8. Press Ctrl-S to save your work, and then close the business object editor.
Optional: Under the covers, you have just created a new XSD or XML schema file with a complex
type in it. If you are curious, you can see the file by right-clicking the FullName business object and
selecting Open With > XML Schema Editor, then choosing the Source tab.

9. Repeat the procedure starting with Step 1 to create another business object named
title_firstname_lastname.

10. Add a single field of type string to the business object and call the field name.
11. Save and close the business object editor.

Create the XML map
Map the source business object fullname to the target business object title_firstname_lastname. When
you save the map, an XSL file is generated.
1. In the Business Integration view, select HelloWorldDataPowerLibrary. Right-click and select New >

Data Map. The New Data Map wizard opens showing the Create an XML Map page.

2. In the Name field, enter fullname_map and click Next. The Select Input and Output Business Objects
window opens.

6 Integration Designer: Hello World for WebSphere DataPower Appliance



3. Add the input business object by clicking the Add button. The Data Type Selection window opens.
4. Type fullname in the entry field.
5. Similarly add the output business object title_firstname_lastname. Click Finish.

The XML Map editor opens, showing the input business object on the left side of the editor, and the
output business object on the right:

You can also add input and output objects by using the icons at the top of the XML Map editor, as
shown below:

6. Wire the title element from fullname to the name element of title_firstname_lastname by dragging
the cursor from title to name. This action creates a mapping with the default transform Move
between the two elements:

7. Wire firstName to the Move transform in the middle.
8. In the Connection Selection Helper dialog, choose to create a primary transform. This changes the

Move transform to a Concat transform.
9. Create another primary connection between lastName and Concat. The map is complete. The values

of the elements title, firstName, and lastName will be input to the Concat transform, where the
strings will be concatenated into a single result. The result will then be put into the output element
name.
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10. Optional: You can set properties to change the order in which the strings are concatenated, or to add
delimiters. Right-click on Concat and select Show In > Properties View. For example, if you want
commas between the input strings you can set the delimiter property as shown below:

11. Optional: The XML map editor provides a number of transforms and functions, including XPath,
EXSLT and DataPower functions. To view the transforms and functions that are available, click the
downward arrow in the transform box.

12. Optional: By default, the DataPower function set is enabled when you create a map in a DataPower
library. You can choose to filter the function sets that you want to work with. To enable or disable
function sets:
a. Click the arrow in the transform box.

b. In the list of available transforms, click the arrow on the upper right corner to view the available
function sets.
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c. Click the function set you want to show or hide.
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Chapter 3. Run the sample

After you have finished building the sample, you can test and run it.

To run the sample, complete the following steps:
v Transfer files to the DataPower appliance.
v Create an XML Firewall service and create a style policy for the service.
v Test the service.

Transfer files to the DataPower Appliance
Configure a DataPower appliance and transfer files to it.
1. Switch to the DataPower view, which is typically below the editor area. If you do not see the view,

you can launch it from Window > Show View > DataPower Appliances. The DataPower appliances
view opens.

2. In the DataPower Appliances view, click New DataPower Appliance....
3. In the New DataPower Appliance window, enter your credentials. For a detailed description of each

of the fields, click the information icon

4. Optional: Click Test the connection to make sure the connection is working.
5. Click OK. An entry for the connection is shown in the Appliances tab:
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6. Switch to the Transfer Files tab. The left side of the pane shows the files in Integration Designer, and
the right side shows the files on the appliance.

7. In the WebSphere DataPower Appliance section on the right, select local: as the root directory.
8. The directory list from the appliance will be loaded into the transfer directory list.

9. In the appliance's transfer directory list, navigate to the directory in which you want to transfer files,
or create a new one.

10. From the list of files in Integration Designer, select the ones that you want to transfer, which are
fullname_map.xsl, fullname.xsd and title_firstname_lastname.xsd. Click Transfer.
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11. When the transfer is complete, you will see the transferred files listed in the target directory.

Create an XML firewall service
Launch the DataPower console and create an XML firewall service. Then create a style policy for the
service.
1. Switch to Appliances tab of the DataPower Appliance view.
2. Select the appliance that you created earlier, right-click, and select Launch Console.

3. If you are prompted by a security alert, click Yes to proceed.
4. At the WebSphere DataPower login prompt, provide a userid and password and click Login.
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The WebSphere DataPower console opens showing the control panel.

5. Configure a pass thru XML firewall with the following properties:

Option Description

Firewall Name SampleHelloWorldDataFirewall

Firewall type loopback-proxy

Request type XML
Note: You may need to edit the XML Firewall after you
create it, in order to set the request type to XML.

The following image shows the configured XML firewall.
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6. Configure a style policy and a rule for the XML service. Create a new rule with the direction Client
to Server and the following actions in order from client to server: validate, transform and validate.

Chapter 3. Run the sample 15



7. Configure the first Validate action with the following properties:

Property Value

Input INPUT

Schema Validation Method Validate Document via schema URL

Schema URL A path to the library that you uploaded to DataPower
(for example local:///anita); fullname.xsd.

SOAP Validation body

Asynchronous off

8. Configure the Transform action with the following properties:

Property Value

Input auto

Document Processing Instructions Use XSLT specified in this action

Processing Control File A path to the library that you uploaded to DataPower
(for example local:///anita); fullname_map.xsl.

URL Rewrite Policy none

Asynchronous off

Output auto

9. Configure the last Validate action with the following properties:

Property Value

Input auto

Document Processing Instructions Validate Document via schema URL

Processing Control File A path to the library that you uploaded to DataPower
(for example local:///anita);
title_firstname_lastname.xsd.

SOAP Validation Body

Asynchronous off

Output OUTPUT

10. Apply the policy.
11. Verify that the policy and the firewall are up and running.

Test the service in Integration Designer
After you create the XML Firewall service and policy, you can test the service in Integration Designer
using the Generic Service Client.

To test the service using the Generic Service Client, follow these steps:
1. Right click HelloWorldDataPowerLibrary and select Test Endpoints > Generic Service Client.
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Note: If you do not see the Test Endpoints option, enable the IBM Process Server or WebSphere ESB
capability by following these steps:
a. Launch the Getting Started page from Help > Getting Started > IBM Integration Designer.

b. Click the Change Environment button.
c. In the Environment Capabilities window, select IBM Process Server or WebSphere Enterprise

Service Bus.
d. Click OK.

2. In the Generic Service Client page, add an endpoint request by selecting Endpoints > Add EndPoint
request

.
3. In the Configure Protocol window, enter the URL of the service that is running on the DataPower

appliance. Click Next.
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4. Select fullname as the root element of the request, and click Finish.

5. Click the edit data button.

18 Integration Designer: Hello World for WebSphere DataPower Appliance



6. In the message form, select title, firstName and lastName and enter their values, as shown below:

7. Click the Invoke button.

8. The concatenated message is returned in the response, as shown below:
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Chapter 4. Import

You can either import a complete ready-made version of the sample, or you can build the sample
yourself.

To import the sample:
1. Open IBM Integration Designer.
2. If the Getting Started page is not open in the workspace, select Help > Getting Started > IBM

Integration Designer. The Getting Started page opens.
3. On the Getting Started - IBM Integration Designer page, select the Go to Samples and Tutorials

link, as shown in the following figure:

The Samples and Tutorials page opens.
4. Under the Hello World for WebSphere DataPower section, click the Import link.
5. You will see the project HelloWorldDataPowerLibrary in the Business Integration view.

Instructions for running the sample are found in the topic "Run the sample".
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Notices

U.S. Government Users Restricted Rights - Use, duplication or disclosure restricted by GSA ADP
Schedule Contract with IBM Corp.

This information was developed for products and services offered in the U.S.A. IBM may not offer the
products, services, or features discussed in this documentation in other countries. Consult your local IBM
representative for information on the products and services currently available in your area. Any
reference to an IBM® product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product, program, or service that
does not infringe any IBM intellectual property right may be used instead. However, it is the user's
responsibility to evaluate and verify the operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter described in this
documentation. The furnishing of this documentation does not give you any license to these patents. You
can send license inquiries, in writing, to:
IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM Intellectual Property
Department in your country or send inquiries, in writing, to:
IBM World Trade Asia Corporation
Licensing
2-31 Roppongi 3-chome, Minato-ku
Tokyo 106, Japan

The following paragraph does not apply to the United Kingdom or any other country where such
provisions are inconsistent with local law: INTERNATIONAL BUSINESS MACHINES CORPORATION
PROVIDES THIS PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR
IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OR CONDITIONS OF
NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some
states do not allow disclaimer of express or implied warranties in certain transactions, therefore, this
statement may not apply to you.

This information could include technical inaccuracies or typographical errors. Changes are periodically
made to the information herein; these changes will be incorporated in new editions of the publication.
IBM may make improvements and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for convenience only and do not in
any manner serve as an endorsement of those Web sites. The materials at those Web sites are not part of
the materials for this IBM product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it believes appropriate without
incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose of enabling: (i) the
exchange of information between independently created programs and other programs (including this
one) and (ii) the mutual use of the information which has been exchanged, should contact:
Intellectual Property Dept. for IBM Integration
Designer IBM Canada Ltd. 8200 Warden Avenue Markham, Ontario L6G 1C7 Canada
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Such information may be available, subject to appropriate terms and conditions, including in some cases,
payment of a fee.

The licensed program described in this documentation and all licensed material available for it are
provided by IBM under terms of the IBM Customer Agreement, IBM International Program License
Agreement or any equivalent agreement between us.

Any performance data contained herein was determined in a controlled environment. Therefore, the
results obtained in other operating environments may vary significantly. Some measurements may have
been made on development-level systems and there is no guarantee that these measurements will be the
same on generally available systems. Furthermore, some measurements may have been estimated through
extrapolation. Actual results may vary. Users of this document should verify the applicable data for their
specific environment.

Information concerning non-IBM products was obtained from the suppliers of those products, their
published announcements or other publicly available sources. IBM has not tested those products and
cannot confirm the accuracy of performance, compatibility or any other claims related to non-IBM
products. Questions on the capabilities of non-IBM products should be addressed to the suppliers of
those products.

All statements regarding IBM's future direction or intent are subject to change or withdrawal without
notice, and represent goals and objectives only.

This information contains examples of data and reports used in daily business operations. To illustrate
them as completely as possible, the examples may include the names of individuals, companies, brands,
and products. All of these names are fictitious and any similarity to the names and addresses used by an
actual business enterprise is entirely coincidental.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which illustrates
programming techniques on various operating platforms. You may copy, modify, and distribute these
sample programs in any form without payment to IBM, for the purposes of developing, using, marketing
or distributing application programs conforming to the application programming interface for the
operating platform for which the sample programs are written. These examples have not been thoroughly
tested under all conditions. IBM, therefore, cannot guarantee or imply reliability, serviceability, or
function of these programs. You may copy, modify, and distribute these sample programs in any form
without payment to IBM for the purposes of developing, using, marketing, or distributing application
programs conforming to IBM's application programming interfaces.

Each copy or any portion of these sample programs or any derivative work, must include a copyright
notice as follows:

© (your company name) (year). Portions of this code are derived from IBM Corp. Sample Programs. ©
Copyright IBM Corp. 2000, 2011. All rights reserved.

If you are viewing this information softcopy, the photographs and color illustrations may not appear.

Programming interface information

Programming interface information is intended to help you create application software using this
program.

General-use programming interfaces allow you to write application software that obtain the services of
this program's tools.
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However, this information may also contain diagnosis, modification, and tuning information. Diagnosis,
modification and tuning information is provided to help you debug your application software.

Warning: Do not use this diagnosis, modification, and tuning information as a programming interface
because it is subject to change.

Trademarks and service marks

IBM, IBM Logo, WebSphere, Rational, DB2, Universal Database DB2, Tivoli, Lotus, Passport Advantage,
developerWorks, Redbooks, CICS, z/OS, and IMS are trademarks or registered trademarks of
International Business Machines Corporation in the United States or other countries or both.

UNIX is a registered trademark of The Open Group in the United States, other countries, or both.

Java and all Java-based trademarks and logos are trademarks or registered trademarks of Sun
Microsystems, Inc. in the United States, other countries, or both.

Microsoft and Windows are trademarks or registered trademarks of Microsoft Corporation in the United
States, other countries, or both.

Linux is a trademark of Linus Torvalds in the United States, other countries, or both.

Adobe is either a registered trademark or trademark of Adobe Systems Incorporated in the United States,
other countries, or both.

Other company, product and service names may be trademarks or service marks of others.
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Terms of use

Permissions for the use of publications is granted subject to the following terms and conditions.

Personal Use: You may reproduce these publications for your personal, non commercial use provided
that all proprietary notices are preserved. You may not distribute, display or make derivative work of
these publications, or any portion thereof, without the express consent of IBM.

Commercial Use: You may reproduce, distribute and display these publications solely within your
enterprise provided that all proprietary notices are preserved. You may not make derivative works of
these publications, or reproduce, distribute or display these publications or any portion thereof outside
your enterprise, without the express consent of IBM.

Except as expressly granted in this permission, no other permissions, licenses or rights are granted, either
express or implied, to the publications or any information, data, software or other intellectual property
contained therein.

IBM reserves the right to withdraw the permissions granted herein whenever, in its discretion, the use of
the publications is detrimental to its interest or, as determined by IBM, the above instructions are not
being properly followed.

You may not download, export or re-export this information except in full compliance with all applicable
laws and regulations, including all United States export laws and regulations.

IBM MAKES NO GUARANTEE ABOUT THE CONTENT OF THESE PUBLICATIONS. THE
PUBLICATIONS ARE PROVIDED "AS-IS" AND WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE.

© Copyright IBM Corporation 2011. All Rights Reserved.
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Readers’ Comments — We'd Like to Hear from You

IBM Integration Designer
Hello World for WebSphere DataPower Appliance
Version 7 Release 5

We appreciate your comments about this publication. Please comment on specific errors or omissions, accuracy,
organization, subject matter, or completeness of this book. The comments you send should pertain to only the
information in this manual or product and the way in which the information is presented.

For technical questions and information about products and prices, please contact your IBM branch office, your
IBM business partner, or your authorized remarketer.

When you send comments to IBM, you grant IBM a nonexclusive right to use or distribute your comments in any
way it believes appropriate without incurring any obligation to you. IBM or any other organizations will only use
the personal information that you supply to contact you about the issues that you state on this form.

Comments:

Thank you for your support.

Send your comments to the address on the reverse side of this form.

If you would like a response from IBM, please fill in the following information:

Name Address

Company or Organization

Phone No. Email address
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