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This presentation provides an overview and explains how to configure and test the
samples provided by the telecom enablement feature of the IBM WebSphere® Telecom
Toolkit V 7.0. To get a better understanding on the content of this presentation first review
the overview presentation of this feature.
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Goals

* Provide an overview of the various Telecom
Application Enablement samples

= Explain the configuration and testing process of
the Telecom Application Enablement samples
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The goals of this presentation are to provide an overview of the various IP Multimedia
Subsystem (IMS) samples available in the Telecom Enablement feature of the toolkit and
explain the setup and testing process of these samples.

The samples are client applications or templates to develop client applications using the
tools available in the Telecom Enablement feature of the WebSphere Telecom Toolkit for
various IMS services or enablers. These samples are a valuable reference for developing
new IMS client applications and server side extensions or enablers and enable developers
to quickly understand the API’s.
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Agenda

» Diameter samples
* Presence Samples
= Session Initiation Protocol Samples

= XML Document Management Server Samples
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The agenda of this presentation covers the steps to configure and test all of the telecom
application enablement samples.

The samples provided are targeted to various IBM IP Multimedia Subsystem (IMS)
enablers that include

- the IMS Connector based on diameter Web services
- the WebSphere Presence Server that provides rich real time presence information

- the WebSphere Session Initiation Protocol (SIP) converged container that provides the
complete infrastructure for hosting SIP applications and

- the XML Document Management server (XDMS) which provides network accessible
storage, retrieval, and management of XML documents owned by entities.
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Diameter Enabler samples

= Rf Test Client
» Offline Charging Rf Web service Java™ client sample

= Sh Test Client — Subscriber Profile Client
» Subscriber Profile Sh Web services Java client sample

* Ro Test Client — Online Charging Client
» Online Charging Ro Web service Java client sample
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The Diameter Enabler Samples set includes three Web service client samples. These
samples can be used to test the design parameters for diameter client applications against
the Rf offline charging, Sh subscriber profile, and Ro online charging Web services.

Each sample can be imported into a Rational® Application Developer workspace by
clicking the import link provided for the sample. These samples initially flag errors when
loaded in the workspace due to a missing com.ibm.ws.webservices.thinclient jar file on the
classpath. To resolve these errors follow the Setup Instructions link in the samples page,
which offers detailed instructions on importing this file.
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Diameter samples setup

= Diameter Rf, Ro, and Sh client samples setup
steps:
1. From the Samples page, load samples into workspace
using ‘Import.." link
2. Right click the imported project -> Select Properties

3. Select Java Build Path -> select Libraries tab -> click
'‘Add External Library' button

4. Add com.ibm.ws.webservices.thinclient jar library from
runtimes folder of WebSphere Application Server.

5. Click 'OK' button to exit Properties dialog.

6. Change the static endPoint string in the Java class

» E.g:http://9.22.95.20:9081/DHADiameterRfWebService/services/Diameter
RfService

The setup process of the Diameter Ro, Rf and Sh Samples involves these steps:

1. Load the samples into the Rational Application Developer workspace using the
Import links from the Diameter Samples page. The Diameter Samples page can be
accessed from the Help->Samples->Technology Samples->Telecom Application
Enablement Feature->Telecom Application Enablement Samples->Diameter page.

2. Review the prerequisite instructions by clicking on Setup Instructions link.
3. Import the sample.
4. Right click the imported project and select the Properties menu item.

5. In the properties dialog select Java Build Path properties page followed by
selecting the Libraries tab in this page. Click the 'Add External Library' button.

6. In the Jar Selection dialog, locate the runtimes folder of the WebSphere
Application Server in use and select the com.ibm.ws.webservices.thinclient.jar

7. Click OK on the Properties dialog.

8. Change the endpoint static variable to point to a valid Diameter Rf, Ro, or Sh
Web services endpoint. For example
http://9.22.95.20:9081/DHADiameterRfWebService/services/DiameterRfService
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Diameter sample - execution

= Right click Project -> Run As — Run Configuration

= Create new Java application configuration
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To run the Diameter test samples follow these steps:

1. Right click the Sample Project and Select Run As -> Run Configuration.
2. Create a new Java Application Configuration as shown in the figure.

3. Click the Run button to run the sample.

4. The results are displayed in the Console view.
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Presence samples

= SIP external source sample
» Demonstrates behavior of a SIP external source
» SIPp script to PUBLISH, SUBSCRIBE and NOTIFY to
external source

* Presence Representational State Transfer sample

» Demonstrates RESTful HTTP interface to retrieve
presence information

» Based on REST interface in WebSphere Presence
Server V7.0

= Presence SIP ample
» Demonstrates SIP requests to and from Presence Server
» Contains SIP code patterns for reuse

The Presence Samples category provides three samples that include:

The Sip External Source sample which demonstrates the behavior of a SIP external
source. The sample application consists of SIPp scripts which provide a PUBLISH,
SUBSCRIBE notify scenario to an external SIP source. The script accepts incoming
subscribe requests, and responds with 200 OK and a NOTIFY message with a simple
presence document. The presence document includes the subscribed presentity identity. It
also simulates state changes for the subscribed presentity by periodically sending NOTIFY
messages with changes in the presence information and stops sending NOTIFY
messages upon receiving an unsubscribe request from the Presence Server. The sample
can be tested using the SIP Client test tool provided. The Sample provides a README file
that describes how to setup this sample to test with the IBM Presence and SIP external
source.

The Presence REST Sample which demonstrates how a RESTful HTTP interface can be
used to retrieve rich presence information from a Presence Server. A REST interface
permits Web clients to perform HTTP GET, PUT, POST, and DELETE requests. The
sample is based on a new feature available in IBM WebSphere Presence Server V7.0 that
provides a REST interface to retrieve presence information. Presence Server supports
interoperability between SIP clients and clients using the REST interface, all connected to
the same server. More details about this sample are explained in the next slide.

The SIP Sample which is a Java EE application that can be used to send and receive SIP
requests to or from a Presence Server. It contains standard SIP code patterns the can be
used in other application scenarios.
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Presence REST sample

= User interface of the Sample
» Fetch: Retrieves Presence information from a Presence

Server
» Publish: Publishes Presence information to a Presence
Server , -
00l U5 |eto//ocaihost 3081/gu. .'.IP.
e Welcome to the IMS 7.0
e Presence Server Web Access
Access
o Sample

Actions

0. Fetch
1. Publish
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The figure shows the user interface of the Presence REST Sample after deploying it on
WebSphere Application Server V7.0.

The Fetch Action provides the functionality to presence subscriber to retrieve presence
information, and the Publish Action provides the functionality for a presentity to publish
their presence information.

To deploy this sample follow these steps:

- Import the sample into a workspace from the Presence Sample category by clicking the
Import Presence REST link.

- Modify the restAddress value in the web.xml to a valid Presence Server

- Right click the presence.sample.rest.war project and select Run As -> Run On Server
and select the WebSphere Application Server V7.0 from the list of servers and Click
Finish.

- The sample gets deployed and the browser shows the sample’s homepage as shown in
the figure.

The Sample provides a README file that describes how to setup this sample to test with
IBM Presence.
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Session Initiation Protocol samples

= IMS Session Control (ISC) Charging Samples
» Rf offline Charging and Ro online charging samples

= Two versions of samples
» WebSphere Application Server V6.1 and V7.0

= Demonstrates use of ISC, Diameter interfaces, P-
Asserted-ldentity and P-Charging Vector headers

» Simulates SIP call flow with Ro and Rf charging functions
in the SIP transaction

» Appendix section includes SIP call flow slides

The SIP samples category provides the IMS Session Control (ISC) Charging sample in
two versions, one version for WebSphere Application Server V6.1 and another version for
WebSphere Application Server V7.0.

The ISC sample demonstrates the use of the ISC interface available in WebSphere
Application Server and Diameter Web services interfaces available in IBM IMS Connector
products. It is demonstrated by simulating a SIP call flow and applying the Diameter Ro
online and Rf offline charging functions in the SIP transaction. The sample also
demonstrates the processing of P-Asserted-Identity and P-Charging-Vector headers.

In an IMS environment, the P-Asserted-ldentity is a header that is inserted into a SIP or
HTTP request by a Call Session Control Function (CSCF) for authenticated subscribers.
Refer to Request for Comment - IETF RFC 3325 for more details on the P-Asserted-
Identity. The P-Charging-Vector header is a charging vector defined as a collection of
charging information on a SIP network. It allows the SIP network elements to collect
charging information for SIP-based communications, that flow across one or more
networks. Network elements originating SIP traffic such as creating new and outbound
telephone calls, can add P-Charging-Vector headers to their outbound SIP requests and
responses. For more details on the P-Charging-Vector headers, refer to 3GPP RFC 3455.

The Appendix section of this presentation includes two slides that depict the SIP call flows
between various network elements when the Rf and Ro ISC samples are run in a IMS
network.
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XML Document Management Server (XDMS)
samples
= XML Configuration Access Protocol Client sample

» Java Application Client that exercises various XCAP
GET, PUT functions against an XCAP server
= XDMS Template
» Provides a template to enable the development of a new
XDMS enablers.
= XDMS ID Mapping Provider sample

» Java Application sample that implements a Public Identity
Mapper Interface
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The XML Document Management Server (XDMS) samples category provides a wide
variety of samples that include both client and server side XML document management
applications. The functionality of the samples include:

- The XCAP client sample that runs batched XCAP requests against an XDMS server and
returns the results.

- The XDMS Template sample is an Enterprise application that contains a Web
Application. The Web application provides a template servlet, stubbed out XML, schema
files, and default property files to develop new XDMS-side enablers.

- The XDMS ID Mapping Provider sample is a Java application that contains a Java class
file along with the dependent libraries. The Java class provides sample code for
implementing the Public Identity Mapper interface.
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XDMS samples

= SharedList, PresRules, SharedGroup,
SharedPolicy, SharedProfile, SharedEnablers
XDMS samples

» Represent XML Document Management (XDM) server
side enablers

» Each sample provides an XDM enabler stub based on
OMA XDM 2.0 specifications to create complete enablers

» Each sample is a Java EE enterprise application that
contains a Web application

» Web application contains corresponding stubbed servlet,
default XML and schema files that support resource-lists
and ris-services documents

Samples setup and testing

The SharedList, PresRules, SharedGroup, SharedPolicy, SharedProfile, SharedEnablers
XDMS samples represent server side XML Document Management (XDM) enablers for
various group list management functions based on the Open Mobile Alliance XDM 2.0
specification. Each of these sample provides an XDM enabler stub for developing the
corresponding XDM enabler. The XDM enabler stubs are shipped as Java EE enterprise
applications that contain a Web application. The Web application contains the
corresponding enabler stubbed servlet, default XML and schema files that support
resource-lists and rls-services documents at a user or group level.
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XDMS client samples setup

= XCAP Client and SamplelDMappingProvider
Samples setup steps:

1.Plain Java applications
2 Load sample into workspace using Import Sample link
3.Right click the imported project -> Select Properties

4 Select Java Build Path -> select Libraries tab -> click 'Add
Library' button

5.Select Telecom Application Enablement Toolkit Libraries -
> click 'Next’ -> check XDMS Client Libraries -> click
'Finish' button.

6.Click 'OK' button to exit Properties dialog
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The XCAP Client and XDMS ID Mapping Provider samples are Java application samples.

The setup process involves these steps:

1. Load the samples into the Rational Application Developer workspace using the
Import links from the XDMS Samples page.

2. Right click the imported project and select the Properties menu item.

3. In the properties dialog select Java Build Path properties, then select the
Libraries tab in this page and click the 'Add Library' button.

4. Select Telecom Application Enablement Toolkit Libraries and click 'Next' button.
Check the XDMS Client Libraries check box and click 'Finish' button.

5. Click the 'OK' button to exit the Properties dialog box.
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XDMS samples setup

= XDMS Template, SharedList, PresRules,
SharedGroup, SharedPolicy, SharedProfile,
SharedEnablers Samples setup steps:

1.Select imported project -> Right click and select Import

2.Select Telecom Application Enablement -> Telecom
Application Enablement Resources -> click 'Next'

3.Checkbox under XDMS Resources Libraries
4 Click 'Finish' button
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The setup process of the XDMS Template, SharedList, PresRules, SharedGroup,
SharedPolicy, SharedProfile, SharedEnablers samples involves these steps:

1. Load the samples into the Rational Application Developer workspace using the Import
links from the XDMS Samples page.

2. Select the imported project, then click File -> Import.

3. Under Telecom Application Enablement, select Telecom Application Enablement
Resources and click the 'Next' Button.

4. Check the Libraries check box under XDMS Resources and click the 'Finish' button.
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Section

Appendix
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This is the Appendix section.
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This figure depicts an IMS Session Control Demonstration Application online charging Ro
service call flow.
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This figure depicts an IMS Session Control Demonstration Application online charging Rf
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