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What this exercise is about   

The objective of this lab is to provide you with an understanding of how to use the WebSphere Integration 
Developer V6 tools to construct an end to end solution using existing components. 

Lab Requirements 

List of system and software required for the student to complete the lab. 

• WebSphere Integration Developer V6 installed 

• WebSphere Process Server V6 test environment installed 

• Sample code in the directory C:\Labfiles60 (Windows
®
) or /tmp/LabFiles60 (Linux

®
) 

• WebSphere Business Integration Toolset installed 

What you should be able to do 

At the end of this lab you should be able to: 

• Create SCA Imports and Exports  

• Define both SCA and JMS Pub/Sub bindings for the Imports and Exports 
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• Use the Visual Test Connector to simulate adapter input and output to the process server 

 

Introduction 

In this exercise, you will construct an end to end solution for the eXchange scenario. The overall flow of 
the solution is depicted in the following diagram.  
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All of the modules represented in the diagram are already implemented. However, the Imports and Exports 
required to connect the modules do not exist and you will be lead through creating them. After that, you will 
test the solution by driving input from the PeopleSoft adapter and then examine the output of the Siebel 
adapter.  

Note:  For this lab exercise, the Flat File JCA Module is not included, but could be easily added to this 
solution as separate module.    
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Exercise Instructions 

Some instructions in this lab might be specific for Windows platforms.  If you run the lab on a platform 
other than Windows, you will need to run the appropriate commands, and use appropriate files (for 
example .sh in place of .bat) for your operating system.  The directory locations are specified in the lab 
instructions using symbolic references as follows: 

Reference 
Variable 

Windows Location Linux Location 

<WID_HOME> C:\Program Files\IBM\WebSphere\ID\6.0 /opt/IBM/WebSphere/ID/6.0 

<WPS_HOME> <WID_HOME>\runtimes\bi_v6 <WID_HOME>/runtimes/bi_v6 

<LAB_FILES> C:\Labfiles60 /tmp/Labfiles60 

<WORKSPACE> C:\Labfiles60\eXchange\EndToEndNoFF
A\workspace 

/tmp/Labfiles60/eXchange/EndToEndNo
FFA/workspace 

<TEMP> C:\temp /tmp 

<SOLUTION> C:\Labfiles60\eXchange\EndToEndNoFF
A\Solution 

/tmp/Labfiles60/eXchange/EndToEndNo
FFA/Solution 

 

Windows users’ note: When directory locations are passed as parameters to a Java program, such as 
wsadmin, you must replace the backslashes with forward slashes to follow the Java convention. For 
example, C:\LabFiles60\ would be replaced by C:/LabFiles60/. 

Note that the previous table is relative to where you are running WebSphere Integration Developer.  The 
following table is related to where you are running remote test environment: 

Reference Variable Example: Remote 
Windows test server 

location 

Example: Remote 
z/OS

®
 test server 

location 

Input your values for the 
remote location of the test 

server 

<SERVER_NAME> server1 cl1sr01  

<WAS_HOME> C:\Program 
Files\IBM\WebSphere\AppServer 

/etc/cl1cell/AppServerNode1  

<HOSTNAME> localhost mvsxxx.rtp.raleigh.ibm.com  

<BOOTSTRAP_PORT> 2809 2809  

<TELNET_PORT> N/A 1023  

<PROFILE_NAME> AppSrv01 default  

<USERID> N/A cl1admin  

<PASSWORD> N/A fr1day  
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Instructions for using a remote testing environment, such as z/OS, AIX or Solaris, can be found at the end 
of this document, in the section “Task: Adding Remote Server to WebSphere Integration Developer 
Test Environment”.  
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Part 1: Initialize the Workspace for this Lab Exercise 

This task is a common description for how to initialize your workspace for doing this lab.  Substitute the values 
listed below for the variables.  

<WORKSPACE> - C:\Labfiles60\eXchange\EndToEndNoFFA\workspace 

<PROJECT_INTERCHANGE> - C:\Labfiles60\eXchange\EndToEndNoFFA\import\EndToEndStart_PI.zip 

<MODULE> - n/a 

<DEPENDENT_LIBRARIES> - n/a 

____ 1. Start WebSphere Integration Developer V6 with a new workspace located at <WORKSPACE>.  

__ a. From Windows Explorer, navigate to the <WID_HOME> directory and double click on wid.exe. 

__ b. When prompted for workspace name, enter the value provided by the <WORKSPACE> variable 
for this lab and click OK. 
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__ c. When WebSphere Integration Developer V6.0 opens, close the Welcome page by clicking on 
the Go to the workbench icon (bent over arrow at top-right).         

    

 

__ d. Ensure you are in the Business Integration perspective. 

____ 2. If this lab requires you to import a project interchange file, setup the required libraries and modules 
for this lab by importing the project interchange file <PROJECT_INTERCHANGE>.  

__ a. From the menu bar, select File -> Import… 

__ b. In the Import dialog, scroll down and select Project Interchange. 
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__ c. Click Next. 

__ d. In the Import Projects dialog, initialize the From zip file: field to <PROJECT_INTERCHANGE>. 

__ e. Click the Select All button. 

 

__ f. Click Finish. 
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Part 2: Understanding eXchange Components 

In this part you will examine the existing components that are part of the eXchange scenario. This will 
provide you with a basis to understand the solution you will be constructing in subsequent parts.  

____ 1. The CleansePublishLibrary contains the common WSDL and XSD files used by the various 
components within the eXchange integration application.  These files define the interfaces and data 
types used by components as they work with the requests received from the PeopleSoft adapter, 
cleanse the data, and publish it to the Siebel adapter.  Examine the library. 

__ a. Expand CleansePublishLibrary and expand Data Types. 

 

__ b. Open the ClipBG and Clip data types.  Notice how ClipBG includes the Clip business object and 
Clip contains the ClipItem business object.   
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__ c. Expand Interfaces under CleansePublishLibrary. 

__ d. Open the different interfaces and notice the operations and the messages.  All messages are of 
the ClipBG type.   

 

____ 2. The CleanPublishBPEL module provides the business logic for cleansing the data received from the 
PeopleSoft adapter before it is sent to the Siebel adapter.  Examine the contents of the module. 

__ a. Expand CleanPublishBPEL and double-click on CleanPublishBPEL to open the assembly 
editor.  The business process has already be created and defined as a component.   

 

__ b. The business process has already been created and defined as a component within the module.  
It has an interface that can be called and 3 references to other service components.  Hover the 
mouse over the interface (“I”) icon on the left to view the interface, which defines how the 
business process is called.  You should see that the CleansePublish interface has been 
specified.   
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__ c. Hover the mouse over the reference icons (“1..1”) to view the interfaces that are called.  You 
should notice two references to the Clean interface and one to the Publish interface. 

 

__ d. Close the assembly editor. 

____ 3. The AutoClean module provides an automated means of cleansing the data within the business 
logic.  The cleansing is done either by a Business Rule or a Java component with a Selector 
component making the determination.  Examine the contents of the module. 

__ a. Expand AutoClean and double-click on AutoClean to open the assembly editor.   

 

__ b. The AutoClean module contains a Selector, Business Rule, and a Java class.  All of these have 
been defined as components.  The Selector (SelectClean) is the main component called to 
determine if the cleansing should be performed by a Business Rule (CleanseRuleGroup) or a 
Java component (Component1).   The Selector is linked to the Business Rule and Java 
component through dynamic wires, which are not shown in the assembly editor.  The Selector 
handles the incoming requests to the module and determines if the Business Rule or the Java 
component should be called to perform the auto-cleansing of the incoming data.   
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__ c. Hover the mouse over the interface icon for the Selector.  Notice the Selector uses the Clean 
interface.   

 

__ d. Hover the mouse over Component1 (Java) and the CleanseRuleGroup components.  Notice 
these also use the Clean interface.  With all components using the same interface, the data can 
be easily passed from one component to another within the module. 

 

__ e. Close the assembly editor. 

____ 4. The ManualClean module provides the ability for human interaction to be part of the cleansing 
process.  Examine the contents of the module. 

__ a. Expand ManualClean and double-click on ManualClean to open the assembly editor.   
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__ b. The ManualClean module contains a human task component.  The human task, ManualClean, 
allows for a person to be part of the data cleansing. 

 

__ c. Hover the mouse over the interface icon.  Notice the Clean interface is used to call the human 
task component.   

 

__ d. Close the assembly editor. 

____ 5. The PeoplesoftAdapter module provides the capability to accept requests and pass the data on to 
the business logic.  Examine the contents of the module. 

__ a. Expand PeopleSoftAdapter and double-click on PeopleSoftAdapter to open the assembly 
editor.   
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__ b. The PeopleSoftAdapter module is used to accept requests from the PeopleSoft adapter and 
convert an application specific business object (ASBO) to a generic business object (GBO), 
which is passed.  The transformation is completed using interface and data type maps 
(InboundDeliveryToCleansePublish). In order to accept the request from the PeopleSoft 
adapter, an Export, wbia/asbo/PsftConnectorDeliveryHub, with a JMS binding is used on the 
maps.  The connection between the map and Export is represented by the wire.    

 

__ c. Hover the mouse over the interface of the Export.  The interface used is named 
InboundDelivery and is specific to interaction with the PeopleSoft adapter.  The interface 
definition is contained within the PeopleSoftAdapter module as it is specific for this module and is 
not shared with other modules. 
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__ d. Hover the mouse over the reference on the map.  Notice the reference is to the CleansePublish 
interface which is the same as used by the business process.   

 

__ e. Select the Export wbia/asbo/PsftConnectorDeliveryHub and select the Properties Tab.   

__ f. Select the Bindings tab.  Notice the JMS binding information specified for the module as it 
receives requests off a queue. 

 

__ g. Select the JMS Destinations tab, and expand the Receive Destinations Properties. 

__ h. The JNDI name of the queue, PSFTCONNECTOR/DELIVERYQUEUE, is set for the Export. 

 

__ i. Close the assembly editor. 

____ 6. The SiebelAdapter module provides the capability to receive cleansed data passed from the 
business logic and pass it onto a Siebel adapter.  Examine the contents of the module. 
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__ a. Expand SiebelAdapter and double-click on SiebelAdapter to open the assembly editor.   

 

__ b. The SiebelAdapter module is used to accept requests and transform the data from a generic 
business object (GBO) to an application specific business object (ASBO) before it is passed to 
the Siebel adapter  The transformation is completed using interface and data type maps 
(PublishToOutboundRequest).  In order to send the request to the Siebel adapter, a JMS 
binding is used on an Import(wbia/asbo/SiebelConnectorAgent).  The connection between the 
map and Import is represented by the wire. 

 

__ c. Hover the mouse over the interface for the Import.  The interface (OutboundRequest) is specific 
to interacting with the Siebel Adapter.  The interface definition is contained within the 
SiebelAdapter module as it is specific for this module and is not shared with other modules. 
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__ d. Hover the mouse over the interface of the map.  Notice the Publish interface is used. 

 

__ e. Select the Import wbia/asbo/SiebelConnectorAgent and select the Properties Tab.   

__ f. Select the Bindings tab.  Notice the JMS binding information specified for the module, required 
to send messages to a queue.  

__ g. Select the JMS Destinations tab, and expand the Send Destinations Properties. 

__ h. The JNDI name of the queue (SIEBELCONNECTOR/REQUESTQUEUE) is set for the Import. 

 

__ i. Close the assembly editor. 
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Part 3: Assemble eXchange 

SCA components in different modules that support the same interfaces can be associated with each other 
through the use of Imports, Exports, and their associated binding. In this part you will add the required 
Imports, Exports and bindings to build an end to end solution from the components you examined in the 
previous part of this lab exercise.  

____ 1. The CleansePublishProcess has the most bindings and references that must be resolved.  Start the 
overall assembly with defining the references and bindings for the CleanPublishBPEL module. 

__ a. Open the CleanPublishBPEL assembly editor. 

__ b. Right-click on the CleanPublishBPEL and select Export…>SCA Binding.  In order for the 
business process to be called as an SCA component from the PeopleSoft adapter an SCA 
binding must be created on an Export.  

 

__ c. Hover the mouse over the interface on the Export.  Notice how it exposes the CleansePublish 
interface for SCA invocation. 

 

__ d. The references will also use SCA to call the AutoClean, ManualClean, and Publish components. 
These components are located in other modules and are called using Imports. An easy way to 
quickly generate Imports is to right-click on the CleansePublishProcess and select Wire 
References to New > Imports. 
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__ e. The Imports will be created and will use the reference name for the Import component name. 

 

__ f. Save and close the editor for now.  The SCA bindings must be set for each Import component to 
call the appropriate module.  The SCA binding can not be completed until the AutoClean, 
ManualClean, and Publish modules are properly exposed as SCA components.  You will return 
to the CleanPublishBPEL assembly editor and set these SCA bindings later.   

____ 2. The AutoClean module only needs a single binding to be generated for calls from the 
CleansePublishProcess.  Assemble the AutoClean module with an SCA binding.   

__ a. Open the assembly editor for the AutoClean module.   

__ b. Right-click on SelectClean and select Export…>SCA Binding.  The Selector is the only 
component in the module that needs to be exposed as an SCA component.     

 

__ c. Save and close the assembly editor.  The Selector, which fronts the calls to the module and 
determines whether to call the Java component or Business Rule, is fully available to be called 
as an SCA component.   
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____ 3. The ManualClean module also only needs a single binding to be generated for calls from the 
CleansePublishProcess.  Assemble the ManualClean module. 

__ a. Open the assembly editor for the ManualClean module.   

__ b. Right-click on ManualClean and select Export…>SCA Binding.  The human task can be easily 
exposed as an SCA component as well.   

 

__ c. Save and close the editor.  The human task is complete as an SCA component.   

____ 4. Set the SCA bindings in the business process.  With the AutoClean and ManualClean SCA 
components defined, the SCA bindings can be defined for the references in the business process.   

__ a. Open the assembly editor for the CleanPublishBPEL module again.   

__ b. Right-click the AutoClean Import component and select Generate Binding… > SCA Binding. 

 

__ c. With the AutoClean Import component selected, select the Bindings tab in the Properties view. 

__ d. Click the Browse button.  The different SCA components which are available will be listed.  
Notice that it is only those modules where the SCA Export has been defined.  
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__ e. Select SelectCleanExport and click OK.  The binding is complete for the business process to 
call AutoClean. 

 

__ f. Right-click on ManualClean and select Generate Binding… > SCA Binding.  A similar set of 
steps can be used for setting the SCA binding on the ManualClean Import component.   

__ g. Browse to and select ManualCleanExport on the Bindings tab in the Properties view. This will 
complete the SCA binding for ManualClean. 

 

__ h. For the binding of the Publish Import Component, JMS will be used instead of SCA.  In order to 
support the publish of data to the Siebel adapter, a JMS Topic will be used.  Set the JMS binding 
by right-clicking on Publish and selecting Generate Binding… > JMS Binding.   
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__ i. Select Publish-Subscribe for the Select JMS message domain. Select Text for the data is 
serialized between Business Object and JMS Message in the JMS Import Binding attributes 
selection dialog. 

 

__ j. Click OK. 

__ k. Select the Binding tab in the Properties view.  The specific topic where the message will be 
published must be specified to complete the binding.   

__ l. Select the JMS Destinations tab. 

__ m. Click on Send Destination Properties. 

__ n. At the bottom enter PublishTopic for the Topic name.  This will cause a topic to be dynamically 
created using the Service Integration Technologies. If a predefined topic exists or is located on a 
different server, the JNDI name can be specified for the JNDI lookup name. 
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__ o. Save and close the assembly editor.  The binding for the Publish Import component is complete 
and the CleanPublishBPEL component now has bindings for all of its imports and exports.   

 

____ 5. The only binding needed for the PeopleSoftAdapter module is to the CleansePublishProcesss.  

__ a. Open the assembly editor for the PeopleSoft module.   

__ b. Right-click on InboundDeliveryToCleansePublish and select Wire References to New > 
Imports.  To create the binding to the CleansePublishProcess SCA component, an Import 
component must be used from the map.  The SCA binding must be used. Right-click on the 
CleansePublish Import component and select Generate Bindings…>SCA Binding. 

__ c. Browse to and select CleansePublishProcessExport on the Bindings tab in the Properties 
view. This will complete the SCA binding for PeopleSoftAdapter module. 
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__ d. Save and close the assembly editor. 

____ 6. The Siebel Adapter must be able to accept the data (ClipBG) published from the 
CleansePublishProcess to the topic.  A JMS binding to the topic must be set. Assemble the 
SiebelAdapter module to utilize the topic to receive the updated data. 

__ a. Open the assembly editor for the SiebelAdapter module.   

__ b. Right-click on PublishToOutboundRequest and select Export…>JMS Binding.  The JMS 
binding is set on the Export component for the PublishToOutboundRequest map component 
as the generic business object (GBO) will be converted to the application specific business 
object (ASBO) for the Siebel adapter.  

 

__ c. Select Publish-Subscribe for the Select JMS message domain. Select Text for the data is 
serialized between Business Object and JMS Message, in the JMS Import Binding attributes 
selection dialog. 
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__ d. Click OK. 

__ e. Select the PublishToOutboundRequestExport you just created and select the Properties view. 

__ f. Click on the Binding tab. 

__ g. Select the JMS Destinations tab.  You must set the Export to use the specific topic where the 
data (ClipBG) will be published.   

__ h. Expand Receive Destinations Properties. 

__ i. Specify the PublishTopic for the Topic Name at the bottom.  This is the same name used by the 
Import Component of the CleansePublishProcess to publish the data. 

 

__ j. Save and close the assembly editor.  The SiebelAdapter assembly is complete.  
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Part 4: Testing eXchange 

In this part you will test the end to end solution. This will be done by using two Visual Test Connectors, one 
to simulate the PeopleSoft application, which will drive the input and the other to simulate the Siebel 
application, which will receive the output. Once the flow is initiated from the Visual Test Connector for 
PeopleSoft, you will need to interact with the Human Task Manager. Once that is done, you should see the 
output in the Visual Test Connector for Siebel.  

____ 1. If using a remote testing environment, follow directions provided in Task: Adding Remote Server 
to WebSphere Integration Developer Test Environment at the end of this document to add a 
server to the WebSphere Integration Developer test environment and start it.  This is especially true 
for z/OS, AIX, Solaris remote test environment, where the WebSphere Integration Developer will be 
remote to the test environment. 

__ a. Your Console view will look something like this once the server has started. 

 

__ b. Click on the Servers tab and verify that the server status shows as Started 

 

____ 2. Publish the PeopleSoftAdapter and SiebelAdapter modules so that the required messaging queues 
can be configured. 

__ a. Right click on the server and select Add and remove projects… from the pop-up menu. 

 

__ b. Select the PeopleSoftAdapterApp in the Add and Remove Projects dialog and use the Add> 
button to add it to the Configured projects list. Repeat this for the SiebelAdapterApp. The dialog 
should now look like this.  
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__ c. Click Finish. 

__ d. In the lower right of the window you will see messages while the publishing is proceeding. Wait 
until there are no longer any messages.  

 

____ 3. Now that the PeopleSoft and Siebel projects have been started in the server for the first time, the 
messaging configuration required by them has been defined to the server. The server must now be 
restarted in order for that messaging configuration to be activated.  

NOTE: As part of publishing the SiebelAdapterApp you may see some exceptions. Ignore the exceptions. 
There is a workaround that is specified at a later stage in this lab 

NOTE: The requirement for a server restart after the installation of an application containing a WBI 
Adapter Import or Export is a one time requirement. After this has been done the first time, the required 
messaging configuration is defined to the server. Additional applications using WBI Adapters can be 
installed without requiring a server restart.  

__ a. Restart the server.  Right click on WebSphere Process Server v6.0 server from the Servers view 
and select Restart from the context menu, or Stop if you are using a remote test environment.  
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__ b. Once the server is stopped, follow directions provided in Task: Adding Remote Server to 
WebSphere Integration Developer Test Environment to restart the server.  This is especially 
true for z/OS, AIX, Solaris remote test environment, where the WebSphere Integration Developer 
will be remote to the test environment.  

 

__ c. Wait for the server to fully restart.  

NOTE: When the server restarts, there might be messages in the Console view. Wait until you see the 
server return to a Started status.  

 

____ 4. Publish all of the projects to the server. 

__ a. Right click on the server and select Add and remove projects… from the pop-up menu. 

__ b. Click the Add All>> button. 

 

__ c. Click Finish. 

__ d. Wait for publishing of the projects to complete (no more messages in the lower right corner). This 
can take several minutes to complete.  
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 NOTE: If the SiebelAdapterApp publishing results in exceptions, follow the steps below as a workaround 

 In the Administrative Console, navigate to Resources � JMS Providers � Default Messaging 

For the scope, select the Server scope 

Click on the “JMS activation specification” link under “Activation Specifications” 

Click on the SiebelAdapter.com.clipsandtacks.scm.PublishToOutboundRequestExport_AS link 

Change the Destination Type from Queue to Topic 

 

Click Ok and save the changes. 

Got to Applications � Enterprise Applications. select the check box next to SiebelAdapterApp and click the 
start button. This will start the SiebelAdpaterApp application 

 

____ 5. Once the server is running with the entire solution deployed, you are ready to test it. To do that, start 
the Visual Test Connectors that will be used to simulate the PeopleSoft and Siebel applications.  

__ a. Follow the instructions found in the Task: Connecting with the Visual Test Connector, using 
the configuration data found at 
<LAB_FILES>\eXchange\PeopleSoft\ASBOs\PsftConnectorWPS.cfg. 

__ b. Open a second visual test connector by following the instructions found in the Task: Connecting 
with the Visual Test Connector at the end of this document, using the configuration data found 
at <LAB_FILES>\eXchange\Siebel\ASBOs\SiebelConnectorWPS.cfg. 
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____ 6.  Load a predefined business object into the Visual Test Connector for the PeopleSoft and examine 
its values. 

__ a. In the VTC window for PeopleSoft, select Edit > Load Business Object. 

 

__ b. Navigate to c:\Labfiles60\eXchange\PeopleSoft\ASBOInstances in the Open dialog, and 
select PsftASBO1.bo. 

__ c. Click Open. 

__ d. Enter a name to be assigned to this instance, such as Psft1. 

 

__ e. Click OK. 

__ f. Look at the values assigned to the Psft_ClipType fields. 

 

__ g. Click the + in front of RetailUnits[n] to expand the Psft_RetailItem array. 

__ h. Click the + in front of [0] to see an instance of Psft_RetailItem. 
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____ 7. Initiate the test by sending the business object from the PeopleSoft VTC to the WebSphere Process 
Server.  

__ a. Select Request > Send. 

 

__ b. You should see a message in the VTC indicating that the message was sent. 

 

____ 8. Part of the application scenario includes a Human Task. This is the opportunity for a human to 
review the contents of the business object and make any necessary changes to it. Start by opening 
the BPC Explorer to handle the Human Task activity.  

__ a. Right-click on WPS Server v6.0 in the Servers view and select Launch > BPC Explorer. If you 
are using a remote server, you can instead open a Web browser and navigate to 
http://<HOSTNAME>:9080/bpc.  The My Tasks view will be shown with the task ready to be 
completed.  
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____ 9. Complete the task so that the flow of the scenario can continue. 

__ a. Click on the check box for instance to select it and then click “Work on”.  This will claim the task 
on behalf of the current user.   

 

__ b. Fill in the values for fields in the task output message based on the values in the input message. 
Since this step in the business process allows a human to review and make updates to the 
business object, you will make a slight modification. Fill in all the output message fields with the 
same values from the input message, except change the color from black to charcoal as shown 
in the screen shot. You will need to click the + in retailItems to fill in the data values for an 
instance.  
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__ c. Click the Complete button. 

____ 10. Verify the data that has been sent to Siebel.  

__ a. Look at the Visual Test Connector window for Siebel and verify that it has received a business 
object.  

 

__ b. Double click on Siebel_ProductType.create to open a window with the received BO. 

 

__ c. Examine the data in the Response Business Object window. 
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__ d. Type in a value for the Key field, such as A1234. 

 

__ e. Click OK. 

____ 11. Send a response back to the server indicating the request was received and providing the Key 
value.  

__ a. Ensure that Siebel_ProductType.create is selected. 

__ b.  Select Request -> Reply -> Success from the menu,  

____ 12. Now that testing is complete, shut down your environment. 

__ a. Right click on the server in the Servers view and select Add and remove projects… from the 
pop-up menu. 

__ b. Use the <<Remove All button to remove the projects from the server. The dialog should now 
look like this:  

__ c. Click Finish. 

__ d. Wait until the projects complete unpublishing and there are no more messages in the lower right 
corner.  

__ e. Click on the Servers tab and then the Stop the server icon.   
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__ f. Close both Visual Test Connector windows.  
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What you did in this exercise 

In this chapter you examined existing components that can be used in the eXchange scenario. You then 
defined the Imports, Exports and bindings  needed to create an end to end solution. Finally, you tested that 
solution by driving input from a Visual Test Connector and examining the resulting output.   
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Solution Instructions 

____ 1. Follow the directions in the task Initialize the Workspace for a Lab Exercise, using the following 
values:  

 <WORKSPACE> 

C:\Labfiles60\eXchange\EndToEndNoFFA\workspace 

 <PROJECT_INTERCHANGE> 

C:\Labfiles60\eXchange\EndToEndNoFFA\Solution\EndToEnd_PI.zip 

 <MODULE> 

n/a 

 <DEPENDENT_LIBRARIES> 

  n/a 

____ 2. Continue with Part 4: Testing eXchange. 
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Task: Adding Remote Server to WebSphere Integration 
Developer Test Environment 

This task describes how to add a remote server to the WebSphere Integration Developer Test 
environment.  The sample will use a z/OS machine. 

____ 1. Create a new remote server. 

a. Right click on the background of the Servers view to access the pop-up menu. 

b. Select New > Server. 

  

 

  

c. Specify hostname to the remote server, <HOSTNAME>. 

d. Ensure that ‘WebSphere Process v6.0 Server’ is highlighted in the server type list.   
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e. Click Next. 

f. On the WebSphere Server Settings page, select the radio button for RMI and change the ORB 
bootstrap port to the correct setting (<BOOTSTRAP_PORT>). 

 

g. Click Finish. 

h. The new server should be seen in the Server view. 
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____ 2. Start the remote server if it is not already started.  WebSphere Integration Developer does not 
support starting remote servers from the Server View. 

a. From a command prompt, telnet to the remote system if needed:   

‘telnet <HOSTNAME> <TELNET_PORT>’ 

 userid :  <USERID> 

 pw :  <PASSWORD> 

If the remote server runs on a System i
® 

server, sign on to the system and start a Qshell session. 

b. Navigate to the bin directory for the profile being used:           

 cd <WAS_HOME>/profiles/<PROFILE_NAME>/bin 

c. Run the command file to start the server:  ./startServer.sh <SERVER_NAME> 

d. Wait for status message indicating server has started: 

 

 

ADMU3200I: Server launched. Waiting for initialization status. 

ADMU3000I: Server cl1sr01 open for e-business; process id is 0000012000000002 
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Task: Connecting with the Visual Test Connector 

This task describes how to create a Profile and start a connection with the Visual Test Connector (VTC). 

____ 1. Ensure the WebSphere Process Server is active (the server is the JMS Broker).   The VTC requires 
an active JMS Broker to start it’s connection.  

____ 2. Start the Visual Test Connector  

__ a. From the start menu, select Programs > IBM WebSphere Business Integration Adapters > 
IBM WebSphere Business Integration Toolset > Visual Test Connector (VTC).  This opens a 
command window in the background where the process runs and the Visual Test Connector 
Interface in the foreground.  Do not close the command window as this will cause the VTC to 
exit.  

____ 3. Create/Select a Profile  

__ a. From the VTC interface, select File > Create/Select Profile 
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__ b. If a profile does not already exist, create one by selecting File > New Profile …  If a profile does 
already exist skip to step d. 

 

 

__ c. Browse to and select the connector configuration file, type in a Connector Name for the Profile, 
and select WAS for the Broker Type.   Click OK. 
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__ d. Select and highlight the profile and click OK 

 

__ e. Select File > Connect 
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__ f. View messages in the lower window.   

 

 

 


