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IBM WebSphere® Enterprise Service Bus V6.0.1 — Lab Exercise

WebSphere Enterprise Service Bus Lab 2 — Add Custom
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What this exercise is about
The objective of this lab is to create another backend, CustomerServiceExtended, and use mediations to

help decide which backend to use. Read the introduction below for a bigger picture of what this lab is
about.

Lab Requirements
List of system and software required for the student to complete the lab.

e WebSphere Integration Developer V6.0.1 with the WebSphere Enterprise Service Bus test server
option installed.
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What you should be able to do
At the end of this lab you should be able to:

e Import project interchange files into the WebSphere Integration Developer V6.0.1 development
environment.

¢ Know how to create Custom Mediation primitives and understand what they do.

e Know how to create Database Lookup primitives and understand what they do.

e Know how to create Message Filter primitives and understand what they do.

¢ Know how to create XSL Transformation primitives and understand what they do.

e Navigate the Properties View for mediation information.

Introduction

In Lab 1 of this lab series, you changed an SCA application to one that uses a mediation module as
described in the diagram below. You added the CustomerRoutingMediationModule between the
PortfolioManager service and the CustomerBackend service to allow you access to message information
being passed between them. You then created a mediation flow called CustomerRoutingFlow that uses a
Message Logger mediation to store message information in a cloudscape database.

.:“CustomerRouting
Portfolio Manager : Mediation Module
Client JSP
Enter Customer ID
(string) H H
Display Va!ue of Import E E EXPOI’t
= — 1
CustomerService : -  CustomerService
: Export ©o :
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" Portfolio Service Import 3
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I —e]
: Import : StockQuotelnterface
: . I : :
-, PortfolioManager Module StockQuotelnterface  © :
llllllllllllllllllllllllllllllllllllllllllllllllllllllllllll "§tockQuoteManager Module “:

In Lab2, you will add to the Message Logger mediation primitive with a couple others available in
WebSphere Integration Developer V6.0.1. The main goal for Lab2 will be to create another backend,
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CustomerServiceExtended, and use mediations to help decide which backend to use. You will first add a
Custom Mediation. The Custom Mediation is a mediation primitive that is used when you want some
custom functionality from a mediation. For this custom mediation, it will use a java snippet that will extract
a two digit prefix from the customer ID and place 2 digit it in the transient context (a business object).
Think of transient context as a scratchpad, a place for information to be stored in a message as it passes
through a flow. You will then add a Database Lookup primitive that uses that two digit prefix from transient
context as key to lookup a backend identifier to place into transient context. The Customer ID prefixes
with 11, 22, 33, and 44 will go to the CustomerService backend. Customer ID prefixes with 55, 66, 77, 88,
and 99 will go to a CustomerServiceExtended backend. To determine the message routing based on
backend identifier, you will add a Message Filter primitive. The old backend will go directly to the callout
for CustomerService and the new backend will go to the XSL Transformation. The XSL Transformation
will transform the CustomerService business object (BO) into the CustomerServiceExtended business
object, then pass the newly formed message to the callout for CustomerServiceExtendedPartner instead
of the CustomerServicePartner. Notice that this is just the request. There is also a flow for the response.
On the response side, the CustomerServicePartner callout response will go directly to the
CustomerService input response. However, the CustomerServiceExtended callout response will need to
go back through an XSL Transformation mediation in order to transform the response body from the
CustomerServiceExtended business object back to the CustomerService business object. Feeding the
CustomerServiceExtended business object to application would end in error because the application only
knows how to work with the CustomerService business object. This is the reason why you need an XSL
Transformation mediation primitive; to map one business object to another. The diagram will now look like
the one below.
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In Lab 3 of this lab series, you will use the Visual Debugger to step through the application in order to see
what is happening behind the scenes.

In Lab 4, you are going to learn how to create EAR files for mediation modules, install EAR files to the
WebSphere ESB Server profile, and edit/connect SCA Binding information without using WebSphere
Integration Developer. You will be using the Administration Console for the WebSphere ESB Server.
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Throughout the lab you will learn what WebSphere Integration Developer does behind the scenes by
manually exporting EAR files, installing EAR files, starting/stopping the ESB server, and using the
Administrative Console to edit SCA Binding information. This is helpful to know how to take these actions
outside of the development environment and to understand what WebSphere Integration Developer is
doing for you when inside the development environment.

Exercise Instructions

Some instructions in this lab may be Windows® operating-system specific. If you plan on running the lab
on an operating-system other than Windows, you will need to run the appropriate commands, and use
appropriate files ( .sh vs. .bat) for your operating system. The directory locations are specified in the lab
instructions using symbolic references, as follows:

<WID_HOME> C:\Program Files\IBM\ID
<LAB_FILES> C:\Labfiles601 /tmp/Labfiles601
<TEMP> C:\temp /tmp

Windows users note: When directory locations are passed as parameters to a Java program such as
EJBdeploy or wsadmin, it is necessary to replace the backslashes with forward slashes to follow the Java
convention. For example, C:\LabFiles601\ would be replaced by C:/LabFiles601/

Note that the previous table is relative to where you are running WebSphere Integration Developer. The
following table is related to where you are running remote test environment:

<SERVER_NAME> serveri cl1sr01

<WAS_HOME> C:\Program /etc/cl1cell/AppServerNode1
Files\IBM\WebSphere\AppServer

<HOSTNAME> localhost mvsxxx.rtp.raleigh.ibm.com

<BOOTSTRAP_PORT> 2809 2809

<TELNET_PORT> N/A 1023

<PROFILE_NAME> AppSrv01 default

<USERID> N/A cltadmin

<PASSWORD> N/A friday

Instructions for using a remote testing environment, such as z/OS, AIX or Solaris, can be found at the end
of this document, in the section “Task: Adding Remote Server to WebSphere Integration Developer
Test Environment”.
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Part 1: Prepare Environment for Lab 2

In this section of the lab, you will be importing all projects inside the WESBIab_StartLab1_PI.zip project
interchange file into your workspace. Remember this is the sample SCA application that you are going to
add ESB specific mediations to.

1. Start WebSphere Integration Developer V6.0.1 with a workspace location of
C:\LabFiles601\WESB\Lab2\workspace.

2. Onthe Welcome window, click the curved arrow at top right to go to workbench.

&
[ -

Workbench
Go to the workbench

Import Project Interchange file, WPIv601_ESB_StartLab2_Pl.zip, into the development
environment if starting fresh, or WPIv601_ESB_FinishedLab1_Pl.zip if continuing from Lab1.

__a. Right-click inside Business Integration View (top left view in the Business Integration
Perspective)

___b. Select Import from list.

F2- Business Integration &7

Mew L4

b

23 Import...

__ . Select Project Interchange from list. Click Next.

__d. Select the top Browse button for From zip file:

__e. Navigate to C:/LabFiles601/WESB/Lab2/ WPIv601_ESB__ StartLab2_Pl.zip.
__f. Click the Select All button to check all checkboxes for projects listed.

__g. Verify you have CustomerBackend, CustomerRoutingMediationModule, PortfolioLibrary,
Portfolio Manager, and StockQuoteManager modules listed in the Business Integration view.

__h. Click Finish button (projects will be imported and auto-build will run).
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__i. Verify you have WebSphere ESB Server v6.0 listed in your Servers view.

|Properties | Problems | 4 Servers 23

Server
_E}H WebSphere ESE Server w60

Prepare Assembly Diagram for Lab 2

__j. Open Assembly Diagram for CustomerRoutingMediationModule by double-clicking the entry in
Business Integration View.

El b CustomerRoutingMediationMadule
- Reetl C1ustomerRoutingMediationModule
G-, Mediation Logic
[55 Data Types

__ k. Change the name of the import CustomerServiceOut to CustomerServiceOld.

(1) & CustomerServiceOld
Add Import CustomerServiceNew in Assembly Diagram of CustomerRoutingMediationModule.
Drag and drop an import on the right-hand side of CustomerRoutingFlow.

Click on Import icon from Assembly Diagram tray ( 2 ).
Click or drag import to the right side of CustomerRoutingFlow.

Change default import name from Import1 to CustomerServiceNew.

1gFlow L1 = CustomerServiceMew

Hover over import or click on import to make the add interface icon appear.

Click “I” icon ( @ ) to add an interface.

1) Select CustomerServiceExtended from the list of matching interfaces. Click OK.
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2) Wire CustomerRoutingFlow and CustomerServiceNew together by clicking on
CustomerRoutingFlow and drag a wire to CustomerServiceNew.
Click OK for any pop-up windows.

T (@) [ CustomerServiceMew
Jow

i = CustomerServiceOld

3) Update SCA binding for CustomerServiceNew.
a) Right-click on CustomerServiceNew and select Generate Binding > SCA Binding.
b) Select the Import CustomerServiceNew on the Assembly Diagram.
c) Open Properties view to the Binding tab.
d) Click Browse... button and select CustomerServiceExtendedExport. Click OK.

e) Here is what your bindings tab should look like now.

1 Properties &% . Problems | Servers

Description = Import: CustomerServicelew (SCA Binding)

Details Module name: | CustomerBackend

Binding Export name: | CustomerServiceExtendedExport

f) Save all work by File > Save All or Crtl + Shift + S.

g) After saving the Assembly Diagram, there should be a red X on the
CustomerRoutingFlow. You need to merge the implementation between the
Assembly Diagram and the Mediation Flow to resolve this conflict.

4) Merge Implementation to synchronize Assembly Diagram and Mediation Flow from adding
the new input.

a) Right click on the CustomerRoutingFlow in the Assembly Diagram.

b) Select Merge Implementation.

c¢) Click OK on warning message that appears.

d) Click OK to add the CustomerServiceExtendedPartner to the Mediation Flow.

e) The Mediation Flow Editor will appear and CustomerServiceExtendedPartner will
be added to the Operation connections view (top-most view of Mediation Flow
Editor).
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f) Drag a wire from the CustomerService operation on left-hand side of the Operation
connections view to the CustomerServiceExtendedPartner.

CustomerServicePartner

- .5_3{3 getCustomerInformation

Ll

CustomerServiceExtendedPartner

L %% getCustomerExtendedInfo

g) Click on the wire in the Operation connections view in the Mediation Flow Editor to
see the Mediation Flow view (middle view).

h) Notice also in the Mediation Flow view that a callout (for Request tab - 1) and an
input (for Response tab - 2) has been added for
CustomerServiceExtendedPartner.

CustomerServicePart... 2‘.}
CustomerServiceExte... |l
CustomerService_get... o[}

b
I CustomerServicePart...

ﬁé} CustomerServiceExte. ..

EE";‘}REE]LJESf: getCustomerInformation aIResponse: getCustomerInformation

i) Save editor by selecting File > Save or Ctrl + S.

5) Create a transient context business object.

In this lab, the custom mediation primitive you will be creating in the next section uses java
code that will extract a two digit prefix from the customer ID and places those 2 digits in the
transient context. Think of the transient context as a scratchpad, somewhere to store
information in a message. It is defined as a business object (or DataType in the Business
Integration view) and part of the SMO (Service Message Object). These following steps

show you how to create a transient context business object.
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a) Go to the Business Integration view on your workspace. Directly under the
CustomerRoutingFlow mediation flow is an entry called Data Types.

—|-'#= Mediation Logic
- T__._’ Flows
% CustomerRoutingFlow
(=% Data Types
(T} Interfaces

b) Right-click on Data Types and select New > Business Object.

¢) Type in GetCustIinfoTransientContext in the Name field. Click Finish.

d) The Business object editor opens. Click the add attribute icon (4@) twice to add two
attributes to the business object.

e) Change the text attribute1 to accountLocationID.

f) Change the text attribute2 to backend. The result should look like below picture.
= Lil GetCustinfoTransientContext

= a|:|:|:|u|'|tL|:u:ati|:||'|IE-:l- string
backend string

g) Save GetCustinfoTransientContext and close the business object editor.
6) Add GetCustinfoTransientContext to mediation flow input.
a) Open the CustomerRoutingFlow Mediation from the Business Integration view by
double-clicking the entry CustomerRoutingMediationModule > Mediation Logic
> Flows > CustomerRoutingFlow.

b) Click on wire connecting CustomerService to CustomerServicePartner and
CustomerServiceExtendedPartner.

¢) Select/Highlight the only input for request tab of the Mediation Flow view,
CustomerService_getCustomerinformation_Input.

ﬂi‘\f CustomerService_get...

d) Go to the Details tab of the Properties view once the input is selected.

e) Click the Browse... button in the same row as Transient Context. You will see
that Transient Context, nor the Correlation context, is specified

f) Select GetCustinfoTransientContext. Click OK.
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g) Your Details tab will now look like the following:

| EXl Properties 7 . Problems | Servers

Description UD, Input : CustomerService getCustomerInformation_Input

Terminal
|| Details
| Correlation context: <Context object is not specified=>

Transient context:  {http://CustomerRoutingMediationModule }GetCustinfoTransientContext
h) Save changes by selecting File > Save or Ctrl+S.

i) You are now ready to start creating mediation primitives.
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Part 2: Add a Custom Mediation primitive to Mediation Flow

In this section of the lab, you will be adding a custom mediation primitive to the mediation flow. The
custom mediation uses java code which is going to be provided for you in a snippet that will extract a two
digit prefix from the customer ID and place it in the transient context.

1. Delete wire from Messagelogger1 to CustomerServicePartner callout in order to connect message
logger primitive to a new custom mediation primitive.

__a. Inthe Mediation Flow view of the Mediation Flow Editor, click on the wire connecting
MessagelLogger1 to CustomerServicePartner callout.

#=

E=7: Messagelogger1 ERishmes S

___b. Press the Delete button on the keyboard or right click on wire and select Delete.
Drag and drop a custom mediation primitive on the Mediation Flow to create a new custom
mediation primitive.

__c¢. Click the custom mediation icon ( ) in the mediation flow palette (left-hand side) and then
click under the MessagelLogger1. The CustomMediation1 will appear.

Wire the output terminal of MessagelLogger1 to the input terminal of CustomMediation1.

__d. Click on output terminal of MessagelLogger1 and drag a wire to the input terminal of
CustomMediation1.

=]
=7 Messageloggerl

CustomMediation1

Define a Service Operation for CustomMediation1.
__e. Click on CustomMediation1 and navigate to the Details tab of Properties View.
___f. Click on the Define... button.

__@. The Define Custom Mediation wizard will appear. Take the default radio button “Create a new
interface with implementation”. Click Next.

__h. For Message Root drop down box, change the value from “/body” to “/”.

__i.Since you wired the Messageloggeri output to the input of CustomMediation1, the input
message body has been automatically defined. However, since you have not wired the output to
any other object, the output message has not been defined. Click on Browse... next to Output
Message Body to run the Change Message Type wizard.

__j. Click the Browse... to open a list of interfaces. Select CustomerService and click the OK
button.
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__ k. For operation, click the drop-down button to populate the box with the getCustomerinformation
operation.

__ . For Message Category, click the box and select Input. You will notice later input is for the
request side of the flow and output is for the response side of the flow.

___m. The Message Type then gets populated when choosing input or output (request or response).
The wizard should look like this:

Interface: | CustomerService Browse...

Operation: |getCus1J:umerInfcurmaﬁu:un

Message Category: IInput

uuut

Message Type: |getCusb:merInfarmaﬁDnRequesﬁ-«"lsg

n. Click OK.

0. Notice that the Transient Context is defined here when defining a new service operation.
Remember this is what you are going to use to store the 2 digits you will retrieve from the
CustomerlD. Click Next.

__p- On the “create a new interface” section of the Define Custom Mediation wizard, notice the
operation will be named “mediate”. Click Next.

__ Q. Select the second radio button. Specify the implementation manually as Java Component or
Import in the Assembly Editor, default Java implementation will not be generated. After
you save the mediation flow, you will have the Assembly Diagram merge implementation to
generate the java component. Click Finish.

r. Here is what you should have for the service operation definition:

Custom Mediation : CustomMediation1

Service operation:® mediate
Service reference:  CustomMediation 1Partner

Root: !

__s. Save all work by File > Save All or Crtl + Shift + S.

Merge Implementation in Assembly Diagram to synchronize the Mediation Flow with Assembly
Diagram.

__ 1. Open the Assembly Diagram for CustomerRoutingMediationModule by double-clicking the entry
in Business Integration View.

El{g CustomerRoutingMediationMadule

: ‘ﬂa CustomerRoutingMediationModule
G-, Mediation Logic
[&5 Data Types

__u. Right click on the CustomerRoutingFlow in the Assembly Diagram.
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__ V. Select Merge Implementation.

__w. Click OK on warning message that appears.

___X. Click OK to add the CustomMediation1Partner to the Mediation Flow.
___y. The Mediation Flow Editor will appear. Go back to Assembly Diagram.

__ z. Notice that the CustomMediation1Partner java component has been created on the Assembly
Diagram. Save the update (File > Save or key in Ctrl + S) and the red x should disappear after
project has built.

@ & CustomerServiceOld

1.1

T) [ CustomerServiceNew

H
[
[
=
g
3
m
i
A
(=]
| =
(=4
= |

i
il
]
=

[l
Ay
.
- |

1.1

11 5 customMediation 1Partner
-]

Generate implementation code for the java component and copy in snippet code.

__aa. The blue exclamation icon on CustomMediation1Partner states it does not have any
implementation code. Therefore, right-click on CustomMediation1Partner and select Generate
Implementation.

__bb. Click on New Package... button. Type in sca.java.impl for the package, and select it from the
generated list. Click OK.

B scajava.impl

__cc. CustomMediationPartner1_1Impl.java will be created and displayed in Java editor. Scroll down
the page till you see the line... public DataObject mediate(DataObject input1) {

__dd. Add snippet to mediate method and organize imports for code.

1) Outside of WebSphere Integration Developer, navigate to
C:/Labfiles601/WESB/Lab2/snippet1.txt and open in a text editor.

2) Copy contents and paste inside mediate method between the { } symbols where currently
there is...

//TODO Needs to be implemented.
return null;

The code to replace this with is...

ServiceMessageObject smo = (ServiceMessageObiject)inputi;

ContextType context = smo.getContext();

DataObiject transientContext = (DataObject)context.getTransient();
DataObject body = (DataObject)smo.getBody();

DataObject customerinfo = (DataObject)body.get("getCustomerinformation”);
String customerID = (String)customerinfo.get("customerID");

if (customerlID.length() > 1)
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transientContext.setString("accountLocationID", customerlID.substring(0,2));
else

transientContext.setString("accountLocationID", "00");
return (DataObject)smo;

3) Notice there will be errors. You will need to organize imports in order for this code to work.
Right-click in the java editor and select Source -> Organize Imports or Ctrl + Shift + O.

4) Select the first interface that displays, com.ibm.websphere.sibx.smobo.ContextType.
Click Finish.

5) Errors should go away. Save work by navigating to File > Save or Ctrl + S.
6) Close Java Editor.
__ee. Save Assembly Editor navigating to File > Save or Ctrl + S.

__ff. You have now fully created a custom mediation primitive with working java code to support it.
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Part 3: Add a Database Lookup mediation primitive to Mediation Flow

This section is two fold. In the first part of this section, you will learn how to set up a datasource that the
database lookup mediation primitive will use. A simple database is supplied for this lab, however walking
through the steps to set up the datasource allows you to view the Administration Console and what it takes
to use a database lookup mediation primitive. In the second part of this section, you will add a Database
Lookup primitive that uses that two digit prefix from transient context as key to lookup a backend identifier
to also place into transient context. The Customer ID prefixes with 11, 22, 33, and 44 will go to the
CustomerService backend. Customer ID prefixes with 55, 66, 77, 88, and 99 will go to a
CustomerServiceExtended backend.

1. Add a datasource in the administration console for the database lookup primitive to use.
Start WebSphere ESB Server v6.0.

If using a remote testing environment, follow the instructions in Task: Adding Remote Server
to WebSphere Integration Developer Test Environment at the end of this document, to
start the remote server.

If using a local testing environment:
1) Open Servers View.

2) Highlight WebSphere ESB Server v6.0 and click Start button ( G ).

-.Prnperﬁes:Pranerns 4l servers 53 ﬁ {} l.;.f;
Server ] Host name I Status
B WebSphere ESE Server v6.0 localhost i Stoppe

| R R T A R (SR SRR

3) This will take some time. Wait for the server status to say Started.

NOTE: You may notice a relationship error in the console view after the server has started. Please
disregard and continue with lab. It is a problem that is currently being fixed.

__b. Right-click on the WebSphere ESB Server v6.0 in the Servers view and select Run
administration console.

__c. Log-in to the administration console with any user ID you like.

__d. Under the Task Filtering Selector section on the first page of the administration console, click on
Server and Bus, then the Apply Button.

__e. Inthe left hand menu options, find Resources and click to open.

__f. Click on JDBC Providers.
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__@. There are 3 radio button choices when you first come to the JDBC Providers page. Click the

B Resources

radio button next to Server: <SERVER_NAME-> and click the Apply button.

data rrom databases.

B Scope: Cell=esbhCall, Mode

IMS Providers

JDEBC Providers

7 call : esbcell
Rescurce Adapters

Mail Froviders ~

o MNode : esbNode
URL Providers
Rescurce Envirocnment
Providers

-+ ¥ Server ! serverl
Common Bvent

Infrastructurs

Provider Apply

__h. Below the Apply button is the list of JDBC providers that the server knows of. Click on

Cloudscape JDBC Provider (XA).

__i. Under Additional Properties on the right hand side of the page, click on Data sources link.

___j. At the datasources table, click on the New button at top-right of the data sources table.

__ k. For name, delete Cloudscape JDBC Driver XA Data Source and replace with ESB Database

Lookup Mediation Data Source.

__ . For JNDI name, replace jdbc/Cloudscape JDBC Driver XA Data Source with

jdbc/CustomerRoutingMediation.

* Name

|E5E!- Database Lookup Mediation DataSource

JNDI name
de|:|:-"CuEtDmerRDutingMEdiatiDn

__m. Scroll down to the bottom of the page and enter

2006 August, 07

C:\Labfiles601\WESB\CustomerRoutingMediation for Database Name.

If using a remote system for testing, you will need to put the database on your remote system by
uploading it in binary. This entails uploading the entire database folder. Once on your remote
system, upload just the service.properties file in ASCII. You will then need to substitute the
directory where you placed the database, such as /u/wsuser/CustomerRoutingMediation.
Make sure the permissions are set up to allow the server to access the database.

Cloudscape data source properties
* Database name
[c:\Labfiless01WESB\Custon

Apply | |OK| | Reset Cancel
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__n. Click the Apply Button.

__ 0. After the page refreshes, click on the save link at the top of the page.

aration. Click Save to apply

changes to take effect.

__p. You will be taken to the Save page. Click the Save button. Only one file, resources.xml, was
updated.

B Total changed documents: 1

Changed Items

cells / esbCell / nodes / esbNode

Sa'.re| Discard | Cancel |

___@. After the file has saved on the running application, you will see the JDBC Providers table is
updated with your new datasource.

ESE Database Lockup Mediation | jdbe/CustomerRoutingMediation
CataScurce

__r. At the top-left of the Administration Console page, click on Logout. Close Administrative
Console.

You have now built the datasource and are ready to build the Database Lookup mediation
primitive in your workspace.

3. Open the Mediation Flow diagram if not already up.
4. Drag and drop a database lookup primitive on the Mediation Flow to create a new database lookup
primitive.
__a. Click the database lookup icon ( D ) in the mediation flow palette (left-hand side) and then
click under CustomMediation1. The DatabaselLookupi primitive will appear.

Wire the output terminal of CustomMediation1 to the input terminal of DatabaselLookup1.

__b. Click on output terminal of CustomMediation1 and drag a wire to the input terminal of
DatabaselLookup1.
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7. Messageloggerl
CustomMediation

[] DatabaseLookupl

Connect the keyNotFound output terminal with the
CustomerServicePartner_getCustomerinformation_Callout.

__c¢. The middle output on DatabaselLookup1 is called the keyNotFound output. As you would think,
if a key is not found when a lookup is performed on the database, the message will be sent to
this output terminal. If a key is not found, you would like to send that message to the
CustomerServiceOld backend.

Click the keyNotFound output terminal of DatabaseLookup1 and drag to
CustomerServicePartner callout.

=] : ¢
1) Messagelogger 1 . CustomerServicePart. .. >:>

CustomerServiceExte...  |jis
CustomMediation1 '

CustomerService_get... ;}G

[] Databaselookup1

d. In the above image, notice that the bottom node on the right-hand side,
CustomerService_getCustomerinformation_InputResponse, will not be wired in this
example. InputResponse stops the message and sends it as-is back as the response (in this
case not going to the backend module and back through the response side of the mediation
flow). Since you do want your message to go to the backend module, you will send the message
through the two callout nodes.

Define the datasource and database lookup information in the details tab of Properties view.
__e. Click on DatabaselLookup1 and open Properties View.
__f. Click on Details tab.

__g. Enter the datasource information.
We have setup a database for you already and have defined this database with a datasource in
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the Administrative Console of the WebSphere Enterprise Service Bus server. In this sub-step,
you are filling out the form to allow this application to use this datasource and database.

1) Data source name: jdbc/CustomerRoutingMediation

2) Table Name: BACKEND_LOCATIONS

3) Key column name: ACCT_NO_PREFIX

4) Key path: Click on Custom Xpath... button to define which element to use.
a) Navigate the menu and click on context > transient > accountLocationID.

& ServiceMessageObject @ PARENT
- @ context : context
+-{3 correlation : anyType
—-{@ transient : GetCustinfoTransientContext
+- (3 accountLocationID : siring
+-{@ backend : string
+-{@ faillnfo : FaillnfoType
+- @ headers : HeadersType
& body : getCustomerInformationRequestMsg

b) Click OK.

5) In the Data Elements table, enter the backend element from the transient context as your
message element you want to lookup.

a) Click on the Add button at the bottom of the Details tab page.
b) In the Add/Edit properties wizard, enter the following values
(1) Value column name: BACKEND_ID
(2) Message value type:java.lang.String (leave as is)

(3) Message element: Click on Custom Xpath... and navigate to context >
transient > backend.

(4) Click OK. Click Finish.

__h. Your final detail tab page should now look like this...

Data source name: ™ |jdI:uc;'CustomerRouﬁngMediaﬁnn |

Table name: * [ BACKEND_LOCATIONS |

Key column name: * | ACCT_NO_PREFIX |

Key path: = |..-'context,."transient,f’accounﬁ_ncaﬁonID = i Custom XPath. ..

O validate input

Data elements:

| Value column name Message valus type | Message element

BACKEMD_ID java.lang.5tring Jrontextftransient,backend
FAit
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Save your work by navigating to File > Save or hitting Ctrl + S on your keyboard. You are finished
defining a Database lookup mediation primitive that looks up the backend identifier.
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Part 4: Add a Message Filter mediation primitive to Mediation Flow

In this section you will determine the message routing based on backend identifier by adding a Message
Filter primitive to the Mediation Flow. The old backend will go directly to the callout for CustomerService
and the new backend will go to an XSL Transformation mediation primitive (XSL Transformation will be
explained in next section).

1. Drag and drop a Message Filter mediation primitive on the Mediation Flow to create a new message
filter.

L
___a. Click the message filter icon ( v ) in the mediation flow palette (left-hand side) and then click
under DatabaseLookup1. The MessageFilter1 primitive will appear.
Wire the output terminal of DatabaseLookup1 to the input terminal of MessageFilter1.

__b. Click on output terminal of DatabaseLookup1 and drag a wire to the input terminal of
MessageFilter1.

[] Databaselookupi

_ﬁ MessageFilter 1

Add OldBackend1 and NewBackend1 output terminals to MessageFilter1
__c. Click on MessageFilter1 and open the Terminal tab of the Properties View.
__d. Right-click on Output terminal and select Add Output Terminal.
__e. Leave terminal type as “match”, but change the Terminal Name to OldBackend1. Click OK.
__f. Right-click on Output terminal and select Add Output Terminal again.
___@. Leave terminal type as “match”, but change the Terminal Name to NewBackend1. Click OK.

__h.You should now have 3 output terminals on MessageFilter1.

= 1 Input terminal

......................................

default

OldBackend1

MNewBackend1 i MessageFilter 1
= ¥ Fail terminal

fail

Add two filter options on Details tab to determine the message routing based on the backend
identifier/pattern.
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__i. Click on the Details tab of the Properties View. Here is where you will provide the filter options
for the message filter to make decisions on which output to send the message to, NewBackend1
or OldBackend1.

__j. Click on the Add button on right-hand side of the Details tab page.
__ k. In the Add/Edit wizard, click on the Custom Xpath... button.
__ . Navigate to context > transient > backend and click on backend.

___m. Below, next to Condition: click on the cell that currently has “Location” in it. Click the self:: ()
node : string option.

__n. For the value, click on “Value” in blue text, and then click on String. Enter the text OLD1 and hit
enter button on keyboard.

+-{3 accountlocationID : string
i3 backend : string
+-i3 failnfo : FaillnfoType
+ - @ headers : HeadersType
+- @ body : getCustomerInformationRequestMsg

o =

wPath Location: | fcontextftransient/backend

Condition: selfi:node() =D
__ 0. Click OK. Keep the Terminal Name of OldBackend1.
__p. Click Finish.

__g. Now do this again to add a filter option for NEW1. Click on the Add button on right-hand side of
the Details tab page.

__r. In the Add/Edit wizard, click on the Custom Xpath button.
__s. Navigate to context -> transient -> backend and click on backend.

__t. Below, next to Condition: click on the cell that currently has “Location” in it. Click the self:: ()
node : string option.

__u. For the value, click on “Value” in blue text, and then click on String. Now this time, enter the text
NEW1 and hit enter button on keyboard. Click OK.

__ V. Click the drop-down box for Terminal Name and change it to NewBackend1.
__w. Click Finish. Here is what you should have in your filters table.

Filters:
I Pattern | Terminal name |

""""" Jcontextftransient/backendizelf::nodei = HEW T NewBadkend1
Jeontextftransient/backend[self: :node()="0LD 17 CldBackend1
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__X. Save your work by navigating to File > Save or hitting Ctrl + S on your keyboard.
Wire default and OldBackend1 output terminals to CustomerServicePartner.

___y. In the mediation flow diagram, click on the default output terminal of MessageFilter1 and drag it
to the CustomerServicePartner callout.

__ z. Click on the OldBackend1 output terminal of MessageFilter1 and drag it to the
CustomerServicePartner callout.

=

E1 Messageloggerl CustomerServicePart.., |l

CustomerServiceExte. .. .s.;“,;
Z2 CustomMediation1 '

CustomerService_get... ’;[}

[] DatabaselLockup1

31 MessageFilter 1

__aa. The NewBackend1 is now reserved to go to an XSL Transformation since you need to change
the CustomerService business object to a CustomerServiceExtended business object.

__bb. Save all changes.
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Part 5: Add XSL Transformation mediation primitives to Mediation Flow

In this section you will create two XSL Transformations that will transform the CustomerService business
object (BO) into the CustomerServiceExtended business object, then pass the newly formed message to
the callout for CustomerServiceExtendedPartner instead of the CustomerServicePartner. Notice that this
is just the request. There is also a flow for the response. On the response side, the
CustomerServicePartner callout response will go directly to the CustomerService input response.
However, the CustomerServiceExtended callout response will need to go back through an XSL
Transformation mediation in order to transform the response body from the CustomerServiceExtended
business object back to the CustomerService business object. Feeding the CustomerServiceExtended
business object to application would end in error because the application only knows how to work with the
CustomerService business object. This is the reason why you need an XSL Transformation mediation
primitive; to map one business object to another.

1.

Drag and drop an XSL Transformation mediation primitive on the Mediation Flow to create a new
XSL Transformation.

a. Click the XSL Transformation icon ( E ) in the mediation flow palette (left-hand side) and then
click under MessageFilter1. The XSLTransformation1 primitive will appear.
Wire the output terminal of MessageFilter1 to the input terminal of XSLTransformation1.

b. Click on output terminal (NewBackend1) of MessageFilter1 and drag a wire to the input
terminal of XSLTransformation1.

1 MessageFilter 1

Bl ¥sLTransformation1

Create a new mapping for this XSL Transformation.

c. Select XSLTransformation1 and open the Details tab of the Properties View.
d. Leave the Root: as /body.

e. Click on the New... button on the Mapping File row.

f. Since you wired the MessageFilter1 to XSLTransformation1, the input message body is already
assigned. Click the Browse... button next to Output Message Body.

g. Click the Browse... button to open a list of interfaces. Select CustomerServiceExtended and
click the OK button.

h. For operation, click the drop-down button to populate the box with the
getCustomerExtendedInfo operation.

i. For Message Category, click the box and select Input since you are still working on the request
side. You will notice input is for the request side of the flow and output is for the response side of
the flow.
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___j. The Message Type then gets populated when choosing input or output (request or response).
The wizard should look like this:

e i

Selected Message: ]

Interface: | CustomerServiceExtended Browse...

Operation: igetCusb:umerExtendedInfﬂ

Message Category: |In|:u_|t

L‘_t*_l*_\_

Message Type: {gEtCustDmerExtendedInfaRequest‘dsg

oK Cancel ‘

__ k. Click OK.

__I. Now you should have getCustomerinformationRequestMsg for the Input Message Body and
getCustomerExtendedinfoRequestMsg for the Output Message Body. Click Finish.

___m. The mapping file XSLTransformation1_req_1.xmx will be created and opened. Fully expand
both the Source and Target objects.

| Source 4L T b w  [X] Target 4L g
= %] ¥ smo =% ¥ smo
---[8] body —--[8] body
---[8] getCustomerInformation ---[€] getCustomerExtendedInfo
[8] customerID [8] customerID

[8] portfolicRequested

n. Click on customerID from the Source side and drag to the customerID on the Target side.
Notice triangle icons appear next to the mapped elements and that the Overview view shows the

mapping.

o. Since portfolioRequested is a new element for the target, you are going to assign a default
value to fill portfolioRequested with something. You are going to put the string “default” in for
this value. Right-click on portfolioRequested and select Define XSLT Function.

__p- Leave string as default function. Click Next.
__@. Change Function Name to String in the drop-down list.

__r. Click the Add button for input parameters and type ‘default’. Click OK. Click Finish.

getCustomerExtendedInfo
[e] ¥ customerID
[e] ¥ portfolioRequested

I'EHI customerID Ei customerID

[e] portfolioRequested .ﬁ' string
__s. Save the mapping by navigating to File -> Save or hit Ctrl + S on your keyboard. Close
mapping file.
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__t. Back in the Details tab of Properties View for the XSL Transformation, click on the Regenerate
XSL button. Click OK on the information message. You will see that
XSLTransformation1_req_1.xsl has been generated.

5 ¥SL Transformation : X5LTransformation1

Root: |.|'bﬂd¥' - 1
Mapping file: * xsltXSLTransformation1_req_1.xmx ‘ Pick Map... | | Pick ¥SL... | E
Associated ¥SL:  xsltXSLTransformation1_req_1.xsl ‘ Edit... | | Regenerate X5L |

__u. Click on Mediation Flow and navigate to File -> Save or hit Ctrl + S on your keyboard to save
your Mediation Flow.

Wire the output terminal of XSLTransformation1 to the
CustomerServiceExtendedPartner_getcustomerExtendedinfo_Callout.

__ V. Click on output terminal of XSLTransformation1 and drag to the
CustomerServiceExtendedPartner_getcustomerExtendedinfo_Callout.

__w. Click on Mediation Flow and navigate to File -> Save or hit Ctrl + S on your keyboard to save
your Mediation Flow.

Add an XSL Transformation to the response side of Mediation flow.
This action turns the CustomerServiceExtended business object back into a CustomerService
business object that the application knows how to work with.

__X. Click on the Response tab of mediation flow (found at bottom of mediation flow, two tabs are
available. Request and Response.

=k
?1§$Request: getCustomerInformation ¢"E: Response: getCustomerInformation |
_. Pranertisa 9:’3 : . Penhlamc | Sarvera .

__vy. Drag and drop an XSL Transformation mediation primitive on the Mediation Flow to create a new
XSL Transformation.

1) Click the XSL Transformation icon ( = ) in the mediation flow palette (left-hand side) and
then click on the flow editor canvas. The XSLTransformation1 primitive will appear.

__z. Wire the callout response for CustomerServiceExtendedPartner to the input terminal of
XSLTransformation1.

1) Click on output terminal of CustomerServiceExtendedPartner and drag a wire to the input
terminal of XSLTransformation1.

Fw

@ CustomerServiceExte... ‘] ¥SLTransformation

__aa. Create a new mapping for this XSL Transformation.
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1) Select XSLTransformation1 and open the Details tab of the Properties View.
2) Leave the Root: as /body.
3) Click on the New... button on the Mapping File row.

4) Since you wired the MessageFilter1 to XSLTransformation1, the input message body is
already assigned. Click the Browse... button next to Output Message Body.

5) Click the Browse... button to open a list of interfaces. Select CustomerService and click
the OK button.

6) For operation, click the drop-down button to populate the box with the
getCustomerinformation operation.

7) For Message Category, click the box and select Output since you are now working on the
response side. You will notice input is for the request side of the flow and output is for the
response side of the flow.

8) The Message Type then gets populated when choosing input or output (request or
response). The wizard should look like this:

Selected Message: |

Interface: | CustomerService Browse...

Operation: |getCustDmerInfc:rmaﬁu:un

Message Category: |0u1q:uut

E_l*_ht

Message Type: |getCustumerInfc:rmaﬁDnRespu:unseMsg

9) Click OK.

10) Now you should have getCustomerExtendedinfoResponseMsg for the Input Message
Body and getCustomerinformationResponseMsg for the Output Message Body. Click
Finish.

11) The mapping file XSLTransformation1_res_1.xmx will be created and opened. Fully
expand both the Source and Target objects.

12) Click on customerID from the Source side and drag to the customerID on the Target
side. Notice triangle icons appear next to the mapped elements and that the Overview
view shows the mapping.
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13) Do this same dragging action (from source to target) for firstName, lastName, stocks,
numberOfShares, and symbol. Since stocks is an array, you have to map the array
elements so that each array and array element is transformed.

[%] Source f&‘ 4L ip B2 b = [] Target b—ﬂ- ¢ B4 .
=[] ¥ smo = [¥] " smo
=--[8] body =--[€] body
=[] getCustomerExtendedInfoResponse —--[€] getCustomerInformationResponse
-1--[8] customerExtendedData =-[e] customerData
[e] * customerID [0..1] [e] " customerID [0.. 1]
[€ * frstiame [0..1] [E " frstiame [0..1]
(€] * lastiame [0..1] (€] * lastiame [0..1]
=--[€] ¥ stocks [0..7] =[€] " stocks [0..%]
[e] * numberofshares [0..1] [&] * number0fShares [0..1]
(€] ¥ symbel [0..1] (€] * symbal [0..1]

[8] servicelevel [0..1]
[e] portfoliolD [2..1]

14) Save the mapping by navigating to File > Save or hit Ctrl + S on your keyboard.
Close the mapping file.

15) Back in the Details tab of Properties View for the XSL Transformation, click on the
Regenerate XSL button. Click OK on the information message. You will see that
XSLTransformation1_res_1.xsl has been generated.

16) Click on Mediation Flow and navigate to File > Save or hit Ctrl + S on your keyboard to
save your Mediation Flow.

__bb. Wire the output terminal of XSLTransformation1 to the
CustomerService_getCustomerInformation_InputResponse.

1) Click on output terminal of XSLTransformation1 and drag to the
CustomerService_getCustomerInformation_InputResponse.

__cc. Click on Mediation Flow and navigate to File > Save or hit Ctrl + S on your keyboard to save
your Mediation Flow.
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Part 6: Test the CustomerServiceExtended backend

In this section you will run a JSP that enters a customerID to start off the process. However, for lab 2 you

are going to test the new CustomerServiceExtended backend instead of the old CustomerService
backend.

1. You have previously started the server as part of the lab. But since you configured a JDBC data
source, you need to restart the server.

Start WebSphere Enterprise Service Bus Server and add modules to server
Open Servers View.
__a. Highlight WebSphere ESB Server v6.0 and click Stop button
__ 2. Start WebSphere Enterprise Service Bus Server and add modules to server

If using a remote testing environment, follow the instructions in Task: Adding Remote Server to

WebSphere Integration Developer Test Environment at the end of this document, to start the
remote server.

If using a local testing environment:

__a. Open Servers View.

__b. Highlight WebSphere ESB Server v6.0 and click Start button ( G ).

-.Prnperties | Problems i Servers 83 ﬁ 2 &
Server ] Host name 1 Status
WebSphere ESB Server va.0 localhost iz Stoppe
EIA'_LI"_L_-_ [ o IS . L

s S

NOTE: You may notice an error in the console view after the server has started. Please disregard and
continue with lab. It is a problem that is currently being fixed.

Add projects to WebSphere Enterprise Service Bus Server (once the ESB Server is started, not
before).

__c. In Servers view, right-click on WebSphere ESB Server v6.0 and select "Add and Remove
Projects...”

Maonitoring L4
’"; Add and remove projects...

Run universal test dient
Restart universal test client
Fun administrative console

NOTE: Notice you are using an ESB profile and not a different server. Therefore, if you have projects
with the same name deployed to the server, there may be some naming conflicts. Open Administrative
Console and stop/uninstall those same-named projects before adding these projects to avoid errors.
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__d. Click Add-All button to move all projects to server and click Finish button. Wait for the

deployment to finish

wonfigure them on the server

Configured projects:

- -

1.

1-{3 CustomerBackendApp

l% PortfolioManagerApp
l% StockQuoteManager App
l% CustomerRoutingMediatior

il 1 (]

1 ”W] Cancel j

Enable web browser icon in WebSphere Integration Developer. You only need to do this once.

__e. Goto Window > Customize Perspective

__f. Click on the commands tab and scroll to the bottom

__g. Click the check box next to Web browser

4+ Customize Perspective

Shortcuts Commands |

Select the command groups that you want to see added to the current perspective (Business Integration). The details field
identifies which menu items and/or toolbar items are added to the perspective by the selected command group.

Available command groups: Menubar Details: Toolbar Details:

[ 1ava Open Actions ;I Navigate toolbar
[ 3ava Search .@ | Mext Annotation
O aunit < Previous Anna...
OLaunch

Qpen External Files

Orrofile

O rroxy Tools

ReportingToolbarLabel

D Resource Mavigation
SampleGalleryactionSetlabel
Search

S&earch...

D Server

Software Updates

Software Updates

[ TutorizlGalleryactionset abel
Web Browser

“ | »

Use F2 to display the description for a selected command item.

-
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__h. Click OK. This should put an icon for Web browser in the WebSphere Integration Developer tools
panel.

| <@ [ &

__i. Click on the web browser icon to launch a browser in WebSphere Integration Developer

__j. Enter http://<HOSTNAME>:<PORT>/PortfolioManagerClient/index.jsp . Where hostname is the
name of the system where the WebSphere Enterprise Service Bus server is located. Port is the
WC_defaulthost port of the WebSphere Enterprise Service Bus profile.

Ex: http://localhost:9080/PortfolioManagerClient/index.jsp

Note: You can get the WC_defaulthost port by going to serverindex.xml file in
<WID_HOME>\pfiesb\config\cells\esbCell\nodes\esbNode. Where WID_HOME is the location where
WebSphere Integration Developer is installed

Ex: C\WID601\pflesb\config\cells\esbCell\nodes\

__ k. Enter 7777777 (7 seven times) in text input box and click Submit to get a response displayed to
the JSP and to the Console View of WebSphere Integration Developer.

__ L. Once you have the value of the customerlID in the JSP, Close the browser.

___m. Stop WebSphere ESB Server v6.0 by highlighting the WebSphere ESB Server v6.0 in the

Servers View and click Stop button ( ® ).
(FYI...You cannot view data in a Cloudscape database when server is running.)

You are done with this exercise. Go ahead and clean up the workspace (steps below) for future
work.
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Part 7: Save Work and Clean Up Server

1. Export project as Project Interchange file

__a.
__ b.

__C.

__d.

e

Navigate to File -> Export.
Select Project Interchange.
Out of all the projects listed, you only need to add a check next to 6 projects.

CustomerBackend
CustomerRoutingMediationModule
PortfolioLibrary

PortfolioManager
PortfolioManagerClient
StockQuoteManager

All other projects are generated upon import of the project interchange into a workspace.
Save in C:/LabFiles601/WESB/Lab2/
Name the project interchange WPIv601_ESB_FinishedLab2_Pl.zip.

If you are not continuing to Lab 3 right now, go ahead and clean up the ESB Server.

2006 August, 07

Start WebSphere ESB Server v6.0 from the Servers view of the Business Integration
perspective.

Right-click on WebSphere ESB Server v6.0 (once started) and select Add and Remove
projects...

Select Remove-All and click Finish.

After remove is done, stop the WebSphere ESB Server v6.0.
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What you did in this exercise

In this lab you added to the Message Logger mediation primitive with a couple others available in
WebSphere Integration Developer V6.0.1. The main goal for Lab2 was to create another backend,
CustomerServiceExtended, and use mediations to help decide which backend to use. You first added a
Custom Mediation that was used to mine out a two digit prefix from the customer ID and place 2 digit it in
the transient context (a business object) using a java snippet. You then added a Database Lookup
primitive that uses that two digit prefix from transient context as key to lookup a backend identifier to also
place into transient context. The Customer ID prefixes you used (77) went to a CustomerServiceExtended
backend. To determine the message routing based on backend identifier, you added a Message Filter
primitive. The old backend went directly to the callout for CustomerService and the new backend went to
the XSL Transformation. The XSL Transformation transformed the CustomerService business object (BO)
into the CustomerServiceExtended business object, then passed the newly formed message to the callout
for CustomerServiceExtendedPartner instead of the CustomerServicePartner. On the response side, the
CustomerServicePartner callout response went directly to the CustomerService input response. However,
the CustomerServiceExtended callout response needed to go back through an XSL Transformation
mediation in order to transform the response body from the CustomerServiceExtended business object
back to the CustomerService business object.
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Solution Instructions
1. Import Solution Project Interchange file.

___a. With a blank workspace in WebSphere Integration Developer, Go to File -> Import -> Project
Interchange.

__b. Click on top Browse button and navigate to C:/LabFiles601/WESB/Lab2/
WPIv601_ESB_Lab2_solution_Pl.zip

___c. Click Finish button.

Add the datasource from the first section of Part 3, the Database Lookup .

Continue past to Part 6 to test the application.
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Task: Adding Remote Server to WebSphere Integration
Developer Test Environment

This task describes how to add a remote server to the WebSphere Integration Developer Test
environment. The sample will use is z/OS machine.

1. Create a new remote server.
__a. Right click on the background of the Servers view to access the pop-up menu.

___b. Select New > Server.

i =
Properties ‘ Problems m\ﬂ:mkz | e 0 =8

Server | Host name I Status I State
ﬁiﬁfehSphere ESE Server v&.0 localhost EEI Stopped Synchronized
'n"'.n'el:uSphere Process Server v&.0 localhost E& Stopped Synchronized

E° server |

__c. Specify hostname to the remote server, <HOSTNAME>.
__d. Ensure that ‘WebSphere Process v6.0 Server’ is highlighted in the server type list.

4= New Server |

Define a New Server

Choose the type of server to create,

specify the host where you want to publish

L

Host name: I mysxxx.rp.raleigh.ibm, com|

Select the server type:
EE? IEM
- WehSphere ESE Server va,0

WehSphere Express v5.0 Server

ﬁ WehSphere Express w5, 1 Server

WebSphere Process ws.0 Server
... 5 iahSnhere wE Server Attach

L_I»

Led e

View By: |Vendor

Description: VWebSphere Process va.0 Server

___e. Click Next.
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__f. Onthe WebSphere Server Settings page, select the radio button for RMI and change the ORB
bootstrap port to the correct setting (<BOOTSTRAP_PORT>).

x

WebSphere Server Settings
Input settings for the new WebSphere sewer]: g
YWebSphere profile mames I j

—Server connection type and admin port
{*' RMI (Better performance)

ORE bootstrap part: | 9131
™ SOAP (Maore firewall compatible)

SOER conmector pork: I a8a0

[ Rum server with resources within the workspace
[ Security is enabled on this server

Zurrent active authentization sethings:

|Jser 10 I

Fassiord; I

Server name: I serverl

—oerver type
¥ BASE, Express or unmanaged Metwork Deployment server

™ Network Deployment server

Metwork Deplovment server name: I

The serwer name is in Ehe form af:
zrelllmame R =node name =/ <server names
For example, localhast/localhost/serverd,

Detect | Click this button to detect the server type.

< Back Mext = | Finish I Cancel

__g. Click Finish.

___h. The new server should be seen in the Server view.
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" _ s
Properties | Problems Ccnsnle| T Gy =4

Server | Host name | Status | State
EWEbSphEFE ESBE Server va.0 localhost E!@ Stopped Synchronized
'v'u'ebSphere Process Server va.0 localhost E!g Stopped Synchronized

ebSphere Process v6.0 Server @ mysxocrtporal...  mvsioocrtp.raleigh.ibm. com Started Synchronized

Start the remote server if it is not already started. WebSphere Integration Developer does not
support starting remote servers from the Server View.

__i. From a command prompt, telnet to the remote system if needed:
‘telnet <HOSTNAME> <TELNET_PORT>’
userid : <USERID>
pw: <PASSWORD>
If the remote server runs on a System i®server, sign on to the system and start a Qshell session.
___j- Navigate to the bin directory for the profile being used:
cd <WAS_HOME->/profiles/<PROFILE_NAME>/bin
___ k. Run the command file to start the server: ./startServer.sh <SERVER_NAME>

__|. Wait for status message indicating server has started:

ADMU3200I:

ADMU3000TI:

Server launched. Waiting for initialization status.

Server cllsr0l open for e-business; process id is 0000012000000002
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