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What this exercise is about 

The objective of this lab is to import an existing BPEL process into WebSphere Integration 
Developer, add CEI events and use Monitor export, which is the plug in capability that 
WebSphere Integration Developer picks up from Modeler, to export a default business 
measures model and monitor it with WebSphere Business Monitor. 

Lab Requirements 
List of system and software required for the student to complete the lab. 

• WebSphere Business Modeler V6 

• WebSphere Integration Developer V6.0 

• WebSphere Process Server V6.0.0 for Monitor Server 

• WebSphere Process Server V6.0.1 for Runtime Server 

• WebSphere Business Monitor V6 – Dashboard Server and Monitor Server 
What you should be able to do 

At the end of this lab you should be able to: 

• Use WebSphere Integration Developer to import a project, enable CEI events and 
export the EAR file from WebSphere Integration Developer 

• Export the EAR file from WebSphere Integration Developer. 

• Use WebSphere Business Modeler to create the default business measures model 
based on the EAR exported from WebSphere Integration Developer. 

• Use the WebSphere Process Server administrative console to install the EAR 

• Use the WebSphere Process Server administrative console to run Monitor schema 
generation 

• Run Monitor scripts to create the Monitor Server tables, replication manager artifacts, 
and start replication manager daemons 

• Use the WebSphere Process Server administrative console to import the business 
measures model 
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• Use the WebSphere Business Process Choreography Explorer to run process 
instances 

• Use Cube Views OLAP Center on the Dashboard Server to import the cubes 

• Use Alphablox on the Dashboard Server to define the cubes 

• Use Portal to define a Dashboard and to view process data 

 
Introduction 

In this lab you will learn how to deploy an existing BPEL process.  This is a complex 
process, but note that you will be performing many different roles during this lab – user 
analyst, process architect, process developer, database administrator, dashboard architect. 
This lab shows you how to enable the CEI events to an existing process imported into 
WebSphere Integration Developer. Then it will show you how to use the plug in capability, 
Monitor Export, which WebSphere Integration Developer picks up from the Modeler and 
generates default business measures model. Then it will guide you to install the EAR file 
into Process Server. Then it will show you how to import the business measures model into 
Monitor Process Server and finally will show you how to monitor and view results in different 
views using WebSphere Business Monitor. 

 
Exercise Instructions 

Some instructions in this lab may be Windows operating-system specific.  If you plan on 
running the lab on an operating-system other than Windows, you will need to run the 
appropriate commands, and use appropriate files ( .sh vs. .bat) for your operating system.  
The directory locations are specified in the lab instructions using symbolic references, as 
follows: 

Reference Variable Windows Location AIX/UNIX Location 

<LAB_FILES> C:\Labfiles60 /tmp/Labfiles60 
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Part 1: Enable Event Monitoring 
____ 1. Import the Model into WebSphere Integration Developer. 

__ a. Select File > Import from the IBM WebSphere Integration Developer. 
__ b. From the Import window select Project Interchange and click Next. 

 
Import Project Interchange Contents window will be opened. 

__ a. Click Browse… and select 
C:\<LabFiles60>\MonitoringProcesses\import\CEIMonitorStart_PI.zip as 
source zipped file. 



© Copyright IBM Corporation 2006. All rights reserved 

2006 May, 09 IBM WebSphere 6.0 – Lab Exercise Page 4 of 56 
 Monitoring Processes Modeled With WebSphere Integration Developer 

__ b. Click Select All and click Finish. 

 
____ 2. Set CEI/CBE event generation for the CleansePublishBPEL process. 

__ a. In the Business Integration view, select CleansePublishBPEL > Business 
Logic > Processes. Double-click to open CleansePublishProcess. 

__ b. Click on any open area in the Assembly editor and select Properties. 
__ c. Select Event Monitor tab. 

There are two destinations for events for business processes. CEI is an event framework 
which is a core component of WebSphere Process Server and available to capture CBE 
events generated throughout the different components running on the server. The Audit Log 
is a specific framework which also accepts events and audit information generated by 
business process components and human tasks only 
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__ d. Insure that CEI checkbox is checked. 

 
__ e. Select All radio button and change Event Content to Full. 
__ f. Check the box for On. 

 
__ g. From the editor, select Receive activity. 
__ h. Select Event Monitor tab again from Properties and insure that CEI checkbox 

is enabled. 
__ i. Click the Selected radio button 
__ j. Check the box for Entry and change Event Content to Full. 
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__ k. Check the On box. 

 
__ l. Now, set all the events to be generated for the AutoClean, ManualClean and 

Publish invoke activities. Set the Event Content to Full and Check the On box. 
__ m. Select inClipBG variable. 
__ n. Click the Selected radio button and check the box for Changed. 
__ o. Select Full for the Event Content and check the On box. 
__ p. Save the process (Ctrl+S).  

Note: You might see some warnings but, you should not see any errors at this time. 

Notice the icon markers added to the activities to indicate monitoring is enabled. 

 
____ 3. Enable the date when process becomes valid. 

__ a. Click on the empty space of the CleansePublishProcess and select Properties. 
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__ b. Select Details tab and check Select date ( UTC) when the process becomes 
valid and ensure that the Valid From date is past date. 

 
__ c. Save the process (Ctrl+S). 
__ d. Close the process editor.  
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Part 2: Export from WebSphere Integration Developer or Modeler 
____ 1. Export EAR file. 

__ a. Right click in the Business Integration view, and then select Export. 
__ b. From Export window select EAR file and Click Next.   

 
__ c. On the ‘Confirm Enablement’ window, click OK.   
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__ d. On the following window, specify the EAR project as CleansePublishBPEL, set 

the destination to Z:\temp\ProjectScenario\CleansePublishBPELApp.ear, and 
check all three options – Export source files, Overwrite existing file, and include 
project build paths and meta-data files.   

 
__ e. Click Finish. 
__ f. Close WebSphere Integration Developer. 

____ 2. Use WebSphere Business Modeler to generate default business measures model 
for the EAR exported from WebSphere Integration Developer in the previous step. 

__ a. From modeler, select File > Export. 
__ b. Select WebSphere Business Modeler Export from Export window and click 

Next. 
__ c. Select WebSphere Business monitor (from BPEL process) from WebSphere 

Business Modeler Export window and click Next. 
__ d. Specify the location of the EAR file which you exported from WebSphere 

Integration Developer as the BPEL location.



© Copyright IBM Corporation 2006. All rights reserved 

2006 May, 09 IBM WebSphere 6.0 – Lab Exercise Page 10 of 56 
 Monitoring Processes Modeled With WebSphere Integration Developer 

 
__ e. Specify the location for Monitor.zip which will be exported from Modeler as 

Export to directory and click Next. 

 
__ f. Select CleansePublishBPEL.jar > com > dipsandtacks > process > 

CleansePublishProcess.bpel. 
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__ g. Select the BPEL activities that you want to monitor and click Next. 

 
__ h. Click Finish. 
__ i. Click OK. 

 
A Monitor.zip file will be created in the specified Export to directory – 
Z:\users\rdyavana\CleansePublishBPELProcess. 

__ j. Close WebSphere Business Modeler. 
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Part 3: Install the BPEL Process on WebSphere Process Server 6.0.1 
____ 1. Deploy the EAR. 

__ a. Copy the EAR to the Runtime Server. 
__ b. If necessary, start Process Server using Start > All Programs > IBM 

WebSphere > Process Server 6.0 > profiles > ProcSrv01 > Start the server. 

Note: Your profile may have a different name than ‘ProcSrv01’. Choose the correct one for 
you. 

__ c. Start the administrative console by selecting Start > All Programs > IBM 
WebSphere > Process Server 6.0 > profiles > ProcSrv01 > Administrative 
console.  

__ d. Click log in.  
__ e. Then, select Applications > Install New Application.  Browse to the EAR file: 

CleansePublishBPELApp.ear.   
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__ f. Click Next on the following window. 
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__ g. Click Next to continue installing the application, accepting all the default step 
settings. 

Note: Click on continue when you get some warnings. 
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__ h. After accepting 9 default settings, click Finish for the summary. 

 



© Copyright IBM Corporation 2006. All rights reserved 

2006 May, 09 IBM WebSphere 6.0 – Lab Exercise Page 16 of 56 
 Monitoring Processes Modeled With WebSphere Integration Developer 

__ i. This window shows a successful install. 

 
__ j. Save the configuration by clicking Save to Master Configuration and then 

clicking Save on the following window. 
__ k. Select Applications > Enterprise Applications. 
__ l.  Select the application CleanseProcessBPELApp and click Start to start the 

application and observer the arrow that indicated that the application is started. 
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Part 4: Run Schema Generator in WebSphere Monitor Server 
____ 1. Run the schema generator. 

__ a. From WebSphere Monitor Server, Select Start > All Programs > IBM 
WebSphere > Process Server 6.0 > Profiles > monitor > Start the server to 
start the server. 

__ b. From WebSphere Monitor Server, Select Start > All Programs > IBM 
WebSphere > Process Server 6.0 > Profiles > monitor > Administrative 
console to open administrative console. 

__ c. In the Monitor Process Server administrative console, select WebSphere 
Business Monitor > Schema Generator > Configuration.   

__ d. For the Business Measures Model, enter the directory path where monitor.zip 
was exported from WebSphere Business Modeler - 
Z:\users\rdyavana\CleansPublishBPELProcess\Monitor.zip.  For the output 
directory, enter Z:\users\rdyavana\CleansPublishBPELProcess.  

 When you run schema generator, it will create a folder called ‘schemagen’ in this output 
directory, and it     will place the generated artifacts there. 

 
__ e. Click Apply. 
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__ f. Click tab ‘State to Runtime Configuration’, and set your ‘Runtime database 
population interval’ to 2.  This sets the replication interval to 2 minutes. 

 
__ g. Click Apply. 



© Copyright IBM Corporation 2006. All rights reserved 

2006 May, 09 IBM WebSphere 6.0 – Lab Exercise Page 19 of 56 
 Monitoring Processes Modeled With WebSphere Integration Developer 

__ h. Click tab ‘Runtime to Historical Configuration’, and set your ‘Historical 
database population interval’ to 2.  This sets the replication interval to 2 minutes. 

 
__ i. Click Apply. 
__ j. Save the configuration by clicking on Save near the top of the administrative 

console, and then click the Save button when it appears. 
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__ k. Select WebSphere Business Monitor > Schema Generator > Generate. 
Click the Generate button.  Messages in the window indicate the result:  

 
____ 2. Run the batch files and run the generated scripts. 

__ a. Refer to WBMonitorV6_EndToEndScenario lab for the instructions and 
complete the steps 2 through 10 of part 3: Run Schema Generator and run the 
generated scripts. 

Note: Replace C:\ProjectScenario with Z:\users\rdyavana\CleansPublishBPELProcess 
(schemagen folder location) while going through the steps from the 
WBMonitorV6_EndToEndScenario lab. 
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Part 5: Import the Business Measures Model and Run Process Instances 
____ 1. Import the business measures model. 

__ a. In the Monitor Server administrative console, navigate to WebSphere 
Business Monitor > Server > Business Measures Model > Model Import.  
Navigate to Z:\users\rdyavana\CleansPublishBPELProcess 
\schemagen\Monitor.zip   

Note: You must specify the path to the Monitor.zip file in the schemagen folder, not the one 
in the parent folder (C:\ProjectScenario) that you specified earlier. 

 
__ b. Click Import. 

Note: This may take some time. 
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__ c. You should see a successful message when it completes: 
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____ 2. Run some process instances. 
__ a. Start the BPC Explorer on the Runtime Server (by default this is accessible at 

http://localhost:9080/bpc), and run several instances of the ProcessScenario 
template.  The process template window will be opened. Click on the My 
Process Templates to see the following window: 

 
__ b. Click on Start Instance and enter the values for all the fields.  
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Note that the process instances are deleted when they are complete, so you will not see 
them listed in the Process Instances list after completion.  This shows the window for 
entering data for a process instance: 

 
__ c. Click Submit. 
You should run several processes like this.  

____ 3. Verify that the process instance data is being stored in the Monitor State database 
and the Monitor Runtime database.  Note that the process instance data is deleted 
from the State database after it has been moved to the Runtime database.  So, if 
you delay in checking this, then the tables may show empty in the State database, 
but then there should be data in the Runtime database. 
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__ a. Start the DB2 Control Center on the Monitor Server.  Select Start > Programs 
> IBM DB2 > General Administration Tools > Control Center.  In the State 
database look for a table name like CTX_*, and the comment ProcessScenario.  
This is the process instance data for your process.   

 
__ b.   Double click on this table and you should see several rows showing process 

instance data: 
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__ c. In the State database look for a table name like AI_*, and the comment ‘Task 
instance table for business measure group ProcessScenario’.  This is the 
task instance data for your process.  

 

 
__ d. In the Runtime database look for a table name like CTR_*, and the comment 

ProcessScenario.  This is the process instance data for completed instances.   

 



© Copyright IBM Corporation 2006. All rights reserved 

2006 May, 09 IBM WebSphere 6.0 – Lab Exercise Page 27 of 56 
 Monitoring Processes Modeled With WebSphere Integration Developer 

__ e. You should see some rows in this table.  But note that you set the replication 
frequency to 2 minutes, so this information will not show up in this table until the 
time period has elapsed following the completion of the process instance.  You 
may need to wait a few minutes, and then click View > Refresh in the DB2 
Control Center before checking the table again. 

 
__ f. If you do not see data in the State database nor the Runtime database, then 

something is wrong. 
1) Ensure that CEI logging is turned on in the Runtime Server -- 

Administrative Console > Servers > Application servers > server1 > 
Business process container settings > Business process container > 
Enable Common Event Infrastructure logging. 

2) Turn on the Monitor trace in the Monitor Server, run a few more process 
instances and check for errors in the trace log.  To get trace details, 
Monitor Server Administrative Console > Troubleshooting > Logs and 
Trace > server1 > Change Log Detail Levels.  Specify log level for sub-
components of com.ibm.wbimonitor.  Then the trace is stored with the 
Process Server logs as trace.log. 
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Part 6: Import Cubes in the Dashboard Server 
____ 1. Import the cube models into DB2 Cube Views.  Note that the remainder of the lab 

will happen on the Dashboard Server. 
__ a. Copy the file Z:\users\rdyavana\CleansPublishBPELProcess 

\schemagen\model_cv.xml from the Monitor Server to the Dashboard server. 
__ b. On the Dashboard Server, select Start > Programs > IBM DB2 > Business 

Intelligence Tools > OLAP Center. 
__ c. When prompted, use userid: db2admin, password: monPa55w0rd. 

 
__ d. The first time you connect to the database, you will get this message.  

 
__ e. Click Yes. 
__ f. The window should look like this. 
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__ g. Select OLAP Center > Import.  For file name, browse (the … button) to the file 
model_cv.xml.  

 
__ h. Click Next. 
__ i. You should see a window like this.   

 
__ j. Click Finish. 
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__ k. Now you will see three models listed in the OLAP Center as follows.  

 
__ l. Close the OLAP Center. 

____ 2. Define the cubes to Alphablox. 
__ a. If the WebSphere Portal server is not running, start it using Start > IBM 

WebSphere > WebSphere Portal V5.1 > Start the Server. 
__ b. Start Alphablox in a browser Start > All Programs > IBM DB2 Alphablox 8.3 > 

Alphablox Analytics > DB2 Alphablox Administrative Pages.   

Note: You may find that Windows will block your attempt to access the page and you should 
see this in the Internet Explorer window in a yellow information bar at the top. Click on this 
bar and select Allow Blocked Content… to continue:  
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__ c. When it prompts for it, enter userid: admin, password: password.  You should see a 
window like this: 

 
__ d. Click on Administration tab to see the following window: 

 
__ e. The first time you use Alphablox, you will need to setup data sources.  So, click 

on the tab ‘Data Sources’ at the top of the Alphablox window. 
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__ f. Click Create to create a data source called HISTORY using values (remember 
to change the adapter field) as in this screen capture: 

 
__ g. Click Save. 
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__ h. Click Create to create a data source called HISTORY_CUBE using values 
(remember to change the adapter field) as in this screen capture. 

 
__ i. Click Save. 
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__ j. Now you should see both data sources defined as follows: 

 
__ k. Use button ‘Test selected data source’ to test each of the two data sources.  

Here is an example of a successful test: 
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__ l. Click on tab ‘Cubes’ at the top of the Alphablox window. Click Create.  You 
should see a window like this: 

 
__ m. Click the checkbox Enabled next to the DB2 Alphablox Cube Name. 
__ n. Select HISTORY for the Relational Data Source. 
__ o. Click the checkbox Enable DB2 Cube Views Settings. 
__ p. Select WBI.CleansePublishProcess for the Cube Model, then click button 

Import Cube Definition. 
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__ q. Type CleansePublishProcess for the DB2 Alphablox Cube Name (do not 
include the WBI).  You should have a screen like this: 
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__ r. Click OK to save the definition.  Then you will see it added to the list as follows: 

 
You will repeat this for each cube in the model.  In this case there are tow cubes, and they 
are listed in the pull down for Cube Model.   
You have defined ProcessScenario and ProcessScenario aggregates, now you will define 
ProcessScenario_Tasks. 

__ s. Click on create to create the cube definition.  
__ t. Click the checkbox Enabled next to the DB2 Alphablox Cube Name. 
__ u. Select HISTORY for the Relational Data Source and click the checkbox Enable 

DB2 Cube Views Settings. 
__ v. Select WBI.CleansePublishProcess_Tasks for the Cube Model, then click 

button Import Cube Definition.  
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__ w. Type CleansePublishProcess_Tasks for the DB2 Alphablox Cube Name 
(do not include the WBI.)  You should have a screen like this: 

 
__ x. Click OK. Then you will see a window showing the two cubes in the list. 
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__ y. Click on the General tab at the top of the Alphablox window.  Then click 
Runtime Management > DB2 Alphablox Cubes.   

 
__ z. For each of the cubes listed, click the Start button.  The status should show as 

‘Running’ for each cube.  Here is an example: 
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Part 7: Configure Dashboards 
____ 3. Make copies of the portlets that you want to use: Active Instances and Reports.  

You should not configure the original portlets, since the configuration cannot be 
removed once it is applied.  So you will make copies of the portlets, then you will 
configure the copies. 

__ a. Start Portal: http://localhost:9081/wps/portal. 

 
__ b. Click ‘Log in’ in the upper right-hand corner.  When prompted, enter userid: 

wpsadmin password: wpsadmin. 

 
__ c. Click on Administration at the top of the page, and then select Portlet 

Management > Portlets. 
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__ d. Browse to page 11 by clicking on the arrow icons.  This page should show the 

portlets for Active Instances and Reports. 
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__ e. On the row containing Active Instances, click the icon for Copy portlet ( )  
You should see this window: 

 
__ f. Click OK. 

__ g. On the row containing Reports, click the icon for Copy portlet ( ).  On the 
next window, click OK. 
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__ h. Now Browse to page 12 by clicking on the arrow icons.  This page should 
show the copies of the portlets for Active Instances and Reports. 

 
____ 4. Create a page containing two views: Active Instances and Reports. 
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__ a. Click on Administration at the top of the page, and then click Portal User 
Interface > Manage Pages. 

 
__ b. Click My Portal, then click tab New Page.  Enter a page title TestPage, click 

OK.  
__ c. On the next window you will get successful page creation message, click OK.   
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Now you should see the new page in the list as follows: 

 
__ d. Click on the Edit Page Layout icon for TestPage. You will find it to the right 

side of the row for TestPage: .  This will open the editor for this page. 

 
__ e. Click button Add portlets on the left side of the screen.  You will see a list of 

portlets.  There are multiple pages of these and you can use the navigation at 
the bottom of the list to look at them.  
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Find Copy of Active Instances (it is on the last page), check it.  

 
__ f. Click OK. 
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__ g. This shows that the Copy of Active Instances view has been added to the 
page: 

 
__ h. Click button ‘Add portlets’ on the right side of the screen.  Find ‘Copy of 

Reports’ on the last page, check it.  
__ i. Click OK. 
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__ j. This shows that both views have been configured on the page: 

 
__ k. Click Done. 
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__ l. Click My Portal at the top of the page.  This window opens and you see that 
there is now a tab for TestPage. 

 
____ 5. Configure the two views on your new page. 

__ a. Click on the tab for TestPage.  This window shows the two views, but they 
need to be configured: 

 

__ b. Click on the Configure icon for the Copy of Active Instances view.  

 
 
 

__ c. Click on Business Measures Model > BPEL Business Measures Project 
(CleansePublishProcess). 
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__ d. Click on Business Measures Groups > CleansePublishProcess. 
__ e. Click the checkbox next to Business Measures to select all of the measures. 

 
__ f. Click Next, Next, Next, Finish. 
__ g. Here is the window showing the active process instances in the view: 

 

__ h. Click the Configure icon on the Copy of Reports view.  
__ i. Click Subject area and select ProcessScenario on the left side of the window. 
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__ j. Click all of the Modeled measures on the right side of the window. 

 
__ k. Click Next. 
__ l. Click Finish.  
__ m. This windows shows both views configured and showing process data: 
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What you did in this exercise 
In the lab, you imported a project into WebSphere Integration Developer, enabled CEI 
events and exported the EAR from WebSphere Integration Developer. Then used Monitor 
export feature of WebSphere Business Modeler to generate default business measures and 
export BPEL process. 
Then you deployed the process (EAR file) to WebSphere Process Server. 
You ran schema generation, created Monitor database and replication manager artifacts.  
You started the replication manager daemons. 
You imported the cubes to Cube Views and Alphablox. 
You configured Dashboards and viewed process data in two different types of views. 
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Solution Instructions 
____ 1. Import the Model to WebSphere Integration Developer. 

__ a. Select File > Import from the IBM WebSphere Integration Developer. 
__ b. From the Import window select Project Interchange and click Next. 

 
Import Project Interchange Contents window will be opened. 

__ c. Click Browse and select 
<LabFiles60>\MonotoringProcess\Solution\WIDExport.zip as source zipped 
file. 

__ d. Click Select All and click Finish. 
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