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What this exercise is about 

The objective of this lab is to show you how to build a monitoring model in WebSphere Integration 
Developer, deploy it to WebSphere Business Monitor, then view your monitoring data on the Monitor 
Dashboards. 

This lab will show you business activity monitoring (BAM) which involves event based monitoring.  With 
BAM, you can have your monitored application running anywhere, and submitting events to the Monitor 
server so that you can view monitored data.  Normally, you identify the events that will be created by the 
application, and then create a monitoring model that represents the monitored data that you want to collect 
from the events. 

 

Lab requirements 

List of system and software required for the student to complete the lab. 

• WebSphere Integration Developer V6.0.2 and the monitoring model editor plug-in 
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• WebSphere Business Monitor V6.0.2 – Basic Installation including the dashboard server and Monitor 
server 

• Optionally, you will need an LDAP server (for example Tivoli Directory Server) if you would like to 
configure Action Manager to create Alerts based on business situation events. 

What you should be able to do 

At the end of this lab you should be able to: 

• Use WebSphere Integration Developer to create the monitoring model, and then export the monitoring 
model as an EAR file. 

• Use the WebSphere Process Server administrative console to install the EAR. 

• Use the WebSphere Process Server administrative console to run Monitor life cycle steps for the 
model. 

• Run Monitor scripts to create the Monitor Server tables, replication manager artifacts, and start 
replication manager daemons 

• Import the cubes to Cube Views 

• Use a sample program to create events that represent events from your process. 

• Use Portal to define a Dashboard and to view monitored data 

 

Introduction 

In this lab you will learn how to deploy a model from end to end using WebSphere Integration Developer 
and WebSphere Business Monitor.  This is a complex process, but note that you will be performing many 
different roles during this lab – user analyst, process architect, process developer, database administrator, 
dashboard architect and user.  This lab will show you the basic procedure for creating and implementing a 
simple model.   

• The model used in this lab is the ClipsAndTacks  model which is also used in IBM Redbook SG247148 – 
Business Process Management: Modeling through Monit oring Using WebSphere V6 Products .  In 
this Redbook, there are several models that are referenced, but this exercise is using the Future 1 
Process.  In the Redbook, the process is implemented as a BPEL process running in WebSphere Process 
Server.  This lab intends to demonstrate business activity monitoring  which can monitor events from 
any source.  So, you will simulate the running of the process, by creating events that could have been 
sourced from anywhere, a J2EE application or BPEL, or any other source.  Note that Monitor only accepts 
events that are in the form of common base events, which is an OASIS standard for common event format, 
and these are used by the common event infrastructure (CEI) in WebSphere Process Server. 

You are also building a monitoring model that has the same basic elements as the one that is defined in 
the Redbook.  Namely you are creating monitoring constructs in support of two KPIs: 

• Average order fulfillment is 3 days or less 

• Percentage of shipped orders is greater than 90% 

 

You also create an additional KPI to demonstrate the usage of a monetary KPI. 

• Average Order Price KPI 
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You also create situation events if Declined Orders is greater than or equal to 5, so in support of that there 
is an additional KPI: 

• Declined order KPI 

You also create situation events if the order fulfillment time is greater than 3 days. 

For dimensional analysis, you will create a Location dimension which allows you to drill down on country 
and city.  You also add Order Status, which shows orders are ‘New’, ‘Cancelled’ or ‘Shipped’.  And you 
add measures for average order price, sum of order price for all orders, and order count. 

Here is a diagram of the ClipsAndTacks process model: 

 

 

 

 

 

 

 

URL Cheat sheet  

The following URLs may be helpful to you as you exercise this lab.  Note that the port numbers in the URL 
of your installation may be different depending on your configuration.  
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• WebSphere Process Server administrative console (for deploying Monitoring models) 

http://localhost:9062/ibm/console/ 

• DB2 Alphablox administrative pages (for deploying cubes) 

http://localhost:9081/AlphabloxAdmin/home  

• WebSphere Portal Server (for setting up and viewing Monitor dashboards) 

http://localhost:9081/wps/portal  

 

 

Note: WebSphere Business Monitor 6.0.2 has improved support for concurrent versions of monitoring 
models. In order to take advantage of the Monitor Server's version handling capabilities, each monitoring 
context must have a unique common base event definition that is the single Inbound Event  that has the 
setting ‘If no instances are found: Create new instance’.  One can think of this as one Inbound Event 
carrying ‘Create Monitor Context’ semantics, and all others as ‘Update Monitor Context’ semantics. Clips 
And Tacks also follows this pattern.  

All developers are encouraged to always have a unique Inbound Event to cause creation of the Monitoring 
Context. 
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Part 1: Create the monitoring model 

To create the monitoring model, you will use the Monitoring Model Editor in WebSphere Integration 
Developer.   

Note that there is a Problems tab that displays errors concerning the model.  Periodically, you should 
check this view to see if you have any problems that need to be addressed. 

If you would like to skip this section, then a solution has been provided.  You can import the supplied 
monitoring model into WebSphere Integration Developer, then proceed to the next section.  Refer to 
Appendix 1, then proceed to the next section. 

 

____ 1. Start WebSphere Integration Developer and setup the environment. 

__ a. Start WebSphere Integration Developer V 6.0.2, and when prompted point to a new workspace 
such as c:\workspaces\ClipsAndTacks 

__ b. Close the Welcome tab. 

__ c. Select Window > Close Perspective  

__ d. By default, you are in the Business Integration perspective.   You want to open the Business 
Monitoring perspective.  Select Window > Open Perspective > Other > Show all > Busi ness 
Monitoring .   

1) If it asks you to Confirm Enablement, then click OK. 

__ e. You should see the following Business Monitoring perspective. 
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____ 2. Create a new monitoring project. 

__ a. Right click the Project Explorer, then select New > Business Monitoring Project…  

__ b. For Project name, enter ClipsAndTacks  
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__ c. Click Finish.  You will see the new project in the Project Explorer view. 

 

____ 3. There is already a common base event definition created for you that represents the event layout for 
events processed in this model.  Import the supplied common base event for ActivityEvent. 
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__ a. Right click in the Project Explorer view, select Import…  

__ b. Select File system , click Next  

__ c. Browse to the location containing the ActivityEvent.cbe file, for example, 
c:\Labfiles602\ClipsAndTacks 

__ d. Select ActivityEvent.cbe  as follows: 

 

 

__ e. Click Finish . 

__ f. Expand the project in the Project Explorer view, then expand the Event Definitions and you will 
see the new event listed. 
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__ g. Double click ActivityEvent  to open the event editor.  Browse the extended data elements to 
familiarize yourself with the event data for this model.   

1) ActivityEventData contains data elements that relate to the activities in the process.  The 
businessUnit and processName  are used to filter out unwanted events that do not relate to 
your particular model.  The activityName is used to associate an event with a specific 
activity in the process.  The eventType is used to identify the state of the activity, either 
starting or completing.  

2) OrderBOData contains data elements that relate to the specifics of a customer order, such 
as orderNumber, country, city, totalPrice, and so on. 
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__ h. WebSphere Business Monitor 6.0.2 has improved support for concurrent versions of monitoring 
models. In order to take advantage of the Monitor Server's version handling capabilities, each 
monitoring context must have a unique common base event definition that is the single Inbound 
Event  that has the setting ‘If no instances are found: Create new instance’.  One can think of this 
as one Inbound Event carrying ‘Create Monitor Context’ semantics, and all others as ‘Update 
Monitor Context’ semantics. Clips And Tacks is a simple sample and could use a single event 
definition for the process. However, to satisfy the requirement of a unique common base event 
definition for version handling, you will create a simple common base event definition now. 

1) Right mouse on Event Definitions and select New > Event Definition…  

2) Enter NewOrderEvent  for the Name 
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3) Click Finish . 

4) The Event Definition Editor for NewOrderEvent opens. 

 

5) Double click the hierarchical icon between the label Parent  and event .  

6) On the Select Event Definition  Dialog double click on ActivityEvent. 
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7) ActivityEvent  is now shown as the parent of NewOrderEvent  

 

8) Press Ctrl-S  to save your work. 

____ 4. Create a new monitor model ClipsAndTacks. 

__ a. Right click in the Project Explorer view, then select New > Monitor Model…  
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__ b. For File name, enter ClipsAndTacks . 

 

__ c. Click Finish .  The model editor is opened as follows: 

Note: When the model editor first opens you will have errors in the model. This is normal and is signaling 
that required elements are missing or incomplete. You will next complete these required elements. 
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____ 5. Notice in the Monitor Details Model navigator that a new model is created (ClipsAndTacks) along 
with a monitoring context (ClipsAndTacks MC).  Now you need to specify the inbound events that 
will be processed by this model.  You need to indicate which event will create a new monitoring 
context instance and which event will terminate the monitoring context instance.  You also need to 
identify the correlation information for the monitoring context so that Monitor knows which monitoring 
context should receive the events.  For the ClipsAndTacks model, you are using one event 
definition, ActivityEvent, to represent the layout of all of the events to be processed. 
NewOrderEvent, which is used for version handling, derives from ActivityEvent but does not add 
additional event elements.  In ActivityEvent, ActivityName is a field used to identify specific activities 
in the ClipsAndTacks process.  You use ActivityName to determine when to terminate the 
monitoring context.  You will create correlation that is based on orderNumber which is another field 
defined in ActivityEvent.  

__ a. In the Monitor Details Model, expand ClipsAndTacks in the navigation view.  Then expand 
ClipsAndTacks MC.  You will see that a key has been created for you automatically when you 
created the model. 



© Copyright IBM Corporation 2007. All rights reserved 

2007 April, 27 IBM WebSphere Business Monitor 6.0.2 – Lab exercise Page 15 of 136 

 ClipsAndTacks 

 

__ b. In the model navigation view, right click on ClipsAndTacks MC, then select New > Inbound 
Event.  

__ c. For the name, type Activity Event .  Notice that the ID will automatically be set for you to the 
same name with underscores (Activity_Event ). 

 

__ d. Click OK. 

__ e. For Type, navigate to ClipsAndTacks > ActivityEvent.cbe > ActivityEvent 

__ f. To enter the Filter Condition, you can use Content Assist using the keys Ctrl-Space, or you can 
type the expression directly into the expression window.  When complete the expression should 
be as follows.  Note the single quotes used for string handling. 
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Activity_Event/extendedData/ActivityEventData/businessUnit = 'Clips And Tacks' and 
Activity_Event/extendedData/ActivityEventData/processName = 'Order Handling' 

__ g. To enter the Correlation Expression, you can use Content Assist using the keys Ctrl-Space, or 
you can type the expression directly into the expression window.  When complete the expression 
should be  

ClipsAndTacks_Key = Activity_Event/extendedData/OrderBOData/orderNumber 

__ h. For If no instances are found, select Treat as error 

__ i. For If one instance is found, select Deliver to the instance 

__ j. For If multiple instances are found, select Treat as error 

__ k. Here is a sample: 
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__ l. Press Ctrl-S  to save your work. 

__ m. In the model navigation view, right click on ClipsAndTacks MC, then select New > Inbound 
Event.  

__ n. For the name, type New Order Event .  Notice that the ID will automatically be set for you to the 
same name with underscores (New_Order_Event ). 
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__ o. Click OK. 

__ p. For Type, navigate to ClipsAndTacks > NewOrderEvent.cbe > NewOrderEvent 

__ q. To enter the Filter Condition, you can use Content Assist using the keys Ctrl-Space, or you can 
type the expression directly into the expression window.  When complete, the expression should 
be as follows.  Note the single quotes used for string handling. 

New_Order_Event/extendedData/ActivityEventData/businessUnit='Clips And Tacks' and 
New_Order_Event/extendedData/ActivityEventData/processName='Order Handling' 

__ r. To enter the Correlation Expression, you can use Content Assist or type the expression directly 
into the expression window.  When complete the expression should be  

ClipsAndTacks_Key=New_Order_Event/extendedData/OrderBOData/orderNumber 

__ s. For If no instances are found, select Create new instance 

__ t. For If one instance is found, select Treat as error 

__ u. For If multiple instances are found, select Treat as error 

__ v. Here is a sample: 
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__ w. Press Ctrl-S  to save your work. 

__ x. In the model navigation view, double click ClipsAndTacks Key , to open the key in the editor. 

__ y. For Key Value Maps, click Add… 

__ z. A row is added to the table and in the expression cell it shows << No expression specified >>.  
Click on this cell of the table, then a button is displayed.  Click on this button and the expression 
editor is displayed.  You can use Content Assist, or type this expression directly into the window: 

New_Order_Event/extendedData/OrderBOData/orderNumber 

__ aa. Here is a sample: 
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__ bb. Click OK.  Here is a sample of the key: 
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__ cc. Press Ctrl-S  to save your work. 

Note: At this point there should not be any errors remaining in the model. The errors shown initially were 
the result of the monitoring context key not being complete. 

 

____ 6. Create triggers that indicate the end of the monitoring context. 

__ a. In the model navigation view, right click on ClipsAndTacks MC , then select New > Trigger .  
Enter these values: 

1) Name - Ship Order to Customer Trigger 

2) ID - Ship_Order_to_Customer_Trigger 

3) Select the check box next to Terminate monitoring context 

4) For Trigger Sources, click Add, then select Other source type > Activity Event, then click 
OK. 

5) For Trigger condition, enter 
Activity_Event/extendedData/ActivityEventData/activityName='Ship Order to Customer' and 
Activity_Event/extendedData/ActivityEventData/eventType='completed' 

__ b. Press Ctrl-S  to save your work. 

__ c. Here is a sample of this trigger: 



© Copyright IBM Corporation 2007. All rights reserved 

2007 April, 27 IBM WebSphere Business Monitor 6.0.2 – Lab exercise Page 22 of 136 

 ClipsAndTacks 

 

__ d. In the model navigation view, right click on ClipsAndTacks MC, then select New > Trigger .  
Enter these values: 

1) Name - Cancel Trigger 

2) ID - Cancel_Trigger 

3) Select the check box next to Terminate monitoring context 

4) For Trigger Sources, click Add, then select Other source type > Activity Event, then click 
OK. 

5) For Trigger condition, enter 
Activity_Event/extendedData/ActivityEventData/activityName='Cancel Order and Send 
Notification' and Activity_Event/extendedData/ActivityEventData/eventType='completed' 
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__ e. Press Ctrl-S  to save your work. 

____ 7. Create a KPI for Average fulfillment 3 days or less 

__ a. In the model navigation view, right click on ClipsAndTacks MC, then select New > Trigger .  
Enter these values: 

1) Name – New Order Trigger 

2) ID – New_Order_Trigger 

3) For Trigger Sources, click Add, then select Other source type > New Order Event, then click 
OK. 

4) For Trigger condition, enter 
New_Order_Event/extendedData/ActivityEventData/activityName='Check Order Handling 
Policy for Automatic Approval' and 
New_Order_Event/extendedData/ActivityEventData/eventType='started' 

5) Press Ctrl-S  to save your work. 



© Copyright IBM Corporation 2007. All rights reserved 

2007 April, 27 IBM WebSphere Business Monitor 6.0.2 – Lab exercise Page 24 of 136 

 ClipsAndTacks 

 

 

__ b. In the model navigation view, right click on ClipsAndTacks MC, then select New > Metric .  Enter 
these values: 

1) Name – Order Start Time 

2) ID – Order_Start_Time 

3) Type - DateTime 

4) For Metric Value Maps, click Add 
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5) In the first row of the Metric Value Maps table, select the cell under column Trigger, then a 
button is shown, then click the button and select Trigger type > ClipsAndTacks MC > New 
Order Trigger, click OK 

6) In the first row of the Metric Value Maps table, select the cell under column Expression, 
then a button is shown, then click the button and enter this text:  

New_Order_Event/extendedData/ActivityEventData/startTime  

7) Click OK. 

8) Press Ctrl-S  to save your work. 

 

__ c. In the model navigation view, right click on ClipsAndTacks MC, then select New > Metric .  Enter 
these values: 

1) Name – Order End Time 

2) ID – Order_End_Time 
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3) Type - DateTime 

4) For Metric Value Maps, click Add 

5) In the first row of the Metric Value Maps table, select the cell under column Trigger, then a 
button is shown, then click the button and select Trigger type > ClipsAndTacks MC > Ship 
Order to Customer Trigger, click OK 

6) In the first row of the Metric Value Maps table, select the cell under column Expression, 
then a button is shown, then click the button and enter this text:  

Activity_Event/extendedData/ActivityEventData/endTime  

7) Click OK. 

8) For Metric Value Maps, click Add 

9) In the second row of the Metric Value Maps table, select the cell under column Trigger, then 
a button is shown, then click the button and select Trigger type > ClipsAndTacks MC > 
Cancel Trigger, click OK 

10) In the second row of the Metric Value Maps table, select the cell under column 
Expression, then a button is shown, then click the button and enter this text:  

Activity_Event/extendedData/ActivityEventData/endTime  

11) Click OK. 

__ d. Press Ctrl-S  to save your work. 
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__ e. In the model navigation view, right click on ClipsAndTacks MC, then select New > Metric .  Enter 
these values: 

1) Name – Order Fulfillment Duration 

2) ID – Order_Fulfillment_Duration 

3) Type - Duration 

4) For Default Value, click Edit… 

5) On the Select Duration dialog, click OK 

6) For Metric Value Maps, click Add 

7) In the first row of the Metric Value Maps table, select the cell under column Trigger, then a 
button is shown, then click the button and select Trigger type > ClipsAndTacks MC > Ship 
Order to Customer Trigger, click OK 
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8) In the first row of the Metric Value Maps table, select the cell under column Expression, 
then a button is shown, then click the button and enter this text:  

Order_End_Time - Order_Start_Time  

9) Click OK. 

10) For Metric Value Maps, click Add 

11) In the second row of the Metric Value Maps table, select the cell under column Trigger, 
then a button is shown, then click the button and select Trigger type > ClipsAndTacks MC 
> Cancel Trigger, click OK 

12) In the second row of the Metric Value Maps table, select the cell under column 
Expression, then a button is shown, then click the button and enter this text:  

Order_End_Time - Order_Start_Time  

13) Click OK. 

__ f. Press Ctrl-S  to save your work. 
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__ g. Click on the Data Mart Model  tab. 

__ h. Add Start Time as a dimension to the Data Mart Model.  This will be used later on when you 
create the definition of the KPI. 

1) In the Dimensions table, click on ClipsAndTacks MC Cube 

2) Click Add Dimension…  

a) Name – Start Time Dimension 

b) ID – Start_Time_Dimension 

3) Click Add Attribute…  

a) Name – Start Time 

b) ID – Start_Time 
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4) In the Dimension table, on the row containing Dimension Attribute Start Time, click on the 
cell in the column Source.  A button is displayed, then click on this button and select 
ClipsAndTacks MC > Order Start Time.  Then click OK. 

5) Press Ctrl-S  to save your work. 

 

__ i. In the Data Mart Model, add a measure for average order fulfillment. 

1) In the Measures table, click on ClipsAndTacks MC Cube 

2) Click Add Measure…  

a) Name – Average Order Fulfillment 

b) ID – Average_Order_Fulfillment 

3) In the Measures table, on the row containing measure Average Order Fulfillment, click on 
the cell in the column Source.  A button is displayed, then click on this button and select 
ClipsAndTacks MC Fact Table> Order Fulfillment Duration Fact.  Then click OK. 

4) Notice that the Aggregation Function for this measure defaults to Average, which is what 
you want. 

5) Press Ctrl-S  to save your work. 
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__ j. Ensure that the KPI Model tab  is selected. 

__ k. Create a KPI context to store your KPIs. 

1) In the navigation view of the KPI Model, right click on ClipsAndTacks, then select New > 
KPI Context  

a) Name – My KPI Context 

b) ID -  My_KPI_Context 
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__ l. Create the average order fulfillment KPI.   

Note that you will create the KPI based on events for August 2006.  This will work for you no matter what 
month or year that you run this lab because the timestamps in the test data are based on August 2006, so 
your results will be the same as in these lab instructions. 

1) Click the KPI Model tab . 

2) In the navigation view of the KPI Model, right click on My KPI Context, then select New > 
KPI 

a) Name – Average Order Fulfillment KPI August 2006 

b) ID -  Average_Order_Fulfillment_KPI_August_2006 

3) Enter these values: 

a) Type – Duration 

b) In KPI Target and Ranges, for Target click Details…, then change the value to 3 
Days, then click OK 

c) In KPI Target and Ranges, for Ranges select Actual values 

d) In the Range table,  

(1) Click Add 

(2) Change the Name to Day 1, and the ID to Day_1 
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(3) A row is created in the Range table with a range name Day 1.   

(4) For this row, select the cell in the Start value column and a button is 
displayed.  Click this button, then change all values to 0, then click OK. 

(5) For this row, select the cell in the End value column and a button is 
displayed.  Click this button, then change Days to 1 and the other values 
to 0, then click OK. 

e) Now you have created one range called Day 1.  Repeat the above step to create 
four more ranges: 

(1) Day 2 with start values 1 Days and end value 2 Days 

(2) Day 3 with start values 2 Days and end value 3 Days 

(3) Day 4 with start values 3 Days and end value 4 Days 

(4) Day 5 with start values 4 Days and end value 5 Days 

f) Cube – click Browse…, then select ClipsAndTacks DMM > ClipsAndTacks MC 
Cube, then click OK 

g) Measure – click Browse…, then select ClipsAndTacks MC Cube > Average Order 
Fulfillment, then click OK 

h) Time dimension – click Browse…, then select Referenced Dimension > Start Time 
Dimension, then click OK 

i) Specify time period – Fixed 

j) Start date – click Edit... then select 2006-08-01 

k) End date – click Edit…, then select 2006-08-31 

Note that the Start Time Dimension is based on the startTime from the common base event. 

4) Press Ctrl-S  to save your work. 
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__ m. Note that this KPI as it stands averages order fulfillment time for shipped orders and cancelled 
orders, but you are not interested in the cancelled orders.  So update the average order 
fulfillment KPI to show the values for shipped orders only. 

__ n. Click the Monitor Details Model tab . 

__ o. In the Monitor Details Model navigation view, right click on ClipsAndTacks MC, then select New 
> Metric .  Enter these values: 

1) Name – Order Status 
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2) ID – Order_Status 

3) Type – String 

4) Default Value (enter this text with single quotes) – ‘New’ 

5) For Metric Value Maps, click Add 

6) In the first row of the Metric Value Maps table, select the cell under column Trigger, then a 
button is shown, then click the button and select Trigger type > ClipsAndTacks MC > 
Cancel Trigger, click OK 

7) In the first row of the Metric Value Maps table, select the cell under column Expression, 
then a button is shown, then click the button and enter this text with the quotes: 

‘Cancelled’ 

8) Click OK. 

9) For Metric Value Maps, click Add 

10) In the second row of the Metric Value Maps table, select the cell under column Trigger, 
then a button is shown, then click the button and select Trigger type > ClipsAndTacks MC 
> Ship Order to Customer Trigger, click OK 

11) In the second row of the Metric Value Maps table, select the cell under column 
Expression, then a button is shown, then click the button and enter this text with single 
quotes: 

‘Shipped’ 

12) Press Ctrl-S  to save your work 
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__ p. Click on the Data Mart Model tab . 

__ q. Add order status as a dimension to the Data Mart Model.   

1) In the Dimension table, click on ClipsAndTacks MC Cube 

2) Click Add Dimension…  

a) Name – Order Status Dimension 

b) ID – Order_Status_Dimension 

c) Click OK 

3) Click Add Attribute…  

a) Name – Order Status 
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b) ID – Order_Status 

4) In the Dimension table, on the row containing Dimension Attribute Order Status, click on the 
cell in the column Source.  A button is displayed, then click on this button and select 
ClipsAndTacks MC > Order Status.  Then click OK. 

5) Press Ctrl-S  to save your work. 

 

__ r. Update the order fulfillment KPI to use the order status dimension as a filter. 

1) Click the KPI Model tab . 

2) In the KPI Model navigation view, navigate to ClipsAndTacks > My KPI Context > Average 
Order Fulfillment KPI August 2006 

3) In the KPI Definition section for this KPI, underneath the Dimensions table click Add 

4) In the dialog, navigate to ClipsAndTacks MC Cube > Order Status Dimension > Order 
Status, then click OK 

5) In the Dimensions table, expand Order Status Dimension. 

6) In the row containing Attribute Order Status, click the cell in the column Value, then enter 
this text (without quotes): 

Shipped 

7) Press Ctrl-S  to save your work. 
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____ 8. Create a KPI for number of approved orders greater than 90%.  For KPIs, you cannot have user 
defined functions, for example, ‘(Shipped Orders / Total Orders) * 100’, so you have to do it another 
way. You will create a metric that will have one of two values for each monitoring context.  For 
shipped orders it will be 100, for cancels it will be 0.  Then you will just average this metric across 
monitoring contexts.  Note that you will set the value of the metric explicitly to 100 when you ship the 
order, but you do not have to set it explicitly when you cancel an order because you will set the 
default for the metric to 0. 

__ a. Click the Monitor Details Model tab . 

__ b. In the Monitor Details Model navigation view, right click on ClipsAndTacks MC, then select New 
> Metric .  Enter these values: 

1) Name – Ship Percentage 

2) ID – Ship_Percentage 

3) Type – Integer 

4) Default value - 0 

5) For Metric Value Maps, click Add 

6) In the first row of the Metric Value Maps table, select the cell under column Trigger, then a 
button is shown, then click the button and select Trigger type > ClipsAndTacks MC > Ship 
Order to Customer Trigger, click OK 
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7) In the first row of the Metric Value Maps table, select the cell under column Expression, 
then a button is shown, then click the button and enter this text: 

a) 100 

8) Click OK. 

9) Press Ctrl-S  to save your work 

 

__ c. Click the Data Mart Model tab . 

__ d. In the Data Mart Model, add a measure for average ship percentage. 

1) In the Measures table, click on ClipsAndTacks MC Cube 

2) Click Add Measure…  

a) Name – Average Ship Percentage 
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b) ID – Average_Ship_Percentage 

3) In the Measures table, on the row containing measure Average Ship Percentage, click on 
the cell in the column Source.  A button is displayed, then click on this button and select 
ClipsAndTacks MC Fact Table> Ship Percentage Fact.  Then click OK. 

4) Notice that the Aggregation Function for this measure defaults to Average, which is what 
you want. 

5) Press Ctrl-S  to save your work. 

 

__ e. Click the KPI Model tab . 

__ f. In the navigation view of the KPI Model, right click on My KPI Context, then select New > KPI 

1) Name – Percent of Orders Approved KPI 

2) ID -  Percent_of_Orders_Approved_KPI 

__ g. Enter these values: 

1) Type – Decimal 

2) Target – 90 

3) Ranges – Actual value 

4) In the Range table 

a) Click Add 

b) Change the Name to ‘High Range’, and the ID to High_Range 

c) A row is created in the Range table with a range name High Range.   

d) For this row, select the cell in the Start value column and a button is displayed.  
Click this button, then change the value to 90, and then click OK. 
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e) For this row, select the cell in the End value column and a button is displayed.  
Click this button, then change the value to 100, and then click OK. 

5) Now you have created one range called High Range.  Repeat the above step to create 
another range: 

a) Low Range with start value 0 and end value 90 

6) Cube – click Browse…, then select ClipsAndTacks DMM > ClipsAndTacks MC Cube, then 
click OK 

7) Measure – click Browse…, then select ClipsAndTacks MC Cube > Average Ship 
Percentage, then click OK 

8) Time dimension – you could select a time dimension if you like to base the KPI on a specific 
period of time. 

Note that the Start Time Dimension is based on the startTime from the common base event.  If you want to 
add a time dimension, then you should check the values of startTime in the common base events to 
determine what range is appropriate for your testing. 

9) Press Ctrl-S  to save your work. 
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____ 9. You might like to see the total order price, the average order price and the total number of orders.  
And you might be interested in seeing this information by country and city.  So now you will create 
dimensions and measures that allow you to see this information.  In order to see the country and 
city information, you will create a multi-level location dimension containing country as the first level 
and city as the second level. 

__ a. Click the Monitor Details Model tab . 

__ b. In the Monitor Details Model navigation view, right click on ClipsAndTacks MC, then select New 
> Metric .  Enter these values: 

1) Name – country 

2) ID – country 
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3) Type –  String 

4) For Metric Value Maps, click Add 

5) In the first row of the Metric Value Maps table, select the cell under column Trigger, then a 
button is shown, then click the button and select Trigger type > ClipsAndTacks MC > New 
Order Trigger, click OK 

6) In the first row of the Metric Value Maps table, select the cell under column Expression, 
then a button is shown, then click the button and enter this text: 

a) New_Order_Event/extendedData/OrderBOData/country 

7) Click OK. 

8) Press Ctrl-S  to save your work 
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__ c. In the Monitor Details Model navigation view, right click on ClipsAndTacks MC, then select New 
> Metric .  Enter these values: 

1) Name – city 

2) ID – city 

3) Type –  String 

4) For Metric Value Maps, click Add 

5) In the first row of the Metric Value Maps table, select the cell under column Trigger, then a 
button is shown, then click the button and select Trigger type > ClipsAndTacks MC > New 
Order Trigger, click OK 

6) In the first row of the Metric Value Maps table, select the cell under column Expression, 
then a button is shown, then click the button and enter this text: 

a) New_Order_Event/extendedData/OrderBOData/city 

7) Click OK. 

8) Press Ctrl-S  to save your work 
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__ d. In the Monitor Details Model navigation view, right click on ClipsAndTacks MC, then select New 
> Metric .  Enter these values: 

1) Name – totalPrice 

2) ID – totalPrice 

3) Type –  Decimal 

4) For Metric Value Maps, click Add 

5) In the first row of the Metric Value Maps table, select the cell under column Trigger, then a 
button is shown, then click the button and select Trigger type > ClipsAndTacks MC > New 
Order Trigger, click OK 

6) In the first row of the Metric Value Maps table, select the cell under column Expression, 
then a button is shown, then click the button and enter this text: 
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a) New_Order_Event/extendedData/OrderBOData/totalPrice 

7) Click OK. 

8) Press Ctrl-S  to save your work 

 

__ e. Click on the Data Mart Model tab . 

__ f. Add location as a dimension to the Data Mart Model.   

1) In the Dimension table, click on ClipsAndTacks MC Cube 

2) Click Add Dimension…  

a) Name – Location 

b) ID – Location 

3) Click Add Attribute…  
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a) Name – Country 

b) ID – Country 

4) In the Dimension table, on the row containing Dimension Attribute Country, click on the cell 
in the column Source.  A button is displayed, then click on this button and select 
ClipsAndTacks MC > country.  Then click OK. 

5) Click Add Attribute…  

a) Name – City 

b) ID – City 

6) In the Dimension table, on the row containing Dimension Attribute City, click on the cell in 
the column Source.  A button is displayed, then click on this button and select 
ClipsAndTacks MC > city.  Then click OK. 

7) Press Ctrl-S  to save your work. 

 

__ g. Ensure that the Data Mart Model tab  is selected. 

__ h. In the Data Mart Model, add a measure for average order price. 

1) In the Measures table, click on ClipsAndTacks MC Cube 

2) Click Add Measure…  

a) Name – Average Order Price 

b) ID – Average_Order_Price 
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3) In the Measures table, on the row containing measure Average Order Price, click on the cell 
in the column Source.  A button is displayed, then click on this button and select 
ClipsAndTacks MC Fact Table> totalPrice Fact.  Then click OK. 

4) Notice that the Aggregation Function for this measure defaults to Average, which is what 
you want.  

__ i. In the Data Mart Model, add a measure for sum of order price. 

1) In the Measures table, click on ClipsAndTacks MC Cube 

2) Click Add Measure…  

a) Name – Sum Order Price 

b) ID – Sum_Order_Price 

3) In the Measures table, on the row containing measure Sum Order Price, click on the cell in 
the column Source.  A button is displayed, then click on this button and select 
ClipsAndTacks MC Fact Table> totalPrice Fact.  Then click OK. 

4) In the Measures table, on the row containing measure Sum Order Price, click on the cell in 
the column Aggregation Function.  Select Sum in the list. 

__ j. In the Data Mart Model, add a measure for order count. 

1) In the Measures table, click on ClipsAndTacks MC Cube 

2) Click Add Measure…  

a) Name – Order Count 

b) ID – Order_Count 

3) In the Measures table, on the row containing measure Order Count, click on the cell in the 
column Source.  A button is displayed, then click on this button and select ClipsAndTacks 
MC Fact Table> ClipsAndTacks Key Fact.  Then click OK. 

4) In the Measures table, on the row containing measure Order Count, click on the cell in the 
column Aggregation Function. Select Count in the list. 

__ k. Press Ctrl-S  to save your work. 
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____ 10. Now that you have Average Order Price as a measure in the Data Mart Model, you can also create 
a KPI for it. 

__ a. Click the KPI Model tab . 

__ b. In the navigation view of the KPI Model, right click on My KPI Context, then select New > KPI 

1) Name – Average Order Price KPI (Dollars) 

2) ID -  Average_Order_Price_KPI__x0028_Dollars_x0029_ 

__ c. Enter these values: 

1) Type – Decimal 

2) Target – 300 

3) Ranges – Actual value 

4) In the Range table 

a) Click Add 

b) Change the Name to ‘High Range’, and the ID to High_Range 

c) A row is created in the Range table with a range name High Range.   

d) For this row, select the cell in the Start value column and a button is displayed.  
Click this button, then change the value to 300, and then click OK. 

e) For this row, select the cell in the End value column and a button is displayed.  
Click this button, then change the value to 1000, and then click OK. 

5) Now you have created one range called High Range.  Repeat the above step to create 
another range: 

a) Low Range with start value 0 and end value 300 
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6) Cube – click Browse…, then select ClipsAndTacks DMM > ClipsAndTacks MC Cube, then 
click OK 

7) Measure – click Browse…, then select ClipsAndTacks MC Cube > Average Order Price, 
then click OK 

8) Time dimension – you could select a time dimension if you like to base the KPI on a specific 
period of time. 

Note that the Start Time Dimension is based on the startTime from the common base event.  If you want to 
add a time dimension, then you should check the value of startTime in the common base events to 
determine what range is appropriate for your testing. 

9) Press Ctrl-S  to save your work. 
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(Optional)  To demonstrate the use of a counter, you can optionally use this section to create a counter 
which will be incremented if you ship the order (versus canceling the order).  For every monitoring context, 
this counter will either be zero or one depending on whether the order is cancelled or shipped.  Counters 
would be more useful in other scenarios – perhaps to count the number of times an iterated activity is run.  
This optional section shows a common technique for counting a subset of instances. 

____ 11. (Optional) In the Monitor Details Model navigation view, right click on ClipsAndTacks MC, then 
select New > Counter .  Enter these values: 

__ a. Name – Ship Counter 

__ b. ID – Ship_Counter 
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__ c. For Counter Controls, click Add, then select ClipsAndTacks MC > Ship Order to Customer 
Trigger, click OK 

__ d. Note that the Resulting Action defaults to Add One, which is correct. 

__ e. Click OK.  

__ f. Press Ctrl-S  to save your work 

 

(Optional)  To demonstrate the use of a stopwatch, you can optionally use this section to create a timer 
which will measure the duration of the monitoring context.  You might find this useful to quickly see which 
monitoring contexts have not been terminated.  

____ 12. (Optional) In the model navigation view, right click on ClipsAndTacks MC, then select New > 
Stopwatch .  Enter these values: 

__ a. Name – Monitoring Context Timer 

__ b. ID – Monitoring_Context_Timer 

__ c. For Stopwatch Controls, click Add, then select ClipsAndTacks MC > New Order Trigger,  then 
click OK. 

__ d. Note that the default Resulting Action is Start 
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__ e. For Stopwatch Controls, click Add, then select ClipsAndTacks MC > Ship Order to Customer 
Trigger,  then click OK. 

__ f. Note that the default Resulting Action is Start, but you need to change it to Stop for this trigger.  
So click on the second row in column Resulting Action.  A drop down box is shown, so pick Stop 
in the list. 

__ g. For Stopwatch Controls, click Add, then select ClipsAndTacks MC > Cancel Trigger,  then click 
OK. 

__ h. Note that the default Resulting Action is Start, but you need to change it to Stop for this trigger.  
So click on the second row in column Resulting Action.  A drop down box is shown, so pick Stop 
in the list. 

__ i. Press Ctrl-S  to save your work.  

 

____ 13. Create a business situation event when the number of declined orders is greater than or equal to 3. 

__ a. In Project Explorer, right click on ClipsAndTacks and select New > Event Definition…  

__ b. For name, enter DeclinedOrderEvent 

__ c. Click Finish 
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__ d. On the event definition, click the icon for Add Extended Data.  This adds a row to the Extended 
Data table. 

__ e. For the new data element, change the Extended Data name to BusinessSituationName 

__ f. For the new element, change the type to string. 

__ g. Press Ctrl-S  to save your work. 

 

__ h. Click the KPI Model tab  for the ClipsAndTacks model. 

__ i. In the navigation view of the KPI Model, right click on My KPI Context, then select New > KPI 

1) Name – Declined Order KPI 

2) ID -  Declined_Order_KPI 

__ j. Enter these values: 

1) Type – Decimal 

2) Target – 3 

3) Ranges – Actual value 

4) In the Range table 

a) Click Add 

b) Change the Name to High Range, and the ID to High_Range 

c) A row is created in the Range table with a range name High Range.   
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d) For this row, select the cell in the Start value column and a button is displayed.  
Click this button, then change the value to 3, and then click OK. 

e) For this row, select the cell in the End value column and a button is displayed.  
Click this button, then change the value to 10, and then click OK. 

5) Now you have created one range called High Range.  Repeat the above step to create 
another range: 

a) Low Range with start value 0 and end value 3 

6) Cube – click Browse…, then select ClipsAndTacks DMM > ClipsAndTacks MC Cube, then 
click OK 

7) Measure – click Browse…, then select ClipsAndTacks MC Cube > Order Count, then click 
OK 

8) Time dimension – you could select a time dimension if you like to base the KPI on a specific 
period of time. 

Note that the Start Time Dimension is based on the startTime from the common base event.  If you want to 
add a time dimension, then you should check the value of startTime in the common base events to 
determine what range is appropriate for your testing. 

9) In the Dimensions table click Add 

10) In the dialog, navigate to ClipsAndTacks MC Cube > Order Status Dimension > Order 
Status, then click OK 

11) In the Dimensions table, expand Order Status Dimension. 

12) In the row containing Attribute Order Status, click the cell in the column Value, then enter 
this text (without quotes): 

Cancelled 

13) Press Ctrl-S  to save your work. 
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__ k. In the navigation view of the KPI Model, right click on My KPI Context, then select New > Trigger   

1) Name – Declined Order Trigger 

2) ID -  Declined_Order_Trigger 

__ l. Enter these values: 

1) Under Trigger Sources, click Add. 
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2) Select Recurring wait time, then click OK 

3) In the Source column you see the default wait time is 1 minute.  

4) In Trigger Condition, enter this text: 

Declined_Order_KPI >= 3 

__ m. Press Ctrl-S  to save your work. 

 

__ n. In the navigation view of the KPI Model, right click on My KPI Context, then select New > 
Outbound Event  

1) Name – Declined Order Outbound Event 

2) ID -  Declined_Order_Outbound_Event 



© Copyright IBM Corporation 2007. All rights reserved 

2007 April, 27 IBM WebSphere Business Monitor 6.0.2 – Lab exercise Page 58 of 136 

 ClipsAndTacks 

__ o. Enter these values: 

1) Type: DeclinedOrderEvent 

2) Under Event Attributes Details, click Add 

3) Select My KPI Context > Declined Order Trigger, then click OK 

4) In the table, on the same row as BusinessSituationName, set Expression to (include the 
quotes): 

'Too many orders have been declined' 

__ p. Press Ctrl-S  to save your work. 

 

____ 14. Create a business situation event when the order fulfillment duration is greater than 3 days. 
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__ a. In Project Explorer, right click New > Event Definition…  

__ b. For name, enter LateAverageOrderShippedEvent 

__ c. Click Finish 

__ d. On the event definition, click the icon for Add Extended Data.  This adds a row to the Extended 
Data table. 

__ e. For the new data element, change the Extended Data name to BusinessSituationName 

__ f. For the new element, change the type to string. 

__ g. On the event definition, click the icon for Add Extended Data.  This adds a second row to the 
Extended Data table. 

__ h. For the second data element, change the Extended Data name to AverageOrderProcessingDays 

__ i. For the second element, change the type to string. 

__ j. Press Ctrl-S  to save your work. 

 

 

__ k. In the navigation view of the KPI Model, right click on My KPI Context, then select New > Trigger   

1) Name – Order Fulfillment Timer Trigger 

2) ID -  Order_Fulfillment_Timer_Trigger 

__ l. Enter these values: 
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1) Under Trigger Sources, click Add. 

2) Select Recurring wait time, then click OK 

3) In the Source column you see the default wait time is 1 minute.  

4) In Trigger Condition, enter this text: 

Average_Order_Fulfillment_KPI_August_2006 ge duration('P3DT1H') 

__ m. Press Ctrl-S  to save your work. 

 

__ n. In the navigation view of the KPI Model, right click on My KPI Context, then select New > 
Outbound Event  

1) Name – Order Fulfillment Outbound Event 

2) ID -  Order_Fulfillment_Outbound_Event 
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__ o. Enter these values: 

1) Type: LateAverageOrderShippedEvent 

2) Under Event Attributes Details, click Add 

3) Select My KPI Context > Order Fulfillment Timer Trigger, then click OK 

4) In the table, on the same row as BusinessSituationName, set Expression to (include the 
single quotes): 

'Average shipment is too late'  

5) In the table, on the same row as AverageOrderProcessingDays, set Expression to: 

string(decimal(Average_Order_Fulfillment_KPI_August_2006) div 86400) 

Note: Here the decimal function converts the duration to seconds, so then it can be divided by 86400 
which will give you the number of days. 

__ p. Press Ctrl-S  to save your work. 
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____ 15. Check for any errors in the Problems view.  You should resolve any errors before continuing. 
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Part 2: Generate the EAR for the monitoring model 

 

In this section you will use WebSphere Integration Developer to create the EAR which will be deployed to 
the Monitor server. 

____ 1. In Project Explorer, right click ClipsAndTacks > Monitoring Models > ClipsAndTacks, then select 
Generate Monitor EAR 

____ 2. Select Overwrite existing projects, then select Finish 

____ 3. A progress dialog shows the status of the operation and it closes when the operation is complete: 

 

____ 4. Select Window > Open Perspective > Other…, then select J2EE 

____ 5. In Project Explorer, right click EJB Projects > ClipsAndTacksEJB , then select Build Project  (If 
Project > Build Automatically  is selected, then Build Project is not shown in the context menu nor 
enabled in the Project  menu. In this case, the project has already been built.) 

____ 6. A progress dialog shows the status of the operation and it closes when the operation is complete: 

 

____ 7. Check for errors in the Problems view.  There may be warnings, but there should not be any errors: 



© Copyright IBM Corporation 2007. All rights reserved 

2007 April, 27 IBM WebSphere Business Monitor 6.0.2 – Lab exercise Page 64 of 136 

 ClipsAndTacks 

 

____ 8. In Project Explorer, right click EJB Projects > ClipsAndTacksEJB , then select Deploy  

____ 9. A progress dialog shows the status of the operation and it closes when the operation is complete: 

 

____ 10. In Project Explorer, right click Enterprise Applications > ClipsAndTacksEAR , then select 
Export… > EAR file  

____ 11. Enter a destination folder, and then click Finish.  ClipsAndTacksEAR.ear will be created in this 
folder. 
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Part 3: Deploy the monitoring model 

In this section you will use the WebSphere Process Server administrative console to run the life cycle 
steps to deploy the monitoring model. 

____ 1. Start the Monitor server and bring up the administrative console 

__ a. In Windows, select Start > All Programs > IBM WebSphere > Process Serv er 6.0 > Profiles > 
wbmonitor > Start the server  

__ b. In Windows, select Start > All Programs > IBM WebSphere > Process Serv er 6.0 > Profiles > 
wbmonitor > Administrative console  

____ 2. Install the monitor model 

__ a. In the administrative console menu, select Applications > Monitor Models  

 

__ b. Click Install  
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__ c. Browse to ClipsAndTacksEAR.ear .  This is the EAR file that you created in WebSphere 
Integration Developer.   

__ d. Click Next  
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__ e. Click Next  
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__ f. Click Continue  
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__ g. Take the defaults for the installation, so just click Step 11  
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__ h. Click Finish  
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__ i. Click Save to Master Configuration , then click Save 

____ 3. Run Step 1 of the model life cycle 

__ a. In the administrative console menu, select Applications > Monitor Models  
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__ b. Click the timestamp  that is listed in the Version column 
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__ c. Click Setup Wizard  
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__ d. Enter the output directory, such as C:\ClipsAndTacks .  The result of running the data services 
generation is a folder called schemagen which will be created in the specified output directory. 

__ e. Change the Database population interval to 2.  For development purposes you want replication 
to run often so that you don’t have to wait to see the updates in the DATAMART database.  Note 
that this interval number represents minutes. 

__ f. Click Run  
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__ g. Click Next  

__ h. Here you see a panel indicating the commands used to run the schema scripts. 
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____ 4. Run Step 2 and Step 3 of the model life cycle. 

__ a. In Windows File Explorer, browse to C:\ClipsAndTacks\schemagen\<timestamp>  
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__ b. Extract DS_DMS_setup.zip  into this same folder 
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__ c. Create the tables for the monitoring model.  In the DB2 command window, enter the following 
commands.  Note that monitor and state are used interchangeably.  The database is defined as 
MONITOR, but you will see references to state such as state.ddl, state.log, 
state_to_datamart_setup_source.bat, and so on. 

1) Open a DB2 command window  

a) Select Start > Run…  

b) Enter this command: db2cmd 

2) Enter these commands into the DB2 command window: 

a) cd \ClipsAndTacks\schemagen\<timestamp> 

b) db2 connect to MONITOR 

c) db2 +c –stvf state.ddl > state.log 

3) Open a second DB2 command window  

a) Select Start > Run…  
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b) Enter this command: db2cmd 

4) Enter these commands into the second DB2 command window: 

a) cd \ClipsAndTacks\schemagen\<timestamp> 

b) db2 connect to DATAMART 

c) db2 +c –stvf datamart.ddl > datamart.log 

5) If the all the commands succeeded,  

a) Enter these commands into the first DB2 command window: 

(1) db2 commit 

(2) db2 disconnect MONITOR 

b) Enter these commands into the second DB2 command window: 

(1) db2 commit 

(2) db2 disconnect DATAMART 

6) If any of the commands failed,  

a) Enter these commands into the first DB2 command window: 

(1) db2 rollback 

(2) db2 disconnect MONITOR 

b) Enter these commands into the second DB2 command window: 

(1) db2 rollback 

(2) db2 disconnect DATAMART 

7) Close the second DB2 command window 

__ d. This will create state.log  and datamart.log .  You should browse these files to verify that they 
worked successfully. 

__ e. Run the replication setup scripts. 

1) In the same DB2 command window, you should still be in folder 
\ClipsAndTacks\schemagen\<timestamp>, so type this command 

State_to_Datamart_setup_source.bat 

2) It will ask for a user ID several times.  Click the enter key when it asks for a user ID. 

3) This will create a file State_to_datamart_setup_source.log .  Browse this file to check for 
errors. 

4) In the same DB2 command window, you should still be in folder 
\ClipsAndTacks\schemagen\<timestamp>, so type this command 

State_to_Datamart_setup_target.bat 
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5) It will ask for a user ID several times.  Click the enter key when it asks for a user ID. 

6) This will create a file State_to_datamart_setup_target.log .  Browse this file to check for 
errors. 

__ f. Start the replication daemons. 

1) In the same DB2 command window, you should still be in folder 
\ClipsAndTacks\schemagen\<timestamp>, so type this command 

a) cd State_to_Datamart\source 

2) Find all scripts with prefix ‘StartCapture’, and run them.  For this scenario there will be one.  
For example type command 

a) StartCapture_5.bat 

3) This opens a new window as follows.  You must leave this window running.  Do not type 
anything into this window. 

 

4) Type this command 

a) cd ..\target 

5) Find all scripts with prefix ‘StartApply’, and run them.  For this scenario there will be one.  
For example type command 

a) StartApply_10.bat 

6) This opens a new window as follows.  You must leave this window running.  Do not type 
anything into this window. 
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__ g. You should now have three command windows open.  You can close the original DB2 command 
window where you have been typing the commands. 

__ h. In the administrative console menu, select Applications > Monitor Models  

__ i. Click the timestamp  in the version column 

__ j. Click Setup Wizard  

__ k. It should detect that Step 2 is complete and automatically move to step 3 as follows 
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__ l. Click Confirm  

____ 5. Run Step 4 of the model life cycle 

__ a. Click Step 4  



© Copyright IBM Corporation 2007. All rights reserved 

2007 April, 27 IBM WebSphere Business Monitor 6.0.2 – Lab exercise Page 83 of 136 

 ClipsAndTacks 

 

__ b. Import the cubes to DB2 Cube Views. 

1) Open a DB2 command window  

a) Select Start > Run…  

b) Enter this command: db2cmd 

2) Enter these commands in the DB2 command window: 

a) cd \IBM\DB2\SQLLIB\MISC 

b) db2 connect to DATAMART 

c) db2 –tvf db2mdapi.sql 

d) db2 disconnect DATAMART 

e) cd \ClipsAndTacks\schemagen\<timestamp> 
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f) db2mdapiclient -d DATAMART -i import_model.xml -o response_model_cv.xml -m 
model_cv.xml 

3) Close the command window 

__ c. Back in the administrative console you should be in Step 4 of the Life cycle of the model. 

__ d. Click Confirm  

____ 6. Run step 5 of the model life cycle 

__ a. Click Step 5  

 

__ b. Start Portal Server 

1) In Windows, select Start > All Programs > IBM WebSphere > Portal Serve r V5.1 > Start 
the server  
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__ c. Find the Portal RMI port in the Portal log 

1) Browse the Portal log, for example, C:\IBM\PortalServer\log\SystemOut.log 

2) Search for ‘RMI Connector’, for example, in the following screen capture you see that Portal 
RMI is port 2810. 

 

__ d. Back in the administrative console, in Step 5 of the model Life cycle, enter ‘localhost’ for Host 
name 

__ e. Enter your RMI Port that you found in the Portal log, for example: 
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__ f. Click Create  

If you get an error here, indicating a connection problem, there may be an issue with the Portal 
configuration.  Refer to Appendix 2 now and run the steps there as a workaround for this problem.  After 
completing the workaround, return here and proceed with the next step.  Here is a sample of the error:  
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____ 7. Run step 6 of the model life cycle 

__ a. Click Step 6  
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__ b. Click Apply  

____ 8. Run step 7 of the model life cycle 

__ a. Click Step 7  

__ b. The Confirm button on the screen for Step 7 should be enabled.  If it is not, wait a few minutes, 
then refresh the screen.  When the Confirm button is enabled, continue with the following steps. 

__ c. In the administrative console navigation pane, select System administration > Save Changes 
to Master Repository , then click Save 

__ d. Recycle the Process Server 

1) In Windows, select Start > All Programs > IBM WebSphere > Process Serv er 6.0 > 
Profiles > wbmonitor > Stop the server  

2) In Windows, select Start > All Programs > IBM WebSphere > Process Serv er 6.0 > 
Profiles > wbmonitor > Start the server  
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__ e. Re-open the administrative console for Process Server. 

__ f. In the administrative console menu, click Applications > Monitor Models  

__ g. Click the timestamp  in the version column 

__ h. Click Setup Wizard  

__ i. It should detect that Step 6 is complete and automatically move to step 7 as follows 

 

__ j. Click Confirm  

__ k. Click Finish  and you will return to the Monitor Models screen. 
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____ 9. If the model shows red (stopped), then wait a moment, then refresh by clicking on the icon to the 
right of Status in the last column of the table. You should see green (started) for the model.  If it 
does not show green, be patient and keep refreshing until it does show green. 

 

____ 10. Check the Process Server log to ensure there are no problems. For example, check 
C:\IBM\WebSphere\ProcServer\profiles\wbmonitor\logs\server1\SystemOut.log 
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Part 4: Configure the action manager for business s ituation events 

If you have an LDAP server, then this section shows you how to configure the action manager to create 
alerts based on business situation events defined in the monitoring model.  The alerts will be visible in the 
Alert view on your dashboard. 

If you do not have an LDAP server, then you can skip this section.  The outgoing events will be created for 
the business situations, but they will not result in entries in the Alert view on your dashboard. 

____ 1. Configure the LDAP Server in the action manager. 

__ a. In the Monitor administrative console, navigate to Applications > Monitor Action Manager > 
Configuration.  

__ b. Click tab LDAP.  

__ c. Add your LDAP information as in this sample: 
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__ d. You are going to setup an Alert in this lab, so make sure the LDAP Alert field is set to the 
identifier for the user ID that you want to use from your directory server.  You also need a user 
defined in Portal on the Dashboard Server which matches this user ID.  For this example, uid = 
wpsadmin   has been defined in the directory server, then you will login to Portal with this same 
user ID to see the alerts.  Click OK. 

__ e. Here is a sample of your user in the directory server: 
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____ 2. Restart the Action Manager application for the configuration changes to take effect. 

__ a. In the administrative console, navigate to Applications > Enterprise Applications .  

__ b. Click to check IBM WB ACTIONMANAGER . Click Stop.  

__ c. Click to check IBM WB ACTIONMANAGER . Click Start.  

____ 3. Add a template for declined order alerts. 

__ a. In the administrative console, navigate to Applications > Monitor Action Manager > Template 
Definitions > Notifications.   

__ b. Click New. 

__ c. Enter a name for the template and a description. 

__ d. Select Alert.  

__ e. Enter an LDAP Query that will bring up the user that you want to alert.  This query can match 
one or more users, and then each of the users will be alerted.  To bring up all the users in the 
directory, you could enter this:  (&(objectclass=top)(objectClass=inetOrgPerson)). 

__ f. Enter a subject. 

__ g. Enter the body. 
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__ h. Click OK. 

____ 4. Add a template for order processing time alerts. 

__ a. In the administrative console, navigate to Applications > Monitor Action Manager > Template 
Definitions > Notifications.   

__ b. Click New. 

__ c. Enter a name for the template and a description. 

__ d. Select Alert.  

__ e. Enter an LDAP Query that will bring up the user that you want to alert.  This query can match 
one or more users, and then each of the users will be alerted.  To bring up all the users in the 
directory, you could enter this:  (&(objectclass=top)(objectClass=inetOrgPerson)). 

__ f. Enter a subject. 
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__ g. Enter the body, and you can optionally enter a substitution variable as shown above.  For the 
actual alert that is sent, the average order processing time from the event payload will be 
substituted for %AverageOrderProcessingDays% in the body. 

 

__ h. Click OK. 

____ 5. Add the binding from the situation event to the action type for declined orders. 

__ a. In the administrative console, navigate to Applications > Monitor Action Manager > Installed 
Situation Event Bindings.  

__ b. Click New. 

__ c. Enter the situation event name that you defined in the model.  In this lab, there is a business 
situation named Too many orders have been declined .   
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__ d. This must match exactly the value in the BusinessSituationName field in the outbound event.  
You may want to copy/paste from the model.  Here is a screen capture from the model showing 
the Declined Order Outbound Event: 
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__ e. Enter a description, then click Apply . 

__ f. Click Add . 

__ g. Select the template AlertDeclined.  
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__ h. Click OK. 

__ i. Notice that you now have one action defined for this situation event.  If you had other action 
templates defined then you could add more actions to this event.  So then you could send a 
notification for this situation to multiple destinations including e-mail, alerts and Web services. 
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____ 6. Add the binding from the situation event to the action type for order processing time. 

__ a. In the administrative console, navigate to Applications > Monitor Action Manager > Installed 
Situation Event Bindings.  

__ b. Click New. 

__ c. Enter the situation event name that you defined in the model.  In this lab, you created a business 
situation name Average shipment is too late .  This must match exactly the value in the 
BusinessSituationName field in the outbound event.  You may want to copy/paste from the 
model.  Here is a screen capture from the model showing the Order Fulfillment Outbound Event: 
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__ d. Enter a description, then click Apply . 

__ e. Click Add . 

__ f. Select the template AlertLate , then click OK. 

____ 7. In the administrative console, navigate to Applications > Monitor Action Manager > Installed 
Situation Event Bindings.  You should see two bindings as follows: 
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____ 8. Make sure that your LDAP Server is started before continuing. 
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Part 5: Run events to exercise the model 

 

Rather than installing a J2EE application to actually create the events that you would like to monitor, you are 
going to use a program to simulate the submission of events from the application.   

The supplied program is ‘BatchCBEWriter’ and it will submit the events to the Common Event Infrastructure.  
Look for the program in \Labfiles602\ClipsAndTacks\BatchCBEWriter.  This program reads XML files which 
represent the common base events for the model.   

____ 1. Update BatchCBEWriter.bat to point PROCSERV_HOME to the Process Server home, for example 
‘set PROCSERV_HOME=C:\IBM\WebSphere\ProcServer’ 

____ 2. Update config.properties, setting the serverName and portNumber.  You can find the port number 
by browsing the Process Server log and finding ‘bootstrap port’.  For example,  check for the log at 
C:\IBM\WebSphere\ProcServer\profiles\wbmonitor\logs\server1\SystemOut.log . Here is an example 
of the config.properties settings: 

__ a. connect.serverName = localhost 

__ b. connect.portNumber = 2811 

____ 3. Open a command window, then change directory to the folder containing BatchCBEWriter, for 
example, type this command 

__ a. cd \Labfiles602\ClipsAndTacks\BatchCBEWriter 

____ 4. Run commands to load the common base events to Process Server.  In the following example 
replace <x_y> with the actual value on the file names: 

__ a. BatchCBEeWriter –Dsource.filename=c:\Labfiles602\ClipsAndTacks\cbe\flow<x_y>.xml 

Note: There are 20 common base event files, so this can become tedious because you need to submit this 
20 times.  If you have a separate folder that contains all of the files, then you can invoke the 
BatchCBEWriter just one time as follows and it will process all the files in the folder:   

BatchCBEWriter –Dsource.filename=<path to folder> 

Substitute your folder name for <path to folder>, for example:  

BatchCBEWriter –Dsource.filename=c:\Labfiles602\ClipsAndTacks\cbe 

____ 5. When you run BatchCBEWriter, you should see results such as: 
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____ 6. To verify that Monitor is processing these properly, open the DB2 Control Center.  In Windows, 
select Start > All Programs > IBM DB2 > General Administrative Tools > Control Center 

__ a. In the MONITOR database, open table CTX_CLIPSANDTACKS_MC.  You may see records as 
in this example.  Note however, that the replication daemons are running, so do not be alarmed if 
you do not see records, since they may have already been deleted and moved to the 
DATAMART database.  In this case proceed to the next step to check the DATAMART database. 

 

__ b. In the DATAMART database, open table FCT_CLIPSANDTACKS_MC.  You should see records 
as in this example.  You may have to wait a few minutes for the Replication Manager daemons to 
run.  If so, wait a few minutes, then click View > Refresh in the Control Center. 
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__ c. Close the DB2 Control Center. 
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Part 6: Create a dashboard 

In this section you will build a dashboard in WebSphere Portal Server.  You will add portlets to the 
dashboard and configure them. 

____ 1. Make copies of the portlets that you want to use: Instances, Dimensional View and KPI View.   

You should not configure the original portlets, since the configuration cannot be removed once it is applied.  
So you will make copies of the portlets, then you will configure the copies. 

__ a. Open the Portal page, http://localhost:9081/wps/portal 

 

__ b. Click Log in, then enter your Portal administrative user ID and password (commonly 
wpsadmin/wpsadmin). 

____ 2. Create copies of the Monitor portlets. 

__ a. Click on Administration  at the top of the page, and then click Portlet Management > Portlets . 
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__ b. Browse to page 10  by clicking on the arrow icons or entering the page number in the ‘Jump to 
page’ navigation box and then clicking the arrow icon .  This page should show the portlets for 
Dimensional View and Instances. 

__ c. On the row containing Dimensional , click the icon for Copy portlet ( )  You should see this 
window: 
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__ d. Click OK. 

__ e. On the row containing Instances , click the icon for Copy portlet ( ).  On the next window, 
click OK. 

__ f. Now Browse to page 11  by clicking on the arrow icons.  This page should show the portlet Key 
Performance Indicator (KPI) plus the copies of the portlets for Dimensional and Instances. 

__ g. On the row containing Key Performance Indicator (KPI) , click the icon for Copy portlet ( ).  
On the next window, click OK. 

__ h. Now Browse to page 10  by clicking on the arrow icons.  This page should show the portlet Alert. 

__ i. On the row containing Alerts , click the icon for Copy portlet ( ).  On the next window, click 
OK. 

__ j. Now Browse to page 11  by clicking on the arrow icons.  This page should show the four portlets 
that you copied. 
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____ 3. Create a page containing four views: Instances, Dimensional, Key Performance Indicator (KPI), 
Alerts. 

__ a. Click on Administration  at the top of the page, and then click Portal User Interface > Manage 
Pages . 
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__ b. Click My Portal , then click the button ‘New Page’ .  Enter a page title ‘Dashboard’.  For Type of 
Page, it defaults to a two column layout, but click the radio button on the far left to select the one 
column layout.  Click OK, click OK.  Now you should see the new page in the list as follows: 
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__ c. Click on the ‘Edit Page Layout’  icon for Dashboard. You will find it to the right side of the row for 

Dashboard: .  This will open the editor for this page. 
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__ d. Click button ‘Add portlets’ .  You will see a list of portlets.  There are multiple pages of these and 
you can use the navigation at the bottom of the list to look at them. Find ‘Copy of Dimensional’, 
‘Copy of Instances’, ‘Copy of Key Performance Indic ator (KPI)’, ‘Copy of Alerts’ (they are 
on the last page), and check all of them. 

 

__ e. Click OK. 

__ f. This shows that the views have been added to the page: 
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__ g. Click Done . 

__ h. Click My Portal  at the top of the page.  This window opens and you see that there is now a tab 
for Dashboard . 
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____ 4. Configure the views on your new page. 

__ a. Click on the tab for Dashboard .  You can use the Alert view immediately, but the other views 
need to be configured: 
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__ b. Click the Configure  icon on the Copy of Dimensional portlet.  
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__ c. For Monitor model, select ClipsAndTacks . 

__ d. For Cube, select CLIPSANDTACKS MC CUBE <timestamp>  

__ e. In Available dimensions, select Measures , then next to Page dimensions, click Add . 

__ f. In Available dimensions, select Location , then next to Row dimensions, click Add .  

__ g. In Available dimensions, select Order Status Dimension , then next to Column dimensions, click 
Add . 

__ h. The screen should look like this: 
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__ i. Click Next.  

__ j. Click OK.  

__ k. This shows the configured portlet: 
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__ l. You are currently looking at the instances count.  To see other measures, click on the Measures 
drop down list.  Select Average Order Price . 

__ m. Currently you are seeing data at the top level.  In the tabular view on the right, double click on 
all  in the column to drill down on Order Status .  Double click on all  in the row to drill down on 
Location .  Here is a sample: 



© Copyright IBM Corporation 2007. All rights reserved 

2007 April, 27 IBM WebSphere Business Monitor 6.0.2 – Lab exercise Page 118 of 136 

 ClipsAndTacks 

 

__ n. Click on the Configure  icon for the Copy of Instances  portlet.  
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__ o. For model, select ClipsAndTacks . 

__ p. For monitoring context, choose ClipsAndTacks MC.  

__ q. For metrics, check Select All.  
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__ r. Click Next.   

__ s. On the next screen, select the check box for Monetary Metric for totalPrice, and select USD for 
the Currency, as you see in this screen capture: 
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__ t. Click Next, Next, Finish . 

__ u. By taking the defaults, you configured the view to show both active instances and completed 
instances. 
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__ v. Click on the Edit  icon for the Copy of Key Performance Indicator (KPI) portlet.  

 

__ w. In column Show in View , check all four check boxes. 
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__ x. Click OK. 

 

 

__ y. For the Alerts  portlet, no configuration is needed.  Click on one of the alerts in the Subject 
column and you can see the details for the alert. 
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What you did in this exercise 

In the lab, you created a monitoring model using WebSphere Integration Developer. 

Then you deployed the model to WebSphere Business Monitor. 

You ran model life cycle steps, created Monitor database and replication manager artifacts.  You started 
the replication manager daemons. 

You imported the cubes to Cube Views. 

If you had an LDAP server, then you also configured Action Manager to create alerts based on business 
situation events. 

You used the supplied program to simulate the submission of events from the monitored application. 

You configured Dashboards and viewed monitored data in several different types of views. 
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Appendix 1 – Import the solution into the monitorin g model editor 

A solution has been provided so that you do not have to build the model from scratch.  This section shows 
you how to import the monitoring model into WebSphere Integration Developer.  After importing the model 
then you can proceed to generate the EAR and deploy the model. 

 

____ 1. Start WebSphere Integration Developer and setup the environment. 

__ a. Start WebSphere Integration Developer V 6.0.2, and when prompted point to a new workspace 
such as c:\workspaces\ClipsAndTacks 

__ b. Close the Welcome tab. 

__ c. Select Window > Preferences > Workbench > Capabilities .  Make sure that ‘Advanced J2EE’ 
is selected. 

__ d. By default, you are in the Business Integration perspective.   You want to open the Business 
Monitoring perspective.  Select Window > Open Perspective > Other > Show all > Busi ness 
Monitoring .   

__ e. If it asks you to Confirm Enablement, then click OK. 

____ 2. Create a new monitoring project. 

__ a. Right click the Project Explorer, then select New > Business Monitoring Project…  

__ b. For Project name, enter ClipsAndTacks  

__ c. Click Finish.  You will see the new project in the Project Explorer view. 

____ 3. Import the supplied mm and cbe files. 

__ a. Right click in the Project Explorer view, and then select Import…  

__ b. Select File system , and then click Next . 

__ c. Browse to the location containing the files, for example, c:\Labfiles602\ClipsAndTacks 

__ d. Select ActivityEvent.cbe  

__ e. Select ClipsAndTacks.mm  

__ f. Select DeclinedOrderEvent.cbe  

__ g. Select LateAverageOrderShippedEvent.cbe  

__ h. Select NewOrderEvent.cbe  

__ i. Click Finish .  

____ 4. Expand the project in the Project Explorer view, then expand the Event Definitions and you will see 
the new events listed.  Expand Monitor Models and you will see the new ClipsAndTacks model 
listed. 

____ 5. Now you can proceed to the section to generate the EAR for the monitoring model. 
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Appendix 2 – Workaround for step 5: Manage Alphablo x cube 

If you receive a connection error running Step 5 of the life cycle steps, then you can use this appendix to 
complete a workaround.  In this section you will manually import the cube in Alphablox, then you will mark 
this step complete in the life cycle table. 

____ 1. Copy the cube name from OLAP Center 

__ a. In Windows, select Start > All Programs > IBM DB2 > Business Intellige nce Tools > OLAP 
Center 

__ b. Enter your DB2 user ID and password 

__ c. You should see the cube model listed as follows: 

 

__ d. Right click on the cube model, and then select Properties… 

__ e. Use the mouse to select the text in the Name field as you see here: 
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__ f. Then press Ctrl-C keys to copy the text to the clipboard. 

__ g. Click Cancel, then close the OLAP Center. 

____ 2. Define the cube to Alphablox. 

__ a. If the WebSphere Portal server is not running, start it using Start > All Programs > IBM 
WebSphere > WebSphere Portal V5.1 > Start the Serve r. 

__ b. Start Alphablox in a browser Start > All Programs > IBM DB2 Alphablox 8.4 > 
AlphabloxAnalytics > DB2 Alphablox Administrative P ages .   

Note: You may find that Windows will block your attempt to access the page and you should see this in the 
Internet Explorer window in a yellow information bar at the top. Click on this bar and select Allow Blocked 
Content… to continue: 
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__ c. When it prompts for it, enter user ID: admin, password: password.  You should see a window like 
this: 

 

__ d. Click on tab ‘Cubes ’ at the top of the Alphablox window. Click Create .  You should see a window 
like this: 
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__ e. Click the check box ‘Enabled ’ next to the DB2 Alphablox Cube Name . 

__ f. Use keys Ctrl-V to replace New Cube with the correct cube name. 

__ g. Select DATAMART  for the Relational Data Source. 

__ h. Click the check box ‘Enable DB2 Cube Views Settings’ . 

__ i. Select the model in the Cube Model dropdown, then click button ‘Import Cube Definition’ . 

__ j. You should have a screen like this: 
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__ k. Note that the DB2 Alphablox Cube Name must match exactly the Cube Model name, except the 
‘WBI.’ prefix is removed from the DB2 Alphablox Cube Name. 

__ l. Click OK to save the definition.  Then you will see it added to the list as follows: 
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__ m. Click on the General  tab at the top of the Alphablox window.  Then click Runtime Management 
> DB2 Alphablox Cubes .   
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__ n. Select the cube in the list, then click the Start  button.  The status should show as ‘Running’ for 
the cube.  Here is an example: 
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____ 3. Update the life cycle table for step 5. 

__ a. Open the DB2 Control Center.  In Windows, select Start > All Programs > IBM DB2 > General 
Administrative Tools > Control Center  

__ b. In the MONITOR database, open table LC_STEP.  For the row containing STEPNAME 
‘createAbxCube’, place a 1 in the column ISCOMPLETE.  Here is an example: 
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__ c. Make sure that you click Commit to save your changes. 

__ d. Click Close 

__ e. Close the DB2 Control Center. 

__ f. Back in the Process Server administrative console, if you are still displaying Step 5 of the life 
cycle, then reload the page in the browser and you should see that Step 5 is now marked 
complete. 

__ g. Return to the instructions for the life cycle steps starting at Step 6. 



© Copyright IBM Corporation 2007. All rights reserved 

2007 April, 27 IBM WebSphere Business Monitor 6.0.2 – Lab exercise Page 136 of 136 

 ClipsAndTacks 

 

 

 

 

 

 

 

 

 

 

 

 

 

This page is left intentionally blank. 


