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IBM WEBSPHERE 6.0 — LAB EXERCISE

Preparing a Process with WebSphere Business Modeler
for WebSphere Integration Developer
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What this exercise is about
The objective of this lab is to provide you the basic steps for exporting a project from WebSphere Business

Modeler V6. This lab will also guide you on how to import a project into WebSphere Integration Developer
V6 and rewire the process in a best practice way to use the imports/exports.

Lab Requirements
e  WebSphere Business Modeler V6

e WebSphere Integration Developer V6.0.1

e Sample code in the directory C:\

What you should be able to do
At the end of this lab you should be able to:
e Import a project into WebSphere Business Modeler V6.
¢ Set Implementation type to Java for the tasks in WebSphere Process Server modeling mode.
e Add customize information to the process.

e Export the project from modeler.
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e Import a model into WebSphere Integration Developer V6.0.1.
e Create modules using library dependency.
e Create implementations and bindings in modules.

e Rewire the process to use imports and exports.

Introduction

In this lab exercise you will learn how to import a project into WebSphere Business Modeler V6. This lab
shows you the procedures of setting the implementation type to Java for a particular task in the
WebSphere Process Server modeling mode, adding customization information to the process, and
exporting the project from WebSphere Business Modeler V6. When exported, the process is converted to
a BPEL business process. The lab exercise will then show you how to import a project into WebSphere
Integration Developer V6.0.1, create modules using library dependencies, create implementation and
binding, and rewire the process to use imports/exports. The rewiring of the process to use imports/exports
rather than components is a best practice which will be beneficial when it comes to modifying the process
in WebSphere Business Modeler and then importing it again into WebSphere Integration Developer. With
the use of the Imports/Exports, changes to the individual task implementations do not have to be modified
when the process is updated.

Exercise Instructions

Some instructions in this lab may be Windows operating-system specific. If you plan on running the lab on
an operating-system other than Windows, you will need to execute the appropriate commands, and use
appropriate files ( .sh vs. .bat) for your operating system. The directory locations are specified in the lab
instructions using symbolic references, as follows:

<LAB_FILES> C:\Labfiles60 /tmp/Labfiles60
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Part 1: Initialize workspace for WebSphere Business Modeler
1. Start WebSphere Business Modeler.

__a. To start the Modeler, click Start > Programs > WebSphere Business Modeler > WebSphere
Business Modeler.

__b. The Modeler workspace window will appear. Click the Browse... button and select
<LAB_FILES>\PrepareProcessForWID\workspace as your workspace directory.

—

Web5phere Business Integration Modeler

WebSphere Business Integration Modeler stores your work in a directory called a workspace. You can change the
workspace each time you start the application. Spedfy the directory to use for this session:

C:\LabFilesa0\PrepareProcessFortyID workspace| Browse. .,

| Use this as the default workspace, and do not show this dialog box again.

Show Details QK | Cancel |

__c. Click OK. If the Quickstart wizard opens, click Cancel.

__d. Close the Welcome view by clicking the X at the top of the view.

%> Business Modeling - IBM WebSphere E
File Edit Mavigate Search Project Modeling

Ewa

{EUENL TS Business Modeler
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4. Import Solution.

__a. Select File > Import.

l@ Business Modeling - ProcessScenario - 1B
@ Edit View Mavigate Search Project Modelim

Mew Alt+Shift-+H L4
=% Mew Business Modeling Project

Close Ctrl+F4
Close all Ctrl+shift+F4
[l save Cri+s
Bl save A

Switch Workspace. ..
Open External File. ..

£ Export...
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__b. From the Import window, select WebSphere Business Modeler Import and click Next.

9 import

Select

WebSphere Business Modeler Import S

=

Select an import source:

g‘gfchedmut Projects from CVS

| Ecore to UML2

e Existing Ant Buildfile

ﬁExisting Project into Workspace
Lk External Features

‘-%,:‘,External Flug-ins and Fragments
[ File system

'9_,_‘|-|'I'I'P Recording

@,Lng File

Li¥) Profiing file

:@,Prnﬁling filter

'f-‘_?-,'Semrity Certificate
EQSympb:um Database File
f'YE'LTeam Project Set

# UMLZ to Ecare

% websphere Business Modeler Impart
@‘ Zip file

= Back I Mext = i Finish Cancel
WebSphere Business Modeler Import window will be opened.
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__c. Select WebSphere Business Modeler Project (.zip) and click Next.

- Web5Sphere Business Modeler Import

Select type.
Select a format and dlick Mext.

s e

Types
@E’Iﬁebﬂphere Business Modeler project (,zip) ] [A]
E=3WebSphere MQ Workflow {.fdl)
i*5WebSphere Business Inteqgration Workbench ¥4.2.4 (.org) [V]
< Back Cancel

__d. Click Browse and select <LAB_FILES>\PrepareProcessForWID\import\ as the Source

directory.
__e. Select the file ProjectScenario_start.zip.
__f. Click New to create a Target Project.

Create a new business modeling project window will be opened.
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__g. Enter ProjectScenario as New project name and click Next.

%9 Create a new business modeling project

Create a new business modeling project

Click Finish to create the new element. B

MNew project name
| ProjectScenarial |

Default process catalog name

| Processes |

|:| Create process,

Mame

= Back Mext = | Finish I Cancel

__ h. Accept the default Free-Form Layout and click Finish.

¥ Quickstart wizard

Specify default editor for processes in this project

Click Finish or change the editor settings ﬁ

specify the initial layout used by the process editor:

& Free-Form Layout
O swimlane Layout

Layout by | |E"
Classifier | |E||

< Back I Mexh = Finish Cancel

__i. Click Finish from the WebSphere Business Modeler Import window.
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__j. Click OK from WebSphere Business Modeler project (.zip) window.

-,

-} WebSphere Business Modeler project (.zip)

- Impart finished
-

2006 January, 12 IBM WebSphere 6.0 — Lab Exercise Page 8 of 38

WBModelerv6_PrepareProcessForWID.doc



© Copyright IBM Corporation 2006. All rights reserved

Part 2: Prepare Process for Export

In this section, you will perform the steps necessary to prepare the process for assembly in WebSphere
Integration Developer and deployment to WebSphere Process Server.

1.  WebSphere Business Modeler provides a number of modeling modes which correspond to different
destination runtimes. Each mode provides and restricts different options depending on what is
supported by the runtime. Since the ProcessScenario process is destined for WebSphere Process
Server, change to this mode accordingly.

__a. Select the WebSphere Process Server modeling mode by selecting Modeling > Mode >
WebSphere Process Server from the main menu.

Modeling Run  Window Help

1 Create k| *¥o o -

Mode ¥ [Z)Basic Alt+Ctrl+8

| B Quickstart wizard Intermediate Alt+Ctrl+1
[l [ Advanced Alt+Ctrl+A
WEI::SpherE Business Integration Server Foundation  Alt+Ctrl+5

[} 'l."'.l'El:lSphEFE MQ Workflow Alt+Ctrl+M

~Elements v @Webﬂphere Process Server Alt+Ctrl+P

You may notice some changes as different options are displayed or removed inline with the support
available for WebSphere Process Server.

Note: You might see some warnings after changing the mode to WebSphere Process Server but you
should not see any errors.

2. For aprocess destined for WebSphere Process Server, the different tasks in the process will be
converted into activities in a BPEL business process. Set the tasks to use a Java implementation.

A resource assignment on a task can dictate what type of activity will be created in the BPEL business
process. For example, if a role or person is assigned to a task and the task is local, then an inline human
task will be created. If the task is global, then a participating human task that is a separate service
component will be created. If the resource assigned to the task is a machine, then a Java component will
be created. If no resource is specified, a Java component will also be created. Besides this behavior, you
can also specify the specific implementation for a task. The implementation setting will cause an empty or
skeleton component implementation to be created. The empty implementation can be completed or act as
a hint for the assembler who will connect the process up to the appropriate existing component. For
simplicity, a Java component will be used for this lab exercise. This will be further explained later in the
lab.

__a. Inthe Project Tree view, select ProjectScenario > Processes and open the process by double-
clicking the ProcessScenario process.

___b. Select the Receive Order task.
___c. From the Attributes View of the Receive Order task, select Technical Attributes View.

__d. Select Implementation in the Technical attributes view.
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__e. Select Java as the Implementation Type from the drop down list.

Attributes - Receive Order | Simulation Contral Panel | Errars (Filter matched 2 of 2 items) [l___, Eﬁ@]
Interface Reguest Response (- Implementation ]
Component Attributes

Define the component information that represents the target implementation

Component display name

Component name

Component description

Implementation tvpe]
[none]

[+

[none]

State Machine
Rule Group
Human Task

Jaw

__f. Select the Package and Ship Order task in the process diagram and repeat steps from 3-b
through 3-d to change the Implementation type to Java.

3l

__g. Save your work (Ctrl+S).
3. Convert the tasks of the ProcessScenario to Global tasks.

When preparing a process for WebSphere Process Server, it is a best practice to make your tasks global
tasks; this will cause the interfaces for the tasks to be packaged into a library and available to other
components in other modules. This will be further emphasized once you import the process into
WebSphere Integration Developer. It is a best practice to have a backup of your process prior to this step.

__a. Right click on the Receive Order task.
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___b. Select Convert to > Global Task.

Receive
Qrder

CLstomerOrd Is Order
() Customer rgr;_q less than &

r Global Process. ..
Input and Qutput ¥ ||  Global Task..
Global Service. ..
il
<7 Undo Local Process...

Pt r

__c. The window Create a new task will be opened. Make sure that the Name of new task is
Receive Order and click Finish.

@ Create a new task

Create a new task

Click Finish to create the new element.
I

=Tz ProjectScenario
l’g‘g Processes

Mame of new task

| Receive Order

Description of new task

Einish | Cancel

__d. Right click on the Package and Ship Order task and repeat steps b and c to convert it to global
task. Click OK if you get the following window:

#= Convert to Global Task |

' This conversion may result in errors or loss of information. Click Preview For
& details,

Preview = | Zancel |
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__e. Observe the difference between the local and global task in the process diagram:

S0 DGlVES ] CustomerOrder

I ]

P s

o~ CustomerOrder @
. Is Order a
@ ] CustomerOrLc/Ier i M Package and %
Receive 5007 [ CustomerOrder Ship Order
Order 24 [N ——
pprove
CustomerCOrder Crder

50.0% No

__f. From the Project Tree, you can observe two new global tasks under the ProcessScenario.

—*l

3

iy

i £

%; Project Tree &4

=Tz ProjectScenario
= EEJ Business items
[C] CustomerOrder

24! Package and Ship Crde
[2;! Receive Order
+ ié‘ﬁ ProcessScenarioResource catalog

__g. Save your work (Ctrl+S).

Note: You will not set the implementation on the Approve Order task or convert it to a global task. The
Approve Order task has a Role (Account Manager) defined as a resource and will be implemented as a
human task. If the task is local, then the human task will be an inline human task inside the BPEL
process. For the process, this tight integration will be used since the human task step is a critical part of
the process. There is no need to make the task a separate service component that will be called outside
of a business process. Converting the Approve Order task to a global task would generate a separate
human task service component which would have to be managed separately from the BPEL process.

The interfaces and BPEL activities that will be generated for the process can be customized prior to
exporting the project. It is recommended that careful consideration is used when specifying these
values since they will be exposed as part of the service definition for the implementation.

4.

__a. Open the ProcessScenario process diagram and click on the white space on the diagram.

___b. Select Technical Attributes View from the Attributes View.
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__c. Select General tab and enter the following under BPEL Attributes:
e Target namespace: http://com/asdfparts/projectscenario
e Process display name: OrderProcessScenario

e Process name: OrderProcessScenario

Attributes - ProcessScenario | Simulation Control Panel | Errars (Filter matched 2 of 6 items) [fﬁ'edﬂniml Attributes \ﬁew}@ I

‘ Interface Request Response Implementation

¥ BPEL Attributes

Define BPEL process information below

Target namespace
| http: /fcom/asdfparts /projectscenario |

Process display name

| OrderProcess5cenario |

Process name

| GrderF‘rncessScenari0| |

__d. Select Interface tab and enter the following under WSDL Interface Attributes:

e Target namespace:
http://com/asdfparts/projectscenario/OrderProcessScenariolnterface

e PortType name: OrderProcessScenario

1{&2%@ Request Response Implementation

¥ WSDL Interface Attributes

Define WSDL interface information below

Target namespace
| http: /fcom/asdfparts /projectscenario/OrderProcessScenariolnterface |

PortType name

| GrderF‘r-:u:essSu:enariu:u| |

Callback PortType target namespace

Callback PortType name

__e. Select Request tab.
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__f. Select the Input criterion and enter the following:
e Operation name: ReceiveOrder
e Message name: InputMessage
e Part name: CustomerOrder
e Activity display name: OrderReceived
e Activity name: OrderReceived

These settings customize the interface of the BPEL process.

General Interface ‘ Response Implementation

¥ Input criterion section

Select an input criterion in the table to see the WSDL and BPEL information in the sections below

Tnout criterion name [ Corresponding outout orit | Valid pneration tvoe | selected poeration tvoe

Input Criterion Qutput Criterion Regquest /response, one ...  Reguest [ response

¥ Operation type
Select the type of operation

® Request [ Response operation

O One way operation

¥ wWsDL Attributes ¥ BPEL Attributes
Define the WSDL interface information Define the BPEL receive activity information
Operation name Activity display name
{Rreceiveorder | | [CererRecEived]
Activity name

¥ WSDL Message Details

{-OrderRecEived]

Define the WSOL message that represents the input of an operation

Message name

'{Inputf\"lessage'] |
Part name

[(-Iustomerﬂrder] |

__@. Select Response tab.
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__h. Select Output criterion and enter the following:
e Message name: OutputMessage
e Part name: CustomerOrder
e Activity display name: OrderReply
e Activity name: OrderReply

These settings customize the response portion of the interface.

Attributes - ProcessScenario | Simulation Control Panel | Errors (Filter matched 2 of & items) | 7 Technical Attributes View &3

(General Interface Reguest m Implementation

¥ Qutput criterion section

Select an output criterion in the table to see the WSDL and BPEL infarmation in the sections below

Qutput criterion name | Corresponding input criterion name | Response type |
Cutput Criterion Imput Criterion Response ]
¥ WSDL Attributes ¥ BPEL Attributes
Define the WSDL interface information Define the BPEL reply activity information
Activity display name
¥ W5DL Message Details
(OrderRepIy]
Define the WSDL message that represents the output of an operation Activity name
Message name (OrderReply ]
1 OutputMessage I |
Part name
{ Customercrder | |

__i. Select Implementation tab and enter the following:
e Component display name: OrderProcessScenario
e Component name: OrderProcessScenario
These settings customize the component that will represent the BPEL process.

General Interface Reguest Response -

¥ Component Attributes

Define the component information that represents the target implementation

Component display name

| QOrderProcessScenario

Component name

| OrderProcessScenario

___j. Save your work (Ctrl+S).
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Note: You can also customize each task of the process individually. Click the Receive Order or Package
and Ship Order task in the ProcessScenario process diagram. From the Technical Attributes View select
General, Interface, Request, Response, and Implementation tabs and enter the required information as
explained in step 4.

5. In order to correctly export out the process, the default business measures will need to be created.
Create business measures.

__a. From Project Tree, select Processes > ProcessScenario.

__b. Right click on ProcessScenario and select Create Business Measures....

m H] = s = T E\I &5 Processsce

El-1zy: ProjectScenario
Eﬁ Business ikems
Elt.gf Processes [};

P 3:3 Proc

[ Package and Shi MNew »

el Receive Order

'é,ﬁ ProjectScenaio Resc

..... [44 Resources Expork

----- {5y Organizations

Imnpark

== Cipen
L& Classifiers

L g Reports Print. ..
[, Cueties

L4 Predefined resource HE 000
: Sirnulate

L Predefined organiza
#-[& Predefined classifier Create Business Measures. ..
Export Diagram. ..

__c. Click OK to accept all selected elements for creating business measures.

#= Select Process Elements | x|

Create Business Measures

@ Select the process elements to measure, Only
elements that can have business measures are
shiown,

E|'" roc Enario

A=) Apprave Crder

™ @ Package and Ship Order
@ Receive Order

- <& Is Order Less Than $5007

0k, I Cancel
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__d. ProcessScenario Business measures window will be opened. Review and close that window.

KPIs
L) KPIs
EEI Mektics This section provides information about key performance indicators (KPIs) calculated across multiple runs of the process,
Marme | Type | Aggregat... | Aggregat... | Lze Target | Target | Lower kar. .. | Lppet kar... | Lawer limit | Upper limit |

Remowve

Situation events

Optionally, specify situation events that are sent when the value of the selacked business measure changes.

Event definition | Event attribute | Attribute bvpe | Attribute calculation |

Remowve

& Send only once [or, if "0n condition” iz set, send only when the condition changes from Falze to true]
O Send every time [or, if "0On condition” iz set. send every time the condition iz trug)

On Condition

__e. ProcessScenario Business measures will be added under the ProcessScenario process in the
Project tree:

¥
2. Project Tree 52 H E % & =50

=Tz ProjectScenario
EE] Business items
EI[EE Processes
- B-L5 Processscenario
.-.Jf.. Processscenario Business measur
[ Package and Ship Order
Receive Order

_—

6. The process is customized and ready to be imported into WebSphere Integration Developer. Export
the ProjectScenario project from Modeler.

__a. Select File > Export.
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__b. From the Export window select WebSphere Business Modeler Export and click Next.

-,

@ Export

Select
WebSphere Business Modeler Export }‘ ]

Select an export destination:

= Datapool

%?.B: Deployable features
ﬁ[ﬁleplnyable plug-ins and fragments
IIFile system

J03AR file

&) Javadoc

:E.b Profiling filter

QESymptﬂm database file

3& Tegm Project st

,@l Zip file

= Back I I Firish Cancel
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__c. The WebSphere Business Modeler Export window is opened. Select Type as WebSphere
Business Monitor and development tool and click Next.

-4 WebSphere Business Modeler Export
Select type. —
Select a format and dick Mext. E
-
Types

£:'WebSphere Business Modeler project {.zip)

£ UML Business Modeling Profile

EWebSphere MQ Workflow {.fdl)

£:1WebSphere Business Integration Server Foundation

e Delimited text (.csv, .ixt)

Ao ;

o T R Ty
[ W EDSONErE PTOCESSs Herver

£ CEI Event Catalog

£:1WebSphere Business Monitor (from BPEL process)

< Back I Mext = I Einish Cancel

__d. Click Browse... and select C:\<LabFiles60>\PrepareProcessForWID\ as the Target directory.

__e. Select the Project as ProjectScenario.

-} Web5Sphere Business Modeler Export

Destination and source
P —

Click Finish to export or Mext for more options, @

-

Target directory
|C:'I,|_a|:lﬁ|ESG|:|'I,F'FEFIEFEF‘FDEESSFDF'L"‘.I'ID' EH Browse... |

Project
| ProjectScenario IE“
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__f. Click Next.

__g. Click Module project name and enter ProjectScenario.

__h. Click Library project name and enter ProjectScenarioLibrary. All interfaces for the process
and global tasks will be placed in the library and available for use by other components not in the
module containing the process.

__i. Click Project interchange name and enter ProjectScenario.

& WebSphere Business Modeler Export

WebSphere Process Server export details

Click Finish to export, E?

Module project name

| ProjectScenario |

Library project name

| ProjectScenarioLibrary |

Project interchange name

| ProjectSceanrio |

WID Workspace location

| - || Browse... |

__ |- Click Finish from the Export finished window.

¥ Export finished

i) Export finished successfully

7. Select File > Exit to exit from the modeler.
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Part 3: Initialize workspace for WebSphere Integration Developer
1. Start WebSphere Integration Developer V6.0.1.

__a. Select Start > Programs > IBM WebSphere > Integration Developer V6.0.1 > WebSphere
Integration Developer 6.0.1.

__b. Workspace Launcher window will be displayed. Click the Browse button and select
<LabFiles60>\PrepareProcessForWID\workspace as your workspace directory.
Workspace Launcher |

Select a workspace

1EM Websphere Integration Developer stores wour projects in a directory called a workspace,
Select the workspace directory ko use Faor this session,

e (e =t B : L abFilesc0l PrepareProcessFor WDy workspace j Browse. ., |

[ Use this as the default and do not ask again

0] 4 I Zancel

__c. Click OK.
2. Import the Model into WebSphere Integration Developer.
__a. Select File > Import from the IBM WebSphere Integration Developer.

___b. From the Import window select Project Interchange and click Next.

4= Import E
Select
Import a project and its dependent projects From a Zip file. Y

=

Select an import source:

2, Log File ;l
=2 performance Call Graph
7&:; Probe

(&) Profiling File
S Profiling Filker
Project Interchange

-

= Back I Mext = I Eimish Cancel

Import Project Interchange Contents window will be opened.
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__c. Click Browse... and select C:\<LabFiles60>\PrepareProcessForWID\ProjectScenario.zip as
source zip file.

__d. Click Select All and click Finish.

4= Import Project Interchange Contents

E3
Import Projects
Impart Projects Fram a zip file.
-
L B =
From zip File:

IC:'l,LaI:uFiIesEuI:I'I,F‘repareP'rDcessFDr'-.-'-.-'ID'I,F‘rl:ujectScenar j ' Browse, ., '
Project location raok: IC:'I,Lal:uFiIEsEnlil'l,F‘rEpareF'rDcessFurWID'l,wnrkspaceWID Browse. .. |

[¥] = ProjectScenario
[¥] = ProjectScenarioLibrary

Deselect all | Seleck Referenced

< Back Mext = | Einish I Cancel
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Part 4: Rewire Process for Components

1. Review the imported artifacts.

_a

In the Business Integration view, notice the two projects. One (ProjectScenario) is the module
containing the process and the other is a library (ProjectScenarioLibrary).

. Expand ProjectScenarioLibrary > Interfaces. Notice there are 3 interfaces in the library. One

for the process (ProcessScenario) and one for each task (PackageandShipOrder and Receive
Order). With the interfaces in the library, they can be used for components defined in other
modules.

. In the Business Integration view, expand ProjectScenario and then double-click

ProjectScenario.

. The Assembly editor will be opened. Notice how the different tasks of the process are exposed

as Java components. The Approve Order task is not exposed as a separate component since it
was a local task and it had a resource assigned to it that was a Role (Account Manager). Even
though the Receive Order and Package and Ship Order tasks are separate components, they
are in the same module as the process. This packaging structure is simple and fine for the
testing and deployment of small applications. When processes become larger and iterative
development of the process occurs, it becomes problematic to keep the components updated
when they are in the same module. Many times the implementation of the component remains
the same, or changes to it are independent of changes to the process. Changes to the process
are also independent of changes to the individual task implementation. For these reasons, it is
better to move these components and their implementation to a different module and use a SCA
Import/Export to connect the components to the process. In the future, when changes are made
to the process, the task implementation, which is a separate component in a separate module,
can be left unchanged.

L7 <
- @ & Recsive OrderExport @ B Receive Order
FLS
R
=0 | ‘Q 1.1
o @ % ProcessScenario Export (L) CrderProcessScenario AL
= o 2 :
T i Packa d Ship Crd
@ & package and Ship OrderExport b il
2006 January, 12 IBM WebSphere 6.0 — Lab Exercise Page 23 of 38

WBModelerv6_PrepareProcessForWID.doc



© Copyright IBM Corporation 2006. All rights reserved

__e. Double-click on the OrderProcessScenario component to open the process. Notice the
Approve Order task is an inline human task.

F . :
& | ProcessScenario Receive

|
- b
& Rereive Order
. |
P"-", Lpprove Order (IJ

I—I

sl
P& Package and Ship Order
J

LU
P{E, Processacenario Reply

©

__f. Close the Process editor and the Assembly editor.

2. In order for the Receive Order and Package and Ship Order component implementations to be
isolated from changes in the process, separate modules for each component should be created.
Create the modules.

__a. Select File > New > Project from the main menu.

4= Business Integration - IBM WebSphere Integration Developer

Edit Mavigate Search Project Run Window Help

Close kel +F4

[ Business Object
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__b. Select Module from the New Project window and click Next.

4% New Project

Select a wizard

Creates a new business inkegration module,

Wizards;

----- & Library

------ = Medigtion Madule

[E‘b Business Inkegration
[E‘b lava

[E‘b Server

[E‘b Simple

[57 Examples

= Back H Bext = I Einish | Cancel |

__¢. From New Module window enter ReceiveOrder as Module Name and click Finish.

& New Module
Module

Create a new business integration module, A module is a project that is used Far l__|

dewvelopment, wersion management, organizing resources, and deploying to the | 7
runkime environmenk,

Madule Ngmeq ReceiveCrder| I

Maodule Location
W Use default

Direckor: IC:'I,'u'-.-'ID WiarkSpace|ReceiveOrder Browse, ., |

Business integration modules can be deployed and run on WebSphere Process Server, They can
conkain many tyvpes of components, such as business processes, assembled together For the
purpose of business integration.

= Back Mext = | i Einish I Cancel

__d. Repeat the above steps to create another module: PackageandShipOrder.
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3. Inorder for components in the new modules to be able to provide the implementation for the
different tasks, the appropriate interfaces in the ProjectScenarioLibrary task must be used. A
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dependency between the module and the library must be established before the interface can be
used for a component. Create the dependencies and add libraries to modules.

__a. Right click on the PackageandShipOrder and select Open Dependency Editor.

rE— =gt

BE g v ‘
'[DL'_‘ ] X
1= ProjectScena g
'[g ProjectScens Open Dependency Editaor
H-[= ReceiveOrdel  Show Files

__b. Click Add from the PackageandShipOrder Dependencies.

?c':ﬁ Assembly Diagram: ProjectScenario

2006 January, 12

Libraries
Configure the required libraries.

Advanced:

O ceploy with Modul

add. .. || Femove
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__c. Select ProjectScenarioLibrary from Library Selection window and click OK.

#4= Library Selection M=l E3

Choose a library (¥ = any character, * = any String):

Matches:

enarioLibrary ;

Location:

Z: WID WorkSpace/ProjectScenarioLibrary

l Ok I Cancel

__d. Save (Ctrl+S) and close the Dependency Editor.

__e. Repeat the above steps for ReceiveOrder module.

4. Generate Implementation and Binding.

__a. Double-click the PackageandShipOrder module and you will see an Assembly diagram for
PackageandShipOrder opened on the right side window.

__b. Drag the PackageandShipOrder interface from ProjectScenarioLibrary > Interfaces and drop
it onto the Assembly diagram.
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__c. Select Component with no Implementation Type from the Component Creation window and
click OK.

= Component Creation E

Select the type to create:

* Excpart with no Binding

if;!'Expnrt with Web Service Binding
= Impaort with nio Binding

iﬁ)lmpnrt with ‘Web Service Binding

o ) o |

__d. An unimplemented component will be created.

?éﬁ Bszembly Diagram: Project3cenario (?éj *fszembly Diagram: PackageandshipOrder EE\

b

I?& »
(1 T, component1
EE w
Ry
=0
E'L:.
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__e. Click on the Component1 and rename it to PackageandShipOrder.

NOTE: You can also change the name by changing the Display name (Name field will automatically be
changed filling Display name field) under the Description tab from Properties view of the Component1. If
you change the name from the Assembly Diagram you should see the Display name and Name changed
from Component1 to PackageandShipOrder in the Description tab of Properties View.

8
C'L:.
Ly = il
EF‘ererties E@]\P_rnblems ‘ Servers| - |
1 Ly Component: PackageandShipOrder [No Implementation]
(Description) il
Details | Display name: {Packageandshiporder | |Name:'PackageandShipOrderI
__f. The component can be implemented any way as long as it uses the PackageandShipOrder
interface. You could implement the component as a human task, business state machine,
business rule or even a business process. For simplicity, right click on the
PackageandShipOrder and select Generate Implementation > Java.
[ ] L]
= :
[ PackageandShipOr
,% - g R <! Undn Update Display Mame
W Cedn
Add »
Change Type... L4
Export, .. L4
Generate Implementation. . L4 j:j Human Task
Select Implementation. .. L4
Imar
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__g. Accept the default package from Generate Implementation and click OK.

4% Generate Implementation M=l

Select the package where the Java implementation will be generated:

Mew Package. ., |

Ik I Cancel

__h. PackageandShipOrderIimpl.java will be opened in Assembly editor. Drop down the arrow (if it
[ t’] is not already) and modify the java code as below:

public DatalChiject InputCriterion(DataChject input)

return input:l

__i. Save your work (Ctrl+S). Close the PackageandShipOrderimpl.java file.

__ |- Right click on the PackageandShipOrder and select Export > SCA Binding. This will make the
component available to be called from outside of the module.

L]
D 5 packageandshipCrA--
<! Undn Add Implementation

W Cedo
&dd k
Change Tvpe... »

Expart. .. I35 Binding
Regenerate Implementation SCA Binding
Merge Implementation Web Service Binding
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__ k. Your PackageandShipOrder Assembly diagram will now look like this:

=E *Azcembly Diagran: Package:

= [} = : -
ol @ 2 PackageandshiporderExport (@) i PackageandShipOrder

__|. Save your work (Ctrl+S) and close the PackageandShipOrder Assembly diagram.
___m. Repeat the above steps for ReceiveOrder module.

4. Rewire process to components.

___a. Open the Assembly editor for ProjectScenario again by double-clicking on ProjectScenario >
ProjectScenario in the Business Integration view.

ssembly Diagram: ProjectScenario X

O
[ =1 :
il 7 @ # peceive Order Expart (1) &5 Receive Crder
=
) f
&> @ % Package and Ship Order Export (1) '@ Package and Ship Order
C.L:‘ 1.1
@ 52 COrderProcess3cenario
@ % orderProcessSeenario Export £

__b. Delete Receive Order, Receive Order Export, Package and Ship Order, Package and Ship Order
Export components.

1.1

@ ¥ Export @© % OrderProcessScenario u
. 2

__c. Save (Ctrl+S) your work.

Note: You should save your assembly diagram after deleting the above elements. Otherwise, you will see
these exports while selecting SCA exports in step j and m.
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__d. Right click on OrderProcessScenario and select Wire References to New > Imports.
B FasEte

¥ Delete

(I Q OrderProcessacenario R.enare
Select Al

Wire References ko Mew Compaonents

WWire ko Exisking
Wire (Bdvanced) ...

Eél 2 (T (3 ReceiveOrderPartner
1.1
EEl (D & ProcessScenario Export @ SZOrderF‘rDcessScenarlu AL
030 ¥ (I) |3 PackageandshipOrderPartner

__f. Right click on ReceiveOrderPartner and select Generate Binding > SCA Binding.

(I) |3 ReceiveCrderPartner

< Unda Move

W Redo

(T) |5 PackageandshipCrderF

add Interface

Generate Binding. .. M3 Binding

Rermove Binding SICA Binding
Shateless Session Bean Binding
= Copy weh Service Binding

‘ Paste I

__g. Repeat the above step for PackageandShipOrderPartner to generate SCA Binding.

__h. Select ReceiveOrderPartner and then from the Properties view at the bottom, select Binding.

- 5
| Properties &2 Froblems | Servers| = — O
Description = Import: ReceiveOrderPartner [SCA Binding)

Details Module name: | |
Binding _| Export name: | |

__i. Select Browse.... SCA Export Selection window will be opened.
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__j. Select ReceiveOrderExport under Matches and click OK.

= SCA Export Selection =]
Choose a SCA export (7 = any character, * = any Skring):

Matches:

'Ec.{!’OrderF‘rncessﬁcenariD Export
e PackageandshipOrderExpork

Cualifier:

i ReceiveCrder/ReceivetrderExport, export

(04 I Cancel

__ k. Select PackageandShipOrderPartner and select Binding from the Properties view.

__|. Select Browse....
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__m. Select Package and Ship Order Export under Matches.

+% SCA Export Selection =]

—hoose a SCA export (7 = any character, * = any Skring):

Matches:

'E#OrderF‘rDcessScenariD Export

P ackageandshipOrderExport
'Eéﬁ'ReceiveOrderExpart

Cualifier:

‘E#F‘al:kageandShipOrder,l'F‘al:k.ageandShipOrderExpDrt.E

| ok I Zancel

__n. Click OK.
__ 0. Save your work (Ctrl+S).

__p. The process is complete and ready for deployment.

1.4

(M@ ProcessScenario Export @ ,QOrderF‘rDcessScenanD AL

» @D = PackageandshipCrderPartner

I'_'-Hi'-u 2 @ = ReceiveOrderPartner
=
R
w0

5. Select File > Exit to exit from the WebSphere Integration Developer.
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What you did in this exercise

In this lab, you imported a project ProjectScenario into the WebSphere Business Modeler V6. In the
WebSphere Process Server modeling mode, you set implementation type to Java for Receive Order and
Package and Ship Order tasks. You also converted these tasks to global tasks, and then you added
customization information to the process and exported the project.

You then imported the project into WebSphere Integration Developer V6.0.1 and created Receive Order
and Package and Ship Order modules for the different components. You established dependencies to the
ProjectScenario library before creating components from the common interfaces. You then created SCA
bindings for the components using Exports. Finally you rewired the process to use the Imports.
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Solution Instructions

_ 1. Import the ProjectScenario project into WebSphere Business Modeler for viewing.
__a. Select File > Import...
__b. Select WebSphere Business Modeler Import and click Next.
__c. Select WebSphere Business Modeler project (.zip) and click Next.

__d. For the Source directory, click Browse... and select the folder
<LAB_FILES>\PrepareProcessForWID\Solution\.

__e. Select ProjectScenarioModeler.zip.
__f. To the right of the Target project field, click New.

__g. Change the New project name to ProjectScenario.

=,

%9 Create a new business modeling project

Create a new business modeling project

Click Finish to create the new element. E/l_

New project name

| ProjectScenario|

Default process catalog name

| Processes

O

Mext = | Einish | Cancel

__h. Click Finish. The Target project field should be filled in with the ProjectScenario value.
__a. Click Finish to complete the import.
2. Import the Model to IBM WebSphere Integration Developer.

__a. Select File > Import from the IBM WebSphere Integration Developer.
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__b. From the Import window select Project Interchange and click Next.

4= Import Ed

Select

Impart a project and its dependent projects from a Zip file, ™,

=

Select an import source:;

%_.-E, Log File ﬂ
=£E Performance Call Graph

7!21; Probe

¥, Prafiling file

T profiling Filter

Arroject Interchange

= Back I Mext = I Eimish Cancel

Import Project Interchange Contents window will be opened.

__c. Click Browse and select
<LabFiles60>\PrepareProcessForWID\Solution\ProcessScenarioWID.zip as source zip file.

___d. Click Select All and click Finish.

+4% Import Project Interchange Contents

Import Projects

Import Projects from a zip file.

1=

Fram zip File: IC:'I,LabFiIesED'l,F‘repareF‘ru:u:essFu:urWID'I,Su:quti-:un'l,F‘ru:uje j !Brnwse...l

Project location rook: IC:'I,LaI:uFiIesEuEl'l,F‘repareF‘ru:u:essFu:ur'-.-'-.-'ID'l,wcurkspace'-.-'-.-'ID Browse. .. |

l=FProjectScenario
[=FProjectscenarioLibrary

Deselect all | Select Referenced

< Back Mext = | Einish I Cancel
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