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What this exercise is about 

The objective of this lab is to provide you with an understanding of the WebSphere® Adapter for Email and 
inbound event processing. In this lab you will install and deploy the WebSphere Adapter for Email and 
create an SCA application that polls for and processes inbound events from the file system 

Lab Requirements 

List of system and software required for the student to complete the lab. 

• WebSphere Integration Developer V6.0.2 installed 

• WebSphere Process Server V6.0 Test Environment installed 

• WebSphere Adapter for Email V6.0.2 installed 

• Unzip LabFiles602.zip to your C:\ (your root) drive 

• Complete WPIv602_AdapterInstallEmailServer lab successfully 
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What you should be able to do 

At the end of this lab you should be able to: 

• Import Email adapter RAR file into WebSphere Integration Developer 

• Use WebSphere Process Server administrative console to create required JDBC provider and a Data 
source under it 

• Use ESD wizard to configure the Activation Spec Properties Resource Adapter Properties to generate 
Business Objects and other artifacts 

• Deploy the adapter application onto the WebSphere Process Server test environment 

• Test the above deployed application using WebSphere Process Server test environment  

• Restore server configuration 
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Introduction 

 

The E-mail RA interacts with the mail server using JavaMail™ API that handles the underlying SMTP and 
IMAP/POP3 protocols. The adapter supplies the necessary parameters required by JavaMail to 
communicate to the mail server. 

The E-mail RA polls on the PollFolders for that user on the specified mail server at regular intervals, and 
picks up all the unread mails as events. You can specify multiple e-mail folders for a user’s mail account 
within the PollFolders property. The multiple e-mail folders are then polled sequentially in the same poll 
cycle. Optionally, you can specify search criteria to pick up event mails and when search criteria is 
specified, all unread mails meeting the search criteria, will be picked up for polling. When no search criteria 
are specified, all unread mails are picked up by default.  
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The E-mail RA writes all the polled mails to the InProgress file -folder, as files saved in the RFC822 format. 
The name of the RFC822 format file will be the Message_ID of the polled e-mail. The E-mail RA 
transforms the mail to an E-mail business object and delivers the same to configured endpoint. The event 
management framework takes care of delivering the event only once to the endpoint. 

The contents of each e-mail will be parsed into an EmailRecord object. The EmailRecord will be routed 
through the Function Selector to the Email-specific data-binding. The E-mail-specific data-binding will be 
aware of the structure of the E-mail business object. It will parse the EmailRecord structure, and route the 
content of the mail and the attachments to the mime-specific data-bindings, according to their mime-types. 
It would then receive back the parsed structures and combine them back into the E-mail business object, 
and send it out to the configured endpoint.  

The Email Event Database is part of the Event Persistence Framework. The event persistence feature 
ensures that the event is delivered to the end point once and only once. 

Once the mail is read and stored in the InProgress folder, it is deleted from the mail server (per the POP3 
specifications). Once a mail is processed, the mail is explicitly marked as deleted on the Mail Server (per 
the IMAP specifications). The mail will be archived or deleted from the InProgress folder. The archiving is 
based on the values for the properties ArchiveFolder and the FailedEventsFolder.  

If the ArchiveFolder is specified, the successfully processed mails are moved into the ArchiveFolder from 
the InProgressFolder. If blank, then the successfully processed mails are just deleted from the 
InProgressFolder.  

If the FailedEventsFolder is specified, the mails that failed processing are moved into the 
FailedEventsFolder from the InProgressFolder. If blank, then the failed mails are just deleted from the 
InProgressFolder.  

If you specify multiple event folders separated by commas in the PollFolders property, the RA will create 
folders with the same name as the poll folder, under the user-specified ArchiveFolder and the 
FailedEventsFolders, and archives corresponding event files in these folders. 

 

Exercise Instructions 

Some instructions in this lab may be Windows® operating-system specific.  If you plan on running the lab 
on an operating-system other than Windows, you will need to run the appropriate commands, and use 
appropriate files ( .sh vs. .bat) for your operating system.  The directory locations are specified in the lab 
instructions using symbolic references, as follows: 
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Reference Variable Windows Location AIX®/UNIX® Location 

<WID_HOME> C:\Program Files\IBM\ID\6.0  

<WPS_HOME> <WID_HOME>\runtimes/bi_v6  

<EMAILADAPTER_HOME> C:\Program 
Files\IBM\ResourceAdapters\Email\adapter\Email 

 

<WORKSPACE> C:\LabFiles602\EmailInbound\workspace  

<LAB_FILES> C:\Labfiles602 /tmp/Labfiles602 

<INPROGRESS> <LAB_FILES>\EMailInbound\InProgress  

<ARCHIVE> <LAB_FILES>\EMailInbound\Archive  

<TEMP> C:\temp /tmp 

Windows users note : When directory locations are passed as parameters to a Java program such as 
EJBdeploy or wsadmin, it is necessary to replace the backslashes with forward slashes to follow the Java 
convention. For example, C:\LabFiles60\ would be replaced by C:/LabFiles60/ 
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Part 1: Create Database in Cloudscape 

This part of the lab, describes the steps for creating the EMAILDATABASE  database in Cloudscape which 
will contain the Event Distribution Table, EMAILTABLE .  The EMAILTABLE  will be created automatically 
for you during the install and deployment of the application containing the E-mail adapter to the 
WebSphere Process Server. 

____ 1. Start the Cloudscape Cview Graphical User Interface (GUI) by executing the cview.bat  file 

__ a. Open a command prompt window and change directories to 
<WPS_HOME>\cloudscape\bin\embedded 

 

__ b. Type cview.bat  

 

__ c. The Cview window will be opened. From that window, select File > New > Database… . 
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__ d. Enter EMAILDATABASE  in the Name field and click OK. 

 

__ e. You will see the EMAILDATABASE  created in the left pane of the Cview window. Now select 
File > Exit  to close the Cview GUI 
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Part 2: Initialize workspace and Import RAR into We bSphere Integration 
Developer  

____ 1. Start the WebSphere Integration Developer V6.0.2 with a new workspace 

__ a. Select Start > Programs > IBM WebSphere > Integration Deve loper V6.0.2 > WebSphere 
Integration Developer V6.0.2  

__ b. From the Workspace Launcher window, enter <WORKSPACE>  for the Workspace field 

 

__ c. Click on the  button on the right hand corner to close the Welcome page and proceed with 
the workbench 
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____ 2. Import the E-mail Adapter RAR file 

__ a. From main menu, select File > Import…  

 

__ b. Select RAR file  from the Import window and then click Next  
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__ c. Click on the Browse…  button next to the Connector file field to select 
<EMAILADAPTER_HOME>\deploy\CWYEM_EMail.rar  

__ d. Uncheck the check box next to Add module to and EAR  project  and click Finish  

 

__ e. Click on No from Confirm Perspective Switch window to continue with the Business Integration 
perspective 
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Part 3: Use WebSphere Process Server Administrative  Console to 
Configure Data Sources 

In this part of the lab, you will make use of WebSphere Process Server Administrative Console to create 
the required JDBC Provider and the Data source that will be used by the Adapter to configure itself to the 
end point. 

____ 1. Start the WebSphere Process Server 

__ a. Select Servers view 

__ b. Right-click on the row that contains WebSphere Process Server v6.0 and select Start  from the 
context menu 

 

__ c. Wait until the test server status shows Started  

____ 2. Right-click on the row that contains WebSphere Process Server v6.0 and select Run 
administrative console  from the context menu 

 

____ 3. From the Administrative Console, enter any User ID  and click on Log In . 
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____ 4. On the left pane expand Resources  and select JDBC Providers  

 

____ 5. Accept the default scope and click on New 

____ 6. In the next screen, for the General Properties, select the these values from the dropdown list: 

__ a. Step 1: Cloudscape  

__ b. Step 2: Cloudscape JDBC Provider  

__ c. Step 3: XA data source  

____ 7. Click Next  
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____ 8. Enter Cloudscape JDBC Provider (XA) for EMail  in the Name field and then click OK 

 

____ 9. Click Save on the top of the window, and then click on Save from the following screen 

____ 10. Click Cloudscape JDBC Provider (XA) for EMail  from the following screen 

____ 11. Select Data Sources  under Additional Properties  on the right hand side 

 

____ 12. Create the required JNDI Data source 

__ a. Click New 

__ b. Enter the these values: 

a) Name: Cloudscape JDBC Driver XA DataSource for EMail  

b) JNDI Name: jdbc/Cloudscape JDBC Driver XA DataSource for EMail  

c) Database name: EMAILDATABASE  
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__ c. Click OK 

 



© Copyright IBM Corporation 2007. All rights reserved 

IBM WEBSPHERE ADAPTER 6.0.2 – LAB EXERCISE 

2007 January, 03 IBM WebSphere Adapter 6.0.2 – Lab Exercise Page 16 of 38 

 Email Adapter Inbound Lab 

____ 13. Click on Save and then Save from the next screen 

____ 14. Test the Data source connection 

__ a. Check the box next to Cloudscape JDBC Driver XA DataSource  for EMail  and click on Test 
connection  from the top of the screen 

 

__ b. You should see this success message on the top of the screen: 
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Part 4: Use Enterprise Service Discovery Wizard to Generate Business 
Objects and other Artifacts 

____ 1.  Launch the Enterprise Service Discovery wizard 

__ a. From the top Menu bar, select File > New > Enterprise Service Discovery  

 

____ 2. Select IBM WebSphere Adapter for Email (version 6.0.2) fro m the ‘CWYFT_EMail’ Connector 
Project  and click Next  

 

____ 3. Configure settings for the Discovery agent 

You will specify the properties to initialize the Resource Adapter and Enterprise Service Discovery agent. 
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__ a. Unzip the XSDs.zip  file under <EMAILADAPTER_HOME>\Samples . You will now see a XSDs 
folder under <EMAILADAPTER_HOME>\Samples 

__ b. Click on the Browse…  button next to the Folder Name  field and select the folder 
<EMAILADAPTER_HOME>\Samples\XSDs , that contains the Wbiaddress and Wbiphone  
XSD files 

Note : For your convenience, Wbiaddress  and Wbiphone  xsd files are placed under 
<LAB_FILES>\EmailFiles        

__ c. Select US-ASCII from the drop down list for the Character Set  field 

__ d. Select text/xml  for the Content Type  field. Once the content type is selected, the DataBinding 
Type  field will be automatically set to XMLBOSerializerDataBinding  
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__ e. Click the Show Advanced >>  button to see the Log file location and Logging level options for 
the discovery log and then click Next  leaving the default log file location 

 

____ 4. To Find and Discover the enterprise services, you will select the business objects and services to be 
used with the adapter 
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__ a. From the Enterprise Service Discovery window, click on Run Query  button. You will see a 
Wbiaddress  and Wbiphone  business object under Objects discovered by query  

 

__ b. Select Wbiaddress  business object and click Add to import list  button. The Wbiaddress 
business object will now be displayed under the Objects to be imported  

__ c. Repeat the above step to add Wbiphone  business object 
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__ d. You should now see the two business objects – Wbiaddress and Wbiphone under Objects to be 
imported area 

 

__ e. Click Next  

____ 5. Configure the objects that will be imported by the discovery agent 

__ a. From the Configure objects window, select Inbound  from the dropdown list for the Service Type 
field. Note the operations available for the selected Service Type 
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__ b. Enter the BO Location  as EMailInBO  and click Next  

 

____ 6. Specify the properties for the artifacts that will be generated in your workspace 

__ a. Create a new module 

1) Click on the New… button next to the Module  field 

2) From the New Integration Project window, ensure that the radio button next to Create a 
module project  is selected and click Next  
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3) Enter EMailInboundModule  for the Module Name field and click Finish  

 

__ b. The module which is created above will appear in the Module  field of the Generate Artifacts 
window 

__ c. From Generate Artifacts window, select the radio button next to Use discovered connection 
properties . This will make the Activation Spec Properties and Resource Adapter Properties 
visible 

__ d. Enter the these values for Event Persistence Properties  of Activation Spec Properties: 

1) EPDataSourceJNDIName: jdbc/Cloudscape JDBC Driver XA DataSource for EMail  

2) EPEventTableName: EMAILTABLE  

3) EPDatabaseSchemaName: EMAILTABLE  
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__ e. For Inbound Connection Properties, enter these values: 
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Note : You will use the configured details of the WPIv602_AdapterInstallEmailServer  lab for the following 
step. 

1) HostName: localhost  (default) 

2) PortNumber: 110 (the port number on which your selected protocol, POP3/IMAP, runs) 

3) Protocol: POP3 (from drop down menu) 

Note : You can select IMAP also from the dropdown menu for the Protocol. For the IMAP selection you can 
specify multiple PollFolders from where the E-mail RA polls events. 

4) UserName: <user>@<domain_name>  (Ex: Emailuser1@aimcp3x4.rchland.ibm.com) 

5) Password: <password for the user> (Ex: password1) 

6) PollFolder(s): Inbox  (Inbox is the default folder from where E-mail RA polls the events, you 
can also give different folder ) 

Note : If the selected Protocol is IMAP, you can enter multiple number of Poll folders separated by the 
delimiter “,” (comma). 

7) InProgress Folder:  <INPROGRESS> 

8) Archive Folder: <ARCHIVE> 

__ f. For Resource Adapter Properties you can enter these values: 

1) Log file name [String]: C:\EMailRA\Inlog.txt  

2) Trace file name[String]: C:\EMailRA\Intrace.txt  
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__ g. Click Finish  

____ 7. Create a Java Component and wire it to the EMailInboundInterface  

__ a. From the Business Integration perspective, expand the EMailInboundModule  folder 
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__ b. Double-click the EMailInboundModule  module to open it in Assembly editor 

 

__ c. From the palette, click the Component (with no implementation type)  icon, and select Java 
component icon from the popup menu and then click in the Assembly Diagram’s empty space to 
drop it there 

 

__ d. Wire the EmailInboundInterface to the Java Component.  

1) Select the wire  icon from the palette. 
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2) Click on EmailInboundInterface  and then click on Component1  to wire them together. 

 

3) Click OK on the Add Wire popup window 

 

4) Click on the Selection Tool  to get back to the normal cursor mode 

 

__ e. Right-click on Component1  and select Generate Implementation  from the context menu 

 

__ f. Select default package  from the Generate Implementation window and click OK 

__ g. Component1Impl.java  will be opened in Assembly editor. Scroll down to the method 
emitEmail(DataObject emitEmailInput ) method and enter this code: 
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System.out.println("*** REACHED END POINT***"); 

 

__ h. Save (Ctrl + S ) and close the Component1Impl.java  window 

__ i. Save (Ctrl +S ) and close the Assembly Diagram: EMailInboundModule  

____ 8. You can also configure/change the adapter properties using Assembly Editor 

__ a. Change to Business Integration perspective if you are in a different perspective 

1) Select Window > Open Perspective > Other… . 

 

2) From the Select Perspective window, select Business Integration (default)  and click OK. 

 

__ b. Expand EMailInboundModule  and double-click EMailInboundModule to open it in Assembly 
Editor 

__ c. Click on EMailInboundInterface  from the Assembly Editor and select Properties  tab from the 
bottom 

__ d. Select Binding  under Properties and select Endpoint Configuration  under Binding itself and 
then select the Connection  tab



© Copyright IBM Corporation 2007. All rights reserved 

IBM WEBSPHERE ADAPTER 6.0.2 – LAB EXERCISE 

2007 January, 03 IBM WebSphere Adapter 6.0.2 – Lab Exercise Page 30 of 38 

 Email Adapter Inbound Lab 

Ensure the radio button next to Specify properties for pre-configured new J2EE Conn ector 
Architecture recourse  is selected and then click on Activation Spec Properties  to expand 
them. You can change these properties, which you entered using the ESD wizard in the previous 
steps, and make sure that you save those changes before you deploy the application onto the 
server 
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__ e. You can also select Resource Adapter tab and review/change those properties 

 



© Copyright IBM Corporation 2007. All rights reserved 

IBM WEBSPHERE ADAPTER 6.0.2 – LAB EXERCISE 

2007 January, 03 IBM WebSphere Adapter 6.0.2 – Lab Exercise Page 32 of 38 

 Email Adapter Inbound Lab 

Part 5: Test the Adapter Application using  WebSphe re Process Server 
Test Environment 

In this part of the lab, you will use the WebSphere Process Server Test Environment to test the SCA 
application outbound processing. 

____ 1. Create events to be polled by the adapter 

__ a. Unzip EmailEventCreator.zip  from <EMAILADAPTER_HOME>\Samples the same directory. 
You will see a EmailEventCreator folder, that contains the createEvents.bat  file along with other 
sample batch files, under the Samples directory 

Note : For your convenience, createEvents.bat  file is also placed under 
<LAB_FILES>\EmailEventCreater  folder. 

__ b. Edit the createEvents.bat  file to specify the appropriate parameters and save those changes 

createEvents.bat  file has the following structure: 

<host> <port> <number of events to be created> <from> <to> <cc> <bcc> <subject> 
<content> <path for event filename> <Boolean for passthrough/nonpassthrough> 

where,  

Path for event file name - is the path on the local folder where the event file attachment has 
been placed. 

Boolean for pass-through/non-pass-through – has true or false values. True  indicates pass-
through and False  indicates non-pass-through. 

1) Pass-through mode: 

a) Edit the createEvents.bat file as shown below to create 10 events from the user 
Emailuser2@aimcp3x4.rchland.ibm.com on the localhost mail server to the inbox 
of the user Emailuser1@aimcp3x4.rchland.ibm.com with the file Inboundtest.txt as 
an attachment. You can also add cc, bcc, subject, content as shown below: 

java -cp .\;.\mail.jar;.\activation.jar EmailEventCreator localhost 25 10 
Emailuser2@aimcp3x4.rchland.ibm.com Emailuser1@aimcp3x4.rchland.ibm.com  
Emailuser3@aimcp3x4.rchland.ibm.com  Emailuser4@aimcp3x4.rchland.ibm.com 
"Test mail" "Testing PassThrough Content" "<LABFILES>\Inboundtest.txt" true  

b) Save (Ctrl +S ) and close createEvents.bat  file 

c) Double-click createEvents.bat  file to create 10 events in the inbox, with txt file as 
an attachment 

2) Non-pass-through mode: 

a) Edit the createEvents.bat file as shown below to create 10 events from the user 
Emailuser2@aimcp3x4.rchland.ibm.com on the localhost mail server to the inbox 
of the user Emailuser1@aimcp3x4.rchland.ibm.com with the file MyAddress.xml as 
an attachment. You can also add cc, bcc, subject, content as shown below: 

java -cp .\;.\mail.jar;.\activation.jar EmailEventCreator localhost 25 10 
Emailuser2@aimcp3x4.rchland.ibm.com Emailuser1@aimcp3x4.rchland.ibm.com  
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Emailuser3@aimcp3x4.rchland.ibm.com  Emailuser4@aimcp3x4.rchland.ibm.com 
"Test mail" "Testing XML Content" "<LABFILES>\Address.xml" false  

b) Save (Ctrl +S ) and close createEvents.bat  file 

c) Double-click createEvents.bat  file to create 10 more events in the inbox, with xml 
file as an attachment 

Note : For your convenience, createEvents_sample_passthrough  and 
createEvents_sample_nonpassthrough  batch files are placed at <LAB_FILES>\EmailEventCreator 
which creates the above mentioned events. 

__ c. You can configure your mail client and use it to verify the above created events 

____ 2. Add the project to the WebSphere Process Server Test Environment 

__ a. Right-click on WebSphere Process Server v6.0  under the server view and select Add and 
remove projects…  from the context menu 
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__ b. From the Add and Remove Projects window, select EMailInboundModuleApp  under Available 
projects panel and click Add >  

 

__ c. You will now see the EMailInboundModuleApp  added to the Configured projects  

 

__ d. Click Finish . Wait until the project is being published onto the server. The server will be started 
in Debug mode if it is not already started before 

__ e. The application will be started along and so does the polling 

____ 3. Verify the results 
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__ a. Check the <INPROGRESS> folder as soon as the adapter starts polling. E-mail RA polls the 
events from the inbox and places them in <INPROGRESS>. Quickly, the files will be moved to 
<ARCHIVE> folder from there 

You might not see any events in <INPROGRESS> folder after they are moved to Archive folder 

__ b. An INBOX folder will be created under <ARCHIVE> directory that contains the 20 events 

__ c. Each file will be the Message_ID appended with Administrator@localhost 
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Part 6: Restore Server Configuration 

____ 1. Right-click on WebSphere Process Server v6.0  under the Servers view and select Add and 
remove projects…  from the context menu 

 

____ 2. Select EMailInboundModuleApp  under Configured projects and click < Remove  

 

____ 3. Click Finish  after you see the application moved to Available projects. Wait until the application is 
unpublished 
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____ 4. Right-click on WebSphere Process Server v6.0  from the Servers view and select Stop  from the 
context menu 
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What you did in this exercise 

In this lab, you created the database in Cloudscape required for this lab. You continued with importing the 
E-mail Adapter RAR file into your WebSphere Integration Developer workspace. Then, used your 
WebSphere Process Server administrator console and configured it to create the Data source required to 
complete this lab. 

You made use of Enterprise Service Wizard available in WebSphere Integration Developer to specify 
Activation Spec Properties and Resource Adapter Properties which, after deploying onto the server will 
generate Business Objects and other artifacts.  

In the end you deployed and then tested the adapter application and restored the server configuration. 


