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This session discusses the Default Configuration Wizard. 
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IntroductionIntroduction

Section

The Default Configuration Wizard is a basic configuration usually created immediately 
after installation. It enables you to become familiar with the Version 6 product very quickly. 
It is mandatory, if you want to install and deploy any of the IBM-supplied sample Broker 
applications.



3_Default_Configuration.ppt Page 3 of 16

IBM Software Group

3
Message Broker Version 6 – Default Configuration © 2006 IBM Corporation

Overview

� Wizards – part of the ToolKit

� Launched through Eclipse 
�From Help

�From WorkBench: File->New menu

� Sets up a standard local Configuration with
�Queue Manager with queues, listener, channels

�Database with ODBC connection

�Configuration Manager

�Broker

The Default Configuration Wizard is accessed through the normal Message Broker Toolkit, 
launched through Eclipse. 

The Wizard sets up a standard, local configuration, which contains all the basic functions 
needed to develop and run the majority of functions available within the Broker. It 
therefore creates an MQ Queue Manager, along with all necessary queues, channels, 
and listeners required by the default Broker. It creates a local database with the 
necessary ODBC connection. It then creates a Configuration Manager and a Broker 
which use the underlying Queue Manager and database.

All required connections are created, enabling the Toolkit to connect to the Configuration 
Manager, and hence to the runtime Broker.
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Invoking the Default Configuration Wizard

� The Default Configuration Wizard may be invoked in the following ways:
�File > New > Other (‘Alt+Shift+N’, Other)

� Broker Administration – Getting Started Components
– Create the Default Configuration

– Remove the Default Configuration

�Help > Help Contents
� V6.0 WebSphere Message Broker (or Event Broker)

– Create a default configuration of WebSphere Message Brokers

�Getting Started on the Welcome page (Help > Welcome)

� Sample Preparation Wizard
�May be invoked from the Default Configuration Wizard

�The samples use the Default Configuration

There are various ways to invoke the Default Configuration Wizard. 

The first way uses the standard Eclipse convention of File, New, Other, and selecting the 
appropriate choice. Note that the combination of “File, New”, done with the mouse, can 
also be accomplished by using the keyboard combination of “Alt+Shift+N”, followed by 
“Other”. This technique also works when creating any other new artifact in the 
Message Broker Toolkit.

At this point, you can either create a new configuration, or remove one that has already 
been created.

The same wizard can be accessed from the Help button at the top of the Message Broker 
Toolkit or by selecting Getting Started from the Welcome page.

The samples depend on the Default Configuration; if you attempt to install or deploy any of 
the supplied samples, without having first created the Default Configuration, you will be 
taken straight to the appropriate point to create this.

Immediately after starting the Version 6 Toolkit for the first time, you will be presented with 
an option to create the Default Configuration. You will not have to perform any explicit 
action (for example, File, New) to start this dialogue.



3_Default_Configuration.ppt Page 5 of 16

IBM Software Group

5
Message Broker Version 6 – Default Configuration © 2006 IBM Corporation

This screen capture shows the Welcome screen in the Message Broker Toolkit. On first 
entry to the Toolkit, the Welcome page is displayed; alternatively, you may open it by 
selecting Help > Welcome.   Selecting the “Getting Started” icon will take you to a second 
screen where you can make specific selections about the Default Configuration. This is 
shown on the next slide.
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This is shown when you select the “Getting Started” icon. Here, you can create the Default 
Configuration, or simply go straight to a simple Broker application, the Pager sample.
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The Default Configuration The Default Configuration –– progress screensprogress screens

Section

The following screens show the main windows that are shown during execution of the 
Default Configuration Wizard.
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This screen shows the basic tasks that the Wizard will perform. It shows the user ID that 
you are currently using, and reminds you that, if using Windows®,  this user must be a 
member of the Administrators group. If using Linux®, the user ID must be a member of 
“mqm” and “mqbrks”.

You can select which of the available Broker installations are to be used for this 
Configuration. If you only had one installation, this selection box will be unavailable.

Should you happen to have more than one DB2® instance available, you can select which 
one you need by using the pull-down box. In this example, there is only one DB2 instance, 
so the DB2 selection is unavailable.

After typing your password, click Next to progress to the next screen.
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This screen simply shows extra information about what is going to be installed and created 
by the Wizard.

In the window near the top, it gives information about where the logs will be placed. You 
will see that the log file is called DefaultConfigurationWizard.log.

It also describes where the workspace is located, gives the names of the Queue Manager, 
the names of the databases that it will create, the name of the Broker, and the name of the 
Configuration Manager. These names are all fixed, and you cannot change these names.

The same names are used across all national languages.

Clicking on “Open Log File” allows you to look at the content of the logfile. It is very rare 
for anything to have failed at this early stage.
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This screen shows where the real work starts. A number of verification checks are 
performed first. If these are successful, then the Wizard proceeds to create each item in 
turn.

If the Wizard does not find an instance of DB2 that it can use, then it will change to using 
Cloudscape, the internal database shipped with the Broker.

However, on Linux, to create the Default Configuration, you will need DB2.

Finally, when every component has been successfully created, the screen will show a 
color version of the created configuration. At this point, you can either click Finish to exit 
immediately, or select the option to move on to the creation of specific samples, using the 
Samples wizard.

When you click Finish, assuming you have entered into the wizard from the Toolkit, then a 
new pane will appear on the Toolkit in the Administration perspective, showing the new 
configuration that you have just created. This will show the new Broker Topology, and the 
new Broker itself.

It is not possible to create more than one instance of the Default Configuration. The 
presence of all components of the Default Configuration is checked early in the process of 
the wizard, and the process will stop if any component is detected to be present.
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In the event of a failure of the Default Configuration Wizard, a pop-up window will appear, 
as shown on this screen. This will give you the option of fixing the problem, if you know 
what it is, or of backing out of the Default Configuration process completely. If you select 
“No”, then the process will move on to the next screen, and remove all traces of the 
Default Configuration.
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In this case, the example shows that the creation of the Default Configuration has failed at 
the stage of creating the Broker. When a failure happens, all stages up to that point will be 
backed out. You can see in this case that the Configuration Manager, which had been 
successfully created, is now being deleted.

Note that the process will attempt to create the broker twice, in case of a transient 
problem.
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Platform differences

�Database
�Linux: Choice of DB2 instance on first page

�Windows: uses mqsicreatedb command

�Services
�Linux: all start/stop is manual

�Windows: auto-start services for broker and qmgr

There are some minor differences between the Windows and Linux platforms. For the 
database, the process of selecting the DB2 instance is slightly different, and on Windows 
this uses the “mqsicreatedb” command.

When creating the Start/Stop services, these are created as auto-start on Windows, but on 
Linux they have to be started manually. This applies to the Queue Manager and to the 
Broker components.
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DebuggingDebugging

Section

This section addresses resolving problems with the Default Configuration.
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Debugging – Basics

� Try Remove Configuration Wizard first to 
eliminate left-overs

� Logs
�DefaultConfigurationWizard.log

� In workspace’s .metadata directory, like .log

� User problems, wizard working as designed

�.log
� As for any other general Toolkit problems.

� Java™ exceptions, other wizard malfunctions

� Trace

Occasionally, problems may arise with creation of the Default Configuration.  If this does 
happen, there are a number of activities that you can try to correct the problem.

The first thing to do is attempt to remove the Default Configuration. Do this by using the 
options provided in the Toolkit. If this is successful, start the creation process again.

If this does not work, the next place to look is the DefaultConfigurationWizard.log file. This 
is where all the errors will be recorded. For example, a failure in each of the stages of 
the Wizard will be recorded here, together with the reasons for the failure.

If this log file does not resolve the problem, look in the “.log” file, in the same directory. 
This contains more general errors, and is not restricted to just the Default Configuration 
Wizard. This will also include problems in any Message Broker internal code.

Finally, as a last resort, the Toolkit provides a trace capability. This is described on the 
next slide.
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Debugging –Trace

�Enable Eclipse trace capabilities
�Window > Preferences > Workbench > Capabilities

� Tester > Profiling and Logging

�Window > Preferences > Broker Administration
� Trace

� Configuration Manager Proxy

�Window > Preferences > Logging

The Eclipse Toolkit provides a powerful trace facility. This is enabled through the Broker 
Toolkit itself, by using the mouse sequence shown on the slide.

When you reach “Capabilities”, select “Tester”, then “Profile and Logging”, and click to 
enable this option.

For problems that may involve communication with the Configuration Manager, select the 
further options shown under “Broker Administration”, namely Trace and “Configuration 
Manager Proxy”.
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Debugging – How to interpret the 
documentation

DefaultConfigurationWizard.log

+++++++++++++++++++++++++++++++++++ task trace +++++++++++++++++++++++++++++++++++++++++++++

TIMESTAMP [Fri Sep 16 15:14:11 BST 2005]

Deleting the database [DEFBKDB6] for the default broker [WBRK6_DEFAULT_BROKER] .

The above task succeeded

Collected output from task >

Stdout: [16/09/2005 15:14:05     0   0   SQL1026N  The data base manager is already active.

SQL1026N  The database manager is already active.

DB20000I  The TERMINATE command completed successfu lly.

DB20000I  The DROP DATABASE command completed succe ssfully.

DB20000I  The TERMINATE command completed successfu lly.

MQSI_WIZ_DROP_DB_SUCCESS]

Stderr: []

The content of the DefaultConfigurationWizard.log file is intended to be self-explanatory, 
since it is expected that you should be able to resolve any issues yourself.

The example in this slide show the status messages of the DB2 database connection, and 
the DB2 commands that are issued to create the Default Configuration.
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