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What this exercise is about 

In this tutorial, you will use the Management Center Catalog and Asset tools to update the store catalog. 
You will use many of the new Management Center enhancements including SKU generation, creating 
many-to-many merchandising associations and moving sales catalog categories. 

This tutorial should take approximately 90 min to complete. 

What you should be able to do 

After completing this exercise, you should be able to: 

• Upload categories and entries in Management Center 

• Import images from a compressed file 

• Automatically generate SKUs 

• Create many-to-many merchandising associations 

• Move a sales category from one parent to another parent 

Introduction 

The following naming conventions are used in the exercises: 

Reference Variable Description 

<WCDE_INSTALL_DIR> C:\IBM\WCDE_ENT70 

<WCDE_HOST> Hostname for WebSphere Commerce Developer 
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Part 1: Set the inventory system to Non-ATP 

In this part of the lab, you will prepare your system to upload the sample catalogs. The sample data load file 
requires a non-ATP inventory system so you will update the Madisons store to be non-ATP. 

____ 1. Update the inventory system for the Madisons store. 

__ a. Open WebSphere Commerce Developer and start your test server. 

__ b. Open a browser window and go to https://localhost/webapp/wcs/admin/servlet/db.jsp 

__ c. Enter the SQL below to set the inventory system for the Madisons storefront asset store to non-
ATP. 

update STORE set INVENTORYSYSTEM=-2 where STORE_ID in (select
 
STOREENT_ID from STOREENT where IDENTIFIER = 'Madisons');
 

__ d. Click Submit Query.
 

__ e. Restart your WebSphere Commerce test server.
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Part 2: Upload Catalog data 

In this part of the lab, you will upload catalog groups and entries to the Madisons store catalog. 

Note: You must use Internet Explorer to complete this part. File upload is not working with Firefox. 

____ 1. Open the hints and tips page at <WCDE_INSTALL_DIR>\hintsandtips.html. 

____ 2. Launch the Madisons store. 

__ a. Navigate through the various sales catalog categories and keep it open for comparison. 

____ 3. Launch the Management Center using the link provided in the Useful URLs section. 

____ 4. Open the Catalogs tool. 

____ 5. In the tool bar, select New > Catalog Upload 

2010 June, 17 WebSphere Commerce 7 Feature Pack 1 – Lab exercise Page 4 of 29 

Catalog enhancements 



        

                                                                           

    

           

          
       

                   

      

 

                 

            

 

 

 

© Copyright IBM Corporation 2010. All rights reserved 

____ 6. Uploading new catalog groups to the Madisons Master Catalog. 

__ a. In the Main Properties section, browse to <WCDE_INSTALL_DIR>\samples\DataLoad\Catalog\ 
directory and select to upload the CatalogGroups.csv. 

__ b. The rest of the fields should be pre-filled. Select Madisons as your Target catalog. 

__ c. Click Save and Close. 

____ 7. In the explorer pane, click Catalog Uploads to see the status of your latest upload. 

__ a. Click the entry to see a full status. 
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____ 8. See the results of upload. 

__ a. Go to Master Catalog Categories. 

__ b. Reload your Catalog Categories by clicking on the Refresh button. You should see Mens 
Fashions and Womens Fashions categories appear. 

____ 9. Upload Catalog entries into the new Mens Fashions and Womens Fashions Categories 

__ a. Repeat step 6 – 8 with CatalogEntries.csv and CatalogEntries2.csv. Upload these entries to 
the Madisons. 

You should find this file in the same location 
(<WCDE_INSTALL_DIR>\samples\DataLoad\Catalog\) as CatalogGroups.csv. 

__ b. Reload your Catalog Categories by clicking on the Refresh button. You should see several child 
categories and entries appear under the Mens Fashions and Womens Fashions categories. 
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Part 3: (Optional) Decrease wait time for file upload 

This part of the lab is optional. When you upload catalog images using the Assets tool in the next part there is 
a delay before the files are copied to the WebSphere Commerce EAR file. The length of the delay is 
configurable and is set to 60 minutes by default. You might want to shorten this time for the purpose of testing 
the catalog image upload. 

____ 1.	 Open the Information Center and navigate to Administering > Marketing > Catalog and 
marketing attachments > Changing managed file WebSphere Commerce EAR updater 
parameters 

____ 2.	 Select the update frequency you want for testing and update <workspace_dir>\wc\xml\config\wc­
server.xml according to the Information Center documentation. 

____ 3.	 Restart your test server. 
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Part 4: Import product images 

In this part of the lab, you will import the images for the new product you will create later. 

Note: You must use Internet Explorer to complete this part. File upload is not working with Firefox. 

____ 1. Open the hints and tips page at <WCDE_INSTALL_DIR>\hintsandtips.html. 

____ 2. Launch Management Center using the link provided in the Useful URLs section. 

____ 3. Open the Assets tool. 

____ 4.	 Select the Madisons store. If the Madisons store does not appear in the drop down store list, find it 
using the store search feature. 

__ a. Select Find Stores 
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__ b. Enter Madisons in the search field and click the binoculars. Select Madisons from the search 
results and click OK. 

____ 5. In the Navigation pane, right click Madisons and select New Directory. 
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____ 6. Name your new directory images and click Save and Close. 

____ 7. Create a new directory catalog under the images directory. Click Save and Close.
 

____ 8. Expand the Madisons folder and right click the new catalog folder.
 

____ 9. Select Create files from compressed file…
 

____ 10. Browse to <WCDE_INSTALL_DIR>\samples\catalogimport\ and select the file images.zip and click
 
Open. 

__ a. You should see a list of 26 images. 
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Part 5: Viewing uploaded data on store front 

In this part of the lab, you will verify the new product you created displays in the Madisons store. 

____ 1. Open the hints and tips page at <WCDE_INSTALL_DIR>\hintsandtips.html. 

____ 2. Launch the Madisons store. 

____ 3. Verify changes on the store front 

__ a. Navigate to the Men’s Fashions and Women’s Fashions category page. 

__ b. Verify that the entries you have added appear on the page. 

____ 4. You can try uploading other .csv files or creating your own. 
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Part 6: (Optional) Reset the wait time for file upload 

If you decreased the wait time for images to be created in the WebSphere Commerce EAR file in Part 1 you 
might want to reset the value when you finish testing. 
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Part 7: Add Defining Attributes 

In this section, you will take an existing product you just uploaded and define its attributes.
 

____ 1. Open the Catalogs tool and select the Madisons store.
 

____ 2. Expand the Madisons catalog from the Master Catalog Categories.
 

____ 3. Navigate to the Mens Fashions > Shirts > Dress Shirt product, and open the product by double
 
clicking or right click and select Open. 

____ 4. Set the product properties 

__ a. Expand the Pricing tab and set the offer price for the shirt as shown below. 

____ 5. Set the product attributes.
 

__ a. Switch to the Defining Attributes tab.
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__ b. Define the Color attribute with values Red, Green, and Blue as shown below and click Save 
and Close to go back to the Defining Attributes tab. 

__ c. Define a second attribute Size with values Small, Medium, and Large. 

__ d. Save and close the product. 
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Part 8: Generate SKUs 

In this part of the lab, you will generate SKUs for the product you defined in the previous part. The product has 
2 defining attributes: Color and Size. Each attribute has 3 possible values for a total of 9 SKUs. 

____ 1. Before you generate the new SKUs, you should delete the existing SKUs uploaded for this product. 

__ a. Select the new product in the Explorer view. Mark the product as Buyable and click Save. 

__ b. Right click the product and click show existing SKUs in the tool bar. 

__ c. Select both SKUs and delete. 
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____ 2. Select the product once more. Click Generate SKUs toolbar button. 

____ 3. The SKU list is populated with the new new SKUs. 

____ 4. Select Save All from the File menu to save the SKUs. 
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Part 9: Test generated SKUs 

In this part of the lab, you will verify the new product you created displays in the Madisons store.
 

____ 1. Launch the Madisons store from the hintsandtips.html.
 

____ 2. Navigate to Mens Fashions > Shirts category page.
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____ 3. Verify that the Dress shirt displays and that you can add a specific item to your shopping cart. 
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Part 10: Creating Many-to-Many Merchandising Associations 

In this part of the lab, you will associate all lamps to the desks in the Madisons store. 

____ 1. Launch the Madisons store using the hintsandtips.html page at 
<WCDE_INSTALL_DIR>\hintsandtips.html. 

__ a. Navigate to the Furniture > Desks product page. You should see 3 desks. 

__ b. Click any of these desks to see the current merchandising associations defined. 

____ 2. Launch Management Center and open Catalog tools. 

____ 3. Click New > Merchandising Associations 
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____ 4. Create many-to-many merchandising associations for all the desks. In the properties view, you see 
two tables to specify the catalog entries and target catalog entries. 

__ a. Open the Utilities View > Browse tab to navigate to the desks category. 

__ b. Drag and drop the 3 desks to the Catalog entries table 

__ c. Navigate to the Desk Lamps category. Drag and drop all 7 Desk Lamps to the Merchandising 
associations (target catalog entries) table. 
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__ d. Select all 7 Desk Lamps and click the Edit Column icon next to the Delete icon. 

__ e. Select the Association column to update, and set the association to Cross-sell. Click Apply 
then OK. 

__ f. Select the Association column to update, and set the association to Cross-sell. Click Apply 
then OK. 

__ g. Check the Remove existing merchandising associations from the Catalog entries box then 
click Save and Close. 

____ 5. Verify the associations you made in the explorer view. 

__ a. Navigate to the Madisons > Furniture > Desks, and verify that each of the 3 desks have cross-
sell merchandising associations with the 7 Desk Lamps. 
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____ 6. Verify the associations on the store front. 

__ a. Open the Madisons store URL again and navigate to the 3 desks. 

__ b. Click the desks to see the merchandising associations. Click the up and down arrows to see all 
the 7 desk lamps associated with the desks. 

__ 

____ 7. You can also delete merchandising associations
 

__ a. Right click a Desk and select Delete Merchandising Associations.
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__ b. On the dialog box, select the For the selected catalog entries, delete all associations. This 
removes all the desk lamps that the Desks reference. 

__ c. Click Refresh on the catalog entry to see your changes. 

____ 8. Test your changes on the Madisons store front. 
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Part 11: Move sales categories 

In this section, you will move child categories from one parent sales category to another to try out the new 
features in this driver. In this driver, you can now move any child category to a parent category as long as they 
both belong to the same Catalog. Moving child categories from one catalog to another will require the use of 
the Link feature (not covered in this lab). 

Note: All steps in this part are done in the Sales Catalog Categories, so make sure you are in this view before 
proceeding. 

____ 1. Open the Madisons store. Since you are making changes to the Madisons Sales Catalog, you 
need to find the Sales Catalog ID in order to view the changes. 

____ 2. Find the CATALOG_ID of the ‘Madisons Sales Catalog’ 

__ a. Open the database query page: https://localhost/webapp/wcs/admin/servlet/db.jsp 

select * from CATALOG;
 

__ b. Modify the Madisons store URL to point to your sales catalog. You can see the Information 
Center article to construct the URL: 
http://publib.boulder.ibm.com/infocenter/wchelp/v7r0m0/index.jsp?topic=/com.ibm.commerce.dev 
eloper.doc/refs/rcatopcat.htm 

____ 3. Verify changes on the store front 

__ a. After you find the Catalog ID of the Madisons Sales Catalog, go to the store front. (EX: 
http://localhost/webapp/wcs/stores/servlet/TopCategories_10051_10101 ) 

____ 4. Open the Madisons Sales Catalog store. 

__ a. Keep the URL open throughout this section to see your changes on the storefront. 

__ b. Navigate to the Oils and Accessories category. 

__ c. You will move this category in the next steps, so leave this open for comparison. 
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____ 5. Launch the Management Center and open Catalogs tool. 

____ 6. Open the Madisons store and view the Sales Catalog Categories. 

____ 7. Open the Oils and Accessories category. 

__ a. Scroll down to the Parents (sales catalog) section of the Manage Category tab. 

__ b. Using the Utility Pane, add the Coffee and Espresso Maker and Pots and Pans categories as 
the Parents. You can add by dragging the categories from the Utility Pane Browse tab to the 
Parents table. 

__ c. Delete the Madisons Sales Catalog as a parent by clicking on the icon 

__ d. Save the Oils and Accessories category changes by clicking on Save and Close. 

. 

__ e. You should see the Oils and Accessories category appear under both Coffee and Espresso 
Maker and the Pots and Pans categories. 
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__ f. Refresh the Madisons store to view the changes. 

__ g. Now you will remove the Oils and Accessories category from the Pots and Pans. 

1) Right click the Oils and Accessories category from the Pots and Pans parent category, 
and select Delete. 

2) You will see the options to Delete, Remove or Cancel. Select Remove. 

__ h. View your changes. 
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__ i. Next you are going to move the Oils and Accessories category from the Coffee and Espresso 
Maker parent category to the Pots and Pans category. 

1) Select the Oils and Accessories category from the properties view. Drag and drop it into 
the Mens Fashions category. 

2) Select Move when prompted. 

3) Click Save from the File menu. 

__ j. Refresh the Madisons store to see the move changes. 
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Part 12: What you did in this exercise 

In this tutorial you learned how to use the new enhancements to the Catalogs tool in Management Center. 

You should now understand how to complete these tasks: 

• Upload catalog data using the Catalogs tool in Management Center 

• Import images from a compressed file 

• Automatically generated SKUs for a product 

• Create and delete many-to-many merchandising associations 

• Move and delete child categories within the same sales catalog 
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