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What this exercise is about 

The objective of this lab is to show you how to use the KPI history and prediction widget. Since the KPI 
history service runs once per hour, it could take some time to build up enough history records for testing 
the widget. In this lab, you will preload the database with history records, then use the widget to view those 
records. You will create a KPI prediction model using the KPI Manager widget, then view the prediction 

based on data that exceeds a threshold which is defined on the prediction model. 
data. Also, you will configure a business user alert using the Alert Manager widget, and the alert will be 

Lab requirements 

List of system and software required for the student to complete the lab: 

•	 Rational Application Developer V7.5 or WebSphere Integration Developer V7.0. 

•	 WebSphere Business Monitor V7.0 – Toolkit Installation including the Monitor Model editor and 
Monitor Server 

What you should be able to do 

At the end of this lab you should be able to: 
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•	 Use the KPI history and prediction widget to view KPI historical information and KPI prediction 
information. 

Introduction 

In this lab you will load the KPI history table with approximately 52,000 records, approximately 3 years of 
data for each of two KPIs. You will load the records into the Derby database for use with the Monitor 
toolkit. 

After loading the database with the history records, you will deploy the monitor model. Then you will create 
a dashboard and use the KPI history and prediction widget. 

You will also create a prediction model and view the prediction values in the dashboard. 

Finally, you will create a business user alert when the KPI prediction values exceed a predefined
 
threshold.
 

URL Cheat sheet 

The following URLs may be helpful to you as you exercise this lab. Note that the port numbers in the URL 
of your installation may be different depending on your configuration. 

•	 Server administrative console 

https://localhost:9043/ibm/console 

•	 Business space dashboard 

https://localhost:9443/BusinessSpace 

2010 April, 06 IBM WebSphere Business Monitor 7.0 - Lab exercise	 Page 2 of 24 

KPI history and prediction 



        

               

     

          

           

              

          

                 

  

          

              

        

             

       
 

       

       

     

© Copyright IBM Corporation 2010. All rights reserved 

Part 1: Load the KPI history table with data 

To load the history data into Derby, use the following procedure. 

____ 1. Open the Monitor toolkit, pointing to a new workspace, for example c:\workspaces\KPIHistory 

____ 2. Stop the Monitor server in the servers view 

____ 3. Open the Data perspective using the icon in the upper right corner of the window 

____ 4. Create a new connection to the MONITOR database 

__ a. In the Data Source Explorer view, right click Databases, then click New 

__ b. Select Derby as the database manager 

__ c. For JDBC driver, select 'Derby 10.2 - Embedded JDBC Driver Default' 

__ d. For database location, browse to 
<WID_WTE_PATH>\runtimes\bi_v7\profiles\qmwps\databases\MONITOR 

__ e. For user name, enter 'user' 

__ f. Leave the password field empty
 

__ g. De-select 'Create database'
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__ h. Click 'Test Connection' button to verify the connection 

__ i. Click OK 

__ j. Click Finish 

__ k. You should see the Monitor database in the data source explorer 

____ 5. Load the supplied data into the Monitor KPI History table 

__ a. In the data source explorer, navigate to Databases > MONITOR > MONITOR > Schemas > 
MONITOR > Tables > KPI_HISTORY_T 

__ b. Right click KPI_HISTORY_T and select Data > Load... 
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__ c. For import file, browse to the supplied file load-KPI-history.data 

1) For example, browse to c:\Labfiles70\KPIHistory\load-KPI-history.data 

__ d. Use column delimiter Comma and character string delimiter ". De-select 'Replace existing data', 
which will preserve history data for any other models, such as the showcase model. 

__ e. Click Finish 

__ f. After a few minutes, in the SQL Results view you should see that the rows were loaded 

____ 6. Disconnect the connection to the MONITOR database 

__ a. In the data source explorer view, right click the MONITOR connection and select Disconnect 
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Part 2: Import the monitor model 

Import the supplied monitor model to the monitor toolkit. 

____ 1. Open the Business Monitoring perspective using the icon in the upper right corner of the window. 

____ 2. If it is not started, start the monitor server in the servers view. 

____ 3. Import the supplied project interchange file 

__ a. In the Project Explorer view, right click then select Import…
 

__ b. Navigate to Other > Project Interchange then click Next.
 

__ c. For the .zip file, browse to the supplied file, for example, c:\Labfiles70\KPIHistory\OrderItem
PI.zip 

__ d. You should see two projects listed, so click Select All. 

__ e. Click Finish. 

__ f. You should see two projects listed in the project explorer. 

__ g. Check for any errors in the Problems view. You should resolve any errors before continuing. 
Warnings and informational messages may be present but these will not be a problem. 

____ 4. Review the two KPIs in the model. 

__ a. In the Project Explorer, navigate to OrderItem > Monitor Models. Double click OrderItem.mm to 
open the monitor model editor. 

__ b. Click the KPI Model tab.
 

__ c. In the editor, navigate to Order Item > FunctionKPIs, then click Avg Order Price.
 

__ d. You see that the check box is selected for keeping track of KPI history.
 

__ e. It has a target and ranges, and colors have been selected for the ranges. These colors will show 
up on the KPI history widget in the dashboard. 

__ f. Notice also that the metric is Item Price and the function is Average, and no time period is 
selected. 

__ g. In the editor, navigate to Order Item > TimePeriodKPIs, then click Sum Price Today. 
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__ h. You see that the check box is selected for keeping track of KPI history. It has a target and 
ranges, and colors have been selected for the ranges. These colors will show up on the KPI 
history widget in the dashboard. Notice also that the metric is Item Price and the function is Sum. 
The time period metric is set to Date Ordered, and the time period is set to a repeating daily 
period. 
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Part 3: Publish the model to the server 

In this section you will use the toolkit to publish the monitor model to the monitor server. 

____ 1. In Project Explorer, expand OrderItem ���� Monitor models ���� OrderItem.mm. Right click over 
OrderItem.mm and then select Generate Monitor JEE Projects from the pop-up menu 

____ 2. Select Finish. 

____ 3. A progress dialog shows the status of the operation and it closes when the operation is complete. 
Check for errors in the Problems view. There may be warnings, but there should not be any errors. If 
you see errors, then try to perform a clean to see if the errors can be removed: Project > Clean… > 
select 'Clean all projects', then click OK. 

____ 4. If your server is not started, in the Servers tab, right click and select the Start option to start the 
server. This may take a few minutes to complete. 

____ 5. Right click in the servers view, then select Add and Remove Projects…. 

____ 6. Click Add to move the OrderItemApplication from the list of available projects to the list of 
configured projects. 

____ 7. Click Finish. 

____ 8. A progress message is displayed in the lower right corner of the window. 

____ 9. Check the messages in the console view. You should see the following message when the 
application has been started: 

Application started: OrderItemApplication 

____ 10. In the servers view, right click, then select Administration > Run administrative console. You 
should see it open in a separate tab. 

____ 11. It will prompt you for user ID and password. Enter 'admin' without the quotation marks for user ID, 
then enter 'admin' without the quotation marks for password. Click Log in 

____ 12. Click Applications > Monitor Models. The application should show green status if it started 
successfully. 

____ 13. If the model shows red (stopped), then wait a moment, then refresh by clicking on the icon to the 
right of Status in the last column of the table. You should see green (started) for the model. If it does 
not show green, be patient and keep refreshing until it does show green. 

____ 14. Check the server log to ensure there are no problems. You can check this in the console view. 

____ 15. If you are using the integrated server within WebSphere Integration Developer or Rational 
Application Developer, then you do not need to setup Monitor data security, since the administrative 
user is automatically authorized to all models. If you are using a different server, then you should 
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open the administrative console, navigate to Security > Monitor Data Security, then add the 
model, role and user information to a resource group. 
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Part 4: Create a dashboard in business space 

In this section you will build a dashboard in business space. You will add views to the dashboard and 
configure them. 

____ 1. Create the dashboard. 

__ a. The default browser is 'Internal Web Browser', but you should not use this one since some 
standard functions are not provided that you may need. Select Window > Preferences > General 
> Web browser > select 'Use external Web browser'. Select an external browser. Click OK. 

__ b. In WebSphere Integration Developer, in the servers view, right click and select Launch > 
Business Space 

__ c. When prompted, enter admin for the user ID and enter admin for the password. You must log in 
with 'admin' so that you can view the alerts which were setup in action manager to be sent to this 
particular user ID. Also, in the toolkit environment, this is the user ID that is automatically defined 
on the secured server. 

__ d. Click in the Actions menu to create a new space 

__ e. Enter a name such as Dashboard, and select the Business Monitoring template. 

__ f. Click Save. 
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Part 5: View KPI history information 

In this section you will use the KPI history widget to view KPI historical information. 

____ 1. Configure the KPI history and prediction widget. 

__ a. On the new space, click the Analysis tab. 

__ b. Click the 'Edit Page' link to enter edit mode.
 

__ c. To configure the KPI history and prediction widget, hover the mouse over the right corner of the
 

widget and then click the down arrow. Select 'Edit Settings…'. 

__ d. On the KPI tab, select 'Latest version', 'KPI ranges', 'KPI target' 

__ e. For the monitor model, navigate to OrderItem <timestamp> > Avg Order Price, then select it. 

__ f. Click OK. 

__ g. You can adjust the granularity and the date window on the widget. The default display is two 
months with daily data points. Initially the data display may be empty because historical data has 
been loaded for this KPI only from years 2008 through 2010. You should adjust the dates to 
display historical data within this date window. To change the date period, you can use the pre
set date windows such as 1D or YTD, or you can click the blue From and To dates to open a 
calendar picker to select specific dates. 
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__ h. The graph shows a line for the KPI value in blue. The black line is the target value. The three 
bands of color represent the three ranges defined in the KPI. 

__ i. To see the values in tabular format, click 'Show data table'. 

__ j. To see specific values in the graph, hover your mouse pointer over the blue KPI value line. 
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__ k. To see specific targets in the graph, hover your mouse pointer over the black target line. Since 
the target coincides with the top of a range, you also see the range values. 

__ l. To see ranges in the graph, hover your mouse pointer over the top of the range. 

__ m. There are hourly records loaded in KPI history and so you can experiment with various 
granularities and date windows. To change the date window, you can use the pre-set date 
windows such as 1D or YTD, or you can click the blue From and To dates to open a calendar 
picker to select specific dates. 

__ n. Click 'Save' to save your changes. 
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Part 6: Create a prediction model and view KPI prediction data 

In this section you will create a prediction model, then view the prediction data in the KPI history and prediction 
widget. 

____ 1. Configure and view KPI prediction for KPI Avg Order Price. 

__ a. On the KPI history and prediction widget, click the Edit Settings… menu option. 

__ b. Previously you configured the widget for the KPI Avg Order Price, so now click the tab History 
and Prediction. 

__ c. Notice that it says that prediction is not enabled for this KPI, but that you can use the KPI 
Manager to enable it. 

__ d. Click the Cancel button to exit the configuration. 

__ e. Click the KPI Manager tab on the dashboard. 

__ f. For model, select Order Item. 

__ g. Select Avg Order Price. 

__ h. Click Actions, and select History and Prediction. 

__ i. Click New Model to create a new prediction model. 

__ j. Enter a prediction model name such as Daily. Select 'Once a day' for prediction data points. Enter 
'30' for the prediction period. 
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__ k. Click OK.
 

__ l. You will receive a message indicating that you need a time period to be set on this KPI.
 

__ m. You could update the model with a daily time period, but this would also delete the KPI history 
when you re-deployed the changed model. To show you the prediction capability for a KPI with a 
daily time period, another KPI 'Sum Price Today' is available which is already setup in the model. 
Proceed to the next section to see how to setup prediction for this KPI. 

__ n. Click OK. Click Cancel. Click Cancel. 

____ 2. Configure and view KPI history for KPI Sum Price Today. 

__ a. On the Analysis tab, click the 'Edit Page' link to enter edit mode.
 

__ b. On the KPI history and prediction widget, click Edit Settings… on the widget menu.
 

__ c. On the KPI tab, select 'Latest version', 'KPI ranges', 'KPI target'
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__ d. For the monitor model, navigate to OrderItem <timestamp> > Sum Price Today, then select it. 

__ e. Click OK. 

__ f. You can adjust the granularity and the date window on the widget. The default display is two 
months with daily data points. Initially the data display may be empty because historical data has 
been loaded for this KPI only from years 2008 through 2010. You should adjust the dates to 
display historical data within this date window. To change the date window, you can use the pre
set date windows such as 1D or YTD, or you can click the blue From and To dates to open a 
calendar picker to select specific dates. 

__ g. Notice that there is a repeating business pattern or business cycle such that there is a 
significant drop in values on the weekends, so there is a seven day business cycle. You will use 
this information when you create the prediction model. 

__ h. Click 'Save' to save your changes. 

____ 3. Create a prediction model for KPI Sum Price Today. 

__ a. Click the KPI Manager tab on the dashboard. 

__ b. For model, select Order Item. 

__ c. Select Sum Price Today. 
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__ d. Click Actions, and select History and Prediction.
 

__ e. Select 'Enable KPI Prediction based on the historical data for this KPI'.
 

__ f. Click Apply. If you forget this step, then the predictions will not be displayed and you may have to 
wait up to an hour for the KPI prediction service to run. 

__ g. Click New Model to create a new prediction model. 

__ h. Enter a prediction model name such as Daily. Select 'Once a day' for prediction data points. 
Enter '30' for the prediction period. As you saw in the KPI history graph, there is a seven day 
business cycle. To provide a more accurate prediction, select 'Include a repeating business 
pattern', and enter 7 Days for the pattern. If you did not know there was a repeating 7 day pattern 
or if you forgot to enter it here, the prediction will still be created, however it will not be as 
accurate. 

__ i. Click OK. The KPI prediction service runs immediately, so this dialog may take a few moments to 
close while the service is invoked. Do not click the OK button twice, since this will create a 
duplicate model. You should see the prediction model listed as follows: 
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__ j. Click OK.
 

____ 4. Configure and view prediction data for KPI Sum Price Today.
 

__ a. On the Analysis tab, click the 'Edit Page' link to enter edit mode. 

__ b. On the KPI history and prediction widget, click Edit Settings… on the widget menu. 

__ c. On the KPI tab, insure that you have selected KPI 'Sum Price Today'. 

__ d. On the History and Prediction tab, select 'Show predictions based on the following prediction 
model. Select Daily. Select 'Show prediction data on graph by default'. Take the defaults for the 
remaining fields. 

__ e. Click OK. 

__ f. Notice the orange diamonds that represent the prediction points in the graph. If you do not see 
the orange diamonds, then the KPI prediction service has not completed, so wait a few moments 
then refresh the widget display by clicking the down arrow in the upper right corner of the widget, 
and selecting the refresh option. 

__ g. Click 'Show data table', and you can see the specific prediction values at the end of the table. 
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__ h. Click 'Save' to save your changes. 

2010 April, 06 IBM WebSphere Business Monitor 7.0 - Lab exercise Page 20 of 24
 

KPI history and prediction 



        

               

     

             

                    
  

                

          

       

                 
      

 

                 

 

           

                 
        

         

         

 

                    
                 

                   
  

© Copyright IBM Corporation 2010. All rights reserved 

Part 7: Create a business user alert based on the KPI prediction model 

In this section you will configure a business user alert that will fire when the KPI prediction data exceeds a 
predefined threshold. 

____ 1. Create a business user alert when the KPI prediction values exceed a predefined threshold. 

__ a. Click the Alert Manager tab in the dashboard. 

__ b. Click the New Alert button. 

__ c. Enter an alert name and optionally a description. Also, for the model, select 'Order Item 2006-08
03 00:00:00' from the drop down. 

__ d. In the Conditions section, click Add, which will add a row to the conditions table. 

__ e. For KPI Name, click to choose Sum Price Today.
 

__ f. For Prediction Model, click to choose Daily (Anytime). You could also choose Daily (End) which
 
would only compare to end of day values. 

__ g. For Condition, click to choose 'Below range'. 

__ h. For Value, click to choose range Medium. 

__ i. In the timing section, set the timing to 5 minutes, and set the notification frequency to 'Only once 
during the KPI time period when the condition applies'. So this means that the condition will be 
checked every 5 minutes, but the alert will be created at most once per day since the KPI period 
is daily. 
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__ j. Click the Alert Content tab, and view the default message that is created. You could customize 
the alert message if the generated content did not meet your needs. 

__ k. Click the Notification tab, and you see that the administrative user is notified using a dashboard 
alert. 

__ l. Click OK.
 

__ m. Click OK. You should see the new alert in the list.
 

____ 2.	 In Business Space, click the Operational tab. You should see the new alert listed in the Alerts 
widget. If you remember, the prediction values that you saw earlier included values that were in the 
low range, so the alert should have been created since the condition on the alert was based on the 
predicted value being below the medium range. If you do not see the alert, then wait a few moments 
then refresh the widget display by clicking the down arrow in the upper right corner of the widget, 
and selecting the refresh option. 
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__ a. To see the details of the alert, click the alert. 
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What you did in this exercise 

In the lab, you loaded the KPI history table with data, deployed a monitor model, and used the KPI history 
and prediction widget to view the KPI historical information. You created a prediction model and viewed 
KPI prediction information. You defined a business user alert based on the prediction model exceeding a 
certain threshold. 
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