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IBM Tivoli Provisioning Manager V7.2.1 

Automation Package Developer Environment 

In this training module, you learn about the Automation Package Developer Environment for IBM 
Tivoli Provisioning Manager V7.2.1. 
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Objectives 

When you have completed this training module, you can perform these tasks: 

� Describe the Automation Package Developer Environment (APDE) 

� Locate APDE installation procedure documentation 

� Name the features of the APDE 

� Name important APDE configuration and log files 

� Identify and resolve APDE problems 

2 Automation Package Developer Environment © 2012 IBM Corporation 

When you have completed this training module, you can perform these tasks: 

- Describe the Automation Package Developer Environment (APDE) 

- Locate APDE installation procedure documentation 

- Name the features of the APDE 

- Name important configuration and log files 

- Identify and resolve APDE problems 

adpe.ppt Page 2 of 18 



Introduction 

� The Automation Package Developer Environment (APDE) is a plug-in on the Eclipse 
platform 

� You can create, edit, view, and test automation packages with APDE 

� There are APDE tools to ease the development of automation packages 
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This slide shows a block diagram of the APDE, LAN, IBM Tivoli Provisioning Manager server, 
and a database server. The APDE remotely accesses both the provisioning server and the 
database server. There already exists a place in the IBM Tivoli Provisioning Manager user 
interface where you can write the tcdriver workflows without using an APDE. 

You can complete the installation, compile and then run the workflows without an APDE. 
However, a formal IDE or application development environment is needed. The APDE is used 
when writing workflows and packages. The APDE allows developers to create, edit, and view 
workflows and packages in a more sophisticated way. The APDE is an Eclipse plug-in that is 
delivered with IBM Tivoli Provisioning Manager. The Eclipse editor is used to write code. 
Embedded Eclipse features are quite useful in development scenarios for those writing code. 
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Installation requirements 

Automation Package Developer Environment (APDE) installation requirements: 

� Eclipse version 3.2.2 or version 3.6 

� JDK version 1.5 

� Operating systems: 
– Windows 
– Linux 

� Either 32-bit or 64-bit Intel platform machines 

� 2 gigabytes of RAM 

� 3.2 Eclipse is not for 64-bit machines 
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Lets review the APDE installation requirements: 

- Eclipse version 3.2.2 or version 3.6 

- JDK version 1.5 

- 2 gigabytes of RAM 

- Either Windows or Linux operating system 

- Either a 32-bit or a 64-bit Intel platform machine 

As a mental note remember that 3.2.2 Eclipse is not for 64-bit machines 
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APDE installation methods 

Configuration script installation method 

� Installing Automation Package Developer Environment automatically using a shell script 

http://publib.boulder.ibm.com/infocenter/tivihelp/v45r1/topic/com.ibm.tivoli.tpm.wkf.doc/workfl 
ows/twkf_apdeinstauto.html 

� Primary and recommended installation method 

Manual installation method: 

Installing and configuring Automation Package Developer Environment manually 

http://pic.dhe.ibm.com/infocenter/tivihelp/v45r1/index.jsp?topic=/com.ibm.tivoli.tpm.wkf.doc/ 
workflows/twkf_apdeinstrem.html 
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The first step is to log in on the IBM Tivoli Provisioning Manager provisioning server to create the APDE package. 
After creating the APDE package, the next step is to deploy it on a remote workstation. Download the eclipse 
compressed file. It can be either version 3.2.2 or version 3.6. The IBM JDK version 1.5 is included with the IBM 
Tivoli Provisioning Manager package. The 32-bit JDK package is not supported for 64-bit operating systems. There
are two methods of installation. They are the manual installation method and the configuration script installation
method. The manual installation method is discussed in the IBM Information Center. The web address is: 
http://publib.boulder.ibm.com/infocenter/tivihelp/v45r1/topic/com.ibm.tivoli.tpm.wkf.doc/workflows/twkf_apdeinstrem.
html 

It is much easier to accomplish an APDE installation by using the configuration script provided with IBM Tivoli 
Provisioning Manager. The web address for the configuration script installation method is: 
http://publib.boulder.ibm.com/infocenter/tivihelp/v45r1/topic/com.ibm.tivoli.tpm.wkf.doc/workflows/twkf_apdeinstauto.
html 

The configuration script is located under TIO_HOME/apde. All of the related installation packages are also under 
TIO_HOME/apde. The Configure_APDE.sh script can be used to generate the installation package for both
Windows and Linux operating systems. The configuration script requires the APDE_install_location. The
recommended directory path for Windows is C:\APDE. This directory must be created before deploying the package 
on the remote workstation. Additional parameters required for the Configure_APDE.sh script are the remote
machine name, the username to connect to the remote machine, whether the eclipse version is 3.2.2 or 3.6, the
eclipse_path, and the JDK_path. The eclipse_path and the JDK_path are the locations of the eclipse and Java
compressed files on the IBM Tivoli Provisioning Manager server. The Configure_APDE.sh script extracts the 
eclipse and the Java files. It builds eclipse and Java files into a single APDE installation file for the target 
workstation. When the Configure_APDE script is run without any syntax it displays an informational message
describing all the available parameters and usage. 

At the completion of the Configure_APDE.sh script run, a compressed package is created. The compressed
package is now ready to be deployed on a remote workstation. The compressed package is only created and not 
automatically copied and deployed on the remote workstation if the installer did not specify a machine name, 
username, and proper command syntax. In this scenario the installer must manually complete the installation on the 
remote workstation by copying the compressed file and extracting it on the remote workstation. 
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Starting APDE and opening the automation package 

� Start Automation Package Developer Environment (APDE) using eclipseLauncher.bat 
(present in the <APDE_HOME>/eclipse folder) 

� To load the automation package perspective, click Window > Open Perspective > 
Automation Package 
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The APDE is now deployed on your workstation. Start the APDE by using the 
eclipseLauncher.bat file located in the APDE_home/ folder. Next, you are prompted to define 
the APDE workspace. The APDE workspace is a user-specified location where the eclipse 
workspace files are stored. Open the automation package perspective after the APDE starts 
successfully. From the Window menu, select Open Perspective and select Automation 
Package. This activates the automation package plug-in within the eclipse environment. 
Installers see additional view tabs that display example workflows and packages after the 
perspective has fully loaded. 
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Creating an automation package project 

� Create a sample automation package 

� Click File > New > Automation Package Project 
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Begin a new automation package project by selecting File>New>Automation Package Project. 
An empty project is created on the left panel of the screen. 
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Creating a workflow 

Files and folders created by the installation wizard: 

� tc-driver.xml 

� build.xml 

� Generated Java code 

� Package file
 

To create a sample workflow click the project folder, click New > Workflow
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In this slide, you see names of the files and folders that are created by the installation wizard. 
These files and folders are needed when creating workflows. To create a new workflow, right-
click the new project folder of the new automation package. Next, select New > Workflow. 
Specify a name for the new workflow and select any logical management operation that is 
implemented by the workflow. If unsure, then do not select any logical management operations. 
Click Finish. A new .wkf workflow file is created. This workflow file has the basic file structure in 
place. 
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Sample workflow code example 

Sample workflow code example 

Each APDE workflow has code that is available for viewing. On this slide, a sample code 
example is displayed. Use the sample code from this slide for your first workflow. 
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APDE features and views 

� Data Center Model view 

� Queries view 

� Workflow Palette view 

Data Center Model 

Workflow Palette view 

Queries 

Show view 
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There are additional views available within the automation package perspective. From the 
Window menu, click Show View. Next, select Other. There are six available views. By default 
the automation package perspective includes automation package, execution results, and 
workflows. Select additional views Data Center Model, Queries, and Workflow Palette. Now 
find the additional tabs in the lower panel of the screen. 
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How to view the source code of a workflow 

Provisioning workflows view (view source code) 
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Search for a specific workflow by using the workflows view tab at the bottom of the screen. 
Double-click a workflow to view the source code. 
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Obtaining context-sensitive help while writing workflows 

Simultaneously press the Ctrl + Space keys for context-sensitive help 
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Sometimes a developer finds it handy to access help files when writing workflows. 
Simultaneously press the Ctrl + Space keys to obtain APDE context-sensitive help. The help file 
reveals the jython syntax options available for that particular code. 
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Important configuration and log files (1 of 3) 

tcdrivermanager.xml 

There are a few important files that are associated with the APDE runtime. The first is the 
tcdrivermanager.xml file. In this slide, the XML file displays the default repository location 
where tcdriver files are stored. This slide also displays the IBM Tivoli Provisioning Manager 
provisioning server’s IP address. 
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Important configuration and log files (2 of 3) 

dcm.xml configuration XML file 

The dcm.xml file is a configuration file. It stores the location of the JDBC type4 jar files. This 
XML file also stores DB2 connection-specific information. The APDE log in password is stored 
as an encrypted value. 
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Important configuration and log files (3 of 3) 

� APDEDev\logs folder 

� Console.log file 

� Trace.log file 
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The APDEDev\logs folder contains both the console.log file and the trace.log file. These log 
files are used in system problem resolution scenarios. Search for information in these log files 
when a workflow is generating error messages or when problems occur while compiling 
workflow code. 
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Summary 

Now that you have completed this training module, you can accomplish these tasks: 

� Describe the Automation Package Developer Environment (APDE) 

� Locate APDE installation procedure documentation 

� Name the features of the APDE 

� Name important APDE configuration and log files 

� Identify and resolve APDE problems 
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Feedback 

Your feedback is valuable 

You can help improve the quality of IBM Education Assistant content to better meet your 
needs by providing feedback. 

� Did you find this module useful? 

� Did it help you solve a problem or answer a question? 

� Do you have suggestions for improvements? 

Click to send email feedback: 

mailto:iea@us.ibm.com?subject=Feedback_about_adpe.ppt 

This module is also available in PDF format at: ../adpe.pdf 
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You can help improve the quality of IBM Education Assistant content by providing feedback. 
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Trademarks, disclaimer, and copyright information 

THE INFORMATION CONTAINED IN THIS PRESENTATION IS PROVIDED FOR INFORMATIONAL PURPOSES ONLY. Other product and service 
names might be trademarks of IBM or other companies. A current list of other IBM trademarks is available on the web at "Copyright and trademark 
information" at http://www.ibm.com/legal/copytrade.shtml 

Intel, are trademarks or registered trademarks of Intel Corporation in the United States, other countries, or both. 

Linux is a registered trademark of Linus Torvalds in the United States, other countries, or both. 

Windows, and the Windows logo are registered trademarks of Microsoft Corporation in the United States, other countries, or both. 

Other company, product, or service names may be trademarks or service marks of others. 

THE INFORMATION CONTAINED IN THIS PRESENTATION IS PROVIDED FOR INFORMATIONAL PURPOSES ONLY. WHILE EFFORTS WERE 
MADE TO VERIFY THE COMPLETENESS AND ACCURACY OF THE INFORMATION CONTAINED IN THIS PRESENTATION, IT IS PROVIDED 
"AS IS" WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED. IN ADDITION, THIS INFORMATION IS BASED ON IBM’S CURRENT 
PRODUCT PLANS AND STRATEGY, WHICH ARE SUBJECT TO CHANGE BY IBM WITHOUT NOTICE. IBM SHALL NOT BE RESPONSIBLE FOR 
ANY DAMAGES ARISING OUT OF THE USE OF, OR OTHERWISE RELATED TO, THIS PRESENTATION OR ANY OTHER DOCUMENTATION. 
NOTHING CONTAINED IN THIS PRESENTATION IS INTENDED TO, NOR SHALL HAVE THE EFFECT OF, CREATING ANY WARRANTIES OR 
REPRESENTATIONS FROM IBM (OR ITS SUPPLIERS OR LICENSORS), OR ALTERING THE TERMS AND CONDITIONS OF ANY AGREEMENT 
OR LICENSE GOVERNING THE USE OF IBM PRODUCTS OR SOFTWARE. 

© Copyright International Business Machines Corporation 2012. All rights reserved. 
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