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This presentation will cover the assembly and deployment tools for WebSphere®

Application Server that are available in Rational® Application Developer V7.5.
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The first section of the presentation provides an overview of the deployment tools 

available in Rational Application Developer V7.5. The second section describes new 

features in the deployment workbench for working with WebSphere Application Server. 

The last section contains information on getting started with application deployment to 

WebSphere Application Server and shows how to create a new server profile and define a 

server connection in the Rational Application Developer workbench.
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This section provides an overview of the deployment tools available in Rational Application 

Developer V7.5.
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The deployment tools components in Rational Application Developer provide the 

necessary framework and adapters for connecting to an application server. This allows 

you to use these server connections to deploy and test your applications from the 

development workbench. The workbench provides an integrated development 

environment, allowing you to quickly build, deploy, test, and debug your enterprise 

applications. You can also use specialized Java EE application testing tools, like the table 

and data source creator that allows you to generate database tables for testing, based on 

the structure of your applications. The workbench also includes a specialized test client for 

testing enterprise beans. The assembly and deployment tools in Rational Application 

Developer can connect to multiple server runtimes, including local and remote servers. 

You configure the defined runtimes within the development workbench.
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The workbench provides specialized tools for connecting to WebSphere Application 

Server. You can install integrated runtime test environments with Rational Application 

Developer, or you can you the tools to connect to an external installation of the application 

server, either on the local system or a remote system. These tools provide a test 

environment where you can test Java EE applications, including artifacts such as 

enterprise beans, JavaServer pages, servlets, and HTML. The tools also allow you to test 

other application components using the application client launcher, table and data source 

creator, Jython editor, or the launcher for administrative scripts. WebSphere Application 

Server V7 is a Java EE 5 compliant application server, so the tools for working with 

WebSphere Application Server V7 support Java EE 5 applications.
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In Rational Application Developer V7.5, there are several new features in the assembly 
and deployment tools. For WebSphere Application Server connections, there is a new 
connection type – InterProcess Connector, or IPC. This offers a more stable and robust 
connection between the workbench and a local instance of WebSphere Application Server 
V7. When creating a server connection, the tools will automatically generate some of the 
connection information for you, and you also have the option of testing the connection. 
After defining an application server connection, you can view server properties that include 
information about the runtime location and direct access to server log files. To help with 
workspace migration, a new dialog opens when you open a workspace that contains an 
undefined server runtime. The wizard helps guide you through defining a new server 
runtime. In addition to supporting WebSphere Application Server V7, the workbench 
provides support for connection to feature packs that are available for WebSphere 
Application Server V6.1, like the feature pack for EJB 3.0 and the feature pack for Web 
2.0. The workbench also provides support for doing Jython script development using new 
objects that are a part of the Jython script library provided with WebSphere Application 
Server V7.

Page 6 of 22



WASv7_RAD_ServerTools.ppt

This section describes new features in the deployment workbench for working with 

WebSphere Application Server.
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The workbench now includes support for IBM WebSphere Application Server V7. The 

table on this slide summarizes the specification levels that each V7 supports. Note that 

Rational Application Developer supports the latest Java EE 5 specification in the 

development environment for WebSphere Application Server V7. The workbench no 

longer supports tools for WebSphere Application Server V5.1 or WebSphere Application 

Server Network Deployment environment. However, using WebSphere Application Server 

Network Deployment, you can continue to run the profile management tool from the 

workbench to create and augment profiles.
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A new option to automatically determine connection settings is available under the server 

connection type and administrative ports section of both the new server wizard and the 

server editor. When you use this option, the workbench automatically selects which 

available connection type to use. A new test connection link is available under the server 

connection type and administrative ports section of both the new sever wizard and the 

server editor. Use this link to test the connection between the server and the workbench to 

determine if there are any connection problems. When a connection fails, messages 

display with possible explanations and solutions 
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When you right-click a server in the Servers view, there is a new properties option in the 

pop-up menu. Use the properties pages to find general information about the server, such 

as the name of the server, server type, vendor, and the location of its metadata. You can 

also use the properties pages to monitor data sent to the server ports. For WebSphere 

Application Servers, you can also use the properties pages to view the log files, profile 

name, and directory. 
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A new workspace migration dialog opens when opening a workspace that contains 

projects targeting a server runtime that is not defined in the workspace. Use this dialog to 

replace undefined server runtimes with runtimes already defined in the workspace. This 

helps resolve errors such as unbound classpath container and target runtime WebSphere 

Application Server V6 is not defined. 
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When publishing an application to a WebSphere Application Server V6.1 with EJB 3.0 

feature pack, Java enterprise Edition (Java EE) 5 support is available for both enterprise 

archive (EAR) and enterprise JavaBeans (EJB) modules; however, container-managed 

persistence (CMP) beans at 2.1, 2.0, or 1.1, are not supported in an EJB 3.0 module. In 

addition, the Web module must remain at Web 2.4, 2.3, or 2.2 specification-level and the 

application client module must remain at Java 2 platform enterprise Edition (J2EE) 1.4, 

1.3, or 1.2 specification level. Although, the WebSphere Application Server V6.1 with the 

feature pack for EJB 3.0 does not support Servlet 2.5 Web archive (WAR) files and Java 

EE 5 application client modules, the application server does support annotated injections 

for Servlet 2.4 WAR files and J2EE 1.4 application clients as a common annotations 

extension. The feature pack for Web 2.0 can be installed with WebSphere Application 

Server V6.1 and V7. Although the WebSphere Application Server with feature pack for 

Web 2.0 can be installed on top of WebSphere application server V6.0.2, the IBM Rational 

software delivery platform currently does not support this runtime configuration. 
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WebSphere Application Server V7 adds numerous WebSphere Administrative (wsadmin) 

objects to the Jython scripting libraries, in addition to the standard five wsadmin objects: 

AdminControl, AdminConfig, AdminApp, AdminTask, and Help. In the Jython preferences 

(Window > Preferences > Jython), select Enable content assist for WebSphere 

Application Server V7.0 script libraries. Then, the additional wsadmin objects are 

available when using content assist (Ctrl+Space) in the Jython editor. The additional 

wsadmin objects are supported only for Jython scripts running on WebSphere Application 

Server V7.
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The table and data source creator wizard now supports creating tables and data sources 

for testing Java Persistence API (JPA) beans on a WebSphere Application Server. When 

you use the wizard shown above to create tables, the tables do not get created 

immediately. Instead, the persistence.xml file gets marked-up to generate the tables 

automatically, and the tables are created during runtime when the tables are needed.
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This section contains information on getting started with application deployment to 

WebSphere Application Server and shows how to create a new server profile and define a 

server connection in the Rational Application Developer workbench.
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You can access the WebSphere Application Server Profile Management Tool directly from 

the Rational Application Developer workbench. First, open the Window > Preferences 

menu, and then expand Server and choose the WebSphere Application Server section. 

From here, you can launch the Profile Management Tool for any of the local application 

server runtimes that you have defined in your workbench. Choose the runtime that you 

want from the list at the top of the panel. The profiles associated with that runtime are 

populated in the list at the bottom of the display. To create a new profile, click the Run 

Profile Management Tool button. This brings up the standard Profile Management Tool for 

WebSphere Application Server.
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The process for creating a server connection is very similar to the previous release of 

Rational Application Developer. Access the server creation wizard either by using the 

product menus (under File > New > Other > Server), or by right-clicking in the Servers 

view in your workspace and choosing the option New > Server from the pop-up menu.
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The server connection wizard allows you to connect to either a local or a remote server. 

The default option is to connect to a local server, so the server host name defaults to 

localhost. To connect to a remote server, you need to provide the fully qualified host name 

for the remote server. You can create server connections for several types of servers, 

including Web servers and application servers. In order to create a server connection, you 

need to have a runtime environment defined for that server type. If you have installed any 

of the WebSphere Application Server integrated testing environments, those runtimes are 

automatically defined for you. If you are connecting to an external installation of 

WebSphere Application Server, you need to manually define that runtime environment.
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On the WebSphere Server Settings panel, choose the WebSphere profile name for the 

server connection you are creating. All of the profiles defined in the runtime that you 

selected on the previous panel are available in the dropdown menu. For a local server 

connection, the configuration tools automatically determine connection settings, including 

port information for the server. The new IPC connector option is the default connection 

type for a local server. If you have administrative security enabled in the selected 

WebSphere Application Server profile, then you need to provide authentication information 

in order to be able to connect to the server. Before completing the configuration, you have 

the option of testing the server connection to make sure that the settings are correct. You 

can only test the server connection if the application server profile is running, otherwise, 

the connection test will fail.
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This section contains a summary of the content covered in this presentation.
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The assembly and deployment tools in Rational application developer V7.5 provide the 

capability to create connections to servers and directly deploy and test applications using 

those server runtimes. The workbench supports WebSphere Application Server V7, 

including Java EE 5 application development and deployment. The server connection 

creation process has been streamlined by enabling the tools to automatically detect server 

configuration information for local servers. The server properties allow you to directly 

access server information, including log files. If you attempt to open a workspace with an 

undefined server runtime, the tools will guide you through the process of configuring a 

supported runtime for that workspace. WebSphere Application Server V7 comes with an 

enhanced Jython script library, which is accessible from the development workbench. You 

can use the table and data source creator to generate testing artifacts for JPA applications 

that you are deploying to WebSphere Application Server. The development workbench 

also provides feature pack support for the feature pack for EJB 3.0 and the feature pack 

for Web 2.0 that run on WebSphere Application Server V6.1. 
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