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What this exercise is about 

The objective of this lab is to show you how to use the Global Monitoring Context wizard to build a monitor 
model which is a composite of monitor models from disparate event sources. In previous releases, this wizard 
required a common key on all inbound events, for example, loan ID for a loan processing scenario. In this 
release the wizard can handle different keys for different event sources. Each subsystem only needs to know 
the correlation key of the previous subsystem. IBM Business Monitor handles building and tracking the global 
key. 

Lab requirements 

List of system and software required for the student to complete the lab: 

•	 IBM Integration Designer V8.0 – Toolkit installation including the monitor model editor feature 

•	 IBM Business Monitor V8.0 – A server installation with IBM Business Monitor on WebSphere
 
Application Server
 

What you should be able to do 

At the end of this lab you should be able to: 

•	 Use the global monitoring context wizard to generate a new global context. 

•	 Deploy the model and playback events that represent events from your process. 

•	 Use the auto-generated dashboard to view monitored data. 

Introduction 

A global monitoring context incorporates metrics from separate monitoring contexts and creates a single 
monitoring context. Through the use of a global monitoring context, you can see the end-to-end execution of a 
process instance in a single view in the dashboard. 

For example, suppose that you have a group of monitoring contexts for an order fulfillment system. The 
monitoring contexts provide information about the lower-level details of the order fulfillment system, such as 
initial order placed, customer acknowledgment sent, and order shipped. If you create a global monitoring 
context, you can monitor the end-to-end execution of an instance of the entire order fulfillment system instead 
of viewing each monitoring context instance as a discrete unit of information. 

When you create a global monitoring context, you define intermediate milestones for the significant steps in the 
overall process. For example, you might want to create milestones for Ordering and Shipping. The Ordering 
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milestone represents multiple monitoring contexts in the ordering process, just as the Shipping milestone 
represents multiple monitoring contexts in the shipping process. 

You use the Global Monitoring Context wizard to create the global monitoring context and the milestones, and 
to provide information about the source monitoring contexts. If the source monitoring contexts contain a metric 
common to all of them (for example, an order ID), you use that metric to link the monitoring contexts. But even 
if the source monitoring contexts do not have a common metric, you can still generate a global monitoring 
context and a set of milestones. You link the monitoring contexts by mapping a metric associated with the first 
monitoring context (the source) to a metric associated with the second monitoring context (the target). 

Here is a diagram of the loan processing system that is used in this lab: 

Suppose that you are monitoring several processes that are part of an overall loan processing scenario. 
Each process is from a different source (for example, a Business Process Manager application or a human 
task). Each step in the process has an associated monitoring context, and you can view the metrics for the 
monitoring context on the dashboard. But you might find it more valuable to group these disparate 
processes into one global monitoring context so that you can have a view of the overall loan processing 
scenario. 

The loan processing scenario consists of five disparate processes. Each of these processes has a 
monitoring context and a set of metrics associated with it. These processes are monitored separately, but 
you now want to group them so that you can see the end-to-end flow of loan processing. To be able to 
monitor the entire loan processing scenario, you use the Global Monitoring Context wizard to create a 
global monitoring context. The existing monitoring contexts (Analysis and Disbursement, for example) are 
used as the source for building the global monitoring context. 

Useful URLs 

The following URLs may be helpful to you as you exercise this lab. Note that the port numbers in the URL 
of your installation may be different depending on your configuration. 

• Server administrative console 

https://localhost:9044/ibm/console 

• Business space dashboard 

https://localhost:9444/BusinessSpace 
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Part 1: Create the global monitoring context 

In this section you import the monitor model containing the monitoring contexts for the loan processing system, 
and you generate the global monitoring context. 

____ 1. Open IBM Integration Designer. 

____ 2. Switch to the Business Monitoring perspective. 

____ 3. Import the supplied monitor model. 

__ a. Right click in the Project Explorer > Import … > Select Project Interchange in the Other category, 
then browse to the model, for example, c:\Labfiles80\ Loan-processing-PI.zip 

____ 4. Open the monitor model 

__ a. In the Project Explorer navigate to Wide Angle example > Monitor Models > double click 'Wide 
Angle Example.mm' 

____ 5. There is a monitoring context for each subsystem in the process. You can use the editor to view the 
keys and metrics for each of them. 

____ 6.	 Start the global monitoring context wizard. 

__ a. In the editor > right click Loan Processing > New > Global Monitoring Context… 

____ 7.	 On the first page of the wizard, give the new context a name, such as 'glob'. Leave unchecked the 
option 'All source monitoring contexts contain a common key'. In this lab each activity does not 
know the global key, but it does know the key of the previous activity. Also uncheck the option 'Do 
not display source monitoring contexts in dashboard'. Normally you might not want this detail, but 
for this lab, you might want to see how the underlying contexts are displayed in the dashboard. 
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____ 8. Click Next. 

____ 9. On the next page of the wizard, create milestones to group the monitoring contexts. In this example 
there are three milestones: 

__ a. Milestone 'm1' containing Application and Analysis 

__ b. Milestone 'm2' containing Automated Approval and Manual Approval 

__ c. Milestone 'm3' containing Disbursement 
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____ 10.	 Click Next. 

____ 11.	 On the next page of the wizard, map metrics for correlation. There are two flows through the 
process. The first contains Application, Analysis, Automated Approval and Disbursement. The 
second contains Application, Analysis, Manual Approval and Disbursement. Each activity needs to 
know the key of the previous activity in the flow. For each mapping, specify the source context, 
source metric, target context, target metric and mapping key. The mapping key is the metric in the 
target context which contains the correlation key for the source context. For example, in the first 
mapping from Application to Analysis, the mapping key metric in the Analysis context is called App 
ID, which will contain the application ID for correlation purposes. When you select a source context, 
the source metric defaults to the context key, and it works similarly for the target context. You can 
use the default source metrics and target metrics. For the mapping keys, use these values: 

__ a. Application to Analysis, Mapping key: App ID 

__ b. Analysis to Automated Approval, Mapping key: Ana ID 

__ c. Analysis to Manual Approval, Mapping key: Anaman ID 

__ d. Automated Approval to Disbursement, Mapping key: Aut ID 

__ e. Manual Approval to Disbursement, Mapping key: Man ID 
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____ 12. Click Next. 

____ 13. On the next page of the wizard, you would normally select just the metrics that you are interested in 
viewing in the dashboard. For this lab, select all the metrics so you can see everything in the 
dashboard: 

____ 14. Click Finish. 
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____ 15.	 You can view the generated global context 'glob' in the editor. There are metrics created based on 
the ones that you selected in the wizard. You can check the KPI and dimensional models to see the 
KPI's, dimensions and measures that you will be able to work with in the dashboard. 

____ 16.	 Generate the Java code for the monitor model. 

__ a. In Project Explorer, right click 'Wide Angle Example.mm' > Generate Monitor Java EE Projects > 
Finish 

____ 17.	 Check for any errors in the Problems view. You should resolve any errors before continuing. . There 
may be warnings, but there should not be any errors. If you see errors, then try to perform a clean to 
see if the errors can be removed: Project > Clean… > select 'Clean all projects', then click OK. 
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Part 2: Publish the model to the server 

In this section you will publish the monitor model to the monitor server. 

____ 1. Make sure that your server is defined in the servers view of IBM Integration Designer, and that it is 
started. 

____ 2. Make sure that your server is marked as a development server, so that the dashboard will be 
generated automatically when you add the application to the server using menu option 'Add and 
Remove …'. If you prefer not to mark the server as development type, you can export the monitor 
model EAR, install it using the administrative console, then you can select to have the dashboard 
generated in step 12 of the deployment. To verify the type of server: 

__ a. In the servers view, right click > Administration > Run administrative console. You should see 
it open in a separate tab. 

__ b. It will prompt you for user ID and password. 

__ c. Navigate to Servers > Server Types > WebSphere application servers > server1 

__ d. Look for the flag 'Run in development mode'. 

____ 3. Right click the server, then select 'Add and Remove …' 

____ 4. You should see Wide Angle ExampleApplication listed, so move it from the Available box to the 
Configured box. 

____ 5. Click Finish.
 

____ 6. A progress message is displayed in the lower right corner of the window.
 

____ 7. In the servers view, right click > Administration > Run administrative console. You should see it 
open in a separate tab. 

____ 8. It will prompt you for user ID and password. 

____ 9. Click Applications > Monitor Models. The application should show green status if it started 
successfully. 
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____ 10.	 If the model shows red (stopped), then wait a moment, then refresh by clicking on the icon to the 
right of Status in the last column of the table. You should see green (started) for the model. If it does 
not show green, be patient and keep refreshing until it does show green. 

____ 11.	 If you are using the integrated server within IBM Integration Designer, then you do not need to setup 
Monitor data security, since the administrative user is automatically authorized to all models. If you 
are using a different server, then you should open the administrative console, navigate to Security 
> Monitor Data Security, add the model, role and user information to a resource group. 
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Part 3: Run events to exercise the model 

Rather than installing a process application to create the events that you want to monitor, you are going to use 
the monitor playback feature to playback events from a file. 

____ 1.	 In the administrative console navigate to Applications > Monitor Services > Recorded Event 
Management > Event Management 

____ 2.	 Import two supplied event files. One file contains events that simulate a complete instance flow 
through the automated approval activity. The other file contains events that simulate a complete 
instance flow through the manual approval activity. 

__ a. Click Import events > browse to c:\Labfiles80\Loan-processing-events-autoflow.xml > Click 
Import events 

__ b. Click Import events > browse to c:\Labfiles80\Loan-processing-events-manualflow.xml > Click 
Import events 

____ 3.	 You should see eight events in the list. 

____ 4.	 Play back all eight events individually. To ensure event sequencing, do not use the button 
'Playback All', instead, use the 'Playback' button for each of the events in order, starting with event 
ID 1. 

__ a. Select 'Event Playback' in the menu in the administrative console. 

__ b. Select the event labeled 1 (at the bottom of the list), select the Loan Processing model in the 
target model version list, then click 'Playback' 

__ c. Select the event labeled 2 (second from the bottom of the list), select the Loan Processing model 
in the target model version list, then click 'Playback'. 
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__ d. Continue in this manner until all eight events are processed. 
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Part 4: View the dashboard 

In this section you will look at the auto-generated dashboard in business space. 

____ 1. Start Firefox and login to business space. 

__ a. For example: https://localhost:9444/BusinessSpace 

__ b. Enter your user and password. 

____ 2.	 Click 'Go To Spaces', then click the auto generated dashboard. It should be named 'Loan 
Processing <timestamp>'. 

____ 3. If you see unusual issues in the dashboard, for example all widgets show as unavailable or you see 
a message such as ‘Callback failed to execute...’, try clearing the browser cache, then logout of 
business space, close and reopen the browser. To clear cache: 

__ a. In Firefox, depending on the version: 

1) Tools > Clear recent history > select Cookies and select Cache > Clear now 

2) Or, History > Clear recent history 

__ b. In Internet Explorer, depending on the browser version: 

1) Tools > Delete browsing history 

2) Or, Tools > Internet options > Browsing history 

____ 4.	 In the dashboard, there are many tabs including tabs for each of the child monitoring contexts, one 
for the global monitoring context, and tabs for KPI's and diagrams. Since you ran two complete 
process instances, you see two instances listed. Click each of the tabs to familiarize yourself with 
the dashboard. 

____ 5. Click the tab for the global monitoring context 'glob Instances'. There is a link between the 
instances widget and the diagrams widget on this page. Click one of the instances in the list and 
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you can see a customized diagram for this process instance. In the diagram it shows the elapsed 
time for each milestone for this instance, and the keys associated with each milestone. 

____ 6.	 Click the tab for the global context KPI's 'glob KPIs KPIs'. Here you can see the average elapsed 
time and current open instance count for each of the three milestones. The counts will show zero 
for this test since all the instances have been completed. 
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What you did in this exercise 

In the lab, you created a global monitoring context, and you published the model to the monitor server. 

You used the supplied events and played them back for the model. Then you viewed the monitored data in 
the auto-generated dashboards. 
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