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Chapter 1. Create a linked WebFacing and HATS application

In this tutorial, you will enable i5/0S® applications for the Web using two different techniques. First, you
will use the IBM® WebFacing Tool to convert the original DDS source for an application. Then, you will
use the Host Access Transformation Services (HATS) Toolkit to dynamically transform another
application. Next, you will link the two applications to create an integrated, combined HATS/WebFacing
application. Finally, you will customize the style and appearance of your integrated application so that it
has a consistent look and feel.

Learning objectives
* Using WebFacing and DDS source files, enable a host application for the Web
* Using HATS, enable a host application for the Web, without the use of DDS source files

* Link your WebFacing and HATS applications into one application, using the Linked HATS/WebFacing
Project wizard

* Find and work with a linked application, using the Project Explorer
* View and edit connection properties for a linked application

* Customize the linked application to provide a more consistent look and feel
Time required

60 minutes

Related information

E [View the PDF version|

Introduction

In this tutorial, you will learn how to link a HATS/WebFacing enabled project with a HATS project,
customize the resulting application, and test it.

Both the IBM WebFacing Tool and the HATS Toolkit offer ways to enable your core business applications
for the Web. The IBM WebFacing Tool converts your original DDS source files, providing a Web-based
user interface for your 5250 host application. The HATS Toolkit transforms 5250 data streams into HTML
dynamically, which enables applications to be migrated to the Web without accessing or modifying the
original source code.

You will use the WebFacing Tool to convert the DDS source for an order entry application. Then, using
the HATS Toolkit, you will Web-enable a customer inquiry application (CelDial).

Next, you will use the linked HATS/WebFacing project wizard to link the HATS and WebFacing projects
and create a single, linked enterprise application. This application utilizes the capabilities of both HATS
and the WebFacing Tool.

You will then use the WebFacing Projects view to run and test the linked application. You will also use
the Project Explorer view, which allows you to locate projects and change connection properties. Finally,
you will learn how to change the display and style settings for the WebFacing project and the HATS
project. These style settings let you render a linked application with a more consistent visual appearance.

Note: When working with your own core business applications, you will have to decide whether a

linked HATS/WebFacing project is the best way to Web-enable your application, or if a standalone
WebFacing or HATS project is better suited. While linked HATS/WebFacing projects generally allow you
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to leverage the advantages of both WebFacing and HATS, several issues should-be-taken-inte-acequnt. For
details on the unique features provided by WebFacing and HATS, refer to the |Developing i5/0S"
[WebFacing Applications|or the [Developing HATS Applications| help topics. For more information about
linked HATS/WebFacing applications, see the [Considerations for Linked HATS/WebFacing Applications|
help topic.

Skill level

Introductory
Audience
Current and prospective HATS and WebFacing developers

System requirements

* IBM Host Access Transformation Services (HATS) for System i Version 7.1 product with the WebFacing
tool installed. HATS and WebFacing installation requirements are listed in product documentation
available at |http:/ /publib.boulder.ibm.com/infocenter/hatshelp /v71/index.jsp|

— Rational Developer for System i (RDi) Version 7.1

— WebSphere® Application Server, Version 5.1 or later, must be installed to run and test your
application. WebSphere Application Server is an available option when installing the base product.

The WebSphere test environment is a runtime environment that is integrated into the workbench, for
testing applications that are targeted to WebSphere Application Server. This is where you will run
and test the HATS project, after first publishing your project to the test environment and starting the
test server.

— A trial license for two concurrent WebFacing connections is included. This trial license allows you to
test your WebFacing projects in the WebSphere test environment.

— All software updates available in the IBM Installation Manager should be applied and installed.
* i5/0S V5R4 or greater, with the latest PTFs installed

Prerequisites

* Verify installation of WebSphere Application Server 5.1 or greater in order to run the created
applications.

* The WebFacing server must be running on your server. Verify that jobs QQFWFSVR and QQFVTSVR
are running. This is done by using the WRKACTJOB JOB(QQF*) command in a 5250 session.

* Restore the WFLABXX savefile (WFLABXX.savf) on an i5/0S™ server:
1. Import wflabxx project in WFLABXX.zip to your workspace.

2. Open the Project Explorer view by clicking Window » Show View » Other > General > Project
Explorer.

3. Expand the wflabxx project.
4. Right-click the wflabxx.savf savefile, and select Restore on i5/0S.

5. Once the save file has been restored to the i5/0S server, you must then add the WFLABXX library
to your default library list.

For additional details on working with remote i5/0S servers, you may want to complete the Maintain
an ILE application using Remote System Explorer RDi tutorial.

* Verify all i5/0OS PTFs required for Rational Developer for System i (RDi) have been installed.
(Right-click i5/0S Objects and click Verify Connection on the pop-up menu).

Expected results

Upon completion of this tutorial, you will learn about the unique advantages offered by linked
HATS/WebFacing projects. You will know how to create and link a HATS/WebFacing enabled project
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http://publib.boulder.ibm.com/infocenter/hatshelp/v71/index.jsp?topic=/com.ibm.hats.doc/doc/getstarti04.htm
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with a HATS project. You will also be able to customize the style of the HATS and WebFacing projects to
provide a unified visual appearance when they run as a linked application.

The following screen captures illustrate the stages of creating a linked HATS/WebFacing project, from the
original 5250 terminal screens, to the WebFacing application and HATS application, and then to the
customized, linked HATS/WebFacing application.

5250 Application

Application dashboard

DASHBOARD Application Dashboard
Select one of the following:

1. Order Entruy
2. CelDial Communications

Selection or command

Fa=Exit Fd4=Frompt F9=Retrieve FlZ=Cancel
Fl3=Information Asz=zistant F1l6=System main menu

Order entry application

Parts Order Entry
Type cheices, press Enter
2=Change
Customar number . . . . Order number
F3=Exit F4=Prompt FE=Accept Order
G 06/833

Customer inquiry application (CelDial)
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CELDIAL CelDial Communications
Select one of the following:

1. Customer inguiry
2. bWork with inventory

Selection or command
===3

Fa=Exit Fd4=Frompt F9=Retrieve Flz=Cancel
Fl3=Information Asz=zisztant F1lb6=System main menu

WebFacing application

Application dashboard

DASHBOARD Application Dashboard

Select one of the following:

Order Entry
CelDial Communications

|N || 4

Order entry application

Parts Order Entry

Customer number . . . . . . . 0001 Order number

Customer name 1ie O

Address

City IO 078951-2345
Opt Part Description

HATS application

Customer inquiry application (CelDial)
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CELDIAL CelDial Communications

Select one of the following:

1. Customer inquiry

2_Wark with inventory

Work with inventory (CelDial)

6/11/29 CelDial -
Iype option, press Enter.
Z2=Change 4=Delete E=Display 8=Print

hdapter -
Antenna -replaceable

Auto Antenna - mag

Luto Antenna - perm

Linked and customized HATS/WebFacing application

Application dashboard: This application has been converted using the IBM WebFacing Tool.

DASHBCARD

Select one of the following:

Order Entry

CelDial Communications

|m|p

Application Dashboard

Customer inquiry application (CelDial) : This application

is shown using HATS.

CelDial
Select one of the following:

1. Customer inguiry
-

2_Work with inventory

Communications

Chapter 1. Create a linked WebFacing and HATS application
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Web-enabling an application with the IBM WebFacing Tool

In this module, you will use the WebFacing Tool to Web-enable a 5250 application, for which the original
DDS source is available. The end result is a HATS/WebFacing enabled project that you will later link to a
HATS project.

Learning objectives

After completing the lessons in this module, you will be able to perform these tasks:
* Start the workbench, then the HATS/WebFacing Enabled Project wizard

* Create a new HATS/WebFacing enabled project

* Set the i5/0S connection properties

* Select source members to convert

e Perform the source member conversion
Time required

This module should take approximately 10 minutes to complete.

Starting the workbench

In this lesson, you start the workbench and set the workspace location.

To begin creating a HATS/WebFacing enabled project, you need to start the workbench. You are asked to
define a workspace for your System i projects. Defining a workspace keeps all of your files in an
organized location.

To start the workbench

1. On the taskbar, click Start > (All) Programs > IBM Software Development Platform > IBM Rational
HATS 7.1 > HATS Toolkit 7.1.

2. When prompted for a workspace location, accept the directory structure provided, but change the
workspace name to 1inkwfhatsXX, where XX is a unique number. (If you are not automatically
prompted by a dialog box, click File > Switch Workspace.)

) Workspace Launcher

Select a workspace

Websphere Development Studio Client Advanced Edition for iSeries stores your projects in a folder called a workspace.,
Choose & workspace folder to use for this session,

Workspace: | C:\Documents and Settings '\Administ'ator'\',\'DrkspacelJink',\'ﬂ'latsbi'.ﬁ(I w |

3. Click OK. The user interface for the product, called the workbench, opens to the initial Welcome view.
Your work will be saved in the directory that you specified as your workspace location.

4. Close the Welcome view by clicking the X button in the Welcome tab.

% Remote System Explorer - Websphere Development Studio Client
File Edit Mavigate Search Project Data Run  Window Help

Welcome X
= = You can now begin working with the
workbench.

You have started the workbench and set your workspace location.
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Lesson checkpoint

You learned these things:
¢ How to start the workbench
* How to specify the name of the workspace

Creating a HATS/WebFacing enabled project

In this lesson, you learn how to begin creating a HATS/WebFacing enabled project.

By creating a HATS/WebFacing enabled project, you can convert the 5250 application source files from
your i5/0S server into a Web-enabled format. The HATS/WebFacing enabled project also allows you to
take advantage of the new interoperability features between HATS and WebFacing, by creating a Linked
HATS/WebFacing project later.

Unlike standalone WebFacing projects, HATS/WebFacing enabled projects are designed to work in
conjunction with HATS projects and cannot be run standalone.

The workbench initially displays the Remote System Explorer (RSE) perspective. This perspective allows
you to establish and manage connections to remote servers. You can also establish a connection when
creating a project, which is what you will do later in this tutorial.

To create a new HATS/WebFacing enabled project:
1. Click File > New > HATS/WebFacing Enabled Project from the workbench menu.

5 Edit Mavigate Search Project Data Run  Window Help

New Alt+shift+M  F B =N
Cpen File...

ﬁ ieries Library

Eﬁj ieries Source Physical File
C;f iSeries Source Member
Eﬁ iSeries Message File

(3t iseries Data Queus

(C§ iseries Data Area

@ WebFacing Web Project

g HATS /WebFadng Enabled Project

fgd WebFacing Portlet Project

Convert Line Delimiters To 4
Other...

% Example...
.
i

n

The HATS/WebFacing Enabled Project wizard opens.

Tip: Pressing the F1 key at any stage of the HATS/WebFacing Enabled Project wizard will provide
additional information about the current window or view and settings.

2. In the Project name field, type the project name 1inkwfXX, where XX is a unique number.

Note: It is probably easiest to use the same value for XX that you used when naming your workspace
and your HATS/WebFacing enabled project.

3. Select WebSphere Application Server v6.1 (if available, otherwise select WebSphere Application
Server v5.1 or later) from the Target Runtime field. Leave the default values for the rest of the fields.

Chapter 1. Create a linked WebFacing and HATS application 7



o] HATS/WebFacing Enabled Project

HATS/WebFacing Enabled Project —
=1
Create & WebFacing Web Project that is enabled for HATS D’

Project name: | linkwfXx |

Project contents:
Use default

Target Runtime

WebSphere Application Server vé. 1 R | ’New. - l

Configurations

| <custom= b’ |

Hint: Get started quickly by selecting one of the pre-defined project configurations.

[ configure advanced settings

4. Click Next. The Choose a Web Style page opens.

5. On the Choose a Web Style page, leave the Select classic WebFacing style radio button selected, and
select swirl from the styles list.

# HATS/WebFacing Enabled Project
Choose a Web Style |

o -
Select a "Look and Feel” style to use for the project.

(T Enable for Web Site Designer

(%) Select dassic WebFacing style

Select a predefined or previously customized style:

AVENUE
corporate 1
financialGreyRedtones
fun

gradient

sage

sagel

sEor’rs

textbuttons

Feretaraint

\Z) < Back ][ Mext = ” Finish H Cancel

8 Create a Linked WebFacing and HATS Application



Note: The financialGreyRedtones and swirl styles have matching styles for HATS projects. In order to

provide a unified user interface across both HATS and WebFacing applications, select one of these
styles.

6. Click Next. The Select Source Members to Convert page opens. You will do more work on this wizard
page in the next lesson.

You have launched the HATS/WebFacing Enabled Project wizard. You also provided a name, project
settings and a style for the HATS/WebFacing enabled project.

Lesson checkpoint

You learned these things:

* About HATS/WebFacing enabled projects

* How to begin creating a HATS/WebFacing enabled project
* How to select a HATS/WebFacing enabled project style

Setting System i connection properties

In this lesson, you learn how to set i5/0OS connection parameters for your HATS/WebFacing enabled
project.

You must establish a connection to a remote i5/0S server in order to select source members and run
applications. Once the connection is established, it will be available to all projects in the workspace.

To connect to a i5/0S:
1. Click New beside the Connection name list.

o) HATS/WebFacing Enabled Project El

i

Select Source Members To Convert
Select "Refresh list” to refresh the library items displayed in the tree. D’
Select members from the tree and add them to the table for conversion,

Project name:
[ linkufxx |
Connection name:

| v [[new... |

% New El

Name personal profile

Uniquely name user profile :H:

Welcome to Remote Systems, Connections can be sharable by the team or
private to you. Enter a profile name to uniquely identify you from your team
members. You will decide for each new connection whether it is owned by the
team profile or your profile.

Profile: | default

@

2. On the Name personal profile page, accept the default profile name, as this is your own private
connection. Click Next.

Chapter 1. Create a linked WebFacing and HATS application 9



10

On the Remote i5/0S System Connection page, in the Host name field, type the name or IP address
of the host system, for example s400a. (Do not use the example shown unless your system is named
s400a.)

% New

Remote iSeries System Connection

Define connection information =H=

Parent profile: | default W |

Connection name: | s400a |

Host name: | 5400z 3 |
Description: | |
Verify host name

':':’:' [ < Back ” Mext = l I Finish ] [ Cancel ]

The Connection name field is automatically filled with the same value.
Leave the Verify host name check box selected to verify that the host name or IP address exists.
Click Finish.

The connection is created and can be re-used by all tools in the workbench. It also opens in the
Remote Systems view. The connection wizard also confirms that the i5/0S host can be reached. If
this test is completed successfully, you return to the Select Source Members to Convert page.
Confirm that your i5/0S host name is selected in the Connection name list.

Make sure that *LIBL is selected in the Library list. Both the File and Member lists should have *ALL
selected, and the Type field should contain DSPF MNUDDS PNLGRP.

Click Refresh list.

Project name:

[ linksx |
Connection name:

|s—1EIDa w | [New. = ]

Library: Files Member: Type:
| D v| [Em v | [Em ~ | |DsPF MNUDDS PNLGRP (v |

Click the Refresh list button, then select files or members and add them to the table for conversion:

I Refresh list

A user ID and password dialog box opens. Before you can select source members to convert, you
must log on to the remote i5/0S system.

Create a Linked WebFacing and HATS Application



% Enter Password E]

System type: iSeries
Hostname: 54004

UserID: | IDTESTL |

Password: | ””””””” |
Save user ID
Save password

[ oK |’ Cancel l

9. In the User ID field, type the name of an i5/0S user profile that has access to the WFLABXX library.

10. In the Password field, type the password for this user profile; select the Save user ID and Save
password check boxes; and click OK.

A connection to the i5/0S server is established. The library list of your i5/0S profile is displayed under
the Refresh list button on the Select Source Members to Convert page.

Lesson checkpoint

You learned these things:

* How to create a new connection profile

* How to establish a connection to a i5/0S server

* How to provide a connection profile on the Select Source Members page
* How to provide your i5/0S user ID and password

Selecting source members

In this lesson, you select source members to be converted for the HATS/WebFacing enabled project.

In order to convert an application using the IBM WebFacing Tool, you must provide a list of source
members to convert from the remote i5/0S server. The WebFacing Tool will generate a Web interface for
your application based on these source members.

To select source members to convert:
1. Select the WFLABXX library from the list.
2. Click the plus sign (+) beside the WFLABXX library to expand it.

| 54004 =LIBL =ALL *ALL DSPF MNUDDS Pt |

=i QsYs2 ”~
B QHLPSYS

= QUSRSYS

= [N

5o QcLsRe

5 qoossre
[ QoDssRop
3 QMNUSRC
[ QPMLSRC
5 gpMLSReP
Ef QrPGLESRC
[ QRPGLESRCP

.- Dl

3. Expand the QDDSSRC source file, and select all its members.

E-E--E- BB

b
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|5400A “LIBL *ALL ®ALL DSPF MNUCDS PP

=i Q5Ys2 ~
=l QHLPSYS
Bl QUSRSYS
=2 WFLABXX

[5 qeLske

=[5 opbssre

[ qoDssRep
5 oMusre
55 qPhLsrRe

E‘ﬂ DK DD

B BB

b

4. Click the push button to copy the selected members over to the list of members to be
converted.

Tip: To move all members in a source file, you can select the source file icon itself and click the push
button . This adds all members in a source file to the list of members to be converted. To
select multiple source files, hold down the Ctrl key while clicking each one.

5. Select the QMNUSRC and QPNLSRC source files, and click the push button to copy the
selected members over to the list of members to be converted.

You have selected the source members that will be converted. The conversion has not happened yet,
but the information is stored for future use.

The list of source files now shows your selected source members.

Library File Member Type

WFLABXX C

6. Click Next to proceed to the Specify CL Commands page of the wizard.
You have selected the source members for the WebFacing Tool to convert.
Lesson checkpoint

You learned these things:
* How to select source files and members for the WebFacing Tool to convert
* About the conversion list

Completing creation of the HATS/WebFacing enabled project

In this lesson, you will complete the creation of your HATS/WebFacing enabled project and convert its
source members.

At this point, you are on the Specify CL Commands page of the HATS/WebFacing Enabled Project
wizard:

12  Create a Linked WebFacing and HATS Application



o] HATS/WebFacing Enabled Project

Specify CL Commands ey

Enter the CL commands that are used in your application, the command labels you want to use, and the signon D’
preference for the generated hypertext links,

Project name: | linkwfXX |

WebFacing generates hypertext links that you can use to launch your application from the Web. Inorder to do this, it needs
to know the text that will be shown for each link and the CL command that each link will invoke. On this page you can define
multiple links, in case several CL commands are used to launch your application.

If your program requires parameters, you can enter them as variables in the CL command. For example: to invoke program
MYPGM with a part number parameter, you would enter CALL MYPGM PARM{&part) as the CL command. The variable "&part”
will be replaced when you dick on the invocation link. For details, refer to the generated index.jsp file. The invocation name is
used to uniquely identify each hyperlink in the index.jsp file.

CL command:

|
Command label: | |
|

Invocation name

(%) Prompt for signon
(") Specify ©5/400 signon values

CL Command Command Label Invocation name User ID

|
155

.

@ ’ < Back ” Mext = l

CL command entries are used to generate a menu, which appears when you run a WebFacing project.

You will specify a CL command for the application.

To add a CL command and complete creation of the HATS/WebFacing enabled project:

1. On the Specify CL Commands page, enter GO DASH in the CL command field. The GO DASH
command launches the Dashboard menu, which allows access to both the order entry and the

customer inquiry (Celdial) applications.

By default, the Command label field is set to the CL command that you specified, and the Invocation

name field is set to INV1.

2. Select the Specify i5/0S signon values radio button. The authentication boxes are populated with the

user ID and password you provided for the i5/0S connection.

CLcommand: | GO DASH |

Command label: | GO DASH |

Invocation name | INV1 |

() Prompt for signon
(%) Specify 05/400 signon values

UserID | IDTEST1 |

e

[F— |

Paszword | | Confirm password

3. Click the Add button to add the command to the CL commands list.

Chapter 1. Create a linked WebFacing and HATS application
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CL Command Command Label Invocation name

GO DASH INV1

You have added a CL command. Now, you will complete the creation of the HATS/WebFacing
enabled project.

4. Click Next.

5. On the Complete WebFacing Project page, select Yes. I want to create the project and proceed with
conversion now.

% HATS/WebFacing Enabled Project ]

Complete WebFacing Project A —

=]

You have indicated the spedifications for your new WebFacing project. To continue, D’
dick Finish.

You are about to create a WebFacing project.
Do you also want to convert the selected display files?

(3)ifes, I want to create the project and proceed with conversion now,

(¥ Mo. I only want to create the project now.

':':’:' et > Finish H Cancel ]

6. Click Finish.

The HATS/WebFacing enabled project is created, and source member conversion automatically
begins.

7. When you are prompted to confirm that you want to switch to the WebFacing perspective, click Yes.
The WebFacing perspective allows you to work with the project resources and view its files.

] Open Associated Perspective?

y This kind of project is assodated with the WebFacing perspective. Do you
\:/ want to open this perspective now?

[Jremember my decision

[ fes l l Mo ]

The WebFacing perspective opens, with your new HATS/WebFacing enabled project in the WebFacing
Projects view. The new HATS/WebFacing enabled project is denoted by the icon shown here:

[ webFacdng Proj... &2 Mavigator | — O
5 linkwfx

You have created the HATS/WebFacing enabled project and converted its source members.
Lesson checkpoint

You learned these things:
* How to add CL commands to a HATS/WebFacing enabled project
* How to complete creation of a HATS/WebFacing enabled project

14  Create a Linked WebFacing and HATS Application



* About the WebFacing perspective

Module summary

In this module you learned how to create a HATS/WebFacing enabled project that can later be linked to
a HATS project. You also learned how to specify a visual style for your project, create a connection, add
CL commands, and convert selected DDS and UIM source members.

Lessons learned

By completing this module, you learned about the following concepts and tasks:
* How to start the workbench

* How to create a new HATS/WebFacing enabled project

¢ About connecting to a remote i5/0S server during project creation

* About the Remote System Explorer and WebFacing perspectives

Assessment
* How do you create a new project in the workspace?
* What is the HATS/WebFacing Enabled Project wizard?

¢ List the steps to create a new connection to a System i from the HATS/WebFacing Enabled Project
wizard.

* List the steps to create a HATS/WebFacing enabled project.
* What perspective allows you to work with HATS/WebFacing enabled projects?

Creating a HATS application

In this module, you will create a new HATS project to run the 5250 customer inquiry (CelDial)
application. You will also run and test the application in the WebSphere test environment. Finally, you
will create a HATS macro to automatically perform a command when the customer inquiry application is
run.

Learning objectives

After completing the lessons in this module, you will be able to perform these tasks:
* Create a new HATS project

* Run and test the customer inquiry application in the WebSphere test environment
* Create a HATS macro

Time required

This module should take approximately 10 minutes to complete.

Creating a new HATS project

In this lesson, you will create a new HATS project using the Create a Project wizard.

Unlike a HATS/WebFacing enabled project, which transforms a particular set of 5250 application source
files, a HATS project transforms the data stream from the remote i5/0S server without requiring
conversion. When testing your HATS project, you can use a display terminal to observe interactions
between the HATS application and the host application.

To create a new HATS project:
1. Click File > New > Other.

Chapter 1. Create a linked WebFacing and HATS application 15



ZW Edit Mavigate Search Project Data Run  Window Help

New ISt T Project...

Cpen File...

@ WebFacing Web Project
@ HATS\WebFacing Enabled Praject
{gd WebFacing Partlet Project

¥ Example...

B New
Select a wizard
Create a HATS project
Wizards:
| type filter text |
(= HATS 2
@i HATS Administration Project
@ HATS Business Logic
% HATS Component
=ﬁ_ HATS Connection
{5 HATS EJB Project
Eﬁ HATS Feature Project
o HATS Host Simulation B
S NFHATS Project
ﬁ HATS Screen Combination
ﬁ HATS Screen Customization
- HATS Template
-[F HATS Transformation hd
[ show all wizards,

3. Click Next.

4. On the Create a Project page, enter TinkhatsXX in the Name field. Leave the default settings for the
Description, Location and Deployment fields.

Note: You can only link a HATS project to a WebFacing project when you select the Web
deployment option.
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#% Create a Project

HATS Project

A HATS project is a set of resources used to transform host terminal applications.

Mame: | linkhatsxx |

Description:
{optional)

Location: Use default location

Deployment

Select a deployment environment and configure deployment options:

& web
Target server: |'.-'u'eb5phere Application Server v6. 1 w |
Enterprise application project: | HATS_EARG1 L¥3 |

Add administration console support

(O Rich client

Press F1 for help on any field in this or any other HATS wizard.

':':7:' ’ < Back ” Mext = l

Click Next. The Connection Settings page opens.

On the Connection Settings page, enter the host name or IP address for your i5/OS server, for
example, s400a.

In the Type drop-down box, you can select either a 5250 connection or a 5250W connection. 5250
connections use the standard System i Telnet connection, while 5250W connections use the
WebFacing server installed on the remote System i. Regardless of which connection type is selected
for the HATS project, a 5250W connection will be used when it is run as part of a linked
HATS/WebFacing application.

Select 5250W in the Type drop-down box.

When the Confirm Requirements message box opens, click OK.

@ Confirm Requirements

. Before selecting the 5250W connection type, please refer to the HATS
\1‘) Information Center for the latest information on operating system
requirements.

Mote: The default port for the 5250W connection type is 4004,

[JDo not show this message again
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9. The Port, Code page and Screen size fields are now enabled. These fields contain default connection
settings. If your WebFacing server runs on an alternative port, or your i5/0S server uses a different
code page or works with another screen size, select the appropriate options from the drop down
boxes. Otherwise, accept the default values.

Create a Project - linkhatsXX

Connection Settings —
Configure host connection settings for this new project. You can spedify advanced connection

values later in the connection editor.

Host name: | s400a |

Type: 525000 v| &3
Port: 4004
Code page: |U3I-' Canada w

Screen size: |24 x 80 L

[[] add graphical interface DDS keywaords (ENPTUI) rendering suppart

7 [ < Back ” Mext = l

10. Click Next to proceed to the Project Theme page.

&% Create a Project - linkhatsXX

Project Theme —
A theme groups a set of commaon appearance and behavior characteristics for
a project. These attributes can be individually modified later.
Look and feel theme
(*) standard
(") Modern Web application
() Classic terminal emulatar
O Custom
Settings: Description:
[] automatic field advance Move the cursor to the next input field if
[] cursor pasitioning on protected fields | | the cursor is located at the end of the
[ Field extended attributes current input field, If aubo:advan-:e i
] Hast keypad disabled, the cursor doesn't go to the
Keyboarclljsupport next input field until the user explicitly
maves it
Cperator information area
Owerwrite mode
Rendering using monospaced font
':':7,' [ < Back ” Mext = l I Finish ] [ Cancel ]

The Project Theme page allows you to customize the behavior of the application, using themes that
closely reflect a specific application environment. For example, the Modern Web application theme
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will make the HATS project act as if it were a typical Web application, with manual advancing of
fields and variable width fonts. The Classic terminal emulator theme applies all the available

settings, making the application act in a similar fashion to its operation on the 5250 terminal. You
can also select individual custom settings.

11. Select the Standard radio button, which provides a balance between a modern Web application and a

classic terminal emulation, and click Next.

12. On the Select Default Template page, select Swirl.jsp from the list of templates. This template will

closely match the style of your HATS/WebFacing enabled project.

&% Create a Project - linkhatsXX

Default Template —
A template controls the basic layout and style (such as color and font) of the application.

‘fou can modify this template later or create one based on your existing Web site,

Template: Preview

Blank.jsp

ClassicTerminal.jsp

CorporateBanner. jsp M Com . an

CorporateBlackshaded.jsp
CorporateBlackTan. jsp
CorporateMonoBlue.jsp
CorporateMonoTan. jsp Host
CorpaorateTanShaded. jsp
EagleCanyon.jsp
EagleFloweringTree.jsp
EagleForestiske.jsp
Eagle\WTabs.jsp
FinancislGreyRedtones. jsp
InsuranceGreenizeometrics, jsp
InsuranceGreenshaded. jsp
SimpleBlack.jsp

SimpleWhite. jsp
SlickMonoGray.jsp

SEorts ! ESE

Transportation. jsp
TravelRandomDestination.jsp
TropicalFlight.jsp

|
|

':':’:' Finish ] [ Cancel

13. Click Finish.

The Create a Project wizard completes and the workbench switches to the Host Access Transformation

Services perspective. Your new HATS project has been created, and the HATS project overview opens in
the editor area.

If a HATS Tip message box opens, read the message, and then click OK.
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%@ HATS Tip

Welcome to HATS!

@ Please follow the tutorial in the "Welcome to HATS' page to create your first

L ﬁ project.

Press F1 for help on any figld,

[ b not show this tip again _
OK

|:| Do not show any tips

Lesson checkpoint

You learned these things:

* About HATS projects

* How to create a new HATS project

¢ About different connection types for HATS projects

* How to specify connection settings for a HATS project
* How to select a visual style for a HATS project

Running and testing the HATS application

In this lesson, you will run and test the customer inquiry application by launching the HATS project in
the WebSphere test environment.

The WebSphere test environment is a runtime environment that is integrated into the workbench, for
testing applications that are targeted to WebSphere Application Server. This is where you will run and
test the HATS project, after first publishing your project to the test environment and starting the test
server.

When you run a HATS project in the test environment, you have the option to display a debug terminal,
so that you can view the native System i connection while testing and debugging your application.

To run and test the customer inquiry application in the HATS project:

1. In the editor area of the workbench, click the linkhatsXX Settings tab. In the Testing section of that
page, click the Launch on WebSphere Application Server in Debug mode link.
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{1 welcome to HATS 52 RN et e

Overview
Summary information for your project. Click & tab at the bottom to navigate to that page.

@ The runtime for this project has not been enabled and will be restricted to 2 connections.

General Information

General information about this praject.

Mame: linkhatsXx
Description:

Template: Swirl.isp
Theme: Standard

Last modified: 11-Dec-2006 12:00:14 PM

Testing
Test this application from your development environment.

{3 Launch on Websphere Application Server

I i? Launch on WebSphere Application Server in Debug mode I

Important: Before you test your application, verify that the WebFacing server is running on your the
server. Verify that jobs QQFWEFSVR and QQFVTSVR are running. This is done by using the
WRKACTJOB JOB(QQF*) command in a 5250 session.

If these jobs are not running then you need to start the WebFacing server. On a CL command line,
type strtcpsvr *webfacing.

When the Display Terminal dialog box opens, click Yes to confirm that you also want to see your
5250 application screens in the debug terminal as you run your HATS project.

] Display Terminal

€ ) Do youwant to see the display (debug) terminal while running your application in the local test
\:{) environment (this setting will not affect the deployed application)? The display terminal can be useful in
diagnosing screen recognition and macro playback problems.

Mote: If your application is already running, you may need to disconnect and restart the application
before your changes can be applied.

oo not shaw this dislog again. You can turn this message back on by going to Window > Preferences > HATS.

[ fes H Mo ” Cancel ]

The HATS Tip dialog box opens. This dialog provides information about the Debug/Run on Server
wizards and Console view. Once you have read the information, click OK to continue.
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The Debug/Run on Server wizards allow you to define the server on
which to test your application. The Console view displays progress while
the server is starting and information while you interact with the application.

When the Web browser appears, you can:

- follow template links

-navigate in your host session

- copy the URL into a regular browser window to see the application as a
user would

Note: Starting in HATS version 7, Debug on Server should be be used if
you want to see changes made to your project as it is running on the server,
and Run on Server should be used if you want to simulate running your
application on & production server,

When you are done, continue to follow the tutorial in the Welcome page.

[[] bo not show this tip again
[] Do not show any tips

The Debug on Server wizard opens.

o) Debug On Server

Define a New Server
Choose the type of server to create

How do you want to select the server?
O Choose an existing server

(%) Manually define a new server

x)

Server's host name: | localhost

Select the server type:

Don't see your server listed? Click here

Eﬁ WebSphere Portal w5. 1 for Import, Export & Deplay
@ WebSphere Portal v5. 1 Server Attach
WebSphere Portal 5. 1 Test Environment
WebSphere Portal v6.0 Server
£ websphere v5 Server Attach
ﬁ WebSphere v5. 1 Server
ﬁ WebSphere v5. 1 Test Environment
WebSphere v6.0 Server
WebSphere v6. 1 Server
(== JBoss

R

b

Description: Runs J2EE projects on the WebSphere v6. 1 Server,

Server runtime: |Web5phere Application Server v6.1 W | [lnsialled Runtimes. .. ]

[“]5et server as project default (do not ask again)

7 [ Mext = ” Finish H Cancel

l

3. The WebSphere test environment provides a local WebSphere Application Server instance on your
workstation for testing Web applications. You will use the WebSphere test environment to quickly
view and test your HATS project, without needing to publish the project to a remote WebSphere

Application Server.

You have a choice of installing and testing on different versions of WebSphere Application Server in
the workbench test environment. HATS projects can run on WebSphere Application Server, versions
5.1 and later. Select the same version of WebSphere Application Server that you specified when you

created the HATS project.
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4. Click Finish.

The WebSphere Application Server test environment starts, and your HATS project is published
there. The display terminal also opens. After a few moments, a Web browser opens in the editor area
of the workbench.

5. Switch between the Web browser view and the display terminal. Notice how the HATS application
has transformed the host screen to a Web look and feel and applied the "swirl” theme that you
selected when you created the project.

6. To demonstrate the Refresh button functionality and synchronization between the terminal and

browser windows, type your user ID and password in the Terminal window. Do not press Enter yet.
(Your sign-on screen may appear differently than the following screen captures.)

IEM Canada Ltd. Toronto Lab S¥stem . . . . .

Subsysten . . . . @

Display . . . . . =

User ID . . . . : IDTESTL Pazsword . _
Program/procedure: Menu

Current library. . :

7. Switch to the Web browser view and click the Refresh button in the set of application keypad
buttons.

The page refreshes the display from the i5/0S connection. The user ID and password fields should
contain the user ID and password entered in the Terminal window.

@ Welcome to HATS linkhatsXX Settings  linkhatsXx X

L] I |htu::.r',ﬂocalhost:gljs1.r1inkhats}{_5{.r'entry
My Compan
IBM Canada Ltd. Toronto Lab Sy=stem
Subsy=stem .
Display . .

User ID

Program/procedure: I:I Menu

Current library.

Password . Tl

i

You can minimize the Terminal window and work with your HATS application entirely within the
Web browser.

Press Enter to sign on to the remote i5/0S system. (Press Enter again, if necessary, to continue the
sign-on request.) HATS dynamically transforms the 5250 data stream from the remote system and
displays the initial command line.

8. To test the customer inquiry (CelDial) application, enter GO CELDIAL on the command line to launch
the CelDial menu.

SJelection or command
===> |60 CELDIAL

The CelDial menu opens.
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CELDIAL CelDial Communications

Select one of the following:

1. Customer inquiry

P

2_Wark with inventory

9. Click 1. Customer inquiry to access the customer inquiry screen.
10. Press F4 to access the customer list prompt.

Select Customer

Type option, press Enter
1=5elect 5=Display

(=]

IR O

Hame
SmithCo Limited Liability

Meridien Electronics Limited

Royal Hardware Supplies

Webster Appliances

0010700 Universal Communications Ltd.

Baker Electronics

11. Type 1 beside a customer name and press Enter to select that customer. The customer number
appears in the Customer number field. Press Enter again to view this customer’s information.

12. The Customer Detail page opens.

CelDial - Customer Detail
Press Enter to continue
Humber . . . . : 0010200
Name . . . . . @ Royal Hardware Supplies
hddres= . . . : Maple View Plaza, 256 Hew Sc.

When you are done viewing the information, close the page by pressing Enter, and then press E3 to
return to the main CelDial Communications menu.

13. Click 2. Work with inventory to access the Work with Inventory screen.

6/11/29 CelDial - Work with Inventory
Iype option, press Enter.
Z2=Change 4=Delete E=Display 8=Print
o Number Description
00001 Adapter - 120V

00002 hdapter - 120V
Antenna -replaceable

Auto Antenna - mag

N =

Luto Antenna - perm

14. Select a part from the list and type 5 beside it to display detailed part information.
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Mode: DISPLAY CelDial - Part Detail

To view another part, press F12 to return to the part selection page.

Note: You can further enhance your HATS project using the many customization features available
to it, such as macros. For more details, please refer to the [HATS Getting Started| help topic, or the
[User’s and Administrator’s Guidel

15. Press F3 to return to the main CelDial menu.

You have successfully run and tested your HATS project in the WebSphere test environment.
Lesson checkpoint

You learned these things:

* About the WebSphere test environment

* About the debug terminal for testing a HATS project

* How to display the debug terminal

* How to run and test a HATS project in the WebSphere test environment

Creating a HATS macro

In this lesson, you will learn about HATS macros, which allow automation of tasks when running a
HATS application. You will create a macro that automates entering a command in the customer inquiry
(CelDial) application.

One of the unique features of a HATS project involves the ability to create macros. Macros allow
sequences of keystrokes to be recorded and sent to the remote i5/0OS server when certain events occur.
They allow you to prompt the user for input, extract data from the host screen, and move from one
screen to another without showing the intermediate screens. For example, a macro can automatically
perform commands when you open an application.

In this example, when you run the application on the Web, you may not want to show the initial CelDial
menu. Instead, you want to invoke the inventory application directly, without giving the end user a
chance to select the customer inquiry option. To accomplish this, you will create a new HATS macro that
automatically selects option 2 on the Celdial menu, which invokes the inventory application.

To create a new HATS macro:

1. Select the linkhatsXX project, and click HATS > Open HATS Host Terminal. (If you do not see the
HATS menu item, switch to the Host Access Transformation Services perspective by clicking
Window > Open Perspective > Other > Host Access Transformation Services.)
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GEAEN Run Window Help
MNew 4
@ Mew Linked HATS /WebFacing Project ...

4 Open HATS Host Terminal
{3 Run HATS Project
I Export Project

ﬁj Open HATS Welcome Page

&= License Settings...

(@ Gather Problem Determination Information

A new HATS host terminal window opens and displays the default sign-on screen for your HATS
connection. (The i5/0S screens may appear different in your environment.) If the HATS Tip window
opens, read the information about the Host Terminal, and then click OK to close the HATS Tip
window.

% main - Host Terminal

Host Terminal | Host Screen Preview |

% & B-B-E %
IBM Canada Ltd. Toronto Lab System . . . . . &
Subsystem . . . . :
Display - . . - . =
User ID . . . . : Password .
Brogram/procedure: Menu

Carrent library. . :

Sign on to the remote i5/0S server using he Host Terminal window. The i5/0S main menu opens.
At the command line, enter GO CELDIAL and press Enter to access the customer inquiry (CelDial
application).

You will record a screen capture of the customer inquiry (CelDial) application. A screen capture is
necessary for HATS to recognize the CelDial menu, so that the appropriate macro can be run when

the CelDial application opens. Click the # Create Screen Capture button in the toolbar. The
Capture a Screen dialog opens.

&% Capture a Screen

Capture a Screen
Enter a name and select a location for this new captured screen.
Mame: | startCeldial |
Select destination location: E Sereen Captures
':':’:' I Finish ] [ Cancel ]

Enter startCeldial in the Name field, and click Finish. The screen capture is saved in your
workspace.

Click the ® Record new macro or insert to the open macro button in the toolbar to begin the
macro recording process. The Record Macro dialog opens.

Enter invMacro in the Name field, and click Finish.
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&% Record Macro

Record Macro
The macro will start recording after you dick finish,

Project: |Iink.hats>{>( v |
Mame: |
Location: | linkhatsXX\Web Content/W/EB-INF /profiles fmacros finvMacro.hma |
Description:

{optional)

':':7:' I Finish ] [ Cancel ]

8. The Define Screen Recognition Criteria page opens.

11.

12.
13.

14.

15.

Screen Mame: | eldialScreen |

CELOIAL Cellial Communicetions

Select one of the following:

1. Customer inguiry

Z2_ Work with inwentory

In the Screen Name field, type celdialScreen. Accept the default selection area, and click Next.
Click Finish. The macro recording process begins.

Type 2 and press Enter. Notice that as you type commands, they appear in the Macro Navigator.
After you press Enter, the Work with Inventory menu is displayed in the terminal area.

Click ® Stop Macro in the toolbar to end the macro recording process. The Define Screen
Recognition Criteria dialog appears.

In the Screen Name field, type exitScreen. Click Finish to complete the macro recording process.

Close the Host Terminal window. When you are prompted to save the macro, click Yes. The macro is
saved in your workspace.

To launch the macro when the CELDIAL menu is displayed, you will create a screen customization.
Right-click the linkhatsXX project in the HATS Projects view, and select New HATS > Screen
Customization. The Create a Screen Customization dialog opens.

] Mew HATS d & Project
Conne MNew Linked HATS \WwebFacing Project...
% Scree % _I# Connection
5 screef Cpen HATS Host Terminal k *E} Host Simulation
=] ﬂ Sereel ﬁj Qpen HATS Welcome Page .
@ ¢ -»i" Screen Customization
5
=8 Macro Fj Screen Combination
% in] =] Copy [ﬁ Transformation
8 Web ( Ei Template
P

In the Name field, enter celdial, and click Next.
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<& Create a Screen Customization @

Screen Customization

A screen event that defines a list of actions to perform when a set of recognition %
criteria matches a host screen.

Project: linkhatsxx W
MName: celdial

Location: linkhatsX¥Wieb Content/\WEB-INF fprofiles/events /screencustomizations fceldial evnt
Description:

{optional)

;

16. The Screen Recognition Criteria page opens.

4 . . .
= Create a Screen Customization - celdial

!

Screen Recognition Criteria
Specify how to identify the screen. You can make the criteria more or less specificin order to ﬁ
match one or many screens. You can add additional criteria in the screen customization editor,

Select 3 screen source

() Use a previously captured screen

Screen: startCeldial

Celliel Caommunicetiona

[ < Back ” Mext > l

You will notice that the startCeldial screen capture is selected by default. Click Next.
17. The Actions page opens.
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18.

19.

20.

21.

22.
23.

. . - .
4= Create a Screen Customization - celdial

Actions
These actions will be performed when a host screen matches the recognition criteria for this screen 5
customization. You can also add or modify actions later using the screen customization editor.

[ apply a transformation
[ Creates a new blank transformation. You can later
add individual compaonents in the Insert Default
Rendering or Insert Host Component wizards.

Macro: |invMacro hd

[ Add advanced actions

':':’:' [ Finish H Cancel ]

De-select the Apply a transformation check box, and select the Play a macro check box. By default,
the invMacro macro is selected.

Click Finish to create the screen customization. The new screen customization is displayed under the
Screen Customizations folder for the linkhatsXX project.

You will now test the macro in the WebSphere test environment. Double-click Project Settings under
the linkhatsXX project to display the linkhatsXX Settings editor.

Click the Launch on WebSphere Application Server link under the Testing header.

The HATS project is published to the WebSphere test environment, and a Web browser opens in the
editor area of the workbench.

Complete the sign-on process in the web browser.

Once the i5/0S Main Menu displays, enter GO CELDIAL on the command line, and press Enter to
open the customer inquiry (CelDial) application. The HATS macro takes control, bypassing the
CelDial menu, and then displays the Work with Inventory menu.
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ﬁ

Bo12.01 CelDial - Work with Inventory

Type option, press Enter.
2=Change 4=Delete S=Di=plav S=Print

0

Humber Description
goool Adapter - 120V

oooo2 Adapter — 120V
ooons Antenna -replaceable

'd
et

oooo4 Auto Antenna — mag

I

oooos Auto Antenna — pern

You have created and tested a HATS macro to perform an application command.
Lesson checkpoint

You learned the following:

e About HATS macros

* How to create and record a HATS macro

* How to use a HATS macro to perform an application command

Module summary
In this lesson you learned how to create, run and test a HATS project in the workbench.

Lessons learned

By completing this module, you learned about the following concepts and tasks:
* About using a HATS project to Web-enable a 5250 application
* How to create, run and test a HATS project in the WebSphere test environment

* How to record a macro and use it in a HATS project

Assessment

* What debugging feature does a HATS project allow when being launched?
* Describe the purpose of the WebSphere test environment.

* What are some of the uses of a HATS macro?

Linking a HATS/WebFacing enabled project with a HATS project
In this module, you will link the HATS/WebFacing enabled project with the HATS project created earlier.

You will also run and test the linked application in the WebSphere test environment.

After you have created a HATS/WebFacing enabled project and a HATS project, you can link them using
the Linked HATS/WebFacing Project wizard. While it does not matter which order the projects are
created in, both projects must exist in the workspace before you can begin the linking process.

Learning objectives

After completing the lessons in this module, you will be able to perform these tasks:
¢ Link the HATS project to a HATS/WebFacing enabled project
* Run and test the newly-linked project
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Time required

This module should take approximately 10 minutes to complete.

Linking the HATS/WebFacing enabled and HATS projects

Using the Linked HATS/WebFacing Project wizard, you will link your HATS/WebFacing enabled project
with your HATS project.

By linking the HATS/WebFacing enabled project and HATS project, you can combine applications with
converted source and unconverted source. This seamless interoperability allows you to leverage the
advantages of both WebFacing and HATS.

Before a screen is displayed in the Web browser, the linked project is scanned for the converted source
files. If these files are present, the WebFaced page is shown. Otherwise, the HATS data stream
transformation is displayed.

1. In the HATS Projects view, right-click the linkhatsXX project.
2. From the pop-up menu, select New Linked HATS/WebFacing Project.

Navig... | — O |[ §] welcome to HATS §

' Projec MNew HATS 3
B Rouu=] B New Linked HATS WebFadng Project...
5 Screer
B screer Open HATS Host Terminal L |
ﬁ Screen [l Cpen HATS Welcome Page
@ Macrod
29 webd

i Source [I2) Copy

¥ Delete

Tip: If you are in the WebFacing perspective, there is an alternative method of creating a new Linked
HATS/WebFacing Project. Simply right-click the HATS/WebFacing project and select Link With >
HATS Project.

The Linked HATS/WebFacing Project wizard opens, with your HATS project name specified by
default. Only HATS Web projects with a connection type of 5250 or 5250W are displayed in this list.

Note: If you select a HATS project with a 5250 connection type, the connection type for the linked
HATS/WebFacing project will still be 5250W.
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% Create a Linked Project

Linked HATS/WebFacing Project ) \—‘l
Select a HATS project and a WebFacing project to link in a single application. L .g

HATS project:
WebFaring project: | w |
Target server: |WEbSphere Application Server va. 1 v |

Enterprise Application project name: | |

P
3] Cancel

3. In the WebFacing project list, select the linkwfXX project. Only HATS/WebFacing enabled projects
are displayed in this list.

% Create a Linked Project

Linked HATS/WebFacing Project t
Select a HATS project and a WebFacing project to link in a single application. L .g

HATS project: linkhatsXx v|
WebFaring project: |Iinkwﬂo< w |
Target server: |WEbSphere Application Server va. 1 v |

Enterprise Application project name: | linkhats)X_linkwfXXEAR |

?) < Back [ Mext = l I Finish ] [ Cancel ]

By default, your linked project name will be the HATS project name, followed by an underscore and
your HATS/WebFacing enabled project name, followed by EAR. Because the HATS project is named
TinkhatsXX and the HATS/WebFacing enabled project is 1inkwfXX, the Enterprise Application project
name will be TinkhatsXX_1inkwfXXEAR.

4. Click Next.
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% Create a Linked Project

Connection Settings = W
Specify the connection properties to be used by the linked application. L g

These connection properties are only for the linked project and will not affect the
y  individual applications.

Host name: | 54003 v |

Port:

I

Code page: | 037 Canada v|

SOTeEn 578 | 944 80 -

®
~
1@
=1}
o

I Finish H Cancel ]

5. The Connection Properties page allows you to specify your host name, port, code page, and screen

6.

size. Because you started the wizard by right-clicking the HATS project, the connection settings of the
HATS project will be selected by default. Accept the default connection settings and click Finish to
create the linked HATS/WebFacing project.

Tip: If the connection information in the WebFacing project is different from the HATS project, you
can select a host name and port from values entered for either project. (If you enter the wizard by
right-clicking a WebFacing project, the WebFacing project values will be selected by default as the host
name and port.) You can also provide new values for the host name and port. Code page and Screen
size lists contain all valid options, but are pre-set to the HATS project settings. For more information
on the settings on this wizard page, press F1 while the page is displayed.

When the HATS/WebFacing linking process is complete, the Project Created message box opens,

offering information on testing and deploying the newly linked application. Read the message and
click OK to continue.

0 Pro ject Created &|

i ) Congratulations! You have created a linked HATS WebFacing project.

You can now preview your linked project by using the Run on Server feature.
verify that your new linked project is configured on the server and that no
other projects containing the individual HATS and WebFacing project that you
just linked have been configured.

[J Do not show this message again.

In the Project Explorer view, you will also notice that the linkhatsXX_linkwfXXEAR project has been
created.
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HATS Projects | Navigator | =] & ~ = O
A3 HATS_FARG

722 linkhatsxx
=B linkhatsxx_linkwfXXEAR
IE Deployment Descriptor: linkhatsXx_linkwfXXEAR
=] % Linked HATS WebFacing Application : linkhatsXX_linkwfXXEAR
|=| Configuration
(== Modules
[=)-l=F HATS : linkhatsXX
@ Deployment Descriptor
=-1=F WebFadng : linkwfX
@ Deployment Descriptor

(= itim
(= META-INF
|=| bidibean.jar
= habeansnlv2.jar
= hasslite.jar
|X| hats_product. xml
|=| hatscommaon.jar
|= hatsruntime.jar
|=| HatsService.jar
.4 hatswelcfg. xml
|=| hodwel.jar
|=| hsrendering.jar
|=| ibmijlog.jar
runtime.properties
runtime-debug.properties
= WFCommon.jar
|X] whhats.xml
T2 linkwPex
=" RemoteSystemsConnections

You have successfully linked the HATS/WebFacing enabled and HATS projects.
Lesson checkpoint

You learned these things:

* About linking a HATS/WebFacing enabled project and a HATS project

* How to create a linked HATS/WebFacing project

* How to specify project and connection settings for a linked HATS/WebFacing project

Running and testing the linked application

In this lesson, you will run and test the linked HATS/WebFacing project in the WebSphere test
environment on your workstation.

As you did earlier with your HATS project, you will publish your linked project to the test environment
and run it there. Before you can publish the linked HATS/WebFacing project, you must remove the
standalone HATS project from the WebSphere test environment. This is because you cannot have two
copies of the HATS project on the server using the same context root.

To publish, run and test the newly linked project:

1. In the Servers view, expand the WebSphere v6.1 Server @ localhost server; right-click the
HATS_EARG61 entry; and click Remove.
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Console | Gallery | Thumbnails | Properties | Problems | Progress m

Server Status State
= WebSphere vé, 1 Server @ localhaost E‘p Started Synchronized

B & HATS_EARG1 i Started

2. When prompted, confirm that you want to remove the project from the server by clicking OK.

3. Activate the WebFacing Projects view by selecting Window > Show View > Other > WebFacing >
WebFacing Projects.)

Important: Before you test your application, verify that the WebFacing server is running on your the
server. Verify that jobs QQFWEFSVR and QQFVTSVR are running. This is done by using the
WRKACTJOB JOB(QQF*) command in a 5250 session.

If these jobs are not running then you need to start the WebFacing server. On a CL command line,
type strtcpsvr *webfacing.

4. In the WebFacing Projects view, right-click the linkwfXX project and select Run As > Run on Server.

Project Explorer TERICTERIVEVDRTE S, HATS Projects |Navigator | — O || inkhatsxx settings | @ Inkhatsxx |

= B , S @ o | htpflocahost:S080
wlgacg New
w3 pos .
wum , My Compan
#-CF sty
Bl indey -
Style 4 7/01/18
Comvert - .
Type option, press Enter.
View Log Z=Change d=elete
License Settings...
Link With r Opt Number Description
r o~ L 1l =mmaa -
Debug As P8 2 Administrative SHpt  Alt+Shift+x, N
Profile Az ¥
= Update EAR Libraries | O Run...
0, Prepare for Deployment L
> | oo 13 E
& Spedfy ISeries Web Tools Runtime Configuration ... ;—l LI LD LIS
Team » j 00006  Auto-dial Ex
Compare With * &l i |
Restore from Local History... - T T
Migrate ' | & Console 33 . Gallery  Thumbnas Prc
WiebSphere Application Server ve.1[V . 4
Properties
[18/01/07 15:51:18:093 ESTI

5. The Run on Server window opens. Select the WebSphere v6.1 Server; select the Set server as project
default (do not ask again) check box; and click Finish. The linked application is deployed to the
WebSphere test environment, and a Web browser opens in the editor area.

Chapter 1. Create a linked WebFacing and HATS application ~ 35



% Run On Server E]

Define a New Server
Choose the type of server to create

How do you want to select the server?
@ Choose an existing server

(") Manually define a new server
Select the server that you want to use:
= = localhost

WebSphere v6. 1 Server @ localhost:

Description: WebSphere Application Server v6. 1

[]5et server as project default {do not ask again)

[ Mext = ” Einish H Cancel

Select program to start

BN GO DASH

6. In the Web browser view, click the Launch button to load the application menu. The Dashboard
menu appears, allowing you to access the order entry and customer inquiry (CelDial) applications.

Application Dashboard

DASHBORRD
Select one of the following:

Order Entry

2. CelDial

Click the number 1. beside Order Entry to open the order entry application. The Parts Order Entry

screen opens.

Parts Order Entry

Type choices, press Enter.

2=Change

Customer number . . . .« . . . I:I
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8.

Tip: Pressing the F1 key on this screen will display one of the UIM Help panels that was converted
as part of your project.

Web Browser

Extended help

Use this panel to specify a customer to work with. Choose one of the following options:

X]

o 1 Select
» 2 Enter number

Click the Prompt link to display the Customer List dialog.

To select customer

Type choices, press Enter.

1=S5elect

Opt Customer
Oakley, Annie O

Farr, George

Weiss=s, Claus

Coulthard, Phil

Fair, Jim J

Masri, Maha

Llame=s, Joe L

N A I

FkeylZ=Cancel

Barber, Elizabeth A

Gungabeesoon, Satish

Coulter, Simon 5

Cnstomer List

You will notice that this application has been transformed by the WebFacing tool to a Web-based
application. You will see common user interfaces that are present in Web-based applications. For
example, hovering over the Opt field next to a customer name displays a drop-down selection box:

=

®
Qa

Opt Cunstomer

v

v

Select a customer from the list by hovering over the text box to the left of their name, and clicking
the 1 radio button. (You can also select a customer by typing 1 in the text box.) Press Enter to
confirm the selection.

Costomer List

To select customer

Type choices, press Enter.

1=5elect

Opt Cuonstomer
rf Oakley, Annie O
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The customer information appears in the Parts Order Entry screen:

Parts Order Entry

Type choices, press Enter.
Z2=Change

Customer number .

Customer name .

Address .

City 078951-2345
Opt Part Description Dty

[ ]

10. Click Prompt to display a list of available parts. The Select Part dialog opens.

Select Part

Tyvpe choices, press Enter.
1=5elect

Opt Part Description
[] 000001 WEBSPHERE REDEBCOE

[] 000002 Radio Controlled Flane

[] 000003 Change Machine 14

[] 000004 Baseball Tickets ST
[] 000005 Twelwve MNum Two Pencils Te5
[] 000006 Over Under Shotgun 65
[] 000007 Feel Good WVitamins 345
[] 000008 Cross_Country Ski Set 31
[] 000009 Rubber Baby Buggy_Wheel 345
[] 000010 ITSO REDEBOOK 5G24-2152 2549 ==

11. Select a part from the list by typing 1 in the box to the left of the part number, and then press Enter.
The part number and description appear on the first line of the order.

12. Press Enter again to add the part to the order.

Opt Part Description Oty

13. You can continue to add parts to the order in the same way. Once you have added all the parts you
want, click Accept Order to complete the order process. To return to the Application Dashboard
menu, click Exit.

Note: Your HATS/WebFacing enabled project also has many unique customization features available
to it, such as Web Settings, which you can use to further enhance your application. Refer to Help
topic [Customizing your WebFacing applications{ and the tutorial Web-enable a 5250 application
using the IBM WebFacing Tool for more details.

As an example, see the following images to see the difference customizing an application can make.

Before customization:
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Cnstomer List

To select customer
Type choices, press Enter.
1=S5elect

Opt Customer
Oakley, Annie ©

Barber, Elizabeth A
Farr, George

Weiss=s, Claus

Gungabeesoon, Satish
Fair, Jim J
Coulter, Simon 5

Masri, Maha

I_
]
[]
]
D Coulthard, Phil
]
L]
]
[

[ ]

Llame=, Joe L LI

FkeylZ=Cancel

After customization:

Click on link to select

Name
Oakley. Annie O
Barber. Elizabeth A
Farr. George B
Willis. MNeil U
Mullen-Schultz, Gary C
Maatta. Bob W
Weiss. Claus J
Palmer. Miel S

Schweyer. Larry R
Llames. Joe | M

14. Now, you will view the customer inquiry (CelDial) application, which is dynamically transformed by
HATS. Click 2. to the left of CelDial Communications to open the application.

15. The CelDial menu opens. Click 2. to open the Work with Inventory screen.
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ﬁ

Bo12.01 CelDial - Work with Inventory

Type option, press Enter.
2=Change 4=Delete S=Di=plav S=Print

0

Humber Description
goool Adapter - 120V

oooo2 Adapter — 120V
ooons Antenna -replaceable

'd
et

oooo4 Auto Antenna — mag

I

oooos Auto Antenna — pern

While both the WebFacing and HATS applications use the same visual style, several items on this
screen indicate that the application is being transformed by HATS. For example, the "GO DASH"
title is changed to "My Company”, and the links at the bottom of the application include the
command key labels (such as F3=Exit and F6=Add a part.) When you customize your linked
application, you will change these elements to provide a consistent appearance across the entire
application.

For details on navigating the application, read the instructions provided in [“Running and testing the]
[HATS application” on page 20.

You have run and tested the newly linked HATS/WebFacing project in the WebSphere test environment.
Lesson checkpoint

In this lesson, you learned the following:
* How to publish, run and test a linked HATS/WebFacing project in the WebSphere test environment

Module summary

In this lesson, you learned how to integrate your existing HATS/WebFacing enabled project with the
HATS project by creating a linked HATS/WebFacing project. The linked HATS/WebFacing project allows
access to applications that have been transformed by the WebFacing Tool, as well as 5250 applications
that have not been converted. You also learned how to publish and run the linked HATS/WebFacing
project on the WebSphere Application Server.

Lessons learned

By completing this module, you learned about the following concepts and tasks:
* How to link a HATS/WebFacing enabled project with a HATS project
* How to publish, run and test the linked HATS/WebFacing project

Assessment
* Which two types of projects are required to create a linked HATS/WebFacing project?
* What is the purpose of creating a linked HATS/WebFacing project?

Working with the linked application

In this module, you will work with the linked project. You will change settings and properties for both
the HATS/WebFacing enabled project, and the HATS project.
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In order to edit the visual style for a linked HATS/WebFacing project, you must locate the template and
Cascading Style Sheet (CSS) files associated with both the HATS/WebFacing enabled project and the
HATS project.

The Project Explorer view allows you to manage the resources and files associated with each of the
projects in the workspace, including linked HATS/WebFacing projects. The Project Explorer view also
displays which HATS and HATS/WebFacing projects are contained in a linked HATS/WebFacing project.

Learning objectives

After completing the lessons in this module, you will be able to perform these tasks:
* Find and work with a linked HATS/WebFacing application, using the Project Explorer
* View and edit settings and properties for a linked project

Time required

This module should take approximately 10 minutes to complete.

Working with the linked project using the Project Explorer

In this lesson, you will locate and work with the newly linked HATS/WebFacing project using the Project
Explorer view.

The Project Explorer view provides access to resources in the workspace, for example files and folders,
organized by their functions and features. You can easily identify items such as project configuration and
deployment descriptor files, without searching through the file system.

Fia Project Explorer X WebFading Projects = q:'p ¥ =0

h=FHATS_EARG1
T2 linkhatsx
B linkhatsx_linkwXXEAR

T2 linkwPx

1= RemoteSystemsConnections

To use the Project Explorer view to work with the linked HATS/WebFacing project that you just created:

1. In the Host Access Transformation Services perspective, locate the Project Explorer view. Expand the
linkhatsXX_linkwfXXEAR project. (If the Project Explorer view is not visible, click Window > Show
View > Other > General > Project Explorer)

The tree expands to show the contents of the linked HATS/WebFacing project. This folder contains
several configuration files:
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P Project Explorer X WebFacng Projects = <f;> = =08

e

RSN HATS EARGL
24 linkhatsXX
- E2 linkhats¥X_linkwfyEAR
---lﬁ Deployment Descriptor: linkhatsXX_linkwfXXEAR
B% Linked HATS fwebFacing Application : linkhatsXX_linkwfXXEAR
Configuration
-2 Modules

= = HATS : linkhatsXX

@ Deployment Descriptor

== WebFacng : linkwfx

'@ Deployment Descriptor

H (= itm
= META-INF
bidibean. jar
= habeansnlv2.jar
= hasslite.jar
hats_product. xml
=| hatscommon. jar
hatsruntime.jar
=| HatsService.jar
hatswelcfg. xml
= hodwel.jar
|=| hsrendering.jar
ibmjlog.jar
runtime. properties
runtime-debug. properties
= WFCommon.jar

| X wihats, xml
52 linkwfXx

[l
E

* wthats.xml contains interoperability settings for the WebFacing and HATS runtime.

2. Expand the HATS project, linkhatsXX, to view its resources. Locate the Swirl.jsp file in the Web
Content\templates folder, which defines the default layout and style for the host screen
transformation.
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mEbFadw Poecs| 5 % T 70
HATS_EARGL

-5 linkhatskx
‘E] Deployment Descriptor: linkhatsXX
(& Security Editor
8} struts
B web site Navigation
?5 Java Resources: Java Source
= bmsmaps
= screens
= -4= Web Content
(= common
1= hatsadmin
(= iojsp
= jsf
i=> macroHandlers
[ META-INF
(= struts
== templates
&l Blank.jsp
&1 ClassicTerminal.jsp
@ CorporateBanner . jsp
[&] CorporateBlackShaded. jsp
[&] CorporateBlackTan.jsp
&l corporateMonoBlue.jsp
&l CorporateMonoTan.jsp
& CorporateTanShaded.jsp
[&] EagleCanyon.jsp
[&] EagleFloweringTree jsp
[l EagleForesti ake.jsp
&1 EaglewTabs.jsp
] FinancialGreyRedtones.jsp
& InsuranceGreenGeometrics. jsp
[&] InsuranceGreenshaded.jsp
&l simpleBlack.jsp
&1 simplewhite,jsp
&l slidMonoGray.jsp
] sports.jsp
@ swirl jsp

| >

3. Expand the HATS/WebFacing project, linkwfXX, to view its resources. Locate the swirl.css file in the
WebContent\webfacing\styles\chrome folder, which defines the default layout and style for the area
surrounding the HATS/WebFacing application.
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mebmﬂg Poecs| 5 % 7 70
61

{ link PXXEAR

&

=52 linkwPot
Ej Deployment Descriptor: linkwf)x
(& security Editor
8 struts
[ Web Diagrams
[ wWeb site Navigation
'?5 Java Resources: src
= config
== Web Diagrams
[=-§= WebContent
(= META-INF
= WEB-INF
== webfadng
= ClientScript
[= images
&= 1sp
= services
== styles
(== apparea
== chrome
= html
8| swirl.css
ﬁ swirl.gif
ﬁ swirltile. gif
g sample. gif
ﬁ transparent.aif
= UIMHelp
index.jsp
== wilabux

The apparea.css file, in the WebContent\webfacing\styles\apparea folder, sets the default appearance
for the application user interface.

Note: WebFacing and HATS files can also be viewed from their respective WebFacing Projects and HATS
Projects views.

You have expanded the project to view its resources, and located files using the Project Explorer.
Lesson checkpoint

You learned these things:
* About the Project Explorer view
* How to navigate projects using the Project Explorer view

Changing project settings and properties
In this lesson, you will modify project settings and properties for the linked HATS/WebFacing project.

Project settings for your linked HATS/WebFacing project are defined by three components: the
HATS/WebFacing enabled project settings, the HATS project settings, and the connection settings for the
linked HATS/WebFacing project. To edit connection settings for the linked HATS/WebFacing project, you
must edit the wfhats.xml configuration file in the linked project folder.

You can modify settings for HATS/WebFacing enabled projects using the Properties dialog box. The

Properties dialog box allows you to modify project-specific settings without editing configuration files. To
modify HATS project properties, you use the Project Settings editor.
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In this lesson, you will change settings for the HATS/WebFacing enabled project and HATS project. You
will also learn about the wfhats.xml file, which contains settings for the linked HATS/WebFacing project.

To change project properties:

1.

First, you will modify project settings for the HATS/WebFacing project. Activate the WebFacing
Projects view. (If you do not see the WebFacing Projects view in your current perspective, activate it
by clicking Window > Show View > Other > WebFacing > WebFacing Projects.)

Right-click the linkwfXX project, and select Properties.

%m I
= CLd New b

[ pDS
% um
CS' Style
&l inde
e logor Delete...
Style 4
Canvert
View Log
License Settings. ..
Link With 4
Run As 4
Debug As 4
Profile As 4
=i, Update EAR. Libraries

% Prepare for Deployment
i specify iseries Web Tools Runtime Configuration ...

Team 3
Compare With 4
Restore from Local History...

Migrate 4

The Properties dialog box opens. This dialog box allows you to change settings for the project, such
as display attributes and authentication settings. You will change the command key display setting,
so that command keys are displayed beside their corresponding labels.

Note: Any properties that you specified during the linking process take priority over settings made
in the Properties dialog. For example, if you change the Host name or Host port values, the host and
port specified in the wfhats.xml configuration file will still be used at runtime.

Conversion iject
Command Key Recognitior
Key Button Labels WebFacing project settings:
Edit Code Options General |A|_|ﬂjenticati0n

MNUDDS Options

¥ML Record Metadata Host name: | S400A Host port: | 4004 | [Change... l

Run Time
=] Handle as if DDS files are compiled with DFRWRT({*YES) option
GO DASH [ Use insert mode for keyboard text entry
DS Object Mappings
IJIM Chiect Mappinas Include command key name in the key label {e.g. Indude F3="in "F3=Return” label}

3. Select the Include command key name in the key label check box.
4. Under the Project category, click GO DASH to display the CL command settings.
5. Change the Command label to My Application.

Chapter 1. Create a linked WebFacing and HATS application 45



Conversion GO DASH
- Command Key Recognitior
‘Key Button Labels
-Edit Code Options
-MMUDDS Options

Command label: | My Application

CLcommand: | GO DAsH
- XML Record Metadata
Run Time Invocation name: | INV1
(= Project
| L.GODDASH Override project settings for this command

6. Click OK to save the project properties.

7. Now, you will modify the rendering settings to display the Application Keypad as links. In the
HATS Projects view, expand the linkhatsXX project, and double-click the Project Settings icon.

inkhatskX
Project Settings

8. Click the Rendering tab at the bottom of the editor area.

9. Select Application Keypad from the left panel.
10. In the Display as list, select Links to display the application keypad using text links.

HinkhatsXX Settings X

Rendering
Configure default rendering, global rules, text replacement, and default component and widget settings.
= DFFE'L'lt Rendering Show default application keypad
iias Select keys to display:
- Global Rules
- Text Replacement Turn Keyboard On/Off
= Components Default
[H- Widgets Reset
- Application Keypad
W
- Host Keypad Refresh
- Operator Information Area Disconnect

View Print Jobs (if applicable)

11. You will now remove the Operator Information Area (OIA) from the HATS application. In the left
panel, select Operator Information Area, and then de-select the Show OIA check box.

(- Default Rendering [CI&how CTA;
Global Rules

Text Replacement
Components

Widgets

Application Keypad
i--Host Keypad

Operator Information Area

i
m

Display area layout

Style class: | statusArea |

12. Click File > Save to save the project rendering settings.
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13. You will now view the wfhats.xml file to display settings for the linked HATS/WebFacing project. In
the Project Explorer view, expand the linkhatsXX_linkwfXXEAR project, and double-click the
wfhats.xml file.

Fim Project Explorer X “WRELAE Projects|WebFacing ijects| =0
o

=32 HATS_EAR61
-2 linkhatsXX
B B2 linkhatsXX_linkwfXXEAR
IE: Deployment Descriptor: linkhatsXX_linkwfXXEAR
B% Linked HATS MiebFacing Application : linkhats¥¥_linkwfXXEAR
|=| Configuration
== Modules
1 1= HATS : linkhatsxx
. Deployment Descriptor
== WebFacing : linkwfxx
@ Deployment Descriptor

|= bidibean.jar
habeansnlv2.jar
- = hasslite.jar
- | X| hats_product.xml
- |=| hatscommon.jar

=| hatsruntime.jar

=| HatsService,jar
hatswelcfg., xml

=| hodwel.jar
hsrendering.jar
ibmjlog.jar

runtime. properties

B runtime-debug.properties
- |=| WFCommon.jar

b AR v fhats, xml

B 2 linkw XX The XML editor opens in the editor area.

Note: You can also double click the ‘Configuration” node under ‘Linked HATS/WebFacing
Application: linkhatsXX_linkwfXXEAR’ to open wfhats.xml.

14. Click the Source tab at the bottom of the editor area to display the contents of the wfhats.xml file.

Ic?xm_'l. wersion="1.0" encoding="UIF-8"7>

<wfhats-app displayName="linkhatsXX linkwfXXERR" enabled-
<host name="s400a" port="4004"/>
<device codePage="037" screenSize="2"/>

</wfhats—-app>

b ¥
Design ISouroe ]
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The wfhats.xml file contains settings for the linked HATS/WebFacing project, such as host name,
code page, and project locations. For example, if you changed the context root of your HATS or
HATS/WebFacing enabled project after the linking process, you would need to edit wfhats.xml to
reference the renamed context root.

Since you have not changed any settings in your workspace that would affect the linked project, you
can close the XML editor.

15. Now, you will launch the application in the WebSphere test environment. In the WebFacing Projects
view, right-click the linkwfXX project, and select Run As > Run on Server.

Note: If you did not select the Set server as the project default (do not ask again) check box on the
Run on Server dialog when you selected the server in |[“Running and testing the linked application”|
ensure that you select the same server on the dialog now. For example, if you had
previously selected WebSphere V6.1 Server, ensure that you select that server now.

The linked HATS/WebFacing application opens.

linkhats)x Settings RS O[] Welcome to HATS g =0

B " |http:/focahost:9080 inkwfXx/ v| B
Select program to start

My Application

16. Click the Launch button beside the My Application command to initialize the Application
Dashboard menu. You will notice that the dashboard menu now displays command key labels beside
each of the actions, and the application title is now "My Application”.

F3=Exit F12=Cancel

17. Click 2. beside the CelDial Communications text to launch the HATS customer inquiry application.
The CelDial Communications application opens. You will notice that the Operator Information Area
is not shown, and the Application Keypad is displayed as a set of links:

F3=Exit F4=Prompt F9=Retrieve F12=Cancel

F13=Information Assistant F16=System main menu

|F‘.eset Default Refresh Disconnect Turn Keyboard Off

You have successfully modified project settings for the HATS/WebFacing enabled and HATS projects, and
learned about settings for the linked HATS/WebFacing project.

Lesson checkpoint

You learned these things:

* How to activate the WebFacing Projects view in the workbench

* How to access the Properties dialog box for a HATS/WebFacing enabled project
* How to modify settings for a HATS project using the Project Settings editor

* About properties and settings available for a linked HATS/WebFacing project

Module summary

In this module you learned about working with a linked HATS/WebFacing project. You used the Project
Explorer to navigate and locate resources, and edited the project properties.
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Lessons learned

By completing this module, you learned about the following concepts and tasks:

* About the Project Explorer view

* How to navigate a linked HATS/WebFacing project using the Project Explorer

* How to edit project properties using the WebFacing Projects and HATS Projects views

Assessment

* What does the Project Explorer view display?

* How do you access the HATS/WebFacing enabled project Properties dialog box?
* Name a HATS project setting.

Customizing the linked application for a unified style

In this module, you will modify style sheets and display properties for the HATS/WebFacing enabled
project and the HATS project. The goal of this module is to customize the style of components created
using the HATS and WebFacing Tool while maintaining a unified look across the application.

You will edit the Cascading Style Sheet (CSS) for the order entry application, which was converted by the
WebFacing Tool, and the Java" Server Page (JSP) for the customer inquiry application, which was
transformed using HATS.

Learning objectives

After completing the lessons in this module, you will be able to perform these tasks:
* Modify style attributes for a WebFacing application

* Modify style attributes for a HATS application

* Display and test the new style customizations

Time required

This module should take approximately 10 minutes to complete.

Modifying WebFacing style attributes

In this lesson, you will modify style attributes for the HATS/WebFacing enabled component in the linked
HATS/WebFacing project.

The goal of this lesson is to make changes to the user interface for the HATS/WebFacing enabled
application. You will customize the title font for the HATS/WebFacing enabled application. You can
refresh the application and immediately preview your changes.

HATS/WebFacing enabled projects implement their style and layout using three key files:

* A Cascading Style Sheet (CSS) file in the WebContent\webfacing\styles\chrome folder provides styling
information for the page template. Because you chose the "swirl” style when you created the
HATS/WebFacing enabled project, you will see swirl.css in this folder.

* apparea.css in the WebContent\webfacing\styles\apparea folder sets the style information for the
application area.

* PageBuilderjsp in the WebContent\webfacing\styles\chrome\html folder defines the HTML layout of
the WebFacing application.

Additionally, the CmdKeys.jsp file in the WebContent\webfacing\styles\chrome\html folder determines
how command key labels and buttons are displayed.

Chapter 1. Create a linked WebFacing and HATS application 49



You will modify the swirl.css file while maintaining the unified style of the HATS/WebFacing enabled
order entry application and the HATS customer inquiry (CelDial) application.

To modify WebFacing style attributes:

1. In the Project Explorer view, under thelinkwfXX project, expand the WebContent > webfacing >
styles > chrome folder to reveal the swirl.css file.

= kX

@ Deployment Descriptor: linkwfXx
fia Security Editor

58 struts

(& wWeb Diagrams

& web Site Mavigation

?5 Java Resources: src

#-[2= Web Diagrams
== webContent

H- (2 META-INF

t B WEB-IMNF
Ei‘—} webfacing
= ClientSeript
&2 images
® jsp

)

8| swirl.css
ﬁs'.'irl.gif
g swirltile, gif
sample.gif

j’ transparent.gif
H = UIMHelp

""" Bl index.jsp

2. Double-click the swirl.css file. The cascading style sheet editor opens.

Browse 4 Uy o5 &g -

Es

f*styles for entire appl

body {

background : white:
font-=ize : 10pt:
margin : lpx;
text—-align : lefc;

le ==>»

font-family: sans-serif

* application header */
headc

background: url (=swirl.g
color @ white;

font: bold 24pt sans—-se
text—-align : lefc;
padding: Spx 10px 0 20p
height: 5S6px:
vertical-align:middle;

3. Click the color: definition inside the .headc style class. The Preview panel displays a preview of the
selected style.
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Style of .headc

4. Change the color: style definition to:
color: yellow;

5. Change the font: style definition to:
font: bold 24pt tahoma;
The Preview panel will change to reflect your new style settings:

Style of .headc

6. Save the swirl.css file by clicking File > Save, and then close the cascading style sheet editor.

You have modified WebFacing style attributes for your HATS/WebFacing enabled project. Next, you will
modify style attributes for the HATS project.

Lesson checkpoint

You learned these things:
* About styles for HATS/WebFacing enabled projects

* How to access and modify a style sheet for a HATS/WebFacing enabled project, using the Project
Explorer

Modifying HATS style attributes

In this lesson, you will modify style attributes for the HATS component of the linked project.

You will modify the layout and style for the HATS application by editing the Swirljsp file. The Swirl.jsp
file contains style definitions and layout information for the Swirl template.

As you have already done for the HATS/WebFacing enabled project, you will modify these files so that
the HATS application will have the same look and feel.

To modify HATS style attributes:
1. In the Project Explorer view, expand the linkhatsXX project.

BT linkhatsX

|§] Deployment Descriptor: linkhatsXX
{.@ Security Editor

8 struts
& web Site Mavigation

'?5 Java Resources: Java Source
= bmsmaps
[ screens

= Web Content
|X| ComponentWidget. xml

2. Expand the Web Content folder.
3. Expand the templates folder.
4. Double-click the Swirl.jsp template. The Page Designer appears in the editor area.
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W¥] linkhatsx Settings Swirl.jsp X

Swirl.jsp - Untitled

4

Host screen transformation will be shown here
Reset Default Refresh Disconnect % Turn Keyboard Off

5. Click the Source tab at the bottom of the editor window. The source code for the template appears.

6. Locate the <style> element in the document. In the . COMPANYTITLE style definition, change the
color: style definition to:

color: yellow;
7. Delete the font-size: and font-weight: style definitions.
8. Add a new font style definition:
font: bold 24pt tahoma;
9. Locate the <span CLASS="COMPANYTITLE"> element in the document. The full tag is:
<span CLASS="COMPANYTITLE"> &nbsp;My Company </span>
Replace the text so that it reads:
<span CLASS="COMPANYTITLE"> &nbsp;My Application </span>

d valign="middle" height="5&6" background="../common/imag

This will change the HATS application title to the same text as the HATS/WebFacing enabled
application title.

10. Save the Swirl.jsp template by clicking File > Save.

11. Click the Design tab at the bottom of the editor area. You will see a preview of the modified style.

Swirl.jsp - Untitled

12. Now, you can test the style modifications in the WebSphere test environment. As before, activate the
WebFacing Projects view, right-click the linkwfXX project, and select Run As > Run on Server.

Note: If you did not select the Set server as the project default (do not ask again) check box on the
Run on Server dialog when you selected the server in [‘Running and testing the linked application”|
ensure that you select the same server on the dialog now. For example, if you had
previously selected WebSphere V6.1 Server, ensure that you select that server now.

The linked HATS/WebFacing project loads in the internal Web browser, and you can see the updated
font style for the application title.

DLSHBOLRD Application Dashboard

Select one of the following:

l. Order Entry

2. CelDial Communications
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13. Click 2. beside CelDial Communications to open the HATS customer inquiry application. The
CelDial Communications menu opens, and HATS displays the modified styles:

CELDIAL CelDial Communications

Select one of the following:

1. Customer inguiry
2_Work with inventory

The linked HATS/WebFacing application has been customized while maintaining a consistent
appearance.

You have modified HATS style attributes for your linked HATS/WebFacing project. You also tested the
changes in the WebSphere test environment.

Module summary

In this module, you learned about customizing a linked HATS/WebFacing project while maintaining a
unified look and feel to both the WebFacing component and the HATS component. You also learned how
to use the Project Explorer to locate and edit the cascading style sheet (CSS) and template files that define
the visual appearance for the project. Finally, you learned how to test your new style modifications in the
WebSphere test environment.

Lessons learned

By completing this module, you learned about the following concepts and tasks:

¢ About cascading style sheets and page templates

* Which files are involved in customizing a linked HATS/WebFacing project

* How to modify WebFacing and HATS components while maintaining a unified visual appearance

Assessment
* Which two types of files define the visual appearance of a linked HATS/WebFacing project?

¢ Which view allows you to navigate to the styles defined for a HATS component?

Creating a new HATS/WebFacing enabled project based on an existing
WebFacing project

In this module, you'll learn how to create a HATS/WebFacing enabled project that is based on an existing
WebFacing project, to avoid the task of re-specifying the base WebFacing project properties.

There are two methods to convert an existing WebFacing project with all its individual selections into a
HATS/WebFacing enabled project:

1. Make a copy of an original WebFacing project and convert it into a HATS/WebFacing enabled project.
2. Convert an existing WebFacing project into a HATS/WebFacing enabled project.

Both of these steps will be described by lessons in this module.
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Learning objectives

After completing the lessons in this module you will know how to do the following:
* Create a HATS/WebFacing enabled project based on an existing WebFacing project

Time required
This module should take approximately 10 minutes to complete.
Prerequisites

To complete this module, you must have a WebFacing project that you want to convert to a
HATS/WebFacing enabled project. For details on how to create a WebFacing project, see the Web-enable
a 5250 application using the IBM WebFacing Tool tutorial.

Converting an existing WebFacing project into a HATS/WebFacing
enabled project

In this lesson, you'll learn how to convert an existing WebFacing project into a HATS/WebFacing enabled
project.

The easiest method for creating a HATS/WebFacing enabled project from an existing WebFacing project is
to convert the existing WebFacing project into a HATS/WebFacing enabled project. This is done by
simply deleting several files from the WebFacing project. The only disadvantage is that after the
conversion, you can no longer use this project as a stand alone WebFacing project; It has to be used as a
HATS/WebFacing enabled project.

To convert the existing project into a HATS/WebFacing enabled project:
1. Expand the src\conf and WebContent\WEB-INF\Ilib folders.

2. In the src\conf, right-click the runtime.properties file, and select Delete.

RSl

&= config d

E‘B src

(= com

B conf

DSPFObjectMapping. properties

i ' runtime. proper ties
B UMObjectMapping

----- |X| classSettings.xml Open

----- [¥] com.ibm.etools.iseries,  Open With

""" Logger.properties

""" |X] renderingSet. xml

""" webfacnglogging.prop . Past

5 € WebContent B=
i [E-(= METAINF Moves..

3. In the WebContent\WEB-INF\lib folder, hold the Ctrl key and select component.xml, habeansnlv2 jar,
hsrendering.jar and WFCommon jar.

MNew 4
»

|3=| Copy

54  Create a Linked WebFacing and HATS Application



EI[E% WebContent
- [2= META-INF
= webfacing

= aerun.jar

=| commons-beanutils. jar
-|= commons-collections.jar
=| commons-digester.jar
= commons-fileupload.jar
=| commons-ang.jar

=| commons-ogging.jar
commons-validatar. jar

companent. xml

=| DDSGeneratedData.jar

hiscreenrendering5250. jar

hsrendering.jar

iseriescomm.jar

=| iseriesloggingutils. jar
- = iseriesut.jar

| jakarta-oro.jar
jt400.jar

=| struts.jar

=| systemscreensae.jar

WFCommon.jar

| WWED i o

4. Right-click one of the files, and select Delete.

U e

component, xml
DD5Generated?

habeansnlv2.jal

Mew 4

hiscreenrenderi |

= COPY
. Paste

~|= iseriescomm.jar

|5 iseriesloggingut I
=| iseriesut.jar Mave...
jakarta-oro.jar Renanme
jt400.jar .
Import..
struts.jar =g tmpor

=
- | =] WFRun.jar -
2] whstruts.ar Validate d

5. Switch to the WebFacing Projects view.

6. Press the F5 key to refresh the view. You will notice that the project is now a HATS/WebFacing
enabled project, denoted by the distinctive icon in the WebFacing Projects view.

§= WebFacing Projects X Mavigator

f#l-T iWF_ORDER |
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You have converted an existing WebFacing project into a HATS/WebFacing enabled project and it can
now be linked to a HATS project.

Converting a copy of the original WebFacing project into a
HATS/WebFacing enabled project

In this lesson, you'll make a copy of your original WebFacing project, and then convert this copy into a
HATS/WebFacing enabled project.

This method of creating a HATS/WebFacing enabled project allows you to preserve the original
WebFacing project.

Important: To complete this lesson, you must have a WebFacing project that you want to convert into a
HATS/WebFacing enabled project. For details on how to create a WebFacing project, see the Web-enable
a 5250 application using the IBM WebFacing Tool tutorial. For the purposes of this lesson, we’ll refer to
the name of the WebFacing project as WF_ORDER.

To convert a copy of your original WebFacing project into a HATS/WebFacing enabled project:
1. If the Navigator view is not visible, in the WebFacing perspective, click the Navigator tab.
2. Right-click your existing WebFacing project, WF_ORDER, and select Copy.

WebFading Proj... SR Elg iseries RSE Getting Started |

iSeries Remote Sy

EE

: »
=-33 wr_orpery MEW

Go Into
Open in New Window

E Copy
. Paste k

¥ Delete

Mrwe

3. Right-click inside the Navigator view and select Paste.

= O || & iseries RSE Getting Started
=
2| B E

"a_ Navigator

WebFadng Proj...

iSeries Remote $y
= Introduction
Welcome to WebSphere Dev

New L
Go Into
Open in New Window

R

#-EZ WF_ORDEREAR

-=| Copy |
— Paste
¥ Delete k

The Copy Project window opens, prompting for a new Project name.
4. Type WF_HATS_ORDER as the new Project name.
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ﬁ) Copy Project

Projectname: | WF_HATS_ORDER|

¥ Use default location

Locakion: | D:fworkspaces/wdht_additions MF_HATS_ORDER Brawse. .. |

CK I Cancel |

Click OK. A copy of the WebFacing project is created with the name WF_HATS_ORDER. To begin

converting the WebFacing project to a HATS/WebFacing enabled project, several files must be
deleted from the WF_HATS_ORDER project.

Expand the src\conf and WebContent\WEB-INF\lib folders in the WF_HATS_ORDER project.
Inside the src\conf folder, right-click runtime.properties, and select Delete.

5 Navigator x N AR

5 € WebContent W
i Bl-(= METAINF Moves..

#-{= config 2]

- com

B[ conf

- DSPFObjectMapping. properties
- runtime.properties
-2 UIMObjectMapping
----- |X| classSettings.xml

----- |X| com.ibm.etools.iseries. Open With b
----- Logger.properties
----- |X] renderingSet. xml
----- webfacinglogging.prop . Past

MNew 4

|{=| Copy

In the WebContent\WEB-INF\lib folder, hold down the Ctr1 key and select component.xml,
habeansnlv2 jar, hsrendering.jar and WFCommon jar.

ElEb WebContent

-2 META-INF
E% webfacing
E-(= WEB-INF
Bl-(= dasses
B lib
- =] aerun.jar
|= commons-beanutils.jar
- = commons-collections.jar
|=| commons-digester.jar
commens-fileupload.jar
=| commons-ang.jar
commons-ogging.jar
=| commons-validator.jar
companent. xml
=| DDSGeneratedData.jar
BEN habeansnlv2, jar
=| hiscreenrendering5250.jar
hsrendering.jar

~|= iseriescomm.jar

-|Z| iseriesloggingutils. jar
iseriesut.jar

=| jakarta-oro.jar
jt400.jar

=| struts.jar
systemscreensae. jar

S8 VWFCommon. jar

=l WWED e dor
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9. Right-click one of the files, and select Delete.

Seriescomm,jar

seriesloggingut I
seriesut. jar Move...
jakarta-oro.jar Renanme

Y 400, _
D Rumport. J

-| struts.jar

-| systemscreens:z E“ﬂ Export..
QMIMon. jar
=| WFRun.jar -
- |5 wistruts.jar Validate ;I

%' Refresh

Next, you have to replace occurrences of the original WebFacing project name, WF_ORDER, with the
new HATS/WebFacing enabled project name, WF_HATS_ORDER.

10. In the Navigator view, under the WF_HATS_ORDER project, open the following files and change all
instances of the string WF_ORDER to WF_HATS_ORDER:

a. .setting/org.eclipse.wst.common.component (2 matches as deploy name and context root value)

B org.edipse.wst.common.component X =0

<?xml wverszion="1.0" encoding="UIF-8"7> ;I
<project-modules id="moduleCoreId"™ project—-version="1.5.0">
<wb-module deploy—name
<wWwb-resource deployv-path="/" source-path="/WebContent"/>
<wb-resource deploy-path="/WEB-INF/classes" scurce-path=
<property name="context-root™ value
<property name="java-output-path" value="webLontent/WEB-
</wb-module>
</project-modules>

-
1| | 3

Design |Source

b. WebContent/WEB-INF/struts-config.xml (1 match as message resource parameter)
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FH struts Configuration File X =0

<global-exceptions> ;IE

</global-exceptionss>

<!-- Global Forwards -->
<global-forwardss>
</global-forwards>

<!—— Action Mappings -->
<action-mappingss>
</action-mappings>

<!—— Message Resources —->
E I(message—rescarces para.meter="c.om.:i.sources.hpp

</struts—config>

=
< | o

Form Bear'lsl Data Soucesl Global Excephoml Controller | Message R.esoucesl Plug-ins | Source | *

WebContent/WEB-INF/web_xml (1 match as display name)

Web Deployment Descriptor X =0
WF_HATS_ORDER =
General Information Usage

Display name: l WF_ORDER I ﬁet:Follc;w:ng Enterprise Applications use this
_I web module:

Description:
Refresh

Session time out:
[ bistributable

Servlets and 1SPs
The following serviets and J5Ps are used in this Listeners
application: The following listeners are used in this

& action application:

Overview | Serviets | Filter | Security | References | WS Handler | Pages | Variables | WS Extension | 3

.project (1 match as name)

B prosect x " =5
<?xml wverszion="1.0" encoding="UIF-8"7> B
<projectDes L

<projects>
</projects>
<buildSpec>
<buildCommand>
<name>com.ibm.etools.common.migration.MigrationBuild
<arguments>
</arguments:
</buildCommand>
<buildCommand>
<name>com.ibm.etool=s.iseries.webfacing.webfacingbuil
<arguments>

</arguments> -
1| | |

Design | Source
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e. config/configuration.xml (1 match as project name)

%] configuration.xml X ="

<?xml wersio 0" encoding="UIF-8" 72> B
<project na ve:rsir:nn="200'?0202 00:17:22" release="T7.
<ddsfiles>

<dspf lastconvert="20070202 00:17:22" lastmodification=" ">

<as400>torasboos/as400>
<library>WFLABXN</library>
<srcpf>QDDSSRC</srcpf>
<name >0RDENTD< / name >
<records>

</records>

< /dspf>

<dspf lastconvert="20070202 00:17:22" lastmodification=" ">
<as400>torasbec</as400>
<library>WFLABXX</library>
<srcpf>QDDSSRC</srcpf>

<name>SLTCUSTD</ name > -
1| | 3

Design | Source

11. When the Modifying Context Root dialog appears, click Yes to fix all links.
x

9 The context root has been modified. Do you want to have links that
\tl) reference the context root fixed accordingly?

v Show this message when fixing up links in files.!

You now have to rename one directory to reflect the new project name.
12. In the Navigator view, expand the src\com\ibm folder.
13. Right-click the wf_order folder and select Rename.

= o CT— =5

£l WF_HATS_ORDER
B .externalToolBuilders
= .settings
(= config
= sre
E|[Eb o
== ibm
Eb as400ad
B-[= conf
----- |X| dassSettings.xml
----- |X| com.ibm.etools.ise
----- Logger.properties |:=| Copy
----- |X| renderingSet.xml . Paste
webfacinglogging. 3 Delete

(= \Web Diagrams Move...
43
[El Properties &2 Gallery| We g Import...
% Funart. ..

Mew 3
Go Into
Open in New Window

[#-[= WebContent

14. Change the name of the folder to wf_hats_order.
15. Switch to the WebFacing Projects view.
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16. Press the F5 key to refresh the view. You will notice that the project is now a HATS/WebFacing
enabled project, denoted by the distinctive icon in the WebFacing Projects view.

= \WebFacing Projects X Mavigator

-1 WF_HATS_ORDER
E-E ER

You have converted a copy of an existing WebFacing project into a HATS/WebFacing enabled project and
it can now be linked to a HATS project.

Module summary

In this module, you learned how to take an existing WebFacing project, and convert it into a
HATS/WebFacing enabled project using two different methods.

Lessons learned

By completing this module, you learned about the following concepts and tasks:
* How to convert a copy of a WebFacing project into a HATS/WebFacing project
* How to convert a WebFacing project directly into a HATS/WebFacing project

Tutorial summary: Create a Linked WebFacing and HATS application

You have completed the process of linking a HATS/WebFacing enabled project and a HATS project to
form a single, linked application. You also learned how to customize the projects to provide a consistent
look and feel across the WebFacing and HATS components.

Lessons learned

By completing this tutorial, you learned about the following key concepts:
* Creating a linked WebFacing and HATS application by combining a WebFacing project with a HATS
project
* Working with linked application resources and settings, using the Project Explorer
* Modifying templates and style sheets while maintaining a consistent look and feel to an entire
application
Related links
The following Web sites and help topics may be useful in locating additional information:
[Considerations for Linked HATS/WebFacing Applications|
[ntroducing Host Access Transformation Services|
[[ntroducing the IBM WebFacing Tooll
[Customizing your WebFacing Applications|

[ [Rational Host Access Transformation Services|

[ [The IBM WebFacing Tool|
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http://publib.boulder.ibm.com/infocenter/hatshelp/v71/index.jsp?topic=/com.ibm.hats.doc/doc/ugwfi.htm
http://publib.boulder.ibm.com/infocenter/hatshelp/v71/index.jsp?topic=/com.ibm.hats.doc/doc/getstarti03.htm
http://publib.boulder.ibm.com/infocenter/hatshelp/v71/index.jsp?topic=/com.ibm.hats.doc/doc/getstarti04.htm
http://publib.boulder.ibm.com/infocenter/hatshelp/v71/index.jsp?topic=/com.ibm.hats.doc/doc/topics/twfcstm.html
http://www-306.ibm.com/software/awdtools/hats/
http://www-306.ibm.com/software/awdtools/hats/features/webfacing.html
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U.S. Government Users Restricted Rights - Use, duplication or disclosure restricted by GSA ADP
Schedule Contract with IBM Corp.

This information was developed for products and services offered in the U.S.A. IBM may not offer the
products, services, or features discussed in this documentation in other countries. Consult your local IBM
representative for information on the products and services currently available in your area. Any
reference to an IBM product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product, program, or service that
does not infringe any IBM intellectual property right may be used instead. However, it is the user’s
responsibility to evaluate and verify the operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter described in this
documentation. The furnishing of this documentation does not give you any license to these patents. You
can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation

North Castle Drive
Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM Intellectual Property
Department in your country or send inquiries, in writing, to:

IBM World Trade Asia Corporation
Licensing

2-31 Roppongi 3-chome, Minato-ku
Tokyo 106, Japan

The following paragraph does not apply to the United Kingdom or any other country where such
provisions are inconsistent with local law: INTERNATIONAL BUSINESS MACHINES CORPORATION
PROVIDES THIS PUBLICATION "AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR
IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OR CONDITIONS OF
NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some
states do not allow disclaimer of express or implied warranties in certain transactions, therefore, this
statement may not apply to you.

This information could include technical inaccuracies or typographical errors. Changes are periodically
made to the information herein; these changes will be incorporated in new editions of the publication.
IBM may make improvements and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for convenience only and do not in
any manner serve as an endorsement of those Web sites. The materials at those Web sites are not part of
the materials for this IBM product and use of those Web sites is at your own risk.

Licensees of this program who wish to have information about it for the purpose of enabling: (i) the
exchange of information between independently created programs and other programs (including this
one) and (ii) the mutual use of the information which has been exchanged, should contact:
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Intellectual Property Dept. for WebSphere Software
IBM Corporation

3600 Steeles Ave. East

Markham, Ontario

Canada L3R 9727

Such information may be available, subject to appropriate terms and conditions, including in some cases,
payment of a fee.

The licensed program described in this documentation and all licensed material available for it are
provided by IBM under terms of the IBM Customer Agreement, IBM International Program License
Agreement or any equivalent agreement between us.

Any performance data contained herein was determined in a controlled environment. Therefore, the
results obtained in other operating environments may vary significantly. Some measurements may have
been made on development-level systems and there is no guarantee that these measurements will be the
same on generally available systems. Furthermore, some measurements may have been estimated through
extrapolation. Actual results may vary. Users of this document should verify the applicable data for their
specific environment.

Information concerning non-IBM products was obtained from the suppliers of those products, their
published announcements or other publicly available sources. IBM has not tested those products and
cannot confirm the accuracy of performance, compatibility or any other claims related to non-IBM
products. Questions on the capabilities of non-IBM products should be addressed to the suppliers of
those products.

All statements regarding IBM’s future direction or intent are subject to change or withdrawal without
notice, and represent goals and objectives only.

Copyright license

This information contains sample application programs in source language, which illustrates
programming techniques on various operating platforms. You may copy, modify, and distribute these
sample programs in any form without payment to IBM, for the purposes of developing, using, marketing
or distributing application programs conforming to the application programming interface for the
operating platform for which the sample programs are written. These examples have not been thoroughly
tested under all conditions. IBM, therefore, cannot guarantee or imply reliability, serviceability, or
function of these programs.

Each copy or any portion of these sample programs or any derivative work, must include a copyright
notice as follows:

© (your company name) (year). Portions of this code are derived from IBM Corp. Sample Programs. ©
Copyright IBM Corp. 1992, 2007. All rights reserved

Trademarks and service marks

The following terms are trademarks or registered trademarks of International Business Machines
Corporation in the United States, other countries, or both.

* IBM

* i5/0S

* iSeries

+ Rational®
e System i
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¢ WebSphere
Intel® and Pentium® are trademarks of Intel Corporation in the United States, other countries, or both.

Microsoft®, Windows®, Windows NT® and the Windows logo are trademarks of Microsoft Corporation in
the United States, other countries, or both.

Java and all Java-based trademarks are trademarks of Sun Microsystems, Inc. in the United States, other
countries, or both.

UNIX® is a registered trademark of The Open Group in the United States and other countries.
Linux® is a registered trademark of Linus Torvalds in the United States, other countries, or both.

Other company, product or service names may be trademarks or service marks of others.
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