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Overview

The IBM Problem Determination Tools plug-ins combined packages contain all of the individual product plug-ins in a
single downloadable zip file. These single all-inclusive zip files make the initial installation and follow-on maintenance
and functional updates easier than the previous individual product plug-in packages.

Hardware Requirements
The following minimum hardware levels are required:

® CPU - 1 GHz or faster 32-bit (x86) or 64-bit (x64) processor, dual or quad core recommended
® RAM - 2.0 GB minimum, 3.0 GB recommended
® Hard disk - at least 500 MB available space

Supported Platforms
One of the following levels of the Microsoft Windows operating system:

Microsoft Windows XP 32-bit
Microsoft Windows Vista 32-bit
Microsoft Windows 7 32-bit

Microsoft Windows 7 64-bit

Microsoft Windows Server 2008 32-bit

Software Requirements
One of the following Eclipse-based platforms:

® |IBM CICS Explorer (for Windows) V5.1.1, or later
® Eclipse 4.2.2, or later (with CICS Explorer SDK V5.1.1.0, or later)

NOTE: We recommend and support installation of the Problem Determination Tools plug-ins into either IBM Explorer for
z/OS, CICS Explorer, or IMS Explorer. At your own risk, you can install the Problem Determination Tools plug-ins into an
Eclipse 4.2.2, or later environment, as long as you also install CICS Explorer SDK V5.1.1.0, or later.

Any combination of one or more of the following IBM Problem Determination Tools for z/OS products:

IBM Application Performance Analyzer for z/OS V12.1, or later
IBM Debug Tool for z/OS V13.1, or later

IBM Fault Analyzer for z/OS, V12.1, or later

IBM File Manager for z/OS V13.1, or later

IBM Workload Simulator for z/OS & OS/390 V1.1, or later

Restrictions


http://www.ibm.com/legal/copytrade.shtml
http://www-01.ibm.com/software/htp/cics/explorer/

IBM Application Performance Analyzer for z/OS plug-in does not install successfully into IBM IMS Enterprise Suite
Explorer for Development.

Preparing to install IBM Problem Determination Tools plug-ins Combined Packages

It is highly recommended that you uninstall any pre-existing Problem Determination Tools plug-ins from your Eclipse
environment. To check what software is installed and to uninstall:

1. Click Help > About IBM CICS Explorer or Help > About IMS Enterprise Suite Explorer
2. Click Installation Details
3. Review the list of Installed Software and click Uninstall...

Installing IBM Problem Determination Tools plug-ins Combined Packages

Download and extract the zip file ( PD_Tool s_pl ugi ns_conbi ned_P2_v xxxxxx . zi p )foralocalinstall. To
install Problem Determination Tools plug-ins Combined Packages:

Start CICS Explorer

Click Help > Install New Software...

In Install click Add...

Click Local...

Browse to and select the directory with the unzipped PDTools plugins

In Install, you have the choice of selecting one or more individual plug-ins, or, selecting all of them. We

recommend that you select all of them by clicking Select All . If, instead, you prefer to select individual plug-ins,

the Problem Determination Tools Common Component must also be selected for installation. Note the

restriction if installing into IBM IMS Enterprise Suite Explorer for Development.

7. If you are installing Application Performance Analyzer, please see the installation notes below before proceeding.

In Install Details, Click Next

Review each of the License agreements, "l accept the terms of the license agreements”, must be selected to

continue, then click Finish

10. The Installing Software dialog will appear

11. If a "Security Warning" dialog appears, Click OK

12. When the "Software Updates" dialog appears, Click Yes , to restart IBM CICS Explorer, to start using the PDtools
plugins.

13. When CICS Explorer has restarted, If IBM Problem Determination Tools Studio Branding was installed, the

Welcome page will contain new content related to the PDTools plugins. Clicking one of the entries will display

more information about the respective plugin.
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Installation Notes for Application Performance Analyzer users:

1. This package contains both the Application Performance Analyzer Version 12 plug-ins and the Application
Performance Analyzer Version 13 plug-ins.

2. Application Performance Analyzer for z/OS Version 12 requires the Application Performance Analyzer version 12
plug-ins. It is not forward compatible.

3. Application Performance Analyzer for z/OS Version 13 requires the Application Performance Analyzer version 13
plug-ins. It is not backward compatible.

4. Only one version of the APA plug-ins can be installed at once, not both.

5. By default the Available Software window will have the option Show only the latest version of available
software checked, and only the Application Performance Analyzer Version 13 plug-ins are displayed when the
Application Performance Analyzer plug-in category is expanded.

6. If you wish to install the Application Performance Analyzer Version 13 plug-ins, continue with the installation

instructions at Step 8) above.

. If you wish to install the Application Performance Analyzer Version 12 plug-ins, you must:

1. Uncheck "Show only the latest versions of available software"

2. Expand the "Application Performance Analyzer plug-in" category
3. Select the v12.1.x Application Performance Analyzer plug-ins.

4. Continue with the installation instructions at Step 8) above.
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Getting Started With IBM Problem Determination Tools plug-ins Combined Packages
After installing the plug-ins, follow the steps below for the plug-in(s) you are using:

® Application Performance Analyzer Plug-in Version 12
1. There is some connections/credentials setup that is unique to Application Performance Analyzer that must
be performed. Please refer to the APA Bridge for CICS Explorer User Guide for details on how to
configure credentials and connections for Application Performance Analyzer and how to connect to
Application Performance Analyzer on z/OS. Once the connection is established, the Select STC dialog is
displayed in which a default startup APA Started Task (STC) must be selected. A list of active APA



Started Tasks (STC's) is displayed. The default STC is the started task which will be selected at the
startup of Application Performance Analyzer. The Default STC is displayed for the first successful login
only, then saved as a preference that can be changed from the "Set as Default STC" context menu item of
the STC List view

. To access Application Performance Analyzer, click Window > Open perspective > Other... . Select APA

and click OK .

Find more information, click Help > Help Contents . Follow the instructions in the IBM Application
Performance Analyzer User Guide section for details on getting started using Application Performance
Analyzer.

® Application Performance Analyzer Plug-in Version 13

1.

Application Performance Analyzer Plug-in Version 13 uses the Problem Determination Tools Common
Component for z/OS to connect with Application Performance Analyzer for z/OS Version 13, through the
Problem Determination Tools Common Server on z/OS.

Click Help > Help Contents. Follow the instructions in the IBM Problem Determination Tools for z/OS
Common Component for details on establishing a Problem Determination Tools for z/OS connection.

. To access Application Performance Analyzer, click Window > Open perspective > Other .... Select APA

and click OK.

Once the connection is established and the Application Performance Analyzer perspective is open, the
default startup Application Performance Analyzer Started Task (STC) must be selected. A list of active
Started Tasks (STC's) is displayed in the STC View window. By default, the first STC in the list is
selected. The default STC is the started task which will be selected at the startup of Application
Performance Analyzer Plug-in. To change the default STC, highlight the STC in the STC View window
and select Set as Default STC from the context menu.

For more information, click Help > Help Contents. Follow the instructions in the IBM Application
Performance Analyzer User Guide section for details on getting started using Application Performance
Analyzer.

Debug Tool Plug-in

1.

2.
3.

Establish a connection between the DTCN Profiles view for CICS and your z/OS system by following the
steps described in DTCN tips .

To access Debug Tool, click Window > Open perspective > Other... . Select Debug and click OK .
Find more information, click Help > Help Contents . Follow the instructions in the Compiled language
debugger section for details on getting started using Debug Tool to debug your application

Fault Analyzer Plug-in

1.

2.

To access Fault Analyzer, click Window > Open perspective > Other... . Select Fault Analyzer and click
OK .

Find more information, click Help > Help Contents . Follow the instructions in the Fault Analyzer for
Eclipse section for details on getting started using Fault Analyzer

File Manager Plug-in

1.

2.

2.

To access File Manager, click Window > Open perspective > Other... . Select File Manager and click
OK .

Find more information, click Help > Help Contents . Follow the instructions in the IBM File Manager
User Guide section for details on getting started using File Manager

Workload Simulator Plug-in
1.

To access Workload Simulator, click Window > Open perspective > Other... . Select WSim Explorer
and click OK .

Find more information, click Help > Help Contents . Follow the instructions in the Using the Workload
Simulator plug-in for Eclipse section for details on getting started using Workload Simulator.

Updating IBM Problem Determination Tools plug-ins Combined Packages

Download the zip file (PD_Tool s_pl ugi ns_conbi ned_P2_v xxxxxx . zi p ) for alocal update. To add either
source to the Available Software Sites:

S
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Click Window > Preferences

In Preferences expand Install/Update

Click Available Software Sites
Click Add...
Click Archive... and specify the zip file (PD_Tool s_pl ugi ns_conbi ned_P2_v xxxxxx .zip )foralocal

update, then click OK

Click OK to go back to Preferences
. In Preferences click OK to close Preferences

To update the Problem Determination Tools plug-ins Combined Packages:

1. Click Help > Check for Updates
If there are any updates found, Available Updates will appear, click Select All

2.



Click Next

In Install Details click Next

Review and accept the terms in the license agreement, and then click Finish
If the Security Warning dialog appears click OK

Click Restart Now to successfully complete the update

Nouohsw

Establishing a connection between the DTCN Profiles view for CICS and your z/OS system

Specify the settings needed to establish a connection between the DTCN profiles view and your z/OS system by doing
the following steps:

Click Window > Show view > Other

Type "DTCN" in the text box at the top of the window. Select DTCN profiles and click OK

Click Window > Show view > Other

Type "Host Connections” in the text box at the top of the window. Select Host Connections and click OK
In the Host Connections view, select DTCN and click Add to create a connection to DTCN.

Specify the settings in the following fields and click Save and Close:
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Name
The name of the connection. If left blank will be auto-filled by combining the host name and port number
entered separated by ":"

Host name
The TCP/IP name or address of the z/OS system as described in "Defining the CICS TCPIPSERVICE
resource” in the Debug Tool Customization Guide

Port number
The port number of the z/OS system as described in "Defining the CICS TCPIPSERVICE resource" in the
Debug Tool Customization Guide

7. Select the DTCN connection you created, and click Connect.
8. In the DTCN Signon window, specify the settings in the following fields, or select "Use existing Credentials” if you
have at least one credential defined, and click OK.

Credentials Name
The name of the credential
User ID
The ID that you use to log on to the CICS system
Password or Passphrase
The password or passphrase that you use to log on to the CICS system

A successful connection is indicated through a green icon for the DTCN connection. Otherwise, review the values you
entered, correct any mistakes, and try the connection test again. You can also review the trace file (as described in
Debug Tool User's Guide Appendix | section "Locating the trace file of the DTCN Profiles or DTSP Profile view") for
diagnostic information that can help identify the cause of the connection error. In the DTCN Profiles view, you can right
click anywhere to see a list of actions available.

Note: If you want require a secured connection, you will need to follow the steps in the section, Establishing a secured
communication between the DTCN profile view for CICS and your z/OS system

Establishing a secured communication between the DTCN profile view for CICS and your
z/OS system

These steps help you enable secure communication via Secure Sockets Layer (SSL) between DTCN profile view and
your z/OS system. The communication between the client and server uses the HTTP protocol.

Client side setup

To enable SSL communication, complete the following tasks for the client side:

1. Install server certificate:
Because the certificate server generated is not from an authorized certificate authority (CA), to solve this issue,
you need to install the certificate to your JDKs keystore.

1. Download copy of the certificate in text mode that the server has exported into your workstation directory
2. Import the downloaded certificate into your JREs keystore. The following is an example how to import the
certificate into keystore using keytool provided by java

Keyt ool inport alias nyprivateroot keystore ..\lib\security\cacerts file dtcnplg.cer
dtcnpl g.cer is the downl oaded copy of the server certificate.
The initial password for the cacerts keystore is changeit.



Note: If you are using CICS Explorer, the keytool utility can be found in the Java installation bin directory,
<CICS Explorer Install Directory=>\jre\bin.
If you are using PD Tools Studio, the keytool utility can be found in the Java installation bin directory, <PD
Tools Studio Install Directory>\jre\jre\bin

Server side setup

To enable SSL communication, do the following tasks for Server side:
1. Generate key pair and self-signed certificate using Rexx RACF command.

1. Use RACF GENCERT command to create a key entry for the CICS region owner. The key entry contains
the key pair and self-signed certificate.
Example (Create a key entry for user USERID with label: USERID-DTCNPLG-CERT):

/* generate key entry */
" RACDCERT | D( USERI D) GENCERT",
" SUBJECTSDN( CN(
" your _host _nane. com
)
" T (' USERI D- DTCNPLG CERT'

o' 1 BM

O ('1BM

L (' San Jose'

SP(' CA

C('us
' NOTBEFORE( DATE(2011-02-28) TI ME(20: 00: 00) )",
" NOTAFTER ( DATE(2031-12-31) TI ME(19: 59: 59) )",
" W THLABEL(
USERI D- DTCNPLG CERT
)"
' Sl ZE (1024 )"

— — — — — —

2. Connect the key entry to a key ring that belongs to the CICS region owner ID. The common name of the
subject DSN must be the host name of the server that the client uses to connect to host.
Example (Connect it to a key ring named USERID):

/* connect key entry to key ring */
" RACDCERT | D(
USERI D

) "
CONNECT( RING (
USERI D

X

" LABEL (
USERI D- DTCNPLG- CERT

)"

3. Export the certificate and store it in a data set using the printable encoding format defined by the internet
RFC 1421 standard
Example (Export the certificate to a data set: USERID.DTCNPLG.CERT)

/* export certificate to a data set */
" RACDCERT EXPORT( LABEL(' USERI D- DTCNPLG- CERT' )
C

USERI D

)"

" DSN(

' USERI D. DTCNPLG. CERT'
)y



" FORMAT( CERTB64 K

2. Initialize parameters in CICS region

1. Add the KEYRING parameter in the CICS region start up job and point to the key ring created for the
region owner ID.
2. The following example adds SYSIN DD data set of CICS region startup job:

KEYRI NG=USERI D

3. Define TCPIPSERVICE resource

1. Add a TCPIPSERVICE resource definitions, see example below in bold texts. Change the SSL and
Certificate attributes.

TCpi pservi ce . EQAHTP8S

GRQup : GROUP_NAME

DEscri ption

U m : EQADPANO no Anal yzer programis used
POr t nunber : 30009 1- 65535

STat us : Open Open | dosed

PRCt ocol : HITP liop | Htp | Eci | User
TRansacti on ;. CWKN

Backl og : 00030 max backl og requests all owed
TSqprefi x

Host : ANY

(M xed Case)

| paddr ess

SCcket cl ose : No No | 0-240000 (HHWMVSS)

Maxdat al en : 008192 3-524288

SECURI TY

S

Yes

Yes | No | Clientauth

Certificate

USERI D- DTCNPLG- CERT

(M xed Case)

PRI vacy : Supported Not support ed| Requi r ed| Support ed
Cl phers : 050435363738392F303132330A1613100D0915120F0C03060201
AUt henti cate . Basic No| Basi c| Certificate| AUTORegi ster | AUTOwatic | ASsert
il a Realm :

(M xed Case)

ATt achsec : Local | Verify

DNS CONNECTI ON BALANCI NG

DNsgr oup :

GRPcritical : No No | Yes

DEFI NI TI ON SI GNATURE

DEFi neti ne : 02/ 14/11 18:56: 32

CHANGETI ne : 03/16/11 14:04:57

CHANGEUsr i d : USERI D

CHANGEAGENt : CSDApi CSDApi | CsSDBatch
CHANGEAGRel : 0660

Technical support

These IBM Problem Determination Tools plug-ins are available at no charge to all licensed users of any of the following
five IBM Problem Determination Tools for z/OS products:

IBM Application Performance Analyzer for z/OS V13.1, or later
IBM Debug Tool for z/OS V13.1, or later

IBM Fault Analyzer for z/OS, V12.1, or later

IBM File Manager for z/OS V13.1, or later

IBM Workload Simulator for z/OS & OS/390 V1.1, or later

agrODE

These IBM Problem Determination Tools plug-ins are supplied under the standard terms and conditions of the IBM



International Program License Agreement (IPLA) and of the associated License Information and other documentation,
and provides a defect correction entitlement for those licensed users entitled to service for any of the IBM Problem
Determination Tools for z/OS products listed above. Service is available for these plug-ins for as long as the IBM
Problem Determination Tools for z/OS product which the plug-ins are to be used with are generally supported by IBM. In
addition, IBM reserves the right to discontinue service on these plug-ins when they are withdrawn from marketing by
IBM. Please reference the IBM Problem Determination Tool for z/OS product that you are using as the entitled product
when contacting IBM and requesting support for IBM Problem Determination Tools Studio.



