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Overview

The IBM Problem Determination Tools plug-ins combined packages contain all of the individual product plug-ins in a
single downloadable zip file. These single all-inclusive zip files make the initial installation and follow-on maintenance
and functional updates easier than the previous individual product plug-in packages.

Hardware Requirements

The following minimum hardware levels are required:

CPU - 1 GHz or faster 32-bit (x86) or 64-bit (x64) processor, dual or quad core recommended
RAM - 2.0 GB minimum, 3.0 GB recommended
Hard disk - at least 500 MB available space

Supported Platforms

One of the following levels of the Microsoft Windows operating system:

Microsoft Windows XP 32-bit
Microsoft Windows Vista 32-bit
Microsoft Windows 7 32-bit
Microsoft Windows 7 64-bit
Microsoft Windows Server 2008 32-bit

Software Requirements

One of the following Eclipse-based platforms:

IBM CICS Explorer (for Windows) V5.1.1, or later
Eclipse 4.2.2, or later (with CICS Explorer SDK V5.1.1.0, or later)

 We recommend and support installation of the Problem Determination Tools plug-ins into either IBM Explorer forNOTE:
z/OS, CICS Explorer, or IMS Explorer. At your own risk, you can install the Problem Determination Tools plug-ins into an
Eclipse 4.2.2, or later environment, as long as you also install V5.1.1.0, or later.CICS Explorer SDK 

Any combination of one or more of the following IBM Problem Determination Tools for z/OS products:

IBM Application Performance Analyzer for z/OS V12.1, or later
IBM Debug Tool for z/OS V13.1, or later
IBM Fault Analyzer for z/OS, V12.1, or later
IBM File Manager for z/OS V13.1, or later
IBM Workload Simulator for z/OS & OS/390 V1.1, or later

Restrictions

http://www.ibm.com/legal/copytrade.shtml
http://www-01.ibm.com/software/htp/cics/explorer/
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IBM Application Performance Analyzer for z/OS plug-in does not install successfully into IBM IMS Enterprise Suite
Explorer for Development.

Preparing to install IBM Problem Determination Tools plug-ins Combined Packages

It is highly recommended that you uninstall any pre-existing Problem Determination Tools plug-ins from your Eclipse
environment. To check what software is installed and to uninstall:

Click or Help > About IBM CICS Explorer Help > About IMS Enterprise Suite Explorer
Click Installation Details
Review the list of Installed Software and click Uninstall...

Installing IBM Problem Determination Tools plug-ins Combined Packages

Download and extract the zip file ( ) for a local install. ToPD_Tools_plugins_combined_P2_v  .zip xxxxxx
install Problem Determination Tools plug-ins Combined Packages:

Start CICS Explorer
Click Help > Install New Software...
In Install click Add...
Click Local...
Browse to and select the directory with the unzipped PDTools plugins
In Install, you have the choice of selecting one or more individual plug-ins, or, selecting all of them. We
recommend that you select all of them by clicking  . If, instead, you prefer to select individual plug-ins,Select All
the must also be selected for installation. Note the Problem Determination Tools Common Component 

 if installing into IBM IMS Enterprise Suite Explorer for Development.restriction
If you are installing Application Performance Analyzer, please see the installation notes below before proceeding.
In Install Details, Click Next
Review each of the License agreements, "I accept the terms of the license agreements", must be selected to
continue, then click Finish
The Installing Software dialog will appear
If a "Security Warning" dialog appears, Click OK
When the "Software Updates" dialog appears, Click  , to restart IBM CICS Explorer, to start using the PDtoolsYes
plugins.
When CICS Explorer has restarted, If IBM Problem Determination Tools Studio Branding was installed, the
Welcome page will contain new content related to the PDTools plugins. Clicking one of the entries will display
more information about the respective plugin.

Installation Notes for Application Performance Analyzer users:
This package contains both the Application Performance Analyzer Version 12 plug-ins and the Application
Performance Analyzer Version 13 plug-ins.
Application Performance Analyzer for z/OS Version 12 requires the Application Performance Analyzer version 12
plug-ins. It is not forward compatible.
Application Performance Analyzer for z/OS Version 13 requires the Application Performance Analyzer version 13
plug-ins. It is not backward compatible.
Only one version of the APA plug-ins can be installed at once, not both.
By default the window will have the option Available Software Show only the latest version of available

checked, and only the Application Performance Analyzer Version 13 plug-ins are displayed when the software 
 category is expanded.Application Performance Analyzer plug-in

If you wish to install the Application Performance Analyzer Version 13 plug-ins, continue with the installation
instructions at Step 8) above.
If you wish to install the Application Performance Analyzer Version 12 plug-ins, you must:

Uncheck "Show only the latest versions of available software"
Expand the "Application Performance Analyzer plug-in" category
Select the v12.1.x Application Performance Analyzer plug-ins.
Continue with the installation instructions at Step 8) above.

Getting Started With IBM Problem Determination Tools plug-ins Combined Packages

After installing the plug-ins, follow the steps below for the plug-in(s) you are using:

Application Performance Analyzer Plug-in Version 12
There is some connections/credentials setup that is unique to Application Performance Analyzer that must
be performed. Please refer to the for details on how toAPA Bridge for CICS Explorer User Guide 
configure credentials and connections for Application Performance Analyzer and how to connect to
Application Performance Analyzer on z/OS. Once the connection is established, the Select STC dialog is
displayed in which a default startup APA Started Task (STC) must be selected. A list of active APA
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Started Tasks (STC's) is displayed. The default STC is the started task which will be selected at the
startup of Application Performance Analyzer. The Default STC is displayed for the first successful login
only, then saved as a preference that can be changed from the "Set as Default STC" context menu item of
the STC List view
To access Application Performance Analyzer, click . Select Window > Open perspective > Other... APA
and click  .OK
Find more information, click . Follow the instructions in the Help > Help Contents IBM Application

section for details on getting started using Application PerformancePerformance Analyzer User Guide 
Analyzer.

Application Performance Analyzer Plug-in Version 13
Application Performance Analyzer Plug-in Version 13 uses the Problem Determination Tools Common
Component for z/OS to connect with Application Performance Analyzer for z/OS Version 13, through the
Problem Determination Tools Common Server on z/OS.
Click Follow the instructions in the Help > Help Contents. IBM Problem Determination Tools for z/OS

for details on establishing a Problem Determination Tools for z/OS connection.Common Component 
To access Application Performance Analyzer, click Select Window > Open perspective > Other .... APA
and click OK.
Once the connection is established and the Application Performance Analyzer perspective is open, the
default startup Application Performance Analyzer Started Task (STC) must be selected. A list of active
Started Tasks (STC's) is displayed in the STC View window. By default, the first STC in the list is
selected. The default STC is the started task which will be selected at the startup of Application
Performance Analyzer Plug-in. To change the default STC, highlight the STC in the STC View window
and select from the context menu.Set as Default STC 
For more information, click Follow the instructions in the Help > Help Contents. IBM Application

section for details on getting started using Application PerformancePerformance Analyzer User Guide 
Analyzer.

Debug Tool Plug-in
Establish a connection between the DTCN Profiles view for CICS and your z/OS system by following the
steps described in  .DTCN tips
To access Debug Tool, click . Select  and click  .Window > Open perspective > Other... Debug OK
Find more information, click . Follow the instructions in the Help > Help Contents Compiled language

 section for details on getting started using Debug Tool to debug your applicationdebugger
Fault Analyzer Plug-in

To access Fault Analyzer, click . Select and clickWindow > Open perspective > Other... Fault Analyzer 
 .OK

Find more information, click . Follow the instructions in the Help > Help Contents Fault Analyzer for
 section for details on getting started using Fault AnalyzerEclipse

File Manager Plug-in
To access File Manager, click . Select and click Window > Open perspective > Other... File Manager 

 .OK
Find more information, click . Follow the instructions in the Help > Help Contents IBM File Manager

 section for details on getting started using File ManagerUser Guide

Updating IBM Problem Determination Tools plug-ins Combined Packages

Download the zip file ( ) for a local update. To add eitherPD_Tools_plugins_combined_P2_v  .zip xxxxxx
source to the Available Software Sites:

Click Window > Preferences
In Preferences expand Install/Update
Click Available Software Sites
Click Add...
Click  and specify the zip file ( ) for a localArchive... PD_Tools_plugins_combined_P2_v  .zip xxxxxx
update, then click OK
Click  to go back to PreferencesOK
In Preferences click  to close PreferencesOK

To update the Problem Determination Tools plug-ins Combined Packages:

Click Help > Check for Updates
If there are any updates found, Available Updates will appear, click Select All
Click Next
In Install Details click Next
Review and accept the terms in the license agreement, and then click Finish
If the Security Warning dialog appears click OK
Click  to successfully complete the updateRestart Now
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Establishing a connection between the DTCN Profiles view for CICS and your z/OS system

Specify the settings needed to establish a connection between the DTCN profiles view and your z/OS system by doing
the following steps:

Click Window > Show view > Other
Type "DTCN" in the text box at the top of the window. Select DTCN profiles and click OK
Click Window > Show view > Other
Type "Host Connections" in the text box at the top of the window. Select Host Connections and click OK
In the Host Connections view, select DTCN and click Add to create a connection to DTCN.
Specify the settings in the following fields and click Save and Close:

Name
The name of the connection. If left blank will be auto-filled by combining the host name and port number
entered separated by ":"

Host name
The TCP/IP name or address of the z/OS system as described in "Defining the CICS TCPIPSERVICE
resource" in the Debug Tool Customization Guide

Port number
The port number of the z/OS system as described in "Defining the CICS TCPIPSERVICE resource" in the
Debug Tool Customization Guide

Select the DTCN connection you created, and click Connect.
In the DTCN Signon window, specify the settings in the following fields, or select "Use existing Credentials" if you
have at least one credential defined, and click OK.

Credentials Name
The name of the credential

User ID
The ID that you use to log on to the CICS system

Password or Passphrase
The password or passphrase that you use to log on to the CICS system

A successful connection is indicated through a green icon for the DTCN connection. Otherwise, review the values you
entered, correct any mistakes, and try the connection test again. You can also review the trace file (as described in
Debug Tool User's Guide Appendix I section "Locating the trace file of the DTCN Profiles or DTSP Profile view") for
diagnostic information that can help identify the cause of the connection error. In the DTCN Profiles view, you can right
click anywhere to see a list of actions available. 

 If you want require a secured connection, you will need to follow the steps in the section, Note: Establishing a secured
communication between the DTCN profile view for CICS and your z/OS system

Establishing a secured communication between the DTCN profile view for CICS and your
z/OS system

These steps help you enable secure communication via Secure Sockets Layer (SSL) between DTCN profile view and
your z/OS system. The communication between the client and server uses the HTTP protocol.

Client side setup

To enable SSL communication, complete the following tasks for the client side:
Install server certificate: 
Because the certificate server generated is not from an authorized certificate authority (CA), to solve this issue,
you need to install the certificate to your JDKs keystore.

Download copy of the certificate in text mode that the server has exported into your workstation directory
Import the downloaded certificate into your JREs keystore. The following is an example how to import the
certificate into keystore using keytool provided by java

        Keytool import alias myprivateroot keystore ..\lib\security\cacerts file dtcnplg.cer
        dtcnplg.cer is the downloaded copy of the server certificate.
        The initial password for the cacerts keystore is changeit.
       

 If you are using CICS Explorer, the keytool utility can be found in the Java installation bin directory, Note:
<CICS Explorer Install Directory>\jre\bin. 
If you are using PD Tools Studio, the keytool utility can be found in the Java installation bin directory, <PD
Tools Studio Install Directory>\jre\jre\bin
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Server side setup

To enable SSL communication, do the following tasks for Server side:
Generate key pair and self-signed certificate using Rexx RACF command.

Use RACF GENCERT command to create a key entry for the CICS region owner. The key entry contains
the key pair and self-signed certificate. 
Example (Create a key entry for user USERID with label: USERID-DTCNPLG-CERT):

        
         /* generate key entry                                  */

         "RACDCERT ID(USERID) GENCERT",

         " SUBJECTSDN(CN(

         'your_host_name.com'

         ) ",

         "            T ('USERID-DTCNPLG-CERT'                 ) ",

         "            OU('IBM'                                 ) ",

         "            O ('IBM'                                 ) ",

         "            L ('San Jose'                            ) ",

         "            SP('CA'                                  ) ",

         "            C ('US'                                  ))",

         " NOTBEFORE(DATE(2011-02-28)  TIME(20:00:00)     )",

         " NOTAFTER (DATE(2031-12-31)  TIME(19:59:59)     )",

         " WITHLABEL(

         USERID-DTCNPLG-CERT

         )",

         " SIZE     (1024                                 )"

        

       

Connect the key entry to a key ring that belongs to the CICS region owner ID. The common name of the
subject DSN must be the host name of the server that the client uses to connect to host. 
Example (Connect it to a key ring named USERID):

        
         /* connect key entry to key ring                       */

         " RACDCERT ID(

         USERID

         ) ",

         "  CONNECT( RING (

         USERID

         ) ",

         "           LABEL(

         USERID-DTCNPLG-CERT

         ))"

        

       

Export the certificate and store it in a data set using the printable encoding format defined by the internet
RFC 1421 standard 
Example (Export the certificate to a data set: USERID.DTCNPLG.CERT)

        
         /* export certificate to a data set                    */

         "RACDCERT EXPORT(LABEL('USERID-DTCNPLG-CERT'          ) ",

         " ID(

         USERID

         ) ",

         " DSN(

         'USERID.DTCNPLG.CERT'

         ) ",

         " FORMAT(CERTB64                                      ))"

        

       

Initialize parameters in CICS region
Add the KEYRING parameter in the CICS region start up job and point to the key ring created for the
region owner ID.
The following example adds SYSIN DD data set of CICS region startup job:
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        KEYRING=USERID
       

Define TCPIPSERVICE resource
Add a TCPIPSERVICE resource definitions, see example below in bold texts. Change the SSL and
Certificate attributes.

        
         TCpipservice    : EQAHTP8S

         GROup          : GROUP_NAME

         DEscription    :

         Urm            : EQADPAN0           no Analyzer program is used

         POrtnumber     : 30009              1-65535

         STatus         : Open               Open | Closed

         PROtocol       : HTTP               Iiop | Http | Eci | User

         TRansaction    : CWXN

         Backlog        : 00030              max backlog requests allowed

         TSqprefix      :

         Host           : ANY

         (Mixed Case)   :

         Ipaddress      :

         SOcketclose    : No                 No | 0-240000 (HHMMSS)

         Maxdatalen     : 008192             3-524288

         SECURITY

         SSl            :

         Yes

         Yes | No | Clientauth

         CErtificate    :

         USERID-DTCNPLG-CERT

         (Mixed Case)

         PRIvacy        : Supported          Notsupported|Required|Supported

         CIphers        : 050435363738392F303132330A1613100D0915120F0C03060201

         AUthenticate   : Basic              No|Basic|Certificate|AUTORegister | AUTOMatic | ASserted

         :I a Realm          :

         (Mixed Case)

         ATtachsec      :                    Local | Verify

         DNS CONNECTION BALANCING

         DNsgroup       :

         GRPcritical    : No                 No | Yes

         DEFINITION SIGNATURE

         DEFinetime     : 02/14/11 18:56:32

         CHANGETime     : 03/16/11 14:04:57

         CHANGEUsrid    : USERID

         CHANGEAGEnt    : CSDApi             CSDApi | CSDBatch

         CHANGEAGRel    : 0660

        

       

Technical support

These IBM Problem Determination Tools plug-ins are available at no charge to all licensed users of any of the following
five IBM Problem Determination Tools for z/OS products:

IBM Application Performance Analyzer for z/OS V13.1, or later
IBM Debug Tool for z/OS V13.1, or later
IBM Fault Analyzer for z/OS, V12.1, or later
IBM File Manager for z/OS V13.1, or later
IBM Workload Simulator for z/OS & OS/390 V1.1, or later

These IBM Problem Determination Tools plug-ins are supplied under the standard terms and conditions of the IBM
International Program License Agreement (IPLA) and of the associated License Information and other documentation,
and provides a defect correction entitlement for those licensed users entitled to service for any of the IBM Problem
Determination Tools for z/OS products listed above. Service is available for these plug-ins for as long as the IBM
Problem Determination Tools for z/OS product which the plug-ins are to be used with are generally supported by IBM. In
addition, IBM reserves the right to discontinue service on these plug-ins when they are withdrawn from marketing by
IBM. Please reference the IBM Problem Determination Tool for z/OS product that you are using as the entitled product
when contacting IBM and requesting support for IBM Problem Determination Tools Studio.


