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Overview

The IBM Problem Determination Tools Plug-ins combined packages contain all of the individual product plug-ins in a
single downloadable zip file. These single all-inclusive zip files make the initial installation and follow-on maintenance
and functional updates easier than the previous individual product plug-in packages.

Hardware Requirements
The following minimum hardware levels are required:

® CPU - 1 GHz or faster 32-bit (x86) or 64-bit (x64) processor, dual or quad core recommended
® RAM - 2.0 GB minimum, 3.0 GB recommended
® Hard disk - 1.8 GB available space, plus 210 MB of temporary space

Supported Platforms
One of the following levels of the Microsoft Windows operating system:

Microsoft Windows XP 32-bit
Microsoft Windows Vista 32-bit
Microsoft Windows 7 32-bit

Microsoft Windows 7 64-bit

Microsoft Windows Server 2008 32-bit

Software Requirements
One of the following Eclipse-based platforms:

® |BM Rational Developer for System z (for Windows only) V9, or later
® |IBM CICS Explorer V5.1.1, or later

Any combination of one or more of the following IBM Problem Determination Tools for z/OS products:

IBM Application Performance Analyzer for z/OS V12.1, or later
IBM Debug Tool for z/OS V13.1, or later

IBM Fault Analyzer for z/OS, V13.1, or later

IBM File Manager for z/OS V13.1, or later

IBM Workload Simulator for z/OS & OS/390 V1.1, or later

Preparing to install IBM Problem Determination Tools plug-ins Combined Packages

It is highly recommended that you uninstall any pre-existing Problem Determination Tools plug-ins from Rational
Developer for System z. To check what software is installed and to uninstall:

1. Start IBM Installation Manager
2. Click Uninstall
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3. Select all the IBM Problem Determination Tools plug-ins installed:
IBM Application Performance Analyzer Plug-in for Eclipse
IBM Debug Tool DTCN plugin for CICS
IBM Debug Tool DTSP plugin for non-CICS
IBM Debug Tools for zOS Explorer
IBM Fault Analyzer Plug-in for Eclipse
IBM File Manager Plug-in
7. 1BM Workload Simulator Plug-in for Eclipse
4. Click Next
5. Click Uninstall
6. Once the plug-ins are successfully uninstalled click Finish
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NOTE: Do not uninstall the IBM CICS Explorer SDK package.

Installing IBM Problem Determination Tools plug-ins Combined Packages

To install Problem Determination Tools plug-ins Combined Packages, you will need to specify the repository location
before installing. The latest offering is located in the IBM Problem Determination Tools website. Download the install zip
file (PD_Tool s_pl ugi ns_comnbi ned_I M v xxxxxx . zip ) foralocal install.

1. Unzip the install zip file to a temporary directory e.g. C: \ PD_Tool s_conbi ned_I M v xxxxxx . A path of 32
or less characters is recommended, but not required. See Installation Note 1
Start IBM Installation Manager
Click File > Preferences...
In Preferences click Add Repository...
Click Browse and specify the temporary directory, then click OK
In Preferences click OK
In IBM Installation Manager click Install
Select all the IBM Problem Determination Tools plug-ins listed:
IBM Application Performance Analyzer Plug-in for Eclipse See Installation Notes
IBM Debug Tool DTCN plugin for CICS
IBM Debug Tool DTSP plugin for non-CICS
IBM Fault Analyzer Plug-in for Eclipse
IBM File Manager Plug-in for Eclipse
6. IBM Workload Simulator Plug-in for Eclipse

9. Click Next
10. Review and accept the terms in the license agreements, and then click Next
11. Click Next to install using the existing package group
12. Ensure that all features are selected, then click Next
13. Click Install
14. Once the plug-ins are successfully installed click Finish
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Installation Notes for Application Performance Analyzer users:

1. This package contains both the Application Performance Analyzer Version 12 plug-ins and the Application
Performance Analyzer Version 13 plug-ins.

2. Application Performance Analyzer for z/OS Version 12 requires the Application Performance Analyzer version 12
plug-ins. It is not forward compatible.

3. Application Performance Analyzer for z/OS Version 13 requires the Application Performance Analyzer version 13
plug-ins. It is not backward compatible.

4. Only one version of the APA plug-ins can be installed at once, not both.

5. By default the Available Software window will have the option Show only the latest version of available
software checked, and only the Application Performance Analyzer Version 13 plug-ins are displayed when the
Application Performance Analyzer plug-in category is expanded.

6. If you wish to install the Application Performance Analyzer Version 13 plug-ins, follow the installation instructions
above.

7. If you wish to install the Application Performance Analyzer Version 12 plug-ins, you must:

1. Check "Show all versions"

2. Expand the "Application Performance Analyzer plug-in for eclipse" category
3. Select the version 12.1.0.x Application Performance Analyzer plugin.

4. Continue with the installation instructions at Step 9) above.

Getting Started With IBM Problem Determination Tools plug-ins Combined Packages

After installing the plug-ins, follow the steps below for the plug-in(s) you are using:
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Application Performance Analyzer Plug-in Version 12

1. There is some connections/credentials setup that is unique to Application Performance Analyzer that must
be performed. Please refer to the APA Bridge for CICS Explorer User Guide for details on how to
configure credentials and connections for Application Performance Analyzer and how to connect to
Application Performance Analyzer on z/OS. Once the connection is established, the Select STC dialog is
displayed in which a default startup APA Started Task (STC) must be selected. A list of active APA
Started Tasks (STC's) is displayed. The default STC is the started task which will be selected at the
startup of Application Performance Analyzer. The Default STC is displayed for the first successful login
only, then saved as a preference that can be changed from the "Set as Default STC" context menu item of
the STC List view

2. To access Application Performance Analyzer, click Window > Open perspective > Other... . Select APA
and click OK .

3. For more information, click Help > Help Contents. Follow the instructions in the IBM Application
Performance Analyzer User Guide section for details on getting started using Application Performance
Analyzer.

Application Performance Analyzer Plug-in Version 13

1. Application Performance Analyzer Plug-in Version 13 uses the Problem Determination Tools Common
Component for z/OS to connect with Application Performance Analyzer for z/OS Version 13, through the
Problem Determination Tools Common Server on z/OS.

2. Click Help > Help Contents. Follow the instructions in the IBM Problem Determination Tools for z/OS
Common Component for details on establishing a Problem Determination Tools for z/OS connection.

3. To access Application Performance Analyzer, click Window > Open perspective > Other .... Select APA
and click OK.

4. Once the connection is established and the Application Performance Analyzer perspective is open, the
default startup Application Performance Analyzer Started Task (STC) must be selected. A list of active
Started Tasks (STC's) is displayed in the STC View window. By default, the first STC in the list is
selected. The default STC is the started task which will be selected at the startup of Application
Performance Analyzer Plug-in. To change the default STC, highlight the STC in the STC View window
and select Set as Default STC from the context menu.

5. For more information, click Help > Help Contents. Follow the instructions in the IBM Application
Performance Analyzer User Guide section for details on getting started using Application Performance
Analyzer.

Debug Tool Plug-in

1. Establish a connection between the DTCN Profiles view for CICS and your z/OS system by following the
steps described in DTCN tips .

2. To access Debug Tool, click Window > Open perspective > Other... . Select Debug and click OK .

3. Find more information, click Help > Help Contents . Follow the instructions in the Compiled language
debugger section for details on getting started using Debug Tool to debug your application

Fault Analyzer Plug-in

1. To access Fault Analyzer, click Window > Open perspective > Other... . Select Fault Analyzer and click
OK .

2. Find more information, click Help > Help Contents . Follow the instructions in the Fault Analyzer for
Eclipse section for details on getting started using Fault Analyzer

File Manager Plug-in

1. To access Fault Analyzer, click Window > Open perspective > Other... . Select File Manager and click
OK .

2. Find more information, click Help > Help Contents . Follow the instructions in the IBM File Manager
User Guide section for details on getting started using File Manager

Workload Simulator Plug-in

1. To access Workload Simulator, click Window > Open perspective > Other... . Select WSim Explorer
and click OK .

2. Find more information, click Help > Help Contents . Follow the instructions in the Using the Workload
Simulator plug-in for Eclipse section for details on getting started using Workload Simulator.

Updating IBM Problem Determination Tools plug-ins Combined Packages

To update Problem Determination Tools plug-ins Combined Packages, you will need to specify the repository location
first. The latest offering is located in the IBM Problem Determination Tools website. Download the install zip file (
PD Tool s_plugins_I Mv xxxxxx .zip )foralocal install.

1.
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Unzip the install zip file to a temporary directory e.g. C: \ PD_Tool s_conbi ned_I M v xxxxxx . A path of 32
or less characters is recommended, but not required. See Installation Note 1

Start IBM Installation Manager

Click File > Preferences...

In Preferences click Add Repository...

Click Browse and specify the temporary directory, then click OK



http://jotunheimr/releases/422/jenkins-PdtccFmStudioV12Service422-31/pdtools/plugins/DTCN_tips.html
http://www-01.ibm.com/software/awdtools/deployment/pdtplugins/

In Preferences click OK

In IBM Installation Manager click Update

Click Next

It's recommended that you select all the packages, then click Next

10. Review and accept the terms in the license agreements, and then click Next
11. Ensure that all features are selected, then click Next

12. Click Update

13. Once the plug-ins are successfully updated click Finish
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Installation Notes
Note 1: Microsoft Windows Maximum Path Length Limitation

Microsoft Windows file systems, have a maximum path length of 255 characters. Extracting to paths longer than 32
characters is supported, but not recommended, as exceeding the Windows Path limit will result in extraction errors.

Technical support

These IBM Problem Determination Tools plug-ins are available at no charge to all licensed users of any of the following
five IBM Problem Determination Tools for z/OS products:

IBM Application Performance Analyzer for z/OS V13.1, or later
IBM Debug Tool for z/OS V13.1, or later

IBM Fault Analyzer for z/OS, V13, or later

IBM File Manager for z/OS V13.1, or later

IBM Workload Simulator for z/OS & OS/390 V1.1, or later
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These IBM Problem Determination Tools plug-ins are supplied under the standard terms and conditions of the IBM
International Program License Agreement (IPLA) and of the associated License Information and other documentation,
and provides a defect correction entitlement for those licensed users entitled to service for any of the IBM Problem
Determination Tools for z/OS products listed above. Service is available for these plug-ins for as long as the IBM
Problem Determination Tools for z/OS product which the plug-ins are to be used with are generally supported by IBM. In
addition, IBM reserves the right to discontinue service on these plug-ins when they are withdrawn from marketing by
IBM. Please reference the IBM Problem Determination Tool for z/OS product that you are using as the entitled product
when contacting IBM and requesting support for IBM Problem Determination Tools Studio.



