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Overview

The IBM Problem Determination Tools Plug-ins combined packages contain all of the individual product plug-ins in a
single downloadable zip file. These single all-inclusive zip files make the initial installation and follow-on maintenance
and functional updates easier than the previous individual product plug-in packages.

Hardware Requirements

The following minimum hardware levels are required:

CPU - 1 GHz or faster 32-bit (x86) or 64-bit (x64) processor, dual or quad core recommended
RAM - 2.0 GB minimum, 3.0 GB recommended
Hard disk - 1.8 GB available space, plus 210 MB of temporary space

Supported Platforms

One of the following levels of the Microsoft Windows operating system:

Microsoft Windows XP 32-bit
Microsoft Windows Vista 32-bit
Microsoft Windows 7 32-bit
Microsoft Windows 7 64-bit
Microsoft Windows Server 2008 32-bit

Software Requirements

One of the following Eclipse-based platforms:

IBM Rational Developer for System z (for Windows only) V9, or later
IBM CICS Explorer V5.1.1, or later

Any combination of one or more of the following IBM Problem Determination Tools for z/OS products:

IBM Application Performance Analyzer for z/OS V12.1, or later
IBM Debug Tool for z/OS V13.1, or later
IBM Fault Analyzer for z/OS, V13.1, or later
IBM File Manager for z/OS V13.1, or later
IBM Workload Simulator for z/OS & OS/390 V1.1, or later

Preparing to install IBM Problem Determination Tools plug-ins Combined Packages

It is highly recommended that you uninstall any pre-existing Problem Determination Tools plug-ins from Rational
Developer for System z. To check what software is installed and to uninstall:

Start IBM Installation Manager
Click Uninstall

http://www.ibm.com/legal/copytrade.shtml
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Select all the IBM Problem Determination Tools plug-ins installed:
IBM Application Performance Analyzer Plug-in for Eclipse
IBM Debug Tool DTCN plugin for CICS
IBM Debug Tool DTSP plugin for non-CICS
IBM Debug Tools for zOS Explorer
IBM Fault Analyzer Plug-in for Eclipse
IBM File Manager Plug-in
IBM Workload Simulator Plug-in for Eclipse

Click Next
Click Uninstall
Once the plug-ins are successfully uninstalled click Finish

 Do not uninstall the IBM CICS Explorer SDK package.NOTE:

Installing IBM Problem Determination Tools plug-ins Combined Packages

To install Problem Determination Tools plug-ins Combined Packages, you will need to specify the repository location
before installing. The latest offering is located in the website. Download the install zipIBM Problem Determination Tools 
file ( ) for a local install.PD_Tools_plugins_combined_IM_v  .zip xxxxxx

Unzip the install zip file to a temporary directory e.g. . A path of 32C:\PD_Tools_combined_IM_v  xxxxxx
or less characters is recommended, but not required. See Installation Note 1
Start IBM Installation Manager
Click File > Preferences...
In Preferences click Add Repository...
Click  and specify the temporary directory, then click Browse OK
In Preferences click OK
In IBM Installation Manager click Install
Select all the IBM Problem Determination Tools plug-ins listed:

IBM Application Performance Analyzer Plug-in for Eclipse See Installation Notes
IBM Debug Tool DTCN plugin for CICS
IBM Debug Tool DTSP plugin for non-CICS
IBM Fault Analyzer Plug-in for Eclipse
IBM File Manager Plug-in for Eclipse
IBM Workload Simulator Plug-in for Eclipse

Click Next
Review and accept the terms in the license agreements, and then click Next
Click  to install using the existing package groupNext
Ensure that all features are selected, then click Next
Click Install
Once the plug-ins are successfully installed click Finish

Installation Notes for Application Performance Analyzer users:
This package contains both the Application Performance Analyzer Version 12 plug-ins and the Application
Performance Analyzer Version 13 plug-ins.
Application Performance Analyzer for z/OS Version 12 requires the Application Performance Analyzer version 12
plug-ins. It is not forward compatible.
Application Performance Analyzer for z/OS Version 13 requires the Application Performance Analyzer version 13
plug-ins. It is not backward compatible.
Only one version of the APA plug-ins can be installed at once, not both.
By default the window will have the option Available Software Show only the latest version of available

checked, and only the Application Performance Analyzer Version 13 plug-ins are displayed when the software 
 category is expanded.Application Performance Analyzer plug-in

If you wish to install the Application Performance Analyzer Version 13 plug-ins, follow the installation instructions
above.
If you wish to install the Application Performance Analyzer Version 12 plug-ins, you must:

Check "Show all versions"
Expand the "Application Performance Analyzer plug-in for eclipse" category
Select the version 12.1.0.x Application Performance Analyzer plugin.
Continue with the installation instructions at Step 9) above.

Getting Started With IBM Problem Determination Tools plug-ins Combined Packages

After installing the plug-ins, follow the steps below for the plug-in(s) you are using:

http://www-01.ibm.com/software/awdtools/deployment/pdtplugins/
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Application Performance Analyzer Plug-in Version 12
There is some connections/credentials setup that is unique to Application Performance Analyzer that must
be performed. Please refer to the for details on how toAPA Bridge for CICS Explorer User Guide 
configure credentials and connections for Application Performance Analyzer and how to connect to
Application Performance Analyzer on z/OS. Once the connection is established, the Select STC dialog is
displayed in which a default startup APA Started Task (STC) must be selected. A list of active APA
Started Tasks (STC's) is displayed. The default STC is the started task which will be selected at the
startup of Application Performance Analyzer. The Default STC is displayed for the first successful login
only, then saved as a preference that can be changed from the "Set as Default STC" context menu item of
the STC List view
To access Application Performance Analyzer, click . Select Window > Open perspective > Other... APA
and click  .OK
For more information, click Follow the instructions in the Help > Help Contents. IBM Application

section for details on getting started using Application PerformancePerformance Analyzer User Guide 
Analyzer.

Application Performance Analyzer Plug-in Version 13
Application Performance Analyzer Plug-in Version 13 uses the Problem Determination Tools Common
Component for z/OS to connect with Application Performance Analyzer for z/OS Version 13, through the
Problem Determination Tools Common Server on z/OS.
Click Follow the instructions in the Help > Help Contents. IBM Problem Determination Tools for z/OS

for details on establishing a Problem Determination Tools for z/OS connection.Common Component 
To access Application Performance Analyzer, click Select Window > Open perspective > Other .... APA
and click OK.
Once the connection is established and the Application Performance Analyzer perspective is open, the
default startup Application Performance Analyzer Started Task (STC) must be selected. A list of active
Started Tasks (STC's) is displayed in the STC View window. By default, the first STC in the list is selected.
The default STC is the started task which will be selected at the startup of Application Performance
Analyzer Plug-in. To change the default STC, highlight the STC in the STC View window and select Set

from the context menu.as Default STC 
For more information, click Follow the instructions in the Help > Help Contents. IBM Application

section for details on getting started using Application PerformancePerformance Analyzer User Guide 
Analyzer.

Debug Tool Plug-in
Establish a connection between the DTCN Profiles view for CICS and your z/OS system by following the
steps described in .DTCN tips 
To access Debug Tool, click . Select  and click  .Window > Open perspective > Other... Debug OK
Find more information, click . Follow the instructions in the Help > Help Contents Compiled language

 section for details on getting started using Debug Tool to debug your applicationdebugger
Fault Analyzer Plug-in

To access Fault Analyzer, click . Select and clickWindow > Open perspective > Other... Fault Analyzer 
 .OK

Find more information, click . Follow the instructions in the Help > Help Contents Fault Analyzer for
 section for details on getting started using Fault AnalyzerEclipse

File Manager Plug-in
To access Fault Analyzer, click . Select and click Window > Open perspective > Other... File Manager 

 .OK
Find more information, click . Follow the instructions in the Help > Help Contents IBM File Manager

 section for details on getting started using File ManagerUser Guide
Workload Simulator Plug-in

To access Workload Simulator, click . Select Window > Open perspective > Other... WSim Explorer 
and click  .OK
Find more information, click . Follow the instructions in the Help > Help Contents Using the Workload

section for details on getting started using Workload Simulator.Simulator plug-in for Eclipse 

Updating IBM Problem Determination Tools plug-ins Combined Packages

To update Problem Determination Tools plug-ins Combined Packages, you will need to specify the repository location
first. The latest offering is located in the website. Download the install zip file ( IBM Problem Determination Tools 

) for a local install.PD_Tools_plugins_IM_v  .zip xxxxxx

Unzip the install zip file to a temporary directory e.g. . A path of 32C:\PD_Tools_combined_IM_v  xxxxxx
or less characters is recommended, but not required. See Installation Note 1
Start IBM Installation Manager
Click File > Preferences...
In Preferences click Add Repository...
Click  and specify the temporary directory, then click Browse OK

http://jotunheimr/releases/422/jenkins-PdtccFmStudioV12Service422-31/pdtools/plugins/DTCN_tips.html
http://www-01.ibm.com/software/awdtools/deployment/pdtplugins/
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In Preferences click OK
In IBM Installation Manager click Update
Click Next
It's recommended that you select all the packages, then click Next
Review and accept the terms in the license agreements, and then click Next
Ensure that all features are selected, then click Next
Click Update
Once the plug-ins are successfully updated click Finish

Installation Notes

Note 1: Microsoft Windows Maximum Path Length Limitation

Microsoft Windows file systems, have a maximum path length of 255 characters. Extracting to paths longer than 32
characters is supported, but not recommended, as exceeding the Windows Path limit will result in extraction errors.

Technical support

These IBM Problem Determination Tools plug-ins are available at no charge to all licensed users of any of the following
five IBM Problem Determination Tools for z/OS products:

IBM Application Performance Analyzer for z/OS V13.1, or later
IBM Debug Tool for z/OS V13.1, or later
IBM Fault Analyzer for z/OS, V13, or later
IBM File Manager for z/OS V13.1, or later
IBM Workload Simulator for z/OS & OS/390 V1.1, or later

These IBM Problem Determination Tools plug-ins are supplied under the standard terms and conditions of the IBM
International Program License Agreement (IPLA) and of the associated License Information and other documentation,
and provides a defect correction entitlement for those licensed users entitled to service for any of the IBM Problem
Determination Tools for z/OS products listed above. Service is available for these plug-ins for as long as the IBM
Problem Determination Tools for z/OS product which the plug-ins are to be used with are generally supported by IBM. In
addition, IBM reserves the right to discontinue service on these plug-ins when they are withdrawn from marketing by
IBM. Please reference the IBM Problem Determination Tool for z/OS product that you are using as the entitled product
when contacting IBM and requesting support for IBM Problem Determination Tools Studio.


