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Overview

The IBM Problem Determination Tools Plug-ins combined packages contain all of the individual product plug-ins in a
single downloadable zip file. These single all-inclusive zip files make the initial installation and follow-on maintenance
and functional updates easier than the previous individual product plug-in packages.

Hardware Requirements
The following minimum hardware levels are required:

® CPU - 1 GHz or faster 32-bit (x86) or 64-bit (x64) processor, dual or quad core recommended
® RAM - 2.0 GB minimum, 3.0 GB recommended
® Hard disk - 1.8 GB available space, plus 210 MB of temporary space

Supported Platforms
One of the following levels of the Microsoft Windows operating system:

Microsoft Windows XP 32-bit
Microsoft Windows Vista 32-bit
Microsoft Windows 7 32-bit

Microsoft Windows 7 64-bit

Microsoft Windows Server 2008 32-bit

Software Requirements
IBM Rational Developer for System z (for Windows only) V8.5
Any combination of one or more of the following IBM Problem Determination Tools for z/OS products:

IBM Application Performance Analyzer for z/OS V12.1, or later
IBM Debug Tool for zZ/OS V12.1, or later

IBM Fault Analyzer for z/OS, V12.1, or later

IBM File Manager for z/OS V12.1, or later

IBM Workload Simulator for z/OS & OS/390 V1.1, or later

Preparing to install IBM Problem Determination Tools plug-ins Combined Packages

It is highly recommended that you uninstall any pre-existing Problem Determination Tools plug-ins from Rational
Developer for System z. To check what software is installed and to uninstall:

1. Start IBM Installation Manager

2. Click Uninstall

3. Select all the IBM Problem Determination Tools plug-ins installed:
1. IBM Application Performance Analyzer Plug-in for Eclipse
2. I1BM Debug Tool DTCN plugin for CICS
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3. IBM Debug Tool DTSP plugin for non-CICS
4. 1BM Debug Tools for zOS Explorer
5. IBM Fault Analyzer Plug-in for Eclipse
6. IBM File Manager Plug-in
7. I1BM Workload Simulator Plug-in for Eclipse
Click Next
Click Uninstall
Once the plug-ins are successfully uninstalled click Finish

NOTE: Do not uninstall the IBM CICS Explorer SDK package.

Installing IBM Problem Determination Tools plug-ins Combined Packages

To install Problem Determination Tools plug-ins Combined Packages, you will need to specify the repository location
before installing. The latest offering is located in the IBM Problem Determination Tools website. Download the install zip
file (PD_Tool s_pl ugi ns_conbi ned_I M v xxxxxx .zip ) fora local install.

1.
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Unzip the install zip file to a temporary directory e.g. C: \ PD_Tool s_conbi ned_I M v xxxxxx . A path of 32
or less characters is recommended, but not required. See Installation Note 1
Start IBM Installation Manager
Click File > Preferences...
In Preferences click Add Repository...
Click Browse and specify the temporary directory, then click OK
In Preferences click OK
In IBM Installation Manager click Install
Select all the IBM Problem Determination Tools plug-ins listed:
IBM Application Performance Analyzer Plug-in for Eclipse
IBM Debug Tool DTCN plugin for CICS
IBM Debug Tool DTSP plugin for non-CICS
IBM Fault Analyzer Plug-in for Eclipse
IBM File Manager Plug-in for Eclipse
6. IBM Workload Simulator Plug-in for Eclipse
Click Next
Review and accept the terms in the license agreements, and then click Next
Click Next to install using the existing package group
Ensure that all features are selected, then click Next
Click Install
Once the plug-ins are successfully installed click Finish
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Getting Started With IBM Problem Determination Tools plug-ins Combined Packages

After installing the plug-ins, follow the steps below for the plug-in(s) you are using:

® Application Performance Analyzer Plug-in

1. There is some connections/credentials setup that is unique to Application Performance Analyzer that must
be performed. Please refer to the APA CICS Explorer User Guide for details on how to configure
credentials and connections for Application Performance Analyzer and how to connect to Application
Performance Analyzer on z/OS. Once the connection is established, the Select STC dialog is displayed in
which a default startup APA Started Task (STC) must be selected. A list of active APA Started Tasks
(STC's) is displayed. The default STC is the started task which will be selected at the startup of
Application Performance Analyzer. The Default STC is displayed for the first successful login only, then
saved as a preference that can be changed from the "Set as Default STC" context menu item of the STC
List view.

2. To access Application Performance Analyzer, click Window > Open perspective > Other... . Select APA
and click OK .

3. Find more information, click Help > Help Contents . Follow the instructions in the APA CICS Explorer
User Guide for details on how to configure credentials and connections for APA and how to connect to
APA on z/OS. Follow the instructions in the APA User Guide for details on using the plug-in.

® Debug Tool Plug-in

1. Establish a connection between the DTCN Profiles view for CICS and your z/OS system by following the
steps described in DTCN tips .

2. To access Debug Tool, click Window > Open perspective > Other... . Select Debug and click OK .

3. Find more information, click Help > Help Contents . Follow the instructions in the Compiled language
debugger section for details on getting started using Debug Tool to debug your application

® Fault Analyzer Plug-in

1. To access Fault Analyzer, click Window > Open perspective > Other... . Select Fault Analyzer and click
OK .
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2. Find more information, click Help > Help Contents . Follow the instructions in the Fault Analyzer for
Eclipse section for details on getting started using Fault Analyzer
® File Manager Plug-in
1. To access Fault Analyzer, click Window > Open perspective > Other... . Select File Manager and click
OK .
2. Find more information, click Help > Help Contents . Follow the instructions in the IBM File Manager
User Guide section for details on getting started using File Manager
® Workload Simulator Plug-in
1. To access Workload Simulator, click Window > Open perspective > Other... . Select WSim Explorer
and click OK .
2. Find more information, click Help > Help Contents . Follow the instructions in the Using the Workload
Simulator plug-in for Eclipse section for details on getting started using Workload Simulator.

Establishing a connection between the DTCN Profiles view for CICS and your z/OS system

Specify the settings needed to establish a connection between the DTCN profiles view and your z/OS system by doing
the following steps:

Click Window > Show view > Other

Type "DTCN" in the text box at the top of the window. Select DTCN profiles and click OK

Click Window > Show view > Other

Type "Host Connections” in the text box at the top of the window. Select Host Connections and click OK
In the Host Connections view, select DTCN and click Add to create a connection to DTCN.

Specify the settings in the following fields and click Save and Close:
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Name
The name of the connection. If left blank will be auto-filled by combining the host name and port number
entered separated by ":"

Host name
The TCP/IP name or address of the z/OS system as described in "Defining the CICS TCPIPSERVICE
resource” in the Debug Tool Customization Guide

Port number
The port number of the z/OS system as described in "Defining the CICS TCPIPSERVICE resource" in the
Debug Tool Customization Guide

7. Select the DTCN connection you created, and click Connect.
8. In the DTCN Signon window, specify the settings in the following fields, or select "Use existing Credentials” if you
have at least one credential defined, and click OK.

Credentials Name
The name of the credential
User ID
The ID that you use to log on to the CICS system
Password or Passphrase
The password or passphrase that you use to log on to the CICS system

A successful connection is indicated through a green icon for the DTCN connection. Otherwise, review the values you
entered, correct any mistakes, and try the connection test again. You can also review the trace file (as described in
Debug Tool User's Guide Appendix | section "Locating the trace file of the DTCN Profiles or DTSP Profile view") for
diagnostic information that can help identify the cause of the connection error. In the DTCN Profiles view, you can right
click anywhere to see a list of actions available.

Note: If you want require a secured connection, you will need to follow the steps in the section, Establishing a secured
communication between the DTCN profile view for CICS and your z/OS system

Establishing a secured communication between the DTCN profile view for CICS and your
z/OS system

These steps help you enable secure communication via Secure Sockets Layer (SSL) between DTCN profile view and
your z/OS system. The communication between the client and server uses the HTTP protocol.

Server side setup

To enable SSL communication, do the following tasks for Server side:
1. Generate key pair and self-signed certificate using Rexx RACF command.

1. Use RACF GENCERT command to create a key entry for the CICS region owner. The key entry contains
the key pair and self-signed certificate.



Example (Create a key entry for user USERID with label: USERID-DTCNPLG-CERT):

/* generate key entry */
" RACDCERT | D( USERI D) GENCERT",

" SUBJECTSDN( CN(

"your _host _nane. con

)

—

(" USERI D- DTCNPLG- CERT'
"1 BM
("1 BM
(' San Jose'
SP(' CA
C('us
" NOTBEFORE( DATE(2011-02-28) Tl ME(20: 00: 00) )",
" NOTAFTER ( DATE(2031-12-31) TI ME(19: 59: 59) )",
" W THLABEL(
USERI D- DTCNPLG- CERT
)"
"SI ZE (1024 )"
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2. Connect the key entry to a key ring that belongs to the CICS region owner ID. The common name of the
subject DSN must be the host name of the server that the client uses to connect to host.
Example (Connect it to a key ring named USERID):

/* connect key entry to key ring */
' RACDCERT | D(
USERI D

)
CONNECT( RI NG (
USERI D
X

. LABEL(
USER! D- DTCNPLG- CERT

)"

3. Export the certificate and store it in a data set using the printable encoding format defined by the internet
RFC 1421 standard
Example (Export the certificate to a data set: USERID.DTCNPLG.CERT)

/* export certificate to a data set */
" RACDCERT EXPORT( LABEL(' USERI D- DTCNPLG CERT' ) "
LD

USERI D

)"

" DSN(

' USERI D. DTCNPLG. CERT'

) "
' FORMAT( CERTB64 )"

2. Initialize parameters in CICS region

1. Add the KEYRING parameter in the CICS region start up job and point to the key ring created for the
region owner ID.
2. The following example adds SYSIN DD data set of CICS region startup job:

KEYRI NG=USERI D

3. Define TCPIPSERVICE resource

1. Add a TCPIPSERVICE resource definitions, see example below in bold texts. Change the SSL and
Certificate attributes.



TCpi pservi ce . EQAHTP8S

GRQup : GROUP_NAME

DEscri ption :

U m : EQADPANO no Anal yzer programis used
POr t nunber : 30009 1- 65535

STat us : Open Open | dosed

PRC: ocol . HITP liop | Htp | Eci | User
TRansacti on : CWKN

Backl og ;00030 max backl og requests all owed
TSqpr efi x :

Host : ANY

(M xed Case) :

| paddr ess :

SCcket cl ose : No No | 0-240000 (HHWVSS)

Maxdat al en : 008192 3-524288

SECURI TY

SSi

Yes

Yes | No | Cientauth

CErtificate

USERI D- DTCNPLG- CERT

(M xed Case)

PRI vacy : Supported Not suppor t ed| Requi r ed| Support ed
Cl phers : 050435363738392F303132330A1613100D0915120F0C03060201
AUt henti cate : Basic No| Basi c| Certificate| AUTORegi ster | AUTOVatic | ASsert
;1 a Realm :

(M xed Case)

ATt achsec : Local | Verify

DNS CONNECTI ON BALANCI NG

DNsgr oup :

GRPcri tical : No No | Yes

DEFI NI TI ON SI GNATURE

DEFi neti me : 02/14/11 18:56: 32

CHANCETI ne : 03/16/11 14:04:57

CHANGEUsr i d : USERI D

CHANGEAGENt . CSDApi CSDApi | CsDBat ch
CHANCEAGRel : 0660

Client side setup

To enable SSL communication, complete the following tasks for the client side:

1. Install server certificate
Because the certificate server generated is not from an authorized certificate authority (CA), to solve this issue,
you need to install the certificate to your JDKs keystore.

1. Download copy of the certificate in text mode that the server has exported into your workstation directory
2. Import the downloaded certificate into your JREs keystore. The following is an example how to import the
certificate into keystore using keytool provided by java

Keytool inmport alias nyprivateroot keystore ..\lib\security\cacerts file dtcnplg.cer
dtcnpl g.cer is the downl oaded copy of the server certificate.
The initial password for the cacerts keystore is changeit

Note: If you are using CICS Explorer, the keytool utility can be found in the Java installation bin directory,
C:\CICS_Explorer_HOME_DIRECTORY)jre\bin.

If you are using PD Tools Studio, the keytool utility can be found in the Java installation bin directory,
C:\PD_Tools_Studio_V121000.32bit HOME_DIRECTORY\PDT_Studio_plugins_x86\jre\jre\bin

APA uses its own listener for the GUI. If you attempt to create a connection that is not as explained below, it will not
work, since APA uses its own listener. To establish a connection with an APA listener you need to perform the following
steps:

1. Start the PD Tools Studio GUI (PD_Tools.exe)
2. Open host connections (right hand side of GUI or at the right bottom)



Open the connections panel and click on Application Performance Analyzer and then click on add...

The location host name is the ftp address for the listener (e.g. 9.30.128.24 in our case for F6)

Enter the listener port number in the port number box, in our case itis 1110

The overall name is filled in automatically or you can overwrite the name.

Click on the started task you desire to connect to, for F6, it is CAZC

Create a credentials entry for you, with your user name and password (can be passphrase if used on the
machine).

9. If you save the password, then you will be automatically connected
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Updating IBM Problem Determination Tools plug-ins Combined Packages

To update Problem Determination Tools plug-ins Combined Packages, you will need to specify the repository location
first. The latest offering is located in the IBM Problem Determination Tools website. Download the install zip file (
PD Tool s_plugins_IMv xxxxxx .zip )foralocal install.

1. Unzip the install zip file to a temporary directory e.g. C. \ PD_Tool s_conbi ned_I M v xxxxxx . A path of 32
or less characters is recommended, but not required. See Installation Note 1
Start IBM Installation Manager

Click File > Preferences...

In Preferences click Add Repository...

Click Browse and specify the temporary directory, then click OK

In Preferences click OK

In IBM Installation Manager click Update

Click Next

It's recommended that you select all the packages, then click Next

10. Review and accept the terms in the license agreements, and then click Next
11. Ensure that all features are selected, then click Next

12. Click Update

13. Once the plug-ins are successfully updated click Finish
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Installation Notes
Note 1: Microsoft Windows Maximum Path Length Limitation

Microsoft Windows file systems, have a maximum path length of 255 characters. Extracting to paths longer than 32
characters is supported, but not recommended, as exceeding the Windows Path limit will result in extraction errors.

Technical support

These IBM Problem Determination Tools plug-ins are available at no charge to all licensed users of any of the following
five IBM Problem Determination Tools for z/OS products:

IBM Application Performance Analyzer for z/OS V12.1, or later
IBM Debug Tool for z/OS V12.1, or later

IBM Fault Analyzer for z/OS, V12, or later

IBM File Manager for z/OS V12.1, or later

IBM Workload Simulator for z/OS & OS/390 V1.1, or later
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These IBM Problem Determination Tools plug-ins are supplied under the standard terms and conditions of the IBM
International Program License Agreement (IPLA) and of the associated License Information and other documentation,
and provides a defect correction entitlement for those licensed users entitled to service for any of the IBM Problem
Determination Tools for z/OS products listed above. Service is available for these plug-ins for as long as the IBM
Problem Determination Tools for z/OS product which the plug-ins are to be used with are generally supported by IBM. In
addition, IBM reserves the right to discontinue service on these plug-ins when they are withdrawn from marketing by
IBM. Please reference the IBM Problem Determination Tool for z/OS product that you are using as the entitled product
when contacting IBM and requesting support for IBM Problem Determination Tools Studio.


http://www-01.ibm.com/software/awdtools/deployment/pdtplugins/

