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System requirements and prerequisites

The following minimum hardware levels are required to run the CICS Explorer or IMS Enterprise Suite Explorer for Development and are therefore

applicable to Debug Tool Plug-in for Eclipse V12.1.0.0:

CPU - Intel® Pentium® 4 or equivalent
RAM - 768 MB in addition to the operating system requirements
Hard disk - 500 MB available space

One of the following levels of Windows operating system is required to install the CICS Explorer and is therefore applicable to Debug Tool Plug-in for

Eclipse V12.1.0.0:

Microsoft Windows 7 32-bit

Microsoft® Windows® XP 32-bit



Microsoft Windows Vista 32-bit

Microsoft Windows Server 2008 32-bit

One of the following levels of Windows operating system is required to install the IMS Enterprise Suite Explorer for Development and is therefore

applicable to Debug Tool Plug-in for Eclipse V12.1.0.0:

Microsoft Windows 7 64-bit
Microsoft® Windows® XP 32-bit

The following levels of software are required to install the Debug Tool Plug-in for Eclipse V12.1.0.0:

One of the following Eclipse-based platforms:
CICS Explorer (for Windows) V1.1.1.0, or later

IMS Enterprise Suite Explorer for Development (for Windows) V2.1.1.2, or later
Debug Tool for z/OS Version 12.1 or later

The Debug Tool Plug-in for Eclipse V12.1.0.0 is available in the following national languages:

English
Japanese

Korean

The following levels of software are required to install the DTCN and DTSP plug-ins:

One of the following Eclipse-based platforms:

CICS Explorer (for Windows) V1.1.1.0, or later
IMS Enterprise Suite Explorer for Development (for Windows) V2.1.1.2, or later

Debug Tool for z/OS Version 12.1 or later
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Downloading Debug Tool Plug-in for Eclipse V12.1.0.0

The IBM Debug Tool Plug-in for Eclipse V12.1.0.0 can be downloaded from the Problem Determination Tools Plug-in website. Then follow the IBM
Debug Tool Plug-in for Eclipse link to the download page and download the file that is called DT_plugin_v12100.zip.
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Debug Tool Plug-in for Eclipse V12.1.0.0 overview

The downloaded compressed file contains the following plug-ins:

The "Debug Perspective for CICS Explorer" which is needed just for CICS Explorer and contains views such as Debug, Breakpoints,
Variables, etc.

The "DTCN for CICS Plug-in" provides the DTCN Profiles view to create and manage DTCN profiles for CICS on your z/OS system.
The "DTSP for non-CICS Plug-in" provides the DTSP Profile view to create and manage the TEST runtime options data set (EQAUOPTS) on
your z/OS system.

The "IBM Debug Tool Plug-in" contains Compiled Language Debugging support that includes views such as the Debug Console, Monitors, etc
which would be part of the Debug Perspective.
The "IBM Problem Determination Tools Common Component" enables the communication between the

DTCN for CICS Plug-in and the HTTP server in the CICS region on your z/OS system and

DTSP for non-CICS Plug-in and the IBM Problem Determination Tools Common Server on your z/OS system.
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Installing Debug Tool Plug-in for Eclipse V12.1.0.0 into CICS Explorer

The following steps are required in order to install the Debug Tool Plug-in for Eclipse V12.1.0.0 into CICS explorer: 

1. Extract all the contents of DT_plugin_v12100.zip to any writable directory of your choice, for example, C:\DebugTool.
2. Delete any com.ibm.pdt.debugtool.profile_*.jar file(s) inside of CICS_Explorer_install_directory\dropins folder.

3. Start CICS Explorer.
4. In the action bar, click "Help" -> "Install New Software".
5. If a previous version of the Debug Tool Plug-in is installed, click "already installed" to display the list of current plugins. Select the existing "IBM

Debug Tool Plugin for Eclipse", "Debug Perspective for Eclipse 3.6" and any DTCN or DTSP plugins (if previously installed), click "Uninstall"

then "Finish". Allow CICS Explorer to restart. Once CICS Explorer has restarted, select "Help" -> "Install New Software" again.
6. Click "Add".
7. An "Add Repository" window should open.

8. Click "Local".



9. Navigate to the directory storing the extracted files.
10. Click "OK".
11. Click "OK".

12. CICS Explorer displays a list of features you can install. Select
the "IBM Debug Tool Plug-in",
the "Debug Perspective for CICS Explorer" (if the Debug Perspective has not previously been installed),

(optionally) the DTCN for CICS and DTSP for non-CICS Plug-ins and
the "IBM Problem Determination Tools Common Component" if either DTCN for CICS or DTSP for non-CICS Plug-in was selected.

13. Click "Next".
14. Click "Next".

15. Accept the feature license agreement and click "Finish". There might be a security warning for unsigned content. Click "OK" if this message
appears.

16. CICS Explorer installs the Debug Tool Plug-in for Eclipse V12.1.0.0. You will be asked if you want to restart CICS Explorer. Click "Restart

Now".

After CICS Explorer restarts, read the following sections:

if you installed "DTCN for CICS Plug-in", read "Establishing a connection between the DTCN Profiles view for CICS and your z/OS system"
if you installed "DTSP for non-CICS Plug-in", read "Establishing a connection between the DTSP Profile view for non-CICS and your z/OS
system"

read "Getting Started Using Debug Tool Plug-in for Eclipse V12.1.0.0" for instructions on how to display the "Getting Started" help topic,
which has instructions on how to start debugging your applications.
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Installing Debug Tool Plug-in for Eclipse V12.1.0.0 into IMS Enterprise Suite Explorer
for Development

The following steps are required in order to install the Debug Tool Plug-in for Eclipse V12.1.0.0 into IMS explorer: 

1. Extract all the contents of DT_plugin_v12100.zip to any writable directory of your choice, for example, C:\DebugTool.
2. Start IMS Enterprise Suite Explorer for Development.
3. In the action bar click "Help" -> "Install New Software".



4. If a previous version of the Debug Tool Plug-in is installed, click "already installed" to display the list of current plugins. Select the existing "IBM
Debug Tool Plugin for Eclipse" and any DTCN or DTSP plugins (if previously installed), click "Uninstall" then "Finish". Allow IMS Enterprise
Suite Explorer for Development to restart. Once IMS Enterprise Suite Explorer for Development has restarted, select "Help" -> "Install New
Software" again.

5. Click "Add".

6. An "Add Repository" window should open.
7. Click "Local".
8. Navigate to the directory storing the extracted files.
9. Click "OK".

10. Click "OK".
11. IMS Enterprise Suite Explorer for Development displays a list of features you can install. Do not install "Debug Perspective for CICS Explorer".

Select
the "IBM Debug Tool Plug-in",
(optionally) the DTCN for CICS and DTSP for non-CICS Plug-ins and
the "IBM Problem Determination Tools Common Component" if either DTCN for CICS or DTSP for non-CICS Plug-in was selected.

12. Click "Next".
13. Click "Next".
14. Accept the feature license agreement and click "Finish". There may be a security warning for unsigned content. Click "OK" if this message

appears.
15. IMS Enterprise Suite Explorer for Development installs the Debug Tool Plug-in for Eclipse V12.1.0.0. You will be asked if you want to restart

IMS Enterprise Suite Explorer. Click "Yes".

After IMS Enterprise Suite Explorer for Development restarts, read the following sections:

if you installed "DTCN for CICS Plug-in", read "Establishing a connection between the DTCN Profiles view for CICS and your z/OS system"

if you installed "DTSP for non-CICS Plug-in", read "Establishing a connection between the DTSP Profile view for non-CICS and your z/OS
system"
read "Getting Started Using Debug Tool Plug-in for Eclipse V12.1.0.0" for instructions on how to display the "Getting Started" help topic,
which has instructions on how to start debugging your applications.
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Establishing a connection between the DTCN Profiles view for CICS and your z/OS
system



Specify the settings needed to establish a connection between the DTCN profiles view and your z/OS system by doing the following steps:

1. Click Window>Show view>Other.
2. Type "DTCN" in the text box at the top of the window. Select DTCN profiles and click OK.
3. Click Window>Show view>Other.
4. Type "Host Connections" in the text box at the top of the window. Select Host Connections and click OK.
5. In the Host Connections view, select DTCN and click Add to create a connection to DTCN.
6. Specify the settings in the following fields and click Save and Close:

Name
The name of the connection. It is autofilled by combining the host name and port number that you specified with ":".

Host name
The TCP/IP name or address of the z/OS system as described in "Defining the CICS TCPIPSERVICE resource" in the Debug Tool
Customization Guide.

Port number

The port number of the z/OS system as described in "Defining the CICS TCPIPSERVICE resource" in the Debug Tool Customization
Guide.

7. Select the DTCN connection you created, and click Connect.
8. In the DTCN Signon window, specify the settings in the following fields, or select "Use existing Credentials" if you have at least one credential

defined, and click OK.

Credentials Name
The name of the credential. You can leave it blank for default.

User ID
The ID that you use to log on to the CICS system.

Password or Passphrase
The password or passphrase that you use to log on to the CICS system.

The connection is successful when you see a green icon for the DTCN connection. Otherwise, review the information you entered, correct any
mistakes, and try the connection test again. You can also review the trace file (as described in Debug Tool User's Guide's Appendix I section
"Locating the trace file of the DTCN Profiles or DTSP Profile view") for diagnostic information that can help identify a mistake. In the DTCN Profiles
view, you can right click anywhere to see a list of actions available.
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Establishing a connection between the DTSP Profile view for non-CICS and your z/OS
system

Specify the settings needed to establish a connection between the DTSP profile view and your z/OS system by doing the following steps:

1. Click Window>Show view>Other.
2. Type "DTSP" in the text box at the top of the window. Select DTSP profile and click OK.
3. Click Window>Show view>Other.
4. Type "Host Connections" in the text box at the top of the window. Select Host Connections and click OK.

5. In the Host Connections view, select Problem Determination Tools for z/OS and click Add to create a connection to the Problem
Determination Tools for z/OS Common Component Server.

6. Specify the settings in the following fields and click Save and Close:

Name
The name of the connection. It is autofilled by combining the host name and port number that you specified with ":".

Host name

The TCP/IP name or address of the z/OS system, which is set by the system administrator according to the instructions in "Installing the
server components for IBM Debug Tool DTCN and DTSP Profile Manager" in the Debug Tool Customization Guide.

Port number
The port number of the z/OS system, which is set by the system administrator according to the instructions in "Installing the server
components for IBM Debug Tool DTCN and DTSP Profile Manager" in the Debug Tool Customization Guide.

Default Encoding
The default encoding is "cp037". If you use a different encoding scheme, specify it in this field.

7. Click Window>Preferences.
8. Click Debug Tool>DTSP (non-CICS) in the navigation pane.
9. Select the Problem Determination Tools connection you created from the Connection list and click Connect.

10. If this is the first time you're connecting to the IBM Problem Determination Tools Common Server, click Yes in the Certificate Information
window.

11. In the Problem Determination Tools Signon window, specify the settings in the following fields, or select "Use existing Credentials" if you have at

least one credential defined, and click OK.

Credentials Name
The name of the credential. You can leave it blank for default.



User ID
The ID that you use to log on to the z/OS system. The DTSP Profile substitutes this ID for the &userid token in the Profile name pattern

field.
Password or Passphrase

The password or passphrase that you use to log on to the z/OS system.

12. Click OK in the DTSP (non-CICS) preference page.

The connection is successful when you see the message "Connected to IBM PD Tools Common Server successfully." in the DTSP (non-CICS)

preference page. Otherwise, review the information you entered, correct any mistakes, and try the connection test again. You can also review the
trace file (as described in Debug Tool User's Guide's Appendix I section "Locating the trace file of the DTCN Profiles or DTSP Profile view") for
diagnostic information that can help identify a mistake. In the DTSP Profile view, you can right click anywhere to see a list of actions available. If you
need to change your connection settings, you can right click in any area of the view and select Preferences.
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Getting Started Using Debug Tool Plug-in for Eclipse V12.1.0.0

The topic "Getting started" describes the steps you must do to start debugging your applications with the Debug Tool Plug-in for Eclipse V12.1.0.0.
To open that topic:

1. In CICS Explorer or IMS Enterprise Suite Explorer for Development, click "Help" -> "Help Contents".
2. Expand "Debug Tool Plug-in for Eclipse".

3. Click "Getting started with the Debug Tool plug-in for Eclipse".

You can find more information on how to use Debug Tool Plug-in for Eclipse V12.1.0.0 in the help of CICS Explorer or IMS Enterprise Suite

Explorer for Development. Click "Help" -> "Help Contents". Expand the topic "Debug Tool for z/OS client for Eclipse".
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Restrictions and limitations

CICS Explorer displays, by default, the Outline View, but you cannot use this view. You can close the view.
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Technical Support

This plug-in is available at no charge to all licensed users of IBM Debug Tool for z/OS V12, or later. It is supplied under the standard terms and
conditions of the IBM International Program License Agreement (IPLA) and of the associated License Information and other documentation, and

provides a defect correction entitlement for those licensed users entitled to service for IBM Debug Tool for z/OS V12, or later. Service is available for

this plug-in for as long as the IBM Debug Tool for z/OS product with which the plug-in is to be used is generally supported by IBM. In addition, IBM
reserves the right to discontinue service on this plug-in when it is withdrawn from marketing by IBM. Please reference "IBM Debug Tool for z/OS" as

the entitled product when contacting IBM and requesting support for this plug-in.


