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Welcome

IBM® DB2® Data Warehouse Edition, Version 9.1 (DWE) combines the strength of DB2 Universal
Database ' (DB2) with the powerful business intelligence infrastructure from IBM. Data Warehouse
Edition provides a comprehensive business intelligence platform with tools that your enterprise and
partners need to deploy and build next-generation analytic solutions.

DWE Version 9.1 has been refreshed with fixes to defects and is translated into the following languages:
¢ Chinese, Simplified

¢ Chinese, Traditional
¢ English

* French

* German

e Italian

* Japanese

* Korean

* Portuguese, Brazilian
* Spanish

Download the DWE Installation Guide

Before you start the installation of DB2 Data Warehouse Edition, Version 9.1, you must download the
DWE Installation Guide. This book contains important installation instructions that are not available
anywhere else. The book is available in PDF format from this Web site:

http://www.ibm.com/software/data/db2/dwe/features.html

It is also contained in the DB2 and DWE Information Center:
http://publib.boulder.ibm.com/infocenter/db21uw/v8/index.jsp



Getting started with Data Warehouse Edition

The DWE Tutorial

DWE provides a tutorial that shows you how you can use the components of DWE to create an
end-to-end business intelligence solution. This tutorial is an excellent starting point for learning how to
use DWE. It introduces you to the highlights of DWE so that you can get up and running quickly and
easily.

Using the DWE tutorial, you can learn how to build and deploy a BI solution that extends the capabilities
of a DB2 data warehouse. The tutorial is based on a new sample database that describes the operations of
a fictional retail company, JK Superstore.

The DWE Design Studio

The DWE Design Studio provides an infrastructure and a set of integrated tools for developing Business
Intelligence (BI) solutions. You can use these tools to build, populate, and maintain tables and other
structures for data mining and OLAP analysis in the context of a DB2 data warehouse. The Design Studio
is built on the Eclipse workbench, which is a powerful development environment that you can customize.

The Design Studio includes the following tools and features:

+ Integrated physical data modeling, based on Rational® Data Architect
¢ SQL Warehousing Tool for data flow and control flow design

* Data mining, exploration, and visualization tools

* Tools for designing OLAP metadata, MQTs, and cube models

+ Integration points with WebSphere® DataStage® ETL systems

By integrating these tools, the Design Studio offers time to value and managed cost for warehouse-based
analytics. All of the tools you need to support your Bl applications are in one place.

The Design Studio Help System
The Design Studio includes a local help system, a set of sample files with a related tutorial, and an
Eclipse “cheat sheet” that you can work through to get started.

* To use the help system, select Help Contents from the Help menu. Use the navigation tree on the left
side of the help browser or the search facility above the tree to find the information that you need. The
help system contains information about the SQL Warehousing Tool, OLAP, and data mining
components.

* To open the sample projects, select File > New > Example... > Data Warehousing Examples. Select one
of the samples and click Next > Finish. You can use these sample projects to work through the DWE
Tutorial at your own pace.

* To run the cheat sheet, select Cheat Sheets from the Help menu, then select Data Warehousing > Data
Flow Cheatsheet and click OK.

The cheat sheet walks you through the steps of creating a new data design project, a physical data model,
a data warehouse project, and a data flow.

Enhancements to Design Studio

This release enhances the following Rational Data Architect (RDA) functions in the Design Studio:
* Automatic alignment of primary key constraints and indexes:

— When two physical tables are compared with each other, the primary key constraint under one table
is now automatically aligned with the counterpart in the other table, if one is found.



— When two physical tables are compared with each other, an index under one table is now
automatically aligned with the one under the other table if both indexes contain the same set of
column names.

* An empty string attribute value in the data model is treated as equivalent to a null attribute value.

* The compare editor does not show internal property differences. For example, the internal schema
properties such as indexes and triggers are no longer compared for differences.

Known issues

While every attempt is made to ensure the highest quality for DB2 Data Warehouse Edition, the following
known limitations and problems remain. See the Known Issues section of the DWE Installation Guide for
additional limitations that are not documented here.

Globalization

In general, database objects and data (tables, columns, rows, and so on) can use non-English locales. Data
flows and control flows that contain non-English data run successfully in both the Design Studio and the
Administration Console. In the Design Studio, you can use non-English names for objects such as data
flows, control flows, variables, and application profiles.

Note the following limitations in globalization support:

* You cannot log into the DWE Administration Console with a user ID that consists of Chinese
characters. (23880)

* You cannot install DWE to a directory with a non-English path name. This is a known issue in DB2
Universal Database and WebSphere Application Server. (24113)

* Source, execution, and target databases must have the same character encodings; otherwise data flows
might fail with data conversion errors such as error -302. To work around this problem, make sure that
all of the databases that are used during execution have been defined with the same coded character
set identifier (CCSID). (24819)

DWE Integrated Installation Program

* You cannot install DWE to a directory with a non-English path name. This is a known issue in DB2
Universal Database and WebSphere Application Server. (24113)

* When you uninstall DB2 Alphablox, some WebSphere variables may remain configured. The variables
WS_EAR_AlphabloxPlatform and WS_EAR_ApplicationStudio should be removed with the WebSphere
Administration Console before you re-install DB2 Alphablox. Alternatively, you can uninstall and
reinstall WebSphere to remove those entries. (23925)

* When you run the DWE configuration tool on the application server, use the same connection and user
information that you supplied to the installation program when you installed DB2.

* If you install the combined DB2 and DWE Information Center, and then run the installation again, the
installation program will allow you to select the installable image for the DWE documentation, even
though those files are installed. (23717)

« When you install on AIX®, you might see a panel with this error message: "For input string:
"2268987392"". This occurs if you do not have enough disk space in the /tmp or /usr/opt directories
for installing DWE. Make sure your computer meets the installation hardware and software
requirements listed in the DWE Installation Guide. (24066)

 The DWE uninstaller cannot uninstall individual DB2 components on AIX or Linux®: You can remove
either all of the DB2 components or none of them. To remove all of the DB2 components, select DB2
Enterprise Server Edition in addition to all of the components. If you select only one component for
uninstallation, such as DWE Cube Views', Query Patroller, or the DWE Information Center, the
registry entry will be removed but not the component. To remove DB2 products, invoke the script
./db2_deinstall from any DB2 CD. (24097)



* When uninstalling DWE components the feature panel and the summary panel might not match: You
might see differences between the components you select in the feature panel and the components that
are listed in the summary panel. This is a known issue that is seen because some components were
installed incrementally while others were not. For example, you initially installed the DWE Base
Edition; later you installed the DWE Enterprise Edition. If you choose to uninstall DWE, you might see
Enterprise Edition listed in the features panel and Base Edition listed in the summary panel. The
feature panel is correct and as long as the proper components are selected in the features panel, the
uninstall should proceed normally. (24109)

* When you copy the extracted installation files to a different location by using a utility or command
that does not copy "hidden" files by default (such as xcopy), those files will be missing. Starting the
installation from the target location then causes the installation program to fail with a Java " exception.
Make sure that your copy command writes all of the files to the target location before you start the
installation process. (24593)

DWE Configuration Tool

* If you install WebSphere on a 64-bit system, the DB2 instance in which you create the control and
schedule databases for the DWE Administration Console must also be 64-bit. If you configure the
Administration Console with a 32-bit DB2 instance while using WebSphere on a 64-bit system, you see
an error message like this:
java.sql.SQLException: Failure in loading T2 native Tibrary db2jcct2
DSRAGO10E: SQL State = null, Error Code = -99,999
The DWE installation program on Linux creates a 32-bit instance in DB2. If you want to run
WebSphere in a 64-bit system, you must create a 64-bit DB2 instance. Take these steps to start that
process:

1. Stop DB2.

2. Log in as root.

3. Go to /opt/IBM/db2/V8.1/instance and run the command ./db2isetup .
4. Start DB2 as the 64-bit instance.

When you run the DWE Configuration Tool, make sure you point to this 64-bit DB2 instance.(24335)

* You must specify local OS groups for the Administrator, Manager, and Operator roles. The fields are
required. (23863)

* When you specify local OS groups, only specify one group for each role. (23274) If you need more
groups, you can add them using the WebSphere Application Server administration tool.

* While configuring DWE, the SCHD0046E message: "The table SCHED_TREG in datasource
jdbc/dwesched used by scheduler resource ETLScheduler (ETLScheduler) is missing or is not
accessible" is displayed. You can safely ignore this message. (23758)

DWE Design Studio

* After closing the Design Studio, a connection to the DB2 UDB database might remain for the
application javaw.exe; you can see this process in the Windows® Task Manager. When you restart the
Design Studio, you will see a "workspace in use” error. Ending the javaw.exe task in the Task Manager
frees the workspace so that you can restart the Design Studio successfully. This problem occurs when
the Design Studio is closed while a metadata replication process is in progress. To avoid this problem,
always wait until metadata replication has finished before closing the Design Studio. (18984)

* On Windows 2000 Server or Windows 2003 Server, when you view the Welcome page of the Design
Studio in Microsoft® Internet Explorer, the viewlets will not run if the Security Setting level in Internet
Explorer is set to High. The viewlets will run correctly if you set the level to Medium or lower. (24551)

* When you run a data flow from the Design Studio and the target table belongs to a remote database,
the execution log does not contain detailed statistics messages that are returned by the target database.
The run profile summary contains the expected information messages that state whether the data flow
succeeded or failed, but the execution log is empty. (22623)



Connecting to CVS from the Design Studio: In order to use a Windows CVS server to work with
Design Studio projects, you must install CVSNT V2.0.41. The repository paths set in CVSNT must be
identical to the repository paths set in Design Studio. (23976)

Long path names can cause control flows to fail during execution because of operating system limits
on the maximum length of a path. These limits apply to control flows that you run in both the DWE
Design Studio and the DWE Administration Console. The length of a control flow path is influenced
by elements such as the installation path and the activity name. Using long names for any of these
components can cause the maximum path length to be exceeded and the control flow to fail. Use good
judgment when selecting installation paths and names. (24207)

SCM plugin compatibility: You might need to use the Resource perspective (or other perspectives) and
the Navigator view for specialized source control management (SCM) operations; check the
documentation that is provided by the SCM plugin vendor. In some cases, the Bl and Data
perspectives and their views are not completely compatible with SCM plugins. For example, the
different CVS perspectives offer specialized support and views for CVS operations, and it is more
convenient to use those perspectives. In other cases, a manual refresh of the projects in the Data Project
Explorer might be necessary. (24246)

SQL support in subflows: Operators that are defined inside subflows must generate SQL that conforms
to the SQL-92 standard. For example, if a select list operator in a subflow has a reference to a SQL-99
OLAP function, the generated code will be incorrect and the data flow will fail to run. This problem
does not apply to operators that are used directly in data flows. (24438)

Limitations of the SQL replication source operator:
— The Replica and CCD replication types are not supported in this release. (21723)

— A SQL replication source operator must use a replication target database server that is installed on
the same computer as the SQL Warehousing Tool runtime environment. In other words, the SQL
execution database that is used for the data flow must belong to a DB2 instance that is running on
the same computer as either the DWE Administration Console or the DWE Design Studio. If this
configuration is not used, the data flow that contains the SQL replication source operator will fail to
run. (24350)

Visibility of execution plan graph (EPG) files: EPG files are not visible in the Data Project Explorer. To
see these files inside the project tree, switch to the Navigator view. The EPG files are inside the
generated-code folder. (23301)

The Database Explorer does not automatically display newly cataloged DB2 databases without manual
intervention: If the Design Studio is open and you catalog a database in the DB2 system on the client
machine (either a local database or a remote database), you must perform one of the following steps to
display the new database in the Database Explorer:

— Restart the Design Studio.

— Use the Database Explorer to connect to the remote database.

— Use the Database Explorer to connect to the local database.

To connect to the remote database:

1. Right-mouse click in the Database Explorer and click New Connection. The New Connection dialog
is displayed.

2. In the Select a database manager field, select DB2 UDB V8.2.

3. In the Host field, type the remote database server name. Do not specify Tocalhost.

4. Specify any additional fields to complete the New Connection dialog.

To connect to the local database:

1. Right-mouse click in the Database Explorer and click New Connection. The New Connection dialog
is displayed.

2. In the Select a database manager field, select DB2 UDB V8.2.

3. In the JBDC driver field, select Other.

4. Type the connection parameters in the appropriate fields to complete the New Connection dialog.



(24006)

* Delta DDL generation in the compare and sync editor: You might experience problems with DDL
generation after comparing OLAP objects in a physical data model in the Data Project Explorer with a
corresponding set of objects in a database in the Database Explorer. In some cases the script that is
generated to deploy the changes to the database might not execute successfully. If you encounter this
problem, use an alternative procedure to deploy the changed OLAP objects to the database:

1. Drop any objects from the target database that are the same as objects in the physical data model.

2. Export the changed OLAP objects from the physical data model to a file, using the File > Export
option. Select the OLAP Metadata option in the first page of the Export wizard.

3. Import the OLAP objects from the file into the target database, using the File > Import option.
Select the OLAP Metadata option in the first page of the Import wizard.

(00499, 00500, 00523)

* When you are working with a physical data model in the Data Project Explorer and you try to replace
a table with an alias on the same table, you cannot select the columns to create the attributes. To solve
this problem, you can create the alias in the database and reverse engineer the alias. (00525)

* Mining flow execution aborts with an "abnormally terminated" error message: In certain cases, the
execution of a correctly defined mining flow can fail with an "abnormally terminated” error message
issued by DB2. Before this message is displayed, execution of the flow typically hangs for a few
minutes. This problem can happen if two or more Intelligent Miner  user-defined functions (UDFs) are
called during processing of one and the same SQL statement. For example, when you have three
quality extractor operators and connect the three output ports with the input ports of the same table
join operator, the resulting SQL statement calls three DM_getQualities() functions and might fail
(function calls contained in SQL views that are referenced by an SQL statement also count). Combining
the outputs of several extractor operators through a union or table join operator is a typical scenario
where you might see this problem, but it can also occur with other mining operators. As a
workaround, append a data station operator to the output port of each mining operator that produces
such an Intelligent Miner UDF (for example, append the data station operator to those extractor
operators that cause the problem). Select TEMPORARY_TABLE as the station type for the data station
operator, but do not check the Pass through option. In this way, the data is buffered and each of the
resulting SQL statements calls only one Intelligent Miner UDEF. (24594)

* A regression model that uses classification as a function cannot be used or opened in the Design
Studio. This kind of model is never created by Intelligent Miner. This problem only occurs with models
that are imported from other data mining vendors.

* When you select Import Database Metadata from the Databases folder of a data warehouse project,
the wizard does not select the parent project by default. You have to select the parent project in the
Destination Project field. The destination project that is selected by default is the first project in the
workspace. (24735)

* The Deploy job metadata to server operation from the DataStage Servers view fails if you try to
import an XML file from a directory location that has spaces in its path. To work around this problem,
move the XML file that you need to import to a location that does not have spaces. (24700)

¢ In the Analyze Model panel, the description text in the text area at the bottom of the panel is not
displayed in the non-English versions of the product. An error message is displayed instead.
(dwe00000587)

DWE Administration Console

* Overwrite and archiving options for process logs: New entries are appended to process log files,
regardless of the logging properties you set. If you set the Log and Trace Reuse option to Overwrite,
the setting does not take effect until you restart the WebSphere Application Server. This problem occurs
because the lock on the main process log file is not released until the server is restarted. Also, if you
archive a process log and then re-run an instance that uses the same log file name, the log might be



empty. To fix these problems, clean up the log directory regularly by removing the .Ick files and the
html.n files. You can also change the log prefix before running new process instances to ensure that a
new log is created. (22718, 23945, 24587)

Console pages return error 500: Console pages sometimes return a null pointer exception (error 500).
After this error occurs once, it tends to recur on other pages that you access. To solve the problem,
restart WebSphere Application Server. (23886)

Error messages about DB2 starting: When you access pages in the DWE Administration Console while
DB2 is not started, you get an error stating that DB2 is not started; this is normal behavior. When you

access pages a second time with DB2 not started, the error message does not display, although it
should.

Application names must not contain forward slash and backslash characters: During deployment, the
name that you enter for a data warehouse application must not contain either backslashes (\) or
forward slashes (/). These characters are interpreted as directory separators and cause the deployment
process to fail. The error message that is currently returned in this case is misleading. (23685)

Long path names can cause control flows to fail during execution because of operating system limits
on the maximum length of a path. These limits apply to control flows that you run in both the DWE
Design Studio and the DWE Administration Console. The length of a control flow path is influenced
by elements such as the installation path, the control flow name, and the activity name. Using long
names for any of these components can cause the maximum path length to be exceeded and the
control flow to fail. Use good judgment when selecting installation paths and names. (24207)

Remote DB2 control data sources (databases that are not local to the DB2 instance on the application
server) must be catalogued in the local DB2 server or administration client. Otherwise, you will not be
able to use the Administration Console to run processes that require DB2 command-line access to those
source and target databases. The DB2 command line is used frequently to run SQL scripts that contain
LOAD and EXPORT statements, for example. Therefore, almost all application processes require remote
databases to be directly accessible from the local catalog. (22677)

After successfully configuring WebSphere Application Server for the DWE Administration Console, if
you change your password in the local OS for either the WebSphere administration user or the user
that is used to authenticate to the databases, you also need to change your password in WebSphere.

If global security is enabled, take the following steps to changes the WebSphere administration user
password:

1. Login to the WebSphere administration console.
Click Global Security.

Under User registries, click Local OS.

Update Server user password and click Apply.
Save the WebSphere configuration.

o oA~ N

In the WebSphere installation Tocation/profiles/default/properties/soap.client.props file, modify
the password at this line: com. ibm.SOAP.loginPassword.

Regardless of whether global security is enabled, take the following steps to change the J2C
Authentication alias used by the data sources:

1. Login to the WebSphere administration console.

2. Click Global Security.

3. Under Authentication, click JAAS Configuration’, then click J2C Authentication Data.
4

. If there are multiple entries, choose the entry for the DWE Administration Console. For example, if
your you WAS hostname is myhost then click on the entry named myhostNode01Cel1/
etTAuthentication_myhostNodeOl_serverl.

5. Update your password and click Apply.

o

Save the WebSphere configuration.
7. Stop and start WebSphere.



Change the administrative account password on the DB2 server. For example, on Windows, you can
change the services startup login password by taking these steps.

1. Click Start > Settings > Control Panel > Services.

2. For each of the following services, click the name of the service in the list, display the right mouse
menu, click Properties > Log On, and then specify the new password:

— DB2 - DB2-0
— DB2 Remote Command Server
— DB2DAS - DB2DAS00

(24470)

Single quotes in application descriptions and comments: When you deploy a data warehouse
application or modify its properties, you can view and update the Description and Comment fields for
the application. If the text in either of these fields contains single quotes ("), you might encounter SQL
errors when you run processes that belong to the application. To avoid these errors, either remove the
single quotes or use two single quotes instead. (24442)

Console must be started after the DB2 instance that contains the runtime control database: If you start
WebSphere Application Server and the Administration Console before you start the DB2 instance that
contains the runtime control database (SQWCTRL), you cannot run data warehouse application
processes. After starting DB2, restart the application server and console in order to manage and run
your applications. (24447)

Unsuccessful test connections for remote databases: Database connections that are required for data
warehouse applications can be made either through the WebSphere Application Server connection pool
or directly using a DB2 client. To connect to a remote database via the DB2 client, you must specify the
authorization (user ID and password) to access that database when you define the data source in the
console (Create or Manage Data Sources page). Remote databases that do not have this authorization
defined return an error message when you use the Test Connection feature. You can ignore this
message if the direct connection is not needed and you intend to access your remote databases
exclusively through the WebSphere connection pool. (24423)

DBCS characters not correctly displayed on the Manage Mining Models panel when importing a
mining model: Here is a possible scenario:

1. Expand the DWE Mining folder on the DWE Administration Console navigation panel and click
Model Management.

2. Import a new model with Japanese model name and description. The model is imported but the
Japanese characters are not displayed correctly on the Manage Mining Models panel.

To correct the problem, import the model from the Design Studio. Connect the Administration Console
to the same database that contains the imported model. The DBCS should display correctly on the
Manage Mining Models panel. (24336)

Users who access the console from a web client can use multiple top-level browser windows (launched
either from Program Files or from a desktop or quick launch icon) to administer the warehouse.
However, the use of child windows within a top-level window (created by selecting File -> New ->
Window from within an existing browser window) is not supported; the child windows share the
session with the parent window and each other, which can cause inconsistent behavior. (24504)

Depending on your browser security settings, you might be prompted to trust an unsigned Java applet
when you use the mining model view in the DWE Administration Console. (22114)

A process instance name can only be reused after it has been permanently deleted. Removing an
instance from a single page view does not necessarily delete the instance. Deleting the same instance
from both the monitoring page and the statistics page with Retain Instance Statistics set to No in the
application properties page permanently deletes the instance. (24589)

Data warehouse applications cannot be deployed to the Administration Console if the names of data
flows and other objects that are part of the deployment package equal or exceed the following limits
(number of characters). These limits are imposed by the column lengths that are predefined for tables
in the control database; therefore, the limits apply only when applications are deployed.



— Application: 128

— Control flow: 220

— Activity: 220

— Data flow: 128

— Resource reference: 64 (database or machine resource name, as defined in a resource profile)
— Variable ID: 128

— EPG: 255 (the relative location of the EPG file)

— EPGname: 192 (a subset of the EPG)

(24765)

DWE Documentation

* Using the DWE uninstaller to uninstall the DB2 and DWE Information Center: If you select only the
Information Center for uninstall, the uninstall program will complete successfully. However, the
component is not physically removed from your system, just the registry entry is. To remove the
Information Center, invoke the script ./db2_deinstall from any DB2 CD. (24097)

DWE Intelligent Miner

* On AIX, if you are running DWE Intelligent Miner on a 64-bit DB2 UDB instance with AIX ServicePack
5300-04-01, you might see error message SQL0444N when your user-defined functions (UDFs) are
processed. In some situations, the service pack prevents DB2 UDB from loading Intelligent Miner
shared libraries. For example, you might see an error if you run the following command:

db2 "values IDMMX.DM_MiningData()..DM_defMiningData('0OK')..DM_getTableName()"

The error message looks like this:

SQLO444N Routine "xABLENAME" (specific name "SQLO51005183118801") is implemented with code in
Tibrary or path "...q1lib/function/idmx", function "udf _getTableName" which cannot be accessed.
Reason code: "9". SQLSTATE=42724

You can check whether the AIX ServicePack 5300-04-01 is installed on your system by running the
following commands:

oslevel -r
oslevel -s

If the command oslevel -r displays 5300-04 and the command oslevel -s displays 5300-04-01, then
ServicePack 5300-04-01 is installed.

The solution is to install APAR IY83580, which is available here:
http://www-1.ibm.com/support/docview.wss?uid=1sg11Y83580

Documentation Updates

The following information is provided as a supplement to the current DWE documentation. This
information will be integrated into the Information Center in a future release.

DWE Tutorial

Before starting the tutorial, note the following updates:

* When you are creating a physical model, reverse engineer the model from the database (the default
choice). Do not select DDL script. This step is missing from Module 1, Lesson 2 and the "Optional:
Start the tutorial here" lessons at the beginning of Modules 2 and 4.

* If you complete Module 3 as documented, when you deploy and run the process that loads the
DWH.ITM_TXN table, the process executes successfully but the table contains no rows. This behavior
is expected. However, if you proceed with the remaining modules sequentially, Module 6 (data mining)
will fail. To work around this problem, reload the DWH.ITM_TXN table before starting Module 6:



1. Create a file named loaddwhtxn.sql in the \samples\data directory (inside your DWE installation
directory).

2. Copy and paste the following SQL commands into the file:

LOAD FROM 'DWH_ITM TXN.txt' OF DEL METHOD P (1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13)
MESSAGES 'LoadDWH_ITM TXN.txt' REPLACE INTO DWH.ITM_TXN

(MKT_BSKT TXN_ID, PD_ID, ITM TXN_TMS, ITM TXN_TP_ID, ITM_TXN_SCAN_TP_ID, NBR_ITM,
ITM_STM_PRC, ITM_TXN_AMT, VAL DIF RSN_TP_ID, LCL_TAX_AMT, NAT TAX_AMT, POS_ID,
SRC_STM_ID) COPY NO INDEXING MODE AUTOSELECT;

COMMIT;

SET INTEGRITY FOR DWH.ITM_TXN IMMEDIATE CHECKED FULL ACCESS;

3. Open a DB2 command window, go to the \samples\data directory, and run the following
commands:
a. db2 connect to dwesamp
b. db2 -tvf lToaddwhtxn.sql

Support for Type 2 and Type 4 JDBC drivers

The default driver for DB2 connections that do not use WebSphere Application Server connection pooling
is the Type 2 driver. Therefore, when you create a new data source in the DWE Common > Database
Profile page of the DWE Administration Console, the Type 2 driver is used. However, existing
WebSphere data sources with Type 4 providers are still supported: any existing data source that can be
selected for attachment in the console is valid, but you must have created these data sources in the
WebSphere Application Server Administration Console, not the DWE Administration Console. Note the
following options and restrictions:

* You can create a new data source with a Type 2 or Type 4 provider as needed in the WebSphere
Application Server Administration Console.

* You can create a new data source with a Type 2 provider in the DWE Administration Console.

¢ For any JDBC connection, you can use a WebSphere data source, whether it has a Type 2 or Type 4
provider.

* For any JDBC connection that depends on DB2 command-line access (db2cmd), which is the case for
most SQL-based data flows, the database must be catalogued with the DB2 Client, whether the data
source has a Type 2 or Type 4 provider.
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