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IBM WebSphere Multichannel Bank Transformation Toolkit
installation guide

This installation guide describes the hardware and software requirements of IBM®

WebSphere® Multichannel Bank Transformation Toolkit and how to install it into
IBM Rational® Application Developer or IBM WebSphere Integration Developer so
that you can develop applications. This document is for anyone who is installing
IBM WebSphere Multichannel Bank Transformation Toolkit.

IBM WebSphere Multichannel Bank Transformation Toolkit in Version 6.1.1
supports 64-bit AIX® runtime environment. For other platforms, it supports 32-bit
runtime and development environments.

Note: IBM Branch Transformation Toolkit for WebSphere Studio has been renamed
to IBM WebSphere Multichannel Bank Transformation Toolkit in Version
6.1.1.

Typographic conventions
The installation guide uses the following typographic conventions:

Convention Description of convention

Bold Used to indicate something you select or
click in the GUI

Italics Used for emphasis or to refer to another
document

Monospace font Used to indicate text that you type yourself
or screen messages

< > Used to enclose descriptions of variables
that you must type yourself or names of
tags within XML files as shown in the
following examples:

v <variable name>

v <tag name>

Keys are identified in this guide just as they appear on the keyboard (for example,
Enter, Tab, Ctrl).

Hardware and software requirements
This section lists the hardware and software requirements for the runtime and
development environments of IBM WebSphere Multichannel Bank Transformation
Toolkit version 6.1.1.

Hardware requirements
Hardware requirements for Server
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Note: These memory and disk requirements listed below are for the IBM
WebSphere Application Server.

For Microsoft® Windows® XP, Server 2003/2008, Vista
v Intel® Pentium® processor at 500MHz or faster
v Intel EM64T or AMD Opteron.
v Minimum 512 MB physical memory; 1 GB recommended Minimum 2GB RAM
v Minimum 1 GB of free disk space for installation (includes SDK)

For Linux® x86
v Intel® Pentium® processor at 500 MHz or faster
v Intel EM64T or AMD Opteron
v Minimum 512 MB of physical memory; 1 GB recommended
v Minimum 1 GB of free disk space for installation (includes SDK)

For IBM AIX (32 bit WebSphere Application Server)
v IBM POWER™ family of processors
v Minimum 512 MB physical memory; 1 GB recommended
v Minimum 1 GB of free disk space for installation

For IBM AIX (64 bit WebSphere Application Server)
v IBM POWER family of processors
v Minimum 1 GB physical memory recommended
v Minimum 1 GB of free disk space for installation

For Solaris SPARC
v Sun Solaris operating environment compatible SPARC workstation at 440MHz,

or faster
v Minimum 512 MB physical memory; 1 GB recommended
v Minimum 1 GB of free disk space for installation

For additional software products, for example DB2® or IBM Communications
Server, refer to the respective product documentation.

Hardware requirements for Client

v x86 processors capable of supporting the supported operating systems
v 512 MB RAM
v 500 MB free disk space
v Display Resolution: Super video graphics array/adapter (SVGA) 1024 x 768

display
v High Contrast Mode: 1152 x 768 display, only default font settings (10pt Sans)

Hardware requirements for development environment

Note: These memory and disk requirements listed below are for the IBM Rational
Application Developer.

v Intel® Pentium® III processor at 800 MHz, or higher recommended
v Display, minimum requirements: 1024 x 768
v 1 GB RAM minimum, 2 GB RAM
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v Disk space requirements: 3.7 GB minimum for installing Rational Application
Developer and additional disk space for development resources (minimum disk
space can be reduced if optional features and run times are not installed).

If the development environment requires additional software products, for example
DB2 or IBM Communications Server, refer to the specific product documentation.

For the latest hardware requirements, refer to the documentation at
http://www.ibm.com/software/.

Software requirements
Supported Platform

v Server
– Red Hat Enterprise Linux ES/AS 4.0 Update 7 (English, 32 bit)
– Red Hat Enterprise Linux, Version 5 (English, 32 bit)
– Microsoft Windows Server 2003, Enterprise & Standard with SP1(32-bit)
– Microsoft Windows Server 2008, Enterprise & Standard (32-bit)
– AIX 5L™ 5.3 with Service Pack 5300-04-01 (32 and 64 bit kernel support)
– AIX 6.1 with Recommended Maintenance package 6100-00-01-0748 (32 and 64

bit)
– Sun Solaris operating environment, Version 10 with the latest Patch Cluster

(32 bit kernel support)
v Client and development

– Windows XP Professional + SP2 (Simple Chinese)
– Windows Vista business + SP1 (English)
– Red Hat Enterprise Linux WS 4.0 Update 3 (English)

v Installer
– Windows XP Professional + SP2 (Simple Chinese)
– Windows Vista business + SP1 (English)
– Red Hat Enterprise Linux WS 4.0 Update 3 (English)

Supported database

v IBM DB2 UDB Enterprise Server Edition V8.2.7
v IBM DB2 UDB Enterprise Server Edition V9 FP3
v IBM DB2 UDB Enterprise Server Edition V9.5
v Oracle 10g Standard/Enterprise Release 2 - 10.2.0.2
v Oracle 11g Standard/Enterprise Release 1 - 11.1.0.6
v Microsoft SQL Server Enterprise 2000 SP4
v Microsoft SQL Server Enterprise 2005

Supported development environment

v IBM WebSphere Application Server V6.1.0.17
v IBM Rational Application Developer V7.0.0.7
v IBM WebSphere Integration Developer 6.1.2

Supported browsers

v Internet Explorer 6.0 SP2 or above
v Firefox 2.0 or above
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Supported JDK

v Server
– IBM 32-bit SDK Java™ 2 Technology Edition, V5.0 SR2
– IBM 64-bit SDK for AIX, Java 2 Technology Edition, V5.0 SR2

v Client and development.
– IBM 32-bit SDK, Java 2 Technology Edition, V5.0 SR2

Optional software

v Lotus® Expeditor V6.1.2 - Client for Desktop, Windows
v Lotus Expeditor V6.1.2 - Client for Desktop, Linux on x86
v IBM WebSphere MQ for Windows, V6.0.2.3
v IBM WebSphere MQ for Linux on x86, V6.0.2.3
v IBM WebSphere MQ for AIX, V6.0.2.3
v IBM WebSphere MQ for Solaris SPARC, V6.0.2.3
v IBM Communications Server for Linux, Version 6.2.3
v IBM Communications Server for Windows, Version 6.1.2.3
v IBM Communications Server for AIX, Version 6.3.1
v IBM Tivoli® Directory Server for AIX, V6.1.1.1
v IBM Tivoli Directory Server for Windows, V6.1.1.1
v IBM Tivoli Directory Server for Linux, V6.1.1.1
v IBM Tivoli Directory Server for Solaris, V6.1.1.1
v IBM WebSphere Portal Server for AIX, V6.1.0
v IBM WebSphere Portal Server for Windows, V6.1.0
v IBM WebSphere Portal Server for Linux, V6.1.0
v IBM WebSphere Portal Server for Solaris, V6.1.0

For the latest supported software, See http://www.ibm.com/software/components
.

Additional requirements
Depending on the framework services you use, you may require other hardware
and software to support financial devices. The following additional requirements
apply to the type of workstation (client, server, or development) that accesses the
financial device.

Table 1. Additional financial devices requirements

Framework component Additional requirements

J/eXtensions for Financial Services Any financial printer, magnetic stripe
reader/encoder, or check reader with a
device service that is compliant with the
J/XFS specification
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Setting up a Bank Transformation Toolkit development environment

In this procedure, you will set up a development workstation so that you can
develop applications based on the IBM WebSphere Multichannel Bank
Transformation Toolkit version 6.1.1. Note that the physical machine must comply
with the requirements listed in the Hardware and software requirements section,
including having IBM WebSphere Integration Developer or IBM Rational
Application Developer.

Note: The following procedure describes how to install Bank Transformation
Toolkit on top of IBM Rational Application Developer or IBM WebSphere
Integration Developer. Each functional unit is contained in its own JAR file
to provide greater flexibility both in the development environment and in
runtime. Consider reviewing functional units, packages, and dependencies
to decide which functional units you need to develop your application.
Note, however, that you can add or remove functional units at any time
provided you account for their corequisite functional units (functional units
that must also exist on the system at the same time).

Installation package structure
The Bank Transformation Toolkit installation package mainly contains two groups
of components - components for the development environment and components
for the runtime environment.

Development environment

For the development environment, Bank Transformation Toolkit supports IBM
Rational Application Developer 7.0.0.7 and IBM WebSphere Integration Developer
6.1.2.

For the development environment, there is a set of plug-ins:
v Plug-ins for IBM Rational Application Developer 7.0.0.7 and IBM WebSphere

Integration Developer 6.1.2

The plug-ins include components that have dependencies on features provided
by IBM Rational Application Developer 7.0.0.7 and IBM WebSphere Integration
Developer 6.1.2

If you have IBM WebSphere Integration Developer 6.1.2 installed on your system,
the toolkit installation wizard will take IBM WebSphere Integration Developer as
your development environment, regardless of whether you have IBM Rational
Application Developer installed. After the installation wizard decides that IBM
WebSphere Integration Developer is your development environment, it copies the
plug-ins for IBM WebSphere Integration Developer to the plugins directory of your
IBM WebSphere Integration Developer automatically during the installation.

If you have IBM Rational Application Developer 7.0.0.7 installed on your system,
the toolkit installation wizard will take IBM Rational Application Developer as
your development environment. After the installation wizard decides that IBM
Rational Application Developer is your development environment, it copies the
plug-ins for IBM Rational Application Developer 7.0.0.7 to the /plugins directory
of your IBM Rational Application Developer 7.0.0.7 automatically during the
installation.

If neither IBM Rational Application Developer 7.0.0.7 nor IBM WebSphere
Integration Developer 6.1.2 is installed on your system, you will need to copy the
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plug-ins to the $D(RAD)/plugins or $D(WID)/plugins directory manually after you
have IBM Rational Application Developer or IBM WebSphere Integration
Developer installed later. Plug-ins for IBM Rational Application Developer or IBM
WebSphere Integration Developer can be found in the <tooklit_root>/plugins
directory.

Runtime environment

For the runtime environment, Bank Transformation Toolkit supports WebSphere
Application Server 6.1.0.17.

Installing the Bank Transformation Toolkit on a development
workstation

To set up the development workstation, do the following:
1. According to your business needs, install IBM Rational Application Developer

or IBM WebSphere Integration Developer.
2. Insert the Bank Transformation Toolkit CD into CD-ROM and browse the CD.

If you want to install Bank Transformation Toolkit for windows, locate and
double-click the setupwin32.exe in the Windows platform. If you want to
install Bank Transformation Toolkit for Linux, locate and invoke
setupLinux.bin in the Linux platform. This starts the Installation Wizard for
Bank Transformation Toolkit. The Introduction window opens.

3. Click Next, and the product license agreement window opens. Check the I
accept the terms in the license agreement checkbox and click Next.

4. The Installation Wizard detects if any version of Bank Transformation Toolkit
is already installed on your system. Bank Transformation Toolkit version 6.1.1
can coexist with Branch Transformation Toolkit version 4.3, 5.0, 5.1 or 5.2.
However Bank Transformation Toolkit version 6.1.1 cannot coexist with
Branch Transformation Toolkit version 5.2.0.1 and 5.2.0.2, Bank Transformation
Toolkit version 6.1.0. It is recommended to uninstall Branch Transformation
Toolkit version 5.2.0.1, Branch Transformation Toolkit 5.2.0.2 and Bank
Transformation Toolkit version 6.1.0 before installing Bank Transformation
Toolkit version 6.1.1. If you already have version 6.1.1 installed, the
Installation Wizard will display a warning message showing that you already
have version 6.1.1 installed. If you continue with the installation, your
previous installation of version 6.1.1 will be overridden.

5. The Installation Wizard also checks the IBM Rational Application Developer
you installed. If you have installed IBM Rational Application Developer, the
Install Wizard will install toolkit components designed for IBM Rational
Application Developer and those for WebSphere Application Server. If you
have IBM WebSphere Integration Developer installed, the Installation Wizard
will install toolkit components designed for IBM WebSphere Integration
Developer, and those for WebSphere Application Server.

6. You are prompted to choose if you want to install 32-bit or 64-bit BTT. If you
want to run BTT in 64-bit AIX runtime environment, select Bank
Transformation Toolkit 6.1.1.0 64-bit and click Next. Otherwise, select Bank
Transformation Toolkit 6.1.1.0 32-bit and click Next.

7. You are prompted to choose the destination directory for the installation files.
If you want to choose a location other than the default location
(C:\IBM\WebSphere\Multichannel Bank Transformation Toolkit 6.1.1.0 for
Windows, and /opt/IBM/WebSphere/Multichannel Bank Transformation
Toolkit 6.1.1.0 for Linux), click Browse, and select that folder you want to use.
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8. Click Next, and the Pre-Installation Summary window opens. It displays the
product name, install folder and the disk space that the installation takes.
Click Install.

9. The Bank Transformation Toolkit installation program creates the following set
of directories on the target machine.

Table 2. Directories created by installation

Directory name Description of contents

doc Product documentation

javadoc Product Java documentation

jre Install Anywhere bundled JVM

lib Product runtime libraries

license Product license files

plugins v Visual beans plug-in

v Transaction Editor plug-in

v APAR tool plug-in

v Migration tool plug-in

v Validation Tool plug-in

v Formatter Simulator plug-in

v Application Wizard plug-in

v XUI Editor plug-in

samples Product samples

template Template for Foreign Exchange

Uninstall Product uninstallation files

10. Start IBM Rational Application Developer or IBM WebSphere Integration
Developer.

11. Set some preferences before you import Bank Transformation Toolkit Java
source:
v To work with complex projects, you should use the source folders as source

containers instead of creating packages directly inside the project. To do
this, you create source folders as children of the project and create your
packages inside these source folders. To automate this, go to Window →
Preferences. Expand the Java node and select the New Project node. Enable
the Folders check box.

v To develop with the Bank Transformation Toolkit, add the framework
functional units (the JAR files containing the classes) to the application
classpath. You can use any approach to do this but you must account for
the class loader policies.
A recommended approach is to add an overall classpath variable named
BTT to point to the root directory of the Bank Transformation Toolkit
installation. To do this:
a. Go to Window → Preferences.
b. Expand the Java node and select Build Path.
c. Expand the Build Path node and select Classpath Variables.
d. Click New and in the Name entry field, type the following:

BTT

e. In the Path entry field, type the path to where the Bank Transformation
Toolkit was installed.
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f. Click OK.
In the same way, add another classpath variable named, for example,
BTT_EXTERNAL to point to the external dependencies. To make the
external classpath variable work, all the required external JARs must be in
the directory to which this variable points. The overall classpath variables
make it easier for you to select the Bank Transformation Toolkit JAR files for
your Java project.
Another approach is to define a classpath variable for each functional unit
available in the product. Each classpath variable points to the concrete JAR
associated with the functional unit (see the tables in Functional units,
packages, and dependencies).
The remainder of this procedure and all the other procedures assume that
you are using the recommended approach.

12. Create a Java project for application. To create the project:
a. Select File → New → Project.
b. Select Java in the left panel and then select Java Project in the right panel.

Click Next.
c. Type the name of the project, such as HomeBanking, and click Finish.

13. When deploying an application, you must embed Bank Transformation Toolkit
functional units, along with the required application resources, inside the J2EE
EAR file. The Bank Transformation Toolkit uses functional units to provide a
coherent structure of JAR files that you use to build an application. The JARs
in the functional units contain the required set of classes for a given execution
environment.
To make the functional units available to your project, you can either add the
compiled JARs to the project’s classpath or you can import the JARs into the
workspace. You can choose the second option if you want to embed the JARs
and resources into your application when, for example, it is self-contained and
independently deployed.
For either option, you only add or import the JARs and their corequisites
needed for the application to optimize the deployment and distribution of the
application. Consult Functional units, packages, and dependencies to obtain
these corequisites.

Once you have installed the Bank Transformation Toolkit in IBM Rational
Application Developer or IBM WebSphere Integration Developer, you can start
developing Bank Transformation Toolkit-based solutions.

Setting up the Validation Tool

The Validation Tool for the Bank Transformation Toolkit is a plug-in. Validation
Tool allows you to validate your definition files with a graphical interface.

Prerequisites to use the Validation Tool:
v If you had installed the toolkit before you installed the IBM Rational Application

Developer or IBM WebSphere Integration Developer, you need to copy the
following plug-in files to the $D(RAD)/plugins or $D(WID)/plugins directory
manually after you have IBM Rational Application Developer or IBM WebSphere
Integration Developer installed later:
– com.ibm.btt.tools.validation_6.1.1

To use the Validation Tool, follow these steps:
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1. Start IBM Rational Application Developer or IBM WebSphere Integration
Developer.

2. Create a simple project.
3. Create a folder to contain the XML files, and copy your XML files to this folder.
4. Click Window → Preferences....
5. In the dialog box that pops up, select BTT Validator in the left panel.
6. In the right panel, the XSD Path and the SCH Path are set automatically. In the

Server Path field, click Browse, and select the folder which contains your XML
file.

7. Click OK.
8. In the Project Explorer view, right-click the XML file, and select Validate.
9. The error will be shown in the editor if there are any.

Setting up the Transaction Editor

The Transaction Editor for the Bank Transformation Toolkit is a plug-in.
Transaction Editor facilitates the XML based end-to-end programming model.

Prerequisites to use the Transaction Editor:
v If you had installed the toolkit before you installed the IBM Rational Application

Developer or IBM WebSphere Integration Developer, you need to copy the
following plug-in files to the $D(RAD)/plugins or $D(WID)/plugins directory
manually after you have IBM Rational Application Developer or IBM WebSphere
Integration Developer installed later:
– com.ibm.btt.tools.transaction.editor_6.1.1
– com.ibm.btt.tools.validation_6.1.1

To use the Transaction Editor, follow these steps:
1. Start IBM Rational Application Developer or IBM WebSphere Integration

Developer.
2. Create a simple project.
3. Create a folder to contain the XML files, and copy your XML files to this folder.
4. Click Window → Show View → Other..., and expand General, and then select

Project Explorer.
5. Right-click the XML file, and select Enable BTTModel.
6. The elements of the XML file will be shown in a hierarchy tree.

Setting up the SWT Visual Beans Editor

The SWT Visual Beans Editor for the Bank Transformation Toolkit is a plug-in. The
SWT Visual Beans Tool helps you develop SWT based transaction panels

Prerequisites to use the SWT Visual Beans Editor:
v If you had installed the toolkit before you installed the IBM Rational Application

Developer or IBM WebSphere Integration Developer, you need to copy the
following plug-in files to the $D(RAD)/plugins or $D(WID)/plugins directory
manually after you have IBM Rational Application Developer or IBM WebSphere
Integration Developer installed later:
– com.ibm.btt.rcp.visualbean_6.1.1
– com.ibm.btt.rcp.visualbean.runtime_6.1.1
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To use the SWT Visual Beans Editor, follow these steps:
1. Start IBM Rational Application Developer or IBM WebSphere Integration

Developer.
2. Create a Java project.
3. Add SWT Visual Bean and Standard Widget Toolkit (SWT) library to the build

path.
a. Right-click project and select Properties.
b. Select Java Build Path, and select Libraries tab, and then click Add Library.
c. Select SWT VisualBean, and click Next.
d. Click Finish in the dialog that pops up.
e. Add Standard Widget Toolkit(SWT) library to the build path in the same

way.
4. Create a visual class.

a. Right-click the project, and select New → Visual Class.
b. In the dialog box that pops up, provide a name in the Name field, and

expand SWT in the Style box, and then select Shell. Check the public static
void main(String[] args) and Inherited abstract methods checkboxes.

c. Click Finish. The visual class loads.

Setting up the Runtime Monitor Tool

The Runtime Monitor Tool for Bank Transformation Toolkit allows you to monitor
the status of BTT in the server side.

To use the Runtime Monitor Tool, you need to import it first. Follow these steps:
1. Start IBM Rational Application Developer or IBM WebSphere Integration

Developer.
2. From the File menu, select File → Import.
3. In the dialog box that pops up, expand Web, and select WAR file.
4. In the EAR Membership field, check the Add project to an EAR checkbox, and

then in the EAR Project Name field, select your EAR project. Click Next.
5. In the WAR file field, click Browse to select the BTTRuntimeMonitor.war file.
6. In the Web project field, the name is automatically generated:

BTTRuntimeMonitor.
7. The Target runtime is set to WebSphere Application Server v6.1 by default.
8. Click Finish.
9. Open your browser, and input the following URL: http://<host

name>:<port>/BTTRuntimeMonitor.

Then you can use the Runtime Monitor Tool.

Setting up the APAR Tool
The APAR Tool for the Bank Transformation Toolkit is a plug-in. The APAR Tool
allows you to trace the your fix changes.

Prerequisites to use the APAR Tool:
v If you had installed the toolkit before you installed the IBM Rational Application

Developer or IBM WebSphere Integration Developer, you need to copy the

10 IBM WebSphere Multichannel Bank Transformation Toolkit: Installation guide



following plug-in files to the $D(RAD)/plugins or $D(WID)/plugins directory
manually after you have IBM Rational Application Developer or IBM WebSphere
Integration Developer installed later:
– com.ibm.btt.tools.apar_6.1.1

To use the APAR Tool, follow these steps:
1. Start IBM Rational Application Developer or IBM WebSphere Integration

Developer.
2. Click Window → Show View, expand Bank Transformation Toolkit, and then

select APAR Tool View.
3. The APAR tool will be launched.

Setting up the formatter simulator

The formatter simulator for the Bank Transformation Toolkit is a plug-in. It
simulates how a string is parsed into a specific data item.

Prerequisites to use the formatter simulator:
v If you had installed the toolkit before you installed the IBM Rational Application

Developer or IBM WebSphere Integration Developer, you need to copy the
following plug-in files to the $D(RAD)/plugins or $D(WID)/plugins directory
manually after you have IBM Rational Application Developer or IBM WebSphere
Integration Developer installed later:
– com.ibm.btt.core_6.1.1
– com.ibm.btt.tools.fs.core_6.1.1.jar
– com.ibm.btt.tools.fs.ui_6.1.1.jar

To use the Validation Tool, follow these steps:
1. Start IBM Rational Application Developer or IBM WebSphere Integration

Developer.
2. Click Window → Show View, expand Bank Transformation Toolkit, and then

select Simulator.
3. The formatter simulator will be launched.

Setting up the Application Wizard

The Application Wizard for the Bank Transformation Toolkit is a plugin. It
provides a quick way to create BTT applications.

Before you use the Application Wizard:
v If you have installed the toolkit before you install the IBM Rational Application

Developer or IBM WebSphere Integration Developer, you should copy the
following plugin files to the $D(RAD)/plugins or $D(WID)/plugins directory
manually after you have IBM Rational Application Developer or IBM WebSphere
Integration Developer installed later:
– com.ibm.btt.core_6.1.1
– com.ibm.btt.tools.aw_6.1.1.jar

Perform the following steps to use the Application Wizard:
1. Start IBM Rational Application Developer or IBM WebSphere Integration

Developer.
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2. Click File → New → Project, and expand WebSphere Multichannel Bank
Transformation Toolkit.

3. Select BTT Business Application Project or BTT Channel Application Project.
The application wizard is launched.

You can also create BTT sample with the Application Wizard by performing the
following steps:
1. Start IBM Rational Application Developer or IBM WebSphere Integration

Developer.
2. Click File → New → Example, and expand BTT Samples.
3. Select BTT Sample or BTT Multichannel Sample. The BTT Sample is

launched.

Setting up the XUI Editor

The XML UI (XUI) Editor for the Bank Transformation Toolkit is a plugin. It is a
WYSWYG tool that creates BTT XML based transaction UI files.

Before you use the XUI Editor:
v If you have installed the toolkit before you install the IBM Rational Application

Developer or IBM WebSphere Integration Developer, you should copy the
following plug-in files to the $D(RAD)/plugins or $D(WID)/plugins directory
manually after you have IBM Rational Application Developer or IBM WebSphere
Integration Developer installed later:
– com.ibm.btt.core_6.1.1
– com.ibm.btt.rcp.xui_6.1.1
– com.ibm.btt.rcp.xui.editor_6.1.1

Perform the following steps to use the XUI Editor:
1. Start IBM Rational Application Developer or IBM WebSphere Integration

Developer. 3. The XUI Editor will be launched.
2. Click File → New → Other, and expand WebSphere Multichannel Bank

Transformation Toolkit.
3. Select XUI File. The XUI Editor is launched.

Installing toolkit applications on a runtime platform
Installing Bank Transformation Toolkit applications on a runtime platform consists
of deploying EAR files onto WebSphere Application Server. You can do the
packaging using IBM WebSphere Integration Developer or IBM Rational
Application Developer, or using the Application Assembly Tool in WebSphere
Application Server.

Functional units, packages, and dependencies

This section identifies the external dependencies and framework corequisites for
each functional unit. You must load these dependencies and corequisites to have a
clean development environment. In addition to the components provided by the
required features for the Bank Transformation Toolkit, you may need other external
packages. See Obtaining missing prerequisites for a list of these packages.
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The tables below include a brief description of the functional unit, and the
functional unit’s JAR file. Each row shows the direct framework corequisites and
the corequisites of these corequisites.

Note: For the jars in the external dependency column, core.jar can be found in the
\java\jre\lib directory of WebSphere Application Server and other jars can
be found in the \lib directory of WebSphere Application Server.

Table 3. External dependencies and corequisites for functional units-JAR files
JAR Name Functional unit or component External dependency Corequisite JAR

bttbcac Business Component - Access Control core, j2ee bttcore,bttbcaccommon.jar,
bttbccommon.jar

bttbcaccommon Business Component - Access Control
Common

core, j2ee bttcore

bttbccounter Business Component - Counter core, j2ee bttcore

bttbccdm Business Component - Cash Drawer
Management

core, j2ee bttcore

bttbccdmcommon Business Component - Cash Drawer
Management Common

core, j2ee bttcore

bttbccdmdb Business Component - Cash Drawer
Management Database

core, j2ee bttcore

bttbccommon

bttbusinesslogic Business Logic core, j2ee, com.ibm.ws.runtime_6.1.1 bttcore

bttchaejb CHA EJB core, j2ee bttcore

bttchaejbclient CHA EJB Client core, j2ee bttcore

bttchannels Channels core, j2ee, struts, commons-digester,
commons-logging, commons-beanutils,
commons-collections,
commons-validator,
com.ibm.ws.runtime_6.1.1,
com.ibm.ws.webcontainer_2.0.0

bttcore, bttinvoker

bttcompat Compatibility core, j2ee bttcore, bttrcpact, bttrcpwa

bttcore Core Component core, j2ee, ras, com.ibm.ws.runtime_6.1.1,

bttdbsvc Database Service com.ibm.ws.runtime_6.1.1 bttcore

bttej

bttjmsmessage Business Component Message com.ibm.ws.bootstrap_6.1.0,
com.ibm.ws.emf_2.1.0,
com.ibm.ws.runtime_6.1.0,
com.ibm.ws.sib.client_2.0.0,
com.ibm.ws.sib.utils_2.0.0,
com.ibm.ws.wccm_6.1.0,
com.ibm.wsspi.extension_6.1.0,
org.eclipse.core.runtime_3.1.2,
org.eclipse.osgi_3.1.2, j2ee, bootstrap,
iwsorbutil

bttmessage

bttmessage Business Component Message bttcore,bttremote

bttoverrideagent Business Component Override bttcore, bttmessage, bttoverrideagent,
bttoverridecommon, bttremote

bttoverridecommon Business Component Override org.eclipse.core.runtime, org.eclipse.swt bttcore

bttoverridecustom Business Component Override org.eclipse.ui, org.eclipse.core.runtime bttcore, bttremote, bttmessage,
bttoverridecommon

bttremote Business Component Remote commons-codec-1.3,
commons-httpclient-3.1,
commons-logging-1.1.1,
commons-logging-api-1.1.1

bttcore

bttinvoker Invoker core, j2ee, axis,
com.ibm.ws.runtime_6.1.1

bttcore

bttldapsvc LDAP Service core, j2ee bttcore

bttmqsvc MQ Service core, j2ee bttcore

bttopsaejb OpStep Adaptor EJB core, j2ee, com.ibm.ws.runtime_6.1.1 bttcore
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Table 3. External dependencies and corequisites for functional units-JAR files (continued)
JAR Name Functional unit or component External dependency Corequisite JAR

bttweb2

Table 4. External dependencies and corequisites for functional units-RAR files

RAR name Functional unit or component External dependency Corequisite JAR

dummysnalu0 BTTDummySnaLu0Connector core, j2ee, wsif-compatb, wsatlib,
com.ibm.ws.runtime_6.1.1

snalu0 BTTLu0Connector core, j2ee, wsif-compatb, wsatlib,
com.ibm.ws.runtime_6.1.1

snalu62 BTTLu62Connector core, j2ee, com.ibm.ws.runtime_6.1.1

Table 5. External dependencies and corequisites for functional units-WAR files

WAR name Functional unit or component External dependency Corequisite JAR

BTTRuntimeMonitor BTT Runtime Monitor core, j2ee bttcore

Table 6. External dependencies and corequisites for functional units-plug-ins

Plug-in Name

Functional
unit or
component External dependency Corequisite plug-ins

com.ibm.btt.bc.ac.common Access
Control Core
Component

com.ibm.btt.core

com.ibm.btt.bc.ac.rcp.nl Language
plug in for
Access
Control UI
Component

com.ibm.btt.bc.ac.rcp org.eclipse.core.runtime com.ibm.btt.bc.ac.common,
com.ibm.btt.rcp.service.manager,
com.ibm.btt.rcp.broker,
com.ibm.btt.rcp.theme, com.ibm.btt.core,
com.ibm.btt.bc.common

com.ibm.btt.bc.common Business
Component
Common

org.eclipse.ui,
org.eclipse.core.runtime

com.ibm.btt.bc.ej.viewer.nl Resource
boundle
plugin

com.ibm.btt.bc.ej.viewer Business
Component
EJ Viewer

org.eclipse.swt, org.eclipse.jface com.ibm.btt.core, com.ibm.btt.bc.ej,
com.ibm.btt.bc.common,
com.ibm.btt.bc.ej.viewer.nl

com.ibm.btt.bc.ej Business
Component
Electronic
Journal

org.eclipse.swt, org.eclipse.jface com.ibm.btt.core, com.ibm.btt.bc.common

com.ibm.btt.bc.override.common Business
Component
Override

org.eclipse.core.runtime,
org.eclipse.swt

com.ibm.btt.core

com.ibm.btt.bc.override.
customization.nl

Business
Component
Override

com.ibm.btt.bc.override.customization

com.ibm.btt.bc.override.
customization

Business
Component
Override

org.eclipse.ui,
org.eclipse.core.runtime

com.ibm.btt.bc.override.common,
com.ibm.btt.bc.override.supervisor,
com.ibm.btt.bc.override.teller,
com.ibm.btt.core, com.ibm.btt.message,
com.ibm.btt.remote
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Table 6. External dependencies and corequisites for functional units-plug-ins (continued)

Plug-in Name

Functional
unit or
component External dependency Corequisite plug-ins

com.ibm.btt.bc.override.
supervisor.nl

Business
Component
Override

com.ibm.btt.bc.override.supervisor

com.ibm.btt.bc.override.supervisor Business
Component
Override

org.eclipse.ui,
org.eclipse.core.runtime

com.ibm.btt.core,
com.ibm.btt.bc.override.common,
com.ibm.btt.message, com.ibm.btt.remote
com.ibm.btt.bc.override.teller

com.ibm.btt.bc.override.teller.nl Business
Component
Override

com.ibm.btt.bc.override.teller Business
Component
Override

org.eclipse.ui,
org.eclipse.core.runtime

com.ibm.btt.bc.override.common,
com.ibm.btt.message,
com.ibm.btt.remote, com.ibm.btt.core

com.ibm.btt.core Core
Component

org.eclipse.core.runtime

com.ibm.btt.csclient.http HTTP C/S
Connector

com.ibm.btt.core

com.ibm.btt.message Business
Component
Message

com.ibm.btt.core com.ibm.btt.remote

com.ibm.btt.rcp.activity RCP Activity
Framework

org.eclipse.core.runtime,
org.eclipse.ui

com.ibm.btt.core

com.ibm.btt.rcp.broker RCP
Property
Broker for
pure RCP
environment

org.eclipse.core.runtime,
org.eclipse.ui

com.ibm.btt.core

com.ibm.btt.rcp.broker.xpd RCP
Property
Broker for
Lotus
Expeditor
environment

org.eclipse.core.runtime,
org.eclipse.ui,
com.ibm.rcp.propertybroker

com.ibm.btt.core, com.ibm.btt.rcp.broker

com.ibm.btt.rcp.navigator RCP
Navigator
Framework

org.eclipse.core.runtime,
org.eclipse.ui

com.ibm.btt.core, com.ibm.btt.rcp.activity,
com.ibm.btt.rcp.theme

com.ibm.btt.rcp.perspective RCP
Perspective
Framework

org.eclipse.core.runtime,
org.eclipse.ui

com.ibm.btt.core, com.ibm.btt.rcp.activity,
com.ibm.btt.rcp.navigator

com.ibm.btt.rcp.service.manager RCP Service
Manager

org.eclipse.core.runtime com.ibm.btt.core, com.ibm.btt.rcp.activity,
com.ibm.btt.rcp.navigator,
com.ibm.btt.rcp.perspective,
com.ibm.btt.rcp.workingarea,
com.ibm.btt.rcp.broker

com.ibm.btt.rcp.theme RCP Theme
Configuration

org.eclipse.core.runtime,
org.eclipse.ui

com.ibm.btt.core

com.ibm.btt.rcp.workingarea RCP
Working
Area

org.eclipse.core.runtime,
org.eclipse.ui

com.ibm.btt.core, com.ibm.btt.rcp.activity,
com.ibm.btt.rcp.visualbean.runtime,
com.ibm.btt.rcp.broker,
com.ibm.btt.rcp.theme
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Table 6. External dependencies and corequisites for functional units-plug-ins (continued)

Plug-in Name

Functional
unit or
component External dependency Corequisite plug-ins

com.ibm.btt.rcp.visualbean SWT Visual
Beans Editor

org.eclipse.ui,
org.eclipse.core.runtime,
org.eclipse.ve.java.core,
org.eclipse.jdt.core, org.eclipse.jem,
org.eclipse.jem.proxy,
org.eclipse.ve.cde, org.eclipse.ve.swt,
org.eclipse.ve.propertysheet,
org.eclipse.gef, org.eclipse.emf.ecore,
org.eclipse.jem.beaninfo,
org.eclipse.core.resources,
org.eclipse.ui.ide,
org.eclipse.ui.views,
org.eclipse.pde.ui

com.ibm.btt.rcp.visualbean.runtime SWT Visual
Beans
Runtime

org.eclipse.ui,
org.eclipse.core.runtime

com.ibm.btt.core

com.ibm.btt.rcp.xui.editor Design and
build the
XUI File by
dragging in
graphical
tools

org.eclipse.ui,
org.eclipse.core.runtime,
org.eclipse.gef,
org.eclipse.core.resources,
org.eclipse.ui.ide,
org.eclipse.ui.workbench.texteditor,
org.eclipse.ui.editors,
org.eclipse.ui.views.properties.tabbed,
org.eclipse.jdt.ui org.eclipse.jdt,
org.eclipse.jdt.core,
org.eclipse.wst.xml.core
org.eclipse.wst.xml.ui,
org.eclipse.wst.sse.core,
org.eclipse.wst.sse.ui,
org.eclipse.wst.common.core,
org.eclipse.wst.validation,
org.eclipse.wst.validation.ui,
org.eclipse.jface.text,
org.eclipse.jdt.launching,
org.eclipse.debug.core,
org.eclipse.debug.ui,
org.eclipse.jdt.debug.ui,
org.eclipse.core.expressions,
org.eclipse.pde.ui

com.ibm.btt.core, com.ibm.btt.rcp.xui

com.ibm.btt.bc.cm.common Cash Drawer
Management
Core
Component

com.ibm.btt.bc.cm.rcp Cash Drawer
Management
UI
Component

org.eclipse.jface,
org.eclipse.equinox.common,
org.eclipse.ui,
org.eclipse.core.runtime

com.ibm.btt.core, com.ibm.btt.rcp.broker,
com.ibm.btt.rcp.service.manager,
com.ibm.btt.bc.cm.common

com.ibm.btt.tools.migration Migration
Tool

org.eclipse.ui,
org.eclipse.core.runtime,
org.eclipse.jdt.core,
org.eclipse.core.resources,
org.eclipse.jface.text

com.ibm.btt.core
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Table 6. External dependencies and corequisites for functional units-plug-ins (continued)

Plug-in Name

Functional
unit or
component External dependency Corequisite plug-ins

com.ibm.btt.tools.transaction.editor Transaction
Editor

org.eclipse.ui
org.eclipse.core.runtime,
org.eclipse.ui.navigator,
org.eclipse.emf.codegen.ecore.ui,
org.eclipse.core.resources,
org.eclipse.wst.xml.core,
org.eclipse.wst.xml.ui,
org.eclipse.wst.sse.core,
org.eclipse.wst.sse.ui,
org.eclipse.jst.j2ee.ui,
org.eclipse.jst.j2ee.navigator.ui
org.eclipse.jdt.ui,
org.eclipse.core.expressions,
org.eclipse.ui.workbench.texteditor,
org.eclipse.wst.common.ui

com.ibm.btt.tools.validation

com.ibm.btt.tools.validation Validation
Tool

org.eclipse.ui
org.eclipse.core.runtime,
org.eclipse.core.resources,
org.eclipse.jdt.core,
org.eclipse.wst.validation,
org.eclipse.help, org.eclipse.jem.util,
org.eclipse.wst.common.frameworks,
org.eclipse.wst.xml.core,
org.eclipse.wst.sse.ui,
org.eclipse.wst.sse.core,
org.eclipse.wst.common.uriresolver,
org.eclipse.wst.common.ui,
org.eclipse.pde, org.eclipse.pde.ui,
org.eclipse.jst.jsp.core

com.ibm.btt.tools.fs.core Formatter
Simulator
Core
Component

org.eclipse.core.runtime,
org.eclipse.debug.core,
org.eclipse.jdt.launching,
org.eclipse.jdt.core,
org.eclipse.core.resources,
org.eclipse.ui

com.ibm.btt.core

com.ibm.btt.tools.fs.ui Formatter
Simulator UI
Component

org.eclipse.core.resources,
org.eclipse.core.runtime,
org.eclipse.jface.text, org.eclipse.ui,
org.eclipse.ui.ide,
org.eclipse.ui.forms,
org.eclipse.debug.ui,
org.eclipse.jdt.core

com.ibm.btt.tools.fs.core

com.ibm.btt.compatible compatibility
component

org.eclipse.ui,
org.eclipse.core.runtime

dseb, dsed, dsegb, com.ibm.btt.core,
com.ibm.btt.rcp.activity,
com.ibm.btt.rcp.workingarea
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Table 6. External dependencies and corequisites for functional units-plug-ins (continued)

Plug-in Name

Functional
unit or
component External dependency Corequisite plug-ins

com.ibm.btt.tools.aw Application
Wizard Tool

org.eclipse.ui
org.eclipse.core.runtime,
org.eclipse.jst.j2ee.ui,
org.eclipse.wst.common.modulecore,
org.eclipse.wst.common.frameworks,
org.eclipse.wst.common.frameworks.
ui, org.eclipse.jem.util,
org.eclipse.jst.servlet.ui,
org.eclipse.pde.ui,
org.eclipse.jdt.core,
org.eclipse.wst.common.project.facet.
ui, org.eclipse.wst.web,
org.eclipse.wst.web.ui,
org.eclipse.wst.common.project.facet.
core, org.eclipse.jst.j2ee.ejb,
org.eclipse.jst.common.frameworks,
org.eclipse.jst.server.ui,
org.eclipse.jst.j2ee,
org.eclipse.jst.j2ee.web,
org.eclipse.ui.ide,
org.eclipse.core.resources,
com.ibm.btt.core

com.ibm.btt.core

com.ibm.btt.tools.apar APAR Tool

The following table lists the packages included in the product and the JAR or RAR
files that contain them. Note that some Java packages are in more than one JAR to
optimize the contents of the JAR files.

Table 7. JAR, RAR or WAR files for packages

Package name JAR/RAR/WAR name

com.ibm.btt.automaton bttcore.jar

com.ibm.btt.automaton.ext bttcore.jar

com.ibm.btt.automaton.ext bttchannels.jar

com.ibm.btt.automaton.html bttchannels.jar

com.ibm.btt.bc.counter bttbccounter.jar

com.ibm.btt.base bttcore.jar

com.ibm.btt.base.types bttcore.jar

com.ibm.btt.base.types.ext bttcore.jar

com.ibm.btt.bc.cm bttbccdm.jar

com.ibm.btt.bc.cm bttbccdmcommon.jar

com.ibm.btt.bc.cm.dao bttbccdm.jar

com.ibm.btt.bc.cm.dao.mem bttbccdm.jar

com.ibm.btt.bc.cm.dao.exception bttbccdm.jar

com.ibm.btt.bc.cm.facade bttbccdm.jar

com.ibm.btt.bc.cm.model bttbccdm.jar

com.ibm.btt.bc.cm.model bttbccdmcommon.jar

com.ibm.btt.bc.cm.rule bttbccdm.jar

com.ibm.btt.bc.cm.rule.impl bttbccdm.jar
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Table 7. JAR, RAR or WAR files for packages (continued)

Package name JAR/RAR/WAR name

com.ibm.btt.bc.cm.dao.db2 bttbccdmdb.jar

com.ibm.btt.bc.cm.dao.db2.exception bttbccdmdb.jar

com.ibm.btt.cha.ejb bttchaejb.jar

com.ibm.btt.cha.ejb bttchaejbclient.jar

com.ibm.btt.channel bttchannels.jar

com.ibm.btt.clientserver bttchannels.jar

com.ibm.btt.config bttcore.jar

com.ibm.btt.config.impl bttcore.jar

com.ibm.btt.config.exception bttcore.jar

com.ibm.btt.cs.html bttchannels.jar

com.ibm.btt.cs.html.util bttchannels.jar

com.ibm.btt.cs.java bttchannels.jar

com.ibm.btt.cs.servlet bttchannels.jar

com.ibm.btt.cs.sessionpropagation bttchannels.jar

com.ibm.btt.element bttcore.jar

com.ibm.btt.element.exception bttcore.jar

com.ibm.btt.element.impl bttcore.jar

com.ibm.btt.element.scope bttcore.jar

com.ibm.btt.element.simple bttcore.jar

com.ibm.btt.element.simple.impl bttcore.jar

com.ibm.btt.element bttcore.jar

com.ibm.btt.element bttcore.jar

com.ibm.btt.event bttcore.jar

com.ibm.btt.format bttcore.jar

com.ibm.btt.format.adapter bttcore.jar

com.ibm.btt.format.exception bttcore.jar

com.ibm.btt.format.impl bttcore.jar

com.ibm.btt.formatter.client bttchaejb.jar

com.ibm.btt.gui.jsptags bttchannels.jar

com.ibm.btt.http bttchannels.jar

com.ibm.btt.invoker bttinvoker.jar

com.ibm.btt.invoker.ejb bttinvoker.jar

com.ibm.btt.invoker.jms bttinvoker.jar

com.ibm.btt.invoker.pojo bttinvoker.jar

com.ibm.btt.invoker.timer bttinvoker.jar

com.ibm.btt.invoker.utils bttinvoker.jar

com.ibm.btt.invoker.ws bttinvoker.jar

com.ibm.btt.invoker.ws.dynamic bttinvoker.jar

com.ibm.btt.invoker.ws.dynamic.axis_extension bttinvoker.jar

com.ibm.btt.invoker.ws.dynamic.tool bttinvoker.jar
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Table 7. JAR, RAR or WAR files for packages (continued)

Package name JAR/RAR/WAR name

com.ibm.btt.jsf bttchannels.jar

com.ibm.btt.jsf.el bttchannels.jar

com.ibm.btt.jsf.event bttchannels.jar

com.ibm.btt.rcp.dse.navigation bttcompat.jar

com.ibm.btt.runtimemonitor BTTRuntimeMonitor.war

com.ibm.btt.samples.business.sna.lu0 sn0dummy.jar

com.ibm.btt.samples.business.sna.lu0.exception sn0dummy.jar

com.ibm.btt.samples.business.sna.lu0.host sn0dummy.jar

com.ibm.btt.samples.business.sna.lu0.host.event sn0dummy.jar

com.ibm.btt.samples.business.sna.lu0.trace sn0dummy.jar

com.ibm.btt.samples.business.sna.lu0.resource sn0dummy.jar

com.ibm.btt.server.bean bttbusinesslogic.jar

com.ibm.btt.server.bean.ejb bttopsaejb.jar

com.ibm.btt.services bttcore.jar

com.ibm.btt.services.comms bttmqsvc.jar

com.ibm.btt.services.jdbc bttdbsvc.jar

com.ibm.btt.services.ldap bttldapsvc.jar

com.ibm.btt.services.ldap.model bttldapsvc.jar

com.ibm.btt.services.mq bttmqsvc.jar

com.ibm.btt.struts bttchannels.jar

com.ibm.btt.struts.actions bttchannels.jar

com.ibm.btt.struts.base bttchannels.jar

com.ibm.btt.struts.config bttchannels.jar

com.ibm.btt.struts.exception bttchannels.jar

com.ibm.btt.struts.plugins bttchannels.jar

com.ibm.btt.struts.resource bttchannels.jar

com.ibm.btt.struts.resources bttchannels.jar

com.ibm.btt.struts.session bttchannels.jar

com.ibm.btt.struts.taglib.html bttchannels.jar

com.ibm.btt.struts.utiils bttchannels.jar

com.ibm.connector2.sna.lu0 snalu0.jar

com.ibm.connector2.sna.lu0.exception snalu0.jar

com.ibm.connector2.sna.lu0.host.event snalu0.jar

com.ibm.connector2.sna.lu0.host snalu0.jar

com.ibm.connector2.sna.lu0.resource snalu0.jar

com.ibm.connector2.sna.lu0.util snalu0.jar

com.ibm.connector2.sna.lu62 snalu62.jar

com.ibm.connector2.sna.lu62.exception snalu62.jar

com.ibm.connector2.sna.lu62.host snalu62.jar

com.ibm.connector2.sna.lu62.host.event snalu62.jar
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Table 7. JAR, RAR or WAR files for packages (continued)

Package name JAR/RAR/WAR name

com.ibm.connector2.sna.lu62.resource snalu62.jar

com.ibm.connector2.sna.lu62.trace snalu62.jar

com.ibm.connector2.sna.lu62.util snalu62.jar

com.ibm.connector2.sna.services snalu62.jar

com.ibm.connector2.sna.util snalu62.jar

com.ibm.connector2.sna.util snalu0.jar

Where to find the missing prerequisites
Use the following table to locate and obtain any missing prerequisites. Some of
them can be found in other JAR or ZIP files.

Table 8. Locations for prerequisites

Prerequisite Resource name How to get them

WebSphere MQ com.ibm.mq.jar Available from WebSphere
MQ

Lotus Expeditor
for Desktop
6.1.2

com.ibm.rcp.propertybroker_6.1.2.jar Available from Lotus
Expeditor for Desktop 6.1.2
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Notices

IBM may not offer the products, services, or features discussed in this document in
all countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user’s responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not give you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM
Intellectual Property Department in your country or send inquiries, in writing, to:

IBM World Trade Asia Corporation
Licensing
2-31 Roppongi 3-chome, Minato-ku
Tokyo 106, Japan

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law:

INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION ″AS IS″ WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS
FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement may not apply
to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or program(s) described in this publication
at any time without notice.

Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.
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Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

Lab Director
IBM China Software Development Lab
Diamond Building, ZhongGuanCun Software Park, Dongbeiwang West Road No.8,
ShangDi, Haidian District, Beijing 100193 P. R. China

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this document and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement, or any equivalent agreement
between us.

Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments may
vary significantly. Some measurements may have been made on development-level
systems and there is no guarantee that these measurements will be the same on
generally available systems. Furthermore, some measurement may have been
estimated through extrapolation. Actual results may vary. Users of this document
should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

This information contains examples of data and reports used in daily business
operations. To illustrate them as completely as possible, the examples may include
the names of individuals, companies, brands, and products. All of these names are
fictitious and any similarity to the names and addresses used by an actual business
enterprise is entirely coincidental.

All statements regarding IBM’s future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which
illustrates programming techniques on various operating platforms. You may copy,
modify, and distribute these sample programs in any form without payment to
IBM, for the purposes of developing, using, marketing or distributing application
programs conforming to the application programming interface for the operating
platform for which the sample programs are written. These examples have not
been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or
imply reliability, serviceability, or function of these programs. You may copy,
modify, and distribute these sample programs in any form without payment to
IBM for the purposes of developing, using, marketing, or distributing application
programs conforming to IBM’s application programming interfaces.
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Trademarks
IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of
International Business Machines Corporation in the United States, other countries,
or both. If these and other IBM trademarked terms are marked on their first
occurrence in this information with a trademark symbol (® or ™), these symbols
indicate U.S. registered or common law trademarks owned by IBM at the time this
information was published. Such trademarks may also be registered or common
law trademarks in other countries. A current list of IBM trademarks is available on
the Web at ″Copyright and trademark information″ at www.ibm.com/legal/
copytrade.shtml

Microsoft and Windows are trademarks of Microsoft Corporation in the United
States, other countries, or both.

UNIX is a registered trademark of The Open Group in the United States and other
countries.

Java is a trademark of Sun Microsystems, Inc. in the United States, other countries,
or both.

Other company, product, or service names may be trademarks or service marks of
others.

Notices 25

www.ibm.com/legal/copytrade.shtml
www.ibm.com/legal/copytrade.shtml

	Contents
	IBM WebSphere Multichannel Bank Transformation Toolkit installation guide
	Typographic conventions
	Hardware and software requirements
	Hardware requirements
	Software requirements
	Additional requirements

	Setting up a Bank Transformation Toolkit development environment
	Installation package structure
	Installing the Bank Transformation Toolkit on a development workstation
	Setting up the Validation Tool
	Setting up the Transaction Editor
	Setting up the SWT Visual Beans Editor
	Setting up the Runtime Monitor Tool
	Setting up the APAR Tool
	Setting up the formatter simulator
	Setting up the Application Wizard
	Setting up the XUI Editor

	Installing toolkit applications on a runtime platform
	Functional units, packages, and dependencies
	Where to find the missing prerequisites

	Notices
	Trademarks


