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1. Introduction 
1.1. Purpose 

The purpose of this document is to provide a detailed description of IBM’s Workplace Forms 
Designer. The Designer is built on the Eclipse framework; this document describes how to 
use the Eclipse Interface in the context the Designer. It can be used as a reference guide to 
the Designer for building standard XFDL and XForms-enabled forms. 

After reading this document, you should be able to: 

 Understand the Difference between a Perspective and a View 

 Recognize, Understand and Navigate the Designer Interface 

 Create an XFDL form 

− Create XFDL items 

− Modify item properties 

− Use alignment tools to define your form layout 

− Change the tab order of your input items 

− Write simple computes 

 Create an XForms form 

− Create XForms items 

− Create XML instances 

− Create links between your items and XML instances 

− Write simple XPath expressions 

1.2. Audience 
This is an introductory document to the Workplace Forms Designer, XFDL and XForms. It 
assumes that the audience has very little knowledge of these topics.
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2. Building Simple XFDL Forms 
2.1. Audience 

This section is intended to teach someone the basic procedures for designing and creating 
an XFDL form in the Workplace Forms Designer.  This module does not have any formal 
prerequisites.  It is the basic introduction to the Workplace Forms Designer tool.  It serves as 
the foundation for all other modules. 

2.2. Overview 
This module focuses on teaching the reader how to navigate the Designer’s main windows 
and dialogs to design simple XFDL forms.  After reading this section the user should: 

• Be able to create any XFDL item on the designer palette 

• Understand the differences between and use the selection types 

• Be able to manipulate the properties of all the objects 

• Be able to move/align items with the three Designer methods 

• Be able to change the default tab order of a form 

• Be able to enclose images within a form 

2.3. Working with the Palette 
2.3.1. What is the Palette? 

The palette is the part of the workspace that contains all of the XFDL and 
XForms items that are used to build electronic forms.  

The palette is made up completely of buttons. Clicking an item button 
selects that object; if you click on the Designer canvas the selected item will 
be created. The drawer buttons are toggles that open and close the 
drawers.  

The palette is a separate window that can be placed on the left or right side 
of the canvas (depending on your preference). To move the Palette click 
and hold the left mouse button over the window header (the section of the 
window that contains the text “Palette”) and drag it to the desired location. 
As you drag the window the outline will snap to a valid location (either left or 
right side of the canvas). 
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2.3.2. Palette Layout 
The palette is responsible for displaying all the items that can be placed on an XFDL form. 
There are several different ways in which those items can be displayed: 

Columns List Icons Only Details 

  

 

 

 

Large Icons 

The picture included in section 2.3.1 is using the Large Icons option, which can be enabled 
by right-clicking on the palette and choosing “Use Large Icons”. 
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2.3.3. Selection Types 
There are a few different selection types that are available to you as you are working your 
way around the Designer. 

Marquee 

Marquee is the term that describes the process of selecting items by drawing a selection box 
around them. To enable the marquee tool press the corresponding button on the palette. 

Select 

The select type is the default selection tool; an item is selected by clicking it. Multiple items 
can be selected by holding down ctrl and clicking the desired items.  

Connection Creator 

The connection creator is the tool that allows you to define the tab order of the form input 
items. Once the tab mode has been activated (please see section 2.11 for details about 
activating tab mode) the connection tool will appear in the palette. You create relationships 
between items by clicking the first object and then the second object, a line with an arrow 
indicating direction will be drawn between the two items. 

2.3.4. Creating Palette Drawers 
What Are Drawers? 

The Eclipse palette is made up of drawers of items.  All of the XFDL and XForms items have 
been placed into a drawer called “Standard Library” (The XForms items will only appear if 
XForms support has been enabled).  The drawers can be collapsed or expanded to hide or 
show their contents. 

 Drawer Collapsed 

 Drawer Expanded 

How Do I Create My Own Drawers? 

Additional drawers can be created to contain custom objects (groupings of multiple XFDL or 
XForms items).  The custom drawer will get created when you export your custom items.  
Refer to section 2.3.5 XFDL Objects for more information on exporting objects. 

 



6  Building Simple XFDL Forms    

2.3.5. XFDL Objects 
For complete item definitions or specific implementation details please refer to the XFDL 
manual. 

Icon Item Icon Item 

 Action  Help 

Line 

Field (Secret) Toolbar

e

cted objects and

 Box  Label 

 Button  

 Cell  List 

 Check  Page 

 Check Group  Popup 

 Check Group Item  Radio button 

 Combobox  Radio Group 

 Date Picker  Radio Group Item 

 Field  Signature 

 Field (Text Area)  Spacer 

   

 Field with Label  Custom Item 

 

How do I cr ate Custom Objects? 

1. You will want to have a project that is dedicated to your custom objects.  Let’s create this 
projec t. 

a. Select File > New > Project 

b. Click Next > 

c. Enter the name of your project (i.e. “My Object Library”) 

Finish 

2. Select the item or groups of items that you want to be saved as a custom object, right-
 sele  select Export O jects…. 

3. Set the Form Object Library Path. 

bclick on of the

d. Click 

t firs
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a. Click 
objec

the Add o at will contain all your custom 
ts (we created this in a previous step, i.e. “My Object Library”). 

4. Set Form Object File Name. 

a. Enter the name of the file that will be used to store the XFDL code for the custom 
object 

5. Set the e. 

6. Palette Drawer Name. 

 (i.e. “My Objects”).  If you have already created a 
ou can select it from the popup list. 

7.  palette and can be used on 
other forms. 

 

How

1. Open the  menu and select Preferences… 

2. Expand  and select  

3. Sel  

  

2.3.6. XF  
We have created an object library that contains several common form items.  These items 

s. 

 

 Path button and browse t  the folder th

the 

Form Object Palette Nam

a. Enter the name that will be displayed on the palette 

Set the 

a. Enter the name of the drawer
drawer then y

Click OK, now the custom object should appear as part of the

 do I remove custom drawers? 

Windows

Workplace Forms Form Object Library

ect the object library you want to remove and click the Remove button

DL Object Library 

can be used just like any of the standard XFDL item

CDN Address Block 

Phone Number   
(###) ###-#### 

Phone Number  
w/ Patterns 

 

Postal Code  

State Popup  
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State Popup  
(Abbreviated) 

Province Popup  

Province Popup 
(Abbreviated) 

 

SIN (###-###-###)  

SSN (###-##-####)  

 Zip Code 

S Address Block U
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2.4. Working with the Canvas 
When in the GUI Editor View, the canvas is the white space next to the palette where the 
form is built by placing, moving and manipulating items. 

There are two ways to create objects on the canvas; you can choose to use the 
default size that has been assigned to every object or define your own. If you want 
to use the default size of an object, select the desired item tool from the palette and 
then click (the left mouse button) on the canvas.  

If you want to define the size of the item being placed on the canvas, 
select the item tool from the palette, click (and hold the left mouse button) 
on the canvas and drag the bounding box (represents the item to be 
created) to the desired width and height. 

The top left corner of the newly created item will be aligned with the coordinates of the 
initiating mouse click. 

Why Does it Matter? 

Deciding when to use the different creation techniques is important and can greatly decrease 
the amount of time required to build a form. Remember that presentation can make the 
difference between a great form and one that is unusable.  

By default, when width and height arguments are not specified for an item, the size will be 
determined by its value. A label’s width will be determined by the length of the text that you 
provide, the width of a popup will be determined by the length of its longest option, etc.  When 
the size of an item is defined by dragging the mouse the height and width are written into the 
XFDL code. The items will no longer expand based on their data; they are now locked to their 
set dimensions. 

 

 

 

 

 

When creating items choose the default sizing, that way they will start with the same 
dimensions and save you from having to adjust the height or width later on in the form 
development process. 

Label was stretched 
manually 

Label was created 
with default size 
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2.5. Working with Item Properties  
Every item has properties that impact the visible or operational state of the object. The 

 

properties window is where all of those properties are listed.  

2.5.1. Changing a property 

erty of many XFDL items, from 
textboxes to pages; nearly every XFDL object can be 

 for 

nge and then click on the 
button with the three dots (“…”).  A color dialog will appear 

 set does not contain the color you want, clicking 
on “Define Custom Colors >>” will expand the window 

Indicates the value 
has been modified 

Only the most common 
properties are shown by 
default. Access this 
menu to show all of 
them 

The list is 
sorted into 
categories 

Changing a color 

Colors are a common prop

assigned a color for at least one of its properties. The 
properties window provides a really simple mechanism
choosing your preferred color.  

Select the color you want to cha

that allows the user to choose from a defined color 
set. 

If the

allowing you to create your own. You can either 
specify the numerical values for: Red, Green and 
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Blue, the Hue, Saturation, and Luminescence, or you can find one in the color wheel. 

Changing a toggle (on/off) 

Several of the properties are toggles that 
can be set to either “on” or “off”. To set this 
property type, select the option from the 
drop down. 

Changing a font 

For changing the font attribute, the 
Designer provides a button that will open a
new dialog. 
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Changing a value (text options) 

When changing a text property the user can enter it into the text field (in the properties 
window) or if they require additional space can launch a text entry dialog by pressing the 
button with the three dots (“…”). 

Adding a Compute 

Clicking on the “…” button will initialize the compute wizard. 

 

For a more detailed discussion of computes please refer to section 3.8 Computes. 
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Changing sub properties 

Some properties contain sub-properties; sub properties are also known as arguments (or 
array elements). These sub properties can be 
manipulated as indicated below. 

Deletes array 
element 

Use arrows to 
move array 
elements 

Re-ordering sub properties 

Sub properties, or array elements, can be re-
ordered at any time. The up and down arrows 
allow the user to change an elements position 
in an array. This is particularly useful when 
working with the itemlocation array since the 
elements are executed and evaluated in order 
from 0 to the length of the array. 

Removing sub properties 

The array elements can be removed from an 
array by pressing the corresponding delete 
button (i.e. square that contains an “X”). 

 

ton 
2. Press 
Add But

1. Select element 
type 

Adding sub properties 

New array elements can be added to an 
array. First select the root node, in this case 
it is the “Location List”. A drop down and 
button will appear. Select the type to be 
added (i.e. x, y, alignl2l, etc.) and press the 
add button. 

 

2.5.2. Resetting a property back to the default value 
A property’s value can be set back to the default value by clicking on the small toggle button. 
The value is written into the XFDL code if the toggle is on (circle is filled), otherwise the 
default value is assumed and it may not appear in the XFDL code. 

 

Value is not default 
Value is default 
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2.5.3. Filtering the Properties View 
The Properties View contains a few filters that change the way the properties are presented. 

 

Show/Hide Categories 

All the properties have been assigned categories. You may show or hide the category 
headings. 

Show/Hide Advanced Properties? 

Show or hide properties that are used less frequently. 

Sort Alphabetically 

Sort the list of properties alphabetically.  If Show Categories is on then the properties will be 
sorted relative to their categories, otherwise all the properties will be listed in order from a-z. 

 

2.6. Form Preview 
The Preview shows what the form looks like in the Viewer. When you press the Preview 
button the Viewer will be embedded within Eclipse.  Forms that are previewed in Eclipse may 
have a few toolbar functions disabled; for example the forms cannot be emailed. 
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2.7. XFDL Exercise 1 - Build Simple X
 

FDL Form 

The purpose of this exercise is to teach the 

 

At the end of the exercise your form should 
 

 

Getting Started 

1. Open Workplace Forms Designer 2.6 

a.  Start > Program Files > Workplace Forms Designer 2.6 > Designer 

2. Open all the training projects (i.e. TrainingExercises_XFDL, 

a. File > Import > Existing Projects into Workspace and click Next >. 

b. Browse to the location of the existing projects and click Finish. 

3. There are two perspectives that are available by default; the Designer and Resource. The 

a. Open the Resource perspective by selecting Window > Open Perspective > 

b. Look for your project in the Navigator View. 

4. Create a new form file 

a. Select your project, right-click and select New > New Workplace Form 

b. Select your project as the parent folder and enter a filename (i.e. 

c. The Designer should automatically switch to the Designer Perspective and open the 

 

reader how to navigate the Designer in order 
to build simple XFDL forms.  Each of the XFDL
widgets will be created and manipulated. 

look like the picture on the right.  Keep this in
mind as you are following the steps and 
creating your objects. 

TrainingExercises_XForms, TrainingSamples_XForms) 

Designer perspective defines the basic views that will be required to build a form. The 
Resource perspective defines the views that are required to manage your projects and 
files.  

Other…, choose Resource from the new dialog and then click OK. 

“simpleXFDLForm”), then click Finish 

file. 

 



16  Building Simple XFDL Forms    

Add a popup item to the form 

5. Click on the popup item from the Standard Library on the 
palette and click on the canvas to create the popup.  

6. The group property is used to associate choices with the 
popup.  Each list must be assigned a group, however multiple 
lists may share the same group if the choices are the same 
between the lists. 

a. In the Properties View, set the popup’s group to ‘color_group’. 

7. The label property in the Properties View sets the label of the popup item when the form 
is viewed.  A popup label appears as the default selection; once a selection has been 
made there is no way to get back to the label.   

a. Set the value of the label to ‘What is your Favorite Color?’ 

 

Add cells (Options) to the popup 

8. The selections within a list have been defined as their own 
XFDL item, they are called cells.  One reason for making list 
selections independent of the main list item is so that they c
be re-used between multiple lists (popups, combo boxes and 
list boxes) within a single form.  Another advantage of havin
cells is that they can store their own individual properti
instance “type”.  Let’s add some cells to our popup that we 
just created.   

an 

g 
es, for 

a. Left click the Cell item from the Standard Library on the palette and then left click on 
the popup item on the canvas to create the cell. The cell is automatically assigned to 
the selected popup’s group. 

9. Notice that the cell is invisible on the canvas, but if you look in the Outline View you will 
see that an object has been created with a SID of “CELL1”.  If you want to modify the cell 
object you must find it and select it in the Outline View.  Once the cell is selected you can 
then modify its properties in the Property View.   

a. Find CELL1 and set its value to Red. 
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10. Add two more cells with values ‘Green’ and ‘Blue’. 

11. Preview the form in the Preview Mode.  Try making a selection in the popup, notice that 
the three colors that you added (in the form of cells) are included within the popup list. 

 

Save Your Form 

12. Now is a good time to save your form.  Get into the habit of saving your form often.  
Every time that you save your form Eclipse adds a record to the local history that can 
then be reviewed or restored; it acts a local versioning system. 

a. Save your form by selecting File > Save, or by pressing Ctrl + S. 

 

Add a list item to the form 

13. Select the List item from the Standard Library on the palette. Left 
click on the canvas to place the list on the form.  

 

 

14. The default size for the list is quite small so expand the object by 
selecting one of the corners and dragging outward. 
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15. Change the value of the group property to “italian_dish_group” and set the label to 
‘What is your favorite Italian Dish?’ 

 

16. Next we will add a few cells to the List. 

a. Left click the Cell item from the Standard 
Library on the palette and then left click on the 
list item (on the canvas). The cell is 
automatically added to the list’s group.  

b. Find the new cell in the Outline View and 
change its value to ‘Pizza’. 

17. Add three more cells with values ‘Lasagna’, ‘Spaghetti’ and ‘Calazone’. 

18. Preview the form in the Preview mode.  

 

Add a combobox item to the form 

19. Select the combobox item from the Standard Library on the 
palette and left click on the canvas to create the combobox.  

 

 

20. Resize the Combobox so that it looks like the one in the 
screenshot of the example (that was provided at the beginning of this exercise). 
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21. Set the value of the group property to 
‘fruit_group’ and the value of the label 
property to ‘What is your favorite fruit?’  

22. Add four cells to the combo box with values 
‘Banana’, ‘Strawberry’, ‘Apple’ and 
‘Orange’. 

23. Preview the form. 

 

 

 

 

 

 

Add a group of radio buttons to the form 

24. Add a label to the form with value set to “What is your favorite bird of prey?”  

25. Select the radio item from the Standard Library on the palette.  

a. Left click on the canvas to place the radio button on the form.  

b. Change the value of the label property of the radio button to “Eagles”. 

26. Add two more radio buttons with labels set to “Hawks” and “Falcons”. 

27. Select all the radio buttons 

a. Left click each radio button while holding down the 
control key or by clicking the canvas and dragging a 
bounding box around each item while the mouse 
button is held down (all the items in the bounding b
when the mouse button is released will be selected).

ox 
 

 

b. Change the value of the group property to 
 radio 

selecting one will turn the others off.  

“birds_group”. Doing this associates all the
buttons to the same group since radio buttons are 
mutually exclusive, in preview you will see that 
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c. 

 

reate an Add Attachment button to the form 

ary on the palette. Left click on the canvas 
to place the button on the form.  

f the button to “Attach” and set its type to Enclose. 

 

Properties” 

 

 

 

 

Preview the form. 

 

 

 

 

 

 

C

28. Select the Button item from the Standard Libr

a. Change the value property o

b. Left click on the down arrow in the properties dock and click on “Show Advanced 
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c. Add a datagroup to the button.  The datagroup option identifies the list of 
datagroups, or folders, in which the user can store the enclosed file.  

Note: All attachments added to a form must be placed within a datagroup. 

d. the value to 
‘Attachment’. We are using the string ‘Attachment’ but this can be any string; you 

can also add multiple datagroups if you want your users to add multiple attachments 

 
 
 
 

 

 

e. Preview the form. 

i. In the Viewer attachments are added by 
clicking the “Attach” button.  A new dialog 

.   

 add a file to the form as an 
attachment. 

 

Create a Displa ton to the form 

9. Select the button item from the Standard Library on the
to place the button on the form.  

“Display Attachments”. Set the type to 

Click on the ‘+’ button to add a datagroupref to the datagroup and set 

might want to give it a name that depicts the type of attachments to be added.  You 

and place them into separate logical groups. 

 

 

 

 

 

 palette. Left click on the canvas 

will appear

ii. Click the Attach button to bring up an 
open dialog, which you use to navigate 
your drive and

y Attachment but

2

a. Change the value of the button to 

 



22  Building Simple XFDL Forms    

Display. 

y on the palette. Left click on the canvas to place 

b. Left click on the down arrow in the 
w 

 
the previous item then this step should 

ady been completed. 

he list of datagroups, or folders, in which the 

ii. Click on the ‘+’ button to add a datagroupref to the datagroup and set the 

d. Prev

i. Attach some files and then 

that 
lists all the files currently 

 the form. 

ay 
nt 

pen 
 

Create a field 

30. Select the fi r
the field on 

31. Change the background color (bgcolor) to dark blue 
elow and the text color (fontcolor) to 

white. 

 

 

 

Properties View and click on “Sho
Advanced Properties”.  If you created

have alre

c. Add a datagroup to the button.  

i. The datagroup option identifies t
user can display. 

value ‘Attachment’. 

iew the form.  

click on the display button.  
A dialog will appear 

attached to

ii. If you select an attachment 
and click Display, the 
Viewer will invoke the 
parent application to displ
the selected attachme
(i.e. a .doc file will open in 
Word, an .xfdl file will o
in a new instance of the
Viewer, etc). 

eld from the Standard Libra
the form.  

as shown b
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a. Preview the form. 

cker 

Date Picker from the Standard Library on 
Date Picker on the form.  

Set the value of the label property to “Date of 

 

 

 

 

dd a date pi

2. Select the the palette. Left click on the canvas 
to place the 

a. Birth”. 

 

 

 

 

 

A

3

 

 

 

b. Preview the form. 
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Add

33. Select Line from the Standard Library on the 
palette. Left click on the canvas to place the Line 
on the form as shown in the picture. 

 

34. Preview the form. 

 

 

 

 

 

 

Add a Text Area 

35. Select the Fiel n the canvas to place 
the field on the form. 

a. Change the v
property to alw
vertical scroll

b. Resize the ob
enou

 

 

 

 

 

 

 a line 

d from the Standard Library on the palette. Left click o

alue of the scrollvert 
ays.  This will add 

bars to the field. 

ject so that it is large 
gh to accept multiple lines of text. 

 

c. Preview the form. 
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Add Checkboxes 

36. l  Library on the palette and left click on the 
canvas to create the label.  

a. Change the value of the label to ‘What is your favorite Greek dish?’ 

37. Select the Check item from the Standard Library on the palette and left click on the 
canvas to create a checkbox. Change the value of the label property to ‘Moussaka’. 

 

38. Add three more checkboxes with labels set to Pastitsioto, Souvlaki and Gyros. 

39. Preview the form. 

 

 

Se ect the Label item from the Standard
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2.8. Grid Options 
Some people find that using a grid is helpful when designing a form’s layout. The Workplace 
Forms Designer supports several grid related options 

Show Grid 

The grid lines can be enabled from the File Menu, select View > Show Grid.  

Snap To Grid 

If you want to the grid lines to serve as more than just a visible marker, then you can enable 
“Snap to Grid”. This feature will cause items to “snap” to the grid lines when being moved or 
resized. 

Snap To Grid can be enabled from the File Menu, select View > Snap To Grid. 

Adjusting Grid Options 

The settings for the grid can be adjusted to suit your development style. The settings can be 
found by selecting Window > Preferences. Expand Workplace Forms and Design View to 
find the options for setting the x and y coordinate spacing and the grid style (choice between 
lines and dots). 

Expand Workplace Forms, Design View and Colors to change the grid color. 

Snap To Geometry 

Snap To Geometry is similar to snap to grid except 
instead of the objects “snapping” to the grid lines they 
snap to other objects on the canvas. When moving an 
object additional guide lines will appear when its edge 
is inline with another item on the form. The edges that 
can be used as “snapping” points are the top, left, right, bottom, and center.  

Snap To Geometry can be enabled from the File Menu, select View > Snap To Geometry 

Show Rulers 

The Canvas can be enhanced by adding rulers to the top and left edge.  The default 
measurement is pixels.  To activate the Rulers select View > Show Rulers from the File 
Menu. 

Creating Guides 

A Guide is a line that is connected to the ruler and 
stretches the length of the canvas.  Guide lines are 
helpful for working on the form layout because when 
you move an item near the line it will snap to its 
edge.  Guide lines can be created both vertically 
and horizontally. 
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To create a guide line the Rulers must first be active.  Click on the ruler in the location where 
you want the guide line to appear.  Once a guide line has been created it can be moved 

Removing Guides 

Guide lines are not visible in the Viewer, however there may come a time where you want to 
s a mark that 

ruler indicating its pixel location.  A guide line is removed by clicking on the 
ruler mark and dragging it off the ruler. 

ult measurement is pixels.  There is no mechanism for adjusting the ruler unit in this 

arker 

r.  

 Menu. 

along the ruler.  

remove the guide lines that you created to aid in its design.  Every guide line ha
appears on the 

Adjusting Ruler Units 

The defa
version. 

Showing the Page Size M

All forms usually have a page size.  To aid the form designer in creating the layout for their 
form within the confines of the page the Workplace Forms Designer has a Page Size Marke
The marker shows the outline of the current page size so that you can place your items 
appropriately. 

To activate the page size marker select View > Show Page Size from the File
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2.9. 
2.9.1. ts 

Moving objects that have already been placed on the canvas is a big part of form design. 
e enough foresight to place each item exactly where they want it the first 

Manually 

s can be moved manually, individually or grouped with other items. 

f moving objects is crude at best, since you are relying on your ability to “eyeball” 
the items into place.  

The Shift key can be used to constrain the movement of the object (or group of objects) to the 

The arrow keys can also be used to “nudge” or “expand” an item by 1 pixel in any direction. 
ound 

the main indices of the selected item clockwise. The arrow keys will modify the item 
according to the rules of the modifier that is visible. Holding shift while pressing the period 
key will cause the cursor to move around the item counter-clockwise. 

the XFDL itemlocation concepts. For more information about how to form proper relative or 
absolute itemlocations please refer to the XFDL manual. 

All of the position modifiers are implemented using a similar 
procedure. When an object is selected it is surrounded by a 
bounding box with black dots on each index and at the center point 
of each side.  

Refining Form Layout 
Moving Objec

Rarely does one hav
time, especially as the form grows in size and complexity. There are two different 
mechanisms that have been provided that enable a form designer to move the objects 
around the canvas. 

Every item on the canva
Select the item(s) to move, and drag the item(s) to a new location on the canvas. This 
method o

first direction that the mouse is moved (either vertical or horizontal) 

Arrow Keys 

Pressing the period key (“.”) will enable this functionality; it moves the focus (cursor) ar

 

Position Modifiers  

The more complex a form the finer the control required to align and move objects. There are 
several different movement modifiers that provide the ability to quickly align or expand 
multiple objects at the same time. These modifiers have been divided into two main groups 
(Relative and Absolute) and two sub groups (Align and Expand), which coincide directly with 

Moves in 
any direction

All others 
resize 
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As more items are added to a selection (by holding the shift or ctrl 
the black dots is the reference object. The last 
s the reference object (and therefore is 

 

Even though the position modifiers all perform different actions, 
this procedure can be applied to all of them. Let’s re-cap it: 

ct the objects to be manipulated. Make sure that your reference object is the last 
ne selected (indicated by black dots). 

2. Right-click, choose the position modifier. 

2.9.2. Aligning Objects 
Align Modifiers 

Category Modifier 

key) the item that has 
item selected is alway
surrounded by the black dots). The reference object can be changed 
by holding the shift key and clicking an item in the selection group. 

The position modifiers apply a particular operation to a selection of multiple items.  

 

 

 

 

Hold down ctr
to sele
multiple fie

3

2

 

 

Want to align 
all the fields to 
this left edge 

4

Selection Order

1

l 
ct 

lds 

Right-click on the last object selected, choose the position modifier 
(in this case “Align Left To Left” which can be found under 
“Absolute Align”). All the items will snap directly beneath the 
reference object. 

1. Sele
o

Top Edge  

 Align Top to Top 

 Align Top to Bottom 

 Align Top to Center 

Left Edge  

 Align Left to Center 
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 Align Left to Left 

 Align Left to Right 

Bottom Edge  

 Align Bottom to Center 

 Align Bottom to Top 

 Align Bottom to Bottom 

Right Edge  

 Align Right to Center 

 Align Right to Left 

 Align Right to Right 

Center  

 Align Center to Bottom 

 Align Center to Left 

 Align Center to Right 

 Align Center to Top 

 Align Center to Center Vertically 

 Align Center to Center Horizontally 

Reposition  

 Align Above 

 Align Below 

 Align After 

 Align Before 

Axis Spacing  

 Align Horizontally Between 

 Align Vertically Between 

 Horizontally equal spacing 

 Vertically equal spacing 
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Absolu gn 

Absolute alignment means that an item’s location will be recorded as absolute coordinates; 
the x, y, width and heigh fined as pixels. 

Relative Align 

Relative alignment mean n is defined in relation to another item. 
Therefore when an item ems whose location is relative to the first will 
move as well. 

2.9.3. Expanding Objects 
Manually 

When an item is selected eight nodes appear which form the “bounding 
box”.  All items can be e  using the bounding box.  Each 
of the nodes can be selected and moved to manipulate the object 
contained within. 

The co des will ex and the item in two directions (height and 
width).  The four center n e of the item, will 
expand the item in its respective direction (i.e. top and bottom 
vertically, left and right h ay an object is resized can 
be modified by holding d r ctrl key.  

Holdin Shift, while drag , will force the height and width 
to expand proportionally.  It has no effect on the four center nodes.  

Holding ctrl, while dragging a corner node, will force the height and width 
to expand proportional in  pinned.  
When e four nter nodes it will cause the item to expand 
in both directions of the current plane (i.e. the top or bottom node will 
force th  field to grow ou up and down, vertically and the 
left or right node will force the field to grow outward, both left and 
right, horizontally.  

Expand Modifiers 

Category Modifier 

te Ali

t values will be de

s that an item’s locatio
is moved all other it

xpanded manually

rner no p
odes, one on each sid

orizontally).  The w
own either the shift o

g ging a corner node

 both directions as if the center is
dragging th ce

e tward, both 

 

Top Edge  

 Expand Top to Bottom 

 Expand Top to Center 

 Expand Top to Top 

Left Edge  

 Expand Left to Center 
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 Expand Left to Left 

 Expand Left to Right 

Bottom Edge  

 Expand Bottom to Center 

 Expand Bottom to Top 

 Expand Bottom to Bottom 

Right Edge  

 Expand Right to Center 

 Expand Right to Left 

 Expand Right to Right 

 

n to another item. Therefore 
grow or shrink as 

Relative Expand 

Relative Expand means that an item’s size is defined in relatio
when an item is moved all other items whose size is relative to the first will 
well. 
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2.10. XFDL Exercise 2 – Alignment 
1. Open Workplace F

rogram Files > Workplace Forms Designer 2.6 > Designer 

2. Switch to the Reso en XFDL_Ex02_fixFormLayout.xfd from the 
TrainingExercises_XFDL project in the Navigator View. 

3. Use the Outline View to help locate the objects by name, if you select an object in the 
tree view it will be  View. 

4. E1 and LINE2 so they meet in the upper left corner of the form. 

a. Select LINE1 and then (holding the Shift key) select LINE2, right-click either object 
and choose A  to Top  

b. While holding  that it becomes the reference point – the black 
dots will surround LINE1), right-click on either object and choose the Absolute Align 
> Left to Left  

5. Modify LINE1 and LINE4 so they meet in the lower left corner of the form. 

and choose Absolute Align > Bottom to Bottom  

b. While holding Shift select LINE1 (so that it becomes the reference point – the black 
dots will surround LINE1), right-click on either object and choose the Absolute Align 
> Left to Left 

6. Modify LINE2 and LINE3 so they meet in the upper right corner of the form. 

a. Select LINE3 and then (holding the Shift key) select LINE2, right-click either object 
and choose Absolute Align > Top to Top  

b. Right-click either object and choose the Absolute Align > Right to Right 

7. Modify LINE3 and LINE4 so they meet in the lower right corner of the form. 

a. Select LINE3 and then (holding the Shift key) select LINE4, right-click either object 
and choose Absolute Expand > Bottom to Bottom  

b. While holding Shift select LINE3 (so that it becomes the reference point – the black 
dots will surround LINE3), right-click on either object and choose the Absolute 
Expand > Right to Right 

8. Modify LINE5 and LINE7 so they span the distance between LINE1 and LINE3. 

a. Holding the Shift key, select LINE5, LINE7, and LINE1. Right-click and choose 
Absolute Align > Left to Left 

orms Designer 2.6 

a. Start > P

urce Perspective and op

 highlighted in the Design

Modify LIN

bsolute Align > Top

 Shift select LINE1 (so

a. Select LINE1 and then (holding the Shift key) select LINE4, right-click either object 

 



34  Building Simple XFDL Forms    

b. Holding the Shift key, select LINE3. Now release the shift key and hold down the ctrl 
key, select LINE1 to deselect it. Right-click one of the selected objects and choose 

t 

9. 

b. Select LINE7 and deselect LINE2, right-click and choose the Absolute Expand > 

10. Move LABEL1 so that it is positioned in the top left corner (under LINE2 and after LINE1). 

a. Select LABEL1 and LINE1, right-click and choose Absolute Align > Left to Right 

b.  a selected item and choose Absolute 
Align > Top to Bottom 

11. Mov
LIN LINE6. 

 > Below 

 

12. ). 

a.  and LINE1, right-click and choose Absolute Align > Left to Right 

 Absolute 
Align > Top to Bottom 

13. Mov e size as FIELD1, and place it directly 
below LABEL2 

a. Select FIELD2 and FIELD1, right-click and choose Absolute Expand > Make Same 

14. Move LABEL3 so that it is positioned in the top left corner under LINE2 and after LINE6. 

a. ht 

b. t LINE6, right click a selected item and choose Absolute 

15. E5, 
LIN

a. Select FIELD4 and LABEL3, right-click and choose the Absolute Align > Below 

Absolute Expand > Right to Righ

Modify LINE6 so it spans the distance between LINE2 and LINE7.  

a. Select LINE6 and LINE2, right-click and choose the Absolute Align > Top to Top 

Bottom to Bottom 

Select LINE2 and deselect LINE1, right click

e/Expand FIELD1 so that it fits below LABEL1 and within the box created by LINE1, 
E2, LINE5, and 

a. Select FIELD1 and LABEL1, right-click and choose the Absolute Align

b. Select LINE6 and deselect LABEL1, right-click and choose the Absolute Expand >
Right to Left 

Move LABEL2 so that it is positioned in the top left corner (under LINE5 and after LINE1

Select LABEL2

b. Select LINE5 and deselect LINE1, right click a selected item and choose

e/Expand FIELD2 so that it is exactly the sam

Width 

b. Select FIELD2 and LABEL2, right-click and choose Absolute Align > Below  

Select LABEL3 and LINE6, right-click and choose Absolute Align > Left to Rig

Select LINE2 and deselec
Align > Top to Bottom 

Move/Expand FIELD4 so that it fits below LABEL3 and within the box created by LIN
E2, LINE3, and LINE6. 
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b. Select LINE3 and deselect LABEL3, right-click and choose the Absolute Expand > 
Right to Left 

16. Move LABEL4 so that it is positioned in the top left corner (under LINE5 and after LINE6). 

a. Select LABEL4 and LINE6, right-click and choose Absolute Align > Left to Right 

b. Select LINE5 and deselect LINE6, right click a selected item and choose Absolute 

17. Move/Expand FIELD5 so that it is exactly the same size as FIELD4, and place it directly 

 
Width 

b. L4, right-click and choose Absolute Align > Below 

a. Select FIELD3 and FIELD2, right-click and choose the Absolute Align > Below 

b. Select LINE3 and deselect FIELD2, right-click and choose the Absolute Expand > 

c. Select LINE4 and deselect LINE3, right-click and choose the Absolute Expand > 

Align > Top to Bottom 

below LABEL4 

a. Select FIELD5 and FIELD4, right-click and choose Absolute Expand > Make Same

Select FIELD5 and LABE

18. Align FIELD3 directly below LINE7, and expand it until it touches LINE3 and LINE4. 

Right to Left 

Bottom to Top 
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2.11. Ta
Tab order refers to the path that the cursor takes through the input items on a form as the 

were created, which is commonly referred to as the “build order”. When the build order does 
not prop  
form designer to change it.  

To chan t first enter into the “tab mode” by pressing the “Show Next 
Tab Order” button. This button is a toggle that shows the next order, the previous order or 

Once the tab order has been activated a new selection tool appears in the palette. The 
Con
first obj hen the second object. As items are added to the tab order the dotted lines 
will 

rsor 
type to Select and then click a line to select it. Once a line has been selected edit points will 
app
canvas. Moving the lines in this manner will modify the tab order 
element

Show Next 

Activati ws the default “next” tab order. The 
dotted lines indicate the direction of the tab order. 

 

Show Previous 

Activating the button a second time shows the default “previous” 
tab order. The dotted lines indicate the direction of the tab order.  

b Order 

user presses the “Tab” button. By default, the tab order is the order in which the input items 

erly reflect the tab order required by the business case it becomes necessary for the

ge the tab order you mus

hides the tab order.  

nection Creation allows the user to define the next object in the tab order by clicking on 
ect and t

be replaced with solid.  

The tab “indicator” lines can also be manipulated directly; from the Palette change the cu

ear at both ends, these edit points can be dragged over other objects on the Design 

s. 

ng the button sho

Select first item 

Select second item, 
notice the line change
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2.12. XFDL Exercise 3 - Modifying the Tab Order 
 

 

Workplace Forms Designer 2.6 has 3 methods for handling tab order, manually moving the 

from left to right and from top to bottom for this exercise. 

Perspective and open XFDL_Ex03_TabOrder_xfdl.xfd from the 
TrainingExercises_XFDL project in the Navigator View. 

 the exception of two, 
ult tab order is based on the order depicted in the 

Outline View we will fix it by rearranging the objects.  For small forms this technique is okay, 
ove into more complex forms this is not a very efficient mechanism for setting 

the tab order. 

t Tab Order 

a. The designer’s work area should now look like the below screenshot when in design 
mode. 

 

 

 

 

 

 

 

b. The grey arrows are arranged by the build order.  The build order is the order in 
which the items were placed on the form.  You can view the build order via the 
Outline View in the designer. 

When creating an electronic form, an important final check is to determine if the tab order is
correct.  Everyone has their way of designing a form, some like to design the form with the 
tab order in mind.  Others prefer to place multiple like items on the form and then worry about
tab order at the end of the form development process. 

tab arrows, using the ‘Connection Creation Tool’, or modifying the build order. 

The tab order will go 

1. Open Workplace Forms Designer 2.6 

a. Start > Program Files > Workplace Forms Designer 2.6 – Designer 

2. Switch to the Resource 

Build Order Method 

In this first method all of the items have been created in order with
FIELD4 and FIELD3.  Since the defa

but as you m

1. To view the tab order, select View > Show Nex
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the item in the Outline View.   

d. 

e. 

c. Selecting an item in the design mode will highlight 

In the form example, FIELD1 is the sid value for 

The tab order has now been successfully 

from First Name to Last Name in the screenshot 

First Name and FIELD4 is the sid value of Last 
Name, to correctly set the tab order, grab the 
FIELD4 name and drag the item until the black line 
is shown below FIELD1. 

changed.  You can now see the grey arrow points 

below. 
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The Tab Order now goes from left to right and from top to bottom (as shown bel

f. Next, Zip item’s tab arrow needs to point to the City item.  
This is done by moving FIELD3 to below FIELD6 in the 
Outline View. 

 

 

 

 

g. ow): 

 

Conne

Do the 
tab orde
a large n

1. the 

2. 

a.  

c

e nnection creation tool to modify the 
is probably the most efficient method of modifying the tab order of forms with 

umber of items. 

Switch to the Resource Perspective and open XFDL_Ex03_TabOrder_xfdl.xfd from 
TrainingExercises_XFDL project in the Navigator View. 

To view the tab order, select View > Show Next Tab Order 

Designer’s work area should now look like the below screenshot when in design
mode. 

tion Creation Tool Method 

xercise again, but this time focus on using the co
r.  This 
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b. To turn on the Connection Creation Tool, you must 
activate the tool in the palette. 

c. Once activated the cursor will either look like        

when over an item or           when within the 

workspace but not over an item. 

d. Click the First Name item.  Note: The action of moving the cursor to the next item will 
cause the designer to draw a guide line from the original clicked item to the cursor. 

e. Click the Last Name item.  Note: moving the cursor over an item will cause the guide 

f. 

 

line to snap to that item. 

Last Name item now has a blue arrow pointing to it from First Name item.  In code 
view, the tag <previous>FIELD1</previous> has been added to Last Name item. 
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g. You may now continue the above process to define your tab order.  The end result 

 

Manually

Do the exerci

1. the 

2. 

. To manually modify the tab order: 

 

 

 

 

b.            

 

 

 

 

should look similar to the screenshot below. 

 modify Tab Order 

se again, but this time we will focus on modifying the tab order manually. 

Switch to the Resource Perspective and open XFDL_Ex03_TabOrder_xfdl.xfd from 
TrainingExercises_XFDL project in the Navigator View. 

To view the tab order, select View > Show Next Tab Order 

3

a. Click arrow to Highlight. 

Position the cursor at the arrow head of the pointer until the cursor changes from
to  
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c. 

 

 

 

 

d. 

e. 

 

 

 

 

 

 

 

 

Hold and drag the arrow to the desired item.  This will create a blue arrow. 

Continue modifying the pointers until you can tab through the form, left to right and 
from top to bottom. 

The forms tab order should look similar to the screenshot below: 
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2.13. Working with Enclosures 
he Enclosures View provides the user the ability to embed different objects inside the form. 

File types that can be imported are images (i.e. gif, png, bmp, tif), jar files, schema files, wsdl 
les or XForms instances. 

 the Enclosures View is not active then it can be opened by selecting Window > Show View 
> Enclosures.  The Enclosures View lists five different categories: Data, JAR, Schema, 
WS  

Files that have been added through the Enclosures View can be saved locally or removed 
om the form by right-clicking the item and selecting the appropriate action. 

2.13.1. Data 
his function provides the ability to embed images within 

your form. 

Within the Enclosures View, expand Data right-click on 
the desi

 standard file dialog where you can navigate your local 
file system.  Locate the image through this dialog and click 

pen.  The file will then appear as a child under the 
selected page.  

Once an image has been enclosed it can then be applied to a label or a button within your 
rm.  If you select the image and drag it onto the canvas then the Designer will create a label 

that p
existing

2.13.2. 
JAR is an abbreviation for Java Archive; JAR files may contain custom extensions that 
rovide additional functionality.  This function provides the ability to embed a JAR file within 
our form.  JAR files contain functions that can be called within XFDL to enhance a form’s 

behavior; usually the functions provide functionality that does not exist within the Viewer. 

Within the Enclosures View, expand JAR right-click on 
e desired page and select Enclose File.  This will 

launch a standard file dialog where you can navigate your 
cal file system.  Locate the JAR file through this dialog 

and click Open.  The file will then appear as a child under 
e selected page. 

ll functions will exist within a package.  The package 
ame is defined by the developer who created the 

extension.  If you know the package name and the functions included in the JAR file then you 
an access them in XFDL (i.e. <packageName>.<function>). 

T

fi

If

DL, and XForms Instance. 

fr

T

red page and select Enclose File.  This will launch 
a

O

fo
 dis lays the image.  You can also drag the image, from the Enclosures View, onto an 

 label or button. 

JAR 

p
y

th

lo

th

A
n

c
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2.13.3. Schema 
This function provides the ability to embed an XML schema within your form.  Schemas can 
only be enclosed if the form already has an XForms model.  Working with XForms model and 
schemas is not a topic for this module. 

2.13.4

 functions.  If you want a form to call a web service then you 

 View, expand WSDL right-click 
Web Services select Enclose WSDL File.  This 

le system.  Locate the WSDL file through this 
dialog and click Open.  The file will then appear as a 

The following XML fragment was taken directly from a WSDL: 

ress location=" ... "></soap:address> 

nces follow the same rules as XFDL 
function>) 

2.13.5
y block of XML code as an XForms 

already has an XForms model.  
odule. 

. WSDL 
WSDL is an abbreviation for Web Service Description Language; it is an xml file that 
describes a web service and its
must first enclose the WSDL that defines it.  Once the WSDL has been enclosed you may 
then access its functions from within XFDL. 

Within the Enclosures
on  and 
will launch a standard file dialog where you can navigate 
your local fi

child under Web Services. 

All the Web Service functions will be placed into a 
package.  The package name is a combination of the 
service name and port name, separated by an 
underscore (_).  

<service name="AirportWeather"> 
 <documentation>AirportWeather</documentation> 
 <port binding="tns:StationBinding" name="Station"> 
  <soap:add
 </port> 
</service> 
 

Given the above fragment the package name for this web service is 
“AirportWeather_Station”.  Once I have the package name I can now access any of the 
functions that are included in the web service.  The refere
functions (i.e. <packageName>.<

. XForms Instance 
This function provides the ability to embed an arbitrar
Instance.  XML fragments can only be enclosed if the form 
Working with XForms and instance is not a topic for this m
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3. L 
3.1. 

re advanced syntactical fundamentals of the XFDL 
ill help the reader to understand topics such as: the XFDL Node 

Structure, Namespaces, References, Operators, Functions, creating custom options, 
n 

3.2. Overview 
Forms Description Language 
dation, but adds an event-based 
echanism for defining the 

guage that are essential to 
n and develop dynamic forms. 

3.3. 
paces provide a simple method for 

Extensible Markup Language documents by 
.org/TR/REC-

xml

Wh f element names 
with thin one 
document. 

A n ration consists generally of a prefix followed by a URI. In XFDL 
documents, the namespaces are defined as attributes to the XFDL declaration, as shown 

/xmlns/prod/XFDL/7.0" 
xmlns:custom="http://www.ibm.com/xmlns/prod/XFDL/Custom" 

.ibm.com/xmlns/prod/workplace/forms/des

refix and is therefore the 
default namespace for the XFDL element and all of its children.  The URI used is that of the 
XFDL namespace.  This means that all elements and attributes found in this document 
implicitly belong to the XFDL namespace.  Elements will not inherit this namespace if their 
name is lead by a prefix associated to another namespace or there is another default 
namespace declaration in the form. 

 

 Understanding XFD
Audience 
This section is intended to teach the mo
language.  This module w

understanding XFDL events, and writing XFDL computes.  Those who are interested i
understanding XFDL in greater detail and leveraging that understanding to build dynamic 
forms should review this section. 

Workplace Form documents are written in the Extensible 
(XFDL).  XFDL is a language that is built on the XML foun
compute engine, the ability to embed attachments and a m
presentation layer.  There are several aspects to the XFDL lan
understanding how to desig

Namespaces 
The W3C (http://www.w3.org) states that "XML names
qualifying element and attribute names used in 
associating them with namespaces identified by URI references" (http://www.w3

-names/). 

at this means is that by using namespaces, we can control the scope o
in the XML document. In essence, we can have different XML syntaxes wi

amespace decla

below: 

<XFDL xmlns="http://www.ibm.com/xmlns/prod/XFDL/7.0" 
xmlns:xfdl="http://www.ibm.com

xmlns:designer="http://www
igner/2.6"> 
 

Four namespaces are declared here.  The first does not define a p
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The second namespace declarati
prefix can be used to explicitly ass

on defines a prefix for the default (XFDL) namespace.  This 
ign an element or attribute to the XFDL namespace. 

ace declaration defines a prefix for the custom namespace.  This 

s 

PREFIX="TheURI", where the prefix is a short word with no 
is commonly a company URL, so that the URI is unique, and information 
mespace is often at the URL. 

ust 

<value></value> 
on>3</custom:myoption> 

 

The third namesp
namespace is typically used when adding custom (non-XFDL) options to the form. 

The fourth namespace declaration defines a prefix for the Designer's namespace.  Thi
namespace is used by the Designer when adding non-XFDL options to the form. 

The default namespace is shown by not having a prefix, whereas the last two namespace 
declarations consist of xmlns:THE
spaces. The URI 
concerning the na

In the example below, 'value' is part of the core XFDL namespace, and therefore does not 
require the namespace prefix, whereas 'myOption' is not, and therefore the designer m
indicate to which namespace it belongs: 

<custom:myopti

For more information, see the XFDL specification, or the W3C namespace specification 
(http://www.w3.org/TR/REC-xml-names/). 



  Understanding XFDL   47 

3.4. 
An XFDL form contains a variety of elements, such as pages, fields, labels, and images. 

 create a 
gle 

node that is the parent of all other nodes. As you add new nodes, or children, to the 

e tree. Each node corresponds to the form 
element of the same name. The levels of this 

rm - This is the highest level of the tree. It always 
consists of just one node: the form node, which is 
created automatically. All other nodes are 

it. 

ge 
e specifies configuration settings for the form as a 

whole. The second node represents the first page in the form. As you create new pages in 
your form, each additional page is represented by a new page node. 

Item - Item nodes are descendants of page nodes. Items are always contained within a page. 
A page can have an unlimited number of item nodes. 

Option - Option nodes are the children of item nodes, and are always contained within their 
parent item or page node. You can also place custom options within page or item nodes. An 
item can have an unlimited number of option nodes. 

Argument - These nodes store settings for option nodes, and are always contained by their 
parent option node. Argument nodes can contain other argument nodes. There can be an 
unlimited number of sub-levels in the argument level. 

Node Structure 

When loaded, the Viewer organizes these elements into nodes.  These nodes link to
top-down hierarchy that is similar in appearance to a family tree. At the top there is a sin

hierarchy, it grows downward and outward. The result resembles an inverted tree, as 
illustrated in the following diagram: 

As you can see, the hierarchy creates natural levels 
that reflect the types of elements discussed earlier. 
Nodes of the same type always reside on the same 
level of th

hierarchy, in descending order, are:  

Fo

descendants of 

Page - This level always contains a minimum of two page nodes. The first is a special pa
node called the global page node. This nod
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3.5. References 
Learning to write XFDL references is fundamental to understanding how to build dynamic
forms.  Properly formed references allow you to refer to specific values or content in a form. 
This means that you can access data from any item in the form, which can then be used to 
determine the content of another option.  You may use references to copy existing da
use it in a calculation. 

 

ta or 

A reference, like the node structure, has four 
levels: page, item, option and argumen
help to think of each level as container
each container is held within its parent
to creating your reference is to “open” 
containers to get to the one you are loo
When constructing your reference the 
levels, the SID of each container is appended 
together and separated by a period.  T
changes slightly once we descend to t
container because it is an array of argu
Arguments, within the reference, are d

 <height>38</height> 

ex of the argument.  Array 
indexes start with zero.  Therefore the reference that retrieves the value of “y” is 
“itemlocation[y]” or “itemlocation[1]” 

t.  It may 
s, where 
.  The key 
all the 
king for.  

first three 

he syntax 
he option 
ments.  

enoted by 
using square brackets (i.e. 
PAGE.ITEM.OPTION[ARGUMENT]). 

XFDL supports an infinite level of arrays.  An 
example of an option that contains an array of 
arguments is the itemlocation: 

<itemlocation> 
 <x>8</x> 
 <y>133</y> 
 <width>217</width> 

</itemlocation> 
 

In XFDL, array arguments can be accessed by the name or ind
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3.6. XFDL Exercise 4 – Writing XFDL References 

form, XFDL_Ex04_XFDLReferences.xfdl, in the Viewer. 

ence in each field 

n label. 

 buttons corresponding with each question. 

At this point you should understand the basics of how to build simple references.  A 
worksheet has been included in this training package that will help you to apply your new 
found knowledge.  Please take a few minutes to work through the questions. 

1. Open the exercise 

2. Answer each question by typing your refer

a. If your answer is correct it will be indicated by a gree

b. The solutions can be seen by pressing the
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3.7. Operators 
The following tables include all the valid operators that can be used within XFDL. 

Numeric 3.7.1. 
Operand Description 

+ Addition 

- Subtraction 

* Multiplication 

/ Division 

% Modulus (returns the remainder) 

^ Exponential 

3.7.2. Logical 
Operand Description 

or Boolean Or 

and Boolean And 

not Boolean Not 

3.7.3. Miscellaneous 
Operand Description 

+. String Concatenation 

+ or +. Function Concatenation 
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3.7.4. Relational 
Operand Description 

== Equal To 

!= Not Equal 

< Less than 

> Greater than 

<= Less than or equal 

>= Greater than or equal 
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3.8. Computes 
Compute rful tools th nce to XFDL forms, by providing built-in logic 
and the ability to perform calcul  ability to include mathematical and conditional 
computes gives form designers a great deal of flexibility in the form’s user interface. Using 
computes, you can make dynam that present different interfaces based on the 
users’ unique needs. 

All computes rely heavily on node referencing, which allows form elements to ‘copy’, ‘share’, 
or ‘update’ informa n from oth ts. You can add computes to a form by using 
the Designer’s Properties View or directly to the XFDL code in the Source View. 

3.8.1. Mathematical Computes 
Typically, form designers want to reduce the potential for user errors. You can drastically 
reduce the potential for mathematical errors by allowing the form to perform all required 
mathematical computes. For example, you could create a tax form that automatically 
performed all of the necessary calculations. As a result, users would only need to enter the 
correct starting values to complete the form. 

You create mathematical formulas by embedding computes in the form. As the user fills in 
the form, the computes run automatically. Mathematical computes include addition, 
subtraction, string concatenation, multiplication, division, integer modulus, sum, unary minus, 
and exponentiation. 

3.8.2. Conditional Computes 
The second type of XFDL compute is the Conditional Expression, or Decision Statement. 
Like mathematical computes, these conditional computes are embedded in the XFDL code 
and their execution occurs on the user’s computer. 

Conditional computes are often referred to as IF – THEN – ELSE expressions.  They are 
symbolically written as “x ? y : z”; where x is a boolean expression and y is what occurs when 
x evaluates true and z when false. . You can read this as: 

If x THEN y ELSE z 
 

In other words: IF condition x is true THEN use condition y. Otherwise use condition z. For 
example, if you wanted a field on page 2 to copy information from a field on page1 if a 
checkbox is selected, you would use the following compute to the field on page 2: 

You could read the above compute as: 

If the checkbox is turned on, then place the value of PAGE1.FIELD1 into the value of 
PAGE2.FIELD2. Otherwise, leave PAGE2.FIELD2 blank. 

<value compute=“PAGE1.CHECK1.value == ‘on’ 
? PAGE1.FIELD1.value 
: ‘’” /> 

s are powe at add intellige
ations. The

ic e-forms 

tio er form elemen
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Empty single quotes indicate an empty value. In other words, if CHECK1 is not selected, the 

3.8.3. 
al 

s; these computes have been broken into six categories: 

The value is equal to a function - Allows you to create a compute that: Assigns the value 
t. 

e 
tc.). 

 

The value is equal to the sum of multiple fields on a form - Allows you to create a 

r test (for instance, is FIELD2.active equal to “on”) and assign the 
option a certain value if the condition is “true” and a different value if the condition is “false”. 

sed in the compute can be based on items’ values, numbers 

ombine more than one type of formula, 

orrectly structure your formula and 
ass er properties, functions, and values for your compute. 

compute does nothing. 

Creating Computes in the Designer 
The Designer contains a compute wizard that provides the user the ability to create sever
different types of compute

The value is equal to another form item - Allows you to set the value of an option equal to 
a property of another item on the form. 

returned by a function such as se

Set by a calculation of 2 values - Allows you to create a compute that calculates the valu
of the option from two other values using any operator (add, subtract, divide, exponent, e
The two values can come from the properties of other items, numbers you provide, the
results of function calls, or combinations of these. 

compute that sets the option to equal the total value of selected fields. 

Determined by a decision (If/Then/Else) -  Allows you to create a compute that will 
evaluate a condition o

The condition and the values u
or text you provide, or the results of function calls. 

Set by a manually created formula - Allows you to type out the formula manually. This 
method allows more flexibility, and the capability to c
but it means that you must be familiar with XFDL syntax.  

Once you have selected the type of formula you want to create, the Formula dialog box 
automatically populates with text, fields, and choices that c

ist you in selecting the prop
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3.9. XFDL Exercise 5 – Writing Computes 
introduce you to the designer’s compute wizard and show you how to 

create a simple XFDL compute. Computes are powerful tools that add intelligence to XFDL 
ons.  The capability to 

include mathematical and conditional computes gives form designers a great deal of flexibility 
f 

ic understanding of the Eclipse interface. 

a. Start > Program Files > Workplace Forms Designer 2.6 – Designer 

 

1. Right click FIELD2 (under Copy of name) and select Wizards > Compute Wizard to 

This lesson is meant to 

forms by providing built-in logic and the ability to perform calculati

in the form’s user interface. This exercise will expose you to five of the most common types o
XFDL computes.  

This document has been written assuming little to no previous knowledge of XFDL. This 
tutorial assumes that the reader has some bas

1. Open Workplace Forms Designer 2.6 

b. Switch to the Resource Perspective and open XFDL_Ex05_XFDLComputes.xfd 
from the TrainingExercises_XFDL project in the Navigator View. 

First Compute: Setting a value equal to the value of another item.  

 

 

 

open the following window: 
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2. Select value from the dropdown list and select the fir

 

st radio button “The value is equal 
to another form item.”  

o 

 to the wizard page where you 
need to once again select the value option from 

5. Click the Finish button to complete your first 

 

Sec

 

 

 

1. Right click FIELD4 (under String Length) and select Wizards > Compute Wizard  

2. Select value from the dropdown list and select the second radio button “The value is 
equal to a function.” Then click Next >. 

4. Select strlen from the function call popup.  

3. Press the Next > button then select the           button. The designer should switch back t
the design view where you should select FIELD1 (under Name). 

4. Once you select the field the application should 
bring you back

the drop down menu. 

compute. 

ond Compute: Setting a value equal to a function.  

3. Click the Function button 

 

5. Select “Choose an item on the form.” Then select the    button. The designer 
should switch back to the design view where you should click on FIELD3 (under Name).  

 

 

6. Click OK then click the Finish to complete your second compute. 

 

Third Compute: Set by a calculation of two values.  

 

 

 

1. Right click FIELD13 (under Product) and select Wizards > Compute Wizard  
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2. Select value from the dropdown list and select the third radio button “The value is set 
by a calculation of two values.” Then click Next >. 

ould click on FIELD5 
3. For the First Value: select “Choose an item on the form.” Then select the    button. 

The designer should switch back to the design view where you sh
(under Multiplicand).  

4. 

5. d by)”.  

m on the form.” Then select the 

Select value from the drop down list 

For the Function choose “* (multiplie

 6. For the Second Value: select “Choose an ite
button. Th

  
e designer should switch back to the design view where you should click on. 

FIELD6 (under Multiplier). 

7. Select value from the drop down list. 

8. Click the Finish button to complete your third compute. 

 

Fourth Compute: Equal to the sum of multiple fields on the form.  

 

 

 

 Total) and select Wizards > Compute Wizard  1. Right click FIELD10 (under

2. Select value from the dropdown list and select the third radio button “The value is equal 
to the sum of multiple fields on the form.” Then click Next >. 

3. Select the  button. The designer should switch back to the 
sign view. Hold down the ctrl key and select FIELD7, FIELD8, 
d FIELD9.  Then click Finished in the box at the top left of your 

de
an
sc

 

reen.  

 

 

 

 

4. Click the Finish button to complete your fourth compute. 
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Fifth Compute: Determined by an if statement  

1. ct Wizards > Compute Wizard  

3. For the If section in the first popup select “Choose an item on the form.” Then select 

 

 

 

Right click FIELD14 (under Maximum value) and sele

2. Select value from the dropdown list and select the third radio button “The value is 
determined by a decision (if/then/else).” Then click Next >. 

e form click on FIELD11 (under A). Then Select the    button. When you return to th
value from the next popup.  

4. Select “Choose an item on the form.” Then select the    button. When you re rn to 
the form click on FIELD12 (under B). Then Select value from the popup 

In the middle popup on the bottom line select >

t

 (greater than) 

u

5. 

 

the form.” Then 
select the  

 

 

6. For the Then section in the first popup select “Choose an item on 
  button. When you return to the form click on FIELD11 (under A). Then 

Select value from the popup.  

 

 

 

7. 
select the  
For the Else section in the first popup select “Choose an item on the form.” Then 

  button. When you return to the form click on FIELD12 (under B). Then 
 f

 

 

8. Click 

Select value rom the popup.  

 

the Finish button to complete your fifth compute. 
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3.10. Functions 
Functions allow forms to perform procedural logic and complex operations that would 
normally require complex conditional statements to achieve. For example, you can use 
functions to count the number of lines a string would take up over a given width, return a sub-
string of a 

You can 
defined fun

All functions are grouped into packages.  The Viewer includes two default packages called 
an be used within XFDL.  They 

clude standard mathematical operations, date and time functions, some generic utility 
functions and functions that manipulate a string. You can call them from any compute in your 

nction dialog box or hand code them in 
Code View or other text editor. 

Parameters are used to pass information to functions. For example, parameters can define 
the option or string that the function will evaluate and the function’s limits, such as its start 
and end point.  These parameters are placed in parentheses immediately following the 
function name. Each parameter is contained in quotation marks and separated by a comma: 

function(‘param_1’, ‘param_n’) 

Ref g functions within XFDL. 

3.10.1
Tak DL specification.  Have a look at the section labeled “Details 
on F  Calls”; all the functions that are available within the XFDL language have been 

strin me that couldn’t 
be categorized (so were thrown together in a miscellaneous category).  If you have a good 

 better equipped to 
design your dynamic forms! 

If you do not currently have the Workplace Forms XFDL Specification it can be downloaded 
from http://www.ibm.com/software/lotus/support/workplaceforms

string, or set the value of a form option. 

choose to use a predefined system function or you can create your own. User-
ctions are discussed in the API training modules. 

“viewer” and “system”.  Both packages contain functions that c
in

form and you can add them using the Designer’s Fu

 
er to the XFDL Specification for additional detail on implementin

. Explore XFDL Functions 
e a moment and open the XF
unction

categorized and explained in detail.  You will find that there are functions for manipulating 
gs, working with dates and times, calculating mathematical values and so

idea of the type of functions that are available then you will be much

 .  Click on the Product 
Documentation link under the Primary support resources heading. 
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3.11. 
This u to the functions that are available within the XFDL 
language. ercise will expose you to five groupings of functions that are available and 
some of the most commonly used.  

This document has been written assuming little to no previous knowledge of XFDL. This 
tutorial assumes that the reader has some basic understanding of the Eclipse interface. 

1. Open Workplace Forms Designer 2.6 

a. Start > Program Files > Workplace Forms Designer 2.6 – Designer 

2. Switch to the Resource Perspective and open XFDL_Ex06_XFDLFunctions.xfdl from 
the TrainingExercises_XFDL project in the Navigator View. 

Function 1 – viewer.messagebox 

This function displays a message box that prompts the user. In this exercise we will call this 
function, when the user changes the value in the Change Value field. 

Method Call 

messageBox(message[, caption, messagetype]) 

Where message string contains the message to display in the main portion of the message 
box. Caption string contains the caption to display in the title bar of the message box, and 
the messagetype specifies whether the message box is an OK or a QUESTION box. If the 
type is OK, then the box will contain an OK button. If the type is QUESTION, then the box will 
contain a Yes button and a No button. The default type is OK. 

1. Right click Change Value field (under the viewer.messageBox label) and select Wizards 
> Compute Wizard. 

2. Create a new custom option called ‘valueChange’.  

3. Select the radio button ‘The value is determined by a decision (If/Then/Else)’ and then 
click Next >. 

4. For the If statement: 

a. In the first drop down, select ‘Choose a function.’ 

b. Click the Function button.  A new window is opened ‘Source Code Being 
Generated’. 

c. In the drop down, select Toggle. 

d. In the Parameters section under references, select “Choose an item on the form’,  

e. Select the hand icon 

XFDL Example 6 – Using XFDL Functions 
 lesson is meant to introduce yo

This ex
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f. Click the Change Value field  

i. Select OK. 

r the value of 1. 

own box, select the function 
‘viewer.messageBox’. 

e 

c. In the caption parameter drop down, select “Enter a number or text’ and enter the 

r 
the value 0. 

e. Select OK. 

g. Click Finish. 

h. Select Value in the drop down next to the hand icon. 

j. Select “Enter a number or text’ in the 2nd If drop down and ente

k. At this point, the Source Code Being Generated should look like this: 

 toggle(PAGE1.ItemOne_Field.value) == '1' ? ('') : '' 
 

5. In the Then drop down box, select ‘Choose a function.’ And select the Function button. 

a. A new window has been created.  In the drop d

b. In the message parameter drop down, select ‘Enter a number or text’ and enter th
value The value has changed! 

value Message Box. 

d. In the messagetype parameter drop down, select “Enter a number or text’ and ente

6. In the Else drop down box, select ‘Enter a number or text.’ And leave the value empty. 

7. Your compute wizard should look like the screen shot below. 
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8. Select Finish. 

9. View the form in preview tab to test it. Enter text in the Change Value field and tab ou
the field to view the viewer.messageBox action. 

t of 

Function 2 – isValidFormat 

This function returns the boolean result of whether a string is valid according to the setting of 

This exercise uses a button to fire the function isValidFormat to check the format of the 
d if the format is invalid and "1" otherwise. 

 

the format option referred to in formatOptionReference.  

Current Date field. "0" is displaye

Method Call 

isValidFormat(string, formatOptionReference)  

Where string is a string to be checked against the format, and formatOptionReference is 
the option reference of the format, including the page sid if necessary, to check the string 
against. 

1. Right click Validate button (under the isValidFormat label) and select Wizards > 
Compute Wizard. 

2. Create a new custom option called ‘onClick’. 

3. Select the radio button ‘The value is determined by a decision (If/Then/Else)’ and then 
click Next >. 

4. For the If statement: 

a. In the first drop down, select ‘Choose a function.’ 

b. Click the Function button.  A new window is opened ‘Source Code Being 
Generated’. 

c. In the drop down, select Toggle. 

d. In the Parameters section under references, select “Choose an item on the form’ 

e. Select the hand icon 
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f. Click the Validate button 

g. Click Finish. 

h. Select activated in the drop down next to the hand icon. 

i. In the Start section, choose “Enter a number or text” and enter “off” in the text box.  

x. 

ue of 1. 

nt Date field. 

d. ference parameter drop down, select “Choose an item on the 

e. 

e text field next to the hand tool says Format. 

j. In the End section, choose “Enter a number or text” and enter “on” in the text bo

k. Select OK. 

l. Select “Enter a number or text’ in the 2nd If drop down and enter the val

5. In the Then drop down box, select ‘Choose a function.’ And select the Function button. 

a. A new window has been created.  In the drop down box, select the function 
‘isValidFormat’. 

b. In the string parameter drop down, select “Choose an item on the form’, Select the 
hand icon then click on the Curre

c. Make sure the text field next to the hand tool says Value. 

In the formatOptionRe
form’, Select the hand icon, Click Current Date field 

Click Finish. 

f. Make sure th

g. Click OK. 
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6. In the Else drop down box, select ‘Enter a number or text.’ And leave the value empty. 

 Finish. 

tion as follows: 

) == '1' ? (isValidFormat(PAGE1.FIELD3.value, 
'PAGE1.FIELD3.format')) : ''"></custom:onClick> 

To: 

ated, 
'off', 'on') == '1' ? viewer.messageBox('isValidFormat ' +. 
isValidFormat(PAGE1.FIELD3.value, 'PAGE1.FIELD3.format')) : 

 
10. e 

current date and click the validate button. 

7. Your compute wizard should look like the screen shot below. 

8. Click

9. Now click on the Source tab and add a viewer.messageBox function to the 
custom:onClick op

From: 

<custom:onClick xfdl:compute="toggle(PAGE1.setIndex1.activated, 
'off', 'on'

 

<custom:onClick xfdl:compute="toggle(PAGE1.setIndex1.activ

''"></custom:onClick> 

To test the form click on the preview tab. Enter * in the current date field to fill it with th
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Thi

set

for 

 

2. 

3. 

4. ent: 

a. In the first drop down, select ‘Choose a function’ and click Next >. 

b. Click the Function button.  In the new dialog select toggle from the function call 
dialog. 

c.  In the Parameters section under references, select “Choose an item on the form’, 
Select the hand icon, Click Push Value button.  If the dialog does not come back into 
focus then press “Finished”. 

d. Select activated in the drop down next to the hand icon. 

e. Set the Start parameter to “Enter a number or text” and enter “off” in the text box. 

f. In the End section, choose “Enter a number or text” and enter “on” in the text box. 

g. Select OK. 

h. Select “Enter a number or text’ in the 2nd If drop down and enter the value of 1. 

Function 3 – set 

This function sets the value of an XFDL form option or of an element in the XForms model. 
s e set function to push the Current Date under isValidFormat to the field 

“Push Current Date here”. 

Method Call 

(reference, value, referenceType, scheme)  

The firs nce, is the string reference of the element being set, and value is 
the reference’s new value. The referenceType and scheme are optional and can be left out 

e

1. Right click Push value button (under the set label) and select Wizards > Compute 

Create a new custom option called ‘onClick’. 

Select the radio button ‘The value is determined by a decision (If/Then/Else)’ and then 

 exercise uses th

t parameter, refere

this xample. 

Wizard. 

click Next >. 

For the If statem
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5. In the Then drop down box, select ‘Choose a function.’ And select the Function button. 

’. 

wn, sele ’, Select 
the hand icon, Click Push Current Date Here 

c. In the value drop down, select “Choose an item on the form’, Select the hand icon, 
Click the Current Date field  

d. Click Finish.  

e. Click OK to close the window. The compute must look like this at the end of this step. 

 

6. Click Finish to exit the Compute Wizard. 

7. Test the form in the preview tab. Enter * in the  Current Date field under isValidFormat 
label to fill it with the current date and click on Push Value button under the set label. 

 

Fun

This exercise uses the power function to return the number represented in number raised to 
ower indicated by power.  

Met

pow

Wh ised to the power in power. 

a. A new window has been created.  In the drop down box, select the function ‘set

ct “Choose an item on the form
field.  

b. In the reference parameter drop do

ction 4 – Power 

the p

hod Call 

er(number, power)  

ere the number in number is ra

1. Right click on the Solution field under the Power  label and select Wizards > Compute 
Wizard. 
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2. Set the Property to Set parameter to Value. Select the radio button ‘The value is equal 
to a function’ and then click Next >. 

. In the next window, click on Function. 

a. In the function window, choose Power from the drop down list. 

meters section under number, select “Choose an item on the form’, 

n, Click Power field under the Power label. 

 to return to the Compute Wizard. 

4.  complete the compute. 

Preview mode to test the form. Enter a number and a power and 

Function 5 –

This exercise mber represented in 
num

Met

log

3

b. In the Para
Select the hand icon, Click Number field under the Power label.  

c. In the Parameters section under power, select “Choose an item on the form’, 
Select the hand ico

d. Click OK

e. Your compute wizard should look like the screen shot below. 

 

Click Finish to

5. View the form in the 
click Solution field. 

 Log 

 uses the log function to return the logarithm of the nu
ber to the base indicated by base.  

hod Call 

(number, base)  
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Where the number in base is the base for which the logarithm will be computed. 

1. 
Wizard. 

2. Set dio button ‘The value is equal 
to a function’ and then click Next >. 

3. In th tion. 

ow, choose Log from the drop down list. 

Select the hand icon, Click Number field under the Log label.  

c. In the Parameters section under base, select “Choose an item on the form’, Select 
the hand icon, Click Base field under the Log label. 

d. Click OK to return to the Compute Wizard. 

the screen shot below. 

 

4. Click Finish 

. View the form r and a base and click 

Right click on the Solution field under the Log  label and select Wizards > Compute 

 the Property to Set parameter to Value. Select the ra

e next window, click on Func

a. In the function wind

b. In the Parameters section under number, select “Choose an item on the form’, 

e. Your compute wizard should look like 

to complete the compute. 

 in the Preview mode to test the form. Enter a numbe5
Solution field. 
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Function 6 – substr 

 exercise uses the log function to retuThis rn the substr to return the substring from the 

Met

sub

This exe  the position 
indi  
then the ter than or equal to 
the length of string then the substring will end on the last character of string.  

An error occurs if start is greater than end, if either of start and end is not a valid integer, or if 
strin

1. Right clic Wizards > Compute 
Wizard. 

2. Set the The value is equal 
to a func

3. In the next windo

a. 

b. In the Parameters section under string: select “Choose an item on the form’, select 
the hand icon, Click String field under the subStr label. 

c.  In the Parameters section under start: select “Choose an item on the form’, select 

d. Finally, in the Parameters section under end: select “Choose an item on the form’, 
select the hand icon, Click End field under the subStr label.  

e. The Function window should look as follows at the end of this step: 

position indicated in start through end. 

hod Call 

str(string, start, end)  

rcise uses the substr function to return the substring of string from
cated in start through end (the first character in string is zero). If start is less than zero

 substring will begin on the first character of string. If end is grea

g is empty.  

k on the Substring field under the subStr label and select 

Property to Set parameter to Value. Select the radio button ‘
tion’ and then click Next >. 

w, click on Function. 

In the function window, choose substr from the drop down list. 

the hand icon, Click Start field under the subStr label.  
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4. Your compute wizard should look like the screen shot below. 

5. Click Finish to complete the compute. 

est the form. Enter a String, a start and end index 

f. Click OK to exit the function window. 

6. View the form in the Preview mode to t

 

and click on the Substring field. 
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Function 7 – strstr 

This exercise uses the strStr function. It will search for a substring within a string and return 
ccurrence or ″-1″ if no occurrence is found.  

d. 

f. 

g. 

 

4. Click OK

5. Your comput

the starting location of the first o

Method Call 

strstr(string1, string2)  

Where string1 is the string and string2 is the substring that is being looked for in string1.  

 

1. Right click on the String index field under the strStr label and select Wizards > 
Compute Wizard. 

tion’ and then click Next >. 

a. In the function window, choose strstr from the drop down list. 

b. In the Parameters section under string1: select “Choose an item on the form’,  

c. Select the hand icon 

2. Set the Property to Set parameter to Value. Select the radio button ‘The value is equal 
to a func

3. In the next window, click on Function. 

Click String field under the strStr label.  

e. In the Parameters section under string2: select “Choose an item on the form’. 

Select the hand icon  

Click Search String field under the strStr label. 

h. The Function window should look as follows at the end of this step: 

 to exit the function window. 

e wizard should look like the screen shot below. 
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6. Click Finish to complete the compute. 

7. View the form in the Preview mode to test the form.  

8. Enter a String, a start and end index and click on the Substring field. 

 

This function returns a date in ″yyyymmdd″ format. Either converts a number of seconds 

option blank to display the current date.  

1. Right click Today’s Date button (under the time label) and select Wizards > Compute 
Wizard. 

 

Function 8 – date 

(from 12 am, January 1, 1970) or returns the current date if no value is provided. This 
exercise uses a button to put the current date into the field.  

Method Call 

date(datesecs)   

Where datesecs is the number of seconds from 12 am, January 1, 1970. We will leave this 
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2. Create a new custom option called ‘onClick’. 

utton ‘The value is determined by a decision (If/Then/Else)’ and then 

 first drop down, select ‘Choose a function.’ 

on button.  A new window is opened ‘Source Code Being 

c. 

orm’. 

g. Select 

h. In the Start section, choose “Enter a number or text” and enter “off” in the text box. 

i. In the End section, choose “Enter a number or text” and enter “on” in the text box. 

j. Select OK. 

k. Select “Enter a number or text’ in the 2nd If drop down and enter the value of 1. 

5. In the Then drop down box, select ‘Choose a function.’ And select the Function button. 

a. A new window has been created.  In the drop down box, select the function ‘set’. 

b. In the se an item on the form’. 

c. Select the ha

d. Click Cu

e. In the ’, Enter date() in the text 
field.  

f. Click Ok 

3. Select the radio b
click Next >. 

4. For the If statement: 

a. In the

b. Click the Functi
Generated’. 

In the drop down, select Toggle. 

 icon. 

activated in the drop down next to the hand icon. 

d. In the Parameters section under references, select “Choose an item on the f

e. Select the hand

f. Click Today’s Date button and click Finish. 

reference parameter drop down, select “Choo

nd icon,  

rrent Date field.  

value drop down, select “Enter a number or text

to close the window.  
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g. The compute must look like this at the end of this step 

 

h. Click Finish to exit the compute wizard. 

6. Select the Today’s Date button in the design view and then select the Source view. 

7. Remove quotations if any from the date() function. The final code should look like: 

<custom:onClick xfdl:compute="toggle(PAGE1.setIndex.activated, 
'off', 'on') == '1' ? (set('PAGE1.FIELD2.value', date())) : 
''"></custom:onClick> 

 click on the preview tab. Click the Today’s Date button. 

 

 

 

 
8. To test the form
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Function 9 – time 

This exercise uses a button to put the current time in the field in ″hh:mm AM″ format.  

hod Call Met

1. 

2. 

3. 

4. 

d. In the Parameters section under references, select “Choose an item on the form’, 
nd icon, Click Today’s Time button and click Finish. 

x. 

r or text’ in the 2nd If drop down and enter the value of 1. 

5. lect ‘Choose a function.’ And select the Function button. 

b. ose an item on the form’, Select 
the value drop down, select “Enter a 

 OK to close the window. The 

 

 

 

tim ()   e

nd select Wizards > Compute 

Cre tom option called ‘onClick’. 

l etermined by a decision (If/Then/Else)’ and then 

tion.’ 

rce Code Being 
Generated’. 

c. In the drop down, select Toggle. 

Right click Today’s Time button (under the time label) a
Wizard. 

ate a new cus

Se ect the radio button ‘The value is d
click Next >. 

For the If statement: 

a. In the first drop down, select ‘Choose a func

b. Click the Function button.  A new window is opened ‘Sou

Select the ha

e. Select activated in the drop down next to the hand icon. 

f. In the Start section, choose “Enter a number or text” and enter “off” in the text box. 

g. In the End section, choose “Enter a number or text” and enter “on” in the text bo

h. Select OK. 

i. Select “Enter a numbe

In the Then drop down box, se

a. A new window has been created.  In the drop down box, select the function ‘set’. 

In the reference parameter drop down, select “Cho
e field. In 

number or text’, Enter time() in the text field. Click
compute must look like this at the end of this step. 

the hand icon, Click Current Tim
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6. Click Finish to exit the compute wizard. 

7. Select the Today’s Time button in the design view and then select the Source view. 

8. Remove quotations if any from the time() function. The final code should look like: 

<custom:onClick xfdl:compute="toggle(PAGE1.setIndex2.activated, 

 

'off', 'on') == '1' ? (set('PAGE1.FIELD1.value', time())) : 
''"></custom:onClick> 

9. To test the form click on the preview tab. Click the Today’s Time button. 
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3.12. 
 input. 

These actions are called events, and you can design your forms so that these events are 
trigger specific responses. For example, using the Event Model you could: 

ate a button that changes color when the user moves the mouse over it. 

• Create a “help” label that displays a different message depending on which field the 

 

 the following XFDL options: 

valu n changed.  A value is only re-
eva

activated ether or not an item, page, or form has been activated by the user. For 
exa l n the user clicks it. 

dirt

focu
fiel

focu

key

mou

prin

the

tha
in e

Events 
The XFDL Event Model tracks user actions, such as mouse movements and keyboard

captured and 

• Cre

• Create a form that submits when the user types F2 on the keyboard. 

user is filling out. 

• Create links to websites or other documents that change color once they have been
clicked. 

The Event Model relies on

e – Detects whether or not the value of an item has bee
luated when the focus leaves the field (i.e. tabbing out of the field). 

 - Detects wh
mp e, a button becomes activated whe

yflag - Records whether the form has been updated since the last save or submission. 

- Detects whether an item, page, or form currently has the input focused s. For example, a 
d

p

er the mouse pointer is currently positioned over an item or page. 

Instead, these options are created in m be thought of a tions - 
y v n 

the form is run. 

This me e 
t the ed 
very  will include an activated option. 

 has the focus when the cursor is in it. 

seditem - Specifies which item in the page currently has the focus. 

ress - Stores the last keystroke made by the user. 

seover - Detects wheth

ting - Indicates whether the form is currently printing. 

These are special options in the XFDL language that are never written out in XFDL forms. 
emory only, and can s virtual op

 ne er appear in the XFDL text for a form, but are always created and maintained whe

ans that you never have to add these options to your form. You can simply assum
y will exist when the form is in use. Furthermore, each option is automatically includ
 item that supports it. For example, every button item
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3.13. XFDL Exercise 7 – Using XFDL Events 
Events are an integral part of the XFDL language.  Events play a major role as they are often 
used by a compute to determine whether the compute is run or is ignored. 

This exercise will provide: 

• a brief overview of what each event does 

• step by step instructions to implement the XFDL events 

• examples of using the events found within XFDL 

Workplace Forms Designer 2.6 is required for this exercise. 

 

1. Open Workplace Forms Designer 2.6 

a. Start > Program Files > Workplace Forms Designer 2.6 – Designer 

2. Switch to the Resource Perspective and open XFDL_Ex07_XFDLEvents.xfdl from the 
TrainingExercises_XFDL project in the Navigator View. 

Dirty Flag 

whether the form has been updated since the 
last save or submission.  If the user attempts to close the form when the dirtyflag is set to on, 

look 
sim

HAS 
form HAS NOT been 

modified...yet.'"></value> 

1. Right click LABEL2 (under the dirtyflag label) and select Wizards > Compute Wizard 

2. At ‘Property to Set’ select value from the popup. 

3. Select the radio button ‘The value is determined by a decision (If/Then/Else)’ and then 
click Next >. 

4. For the If statement: 

a. In the first popup, select ‘Choose an item on the form.’ 

b. Click the hand icon.  In the Outline View, expand the globalpage and select Form 
Global 

The dirtyflag is a global variable that records 

the user will first be prompted to save their changes. 

In this exercise, the compute wizard will be used, but the code view of the compute will 
ilar to the compute below. 

<value compute="global.global.dirtyflag == 'on'  ? 'The form 
been modified.' : 'The 
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c. In the Compute Wizard Dialog, a new drop down menu will appear with the default of 

5. At this point, the Source Code Being Generated should look like this: 

global.global.dirtyflag == 'on' ? ('') : '' 

6. 
the wn and select ‘Enter a number or text.’ 

7. The p down should contain ‘Enter a number or text’. If this is not the case click 
ber or text.’ 

Activated 

Specifies whether an item, page or form is currently activated by the user or not.  The 
activated event is usually associated when using a compute toggle within a button.  The 
activated option is also used with actions, cells, combo boxes, popups, page global and form 
global items. 

activated.  Click the drop down and select ‘dirty flag’. 

d. On the last drop down on the ‘If’ line select ‘on’ 

 
The ‘Then’ drop down should contain ‘Enter a number or text’. If this is not the case click 

arrow on the drop do

a. In the field below, type The form HAS been modified. 

 ‘Else’ dro
the arrow on the drop down and select ‘Enter a num

a. In the field below, type The form HAS NOT been modified…yet. 

8. Your compute wizard should look like the screen shot below. 

 

9. Select Finish 

10. Select the preview tab to test your form. 
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In this exercise, you will create a custom compute that will notify when the item has been 
activated by throwing a viewer messageBox with an appropriate message.  We will be 

<custom:onClick xfdl:compute=" 
== '1'  

 ? viewer.messageBox('You just activated/clicked the button!', 

 : '' "></custom:onClick> 

ct Wizards > Compute Wizard 

. Select the button Create Custom Option  

 into Option Name: onClick, then select Ok. 

4. ’ and then 
click Next >. 

b. 

5. At this point, the Source Code Being Generated should look like this: 

toggle(PAGE1.BUTTON1.activated, 'off', 'on') == '1' ? ('') : '' 
 

6. n. 

7. A new window has been created.  In the drop down box, select the function 
‘viewer.messageBox’ 

creating the custom compute using the compute wizard.  The code view of our compute will 
look like the compute below: 

 toggle(activated, 'off', 'on') 

        'activated event')  

 
1. Right click BUTTON1 (under the activated label) and sele

2

3. Use the namespace custom and input

Select the radio button ‘The value is determined by a decision (If/Then/Else)

a. For the If statement: 

i. In the first drop down, select ‘Choose a function.’ 

In the drop down, select Toggle. 

ion under references, select “Choose an item on the form’, 
Select the hand icon, Click BUTTON1 and click Finish. 

in the start parameter and enter the value off. 

ii. Click the Function button.  A new window is opened ‘Source Code Being 
Generated’. 

c. In the Parameters sect

d. Select Activated in the drop down next to the hand icon. 

e. Select “Enter a number or text’ 

f. Select “Enter a number or text’ in the end parameter and enter the value on. 

g. Select OK. 

h. Select “Enter a number or text’ in the 2nd If drop down and enter the value of 1. 

In the Then drop down box, select ‘Choose a function.’ And select the Function butto
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8. 
valu

9. number or text’ and enter the value 
activated event. 

10. In the messagetype parameter drop down, select “Enter a number or text’ and enter the 

12. In the Else drop down box, select ‘Enter a number or text.’ And leave the value empty. 

13. Your compute wizard should look like the screen shot below. 

 

14. Select Finish. 

5. Select the preview tab to test your form. 

 I 

ouse pointer is currently over an item or page.  
When the event occurs, XFDL can indicate this event by changing the color of the item or by 

 different value. 

ng the 

ompute=" 

In the message parameter drop down, select ‘Enter a number or text’ and enter the 
e You just activated/clicked the button! 

In the caption parameter drop down, select “Enter a 

value 0. 

11. Select OK. 

1

Mouseover – Part

The mouseover event specifies whether the m

displaying a

Our first example, we will create a mouse over event within the value tag of an item usi
compute wizard.  The end compute should look like this: 

<value c
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 toggle(mouseover, 'off', 'on') == '1'  
 ? 'Congratulations!'  
 : 'Mouse over me!' ">Mouse over me!</value> 
 

 

k. Select “Enter a number or text’ in the 2nd If drop down and enter the value of 1. 

At this point, the Source Code Being Generated should look like this: 

toggle(PAGE1.FIELD3.mouseover, 'off', 'on') == '1' ? ('') : '' 

5. Open the Then drop down box and select ‘Enter a number or text.’ 

a. In the field below, type  

Open the Else drop down box and select ‘Enter a number or text.’ 

1. Right click FIELD3 (under the mouseover label) and select Wizards > Compute Wizard 

2. l

3. 

 For the If statement: 

i. In the first drop down, select ‘Choose a function.’ 

ii. Click the Function button.  A new window appears called ‘Source Code 

c. In the Parameters section under references, select ‘Choose an item on the form’,  

d. Select the hand icon 

e. Click FIELD3 

f. Click Fi

xt to the hand icon. 

i. Select ‘Enter a number or text’ in the end parameter and enter the value on. 

j. Select OK. 

4. 

. 

Se ect value in the drop down. 

Select the radio button ‘The value is determined by a decision (If/Then/Else)’ and then 
click Next >. 

a.

Being Generated’. 

b. In the drop down, select Toggle. 

nished. 

g. Select mouseover in the drop down ne

h. Select ‘Enter a number or text’ in the start parameter and enter the value off. 

 

Congratulations!

6
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a. In the field below, type Mouse over me! 

7. Your compute wizard should look like the screen shot below. 

8. Select Finish. 

9. Select the preview tab to test your form. 

Mouseover – Part II 

Our next example, we will create a mouse over event with the bgcolor tag of an item using 
the compute wizard.  The end compute should look like this: 

<bgcolor compute=" 
 toggle(mouseover, 'off', 'on') == '1'  
 ? '#408080' : '#FFFF80' ">#FFFF80</bgcolor>  
 

EL1 (under FIELD3) and select Wizards > Compute Wizard 

utton ‘The value is determined by a decision (If/Then/Else)’ and then 
click Next >. 

i. In the first drop down, select ‘Choose a function.’ 

 is opened called ‘Source Code 
Being Generated’. 

1. Right click LAB

2. Select bgcolor in the drop down. 

3. Select the radio b

a. For the If statement: 

ii. Click the Function button.  A new window
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b. In the drop down, select Toggle.  

 n item on the form’, 

4. 

5. 

6. 

w, type #FFFF80 

7.  should look like the screen shot below: 

 

c. In the Parameters section under reference, select ‘Choose a
Select the hand icon, Click LABEL1 and click Finish. 

d. Select mouseover in the drop down next to the hand icon. 

e. Under start (optional), select ‘Enter a number or text’ and enter the value off. 

g. Select OK. 

h. Select ‘Enter a number or text’ in the 2nd If drop down and enter the value of 1. 

At this point, the Source Code Being Generated should look like this: 

toggle(PAGE1.LABEL1.mouseover, 'off', 'on') == '1' ? ('') : '' 

elect ‘Enter a number or text.’ 

n box and select ‘Enter a number or text.’ 

f. Under end (optional), select ‘Enter a number or text’ and enter the value on. 

 
Open the ‘Then’ drop down box and s

a. In the field below, type #408080 

Open the ‘Else’ drop dow

a. In the field belo

Your compute wizard
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8. e

Focus

Focu

Sel ct Finish. 

9. Select the preview tab to test your form. 

editem 

seditem specifies which item in the page currently has the focus. 

In LABEL12 the final compute will look like this:  

<before compute="global.focuseditem">FIELD1</before> 
 

Create the before tag 

1. Highlighting LABEL12 

Hold down the Ctrl button and select another item (FIELD1) 

Right click LABEL12 and select Relative Align > Relatively Align Before 

a. LABEL12 should now be positioned before FIELD1, as shown below. 

2. 

3. 

 

Mod  ify the before tag 

4. Highlight LABEL12 

5. In the Properties Tab, expand itemlocation, Location List and before. 

6. Highlight Ref1 and select the compute function          button. 

dd a new row under Ref1 called compute a. This will a
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7. to the attribute and hit enter. 

8. 

Keypress 

Con
exe .  
Note that when a field has focus, only the F1-12 keys will activate the message box.  We will 
be u

te="(global.global.keypress != '')  
? viewer.messageBox('You pressed the ' +. global.global.keypress 

 
1. 

3. e etermined by a decision (If/Then/Else)’ and then 
click Next >. 

a. For the If statement: 

i. In the first drop down, select ‘Choose an item on the form.’ 

ii. Click the hand icon.  In the Outline tab, expand the globalpage and select 
Form Global. 

b. A new drop down menu has appeared with the default of activated.  Select 
‘keypress’. 

c.

d. 

4.  look like this: 

 
5. In ’ And select the Function button. 

a. ct the function 

b. oose an item on the form.’ 

c. 

d. ct Form Global. 

Enter the value global.focuseditem in

Select the Preview tab to test your form. 

tains the last keystroke made by the user in the focused item, page, or form.  In this 
rcise, keypress will be used to activate a message box when the page/form has focus

sing the following compute in the value tag of LABEL11. 

<value compu

+. ' key.', 'Keypress Event', ‘Keypress Event’)  
: 'Press a key...'">Press a key...</value> 

Right click LABEL11 (Press a key… label) and select Wizards > Compute Wizard 

2. Select value in the drop down. 

Sel ct the radio button ‘The value is d

 Select != (not equal to) in the drop down. 

Leave the final If dropdown field empty. 

At this point, the Source Code Being Generated should

global.global.keypress != '' ? ('') : '' 

the Then drop down box, select ‘Choose a function.

A new window has been created.  In the drop down box, sele
‘viewer.messageBox’ 

In the message parameter drop down, select ‘Ch

Click the hand icon. 

In the Outline tab, expand the globalpage and sele
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e. Select keypress in the drop down next to the hand icon. 

select ‘Enter a number or text’ and enter the 
value Keypress Event. 

ber or text’ and enter 
the value Keypress Event. 

h. Select OK. 

6. e value Press a 

w should look like the screen capture below. 

 

7. Select Finish. 

8. Highlight LABEL11. 

9. Select the Source tab. 

10. Edit the first parameter in viewer.messageBox.  Change the parameter to ‘You pressed 
the ‘ +. global.global.keypress +. ‘ key.’ 

11. Select the Preview tab to test your form. 

f. In the caption parameter drop down, 

g. In the messagetype parameter drop down, select ‘Enter a num

In the Else drop down box, select ‘Enter a number or text.’ And enter th
key… . 

a. The compute windo



  Understanding XFDL   87 

Focused 

Specifies whether an item, page, or form currently has the input’s focus.   The exercise will 
highlight all text when the FIELD4 gains focus.  A custom compute will be used and the 

 will look similar to the following code: 

1. 

2. 

3. 

4. 

b. 

c. 

d. 

f. Select ‘Enter a number or text’ in the end parameter and enter the value on. 

g. Select OK. 

n and enter the value of 1. 

toggle(PAGE1.FIELD4.focused, 'off', 'on') == '1' ? ('') : '' 
 

6. In h

en created.  In the drop down box, select the function 
‘viewer.setCursor’ 

source code

<custom:onFocus xfdl:compute=" 
 toggle(focused, 'off', 'on') == '1'  
 ? viewer.setCursor('0', strlen(value))  
 : ''"></custom:onFocus> 
 
Right click FIELD4  and select Wizards > Compute Wizard 

Select the button Create Custom Option  

Use the namespace custom and input into Option Name: onFocus, then select OK. 

Select the radio button ‘The value is determined by a decision (If/Then/Else)’ and then 

i. In the first drop down, select ‘Choose a function.’ 

ii. Click the Function button.  A new window is opened called ‘Source Code 

In th

In the Parameters section under reference, select ‘Choose an item on the form’, 

Select focused in the drop down next to the hand icon. 

e. Select ‘Enter a number or text’ in the start parameter and enter the value off. 

click Next >. 

a. For the If statement: 

Being Generated’. 

e drop down, select Toggle. 

Select the hand icon, Click FIELD4 and click Finished. 

h. Select “Enter a number or text’ in the 2nd If drop dow

5. At this point, the Source Code Being Generated should look like this: 

t e Then drop down box, select ‘Choose a function.’ And select the Function button. 

a. A new window has be
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b. In the start value parameter drop down, select ‘Enter a number or text.’ Enter the 
value 0. 

c. er drop down, select ‘Enter a number or text’ and enter the 
value 1. 

d. 

7.  down box, select ‘Enter a number or text.’ And leave the value empty. 

 

 

9. Select Finish. 

10. Highlight FIELD4. 

11. Select the Source tab. 

12. Edit the second parameter in viewer.setCursor.  Change the parameter to strlen(value) 

13. 

Value reflects the contents of an item.  In this exercise, when tabbing out of FIELD5, a 
message box will popup and display the value of the field.  The compute will look similar to 
this; 

In the end value paramet

Select OK. 

In the Else drop

8. Your compute wizard should not look like the screen shot below: 

Select the Preview tab to test your form. 

Value 
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<custom:onChange xfdl:compute=" 

e change event')  
 : ''"></custom:onChange> 

1. izard 

2. 

3. e the namespace custom and input into Option Name: onChange, then select OK. 

4. Select the radio button ‘The value is determined by a decision (If/Then/Else)’ and then 

ii. Click the Function button.  A new window is opened called ‘Source Code 
ted’. 

b. In th

c. In th ’ 

d. Select the hand icon 

e. Click FIELD5 

f. 

 toggle(value) == '1'  
 ? viewer.messageBox('You just changed the fields value to 
&quot;' +. value +. '&quot;', 'valu

 
Right click FIELD5  and select Wizards > Compute W

Select the button Create Custom Option  

Us

click Next >. 

a. For the If statement: 

i. In the first drop down, select ‘Choose a function.’ 

Being Genera

e drop down, select Toggle 

e Parameters section under references, select ‘Choose an item on the form

Click Finished 

g. Select value in the drop down next to the hand icon 

h. Leave the start parameter empty 

i. Leave the end parameter empty 

j. Select OK 

 

’ 

x’ 

b. In the message parameter drop down, select ‘Choose an item on the form’ 

k. Select ‘Enter a number or text’ in the 2nd If drop down and enter the value of ‘1

5. At this point, the Source Code Being Generated should look like this: 

toggle(PAGE1.FIELD5.value) == '1' ? ('') : '' 
 

6. In the Then drop down box, select ‘Choose a function.’ And select the Function button. 

a. A new window has been created.  In the drop down box, select the function 
‘viewer.messageBo
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c. Click the hand icon.  The form canvas will be brought to the forefront. 

d. Select FIELD5.  If after clicking the field the compute dialog does not come back then 

e. In the drop down next to the hand icon, select value. 

f. In the caption parameter drop down, select ‘Enter a number or text’ and enter the 

ber or text’ and enter 
the value change event. 

h. Select OK. 

7. In the Else drop down box, select ‘Enter a number or text.’ and leave the value empty. 

8. Your compute wizard should not look like the screen shot below: 

 

9. Select Finish. 

10. Highlight FIELD5. 

11. Select the Source tab. 

 

elect the Preview tab to test your form. 

click Finished (located in the top left corner). 

value change event. 

g. In the messagetype parameter drop down, select ‘Enter a num

12. Edit the first parameter in viewer.messageBox.  Change the parameter to 'You just
changed the fields value to &quot;' +. value +. '&quot;' 

13. S
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3.14. Cu
Becaus is possible to create your own “custom” elements.  
Any le d a 
cus tion to your form. 
The tions: 

3.14.1

stor aybe used in multiple places within an application.  Variables can be used 
in mathematical calculations, string concatenation, or data extraction (i.e. placing a repeated 
valu  referenced).  Since XFDL is a programming language it also 
has a variable construct.  Variables in XFDL are “custom” XML elements created in a 

th

W

c

The are 
dynamically determining.  For example computes that determine an item’s visibility, active 

utes cannot be 
placed inside the option that they manipulate.  If you are dynamically determining the value of 
a fie n. 

in that instance of the form the compute is “over-written.”  In cases where the item’s value is 
rea value 
option). emain editable and support a compute then it must be placed 
with

stom Options 
e XFDL is an XML document it 

 e ment that is created by the user that is not part of the XFDL schema is considere
tom option.  Custom options allow you to add application specific informa
re are two reasons for creating custom op

• Creating re-usable variables 

• Containing computes 

. Creating Re-Usable Variables 
Nearly every programming language has a variable construct.  Variables are useful for 

ing data that m

e in a variable that can be

“custom” nam  can create any elements 
at you wan

An example of a variable is an element created in the default custom namespace, that is 
defined  the Designer, to keep track of a row count that 
increments as rows are added to a duplicating section. 

<custom:rowCount>5</custom:rowCount> 

An example of a compute that references this variable is: 

<label sid=”rowCount_lbl”> 
te=“‘There are’ +. custom:rowCount + ‘ rows.’” 

 
h stom:rowCount” within a compute the Viewer will 

first retrieve the value of the custom option, which is ‘5’, and then continue evaluating the 
om te  value of the label to “There are 5 rows”. 

3.14.2. Creating Containers for Computes 

espace.  Once your namespace has been created you
t and these elements can be used as re-usable variables. 

when you create an XFDL form in

 

 <value compu
</label> 

en you reference the custom option “cu

pu .  The above compute will set the

re are times when it makes sense that your computes exist within the option that they 

state or required status are perfect candidates.  However sometimes comp

ld then your compute must be placed outside of the value optio

When text is entered into a field, the text takes precedence over any compute that may exist; 

d-only the original rules apply (it is appropriate for the compute to exist within the 
  But when a field must r

in a custom option that serves as a container. 
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The l d by 1.07.   

 , value * ‘1.07’) : ‘’”> 
</custom:setValue> 

If th o
the field  removed. 

An m
specific he most common exam mpute 
that performs an action when a button is clicked: 

<custom:onClick xfdl:compute=” 

 
 and should be placed 

inside of a custom option. 

3.14.3. Exercise - Creating a Custom Option in the Designer 
Custom Options can be added to any form item 
through the Properties View.  Open the Properties 
View; make sure that the Advanced Properties are 
active by selecting the down arrow and Show 
Advanced Properties.  

 

1. Expand the Miscellaneous category, select 
the value of the Custom Options property and 
press the add button. 

2. Expand Custom Options > Custom Options 
and now you can set the properties of the 
custom option that you just added. 

a. The Value is the content of the custom 
option 

ame is the option name (i.e. 
<localName></localName>) 

c. The Prefix refers to the namespace that the custom option will belong to; all custom 
igned a namespace.  By default you will be able to select either 

the custom or designer namespace. 

n which can be built using the 
compute wizard.  Select the value of the compute property and a “…” button will 

d. 

 fol owing compute will set the value of the field to its current value multiplie

<custom:setValue xfdl:compute=” 
toggle(value) == ‘1’ ? set(‘value’

 
is c mpute was created in the <value> option then as soon as the user entered text in 

 the compute would be

exa ple of another compute that requires a container is when the compute is not 
ally changing an option.  T ple of this is creating a co

 toggle(activated, ‘off’, ‘on’) == ‘1’ ? ‘set(...)’ : ‘’” 

The above compute does not necessarily operate on a specific option

b. The Local N

options must be ass

d. The compute property contains a conditional expressio

appear that opens the compute wizar
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4. oncepts 
4.1. 

4.2. Ov v
XFD ompasses presentation, logic and data management.  

rm that does take practice.  Unfortunately the 
esigne ore complex forms requires a deeper 

t 

 

• The reader will be able to create a form that contains a dynamically duplicating 

4.3. 
4.3.1. Wh

Cod pletion, also known as content assist, is a functio

pos process. In 
Cod
pro

The Designer will only list the options that can legally be added 

Advanced XFDL C
Audience 
This section is geared toward applying some of the concepts learned in “Understanding 
XFDL”.  

er iew 
L is a rich language that enc

Building dynamic forms is somewhat of an art fo
D r is still in its infancy and building the m
understanding of how XFDL works.  In the future we hope the Designer will abstract tha
complexity but until then we must explore deeper into XFDL. 

The objectives of this module are: 

• The reader will be able to use the Source View to write XFDL code; leveraging
content assist and other tools. 

section (i.e. pages or items).  

Working with the Source View 
at is Code Completion? 
e com n 

that interprets what is being entered and provides a list of 
sible options to help expedite the manual coding 

 Vie ew if I enter an open angle bracket then the editor 
wing: vides the follo

to the current item. As you continue to type the list will 
automatically be reduced only displaying the options that still 
meet that criteria. 

 

If the code completion tool does not appear or it disappears for 
any reason it can be re-opened by using the default key 
sequence of ctrl + space bar. 
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4.3.2. 

4.3.3. 

What is folding text? 

Click to collapse 

Click to expand 

 

What do the marks

text 

Hover over 
collapsed 
arrow to see 
the collapsed 

 on the left indicate? (That appear when editing) 

 

Marks denote 
the ope
closing tag

Current line is 
highlighted ning and 

s 
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Rev

Code V
change de editor. Hovering over 
the marker will display the line before it was changed. If you want to revert back to the 
original text, right-click the colored mark and choose Revert Line. 

 

4.3.4. What are Bookmarks? 
For information about the Bookmarks View please refer to the Eclipse help, which can be 
found by selecting Help > Help Contents from the File menu and entering “bookmarks” as 
the search criteria. 

4.3.5. Validating Your Code 
This function in the Source View will validate your XFDL.  

4.3.6. Check if code is well formed 
This function in the Source View will check your code to insure that it is well formed. Any 
errors in format will be flagged and displayed in the Problem View.  

  

erting text back to previous value 

iew keeps track of lines as they are changing, before the document is saved. The 
s are indicated by colored marks on the left margin of the co

Value was changed from 120 
to 250; select Revert Line and 
it will go back to 120. 
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4.4. Duplication 
Sometimes you won't know how much information users need to enter into a form, and 
therefore don't know how large to make a form.  Paper form designers know that users can 
write in the margins or on the back of a form, or even attach additional pages, but electronic 
form designers don't have that luxury.  However, if you have a form that requires users to 
enter a variable amount of information, such as an accident report or a bibliography, you can 
create a small form that dynamically generates new pages or items as needed, instead of 
creating a large form with many pages or tables.  This can be done using the duplicate 
function.  

The duplicate function can duplicate items and pages.  If you use it to duplicate items, it 
automatically duplicates the item's options and arguments.  If you use it to duplicate pages, it 
automatically duplicates every item and option on the page. 

Note: If you are thinking about duplicating an option…don’t… you should use the set 
function rather than the duplicate function to duplicate options.  If the option that you 
are setting does not exist then it will create it. 

The duplicate function is described by 6 properties or parameters: 

1. A reference to the form element that you want to duplicate. 

2. The type of element referenced in parameter 1 (i.e. page, item, or option). 

3. A reference to the form element that will anchor the newly duplicated element (using 
relative positioning) in the form's build order. 

4. The type of element referenced in parameter 3. 

5. The relation of the new item to the anchor item. 

• Valid choices are append_child, after_sibling, and before_sibling. 

6. The name of the new form element. 

The following code sample shows how to create a simple duplicate function: 

duplicate('TEMPLATE_PAGE', 'page', 
 'TEMPLATE_PAGE', 'page','before_sibling', 
 'PAGE') 
 

Duplicate functions are usually contained within computes that are triggered by a user’s 
action, and are therefore often partnered with set and toggle functions, as shown below: 

<custom:on_activated xfdl:compute=” &#xA; 
 toggle(activated, 'off', 'on') == '1' &#xA; 
 ? (set('custom:page_count', custom:page_count + '1') &#xA; 

+. duplicate('TEMPLATE_PAGE', 'page', 'TEMPLATE_PAGE', 
'page', 'before_sibling',  
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'PAGE' +. custom:page_co
+. set('PAGE' +. custom:

unt) &#xA; 
page_count +. 

geNumber_LABEL.custom:myPage_num', page_count)) &#xA; 
 : ''”> 

'.pa

</custom:on_activated> 
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4.5. Page Duplication 
You can use the duplicate function to duplicate entire pages. This allows the user to add an 
unknown or infinite number of pages to the form. This is generally done by creating a 
template of the page you want to duplicate. A template page is a page that the user can’t 
access and is only used as a source for duplication. Since you typically don’t allow the user to 
access th its items remain blank. This means that you won’t have to clear 
any user information from the page after it is duplicated. 

When du you usually want to place each page one after another so that the 
newest page has the highest page number. Your form will run faster if you place the new 
pages before a static (non-duplicated) page, such as your template page, rather than placing 
each new page after the last duplicated page. It requires more work to evaluate the SID of 
the last duplicated page than it does to evaluate a static page SID. 

The template page should have a Next Page and Previous Page buttons, so that users can 
navigate through all the newly duplicated pages. However, you should configure the Next 
Page butt bled if the next page is the template page. 

Both the t and the last page of the form usually contain an Add Page button. 
This butto age duplication when it is clicked. You can add custom options to 
this button  store dynamic information, such as how many pages has been added to the 
form. You can then reference this information to display a running page total to the user. 

Note: You can simplify page navigation by using relative page tags in the code of the 

e template page, 

plicating a page, 

on to be disa

emplate page 
n triggers the p
 that

Next Page and Previous Page buttons, instead of setting their url option. The relative 
page tags are global.pagenext and global.pageprevious. 
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4.6. ng Form Pages 

2. Create a new form file 

a. Select your project, right-click and select New > Ne

b. Select your project as the parent folder and enter a plication”), 
then click Finish 

c. The Designer should automatically switch to the Designer Perspective and open the 
file. 

3. Create the first page of the form as shown below. In the Properties View, change the 
SID to “page_1”. 

 

 

s in the form.  In the 
Properties View, change the SID to “template”. 

 

 

 

 

 

 

XFDL Exercise 8 – Duplicati
1. Open Workplace Forms Designer 2.6 

a. Start > Program Files > Workplace Forms Designer 2.6 – Designer 

w Workplace Form 

 filename (i.e. “PageDu

 

 

 

 

 

4. Create a template page which will be copied to create new page
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a. The template page has a previous page button which is not present on the first p
Pages can only be added from the first page and hence the template page does not 
have an Add Page button. Note that the Next Page and Previous Page buttons are o
the type pagedone. 

5. On PAGE1 modify the Next Page button so that it is only active after a new page has 
been added to the form. Ensure that the Next Page button does not take the user to
templa

age. 

f 

 the 
te page.  

 

b.  

 

 

c. Add the condition global.pagenext == template.global, notice that both fields are of 

 the SID of the next available page. Use 

f’ and else to ‘on’. 

a. Right click on the button and select Wizards > Compute Wizard.  

 

Change the value to active and click on ‘The value is determined by a decision’. Click
next. 

 

 

 

 

 

kind Enter a number or text. 

d. The built in option global.pagenext contains
this in a compute on the active option. 

e. Set then to ‘of
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f. Click Finish. 

g. Go back into the compute wizard, select active from the “Property To Set” popup 
then select the radio button “The value is set by a manually created formula” and 
remove the single quotes around global.pagenext. 

 

6. Repeat the above step for the Next Page button on the template page. 

7. Select the “Add Page” button and open the Compute Wizard. 

a. Press the “Create Custom Option” button.  Create an option in the custom 
namespace called “page_count.” It will be used to keep track of the current number 
of form pages. 

b. And click OK 
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c. The custom option has been created, but we don’t want to create a formula for it so 
tead we want to set the custom option’s value to 1. 

b. In the If t toggles on the 

c. Select toggle from the function call popup. 

d. Select Choose an item on the form and click the button with the hand.  This will 
bring the form into the foreground, select the Add Button (the compute wizard should 
come back into focus but if it doesn’t then press the finished button in the top left-
hand corner). 

e. Select activated from the popup.  Set the start and end parameters to Enter a 
number or text with values of off and on respectively. 

 

 

 

f. tion 

 

just click Cancel.  Ins

d. Select the Add Button and open the Source View, enter ‘1’ as the value of the 
page_count option. 

8. Press the “Create Custom Option” button a second time and create an option in the 
custom namespace called “on_activated.” It will contain the compute that triggers the 
duplication.  Click OK. 

 

 

 

 

 

 

a. Select “The value is determined by a decision” and click Next >. 

section of the compute we are going to create a formula tha
activated status of the Add Page button.  Select Choose a Function from the 
popup.  And press the Function button. 

 In the Then section of the compute select Choose a function and click the Func
button.  Select Duplicate from the Function Call popup. 
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ter the SID of the template 
page template in the field below it. 

h. Select a number or text from the type popup and enter “page” in the field below it. 

 

 

 

 

w 

k. the 
field below it. 

 

 

l. Select a number or text from the newName popup and enter “PAGE_” in the field 
below it. 

 

9. After the page has been duplicated we need to increment the variable that contains the 
number of pages. Select the Add Button and Click on the Source Tab to open the Source 

 

        'page_'+.custom:page_count))  
  : ''"></custom:on_activated> 
 

g. Select a number or text from the reference popup and en

i. Select a number or text from the newReference popup and enter the SID of the 
template page template in the field below it. 

 Select a number or text from the location popup and enter “before_sibling” in 

j. Select a number or text from the newType popup and enter “page” in the field belo
it. 

 

 

 

View and change the on_activated toggle as follows: 

<custom:on_activated xfdl:compute=" 
toggle(page_1.BUTTON1.activated,'off','on') == '1'  

 ? set('custom:page_count', custom:page_count + '1')  
 +. duplicate('template', 'page',  
        'template', 'page', 'before_sibling',  
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10. Create a custom option called 
myPage_num in LABEL1 on both page_1 

and
the 
crea ustom 
name

 

just click Cancel.  Instead we want to se
label and open the Source View, enter ‘1

b. The value of this label must be set to the current page number which is stored in 

lue to read 

LABEL1.custom:myPage_num +. ' of ' +. 
page_1.BUTTON1.custom:page_count 
 

On the final form, this would read as ‘2 of 23’, where the user is on the second page 
and there are 23 pages in total. 

 

 

 

 

11. As each pag
(BUTTO ge 
the on_a

<custom:on_activated xfdl:compute=" 
 toggle(page_1.BUTTON1.activated,'off','on') == '1'  
 ? (set('custom:page_count', custom:page_count + '1')  

and the template page.  Select the label 
 open the compute wizard.  Click on 
Create a Custom Option button and 
te the option in the c
space.  Click OK in the custom 

option dialog. 

a. The custom option has been created, but we don’t want to create a formula for it so 
t the custom option’s value to 1.  Select the 
’ as the value of the myPage_num option. 

custom:myPage_num. Right click on the label and go to the compute wizard. Change 
the va

 

e gets created we want to store the current page number 
N1.custom:page_count) in the myPage_num custom option of the label. Chan
ctivated toggle in BUTTON1 as follows: 
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 +. duplicate('template', 'page', 'template', 'page',  
        'before_sibling', 'page_'+.custom:page_count)  
 +. set('page_' +. custom:page_count +.  
      '.LABEL1.custom:myPage_num',custom:page_count))  
 : ''"></custom:on_activated> 
 

2. One last thing to add in the toggle is to set the url of the next page in the sequence. 
Change the toggle to the following 

<custom:on_activated xfdl:compute=" 
 toggle(page_1.BUTTON1.activated,'off','on') == '1'  
 ? (set('page_' +. custom:page_count +. '.BUTTON2.url', 

 '#page_' +. (custom:page_count + '1') +. '.global')  
t('custom:page_count', custom:page_count + '1')  

  duplicate('template', 'page', 'template', 'page',  
       'before_sibling', 'page_'+.custom:page_count)  
 et('page_' +. custom:page_count +.  
      '.LABEL1.custom:myPage_num',custom:page_count))  

 
Where BUTTON2 is the sid of the “Next Page” button on each page. 

13. To set the Previous Page Button on each page we need to just change th te 
page. Open the compute wizard for the Previous Page button and change the value of 
the  

 

 

 

 

 

1

 
 +.se

+.
 
+. s

 : ''"></custom:on_active> 

e templa

url field as follows:
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14. Now preview the form and try pressing the Add Page button. To test the code that we just 
added, add some pages and navigate back and forth. 
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4.7. orking with the Outline View  
4.7.1. Wh

The Ou
that displays all the objects that make up 
the form. All of the items are also 
disp
that the
referred to as the “Build Order.”  

When an item is selected in the Outline 
View it is also selected in the Design View. 
If an object has children (i.e. Page, etc.) 
then it can be expanded and collapsed like 
a folder in a file explorer. 

The Build Order is important for a few 
reasons

 Wh isplayed 
in front of the other objects. 

 When positioning items relatively, an item cannot refer to an object that comes after it in 
the Build Order. 

 The default Tab Order is defined by the Outline View or Build Order. The Tab Order 
defines how the cursor will move through the form’s input items when the user presses 
the “tab” key.  

4.7.2. How D
The order of items in the Outline View can be rearranged quickly and easily. Select the item 
to m
Order. As you drag the item a black line will appear to indicate where it will be placed. 

4.7.3. Ho
The Outline View can be opened from the Eclipse File Menu, select Window > Show View > 
Other. In the dialog that appears, expand Basic select Outline and click OK. 

4.7.4. What Is Filter On Visible? 
Filter on Visible is an option in the Outline View, when it is turned on then only the currently 
selected item and its children will be displayed in the Design View.  

4.7.5. Copy/ g Objects in the Outline View 
The Outline View supports the Cut, Copy and Paste operations. The operations can be 

ccessed by using the standard keyboard shortcuts or by using the right-click menu. When 
asting into the Outline View the object will always be appended to the end. 

W
at is the Outline View? 

tline View is a hierarchical structure 

layed from top to bottom in the order 
y were created. This is also 

: 

en items overlap in the Design View, the last item in the Build Order will be d

o I Re-arrange the Build Order? 

ove, click and hold the left mouse button and drag the item to its new place in the Build 

w Do I Open the Outline View? 

Pastin

a
p
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The Designer will automatically insure that items have unique sids by either appending a 
number to the item’s name or incrementing it if one already exists. 

4.7.6. Expanding/Collapsing View 
If an ob ildren (i.e. Page, etc.) then it can be expanded and collapsed like a folder 
in a file explorer. There are several different methods of performing these operations: 

 se the buttons provided in the Outline View toolbar. 

 Use the “+” and “-” buttons next to the item in the Outline View. 

 
se and expand the selections 

respectively). 

4.7.7. Page 
Wh page in the 
Out s have been provided as quick 
nav

ject has ch

U

Use the arrow keys to navigate the Outline View (i.e. the up and down arrows move up 
and down the list, while the left and right arrows collap

Navigating 
ile designing

 Design View. Two button
 a form, switching pages is done in the Outline View. Selecting a 

line View displays it in the
igational tools to cycle through the pages of the form.   
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4.8. Relative Alignment 
here are two ways of aligning items within XFDL; absolute and relative.  Items that are 

positioned absolutely will have an <itemlocation> that contains the x and y coordinates of 
e top-left corner. 

<field sid="FIELD1"> 
 <itemlocation> 
  <x>153</x> 
  <y>89</y> 
 </itemlocation> 
 ... 
</field> 
 

ems that are positioned relatively will define a relationship to another form item.  The field 
defined below will be positioned directly beneath “FIELD1”, where the left edges are aligned 

 <itemlocation> 

Rel
pos mining it 
dyn  when 
the  XFDL). 

T

th

It

and there is a 4-pixel space between the items. 

<field sid="FIELD2"> 

  <below>FIELD1</below> 
 </itemlocation> 
 ... 
</field> 
 

rm items.  Since relative ative alignment is essential when dynamically duplicating fo
on g riti in elies on knowing the SID of the reference object you need a way of deter

iewer options that are only presentamically.  Therefore we have provided some V
ewer is running (they are not serialized in theVi

Dynamic 
Options 

Description 

pa  current page)ge xt Returns the sid of the next page in the Build Order (from thene

pa  current geprevious Returns the sid of the previous page in the Build Order (from the
page). 

ite e rrent item) mn xt Returns the sid of the next item in the Build Order (from the cu

ite rmp evious Returns the sid of the previous page in the Build Order (from the current 
item) 

 

The e, let’s re-write the 
above example but this time use the itemprevious dynamic option. 

<field sid="FIELD2"> 

se options are evaluated from the object that contains them.  Therefor

 



110  Advanced XFDL Concepts    

 <itemlocation> 
  <below compute=“itemprevious”></below> 
 </itemlocation> 
 ... 
</field> 
 

ince FIELD1 is the object that comes before FIELD2 in the build order the “itemprevious” 
ption will evaluate to “FIELD1”.  

S
o
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4.9. XFDL Exercise 9 – Implementing Relative Alignment 
emonstrate how to create a dynamic form using relative 

nd Date item locations to relative 
the synopsis field to expand and shrink based on the 

 the scrollbar off if the Synopsis field does not have the 

ge the build order 

however with relative positioning it is essential. 

elationship 

the build order then 

references to relative we must first make sure that the 
e 

The purpose of this example is to d
alignment. 

In this exercise we will: 

• convert Synopsis, Author, Publisher a
• create a compute that will force 

amount of text entered 
• create a compute that will turn

focus 
• learn to use the Outline View to chan
 
 
 
 
 

 

 
 

 
 

 

 
 
 

 

 

 

 

 

When using absolute positioning the order is irrelevant, 

Items that are relatively positioned define a r
and a reference item.  The reference item must 
precede the item being aligned.  If an item tries to 
reference an item that follows it in 
the item location will be ignored. 

Since we are going to change all of the absolute item 

build order is correct.  We need to make sure that all th
items in the Outline View are in the same order as they 
appear on the canvas. 
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Note: The Outline View is created as items are created, so if you know that you are 
building a form with relative alignment if you build it in order then you will save 
yourself the following steps. 

1. Open the exercise form file 

a. Open Workplace Forms Designer 2.6 

i. Start > Program Files > Workplace Forms Designer 2.6 > Designer 

b. Switch to the Resource Perspective and open XFDL_Ex09_RelativePositioning.xfd 

2. d order of the items in the Outline View. 

art of the “Designer” Perspective, but if it is closed it can be 
opened by selecting Window > Show View > Other… from the Designer menu.  A 

pearance (i.e. Synopsis, Author, 
Publisher and Date).  Only one item in the Outline View can be adjusted at a time. 
Select the item, click (and hold) the left mouse button and drag it to a new location; 
as you drag an item a black line will appear indicating where the item would be 
placed if you released your left-mouse button. 

c. Select the “publisher_FIELD”, click (and hold) the left-mouse button and drag it 
between the “summary_FIELD” and “pubDate_FIELD” then release the mouse 
button. 

 

 

 

 

 

 

 

d. Follow the same steps and move the “author_FIELD” so that it is between 
“summary_FIELD” and “publisher_FIELD”. 

3. Use the Alignment tools to convert the Synopsis, Author, Publisher and Date items to 
relative positioning.  On the canvas: 

from the TrainingExercises_XFDL project in the Navigator View. 

Modify the buil

a. The Outline View is p

new dialog will appear, expand Basic, select Outline and click OK. 

b. Rearrange the items so that they are in order of ap
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a. Select the Author field, hold down “ctrl” and select the Synopsis field.   Point your 
mouse at one of the selected objects, right-click and select Relative Align > 

ublisher field, hold down “ctrl” and select the Author field.  Point your 
mouse at one of the selected objects, right-click and select Relative Align > 

old down “ctrl” and select the Publisher field Point your mouse 
 objects, right-click and select Relative Align > Relatively 

4. putes that force the Synopsis field to grow and shrink. 

ng 
the down arrow in Properties View and 

d Properties. 

 advanced properties have been 
activated, create three custom options.  To 

 ea  that was created 
ange their “Local Name” to 

“my_height”, “set_myHeight” and 
_heigh

“min_height a default value of “2”.

d. The “my_h d “min_height” 
options are variables that will be 

d to con
m n

synopsis fie

 that will do most of the 
 the synopsis field changes we want to measure the height 

Relatively Align Below. 

b. Select the P

Relatively Align Below. 

c. Select the Date field, h
at one of the selected
Align After. 

Add the com

a. Select the Synopsis field; in the Properties 
View make sure that the Advanced Properties 
are visible.  They can be activated by clicki

selecting Show Advance

 

 

b. Once the

create a custom option, in the “Advanced” 
category there is an option called “Customs”, 
select “Custom Option” from the drop down 
and press the add button three times. 

c. Expand
and ch

ch custom item

“min t”, respectively. Give 
 

eight” an

use tain the current and 
minimu umber of lines for the 

ld. 

 

 

e. The “custom:set_myHeight” option will contain the compute
work.  When the value of
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of its contents. We do this by using the Viewer Function called 
r_Functions.pdf for 

set_myHeight custom option, 
e value of the compute option 

g. Select the value is determined by a decision (If/Then/Else) and click Next >. 

 

 

h. Create a toggle compute that monitors the value 
of the Synopsis field.  Select Choose a function 
from the popup and press the Function button. 

i. In the new dialog, select toggle from the function call popup.  Then select Choose an 
item on the form from the reference parameter popup and click on the button with 
the hand.  This will bring the form canvas to the foreground, select the synopsis field 
and click Finished.  The Designer will return to the Function dialog and fill in the 
remaining popup and field. 

 

 

 

 

 

k. Select == (equal to) from the center popup and type “1” in the last field of the “If” 
section. 

l. Select Choose a function in the popup of the Then section and click the Function 
button. 

m. Choose set from the function popup. 

n. As the reference parameter, select Choose an item on the form from the popup, 
click the hand button and select the Synopsis field.  Select “custom:my_height” from 
the popup. 

viewer.measureHeight().  Please reference pg 29 of Viewe
more information. 

f. Expand the 
click in th
and click the “…” button that appears.  

 

j. Click OK to go back to the main function dialog and complete the formula: 



  Advanced XFDL Concepts  115 

o. As the value, select Enter a number or text from the popup and enter 
“viewer.measureHeight(‘chars’, ‘’, ‘never’)”. 

ss OK to exit the Source Code Being Generated dialog. 

exit the Compute Wizard dialog. 

te wizard again; 

): 

? (set(' PAGE1.summary_FIELD.custom:my_height', 
 "viewer.measureHeight('chars', '', 'never')")) 
: '' 
 

. The next step is to add a compute that will make the height of the Synopsis field 
dependent on the variables “my_height” and “min_height”. If “my_height” is greater 
than “min_height” we want “my_height” to be used as the height of the field, otherwise 
“min_height” will be used.  Remember that we set the default value of “min_height” to 
'2'.  

a. Select the Synopsis field, in the 
Properties View expand the 
Advanced category and then 
expand the size option.  Highlight 
the value of the height attribute and 
press the “add the compute 
attribute” button. 

b. Create a compute that sets the y coordinate of the field’s size option to equal either 
the minimum height or actual height values.  

ater than the height of the field then make the 
field height equal to the height of the text, otherwise set the field height to the 

nd press the “…” button.  Create a 
 click Next. 

 

p. Pre

q. Press Finish to 

r. Within the custom option press the “…” button to bring up the compu
your formula should look like the following if it doesn’t please fix it now (you must 
remove the single quotation marks surrounding the viewer.measureHeight function

toggle(PAGE1.summary_FIELD.value) == '1' 

5

c. In English, if the height of the text is gre

minimum, which is 2. 

d. Highlight the value of the compute attribute a
compute that is determined by a decision and
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a. In the If section, Choose an item on the form and select the Synop
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a. In the If section, Choose an item on the form and select the Synopsis field, then 

b. rm and select the Synopsis field, 
then select custom:my_height from the following popup.  In the Else section, 

c. The compute should look like the following:  

PAGE1.summary_FIELD.custom:my_height > 
PAGE1.summary_FIELD.custom:min_height ? 
(PAGE1.summary_FIELD.custom:my_height) : 
PAGE1.summary_FIELD.custom:min_height 
 

6. Preview the form. 

7. Enter several lines of text into the Synopsis field (more than 5), tab out of the field and 
watch the field grow! 

. Now to complete the third part of the exercise that will only show the scrollbars for the 
Synopsis field when it has the “focus” (the cursor is inside of the field). 

a. r when the focus leaves the field. 

c. When the field is “focused” the scrollvert option should contain “always”, otherwise 
“never”. 

select custom:my_height from the following popup.  Select > (greater than) from 
the middle popup and then choose an item on the form and select the Synopsis 
field, then select custom:min_height from the following popup 

In the Then section, Choose an item on the fo

Choose an item on the form and select the Synopsis field, then select 
custom:min_height from the following popup. 

8

Create a compute that disables the scrollba

b. In the Properties View, select the Scrollvert option and press the add a compute 
attribute button. 
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d. Press the “…” button in the compute attribute and create a formula that is 
determined by a decision and click Next.  Select Choose an item on the fo
select focused, set the ce

rm and 
nter popup to equal to and place the text “on” in the last 

field of the If section. 

e. 

f. Your compute should look like the following: 

PAG
 

9. Preview your form again and this time you will notice that the scrollbar only appears when 

In the then field enter “always” and in the else field enter “never”. 

E1.summary_FIELD.focused == 'on' ? ('always') : 'never' 

the cursor is in the Synopsis field. 
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4.10. Item D
If a form ction, you may want to allow the user to dynamically add rows to 
the table  functionality requires the form to include a template. In this 
cas

Usually ame page as the table. It can be either the first 
row of t  be invisible so that it is only used for duplication purposes. Both 
techniques require about the same amount of work. If you use the first row of the table as the 

mplate row, you must clear the value options of all the newly duplicated items so that they 
do not contain the user input from the first row. If you hide the template row, the value options 
of th  on. 

Setting up a template row of items requires a lot of configuration. You must configure the 
template row using relative positioning and relative item tags, so that duplicated items don’t 
overlap the original items. Relative item tags include itemnext and itemprevious. Once you 
have co low or after the previous item in the 
build or  in the correct position. Additionally, if 
you pla  must position them using relative 
position ve down as the user adds new rows. 

As u
way to a
build or
duplicat

Other w tion include adding a row every time the user leaves the 
st item of the last row. This method guarantees that there will always be an empty row. 

uplication 
 contains a ‘table’ se
. As with pages, this

e, the template must be a row of items. 

, you place the template row on the s
he table, or

te

e duplicated items will be blank, but you must remember to set their visible options to

nfigured each template item so that it is placed be
der, any new rows are automatically displayed
ce any items below this table section, you
ing so that they mo

in d plicating pages, it is usually best to use an Add Row button to provide the user with a 
dd additional rows. If you place this button below the template row within the form’s 

der, you can use it as a static item in the build order, allowing you to place newly 
ed items before it in the build order. 

ays of triggering row duplica
la
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4.11. XF
1. Open Workplace Forms Designer 2.6 

a. Start > Program Files > Workplace Forms Designer 2.6 – Designer 

2. Create a new form file 

a. 

b. 

ctive and open the 

3. eate the first page of the form as shown below. Create two buttons, one to add a row 
Name’, 

 

4. Now ill be 
sub ow 
butt

a. Add a field to the canvas and place it below 

b. In the Properties View change its sid to “name1”.  

5. The ts are 
crea relative alignment to work properly.  We are going to 
position the name field relatively with the item that precedes it in the build order. 

a. elatively Align Below 
Previous Item. You will notice that the name field is now sitting directly beneath the 
Gender label. 

DL Exercise 10 –Duplicating Rows of Items 

Select your project, right-click and select New > New Workplace Form 

Select your project as the parent folder and enter a filename (i.e. “ItemDuplication”), 
then click Finish 

g. The Designer should automatically switch to the Designer Perspe
file. 

Cr
and the second one to delete the last row. Create three labels with values set to ‘
‘Date of Birth’ and ‘Gender’. 

 

 

 we will create the first row which w
sequently duplicated when the Add R
on is pressed.  

the Name label. 

 build order is very important in this exercise.  We must insure that all the objec
ted in the proper order for our 

Right click on the name1 field and select Relative Align > R
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6. Now we want to align the name field with the Name label. 

a. Left click on name1, hold the control key and left click on the name label to select 
both the items. 

b. Right click on one of the two selected items and click on Absolute Align > 
Absolutely Align Left to Left. 

 

 

 

 

 

 

7. pup with a sid of “gender1” and label of 
“Please Select”. 

8. . 

9. fter Previous Item.  

10. ft click on dob1, hold the control key and left click on the date of birth label to select 
ht click on the label with both items still selected and click on 

11. gender1 and select Relatively Align > After Previous Item.  

  
 on Absolute 

13. 

a. an from the name label to the gender label. 

14. l e Relatively Align > Below Previous Item

 

Create another field with a sid of “dob1” and a po

Add two cells ‘Male’ and ‘Female’ in the gender popup

Right click on dob1 and select Relatively Align > A

Le
both the items. Rig
Absolute Align > Absolutely Align Left to Left. 

Right click on 

12. Left click on dob1, hold the control key and left click on the gender label to select both
the items. Right click on the label with both items still selected and click
Align > Absolutely Align Left to Left. 

Create a horizontal line with sid ‘Line’ below the fields. 

The line should sp

Se ect the lin  and select . 
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15. lect both 
the 
Alig

16. In the Outline View move the line so it is located under gender1 in the build order. 

 

 

  

17. to store the current row count. 

a. Right click on the form and select Wizards > Compute wizard. 

b. Press the Create a Custom Option button and create a new custom option in the 
custom namespace called row_count. 

c. Click OK and then Cancel. 

d. Open the Source View and modify the value of the custom option so that it contains 
the number 1. 

 

 

 

 

 

18. Now we need to implement the add row button. 

a. Right click on the button and select Wizards > Compute Wizard. 

b. Create a new custom option called 
onclick. 

c. Click OK to get back to the main 
compute dialog. 

 

 

 

Left click on the line, hold the control key and left click on the name label to se
items. Right click on the label with both items still selected and click on Absolute 
n > Absolutely Align Left to Left. 

We need a custom option variable 
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d. Now we add a toggle using the if/then/else decision. 

p 

 

 

 

 

 

g. In the Then case, choose ‘Choose a Function’ from the drop down list. 

i.  Click on the Function button and choose ‘duplicate’ from the drop down list.  

ii. Choose ‘Enter a number or text’ from the reference drop down and enter 
‘name1’ in the field.  

iii. Choose item from the type drop down list.  

iv. Choose ‘Enter a number or text’ from the newReference drop down and 
enter ‘Line’ in the field. 

v.  Choose item from the newtype drop down list.  

i. Select ‘The value is determined by a decision (If/Then/Else) 

ii. Click Next >. 

e. In the If section of the compute, select Choose a 
Function from the popup.  

i. Click on the Function button and choose 
toggle in the next screen. 

 

f. Select ‘Choose an item on the form’ in the reference. 

i. Click the Add button using the hand tool and choose ‘activated’ from the dro
down list. 

ii. Choose ‘Enter a number or text’ in the start and end drop downs. 

iii. Enter ‘off’ in the start field and ‘on’ in the end field. 

iv. Press OK. 
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vi. Choose before_sibling from the location drop down list.  

or text’ from the newName drop down and enter 
‘name’ in the field. 

viii.  Press OK and then press Finish to exit the compute wizard. 

 

 

 

 

 

 

r custom:onclick manually. We need to 
r items and also increase the row count by one each time Add Row 

code view. 

? (duplicate('name1', 'item', 'Line', 'item',  

: '
 
to 

toggle(PAGE1.BUTTON1.activated, 'off', 'on') == '1'  
? (set(‘global.custom:row_count’, global.custom:row_count + ‘1’) 
+. duplicate('name1', 'item', 'Line', 'item',  
     'before_sibling', 'name' +. global.custom:row_count)  
+. duplicate('dob1', 'item', 'Line', 'item',  
     'before_sibling', 'dob' +. global.custom:row_count)  

vii. Choose ‘Enter a number 

 

 

 

 

 

h. Go back into the wizard to edit the formula fo
duplicate the othe
is pressed. You may also change the toggle in the 

i. Change the formula from 

toggle(PAGE1.BUTTON1.activated, 'off', 'on') == '1'  

     'before_sibling', 'name'))  
' 
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+. duplicate('gender1', 'item', 'Line', 'item',  
     'before_sibling',  

: '

j. essing the Add Row button. To test the code that we 
o the fields and then press the Add Row button. 

 

 

 

 

 

 

Note: In the example above, the first row is copied to create subsequent rows and 

     'gender' +. global.custom:row_count) )  
' 

 
Now preview the form and try pr
just added, enter some data int

hence any data entered in the first row will be copied over into the new cells. To get 
around this, you can delete the contents of a field after it is created or create invisible 
fields on the form to copy from. Once the invisible fields are duplicated, the <visible> 
option can be set to true. 

 

k. To clear the duplicated fields after they are created add appropriate set functions in 

code view. 

') == '1'  
? (set('global.custom:row_count', global.custom:row_count + '1') 

ibling',  

. global.custom:row_count)  
+. duplicate('gender1', 'item', 'Line', 'item',  

     'gender' +. global.custom:row_count)  

om:row_count +. '.value' ,'') )  

the toggle. We will set the value of the newly created fields to ‘’. You may change the 
toggle in the 

toggle(PAGE1.BUTTON1.activated, 'off', 'on

+. duplicate('name1', 'item', 'Line', 'item', 'before_s
     'name' +. global.custom:row_count)  
+. duplicate('dob1', 'item', 'Line', 'item',  

   'before_sibling', 'dob' +

     'before_sibling',  

+. set('name' +. global.custom:row_count +. '.value' ,'')  
+. set('dob' +. global.custom:row_count +. '.value' ,'')  
+. set('gender' +. global.cust
: '' 
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Deleting the Last Row 

19. We must now use the destroy function just like we used the duplicate function and then 
decrement the global.custom:row_count by one each time a row is deleted. 

Right click the Delete Row button and o20. pen the Compute Wizard. Create a new custom 

 

21. Now ecision.  

ined by a decision 
(If/Then/Else) and click Next >. 

22. Cho  in the If. 

a. Click on the ‘Function’ button and choose toggle in 
the next screen. 

23. Select ‘Choose an item on the form’ in the reference.  

a. Click the Delete Row button using the hand tool and choose ‘activated’ from the drop 
down list.  

i. Choose ‘Enter a number or text’ in the start and end drop downs.  

ii. Enter ‘off’ in the start field and ‘on’ in the end field.  

iii. Press OK. 

 

 

 

 

option called onclick. 

 

 

 

 

 we add a toggle using the if/then/else d

a. Select ‘The value is determ

ose ‘Function’
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24. In the Then case, choose ‘Choose a Function’ from the drop down list. 

a. Click on the Function button and choose ‘destroy’ from the drop down list. 

b. Choose umber or text’ from the reference drop down and enter ‘name’ in 
the field. 

c. Choose item from the type drop down list. 

d. Click OK to exit the Then case. 

e. Click Finish to exit the compute wizard. 

 

 

25. Go back into the wizard to edit the formula for custom:onclick manually. We need to 
duplicate
pressed.  

26. Change the ew from 

toggle(PAGE1.BUTTON2.activated, 'off', 'on') == '1'  
? (destroy('name', 'item'))  
: '' 
 

 

 ‘Enter a n

 

 

 

 

 the other items and also increase the row count by one each time Add Row is 

 formula in the code vi
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to 

toggle(PAGE1.BUTTON2.activated, 'off', 'on') == '1'  
? (de
+. destroy('dob' +. global.custom:row_count, 'item')  
+. destroy('gender' +. global.custom:row_count, 'item')  
+. set(‘global.custom:row_count’, global.custom:row_count – ‘1’))  
: '' 
 

27. Now preview the form and try pressing the Add Row button. To test the code that we just 
added, add some rows to the form and press the Delete Row button. 

8. The last step is insuring that the user is not able to delete the first row, since it is being 
used as the reference for adding new rows.  We must set the active of the Delete Button 
to off if the row count is equal to 1. 

9. Select the Delete Button, right-click and open the compute wizard. 

0. Select active from the property popup, select The value is determined by a decision 
and click Next. 

1. In the If section select Choose an item on the form, click the hand button and click 
somewhere on canvas (this selects the page global).   

32. In the middle popup find custom:row_count and then enter the number 1 in the last field 
of the If section. 

3. In the Then section enter off and on in the else section. 

4. Click Finish. 

35. Preview the form, the Delete button should be inactive until a new row is added. 

stroy('name' +. global.custom:row_count, 'item')  

2

2

3

3

3

3
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4.12. XF ive Checkboxes 
1. 

signer 

2. a new form file 

b. , then 
click Finish 

c. The Designer should automatically switch to the Designer Perspective and open the 
file.  Create a label ‘Mutually Exclusive Checkboxes’ with a font size of 12 pts. 

. Create a label with the value ‘Please 
select your favorite Italian dish:’.  

4. Create four checkboxes under the 
label. Label the Checkboxes ‘Pizza’, 
‘Lasagna’, ‘Spaghetti’ and ‘Calazone’. 
The final form should look as follows 
in the design view. 

5. To m
che
that
cha  the value of the other checkboxes to ‘off’. 

6. et us create the toggle for the first checkbox. Right click on Pizza checkbox and click on 
Wizards > Compute Wizard. 

7. Clic

8. Clic

9. t. 

 

 

 

 

 

DL Exercise 11 – Creating Mutually Exclus
Open Workplace Forms Designer 2.6 

a. Start > Program Files > Workplace Forms Designer 2.6 – De

Create 

a. Select your project, right-click and select New > New Workplace Form 

Select your project as the parent folder and enter a filename (i.e. “Checkboxes”)

3

ake the checkboxes mutually exclusive so that the users can turn on only one 
ckbox at a time, we have to use the toggle and the set functions. The basic idea being 
 we toggle on the value of the checkboxes and when the value of a checkbox 
nges from ‘off’ to ‘on’, we set

L

k on Create Custom Option, call the new option valueOff. 

k OK.  

Check ‘the value is determined by a decision(If/Then/Else)’ and click Nex
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10. Select ‘Choose a function’ from the If popup list and click on the Function button. 

11. Select toggle from the function popup list.  

a. Choose the Pizza checkbox using the hand tool for the reference.  

b. Select Enter a number or text from both the start and end drop down list.  

c. Enter ‘off’ as the start value and ‘off’ as the end value. 

 

d. Click OK to exit the toggle function and return to if/then/else window.  

e. Type 1 in the == (equal to) field.  

12. When the Pizza checkbox is switched from off to on, we want to set the value of the 
remaining checkboxes to off using the set function. Select Choose a function in the 
Then popup list and click on Function. 

a. Select set from the function popup list. In the reference field, select the ‘Lasagna’ 
checkbox.  

b. Select Enter a number or text in the value popup list and type off in the field.  

c. Value is the new value that will be assigned to CHECK2.value. You can leave the 
Type and Scheme options blank. 
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13. Click OK to exit the set function.  

t 

start of the code relevant to the pizza checkbox should be highlighted in the s de 
view. Now change the toggle  

from 

<check sid="CHECK1"> 
 <itemlocation> 
  <x>214</x> 
  <y>185</y> 
 </itemlocation> 
 <custom:valueOff xfdl:compute=" 
  toggle(PAGE1.CHECK1.value, 'off', 'on') == '' 
  ? set('PAGE1.CHECK2.value', 
  : ''"></custom:valueOff> 

to 

<ch

  <x>234</x> 

 </itemlocation> 
 <custom:valueOff xfdl:compute="        &#xA; 
   toggle(PAGE1.CHECK1.value, 'off', 'on') == '1' &#xA; 
   ? set('PAGE1.CHECK2.value', 'off')       &#xA; 

')      &#xA; 

   : 
</check> 
 

line 

14. Then click Finish to exit the if/then/else window. We still need to set the values of the las
two checkboxes to off. We can do that in the code view. 

15. Left click on Pizza checkbox and click on the Source tab at the bottom of the page. The 
ource co

     &#xA; 
&#xA; 

'off')      &#xA; 

</check>  

eck sid="CHECK1"> 
 <itemlocation> 

  <y>201</y> 

   +. set('PAGE1.CHECK3.value', 'off
   +. set('PAGE1.CHECK4.value', 'off')      &#xA; 

''"></custom:valueOff> 

Noti #xA; to break up a 
into multiple lines for readability purposes. 

You may test the partially implemented form at this stage.  

a. Preview the form and click on the Calazone checkbox.  

b. Now if you click on the Pizza checkbox the Calazone checkbox should automati
be unselected. 

 Follow steps 7 through 15 for the other three checkboxes. As a shortcut you may
custom option in each of the other checkboxes and then copy and paste the entire 

ce the use of +. to concatenate multiple statements and &

16. 

cally 

7.  create a 1
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 </itemlocation> 
<custom:valueOff2 xfdl:compute="      &#xA; 
 toggle(PAGE1.CHECK2.value, 'off', 'on') == '1'  &#xA; 

  ? (set('PAGE1.CHECK1.value', 'off')     &#xA; 
  +. set('PAGE1.CHECK3.value', 'off')     &#xA; 
  +. set('PAGE1.CHECK4.value', 'off'))     &#xA; 
  : ''"></custom:valueOff2> 

</check> 

compute. Then change the references within the set() statements. For example the 
complete code for the Lasagna checkbox should look like: 

<check sid="CHECK2"> 
 <itemlocation> 
  <x>102</x> 
  <y>134</y> 
  <alignt2t>CHECK1</alignt2t> 
  <offsetx>193</offsetx> 

 
 

 

 

 

 

 

 

Bonus Exercise 

Use custom options and the getReference function instead of toggle and set to make the 
checkboxes mutually exclusive. This approach is quite generic. 

1. 

.  

2. 

 <value>off</value> 
 <label>Lasagna</label> 

Firs we need to create a custom option in the Pizza checkbox called last_selected. This 
option will hold the sid of the currently checked checkbox. 

a. izza checkbox and select Wizards > Compute Wizard

b. Click on Create Custom Option button. 

c. Type last_selected as the Option Name. 

d. Click OK to return back to the compute wizard and then click Cancel to exit the 
compute wizard. 

Now we will give custom:last_select a default value.  

t, 

To do this right click on the p
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a. Left click on the Pizza checkbox. 

b. Select the Source view tab. 

ck to the design view. 

respective sid’s.  

izard. 

k on Create Custom Option button. 

Type my_id as the Option Name. 

d. Click to return back to the compute wizard and then click  to exit the 

stom:my_id xfdl:compute="getReference('', '', 'item')"></custom:my_id> 

4. Now we need to add a custom compute to the Pizza checkbox which will turn the last 
a 

5. To do so, right click Right click on the Pizza checkbox and select Wizards -> Compute 

b. Type my_id as the Option Name. 

ct This decision is determined 
by a decision (If/Then/Else). 

 go to (If/Then/Else) screen. 

nd click the Function button.  

ction window, 

c. Add the sid of the Pizza checkbox in between the custom:last_select tags. 

<custom:last_selected>PAGE1.CHECK1</custom:last_selected> 
d. Go ba

3. Each checkbox will also contain a custom option that holds their 

a. Right click on the Pizza checkbox and select Wizards > Compute W

b. Clic

c. 

OK Cancel
compute wizard. 

e. Select the Source View tab with the Pizza checkbox selected. 

f. Create a compute inside the custom:my_id option. 

g. <cu

h. Save the form and go back to the design view. 

selected checkbox to off and set the value of custom:last_selected to the sid of the Pizz
checkbox. 

Wizard. 

a. Click on Create Custom Option button. 

c. Click OK to return back to the compute wizard. Sele

d. Click Next to

e. Select Choose a function from the If drop down list a

f. In the Fun

i. Choose toggle from the drop down list.  
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ii. Select Choose an item on the form from the reference list and use the 
hand tool to select the Pizza checkbox.  Make sure that value is selected in 

e end drop 

 

 

 

 

 

g. Enter 

Select Enter a number or text in the value drop down list.  

eme options 
blank. 

 

the list next to the hand tool.  

iii. Select Enter a number of text in the start drop down list and th
down list.  

iv. Enter off in the start field and on in the end field. 

 

v. Click OK to return to the If/Then/Else window.  

1 in the field next to == (equal to) field. 

n. 

i. Choose set from the drop down list. 

o select the Pizza checkbox.  

h. We want to use the set function to set the last_select value to off. To do so, select 
choose a function from the then drop down list and click on the Function butto

ii. Use the hand tool t

iii. Choose custom:last_selected from the drop down list next to the hand tool.  

iv. 

v. Enter off in the value field. You may leave the type and the sch
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vi. Click OK to get back to the If/Then/Else window.  

i. Click Finish to exit the compute wizard. 

j. Now we will finish the rest of the compute in the Source view. Select the Pizza 
checkbox and left click on the Source tab. 

k. We only want to change the last_selected if the current checkbox was not the one in 

i. Note that custom:my_id contains the sid of the current checkbox.  

ii. Remove the single quotes from PAGE1.CHECK1.custom:last_selected.  

iii. Also note that last_selected contains the sid of the checkbox that needs to 
be turned off, hence we need to set the custom:last_selected.value to off 
instead of just setting custom:last_selected to off.  

<custom:radio_behaviour xfdl:compute=" 
 toggle(PAGE1.CHECK1.value, 'off', 'on') == '1' and  
   (CHECK1.custom:lastSelected != custom:my_id)  

’, off))  
 : ''"></custom:radio_behaviour> 

6. Finally, to complete the toggle, we need to set the sid of the current checkbox to 

ompute=" 
 toggle(PAGE1.CHECK1.value, 'off', 'on') == '1' and  

 GE1.CHECK1.custom:last_selected +. ‘. Value’, off) 
 +. set('CHECK1.custom:last_selected', custom:my_id))  

7. Now r code to all the checkboxes to complete the 
exercise. 

 

 

 

 

last_selected.  

 ? (set(PAGE1.CHECK1.custom:last_selected +. ‘. Value

 

custom:lastselected. Change the toggle as follows 

<custom:radio_behaviour xfdl:c

 (CHECK1.custom:lastSelected != custom:my_id)  
? (set(PA

 : ''"></custom:radio_behaviour> 
 

 copy the custom:radio_behaviou
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4.13.  

may erent users, or you may want a 
custom item to continue working after the form is signed. You can accomplish this with 

Sig ich form elements you want to sign. There are two kinds 
of signatu

•

Creating Signature Filters
Occasionally, you may find that you don’t want certain items or options to be signed. You 

 wish to create different form sections to be signed by diff

signature filters. 

nature filters allow you to set wh
re filters: 

 Omit filters let you specify the form elements you don’t want to sign, and 
e form is signed. This filter guarantees that everything in 

ept the form elements that you choose. 

 you specify the form elements you want to sign, leaving the 
. This filter only secures the form elements that you choose, 

st use a keep filter, use it in conjunction 

omit – 
ensures that the rest of th
the form is secured, exc

• keep – Keep filters let
rest of the form unsigned
leaving the remainder of the form unprotected. 

Note: Omit filters provide greater security than keep filters. It is good practice to use 
omit filters rather than keep filters. If you mu
with an omit filter. For example, you might want to omit the items in a “For office use 
only” section from a user’s signature, but you would secure the location and 
appearance of these items with a keep filter. 

Wo s it easy to create secure signature filters. It allows you to 
sele ant to omit from the signature, while automatically retaining 
item filter option is called signitemrefs. Signitemrefs allows you to 
spe ignature will omit or keep. For example, you might set the 
filte

The  custo  s rs.  
Cus

e, 
 from the signature. 

Options – Specifies the types of options that the signature will omit or keep. For 

• 

• 

rkplace Forms Designer make
ct specific items that you w
 position information. This 

cify individual items that the s
r to omit BUTTON1 on PAGE1. 

 Designer also provides an interface that assists you in creating m ignature filte
tom signature filters allow you to omit or keep specific form elements, such as: 

• Items – Specifies the types of items that the 
ht set the filter to omit all button items

signature will omit or keep. For exampl
you mig

• 
example, you might set the filter to omit all triggeritem options from the signature. 

Groups – Specifies one or more groups, as defined by the group option, that the 
uttons or cells belonging to 

that group, but does not filter list, popup, or combobox items. For example, if you had 
e filter to omit the State 

group, which would omit all cells in that group. 

Specifies one or more datagroups, as defined by the datagroup 
option, that the signature will either omit or keep. This filters data items belonging to 

signature will either omit or keep. This filters any radio b

a popup containing a cell for each State, you might set th

Data groups – 

that datagroup, but does not filter any action, button, or cell items. For example, if you 
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had an enclosure button containing references, you might set a filter to omit the 
References datagroup, which would omit all data items in that group. 

XFD , option, and page references. While these options are not 
curr gnatures while using the Designer, you can add these options 
in th indow: 

 that the signature will omit or keep. For 
ON1.value on PAGE1. 

e s r 

ae> 

For tion on creating digital signatures and their filters, see “Creating Signature 
uttons in XFDL

Workplace F s). 

L also allows you to filter item
ently available for custom si
e Designer’s Code View w

• signoptionrefs – Specifies individual options
it BUTTexample, you might set the filter to om

• signpagerefs – Specifies individual pages that th ignature will omit or keep. Fo
example, you might set the filter to omit PAGE1. The following code sample 
illustrates a signoptionrefs filter that omits a checkbox’s visible option: 

<signoptionrefs> 
<ae>omits</ae> 
<ae>PAGE1.accept_CHECKBOX.visible</
</signoptionrefs> 
 

 more informa
B ” and the XFDL Specification. These documents are available on the IBM 

orms Support web site (http://www.ibm.com/software/support/workplaceform



  Advanced XFDL Concepts  137 

4.14. XF  Signature Filters 
This exe ation form that contains three sections.  Currently, all 
three sections are mandatory and active at the same time. Modify this form so that the status 
of each  
form is first opened, Section I should be mandatory and active. When this section is complete 
and II is 
sign  ndatory and active. 

2.  XFDL_Ex12_SignatureFilters.xfd from 
n the Navigator View. 

Set

3. All t ns have been configured such that their Type is set to Signature.  

4. s 
from each signature button. 

a. Right click on Traveler Signature button and 

 

 

lumn. Click Next to go to the next step. 

DL Exercise 12 – Creating
rcise uses a Travel Authoriz

section is dependent on the previous section being signed. In other words, when the

 signed, Section II should become mandatory and active. Finally, when Section 
ed, Section III should become ma

1. Open Workplace Forms Designer 2.6 

a. Start > Program Files > Workplace Forms Designer 2.6 – Designer 

Switch to the Resource Perspective and open
the TrainingExercises_XFDL project i

ting up Signature Filters 

he signature butto

Since all the buttons only sign their respective sections, we need to omit other section

click on Wizards > Signature Wizards. 

b. Click on Parts of the form radio button and 
click Next. 

 

c. Click on Items to sign and click Next. 

 

 

d. Page1 should be under the Not Signed co
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e. Use
form. To

button. 

 

f. 

g. You el Info 
sect  

 

 

 

 

h. Choose your signature. We will choose Clickwrap for this example. Click Next. 

i. Enter a suitable Title for the Signature and a Prompt (Answer the following 
question?). Enter a Safeguard Question and provide a Default Answer. 

 

 

 

 the hand tool to select all the items under the Travel Request section of the 
 select multiple fields, hold down the “Ctrl” key and left-click the mouse 

Click Finished to return to the Signature Wizard. 

should have all the items under the Trav
ion marked to be signed. Click Next.  
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rap for this example. Click Next

ovide a Default Answer 

 

 

j. Click Finish to exit the signature wizard. 

5. Preview the form and test the signature. You should not be able to alter any items in the 
Travel Info 

6. Select the S

cts, press Finished to go back to 

. 

r

 

e. Click Finish

. Finally we want the finance rm. 

a. Right click on Finance Officer’s Signature button and click on Wizards > Signature 
Wizards. 

b. Click on The complete form radio button and click Next.  

c. Choose your signature. We will choose Clickwrap for this example. Click Next. 

d. Enter a suitable Title for the Signature and a Prompt (Answer the following 
question?). Enter a Safeguard Question and provide a Default Answer. 

section once the form is signed using the Traveller’s Signature button. 

upervisor's signature and repeat step 4. 

a. Once you have completed selecting all of the obje
the Filter dialog. Click Next. 

b. Check to make sure the desired items are covered under the signature. Click Next. 

c. Choose your signature. We will choose Clickw

d. Enter a suitable Title for the Signature and a Prompt (Answer the following 
question?). Enter a Safeguard Question and p

 

 

 

 

 to exit the Signature compute wizard. 

 officer's signature to sign the entire fo7
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e. Click Finish to exit the Signatur

 simulates a workflow, the implied order is from Employee to Supervisor to 
ce Officer. We should not be able to fill out the sections out of order and this is what we 

Right click the Supervisor’s Signature button and select Wizards > Compute Wizard. 

T

e compute wizard. 

Finan

1. 

2. Cha
(If/

 

 

 

 

 

 

 

 

 

3. Now we need to comp

a. he hand tool to 
select the Travel  in the drop down next to the 

b. Then in the middle po

c. 

d. 

f. 

 

Building Workflow by Setting Fields Inactive 

Because the form

are going to enforce by using a few simple computes. 

nge the property to active and click on The value is determined by a decision 
hen/Else) radio button. Click Next. 

lete the If/Then/Else block 

ers Signature button. Choose Signer

pup select == (is equal to). 

In the first If popup select Choose an item on the form and use t

hand tool. 

The last popup in the If section should be a number or text and the field below it 
should be empty. 

In the Then popup select off. 

e. In the Else popup select on. 

Press Finish to exit the Formula dialog. 
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4. Sel
“SIG

r. Do one section at a 

b. d select Wizards 

c. orm item. 
Click Next. 

 select the Traveler Signature button. Choose Active from the 

 

 

gn view. 

6. Rep

Conf

When we want the fields of that section to be 
mandato

1. .  

a. Set the Property to Mandatory and select The value is equal to another form item. 
Click Next >. 

b. Use the hand tool to select the Traveler Signature button. Choose Active from the 
popup list below the hand tool. 

 

 

 

ect the Finance Officer's signature and repeat steps 1-3. References to 
2_BUTTON” should be changed to “SIG3_BUTTON”. 

5. The next step is to Configure the Field and Labels’ Active State under each section. 

a. This step requires that we setup similar objects at the same time. So do the 
checkboxes together, the labels together and the fields togethe

Select an object (or more than one of the same type), right click an

time. 

> Compute Wizard.  

Set the Property to Active and select The value is equal to another f

d. Use the hand tool to
popup list below the hand tool.  

 

 

e. Click Finish to exit the compute wizard and return to the form in the desi

eat until all the fields of each section have been configured. 

igure the Field’s Mandatory State 

 the signature button of a section is active then 
ry. 

Select an object, right click and select Wizards > Compute Wizard
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c. Click Finish to exit the compute wizard and return to the form in the design view. 

2. Repeat until all the fields of each section has been configured. 
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4.15. XF
This exercise demonstrates how to implement a Web Service within a form.  This assumes 
that you already have a WSDL that can be used as the starting point.   

Prerequisites 

 This exercise requires that the student have access to the Internet. 

 This exercise is dependent on a Web Service that is not hosted by IBM and therefore its 
availability can not be guaranteed.  The service used in this exercise can be substituted 
for any other valid Web Service. 

Exercise 

1. Open Workplace Forms Designer 2.6 

a. Start > Program Files > Workplace Forms Designer 2.6 – Designer 

2. Create a ne
Traini

a. Select 

b. Select 

c. Enter XFDL_Ex13_Web Services.xfd as the file name 

f. Finish

3. Enclose the Web Service WSDL called XFDL_Ex13_spellcheck.wsdl that is included in 
the TrainingExercises_XFDL project. 

a. Open the Enclosures View and expand WSDL. 

b. Right-click on Web Services and select Enclose WSDL File. 

c. In the new dialog that appears, browse to the location of the 

at the 

. Add a label

a. Position an form as you like. 

b. The field will 

DL Exercise 13 – Implementing Web Services in XFDL 

T

w form, called XFDL_Ex13_Web Services.xfd, in the 
ngExercises_XFDL project. 

File > New > New Workplace Form 

rainingExercises_XFDL  as the parent folder 

d. Click Next 

e. Select Default Empty Form – XFDL 

Click  

XFDL_Ex13_spellcheck.wsdl file and click Open.   

d. In the Enclosures View if you expand Web Services you should now see th
WSDL has been added to the form. 

4 , a field and a button to the Designer Canvas. 

d layout are not crucial here.  Feel free to “dress up” the 

contain the word to spell check. 
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i. Change the label property of the field to ‘Enter a word to spell check’ 

c. The label will display the result of the Web Service. 

i. Change the value property of the label to ‘Web Service Result’ 

d. The button will trigger the call to the Web Service. 

i. Change the value property of the button to ‘Check Spelling’. 

5. When the button is pressed we want to call the Web Service and place the result into the 
mpute on the ‘activated’ state of the 

button). 

.   

ld be custom and the option name will be onClick. 

ted 

d. 

e. In the If popup select Choose a Function and click the Function button. 

i. Select toggle from the popup 

ii. Select Choose an item on the form as the reference and click the button 
with the hand. 

iii. Click the “Check Spelling” button and then click Finished. 

iv. Select activated from the popup that follows the button with the hand. 

t popup and enter off as the 

 

label.  (To accomplish this we will require a co

a. Right-click the button and select Wizards > Compute Wizard.  

b. We want to place this compute in a custom option

i. Click the Create Custom Option button. 

ii. The namespace shou

iii. Click OK.  

c. The Property to Set should already contain the custom option that you just crea
called onClick; if it doesn’t then select it from the popup. 

Select The value is determined by a decision and click Next >. 

v. Select Enter a number or text from the star
value 

vi. Select Enter a number or text from the end popup and enter on as the 
value 

vii. Click OK 

f. Make sure that == (equal to) is selected and then type 1 in the next field. 

g. In the Then popup select Choose a function and click the Function button.
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i. Select set from the function popup. 

ii. Select Choose an item on the form as the reference and click the button 
with the hand. 

v. Select Enter a number or text as the value and then enter 

h. Click Finish. 

i. The compute is pretty much complete but there is one change that must be made 
before it will work correctly.  When we entered the Web Service function name as a 
number or text the Designer surrounded it in single quotes; we must remove these 
quotes.   

i. Select the button, right-click and open the Compute Wizard again. 

ii. Select the custom:onClick property from the Property to Set popup 

iii. This time the compute can be seen in the field at the bottom of the dialog.  
Inside of that field remove the single quotes that surround the second 
parameter of the set function. 

toggle(PAGE1.BUTTON1.activated, 'off', 'on') == '1' ? 
(set('PAGE1.LABEL1.value', 
'GoogleSearchService_GoogleSearchPort.doSpellingSuggesti
on('1tnBlt5QFHLMq2jrDsaTUtk40yw/s6Fy',PAGE1.FIELD1.value

toggle(PAGE1.BUTTON1.activated, 'off', 'on') == '1' ? 

GoogleSearchService_GoogleSearchPort.doSpellingSuggestio
)

odifying the compute, click Finish. Click OK. 

he Web Service. Keep in mind that you must have 
st be active. This service is not 

maintained by IBM and is therefore not guaranteed to work at all times. 

iii. Click on the label and then click Finished 

iv. Select value from the popup that follows the button with the hand. 

GoogleSearchService_GoogleSearchPort.doSpellingSuggestion('1tnBlt
5QFHLMq2jrDsaTUtk40yw/s6Fy',PAGE1.FIELD1.value) as the value. 

vi. Click OK. 

)')) : '' 
 
becomes 
 

(set('PAGE1.LABEL1.value', 

n('1tnBlt5QFHLMq2jrDsaTUtk40yw/s6Fy',PAGE1.FIELD1.value
)) : '' 
 

iv. When you are done m

j. Now preview the form to test t
access to the internet and this Web Service mu
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i. In the field, type ‘allowes’ 

ii. Click the ‘Check Spelling’ button. 

iii. The label is updated to show the correct spelling, ‘allowed’. 
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5. Building Simple XForms Forms 
5.1. Au

ms that implement 
XForms.  Building simple XForms forms are primarily schema/instance driven; therefore the 
user should understand the basic structure of an XML instance.  This module will enable you 
to create a static form that uses XForms UI Controls. 

5.2. Overview 
A new blank XForms form can be created using the ‘Default Empty Form – XForms’ template 
provided in the Workplace Forms Designer.  If a different template is selected that does not 
have XForms support, the user will not have access to any XForms elements until XForms 
support has been enabled, and both a model and instance have been created. 

5.3. Adding XForms Support – Template vs. Enable 
XForms support is required if your form will use XML instances, schemas, or XForms.  There 
are two ways to Add XForms support to your XFDL forms: 

1. While creating a new form 

If you create your new form using the Default Empty Form – XForms template the Designer 
will automatically enable XForms.   

2. Modifying an existing XFDL form 

To enable XForms support for an existing 
form, open the XForms View, right click 
on the “No Model Exists” element and 
select “Add XForms Support”. 

Adding XForms Support, with either method, will create a default model that can be used to 
enclose XForms Instances. 

dience 
This section is intended to teach the reader how to create simple for
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5.4. Creating XForms Instances – Various Methods 
An XForms Instance is the mechanism 
that is used to embed arbitrary XML into a 
form. The instance data can be used to 

s, pre-populate fields with 

ections. 

inst  
instance from within the XForms View, 

he model element and select 
Create Instance. Once the instance is 

a

Inst chanisms 
that can be used to create an Instance: 

1. es not contain any children 

2.  current document  

3. 

4. 

Eac escribed below in further detail. Once you are finished creating your 
instance, continue on to section 5.5: “Creating XForms Objects”. 

 

5.4.1. Creating a new empty instance  
Cre ult data instance:  

> 
 <data> 

 
The use nual operations are provided; 
elem

Adding

 as a sibling.  

To a  
Element. A new element will be created beneath the selected element. If the parent already 
has existing elements. Siblings can only be 

store input value
data, or dynamically generate list 
sel

There are several different ways that an 
ance can be created. To create an

right-click t

cre ted the user must define its structure. 

ances can also be created in the Instance View. There are three different me

Creating a default instance that do

Generating an instance based on the items in the

Creating a new instance from a web service 

Creating an instance based on a schema file 

h procedure is d

ating a new instance will create the defa

<xforms:instance id="INSTANCE1" xmlns=""

 </data> 
</xforms:instance> 

r must then modify the instance manually. Several ma
ents can be added, renamed, given default values, given attributes or removed. 

 Elements 

Elements can either be added to the xml instance as children or

dd a child element to the instance select the parent element, right-click then choose Add 

children then the new child will be added after the 
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added before lement 
Before; a new element will be created before the one that was selected. 

Changing an Element’s Name 

Double-click the element, in the Instance View, to change its name; a field will appear 
allo ust not contain special characters 
(i.e. spaces, <, >, &, etc). 

Adding a Default Value to an Element 

If yo
crea element called “Text”; double-click this new element and enter the desired 
default value. 

Adding an Attribute to an Element 

If yo elect Add Attribute. This will 
create a “chil oth of these operations can be 
found in the right-click menu; they are Rename and Edit, respectively.  

Removing Elements 

Elements ca nce View in two ways: pressing the delete button 
and

5.4.2. Creati
If th l mirror the 
structure of the current form. The generated instance of a form that has one page and two 
field

<xforms:instance id="INSTANCE" xmlns=""> 
 <do
    <PA
     <FIELD1></FIELD1> 
      
    </PAGE1> 
   </d
</xfor

The operation u  sid of each object as the element name. Every form item is 
represented in the resulting instance. This instance shows the page as a parent element and 
each item o

 the selected element. Choose an item then right-click and select Insert E

wing the user to enter a name. Note: Element names m

u want to give the element a default value, right-click and select Add Text. This will 
te a sub-

u want to add an attribute to an element, right-click and s
d” that can be renamed and given a value. B

n be removed from the Insta
 selecting “Delete” from the right-click menu. 

ng an instance from the current form 
e form has already been created an instance can be generated that wil

s would appear as follows: 

cument> 
GE1> 

 <FIELD2></FIELD2> 

ocument> 
ms:instance> 

ses the

n the form page as a child element. 
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5.4.3. Creating a ice  
If a WSDL h  
an empty instan sed to store the request and response of a Web Service.  To 
create an instance from an enclosed WSDL, open the Instance View and click on the “Create 
Instance fro

5.4.4. Creating 
If a schema igner can create 
an empty instan
open the Instan

 new instance from a Web Serv
as been enclosed within a form then the Workplace Forms Designer can create

ce that can be u

m a WSDL” button. 

a new instance from a schema 
has been enclosed within a form then the Workplace Forms Des

ce that adheres to its rules. To create an instance from an enclosed schema, 
ce View and click on the “Create Instance from a Schema” button. 
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5.5. Creating 
XForms is a rmat of the data collection process from 
the interface. XForms defines UI Controls that generically define what type of input is 
expected an concerned 
about the presentation of the form, since its purpose is to provide business rules that can be 
implemented across multiple mediums; one of which is XFDL. XFDL “wraps” the XForms UI 
Controls providing finer control over the presentation layer of the form. 

The XForms drawer and items will only be available if the form contains a valid XForms 
model. For more details on creating an XForms model please refer to section 5.3 “Adding 
XForms Support”. For every XFDL item there is a corresponding XForms item; an XForms 
item is comprised of the original XFDL code and a corresponding XForms expression. For 
complete item definitions or specific implementation details please refer to IBM’s XFDL 2.6 
specification. 

 

Icon Item Description 

XForms Objects 
method of abstracting the rules and fo

d stores the received data into an XML instance. XForms is less 

 

 Action (Submit) An XFDL action that is linked to an XForms submission, 
and will submit the XForms data to a specified URL. 

 Action (Trigger) An XFDL action that executes one or more XForms actions 
when it is activated. 

 Button (Submit) A button that is linked to an XForms submission, and will 
submit the XForms data to a specified URL. 

 Button (Trigger) A button that executes one or more XForms actions when it 
is pressed. 

 Button (Upload) A button that allows the user to attach a file to the form. 

 Case A pane object that is used with the XForms Switch, only 
one case can be visible at a time. 

 Check (Input) A standard checkbox. 

 CheckGroup (Select) A control that allows check boxes to be grouped together 
and supports selecting multiple items. 

 CheckGroup 
(Select1) 

A control that allows check boxes to be grouped, but only 
one may be selected at a time. 

 Choice (Item) Allows user to add an item to a CheckGroup, RadioGroup, 
Popup, Combobox or List. 

 Combobox (Select1) A Combobox that only allows the user to select one item or 
type their own entry. 
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 Custom Item An item that exists in the “custom” namespace, used to 
contain a variable or compute. 

 Date Picker (Input) A date field with a button that opens a calendar. 

 Field (Input) A standard one line field. 

 Field (Secret) A standard field where all input appears as an asterisk. 

 Field (TextArea) A multi-line field. 

 Label (Output) A standard label. 

 List (Select) A list box that supports the selection of  multiple items. 

 List (Select1) A list that only supports selecting one item at a time. 

 Pane (Group) Creates a container that can be
objects together. 

 used to group multiple 

 Pane (Switch) The XForms control that allows multiple panes to overlap 
each other, only one pane is visible at a time. 

 Popup (Select1) A popup that only supports the selection of one item at a 
time. 

 RadioGroup A control that allows radio buttons to be grouped, but only 
(Select1) one may be selected at a time. 

A slider object that can be used to represent a range. 

A repeating section (table) that is generated from XML dat
in the XForms instance. 

 Slider (Range) 

 Table (Repeat) a 

 Table (Repeat) By A repeating section (table) that uses a wizard to help the 
Wizard user create their table. 

 

The process for creating an XForms item is the same as that for creating an XFDL item. 
Select the item you wish to create from the Design Palette and then click on the Design 
canvas. 

In addition to the original XFDL properties, XForms items have properties that are specific to 
XForms. The XForms properties can be found in the Properties View under the XForms 
category. 

For additional information regarding the XForms items please refer to the XFDL specification. 
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5.6. Creating Items from an XForms Instance 
Form items can be generated directly fro
items one at a time or grouped by parent el

5. Open the Instance View and expand th
instance so you can see all the
example

m a
e

 element
 the XML instance has a parent 

that contains several children. 

o cr
n 

e created (one for each child) grouped within a 
pane. 

 and drag the selected element onto the canvas.  
This will create a field for every child element contained within the selected element. 

Note: Items created using drag and drop from the Instance View now get created with 

n XML Instance.  You can choose to create 
ments.  If your form contains an XML Instance: 

e 
s.  In this 
element 

ent that 
eate.  If 
a single 
be stored in the instance.  If you select the 

6. Select a single element or a parent elem
contains all the items that you want t
you select the “lastName” element the
field will be created and the contents will 
“person” element then three fields will b

7. Click and hold the left-mouse button

corresponding labels.  The label sid is a concatenation of the field name, “_LABEL” 
ing with 1). and a unique number (an increment start
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5.7. 
One of the main differences between XFDL and XForms items is that the latter stores its data 

Forms item must be bound to an instance element.  Every 
XForms item has a “ref” attribute that defines the instance element where its data should be 

tely, 

ay be required to write a few of these on your own. 

the corresponding fields, then the next step is 
ce. 

ag it onto a form item to create a link between the two objects. 

e.  

nData. Once the instance has be
elements naming each one until we get to the one that we want.  

It is
be i ences to elements inside the instance. 
the e ta/person/name. 

5.7.1. Hig g
The quick tool that allows you to see if a rela
esta objects and the XML instance data

 or which items 
the time it takes to repair those mistakes.  This tool is located in t
Forms Designer. 

Highlight Objects With Binds  

Activating the button highlights all of the input items that have an 

Links to Data Model 

in an XML data instance.  Every X

stored.  The “ref” attribute uses an XPath statement to reference the instance.  Fortuna
the Designer will create simple versions of these statements for you, but as the complexity of 
your form increases you m

If your form already contains an instance and 
to “bind” them together so that when data is entered into an item it is stored in the instan
Open the Instance View, expand the instance, and locate the first element.  Select the 
element and dr

Let’s break down an example referenc

 

The first part of the reference is pointing to the proper instance, in
this case the instance id is perso

 important to note that 
fer

the first child element of an instance is 
ncluded in XPath re

ename lem nt is person/name not da

hlightin  Bound Items 
 Designer provides a 
blished between the form 

highlight objects with binds, highlight object without binds and hid
with a complex busy form can be challenging and  binds are an e
able to quickly determine which items have binds

<xforms:input 
  ref=“instance(‘personData’)/person/name”> 

 

</xforms:input> 

  <xforms:label></xforms:label> 
</xforms:value>   <xforms:value>
<instance id=“per
  <d

sonData”>
ata> 

   <person> 
     <name></name> 

  </data> 
</instance> 

   </person> 
 
en defined, we traverse the 

e root node. It should not 
Therefore, the reference for 

tionship has been 
.  This tool has three modes: 

  Working 

do not will greatly decrease 
he toolbar at the top of the 

associated XForms bind.   

stance(‘theInstanceID’), in

th

e bind highlighting.
asy thing to forget.  Being 
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Highlight Objects Missing Binds  

Activating the button a second time highlights all of the input items that do not have an 
associated XForms bind.  

Hide Bind Highlighting  

Activating the button a third time will turn off the bind

 

 highlighting. 
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5.8. XForms Exercise 1 – Build Simple XForms Forms 

you an opportunity to explore the 

 

 

1. Open Workplace Forms Designer 2.6 

a. > Program Files > Workplac  2.6 – Designer 

2. te a new p

a. File > New > Project 

b. The Simple Project should be selected (select it if it isn’t), then click Next 

ter a pro he “Proje
Finish 

3. Create a new form file 

lect you -click and s rkplace Form 

lect you t fol

c. Select the Default Empty Form – XForms template, then click Finish 

d. The Design matically ctive and open the 
file. 

up item to the form. 

1. d to create an xml instance and populate it 
ata. To create an xml instance click on the xml 

button on the Instance View as shown here. 

 

Now that we have discussed the basic 
XForms elements and how to bind 
them to instance data it is your turn!  
The purpose of this exercise is to give 

creation and modification of XForms 
items.  We will be creating the exact 
same form as in the XFDL module.  
This time we will be using XForms 
items instead of the traditional XFDL 
items. 

 

Start e Forms Designer

Cre roject  

c. ject name into t ct Name” field (i.e. “FormExamples”), then click 

a. r project, right elect New > New Wo

b. r project as the paren der and enter a filename (i.e. “XFormsPaneEx”) 

er should auto switch to the Designer Perspe

a

En

Se

Se

Add a pop

First we nee
with our d
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2. w Add an el ‘colors‘ to t

 

 

 

 

 

 

 

3. ements to the instance as e 
colors element.  

a. ame each of 3 child elements to

Add a value to each of the options.

i. Right click on the option element and choose 
“ad

ii. Add three option elements; ‘Red’, ‘Green’ and ‘Blue’. 

 

 

No ement called he instance as a child of the data element.  

 the children of th

 “option”. 

b.   

d text”. 

Next add 3 el

Ren
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4. To create a popup from a data instance, use the select1 c

ect1 control on the 

your Favorite Color?’ 

f the popup item. 

ontrol. The select1 control 
limits users to a single choice.  

Palette. 

l

c. Set the value of the label property to ‘What is 

o

 

 

 

 

 

5. Item
dynamic choices that are determined while the form is 

option

a. 
itemset control. This label is used to provide the 
choices for the list. Using a reference to the 
attributes of the <option> nodes, label creates and 
displays the list of choices that are displayed to the 
user. 

b. The value option indicates which options are 
selected. Value has one attribute called ref, which is 
the path to the instance node. 

 

c. Set the itemset > value > ref and itemset > label > ref to ‘.’ and the nodeset to 
instance('INSTANCE')/colors/option. 

i. The simplest method of setting the nodeset is to open the Instance View 

ii. Select one of the colors > option elements, right-click and choose Copy 
Reference. 

a. Left click on Popup (Select1) from the Standard Library on the 

b. Left click on the canvas to place the popup se
form. 

d. Expand the XForms control in the properties 

set allows you to create lists and groups that offer 

in use. Itemset has one attribute called Nodeset, which 
is the path to the group of nodes that provide the list 

s.  

The label option is a mandatory element of the 
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iii. In the Properti

 

es View, find the nodeset property and paste the copied 
reference into its value. 

 

 

 

7 . 

tance View 

_result element and drag it over top of th is will 
automatically set the Select1 > ref to the intended value. 

8. Preview the form. 

 

 

3. To create a list from a data instance, use the select1 or select 
imits users to a single choice.  

a. Left-click on List (Select1) from the Standard Library on the 
Palette.  

 

6. Add another node to the instance called color_result to store 
the result of the choice.  

 

 

. Set Select1 > ref to instance('INSTANCE')/color_result

a. To accomplish this task, open the Ins

b. Select the color e “color” popup.  Th

 

 

 

Add a list item to the form 

1. Create a child node called Italian to the xml instance created in step 
1.  

2. Create a child node under Italian called option for Pizza, Lasagna, 
Spaghetti and Calazone. 

control. The select1 control l
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b. Left-click on the canvas to place the list select1 control on the form. 

5. Expand the XForms control in the properties of the popup item. 

c choices that are 
determined while the form is in use. Itemset has one attribute called Nodeset, which is 
the path to the group of nodes that provide the list options.  

a. The label option is a mandatory element 
of the itemset control. This label is used 
to provide the choices for the list. Using 
a reference to the attributes of the 
<option> nodes, label creates and 
displays the list of choices that are 
displayed to the user. 

b. The value option indicates which options 
are selected. Value has one attribute 
called ref, which is the path to the 
instance node. 

c. Set the itemset > value > ref and 
itemset > label > ref to ‘.’ and the nodeset to instance('INSTANCE')/italian/option. 

7. Add another node called italian_result to the instance 
to store the result of the choice. 

8. After creating the instance element, select the node in 
the Instance View and drag it onto the List object on the 
canvas.  This will create a link between the form item 
and the instance data, that way when a selection is 
made it will be stored in the instance element. 

9. Preview the form. 

4. Set the value of the label property to ‘What is your favorite Italian dish?’ 

6. Itemset allows you to create lists and groups that offer dynami
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Add a combobox to the form 

1.  Create a 

ct1 

3. Set the label to ‘What is your favorite fruit?’ 

4. Expand the XForms control in the properties of the popup item. 

5. In the Instance View select one of the option elements under 
“fruit”, right-click and select Copy Reference.   

orms and paste the text 
into the value of the nodeset option.   

b. Set the itemset > value > ref and itemset > label > ref to 

6. uits_result to the instance to store 
the result of the choice. 

7. Now we will link the fruits_result node we just created to the 

prop iew, expand the XForms (select1) properties and set 

8. 

child called fruits to the instance created in step 1. 
berry, Apple and 

ta instance, use the sele

Select1) item from the 
te. 

ct1 control on 

Create an option for Banana, Straw
Orange.  

2. To create a combobox from a da
control.  

a. Left click on the Combobox (
Standard Library on the Palet

b. Left click on the canvas to place the list sele
the form. 

a. In the Properties View, expand XF

‘.’. 

Add another node called fr

favorite fruit popup.  Click on the popup in the canvas.  In the 
erties v

the ref property to instance('INSTANCE')/fruits_result. 

Preview the form.
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Add a RadioGroup to the form 

1. To create a radio group from a data instance, u

a. Left click on the RadioGroup (Selec
Palette.  

b. Left click on the canvas to place 

. Set the value of the label property to ‘

. Expand the XForms control in the prope

. This time instead of using itemset we are goi

se the select1 control.  

 item from the Standard Library on the 

o group control on the form.  

your favorite bird of prey?

t1)

the radi

What is ’ 

rties of the popup item. 

ng to specify the items in the list explicitly.  
Expand the XForms category in the Properties View, set the itemset back to default 
(click the blue dot so that it is clear). 

icking on the ‘+’ button 
three times. 

b. Expand each of the children and set 

‘Hawks’, and ‘Falcons’ – these are 
the label
user wh is previewed. 

c. Now rep f each item instead of 
ased on the user’s selection, in the xforms 
group. 

5. e the result of the choi

6.  the group of
and dragging it onto the Ra
nstance('INSTANCE

 

7. 

 

 

 

 

2

3

4

a. Expand Item and add three item 
children by cl

the label of each item to ‘Eagles’, 

s that will be shown to the 
en the form 

eat the previous step, however this time set the value o
the label.  The value is what is stored, b
instance node that is linked to the radio

Add another node to the instance to stor

Link the instance element “birds_result” to
instance element in the Instance View 
action will set the ref of the radiogroup “i

Preview the form. 

ce called “birds_result”. 

 radio buttons by selecting the 
dioGroup object.  This 

')/birds_result”. 
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Add an ent Button to the form 

me

Attachm

Note: Only a single file may be attached using XFORMS attach nt procedures. 

1. First we need to create an xml node that will hold information about the file. The data 
  

Data node - The node that will contain the actual file you are

attaching. Call this node filedata. 

filename — The node that will contain the actual name of 

the file.  

mediatype — The node that describes 

2. To create an attachment button from the data insta
created above.  

a. Left-click on the Button (Upload)
Standard Library on the Palette.  

b. Left-click on the canvas to 

. Set XForms > label > Text to ‘Attach’ as shown below. 

. Set XForms > ref to the path to the data node which is 
instance('INSTANCE')/enclose/filedata. This attribute links the upload control to the 
node that will contain the file. 

instance that will contain the attached file must include the following nodes:

 

the file’s mediatype.  

nce 

 item from the 

place the button on the form.  

3

4
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5. Set the XForms > mediatype > ref and XForms > filename > ref attributes to the paths 
f their corresponding instance nodes (ie. instance('INSTANCE')/enclose/mediatype  

and instance('INSTANCE')/enclose/filename). These attributes link the mediatype (ie. 

nod

6. Preview 

 

Add an Input Field to the form 

. Create a node to store the input field data. Call it field_data.  

. To create a field:  

a. Left-click on the Field (Input) item from the Standard Library on the Palette. 

3. 
data
on the canvas. Release the mouse. 

4. The background color and text color may be 
changed by changing the fontcolor and bgcolor 
attributes in the properties dock. 

 

 

dd Date Picker to the form 

. Create a child node to data for storing the result of 
the date picker. Call it date_data. 

o

text/plain) and filename (ie. sample.txt) properties of the selected file to the instance 
es we created.   

the form. 

1

 

2

b. Left-click on the canvas to place the list select1 
control on the form 

To link the data node with the field, left-click on the 
 node ‘field_data’ and drag it over the input field 

A

1
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n the Palette. 

nd drag 

5. 

 

1. t field data. Call it 
textarea_data.  

2. 

Standard Library on the Palette. 

rea control on the form 

3. To link the data node with the field, left click on the data node ‘textarea_data’ and drag it 
over the input field on the canvas. Release the mouse. 

To create a field: 2. 

a. Left click on the Date Picker (Input) item from the Standard Library o

b. Left click on the canvas to place the Calendar control on the form. 

3. Change the value of the label property to ‘Date of Birth’. 

4. To link the data node with the date picker, left click on the data node ‘date_data’ a
it over the date picker on the canvas. Release the mouse. 

Preview the form. 

Add a Text Area to the form 

Create a node to store the inpu

To create a text area: 

a. Left click on the Field (Text Area) item from the 

b. Left click on the canvas to place the Text A
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4. Preview the form. 

 

Add a M roup to the form 

1. 
Cre Moussaka, Souvlaki, Pastitsioto and 
Gyros. 

2. To create a check group from a data instance: 

e the select1 or select control. The select1 control 
limits users to a single choice.  

ckGroup (Select1) item from the 
Standard Library on the Palette.  

c. t select1 control on the form.  

3. Expand the XForms control in the properties 

4. ate lists and 
groups that offer dynamic choices that are 
determined while the form is in use. Itemset 

utually Exclusive Checkbox G

Create a node called greekdish as a child of data element. 
ate an option for 

a. Us

b. Left-click on Che

Left-click on the canvas to place the lis

d. Set the label to ‘What is your favorite Greek dish?’. 

of the popup item. 

Itemset allows you to cre
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has one attribute called Nodeset, which is the path to the group of nodes that provide the
list options. The label control is a mandatory element of the itemset control.  

in STANCE')/greekdish_result

 

 

5. This item e list. Using a reference to the 
attributes of t splays the list of choices that are 
displa

6. The cted. Value has one attribute 
calle

7. Set the to ‘.’ and the nodeset to 
instan

8. Add anothe ce. 

a. Set . 

 

 

 

 

 

 

9. Preview the form. 

 

 

 

 

 

 

 

 

 

set label is used to provide the choices for th
he <option> nodes, label creates and di

yed to the user. 

itemset value control indicates which options are sele
d ref, which is the path to the instance node.  

itemset > value > ref and itemset > label > ref 
ce('INSTANCE')/greekdish/option. 

r node to the instance to store the result of the choi

Select1 > ref to stance('IN
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5.9. Ta
 the tab order is 

correct.  Workplace Forms Designer 2.6 has a number of methods for handling tab order: 
an l g the 

next an  items in the tab order thought an item’s property view or modifying the 
build order.  To enable the Connection Creation Tool, which appears in the palette, the tab 
orde

b order.    
roups. Notice 

there are no grey arrows between the Male and Female radio button in the RadioGroup item.  

orde he 
Out rms items are displayed. 

 

 

 

 

 

 

 

 

Usin
item
ains focus.  When the user tabs to the next item, the 

XForms item, female, will gain the focus. 

jects are treated like an item, 
et within these objects the tab order can be defined.  

The tab order within these XForms objects are 
managed the same way XFDL items are ordered, 
through the build order, Connection Creation Tool, or 
manually modifying the tab order. 

b Order 
When creating an electronic form, an important final check is to determine if

ual y moving the tab arrows, using the ‘Connection Creation Tool’, explicitly definin
d previous

m

r view must be visible.   

The way to handle XForms item’s tab order is similar to the way XFDL handles ta
One difference to make note of is how XForms handles the tab order within g

This is how XForms handles grouped items.  The tab order is handled through the build 
r.  When we look at the Gender RadioGroup and the Favorite Color CheckGroup in t

line tab below, the build order of the XFo

 

 

g RADIOGROUP1 as an example, the XForms 
 male will gain focus when the RadioGroup first 

g

The Table and Pane ob
y



  Building Simple XForms Forms 169 

These XForms objects have a unique linker, an initial pointer that points from the object to the 
item within the object and then a final pointer from the last item to the object.  In the example 
elow, the initial pointer points from the Pane object to the Name field.  The final pointer 

points from the Close button to the Pane object. 

 

 

 

 

 

 

 

 

 

 

 item outside of the object. 

b

 

 

Note: You can not point an item within an XForms object to an
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5.10. XForms Exercise 2 – Modifying the Tab Order 
he tab order will go from left to right and from top to bottom for this exercise. 

 
Exercises_XForms project in the Navigator View. 

er, select View > Show Next Tab Order 

3. Adjust the tab order to go from left to right, top to bottom using one of the methods listed 
below. 

Moving the tab arrows 

a. Select an arrow (back squares will appear at both ends of the arrow). 

b. Position mouse over one end until a cross appears. 

c. Click and drag the arrow to reflect the correct tab order . 

tion Tool’ 

/pre
be visible for the Connection Creation tool to be enabled). 

b. Select an item on the Designer canvas, this will be your starting point.  Select a 
at is to follow the first in the tab order.  An arrow will be drawn to show 

erty view 

a. iew for an item. 

vious values either by entering an 

Modifying the Build Order 

b. Drag and drop the item within the Outline view to reflect the proper tab order. 

 

T

1. Open Workplace Forms Designer 2.6 

a. Start > Program Files > Workplace Forms Designer 2.6 – Designer 

b. Switch to the Resource Perspective and open XForms_Ex02_XFormsTabOrder.xfd
from the Training

2. To view the tab ord

Using the ‘Connection Crea

a. Select the Connection Creation tool from the palette, (next vious tab order must 

second item th
the connection. 

Explicitly setting tab order through an items Prop

Select the Property v

b. Under the General heading, set the next and pre
items sid or by using the dropdown list. 

a. Select the Outline view for an item. 
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6. Under
6.1. Audience 

his section is intended to teach the user the fundamentals of the XPath language, which 
omprises most of the expressions written in XForms.  This module will help you to 

understand and write your own XPath expressions; enabling you to build dynamic XForms 
rms. 

6.2. 
Pa s e 

used to navigate through elements and attributes of an XML instance.  Many of the 
stat rite and interpret 
XPath expressions is very important. 

• XPath is a syntax for referencing parts of an XML instance 

s 

• XPath contains a library of standard functions 

• XPath is a W3C Standard 

Node: The term refers to an element of an XML instance.  Each tag within an instance is a 
node.  Nodes can have children, which are also referred to as nodes. 

An XML instance is a tree comprised of a root node that may contain multiple levels of other 
nodes.  From the XPath perspective there are seven kinds of nodes: element, attribute, text, 
namespace, processing-instruction, comment, and document (root) nodes (there is a 
difference between the root node and the root element).  The tree's root node contains the 
entire document, including the root element and comments and processing instructions that 
occur before the root element start tag or after the root element end tag. 

standing XPath 

T
c

fo

Overview 
th i  a language for referencing data elements (nodes) in an XML instance. XPath can bX

ements in XForms are XPath expressions; therefore learning to read, w

• XPath uses path expressions to navigate XML instance

 

 

 

 

 

 

stance id="customers" xmlns=""> 
 <customer_data> 
  <customer id_num=""> 
   <contact_person> 

 <name/> 

n> 
 <total_owed/> 

   <rented_machines> 
 <model CPU="" RAM=""></model> 

    <id_no></id_no> 

    <date_rented></date_rented> 
cost> 

   </rented_machines> 
  </customer> 

</customer_data> 
</xforms:instance> 

Namespace 

Element 

Attribute 

Comment

Text 

R

nt 

 <xforms:in

 

    oot Node 
    <phone/> 
   </contact_perso
  Root Eleme

    

    <!--This is a comment --> 

    <total_cost>1200</total_
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6.3. 
Nam uzzle and XForms documents 

re no different.  XForms introduces several new namespaces into the mix: 

xmlns:ev="http://www.w3.org/2001/xml-events" 
xmlns:xforms="http://www.w3.org/2002/xforms” 
xmlns:xsd="http://www.w3.org/2001/XMLSchema"  
xmlns:xsi=http://www.w3.org/2001/XMLSchema-instance 
 

Each of these namespaces is required within an XForms document.  They are responsible for 
dding functionality to our XForms implementation. 

xmlns:ev – Allows us to access XForms events like DOMActivate, xforms-value-changed, 
mit-done. 

xmlns:xforms – This is the XForms namespace where all the XForms specific tags are 
defined (i.e. xforms:input, xforms:output, etc.). 

xmlns:xsd – This is where all the tags and options are defined for defining an XML Schema. 

xmlns:xsi – This is where all the tags and options are defined for defining an XML Schema 
Instance. 

Namespaces 
espaces are an important piece in the XML document p

a

a

and xforms-sub
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6.4. 
6.4.1. Nu

XPath Operators 
meric 

Operand Description 

+ Addition 

- Subtraction 

* Multiplication 

div Division 

mod Modulus (returns the remainder) 

6.4.2. 
Operand Description 

Boolean 

or Boolean Or 

and Boolean And 

= Boolean Equal 

!= Not Equal 

< Less than 

> Greater than 

<= Less than or equal 

>= Greater than or equal 
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6.5. XPath References 
6.5.1. uilding XPath References 

he majority of XPath expressions are used to select a node or set of nodes from an XML 
instance.  When an XPath expression returns a node or set of nodes the expression is 

ferred to as a location path.  The XPath location path is the most common type of XPath 
expression.  Location Paths can be relative or absolute; a relative path includes the reference 
from the current node and an absolute path includes the complete path (from the beginning of 
the document).  The following is a table of the basic syntax elements used for creating XPath 
expressions that return location paths. 

Expression Description 

B
T

re

instance(‘instanceID’) Selects the instance whose id matches “instanceID”, if an 
“instanceID” is not specified then the first instance is used as the 
“default” 

nodename Selects all nodes, in the default instance, whose name matches 
“nodename” 

/nodename Selects all nodes, in the default instance, whose name matches 
“nodename” and they are root nodes (nodes at the first level of the 
instance) 

//nodename Selects all nodes, anywhere in the default instance, whose name 
matches “nodename” 

. Selects the current node 

.. Selects the parent of the current node 

@attibuteName Selects all attributes, where name matches “attributeName” 

nodename[exp] Selects all the nodes whose name matches “nodename” and where 
the “exp” evaluates to true. Referred to as a predicate. 

6.5.2. The Root Location Path 
The simplest location path is one that selects the root node of the XML instance, which is 
defined by forward slash (/).  The forward slash is an absolute location path because no 
matter where you are when you use it, it always refers to the root node. 

6.5.3. Locating Children Elements 
Selecting children elements can be done by first specifying the root node and then the 
desired child (/bookstore).  This command will return all the nodes that are children of the root 
node and called “bookstore”. 
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6.5.4. Sample XForms Instance 

9.99</price> 

             <price>69.00</price> 

This expression will return the “lang” attribute for the first book in the bookstore.  In XPath 
rrays begin with an index of 1. 

6.5.6. 
ode

x
alse’.  If yo

wi

<xforms:instance id="INSTANCE" xmlns=""> 
 <data> 
    <bookstore>                         
       <book lang="en"> 
          <title>Book1</title> 
            <author>Jane Doe</author> 
            <price>
         </book> 
         <book lang="en"> 
             <title>Book2</title> 
             <author>Scott Tiger</author> 
             <price>35.99</price> 
         </book> 
         <book lang="en"> 
             <title>Book3</title> 
             <author>Joe Nobody</author> 

         </book> 
         <book lang="fr"> 
             <title>L'auvre4</title> 
             <author>Pierre Francois</author> 
             <price>38.00</price> 
         </book> 
  </bookstore> 
 </data> 
</xforms:instance> 

6.5.5. Locating Attributes 
ttributes can also be referenced by using XPath.  Use the “at” sign (@) followed by the 

name of the attribute to retrieve its contents. 

/bookstore/book[1]/@lang 

A

a

Predicates 
Predicates are used to find a specific node or set of n
Predicates are defined by using square brackets. The e
predicate must evaluate to either ‘true’ or ‘f

s that meet a specified criterion.  
pression used in the value of a 

u want to dynamically determine the 
n. 

ng table: 

k element that is the child 
ment 

k element that is the child 

position you must use the position() function in the expressio

Common predicate examples are described in the follo

Path Expression Result 

/bookstore/book[1] Selects the first boo
of the bookstore ele

/bookstore/book[last()] Selects the last boo
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of the bookstore element 

/bookstore/book[last() - 1] Selects the second to last book element that 
is the child of the bookstore element 

/bookstore/book[position() < 3] Selects the first two book elements that are 
children of the bookstore element 

//book[@lang] Selects all the book eleme
attribute named lang 

//book[@lang=’en’] Selects all the book eleme
attribute named lang 

/bookstore/book[price > 35.00] Selects all the book eleme
element that have a price 
value greater than 35.00 

/bookstore/book[price > 
35.00]/title 

Selects all the title elemen
elements of the bookstore 
a price element with a value greate
35.00 

 

XPath Sample Form 

nts that have an 

nts that have an 
with a value of 'eng' 

nts of the bookstore 
element with a 

ts of the book 
element that have 

r than 

6.5.7. 
A form has also been provided that demonstrates these XPath expressions in action.  Open 

described above have been demonstrated in this form.  Each section contains an 
xforms:repeat that is linked to the sample XForms instance using XPath predicate 
statements.  Feel free to experiment with predicates within this sample form. 

Sam_XFormsPredicates.xfdl from the training package.  Several of the expressions 
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6.6. XPath Functions 
The following is a table of the XPath functions that are supported. 

Function Parameters Description 

Count Reference to Instance Element Returns the number of children 
elements 

S
Element 

he string tring-length String or Reference to Instance Returns the length of t

Local-name Reference to Instance Element Returns the local name of the 
reference 

Name n/a Returns the element name of the 
corresponding nodeset 

Number Reference to Instance Element Converts the item to a Number 

Ceiling Reference to Instance Element Rounds the number up to the nearest 
value 

Floor Reference to Instance Element Rounds the number down to the 
nearest value 

Round Reference to Instance Element Rounds the number to the nearest 
value 

String Value or Reference to Instance 
Ele

Converts the item to a string 
ment 

Concat Comma separated values to Combines m
concatenate together 

ultiple strings together to 
form one string 

Substring Source String, Start value, End Returns the characters from the start 
. value to the end values of the source string

Contains Source String, Search String Returns true if the source string 
contains the search string 

Starts-with Source String, Search String Returns true if the source string 
begins with the search string 

Normalize-space Source String or Reference to 
Instance Element 

Removes all excess White space 

Substring-before Source String, Search String Returns the characters of the source 
string that precede the first 
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occurrence of the search string 

Substring-after Source String, Search String Returns the characters of the source 
string that follow the first occurrence 
of the search string 

Boolean XPath Expression Converts item to a Boolean 

Not XPath expression Provides the negative of the 
expression  

True n/a Returns a Boolean “true” 

False n/a Returns a Boolean “false” 

 

6.6.1. XP
A fo  h nctions being used.  The 
form is titled “Sam_XPath Functions.xfdl” and can be found in the package distributed with 
this c

 

ath Functions Sample Form 
rm as been provided that demonstrates each of the above fu

 do ument. 
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7. s Concepts 
7.1. 

This ild dynamic forms with an 
XFo

7.2. Ov
XForms can be a difficult language to learn, it may be an emerging standard but it is still very 

eader should: 

• Understand how to use XForms actions 

 

7.3. 
 

ill react to data input. Both XForms and XFDL have their own mechanisms for 
adding logic to control how the form behaves. Choosing which method to use will depend on 
what the rules are, how they affect the form, and whether or not the language supports it. 

A general rule to follow, when building an XForms form, is that any logic dependent on the 
data should be implemented using XForms. Because XForms is a new technology there may 
be things that you want to do that are not currently supported, this is where XFDL steps in. 
Use XFDL to complement your XForms logic. 

7.4. XForms Bind 
In XFDL calculations are executed at the item level by adding a compute attribute to one of 
its options, but in XForms they are executed at the instance level. All of the XForms logic is 
triggered by changes in an XML instance, we use a bind to monitor an instance element and 
execute a calculation when the value changes.   

An XForms bind must define a nodeset. A nodeset is the path to the instance element that is 
being manipulated. Once the nodeset has been defined then all subsequent attribute 
references become relative to the nodeset value.  

There are several different properties of a bind that can be used to affect the value, behavior 
or appearance of an instance element and its associated form item.  A bind may contain one 
or more of these attributes at the same time. 

7.4.1. readonly 
The value of this attribute supports an XPath expression that should evaluate to true or false. 
Setting an element to readonly will not allow the value to be changed, either by the user or 
programmatically. 

Advanced XForm
Audience 

 section is intended for users who must understand how to bu
rms model. 

erview 

much in its infancy.  This section is focused on presenting some of the more complex 
concepts of XForms.  After reading this section the r

• Understand how to create a bind in the Designer to manipulate instance data 

• Understand how to use XForms events

Adding Form Logic 
There are two types of form logic; rules that define data constraints and rules that define how
the form w
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<bind nodeset=“instance(‘personData’)/people/person/name”  
eadonly=“true()”/> 

7.4.2. required 
The value of this attribute supports an XPath expression that should evaluate to true or false. 
Setting an element to required m t the user must enter a value into the corresponding 
form item before the form will be considered complete. The behavior of the form widget also 
changes, when the form loads t e a golden yellow, once the item is given a value 
then it will change to white. 

<bind nodeset=“instance(‘personData’)/people/person/name”  
  required=“true()”/> 

7.4.3. relevant 
 this attribute supports an XPath expression that should evaluate to true or false. 
t is set to relevant then it will be included in a submission and the corresponding 

form elem  visible. If an element is not relevant, then it will not be included in a 
submission, and the corresponding form item will be invisible. 

<bind nodeset=“instance(‘personData’)/people/person/name”  
  rele =“true

7.4.4. calculate 
The value of this attribute suppo h expression. The calculate attribute supports 
standard mathematical operations as well as references to instance data. This is most 
commonly used for calculating the result of evaluating multiple instance elements. An 
example of a calculate attribute is: 

<bind calculate=”instance(‘itemData’)/item/cost *  
 instanc temDat

7.4.5. constraint 
The value of this attribute supports an XPath expression that should evaluate to true or false. 
If the constraints are not met, then the items in the nodeset will be flagged as containing 
invalid input. 

<bind nodeset=“instance(‘personData’)/people/person/age”  
  constraint=“. &gt; ‘18’”/> 

 

For a detailed description of the properties described above, please refer to the “Details on 
XForms Options -- xformsmodels” section of the XFDL Specification. 

7.4.6. Creating a Bind 
To create a bind in the Designer: 

1. Open the XForms View, expand “XForms” and “Model: Default”. 

  r

eans tha

he item will b

The value of
If an elemen

ent will be

vant ()”/> 

rts an XPat

e(‘i a’)/gst” /> 
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2. Then right-click “Model: Default” and select Create Bind from the menu. 

orms View, select it and open the Properties View. 

w the form it should appear with a yellow 
background. 

3. Once the bind appears in the XF

4. Expand “General” and “Model Item Properties”. 

5. Within the “Model Item Properties” category you will find all the attributes described 
above; select required and enter “true()” as its value. 

6. The last step is to define the nodeset, set it to 
“instance(‘personData’)/person/name”. Now if the field has been “linked” to the 
instance data, then when you previe
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7.5. XForms Exercise 3 – Implementing XForms Binds 
This ds are created in the designer. In 
XFo he data stored in the XForms 
mod s and nature of the calculation 
to b  to gain familiarity with the designer and not 
to le code for you. This exercise will 
exp

This us knowledge of XFDL, XForms 
and sic understanding of the 
Ecli

1. 6 

er 2.6 – Designer 

2.  and open XForms_Ex03_XFormsBinds.xfd from 
igator View. 

3. tem.  

 

 

o 

you will have to drag and drop the 
<Name1> element in the instance view onto 

 of name).

Since both fields are linked to the same instance 
element this will simulate copying data from one 

 

 lesson is meant to introduce you to the way XForms bin
rms, binds are used to handle logic in the form based on t

s. I  to define the functionel’s node nternally, XPath is used
e performed. Since the goal of this exercise is
arn XPath, we have provided the necessary lines of 
ose you several forms of binds. 

 document has been written assuming little to no previo
 XPath. This tutorial assumes that the reader has some ba
pse interface. 

Open Workplace Forms Designer 2.

a. Start > Program Files > Workplace Forms Design

Switch to the Resource Perspective
the TrainingExercises_XForms project in the Nav

First Calculation: Setting a value equal to the value of another i

 

a. In order to “copy” data from one field to another we will simply link the two fields t
the same node in the instance.  

i. To do this 

FIELD2 (below Copy  

ii. 

element to another 
Note: the readonly property of the Copy of name 
field must be set “on”, otherwise both fields can edit the text that is stored in
the node. 
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b. If you want to test your work c load the form. 

 a value copied 
over to the Copy of n

ote aves 
FIELD1 (i.e. tabbing o  would change the 
focus). 

c. BONUS question: Can you g creating a bind and linking 
FIELD2 to the bind instead of using a ref?  If you don’t know the answer try the rest of 

ck t

4. Calculation Bind: Set a field by a calculation of two values.  

 

 

a. Open up the XForms View a
and select Create Bind. Then p the Properties 
View of the bind by left clicking on the newly created bind. 

o a multiplication of two integers as our 

ct XPath 

culate has to 
contain the two elements being multiplied together.  

iii. If you want to try this out on your own then don’t look at the screen shot 
below; otherwise, fill in the id, calculate, and nodeset fields as shown 
below.  

 

lick on the Preview tab to 

i. Try inputting into the Name field (FIELD1) and see if it gets 
ame field (FIELD2). 

ii. It’s important to n that the changes won’t occur until the focus le
r mouse clicking onto another field

et the same result by 

the exercise and come ba o it. 

 

nd right-click Model: Default 
 open u

b. We’ve chosen to d
calculation.  

i. First we have to give our new bind an id (Product 
was chosen for this example) then we need to formulate the corre
statements. 

ii. The nodeset needs to point to the Product element while cal
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c. Now link the bind to the appropriate input field by clicking on FIELD13 (below 
Product) and selecting the Product bind as shown below.  

 

d. If you want to test this calculation select the Preview teger into 
bo l d ld 
should contain the product of the two values. 

5. Calculation Bind: The sum XPath function. 
There are many XPath functions that can be used in the bind properties.  Here we will 
use the s t e
pointing to nodes.  It then sums up the values conta e nodes.  Note that the 
xpath arguments can each point to nodesets, in which case all the nodes in the nodesets 
will be s  x ll 
the nodes we want to sum. 

 

 

 

a. O  d
Then open u operties View of the bind
bind. 

b. Open up the Properties View for the bind by le ted bind. 

c. n ent r 
XPath statement.  

t u

ii. If you want to attempt the XPath statements on your own then ignore the 
e the 

shown. 
 
 

tab and enter an in
th the Mu tiplicand and Multiplier fields an  then press tab. The Product fie

um(xpa h1, xpath2,…) function which tak s a number of xpath arguments 
ined in all thos

ummed.  We will use this property in the e ercise to provide a single xpath to a

pen up the XForms View and right-click Mo
p the Pr

el: Default and select Create Bind. 
 by left clicking on the newly created 

ft clicking on the newly crea

In order to fi d the sum of these three elem s we will have to create the prope

i. For his sample bind we’ve chosen “S m” as the id.  

scre nshot below; otherwise, fill in id, calculate, and nodeset fields as 
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t cussion: Note that “sum(../N
“sum(../Numbers/Int[1], ../Numbers/Int[2], ../Numbers/Int[3])” are equivalent to 

n shown above. 
 

 

 

 

 

 

 

 

 

e. If you want to test the sum calculation: 

i. Click on the preview tab. 

ii. Fill in fields A, B, and C with integer values then press tab. 

iii. The sum of these 3 values should be located in the Sum field. 

6. Setting Multiple Properties: The Required and Relevant Properties. 
So far, we have only dealt with a single bind property, the calculate property.  In this 
exercise, we will demonstrate the use of the relevant and required properties.  Also, we 

XPa h Dis umbers/*)” and 

the solutio

 

d. Now link the bind to the appropriate input field by clicking on the Total field (below 
Total label) and selecting the Sum bind as shown below.  
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will set both properties on the same bind.  Th
visible and required when a checkbox is chec

e goal is to make a field that will only be 
ked. 

and select Create Bind. 
ated 

bind. 

b. Open up the Properties View for the bind by left clicking on the newly created bind. 

c. s so that the Phone Number field will only 
eck box is checked. 

 

cked.  So we need to write XPath queries 
which test the checkbox node.  If an xpath statement returns any nodes, it is 
equivalent to the boolean value true.  If it does not return any nodes, it is 

 
e. 

 

a. Open up the XForms View and right-click Model: Default 
Then open up the Properties View of the bind by left clicking on the newly cre

Now we need to set the bind propertie
y when the chappear and be mandator

i. For this example we’ve chosen “RequiredAndRelevant” as the bind id. 

ii. Provide an xpath query for the nodeset that selects the “PhoneNumber” 
node in the data instance.  See the screen shot below for the solution. 

iii. Provide xpath queries for the required and relevant properties.  Both these
xpath queries will be the same.  See the screen shot below for the solution. 

 

XPath Discussion: We want to set the relevant and required properties to 
true whenever the checkbox is che

equivalent to boolean false.  In this example the filterstep is [PhoneCheckbox 
= “true”] because we only want to select a node when the checkbox node is
tru
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d. Now link the bind to the appropriate input field by clicking on the TelephoneNumber 
 and selecting the RequiredAndRelevant bind as 

n below.  

i. Click on the preview tab. 

e 
ox. 

iii. When the checkbox is checked, the field should appear and be colored 

7. Setting Constraints 
e data we enter 

 enter is larger than the number in another 

on the newly created 
bind. 

b. Open up the Properties View for the bind by left clicking on the newly created bind. 

c. Now we need to set the bind properties so that the A number field will show an error 
 in B. 

field (below Phone Number label)
show

 

e. If you want to test the bind: 

ii. When the phone number c
invisible.  Click the checkb

heck box is not checked, the field should b

yellow to indicate it is mandatory. 

iv. Unchecking the checkbox should make the field disappear again. 

In this exercise we will create a bind that will enforce a constraint on th
into the form.  In this case, that the number we
field. 

 

a. Open up the XForms View and right-click Model: Default and select Create Bind. 
Then open up the Properties View of the bind by left clicking 

if the number entered in A is smaller than the number entered
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i. For this example we’ve chosen “AGreaterThanB” as the bind id. 

e 
data instance.  See the screen shot below for the solution. 

iii. Provide an xpath query for the constraint property that is true when the 

XPath Discussion: The constraint xpath is also equivalent to 
“instance(‘INSTANCE1’)/PAGE1/NumA > 
instance(‘INSTANCE1’)/PAGE1/NumB”, but here we used the xpath 
shorthand “.” which means “current node” and “..” which means parent.  
XPath statements entered in the properties fields of a bind are relative to the 
xpath used to point to the nodeset, but you can also use full paths if you 
prefer. 

d. BONUS question: Can you predict what will happen if the nodeset for this bind points 
to NumB instead?  Be careful to update the constraint xpath since it is relative to the 

ided in the XPath Discussion section). 
 

 

 

ii. Provide an xpath query for the nodeset that selects the “NumA” node in th

NumA node is greater than NumB.  See the screen shot below for the 
solution. 

nodeset (you can use the full paths prov
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7.6. XForms Actions 

 

error.  

XForms actions allow you to initiate a number of processes, including submitting a form, 
setting a value in a form, and inserting a row in a repeat table. 

XForms actions are triggered by events in the form. For example, you might create an action 
that occurs when the user clicks a button, when a particular value in the form has changed, or 
when a submission has returned an 

Please refer to the “Details on XForms Actions” section of the XFDL specification for a 
complete list of all the actions that are supported and how to implement them. 
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7.7. XForms Exercise 4 – Using XForms Actions 
In th age, 
xforms:setvalue, xforms:setfocus, and xforms:setindex. 

1. Open Workp

a. Star

2. Switch to th rce Perspective and open XForms_Ex04_XFormsActions.xfd from 
the TrainingExercises_XForms project in the Navigator View. 

 

xforms

age.  We will show a 
message box when the data instance has been initialized and when an XForms item’s value 
has changed. 

Data Model Method

is exercise you will be introduced to the following four actions: xforms:mess

lace Forms Designer 2.6 

t > Program Files > Workplace Forms Designer 2.6 

e Resou

:message 

In this exercise we will show 2 different ways to use xforms:mess

 

When creating the xforms:message in the data model, the code will look similar to this: 

ready">Form has 
bee
 

1. e

2. Rig l:Default. 

3. Select A o

 

4. Highlig View. 

<xforms:message level="modal" ev:event="xforms-
n loaded.</xforms:message> 

Sel ct the XForms View. 

ht-click Mode

cti ns > Create message. 

ht the newly created message item.  Expand XForms in the Properties 
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5. In the Text property, input Form has been loaded. 

6. In the level property, select modal.  This setting is an XForms option which determines 
the style of the message box to be displayed.  All messages are displayed as modal style 
message boxes by the viewer, so it doesn’t matter which setting is chosen here. 

7. In the event property, select xforms-ready.  xforms-ready occurs when the forms 
viewing application has finished the initial set up of all XForms constructs and is ready for 
user interaction. 

8. Your properties should look like the screen shot below. 

9. Select the Preview tab and view results. 

Item Method 

When creating an xforms:message in an item, the code will look similar to this: 

<xforms:message level="modeless" ev:event="xforms-value-
changed">Your data model has changed.</xforms:message> 
 

1. Select the item, FIELD1. 

2. Expand XForms in the Properties View. 

3. Click Actions, select message in the drop down. 

4. Once message is selected, click  to add the action. 

5. Expand the Actions and message property. 
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6. In h

7. In the level property, select modal.  This setting is an XForms option which determines 
the style of the messag s are displayed as modal style 
message box setting is chosen here. 

8. In the event prop .  xforms-value-changed occurs 
when a value is cha option. 

9. Your properties shoul

 

10. Select the Preview tab to test the results. 

11. Enter text into FIELD1 and tab out to see the message. 

 

xforms:setvalue 

In th  
value us

Wh

value="../item1"></xforms:setvalue> 
 

1. Select th

2. Expand 

3. Click Action

4. Once setva e is selected, click 

t e Text property, input Your data model has changed. 

e box to be displayed.  All message
es by the viewer, so it doesn’t matter which 

erty, select xforms-value-changed
nged in an xforms:select or xforms:select1 

d look like the screen shot below. 

is exercise, we will take the value found in FIELD1’s data instance and set it to FIELD4’s
ing xforms:setvalue. 

en completed, the source code in the pushValue button will look similar to this: 

<xforms:setvalue ref="instance('INSTANCE1')/item2Set" 

e button, pushValue. 

XForms (trigger) > Actions > action in the Properties View. 

s, select setvalue in the drop down. 

lu  to add the action. 
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5. Expand the 

6. In the value

7. In the ref pro .  Alternatively you 
can locate ite ct Copy 
Reference

8. Your prope

 

9. elect the Preview tab and view results. 

 

xforms:setfocus 

In this exercise, we will set the cursor’s focus back the Name field when the ‘Reset Info’ 
button is clicked.  The values in the 3 fields will be cleared using the xforms:setvalue action 
whi s already been setup. 

The d en a unique id that the action’s control will 
point to. 

1. Select the field labeled “Name”. 

2. Expand XForms (input) in the Properties View. 

3. In the id property, input the value name. 

Actions and setvalue property. 

 property input ../item1, hit enter. 

perty enter instance('INSTANCE1')/item2Set, hit enter
m2Set in the instance view, right click on the node and sele

, then paste the reference into the ref property. 

rties should look like the screen shot below. 

S

ch ha

 fiel  that gains the focus will need to be giv
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4. The code view for xforms:setfocus will look like this when we are done. 

5. 

. Click Actions, select setfocus in the drop down. 

8. c

<xforms:setfocus control="name"></xforms:setfocus> 
 
Select the button labeled “Reset Info” (the button’s sid is “resetFocus”). 

6. Expand XForms (trigger) > Actions > action in the Properties tab. 

7

On e setfocus is selected, click  to add the action. 

and Ac9. Exp tions and the newly created setfocus property. 

10. h

11. 

 

12. 

 

xforms:setindex 

In this exercise,
table consists of
and then set the
will concentrate 

<xforms:s
 

In t e control property, input name, hit enter. 

Your properties should look like the screen shot below. 

Select the Preview tab and view results. 

 xforms:setindex is used to set the focus to a particular index in a table.  The 
 three rows.  When the button is selected, we set the index to the first row 
 focus back to the table.  The setfocus will already be provided; this exercise 
on setting the index.  The code will look similar to this: 

etindex index="1" repeat="TABLE1"></xforms:setindex> 
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1. 

2. Exp igger) > Actions > action in the Properties View. 

3. Click Actions, select setindex in the drop down. 

4. Once setindex

Select the button labeled “Reset To This Index”, (the button’s sid is “setIndex”). 

and XForms (tr

 is selected, click  to add the action. 

 and the newly created setindex property. 

erty, set the value to 1, hit enter. 

perty to the id of the XForms repeat object, which

d look like the screen shot below. 

5. Expand Actions

6. In the index prop

7. Set the repeat pro  is “TABLE1” 

8. Your properties shoul

 

9. Select the Preview tab and view results. 
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7.8. XForms 
XForms eve
particular choice ms system. This 
allows you to create actions that are triggered by these events. For example, you might 
create an ac
choice in a list is on of 
the XFDL speci  a complete list of all the events that are supported and how to 
implement them. 

Events 
nt handlers track events in the form, such as a button click or the selection of a 

. When these events occur, they are registered by the XFor

tion that is triggered when a particular button is clicked, or when a particular 
 selected. Please refer to the “Details on XForms Event Handlers” secti

fication for
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7.9. XForms Exercise 5 – Using XForms Events 

a. Start > Program Files > Workplace Forms Designer 2.6 

t in the Navigator View. 

 

1. Open Workplace Forms Designer 2.6 

2. Switch to the Resource Perspective and open XForms_Ex05_XFormsEvents.xfd from 
the TrainingExercises_XForms projec

Note: If you are not using the example form to complete this exercise then after
creating a blank form you must enable the XForms view.  This can be done by 
clicking Window > Show View > XForms.  Open the XForms tab in the Designer 
view, right-click anywhere inside the view and select Add XForms Support. 

Event 1 – XForms-Ready 

This event occurs when the forms viewing application has finished the initial set up of all 

XForms constructs and is ready for user interaction. In this example this occurs before the 

form is displayed on the screen.  In this part of the exercise, we will cause a message box to 

appear when the form has been initialized. 

The code will look similar to this: 

ev:event="xforms-ready" 
 

1. Expand the XForms element and right click on Model. Select Actions > Create 
Message 

 

2. In the Properties View, choose modal from the level dropdown and xforms-ready from 
the event dropdown.  The level setting is an XForms option which determines the style of 
the message box to be displayed.  All messages are displayed as modal style message 

 



198  Advanced XForms Concepts  

boxes by the viewer, so it doesn’t matter which setting is chosen here.  To finish this 
event set the Text property to “The XForms model has been initialized”. 

 

 

. Test the event by viewing the form in the preview mode. The message should be 
displayed before the form is displayed. 

 

Eve

DO ivation of the presentation element that contains 

g a button registers the DOMActivate event for that button.  

: 

ev:event="DOMActivate"  
 

1. 

2. 

3. Within 

4. Cho

 

 

 

 

3

 

 

 

nt 2 – DOMActivate 

ctivate is the event that detects the actMA

this event. For example, clickin

The code will look similar to this

Select the Click me! Button.  

In the Properties View, expand XForms > Actions 
and add a message action. Select message from 
the drop down list and click the + button. 

the message action, set the text to “You just 
activated/clicked the button”.  

ose modal from the level drop down and set the 
event to DOMActivate. 
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5. Test the form in the preview mode. Click the button to fire the DOMActivate event. 

ent 3 – xforms-value-changed 

rs when a value is changed in an xforms:select or xforms:

se we will create an action that is triggered when

p. 

The code will look similar to this: 

ev:event="xforms-value-changed"  

Select xforms_value_changed input field.  

In the Properties View, expand XForms > Actions.  Selec

 

 

 

 

 

Ev

Occu select1 option.  In this part of 

the exerci  the user makes a choice from a 

popu

 
 
 
 

1. 

2. t 
k the + button. 

message, set the text to “You just changed the 
value”. 

4. Choose modal from the level drop down and set the event 

message from the drop down list and clic

3. Within the 

to xforms-value-changed. 
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5. Test the form in the preview mode. Change the value of the field and tab out to fire the 
xforms-value-changed event. 

ent 4 – xforms-submit-done 

rs when an XForms submission has successfully

look similar to this: 

ev:event="xforms-submit-done"  

The XForms submission button has been provid
To make a submission event handler, right click on the
view and click on Actions > Create message. 

 

 

 

Ev

Occu  completed.  

The code will 

 
1. ed in the form with the submission rule. 

 Submission action in the XForms 

 

 

 

2.  the Properties View, enter xforms-submit-done as the event. Change the text to 
ccessfully submitted to a file.” 

 

 

 

 

 

 

 

 In
“The data instance has been su
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3. The submission that is used needs a path where the submission will be sent.  In the 
XForms view, select the SubmitFormData submission. 

 

4. ssion.  Change the action 

5.  button to submit the instance and 

 

 

 

 

comes required, or 

n XForms 

 with three choices, 

n the user selects the 

‘Marri cted. 

 
1. model, binds and the 

dler: 

The properties view now shows the properties for the submi
property to a valid path on your local machine. 

Test the form in the preview mode. Click on the Submit
fire the xforms-submit-done event. 

 

Event 5 – xforms-required 

This event occurs when a data node that is optional (required = false) be

 bound to that node. We will bind this event to a

input element, Spouse First Name. The form contains a radio group

 ‘Single’, and ‘Divorced’. The input field becomes required whe

ed’ choice and optional when any of there other choices are sele

The code will look similar to this: 

when a data node that is required changes value and remains required. This event is 

triggered on the XForms control

‘Married’,

ev:event="xforms-required"  

You have been provided with the data 
XForms items. To create the event han
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a. Select xforms_required input field labeled “Spouse First Name”. 

e drop down list 
and clic

quired now”. 

d. Choo xforms-required. 

2. Married radio button to fire the xforms-

 

  

 

 

Ev

(read

triggered on the XForms control bound to that node. The 

forms-readwrite label becomes writable when Married

The code will look similar to this: 

ev:event="xforms-readwrite"  

b. In the Properties View, XForms > Actions.  Select message from th
k the + button. 

the message, set the text to “This field is re

se modal from the level drop down and set the event to 

c. Within 

Test the form in the preview mode. Click on the 
required event.  

ent 6 – xforms-readwrite 

This event occurs when a data node that is read only write = false) becomes read-write, 

s read-write. This event is 

Spouse First Name field under 

 radio button is clicked and read only 

or when a node that is read-write changes value and remain

x
when any of the other radio options are checked. 

 
1. You have been provided with the data model, binds and the 

XForms items. To create the event.  
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a. Select xforms_readwrite input field labeled “Spouse First Name”. 

b. In the Properties View, XForms > Action.  Select message from the drop down list 
and click the + button. 

c.  
e field.”.  

 

 

 

 

 

2. Married radio button to make the field 

 

 

 

 

Ev

levant (rele

r when a node that is relevant changes value and remains releva

on the XForms control bound to that node. 

The code will look similar to this: 

 
1. model, binds and the 

a. d “Spouse First 

 Within the message action, set the text to “The field is
th

drop down and set the 
event to xforms-readwrite. 

readwrite now or a change has been made to 

d. Choose modal from the level 

Test the form in the preview mode. Click on the 
readwrite. 

ent 7 – xforms-enabled 

This event occurs when a data node that is non-re vant = false) becomes relevant, 

nt. This event is triggered o

ev:event="xforms-enabled" 

You have been provided with the data 
XForms items. To create the event. 

Select xforms_enabled input field labele
Name” under the xforms-enabled label.  
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b. In the Properties View, XForms > Actions.  Select 
message from the drop down list and click the + button. 

2. radio 

 

 

 

 

c. Within the message action, set the text to “This field is 
relevant now.” 

d. Choose modal from the level drop down and set the event 
to xforms-enabled.  

Test the form in the preview mode. Click on the Married 
button to make the field relevant. 
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7.10. XForms Submissions 

 

Forms data model, you can submit either the 
entire form or just a particular data instance. This makes it possible to send your data 
inst se the complete form 

If yo ission rules. These rules 
help determine what data is submitted, how the data is submitted, and where the data goes. 
In additi  the 
rules. 

Each se a 
model, as shown: 

attributes
 </xforms:submission> 

Each submission is further defined by adding attributes to the <submission> tag and by 
s. For additional information regarding creating and 

configurin  Specification. 

When submitting a form that contains an X

ance directly to processing applications rather than having to par
and extract the data instance. 

u want to submit a data instance, you must create a set of subm

on to submission rules, you must also create a submission button that is linked to

t of submission rules is inserted within the <xforms:submission> tag in the dat

<xforms:model> 
 <xforms:submission ... ...> 

</xforms:model> 
 

including optional serialization rule
g an XForms submission refer to the XFDL
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w 

e.  

7.11. XF
This lesson is meant to show you how the Form Designer can help you cre
ubmissions. In this example, you will be asked to create an XForms

configure a submit button to use it.  

1. Open Workplace Forms Designer 2.6 

a. Start > Program Files > Workplace Forms Designer 2.6 – Design

. Switch to the Resource Perspective and open XForms_Ex06_XFo
from the TrainingExercises_XForms project in the Navigator Vie

witch to the Designer Perspective and open the 

 
a.  

 

 

3. In order to submit an instance in XForms you need to create a Submission rule that 
e submission. For this example follow these steps: 

a. Right click on the Model: Default in the XForms view and select Create Submission 
for Instance (as shown below).  

 

 

 

n the Properties Vie
nd the XForms heading. In this example, 

there are four values that we have to set for the submission rul

i. The id of the submission,  

orms Exercise 6 – Using XForms Submissions 
ate XForms 

 submission rule and 

er 

rmsSubmission.xfdl 
w. 

s

2

a. The Designer should automatically s
file with the instance as shown below. 

 

 

 

 

describes the characteristics of th

 

b. Select the newly created submission item, ope
(shown below) and expa
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ii. The reference to the instance data that we will be submitting (ref) 

iv. The reference to the node in the instance that defines the submission 
location (actionref).  

c. Set the id attribute within the General heading to SubmitFormData 

d. The ref attribute contained in the XForms heading 
should contain an XPath statement that points to the 
instance that we want to submit. In this case it is the 
FormData instance.  

e. Since we are saving our instance locally we will choose put 
erializes the data in the XForms 

For this example we must set the replace attribute to instance which replaces the 
instance specified by the instance attribute. 

g. A bind has been written that stores the filename and path in the ActionRef node of 
ribute will have to contain an XPath 

statement that points to this location. 

 

iii. The submission method (method) 

for 
the method attribute.  Put s
model as XML. No response is expected (this is generally used 
with a file URL). 

f. 

the FormData instance. The actionref att

 

U
tion 

nnot be computed.  The actionref property was adde

Note: The action and actionref attributes both define the 
however there are differences between them.  The ac
and ca

RL of the submission, 
property is a static string 

d to support XPath 
.  The action is mandatory, 

et it.  Since the actionref 
action, so it doesn’t matter what value we 

mined by actionref” 

expressions so that the URL could be computed at runt
but 

ime
if actionref is present it will be used instead of the action. 

h. The action property is mandatory and therefore we must s
also exists it will be used instead of the 
give the action.  Set the action property to “URL deter

i. The submission rule is now complete. 

4. The next step is to configure the submit button to use the submission rule you just 
created. 

a. Click on the submit button and open the Properties view for this item. 

b. Find the submission attribute under the XForms heading and select 
SubmitFormData. 
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5. Test your form by selecting the Preview tab. 

a. Enter data into the First name, Last name, and Comments

b. Since there are some permission restrictions on where the form 
enter c:\temp in the File Path field.  

d. s file 

ww.ibm.com/xmlns/prod/XFDL/Custom" 
xmlns:designer="http://www.ibm.com/xmlns/prod/workplace/forms/des

w3.org/2001/xml-events" 
mlns/prod/XFDL/7.0" 

LSchema-instance"> 
   <FormData> 
      <FirstName>John</FirstName> 
      <LastName>Smith</LastName> 
      <Comments>I love forms!!!</Comments> 
      <FilePath>c:\temp</FilePath> 
      <ActionRef>File:\\c:\temp\FormData.xml</ActionRef> 
   </FormData> 
</document> 

 

c. The submit button is now configured. 

 fields. 

can write the file, 

c. Press the Submit button. 

Finally, browse to c:\temp and look for a file called FormData.xml open up thi
ilar to this: 

<document xmlns="" 

and verify that it looks sim

xmlns:custom="http://w

igner/2.6" xmlns:ev="http://www.
lns:xfdl="http://www.ibm.com/xxm

xmlns:xforms="http://www.w3.org/2002/xforms" 
xmlns:xsd="http://www.w3.org/2001/XMLSchema" 
xmlns:xsi="http://www.w3.org/2001/XM
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7.12. XForms Tables 
 is common for forms to have a repeating section. Prior to version 2.6, repeating sections 

were very tedious to implement because the repeating items had to be created and destroyed 

XForms provides the ability to create a traditional table of repeated items organized into rows. 
w that includes all of the items that should 

appe the XForms data model.  Each time a new row 
is add plicated to create the new row. This occurs 
whe e linked to those items are duplicated. This 

ing that data for each row in the table is still 

able.  First, there is the manual process where 
 item from the palette which will lay down a table outline 

n the canvas.  The empty table can then be populated with other items from the palette. 

the tion provides a Simple Setup and an 
Advanced Setup that uses existing data from an instance.  Further customization provided 

opti

It

manually using XFDL functions.  

This is accomplished by creating a template ro
ar in each row. This row is then linked to 
ed to the table, the template items are du

n the elements in the data model that ar
allows the table to expand to any size while ensur
maintained in the data model. 

The Designer provides two ways to create a t
the user selects the Table (Repeat)
o

Alternatively, the Designer provides a table wizard (Table (Repeat) by Wizard) that walks 
user through the steps to create a table.  This op

through the table wizard includes setting table appearance, row editing, and row formatting 
ons. 
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7.13. XForms Exercise 7 – Creating a Table (w/ Table Wizard) 
This nstrates how to create a table with the Designer’s Table Wizard.   

Exe

1. Ope lace Forms Designer 2.6 

er 2.6 – Designer 

2. Create a new form file 

a. your project, right-click and select New > New Workplace Form 

 
TableWizard.xfd”), then click Finish 

c. Click the Next Button and select the Default Empty Form – XForms Template.  
Click the Finish Button. 

d. The Designer should automatically switch to the Designer Perspective and open the 
file. 

3. Find the Table object on the XForms palette, change the 
active object to Table (Repeat) By Wizard.  

 

4. Click the palette object and then click on the canvas.  This will initialize the Table Wizard. 

5. tup and click Next >. 

. In the first section of the wizard we are going to define the instance elements that will 
be used to store the data contained within the table.  

a. Enter fname as a new element name and press Enter. 

b. Enter mname as a new element name and press Enter. 

c. Enter lname as a new element name and press Enter. 

ill appear in the summary list on the left 

selecting an element and then pressing the arrow buttons.   

ditional configuration settings.  When you 
are creating a table you have the choice of creating a new instance (which is the 

xisting instance.  In this case we will just create a new 
instance. 

 exercise demo

rcise 

n Workp

a. Start > Program Files > Workplace Forms Design

Select 

b. Select your project as the parent folder and enter a filename (i.e. “XForms_Ex07_

Select Simple Se

6

d. Each element name w
side of the dialog.  The element order can be changed by 

e. Our table will start with one row, so leave the Number of 
Initial Rows field with the default value of 1. 

f. Clicking the Advanced button activates ad

default) or linking it to an e
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g. Click Next > 

7. The second step is to configure the columns.  For each element in the table we can 
define its read/write status, header and width. 

dth to 150  

i. Change the Header from “mname” to “Middle 

ii. Change the Width to 100 

c. Select lname in the Display Columns listbox  

i. Change the Header from “lname” to “Last Name” 

ii. Change the Width to 150 

d. Click Next > 

8. Finally, we are going to customize some of the display setting of the table.  We can 

a. Change the table name to “personTable” 

b. Make sure that Lines between Columns and Border around Table are checked 

 

 

 

 

a. Select fname in the Display Columns listbox 

i. Change the Header from “fname” to “First Name” 

ii. Change the Wi

b. Select mname in the Display Columns listbox 

Name” 

change the table’s name, appearance, row editing settings and row formatting. 
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c. Check the Color Alternate Rows checkbox.  Select colors for the first and second 
rows by clicking on the color square to bring up the color dialog 

d. Click Finish.  Your table should resemble the one below. 

e. Preview your form. 

 



  Advanced XForms Concepts   213 

7.14. XForms Exercise 8 – Creating a Table (w/out Table Wizard) 
rt 

We are going to create a table that contains people’s first, middle and last names. 

1. 

lace Forms Designer 2.6 > Designer 

 If you created a project in a previous example and you want to reuse it skip step 2. 

a. In the file menu, select File > New > New Workplace Form 

b. Select your project as the parent folder and enter a filename (i.e. “XFormsTableEx”), 
then click Finish 

c. The Designer should automatically switch to the Designer Perspective and open the 
file. 

3. Create an instance 

a. In the Instance View, click the button to create a blank xml instance.  

The following is a step-by-step procedure for creating a table object.  This table will suppo
adding and removing rows. 

Open Workplace Forms Designer 2.6 

a. Start > Program Files > Workp

b.

2. Create a new form file 
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b. Create the following instance: 

 <data> 
  <people> 
   <person> 
    <fname></fname> 
    <mname></mname> 

   </person> 

    <mname></mname> 

 
 </people> 

 
c. e

clicking

d. 

e. 
Instance View should look as 
shown to the right. 

 

 

 

. Crea

a. Select s. 
ts into.  The table 

will resize to fit the items placed within it. 

b. bl
rsonT

value of the “id” property. 

c. We are also going to bind the table to the “person” instance element. In 
View select the person element and drag it onto the table item. Select “update” from 
the dialog that appears. 

    <lname></lname> We will explain the
purpose for both 

   <person> 
    <fname></fname> 

later on… 

    <lname></lname> 
  </person> 

 

 
 </data> 

Right-click the data element and sel
Rename it to “people”, by double 
name. 

Create the rest of the elements by 
following the same procedure. 

When you are finished your 

ct Add Element, a child element will be created. 
 the new element and then typing the new 

 

4 te a Table 

the Table (Repeat) item from the palette and then click on the canva
Manually resize the object so that it is large enough to place objec

We are going to give the table an id of “personTable”. Select the ta
Properties View. Expand the “XForms (repeat)” property.  Put “pe

e and open the 
able” into the 

the Instance 
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d. The

 

5. Cre

a. Select the XForms Input (Field) item from the palette and then 

b. me
*Hint: use the after alignment modifier.** 

 

6. If yo the 
tem
we at is duplicated and the 
other is the first item in the table. We must make sure that the second occurrence is not 

a. 

Create Bind from the menu 

. 
nd “General” and “Model Item Properties”.  

 Properties View should now look like the following: 

ate the input fields 

click on the canvas. 
Do this three times. 

Position the fields after one another so that they are along the sa
the middle field. *

 line and shrink 

c. Select all three fields and move them into the table item. 

u preview your form now you will notice that there are two rows visible.  One is 
plate that will be used when adding additional rows.  When we created our instance 
created two persons, one of them will be the empty instance th

visible. We will write a bind that will hide the template row. 

Open the XForms View and expand “XForms” and “Model: Default” 

b. Right-click “Model: Default” and select 

c. Select the newly created bind in the XForms View and open the Properties View
Expa

Set the following properties: 

 

relevant = false() 
non-relevant nodes are omitted from XForms submissions. UI elements linked to this 
node (the three fields in this case) will not be displayed  



216  Advanced XForms Concepts  

nodeset =  people/person[position()=last()] 
specifying that it is the last occurrence of person that we wish to hide 

 

Let’s break this down: 

i. people/person is the path to the element that we want to bind 

ii. [ equation ] the equation in the square brackets is
that are returned (that is, all person nodes are ret
equation criteria). 

 used to filter the nodes 
urned that meet the 

ents where their index (position) is not 
d out. 

one row. 

7. 

igger (Button) item from the palette and click on the canvas. 

b. Change the value to “Add” 

c. Position the button below the table. It will be important to use relative placement 
because as items are added the table will grow.  Select the Add button and then 
select the table (while holding down the shift key), then right-click one of the objects 
and select Relative Align > Relatively Align Below. 

Note:  If the Add button does not move then there may be an issue with your build 

[position() = last()] all person elem
equal to the last one will be filtere

Now when you preview your form you should only see 

Create the Add Button 

a. Select the Tr

order. If the button does not come after the table in the build order then it cannot refer 
to it. Your build order can be seen in the Outline View and should appear as shown:  
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If you have to fix the build order then select the item that you want to move, click an
hold the left mouse button and drag the item to its new location. A black line will 
appear indicating where the object will be placed within the build order; release the 
mouse button when the

d 

 black line is where you want to position the selected item. 

i. insert 

n 

repeat creates corresponding items that are displayed to the user. 

Select the Add button, open the Properties View and expand the XForms 
heading.  Expand Actions/action/Actions and select insert from the drop down 
list and click the + button. 

 

Expand “Acti ated 
XForms

at = inde

d. Now it is time to add the XForms statements that “trigger” the addition of rows to this 
table. The two XForms statements we are going to add are insert and setfocus. 

Allows you to add a row of elements to a table. This function copies the last 
row of elements in the data model, then inserts the copy in the desired locatio
in the data model. Once the copy is inserted in the data model, the table’s 

 

ons” and “insert” to see the properties for this newly cre
 statement. We want to set the following properties: 

x(‘personTable’) 
an index number that sets the insertion point. 

position = after 
determines where the copy is placed, before or after the insertion point 

nodeset = people/person 
XPath to the collection of table rows in the data model where the last row is the 
row that will be duplicated.  
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ii. setfocus 

Setfocus will put the focus back on the table after the button has been clicked
Add this action in the same ma

.  
nner as insert. 

e to an element in the data model 
control = personTable 
an XPath referenc

8. 

a. Select the Trigger (Button) item from the palette and 

c. Position the button after the “Add” button. It will be important to use relative 
placement because as items are added the table will grow. 

d. Select the “Delete” button first then the “Add” button, right-click one of the selected 
elatively Align After.  This will position the 

“Delete” button directly after the “Add” button, using relative positioning such that 

e. Now it is time to add the XForms statements that “trigger” the removal of rows from 
elete a

XForms model, then the table’s repeat deletes the visi

Expand Actions/action/Actions and select delete from

Create the Delete button 

click on the canvas. 

b. Change the value to “Delete” 

items and select Relative Align > R

when the “Add” button moves so will the “Delete” button. 

this table. The two XForms statements we will add are d nd setfocus.  

eted from the 
ble items that were 

nd the XForms heading.  
 the drop down list and 

i. delete 

Deletes a row of elements from a table. The elements are first del

linked to those data elements. 

Select the button, open the Properties View and expa

click the + button. 
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Expand “Actions” and “delete” to see the properties
to set the following prop

 

 for this newly created 
erties: 

we wish to hide 

XForms statement. We want 

at = index(‘personTable’)  
an index number that determines which row to delete 

n  people/person[position() != last()] odeset =
specifying that it is the last occurrence of person that 

 

ii. setfocus 

Setfocus will put the focus back on the table after the button has been clicked.  

control = personTable 

Add this action in the same manner as delete. 

an XPath reference to an element in the data model 

9. Bind the table and fields to the instance 

a. Binding instance data to input fields is very simple. Open the Instance View and 
expand each layer so that you can see the elements fname, mname and lname. 

. Select the fname element, click and hold the left mouse button and drag the element 
over top of the first field. Repeat this for the mname and lname for their 
corresponding fields. 

. To confirm that the binds have been created properly you should see the following in 
the Properties View for each field: 

 

 

b

c
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Each field is bound to 
the matching instance 

element 
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7.15. XForms Pane 
Sometimes electronic forms employ techniques that are not used on traditional paper forms. 
An example is a form section that contains multiple overlapping sections whose visibility is 
controlled by another input object. In previous versions of the Designer this was a very 
tedious process because the XFDL language did not contain a mechanism for grouping 
objects together. The visibility for each object had to be controlled independently, which 
meant creating a compute in every object. 

The 2.6 product introduces the Pane object which allows the grouping of objects together. If 
the pane is invisible then all the items that are contained within it are also invisible. With the 
introduction of the pane we can also leverage some XForms UI Controls; xforms:switch and 
xforms:case. An xforms:case is represented by a XFDL pane. The xforms:switch can contain 
multiple xforms:cases and allows us to define which xforms:case is visible. 
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7.16. XF m te a Multi-Pane Section 
The p-by-step procedure for creating a multi-pane object in the Workplace 
For

1. 

Forms Designer 2.6 – Designer 

 a previous example and you ip step 2. 

2. 

lect New > New Workplace Form 

 parent folder and enter a filename (i.e. “XFormsPaneEx”), 

Click the Next Button and select the Default Empty Form – XForms Template.  

d. signer should automatically switch to the Designer Perspective and open the 
file. 

3. Cre

  <maritalStatus></maritalStatus> 
  <ClientInfo> 
   <fname></fname> 
   <lname></lname> 
  </ClientInfo> 
  <SpouseInfo> 
   <fname></fname> 
   <lname></lname> 
  </SpouseInfo> 
 </data> 

a. In the Instance View, click the button to create a blank xml instance.  

b. . 
the new element (to edit) and then type in 

the new name. 

c. 

or s Exercise 9 – Crea
 following is a ste
ms Designer 2.6. 

Open Workplace Forms Designer 2.6 

a. Start > Program Files > Workplace 

b. If you created a project in  want to reuse it sk

Create a new form file 

a. Select your project, right-click and se

b. Select your project as the
then click Finish 

c. 
Click the Finish Button. 

The De

ate the following instance 

 <data> 

Right-click the data element and select Add Element, a child element will be created
Rename it to “maritalStatus”; double click 

Create the rest of the elements by following the same procedure. 
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When you are finished your Instance View should look like t

 

he following: 

 

4. Cre

 Library on the palette and 
click on the Design canvas.  

b. Set the label of the radiogroup to “Marital Status”, this property is beneath the 
“General” category. 

c. Add 2 items to the radio group (Single, Married) 

i. Select the Choice (Item) from the 
Standard Library on the Palette and click 
the radiogroup item on the canvas. Do 
this a second time to create a second 

“single” as its text value, then expand 

d. o that it follows the “Single” one. 

“Married” radio and then the “Single” Radio, right-click and choose 

ate a radiogroup that will control which case is displayed. 

a. Select the RadioGroup (Select 1) item from the Standard

radio. 

ii. Select the radiogroup item on the 
canvas and open the Properties View 

iii. Expand XForms (select1) 

iv. Expand Item > item > value and enter 

label and type “Single” as its text value. 

v. Expand the second item and set its 
value to “married” and label to “Married”.  

Position the “Married” radio s

i. Select the 
Relative Align > Relatively Align After Previous Item 
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e. ment.  Select the element in the 
e radiogroup, 

then release the mouse button to apply the link.  This will set the ref property to 
“instance('INSTANCE1')/maritalStatus” 

5. Create the first pane o

a. Select the (if you don’t see it, look for 
Pane (Group pup menu that 
defaults to  it is large enough 
to place oth n a Switch is 
created. 

b. Select the ne Properties View 
to change the bgcolor 
property, cho

6. Setup Case 1 – The client information 

a. be used to group all the 
items together.  Select the Group item from the 
pale

b. Exp
enough

c. Select the inner pane and open the Properties 
View to
“Appea

t)  

e 

Field (input)  to the case.  Label text can be added to the fields 

f. 

i. Open the Instance View, expand the entire tree. 

iii. Select lname, click and hold the left mouse button and drag it overtop of the 
last name field then release the mouse button. 

Bind the radiogroup to the maritalStatus ele
Instance View, left-click and hold the mouse button and drag it over th

bject that will control the switching. 

Pane (Switch) item from the XForms palette 
) on the palette, the Pane (Switch) is located in the po

Pane (Group)), click and drag it onto the canvas so that
er objects inside it.  By default the first Case is created whe

wly created object (the sid is “PANE1”) and open the 
 background color. Expand “Appearance” and locate the 
ose a color. 

Create a pane that will 

tte and add it to the XForms Switch item. 

and the inner pane (group) so it will be large 
 to hold the two fields and label. 

 change the background color. Expand 
rance” and locate the bgcolor property, 

choose a color. 

d. Add a Label (outpu

i. Use the Properties View to change the label text to match that in th
screenshot. 

e. Add two  items
through the XForms (input) heading in the Properties view. 

Bind the two fields on this case to the corresponding elements of “ClientInfo” in the 
instance. 

ii. Select fname, click and hold the left mouse button and drag it overtop of the 
first name field then release the mouse button. 



  Advanced XForms Concepts   225 

7. Create and Setup Case 2 

a. Select the Case palette, click on the Design 
canvas inside
pane). 

When you add a ca
automatically become
any of the other ca
active case.  This can be accomplished by selecting 

b. Create two panes (the Group item in the Palette) 

Info. 

c. Resiz

d. Selec
color.

e. Add a Label (Output) to each group. 

i

f. Add two Field (Input) items to each case. 

g. Bind the two fields in the client pane to the corresponding elements of “ClientInfo” in 
the Instance and the two fields in the spouse pane to the corresponding elements of 
“SpouseInfo” in the Instance. 

i. Open the Instance View, expand the entire tree. 

ii g it overtop of the 
first name field then release the mouse button. 

iii old the left mouse button and drag it overtop of the 
n. 

8. Add the S ality 

a. Select the radiogroup, open the 
Prope  
XForm

– The client and spouse information 

item form the Standard Library on the 
 of the XForms Switch item (the outer 

se to a Switch item it 
s the active case.  To modify 

ses you must first make it the 

the Switch (outer) pane, right-click and choose 
Active Case > caseX.  Only the active case and the 
items it contains will be visible. 

that will be used to group all the items together. The first will be for Client Info 
(exactly the same as the one on the first case) and the second will be for Spouse 

e the panes so that they match the screen shot. 

t each inner pane and open the Properties View to change their background 
 Expand “Appearance” and locate the bgcolor property, choose a color. 

. Change the label text to match that in the screenshot. Use the Properties 
View. 

. Select fname, click and hold the left mouse button and dra

. Select lname, click and h
last name field then release the mouse butto

witching Function

rties View and expand the
s category. 
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b. Under Action, select action from the popup and click the add button. 

c. Expand the item that was just created. 

d. Under Actions, add two toggle actions.  Select toggle from the popup and click the 
add button.  Do this twice. 

e. Expand the items that were just created.  Now we must configure the two toggle 
actions that we added in the previous step. 

i. The first toggle will point to “CASE1” (set case property to CASE1) if the 
io is selected (set if property to . = ‘single’)  

ii
. = ‘married’). 

9. Open the nfirm that the panes switch when the radio button is 
toggled fro

7.17. chemas 
A w nd uses a 
standardized XML . XML is used to encode all communications to a web 
serv a web service by sending an XML message, then waits 
for a corresponding XML response. Because all communication is in XML, web services are 
not erl; 
Window

An 
XML do ned 
structur

The purpose of an XML Schema is to define the legal building blocks of an XML document 

An XML

• defin s that can appear in a document  
• defines attributes that can appear in a document  
• define
• define
• define  
• define or can include text  
• define
• define

 

“single” rad

. The second toggle will point to “CASE2” (set case property to CASE2) if the 
“married” radio is selected (set if property to 

form in the Preview to co
m “single” to “married”. 

 Web Services and S
eb service is any piece of software that makes itself available over the internet a

 messaging system
ice. For example, a client invokes 

tied to any one operating system or programming language--Java can talk with P
s applications can talk with Unix applications. 

XML Schema is a language for describing the structure and constraining the contents of 
cuments.  A schema guarantees that the XML elements linked to it follow the defi
e 

 Schema: 

es element

s which elements are child elements  
s the order of child elements  
s the number of child elements 
s whether an element is empty 
s data types for elements and attributes  
s default and fixed values for elements and attributes  



  Advanced XForms Concepts  227 

7.18. XForms Exercise 10 – Implementing Web Services in XForms 
This exercise demonstrates how to implement a Web Service within a form. This assumes 
that you already have a WSDL that can be used as the starting point.   

Prerequisites 

 This exercise requires that the student have access to the Internet. 

 This exer  and therefore its 
availability can not be guaranteed.  The service used in this exercise can be substituted 
for any ot

Exercise 

1. Open Wo

a. Start > Program Files > Workplace Forms Designer 2.6 – Designer 

2. Create a new form file 

a. Select your project, right-click and select New > New Workplace Form 

b. Select your project as the parent folder and enter a filename (i.e. 
“XForms_Ex10_Web Services.xfdl”), then click Next 

. Select the Default Empty Form – XForms Template and click Finish. 

d. The Des utomatically switch to the Designer Perspective and open a blank 
form. 

3. First, we w ms_Ex10_spellcheck.wsdl 
that is inc rcises_XForms project. 

a. Open

ect Enclose WSDL File. 

4. Add 3x Field (Input) and a button (Submit) to the Designer canvas. 

a. ere. Feel free to “dress up” the form as you like. 

b. The first Field (Input) will contain the word you want to spell check. 

i. In the Properties view, change XForms (Input) > label > Text to ‘Enter the 
word to spell check’ 

cise is dependent on a Web Service that is not hosted by IBM

her valid Web Service. 

rkplace Forms Designer 2.6 

c

igner will a

ill enclose the Web Service WSDL called XFor
luded in the TrainingExe

 the Enclosures View and expand WSDL. 

b. Right-click on Web Services and sel

c. In the new dialog that appears, browse to the location of the 
XForms_Ex10_spellcheck.wsdl file and click Open.   

d. In the Enclosures View if you expand Web Services you should now see that the 
WSDL has been added to the form. 

Position and layout are not crucial h
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c. The second Field (Input) will display the result of the Web Service. 

i. Change the XForms (input) > label > Text property to ‘Web Service Result’ 

d. The third Field (Input) will hold the ID key we need for this Web Service. 

i. Change the XForms (input) > label > Text property to ‘ID Key’ 

e. The Submit (button) will trigger the call to the Web Service. 

i. Change the General > value property of the button to ‘Spell Check’. 

5. XForms Instances are the foundation of all XForms forms. The instance structure for this 
form will be generated from the WSDL that we embedded in the form in a previous step. 

a. Open the Instance View 

b. Click the button that generates an instance from th

c. Click the checkbox for both messages: doSpellingSugg d 
doSpellingSuggestionResponse 

d. Click OK 

6. Now that our items have been created we must link them to an XForms Instance. 

a. In the Instance View, expand both instances that were created from the previous step 

b. In the first instance, select the <phrase> element, hold the left-mouse button, drag it 
over the ‘Enter the word…’ field and release the left-mouse button. This will create a 
“link” between the form item and the XForms instance element. 

c. In the first instance, select the <key> element, hold the left-mouse button, drag it 
over the ‘ID Key’ field and release the left-mouse button. This will create a “link” 
between the form item and the XForms instance element. 

d. In the second instance, select the <return> element, hold the left-mouse button, drag 
it over the ‘Web Services Result’ field and release the left-mouse button. This will 
create a “link” between the form item and the XForms instance element. 

7. When the button is pressed we want to call the web service and place the result into the 
‘Web Services Result’ field. (To accomplish this we will link the button to an XForms 
Submission). 

a. Open the XForms View, expand XForms > Model:Default 

b. Right-click Model:Default and select Create Submission 

c. Select the submission in the XForms View, and open the Properties View.  

d. Expand the XForms category. We need to set the ref property to the instance that 
contains the request. 

e enclosed WSDL  

estion an
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e ref, type: instance(‘INSTANCE’) 

 be 

i. Besid

e. Now we need to set the instance property to the instance that will store the result.  

i. Beside instance, type: INSTANCE1 

f. We need to set the action property to the URL of the web service.  The URL can
seen as part of the WSDL 

i. The URL is http://api.google.com/search/beta2 

ii. Copy this URL into the action property of the XForms Submission 

Note: To find this URL, click the Source tab to open the Source View. Look for the 
element called soap:address. This element has an attribute called location  

g. Set the method property to post. 

h. Find the mediatype property and select application/soap+xml 

i. Open up the Source tab and find the xforms:submission entry.  

ii. Change the mediatype attribute to look like this application/soap+xml; 
action=urn:GoogleSearchAction 

Note: To find this value, click the Source tab to open the Source View.  Look for the 
element called soap:operation.  This element has an attribute called soapAction. It 
is placed in the header of the submitted request and is used to aid the web service in 
determining which method has been called. 

i. Return to the design view by clicking on the Design tab.  Return to the properties 
view for the submission.  Expand the XForms category. Find the replace property 
and select instance from the drop down box.  

j. Select the button on the canvas, and open the Properties View 

k. Expand the XForms (submit) category and set the submission property to 
SUBMISSION (it will be the only item in the popup). 

8. Now preview the form to test the Web Service.  Keep in mind that you must have access 
to the internet and this Web Service must be active.  This service is not maintained by 
IBM and is therefore not guaranteed to work at all times. 

a. Enter the following Key in the ID Key field: 1tnBlt5QFHLMq2jrDsaTUtk40yw/s6Fy 

b. Type ‘allowes’ in the field 

c. Click the ‘Spell Check’ button. 

d. The ‘Web Service Result’ field now shows ‘allowed’. 
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7.19. XForms Exercise 11 – Implementing Schema Validation 

1. 

chemaValidation.xfd”), then click Finish 

called XForms_Ex11_schema.xml that is included in the 
TrainingExercises_XForms project. 

 select Enclose Schema File. 

rowse to the location of the 
ml file and click Open.   

chema and the default model you should see that 
e form. 

4. te an XML instance, which will store all the form data.  The schema will 
validate the structure and content of this instance.  This instance can be generated 

 you would be given the choice if more than one existed. 

5. e. 

a. In the Instance View, expand the data and person elements.  You should now see 
the entire structure of the XML Instance. 

This exercise demonstrates how to implement a form that uses a schema for client-side 
validation. 

Exercise 

Open Workplace Forms Designer 2.6 

a. Start > Program Files > Workplace Forms Designer 2.6 – Designer 

2. Create a new form file 

a. Select your project, right-click and select New > New Workplace Form 

b. Select your project as the parent folder and enter a filename (i.e. 
“XForms_Ex11_S

c. Click the Next Button and select the Default Empty Form – XForms Template.  
Click the Finish Button. 

d. The Designer should automatically switch to the Designer Perspective and open the 
file. 

3. Enclose the XML Schema file 

a. Open the Enclosures View and expand Schema. 

b. Right-click on Model:Default and

c. In the new dialog that appears, b
XForms_Ex11_schema.x

d. In the Enclosures View, under S
the schema has been added to th

Now we will crea

automatically.  

a. Open the Instance View and click the button that generates an instance from an 
embedded schema file.  Since there is only one schema embedded in the form it is 
used by default,

Create the input items that are linked to the schema-generated instanc
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use button, 
drag the Person element onto the canvas and release the mouse button.  This will 
create a pane that contains a field for every child element contained within the 
Person element.  Each field is already linked through XForms ref attributes. 

6. Preview the form to test the schema validation. 

a. Click the Preview tab at the bottom left corner of the designer canvas. 

b. The schema defines six data elements: 

i. First Name –Has a maximum length of 10 

ii. Last Name – Has a maximum length of 10 

iii. Email Address – Has a maximum length of 35 

iv. Phone Number – The string must match the pattern (###) ###-#### 

v. Age – The integer must be >= 55 

e the format YYYY-MM-DD and cannot be empty. 

he 
valid.

b. With the mouse, select the Person element. Click and hold the left mo

vi. Birth Date – Must hav

c. Enter data into each of the fields, if it does not adhere to the above rules then t
field will be flagged in
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8. Cho
8.1. udie

This section is intended to describe some of the differences between XFDL and XForms.  In 
form development each has its place and it is important to learn how and when each method 
should b

8.2. Overv
Both XF ines that can be used to manipulate 
a form. e presentation layer or “skin” 
off the u re still several areas where these two 
implementations overlap each other.  While designing a form you may be faced with several 
situation ppropriate, XFDL or XForms.  A 
simple r  are dependant on business 
rules s
infancy guage does not contain the necessary constructs 
required to produce a desired result.  In these cases it is appropriate to use the functionality 
of X L rms over XFDL procedures is 
also imp d 
using X er to 
implement the XForms model with a different presentation layer (i.e. XHTML). 

8.3. Examples Implementing XForms vs. XFDL: 
8.3.1. Item Visib

Create an XForms bind with the relevant attribute instead of placing a compute on the visible 
ti n when hiding a delete row button if there 

is only one row in the table.   
 
<visible compute=“custom:rowCount > 1 ? ‘on’ : ‘off’” /> 
 
<bind node
 
The visible o
the instance dat rms:trigger” where the ref 
attribute points to the same “rowCount” element), to determine whether or not it should be 
shown.  The
visibility on the s ant then it will not be 

ion. 

8.3.2.  Optional 
Create ttribute instead of placing a compute on the 
format o  field’s mandatory status.  The following example is a common 
implementation of a field that is mandatory when the user selects the “other” checkbox, which 
requires the user to specify the item explicitly. 

osing Between XFDL and XForms 
nce  A

e leveraged. 

iew 
orms and XFDL have event-driven compute eng
 The XFDL language has been modified to serve as th
nderlying XForms model, however there a

s where you are unsure of which method is most a
ule to follow is:  Any logic or behavioral effects that
hould be controlled by XForms, where possible.  Because XForms is still in its 
there will be times where the lan

FD  to supplement the deficiencies in XForms.  Using XFo
ortant if you are interested in exporting your XForms model.  Any logic that is define

Forms binds will be included in the export procedure, which makes it much easi

ility 

on of an item.  The following example is commoop

set=“rowCount” relevant=“ . > 1” /> 

ption is a child of the button being hidden.  The XForms bind uses an element in 
a, to which the delete button is bound (using “xfo

 advantage of the XForms method is that the relevancy not only affects the 
creen, but if the “rowCount” element is not relev

submitted during an XForms submiss

Item Status: Mandatory or
an XForms bind with the required a
ption to determine a
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<format> 
  <constraints> 
   
  </co
</format> 
 
<bind nodeset=“otherField” required=“ ../otherCheck = ‘true’” /> 
 
The first cod  
mandatory statu

The XForms
store the result f the bind to be 
“true”, otherwise “false”.  The instance element “otherCheck” stores the value of the 

field heck box is on. 

culations 

’”></value> 
 

ode snippet is an example of a compute within the value option that gets set to the 
result of the priceField multiplied by “1.07”. 

The XForms bind uses two elements in the instance data.  The first is “totalPrice” which will 
he bind; the product of “price” and “1.07”.  The instance element “price” 

contains the current price as a float.  When you link the “total” field to this bind its value will 
con  

 

 
 

 <mandatory compute=“CHECK1.value” /> 
nstraints> 

e snippet is an example of a compute within the format option that toggles the
s of the field based on the value of the check box. 

 bind uses two elements in the instance data.  The first is “otherField” which will 
of the bind; if the check is on we want the required attribute o

checkbox, either “true” or “false”.  When you link the “other” field to this bind the result is a 
 that becomes mandatory when a c

8.3.3. Item Value: Performing Simple Cal
Create an XForms bind with the calculate attribute instead of placing a compute on the value 
option to dynamically calculate a field’s value.  The following example is a common 
implementation of a field whose value is the result of a mathematical calculation. 
 
<value compute=”priceField.value * ‘1.07

<bind nodeset=“totalPrice” calculate=“../price * 1.07” /> 
 
The first c

store the result of t

tain the product stored in the “totalPrice” element.
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9. Appendix A - Learning Eclipse Components 
The new Workplace Forms Designer has been built on the Eclipse platform. By building it on an 
existing framework we have been able to leverage several features that are already available 

o create them. 

many form building 
techniques that are better suited to this new paradigm. This section has been written to help 

e 
disc DL 
form

9.1.  a Perspective? 
iews. A perspective is used to define what views are 

pres t provides a 
specific functionality. Some examples of views are the properties view (which displays all the 

em), design view (drawing space), and outline view (shows all the 
objects that have been created). Each of these views can be added to a perspective so that every 
time  can share the 
same views. 

The Wo ectives. The Designer perspective 
is the default perspective for creating and modifying forms. The Views that belong to the Designer 
per eview, the item 
pale  
XForms al information about Perspectives please refer to the Eclipse help, 
which can be found by selecting Help > Help Contents from the File menu and entering 

r

9.1.1. How Do I Activate a Perspective? 
Ecli es can be activated from the File Menu; 
sele t contains all of the 
perspectives that are available. Select the perspective you wish to open and click OK. 

The per er of the interface. Each tab is a 
button linked to its perspective, pressing the Designer button activates the Designer perspective. 

 

without having t

Learning the Eclipse platform can be a bit daunting at first but there are 

prepare you for the task of building forms in the new Designer. The Eclipse components will b
ussed in the context of how IBM’s Workplace Forms Designer leverages them to build XF
s. 

What is
Eclipse is composed of perspectives and v

ent and where they appear on the screen. A view is a moveable window tha

properties of the selected it

 the perspective is opened these views will be present. Multiple perspectives

rkplace Forms Designer comes with two default persp

spective are the: properties view, instance view, design view, source view, pr
tte, the outline view, enclosures view, problems view, tasks view, bookmarks view and 

 view.  For addition

“pe spectives” as the search criteria. 

pse comes with several other perspectives. Perspectiv
ct Window > Open Perspective > Other… A dialog will appear tha

spectives will appear as tabs in the upper right-hand corn
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9.1.2. Customizing a Perspective 
The layout o
Views are designed as “tabs” within the Designer interface, if you click and hold a tab then you 
can e as you move 
it around the perspective. Take some time once you have familiarized yourself with the multiple 
views to cust

9.1.3. e
If you have c nal layout, 
right-click the perspective button (in the top right-hand corner) and select Reset. 

9.1.4. Clo
Clo the corresponding button from the perspective toolbar. Close a 
perspective by right-clicking its button and select Close. Hidden or closed perspectives can be re-

e

9.1.5. Sa
Perspec ny changes made to their layout. However if you 
wan  a default perspective and save it with a different name then right-click the 
perspective button and select Save As… Once you give your perspective a name then a button 

f the views within a perspective can be customized to suit your needs. All of the 

 move it to a different location in the Perspective. The View will “snap” into plac

omize their arrangement. 

setting a Perspective R
ustomized the layout of a perspective and want to revert back to the origi

sing a Perspective 
sing a perspective will remove 

ned from the File Menu. op

ving a Customized Perspective 
tives will automatically “remember” a

t to customize

will be created in the perspective tab for quick access to it. 
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9.2. The Resource Perspective 
The Re
Resource perspective contains all the previous views but adds the Navigator view and its layout 
is also differe

9.2.1. Ma g
What is a Project? 

A project is th b  related to a particular function 
or applicatio

How Do I Create a Project? 

A projec

1. 

2. 

 

source perspective is the default perspective for managing projects and files. The 

nt from the Designer perspective. 

na ing Your Files 

e asis for all form development; it groups all the files
n. All forms must exist within a project. 

t can be created from the File Menu:  

Select File > New > Project. 

Select Next. 
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3. Enter a project name. By default the project will be created in the Eclipse Workspace (that is 
can be defined every time Eclipse is launched). 

 

4. Click Finish. 

How Do I Create a New File? 

Onc
seen in
Vie
project 

the 

 

 

 

 

 

e the project has been created then it can be 
 the Navigator View. Open the Navigator 

w and look for your new project. Right click the 
and select New > New Workplace Form. 

Provide the project where the file will be stored and 
name of the file. 
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Click Next >.  Now you can choose between a series of templates.  Select the desired t
k Finish. 

emplate 
and clic

 

How Do I Import an Existing File Into an Existing Project? 

Sometimes files have already been created and you want to import them into a new project. 
Import an existing file into a project by right-clicking the project (in the Navigator View) and 
selecting Import. 

There are several different locations from which a file can be imported; select the import source 
and click Next. The dialogs will be different for each import source and will not be covered in this 
document. For more information please refer to the Eclipse Help. 
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Comparing Your Current File Against the Local History? 
Once it is open you can access the local history for any file in the current project. Right-click th
desired file and choose Compare With > Local History. 

9.4.3. 
e 

9.4  D  Local History? 
ck to one 

ry, 
en 

 

 file 

The difference 
between the files 
is highlighted 

were saved. 

The current The saved file

A list of the files 
and the time they 

.4. How o I Replace a File With One From the
There is a procedure that if after changing a file you determine that you want to revert ba
of the saved editions stored in the local history. To replace a file with one from the local histo
right-click the file and select Replace With > Local History… select the desired edition and th
press the Replace button. 
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9.5. Problems View 
For informati
selecting Help > Help Contents File
criteria. 

Tasks Vie
For information about the Tasks View please refer to the Eclipse help, which can be foun
selecting Help > Help Contents from the File menu and entering “tasks view” as the sea
criteria. 

on about the Problems View please refer to the Eclipse help, which can be found by 
 from the  menu and entering “problems view” as the search 

9.6. w 
d by 
rch 
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Notices 
This information was developed for products and services offered in the U.S.A.  

IBM may not offer the products, services, or features discussed in this document in other 
countries. Consult your local IBM representative for information on the products and services 

ration of any non-IBM product, program, or service. 

ply to the United Kingdom or any other country where 
such provisions are inconsistent with local law:  

 “ 
UT 

ou.  

iate 
. 

information about it for the purpose of enabling: (i) 
the exchange of information between independently created programs and other programs 

IBM Corporation Office  

U.S.A. 

Such information may be available, subject to appropriate terms and conditions, including in 
some cases, payment of a fee.  

The licensed program described in this information and all licensed material available for it are 
provided by IBM under terms of the IBM Customer Agreement, IBM International Program 
License Agreement, or any equivalent agreement between us.  

currently available in your area. Any reference to an IBM product, program, or service is not 
intended to state or imply that only that IBM product, program, or service may be used. Any 
functionally equivalent product, program, or service that does not infringe any IBM intellectual 
property right may be used instead. However, it is the user’ responsibility to evaluate and verify 
the ope

The following paragraph does not ap

INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS PUBLICATION
IS” WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, B
NOT LIMITED TO, THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, 
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some states do not allow 
disclaimer of express or implied warranties in certain transactions, therefore, this statement may 
not apply to y

This information could include technical inaccuracies or typographical errors. Changes are 
periodically made to the information herein; these changes will be incorporated in new editions of 
the publication. IBM may make improvements and/or changes in the product(s) and/or the 
program(s) described in this publication at any time without notice.  

IBM may use or distribute any of the information you supply in any way it believes appropr
without incurring any obligation to you

Licensees of this program who wish to have 

(including this one) and (ii) the mutual use of the information which has been exchanged, should 
contact: 

4360 One Rogers Street  
Cambridge, MA 02142  
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Any performance data contained herein was determined in a controlled environment. Therefore, 
ents 

f 
le data for their specific environment.  

 products was obtained from the suppliers of those products, their 
er publicly available sources. IBM has not tested those products 

ssed to the 

’s suggested retail prices, are current and are subject to change 

d in daily business operations. To 
illustrate them as completely as possible, the examples include the names of individuals, 
companies, brands, and products. All of these names are fictitious and any similarity to the 
names and addresses used by an actual business enterprise is entirely coincidental.  

Trademarks  
IBM, the IBM logo, Workplace Forms, DB2, and WebSphere are trademarks of International 
Business Machines Corporation in the United States, other countries, or both:  

Java and all Java-based trademarks are trademarks of Sun Microsystems, Inc. in the United 
States, other countries, or both.  

Other company, product, or service names may be trademarks or service marks of others. 

the results obtained in other operating environments may vary significantly. Some measurem
may have been made on development-level systems and there is no guarantee that these 
measurements will be the same on generally available systems. Furthermore, some 
measurements may have been estimated through extrapolation. Actual results may vary. Users o
this document should verify the applicab

Information concerning non-IBM
published announcements or oth
and cannot confirm the accuracy of performance, compatibility or any other claims related to non-
IBM products. Questions on the capabilities of non-IBM products should be addre
suppliers of those products.  

All statements regarding IBM’s future direction or intent are subject to change or withdrawal 
without notice, and represent goals and objectives only.  

All IBM prices shown are IBM
without notice. Dealer prices may vary.  

This information is for planning purposes only. The information herein is subject to change before 
the products described become available.  

This information contains examples of data and reports use
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