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New features and improvements

The following improvements have been made in this release of the Designer. For
detailed information about these improvements, see the Workplace Forms ' Designer
User’s Guide.

Form templates

You can now create a new form based on one of several pre-defined templates:
* A form with a horizontal tabbed toolbar

* A form with a vertical tabbed toolbar

¢ A form with an attachment popup toolbar

* A form with a striped toolbar

* A form with a styled button toolbar

¢ A form with a three color banner.

You can also use any form that you have created as a template.
Table Wizard

The Designer now includes a Table Wizard for easily setting up XForms tables. You
can access the wizard using the Table (Repeat) By Wizard tool in the Palette.

Note: This tool is only displayed in the Palette if your form contains XForms.
Palette re-organization

The XFDL 7.0 and XForms 1.0 drawers in the Palette have been merged,
reorganized, and renamed to Standard Library. Tools that create XForms items
have also been renamed.

If your form contains XForms, then the Standard Library includes tools for creating
all XFDL and XForms items. If your form does not contain XForms, then the
Standard Library only includes tools for creating XFDL items.

Object library

The Palette now includes an Object Library containing tools that let you easily
create several predefined objects:

¢ Canadian address block consisting of several fields with constraints

* U.S. address block consisting of several fields with constraints

e Phone number field using a (###) ###-#### template

* Phone number field using various patterns

* Canadian postal code field using a A#A #A# pattern

* U.S. zip code field using a ##### or #####-#HHH# pattern

* Popup list of Canadian provinces that stores the full province name

* Popup list of Canadian provinces that stores the abbreviated province name
* Popup list of U.S. states that stores the full state name

* Popup list of U.S. states that stores the abbreviated state name.
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* Social Insurance Number field using a ###-###-##Ht pattern
* Social Security Number field using a ###-##-#### pattern

You can also create your own custom objects using an improved export interface.

Note: Custom objects can include XForms interface items; however, they cannot
contain XForms model elements (for example, instance data).

Note: The new custom object functionality replaces the export functionality that
was in Designer 2.6.

Properties view

The following improvements have been made to the Properties view:
* You can now list properties in alphabetical order.

* The Advanced category has been renamed to Miscellaneous to avoid confusion
with Show Advanced Properties.

* The Show Categories, Show Advanced Properties, and Sort Alphabetically
settings are now saved when you exit the Designer.

Online help

The Designer User’s Guide is now available as an online help system:
http:/ /publib.boulder.ibm.com/infocenter /wf/v2rém1/index.jsp

Creating fields from instances

When you create a field by dragging an instance from the Instance view and
dropping it onto the canvas, the Designer now inserts a field and label on the
form. (The label text is the name of the element.) Previously, dragging an instance
from the Instance view and dropping it onto the canvas would only insert a field
on the form.

Creating fields with labels

You can now simultaneously insert a field and label on the form using the new
Field with Label tool in the Palette.

Hiding invisible items

You can now hide all items that have a visible value of off using the Hide items
that have their visible property turned off check box in the Preferences window.
This can make it easier to work with forms that contain many invisible items.

Nudging items

You can now nudge items by one pixel at a time by selecting them and pressing an
arrow key. You can also nudge items by the grid spacing distance by holding
down the Ctrl key and pressing an arrow key.

Showing views
You can now show all Designer views directly from the Window » Show View

menu. Previously, you had to open Window » Show View » Other to show certain
Designer views.


http://publib.boulder.ibm.com/infocenter/wf/v2r6m1/index.jsp

Inserting a new page

When you insert a new page onto a form, the canvas now displays a watermark
indicating that it is a new blank page. Previously, the canvas would become
entirely blank.

Eclipse menus

Eclipse menu items that were not required for users of the Designer have been
removed from the interface.

Selecting cases

When you right-click an XForms switch and click Active Case to list the switch’s
cases, the selected case is now indicated by a check mark. Previously, the selected
case was dimmed in the list.

Preview

If you click the Preview tab and do not have the 2.6 version of the Viewer installed
on your system, the message that is displayed now clearly indicates that you must
have the 2.6 version of the Viewer installed to preview forms in the Designer.
Previously, the message simply indicated that the Designer was unable to preview
the form.

Switching from Source tab to Design tab

The following improvements have been made when switching from the Source tab
to the Design tab:

* When you switch from the Design tab to the Source tab and edit the form, and
then switch back to the Design tab, the page that was originally displayed in the
Design tab is re-displayed and the item that was originally selected in the
Design tab is selected. Previously, the first page of the form would be displayed,
no matter which page was originally displayed.

* When you switch from the Source tab to the Design tab, and your form does
not validate against the XFDL schema, a message window is displayed clearly
indicating that you cannot return to the Design tab because of the schema
validation error. Previously, a technical message would be displayed in the
Problems view, so it was not obvious why you could not return to the Design
tab.

* When you make an edit in the Source tab and then switch to the Design tab, a
progress bar is now displayed while the form interface is rendered.

Copying and pasting between pages

The following improvements have been made to copy and paste:

* When you copy and paste an item from one page to another, it is pasted to the
same XY location as the original item. Previously, the item would be pasted into
the top left corner of the form.

* When you copy an item that contains an image, and the item does not specify
on which page the image file is enclosed, and then you paste the item onto a
different page, the pasted item will also contain the image. Previously, the
pasted item would not contain the image.
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Note: When creating items with images in the Designer, by default the item
specifies the page on which the image file is enclosed. However, if you
are using legacy forms or creating or modifying forms in the Source tab
or in a text editor, you may not always explicitly specify the page on
which an image file is enclosed.

Creating project sub-folders

You can now create a folder within a project by clicking File > New Folder.
Previously, you had to click File » New » Other, expand Simple, and select Folder.

Opening older forms

If you open a form that is based on XFDL 6.x, the Designer now asks if you want
to upgrade the form to XFDL 7.0. Previously, the Designer would open the form in
the Source tab without upgrading it to XFDL 7.0.

Navigator view
Project files (*.project) are no longer displayed in the Navigator view.
Default project

The default project has been renamed from Workplace Forms Designer to My
Forms.

Compute Wizard

The Compute Wizard now includes a larger area for manually creating formulas.
You can also increase this area by re-sizing the Compute Wizard window.

View menu settings

The View menu settings now apply to all open forms, and the settings are now
saved when you exit the Designer:

* View » Show Grid

* View » Snap To Grid

* View » Snap To Geometry
* View » Show Rulers

* View » Show Page Size.

Feedback pages

You can now easily provide feedback on the Designer and the Designer
documentation by clicking Help » IBM Product Feedback and Help » IBM Help
Feedback.

Customizing the Palette

You can no longer customize the Palette by right-clicking the Palette and clicking
Customize. Previously, these settings were not saved after exiting the Designer.

Fixed limitations

The following limitations have been fixed in this release of the Designer:



* You can once again use &#xA; in your source code to define line breaks. Use of
&#xA in Workplace Forms Designer 2.6 would not maintain line breaks. Code
samples in the documentation use &#xA; extensively, so you can once again
copy code samples from the documentation and paste them into the Designer
and line breaks will be maintained.

¢ The Compute Wizard now accepts valid computes containing the set method
and an empty value.
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Appendix. Notices

This information was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user’s responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not grant you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation

North Castle Drive
Armonk, NY 10504-1785
US.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM
Intellectual Property Department in your country or send inquiries, in writing, to:

IBM World Trade Asia Corporation
Licensing

2-31 Roppongi 3-chome, Minato-ku
Tokyo 106-0032, Japan

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law:
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS
FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement may not apply
to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.
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Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

IBM Corporation
Office 4360

One Rogers Street
Cambridge, MA 02142
US.A.

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this information and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement, or any equivalent agreement
between us.

Trademarks

The following terms are trademarks of International Business Machines
Corporation in the United States, other countries, or both:

AIX

IBM

Workplace
Workplace Forms

Other company, product, or service names may be trademarks or service marks of
others.
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