
This is the Tech Preview document for PL/I support of EST single service projects in WD/z 7.0.1.
The following table summarizes important information about EST single-service projects for PL/I:

	

	Scenarios
	Action
	Description
	Supported File Extensions
	Supported Runtimes

	Create New Service Interface (bottom-up)
	Create XML conversion artifacts (compiled only) for target runtime.
	Generate a Web service description and runtime specific XML message processing from a high level language structure. You can use this option when you expose an application program as a service provider.
	.pli, .inc, .mac
	· Batch, TSO and USS 

· IMS™ SOAP Gateway 


Overview of the IMS SOAP Gateway for PL/I
The IMS SOAP Gateway is a Web service solution that integrates IMS assets in a Service-Oriented Architecture (SOA) environment.

The IMS SOAP Gateway enables IMS applications to interoperate outside of the IMS environment through SOAP to provide and request services independent of platform, environment, application language, or programming model.

You can enable an IMS™ PL/I application for Web services by using a wizard from the Enterprise Service Tools to generate Web service files for the PL/I application. You then deploy these Web service files to the IMS SOAP Gateway to make an IMS application available as a Web service. Different types of client applications, such as Microsoft®.NET, Java™, and third-party applications, can then submit SOAP requests into IMS to drive the business logic of the PL/I applications.

There are two main steps to enabling your IMS application as a Web service running in the IMS SOAP Gateway environment: 

1. Use the Create New Service Interface (bottom-up) wizard from the Enterprise Service Tools to generate Web service files for your IMS application. (The generated files are described in the next paragraph.) 

2. Use the IMS deployment utility to deploy the Web service interface to IMS SOAP Gateway. (The IMS deployment utility allows you to define connection and correlation information for the Web service.) 

In the first step, you use the Create New Service Interface (bottom-up) wizard from the Enterprise Service Tools to generate the Web service files from an existing PL/I source file in your IMS application. The source file must contain the inbound and outbound interface data structures for your IMS application. In most cases you do not have to modify or add to your existing IMS application source code. 

The wizard generates the following Web service files: 

· A Web Services Description Language (WSDL) file, which describes the Web service interface of the IMS application so that the client can communicate with the Web service. 

· A correlator file, which contains information that enables the IMS SOAP Gateway to set the IMS properties and call the IMS application. 

· A PL/I source file that contains a Web service driver and runtime XML conversion programs. These runtime XML conversion programs convert inbound and outbound data in XML format, which is the format used by SOAP, to and from the inbound and outbound PL/I interface data structures in your IMS application. 

For more information about using the IMS SOAP Gateway, including samples, see IMS SOAP Gateway documentation and the IMS SOAP Gateway web site at http://www.ibm.com/ims.

Generating Web service files from the IMS application

Use the Enterprise Service Tools to generate the artifacts that are needed to enable your existing IMS™ PL/I application to run as a Web service in the IMS SOAP Gateway environment.

To generate the artifacts that are needed to enable an existing  PL/I application for the IMS SOAP Gateway, you must have a PL/I include file that describes the format of the input and output messages for the IMS application.

Because artifacts generated by the Enterprise Service Tools wizard (the WSDL file, the correlator file, and the PL/I  source file containing the Web service driver and the runtime XML conversion programs) must be transferred to a z/OS® system, you can use the z/OS Projects perspective and a Local Project in the WebSphere® Developer for System z to assist with this task.

To generate Web services artifacts for the IMS SOAP Gateway: 

1. Open the z/OS Projects perspective: 

a. Click the Open Perspective icon. The Open Perspective window opens. 

b. In the Open Perspective window, select z/OS Projects. The z/OS Projects perspective opens. 

2. Create a Local Project (Workstation COBOL or PL/I): 

a. On the workbench's main menu bar, select File > New > Project. The New Project wizard opens. 

b. In the New Project wizard: 

i. Expand Workstation COBOL or PL/I. 

ii. Select Local Project. The New Local Project wizard opens. 

c. In the New Local Project wizard, follow the steps to create a new local project. 

3. Verify that the Navigator view is open in the z/OS Projects perspective; a Navigator tab should be visible on the interface. If the Navigator view is not open, follow these steps to open the Navigator view: 

a. In the workbench's menu bar, select Window > Show View > Other. The Show View wizard opens. 

b. In the Show View wizard: 

i. Expand General. 

ii. Select Navigator. 

iii. Click OK. 

The Navigator view opens. 

4. Import into your local project the PL/I include file that contains the data structures that describe the input and output data structures of your IMS application. The imported file should also be visible in the Navigator view. The following table describes the files that can be used by the currently supported PL/I wizards: 

	Wizard:
	Supported File Extensions

	Create New Service Interface (bottom-up) 
	.pli, .inc, .mac


5. Start the Enterprise Service Tools Wizard Launchpad from the Navigator view: 

a. In the Navigator view, right-click the imported source file (file with a .pli, .inc, .mac extension) that contains the input and output data structures of the IMS application. 

b. Select Enable Enterprise Web Service. 

The Enterprise Service Tools Wizard Launchpad wizard opens. 

6. Launch the Create New Service Interface (bottom-up) wizard: 

a. In the Enterprise Service Tools Wizard Launchpad wizard: 

i. In the Runtime list box, select IMS SOAP Gateway. 

ii. In the Scenario list box, select Create New Service Interface (bottom-up). 

iii. In the Conversion type list box, select Compiled XML Conversion. 

iv. Click Start. 

The Create New Service Interface (bottom-up) wizard opens. 

7. On the first page of the wizard (entitled Language structures): 

a. Click the button Change PL/I Preferences. The Preferences window opens and displays the PL/I preferences in the right pane. 

b. In the PL/I preferences: 

i. On the General tab: 

1. Expand the Platform list box and select z/OS. 

2. Do not change any other options on this tab. 

ii. Click OK. The Preferences window closes. 

c. In the Inbound Language Structure tab, select the PL/I structure that is the input structure for your IMS application. (By default the first structure defined in the program source file is selected.) 

d. In the Outbound Language Structure tab, select the PL/I structure that is the output structure for your IMS application. (By default the first structure defined in the program source file is selected.) 

e. Click Next. 

8. On the second page of the wizard (entitled Generation Options): 

a. In the XML Converters tab: 

i. In the list box Host code page select the code page that the host uses. 

ii. In the list boxes Inbound code page and Outbound code page, select 1208 Unicode, UTF-8. 

Note: At this time the IMS SOAP Gateway runtime supports only UTF-8. 

b. In the WSDL and XSD tab: 

i. In the Service Location input field, change the host name and port name to the location of the IMS SOAP Gateway. 

Note: This URI specifies the address of the Web service.

ii. Do not change any other fields. 

c. Click Next. 

9. On the third page of the wizard (entitled IMS SOAP Gateway Web Service Provider): 

a. In the Correlator Properties tab, specify any correlator properties that need to be specified for your IMS SOAP Gateway environment. In particular: 

i. In the input field Correlator file container specify the folder and subfolder in which you want the correlator file to be generated. 

Note: You can generate artifacts directly to the USS file system (see Generating artifacts remotely).

b. Click Next. 

10. On the fourth page of the wizard (titled File, data set, or member selection): 

a. In the XML Converters tab: 

i. In the input field Converter file container, specify the folder and subfolder in which you want the converter programs to be created. 

ii. In the input field Converter driver file name, type the name of the file in which you want the converter programs to be generated. 

Note: Make sure that the check box Generate all to driver is selected. This causes all the generated Web service programs (driver, inbound converter, and outbound converter) to be placed in the same file. 
Note: You can generate artifacts directly to MVS (see Generating artifacts remotely)

b. In the WSDL and XSD tab: 

i. In the input field WSDL file container, specify the folder and subfolder in which you want the WSDL and XSD files to be generated. 

ii. Make sure that the check box preceding the input field WSDL file name is selected. 

iii. In the input field WSDL file name, type the name of the file in which you want the WSDL document to be created. 

iv. Clear the check boxes preceding the input fields Inbound XSD file name and Outbound XSD file name. 

Notes: 
1. The XSD files are not required by IMS SOAP Access. However, as an option, you can select these two check boxes to cause the two XSD files to be generated.

2. You can generate artifacts directly to the USS file system (see Generating artifacts remotely).

c. Click Finish. 

The following files are generated: 

· The WSDL file (.wsdl). 

· The correlator file (.xml). 

· The file containing the Web service driver and runtime XML conversion programs (.pli). 

· The inbound and outbound XSD files (.xsd). 

After you create the Web Services files, the next step is to deploy the Web service files to the IMS SOAP Gateway using the IMS SOAP deployment utility (see Deploying the Web service files to the IMS SOAP Gateway). 

Deploying the Web service files to the IMS SOAP Gateway

This topic provides a brief overview of the tasks required to deploy the generated Web service files to the IMS SOAP Gateway.

For information about completing the IMS SOAP Gateway tasks listed in this topic, see the IMS SOAP Gateway web site at http://www.ibm.com/software/data/ims/soap/.

To deploy the generated Web service files to the IMS SOAP Gateway:

1. Install the IMS™ SOAP Gateway. 

2. Configure IMS Connect for the IMS SOAP Gateway. (Note: IMS Connect must be installed and properly configured.) 

3. Locate the Web service files that you generated using the Create New Service Interface (bottom-up) wizard from the Enterprise Service Tools (see Generating Web service files from the IMS application). 

4. Deploy the Web service files to the IMS SOAP Gateway using the IMS SOAP deployment utility. 

5. Create the client application. 

6. Run the client application. 

Setting preferences for PL/I  XML converters

Setting the preferences for PL/I XML converters affect EST single-service projects, including: 

· IMS SOAP Gateway projects 

· Batch, TSO, USS projects 

These preferences affect how runtime XML conversion programs generated by EST single-service wizards in the Enterprise Service Tools convert data between the XML format used in Web service requests and responses and the high-level language data structures used by PL/I:

To set generation preferences for runtime XML conversion programs: 

1. On the workbench menu bar, select Window > Preferences. The Preferences window opens. 

2. In the left pane of the Preferences window, select Enterprise Service Tools. 

Note: If the Enterprise Service Tools entry is not listed in the Preferences window, see IMPORTANT: Enabling the Enterprise Service Tools.

3. Select PL/I XML Converters
4. Change the preferences: 

	Preference:
	Effect of this preference:

	Converter program name prefix
	This input field specifies the entry label for the procedure. If you type ACCT, for example, the wizard identifies the input converter program as ACCTI, the output converter program as ACCTO, and the driver as ACCTD

	Author name
	This input field is embedded as a PL/I comment.

	Inbound code page
	This list box specifies the code page to be used for encoding the inbound XML message.

	Host code page
	This list box specifies the code page that is used by the z/OS host system.

	Outbound code page
	This list box specifies the code page to be used for encoding the outbound XML message.


· Click OK when done. 

Language structures page

The Language structures page lists all the high-level language structures in the source file that you right-clicked before you started the wizard. The file that you right-clicked should contain both the inbound language structure and the outbound language structure for your application.

Follow these steps to complete this page: 

1. On the Inbound Language Structure tab, select the data structure that is the inbound data structure of your existing application (that is, the data structure with which your application is invoked). 

2. On the Outbound Language Structure tab, select the data structure that is the outbound data structure of your existing application (that is, the data structure that your application returns when it terminates). 

3. a. Click Change PL/I Preferences button to open the Importer > PL/I preferences page. These preferences control how PL/I files are imported (see Setting Importer > PL/I preferences).
b. Click Change PL/I Preferences button  Change PL/I Preferences button to open the Importer > PL/I preferences page. These preferences control how PL/I files are imported (see Setting Importer > PL/I preferences).
Setting Importer > PL/I preferences

Use these preferences to control how PL/I files are imported. These settings affect all PL/I files that you import into the workspace, for any project.

To set preferences for importing PL/I files: 

1. On the workbench menu bar, select Window > Preferences. The Preferences window opens. 

2. In the left pane of the Preferences window, expand Importer and select PL/I.
Note: When using XSE/PLI functions, UNCHECK  Enable IMS support.

3. Change the preferences (see the information below). 

For a more detailed description of these options see the Enterprise PL/I for z/OS Programming Guide Version 3 Release 6, available from the Enterprise PL/I for z/OS Web site.
On the General tab the options are as follows: 

Platform 

Specifies the target generation platform. Select the appropriate value from the pull down list. 

Code Page 

Specifies the code page for the locale. Select the appropriate value from the popup window. See Supported code pages (CCSIDs). 

Enable IMS support


Allows for IMS support, the PL/I converter to converts 4 bytes LL field to 2 bytes.
Floating point format
Specifies the floating point format. Select the appropriate value from the pull down list. 

Endian 

Select the appropriate value from the available options. 

Specify the PL/I options 
DBCS option
Select the appropriate value from the available options: NODBCS or DBCS
Graphic option 

Select the appropriate value from the available options: NOGRAPHIC or GRAPHIC 
File Extension Support 

Specify the file extension support. To change the value, select support for a specific file extension and then, using the pulldown arrow, select the new value from the pull down list. 

On the More PL/I options tab the options are as follows: 

Error message language 


Select the appropriate value from the available options.

LIMITS


Select the appropriate value from the available options.

Margins

Select the appropriate value from the available options.

Macro preprocessor


Select the appropriate value from the available options: NOMACRO or MACRO

Character conversion


Select the appropriate value from the available options: BLANK, CURRENCY, NOT, and OR

NAMES


Select the appropriate value from the available options.
Generation options page

The Generation options page sets generation options for the generated Web service files.

To set default values for some of the fields on this page, use the PL/I XML Converters page in the Preferences window (see Setting preferences for PL/I XML converters). 

On the PL/I XML Converters tab, specify the following options: 

Specify identification attributes 

Converter Program name prefix 

This input field specifies the entry label for the procedure. If you type ACCT, for example, the wizard identifies the input converter program as ACCTI, the output converter program as ACCTO, and the driver as ACCTD. 

Author name 

This input field is embedded as a PL/I comment. 

Inbound code page 

Specify the code page for encoding the XML input message. 

Host code page 

Specify the code page for the z/OS® host system. 

Outbound code page 

For more information see XML converter diagnostics.

PL/I Converter runtime storage information utility programs

The inbound and outbound XML converters provide utility programs for retrieving the sizes of the respective storage areas which must be provided when the converters are invoked. 

There are three storage areas which the caller may need to allocate dynamically before invoking the converters. These areas are for storing the following structures: 

· Inbound language structure 

· Outbound language structure 

· Outbound XML document 

Normally, users of Enterprise Service Tools (EST) need not be concerned with manually allocating these areas, since the generated converter driver handles the allocation of these areas in a runtime appropriate way. If the converters are deployed into a custom runtime environment, the utility programs described here can be useful to a component which dynamically selects converters to call without having any knowledge of the language structure definitions on which an XML converter is based. 

The IMS XML Adapter for IMS Connect is an example of a component which makes use of the utility programs. To remain stateless, the IMS XML Adapter relies on the utility programs to determine how much storage to allocate before invoking the converters. 

Inbound and outbound XML converter utility programs

The inbound and outbound XML converters consist of a suite of programs which work together to perform conversion. The following programs can be called before the main XML conversion program, to prepare the necessary storage areas or check boundary conditions. Note that the parameters passed to these programs are by reference and output only. 

	Name:
	Inbound Converter:[Program Name Prefix] + 'J'

	Description:
	Get inbound language structure storage requirements 

	Parameters:
	Name:
	Type:
	Output

	
	p_instruct_max_size
	4 byte signed binary
	Maximum length in bytes of the inbound language structure

	Name:
	Outbound Converter:[Program Name Prefix] + 'L'

	Description:
	Get outbound language structure storage requirements 

	Parameters:
	Name:
	Type:
	Output

	
	p_outstruct_max_size
	4 byte signed binary
	Maximum length in bytes of the outbound language structure 


	Name:
	Outbound Converter:[Program Name Prefix] + 'K'

	Description:
	Get outbound XML document storage requirements 

	Parameters:
	Name:
	Type:
	Output

	
	p_outxml_max_size
	4 byte signed binary
	Maximum length in bytes of the outbound XML document


Maximum length in bytes of a language structure 

The maximum length of a language structure uses the upper bound for all the variable length elementary and group items in the structure. This value represents how much storage would be occupied by the language structure in the worst case.

Maximum length in bytes of the outbound XML document

Based on the outbound language structure and the outbound XML schema, the tool will compute the maximum number of bytes which could be occupied by the outbound XML document. The computation takes several factors into account. They include: 

· Length of the XML element tag names 

· Maximum number of character positions in each data item when convertered to display format 

· Maximum number of bytes required to represent a character in each data item 

· Maximum number of occurrences of each data item 

· Expansion of the 5 predefined entities in XML (<,>,',",&). which are escaped to &lt;, &gt;, &apos;, &quot;, and &amp;. 

PL/I Converter driver aggregate utility program

The converter driver program suite contains a utility program which provides all the available information known to the converter. In addition to the information which can be learned from the inbound and outbound converter utility programs, the coded character set identifiers (CCSIDs) of the inbound, host and outbound codepages are also included.

	Name:
	Outbound Converter:[Program Name Prefix] + 'X'

	Description:
	1. Get language structure and XML message storage requirements. 

2. Get inbound XML, host and outbound XML code page information. 

	Parameters:
	Name:
	Type:
	Output:

	
	p_instruct_max_size
	4 byte signed binary
	Maximum length in bytes of the inbound XML document

	
	p_outstruct_max_size
	4 byte signed binary
	Maximum length in bytes of the outbound language structure

	
	p_outxml_max_size
	4 byte signed binary
	Maximum length in bytes of an XML Message derived from the outbound language structure

	
	p_inbound_ccsid
	4 byte signed binary
	Coded CharacterSet IDentifier for inbound XML

	
	p_host_ccsid
	4 byte signed binary
	Coded CharacterSet IDentifier for language structures

	
	p_outbound_ccsid
	4 byte signed binary
	Coded CharacterSet IDentifier for outbound XML


Message WSED0325U issued during generation of the XML Converters

The text of this message should read "The length of an XML document that can be derived from the outbound data structure exceeds 16,777,210 bytes". As described above, the tool computes the maximum size of the outbound XML document. The outbound XML converter is bounded in regards to the maximum size of an XML document it can generate. The upper bound is approximately 16 megabytes, because that is the size of the XML buffer declared in the converter. Receipt of the message WSED0235U during generation indicates that the outbound converter would not be able to buffer the outbound XML document in the worst case. Taking this into account, generation is halted to prevent creation of an outbound XML converter which may fail at runtime. 
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