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equivalents may be substituted, but the user must verify that such substitutes,
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Hewlett-Packard Company.
Intel is a registered trademark of the Intel Corporation.
Microsoft, TrueType, Windows, Windows 95, and Windows NT are
registered trademarks of Microsoft Corporation.
Motif is a trademark of Open Software Foundation, Inc.
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X Windows is a trademark of the Massachusetts Institute of Technology.
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About this publication

IBM EDMSuite OnDemand Version 2.20 provides an easy-to-use graphical
user interface that runs under Windows NT and Windows 95. This book gives
you an overview of OnDemand and how to use it to search for and view
documents.

Who should use this publication

This book is of primary interest to the end-users who use the graphical user
interface (GUI) to search for, view, and print documents. This book introduces
you to the basic features of OnDemand. For more information, please see the
OnDemand Windows NT or Windows 95 Help when you are using the
product.

How this publication is organized

This book contains the following sections:
v “OnDemand documentation” on page xii contains a list of books you might

find helpful when working with OnDemand and other components of the
system.

v “Chapter 1. Introducing OnDemand” on page 1 contains an overview of
OnDemand and the Server operating environment.

v “Chapter 2. Taking a test drive with OnDemand” on page 7 describes the
basic tasks associated with OnDemand.

v “Glossary” on page 31 contains a glossary of terms used in OnDemand.

v “Readers’ Comments — We’d Like to Hear from You” on page 37 contains
an index of the information contained in this book.

Product support

The IBM Support Center maintains current information about IBM EDMSuite
OnDemand, including program temporary fixes (PTFs).

Before you install OnDemand, contact the IBM Support Center or your IBM
software service representative to obtain the latest maintenance level of
OnDemand.
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If you encounter problems or errors running any of the OnDemand programs,
you can call the IBM Support Center to obtain software problem and defect
support. The phone number for the IBM Support Center is 1-800-237-5511. The
IBM EDMSuite OnDemand, Version 2 Release 2 program number is 5622–622
for AIX and 5639–E12 for NT.

OnDemand documentation

The following publications contain information about OnDemand Version 2.2:
Introduction and Planning Guide, G544–5281
Installation and Configuration Guide for AIX, G544–5280
Installation and Configuration Guide for NT, G544–5526
Installation Guide for OnDemand Clients, G544–5527
Administrator’s Reference, S544–5293
Indexing Reference, S544–489
Getting Started with the User Interface for OS/2, S544–5510
Getting Started with the User Interface for Windows 3.1, S544–5509
Getting Started with the User Interface for Windows NT and Windows 95,
S544–5469
Getting Started with the Administrator Interface for Windows NT and Windows
95, S544–5463
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Chapter 1. Introducing OnDemand

Welcome to IBM EDMSuite OnDemand—a system designed to help you get
control of information. You can use OnDemand for almost any process that
can benefit from hard copy or microfiche replacement and fast access to
information. OnDemand manages electronic archives of documents and
searches for and retrieves documents. You use OnDemand to view documents,
print and fax copies of documents or pages, and attach notes to documents.

This publication explains how to use the OnDemand Windows NT or
Windows 95 Client to quickly find the documents you need and the standard
features you have for working with documents. 1

Overview

OnDemand supports any organization that can benefit from hard copy or
microfiche replacement and instant access to information. An OnDemand
system can support small office environments as well as large enterprise
installations with hundreds of system users. OnDemand can dramatically
improve productivity and customer service in many businesses by providing
fast access to information contained in archived documents.

OnDemand processes the output of application programs, extracts index
fields, stores index information in a relational database, such as DB2, and
archives documents in ADSTAR Distributed Storage Manager. OnDemand’s
storage management system supports archiving newly created and frequently
accessed documents on high speed, magnetic storage volumes and can
automatically migrate documents to other types of storage volumes as files
age.

OnDemand fully integrates the capabilities of Advanced Function Presentation
(AFP), including management of resources, indexes, and annotations, and
supports full fidelity reprinting and faxing of documents on devices attached
to a PC, LAN, and server.

OnDemand provides the administrator with management programs, including
the OnDemand administrator interface, to manage OnDemand servers,
maintain OnDemand applications, archive documents, authorize end-users to
access OnDemand servers, and back up critical files and databases.

1. In this publication, the term ‘document’ includes report files and line data.
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OnDemand provides end-users the ability to view documents, print or fax
copies or pages of documents, and attach electronic notes to archived
documents.

Some of the advantages OnDemand offers over data archiving and retrieval
methods you may have used include the ability to:
v Retrieve the section of the document that you need without processing the

entire document.
v Easily locate data without knowing the individual document or cycle date.
v Print or fax a replica of the original document.

OnDemand provides you with an information management tool that can
increase your effectiveness when working with customers.

OnDemand does the following:
v Integrates data created by application programs into an online, electronic

information archive and retrieval system.
v Provides access to millions of reports at near real-time speeds.
v Retrieves the data you need when you need it.
v Provides capabilities to view, annotate, print, and fax documents.

These features mean that OnDemand can help you quickly retrieve the
specific page of a document that you need to provide fast customer service.

OnDemand documents

OnDemand documents represent indexed groups of pages. Typically an
OnDemand document is a logical section of a larger report, such as an
individual customer statement within a report file of thousands of statements.
An OnDemand document can also represent a portion of a larger report file.
For report files that do not have logical groups of pages, such as transaction
logs, OnDemand can divide the report file into 100 page objects. The 100 page
objects are individually indexed and can be retrieved to the client workstation
much more efficiently than the entire report file. Documents are usually
identified by name, for example, BANKSTMT, and date.

The OnDemand system

An OnDemand system consists of client programs and server programs that
communicate over a network running the TCP/IP communications protocol
and storage and database management programs that provide support for
various types of storage devices.
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Figure 1 shows an example of a typical OnDemand system. In the example,
OnDemand client programs communicate with the OnDemand servers over a
network running the TCP/IP communications protocol. Another OnDemand
client program communicates with OnDemand over telephone lines using
modems, also supported by TCP/IP. The OnDemand library server manages a
database of information about the users of the system and the documents
archived in OnDemand. An OnDemand object server, residing on a different
server connected to the network, manages the documents that reside on
magnetic and optical storage devices.
OnDemand client programs operate on personal computers running OS/2 or

Windows. The client program is your gateway to documents archived in
OnDemand. Using the client program, you can construct queries and search
for documents, retrieve items from OnDemand, view, print, and fax copies or
pages of documents, and attach electronic notes to document pages.

OnDemand servers manage control information and index data; store and
retrieve report files, resource group files, and documents; and process query
requests from OnDemand client programs. Documents can reside on magnetic

Object
Server
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Storage Volumes

OnDemand
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OnDemand
Client

OnDemand
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Client
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Figure 1. The OnDemand System.
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and optical storage volumes. New documents can be archived in OnDemand
every day. That way, OnDemand always retrieves the latest information
generated by application programs.

OnDemand client programs and servers communicate over a computer
network supported by TCP/IP. When you search for documents, OnDemand
sends a search request to the OnDemand library server. The library server
returns the list of items that satisfy your search request. When you select an
item for viewing, the client program retrieves a copy of the item from the
object server where the item resides, opens a viewing window, and displays
the item.

How to use this guide

This User’s Guide introduces you to the standard features of OnDemand. To
use OnDemand, your PC must communicate with a server over a network.
Please see your OnDemand administrator for information about the server
that contains the documents you need. Your OnDemand administrator can
also verify that you have the correct operating environment and other
information needed to use OnDemand.

About Windows NT or Windows 95

To gain the full benefits of OnDemand, first familiarize yourself with
Windows NT or Windows 95. This publication assumes you know how to use
Windows NT or Windows 95 and uses Windows NT or Windows 95 specific
terminology. For help with Windows NT or Windows 95, refer to your
Windows NT or Windows 95 documentation and the Windows NT or
Windows 95 Help (see Help after clicking on the Start button on the Taskbar).

Before you begin working with OnDemand

Before starting OnDemand and working with documents, we recommend the
following:
v Familiarize yourself with Windows NT or Windows 95 and using a

pointing device.
v Familiarize yourself with the OnDemand work space. When you start

OnDemand, the main window appears. The main window is where you
open folders, search for documents, and work with documents.

v Review “Chapter 2. Taking a test drive with OnDemand” on page 7. It
contains information about tasks you can perform with OnDemand. A
glossary of definitions of terms you will encounter using OnDemand can be
found on page 31.
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Install the OnDemand Client program. For more information about
hardware and software requirements and installing the Client, refer to IBM
EDMSuite OnDemand: Installation Guide for OnDemand Clients.

v Find the name of the OnDemand Server, your User ID and Password.
v Find the name of the folder that contains the documents you need.
v Locate the OnDemand program on your Windows NT or Windows 95

system. For more information, see “Starting the OnDemand Windows NT
or Windows 95 client” on page 7

Chapter 1. Introducing OnDemand 5
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Chapter 2. Taking a test drive with OnDemand

This section covers OnDemand essentials:
“Starting the OnDemand Windows NT or Windows 95 client”

“Logging on to a server” on page 10

“Updating server information” on page 12

“Opening folders” on page 17

“Searching for documents” on page 20

“Selecting and viewing documents” on page 23

“Using the OnDemand toolbar” on page 26

“Ending your OnDemand session” on page 28

Note: OnDemand processes documents and report files similarly. Therefore,
when this guide refers to documents, the information also applies to
report files.

Starting the OnDemand Windows NT or Windows 95 client

You can start the OnDemand Windows NT or Windows 95 client from
different places:
v “Starting from the desktop”

v “Starting from the Start menu” on page 8

v “Starting from the Run dialog box” on page 9

Starting from the desktop

To start the OnDemand Windows NT or Windows 95 client from the desktop,
follow these steps:
1. Locate the OnDemand icon on the desktop.
2. Double-click the OnDemand icon. The OnDemand application window

appears in the background. The Logon to a Server dialog box appears in
the foreground.
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OnDemand needs to know certain information to begin communicating with a
server. OnDemand collects this information in the Logon to a Server dialog
box. For more information about logging on, see “Logging on to a server” on
page 10 .

Starting from the Start menu

If you added the OnDemand Windows NT or Windows 95 client to your Start
menu during installation, you can start OnDemand from the Start menu by
following these steps:
1. Click the Start button on the Taskbar. Windows NT or Windows 95 opens

the Start menu.
2. Click on Programs on the Start menu with your mouse or with the arrow

keys, and Windows NT or Windows 95 opens the Programs folder.
3. Click on OnDemand32, and then click on OnDemand32 English.

Windows NT or Windows 95 opens OnDemand32.
4. The OnDemand application window appears in the background, and the

Logon to a Server dialog box appears in the foreground.
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OnDemand needs to know certain information to begin communicating with a
server. OnDemand collects this information in the Logon to a Server dialog
box. For more information about logging on, see “Logging on to a server” on
page 10 .

Note: For help with adding the OnDemand32 client to your Start menu,
consult your Windows NT or Windows 95 documentation or online
help. You may also ask your OnDemand administrator for help with
this task.

Starting from the Run dialog box

To start the OnDemand Windows NT or Windows 95 client from the Run
dialog box, follow these steps:
1. Click the Start button on the Taskbar. Windows NT or Windows 95 opens

the Start menu.
2. Click on the Run selection in the Start menu with the mouse or the arrow

key. Windows NT or Windows 95 opens the Run dialog box.
3. Type your OnDemand drive and folder, followed by arsgui32.exe

If you do not know the path, click on the Browse... button and use the
Browse dialog box to select it.

4. Click on the OK button. Windows NT or Windows 95 closes the Run
dialog box and starts OnDemand

5. The OnDemand application window appears in the background. The
Logon to a Server dialog box appears in the foreground.

Chapter 2. Taking a test drive with OnDemand 9



OnDemand needs to know certain information to begin communicating with a
server. OnDemand collects this information in the Logon to a Server dialog
box. For more information about logging on, see “Logging on to a server”.

Logging on to a server

To logon to an OnDemand server, follow these steps:
1. Select Logon... from the File menu. The Logon to a Server dialog box

appears.

2. If your OnDemand administrator has set up default servers, the names of
the default servers are listed in the pull-down list on the Server entry
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field. To access the pull-down list, click the arrow to the right of the
Server entry field and select a name from the list. If you cannot find the
server listed, choose the Update Servers... command button. The Update
Servers dialog box appears. See “Updating server information” on page 12
for more information on adding a server to the list in the Logon to a

Server dialog box or changing information for a server that is listed.

3. Type your OnDemand User ID and Password into the fields provided.
Press the Tab keyboard key to move from one field to another or use the
mouse to select them.

4. Choose OK or press the Enter keyboard key to complete the log on
process. OnDemand verifies your OnDemand User ID and Password on
the Server. When your OnDemand User ID and Password are verified, the
Open a Folder dialog box appears. See “Opening folders” on page 17 for
information on opening folders.

Note: The Logon... command is only available when you are not currently
logged on.

Figure 2. Logon to a Server with all entry fields filled out
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Updating server information

You use the Update Servers... command button on the Logon to a Server
dialog box to add a server to the list of servers you can access, to change
information for a server that you can access, or to delete a server from the list
of servers that you can access. You can change information for TCP/IP servers
and Local servers.

The first time that you start OnDemand, the Server entry field and the
pull-down list may not contain any entries. Check with your OnDemand
administrator for a list of servers that you need to enter for your use.

Updating information for TCP/IP servers

This section covers information about TCP/IP servers.

To add the name of a TCP/IP server to the list of servers:
1. Choose the Update Servers... command button on the Logon to a Server

dialog box. The Update Servers dialog box appears.

2. To add the name of a server to the list of available servers, type the name
of the OnDemand library server in the Server entry field. The server name
can be a TCP/IP host name alias, fully-qualified host name, or IP address.

3. Optionally, enter the TCP/IP host name alias, fully-qualified host name, or
IP address of the OnDemand library server in the Host Name entry field.
By default, Host Name contains the same value as Server.

4. Select TCP/IP as the Protocol, if it isn’t already selected. There are two
choices: TCP/IP and Local.

5. Verify the port number. This is the TCP/IP port number that the server
program monitors for client program requests.
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The default value, 0 (zero), means that OnDemand uses the port number
of the OnDemand service found in the /etc/services file. If you did not
register the OnDemand service, OnDemand attempts to use port number
1445.
If you did not register the OnDemand service and you plan to use a port
number other than 1445, you must enter a valid port number.

6. Choose the Add command button to include the server in your list of
server choices. If you don’t want to add the server, choose the Close
command button instead to return to the Logon to a Server dialog box.

7. Choose the Close command button to close the Update Servers dialog box
and return to the Logon to a Server dialog box.

To change information for an existing TCP/IP server:
1. Choose the Update Servers... command button on the Logon to a Server

dialog box. The Update Servers dialog box appears.

2. Select the server name from the Server pull-down list.
3. Make changes to the Host Name by typing over the name in the Host

Name entry field. By default, the Host Name contains the same value as
Server.

4. Make changes to the Port number by typing over the number in the Port
entry field.
The default value, 0 (zero), means that OnDemand uses the port number
of the OnDemand service. For more information about port numbers, ask
your system administrator.
If you did not register the OnDemand service and you plan to use a port
number other than 1445, you must enter a valid port number.

5. Choose the Update command button to change the information for the
server you selected on this dialog box. If you don’t want to change
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anything for the Server named in the Server entry field, choose the Close
command button before you use the Update command button to return to
the Logon to a Server dialog box.

6. When you have finished making changes for the server you are working
with, choose the Close command button to return to the Logon to a Server
dialog box and continue with the Logon task.

Updating information for local servers

There are three kinds of local servers:
v CD-ROM
v Network
v Hard Drive

To add your CD-ROM to the list of OnDemand servers:
1. Choose the Update Servers... command button on the Logon to a Server

dialog box. The Update Servers dialog box appears.

2. Type the name into the Server entry field that will be used to select the
CD-ROM drive (for example, suppose the drive letter of your CD-ROM is
d:, a name for your server could be CD-ROM-D). When you have more
than one CD-ROM drive, you need to be able to distinguish between the
drives.

3. Select Local from the Protocol pull-down list.
4. Enter the drive letter associated with your CD-ROM (for example, d:) in

the Directory entry field.
5. Choose the Add command button to include the server in your list of

server choices. If you don’t want to add the server, choose the Close
command button before you use the Add command button to return to
the Logon to a Server dialog box.
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6. Choose the Close command button to close the Update Servers dialog box
and return to the Logon to a Server dialog box.

To add your Network drive or Hard drive to the list of OnDemand servers:
1. Choose the Update Servers... command button on the Logon to a Server

dialog box. The Update Servers dialog box appears.

2. Type the name of the Network drive or Hard Drive server that you want
to use as an OnDemand server (for example, netusers or hdusers) in the
Server entry field.

3. Select Local from the Protocol pull-down list.
4. When you add a Network drive or a Hard Drive as an OnDemand server,

you must enter the directory or directory path to the server files in the
Directory entry field.

5. Choose the Add command button to include the server in your list of
server choices. If you don’t want to add the server, choose the Close
command button before you use the Add command button to return to
the Logon to a Server dialog box.

6. Choose the Close command button to close the Update Servers dialog box
and return to the Logon to a Server dialog box.

To change information for an existing Local server:
1. Choose the Update Servers... command button on the Logon to a Server

dialog box. The Update Servers dialog box appears.
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2. Select the server name from the Server pull-down list.
3. Make changes to the appropriate information for the server you are

working with.
4. Choose the Update command button to change the information for the

server you selected on this dialog box. If you don’t want to change
anything for the Server named in the Server entry field, choose the Close
command button before you use the Update command button to return to
the Logon to a Server dialog box.

5. When you have finished making changes for the server you are working
with, choose the Close command button to return to the Logon to a Server
dialog box and continue with the Logon task.

Deleting a server from the list of servers

To delete a server from the list of servers that you can access, follow these
steps:
1. Choose the Update Servers... command button on the Logon to a Server

dialog box. The Update Servers dialog box appears.
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2. Select the server name that you want to delete from the Server pull-down
list.

3. Choose the Delete command button on the Update Servers dialog box.
OnDemand removes the server from the list of servers that you can access.
If you don’t want to delete the server, choose the Close command button
before you use the Delete command button to return to the Logon to a
Server dialog box.

4. Choose the Close command button to close the Update Servers dialog box
and return to the Logon to a Server dialog box.

Opening folders

Your OnDemand administrator stores information in related collections called
folders. Think of a folder as a container for related information, such as
statements, invoices, or correspondence, just like a manila folder is used in a
metal filing cabinet. When you open a folder, you have access to the
information contained in that folder. For example, a billing folder could
contain the reports for customer transactions over the past two years.

Note: OnDemand displays the Open a Folder dialog box only if there is more
than one folder from which to choose. Otherwise, OnDemand displays
the Search Criteria and Document List dialog box immediately after
logging on the server. If you do not have to choose folders, skip the
following steps and go to “Searching for documents” on page 20.

To open a folder on your OnDemand client, follow these steps:
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1. Select Open Folder... from the File menu or choose the

toolbar button to display the Open a Folder dialog box.

The folders you can access appear in the Open a Folder dialog box.

2. To open a folder, double-click a folder name or choose a folder name and
then choose Open. The Search Criteria and Document List dialog box
appears.
See Figure 3 on page 19 for an example of the Search Criteria and
Document List dialog box.

Note: You can have more than one folder open at a time. When you are
working with multiple folders, OnDemand lists the folders you
have open in the Window menu.
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Note: The AutoScroll check box is not included in the Search Criteria and
Document List dialog box when the documents in the Document List
are generated in sorted order.

Figure 3. Description of the Search Criteria and Document List dialog box.
v Title Bar: The name of the folder you selected appears here. In this figure, it is Student Information.

v Search Criteria: The field names, operators, and entry fields are contained in this section.

v Search Criteria command buttons: Choose a command button to perform the action suggested by the caption.

v Logical operators performed on search entry fields. AND means the search must satisfy all search criteria. OR
means the search must satisfy at least one of the search criteria.

v Document List: OnDemand lists the documents that satisfy your search criteria here. Select the documents you
want to view or print from this list box.

v Document List command buttons: After completing a search, use these buttons to work with the documents listed
in the Document List.

– View All Selected: Choose this command button to view the documents you selected. OnDemand displays each
document in a separate display window.

– Print All Selected: Choose this command button to print the documents you selected.

– Sort List: Choose this option to resequence the documents in the Document List.

– Append: Check this item to place new search results after those already in the Document List.

– AutoScroll: Check this item to automatically scroll the Document List as search results are found.
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Searching for documents

Search for documents using the Search Criteria and Document List dialog box.
The name of the folder you selected appears in the title bar of the Search
Criteria and Document List dialog box.

To search for documents using the Search Criteria and Document List dialog
box, follow these steps:
1. Choose the

toolbar button or select Open Folder... from the File menu, if necessary, to
select a folder and display the Search Criteria and Document List dialog
box.

Figure 4 on page 21 is an example of the Search Criteria section of the
dialog box.
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Figure 4. Search Criteria section of the Search Criteria and Document List dialog box.
v Search field names: The number and names of the fields vary by folder. In this example, there

are 4 search fields.

v Search operators: OnDemand uses the standard search operators to search for documents. Click
the search operator button and OnDemand displays the Select Operator dialog box. The dialog
box lists the search operators available for the selected field. Figure 5 shows the Select Operator
dialog box for the Student ID search field.

Note: The specific operators available are set by the OnDemand administrator and will vary by
folder and search field.

v Search entry fields: Type text and numbers in these entry fields. When a search entry field has a
↓, click the ↓ to select from pre-set choices.

v Search Criteria command buttons: Choose a command button to perform the action suggested
by the caption.

v Search logical operators: AND means the search must satisfy all search criteria. OR means the
search must satisfy at least one of the search criteria.

Figure 5. Select Operator dialog box for Student ID search field
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2. Enter search criteria for OnDemand by typing text (for example, a
student’s name) and numbers (for example, a student’s ID number) into
search entry fields and selecting search operators.
v Press the Tab keyboard key to move from one entry field to another.

You do not have to type a value in every entry field. However, you may
need to type a value in at least one entry field. Check with your
OnDemand administrator about required values in the folders that you
access.

v Use wildcards with the Like and Not Like search operators to represent
other letters, numbers, or special characters. OnDemand uses two
wildcards. The _ (underscore) character matches any single letter,
number, or other special character. For example, if you type 1_0 in a
string field, OnDemand will find 100, 110, 120...190. The % (percentage)
character matches zero or more letters, numbers, or other special
characters. For example, if you type MARS% in a string field,
OnDemand will find MARS, MARSCH, MARSHELL, MARSTEENS, and
so forth.

v Choose search operator buttons to display the full range of operators
available for each field. Select a search operator for a field by choosing
one of the buttons in the Select Operator dialog box.

3. Choose Search. OnDemand fills the Document List with the documents
that satisfy your search criteria and updates the status bar with a count of
the number of documents. OnDemand lists the documents in the order
they occur on the server or the order chosen by the OnDemand
administrator.

4. OnDemand displays the following message in the first section of the
OnDemand status bar when it is searching the database:
Search is proceeding ... nnn documents have been selected.

where nnn is the number of documents that have satisfied the search
criteria.

If you need to stop a search, click the

toolbar button or press the space bar. OnDemand stops the search.

Most search requests will process quickly. It is possible for complex search
requests to take several minutes. The more specific the search criteria you
use, the less time OnDemand requires to complete a search. For example,
searching using the Equal operator (that is, Equal MARSHAL) takes less
time than searching using the Like operator (that is, Like MARSHAL).
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Note: If you selected the AutoView command on the Options menu with the
First Document choice, OnDemand automatically displays the first
document from the list of documents that satisfies your search criteria;
if you selected the AutoView command on the Options menu with the
Single Document choice and OnDemand finds only one document that
satisfies your search criteria, OnDemand automatically displays the
document for you.

Please see “Selecting and viewing documents” for information about selecting
and viewing documents.

Selecting and viewing documents

Select documents for viewing using the Document List section of the Search
Criteria and Document List dialog box.

Figure 6 on page 24 is an example of the Document List section of the Search
Criteria and Document List dialog box. Note the multiple document selection.
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The number of documents that you can view concurrently is determined by
the availability of system resources and the type of document. Typically fewer
AFP formatted documents can be displayed at one time, while a larger
number of line data documents can be displayed at one time. Experiment to
determine how many documents you can display at one time. OnDemand
displays each document you select in a separate window.

If you selected the AutoView command on the Options menu, you have the
following choices when viewing documents:

None AutoView is not enabled; OnDemand does not automatically display
a document found by a search.

First Document
OnDemand automatically displays the first document from the list of
documents that satisfy the search criteria.

Single Document
When OnDemand finds only one document that satisfies the search
criteria, OnDemand automatically displays the document for you.

Figure 6. Example of Document List when selecting and viewing documents.
v Field names for the folder you selected appear along the top of the Document List.

v Documents that satisfy the search criteria appear here. If necessary, use the horizontal scroll bar
to see the right-most fields and use the vertical scroll bar to scroll through the Document List.

v Use these Document List command buttons after selecting documents.

– View All Selected: Choose this command button to view the documents you selected.
OnDemand displays each document in a separate display window.

– Print All Selected: Choose this command button to print the documents you selected.

– Sort List: Choose this option to resequence the documents in the Document List.

– Append: Check this item to place new search results after those already in the Document
List.

– AutoScroll: Check this item to automatically scroll the Document List as search results are
found.

Note: The AutoScroll check box is not included in the Search Criteria and Document List
dialog box when the documents in the Document List are generated in sorted order.
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Selecting documents for viewing

To select documents for viewing, follow these steps:
1. Select documents from the Document List on the Search Criteria and

Document List dialog box using one of the following methods.
v Choose a single document you want to view.
v Place the pointer on the first document you would like to view. Click

the mouse button. Move the pointer to the next document you would
like to view. Hold down the Ctrl key and click the mouse button.
Release the Ctrl key. Repeat to select additional documents.

v Place the pointer on the first document you would like to view. Click
and hold down the mouse button. Drag the pointer to select a group of
documents. Release the mouse button.

v Place the pointer on the first document you would like to view. Click
the mouse button. Move the pointer to the last document you would
like to include in the group. Press and hold down the Shift key. Click
the mouse button. Release the Shift key.

2. Choose View All Selected. OnDemand displays the selected documents,
each in a separate window.
When you are selecting multiple documents for viewing, OnDemand
displays the following message in the first section of the status bar:
Document retrieval is proceeding for document name.

Note: Choose the

toolbar button or press the space bar to cancel the document
retrieval for the current document and any remaining documents
that you selected before choosing View All Selected.

Figure 7 on page 26 shows a displayed document in a window after you have
chosen the View All Selected command button on the Search Criteria and
Document List dialog box.
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Using the OnDemand toolbar

When you select Show Toolbar on the Options menu, OnDemand displays a
toolbar across the top of the application window, below the menu bar. Several
of the OnDemand toolbar buttons can help you display pages and quickly
navigate your way through documents. Figure 7 shows the OnDemand toolbar
above the displayed document.

Note: When the toolbar buttons are active, they are displayed in colors;
otherwise, they are grayed out.

Figure 7. Example of displayed document in a window
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Table 1. Description of OnDemand toolbar buttons

Choose To

Open an OnDemand folder. Choose this toolbar button and the Open a Folder dialog
box appears.

Print the page or pages you are viewing. Choose this toolbar button and the Print
dialog box appears.

Enlarge or reduce the image of the page you are viewing. Choose this toolbar button
and the Set Zoom Percent dialog box appears.

Navigate within the document you are viewing to a specific page. Choose this
toolbar button and the Go To dialog box appears.

Locate information in the document you are viewing. Choose this toolbar button and
the Find dialog box appears.

Locate a previous occurrence of the search string.

Locate the next occurrence of the search string.

Display the previous page of the document you are viewing.

Display the next page of the document you are viewing.

Add or view notes about the document you are viewing. Choose this toolbar button
and the Add a Note dialog box appears if there are no notes saved for the document
you are viewing or the Notes dialog box appears with the notes saved for the
document you are viewing.

Return to document. Choose this toolbar button to return to the document you were
viewing. This button is inactive when no documents have been selected for viewing.

Return to the Search Criteria and Document List dialog box. Choose this toolbar
button to return to the Search Criteria and Document List dialog box when you are
viewing documents.

Display the previous document you selected for viewing. Choose this toolbar button
to display the previous document when you are viewing multiple documents.
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Table 1. Description of OnDemand toolbar buttons (continued)

Choose To

Display the next document you have selected for viewing. Choose this toolbar
button to display the next document you have selected when you are viewing
multiple documents.

Retrieve and display the previous document in the Document List on the Search
Criteria and Document List dialog box. Choose this toolbar button to display the
previous document in the Document List for the folder you are working with.
OnDemand closes the document you are viewing before opening the previous
document.

Retrieve and display the next document in the Document List on the Search Criteria
and Document List dialog box. Choose this toolbar button to display the next
document in the Document List for the folder you are working with. OnDemand
closes the document you are viewing before opening the next document.

Display help for the topic or area of the screen you are pointing to. This tool lets you
explore the OnDemand window and get information about OnDemand commands.
When you choose this toolbar button, the pointer changes to an arrow and question
mark (like the icon on the toolbar button). Move this arrow and question mark to a
command or region of the OnDemand work place that you want more information
on, click once, and OnDemand displays information about the item in the help
window.

Stop the current operation. Choose this toolbar button to stop an operation, such as a
search, document retrieval, or find operation.

Ending your OnDemand session

This section describes the things you need to do when you are ready to close
documents or folders and to logoff the OnDemand server.

Closing documents

There are several ways to close documents:
v Select Exit OnDemand from the File menu to close the document you are

viewing and exit OnDemand. OnDemand asks you to confirm this choice.
Choose Yes in the dialog box to continue.

v Select Close Document from the File menu or press F3 to close one
document.

v Select Close All Documents from the File menu or press Alt + F3 to close
all open documents.

v Select Close Folder from the File menu or choose the Close Folder
command button in the Search Criteria and Document List dialog box to
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close the folder and all open documents. OnDemand asks you to confirm
this choice. Choose Yes in the dialog box to continue.

v Select

in the upper left corner of the document you are viewing and select Close.
OnDemand closes the document you are viewing and returns to the Search
Criteria and Document List dialog box.

v Select the

icon in the upper left corner and then select the Close command or press
Alt + F4 to close the documents, close the Search Criteria and Document
List dialog box, and exit OnDemand. OnDemand asks you to confirm this
choice. Choose Yes in the dialog box to continue.

v Select the

button to close the document you are viewing and open the previous
document in the Document List.

v Select the

button to close the document you are viewing and open the next document
in the Document List.

Closing folders

Use one of the following methods to close a folder without exiting
OnDemand or logging off a server:
v Choose the Close Folder command button on the Search Criteria and

Document List dialog box.
v Select Close Folder from the File menu.
v Select Close All Folders from the File menu.
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With these methods, OnDemand asks you to confirm before closing any open
documents. Choose Yes in the dialog box to continue.

Note: If you have more than one folder open and you select Close Folder
from the File menu, OnDemand closes the current folder. (OnDemand
places a check next to the current folder in the Window menu.)

Logging off a server

To log off a server, follow these steps:
1. Select Logoff from the File menu. OnDemand asks you to confirm before

closing any open documents.
2. Choose Yes in the dialog box to continue. OnDemand closes any open

documents and folders.
3. Select Exit OnDemand from the File menu. OnDemand logs off the

OnDemand server and ends your session.

Note: The Logoff selection is only available when you are logged on to a
server.

Stopping OnDemand

To stop OnDemand, follow these steps:
1. Select Exit OnDemand from the File menu, click the

icon in the upper left corner and then select the Close command, or press
Alt + F4. OnDemand asks you to confirm before closing any open
documents and logging off the server.

2. Choose Yes in the dialog box to continue. OnDemand closes any
documents, closes the folder, closes the Search Criteria and Document List
dialog box, logs off the server, and exits the program.
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Glossary

ACIF. AFP Conversion and Indexing Facility.

Advanced Function Presentation (AFP). A set
of licensed programs that use the all-points
addressable concept to print data on a wide
variety of printers. AFP also includes creating,
formatting, archiving, viewing, retrieving, and
distributing information.

Advanced Function Presentation Application
Programming Interface (AFP API). An AFP
program shipped with PSF/MVS 2.1.1 and
PSF/VM 2.1.1 that creates the AFP data stream
from the COBOL and PL/1 high-level
programming languages.

AFP Conversion and Indexing Facility (ACIF).
An AFP program you can use to convert a print
file into a MO:DCA–P document, to retrieve
resources used by the document, and to index
the file for later retrieval and viewing.

AFP. Advanced Function Presentation.

AFP API. Advanced Function Presentation
Application Programming Interface.

application. Within OnDemand, an application
is a definition for a specific type of document or
report, including the format of the pages, the
datastream, and logical view characteristics.
There is usually a direct correlation between an
OnDemand application and the host application
that produces output for OnDemand.

BookMaster. A powerful text-processing
program that uses DCF’s Generalized Markup
Language (GML) tags, the SCRIPT/VS text
formatter, plus additional tags, attributes, and
predesigned style files, all designed to create
complex documents.

client. A personal computer connected to a
network that requests documents from an
OnDemand server.

copy group. A portion of a form definition that
defines a set of modifications that can be used
when viewing a page. Modifications can include
text suppression, form flash, overlays, etc.

DCF. Document Composition Facility.

default. A value, attribute, or option that is
assumed when no alternative is specified by the
user.

default value. A value stored in the system that
is used when no other value is specified. See also
default.

dialog box. An application window on the
display that requests information from the user.

Document Composition Facility (DCF). An
IBM licensed program used to prepare printed
documents.

double-click. To rapidly press mouse button 1
twice while pointing to an object.

drag. To hold down mouse button 1 while
moving the mouse.

enter. (1) An instruction to type specific
information using the keyboard. (2) A keyboard
key that, when pressed, confirms or initiates the
selected command.

entry field. The place in a dialog box where you
type text and numbers. Use entry fields in
OnDemand to type search criteria.

folder. A folder is a container for related
information, such as statements, invoices, or
correspondence, just like a manila folder is used
in a metal filing cabinet. When you open a
folder, you have access to all the information
contained in that folder. For example, a billing
folder could contain all of the reports for all
customer transactions over the past two years.
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font. A family of characters of a given size and
style. For example, 10-point Helvetica.

icon. A 32 by 32 pixel bitmap used in Windows
to represent an application or other window.

LAN. Local area network.

line data. Data prepared for printing on a line
printer, such as an IBM 3800 Model 1 Printing
Subsystem. Line data is usually characterized by
carriage-control characters and table reference
characters.

line-data print file. A file that consists of line
data, optionally supplemented by a limited set of
structured fields.

local area network (LAN). A computer network
located on a user’s premises within a limited
geographical area. Communications within a
local area network is not subject to external
regulations; however, communication across the
LAN boundary may be subject to some form of
regulation.

menu bar. The area at the top of a window that
contains choices that give a user access to actions
available in that window.

mouse. A hand-held locator that a user operates
by moving it on a flat surface. It allows the user
to select objects and scroll the display screen by
pressing buttons.

named query. A set of entry field values on the
Search Criteria and Document List dialog box
that a user has named and saved for selection as
search criteria at a future time.

network. A collection of data processing
products that are connected by communication
lines for information exchange between locations.

notes. Comments, clarifications, and reminders
that can be attached to a document or report.

PC. Personal Computer.

Pitch. A unit of width of type, based on the
number of characters that can be placed in a
linear inch. For example, 10-pitch type has ten
characters per inch.

point. (1) To move the mouse pointer to a
specific object. (2) In measuring type, a unit of
about 1/72 of an inch. Characters in 72 point
type are one inch tall.

press. To touch a specific key on the keyboard.

Print Services Facility (PSF). An IBM program
product that manages printers and supports
printing AFP files and line data.

radio button. Round option buttons grouped in
dialog boxes; one is pre-selected. Like a radio in
an automobile, select only one button (“station”)
at a time.

select. To pick a menu command or other object
with a single click of the mouse.

server. A workstation connected to a network
that runs OnDemand programs. An OnDemand
server retrieves documents for client personal
computers.

string. A series or set of alphabetic or numeric
characters. A string can be composed of letters,
numbers, and special characters.

toolbar. The region directly beneath the menu
bar of the main window.

toolbar button. A small bitmap on the toolbar
that represents OnDemand commands. Click a
toolbar button to quickly access a command.

typeface. A specific style of type, such as
Helvetica or Times New Roman. See also Font.

type. To enter specific information using the
keyboard, typing characters exactly as given.

type size. A measurement in pitch or point of
the height and width of a graphic character in a
font. See also Pitch and point.

type style. Attributes of a font such as weight
(bold) or posture (italic).
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user. In OnDemand, a person authorized to
access applications on the server.

viewing window. The window in OnDemand
where you look at or browse documents.

wildcard. Search characters that represent other
letters, numbers, or special characters. In

OnDemand, the % (percentage) and the _
(underscore) are wildcard characters that can
only be used with the LIKE and NOT LIKE
search operators.
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toolbar buttons (continued)
display the previous document

28
Find 26
Find for next occurrence 26
Find for previous occurrence 26
Go To 26
print 26
retrieve and display the next

document in the document list
28

retrieve and display the previous
document in the document list

28
return to document 26
return to the Search Criteria and

Document List dialog box 26
stop the current operation 28
when viewing documents 26
zoom 26

toolbar for OnDemand 26

U
Update Servers dialog box 12
updating server information 12
using CD-ROM as a server 14

using hard drive as an OnDemand
server 15

using Network drive as an
OnDemand server 15

using the OnDemand toolbar 26
using this guide 4

W
wildcards 22

Z
zoom toolbar button 26
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