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Lab 1. Verifying the environment to work

Objectives

Lab prerequisites

© Copyright IBM Corp. 2002. All rights reserved.

eXtensible Markup Language (XML) is the evolution of HTML like a mechanism to
share information between computers in a simple and documented form. It is the
standard for data interchange in e-business. When you manage information in
XML format you know exactly with what type of information is working.

The most important part of XML is that you can publish information on the Web
very easily. You can:

 Locate the information in the tables that your applications already are using
» Designh a Web page for your data
« Transform the data using the DB2 attributes and send them to the Web

You will work with five different labs that are related to the requirements of your
business — deploying information to the Web. When you complete these five labs,
you will understand how easy is to deploy information to the Web when XML is
used. You will also understand how easy it is to put the information that you are
receiving into your database.

There are many different ways (and tools) available to communicate your
information via the Web. XML is a product completely integrated with your
database tables. Your information in XML format will be tied with the data that
your applications are using now.

You will work with the two different forms to store information. And, you will
transform data in your tables to XML format. Among the activities that you will
perform are:

« Store an XML document into your database table
« Decompose an XML document to update your database tables
e Compose an XML document to publish information from your tables

Before you begin this lab, be sure the following prerequisites are available:
« An IBM @server iSeries or AS/400e server with OS/400 V5R1 (or higher) with:

—5722-SS1 Option 12: Host Servers

—5722-SS1 Option 13: OS/400 - System Openness Includes
—5722-SS1 Option 30: OS/400 - QShell Interpreter

—5722-SS1 Option 34: OS/400 - Digital Certificate Manager
—5722-SS1 Option 39: OS/400 - International Components for Unicode
—5722-DE1 DB2 UDB Extenders

—5722-DE1 Option 1: DB2 UDB Text Extender

—5722-DE1 Option 2: DB2 UDB XML Extender

—5722-TC1 TCP/IP Connectivity Utilities

—5722-WDS WebSphere Studio Application Developer

« A PC with Client Access Express V5R1MO with the latest Service Pack applied
* A Windows IP address HOSTS file containing an 1400WS entry that point to
your iSeries server

Note: You need to install the latest PTFs for the products on your iSeries server.



Time required
The time required to efficiently complete this lab is 20 minutes.

Required information for working with the lab

In many steps of these labs, you need to provide information about your
environment of work. You are asked for a group number. Every time you see a
double character (XX), you need to replace it with your group number. For
example, DBXMLXX is the user profile for group “xx”, your group number.

In this document, we use the term "schema" as a qualified or unqualified hame
that provides a logical grouping for SQL objects. Starting with V5R1, the term
“schema” is used in the same sense as the term “collection”. This is an OS/400
library created with automatic DB journaling enabled and local DB catalog views.

A user profile, DBXMLXX, has been created for you, with the password DB2UDB.

An IFS structure is already created, but you need to add a directory to store the
XML documents created during the labs.

Task 1: Configuring a PC connection to the iSeries server

Before you begin, you must configure a connection between your PC and the
iSeries. This connection will be used to transfer files and execute code in the
Server.

__ 1. Double-click the iSeries Navigator icon on your Windows Desktop.

If this is your first time running iSeries Navigator on your PC, a message
window appears indicating that there are no connections to the server yet.
Click Yes.

2. The Add Connection - Welcome window (Figure 1) appears. Complete the
following steps:

a. Inthe Server input field, type | 400V&.

b. Move your cursor to the Description field and type i Series Version 5
or any description you prefer.

c. Click Next.
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Add Connection - Welcome =]

yyielcome ta the iSeries Mavigator Add Connection wizard.

yyhat is the name of the server to which you
weant 1o connect?

3

Server: I 1400Ws
Description: | iSeries Wersion 5
Enviranment: IMy Connections j

= Beck I [Mext = I Cancel

Figure 1. Add connection - Welcome window

3.

The Add Connection - Signon Information window appears. Select the Use
default User ID, prompt as needed radio button and type your team
profile (DBXMLXX) in the input field shown in (XX is your team number).

— Note

For the purposes of this lab, the server name |1 4006 is used for the
primary connection. If you decide to use different server names, you
must make appropriate changes throughout this and subsequent lab
documents.

. Click Next. The Verify Connection window appears. Click Verify

Connection to verify that the Host Servers functions on the server are up
and running. If you receive an error message in this step, notify your lab
supervisor or your system administrator (if you are in your office). When
the verification is successful, click OK and then click Finish.

From the iSeries Navigator window, click the plus sign (+) in front of the
1400WS connection. A new window appears prompting you for your user
name and password (see Figure 2).



Signon ko iSeries

2%

E Server I|4DDW5

User ID: |DERMLT

Ixxxxxx

Pazsword:

o

Cancel |

Figure 2. Signon to the iSeries server

Because this is your first time signing on to the iSeries server, the client
checks the server for the available functions to be displayed in the left

panel.

Task 2: Verifying the Coded Character Set ID

When you need to transfer files from the PC to the iSeries, be sure that you are
using the correct conversion. For this reason, you need to verify your user profile
and make changes if necessary:

4

__ 1. Click the plus sign (+) in front of the Users and Groups icon to expand it.

See Figure 3.

€ iSeries Navigator
File Edit Wiew Help
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W BRR X SEe

B9 minutes old

| Enwvironment; My Connections | 1400ws: Dbxml — Include: All

EI-::I% Management Central {As27) | Profile | Description
=-8f My Cornections AL Dbomin ITS0 ¥ML Lab - Group 01
o[ As0zb L Dbxrnloz ITS0 ¥ML Lab - Group 02
B sz L Dbl ITS0 ¥ML Lab - Group 03
o B Asz7 i Dbl ITS0 %ML Lab - Group 04
=B 100w ) L Dhening IT50 XML Lab - Group 05
(585 Basic Operations L Dbl ITS0 %ML Lab - Group 06

B8 Work Management

i1 B® Configuration and Service
- b Metwork

-8 Security
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i Groups
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5-{& Backup

@ AFP Manager

¥y Tasks
! Add a connection
@ Install additianal components

4

wlJzers and Group:

M Create a new uzer

@88 Create a new group

¥ 2 Help for related tasks

11 - 6 of & obijects [

Figure 3. Main Operations Navigator window
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__ 2. Click the plus sign (+) in front of the Groups icon. A list of existing group
profiles displays. Locate the group DBXML (note that this is the main user
profile; there is no group number) and click it.

___ 3. Theright pane updates with the list of users in this group. Double-click your
user profile, and a Properties window (Figure 4) appears.

Dbxml01 Properties - I400ws T 2l x|
IJzer name: I[J BibAL 7
Diescription: [IT50 ML Lab - Group 01
Pazaward: IU:;e Fame password j
Previous sign-on: 03/30/02 16:38. 24
Sign-on attempts not walid: i]

[ | lzer must change password at riext sion-on

¥ | Eriable tzer fon processing

Groupz Perzonal Capabilities Jobs

Metwarks

ak. | Cancel | Help

Figure 4. Properties of your user profile

__ 4. Click the Jobs button. The Jobs window opens. In the Jobs window, select
the International tab. Compare the CCSID values of your user profile with
the values listed in the Figure 5.



General | Session Starup | Display Sessinnl Outpt

Language: [US Engish j
Country:

IUn|ted States of America

Coded character set |D: |3? Brazilian Portuguese; DJ Browse. . |

Locale: IUse system value J

—Job attributes ta et from locale

% |se spstem value

) Do ot set any job attibutes

€ se one on more af the follawing:
[©| Coded|character set D [T Sort sequence
[ Date format [™ | Time separator
[T Date separator %

™| Decimal format

Advanced |

Ok I Cancel Help

Figure 5. CCSID values for a user profile

___ 5. If you see a different value, ask to your instructor or system administration
for changes. The value for Coded character set ID must be 37.

You have now completed this task.

Task 3: Mapping the ITSO folder on the IFS

When you work with XML, you need PC tools to help you with development tasks.
In this lab, you create XML code in your PC and transfer the files to the iSeries.

This task explains how to map an existing directory in the IFS as a PC drive. We
created a place to organize the work for all groups. Mapping this directory will
help you to send files to the iSeries.

Share the IFS folder with NetServer:

1. Go to the iSeries Navigator Main Window. Click to expand File Systems->
Integrated File System. This expands to show the main file systems
supported by iSeries. Then expand Root, which expands to show the main
folders in the IFS. See Figure 6.
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€ iSeries Navigator i . 5 |EI|1|
File Edit Wiew Help

iﬁj|%ﬁ|><|@@ 0 minutes old
| Enwvironment; My Connections | 1400ws: ITSOLab  Include: %%
E|--! T400ws ;I ame | Size | Type | Changed

2 Basic Operations ML File Folder 30312002 12
ER work Management

B2 Configuration and Service

[ & Network

Security

#@® Users and Groups
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a2 File Systems

EI@ Integrated File System

EII% Roat
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-] dev

- et

-2 home

E- &
£

£

£

£

e QIEM
-] Q3R
i-[2] QTCPTMM
72 tmp

- st
{75 Mninenswe LI 4] | LI

! Add a connection 4 ? Help for related tasks
@ Install additional components

IR

[1-1 of 1 obijects [

Figure 6. IFS directories

__ 2. Right-click the ITSOLab icon. This directory is used to manage all the
directories for all groups. If this folder appears with a hand on the base of
the icon, someone may have already created the Share. In this case, skip
to 5 on page 8.

From the pop-up menu, select Sharing-> New share as shown in Figure 7.

€ iSeries Navigator ] =lolx=
File Edit Wiew Help
ﬁj|c¥:%ﬁ|><|@@ 13 minutes old
| Environment; My Connections | 1400ws: ITSOLab  Include: %%
EI@ Integrated File System ;I Iame | Size | Type | changed
=-{Z3 Root ML File Falder 3(31/2002 12
-] bin
-] dev
- et
-2 home
i 5 H——
= E Explore
B Qpen
B Create Shorbout
E-F Custormize this Yiew »
- Include..
[J"'I% & Mew Faolder,..
[J"'l% o
[J"'I% ‘ Delete...
[J"'I% e Renare. ..
HE G cut
|; Copy
Baste
Permissions e
<[4l | 5
Send...
@ Install additional ¢ Journaling. . d
Creates a new iSeries het  1WF3 Expart ’ i

Figure 7. Sharing the ITSOLab directory



___ 3. The iSeries NetServer File Share window (Figure 8) opens. In the
Description field, write a meaningful identifier. For Access, select
Read/Write because you need to place your files here.

iseries NetServer File Share - [400ws : 21|

General | Text Conversion

1BM iSerniez Support for Windows Network, Meighborhood

Share name: IITSDLab

Description: IMain directory for XML lab

Access

t aximum number of users

% Mo maximum

 Masimum users [0 - 2147483647); ID

Fath name: Ia’ITSEILab

O% I Cancel Help
L)

___ 4. Click the OK button to confirm your task. After this operation, the ITSOLab
folder is shared for others to access. The folder appears with a hand on the
base of the icon (in the main window of iSeries Navigator).

Figure 8. Adding a description to your Share

5. Assign a disk drive letter to this folder. You can go to iSeries Navigator
main window and click the File Shares icon to see a list of all file shares
(Figure 9).
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_|oi x|
5 minutes old

Series Navigator
File  Edit

‘Wiew  Help

alime|xE|GEe

| Enwvironment; My Connections

B Security d
#@® Users and Groups

B Databases

a2 File Systems

EI@ Integrated File System
EII% Roat

-] bin

-] dev

- et

721 home

|- fgad ITS0Lab
[-ad QIEM

-] Q3R

-] QTCPTMM

| 1400ws: File Shares  iSeries NetServer: QRCHASM27

| Descripkion
Directorio para el perfil de
MMain directory For XML lab
Q50400 -- Directory Servic
16M Product Directories

| path
Thome/carlos
JITS0Lab
TQIBMIProdDataioS400/DirSry
JIEM

Mame
carlos
A Tksolab
A odirsry
Agibm

QDLs

[, AFP Manager

| | i
Fie B

! Add a connection ? Help for related tasks
@ Install additional components LI

|1 - 4 of 4 obijects |

Figure 9. iSeries Navigator file shares

L«l

=)
3

e

___ 6. Right-click the entry for Itsolab and select Map Network Drive as shown in

Figure 10.

_|oi x|
160 minutes old

Series Navigator

File Edit Wiew Help

MR

| 1400ws: File Shares  iSeries NetServer: QRCHASM27

;I Mame | Path | Description
ACarlos fhomefcarlos Directorio para el perfil de
TS ah MMain directory For XML lab
odirsry OPEN S400/DirSry 15/400 -- Directory Servic
Agibm Explore 1EM Product Directories
[J"'I% QOpenSys Properties
{23 QDLS
[#-{T3 QSYS.LIB
{23 QFileSvr.400
{73 QOPT
{53 QNTC
----- 1Y File Shares R ik | |
EElrile
Add a connection b2 Help for related tasks
@ Install additional components ;I
Assians a drive letter to a netwark resource, 4

Figure 10. Menu option to map a drive

___ 7. On the Map Network Drive window (Figure 11), complete the fields as
explained here:

a. The Local drive field is already filled in. In this lab, we use letter “I” for
the main folder in this lab. If drive | is not selected, click the list button

and change it.



The drive letter assigned is the next letter in ascending order to the last
drive assigned. If you are in your office working with this lab, more than
one drive may be assigned to your PC.

b. In the Connect as field, verify that your user ID is entered.
c. Enter your password.
d. Verify that the Reconnect at logon option selected.

Click the OK button to confirm your options.

Map Network Drive - 7=
Share narne: [tzolab
Local drive: IW]‘
Connect as: Idb:-tmlD'I
Pazzword: I xxxxxx

¥ Feconnect at logon

ak. ! Cancel

Figure 11. Information about your mapped disk drive

This task is now completed.

Task 4: Creating a directory to store your files

It is important to organize the information in the IFS, especially when many
developers are working with e-business solutions as XML and many directories
are created. Find information can be a challenge if the data is not well organized.

For this lab, the folder ITSOLab is the main directory. In the previous task, you
mapped it. Now, create your folder to store your XML files:

1. Click the ITSOLab icon. When the list expands, you see the XML folder. If
there more folders, ignore them. All labs will work inside XML folder.

___ 2. Right-click the XML folder and select New Folder... as shown in Figure 12.
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@ iSeries Navigator i 0] =|
File Edit Wiew Help

ﬁj|¥:|}3“a|}(@"|@@ B minutes old
| Environment; My Connections | 1400ws: HML  Include; =%
E@ Integrated File System ;I Mame | size | Tvpe [ Changed
- B Reat Dlaroupix File Folder 3/29(2002 11
B[] hin
-] dev
- et
-2 home
£l IT50Lab
= 3
B Q CIEM Explore
-] Q3R Open
-1 QTCPTT Create Shartcut
-2 tmp Customize this Yiew ¥
- st Include. ..
EJ---I‘Bg QOpenSys
{23 QDLS M
{23 Q5¥S.LIB Delete...
[-[23 QFilegyr.40  Rename..,
[#-{T3 QOPT o
- E-{Eg o .
- File shares _opy
Backup Paste
Permissions
mll -~
B 44d a connection Send.., for related tasks
@ Install additional component S 3 d
Creates a new Folder. Journaling. .. 4

Figure 12. New folder

3. A New Folder window (Figure 13) opens where you nhame your container.
Write the name of your folder GROUPXX, where xx is your group number.
Click the OK button.

Enter a nevs name for the object;

IgroupD1|

ak Cancel |

Figure 13. New folder information
The right pane updates with your folder as part of the list.

This task is now completed.

Task 5: Getting started with WebSphere Studio Application Developer

WebSphere Studio Application Developer is IBM’s latest suite of e-business
application development tools. This tool is focused in productivity and integration.
It provides a visual interface armed with powerful environments to create
applications.

We use the editing facilities provided with WebSphere Application Developer to
create and update XML files.

WebSphere Application Developer provides additional tools that can be used to
browse relational database schemas, build SQL queries, and generate Document
Access Definitions (DAD) files using simple drag-and-drop techniques to
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Eile

associated XML content with relational database entities. These tools can make
DAD file creation and maintenance easier.

In this lab, you have to create DAD files using a basic XML editor to give you a
better feel for the information contained in a DAD file and the role it plays within
XML Extender.

1

ZEE - Application Developer

Using the Start menu navigator of Windows, locate the WebSphere
Application Developer product. Click Start-> Programs-> IBM WebSphere
Studio Application Developer-> IBM WebSphere Studio Application
Developer. The Welcome to WebSphere Studio (Figure 14) opens.

_lol x|

Edit Perspective Project  Windomw Help
:ﬁvl & &S & @Il%a}lo_ ESIE-X IR
|| & J2EE view x x |
= ER ﬂ Enterprise Applications Welcome to WebSphere Studio
: D Application Client Modules -
Euo ‘wieb Modules Thiz page tellz you what wou should know before you start desveloping applications with webS phere =
% EJE Modules Studio Application Developer. Clhick the highlighted links to perform the described tasks.
|‘_°ﬁ Server Configurations —
ﬂ’ Semver Instances
f_'l D atabazes = MNavigating the workbench
The workbench containg one or more perspectives. Each perspective consizsts of views [zuch asz
the Mavigator] and editors for working on a particular tepe of file. The buttons on the shortout
bar at the far left allow pou to open new perspectives and move between open perspectives.
The title bar tellz you which pelspectlve You are cunentl_l,l wiorking with, *ou have the option of
opening each new perspective in its awn windaw; this is configured from ‘windows »Preferences.
For example. vou might want to open the Help Pergpective in a new window. Once you have et pour
preferences, you can open the Help from the Perspective menu to display it in itz own window.
(% Customizing your workbench
ou can mowve views and editorz around the workbench by dragging their title bars. vou can
alzo add views to the current perspectwe by clicking Perspective » Show Yiew, and You can -
- - e ek sieaas be "Feab simane!! Faa Are—mmiveen Hemoen be Heee alemrbeaab boere moe Blee LeFE AF Bl e
JZ2EE \-"lew]Nawgator | r » |
o= Outline x Tasks [0 items] G = x
#n outling is not available | £ 1 | Description | Fiesource | In Folder | Location

T asks] Froperties

Figure 14. WebSphere Studio Application Developer welcome window
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If the workstation that are you using, is already customized, the Welcome
window does not open. Instead, a window reflecting the developer
environment opens.

Create a new project. The Open The New Wizard (left-most icon in the
toolbar) calls a wizard and helps you organize your workbench. Click the
Open The New Wizard icon.

Tell the wizard what kind of project you are working on. As shown in Figure
15, select Simple for the resource. In this lab, we use the basic workbench.
Note in the right pane that Project is selected. Click the Next button.
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Select

Create a newy project resource

VS

- Data

- EJB

=

—lava

- Plug-in Development
- Remote File Transfer
- BEFYEr

- Wyeh Services
- RML
[+ Examples

é Project
% Folder
File

= Hack Mext = Eirizh | Cancel
b

Figure 15. WebSphere Application Developer: Creating a new project

___ 4. Onthe New Project display (Figure 16), enter XM_ Proj ect for G oupXXas
a description for this project. Click the Finish button.
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New Project

Project

Create a new project resource.

WML Lab for Groupzx

Figure 16. Naming the project

Your project is created. The window shown in Figure 17 contains an
example only. In the upper left pane, you see the entry for the project
created for you.
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. ¥ Resource - Application Developer
File Edit Perspective Project Script  Window Help

=10l x|

EEEIEF Y =

?gT;Navigator = =S |, 4

3 TS0 Lab 5

a Bl AR * disable the column =/

HML Lab for Group 1

o/* drop the tahles */
drop table groupx<.results;
drop table groupxx.order=ml;
drop table groupxx<.parts;
drop table groupx<.status;
drop table groupx<.classes;
drop table groupx<.units;

er‘op collection groupxs;

[Marvigator ]Repos'rtories

2= Outiine ®
-3 invalid statement:
-3 invalid statement:
-3 invalid statement:

- disables XML CoTumn, drops the tables, drops the collection *
; --— this script may stop at anmy point if 1t senses a failure. */
(= Collections @/ --- for example - 3f the column was never enabled, you will get a failure
(2= Columns ---= when disabling the column, 1t's ok to continue from that point. =/

20 Setup-tables.sql call gdbxm. gzxmadm ('d'isab'le_co'lj-l;mn', 'T400Ws ', 'groupxx.ordersml ', ‘wml_doc');

o

-3 invalid statement: ﬂ

3 drop incomplete

g droz takle :rderxml 7| Tasks (8 tems) SR Sp X

.@ drop table parts | I | | | Description Resource In Falder | Location

24, drop table status ) Inwvalicl statemert: / Cleanup-tables.... | ITSO Lab line 1

%4, drop table classes o Invalid statemert: Cleanup-tables... | TS0 Lab fine 2

% drop tshie-unis o Invalid statement: Clesnup-tables.... | TS0 Lab fine 3

""" & diopmcainplete ) Invalid statemert: 7 disable the column ® ca..  Cleanup-tables.... TS0 Lab ine &

[x] DROP parsed unsuccessfully. Parsing hatted aft... | Cleanup-tables. ... TS0 Lab line 9
[x] DROP parsed unsuccessfully. Parsing hatted aft... | Cleanup-tables.... TS0 Lab line 16
[x] Irvalid statement; * 1-Decompose-... TS0 LabiCollections line 1
[x] Irvalicd statement: call dxxsamples shod«('14000%S'.. 1-Decompose-... | ITSO LabiCollections line 3

Figure 17. WebSphere Application Developer workbench

The main window is called the workbench. It contains four panes with

information about your work:

« The Navigator pane displays projects and folders used to organize your
work and the various files associated with each project and folder. You
can select items in the navigator and perform various actions on them,
depending on the type of the item (such as editing a DTD file).

« The Editor pane displays files that are currently being viewed or edited.
If more than one file is currently being edited, it will appear as a tab

along the top of the Editor pane.

« The Outline pane represents a view of the information being edited.
When you edit an XML DTD, the Outline pane displays the various
elements and attributes defined in the DTD. When you edit a DAD file,
the Outline shows the elements and attributes for the file being edited.

* The tasks pane serves as a “to-do” list of tasks that need to be

performed. Task pane use varies by application. The Tasks section is

used by compile processes to show the compile-time errors
encountered. Clicking a compile error entry in the Task pane brings up

an edit session on the source generating the error.

__ 5. Because this lab is an XML development project, we need to activate more

facilities from WebSphere Application Developer. Create a Perspective,
which in WebSphere Application Developer represents a canned set of
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windows and actions, optimized for performing a given task like working
with XML data. Click Perspective-> Open-> Other (Figure 18).

¥ Resource - Application Developer

Edit | Perspective  Project  ‘Window Help

T e

=10l x|

éa Setup-tables =gl
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< _stnrks
P Alt+Down Arrow cprologs?xml wversion="1.0"7</prolog:
cdoctypes IDOCTYPE ProductCatalog SYSTEM “catalog.dtd” < /doctypes
Close zroot_nodes
Close all <e'|emen1_:EnDde ngme="Pr‘DductCata'IDg">
G 13 cattribute_node name="company''s
pa S! AT 14 zcolumn name="COMPANY" />
partsliztrolb.dad 15 < attribute_nodes L
{Z= Columns 16 <e'|emen1_:EnDde ngme="Pmduct;> ;
£ 17 cattribute_node name="productNumber':
£0] Cleanup-tables sef A ccolumn name="PARTNUMEER" />

S

Design lSource ]

’EEl Tasks (5 tems)

s e i
?}._ﬁbx

|

| @ | | | Description Resource In Folder Locstion
[x] Irvvalicd statement: Cleanup-tables.... TS0 Lab line 1
[x) Irvalid statement: * Cleanup-tables.... TS0 Lab line 2
(%] Irvalid statement: * Cleanup-tables.... TS0 Lab line 3
[x] Irvalicd statement: * disable the column */ ca... Cleanup-tables.... TS0 Lab line &
[x] DROP parsed unsuccessfully. Parsing hatted aft... | Cleanup-tables. ... TS0 Lab line 9
[x] DROP parsed unsuccessfully. Parsing hatted aft... | Cleanup-tables.... TS0 Lab line 16
[x] Irvalicd statement: * 1-Decompose-... TS0 LabiCollections line 1
[x] Irvalicd statement: call dxxsamples shod«('14000S".. 1-Decompose-... | ITSO LabiCollections line 3

Figure 18. Activating a perspective for your workbench
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6. At the end of the list, select XML. A more productive workbench to work
with XML now appears.

7. In this lab, we do not use the Tasks pane (Figure 19) because all code will
be used for the server. Click the Close button.

Rezource

In Folder

W X
| Location

DOV DD

Invvalicl statement:
Irvealic] statement:
Invalicl statement:

Irvvalicd statemert: # dizable the column * call .
DROP parsed unsuccessfully. Parsing hatted after: ..
DROP parsed unsuccesstully. Parsing hatted after:...
CREATE parzed unsuccessfully. Parsing hatted aft. ..
Irvealicl statement: #* This will

Cleanup-tables. ..
Cleanup-tables. ..
Cleanup-tables. ..
Cleanup-tables. ..
Cleanup-tables. ..

Cleanup-tables. ..
Setup-tables =gl
Setup-takles sql

HML Lab for Group 1
HML Lakb for Group 1
HML Lab for Group 1
HML Lak for Group 1
XML Lab for Group 1
AWML Lak for Groug 1
XML Lab for Group 1
AWML Lak for Groug 1

line 1 _CIos.
line 2

ling 3

line &

ling 9

line 16

ling 1

line 1 -

ags, Dinfos

Figure 19. Closing the Tasks pane

This task is completed.

You have now created the environment and objects necessary to work with your
XML lab. You have now completed this lab.
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Lab 2. Working with XML Columns

Objectives

When you decide to use XML documents, there are two ways to store them:

e Using XML Columns
« Using XML Collection

In this lab, we work with XML Columns. An XML Column contains the entire XML
document that can be updated, searched, and extracted; it is created as an XML
user data type (such as XMLVARCHAR) in a single column of a database table.
Other columns in the same table may be used for storing other non-XML data. In
summary, an XML Column represents another type of data type that can be
associated with a column in a database table.

In addition to simple data storage, XML Columns support the notion of side tables
that can be used to store a subset of information from the XML document found in
the associated XML Column. When you define an XML Column, you can specify

« The number of side tables to create

« The name and data type for the columns appearing in each side table

* The particular XML element or attribute values that will be the source of data
stored in each column

Side tables are very useful when you want to hold key information about your
XML documents. Side tables are managed by DB2 UDB XML Extender. You do
not need to create them, and you do not need insert, update, or delete entries in
a side tables. Side tables are created when an XML Column is enabled for a
given database table. Database triggers are used by DB2 UDB XML Extender to
insert, update, and delete side table entries as XML documents are inserted,
updated, and deleted from the corresponding XML Column. Side tables can be
queries by applications.

A key benefits of using side tables is for simplifying and optimizing queries
performed against the key data items maintained in a side table. You can create
an index over columns in a side table to further optimize query performance.

XML Columns are a good way to store complete XML documents for archival
reasons. The side tables associated with XML Columns provide an easy and
efficient mechanism to quickly locate XML documents based on queries on
individual data items within the document.

In this lab, you learn the steps required to setup and use an XML Column
associated with one of the tables in our database. The XML Column will be used
to store purchase orders received by our example lawn and garden supply center.

You will configure DB2 UDB XML Extender to generate side tables to hold a
subset of the information contained in the XML purchase order documents. You
will also run a number of queries to see how can you extract and manipulate the
data stored in XML Columns and their associated side tables.
To understand how DB2 UDB XML Extender works, you will:

* Review the XML documents that you will store in an XML Column

» Create a Document Access Definitions (DAD) file, describing a side table

© Copyright IBM Corp. 2002. All rights reserved. 17



Lab prerequisites

Time required

» Use the DAD file to enable an XML Column to an existing database table

« Use functions provided with DB2 UDB XML Extender to store XML documents
in the XML Column

« Use other XML functions to extract and update values associated with
elements and attributes stored in the XML Column

Prior to completing this lab, you must have completed Lab 1, “Verifying the
environment to work” on page 1. You must also verify the following items:

* Your user profile has the correct parameters
* You have created a folder for your group

* You have mapped your folder in the IFS; all code has a reference to the
mapped drive

« Verify that the product WebSphere Studio Application Developer is installed

The time required to efficiently complete this lab is 30 minutes.

Required information for working with the lab

18

Be sure that the drive letter for your folder in the IFS is drive “I”. If you are working
in your office and you do not assign this letter to the IFS, you have to change all
references to it in the source code. We recommend that you work with the “I”
drive for IFS.

Every time you need to run code in the iSeries, you are prompted for your server
information as shown in Figure 20.

The Connect to Server dialog contains two parts. First, it asks you for the server
name. Click the OK button. Then, the system validates your access information

and returns the name of the local relational data base name. The local name is

used for all labs.

Connect to Server x|
Senver: fid00ws -]
Database: |I4DDW5 =l

8154 I Cancel |

Figure 20. Connecting to the iSeries

If you do not have an active connection, you are prompted to supply your user ID
and password to access the server.
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Task 1: Importing source code to be used in the PC side

Before you begin

Ensure that you have observed the prerequisites specified for this lab and
given consideration to the “I” drive issue.

All files that you need to complete this lab are stored in the IFS as a zip file. In
this task, you need to import this code to the WebSphere Application Developer
environment.

Here are the steps necessary to import ASCII files:

1. start WebSphere Studio Application Developer from the Windows desktop.
Click Start-> Programs-> IBM WebSphere Studio Application
Developer-> IBM WebSphere Studio Application Developer.

When the product is loaded, the workbench is ready for you.

___ 2. From the menu bar, click File-> Import... as shown in Figure 21.

. ¥ XML - Application Developer
File Edit Perspective Project ‘Window Help

= 4
Close CErl-F4
Close &l Ctr| S
Save Ctrl4s
B sove s
i@ sevs Al (it |+ ift+S
it Ctrleh

Irnport,,.

1y Expart..,

1 ...For Group 1 ColumnsiPurchaseOrderyML . dad
2 wML Lab For Group 1Columns/dad. dtd

Exit

Figure 21. Importing a zip file

___ 3. Onthe Import - Select dialog (Figure 22), click Zip file to select the type of
resource.
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Select

Impart resources from a Zip or Jar file on the local file system i I

Select an import source:

& App Clisrt JAR file
[ EAR file

(@ EJB JAR file

[, File =ystem

Fp,FTP

httg T TR

OEProfiling file

8, Server Configuration
ool

(T, AR file

o

= Hack I Mext = I Eirizh Cancel

Figure 22. Define the type of resource to import

___ 4. Click the Next button to confirm your selection.

__ 5. On the Import Zip file dialog (Figure 23), click the Browse button to locate
your zip file.
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Source must not be empty.

Zip file p
£

Zip file:

select Typez... select Al Deselect Al

Select the destination for imported resources:

Falder: I AML Lab for Group 1 Browwse... |

Options:

[~ Owverwrite existing resources withaut swarning

= Back | [ext = | Eirizh I Cancel

Figure 23. Locating the file to import

__ 6. Inthe Open window (Figure 24), locate and select the “I” drive in the Look

in drop-down list. In this lab, the drive is named itsolab on ‘i400ws’ (I:).

2

Laak in: |§rtsnlab on 400 (1) j & cf E-

=

File name: I j Qpen
j Cancel |
P

Files of type: I*_jar;*.zip

Figure 24. XML folder in the ITSOLab (IFS)
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__ 7. Double-click the XML folder. This folder contains a list of files. If you are
the first (or only) group accessing this folder, one file only exists —
GroupXX.ZIP.

8. Click GroupXX.ZIP to open it. The File name entry is already filled for you.
Click Open to accept it. For the folder under Select the destination for
imported resources, click the Browse button and select your XML Lab for
Group XX subdirectory as shown in Figure 25.

Impart the cortents of & Zip file from the local file system.

Zip file E
29

Zip file: II:\}{MLIGroup}{}{.ZIP

Select Types... Select All Dezelect Al

Select the destination for imported resources:

Falder: I ¥ML Lab for Group 1 Browvvse. .. |

Options:
[~ Owerwrite existing resources without swarning

= Back Iext = | Finish Cancel
L\L

Figure 25. Last step before importing the zip file

__ 9. Click Finish. Your files are now transferring to your workbench. A
progression bar appears. When the transfer is finished, your workbench is
updated.

You have transferred two folders (Collections and Columns) and two files in
the root directory (Cleanup-tables.sgl and Setup-tables.sql).

__10.In the Navigator pane (Figure 26), verify the file names that you need to
complete this lab.
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- ¥ XML - Application Developer

File Edit Perspective Project  Window Help

S-HEES oD RBH| <
E BT Outline b

ﬁl An outling is not available

H |

Hix

e,

kil

-z Additional

--{B Collections

—|-{= Columns

--{;3- OrderSamples

2] 1-Enable-XML-Column sl

E 3-Query-Customer_Names g
20] 4-Query-cancellsd sl
2] 5-Query-Orders-by-date ol

b PurchaseCrder XML dad
----- £0) Cleanup-tables sql
LB Setupables gl

o | »

Figure 26. Verifying the content of your project
___11.0pen the Columns folder to see what files are inside.

This task is now completed.

Task 2: Creating your schema and database tables

In this task, you create the schema and database tables necessary to work with
your lab. You also populate the database tables by executing an SQL script.

In some steps, you are asked to open and close the files with WebSphere
Application Developer Editor. You are asked again to open them with the System
Editor. The purpose of this is to compare how the source code is presented using
both tools. You need to know how to achieve the best productivity when building
e-business solutions.
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The main difference between using the Application Developer Editor and the
System Editor is the standards associated with your source statements. We
recommend you use both options when doing the labs.

1. Locate the SQL Script named Setup-tables.sql in the main folder of your
project. This script creates the schema and database tables used by your
group throughout this lab.

2. To open a file, there are several options depending what are you trying to
do. In this step, open it with the default editor and change the references
for your group number. Right-click the Setup-tables.sql file and click Open
as shown in Figure 27.

. ¥ XML - Application Developer

File Edit Perspective Project Window Help

S-HEE @R RBR|
E B Outline ®

ﬁ An outline iz not awailakle

g

i

i79

W

T 3
Qo To 3
Qpen Al

Cipen With 4

- XML Lab farc  oP¥
WG Addtional  MO¥e
F-= Collection:  FEname

= = Columns Delete
= Order #Add Bockmark.
20| 1-E
£ 1:Fw Refresh From Local
é_uj 2-Inse
0] 3-Que % FLur on Server
?@ 4oL
E Team »
il & cuc g with b
[B] ciact.o nn';pare _||-I :
Purch Replace Wit
""" 0] Cleanup-t: Properties
EOTR = =tLin-tabim s ey
1| | »

WML Lab for Group 1 /Setup-tables =gl

Figure 27. Opening the SQL Script file

__ 3. After you open the file, the components of your workbench are updated.
The right pane contains the code of the SQL Script. The statements have
tokens with colors to facilitate the reading of code.
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The Outline pane contains messages about your source code. These
messages are not sent by a compiler, but because syntax checking is
active in your editor.

Change all references for Group XX to your group humber now. You must
also change the name of your schema, the place where all tables are
created and, the place where the tables exists to insert rows.

For example, we GroupO1 as a valid group name. Figure 28 shows the
source code with statements already replaced for GroupO1.

Hint

You can use the search and replace function of your editor for more
efficiency.

f x |

* This will create the collection and the tahles that all of the 50L scripts and the DBZ2 XML .
/% Do not forget to change Group Mumber */ -

/% create the collection */
create collection groupdl;

* create the main table for the ML Column samples ¥/
create table groupll.ordersml (eml_doc dbzwml.xmlclaob);

@/ create the tables for the XML Collection samples =/
create table groupdl.parts (company int not null with default 1, partnumber char {103 not null

create table groupll.status {statusref int not null primary key, statustext warchar {10) not n
create table groupOl.units (unitref int not null primary key, unitdesc warchar (10) not null w
create table groupll.classes {classref int not null primary key, classdesc warchar {200 not nu

@create table groupll.results (result_xml db2<ml.xmlclob);

* £111 1in some data for the =ml collection tables =¢
insert into groupdl.status walues{d, 'none');

insert into groupdl.status walues{l, 'In Stock');
insert into groupdl.status wvalues(?, 'Back Order');
insert into groupdl.status walues{3, 'Hot fwail');
insert into groupdl.status walues{d, 'Closecut');

insert into groupdl.units walues{D, 'none'’;
insert into groupdl.units walues{l, 'each');
insert into groupdl.units walues({2, 'box');
insert into groupdl.units walues{3, 'inch');
insert into groupdl.units walues{d4, 'foot');
insert into groupdl.units walues{5, ‘yard');
insert into groupdl.units walues(s, 'sg. foot');
insert into groupdl.units walues(7, 'meter');
insert into groupdl.units walues({&, 'bag');

insert into groupdl.classes walues{d, 'none');

insert into groupdl.classes walues(l, 'Tools');
insert into groupdl.classes walues(z, 'Fasteners');
insert into groupdl.classes walues(3, 'Lawn/Garden’);
insert into groupdl.classes waluesi{d, 'Electrical'l};

-

4 | i

Figure 28. Setup-tables.sql modified

4. The Editor continues showing warnings about errors in your code. These
errors are detected because the source was coded to be executed in the
server. The pair of /* and */ are not SQL statements; they are only
comments for the server and used as documentation.

From the menu bar, click File-> Save Setup-tables.sql.
Exit the Editor. From the menu bar, click File-> Close.

7. The SQL Script is ready to be executed in the host. Right-click the file and
select Open With-> System Editor.
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You see a status bar that shows the progression of loading the SQL Script
file. When completed, a new window opens for you to work with the script
file. Figure 30 shows the same interface used by Run SQL Scripts....

8. Verify that you are using the SQL naming convention in your session. From
the menu bar, select Connection-> JDBC Setup.... On the JDBC Setup
window (Figure 29), click the Format tab and verify that SQL (*SQL) is
entered in the Naming convention field.

IDEC Setup - 1400ws x|

Sewerl F'au:kagel Ferfarmance Languagel Otherl Translation

Maming carmention:
|s0L rsaL _E'
Decimal separatar;
|. {periad) ;l
—Time
Format:
Jhh.mm.ss 150) =l
Separataor:
|. (period) ;l
—Date
Format:
finpy-rorn-el 1209 =l
Separatar:
|- (dashy =l

[o]34 I Cancel | Help |‘?|

Figure 29. Setting the SQL naming convention

__ 9. Figure 30 shows the window with the SQL Script already open. You can
execute all statements from the menu bar by clicking Run-> All. Or, you
can click the Run All icon on the toolbar. If you prefer to follow the
execution of this script, you can execute the statements one by one.
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iF C\PROGRA~1YIBM\APPLIC~1' WORKSP~1' 2MLLAB~1 o ] |
File Edit ¥iew BRun ¥isualExplain Monitor Options Connection Help

@ AR FTTOC MM P

Examples Run All | j ﬂl

I* Thiz will create the collection and the tables that all ofthe SQL scripts and the DB2 XML Extender will =
ark with =5
* Do not farget to change Graup Mumber =

™ create the collection =
create collection group0t;

™ create the main table far the XML Column samples
create table group01xardersml xmi_doc dh2xmlxmliclab);

™ create the tahles for the XML Collection samples *F

create table group0l . parts (company int not null with default 1, partnumber char {100 not null prirmany key,
name char (18] not null with default, description varchar (200) not null with default, instock int not null with
default 0, price decimal {10,2) not null with default, currency char (3 not null with default 'S0,
unitmeasureid int not null with default 1, statusid int not nall with defadlt 1, classid int not null with default

1

create table group0l . status (statusrefint not null primary key, statustest warchar (100 not null with defaulf);
create table group01.units (unitref int not null primary key, unitdesc varchar (100 not null with defaulf);
create table group0l .classes {classrefint not null primary key, classdesc varchar (203 not null with defadlt);

create table groupdl . results result_xml dh2xmlxmlcloby;

il in same data for the xml collection tables =
insert into group01 . status values(0, ‘none?;
insertinto group01.status values(l, 'In Stack?); j

T N T TR LAk B S TP PR L o Py P SV e

Messages I

Figure 30. Running SQL Script to create schema and tables

___10.You are prompted for your server information, which we explained at the
beginning of this lab. Click OK to run the SQL Script.

___11.After all SQL Script statements are executed, click File-> Exit.

This task is now completed. Now we have a schema with populated tables on the
iSeries server.

Task 3: Reviewing the information in an XML document

An XML document is very simple in that it only contains tags and data. It is
something like the data portion of an HTML document. An XML document does
not contain presentation tags.

The tag names used in an XML document represent the data. This is the main

reason why these types of documents are used to share information in the
e-business world.

27



In this task, you review a typical XML file:

1. Go to the WebSphere Application Developer main window.

2. In the Navigator pane (Figure 31), expand the folders Columns->
OrderSamples. You should see six XML documents files listed inside the
OrderSamples folder.

Tl IS0 Lab

[E-Ta XML Lab for Group 1
--{Er Collections
E{Er Columnz

i--{B OrderSamples

------ [¥] OrderRect xml

6] OrderRe2ml
o] OrderRen3 xml

------ [¥] OrderReqd ml

o] OrderRens wml =

------ [¥] OrderRes ml

----- £d] 1-Enable-KML-Column sgl

----- 0] Z-IrsertsbL sol

----- é_uj 3-Cuery-Customer_Names :

1| I

Figure 31. OrderSamples folder

___ 3. Open one of these files and examine the information inside. For example,
using Web Browser in WebSphere Application Developer, right-click the
OrderReqgl.xml file and select Open With-> Web Browser.

4. The opened XML file appears as shown in Figure 32. XML is built of tags
and data. The red color is used for a tag. The black color is where the data
is.

Review how the information is grouped for the Purchase Order. The
Header tag is defined for the Customer and Order sections. Customer has
an ID and a name. Order has an ID, date, type, etc.
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@ <»

<7uml version="1.0" 7>
- <PurchaseQrderxML version="0.1">
- «<Header>

- <Customer id="CNODODOD1"=
zMamezRons Hardware</Namex
=/Customers
- =Orderlnfo orderID="0ON74334458" date="2001-10-05" type="new":=
=Shipping /=
<TotalMoney currency="USD">260.00</TotalMoney>
zMotes=None«</Motes:=
</0rderInfoz
=/Headers>
- «<Itemlists
- <Item partnum="PNODO0ODO15">
<Description=Screw Driver</Description:
<Quantity=10</Quantity >
<Price>1.00</Prices
=hotes /=
</Ttems
- <Item partnum="PNODOO0O0D0O03">
<Description=8heet Metal Scr</Description=
<Quantity=50</Quantity>
<Price=>5.00</Price:
=/Ttems
</TtemList=
=/Purchase0rdershL=

Figure 32. Opening an XML file with Web Browser

___ 5. To continue reviewing this XML file, open the same file using the XML
Editor. Right-click the OrderReqg1.xml file and click Open With-> XML
Editor.

Figure 33 shows the source code for your XML file. Here, you see colors
for both tags and fields. You also see that several ItemList sections make
up an order and Item has a part number, description, quantity, etc.
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" Wyeh Broveser

----- c7=ml wersion="1.0" 7>

2

3 <Purchasedrder>¥ML wersion="0.1"»

4 <Header:

g sCustomer 1d="CNOCD001" >

a cMamesRons Hardware« MHames

F AT ustomers

8 OrderInfo orderID="0NF4334458"
9 date="2001-10-05"

10 type="new' s

11 cshipping: </ Shippings

12 cTotalMoney currency="UsD"»260.00/TotalMoney:
13 cHotes»None < /HNotess

14 o /orderInfos

15 ¢ /Headers
16 «ITtemLists

17 zItem partnum="PNIO00C015" >

1a cDescriptionsscrew Driver o /Description:
19 cuantity» 10« Quantitys

20 ¢Prices»l.00</Prices

21 cHotes /»

22 2/ Ttem:

23 zItem partnum="PNIO00CO03"

24 Description:Sheet Metal Scre/Description:
25 cuantity» 50 Quantitys

26 cPrices5. 00« /Prices

27 o Ttems

2a «/Ttembists

29/ Purchasedrder>MmLz

Figure 33. Opening an XML file with XML Editor

6. XML Editor offers you more options to facilitate your work. Click the Design
tab located at the bottom of the Editor pane. This view of the code is more
structured and easier to read. It is similar to the information shown in the
Outline pane, but has more functions.

7. In the Editor pane, using the XML Editor, find the date of this order. Click
the plus sign in front of PurchaseOrderXML tag. The list is expanded and
you see the main structures for this document: Header and ItemList.

8. The date information is in the Header section. Click the plus sign in front of
Header tag. The list expands and you see the Customer and OrderInfo
tags.

9. Expand the OrderInfo tag. Now you see that the entry for date is visible
with the value 2001-10-05. Figure 34 shows a view of the file structure.

) Weh Broweser b4 l
i=d il wersion="1.0"
[El-48> PurchazeOrderxhL
;....<a> wersion 01
[=-<&» Header
[H-4&r Customer
148> Orderinfo
eq@y orderlD OM74334455
<o st R > -1
48y type ey 5[%
48y Shipping
[F-<&» TotalMoney
48 Motes Mone
[F-<€» femList

Figure 34. Date value for the tag in the XML file

___10.Close the two opened views of the file. This time, use the close button
(marked with an “X") of the tab for the view. Figure 35 shows a portion of
the Editor pane.

Integrating DB2 UDB for iSeries and XML



ndow  Help

‘BaR v[saxE ®E

x || 4 web Browser d _)’r\“
=B wml e wersion="1.0"
[=-4er PurchazeOrder<il
48y wersion 041
[=]-4&r Header
. [#-4&» Customer
. [El-<er Orderinfo
i Ay orderlD QN 4334458
L4aY 2001-10-05
iedar type Ny

48y Shipping

[+]-<&» TaotalMoney

Figure 35. Closing the view with the Close button

You have now completed this task.

Task 4: Exporting XML documents to the IFS
In this task, you transfer all the XML documents to the IFS. DB2 UDB for iSeries

XML Extenders needs these files in the IFS. Depending of your experience, you
can use the tool of your choice and skip these instructions.

In this lab, you are asked to use the Export function of WebSphere Application

Developer. It is already integrated and easy to use.

Follow these steps:

1.

2.

Locate the OrderSamples in the Navigator pane.

Click the OrderReql.xml file to select it. Then hold down the shift key and

click the OrderReqg6.xml file to select the group of entries as shown in

Figure 36.
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plication Developer

¢

Lakh far Grougp 1
= Addtional
= Collections

a 2nzertyhl =gl
-] 3-Query-Customer_Mame
~Ed] 4-Query-cancelled gl

£4) S-Query-Orders-by-date = 5

Figure 36. Selecting a group of files to import

__ 3. Click File-> Export.... The Export - Select dialog (Figure 37) opens and
shows the resources available.

32  Integrating DB2 UDB for iSeries and XML



Select P

Export resources to the local file system ﬁ I

Select an export destination:

B App Cliert JAR file

{E5. EAF file

(& EJB JAR file
=]

FeFTP

I JAR file
e
JBWAR file

B Zip tile

< BECk I Mext = | Eimish Cancel

Figure 37. Resource available for export function

4. Select File system. Click the Next button.

___ 5. The Export - File System window (Figure 38) opens. Specify the target
directory, which is '\XXML\Group XX in this lab.
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File system /EI
Export resources ta the ocal file system.

Select the resources to export:

EE@ WML Lab for Grougp 1 [F1[H] CrderRegt smi
-] Collections [A %] orderReqz xml
ElE[B Columns [F1[H] CrderReqs xmi
- [El= orderSamples [#] (] OrderReqs xmi
[F1[H] CrderRegs xmi
™ [#] OrderRecs xml

Select Types. Select All Deszelect Al

Select the export destination:

Directary:

j Elgowse...l

Options:
[~ Cwverwrite existing files without warning

[~ Creste directory structure for files

= Back [dext = | Finizh ! Cancel

Figure 38. Selecting the export directory for your files

___ 6. Notice that the list has been expanded in the Select resources to export
box. Click Finish to transfer your files. A progression bar activates.

You have now completed this task.

Task 5: Enabling

an XML Column

Before you use an XML Column for the first time, you must enable the column in
the database table. This process associates the Document Access Definitions
(DAD) file with the column and creates any side tables defined within the DAD
file.

When you created the tables for this lab in Task 2, "Creating your schema and
database tables” on page 23, a table named ORDERXML was created with a
single XML Column of type XMLCLOB. This is a UDT provided by DB2 UDB XML
Extender that is capable of storing and XML document.

Before you can enable an XML Column, the DAD file associated with the XML
Column must be available in an IFS directory.

___1. Inthis exercise, you use a side table. One of the benefits of using a side
table is performance. The entire document is in the XML Column and key
information in the columns can be shared with your traditional applications
that are already running.
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Using the DAD Editor, open the PurchaseOrderXML.dad file. To do this,
right-click Purchase OrderXML.dad, and click Open With-> DAD Editor.

2. Locate the table name that is created for this XML Column. To find this
information, go to the Design tab on the Editor pane. Under XColumn, you
see a table entry and beneath the table entry, you see the name entry.

3. Replace the Schema name for your table. Figure 39 shows a DAD file
changed to Group01 (using the Source view).

- ¥ ¥ML - Application Developer =01 x|
File Edit Perspective Project =ML ‘Window Help
B HES ap S RBR| <88R FE
5 |22 outine x | (R : x|
FY) 1:7eml wersion="1.0"7» -
ik 4 ml 2:IDOCTYPE DAD SYSTEM “dad.dtd"s
s @ DOCTYPE:DAD 3 <DAD>
=48> DAD 4ovalidation: N0« validations
E 5 <o umns
ﬁ E----<e> walicdation z ctable name=" IR -
=3 =< Xcolumn ccolumn name="IDENTITY type="char{g8)" path="/Purchasetrder:ML/Header Customeraid" mu’
<€ table kil zcolumn name="0RDERID" type="char(10)" path="/Purchasedrder>MLHeader OrderInfo/eorder:
3 ccolumn name="ORDERTIME" type="date" path="/PurchaselrderML/Header OrderInfo/adate" m
(] ccolumn name="ORDERTYPE" type="char(10)" path="/Purchasedrder:ML /Header OrderInfoatym
1 ccolumn name="TOTALMOWEY" type="decimal {10,2)" path="/Purchaselrder>ML Header OrderInf:
2 </ tables
13 </ columns
14« /DAD
15
?g_:Navigator = R =t s Tl &
o [H] OrderRen2 xml -
m Orderfeqdxml
m Crderfeqd xml
m OrderReqd . xml
m OrderReqs xml
£ 1-Erable-XML-Column s
0] 2-InserthL s
: éa 3-Guery-Customer_Names :
20| 4-Guery-cancelled sol
éa S-Guery-Crders-by-date =g
o [0 chact ctted
%] PurchaseOrder XML dad
- '_ﬂ Cleanup-tables =gl -
----- £ Setup-tables 2o = 4| | »
<| | }l Design|80urce|

Figure 39. PurchaseOrderXML.dad file changed for use the correct side table

Save the file. Click File-> Save PurchaseOrderXML.dad.
Exit from the Editor. Click File-> Close.

Using the export function of Application Developer, transfer the DAD file.
Click the PurchaseOrderXML.dad file and use the Export function as
explained in Task 4, "Exporting XML documents to the IFS” on page 31.
Use the same target directory.

7. You are ready to enable the XML Column using the DAD file. Expand the
Columns folder. Then locate and right-click the 1-Enable-XML-Column.sq|
file. Select Open With-> System Editor.

This action launches the Run SQL Script utility in iSeries Navigator. Figure
40 shows two SQL sentences that are executed.
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Note

Be sure you replace xx with your group number.

i O PROGRA~14JBM APPLIC~1 WORKSP~1"XMLLAB~1" Column: o ] |
File Edit ¥iew BRun ¥isualExplain Monitor Options Connection  Help

e 2R PP || I
b
Examples Runall | | = Insert |

I --- The first command will enable the XML Column with the
--- DAD file that was just created and sent to the server =F
- Werify if the DB name needs to be changed

™ --- Do not forget to change group numhber =

call gdbxm.gzemadm (enable_column’, 1400WWS", ‘group01 . orderxml’, ¥ml_doc’,
MTS0Labi=MUgroup 01 PurchasedrdermML dads;

I* -—- This next statement will check the db2xmlxmi_usage

--- table to verify that the enable column was successful

--- there should be one line in the result set helow *

select TABLE_SCHEMA fram dh2xmlxml_usage where table_schema="group01’

Messages |

Figure 40. Enabling an XML Column

The first sentence is a Call statement to enable the XML Column. The
program called is gzxmadm and is part of DB2 UDB XML Extender. The
parameters used by this program are:

» enable_column: The action to perform

1400WS: The name of the relational database name; use capital letters
GROUPXX.orderxml: The name of the table within schema

xml.doc: The name of the column to be enabled
ITSOLab/XML/GROUPXX/PurchaseOrderXML.dad: Your DAD file

— Note

If you experience problems running this command, try using a 5250
session. Open a 5250 session and invoke the Qshell interface. On the
command line, type &h and type the following command:

dxxadm enabl e_col um | 400\8 GROUPxx. or der xmt  xnm _doc
/1 TSQLab/ XM/ G oup10/ Pur chaseQ der XM.. dad)

The second sentence is a Select statement where only one column is
retrieved for you. The purpose of this statement is to check whether DB2
UDB XML Extender has accepted your request for enabling your column.
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DB2XML is the product library, and XML_USAGE is a directory used by the
product.

8. Run your SQL Script to enable the XML Column and to verify if it has been
accepted. Use the Run All icon to execute it. Provide your server ID and
then the database name in the dialog window. Enabling a table column
takes some time. Wait for the completion of the process.

—— Do not continue if...

...no record was selected. Tell your instructor or system administrator
that DB2 UDB XML Extender has not accepted your request.

A common problem is when you do not replace your group humber
correctly. or you specify the wrong local relational database name for
your system

__ 9. Exit from iSeries Navigator. Click File-> Exit.

___10.Because you made changes to the script file, you are asked if you want to
keep the changes in your file. Respond by clicking Yes to this message.

__11.i1f you have time, review what was created automatically in your schema.
Four triggers and a database table were created by DB2 UDB XML
Extender. The database table ORDERS is a side table to help you in the
search of elements from the XML documents.

This task is now completed.

Task 6: Storing your document into the XML Column

Your database table is ready to store your XML documents. You have already
enabled the column in your table and it is waiting for your documents. An SQL
Script file is already created for you.

Follow these steps:

1. In the Navigator pane, locate and right-click the 2-InsertXML.sql file. Then
click Open With-> System Editor. This launches Run SQL Script.

2. Make changes appropriate to work with your group number. Remember
that the Replace function is available. It is more accurate and faster since
you need to change the schema name and the IFS directory where your
data is.

3. Figure 41 shows you the SQL Script with all references replaced for
GroupO1.

37



7 C\PROGRA~1,IBM\APPLIC~1 ' WORKSP~1', XMLLAB~1" Column 10l =l
File Edit Yiew Run “isualExplain Monitor Options Connection  Help

[EL4 JES=) -V g e @
|

[ --- Inzeding the XML documents into ORDERXML *f

Examples

;l Inser |

/¥ --- There are 6 documents that will be inserted.
--- The next & insert commands will perform that operation =7
/¥ --- Do notfarget to change group number *f

insertinto Group01 . ardersml GML_DOC)

valuesidb2xml ¥MLCLOBFromFile(MTSOLabfxmliGroup01i0rderReqt xmiT);
insertinto Group01 . ardersml GML_DOC)

valuesidb2xml ¥MLCLOBFromFile(MTSOLabfxmliGroup01i0rderReq2 xmi?);
insertinto Group01 . ardersml GML_DOC)

valuesidb2xml ¥MLCLOBFromFile(MTSOLabfxmliGroup01i0rderReq 3 xmi’);
insertinto Group01 . ardersml GML_DOC)

valuesidb2xml ¥MLCLOBFromFile(MTSOLabfxmliGroup01i0rderReqd xmi?);
insertinto Group01 . ardersml GML_DOC)

valuesidb2xml ¥MLCLOBFromFile(MTSOLabfxmliGroup01i0rderReqs xmi’);
insertinto Group01 . ardersml GML_DOC)

valuesidb2xml ¥MLCLOBFromFile(MTSOLabfxmliGroup01i0rderReqs xmi?);

[ --- the next statement will run a query on the side tahle

--- created when the column was enabled to ensure

--- the insert operations were successiul. Make sure there
--- are four entries in the result set below *F

select* from [ELEIg) orders;

LL{ e

Messages I

Figure 41. SQL Script to insert XML documents in the database table

There are two types of SQL statements in this script:

* The Insert statements to insert a row in the database table: Note that
there is no reference to the side table. This is done by DB2 UDB XML
Extender to preserve the integrity between XML documents and
database rows.

* The Select statement at the end of the script used to verify that the six
XML documents were accepted by DB2 UDB XML Extender. All
columns of the table are selected in this statement.

Run the SQL Script using the All icon.

When the Select statement is executed, six are displayed as shown in
Figure 42.
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i €4 PROGRA~1IBM APPLIC~1 '\ WORKSP~1" XMLLAB~1 ' Column o ] [
File Edit Yiew Run WisualExplain Manitor Options Connection Help

EFS | - RBn FPHEOO WY I

Examples | ;l Inser |

values{db2Zxml XMLCLOBFromFile(MTSOLabkmifgroup01fOrderReq 2 xmly); ;l
insertinto group01.ordersml KL_Doic)

values{db2Zxml MLCLOBFromFile(MTSOLabkmifgroup01f/OrderReq 3 xmliy);
insertinto group01.ordersml KL_Doic)

values{db2Zxml MLCLOBFromFile(MTSOLabkmifgroup01f/OrderReqd xmly);
insertinto group01.ordersml KL_Doic)

values{db2Zxml XMLCLOBFromFile(MTSOLabkmifgroup01f/OrderReqa xmliy);
insertinto group01.ordersml KL_Doic)

values{db2xml XMLCLOBFromFile(MTSOLabkmifgroup01fOrderReqf xmly);

I -—- the next statement will run a query on the side tahle
--- created when the column was enabled to ensure
- the insert operations were successful. Make sure there
--- are four entries in the result set below =

select* from groupd1 .arders;

b

DXHROOT_ID IDEMTITY QRDERID QORDERTIME QORDERTYT
F?FBFEFDFSFL:{‘IFDFDFDFDFDF‘I CHOooon1 OMT4334458 2001-10-05 neww
FYFRFBFOF3IF4F3FOFOFOFOFORT CHO00onz2 OMBE323281 2001-10-05 cancel
FYFRFBFOF3IF4F3FOFOFOFOFORT CHO00003 OMEB328354 2001-10-04 neww
FYFRFBFOF3IF4F4AFOFOFOFOFORT CHOooon1 OMT4334458 2001-10-08 cancel
FYFRFBFOF3IF4F4AFOFOFOFOFORT CHO00004 OMEB283524 2001-10-05 neww
FYFRFBFOF3IF4FSFOFOFOFOFORT CHO000ns OM99482374 2001-04-05 neww
A | o

Messages | select* from group0l orders

Figure 42. XML documents accepted by DB2 UDB XML Extender

___ 4. The Select statement displays all columns in the table. The DXXROOT_ID
column was created by DB2 UDB XML Extender and is used to correlate
side tables entries with corresponding XML documents (used to generate
side table content).

As XML documents are stored in the XML Column, DB2 UDB XML
Extender generates a unique ID. The ID is stored in the DXXROOT_ID
column for use in queries that involve join operations between the XML
Column in the table and its associated side tables.

Exit from the System Editor by clicking File-> Exit.

5. Save the file when you are prompted, or use the save option before you
exit from this system utility.

This task is now completed.

Task 7: Running queries against XML Columns and a side table

DB2 UDB XML Extender provides a number of functions for extracting or
updating individual elements and attribute values in an XML Column, even if the
values are not stored in a side table.
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In this task, you run a number of queries to demonstrate some of the accessing
functions provided by DB2 UDB XML Extender for working with data in XML
Columns:

1. In the Navigator pane, expand the Columns folder and locate the
3-Query-Customer_Names.sql file.

2. Open this file with the System Editor. Change references to your group
number. Figure 43 shows the SQL Script changed for Group01.

F CPROGRA~1IBM' APPLIC~1' WORKSP~1' XMLLAB~1" Columns'
File Edit Yiew BRun ¥isualExplain Monitor Qptions Connection  Help

HEE| L BB FPDO | @

Examples | ;l Insert |

" --- This select staterment will get the descriptive names for the customer
--- aut of the XML document stared in the colurmn. Naote that the side takle
--- does not stare the name of the customer. This statement is actually
--- pulling the value out of the XML document *f

" --- Do not forget to change group number =

=0l x|

SELECT dhZxml extractvarcharfml_doc,'PurchaseOrderMLUHeader/CustomerMame” from
groupll . ardersml

0ooot
Rans Hardware
Als Lawn and Garden
Hardware Super Store
Rans Hardware
Fastenatars Inc.
Wine Road Greenhouse and Lawn Supply

SELECT dbZsmlextractarcharisml_doc YPurchaseQrder=MLIHeaderCustaomentame’ from group0l .ord
| Messages |

Figure 43. Querying the Customer Name in the orders

___ 3. Notice that this query uses the DB2 UDB XML Extender extractVarchar
function. This function is used to extract individual elements or attribute

values from data in an XML Column based on a location path that identifies
the element or attribute of interest.

In this script, you extract the customer names from purchase orders stored
in our XML Column. Also, note that the side table generated from our XML
Column is not involved in this query.

Save your file changes and close the Run SQL Script window.

4. Execute another script. Locate the 4-Query-cancelled.sql file and open it
using System Editor. Change the group number. An example of this query
is shown in Figure 44.
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75 CYPROGRA~1WIBM Y APPLIC~ 1 WORKSP~1 4 XMLLAB~1" Colun o ]
File Edit View Run “isualExplain Maonitor Options Caonnection  Help

TEE | s R PP M| P
L3

Examples | ;l Insert |

/™ --- This query will combine use of the roves in the side table and pulling information
-—- out ofthe carresponding =ML document stored in the XML calumn

--- The query finds all orders with status "cancel” in the side table and pulls the

--- customer name and notes out ofthe XML document, *r

/™ --- Do not forget to change group number *F

SELECT dhZxml extractvarcharml_doc,"PurchaseQrdersMLHeader Customer/Name?,
dbzxmlexdractyarcharimi_daoc, "PurchasedrderxiUiHeaderQrderinfafMotes’ from groupld . ardersml,
group01.arders where ordertype = 'tancel’ and Ryl =Teigqll oot_id = group01.ord ot_id)

Messages |

Figure 44. Query cancelled orders

__ 5. This query is designed to return the list of customer names and order notes
for those orders that have been cancelled. The function extractVarchar is
used to retrieve customer names and order notes. In this case though, the
side table is used to select only those orders that have been canceled.

This query also demonstrates that DB2 UDB XML Extender generates a
unique ID column for XML Columns that can be used to perform SQL join
functions between the XML Column and its associated side table(s). This is
done by the join condition:

groupl0. order xn . dxxroot i d = groupl0. orders. dxxroot _id
Save your file and close the Run SQL Script.

6. Your last query for this task is to query all orders placed on a particular
date. Locate the 5-Query-Orders-by-date.sql file and open it with System
Editor. An example of the code with the group number replaced is shown in
Figure 45.
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%1 C\PROGRA~14IBM APPLIC~ 14 WORKSP~ 14 XMLLAB~1% Columns',5 -10]=l
File Edit Yiew Run “isualExplain Monitor Options Connection  Help

TS RB| PP DO O ey @
[
Examples Run Selected ;l Insen |

[* - This queny will extract all of the documents which took place an Septernber 30th, 2001 *F

/™ --- Do not forget to change the group number =F

select orderid, totalmoneyxml_doc from group0? . orderaml, group01 .orders where

graupdl ardersml.dsraot_id=group0l . arders.dsxraot_id and orderime = (UL

ORDERID TOTALMOMEY | XML_DOC

QOrT43344453 260.00(=7%ml version="1.0"?*=00=PurchazeOrder=ML version="0.1"=0 -

QMBI 0.00=?xml wersion="1.0"?=00=PurchaseQrderxML varsion="01"=0 -

QMBI 0.00=?xml wersion="1.0"?=00=PurchaseQrderxML varsion="01"=0 -

QrB3253824 2700.00=7sml version="1.0"?==PurchazeOrder=ML version="0.1"= =Hea

QrB3283824 2700.00(="ml version="1.0"?"=00=PurchazeCrder=ML version="0.1"=0 -

4 | i

select orderid, totalmoneyxml_doc from group0? ordergml, group01 orders where group01 orderml diero
Messages |

Figure 45. Query orders for a particular date

___ 7. The ordertime column in the side table is used to select orders for a given
date. Similar to the previous query, a join is performed between the side
table an the XML Column table to select the purchase order documents
matching the desired order date.

In this case, our result set includes the complete purchase order
documents rather than selected fields from the order. Note the XML_DOC
column that contains the XML document.

When you finish reviewing this output, save your file and close the Run
SQL Script.

___ 8. Close the Columns folder.

You have now completed this task and Lab 2.
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Lab 3. Decomposing XML data using an XML Collection

Objectives

Lab 2 explains how to store an XML document in a database column. XML
Columns are a good option when you want to keep all the content of your
documents. For example, you receive XML documents about products from
different sources, but you are not interested in changing your current providers
and want to keep all the information as it is.

When storing the documents in an XML Column, you feel comfortable because
you know the information is in a safe place and available when you need it. Unlike
XML Columns, XML Collections store XML data in database files as individual
fields rather than as complete XML documents. Elements and attributes values
from the XML document are mapped to columns in one or more database tables
based on information specified in a Document Access Definitions (DAD) file.

XML Collections work with existing database tables. You map document
information to your existing columns in tables. Be sure to use caution when
mapping to the correct fields.

There are two forms of mapping XML data to database tables and columns that
are supported:

« Relational database (RDB) mapping: Where the DAD file defines explicit
relationships between an XML element or attribute to a database table or
column

* SQL mapping: Where an SQL Query is used to extract information from one
or more database tables, and the columns in the resulting table are mapped to
an XML document

The RDB mapping technique can be used for both:
e Decomposition: XML document to the database

e Composition: XML document from the database

The SQL mapping technique can be only used for XML data composition from
existing database information.

In this lab, you populate an existing database with information contained in an
XML document. Our example lawn and garden center inventory database is
updated from XML documents defining the set of new items received.

This lab demonstrates the support provided by XML Collections for decomposing
XML data and storing it in one or more database tables.

By the end of this lab, you will be able to:

» Create a DAD file to map data from an XML part list document to an existing
part information database.

* Use XML document decomposition facilities provided with XML Collections to
extract part data from an XML document and store it in an existing database
table, based on a specified DAD file.

« ldentify with more accuracy when it is better to use XML Collections or XML
Columns, as shown in the Lab 2.
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Lab prerequisites

Time required

You must have completed Lab 2, “Working with XML Columns” on page 17,
before you start this lab. If you did not have time to complete the, you can read
the material to learn the concepts introduced there. The most important part is in
Task 2, "Creating your schema and database tables” on page 23. In this lab, the
database tables used in the lab were created.

We recommend that you complete Lab 2, “Working with XML Columns” on page
17, before you begin this one.

The time required to efficiently complete this lab is 30 minutes.

Required information for working with the lab

The same requirements from the previous lab are valid here:
* You must assign drive “I” to the ITSOLab folder in the IFS.

* You must have the name of your server and be prepared to supply this
information when prompted.

Task 1: Preparing the WebSphere Studio Application Developer Workbench

Before you begin

Ensure that you have observed the prerequisites specified for this lab and
given consideration to the previous lab.

To do this lab, you do not need any of the files used in the previous lab. You can
collapse the Columns folder in the Navigator pane and expand the folder that you
need in this lab.

To prepare your workbench, follow these steps:

__ 1. Start WebSphere Studio Application Developer from the Windows desktop
if it is not already open. Click Start-> Programs-> IBM WebSphere Studio
Application Developer-> IBM WebSphere Studio Application
Developer.

2. WebSphere Studio Application Developer is recursive, if you exit from the
product using the Close option, your configuration settings are preserved.
Click the minus sign (-) to collapse the Columns folder as shown in Figure
46.
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-1 ¥ML Lak for Group 1
B Addtionsl
--{B Collections
i--{B Columns

----- £0) 1-Enable-HML-Column sl

----- 0] Z-Insertimil sl

----- E@ 3-Query-Customer _Names g
----- 0] 4-GQuery-canceled sl

----- 0] 5-Query-Orders-by-date sgl
----- [0 chadd ctted

----- Purchaserder ML dad

----- £d) Cleanup-tables sql

..... é_uj Setup-tables =gl

| | v

Figure 46. Collapsing the Columns folder

___ 3. Review the contents of the folder that you will use. Expand the Collections
folder as shown in Figure 47.

E-Ta$ ¥ML Lab for Groug 1
{5 Additionsl
= R=a_ollections

-20] 1-Decompose-PartsListkML-R

----- 28] 2-Compose-CatalogkML-SALD

----- @ catalog.ctd

----- catalogsgl.dad

----- [0 dad.dtd

----- 0] partsfist.dtcl

----- @ partslist. ml

----- partslistrol dad

= Columns

----- g='._n_°| Cleanup-tables sl

----- g='._n_°| Setup-tables =gl

1 | 3

Figure 47. Expanding the Collections folder

4. From this list, you will work with all files associated with the part lists; the
other file will be used in Lab 4, “Composing XML documents from existing
data” on page 57.

This task is now completed.

Task 2: Reviewing the information in the XML file

The XML document used for this lab has a more complex structure. In this task,
you read the contents of the XML file:

___ 1. Locate the partslist.xml file and open it using the XML Editor. If this is the
first time you open a file, XML Editor is the default. This means that you
can select the partslist.xml file, right-click, and click Open as shown in
Figure 48.
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Ga To 3

Open With lg »

Copy
Maove

Renarne
Delete
Add Bookmark.

Refresh From Local

B ¥ML Lak for Groug Run Ak, .,
--EB- Additional E_-| Blun on Server

£ Collections validate %ML File
£d] 1-Decomgc

Team 3
20 2-Compos Campare With *
@ c:a:og.dtld Replace \With r
catalogsl.
Apply ®5L 3
[B] ehat.chtel R

[0 partslist ot Properties

“-[€] partslistrob.dad
#-{= Columnz

----- 28] Cleanup-takles =gl
...... ;ﬂ Setup-tables gl

1| | »

WML Lab for Group 1 /Collectionspattslist xml

Figure 48. Opening a file using the default open option

___ 2. When the file is loaded, the Editor and Outline panes are updated. First,
you work with the Editor pane. Verify that the Source tab (at the bottom) is
selected. You see the document content as shown in Figure 49, and tokens
with colors for each component.
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- ¥ ¥ML - Application Developer
File Edit Perspective Project XML

Window  Help

=0l x|

DOCTYPE Parts
[#-<€» Parts

&8 E s

F-HES KRR RRB| Y AAE(EE

5 |22 outine x @ x |

D e —————————— <7«m| wersion="1.0"7x -
ik » il 2 |DOCTYPE Parts SYSTEM "partslist.dtd"s -~

?g_; Mavigator far R

=& XML Lak for Group 1
-z Addtionsl
=z Collections

partslist xml
o] partslistrdb dad

#-{Z= Columns

----- 20 Clesnup-tables ol

Bl Setup-tables sl

1

£ 1-Decompose-PartsListiML-R

J<Parts date="2001-10-08">

4  cPart partnumber="PHOOOD0000" class="1"»

5 <Mame: Hammer < /Hame:

6 cDescription=High durability standard hammer. ¢/Descriptions
7 cPrice currency="UsD" unit_1d="1":10.99¢/Frices

g ¢Instock status_id="1":100¢/Instock:

9  ¢/Parts

10  <Part partnumber="PHOOOO0001" class="1"»

abal cHame=Tape Measure:/Mame:

12 cDescriptionzMeasures up to 25 feet. Measures Metric and English units. </Descriptions:

13 <Price currency="UsD" unit_1d="1":14.99¢/FPrices
14 ¢Instock status_id="1":2250¢/Instocks:

15 </Parts

16 <Part partnumber="PHODOOOO002" class="2"»

17 cHamezHex Cap Screws/Hames

18 chescription=1/4 in. dia. Hex Cap screw. 50 per box.</Description:

19 <Price currency="UsD" unit_id="2":5.00</Prices

20 ¢Instock status_id="1":100¢/Instock:

21 </Parts

22 <Part partnumber="PHOOO00003" class="2"»

23 cHames>Sheet Metal Scre/Hames

24 chescription:=1/4 in. dia. sheet metal screw. 50 per box.c/Description:
25 cPrice currency="UsD" unit_id="2":5.00</Prices

26 ¢Instock status_id="2":0¢/Instocks

2F  </Parts

28 <Part partnumber="PHOOO00004" class="2"»

29 cHame:Elevator Bolte Mames

30 chescription=1/2. in. dia. Elevator bolt. 10 per box.</Description:
31 cPrice currency="UsD" unit_id="2":10.00¢/FPrices

32 ¢Instock status_id="1":10¢/Instocks:

33 </Parts
34  <Part partnumber="PHOOOOO005" class="2"»
35 <MamesCarriage bolt:/MName:

36 chescription=1/2. in. dia. Carriage bolt. 10 per box.</Description:
37 cPrice currency="UsD" unit_id="2":7.00</Prices
38 ¢Instock status_id="4":25<¢/Instocks:

39 </Parts

40 ¢Part partnumber="PHOO000006" class="3":

41 c<HamesDecor. Bricke/Mame:

42 cDescription:Red adobe decoratiwve bricks. ¢/Descriptions

43 cPrice currency="UsD" unit_id="8":4.00</Prices
44 ¢Instock status_id="1":>1000¢/Instocks

45 </Parts

46 <Part partnumber="PHOO000007" class="3":

4 |

i

Design lSourcg\]
{

iy

Figure 49. Source view of an XML document

___ 3. Skip the first two lines. Position your cursor on the third line (any column)

Notice that from line 3 to the end, the number of lines (left column) are
shaded. This is to highlight the entire structure of the Parts document
referred in the second line. Parts have many Part records. Parts also have
tags that define each of the elements.

All the elements are in the color cyan on your screen. The attributes of
each element are in magenta. And the data, is in black.

Position the cursor at line 4. Did you note the change? The line numbers
are shaded from line 4 to line 9. This is done because the Part’s
boundaries (<Part> and </Part>).

Do you want a better approach to read your data? Try the Design tab.
Figure 50 shows you the same document with all elements expanded for
the first record of the document.
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2= wml warsion="1 0"
@' DOCTYPE Parts SYSTEM "partslizt otd"
[El-4e» Parts (Fart+)
i claite: 2001-10-08
B« (Mame, Description, Price, Instock)
4@y partnumber PMOQOOCO00
P clazs 1
Matne Hatmimer
Descrigtion High durahilty standard hammer.

Price
Instock

-

Figure 50. Design view of an XML document

Now the data is much easier to read.

When you receive XML documents usually, they came with the DTD
(Document Type Declarations) where the elements and attributes are
defined.

5. Go to the Outline pane and click one Part item, which expands as shown in
Figure 51.

2wl
[ DOCTYPEParts
[=]-<es Parts

Iig:f”

|»

----- <er Mame

~4er Description

-4y Price

~4er nztock

Part

Part —
Part

Part

Part

[#-4er Part

--<e> Part j

Figure 51. Outline view of the XML file

___ 6. Note when you click in one of the elements, your Editor pane is updated.
Work with these two panes for a couple of minutes and look at the
relationships that WebSphere Studio Application Developer makes for you.
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__ 7. Do not close the partslist.xml file. In line 2, you can read a reference to the
partslist.dtd file. What is a DTD?

This task is now completed.

Task 3: Reviewing the associated DTD file

A Document Type Declarations (DTD) file contains information about the
elements and attributes that the XML file have.

When you decompose an XML document, you need to have a DTD to tell to DB2
UDB XML Extender how to format your data. In this task, you review the
information in the DTD file for your XML document:

. Verify that the Editor and Outline pane was updated.

From the Navigator pane, double-click the partslist.dtd file to open it.

. Change the view of your Editor. Click the Source tab (at the bottom). You

see the structure of your document. Figure 52 illustrates a source view of a

DTD file.

. ¥ XML - Application Developer

File Edit Perspective Project DTD ‘Window Help

5 [= 3]

=1 ¥ML Lak for Group 1
-z Additional
{B_v Collections

2-Compose-CatalogiML-SQLDAD gl
@ catalog.ctd

catalogsgl.dad

[0 dact ottt

(D] partslist.otdl

m partslist.xml

partslistrob dad

{= Columns

20 Cleanup-takles sol

é_ﬂ Setup-tables sgl

1-Decompose-PartsList¥ML-RDBOAD =g

S-HE O @R DR HR| 7 ARG 0] @ wed
= 22 Qutiine A B x || 2 partsistaom : x]
| e 7 =TS-ASCIIN?
= EI@ partaistotd H 2< «m] encoding E “
EEI <7xml encoding="US-ASCI"?= 3 <|ELEMENT Parts {Part+ls
n 4<IATTLIST Parts
43
Hhenibas 5 date CDATA #IMPLIED
B || &Y pas &
EI-:) [=l-4e» Part 7 <lELEMENT Part (Mame, Description, Price, Instock)s
& B &< IATTLIST Part
ﬁl : 9 class CDATA #REQUIRED
e F 10 partnumber CDATA #REQUIRED:
11
12<!ELEMENT Hame (#PCDATA):
13 ¢ |ELEMENT Description (#PCDATA):
14 < |ELEMENT Price (#PCDATA):
15 < IATTLIST Price
£ar class 16 currency CDATA #REQUIRED
17 unit_id CDATA #EEQUIRED:
£ar parnumber 18
19 |ELEMENT Instock (#PCDATA):
P ikt 20 <1ATTLIST Instock
-4
E Dgscrlpﬂon o 21 status_id CDATA #REQUIRED:
[#-4€» Price
@ o
H-[5] Price
.40y Instack LI
?QT; Mavigator - ™

4

o

Design

SourceJ
{

&

Figure 52. Source view of a DTD file

4. WebSphere Studio Application Developer use the Outline pane to view the
indentation of an XML file.
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___ 5. Go to the Outline pane and verify that the elements (letter “e” in blue color)
and attributes (letter “a” in green color) are there. Figure 53 shows an
example of how the Part element is created.

. ¥ XML - Application Developer

File Edit Perspective Project Window Help

=1olx|

=@ ¥ML Lak for Group 1
Bz Addtional
EIB Collections
1-Decompoze-PartsListAML-RDBOAD =g
2-Compose-CatalogEML-SQLDAD sgl
catalog otd

F-{= Columns
] Cleanup-tables sol
é_ﬂ Setup-tables gl

B HBE @B BRR| S| B RBR| e e b
=0 - cuine 4 B x || dpartsistaonl | [B) partstst.otel X |
1«7xml d ="US-ASCII" 7
m =5 [0) patslist ctd = 2< «ml encoding = a
= =7xml encoding="US-45CI"?= 3 |ELEMENT Parts (Fart+)s
Rt 42 IATTLIST Parts
By 5 date CDATA #IMPLIED:
il -] Parts B
E) [=-4e» Part < |ELEMENT Part (Mame, Description, Price, Instock):
= B < IATTLIST Part
ﬁl 3 class CDATA #REQUIRED
1) Mame partnumber COATA #REQUIRED:
1) Description 1
12 ZVELEMENT Hame (#PCDATA):
13<|ELEMENT Description (#PCDATAY:
14 < |ELEMENT Price (#PCDATA)>
15« IATTLIST Price
16 currency CDATA #REQUIRED
17 unit_id CDATA #REQUIRED:
Le4dr partnumber a
48> MName 19« |ELEMENT Instock (#PCDATA):
F-4er it 20<IATTLIST Instock
B DF_:SCrIpTIDn b 21 status_id CDATA #REQUIRED:
[+-4&» Price
@ o
[#-"ZF] Price
.40y Instock ﬂ
?g_; Mavigatar o A w

1

Design |Sourceﬁ |

Figure 53. Outline pane for the DTD file

___ 6. When you click an element or structure in the Outline pane, the
corresponding line in the Editor is updated with the line numbers shaded.

Click the date attribute and

line 5 is shaded.

What do these keywords mean in this definition? If you change the Editor
to the Design view, you have a great support. See Figure 54.
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Figure 54. Prompt for definitions

B || == outine 13 & x || 2 partsiistam m
E@ E@ partslist it —Aftribute Information
=7xml encoding="US-ASCI"?= _
o T Mame: |date j
ﬁ [ QL (Character Data ()
Bl L (+) Part
S B “?_g’] Partz — Attribute default valus
Lodd@y clat
e, =  #IMPLED (" #REQUIRED
f-
- part (" #FIXED " Defautt
[#-4€» Mame
[#]-4e» Description I
[#-4€> Price E FER
B u% Price —Enumerated defaults
[#-4e¥ Instock A ==
[ “?g’] Instock I _I
== REmayE I
|E‘3_: Mavigator v X | " | Defaul

___ 7. Leave this file open.

This task is now completed.

Task 4: Reviewing the associated DAD file

You already know the information that comes in the XML file and the type of data
in the document. Now you need to tell DB2 UDB XML Extender where to put this
information.

When a document is decomposed, you can use as many tables as needed. In this
lab, you decompose the XML document in one database table only. As we
discussed earlier, you are responsible for the database table creation and the
columns and their attributes. See Task 2, "Creating your schema and database
tables” on page 23, in Lab 2, if you want to learn more about the structure of the
parts database.

In this task, you work with the DAD file to provide information about how the
information will be transformed to the database table:

___1. Inthe Navigator pane, locate and double-click the partslistrdb.dad file top
open it.

2. At the bottom of the Editor pane, click the Source tab to change to the
source view of your code. To see the structure of the DAD file, you can see
similar results using the Outline pane.

3. Using the Outline pane, expand some level of the code. As soon as you
expand a level, the corresponding details expand in the Editor pane.

4. When you are creating a DAD file, the most important part is to define the
attributes for each element. The Design view of the file allows you to do
this. Click the Design tab (at the bottom of Figure 55) if necessary.
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- ¥ ¥ML - Application Developer
File Edit Perspective Project XML

Window

Help

=0l x|

BSHES KRR RBR| S AAR|FHE

5 |[5= outine s || i) partstistoml | D) partsist ctd %
% L48) pralog Al =B xml wersion="1 0"
4@y doctype [ DocTYPE DAD SYSTEM "dad dtd”
[J-48% root_node El4e> DAD - e e
il El-4e> element_node 48> validation
irg) [#-«e» ROB_node [l-4€» Kcollection
=48> elemert_node -4 prolog 2uml version="1.0"7
’% [#]-4e3 sttribute,node 4> doctype IDOCTYPE Parts SYSTEM "partslist ctd”
T [#-4€» attribute_node [=1-4er root_nods (
[#-<e> element_node I?|--<E> element_node
<o #TOMMENt :
[*-<&» element_node -+e+ RDB_nods
----- ey #oomment
[H-4e» element_node
----- des #ocomment |
[H-4e» element_node
----- de #oomment FEea
1 | Add ttributs b | e
F5- Navigstar S G ow X ISR <> =ttributs_node

e element_node

=& XML Lak for Group 1 -

-z Additional
EIB Collections
£ 1-Decompose-PartsListiML-R
2] 2-Compose-CatalogML-SaLD
@ catalog dtd

Add Before  # =7
e
<e» element_node 5

er element_node  Feplace With ¥

<€ namespace_node
e element_node
L.

<8» process_instruction_node

<e» RDB_node

catalogsgl.dad
[0 dact cital dews Comment
@ partslist dtd &% Processing Instruction
m partslist xml

partslistrob dad
F-{Z= Columns

'_ﬂ Cleanup-tables =gl
4 :ﬂ Setup-tables =gl

Design ]Source

Figure 55. Adding attributes

5. Make some changes to this DAD file. Specify where your columns and
database table are located. Be sure to change the group number in your
schema.

6. Locate the references for the table name. Change the table name and the
SQL statement that selects all rows. There are two lines in total.

7. Change the references for the schema for the columns of the table. You
need to change nine columns. You can use the Find & Change support for
additional help. Press Ctrl+F in your keyword and a dialog box opens. See
Figure 56 for details.
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. ¥ Find/Replace x|

Firel: I OroLIpE j
Replace With; Igl’DupD'l j
Direction Options ———————
% Forvward [~ Case Sensitive
" Backward [~ Wrap Search
[ Whiole Wiord

Find Hext | Replacefind |

Replace | Replace Al L\J

Close |

Figure 56. Searching and replacing the schema name

___ 8. Click the Replace All button.
9. From the menu bar, click File-> Save to save the file.

___10.Close this window when you are finished but leave this file open.

This task is now completed.

Task 5: Working with the three related files

The objective of this task is to summarize what you have learned. To decompose
an XML file, you need to have a DTD file where elements and attributes are
defined. And you need to have a DAD to be used by DB2 UDB XML Extender to
transform the information from an XML file to database table.

A common problem when decomposing an XML document is when the DAD is
not correctly coded, especially with numeric columns. Check all information
related to the price of a part item and see how to define a numeric data. This data
is transferred to the Price database column, which is defined as decimal.

After you verify that all references to the schema name have been replaced to
use the schema for your group, send these files to the IFS:

___1. Close the three files currently open, using the Close button, as shown in
Figure 57.

B -lolx|
28 &R | #[E

] partsistoanl | O] partslist.td

1c?=ml wersion="1.0"7:
Z<IDOCTYPE DAD SYSTEWM "dad. dtd":
3 <DAD
ovalidations>NO ¢ validations
<xcollection:

cprologs?=ml wversion="1.0"7< /prologs

cdoctypes IDOCTYPE Parts SYSTEM "partslist.dtd” </ /doctypes

<root_node:

<element_node name="Parts":
Hatol ot - da.

x|
s

L
bR o T s R, Y

Figure 57. Closing files using the Close button
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___ 2. Gotothe Navigator pane (Figure 58). Click the partslist.dtd file. Then hold
the shift key and click the partslistrdb.dad file to select the three files as a

group.

=-Ta$ ¥ML Lab for Groug 1

F-E= sdditionsl

El-Z= Collections
----- 28] 1-Decompose-PartsListiML-F]
----- 28] 2-Compose-CatalogkML-SALD
----- @ catalog.ctd
----- catalogsgl.dad
..... @ dad.dt

= Columns
----- é_nj Cleanup-tables sl
----- é_nj Setup-tables =gl

1 | »

3 tems zelected

Figure 58. Selecting the files to be transferred

___ 3. Use the Export function of WebSphere Studio Application Developer to
transfer the files to the IFS.

This task is now completed.

Task 6: Decomposing the XML file

54

To decompose an XML document, use a stored procedure shipped with DB2 UDB
XML Extender. This program, calls the dxxShredXML() function to perform the
decomposition and storage of the resulting data in the database table.

Input to the dxxSHredXML() function includes the DAD file defining the XML
Collection and the XML document to be decomposed.

You need to run the decomposition process in the server:

1. Go to the Navigator pane, locate the
1-Decompose-PartsListXML-RDBDAD.sql file, and open it using the
System Editor to invoke the Run SQL Script.

2. Change the references to your group number.
3. This script file has two SQL sentences:

e Function dxxShredXML(): A call to program shdx that uses the
dxxShredXML() function. This program needs the name of the relational
database as a first parameter. The second parameter is the name of the
DAD file. And the third parameter is the name of the XML file.

« Select statement: The second statement is a Select statement to verify
that DB2 UDB XML Extender has accepted your XML file.

Figure 59 shows you a copy of the SQL Script file.

Integrating DB2 UDB for iSeries and XML



iF G\ PROGRA~1YIBM\APPLIC~1 WORKSP~1' XMLLAB~1 COLLEC~ D i o] |
File Edit Yiew Run ¥isualExplain Monitor Options Connection  Help

et 2B PR o |k @
L

Examples Run All j Insert |

¥ -—- This script will decompose the specified XML document using the DAD file just created
= ---erify if the DB name needs to be changed *F
¥ -—- Do not farget to change group number

nle BEY| 400" MTSOLabixmligroup 0 ipartslistrdb.dad’,
MTSOLabxmiigroup0lipartslistxmly;

" --- This query will show the values that were stored into the takle when the document was decomposed:
il

select * from groupll parts;

Messages |

Figure 59. SQL Script to decompose a document

___ 4. Save the file. Click File-> Save or press Ctrl+S.

__ 5. Run your SQL Script. Figure 60 shows the first rows in your patrt file.

COMPANY | PARTHUMBER | MAWME DESCRIFTION
1(PMO0000000 Hammer High durahility standard hammer. -
T{PMO0000001 Tape Measzure Measures up to 25 feet Measures Me
1(PMO0000002 Hex Cap Screw 1/4 in. dia. Hex Cap screw. 50 per hox
T(PMO0000003 Sheet Metal Scr 1/4 in. dia. sheet metal screw. 50 per
T(PMO0000004 Elevataor Balt 172, in. dia. Elevator halt. 10 per bax
1(PMO0000005 Carriage bolt 172, in. dia. Carriage balt. 10 per box,
1|PMO00O0000E Decaor. Brick Red adobe decarative bricks.
1(PMO0000007 Sod-midgrade Mid-grade sod 1 vard wide.
1(PMO0000008 Sod-highgrade High-grade sad 1 vard wide,
1(PMO0000009 Garden Hasze Rubber garden hose. Ends sold seps
T(PMO0000010 Grass Seed 24lb grass seed
1|PMO0O000T1 1 in. Canduit 1in. dia. electrical conduit
T(PMO0000012 CopperWire House-wiring grade copperwire. Insr—
1|PMO0O00013 Elec, Box Standard Size 2-autlet electrical wall £ -
AIPRIOAOANNA A Patinm Sail Al rlazanad nodina e nil
i s
Messages | select* from groupdl parts |
L

Figure 60. First records selected from the database table
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___ 6. Ifyou do not see any rows after the select statement runs, advise your
instructor or system administrator. These records must be selected.

___ 7. Close the SQL Script windows to return to WebSphere Studio Application
Developer.

This task is now completed.

Task 7: Running queries against XML Columns and side table (optional task)

The DB2 UDB XML Extender has transferred all the information to databases
tables. This means that you can execute any SQL statement you want. Using the
Run SQL Script from iSeries Navigator is a good interface to the server. Look at
the content of PARTS table in your GROUPxx collection. It should contain the
elements of the XML document.

Take some time to work with this database, but do not forget you need to do
another lab.

You have now completed this lab!
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Lab 4. Composing XML documents from existing data

Objectives

Lab prerequisites

Time required

As we explain in Lab 3, “Decomposing XML data using an XML Collection” on
page 43, XML Collections decompose and compose XML documents into and
from DB2 UDB for iSeries. Each element and attribute value in the XML

document is mapped to columns in one or more database tables or vice versa.

Decomposition refers to the act of storing XML data across one or more database
tables. Composition refers to generation of an XML document from existing
database tables.

RDB mapping and SQL mapping represent two techniques for composing XML
documents. Both describe the mapping process via a Document Access
Definitions (DAD) file used by DB2 UDB XML Extender at runtime to perform the
composition function. For SQL Mapping, the DAD file contains an SQL query that
is used to extract information from one or more database tables.

The result set of this query is then mapped to individual XML document elements
and attributes via additional instructions in the DAD file. Any number of DAD files
may be used with a given database, enabling multiple types of XML documents to
be generated from the same database schema.

The XML Collection feature of DB2 UDB XML Extender is used for this lab. In this
case, you compose a new XML document from database tables.

To achieve these objectives, you will:

« Create a DAD file to specify how to generate an XML document from existing
database tables using the SQL Mapping technique of XML document
composition supported by DB2 UDB XML Extender

» Use the DAD file and XML document composition facilities provided with XML
Collections to generate an XML product catalog from a part inventory
database

This lab builds on the results of Lab 3, using information from the parts database
to generate an XML-based catalog of the items available for sale from our
example lawn and garden center.

You must complete Lab 3 before start this lab.

The time required to efficiently complete this lab is 25 minutes.

Required information for working with the lab

The same requirements from the previous lab are valid here:
« You must assign drive “I” to the ITSOLab folder in the IFS.

« You must have the name of your server and be prepared to supply this
information when prompted.
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Task 1: Preparing the WebSphere Studio Application Developer Workbench

Before you begin

Ensure that you have observed the prerequisites specified for this lab and
given consideration to the previous lab.

In this lab, you continue to use the Collections folder. Your work is to create a
catalog of parts available in your database table. This folder has the necessary
files that you need.

To prepare your workbench, follow these steps:

1. start WebSphere Studio Application Developer from the Windows desktop
if it is not already open. Click Start-> Programs-> IBM WebSphere Studio
Application Developer-> IBM WebSphere Studio Application
Developer.

2. Expand the Collections folder in the Navigator pane to open it.

3. Verify that you have two files related to XML for your parts catalog (DTD
and DAD) and an SQL Script to invoke DB2 UDB XML Extender functions
as shown in Figure 61.

E-(Z3 Addtionsl
E-{Z= Collections
----- é_uj 1-Decompose-PartsLiztXML-RDBDAD =gl

----- [0] partslist ctel

----- [{] partsiist xml

----- partslistrdb cdac
#-{= Columnz

..... £0) Cleanup-tables sl
..... E@ Setup-tables =gl

Figure 61. Contents of the Collections folder

This task is now completed.

Task 2: Reviewing the information in DTD file

Unlike working with columns, when you are decomposing or composing a
document, a DTD file is necessary. In this task, you review the DTD file that is
necessary to compose a document:

__ 1. Locate the catalog.dtd file and open it using the XML Editor or DTD Editor.

___ 2. Click the Source tab at the bottom of the Editor pane to use the Source
view as shown in Figure 62.
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15 currency CDATA FREQUIRED
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[=-{a$ XML Lak for Group 1
{2 Additional
EIB Collections
é_ﬂ 1-Decompose-PartsListAML-RDBEDAD =gl
é_ﬂ 2-Compose-CatalogXhL-SALDAD =gl
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catalogsgl.dad
[0 dad.dtd
[0 partslist el
m partslist xml
partslistrob dad
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----- é_ﬂ Cleanup-tables =gl
i é_ﬂ Setup-tables =gl

4

o

Design lSourceJ
|

M

Figure 62. Source view of the DTD document

In examining this view, you can see that the DTD files are very similar. A
DTD file shows the dependencies of the information. An element has
attributes and sometimes it has a list of attributes.

___ 3. Close this file.

This task is now completed.

Task 3: Reviewing the DAD file

This DAD file is simple. It contains the information you want to have in the XML

file. You can find relevant information about this file if you read the file's code:

___ 1. From the Navigator pane, double-click the catalogsql.dad to open it.

The

Editor and Outline panes are updated.

__ 2. Go to the Editor pane and select the Source view for your source. You see
a copy of the file as shown in Figure 63.
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§ *cati 4
1c7=ml wersion="1.0"%x o
2<IDOCTYPE DAD SYSTEM "dad.dtd"» —
3 <DAD
4  ovalidation:HN0e validations:
5 «<xcollections
o WSELECT COMPANY, CLASSDESC, PARTHUMBER, MWAME, DESCRIPTICHM,
7 cprologs: ?=ml wversion="1.0"7< /prolog:
a cdoctypes IDOCTYPE ProductCatalog SYSTEM "catalog.dtd” </ doctypes
9 <root_nodes
10 celement_node name="ProductCatalog"s
11 cattribute_node name="company'
12 coolumn names="COMPANY"
13 < attribute_nodes
14 <element_node name="Product" s
15 cattribute_node name="productNumber':
16 coolumn name="PARTHNUMEBER" />
1k < fattribute_nodes
18 cattribute_node name="category's
19 coolumn name="CLASSDESC" /=
20 < attribute_nodes
21 celement_node name="Hame':
22 «text_nodes
23 coolumn name="HNAME" />
24 </ tewt_nodes
25 < /element_nodes
26 celement_node name="Description':
27 «text_nodes
28 coolumn name="DESCRIPTION" /=
29 </ tewt_nodes
0 < /element_nodes
31 <element_node name="Price":
iz cattribute_node name="currency':
33 coolumn name="CURRENCY"
34 < fattribute_nodes
35 cattribute_node name="unitMeasure":
6 coolumn name="UNITDESC"
5] < attribute_nodes
38 <text_nodes: |
39 coolumn name="PRICE" /=
40 </ tewt_nodes
41 < /element_nodes
42 celement_node name="foailability's
43 «text_nodes
44 coolumn name="STATUSTEXT" /=
45 < tewt_nodes b
4 | 3
Design SourceJ
|
)

Figure 63. Source view of the DAD file

__ 3. Verify that you have a <XCollection> element. This element indicates that
this is a DAD file for an XML Collection.

In line 6, there is an <SQL_stmt> element. This element identifies the SQL
guery that will be executed to extract information from your database that is
used to populate the XML document generated via this DAD file.

This SQL query has been provided for you. It extracts the list of parts from
a parts table and does a join to resolve identifiers for unit of measure, part
status, and part classification to human readable terms.

4. Using the Editor’s search/replace function or any method to advance on
this line, change the references for your group number in the SQL query.
Four tables are used: PARTS, UNITS, STATUS, and CLASSES. All of them
reside in the same schema. Change to use the correct schema name for all
of them.

« <doctype>: Identifies the DTD associated with the XML document.

« <root_node>: Defines the root of the XML document that will be
generated.
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* <element node>: The first one defines the outermost element in the
target XML document. It is named ProductCatalog.

« <attribute_node>: The initial element defines an attribute for
ProductCatalog named company. The <column> element associated
with <attribute_node> indicates that the value for this attribute comes

from the COMPANY column of the result set generated by the SQL
query statement.

The remaining <element_node> and <attribute_node> items define the
remaining elements and attributes in our XML document.

5. There are many elements, attributes, and columns in this DAD file. Click

the Design tab at the bottom of the pane to change to the Design view of
the Editor (Figure 64).

- ¥ ¥ML - Application Developer
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File Edit Perspective Project ®ML  ‘Window Help
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[=-{a$ XML Lak for Group 1

{2 Additional

= Collections
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2-Compose-CatalogXhL-SALDAD =g
catalog. i
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clac ot

D] partslist ctd

R

Figure 64. Design view (collapsed) of the DAD file

___ 6. Click the Expand All button at the top of the Editor pane (Figure 65) to
expand all elements and attributes of your file. This button is available only
if you are working in the Editor pane.

=
7|6 @ = | FE

ci Expand &l
[=l-4er column

Figure 65. Using the Expand All button

Now you can see all statements as shown in Figure 66.
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2= wml wersion="1.0"

|»

i [gF DOCTYRE DAD SYSTEM "dad chd"
[=-4e» DAD

4@y walication MO

[=-4e» Hollection

ed@r SO _stmt SELECT COMPANY  CLASSDESC, PARTMUME
4er prolog Puml version="1.0"?

48 dloctype IDOCTYPE ProductCatslog SYSTEM "catalog o
[=l-<e> root_node

[=-<e¥ element_niode

;....43) name ProductCatalog
[E-<er attribute_node
i bedar [ETIEE COMmpany
[=]-4e» calumn
i Le4@d MAME COMPARNY
[=l-<es element_node
L@ mEme Procuct

=-<e» attribute_nade
4@y Mame productiumber

[=l-<e column
: 483 nEme PARTHUMEER
[]-4e» sttribute_node |
[ hed@d name category
[=l-¢e> column
: 48 MEme CLASSDESC
[=-<e» element_node
[ hed@d name Matme

[El-<es text_node

[=-<e» column
: Led@) MEAME NAME
[=-<e» element_node

o Description
[=l-<es text_node
[=]-<e3 caolumn
L 48) MEme DESCRIPTICHN b
DesignJSource
g

Figure 66. Design view (expanded) of the DAD file

7. To read the DAD file, locate the <Attribute_node> that has an attribute of
name equal to productNumber. This is the attribute of the Product
element.

Review other elements and their attributes.

9. When you finish reviewing the components of this DAD file, close it.

This task is now completed.

Task 4: Transferring the files before composition

——You must verify...
... that you have replaced the name of the schema.
You need to use the schema name for your group. Step 6 in Task 3 is where

you replaced the name for your schema in the SQL statement to select the
record to build the XML file.
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Your iSeries server needs to have the DTD and DAD files in the IFS before you
can do any composition from your database table. In this task, you transfer these
files:

1. Onthe Navigator pane, expand the Collections folder. Click the
catalog.dtd file. Then hold down the Shift key and click the catalogsql.dad
file to select the files as a group (Figure 67).

= Pl 1 it
== ¥ML Lab for Group 1

-5 Addtional

E‘Ep Collections
----- é_uj 1-Decompose-PartsLiztXML-RDBDAD =gl
----- é_uj 2-Compose-CatalogEML-SQLDAD =gl

..... o)

----- [0] partslist ctel
----- [{] partsiist xml

----- partslistrdb cdac
#-{= Columnz

..... £0) Cleanup-tables sol
..... E@ Setup-tables =gl

2 tems selected

Figure 67. Selecting the files to export to the IFS
___ 2. Use the Export function to send these files to the IFS.

This task is now completed.

Task 5: Composing XML documents using the SQL Mapping DAD file

The Composition process is run under the control of DB2 UDB XML Extender. It
uses the dxxGenXML() function to compose an XML document. The XML
document is created inside the QSYS.LIB.

This XML file needs to be transferred to a PC-like file system to be used by a
Web browser or PC-like software with attributes to process XML files.

Follow these instructions to compose an XML document from an existing
database table:

___ 1. On the Navigator pane, open the 2-Compose-CatalogXML-SQLDAD.sql
file using the System Editor. Remember that this option invokes the Run
SQL Script function of iSeries Navigator.

2. Replace all references for the schema name and the IFS folder to your
group number. Take the time to verify that you replace the correct values. If
you prefer, use the Replace function provided in the Run SQL Script
support. A copy of the script using group01 is shown in Figure 68.
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i G4 PROGRA~1YIBMY APPLIC~ 1 WORKSP~ 1 XMLLAB~1" COLLEC~ o ] [
File Edit ¥ew Run YisualExplain Monitor Options Connection Help

= | & By by | b
b
Examples Run Selected = Insert |

I --- This script will use the SQL DAD file to compose the catalog XML file -- ™7,

= --- Verify if the DB name needs to be changed | =
i* --- Do not forget to change group number -
= --- First, clean the results table -

delete from group01.results;

I* --- Mext, generate the XML and put it into the results tahle -
call decsamples.geny (400WS", YITSOLahimiigroup0icatalogsgl.dad’, 'group0l results’, resalt_xml’, ™;

I* --- Mo the file has to be extracted fram the resuits takle and
-~ putinto the IFS as an XML file -
select db2xml Contentiresult_xml, ITSOLabixmifaroup0lfcatalog xmly from graupdi . results;

* - Copy the file to get it to the right CCEID -
call deesamples.chgeosid (819, MTSOLabMUgroup01/catalog.xml;

Messages I

Figure 68. Script to Compose an XML document

___ 3. This script is prepared in a different way. Take note because you need to
run it statement by statement.

4. The first executable statement is a delete statement. Regardless of
whether you are running this lab for the first time, make sure you perform
this step. Position the cursor in the line where the delete statement is (any
position) and click the Run Selected icon as shown in Figure 69.

PPLIC~1WORKSP~1XMLLAB~1"COLL

YisualExplain  Monitor Qptions  Connection  Help

AR PO MK @
?
Run Selected

the SGL DAD file to compose the catalag XML file =7
g needs to be changed =F

Ange group number =

Figure 69. Running selected statements

___ 5. The next statement is a call statement. A call to a program is already
supplied for you — dxxsamples.genx. This program uses the dxxGenXML()
function to compose the XML document. The output table name is
RESULTS. Click the Run Selected icon to run this statement to generate
the RESULTS table in the OS/400 file system.

Your file is ready to be transferred to your IFS folder using a program
supplied by UDB DB2 XML Extender.
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6. The next statement is a call to the program Content. The purpose of this
program is to extract the information from the database table and write this
information as an XML file in the IFS. Click the Run Selected icon to run
this statement to generate XML file.

7. You have stored the file in the IFS. You must make this file readable for PC
software before it can be viewed. Click the Run Selected icon to execute
the last statement to change the CCSID to the XML file.

8. Close the Run SQL Script.

This task is now completed.

Task 6: Viewing the XML file

Your XML document is now ready. Using Microsoft Internet Explorer Web
browser, you can see the file directly from the IFS because a drive is mapped:

__ 1. From the Windows desktop, click Start-> Run....

___ 2. Type the name of the Explorer executable file in the Open field, which is
i expl ore. exe in our example (Figure 70). The extension is not necessary
but, your PC may have a bat file. A bat file is selected first. When you write
the extension exe, you are executing exactly the Explorer Web browser.
Note the name of the .exe file.

Type the name of a program, Folder, document, or
Internet resource, and Windows will open it for wou,

Open: I iexplore.exe| j

o4 I Zancel | Browse, .. |

Figure 70. Running Internet Explorer

3. Click the OK button.

4. When the browser is loaded, open your XML file from the IFS. To do this,
write the address for the file: i : \ xm \ gr oup0O1\ cat al og. xnt in the Address
field of your browser (Figure 71).

/3 IBM Intranet - Microsoft Internet Explorer

J File Edit ‘iew Favorites Tools Help

- = - PDRAREI DS

J Links &]IBM Business Transformation @] 16M Internal Help &7 1BM Standard ;

Address I it\emllgroupil e atalog, =mi|

VS

Figure 71. Opening the XML file from the IFS

___ 5. Yourfile is loaded and the browser uses its own viewer to format the output
(Figure 72).
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wml'.group01*,catalog.xml - Microsoft Internet Explorer

J File Edit \Wiew Favorites Tools Help

|&-=»-DEA DI DS

J Links #&]1BM Business Transformation & ]16M Internal Help  &71BM Standard Software Installer

J Address I Liixmliygroup0licatalog, xml

<7xml wersion="1.0" 7>
<IDOCTYPE ProductCatalog (Wew Source for full doctype... )»
- <ProductCatalog company="1"»
- <Product producthumber="PNO0000000" category="Tools">
zMame=Hammer</HNamea:>
<Description=High durability standard hammer.</Descriptions
=Price currency="USD" unitMeasure="each"=10.99</Price:
<Availability=>In Stock</Availability=
=/Products
- «<Product producthumber="PNOD000001" category="Tools">
=Mame=Tape Measure</Hame:>
<Description=Measures up to 25 feet. Measures Metric and English units.</Descriptions
<Price currency="USD" unitMeasure="each">14.99</Price=
<Availability=In Stock</Availability=
=/Products
- <Product productMumber="PNOOD0O0ODD2" category="Fasteners":=
<Mamex=Hex Cap Screw</Mame:>
=Description=1/4in. dia. Hex Cap screw. 50 per box.</Description>
<Price currency="USD" unitMeasure="box">5.00</Prices
=aAvailability=In Stock</availability=
</Product=
- =Product productMumber="PNOD00D0DD3" category="Fasteners":>
<Mame=8heet Metal Scr</Mamez
zDescription=1/4in. dia. sheet metal screw. 50 per box.</Description:>
<Price currency="USD" unitMeasure="box">5.00</Pricex
<Availability=Back Order</svailability>
=/Products
- <Product producthumber="PNO0000004" category="Fasteners"=
=Mame=Elevator Bolt</Mame:>
<Description=1/2. in. dia. Elevator bolt. 10 per box.</Descriptions
=Price currency="USD" unitMeasure="box">10.00=/Price:>
<Availability=In Stock</Availability=

|@ Done I_I_ E Local inkrar

Figure 72. Web browser display

You have now completed this lab.
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Lab 5. Additional exercises to work with XML documents

This lab contains additional exercises to show you some of the more advanced
features of the DB2 UDB XML Extender product. Each task is independent of the
other. You may choose to work with the ones that apply more to your business.

Objectives
This lab uses some of the functions of the DB2 UDB XML Extender product. They
have been used to create some programs that will use some of the SQL Scripts
provided for you.
To achieve these objectives, you will:
» Learn to update individual elements or attribute values in an XML Column

« Use SQL in a more efficient way to deal with the data to compose an XML
document

» Use the DTD reference table maintained by DB2 UDB XML Extender

* Learn how to use a DAD file to compose and decompose an XML document

Lab prerequisites

This lab builds on the results of Lab 4, “Composing XML documents from existing
data” on page 57. You must complete Lab 4 before you start this one.

Time required
The time required to efficiently complete this lab is 40 minutes.

Required information for working with the lab
The same requirements from the previous lab are valid here:
¢ You must assign drive “I” to the ITSOLab folder in the IFS.

* You must have the name of your server and be prepared to supply this
information when prompted.

* You are working with SQL scripts and some of them have many statements.
Examine each statement and execute them one-by-one using the Run
Selected icon in the Run SQL Script support of iSeries Navigator.

Task 1: Updating elements or data attributes in an XML Column

In this task, you learn how to use the DB2 UDB XML Extender function to update
individual elements or attribute values associated with data in an XML Column.
Instead of replacing the entire XML document to update a particular element
value, DB2 UDB XML Extender allows updating of individual items in the
document.

In addition, the updates to the XML Column items that are mapped to a side table
will cause the corresponding side table rows to also update.

To prepare your workbench, follow these steps:
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Start WebSphere Studio Application Developer from the Windows desktop
if it is not already open. Click Start-> Programs-> IBM WebSphere Studio
Application Developer-> IBM WebSphere Studio Application
Developer.

Expand the Additional folder.

Locate the Update-XML-Column.sql file and open it using the System
Editor. The Run SQL Script window opens.

This script shows you some records before and after the update. You have
to change the properties for this SQL session to open a new window each
time a select statement is executed. Click Options-> Display Results in
Separate Window as shown in Figure 73.

=of

i —

el

Examp

| ¢ BEREE FEEH G ( vStponEror

¥ Smart Statement Selection

Di 1sUlts in Se o o

Include Debug Messages in Joh Lag

les I_

- Lp
- Th
- Do

*-- Th
select

i*--Th

i*--Th

The call to db2uml Update is what performs the change in both the XML document and the side table.

Three parameters are passed to dbZxml Update - The column where the update is being perfarmed,

the path to the element or attribute heing updated and the new value for the element or attribute.

Mote that ifthe walue heing changed is also stored in a side takle then the new value must fit the

format far that column in the side table. -
update groupardersim| setxmil_doc = dbZeml Updatedsmi_doe,
‘iPurchaseOrde<MUHeaderOrderinfol@date’, 1970-01-01) where dixroot_id in (select daoroot_id fram i
groupsdorders where ardetype="cancel?};

E Insert |
q
* A

date information stared in XML documents oy ctatement on Double-Click - A
is update will change the ardedime caolumn - = -5
not forget to change your group number, Change Query Attributes. . %
is first select will show the initial table. -

*from groupecorders where ordertype="tancel’,

is next staterment performs the update:

iz final selectwill show that the values in the ordedime column have been changed. -, ;|

Figure 73. Changing the options for this session

5.

In the script file, change the references for your group number before any
statement is executed.

You can run this script with the Run All icon, but this time click the Run
Selected icon to execute statement by statement to make it easier to see
what is happening.

The first statement is a select statement. See Figure 73. After you run this
statement, you can see the orders. Move the horizontal bar to read the
values of column ORDERTIME as shown in Figure 74.

%51 select * from groupxx.orders where order I ] |
IDEMTITY ORDERID ORDERTIME ORDERTYPE TOTAL
Cnooooo2  jOMNB8323231 2001-10-05 cancel

Crooooo OMT 4334458 2001-10-06 | |cancel

4

Figure 74. Selecting records before the update
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___ 8. Run the next statement — update. It uses the DB2 UDB XML Extender
function db2xml.Update to change the data attribute of an order to a new
value. This statement sets the ordertime column for all cancelled orders to
1970-01-01.

9. Continue and run next statement. This select statement displays the same
rows that are in the window for the first select statement. But this time,
ordertime is updated with a new date (Figure 75).

iZ select * from groupxx.orders where urderty@f:' -0l =l
IDEMTITY ORDERID ORDERTIME ORDERTYFE TOTAL
CMOooooo2  JONBE323281 1970-01-01 cancel

CHoonoo OM74334458 1970-01-01 cancel

B by

Figure 75. Selecting records after the update

___10.Note that these queries are performed against the side table and
demonstrate that side tables values are updated as corresponding XML
Column updates are made. The updates are done by SQL triggers
provided by the product. Switch between these two windows with the
records selected to see the updated column.

__11.Save your SQL script and close the session.
Now, you are going to try a more complex update to your XML document stored in
the database table. You need to change two attributes:

* Quantity ordered for an item

* The total amount for the order
Use the Run Selected icon in the Run SQL Script to run statement-by-statement
in this script:

1. Locate the Update-XML-Column-2.sql file and open it using the System
Editor (Figure 76).
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File Edit Yiew Run “isualExplain  Monitor

51 CHPROGRA~ 1N IBM' APPLIC~1 " WORKSP~1" XMLLAB~1" ADDITL

Options  Connection  Help

=2

& |+ ORTPTTOS MM I

Examples

;l Inser |

-~ Update infarmation stored in =ML documents that have already heen inserted into an XML colurnn -, =]
Do not forget to change your group number!

/- Thiz update will change the order from customer CHNO00003, order number ONBE3IZE384.
The guantity of tape measures arderad will be changed frarm 25 to 50 and the totalmoney value in
the result set and in the xml file will be changed as well.
Update groupssordersml
set ¥xml_doc = db2uml Updatexml_doc,

TPurchase0rdersMLMtermListitem{@patnum="FMO0000001")Quantity’, 507

where dixroot_id in (select dxroot_id from groumeorders where orderid="0MNB33283847;

update groupcordersml
setxmi_doc = dbhzxml Updateanl_dac,
TPurchasedrderMLUHeader/Orderinfo/TotalMoney', '859.407%

A

-

where dixroot_id in {select dwxraot_id from groupesorders where arderid="0n28328384"%;

- Wirite the file autto ATSOLabf=MUgroumeUpdated Crder.xml
select dbhZxml Contentixmi_doc, TTSOLahiMLU groumedUpdatedOrder xml?)

Figure 76. Copy of the Update-XML-Column-2.sq! file

___ 2. Examine the first two SQL statements, which are updates to your XML

Column.

Run the first update to change order ON88328384. For part number

PNO00000001, the quantity is changed to 50.

Run the next update. The second update changes the amount for the same
order. The TotalMoney column is changed to 859.50.

You already changed the XML document. Run the next statement that is
using the Content() function to extract the document from the DB2 UDB
XML Extender database and placing it in the IFS. Examine the where
clause. The statement selects the order ON88328384 and the
corresponding information from the side table.

After the XML is placed in the IFS, the next statement changes the
character code of the file to 819, using the program chgccsid. Run this
statement. You need to convert this file before you can view it on the PC.

To demonstrate that the update operation was done in the side table, the
next select statement displays the order information. Run this statement

(Figure 77).

IDEMTITY

ORDERID

ORDERTIME

ORDERTYPE

TOTALMOMNEY

FOFOF1

CNOooo00z

OMER328384

2001-10-04

ey

259.50

Kl

I»]

Messages | select * from groupscorders where orderid='"0MNE8325384'

Figure 77. Order selected from the side table
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__ 8. Doyou want to see the order with a browser? Open your browser. Be sure
you have a version that supports XML. Open the UpdatedOrder.xml file as
shown in Figure 78.

x|

E nter the YW arld Wwide web location (URL) ar zpecify the lozal file you would
like to opern:

e pdatedOrder. «ml Choosze File... |

Dpen location or file in: " Composer

(= Hiavigaior Open I Cancel | Help |

Figure 78. Opening the UpdatedOrder.xml file with a browser

___ 9. Make sure that the changes to the document were made. When you finish
reviewing this file, save your SQL script and close your session.

This task is now completed.

Task 2: Using SQL overrides during XML Composition

SQL overrides provide a more dynamic mechanism to control the set of data used
to compose an XML document from an XML Collection. A DAD file is based on
SQL Mapping and contains a fixed SQL statement that is used to extract data for
XML document composition. An SQL override allows the SQL statement to be
customized without having to update the DAD file for each query variation.

In this task, you use SQL overrides to create a number of separate products
catalogs based on different class of product items offered by our lawn and garden
center. First, you generate a catalog for tools parts:

1. Locate the Override-SQL.sql file and open it using the System Editor.
Click the Run Selected icon to run statement-by-statement when you are
instructed (Figure 79).

2. Run the first executable statement. This is a delete statement. If you
already deleted the RESULTS table, ignore the error displayed at the
bottom pane.

3. To generate the XML document, you call program genx. This program
invokes the dxxGenXML() store procedure.

In this program, the fifth parameter instructs to DB2 UDB XML Extender to
use the override capability. The SQL to execute is coded in the following
parameter. This provides the query to override the SQL query found in the
DAD file.

You need to run this statement.
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i O PROGRA~14JBM APPLIC~1 WORKSP~1'XMLLAB~1" ADE i ]
File Edit Yiew Run ¥isualExplain Monitor Options Connection Help

&S =200 FTTO0 MMP

Examples | R Insert |
__*I. E

I*-- This scriptwill uze the SQAL DAD file to compase the toals-catalog XkL file

"~ ltwill use an override SGL statement -
- Yerify the name ofthe relational database for this semer -
*-- Do not forget to change the group number. -
*-- First, clean the results tahle -

delete from groupsresults;

- Mewt, generate the =ML and put it into the results tahle
notice the -0 SQL_COVERRIDE parameter has been added, as well as the new SGL Staternent

this 3oL staternent will only select the parts that are inthe Tools class -*
call dsamples.geny CA00WS', MTSOLabi<mMUgroupedcatalogsgldad, ‘groumeresalts’, resali_xml'’, ", -0,
1 OVERRIDER

'"SELECT COMF‘AIT.’, CLASSDESC, PARTHUMBER, MAME, DESCRIFTION, CURREMCY, UNITDESC,
PRICE, STATUSTEXT FROM groupx PARTS, aroup:.c UNITS, groupe STATUS, groupx CLASSES WHERE
UMITMEASUREID=UNITREF AND STATUSID=STATUSREF AND CLASSID=CLASSREF

AMD CLASSID=1

ORDER BY COMPANY, CLASSDESC, PARTMNUMBER'); _v|

Figure 79. Overriding the SQL statement in the DAD file to generate XML file

4. The XML file has been generated. Import this file from the DB2 UDB XML
Extender executing the next select statement. Here, you use the Content()
function to place the XML file in the IFS.

5. The final statement changes the CCSID code to 819. This is mandatory
before you can view the file with your browser.

6. With your browser, open the tools-catalog.xml file.

Save your script file.

— Optional

You already generated the catalog for tools parts. If you want to try to generate
other catalogs for fasteners, lawn and garden, and electrical items, follow these
instructions. If you do not want to run these steps, skip to Task 3, "Validating
composed XML documents using a DTD” on page 73.

___1. To generate a catalog for fasteners parts, select only the records with a
class ID equal to 2. Change the SQL to execute parameter to select only
fasteners as shown in Figure 80.
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= c:'-.,PRnGRA-x-1'-.,IBM'-.,APPLIc-x-1'-.,wunxsp-x-1'-.,xMLLAB-x-l'-.,AD'j o ]
File Edit Yiew Run “isualExplain Monitor Options Connection  Help

& |+ ORTPTTOS MM I

Examples | = Insert |

- Thiz scriptwill use the SaL DAD file to compose the tools-catalog =ML file R
/- Itwill use an override SQL statement -
- Werify the name ofthe relational database far this sener -*
/- Do not forget to change the group number. -
/-~ First, clean the results tahle -

delete from groupsresults,

- Mext, generate the XML and put it into the results tahle

natice the -0 SCQL_OWERRIDE parameter has been added, as well as the new SQL Staterment

this 8QL staterment will only selectthe parts that are in the Tools class -
call dsamples. genx (14000WE", MITSOLabfMUnroupedcatalonsgl.dad’, ‘groupecresults’, result_xml’, ", -0’
'B5CL_OVERRIDE',
'SELECT COMPANY, CLASSDESC, PARTHUMBER, MAME, DESCRIFTION, CURREMNCY, UNITDESC,

PRICE, STATUSTERT FROM groupma PARTS, grouma LUMITS, aroupa STATUS, groupex CLASSES WHERE

Figure 80. CLASSID column to select part type

___ 2. Locate the two references to tools-catalog.xml and change to
fastener-catalog.xml so that a separate XML document is generated to
contain the fasteners.

Execute the SQL script to generate the fastener-catalog.xml file.

Open the generated fastener-catalog.xml file with your browser to verify
the work you do.

Save this SQL script file with a meaningful name, if you want.

Change CLASSID to a value of 3 for lawn and garden parts. Repeat steps 2
through 5 and use a different XML file name.

7. After you verify that you created the new catalog, change CLASSID to a
value of 4 for electrical items and again. Repeat steps 2 through 5.

8. Close the SQL session.

This task is now completed.

Task 3: Validating composed XML documents using a DTD

DB2 UDB XML Extender also supports registration of DTDs that may be used to
validate XML data during composition, decomposition, and insertion into an XML
Column. In this task, you store a DTD in the DTD reference table maintained by
DB2 UDB XML Extender. You use this DTD during composition to generate a

valid XML document using the SQL mapping technique provided by the DAD file.

Follow these instructions:

__ 1. Locate the Insert-DTD.sql file and open it using the System Editor. The file
is shown in Figure 81.
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75 CYPROGRA~1YIBMYAPPLIC~1" WORKSP~1\ XMLLAB~1", ADDITI: B ]|
File Edit View Run WisualExplain Manitor Options Connection Help

S| RE FFDO 6| hh @

Examples | ;l Inser |

-~ Insers the catalog DTD into the DTD reference tahle. -
- Thiz allows the composition functions to validate the XML file thatis being composed. -,
IS0 not forget to chane the aroup numhber -

I

insert into dh2xml.dtd_refvaluesMTSOLabxMUgroumaedcatalog. did’,
dbzxml=MLCIabFramFiledITSOLabi=MLU groumadcatalog. did?,
0, 'groupsd, ‘groumed, aroupd;

Figure 81. View of the Insert-DTD.sql file

___ 2. Examine the SQL script. This script inserts our catalog DTD into the DTD
reference table. A table is used by DB2 UDB XML Extender for registration
of DTDs that are referenced during XML document processing.

3. Change the references to your group number. Remember that other
students will be adding their DTD reference row to the same dtd_ref table.

4. Run the SQL script. After this operation, the DB2 UDB XML Extender is
updated with an entry for your DTD.

You are ready to change the DAD to reference the DTD that is already stored.
The DAD you use was used before in Lab 4, “Composing XML documents from
existing data” on page 57. You are prompted to open this file and save it with a
different name.

1. Expand the Collections folder and open the catalogsqgl.dad file using the
DAD Editor. Remember, you will save it later to another folder under
another name.

2. When the file is opened, click the Design tab at the bottom of the Editor
pane.

3. You need to turn on the validation. Locate the <validation> element and
set this value to YES to indicate that XML documents composed using this
DAD file should be validated against a given DTD.

4. You are adding a <dtdid> element as a child of the <DAD> element. To do
this, locate and right-click the <DAD> element and select Add Child->
dtdid as shown in Figure 82.

vergion="1.0"
DAD SYSTEM "dad ctd”

ey val Remave MO
Dl<er Hol fdd Atbribute. P |

R Add Chid D m OMP&RY , CLASSDESC, PART
i.4gy  AddEefore jon="1.0"7

3
: ey Comment

e[GO E ProductCatalog SYSTEM "cat
<& rot_node 2% Processing Instruction

<& element_node

Figure 82. Adding the dtdid element
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__ 5. Specify the value of this new element as

/1 TSCLab/ XM/ gr oupxx/ cat al og. dt d. Do not forget to change your group
number. See Figure 83.

- ¥ ¥ML - Application Developer i [l 3
File Edit Perspective Project ®ML  ‘Window Help

B HES RSB Y OAN[HE

ﬁ » < b 4 |
e oad=d i wersion="1.0"
iy - [# DocTvPE DAD SYSTEM "dad i’
&g S48y DAD {citclic?, validation, (Xcolumn | ¥oalle
i e R 70 shHMLigroupocdcatalog dtd
4 walidation e}
) e ¥eollection [#-<e> Xecollection (SQL_stmt*, prolog, doctype, roct_T
,% <e» SQL_stmt
= <& prolog
e doctype
--<e> root_node
?g_; Mavigatar e B e R e,

20] Compoze-Yalidate-SGLl -
20| Inzert-DTD.sgl

20 Owerride-SGL =gl

20| RDB-Compose.zgl

20| Update-XhL-Column gl

20| Update-XhL-Column-2 .2
E-{= Collections

é_ﬂ 1-Decompose-Partslist!
é_ﬂ 2-Compose-Catalog=ML
@ catalog dtd
m catalog.xml
catalogsgl.dad
[0 dad.dtd

[0 partslist ot
m partslist xml

b partslistrob cad =
4 | | 4 Design]Source

Figure 83. Reference to the DTD file

This entry identifies the DAD file that will be used to validate documents
during composition.

6. Click File-> Save catalogsql.dad As... to save this file with a different
name in a different folder.

7. In the Save As dialog (Figure 84), change the file name to
cat al ogsgl val i d. dad in the File name field. Do not press Enter!

8. Click the Additional folder icon and note that the folder name changes too.

__ 9. Verify your changes with the display shown in Figure 84. You may find a
difference only with the name of your main folder. It is very important to
save the file in the Additional folder because you need to transfer the new
file to the IFS.
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x

Save File As...

Enter or select the folder:

I WML Lab for Group 1 /Additional

B e -

Tl TS0 Lab

-1 ¥ML Lak for Group 1
(5 Addtional

{= Collections
#-= Columnz

File narme: I catalogsqlvalidldad

Ok | Cancel

Figure 84. Saving the new file in a different folder with a different name

__10.Click OK.

__11.Close the Editor session for this file.

__12.Close the Collections folder.

__13.Click the catalogsqlvalid.dad file (in the Additional folder) and export it to
your group’s folder in the IFS.

Now you must generate the catalog. This time you are using a different name, so

do not replace the name from the previous lab.

1. Open the Additional folder and locate the
Compose-Validate-SQLDAD.sql file. Open this file with the System
Editor. The file is shown in Figure 85.

% C\PROGRA~1YIBM', APPLIC~1 WORKSP~ 14 XMLLAB~ 1} ADDITI~1 ]
File Edit Yiew BRun ¥isualExplain Monitor Qptions Connection  Help

M| 2nh FPRO 0| @

Examples | ;l Insert |

*-- Thig scriptwill use the SQL DAD file to compose the catalog XML file -
*-- Do not forget to change the group number, -
*—- First, clean the results table -

delete from groupme results;

*-- Mext, nenerate the XML and put it into the results tahle -
call xsamples.geny (400WwS" MTS0LakiMUigroupeedcatalogsgldad’, 'groumasresalts’, result_xml', M,

- Mow the file has to be exdracted from the results table and putinto the IFS as an XML file -*
select dh2xml . Content{result_xml, ITSOLabimMUigroupcatalogvalidated xml) from groupecresults;

*-- Copy the file to get it to the right CCSID -
call xsamples.chgoosid (‘819 'IITSOLahJ’KMLIgroupx}dcatalogvalidated.}{ml');:[

Figure 85. View of the Compose-Validate-SQLDAD.sq| file
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2. Change the references to your group number. You need to change the
name of your collection and the folder for your group, where you export the
new DAD file.

Save the file.

4. As you can see in the SQL script, this script creates an XML file named
catalogvalidated.xml from your database. Click the Run All icon to run the
script. At the end, there is a CCSID conversion, which gives you the ability
to view it with a browser.

5. Close this SQL session.

. Using Microsoft Internet Explorer, open the catalogvalidated.xml file from
the IFS. The file should look like the example in Figure 86.

XML groupxs’ catalogvalidated.xml - Microsoft Internet Explorer i |EI|1|

File Edit View Favorites Tools  Help ﬁ

-2 - DA QEB RS

Links & ]1BM Business Transformation & 16M Internal Help &7 16M Standard Software Installer

|
|
|
|

Address I L\ ¥MLigroupscxicatalogvalidated. xml j PG

- =ProductCatalog company="1">

| v

<7uml version="1.0" 7>
<!DOCTYPE ProductCatalog (Wew %or full doctype... )=

- =Product productMumber="PN0OD000D000" category="Tools">
<Mame>Hammer/MNamez
<Description=High durability standard hammer.</Description:
=Price currency="USD" unitMeasure="each">10.99</Price:>
<Availability>In Stock</Availability=
</Products
- =Product productMumber="PN0OD00D0D001" category="Tools">
<Mame>Tape Measure</MName>
=Description=Measures up to 25 feet. Measures Metric and English units.</Description:=
=Price currency="USD" unitMeasure="each">14.99</Price:>
<Availability>In Stock</Availability=
</Products
- =Product productMumber="PNO00000D2" category="Fasteners">
<Mame>Hex Cap Screw</Mame:>
=Description=1/4 in. dia. Hex Cap screw. 50 per box.</Description:
=Price currency="USD" unitMeasure="box">5.00</Price:>
<Availability>In Stock</Availability=
</Products
- =Product productMumber="PNO00000D3" category="Fasteners">
<Mame=Sheet Metal Scr</Mameaz
=Description=1/4 in. dia. sheet metal screw. 50 per box.</Description>
=Price currency="USD" unitMeasure="box">5.00</Price:>
<Availability>Back Order</Availability>
</Products
- =Product productMumber="PNO00000D4" category="Fasteners">
<Mame=Elevator Bolt</Mameaz
=Description=1/2. in. dia. Elevator bolt. 10 per box.</Description:=
<Price currency="USD" unitMeasure="box">10.00</Price:=
<Availability>In Stock</Availability= x|

|@ Daone ’_’_ (2 Local intranet i

Figure 86. View of the catalogvalidated.xml file

___ 7. Notice that it contains a DOCTYPE reference. Using the menu bar of

Microsoft Internet Explorer, select the View-> Source. The first part of the
view is shown in Figure 87.
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ﬂ catalogvalidated.xml - Notepad
File Edit Format Help

<7xm] wersion="1.0"7»

<!DOCTYPE Productcatalog SyYSTEM W o

<ProductCatalog company="
<Product productiumber=" PNOOOOOOOO category="Tools">

<MWamez=Hammer </Mamex
<bescriptionsHigh durability standard hammer. </ /Description:
<Price currency="Usp" unitMeasure="each"> 10.99%</Price>
<Availability>In stock< availabilitys

</Product >

<Product productiumber="PN0O0000001" category="Tools"x

Figure 87. Part of the source code for the catalogvalidated.xml file

___ 8. Here, you can read that DOCTYPE makes a reference to the catalog.dtd
file used during validation.
__ 9. Close the window with the view of the source code.

___10.Close Microsoft Internet Explorer session (optional).

This task is now completed.

Task 4: Using the RDB node DAD file for document composition
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In this task, you use the same RDB node DAD file created in the XML
composition exercise (Lab 4, “Composing XML documents from existing data” on
page 57) to compose an XML document based on the same set of elements and
attributes used in the database schema mapping rules.

This task demonstrates the use of the RDB node mapping technique for
bi-directional exchange of data between XML and relational data formats. Refer
to Task 4, "Reviewing the associated DAD file” on page 51, in Lab 3, for
information.

You use the same DAD file to compose an XML document. This demonstrates
that the RDB mapping technique can be used for both XML document
composition and decomposition.

___ 1. Open the Additional folder and locate the RDB-Compose.sql file. Open
this file using the System Editor.

2. Examine this script. It uses a DAD file with the RDB mapping technique to
compose an XML document from our existing catalog data.

3. Locate the string FULL PATH TO THE DAD FILE and replace it with the full
path to the RDB mapping DAD file you created in Lab 3, “Decomposing
XML data using an XML Collection” on page 43,
/ITSOLab/XML/groupxx/partslistrdb.dad.

4. Locate the string OUTPUT FILE NAME (two occurrences). Change each
occurrence to the file to be generated during XML document composition.
We recommend a name such as /ITSOLab/XML/groupxx/rdbxml.xml. If
you decide to create the file with another name, write it down because you
need to open this file later.

5. Verify your changes as shown in the example in Figure 88.
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\PROGRA~141BM' APPLIC~ 1\ WORKSP~1' XMLLAB~ 1 ADDITI
Edit ¥iew Run VisualExplain Monitor Options Connection Help

e s+ nBR FTTO6 MM I

Examples | = Insett |
-E

- Update this script to use the RDB DAD file to compose the catalog XML file.

=10l x|

- Yerify the name of the relational database for your system. -
i*-- Do not forget to change yaur graup number. -
*-- First, clean the results tahle i

delete from groumesresults;

*-- Mext, generate the XML and put it into the results tahle -
call deesamples.geny (1400WS" ATSOLab<MUgroumespanslistrdb.dad’, ‘groupsecresalts|, resal_sml', %;

- Mow the file has to be extracted from the results table and putinto the IFS as an XML file =%

select dhZwml Content{result_xml, MITSOLabi<MUgroupd TS OLabi<mUigroupsrdbeml xml frorm
groumeresults;

*-- Copy the file to get it to the right CCSID -
call desamples.choeesid (8197 'IITSOLabD{MUgmuerdbxml.}{mljﬂ

Figure 88. Composing an XML file using RDB technique

Before you run this script, review Figure 88 to see what it is happening. It
removes the output from previous labs. It generates the XML document
into the DB2 UDB XML Extender repository. It extracts the generated file
and places it into the IFS. And it changes the file to use the right CCSID.

Save your file.

__ 6.

___ 7. Click the Run All icon to run the script and generate your XML document.
___ 8. Close this SQL session.
_ 9

Verify your work, opening this file from the IFS, using a browser.

This task is now completed.

Task 5: Cleaning the server of objects and files created during lab

— If you plan...

... to make a backup of the work you have done, do it now. Ask your instructor
or system administrator about the resources you can use to make a backup of
your library and the folder you created.

Some objects were created in the iSeries server and some were created in your
PC. Your iSeries has many database objects related to your lab:

* Your schema

» Tables created using SQL scripts

 Triggers created by DB2 UDB XML Extender

Your iSeries server also holds many tables related to XML integration:

*» DTDs
* DADs
« XML
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In your PC, some directories and objects managed by WebSphere Application
Developer are created.

In this task, you clean the server using an SQL script and iSeries Navigator. You
clean the PC using WebSphere Application Developer tools.
First, clean the iSeries server of database objects:

1. Go to the Navigator pane and open the Cleanup-tables.sql file using the
System Editor.

2. When the Run SQL Script window appears, change all references to your
group number for the schema and verify that the relational database
corresponds to the database of your system.

3. You can read some notes about the process that this script runs. Note that
if you receive an error in a sentence, you can continue using the Run
Selected icon, sentence by sentence.

4. The first SQL statement is a call to a function of DB2 UDB XML Extender.
The program named in the call statement invokes this function and
disables the column you enabled in Lab 5, “Enabling an XML Column” on
page 34, in Lab 5.

5. The second set of statements is a drop of database objects. At the
beginning, it drops all tables created in Task 2, "Creating your schema and
database tables” on page 23. Then, the schema is dropped from the
system.

___ 6. Close the Run SQL Script window. Save the file (optional).
You have now cleaned the database objects from the server. Next you need to
clean the IFS removing your folder:

1. IniSeries Navigator, click File Systems-> IFS-> Root-> ITSOLab to open
the main folder for labs.

__ 2. Click XML-> group01, right-click and select Delete as shown in Figure 89.
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@ iSeries Navigator __ =]

File Edit Wiew Help

El&alx@l@@ 44 mirutes old
| E nvironment: My Connections | 1400ws: File Shares iSeries MetServer ORCHASMZ27
-- Security :I Mame | Path | Description
™ Users and Groups A Carlos fhomejcarlos Directorio para el perfil de
E Databases Atsclab JIT30Lab IMain directory for XML lab
-5, File Systems D0dirsry JQIEM ProdData/OS400/DirSry 5400 - Directary Servic
=-{& Integrated File System Ligbm JQIEM IBM Product Directoriss
=-{55 Root
-2 bin
-] dev
-2 ete
-2 home
el ITSOLab
= %ML
= 2
B Q QIEM Explore
- D SR Cpen
-2 QTCPTMM Create Shorkcut
B2 tmp Customize this Yiew P
B2 ust Include. ..
- {23 Qopensys
[J"'l% QoLs Mew Folder. ..
B-{E5 QSYS.LIB M | ]
B 4dd a connection Cut d tasks
@ Install additional companents Copy ;I
Haste
Deletes the selected item, B 5

Figure 89. Deleting a folder

__ 3. Adialog (Figure 90) opens asking you to confirm whether you want to
delete your folder. Click Yes to respond to this question.

« i9eries Navigator

@ Are you sure vou want ko delete group0l and its contents?

Yes Mo |

Figure 90. Dialog to confirm the folder deletion
___ 4. After the folder is deleted, close iSeries Navigator.

You have cleaned the IFS. And now, it is time to clean your PC:

__ 1. Inthe Navigator pane, select the project folder, right-click, and select
Close Project as shown in Figure 91.

81



82

- ¥ XML - Application Developer

File Edit Perspective Projeck

Window  Help

.: Go Inkta
Ao Go To
Open Perspective

il = e e

*

4
3

Copy
Maree:
Rename

EEEEE

Delete

openFroject

Refresh From Local

Rebuild Project lg

% R on Server
Hestart Projeck
Run Yalidation
Team
Caompare With
Replace with

Flw x

Properties

L:_HB- Collections

b B 1-Decompose-

w0 catalog it

- [H] catalog xml
catalogzgl.dad
[0 dad dtd

[0 partslist dtel

- [H] partslist ml

F-{Z= Columnz
----- 20 Cleanup-tables ol
----- 20) Setup-tables gl

ol |

4] 2-Compoze-CatalogkL-3

partzlistrob dad

PartsListxhil

#ML Lab for Group 1

Figure 91. Closing the project

___ 2. Your project is closed. It is safe to copy this folder. Ask your instructor or
your support department for resources to do a backup of your folder.

___ 3. Delete the project. This option removes your folder and objects from inside
ture. Right-click your closed project and select Delete as

your PC file struc

shown in Figure 92.
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— = Mew Fl—
o Dutlinie Go Into

An outling iz not &vailable o b

Open Perspective Pk

Copy
Maovve
Rename

Open Project
C|gse Project
Hebuild Project
RefreshiFrom Lacal

% RumoniServer
Restart Fraject
Run Validation

Team [ 3
Compate With 3
Replace with 4
Properties

#hL Lab for Group 1

Figure 92. Deleting the project from your PC

___ 4. Adialog asking if you want to delete your folder appears. Click Yes as
shown in Figure 93.

elete Project Contents? x|

About to delete project =ML Lak for Grougp 1°
Delete all ts contents under C:Program FilesiBMApplication
Developeriworkspace WL Lab for Group 1 as well?

Yes Mo Cancel

Figure 93. Confirming to delete the project

You have now completed this task and the entire lab.
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