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Lab 1. iSeries Navigator setup

This lab explains how to set up iSeries Navigator.

Introduction

If you completed the Piloting DB2 UDB with iSeries Navigator in V5R2 lab, you do
not need to recreate the environment necessary to complete this lab. If this is the
case, you can proceed to Lab 2. Otherwise, you have to complete this lab to
create the necessary environment for these labs.

The notation XX that appears in library names, profile names, and so on refers to
your Team Number (for example, DBNAVXX, SAMPLEDBXX and LIBXX). Refer
to your lab worksheet for details.

Note

As part of iSeries Navigator in V5R2, the SQL Script Center uses JDBC instead
of an ODBC connection to the server. Connection parameters used by JDBC
are similar to those used by ODBC.

Objectives
This lab teaches you how to:

» Create a sample Database (SAMPLEDBXX)
« Display the Database using iSeries Navigator
» Display the contents of the sample database using iSeries Navigator

Lab prerequisites
Before you begin this lab, be sure the following prerequisites are available:

« An IBM @server iSeries or AS/400e server with OS/400 V5R2, or higher, with:

—5722-SS1 Option 12: Host Servers
—5722-TC1: TCP/IP Connectivity Utilities

* A PC with iSeries Access for Windows V5R2MO0 with the latest Service Pack
applied

« User profile DBNAVXX created in the iSeries server

Time required
The time required to efficiently complete this lab is 20 minutes.

Task 1: Getting connected

In this task, you create a connection definition from iSeries Navigator on your PC
to the iSeries server.

___1. If you have a connection to iSeries server using iSeries Navigator, go to
Task 2, "Creating a sample schema (database)” on page 3.

___ 2. Double-click the iSeries Navigator icon on your desktop. If this is your first
time running this application, a message box appears stating that there are
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no connections to the iSeries server. Click Yes. The Add iSeries
Connection dialog appears.

. In the iSeries server text box, enter 1 400W&. Click Next. The iSeries Signon

Information dialog appears as shown in Figure 1. Select the Use default
User ID, prompt as needed radio button. In the text box shown in Figure
1, enter DBNAVXX

Add Connection - Signon Information E3

What uzer 10 do you want to uee bo zign on to "sezess’?

© Use Windows user name and password, no prompling

|ITSEID4‘I

£+ Use default user 1D, prompt az needed

|DENAW:><

€ Prompt every time

< Back I Hewt » I Cancel

Signon ko iSeries ﬂﬂ

! Server: {14005

Figure 1. iSeries Signon Information

___ 4. Click Next. The Verify Connection dialog appears. Click the Verify

Connection button. Make sure that the host servers on the iSeries server
are up and running. Click OK and then click Finish.

. Right-click the My iSeries Connections object in the main iSeries

Navigator window. Select Add iSeries Connection. The Add iSeries
Connection - Welcome dialog appears.

. In the iSeries Navigator window, click the 1400WS connection. A window

prompts you to enter a username and password as shown in Figure 2.
Consult your iSeries lab worksheet for your profile name and password.
When you are finished, click OK. Because this is the first time you are
signing on to the iSeries server, the system has to update iSeries Navigator
with its capabilities.

User |0 |DENAYDT

Pasaward: I“““““““’i

ak. I Cancel

Figure 2. Signon to iSeries
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___ 7. Click the plus sign (+) in front of the Databases icon to expand it. Then
click the plus sign (+) in front of the Named Database icon (1400ws in this
case). The Libraries, Database Navigator, SQL Performance monitors, and
Transactions options appear in the expanded list as shown in Figure 3.

Note

You see a different name for the Named Database icon if you let the
system create it automatically.

£ iSeries Navigator =10l x|

File Edit Wiew Help

E%@@l%|%ﬁ|><|®o 1 mirtes old

| Environment: My Connections | 1400wz Databazes

@ Management Central (T400ws) Tame | Tvpe | Status | Description |
E! My Connections % I400ws Local Bvailable WSR2 SY3BASE
B[ As23
- @ Astha
-l H00ws
% EBasic Operations
@ ‘Wark Management
B Configuration and Service
- Metwark
-3, Security
[-g® Users and Groups

E[%E Databases
=By T400ms
#-{[5) Libraries
% Database havigator
Bl S0L Performance Maonikars
--*-‘93.\ Transactions
-2 File Systems
-2l Backup
(-8, AFP Manager

[Ty Tasks == atabas
! Add a connection
(@ Install additional components

[1-10f 1 objects [

Figure 3. Main iSeries Navigator panel

NG| Kl

In iSeries Navigator, there are three places from which to access the functions for
an object:

* The File menu
* Anicon from the toolbar
« An object’s right-click menu

In the remaining labs, use the right-click menu to access these functions.

Task 2: Creating a sample schema (database)

In this task, you run a system-provided stored procedure to create a sample
schema (database) from which to work:

__ 1. Ifyou already created a sample schema SAMPLEDBxx, go to Task 3,
"Displaying properties and descriptions of DB objects” on page 5.



___ 2. Invoke the SQL Script Center by right-clicking the Database Name
(1400WS icon under your Databases icon). Select Run SQL Scripts. A
new Run SQL Scripts window appears.

___ 3. Click the Options menu item and select the following items (one at a time)
as shown in Figure 4:

¢ Stop on Error
* Smart Statement Selection
* Run Statement on Double-Click

i Untitled - Run SAL Scripts - 1400ws =
File Edit View BRun “isualExplain Options  Connection  Help

E# @ v StoponError

¥ Smart Statement Selection
Display Results in Separate \Window
Include Debug Messages in Joh Lag
¥ Run Statement On Double-Click

E-r IR LY

Change Query Attributes...

Figure 4. Run SQL Scripts: Options menu item

— Note

When the Smart Statement Selection option is selected, all highlighted
SQL statements run in sequence. If this option is not selected, the
highlighted SQL statements are executed as a single statement. This
option also ensures that complete statements are run even if one or
more statements are only partially highlighted.

4. Invoke the V5R2-supplied stored procedure that creates a sample
database that you use in subsequent tasks. In the SQL statement working
area, type the following statement:

CALL QBYS. CREATE S SAMPLE(’ SAMPLEDBXX ) ;
Be sure to replace XX with your team number.

Note

Always type a semicolon (;) at the end of every SQL statement so the
Smart Statement Selection feature knows where each statement ends.

5. Move the text cursor anywhere into the statement and double-click to run it.
Watch the Messages tab for a completion notification informing you that
you have a sample database with which to work.

If an error message appears, notify your lab supervisor.
You now have a sample database to use during the next lab.
6. Close the Run SQL Script window.
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Task 3: Displaying properties and descriptions of DB objects

In this task, you use iSeries Navigator to explore the sample database that you
created in the previous task:

___1. Inthe left panel of the main iSeries Navigator window, click the plus (+)
sign next to the Database icon.

__ 2. Right-click the Libraries icon and select Select Libraries to Display from
the pop-up context menu as shown in Figure 5. The Select Libraries to
Display window appears.

¥ iSeries Navigator
File Edit Wiew Help

iR B i ReXE | 9ES

| Erwironment; My Connections | | 400wz Libraries  Databasze; [400ms
B nstha ;I Marne | Description
E! 1400ws (6 spL General Purpose Library
-85 Basic Operations [ aTEMP
B Work Managsment [ 5AMPLEDED] COLLECTION - craated by SQL
-8 Configuration and Service I/ SAMPLEDEOZ COLLECTION - created by SQL
Hetuiork [ 5AMPLEDBNS COLLECTION - created by SQL
__ E‘:;:'::’n § Groups [fE5|SAMPLEDE4S COLLECTION - created by SOL
EE Datahases SHMPLEDBQQ COLLECTION - created by SQL
=By 1400ms & TEZCMDS TOOLS product short-cuk command i
EI"@ Mxplure
""" Qpen
Create Shortouk
..... Customize this Wiew 3
,,,,, T Library
..... 5 gt aries ko Di
""" Fropetties

Figure 5. Select Libraries to Display to include iSeries Navigator

__ 3. Inthe Enter Libraries input field, type SAMPLEDBXX and click Add as shown in
Figure 6. The SAMPLEDBXX library is added to the list in the right panel of
the window. Click the OK button.

Be sure to replace XX with your team number.



Select Libraries to Display - As27

* Enter libraries: Libraries to displag:

SAMPLEDEM NICOLAS
ORDAPFLIE
™ Select from list add> | [ooRL
QSPL
OTEMP
SAMPLEDEOS
Femave SAMPLEDEDGE
4| SAMPLEDEOT
SaMPLEDBOR
SAMPLEDER
TEZCMDS

ok Cancel Help

Figure 6. Select Libraries to Display window

___ 4. Right-click your SAMPLEDBXX library and select Properties. A new
SAMPLEDBXX Properties window appears.
__ 5. Explore the information in this window and answer the following questions:

* How large is this library? megabytes

Hint: General->Total allocated size

« How many objects are in this library?
Hint: Storage->Contents

* When was this library last-saved?
Hint: Save->Last saved

« When was this library created? By whom?

Hint: Creation->Created
Click OK when you are finished.

6. Double-click your SAMPLEDBXX library to see all the database objects of
this library displayed in the right panel.

7. Locate and right-click the EMPLOYEE table. Select Description. This
option is a new function added in V4R5. A new Description window
appears with six different information tabs.

This option is used in the same manner as the CL commands Display File
Description (DSPFD), Change Physical File (CHGPF), and Change Logical
File (CHGLF).

Click each different tab and then click Help to see detailed information of
all table description attributes in the corresponding tab that you are in.

8. Explore the information in this window and answer the following questions:

« How large is this table? kilobytes

« How many rows are in this table?

+ Is the Reuse deleted rows feature active?

Database Navigator and Generate SQL in DB2 UDB for iSeries on V5R2



Hint: General Tab
* How many bytes is the longest row in this table? bytes
Hint: Details->Maximum row length
Click OK when you are finished.

9. In the previous step, you found that there are two indexes built for the
EMPLOYEE table. How do you identify its indexes?

Hint: Right-click the EMPLOYEE table and select Properties. Find the
correct tab that shows you this information.

Click the Indexes tab. Two index nhames (XEMP1 and XEMP2) appear.
Click OK when you are finished.

__10.Click OK to go back to the iSeries Navigator main window. Locate and
right-click the VEMPDPT1 view. Select Description.

__11.Click the Details tab and note the Allowed activities attribute. Why is it
read-only? Notice the check mark in front of Read, while there is none for
Update, Write, and Delete. Why is this?

Click OK when you are finished.

Normally, a joined view is a read-only object. You can prove that
VEMPDPT1 is a joined view by right-clicking VEMPDPT1 and selecting
Properties. The SQL DDL statement that joins DEPARTMENT and
EMPLOYEE tables appears. Click OK when you are finished.

At this point, you are ready to run the second lab, which introduces a new feature
called Database Navigator (included with iSeries Navigator in V5R2).

You have now completed this lab!
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Lab 2. Database Navigator: General tasks

This lab outlines some of the general tasks that are available with Database
Navigator.

Introduction

Database Navigator enables you to visually depict the relationship of database
objects on your system. The visual depiction you create for your database is
called a Database Navigator Map. In essence, the Database Navigator Map is a
"snapshot" of your database and the relationships that exist between all of the
objects in the database.

Using iSeries Navigator, you can explore the complex relationships of your
database objects using graphical representations that present the tables in your
database and the relationship between tables, indexes, and constraints that are
attached to tables. After you connect to your system, you can use iSeries
Navigator to:

« Generate a map of a set of tables and the relationships between them.

* Manipulate the map to show items of interest, without changing objects on the
system.

* Generate SQL for all the objects in the map.
* Print maps.
e Save maps and view them later.
In this lab, you use the example database SAMPLEDBXX. Remember that XX in

library names, profile names, and so on refers to your team number (for example,
DBNAVXX). Refer to your lab worksheet for details.

Objectives
This lab teaches you how to:

* Generate a MAP from some tables and view the relationship between such
database objects as tables, views, indexes, referential constraints, and
primary keys

* Add Primary Key Constraints
« Zoom and Arrange objects
* Save the MAP

Lab prerequisites
Before you begin this lab, be sure the following prerequisites are available:
* An IBM @server iSeries or AS/400 server with OS/400 V5R2, or higher, with:

— 5722-SS1: Host Servers
—5722-TC1: TCP/IP Connectivity Utilities

» Client Access Express V5R2MO with the latest Service Pack applied
e Sample Database SAMPLEDBXX created
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Time required
The time required to efficiently complete this lab is 30 minutes.

Task 1: Creating the Database Navigator Map

In this lab, you create your first Database Navigator Map and work with the
components. You also learn general navigation operations using the map.

___ 1. Inthe Navigator window, click the 1400WS connection. A window prompts
you to enter a username and password as shown in Figure 7. Consult your
lab worksheet for your profile name and password. When you are finished,
click OK. Because this may be your first time signing on to the iSeries
server, the system has to update Navigator with its capabilities.

Signon ko iSeries ﬂﬂ
E Server: I|4DUWS
User ID: |DENAYDT
Pasaward: I “““““““ 1

ak. I Cancel |

Figure 7. iSeries Sign on information

__ 2. Click the plus (+) sign next to the Database icon to expand it. The
Libraries, Database Navigator, and SQL Performance Monitor functions
should appear in the expanded list as shown in Figure 8.

___ 3. Click the Database Navigator icon. All of the existing maps on the iSeries
or AS/400 server should appear as shown in Figure 8.
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fB.iSeries Navigator =10 x|

Fle Edit Yiew Help

4 E|X|@° 0 minutes old

| Environment: My Connections 1400ws: Database Mavigator  Database: [400ws

(B} Management Central (I400uws) Marme | Librar Ciescription
EH My Connections
B As0zb
H Asz3
- B Astha
-l 1400ws
% Basic Operations
71-Ef) Work Management
B2 Canfiguration and Service
[ @ Mebwork
Hl Security
- Users and Groups
-5 Databases
=By H00ws
-5 Libraries
R amfDatabase
SaL k— tformance Monitors
--J—*»‘Q Transactions
[]--c.‘;-':'. File: Systems
[l Backup
-, AFP Manager ‘| I 0

Mavigator

0 T B
B 2dd a connection B Create new summary SOL performance monitar lg® Fun an SOL script
@ Install additional components & Create new detailed SOL performance monitor B Map your database
25 Select ibraries to display ¥ Y Help far related tasks LI
[ |0objects [ v

Figure 8. Database Navigator option

4. Click the plus sign (+) sign in front of the Libraries icon to expand the
Navigator library list.

5. Check whether your SAMPLEDBXX library is included in the list. If it does
not exist, change the iSeries Navigator Library List to include it. Refer to
step 2 in Task 3, "Displaying properties and descriptions of DB objects” on
page 5, in Lab 1.

6. Right-click the Database Navigator object and select New to create your
Map as shown in Figure 9. A new Database Navigator window appears as
shown in Figure 10 on page 14.
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Series Navigator
File Edit Wiew Help

sRB| X5 |FES

| Ervvironment; My Connections | | 400wz Data
@ Managemment Central (T400ks) Mame
=-Hf My Connections
BB Asizh
B as23

-l Astha
BBl 1400ws

-5 Basic Operations
@ Work Managernent
%!1 Canfiguration and Service
ﬁ Metwark,
BB Security
@ Users and Groups
- Databases
E-Ey T400ws
E@ Libraries
! CPL
QTEMP
SAMPLEDBOL
SAMPLEDEOZ
SAMPLEDEOZ
SAMPLEDESS

TEZCMDS
% SQL Perfarm Explore
Open

- Transactions
[H-02 Flle Systems Create Shortouk
[].. Backup Custarize this Yiew *

=B aep Manager B
Properties

Figure 9. Selecting New to build a new map
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—— Exploring the Database Navigator window

The primary workspace for Database Navigator is a window that is
divided into four main areas. These four areas allow you to find the
objects to include in a map, show and hide items in a map, view the map,
and check the status of pending changes for a map. The following list
briefly describes the main areas of the database navigator window:

» Locator Pane: The Locator Pane is located on the left side of the
Database Navigator window. It is used to find the objects that you
want to include in your new map or to locate objects that are part of
an open map. The upper Location Pane is a search facility that can
be used to specify the Name, Type, and Library of the objects that
you want to include in the map. The results of the search are
displayed in the lower Locator Pane under the Library Tree and
Library Table tabs.

« Map Pane: The Map Pane is located on the right side of the Database
Navigator window. It graphically displays the database objects and
their relationships.

* Object Status Bar: The Object Status Bar is located on the bottom
left of the Database Navigator window. It displays the number of
visible and eligible objects in the map.

» Action Status Bar: The Action Status Bar is located on the bottom
center of the Database Navigator window. It provides a clear
description of what has taken place in the map and whether
modifications are pending.

* Modification Status Bar: The Modification Status Bar indicates
whether a modification has been made or is pending.

. The iSeries Navigator library list appears in the left side of the Database
Navigator Window. Double-click your SAMPLEDBXX library to expand the
objects (XX is your team number) as shown in Figure 10.

. Double-click Tables in the Locator Pane to expand all the tables in a
database.

. Double-click the EMPLOYEE table on the lower Locator Pane to start
building a map. This table is added to the map and all its related objects.
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gm Untitled - Database Navigator - As27

File “iew Qptions Map Help

DEEH@ BRSO [T Emiaw] @l

Search for Ohjects
Marme: Al names =
Type: All types hl
e ity =l —p» Upper Locator Pane
Library: JList o libraries =
Search |

Library Tree | Library Table | Objects In Map|
[_@ Libraries |
i) MICOLAS
QGPL

+-{iE SAMPLEDB0S
SAMPLEDBOG
=-fiE SAMPLEDBOT
=- Tahbles
=0 ACT

[T DEPARTMENT — p Lower Locator Pane
0 EEEE
[0 EMFPROJACT
[ EMF_PHOTO
[0 EMF_RESUME

#-[0 SAMPLEDEMAFROT ;I o

Figure 10. Selecting a database to build a map
The Map is built from the cross reference files (XREF) on the iSeries. The

relationship and statistics are based from the table that you selected to
generate a map as shown in Figure 11.

14 Database Navigator and Generate SQL in DB2 UDB for iSeries on V5R2



ntitled™ - Database Mavigator - As80

=-00 EMP_PHOTO
Figure 11. Building a Database Navigator Map

___10.Click the minus (-) sign next to the SAMPLEDBXX database object to
collapse the tree view.

___11.Use the vertical and horizontal scroll bars to navigate the map. Use the
Zoom icons on the toolbar to zoom in and zoom out the MAP as shown in
Figure 12.
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gim Untitled* - Database Navigator - I400ws({I400ws) 10l =|

File View Options Map Help

HEHP BRI ¢mn ARdRe-vESE N

Search for Objects

MName: F\II names vl
Type: IAIItypes vl
Library: |List of libraries vl

Search |

Library Tree | Library Table | Objects In Map|

=& 5AMPLEDBO1 |

-0 Tables

DEPARTL Q8VS_DEPTH..
QSVS_RESRE..
EMP_RESUME
QEVS_EMPNO...
QEVS_EMPNO...

% Indexes

-4 Views -
47 SAMPLEDB02 =l | _,l—l

|23 of B8 ohjects in map are visible. | o

Figure 12. Database Navigator Map

The default view of a map only shows tables and referential constraints.

__12.Click Options and select the User Preferences option to open a new
window to include or remove the defaults user preferences as shown in
Figure 13.

m Untitled* - Database Navigator - I400ws(I400ws)

Eile_yiew [FEUSIEN Van _Help

2= o | @By B8N
Sﬁm%\:ffw Ejrccbr:ange preferences |

Mame: JAll names =]

Type: Al types =

Library: |SAMPLEDRD? ]

Library Tree | Library Tahle | Ohjects In Mapl

1] Libraries

=i SAMPLEDBO
=0 Tables

=00 acT

-EH CL_SCHED

Figure 13. Viewing or Changing the user preference for Database Navigator Map
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__13.You can see that the User Preference window shows you the various
objects that may be included on the map, click OK to return to Database
Navigator Map as shown in Figure 14.

User Preferences x|

When adding an object ta the map find these related ohjects:

[+ Aliases [+ Primary key constraints
[+ Check constraints [+ Unigue key constraints
vl Indexes I Trigogers

[ Journals [ Wiews

r

[+ Show flyover help on objects in map

[ Show properties dialog for generate SAL

OE | Cancel Help |‘?|

The map is generated based on default user references. In V5R2, support for
Trigger objects in the MAP was added. You can change the default option to
remove or add extra objects.

Figure 14. Database Navigator user preference

Task 2: General tasks using the Database Navigator window

In this task, you select some general functions on the Locator Pane on the left
side of the Database Navigator to find and include objects in the map that are part
of an open map.

___ 1. Use the criteria selection in the Upper Locator Pane to select only your
SAMPLEDBXX library. Click and select the library parameter as shown in
Figure 15.

___ 2. Click the Search button to execute. The result is shown on the bottom
pane, under the Library Tree and Library Tables tabs.

Note

When you open your database, the default search process is the list of
libraries on the iSeries Navigator window. Therefore, you always can see
the list of libraries on the Library Tree tabs.
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[ Libraries SAMPLEDBOZ B DETH
- QPL SAMPLEDROZ -
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—_—
257S_ENPND... EMPLOVEE

m

\ 7 h LILI

Kl |

|23 07 68 ohjects in map are visihle, |Search for objects completed Mo

Figure 15. Search criteria on the locator pane

3. Click the plus (+) sign next to your SAMPLEDBXX database on the Lower
location Pane to show the objects found, such as Tables, Indexes, and
Views.

4. Click the (+) sign next to the Tables database object to expand it.

5. All of the tables in the map should appear as shown in Figure 16. Do an
advanced search using the criteria selection in the Upper Location Pane to
select all tables that begin with the literal ‘EMP’.
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iim SAMPLEDEMAPOS - Database Mavigator - 1400ws

File Wiew Options Map Help
IEHE BARaAn| I sma A@®E

Search for Ohjects

Marme: Al names =
Type: IAllh,rpes ;l
Library: [5AMPLEDEDS =

Library Tree | Library Table | Objects In Map|
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=i SAMPLEDBNS
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-0 ACT

#-00 CL_SCHED
1#-[0 DEPARTMENT
1+~ EMPLOYEE
-0 EMPPROJACT
-0 EMP_PHOTO
#-[0 EMP_RESUME
-0 GENSQLHHE
-0 IN_TRAY
=-00 ORG

-0 PROJACT
-0 PROJECT
#-00 QGSALSRC
-0 SALES

#-[0 SAMPLEDEMAFDS
-0 STAFF

- Indexes

Figure 16. Using the Locator pane

___ 6. Inthe Name input field, type BEMP-. In the Type input field, select Table as
shown in Figure 17.

___ 7. Click Search to execute. The search results are shown on the bottom pane

under the Library Tree and Library Tables tabs.
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Library Tres | Library Table | Objects In Map |
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=00 EMP_PHOTO
=0 EMP_RESUME

Figure 17. Advance search using the Locator pane

___ 8. Use the criteria selection again to show all of the tables on the Lower
Location Pane. Click in the Name input field and select All names to view
all of the tables in the schema. Click the Search button. In the next step,
you use the Find objects in the map function.

9. Right-click the PROJECT table from the list of tables and select the Find in
Map option to find this table in the map as shown in Figure 18.
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Figure 18. Selecting a specific object to locate in a map

___10.Move the pointer over the PROJECT table on the map. The general
description about it (flyover window) should appear as shown in Figure 19.

___11.Use the criteria selection again to show the tables, Indexes and views on
the Lower Location pane. Click in the Type field and select All types. Click

the Search button.

21




ii':n Untitled* - Database Navigator - I400ws{I400ws)

=l
File VWiew Options Map Help
EEE P BAXAS T dme ABdRe=vEDSE D
Search for Objects %‘A ;l

MName: FAII names vl
Type: |Tab\e 'l
Likrary: ISAMPLEDEIM vl

Library Tree | Library Table | Objects In Map |

Libraries

=& SAMPLEDEDT

-0 Tables

@ AcT
#-[0 CL_SCHED
- [T DEPARTMENT
- [ EMPLOYEE
[T EMPPROJACT
[ EMP_PHOTO
-0 EMP_RESUME
=00 IN_TRAY

[ ORG

[ PROJACT

M ) »

T QAQQIN
[0 SALES
&[0 STAFF
&[0 TEST
&[0 TESTH

G

 EMFHO...

h .

MPNO... BuPLOYEE

il

DEPARTH

ROE

FFF

05Y5_RESPE...

PROJACT F

RPAP

PROJECT

System Mame:
Library:
Type:

PROJECT
SAMPLEDBO1
Tahle

Q5T5_DEFTH...

|23 of B8 abjects in map are visikle. |

Jod

22

Figure 19. Locate specific object in a map

You can see the Object Status bar at the bottom left of the Database
Navigator window as shown in Figure 20. This displays the number of
visible and eligible objects in the map. As shown in Figure 20, only 23 of 68
objects qualify as eligible objects and are included on the map. This is
because only the tables and constraints are included in the map.
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Figure 20. Status bar code

__12.Select the Library Table tab on the Locator Pane to show the complete list
of tables, indexes, and views on the database selected as shown in Figure

21.
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__13.Use the vertical and horizontal scroll bars to view all of the objects in the

Library Table list.

__14.Click Objects In Map in the lower locator pane and a list of objects in the
map should appear. Only the selected objects in the list are included in a

MAP.

___15.Click the Type tab on the Object In Map field to organize the objects by

Type.

___16.Use the vertical and horizontal scroll bars to search the index objects in the

Objects In Map list.

___17.Select all of the indexes (one by one) in the list to include them in a map.
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Figure 21. Including a new object in a map

Each time you select an index or another object from the Library Table, the

map and the Status bar message is updated.

___18.Right-click in a free space on the Map Pane in the Database Navigator

window.

___19.Select Zoom and then select the To Fit Window option to fit the map in the

window as shown in Figure 22.
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Figure 22. Selecting To Fit Window

You can see all objects in the current window as shown in Figure 23.

When the objects are shown under the Library Tree and Library Table tabs,
you can also add objects to the map by right-clicking an object and
selecting Add to Map, or double-clicking the object name.
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Figure 23. Sizing a map to fit the display window

Notice the Object Status Bar in the bottom left of the Database Navigator
window. This displays the number of visible objects in the map of the total
found.

20.Click File and select Save As... to save the Map.

21.From the Save As... window, click the Libraries parameter and select your
SAMPLEDBXX library.

22.In the Name input field (Figure 24), type:
SAVPLEDBVAPXX

23.In the Description input field (Figure 24), type:
"MAP created by DBNAVXX

24. Click OK to save your map.
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Figure 24. Saving the database map

Note

The Database Navigator Maps are stored on the iSeries server. After you open
a Database Navigator Map, it is locked from other users to prevent conflicts
where other users try to update the same map at the same time.

Task 3: General task using print capability to print a MAP

26

In this task, you select some general functions on the Locator Pane on the left
side of the Database Navigator. These functions help to find and include objects
in the map that are part of an open map. You also select the print options to setup
different ways to print a MAP.

___ 1. Click Objects In Map in the lower locator pane, and a list of objects in the
map should appear. Only the selected objects in the list are included in a
MAP.

2. Click the Type tab on the Object In Map field to organize the objects by
Type.

3. Use the vertical and horizontal scroll bars to search the index objects in the
Objects In Map list.

4. Select all objects (one by one) in the list to include them in a map.

5. Right-click in a free space on the Map Pane in the Database Navigator
window.

6. Click Zoom and then select the To Fit Window option to fit the map in the
window. Now you can see all the objects included in a MAP.

You can see the Object Status bar at the bottom left of the Database
Navigator window as shown in Figure 20 on page 22. This displays the
number of visible and eligible objects in the map. As shown in Figure 25, 68
of 68 objects in the map are available.
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Including all objects in a map

Each time you select an index or another object from the Library Table, the
map and the Status bar message is updated.

Click File and select Print Preview to open a new window to preview and
customize different options to print a MAP as shown in Figure 26.
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Figure 26. Selecting the Print Preview option

8. Click Print Setup to customize the printout to be on 2 x 2 matrix (two lines
by two columns).

9. Select Print Entire Graph. On Scale Box, select Pages to print the output
across several pages.

___10.In the Page Columns input field, type 2.
___11.In the Page Rows input field, type 2 as shown in Figure 27.
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Figure 27. Printing map using Scale by Page
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__12.Click OK to see your map split on a 2 by 2 matrix as shown in Figure 28.

Figure 28. Printing a Map using Scale by Page

With this option, you can split your map across many pages to see the
entire object in a Map.

__13.If a printer is available in the Lab, click the Print button and select the
printer to print your Map. Otherwise, click close to return a Database
Navigator Windows.

___14.Click File and select Print Preview to open a new window to preview.
Customize the Scale by Actual size option to print a MAP.

__15.Click Print Setup... to customize the printout automatically based on the
number objects in a map.

__16.Select Print Entire Graph. On Scale Box, select Actual Size to set the
printout to print automatically as shown in Figure 29.
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Figure 29. Printing using Actual Size Scale

__17.In the Caption section, replace the name Untitled with Proj ect Dat abase MAP

(try now to enter a title for the printer map).

__18.Click Position and select Top left option.

___19.Click Font button to customize printout to automatically print based on the
number objects in a map.

__20.0n the Choose Font window, select the font ScanSerif Bold and size 18
as shown in Figure 30.

Choose Font

=l |9123A2BbYyZ2

Cancel

o |

Figure 30. Choose Font window

___21.Click OK to return printer setup see your preview printing Map as shown in

Figure 31.
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Figure 31. Printing using Actual Size scale

__22.If you a printer is available in the Lab, click the Print button. Then select
the printer to print your map. Otherwise, click close to return to the
Database Navigator window.

Note

On V5R2, the print options have been enhanced to provide different

options to print MAP. This gives the user good documentation about the

logical design of the database.

You have now completed this lab!
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Lab 3. Changing the Database Navigator Map
The lab explains how to change a Database Navigator Map.

Introduction

This exercise teaches you how to manage a Database Navigator Map,
manipulate the map, and show specific objects in the map (this includes showing
you the different alternatives for including objects such as views, remove objects,
change object placement, and so on). In this lab, you manipulate the map in more
detail and you use a mix function from the menu bar and toolbar.

You use the SAMPLEDBXX example database. Remember, XX in library names,
profile names, and so on refers to your team number (for example, DBNAVXX).
Refer to your lab worksheet for details.

— Note

In the Database Navigator Map window, there are two places from which to
access map functions. You can use either the File menu or an icon from the
toolbar. For a specific object, use the right-click menu. In the remaining labs,
the right-click menu is used to access these functions.

Objectives
This lab teaches you how to:

* Add Views, Primary Key Constraints, etc., that exist on the iSeries server but
that are not included in the Database Navigator Map

* View a different Map layouts: Symmetric (default), Circular, and hierarchic
design

« Analyze a map relationship for a specific object
* Remove objects from the map

» Change object placement in the map

» Create a user-defined relationship (UDR)

« Expand and collapse tables in a map

« Save the map

Lab prerequisites
Before you begin this lab, be sure the following prerequisites are available:
* An IBM @server iSeries or AS/400 server with OS/400 V5R2, or higher, with:

— 5722-SS1: Host Servers
—5722-TC1: TCP/IP Connectivity Utilities

 Client Access Express V5R2MO with the latest Service Pack applied
« Sample Database SAMPLEDBXX created
« Sample Database Navigator Map SAMPLEDBMAPXX created
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Time required

The time required to efficiently complete this lab is 30 minutes.

Task 1: Selecting the Database Navigator Map
In this task, you select the map that you want to manage:

1. Click the plus (+) sign next to the database object to expand the different
options.

___ 2. Click the Database Navigator to display the maps in the right panel that
exist on the iSeries server as shown in Figure 32.

¥ iSeries Navigator
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i@l Asozh
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- Astha
- @ 1400ws
% Basic Operations
% ‘Whark, Management
ﬁ' Configuration and Service
G Mebwark
0 Security
[ Users and Groups
B[ Databases
L 2By 1400ws

@ Libraries

% Datahase Mavigator
o SOLEerformance Monikars

: --ﬁ‘g\ Transactions
=2 File Systems

[T} -

Figure 32. Opening the Database Navigator Map

___ 3. Double-click the Database Map that you created in Lab 2, “Database
Navigator: General tasks” on page 9, to open it. If it does not appeatr,
refresh the window.

4. Click View. From the pull-down menu, select Zoom-> To Fit Window to fit
all objects on the map in this window as shown in Figure 33.
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Figure 33. Fitting all objects in a map
___ 5. Use the toolbar to select the icons Zoom In, Zoom Out, and Zoom to fit

for the object size on the map in this window as shown in Figure 34. It also
shows the different options that are available on the toolbar.

gm Untitled™ - Databasze Navigator - As27
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Check Constraints

Zoom Icons
Overview Window -
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Figure 34. Toolbar options

__ 6. Use the vertical and horizontal scroll bars to navigate to the top of the map.

___ 7. You can see the Objects Status Bar in the bottom left of the Database
Navigator window. This displays the number of visible objects in the map
and the total found. Write the number of visible objects in the Map:

Task 2: Adding views in the map

__ 1. Click View-> Show Objects of Type-> Views to include all Views in the
map as shown in Figure 35. In the bottom left of the Database Navigator
window, the Object Status Bar that was updated with the new objects

included in the map appears.
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Figure 35. Selecting the Views object type to appear in the Map

36 Database Navigator and Generate SQL in DB2 UDB for iSeries on V5R2

JMad

2. Write the number of visible objects in the Map:

Use the toolbar to select the Zoom icons (including Zoom in, Zoom Out

and Zoom to fit Window) to fit all objects on the map in this window.

as shown in Figure 36.

4. Use the vertical and horizontal scroll bars to navigate to the top of the map

You can change the zoom level of the Database Navigator Map to manage how
much of the map you can see in the map pane on the Database Navigator

window.
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Figure 36. Using scroll bars to navigate to the top of the map

Task 3: Showing the relationships of a specific object

___ 1. Use the criteria selection in the locator pane to select only your

SAMPLEDBXX library. Click the Library parameter and select your
SAMPLEDBXX library.

2. Click the Search button.

Click the plus (+) sign next your SAMPLEDBXX database to expand the
objects for Tables, Indexes, and Views.

Click the (+) sign next to the Tables database object to expand it.

5. Double-click the PROJECT table from the list of tables to find this table in a

map.

Click the zoom icons (Zoom in, Zoom Out, and Zoom to fit window) in
the toolbar to focus the PROJECT table in the map pane.

Use the vertical and horizontal scroll bars to navigate and focus on every
relationship object of the PROJECT table as shown in Figure 37.
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Figure 37. Fitting the object in a map

___ 8. Place the cursor over every relationship to view a brief description (Object
Name and Type of Relationship) and fill in Table 1 with all the relationships

of the Project table.

Table 1. Relationship objects

Original table Relationship object name

Type of relationship

Project
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Task 4. Removing objects from the map using the toolbar

1.

Click the Index and Views icons on the toolbar to remove indexes and
views from the map as shown in Figure 38.

Click the zoom icons (Zoom in, Zoom Out, and Zoom to fit window) from
the toolbar to fit the objects in a Database Navigator window.

Use the vertical and horizontal scroll bars to navigate to the top of the map
on the Database Navigator window.

. Write the number of visible object in the Map:
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Figure 38. Removing objects from the map

__5.

Click File-> Save to save the changes in the map.

Task 5: Changing object placement and arranging objects in a map

In this task, you learn how to arrange and move objects in the map. You also
learn how to remove the bends that appear on the relationship lines after the
object is moved to the new location.

1.

Double-click the EMPLOYEE table from the list of tables to find this table in
the map.

Click the zoom icon options in the toolbar to see all of the objects in the
map pane.
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__ 3. Use the vertical and horizontal scroll bars to navigate on the Map on the
Database Navigator Windows.

___ 4. Drag-and-drop the EMPLOYEE table to the left as shown in Figure 39.
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Figure 39. Changing object placement

5. Repeat steps 2, 3, and 4 to move the DEPARTMENT table to the right.
A window similar to the example in Figure 40 appears.
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Figure 40. Moving the Department object in a map

When objects are moved or added to a map, you usually use the Arrange

function to reorganize the Map in Map Pane.

Arrange option

The arrange option was enhancement in V5R2 to provide additional Map
layout: Circular, Hierarchic, and Symmetric (default). The Arrange layout

option puts the map in the Default state.

Right-click in a free space on the map pane in the Database Navigator

window. The Arrange function appears.

Select Arrange to chose the Symmetric (default) option to put the Map in

its original state as shown in Figure 41.
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Figure 41. Selecting the Symmetric layout option

___ 8. Use the icons in the toolbar in the Database Navigator windows to include
the Indexes, Views, and Primary Key Constrained to gain a good view of
different layout Maps.

___ 9. Click the zoom icons (Zoom in, Zoom Out, and Zoom to fit window) from
the toolbar to fit the objects in a Database Navigator window.

___10.Use the scroll bar to go to the top of the map. You can see the Symmetric
(Default) layout as shown in Figure 42.
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Figure 42. Symmetric (Default) layout or the map

___11.Right-click in a free space on the Map Pane in the Database Navigator
windows.

___12.Select Arrange and then select the Circular option to see the Circular
layout as shown in Figure 43.

___13.Repeat steps 11 and 12 to see the Hierarchic layout map and then return to
the Symmetric (Default) layout.

___14.Use the icons in the toolbar in the Database Navigator windows to remove
the Indexes, Views, and Primary Key Constrained.

___15.Click File-> Save to save the changes in the map.
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Figure 43. Circular layout of the map

Task 6: Expanding and collapsing a table object

This task shows you how to expand a table icon in your Database Navigator Map.
This allows you to view essential data about the table. The data that appears in
the expanded table is a subset of the data you can see in Table Properties.

___ 1. Double-click the PROJACT table from the list of tables to find this table in
the map.

___ 2. Clickthe Zoom Icons in the toolbar to see all the objects in the map pane.

__ 3. Right-click the PROJACT table on the Database Navigator window and
select Expand as shown in Figure 44.
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4. Resize the PROJACT table to increase the size as shown in Figure 45.
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Figure 45. Expanding the table in a map

___ 5. Click the Columns tab on the table.

___ 6. Use the cursor to widen the header of the second column on the column
table. This column contains the fields that comprise the primary key (if any)
for this table.

___ 7. Fillin Table 2, in the correct order, with the columns that have a primary
key on them.

___ 8. Click the Indexes tab on the table.
9. Use the vertical and horizontal scroll bars to view the Indexes.

___10.Enter the Index Name in the following field and, in the correct order, fill in
Table 2 with the columns that include an index.

Index Name:

Table 2. Primary Key and Indexes

Table Primary key columns Index columns

PROJACT
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__11.Right-click the PROJACT table and select the Collapse function to
compress the table to its original size in the map (iconify the table) as
shown in Figure 46.

___12.Click File-> Save to save the changes in the map.
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Figure 46. Collapsing the table in the map

You can now see the entire map in the Database Navigator window.

Task 7: Creating a user-defined relationship (UDR)

In this task, you to create a user-defined relationship in a map.

User-defined relationship

When you have a relationship that is defined by your program, you can create
a user-defined relationship. An example of this is when the referential integrity
is controlled by the application and is not defined in the database.

___ 1. Right-click in a free space on the map pane in the Database Navigator
window. Select the Create function as shown in Figure 47.

___ 2. Select Create-> User Defined Relationship to create the new object
(UDR).
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Figure 47. Selecting the function to create a User Defined Relationship

__ 3. Inthe Name input field, type SAMPLEUDRXX. In the Description field, type ' UDR
created by DBNAVXX as shown in Figure 48.

Important

It is important to provide a meaningful description for your user-defined
relationship since it is the only way for you to indicate what the
user-defined relationship represents.

4. Click Type on the Select Object in Relationship to organize the objects by
type.

5. Select the PROJECT and DEPARTMENT tables from the list of objects.

6. Select Square for Shape and Blue for Color for this relationship.
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Figure 48. Creating a user-defined relationship

___ 7. Click OK to create the user-defined relationship and return to the map.

__ 8. Click the zoom icons in the toolbar to see all the objects in the map pane

(Figure 49).

__ 9. Click File-> Save to save the changes in the map.
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Task 8: Overview window function

The Overview window is a small window that shows the map on a reduced scale.
It has a highlighted area that represents the parts of the image that are currently

displayed in the main window.

In the Overview window, you can move to specific areas of the map by

right-clicking the highlighted area and moving the highlighted area to the area you

want to view.

This task shows you to how to view the map in the Overview window and invoke

the both function from the toolbar and the view menu. You add the Indexes,

Views, Primary Key Constraints, and Check Constraints to gain a better idea of

how this function is useful.

1. Use the icons in the toolbar in the Database Navigator window to include

the Indexes, Views, Primary Key Constraints, and Check Constraints.

2. Click the zoom icons in the toolbar to see all the objects in the map pane.

Use the scroll bar to go to the top of the map as shown in Figure 50.
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Figure 50. Adding objects in the map

ot

4. Click the Show Overview Window icon in the toolbar to open the
Overview window as shown in Figure 51.

Figure 51. Overview window

___ 5. Click the highlighted area and move the blue box to the right of the
Overview window as shown in Figure 52.
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Figure 52. Moving the Overview window

The map pane should include a highlighted part of the map on the
Overview window as shown in Figure 53.
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Figure 53. A map using the Overview window
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The Overview window contains all of the objects in the map. You can move
to specific areas of the map by moving the highlighted area to the area you
want to view. In addition, you can reduce or widen the highlighted area to
include a specific area.

___ 6. Close the Overview window and the Database Navigator window.

You have now completed this lab!
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Lab 4. Generating SQL using iSeries Navigator

Objectives

Lab prerequisites

Time required

Introduction

This lab explains how to generate the SQL statements from existing database
objects via iSeries Navigator. This process is often referred to as Reverse
Engineering.

The notation XX that appears in library names, profile names, directories in your
PC, and so on refers to your team number.

This lab teaches you how to:

« Generate SQL statements from a map
* Generate SQL statements from an object in a Library
« Save the SQL Script in a Database Source File and PC file

Before you begin this lab, be sure the following prerequisites are available:
* An IBM @server iSeries or AS/400 server with OS/400 V5R2, or higher, with:

—5722-SS1: Host Servers
—5722-TC1: TCP/IP Connectivity Utilities

« Client Access Express, V5R2MO, with the latest Service Pack applied

* You must have completed Lab 1, “iSeries Navigator setup” on page 1, before
generating the SAMPLEDBXX sample database.

* You must have completed Lab 2, “Database Navigator: General tasks” on
page 9, to generate the SAMPLEDBMAPXX map used in this lab.

* You must have completed Lab 3, “Changing the Database Navigator Map” on
page 33, to obtain the necessary skills.

« The DDSLIBXX library must be available because it contains the physical and
logical files created with DDS.

The time required to efficiently complete this lab is 60 minutes.

The new Generate SQL function for iSeries Navigator provides a GUI interface
that allows you to reverse engineer several types of database objects. The results
are SQL create statements (often referred as DDL statements).

After you select one or more objects to be reverse engineered, you have the
option to view the resulting SQL in the Run SQL Scripts Dialog. Or, it can be
saved to a file on the PC or a Source physical file on the iSeries server.

The new Generate SQL Database Object supports the following objects:

* Aliases

« Distinct types
* Functions

* Indexes
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e Procedures

* Schemas (Collections) and libraries
Tables and Physical files

* Views and logical files

Task 1: Generating SQL from the library in the iSeries Navigator window

In this task, you learn how to invoke the Generate SQL option from your
SAMPLEDBXX library in the iSeries Navigator window to generate the SQL DDL
statement for some objects:

1. Start iSeries Navigator and expand Database-> 1400WS-> Libraries.

You should see the SAMPLEDBXX library in the active library list under the
Libraries icon. If not, add it by right-clicking Libraries and select Select
Libraries to Display. Refer to Task 3, "Displaying properties and
descriptions of DB objects” on page 5, in Lab 1, for information on how to
do this.

2. Click the SAMPLEDBXX library to display the current content in the right
window panel.

3. Click Type in the right window panel to organize all objects.
4. Use the scroll bar to show the Table objects.

5. Press the Ctrl key on the right panel, and locate and select the following
tables:

* ACT
CL_SCHED
DEPARTMENT
« EMP_PHOTO
EMP_RESUME
EMPLOYEE

6. Right-click and select Generate SQL as shown in Figure 54.

54 Database Navigator and Generate SQL in DB2 UDB for iSeries on V5R2



g eries Navigator
File Edit WYiew Help

=10l x|

| Environment: My Connections

% Basic Operations
£ work Management
Configuration and Service

#® Users and Groups

[ Databases
=By 1400ms
=) Libraries
- DDSLIEOL

- MICOLAS

- QiaPL

- QTEMP

- SAMPLEDEIL
- SAMPLEDEOZ
- SAMPLEDEO3
- SAMPLEDE4S
- SAMPLEDESS
----- TEZCMDS

! Add a connection
@ Install additional components

|

- fn Database Mavinator
| f »

E%@@|@|%E|X|@o 0 minutes old
| 1400ws: SAMPLEDBOT  Database: [400ws
Marme | Type | Descripkion | ;I
Table
Table
Table
Open i
Quick Yiew i
3
Description
EHEMPPROIAC b= 3
Create &lias
EHGENSQLOL3 —— 3
Em_TRAY 9 3
Edora E
EFPrOIACT
EFPROIECT 3
ERQaQ0INT m—— e GUERY OPTIONS FILE
EFsaLES 3
=l Cut 3
E==haa) Capy 3
ERTESTX o " =
BREmp pHoTC__ e
b cvc Lo [T FET R S, LI
Create new summary SOL performance monitar g Run an SOL script
ﬁ Create new detailed SGL performance monitor B Map pour databasze
@ Select libraries to dizplay 4 ? Help for related tasks

Generate the SCL used to create this object.

=
4

Figure 54. Selecting objects from the library to generate SQL

When the Generate SQL function is invoked, the new Generate SQL

window appears as shown in Figure 55. This window provides a list of the
objects initially selected and the Output, Options, and Format tabs that are

used for the generated SQL.
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Figure 55. Generate SQL window

7. In the Generate SQL window, click the Output, Options, and Format tabs
to see and accept the default values. Explore the information in this
window and answer the following questions:

* Where will it Generate SQL?
* Which is the Standards Option?
* Which is the Naming Convention?

8. Click Generate to accept the default values as shown in Figure 56.

Note

The initial list of objects in the Generate SQL window could be modified
using the Add and Remove buttons to add new objects or remove
objects from the initial list.
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Generate SOL - 1400ws{I400ws) |

Ohjects for which to generate SCL:

Mame | Library | Type |
ACT SAMPLEDBDM Tahble
CL_SCHED SAMPLEDBD Table Al
DEPARTMENT SAMPLEDBD Table
EMP_PHOTO SAMPLEDBD Table Barmme |
EMP_RESLIME SAMPLEDBD Table
EMPLOYEE SAMPLEDBD Table

utpu | Optians | Format|

& Qpen in Fun SEL Soripts

Generating SCGL
1 yiite o file - 3%

Eile tyme: IDatabase source file ;l
Likrany: jacPL =
Filenarme: |
fermber: |

¥ Append

G]z] ate I Zancel Help |7|

Figure 56. Generating SQL statements

___ 9. Switch to the new Run SQL Scripts window to see the generated SQL
statement. Use the scroll bar to navigate as shown in Figure 57.



155 C\Nicolas', AS-2112Residency’,Piloting DBZ UDE PAT II'S0L Script'GENSOLO1 1.sql - Run SOL Scripks -
Edit ¥iew BRun VisualExplain Monitor Options Connection Help

g =[]

;I Insert |

Mew Cirl+M
Open... Ctrl+0
Save Cirl+S
Print... Cirl+F

ChAMicolasits-2112ResidencyiPiloting DB2 UDB PAT INSQL ScriphGENSQLOT1.sql

GIHBEDOYA@ITSOWS-2112ResidencyisualExplaimSalScriptsiBasiciLab03 Taski2 Sal
GAHBEDOYA@ITSOAS-2112ResidencyivisualExplaimSaLScripts\BasiciLab04 Task0l . SaL
GIHBEDOYA@ITSOWS-2112ResidencyisualExplaimSalScriptsiBasiciLab03 Taski4. Sal
GAHBEDOYA@ITSOWS-2112ResidencyivisualExplainSGLScripts\BasiciLab03 Task03.5aL
GIHBEDOYA@ITSOWS-2112ResidencyisualExplaimSalScriptsiBasiciLab02 Taskil .SalL

Exit

ACTIKWD CHAR(E) CCSID 37 MOT MULL ,
ACTDESC VARCHAR{Z0) CCEID 37 NOT MULL ,
CONSTRAINT SAMPLEDBOVQSYS_ACT_00001 PRIMARY KEY{ACTNO ) ) ;

CREATE TABLE SAMPLEDBO/CL_SCHED (
CLASE_CODE CHAR(Y) CCSID 37 DEFAULT NULL ,
"DAY SMALLINT DEFAULT NULL ,
STARTING TIME DEFAULT NULL ,
EMDING TIME DEFAULT MULL ) ;

CREATE TABLE SAMPLEDBO/DEPARTMENT {
DEPTMO CHAR(3) CCSID 37 NOT NULL ,
DEPTMAME YARCHAR(36) CCSID 37 MOTMULL ,
MGRMO CHAR(E) CCSID 37 DEFAULT MULL ,
ADMRDEPT CHAR(Z) CCSID 37 MOT MULL,
LOCATION CHAR(16) CCSID 37 DEFAULT MULL ,
CONSTRAINT SAMPLEDBOVQSYS_DEPARTMENT_00001 PRIMARY KEY(DEPTNO ) ),

ALTER TABLE SAMFLEDBO1/DEPARTMENT

7

Messages |

Figure 57. SQL generated in the Run SQL Scripts window

___10.After the Run SQL Scripts window is created, explain the reasons for the
ALTER table statements to be added to the create table window.

Note

You can generate SQL for a Schema, Table, Type, View, Procedure
Function, Alias, and Index. When you generate SQL for a table that
contains constraints or triggers associated with it, the SQL Generate is

generated for those as well.

___11.Click File-> Save As... to save the SQL script as shown in Figure 58.
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1% Untitled - Run SAL Scripts - As27
Edit Yiew Bun VisualExplain  Options Connection Help

e Ctrl+M
Open... Cirl+0

Save Ctrl+5

Print... Ctrl+P

CAmMicolasias-1113ResidencyilabHandoutstddvancediGenSampleDBOYa. 540l
CAMicolasias-1113ResidencyiLabhHandouts\WdvancediGenSampleDBOY. sql
CAmMicolastas-1113ResidencyilabHandoutstadvancediSaMPLEDBOT sal
CATEMPITEMP 50l

CATEMPInicksgl.sqgl

CATEMPUah3 =ql

Exit

BIRTHDATE DATE DEFALILT MULL ,

SALARY DECIMALIY, 2 DEFAULT MULL

BOMUS DECIMALG, 23 DEFAULT MULL ,

COMM DECIMALLY, 23 DEFAULT MULL ,

COMETRAINT SAMFLEDBOS.QS3YS_EMPLOYEE_00001 PRIMARY KEY{ EMPMNO 3 3 ;

ALTER TABLE SAMPLEDBOS EMPLOYEE
ADD COMSTRAINT SAMPLEDBOS.RED

FOREIGMN KEY{WORKDEFT )
PEFERFRICES CAMPI EFMANS MEPLRTMERT ¢ HEFTRM

Messages |

Figure 58. Saving the Script SQL

___12.A Save window appears. Click Look in to select your directory

(C:\DBNAV\SQLScript) from the pull-down menu to save your file as shown
in Figure 59.

___13.In the File name input field, type GA\SQ@XX1. In the Files of type input field,

leave the default as SQL files(.SQL) as shown in Figure 59.

You can use the SQL file to replicate your Database files on another
system (for example, a development system). On the GENSQLXXn file
name, the XX refers a your team number and the n is a sequential number.

___14. Click Save to save the SQL script file.

Loak in:

GENSQLOT1.5gl

File name: |GENSQLD11.sqI Save |
Files oftype:  |SGL iles (sql) | cancel |

Figure 59. Saving the SQL script
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___15.Click File-> Exit to close the Run SQL Script window.

Task 2: Generating SQL to PC and data source files on the iSeries server

60

In this task, you generate the SQL statements to a PC file and to a source
member on the iSeries server. You start by generating all the SQL statements of
all the objects in your library from the iSeries Navigator window:

__ 1. Click the SAMPLEDBXX library to display its content in the right window
panel.

__ 2. Right-click the SAMPLEDBXX library and then select Generate SQL as
shown in Figure 60.

& iSeries Navigator
File Edit Wiew Help

@ m B 2R Xy | SEe

| Envitanment: My Connections | 1400ws: SAMPLED
&1-%% Basic Operations d Marne
[]---@ wiark Management DEPT
B Configuration and Service BEeme
- Metwork %EMP ACT
[]-- Security %EMP;CT
F+-if® Users and Groups Brrol
= Databases ATt
=B [400ws bEacTz
=E5) Libraries
----- TR | =
----- QTEMP l".EUI'\I:nTS
_____ -y Explore
----- SAMPLI Epen H 3
_____ SAMPLI reate S Dl’t.CLIt. | PHOTO
_____ SAMPLI Customize this Wiew  » RESLIME
_____ remy]  Generate SO 11
Database b Remave Framn Lisk 1
% SQL Perfor Delete, . 1aC1
[+ %4, Transactior  PEmissions RN
NEW ' (a3 ninluk}
s tasks
B £dd a connection Pashe e nev sumi
(2 Install additional component Paste Definition E new deta
Properties t libraries b

Generate the S0L For this library and all objects within this library

Figure 60. Generate SQL library in the Operation Navigator window

__ 3. Inthe Generate SQL window, select the Write to file option on the Output
tab as shown in Figure 61. The generated SQL is saved to a PC file.
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Generate SOL - I400ws{I400ws)

Ohjects for which to generate SCGiL:

Marme | Library | Type |
SAMPLEDBOT Library i’
ACT SAMPLEDBOT Tahle
CL_SCHED SAMPLEDBOT Tahle
DEFARTMEMNT SAMPLEDBOT Tahle
EMPLOYEE SAMPLEDBOT Tahle
EMPPROJACT SAMPLEDBOT Tahle ll

Output | Optians | Format]
" Openin Run SGL Scripts

&+ Write to file

Add ..

EEmovE |

File type: |PC file =l
Location : IEIF'ATID.SQL ScriphGENSGL012 50l
Generate Cancel Help |7|

Figure 61. Selecting Generate SQL to PC

Click File type and select the PC file option.

In the Location file, click Browse, and then select your directory

(C:\DBNAV\SQLScript) to save your file.

Loakin: |1 SQL Script

GENSQLOT1.5gl
GENSQLOTE.5gl

File name:  |ENS@LO12|sgl aelect |

Files of type: |SQLT’|IES (=gl jSave selected file

6. In the File name input field, type GNSQXX2.SQL In the Files of type input
field, leave the default SQL files (.SQL) as shown in Figure 62.

7. Click the Select button to return to the Generate SQL Output tab.

Figure 62. Saving the SQL script to PC file
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___ 8. Click the Generate button to start generating the SQL DDL statements for
all the objects in the library.

A status window appears showing the progress of the generate SQL as a
percentage as shown in Figure 63.

Generating SQL
| E&

Figure 63. Generating SQL window

9. Inthe iSeries Navigator window, click the Run an SQL script icon in the
database task pad. Explore the SQL file saved previously as shown in
Figure 64.

— Note

The task pad (located in the lower part of the iSeries Navigator window)
was introduced in V5R1. If you click the various higher level options,
such as Security, Users and Groups, Database, etc., this task pad
changes accordingly. One of the database tasks of the task pad is Run
an SQL Script (among others).

B iSeries Navigator
File Edit Wiew Help

g@@|@|éﬂ:ﬁ|><|@@ 4 mnirit
| Enviranment: My Connections | 1400wz SAMPLEDED  Database: 1400ws
[]---% Basic Operations d Marne | Type | Descripkion |
[]---@ wiark Management %DEPT alias
B Configuration and Service BEeme Alias
51 L Metwork Beve_act Alias
gl Security Eempact Alias
=i Users and Groups Brrol dlias
H"'% %t‘?sgzes blacT Index
- ids
; ARCTZ2 Ind
=E5) Libraries N e
_____ oL b wpERT1 Index
_____ QEMP b xpEPTZ Index
_____ < AMPLEDED1 b woEPTS Index
..... SAMPLEDEBODZ l!§><E|'\"'|F‘1 Index
SAMPLEDEO3 b uempz Index
..... SAMPLEDEAS b xEMP_PHOTO Index
..... SAMPLEDESS bR wEMP_RESUME Tndex
----- TEZCMDS — |xpron Index
% Database Mavigator &QXPROJz Indesx
----- b 3L Performance Monitor &Expp@ma Tnides
F+1-5 Transactions 1B osqmru Journal COLLECTION - created by SQL
‘ I ’ fal=ta'hlnl i ninlnk} Ml e Tl L BT TTOAL emmbad bas Tl

_-_ I
B &34 connechon Hinl Create new summary SGL performance monitar o '.‘ an S0L script
(2 Install additional components Bl Create new detailed SOL performance monitar BN MEp mour databasze
@ Select libraries to dizplay b ? Help for related tazhks

Figure 64. Selecting Run SQL script from the Taskpad option

__10.Inthe Run SQL scripts window, click File-> Open to open your SQL Script
file (GENSQLXX2).
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___11.Click Look in and select your directory (C:\DBNAV\SQLScript) from the
pull-down menu to save your file.

___12.Select your GENSQLXX2 file and click the Open button as shown in Figure
65.

Lookin: | S0L Script e | | |:¥| i
GENSQLITT sgl
] GENSQLO12 5gl
GENSQLITE sl

File name: |GENSQLD12.sqI

Open selected file

Files oftype: |SQL files (.sql)

Figure 65. Restoring an SQL script file from a PC

___13.View the SQL statements generated on the Run SQL Script window as
shown in Figure 66. Take some time to analyze the order of the statements.

Once the statements are generated, they can be edited to, for example,
create a new copy in another library and optionally saved, or run using the
SQL Script facility. If multiple objects were selected to be SQL Generated,
you have the option to run one, some, or all of the statements after any
required editing.

63



64

C:*Nicolas'A5-2112Residency*,Piloting DB2 UDB PAT II'S0L Script, GENSQLD12.5q] - Run SOL Scripks - 14
le Edit ¥ew Run YisualExplain  Monitor Options Connection Help

1SS LR PPROS

wf 10§ |

kamples

- Generate SQL

- Version: WARZIMO 0207149

- Generated on: 03722102 10:96:49
- Relational Databasze: [400AS

- Btandards Option: CBZ DB AS400

'REATE SCHEMA SAMPLEDB4S ;
- BAL150C 10 CRTAUT for schema SAMPLEDB44 ignored.

‘REATE TABLE SAMFLEDB4SIACT (
ACTMO SMALLIMT MOT MULL ,
ACTEWD CHAR(E) CCSID 37 NOT MULL ,
ACTDESC VARCHAR(ZO) CCEID 37 MOT MULL ,
COMNSTRAINT SAMPLEDBAS/QSYS_ACT_00001 PRIMARY KEY{ACTNO ) ),

‘REATE TABLE SAMPLEDB45/CL_SCHED (
CLASS_CODE CHAR(T) CCEID 37 DEFAULT MULL,
"DAY SMALLINT DEFAULT MULL ,
STARTING TIME DEFALLT MULL ,
EMDING TIME DEFAULT MULL Y,

‘REATE TABLE SAMPLEDB4S/DEFARTMENT (
DEPTMO CHAR(Z) CCSID 37 NOT MULL ,
DEPTHAME WARCHAR(IE) CCSID 37 MNOT MULL ,
MGRMNO CHAR(E) CCSID 37 DEFAULT MULL
ADMRDEPT CHAR(3) CCSID 37 MOT MULL ,
LOCATION CHAR( B) CCEID 27 DEFAULT MULL
COMNSTRAINT SAMPLEDB4S/QSYS_DEPARTMEMT_00001 PRIMARY KEY{DEPTMNC ) ),

Figure 66. SQL Script Statement generated

___14.Click File-> Exit to close the Run SQL Scripts window. If you made
changes in the SQL script statement, do not save.

You now generate the SQL statement directly to a Source physical file
member on the iSeries server from the iSeries Navigator window using the
File menu.

__15.Click the SAMPLEDBXX library to display the content in the right window
panel.

___16.Click File-> Generate SQL... to view the Generate SQL window as shown
in Figure 67.
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8 i5eries Navigator
File Edit View Help
Explore
Open
Create Shorbout

bR XE | PE e

| 1400wz SAMPLEDBO

Databaze: 1400ws

Customize this Yiew  * fent =] | Mame | Type
Connel&un ko Servers P pnd Service %DEPT Alias
Install Options * Eemp Alias
era l Elemp_acT alias
Remave From List ps %EMPACT Alias
Delete... Brros Alias

Permissions buncTt Inidesx

New R ;L bRwacTz Index

b BEwpEPTY Index

Print WPLEDB1 U0epT2 Indkex

Prink Prewview PLEDEL? l!§><|:)EPT3 Index

Properties PLEDENS bl wEmP1 Index

Close PLEDEAS Rl Evpz Index

: r—AMPLEDESS B wEMPp_PHOTO Index

[ TEZCMDS b xEmP_RESUME Index

% Database Mavigakor | &EXPROH Index

SOL Performance Man t!QXF‘ROJZ Index

: -3 Transactions b prO1AC Index

=2 File Svstems QSQIRN

4

! Add a connection

& Install additional componets

| o8

H ' mcmanminnna

Bk
BH Create new summary SOL performance monitor
ﬁ Create new detailed SOL performance monitor
@ Select libraries to dizplay

Figure 67. Selecting Generate SQL from the File menu

___17.In the Generate SQL window, click the Write to file option in the Output

tab as shown in Figure 68.

Journal

Fimmmin e

___18.Click File type and select the database source file.
___19.Click Library and select your SAMPLEDBXX library.
___20.In the File Name input field, type GENSQXX3. In the Member input field, type

GENSQLXGS.

Note

You can use the SQL file to replicate your schema tables on another
system, such as a development system. For the GENSQLXXn file name,
the XX refers to your team number and the n is a sequential number.

___21.Click the Generate button to start Generate SQL on the iSeries server.

65



Generate SOL - 1400ws{I400ws) |

Ohjects for which to generate SCL:

MHarme | Library | Typ[. |
SAMFLEDBD Library % ﬂ
ACT SAMFLEDBD Table Add
CL_SCHED SAMFLEDBD Table
DEPARTMENT SAMFLEDBD Table T |
EMPLOYEE SAMFLEDBD Table
EMPPROJACT SAMFLEDBD Table -

OUmUTl Optians | Format|
 Open in Run SGL Scripts

& yyrite to file

File type: IDatabase source file ;l
Library: [SAMPLEDB1 =]
File name: JGENSGLOTS
Member: joENSQLOTY

¥ Append

Generate I Cancel Help |‘?|

Figure 68. Generating SQL to the iSeries server

For existing files, the option to append to the file is provided. If an existing
file is selected, and the append option is not chosen, you are asked if you
want to overwrite the existing file.

___22.Double-click GENSQLXX3 to see the script on the iSeries Navigator
window as shown in Figure 69.

€ iSeries Navigator

File Edit Wiew Help

EHEE B e XE | 9ES

| Erwironment; My Connections | | 400wz, SAMPLEDBEOT  Databaze: 1400ws
E-Eg Wark Management = | Mame [ Type
ﬁ' Configuration and Service E=EMP_RESLIME Tahle
Metwork E=EMPLOVEE Table
Security EJEMPPROIACT Table
- Users and Groups e Table
EI---?%&:&I:;;ES EIN_TRaY Table
- s

s E2oRG Table

5-E31 Librari
= {Eﬁl"z :;;L EPROJACT Table
..... OTEMP ERPROJECT Table
----- SAMPLEDEO1 Eoaaam Table
----- SAMPLEDEOZ E=sALES Table
..... SAMPLEDEOS — |E=sTaFF Tahle
..... SAMPLEDE4S E=TEST Table
----- SAMPLEDESS B TEST™ Table
..... TEZCMDS « | |EFHEMP_PHOTO_RESUME View

1| | B <

Figure 69. Selecting the source physical file to show the generate SQL script
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__ 23.Expand the window and use the scroll bar to explore the script file as
shown in Figure 70.

= - =100] %]
File Edit Wiew Fows Help
SRCSEQ SRCDAT SRCDTA ﬂ
1.00 20325 — Generate SCL
2.00 20325 — “ersion: WERZMO 020714
3.00 20325 — Generated on: 03/25/02 14:32:57
4.00 20325 — Relational Database: 14005
500 20325 — Standards Option: DBz LUDE Az/400
G.00 20325 Y
.00 20325 CREATE SCHEMA SAMPLERED
a.00 20325 — S0L150C 10 CRTAUT for schema SAMPLEDBOT ign...
q.00 20325
10.00 20325
11.00 20325 CREATE TABLE SAMPLEDBOACT (
12.00 20325 ACTMNO SkAALLINT MOT MULL,
13.00 20325 ACTEWD CHAR(E) CC3I0D 37 NOT NULL,
14.00 20325 ACTDESCWARCHARZD CCSID 37 NOT NULL,
15.00 20325 COMETRAINT SAMPLEDBOT/OSYS_ACT_00007 PRIM...
16.00 20325
17.00 20325
18.00 20325 CREATE TAELE SAMPLEDBOT/CL_SCHED |
19.00 20325 CLASS_CODE CHAR(Y) CCSID 37 DEFAULT MULL,
20.00 20325 "DAY" ShAALLINT DEFALULT MULL,
21.00 20325 STARTIMNG TIME DEFALILT MULL,
22.00 20325 EMNDING TIME DEFAULT MULL Y
23.00 20325

Figure 70. Exploring the SQL script file from iSeries Navigator

___24.Close the window of the SQL script file to return to the iSeries Navigator
window.

Task 3: Generating SQL from the Database Navigator Map

In this task, you learn how to generate the SQL DDL statement from some and all
objects in a map:

1. Click the Database Navigator to display the maps on the right that exist on
the iSeries server as shown in Figure 71.
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£ AS /400 Operations Navigator
Fle Edit “iew DOption: Help

M=l B3

HER XSG

18 minutes ald

| Erwvironment; My Connections

| 4580 Database Navigatar

(I} M anagement Central [4:27)

| Library ‘ Description

1 Basic Dperations

- BB Work Management

@ Metwork

BB S ecurity

W™ Users and Groups

[ Database

5] Libraries

. 13 vigator

- Hi] SGL Performance Monitors
=2 File Spstems

Backup

+ @ Application Development
-, AFF Manager

=-8f My Connections {1 SAMPLEDEMAPDS
o As27 1 SAMPLEDEMAPDS
BBl 4sB0 1 SAMPLEDBMAROT

SAMPLEDBOS  Database MAP of SAMPLEDBOS
SAMPLEDBOE  Database MAP of SAMPLEDBOE
SAMPLEDBO?  Map of SAMPLEDBO?

elect libraries to dizplay
ﬁ Create new summary SOL performance monitor
B Create new detailed S0OL performance maoniton

tap your databaze

s Fun an SOL script
b} Help tor related tasks

[1-20f 3 objects [

Nl

Figure 71. Opening the Database Navigator Map

2. Double-click to open the database map that you created in the last

exercise. If it does not appear, refresh the window.

w

the map in this window as shown in Figure 72.

File Options  Map  Help

g

e

B zeom [

Refresh Qut
Mar  Show Overview YWindow T Bl ected| Chjhk

HE-/v= o0

Show Objects of Type P
LG Arrange ] :I'

Library: |List of libraties =|

Library Tree | Library Table | Objects In Map |

1] Libraries

-8 @GPL
SAMPLEDBOT
SAMPLEDBOZ
SAMPLEDBO3
SAMPLEDBSS
QTEMP
-8 TEZCMDS

Figure 72. Fitting all objects in a map

Fits all abjects on the map in this window l‘_—‘—

e

B @ -

55 _DEPTH..

XDEPT1 /

XDEPT3 \\\‘ —-

ey

XDEPT2
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Click the View menu and click Zoom-> To Fit Window to fit all objects on




___ 4. Use the toolbar to select the Zoom In and Zoom Out icons to fit the object
size on the map in this window.

__ 5. Use the vertical and horizontal scroll bars to navigate to the top of the map
as shown in Figure 73.

ﬁ'in Untitled* - Database Mavigator - 1400ws{I400ws)

— o =
File Wiew Options Map Help
@ BARAS I s aPpdlc/vs80
Search far Ohjects =
Mame: F\II names vl
Type: IAII types - T
Library: |L|St of libraries vl ot =
RPAR
=
Search | \ /aa’va_EFTl... /
Library Tree | Library Table | Objects In Map | vEpARTHENT aREBEFTR, e
[E3) Libraries / \ =] =]
= ] /w” nsmm\“\
=]
RED PROJECT
& - / \_ BwepRoIT
=
/ﬁQEYS_BIFIO---\A\ ] /qsﬁ'a_ﬁllE... E,
- v
(5 OTEMP B o ewo wwmrmre. o
QEVE_BAPNO ... [
[
QEVE_BUPND... I
QEVE_BAPND...
EMP_PHOTO
- | »f

Figure 73. Showing all objects included in the map

___ 6. Use the criteria selection in the locator pane and select only your

SAMPLEDBXX library. Click the Library parameter and select it as shown
in Figure 74.

__ 7. Click the Search button.
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itled™ - Database Mavigator - 1400ws{I400ws

File Wiew Options Map Help

IFEHS BARAAD I s AR RV FE

Search for Ohjects

Marme: JAll names =
Type: IAllh,rpes ;l
Library: |5AMPLEDBD =

Library Tree | Library Table | Objects In Map|

[_@ Libraries
-/ SAMPLEDBO

=

i
GEVE_BIFND...

T

BUP_RESUME
‘-\\ e

QEYE_BMPNO ...

Figure 74. Selecting only your sample library to appear in the Database Navigator Map

__ 8. Click the plus (+) sign next your SAMPLEDBXX database to see the
objects found, such as Tables, Indexes, and Views.

___ 9. Click the (+) sign next to the Tables database object to expand it.
___10.Double-click the EMPLOYEE table in the list of tables to find this table in

the map.

__11.Click the zoom icons (Zoom in, Zoom out, and Zoom to fit window) from
the toolbar to focus the EMPLOYEE table in a Map Pane.

___12.Right-click the EMPLOYEE table and select Generate SQL as shown in

Figure 75.
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Figure 75. Generating SQL of a specific object from the map

___13.In the Run SQL Script window, explore the generated SQL statements,

using the scroll bar to navigate as shown in Figure 76.
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%53 Untitled - Run S0L Scripts - I400ws(I400ws]) *

File Edit Yiew Run “isualExplain  Monitor Options Connection  Help

BFE f DRB PFDIOO way @

Examples I
- Generate SQL

- Version: WARZIMO 0207149

-- Generated on: 03726002 11:03:15

-- Relational Database: |400AS

-- Btandards Option: CE2 DB AS400

CREATE TABLE SAMPLEDBO1/EMPLOYEE
EMPMNO CHAR(E) CCSID 37 MOT MULL ,
FIRSTHME ¥ARCHAR{12) CCSID 37 MOT MULL
MIDINIT CHAR(T) CCSID 37 MOT MULL
LASTHAME WARCHAR{ 8) CCSID 37 NOT MULL
WORKDEPT CHAR(3) CCSID 37 DEFAULT MULL
PHOMEMND CHAR(4) CCSID 37 DEFAULT MULL
HIREDATE DATE DEFAULT MULL ,
JOB CHAR(S) CCSID 37 DEFAULT MULL ,
EDLEVEL SMALLINT MOT MULL
SEX CHAR(1) CCSID 37 DEFAULT MULL,
BIRTHDATE DATE DEFALULT MULL ,
SALARY DECIMALLY, 20 DEFAULT MULL ,
BOMUS DECIMALLG, 2) DEFAULT MULL ,
COMBM DECIMALY, 23 DEFAULT MULL
COMSTRAINT SAMPLEDBO1/GQEYE_EMPLOYEE_D0001 PRIMARY KEY{ EMPMO 3,

ALTER TABLE SAMPLEDBO1/EMPLOYEE

ADD COMSTRAINT SAMPLEDBO1/RED

FOREIGM KEY({WORKDEPT )

REFEREMCES SAMPLEDBOVDERARTMENT { DEPTMO )
OM DELETE SET MULL

OMNMUPDATE MO ACTION ,

ALTER TABLE SAMPLEDBOVEMPLOYEE
ADD COMETRAIMT SAMPLEDBO1/NUMBER
CHECK{ PHOMNEMNQ =='0000" AMD PHOMEMNC =="9999") ;

Figure 76. Generating SQL from the employee table

You can see that two Constraint rules were generated in addition to the
EMPLOYEE table. One of them, the Referential Constraint Key, is
represented as RED in the map to show the relationship between the
EMPLOYEE and DEPARTMENT tables as shown in Figure 77.
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Figure 77. Showing a Referential Constraints Key in the map

___14.Click File-> Save As... to save the SQL script as shown in Figure 78.
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Exit

PN ENUL AR O T DAL T VUL
HIREDATE DATE DEFALLT MULL

JOB CHAR(B) CCSID 37 DEFAULT NULL
EDLEVEL SMALLINT MOT MULL,

SEX CHAR(1) CCSID 37 DEFAULT MULL ,
BIRTHDATE DATE DEFAULT MULL ,

SALARY DECIMALLS, 2) DEFALULT MULL
BONUS DECIMALLG, 23 DEFAULT MULL,

COMM DECIMALLS, 23 DEFAULT MULL

ALTER TAHLE SAMPLEDBO1EMPLOYEE
ADD COMSTRAINT SAMPLEDBO1/RED
FOREIGN KEY{WORKDEFT )
REFEREMCES SAMPLEDBO1/DEFARTMENT (DEPTMO )
OMDELETE SET MULL
ON UPDATE MO ACTION ;

ALTER TABLE SAMPLEDBO1/EMPLOYEE
ADD COMETRAINT SAMPLEDBO1MNUMBER
CHECK{ PHONEMNGC =="'0000" AMD PHONEMNO == '9999");

CONSTRAINT SAMPLEDBO1/QSYS_EMPLOYEE_00001 PRIMARY KEY{ EMPMO ),

Messages |

Figure 78. Selecting save Script SQL

___15.0n the Save window, click Look in to select your directory

(C:\DBNAV\SQLScript) from the pull-down menu to save your file.

___16.In the Name input field, type GENSQXX4. In the Type input field, leave the
default SQL files (.SQL) as shown in Figure 79.

___17.Click Save to save SQL script file.

Look in: 1501 Script

= &) o o

GENSQLOTT sgl
GENSQLIT 2 sgl
GENSQLOTT sgl
GENSQLOTE. gl
GENSQLOTE.sgl

File name:  [GENSGLO14sgl

Save |

Files of type: |SQL files (.sql)

;l Cancel |

Figure 79. Saving the SQL script

__18.Click File-> Exit to close the Run SQL Script window.
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___19.Switch to the Database Navigator window. You are now going to generate
the SQL statement for all objects in a library.

__20.Click Map-> Generate SQL-> All Objects... to generate the SQL
statement for all objects in your library as shown in Figure 80.

sim SAMPLEDBMAPOS - Database Mavigator - As27

File “iew Options l@a Help

s He B = S
T  Create 4 == =101 pe— - - -
- = Generate and show creation SGL for all objects in ma -
Searchfort  Delete Map... Wisibleomrerts I ! p| I—
MName: Il harmes ;I
Type: |Alltwaes vl EMP_RESUME EMP_PHO"
Library: ISAMPLEDEIDS vl ﬁ? v
QSYS_EMPNO..  QSYS_EMF
Library Tree | Library Table | Objects In Map |
| Libraries =
=) SAMPLEDBOS
--[ Tables
[0 DEFARTMENT
[SREEERE P L O EE] -
C E-A Indexes =l | | »
|20 0f 65 ohjects in map are visikle. |

Figure 80. Generate SQL for all objects in a library.

A status window appears showing the progress of the generate SQL as a
percentage (Figure 81).

Generating SCQL
N

Figure 81. Generating the SQL window

___21.In the Run SQL Script window, use the scroll bar to navigate to see the
generated SQL statements.

__22.Explore all the generated statements and enter the order in which they

were created (example, views, constraints, tables, Schema, alias....) in
Table 3.

Table 3. SQL Generate order

SQL statements Objects
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__ 23.Click File-> Save As... to save the map.

___24.In the Save window, click Look in to select your directory
(C:\DBNAW\ASQLScript) from the pull-down menu to save your file.

__25.In the File name input field, type GENS@LXX5. In the File of type input field,
leave the default as SQL files(.SQL).

__26.Click Save to save the SQL script file.
__ 27.Click File-> Exit to close the Run SQL Script window.

__ 28.Return to the iSeries Navigator main window.

Task 4: Generating SQL from DDS

The generate SQL function works with objects created using SQL and using
DDS. These objects can also be reverse engineered into an SQL create
statement.

However, there are options that allow the user to specify that the generated
statement should adhere to certain standards. Depending on the standard
selected, some objects created through native OS/400 interfaces may not be
compatible for use with this functions.

In this task, you generate the SQL statements for physical files that were created
using a DDS source file member. You use the DB2 UDB Family standard to
generate this SQL statement.

—— Comment

The objective of this exercise is to combine Generate SQL with the Database
Navigator feature. You create two maps of the same schema while following
different steps.

DDS (PF) DDS (PF)
DDSLIBxx DDSLIBxxh
SQLl DDL Generate
l MAP
Create l
SCHEMA ——» Generate _ » Compare MAPS
DDSLIBXxC MAP 27?7

Figure 82. Generate SQL and Database Navigator combined

__ 1. Click the plus (+) sign next to the Libraries object to expand the list of
libraries.

__ 2. Change the list of libraries in iSeries Navigator to include the DDSLIBXX
Library. Refer to the first step in Task 3, "Displaying properties and
descriptions of DB objects” on page 5, in Lab 1.
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__ 3. Click DDSLIBXX (on the right side of the window).

___ 4. Right-click the DDSLIBXX library and select Generate SQL as shown in
Figure 83.

eries Mavigator
File Edit Wiew Help

addE B iR2e XE | 9ES

Erwironment; My Connections | |400ws; DOSLIB0OT  Database; [400ms
@ Management Central (I400ws) | | Mame I Type
E|---.:, My Connections EaUDITFIL Table

- @ Asizb EECTLFILE Table

B ns23 ECUSTOMER Table
B Astha E=[] Table
=@ 100ws , E=SCRDERDTL Table
i3 Basic Operations EEORDERHDR Table
£3 Work Management ErroDpic Tahle

ﬁ' Configuration and Service
£ Netwark ERQCLISRC Table
B8 Security =[elul=T Table
@™ Users and Groups EQmpsRe Table
I Databases BEqcsre Table
=By 1400ws E=qDDSsRC Table
=) Libraries EqsqLske Table

----- ool

lllll L xplore

..... TEN Open

3 camp  _reate Shortout
Customize this Wiew »

Generate SQL. ..

Rettgree From Lisk

Delete. .
Permissions
Dakabase " N
----- soLPerf o
[]--ﬁ‘g.\ Transacti  paste
[#-aZ, File Systems Paske Definition
(] Backup
1| Propetties

Figure 83. Selecting physical files to generate an SQL statement

window.

posted in the working area as shown in Figure 84.

7. Use the vertical scroll bar to explore the SQL statements.

5. Leave the default options. Click the Generate button in the Generate SQL

6. The SQL Script Center appears with the generated SQL DDL statements
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%3 Untitled - Run 5QL Scripts - 1400ws

File Edit View Run VisualExplain Options Connection Help

RS L REB PFDIO O | ey @
Examples

- Generate SQL

- Wersion: WARTMO 010525

- Generated on: 02523001 13:40:44

- Relational Database: RCHASM2Y

- Standards Option: DBz UDB AS400

CREATE SCHEMA DDSLIBHY,
- SQL150C 10 CRTAUT for scherma DDSLIBXK ignored.

CREATE TABLE DDSLIBALALUDITFIL |

-~ SQL1509 10 Format name AUDITFILR for ALUDITFIL in DDSLIBRX ignored.
SEMBR CHARTO) CCSID 37 WOT MULL DEFALLT
CUSHBR CHARS) CCEID 37 MOT MULL DEFALULT "y,

LABEL O TABLE DDSLIEAR ALDITFIL
|5 ‘Audit file for invalid orderhdr insersiupdates’;

LABEL ON COLUMMN DDELIBX A AUDITFIL
{ SRMNBR TEXT IS "SALESREP_NUMBER",
CUSMBR TEXT IS 'CUSTOMER_MUMBER']) ;

CREATE TABLE DDSLIBRA.CTLFILE |
MUMREC DECIMALS, 0y NOT MULL DEFALULT O},

CREATE TABLE DDSLIBHA.CUSTOMER (

CUSTOMER_MUMBER FOR COLUMM CUSNBR  CHAR(S) CCSID 37 MOT MULL DEFAULT ™,
CUSTOMER_MAME FOR COLUMMN CUSMAM  CHAR(ZO) CCSID 37 MOT NULL DEFAULT ",
CUSTOMER_TELEFHOMNE FOR COLUMN CUSTEL  CHAR{15) CCSID 37 MOT MULL DEFAULT ™,
CUSTOMER_FAX FOR COLUMMN CUSFAX  CHAR(15) CCSID 37 MOT MULL DEFAULT ",
CUSTOMER_ADDRESS FOR COLUMMN CUSADR CHAR{ZO) CCSID 37 MNOT NULL DEFAULT ",

II
Figure 84. Exploring SQL script generated from a physical file

— Note

Previously, you generated SQL statements that can recreate your
existing database (for example, on another iSeries server). In this case,
you are going to recreate an existing database on the same iSeries
server. For this reason, you must change the schema (database) name
from DDSLIBxx to DDSLI BxxC. There are some DDS-specific keywords
that cannot be converted to SQL. This appears in the code as messages
(see SQL150C and SQL509 in Figure 84).

__ 8. Click Edit and select Replace. A Replace window like the one shown on
Figure 85 appears.

Replace
Find what: Find Masxt
|PDSLIE

Replace |
Replace with:
|D DS LB RepIEceAII |
[ Match case Cancel |

Figure 85. Replace window
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9. Review all of the SQL statements. Before you run the script to generate the
new schema (DDSLIBxxC), you must move the ALTER TABLE ORDERDTL
statement to follow the CREATE TABLE ORDERHDR. You must do this
because, in the ALTER TABLE statement, you are trying to define a
Referential Integrity constraint, which involves ORDERHDR, that has not
been created yet. For this reason, you must move it after the creation of the
ORDERHDR table. Figure 86 shows the ALTER statement that you must
move to appear after the CREATE TABLE ORDERHDR.

DERHDRMIIM

RDERHDR ( ORDER_MUMBER )

CREATE TABLE DDSLIBO2C.ORDERHDR |
ORDER_MUMBER FOR COLUMM ORHMBR  CHAR(S) CCEID 37 NOT MULL DEFALULT ",
CUSTOMER_MUMBER FOR COLUMMN CUSHNBR  CHAR(S) CCSID 37 NOT MULL DEFAULT ™,
ORDER_DATE FOR COLUMM ORHDTE  DATE MOT MULL DEFAULT CURREMT_DATE ,
ORDER_DELIWERY FOR COLUMM ORHDLY  DATE MOT MULL DEFAULT CURREMNT_DATE
ORDER_TOTAL FOR COLUMMN ORHTOT  DECIMAL{T1, 2) MOT NULL DEFAULT O,
ORDER_SALESREFP FOR COLUMM SRMNBR  CHAR{10) CCSID 37 NOT MULL DEFAULT *,
COMETRAINT DDSLIBOZC.ORDERHKEY PRIMARY KEY({ ORDER_MUMBER ) ) ;

ALTER TABLE DDELIBOZ2C.ORDERHDR
ADD COMSTRAINT DDSLIBOZ2C.ORDERHDRCMBR
FOREIGMN KEY{ CUSTOMER_MUMBER )
REFEREMCES DDSLIBOZ2C.CUSTOMER { CUSTOMER_MNUMBER )
OM DELETE RESTRICT
On UPDATE RESTRICT

Figure 86. Altering a table after table creation

___10.Click the Edit->Cut and Edit->Paste options to move the text.

___11.Run all the SQL statements and verify that they run successfully. You just
created a schema (DDSLIBxxC) from the SQL statements that you created
from the original DDS created database (DDSLIBxx).

___12.You now create a Database Navigator Map of the generated SQL DDSLIB.
In the main iSeries Navigator window, expand the Database icon.

___13.Right-click the Database Navigator object and select New to create a new
map.

___14.Use the criteria selection in the upper locator pane to select your new
schema (DDSLIBxxC).

___15.Click Search to execute. The result appears on the bottom pane under the
Library Tree and Library Tables tabs.

__16.Click the plus (+) sign next to your DDSLIBxxC schema to show objects,
such as Tables, Indexes, and Views.

___17.Click the (+) sign next to the Tables object to expand it.

__18.Double-click the CUSTOMER table on the lower locator pane to start
building a map. This table is added to the map and all of the related objects
as shown in Figure 87.
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T EHRBARS | T dma | sPdBe-vEyaS

Search for Objects =
pinames ]
artpes 5

Lirary Tree | Library Table | objects In Map |
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FRODPIC
-0 QCLISRC
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=00 QCsre
|I|:| QDDSERC
=-00 QSALSRC
- Indexes
-4 views

Tl

4 >
|5 of 8 objects in map are visible. | JMad

Figure 87. Map of DDSLIBxxC

__19.Click File-> Save As... to save the Map.

___20.From the Save As... window, click the Libraries parameter and select your
DDSLIBxxC library from the pull-down menu.

__21.In the Name input field, type DDSLI BxxMAR
___22.In the Description input field, type Map created for the DDSLI BxxC
___23.Click OK to save the map.

Task 5: Generating a map from DDS

In this task, you learn to generate a Map from a DDS-created database. Then you
generate the SQL statement from the Map.

___1. Inthe left panel of the main iSeries Navigator window, expand Database->
[400WS-> Libraries.

___ 2. Double-click your DDSLIBXX library. All the objects in this library appear in
the right panel.

___ 3. Right-click the Database Navigator object and select New to create your
Map as shown in Figure 88.
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¥# iSeries Navigator
File Edit WYiew Help
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Environment: My Connections | 1400ws: DDSLIBOT — Database: |400ws
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ERAUDITFIL Table Audit file For invalid orderhdr insertsjupdates
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B Eztn:\jg::ation and Service E=PRODPIC T able
Bl Security [E==[elaic e Table SOURCE PR FOR ALL CLI PGMS OF ORDER. ...
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Figure 88. Creating a map from physical files

___ 4. Use the criteria selection in the upper locator pane to select only your
DDSLIBXX library. Click the Library parameter and select your library.
Refer to the second step in Task 2, "General tasks using the Database
Navigator window” on page 17, in Lab 2.

5. Click Search to execute. The results appear on the bottom pane under the
Library Tree and Library Tables tabs.

6. Click the plus (+) sign next to your DDSLIBXX database to show the
objects found, such as Tables, Indexes, and Views.

Click the (+) sign next to the Tables database object to expand it.

8. Double-click the CUSTOMER table in the lower locator pane to start
building a map. At this time, this Table is added to the map and all related
objects.

9. Use the toolbar to select the Zoom In and Zoom Out icons to fit the object
size on the map in this window.

___10.Use the vertical and horizontal scroll bars to navigate to the top of the map
as shown in Figure 89.
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Figure 89. Displaying a map from physical files

___11.Take a few moments to analyze the map. Compare it with the one you
created in the previous task (GENSQLxx6). Are the maps the same?

___12.As an optional step, generate an SQL statement from a the map and
compare the SQL statement with the one generated in Lab 2, “Database
Navigator: General tasks” on page 9.

You have now completed this lab!
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