Chapter 3


The Windows 95 User Interface





When you first boot Microsoft Windows 95, you know immediately that the old world of Windows running on top of MS-DOS is no more. Gone are the character-mode boot messages that held meaning only for a very small minority of computer users. Instead, you are graphically carried to the desktop of the new Windows 95 user interface (UI).


More than any other part of the operating system, the UI defines the user’s overall experience. The easier, more powerful, and more compelling the UI, the better the user feels about computing and the more productive the user is likely to be. A great UI helps the computer industry grow because it makes computing easier and more natural for all people, from the novice user to the power user.


This chapter discusses the design process that produced the UI in Windows 95 and then introduces the components of the UI, organized into the following categories:


·	Easy. Outlines UI features that make Windows 95 easy to learn and use, especially for those new to Windows.


·	Powerful. Outlines UI features that make Windows 95 more powerful, efficient, and customizable for the experienced Windows user.


·	Compatible. Outlines UI features that make Windows 95 easy to learn and to use for those familiar with Windows 3.1.


Designing the Windows 95 User Interface





�xe “"UserInterface:objectivesfor "�The overarching goal of the UI in Windows 95 is to make PCs even easier to use for all people. Fulfilling this goal is a challenge because different people work in very different ways. Novices want learning how to perform a task to be easy, even at the expense of efficiency. However, experienced users want to do more with their PCs, and they want efficiency and flexibility. In addition, users upgrading from Windows 3.1 want to make the transition without throwing out everything they have already learned.


Windows 95 meets these disparate needs by being scaleable—that is, by being able to fit the proficiency and preferences of the individual user. For novices, the most common and essential features of Windows 95, such as launching an application, task switching, and finding a file, are easily “discoverable” via the taskbar, with its Start button and push-button task switching. For experienced users, Windows 95 promotes efficiency, customizability, and control via such power-user capabilities as the Windows Explorer, rich secondary mouse-button clicking, property sheets, and shortcuts.


Design Methodology


The UI in Windows 95 was not constructed from a blueprint drawn from a master specification. It started with clear objectives, guiding design principles, and a skilled team. The design process started with the basic question, “How can the UI in Windows 3.1 be improved?” That question launched a continuous cycle of discarding old ideas, conceiving new ideas, and learning—a constantly iterating design-usability test-redesign loop like the one shown in Figure 2.


	�


Figure 2. The design loop of Windows 95


Improving the Windows 3.1 User Interface


�xe “"UserInterface:improvingWindows3.1 "�There was no shortage of information about how the Windows 3.1 UI might be improved. The table on the following page summarizes key findings.


The following mechanisms were used to compile this feedback data:


·	Usability tests. �xe "Usability testing"�The Microsoft Usability Lab, described on the following page, is primarily used for testing usability of new designs. However, to better understand how people use Windows 3.1 and to establish a baseline, several phases of testing were dedicated to Windows 3.1.


·	Focus groups. Several focus groups were conducted with different levels of users to identify the problems people have with Windows 3.1.


·	Educator feedback program. A team of UI designers and testers visited 12 independent software education companies. More than any other group of users, software educators understand the everyday usage challenges faced by novice and intermediate users. The educators were asked questions such as, “What are the five hardest tasks for students to learn in Windows?” and “What five changes would you make to Windows to make it easier to learn?” The educators also tested prototypes of the UI in Windows 95.


·	Suggestion database. Thousands of UI suggestions from Windows 3.1 users and corporate customers were compiled and analyzed, along with beta-tester UI feedback.





How Can the Windows 3.1 UI Be Improved?�
�
Make It ...�
Problem Areas�
�
Easier to learn for novices�
·	Window management (overlapping and minimized windows) is confusing.


·	Hierarchical views (like those in File Manager) are confusing.


·	Double-clicking to launch applications is not discoverable.


·	Task switching is not discoverable. As a result, many users never run multiple applications.�
�
More efficient and customizable for experienced users�
·	There is too much “middle management,” with confusing and overlapping functionality between Program Manager, File Manager, Print Manager, Windows Setup, and Control Panel.


·	8.3 filenames are restrictive.


·	The UI is not customizable.


·	Network and connectivity integration is poor.�
�
Putting New Designs to the Test


�xe "Usability testing"�Conducting extensive live tests in a variety of settings with a variety of subjects has been key to engineering a state-of-the-art UI. A large portion of the total development budget of Windows 95 has been expended on this critical activity, and Windows 95 is probably the most usability-tested product ever. The following methods have been used to test the UI in Windows 95:


·	Formative testing in the Usability Lab. Conducted primarily in the groundbreaking Microsoft Usability Lab, formative testing collects data as test subjects perform specific tasks, such as launching a program, finding a file, and installing a printer. The Usability Lab has nine testing suites, each with a one-way mirror, cameras, and other equipment for observing and recording users as they work. Central to the Lab’s operations is online data-collection software that helps specialists collect cognitive and quantitative process data as subjects work through the sets of tasks.


	Usability tests are observed firsthand by the design team and are essential in future designs. At the time this guide was being written, more than 1000 hours of usability testing in 48 phases with more than 400 participants had been conducted. The experience of test subjects has ranged from novice users to intermediate/advanced users, so the test results focus on new computer users as well as users familiar with Windows.


·	Summative testing. Conducted at customer sites and in the Usability Lab, summative testing involves testing the UI as a whole with real users over longer periods of time.


·	UI-expert and industry-expert review. In the fall of 1993, a panel of UI experts and industry experts was assembled to review and critique the UI in Windows 95. In addition, four independent consultants each spent large blocks of time with Windows 95 and gave extensive feedback.


Easy to Learn





This section describes the features of the UI that are designed to make learning Windows 95 easy for novices.


The Desktop: Neat, Clean, and Logical


After users start their computers, they are presented with the Windows 95 desktop shown in Figure 3. It’s neat and clean and displays only a few graphical objects.
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Figure 3. The desktop


The simplicity of the desktop appeals to all users’ sense of organization, but it also serves to focus the novice user on the following essential elements:


·	The Taskbar. Users can quickly start a program or open a document by clicking the Start button. And they can easily switch between tasks.


·	My Computer. Browsing a PC is now logical and easy.


·	The Network Neighborhood. In the world of mapped drives and complex interfaces, users can’t browse their network. With the Network Neighborhood, they can easily browse the network, regardless of which network provider (such as Windows NT Server, a NetWare server, or Windows 95 itself) is being used.


·	The Recycle Bin. The Recycle Bin allows users to recover deleted files and easily return them to their original location on the local system.


The Taskbar: Home Base


�xe “"UserInterface:theTaskbar "�More than any other feature, the taskbar, which is shown in Figure 4, exemplifies the order-of-magnitude improvement in ease of use and ease of learning of the UI in Windows 95. It is the UI’s anchor. Its mission is to make 95 percent of what a typical user wants to do with the operating system easy to accomplish at all times. The taskbar started out specifically as a program launcher and task switcher for novices. However, because of its simplicity and power, the taskbar is also popular with experienced users, who can take advantage of its many other capabilities.
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Figure 4. The Taskbar


The two key features of the taskbar are the Start button and push-button task switching, which are examined in the next two sections.


The Start Button: Up and Running in Seconds


�xe “"UserInterface:theStartbutton "�Usability tests on Windows 3.1 have shown that launching Write takes a new Windows user an average of nine minutes. With Windows 95, launching WordPad takes a new user an average of three minutes. If only the users that launch WordPad via the Start button (rather than by another means) are counted, the average launch time drops below one minute!


The main reason for this dramatic 3x–9x speed improvement is the Start button, which is shown in Figure 5. Without knowing about double clicking or complex hierarchies, a novice user of Windows 95 can quickly launch a program and get to work.
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Figure 5. The Start button and its menu


However, the Start button is much more than a super-efficient program launcher. Its capabilities include the following:


·	Programs. The Start button’s Programs menu allows users to quickly launch programs. This menu is the equivalent of Program Manager in Windows 3.1, and in fact, when a PC running Windows 3.1 is upgraded to Windows 95, the contents of the program groups in Program Manager are transferred to the Programs menu.


·	Documents. �xe "Documents:opening from the Start button"��xe "Settings:accessing from the Start button"�The Start button’s Documents menu contains a list of the last 15 documents opened. This menu provides very quick access to the information most recently worked with and helps prevent time-consuming and frustrating browsing. It also helps users think of their work in terms of documents (a concept known as document-centricity), rather than applications.


·	Settings. The Start button’s Settings menu allows users to quickly change or view the PC’s settings and options, including the Control Panel (for computer settings)�xe "Control Panel:access from the Start button"�, the Start menu, and the Printers folder. It also allows users to customize the Taskbar to suit personal working preferences—for example, to specify which programs should be included on the Start button’s Programs menu.


·	Find�xe "Find:searching for information in Windows 95"�. The Find item in Windows 95 goes far beyond the Search feature of File Manager in Windows 3.1. Searches do need not conform to the *.* searching syntax, and criteria such as last modification date, size of file, and actual text within a document can be used to find information.


·	Help. Help has been overhauled in Windows 95 and is easily accessible via the Start button.


·	Run. The Start button’s Run item provides enhanced command-line type functionality.


·	Shutdown. The Shutdown item provides easily accessible and safe shutdown, restart, and logoff.


Task Buttons: Task Switching Made Simple


�xe "Taskbar:task switching"�Novices need to have powerful features presented to them in a simple and compelling way; otherwise they won’t use these features. Research conducted with active Windows users indicates that fewer than 50 percent frequently use more than one application at a time and only 20 percent frequently use alt+tab task switching. These powerful features of Windows 3.1 are simply not discoverable.


�xe "Taskbar:objective for"�The objective of the taskbar is to make switching among multiple applications as simple as changing channels on a television set. Every open window has a button on the taskbar, allowing the user to see which documents and applications are currently open. Switching applications is a simple matter of selecting the desired “channel” on the taskbar. No more minimized program icons; no more disappearing windows. The user can see all the active tasks simply by looking at the taskbar, the TV Guide of Windows 95. When a task is minimized into the taskbar or maximized from the taskbar, animation helps new users understand “where” the task goes.


�xe "Taskbar:task buttons"�Task buttons resize themselves automatically depending on the number of active tasks. If the buttons get too small to be useful, the user can customize the taskbar. In fact, a host of other taskbar configuration�xe "Taskbar:customizing the configuration"� options allow the user to customize it in other ways, including the following:


·	Reposition. The Taskbar can be dragged to any perimeter position on the screen.


·	Resize. The width of the Taskbar can be widened by dragging its inside edge.


·	Auto Hide. The Taskbar can be hidden and made to appear on the screen only when the mouse hits the screen edge, by selecting Settings and then Taskbar from the Start menu.


�xe "Task switching:improvements to "cool switch""�In addition to making task switching dramatically easier and more accessible via the taskbar, the UI in Windows 95 includes an updated version of the familiar alt+tab “cool switch.” It now displays an iconic road map of all active tasks to prevent users from getting lost in an infinite alt+tab loop, as was common under Windows 3.1.


Try It!


Customize the Start Button


1.	Click Start, and then Settings, and then Taskbar.


2.	On the Change Start Menu property sheet, select the programs you want to appear either at the Start button’s first level or on the Programs menu.


3.	Close the property sheet and check your new configuration by clicking the Start button.


Hint: You can also add a program to the Start button by dragging a shortcut defined for the program to the button.


Test a Novice


1.	Find a stopwatch and a friend or family member who is a computer novice.


2.	Sit the novice down at a PC that is running Windows 95 with no programs loaded and a clean desktop.


3.	Ask the novice to start an application that you know is listed on the Programs menu. Note the time taken to successfully start the application.


4.	Try the same task on a PC running Windows 3.1.


5.	Compare the times to complete the task. The time using Windows 95 should be the same or faster than the time using Windows 3.1.


Display the Start Menu


·	Press ctrl+esc, and the Start menu pops up.


My Computer: An Easier Model �for File Management and Browsing


�xe "Browsing:not intuitive in Windows 3.1"�File management and browsing in Windows 3.1 are not intuitive. Fewer than 55 percent of Windows users regularly use File Manager, and File Manager is especially confusing and intimidating for novice users.


�xe "Browsing:discoverable in Windows 95"�Designing a discoverable and comfortable model for browsing and file management for the novice user has been a priority for the UI design team because of the observed difficulties with Windows 3.1. Several significantly different designs have been tested and thrown out. In the course of this testing, the design team made the following discoveries about basic file management and browsing:


·	Exposed hierarchies are intimidating and un-intuitive.


·	Dual-pane views—hierarchy on the left and contents on the right—are also intimidating and un-intuitive. Novices have difficulty understanding the connection between the logical tree hierarchy pane and the contents pane.


·	An object-oriented UI works well for basic tasks but not for complex ones. The general belief is that the more object oriented a UI is, the easier it is to use. However, this is not the case. Although the direct manipulation of screen objects to achieve logical results is important for basic tasks (such as dragging a file from a folder to the desktop), direct manipulation to carry out more advanced tasks (such as dragging a file to a printer icon) is not intuitive. On the other hand, selecting an object with the mouse and then browsing menus or buttons for actions to perform on that object is intuitive.


·	Large icon views are much more comfortable than list views.


·	Whether novice users can find what they are looking for and whether they feel comfortable and “grounded” along the way are the defining characteristics of a good browsing experience. Efficiency and speed are less important.


The My Computer default browsing model is the result of this testing. A folder or drive can be opened by double-clicking it, or by selecting it and choosing Open from the File menu. The default browsing model brings up a new window in large icon view, as shown in Figure 6.
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Figure 6. Browsing My Computer


To many advanced users this behavior seems cumbersome. “Why not open in list view?” they ask. “Why create a new window that just clutters up my screen?” “Why not open in a dual-pane view? It’s much more efficient for me.” “Why not turn the Toolbar on by default?” All of these possible default models and more were tested thoroughly and discarded because they caused confusion and stress for novices. Novices respond best when they are presented only with essential information and when they can easily “get back” to where they just were, so the default model was designed to meet these needs.


(Experienced users can select from multiple configuration options by choosing Options from the View menu. Also for experienced users, Windows 95 has a very powerful dual-pane browsing application called the Windows Explorer. In addition, File Manager from Windows 3.1 is still available and can be run for backward compatibility.)


The new capabilities of the default browsing model should not be overlooked in this discussion of simplicity. �xe "Folders:folders within folders"�Folders can be created within folders. Files and folders respond logically to being dragged and dropped. Files and folders can be cut, copied, and pasted just like text and objects within applications can. Views can be customized, and each window “remembers” how it was last configured and opens automatically in that view. The best way to discover the capabilities of the default browsing model is to explore it, or better yet, watch a novice user explore it.


Try It!


Browse Folders with a Single Window


1.	Double-click My Computer.


2.	From the View menu, choose Options. On the Folder property sheet, select the Browse folders with a single window that follows you as you open each folder option.


3.	Turn on the Toolbar by choosing Toolbar from the View menu.


4.	Now double-click the icon for your hard drive. No new window opens.


Long Filenames: Greater Flexibility�When Naming Files


�xe "Long file names:usability benefits"�By far the most-requested file system feature since Microsoft first released MS�DOS is support for long filenames, but until Windows 95 long filenames have not been possible. Windows 95 allows filenames of up to 255 characters. An example is shown in Figure 7. Eliminating the need to conform to the 8.3 naming convention results in obvious and large gains in usability. However, to ensure backward compatibility with existing MS-DOS and Win16–based applications, extensions have not been eliminated entirely; they are simply hidden from view by default.
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Figure 7. A sample long filename


�xe "Files:renaming filenames"�Files can be renamed in place in Windows 95 by selecting the file, clicking the filename, and typing the new name. The hidden file extension is not affected when a file is renamed. Files can also be renamed from within the new common dialog boxes, including the Open and Save dialog boxes.


Try It!


Display the File Extensions


1.	From any folder, choose Options from the View menu.


2.	Select the View tab.


3.	Deselect the checkbox for the Don’t display MS-DOS file extensions for files that are properly registered option.


The Network Neighborhood:�Accessing Networking Features


�xe "Network Neighborhood:browsing networks is easy"�This section discusses how the network client in Windows 95 makes browsing networks not only possible but easy, regardless of the network provider (Windows NT Server, Novell NetWare, Windows 95, and so on). For more details about the networking capabilities of Windows 95, see Chapter 9, “Networking.”


Network browsing is accomplished by means of the Network Neighborhood�xe "Network Neighborhood:icon in the Windows 95 UI"�, which sits on the desktop and logically represents the resources not available via My Computer. Its icon is shown in Figure 8.
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Figure 8. The Network Neighborhood icon


Browsing the network via the Network Neighborhood is as easy as browsing a local hard disk. 


·	Top-level configuration. The Network Neighborhood can be configured by the network administrator to display only those PCs, servers, and printers that are in the user’s immediate workgroup. Top-level configuration insulates the user from the vastness of large corporate networks. The user can still browse the larger network by opening Entire Network from within the Network Neighborhood. (Until Windows 95, browsing the larger network was not possible.) When a user browses a server, network connections are made without drive “mapping” (the assigning of new drive letters to a specific network resource).


·	�xe "UNC pathnames:obsoletes "mapping" drives"�System-wide support for UNC pathnames. This technology makes obsolete the process of mapping drives and allows natural network browsing via the Network Neighborhood. UNC pathname support allows a whole host of usability improvements of which network browsing is just one.


·	�xe "Network:tool in Control Panel"�The Network Control Panel tool. This tool consolidates all networking configuration in one location, and thereby eliminates the difficulty of configuring networking under Windows 3.1 and Windows for Workgroups 3.x.


·	�xe "Drive mappings:made easy in Windows 95"�Easy drive mapping. A Map Network Drive button on the Windows Explorer and browsing window toolbars make drive mapping available in Windows 95. (Power users can also right-click My Computer.) Mapped drives appear as connections in My Computer.


·	Networking and mobility�xe "Copying files:status displayed over slow links"�. The UI in Windows 95 was designed from the ground up with networking and remote access in mind. For example, when a file is copied over a slow-link (a modem connection), the Copy dialog box includes an Estimated time to completion status message.


·	Networking integration with new common dialog boxes. The new common dialog boxes, which are standardized in applications that make use of them, provide a consistent way to open and save files on network resources as well as on local drives. In addition, the Network Neighborhood can be browsed directly from the common dialog boxes, and the majority of basic file management tasks can be performed from them.


Try It!


Create a Shortcut to a Network Folder on the Desktop


1.	Browse the Network Neighborhood until you find an often-used network folder.


2.	Point to the folder, hold down the right mouse button, and drag the folder to the desktop.


3.	Choose Create Shortcut Here.


4.	Close the network window.


5.	Double-click the shortcut. The network folder opens in a new window. The shortcut will be available every time you boot Windows 95.


Use the UNC Path to “Run” a Favorite Network Folder


1.	From the Start menu, choose Run.


2.	Type the full UNC path to your favorite network folder, such as \\MKTG\PROGRAMS\SARAHB, and press enter. The folder opens in a new window, with no drive mapping.


Create a New Folder from Within Common Dialog Boxes


1.	Click the Start button, and then choose Programs, Accessories, and WordPad. (WordPad is the word processing equivalent in Windows 95 of Write in Windows 3.1. It uses the common dialog boxes.)


2.	From the File menu, choose Open, and click the Look in drop-down box, which provides access to the entire PC hierarchy, including the Network Neighborhood.


3.	From the File menu, choose Save, and click the Create New Folder icon. Unlike in Windows 3.1, where you have to start File Manager or exit to the MS-DOS command prompt to a create a new folder, you can create a folder when you save a document.


The Recycle Bin: Easy Deleting�and Undeleting of Files


�xe "Recycle Bin: described"�The Recycle Bin is an easily recognizable metaphor for being able to “throw away” files and then recover them by simply removing them from the bin. Files deleted in Windows 95, or deleted from the common dialog boxes in applications that support them, are moved to the Recycle Bin. Users can remove an item from the Recycle Bin and drag or cut/copy/paste it to another location, or they can restore it to its original location by choosing Undo Delete from the Edit menu.


The Recycle Bin graphically indicates whether it is empty or contains items. Information about “deleted” items is available in the Recycle Bin’s details view, as shown in Figure 9.
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Figure 9. The Recycle Bin with deleted items and the Recycle Bin details view showing additional information


Focus on Documents: Working the Way Users Work


�xe "OLE:more document centric"�OLE introduced the concept of “document-centricity” by incorporating in-place editing of objects. In a document-centric environment, the application window changes and the document stays the same, so that software works the way people work, rather than vice-versa.


The UI in Windows 95 picks up on the concept of document-centricity in the following subtle but powerful ways:


·	Windows as views of objects. When the user opens an object from anywhere in the UI, a new window opens. Logically, the title of the new window is the same as that of the object’s icon. For example, when the icon of a Microsoft Word document called My Document is double-clicked from the anywhere in the UI, a new window opens entitled My Document—Microsoft Word.





·	Document creation from within folders and in the Windows Explorer. From within any folder in Windows 95 or from the desktop, users can create new files in place by choosing New from the File menu and then selecting a file type. An icon like the one shown in Figure 10 is then created to represent the new file. This flexibility makes it very convenient to manage files based on projects, rather than at the whim of an application.
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Figure 10. The icon for a new Word document


Try It!


Create a New Document from Within a Folder


1.	Select a project folder in which you want to create a new document.


2.	From the File menu, choose New and then select Microsoft Word 6.0 Document.


3.	Type a name and press the enter key.


4.	Double click the new document to open it in WordPad.


Hint: This functionality can also be accessed by right-clicking from within any folder or on the desktop.


Backtracking: Undoing File Operations


When working with files on your system, �xe "Control Panel:improvements over Windows 3.1"�how many times have you said to yourself, “I didn’t mean to do that!” after accidentally deleting, renaming, moving, or copying a file that you didn’t intend to? Windows 95 has a simple answer for putting things back the way they were. Windows 95 provides a multilevel undo feature that allows users to undo one or more of their preceding actions. Users can undo file deletions, renames, moves, or copies by simply choosing Undo from the Edit menu of any UI window, as shown in Figure 11.
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Figure 11. The Undo command on the Edit menu, which can be used to undo file operations


Try It!


Undo a File Operation


1.	Open a folder and select a file.


2.	Rename the selected file.


3.	From the Edit menu, choose Undo Rename to undo the rename operation.


Undo Multiple File Operations


1.	Open a folder and select a file.


2.	Rename the selected file.


3.	Drag the file from the folder to the desktop.


4.	Delete the file.


5.	Go back to the folder you first opened.


6.	From the Edit menu, choose Undo Delete to undo the delete operation.


7.	Choose Undo Move from the Edit menu to undo the move operation.


8.	Choose Undo Rename from the Edit menu to undo the rename operation.


Wizards: Guides to Powerful Capabilities


�xe "Wizards:functionality in Windows 95" \i�Originally developed in Microsoft’s Applications Group and used in applications such as Microsoft Word and Microsoft Excel, Wizards are a proven tool that make it easy for all classes of user to take advantage of powerful but complex functionality. The Wizards guide a user through a series of questions, which are posed to the user in a friendly and straightforward way, and walk the user through a process like the one shown in Figure 12.
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Figure 12. The Add Printer Wizard, which walks the user through the printer installation process


Windows 95 uses Wizards throughout the operating system to assist all types of users. For example, Wizards are used to perform the following operations: �xe "Wizards:Different types of Wizards supported in Windows 95"�


·	Displaying Setup options to the user during the installation process


·	Adding a new device to the system, such as a printer or modem


·	Setting up remote access in the Network Neighborhood


·	Creating a shortcut for an application


·	Installing a new application


·	Creating a Briefcase for synchronizing files between two PCs


·	Creating a workgroup post office for use with the Microsoft Exchange e�mail client


A New Help Engine: Accessible�and Useful Online Information


�xe "Help:new online help in Windows 95"�Online Help has been completely retooled in Windows 95. It underwent extensive usability testing and the result is a significantly easier-to-use and easier-to-learn Help system. Additionally, it is now dramatically easier for independent software vendors (ISVs) and corporate customers to customize and develop Windows help files. Following are brief descriptions of the major features of the new Help system in Windows 95:


·	�xe "Help:simplified interface"�Simplified interface. Help in Windows 3.1 was difficult to learn and to use. It had three main functions: Contents, Search, and Glossary. The Contents view was not well organized and presented, and there was some ambiguity about which functions to use when. Windows 95 behaves much more intuitively and more like a real reference book. It only has two Tabs: Contents and Index.


·	�xe "Help:table of contents"�The Contents tab. Organized like a book’s table of contents, the Contents tab displays top level “chapters” (iconically represented as books) from which users can “drill down” to subtopics (iconically represented as pages). Many chapters also have Tips and Tricks subsections that have proved popular in lab testing.


·	Short Help topics. Topics all fit in one small window, so users don’t have to scroll through large, complicated help information.


·	Shortcut buttons. �xe "Help:Shortcut Buttons"�New shortcut buttons make using Help even easier in Windows 95. Some Help topics contain shortcut buttons, like the one shown in step 1 in Figure 13, that take users to the referenced area in Windows 95. For example, a user who is searching for help on how to change the date on a PC can “jump” right to the Clock Control Panel tool from within Help.
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Figure 13. A Help shortcut button (in step 1)


·	�xe "Help:What's this?"�What’s This? button. All Control Panel tools in Windows 95 have a ? button at the right end of their title bars. When the user clicks this button, the pointer changes to a question mark. Clicking any object in the dialog box with this pointer brings up a short description of the object. Users can also access the question-mark pointer by right-clicking within a Control Panel tool.


Try It!


Use Help’s Shortcut Button to Change the Desktop Color


1.	From the Start menu, choose Help.


2.	Select the Index tab.


3.	Type display. Double-click the background pictures or patterns, changing topic.


4.	Click the Properties for Display shortcut button to move directly to this property sheet.


Transition Aids: Easy Migration�to the Windows 95 User Interface


�xe “"UserInterface:TransitionaidsforusersofWindows3.1 "�Windows 95 provides several aids for helping both users new to Windows and users of Windows 3.1 become productive quickly in the Windows 95 UI. Usability tests indicate that, with little or no additional training, users can complete common tasks under Windows 95 as quickly as they did under Windows 3.1, or even quicker. Windows 95 offers the following self-paced aids:


·	Quick tutorial of Windows 95. This tutorial walks users through the basics of Windows 95 and covers topics such as starting programs, task switching between open windows, finding information on the local computer, and using the online Help system. The tutorial is designed for both novice users and experienced Windows users and shows how to complete common tasks.


·	Transition aids for Windows 3.1 users. The Help system provides additional Help topics designed to make the transition to the UI in Windows 95 easier for Windows 3.1 users. These Help topics answer common questions to help users familiar with the components of Windows 3.1 quickly and easily find the respective tools or commands in Windows 95.


·	Readily available information in the online Help system. The Help system in Windows 95 is designed to provide the information needed to complete the desired task. Topics include How To, Tips and Tricks, and Troubleshooting categories. Help is always available and can be easily accessed by choosing Help from the Start menu.


Powerful Features





Experienced users glean many of the same benefits from the taskbar and the Start button—quickly launching a new program, quickly switching to another task, and so on—as novices. However, experienced users need more, including the following:


·	They need a powerful way to browse and manage file hierarchies, whether they are local or not.


·	They need to be able to customize the UI to suit their needs and tastes.


·	They need to be able to take shortcuts to get tasks done more quickly and efficiently.


·	They need to be able to do more.


The new UI in Windows 95 definitely enables the experienced user to do more, as the following sections show.


The Windows Explorer: For File Management�and Information Browsing


�xe "Windows Explorer:described" \i�The Windows Explorer, shown in Figure 14, has been described as “File Manager on steroids.” It is powerful, flexible, efficient, and extensible. It also solves many of File Manager’s fundamental problems, such as having different windows for different drives. For many power users of Windows 95, the Windows Explorer will be the primary interface for navigating through information.


�


Figure 14. The Windows Explorer


The best way to understand the Windows Explorer is to experience it firsthand. However, here is an overview of its major features:


·	�xe "Windows Explorer:single view on a world of information" \i�Single view of a world of information. The Windows Explorer is the eyes of any PC running Windows 95. With it, users can view the entire namespace (all resources, local or connected) from the equivalent of 10,000 feet, or they can zoom down to the equivalent of 10 inches. My Computer and the Network Neighborhood can be browsed and managed, quickly and easily.


·	�xe "Windows Explorer:flexible and customizable" \i�Flexible and customizable. Via the Windows Explorer toolbar and the View menu, users can view folder contents in several ways, including large icon, small icon, list, and details views. Folder contents can easily be sorted by name, size, type, and modification date by selecting the column title. Users can also map network drives from the Windows Explorer toolbar.


·	�xe "Windows Explorer:details view" \i�Rich information about objects in details view. Details view provides a wealth of context-sensitive information about folder contents. For example:


·	Files retain their identifying icons.


·	Drive sizes and free space (even mapped network drives) are reported in My Computer.


·	Descriptions of Control Panel tools are provided.


·	Jobs in the print queue are listed in the Printers folder.


·	Comments on other computers in the Network Neighborhood can be viewed.


All the powerful right-click and properties features described in the next two sections are supported in the Windows Explorer.


Try It!


Copy a File to a Different Drive Without�Opening a New Window 


1.	Right-click My Computer and choose Explore. Maximize the window.


2.	Select a file that you want to copy to a network or floppy drive.


3.	Move to the left pane in the Windows Explorer and use the + icons to the left of the folder and drive icons to find the network folder to which you want to copy the file. Do not click the destination folder.


4.	Go back to the right pane where the file is currently stored and drag or cut/copy/paste the file to the destination folder.


Operations like this one could not be performed in Windows 3.1 without opening two or more File Manager windows.


Right-Click to Create a New Folder


1.	In the Windows Explorer, right-click an unused space inside a folder in which you want to create a new folder.


2.	Choose New Folder.


Shortcuts: For Accessing Objects


�xe "Shortcuts:described" \i�Shortcuts are an extremely powerful tool for increasing efficiency. They are especially useful in a networked environment. Users can create a shortcut to any object, such as a file, program, network folder, Control Panel tool, or disk drive, and place it anywhere in the UI or in an application. Opening the shortcut opens the object that the shortcut is “pointing” to. �xe "Shortcuts:using" \i�For example, if a user creates a shortcut to My Network Folder on a network server and drops the shortcut on the local desktop, opening the shortcut actually opens My Network Folder. Shortcuts are represented by icons that have a small “jump” arrow in the lower-left corner, as shown in Figure 15.
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Figure 15. Shortcut icons for a folder and a program


Shortcuts are created by selecting an object and choosing Create Shortcut from the File menu or by right-clicking the object and choosing Create Shortcut. After creation, shortcuts can be renamed. If the shortcut is for an object that was created after installation of Windows 95 and the object is renamed, Windows 95 changes the shortcut definition to reflect the new name. �xe "Shortcuts:tracking of renames" \i�For example, if a user creates a shortcut on the local desktop to \\Server\Share\Public Folder and the folder is subsequently renamed, the shortcut will still work. �xe "Shortcuts:deleting does not delete object" \i�A shortcut can be deleted without affecting the object to which it points.


Uses for shortcuts are virtually limitless, but the following are some common powerful uses for shortcuts:


·	�xe "Shortcuts:in the Programs folder" \i�Shortcuts in the Programs folder. Shortcuts are an extension of the icons that in Program Manager groups in Windows 3.1. The icons simply pointed to an executable file somewhere in the file system. In Windows 95, the icons that appear on the Start button’s Programs menu, which can be customized by choosing Settings and then Start Menu from the Start menu, also appear as shortcuts in the Programs folder. When a shortcut is added to or deleted from the Programs folder, it is also added to or deleted from the Programs menu. As a result, users can keep shortcuts to all favorite programs in one central place, regardless of where the programs are actually stored.


·	�xe "Shortcuts:on the desktop" \i�Shortcuts on the desktop. Power users can create shortcuts to commonly accessed files, programs, drives, folders, and utilities right on their desktops. This capability is especially powerful with network resources because no complicated browsing or drive mapping is required to access network folders.


·	�xe "Shortcuts:embedding in applications" \i�Embedded shortcuts in applications. A shortcut to a large file stored on the network can be dragged to an e-mail message. When the message recipient double-clicks the shortcut, the network file opens. This process is much more efficient than embedding the actual file in an e-mail message because the message is smaller, and embedding shortcuts cuts down on file version proliferation.


Try It!


Discover Where the Start Button’s Programs Menu Is Stored


·	From the Start menu, choose Settings and then Start Menu. The Start Menu folder, which is a sub-folder of the Windows folder, opens. The Programs folder contains the items that appear on the Start button’s Programs menu.


The shortcuts and folders are those that appear on the Programs menu. Adding or deleting shortcuts and folders changes the items that appear on the menu.


Properties: For Customizing All Objects


Property�xe "Property sheets:explained"� sheets are a pervasive feature in Windows 95. All objects in the UI carry context-sensitive properties that can be accessed and customized by choosing Properties from the File menu or by right-clicking the object and choosing Properties. Good, consistent, easily accessible property sheets have been a favorite of power-user testers. Try the following examples to see how property sheets work.


Try It!


Rename a Hard Drive


1.	In the Windows Explorer or My Computer, right-click to select your hard disk and choose Properties to open a property sheet like the one shown in Figure 16.


2.	In the Label box, type a new name and choose OK.


3.	From the View menu, choose Refresh.
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Figure 16. The properties for a disk drive


Share a Folder


1.	In the Windows Explorer, right-click a folder you want to make available to others on your network and choose Properties.


2.	Select the Sharing tab.


3.	Select Shared As, and then complete the other fields in this dialog box.


Customize a Shortcut Icon


1.	Click the Start button and choose Settings and Start Menu.


2.	Open the Programs folder.


3.	Right-click any shortcut and choose Properties.


4.	Select the Shortcut tab.


5.	Click the Change Icon button.


6.	Select a new icon for the shortcut and choose OK.


7.	From the View menu, choose Refresh.


Right-Clicking: For Performing Actions on Objects


�xe "Mouse:right-clicking"�Right-clicking, like properties, is a pervasive, context-sensitive feature of Windows 95. (In this book, “right-clicking” refers to clicking the secondary mouse button. Most right-handed people set their mouse options to use the left button as primary and the right button as secondary.) Usability tests have shown that right-clicking as a shortcut way of performing common actions on an object is a very popular power-user feature. However, in general, right-clicking is not a feature that novices discover or remember, so the vast majority of functions that can be performed by right-clicking can also be performed by choosing the corresponding menu commands. 


The power of right-clicking can be explored by carrying out the following examples.


Try It!


Right-Click the Desktop to Customize It


1.	Right-click a blank space on the desktop.


2.	Choose Properties.


Minimize or Tile All Open Windows


1.	Right-click a blank space on the Taskbar.


2.	Choose Minimize All or Tile Horizontally.


3.	To undo this operation, right-click a blank space on the Taskbar and choose either Undo Minimize All or Undo Tile. �xe "Taskbar:Undoing window operations"�


Create a Shortcut


1.	Right-click an object for which you want to create a shortcut.


2.	Choose Create Shortcut.


Drag a File and Create a Shortcut


1.	�xe "Drag and Drop:using a mouse right-click"�Right-click and drag a file from the Windows Explorer onto the desktop. A menu like the one shown in Figure 17 appears.


2.	Choose Create Shortcut(s) Here.
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Figure 17. The menu that appears when a file is dragged using the right mouse button


Right-Click a Screensaver to Test It


1.	Choose Find Files or Folders from the Start menu.


2.	Type bezier and choose Find Now.


3.	Right-click Bezier.


4.	Choose Test.


Close a Task from the Taskbar


1.	Right-click the Task button for a window or program you want to close.


2.	Choose Close.


Access the Property Sheet for an Open Window


1.	Right-click the mini-icon in the upper-left corner of any window.


2.	Choose Properties.


The Control Panel: The Consolidated Control Center


�xe "Control Panel:improvements over Windows 3.1"�The objective of the Control Panel is to consolidate all command, control, and configuration functions in one location. With Windows 3.1, these functions were difficult to find, use, and remember—for example, video resolution was changed in Windows Setup, but a printer was installed by selecting the Control Panel’s Printers icon. As shown in Figure 18, in Windows 95 distinct graphics make all important functions instantly recognizable and previews are offered where appropriate.


�


Figure 18. The large icon view of the Control Panel in the Windows Explorer


The individual functions available through the Control Panel tool are discussed in the relevant sections of this book—for example, the Network tool is discussed in Chapter 9, “Networking.” However, one Control Panel tool, Display, controls the configuration of the UI in Windows 95 and allows users to customize the UI itself. �xe "Control Panel:properties for Display"�As shown in Figure 19, its property sheet has the following four tabs:


·	Background. Allows pattern and wallpaper configuration and preview.


·	Screen Saver. Allows screen saver configuration and preview.


·	Appearance. Allows configuration and preview of all of the user interface metrics (fonts, sizes, colors, and so on).


·	Settings. Allows configuration of monitor resolution and color palette size.


�embed Word.Picture.6 ���


Figure 19. The display properties


Try It!


Switch the Display Resolution


�xe "Display resolution:switching on-the-fly"�Dynamic resolution switching allows the resolution of the display to be changed without having to restart Windows 95 or reboot the PC. This feature depends on several factors, including the type of video card and the selected color palette.


1.	Choose Settings and then Control Panel from the Start menu.


2.	Open the Display icon.


3.	Select the Settings tab.


4.	Set Color Palette to 256 colors and click Apply Now to restart your PC.


5.	After your PC restarts, repeat steps 1 and 2 to reopen the Display icon.


6.	Choose another video resolution that is supported by your card by sliding the Desktop Area slider bar. For example, change the desktop area size from 640 x 480 to 1024 x 768.


7.	Click Apply Now.


8.	Now try playing a video clip.


Finding Files or Folders: Easy and Efficient


�xe "Find:powerful new utility in Windows 95"��xe "Find:searching for files"��xe "Find:improvements for searching over Windows 3.1"�A powerful new Find utility is built into Windows 95. As shown in Figure 20 and Figure 21, it goes far beyond the minimal functionality of File Manager’s Search utility in Windows 3.1.
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Figure 20. Finding files or folders in Windows 95
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Figure 21. Searching in Windows 3.1


The Find utility includes the following features:


·	Partial name searches. Type rep in the Find Files Named window, and all files and folders with rep somewhere in their names are found.


·	Searches on last modification date. Because files can be searched on their last modification dates, users can perform searches such as Find all Word documents modified in the last 3 days.


·	Full-text searches. Documents containing specified text can be searched for.


·	Saving of search results. Complex or useful searches can be saved.


·	File management from the search results pane. Operations such as renaming files or viewing file properties can be carried out within the results pane in the same way as in the Windows Explorer.


Try It!


Save the Results on a Complex Search


1.	Click the Start button, and choose Find and then Files or Folders.


2.	Type a partial string that you know will be present in many files, such as rep or doc.


3.	Select the Date Modified tab.


4.	Select Modified during the previous seven days.


5.	Select the Advanced tab.


6.	If necessary, select a file type.


7.	Click Find Now.


8.	When the find operation is complete, choose Save Search from the File menu. (Notice that because the Find feature is 32-bit preemptively multitasked, you have control and can go perform other tasks while Find is running.) A Find Results icon is automatically created on the desktop.


9.	Double-click the Find Results icon.


The Printers Folder: Consolidated Printer Control


�xe "Printers folder:described"�The Printers folder, shown in Figure 22, offers one-stop shopping for printer management and configuration. It replaces the troublesome Print Manager and Printers dialog box in the Windows 3.1 Control Panel, which is shown in Figure 23.
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Figure 22. The Printers folder in Windows 95
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Figure 23. The Printers dialog box in Windows 3.1


The Printers folder is discussed in more detail in Chapter 11, “Printing.”


Font Settings: More Powerful Font�Management and Preview


The Fonts folder in the WINDOWS directory �xe "Fonts folder:described"�represents a single namespace in which all fonts used in the system can be installed or manipulated. (If any fonts are identified in the WIN.INI file, Windows 95 moves them to the Fonts folder on startup, so all fonts in the system reside in a single location.)�xe "Fonts:integrated with the UI"� Different views of the Fonts folder present additional information about the fonts installed in the system (the large icon view is shown in Figure 24.)


�


Figure 24. The large icon view of the Fonts folder


Operations can be performed on fonts in the same way they are performed on other file system objects. For example, a font can be removed from the Fonts folder by dragging it to another location, a font can be deleted from the system by deleting it from the Fonts folder, and a font can be added to the system by dragging it from another location into the Fonts folder.


Try It!


Preview the Fonts


1.	Open My Computer and double-click the Fonts folder, or open the Fonts icon in the Control Panel.


2.	Right-click the font you want to preview.


3.	Choose Open. Samples of the selected font are displayed and may be printed.


Quick Viewers: Examining Files�Without Opening Them


The �xe "Files:quick viewing contents of"�Quick Viewers allow users to preview a file from the UI without having to open the application that created the file. In fact, users don’t even have to have the application that created the file on their system. As a result, documents can be sent over a network or through e-mail. Figure 25 shows a quick view of a Microsoft Excel worksheet.
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Figure 25. A quick view of a Microsoft Excel worksheet


For more information about the Quick Viewers in Windows 95, see Chapter 20, “Applications and Utilities.”


Try It!


Quick-View a File


1.	Right-click an icon for a file created by a registered application—for example, a bitmap, a text file, or a WordPad document.


2.	Choose Quick View.


Compatibility


�xe "Compatibility:user interface"�Compatibility is a requirement for Windows 95. It is a no-excuses, “no-brainer” upgrade from Windows 3.1. Overall, compatibility is most important for third-party software and hardware. However, it also applies to the UI. The UI in Windows 95 must be compatible with the way current Windows and MS-DOS users work, and it must scale itself to the level and preferences of individual users.


For Users of Windows 3.1


Of primary importance is that new UI features be easy for current Windows 3.1 users to learn at their own pace. In addition, UI visual elements and operations in Windows 95 must be consistent, to the extent possible, with the elements users are already familiar with in Windows 3.1. In addition to providing aids for users migrating from Windows 3.1, Windows 95 also includes tools familiar to Windows 3.1 users. For example, the system menu in the upper-left corner of most windows, and keyboard shortcuts such as alt+f4, alt+tab, ctrl+x, ctrl+c, and ctrl+v, are present in Windows 95, easing the requirement for relearning or retraining.


�xe “"UserInterface:usingProgramManagerfromWindows3.1 "��xe “"UserInterface:usingFileManagerfromWindows3.1 "��xe “"UserInterface:migratingfromWindows3.1 "�With minimal changes in appearance, Program Manager and File Manager run under Windows 95 and are easily accessible via the Start button. As of this writing, the designs for access and default configuration of these Managers is not yet set. For example, when a user who has upgraded boots Windows 95 for the first time, the Program Manager window might be open. Or the Start button might have a Windows 3.1 Compatibility menu item that will launch Program Manager and File Manager. Regardless of the final design, many help and learning devices will be specifically designed for the upgrade, such as a Click Here to Begin arrow that zooms to the taskbar when the user first boots Windows 95.


For Users of MS-DOS


Users of the command line in MS-DOS won’t have to give it up when they move to the graphical UI of Windows 95. In fact, “command-line junkies” will find that the usability and power of the MS-DOS command prompt have been dramatically improved. New command-line functionality includes the following:


·	Launching Windows–based applications


·	Opening documents from a command-line


·	Scaling the size of the MS-DOS command prompt


·	Using cut/copy/paste operations to integrate information from MS-DOS and Windows–based applications


·	UNC pathname support


See Chapter 6, “Support for Running MS-DOS–based Applications,” for more information.
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