devel/sdl12-compat - The NetBSD Packages Collection

SDL-1.2 compatibility layer that uses SDL 2.0 behind the scenes

This is the Simple DirectMedia Layer, a general API that provides low level
access to audio, keyboard, mouse, joystick, 3D hardware via OpenGL, and 2D
framebuffer across multiple platforms.

This code is a compatibility layer; it provides a binary and source compatible
API for programs written against SDL 1.2, but it uses SDL 2.0 behind the
scenes. If you are writing new code, please target SDL 2.0 directly and do
not use this layer.

Build dependencies

pkgtools/x11-links x11/xorgproto x11/xcb-proto pkgtools/mktools devel/cmake pkgtools/cwrappers

Runtime dependencies

devel/SDL2 graphics/MesaLib graphics/glu graphics/glu devel/SDL2 graphics/MesaLib graphics/glu

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64sdl12-compat-1.2.52nb2.tgz
NetBSD 10.0aarch64sdl12-compat-1.2.52nb2.tgz
NetBSD 10.0earmv6hfsdl12-compat-1.2.52nb2.tgz
NetBSD 10.0earmv6hfsdl12-compat-1.2.52nb2.tgz
NetBSD 10.0earmv7hfsdl12-compat-1.2.52nb2.tgz
NetBSD 10.0earmv7hfsdl12-compat-1.2.52nb2.tgz
NetBSD 10.0i386sdl12-compat-1.2.52nb2.tgz
NetBSD 10.0powerpcsdl12-compat-1.2.52nb2.tgz
NetBSD 10.0powerpcsdl12-compat-1.2.52nb2.tgz
NetBSD 10.0x86_64sdl12-compat-1.2.52nb2.tgz
NetBSD 10.0x86_64sdl12-compat-1.2.52nb2.tgz
NetBSD 8.0i386sdl12-compat-1.2.52.tgz
NetBSD 8.0i386sdl12-compat-1.2.52nb2.tgz
NetBSD 8.0powerpcsdl12-compat-1.2.52nb2.tgz
NetBSD 8.0powerpcsdl12-compat-1.2.52nb2.tgz
NetBSD 8.0x86_64sdl12-compat-1.2.52.tgz
NetBSD 8.0x86_64sdl12-compat-1.2.52nb2.tgz
NetBSD 9.0aarch64sdl12-compat-1.2.52nb2.tgz
NetBSD 9.0aarch64sdl12-compat-1.2.52.tgz
NetBSD 9.0aarch64sdl12-compat-1.2.52nb2.tgz
NetBSD 9.0earmv6hfsdl12-compat-1.2.52.tgz
NetBSD 9.0earmv6hfsdl12-compat-1.2.52nb2.tgz
NetBSD 9.0earmv6hfsdl12-compat-1.2.52nb2.tgz
NetBSD 9.0earmv7hfsdl12-compat-1.2.52nb2.tgz
NetBSD 9.0earmv7hfsdl12-compat-1.2.52nb2.tgz
NetBSD 9.0earmv7hfsdl12-compat-1.2.52.tgz
NetBSD 9.0i386sdl12-compat-1.2.52.tgz
NetBSD 9.0i386sdl12-compat-1.2.52.tgz
NetBSD 9.0i386sdl12-compat-1.2.52nb2.tgz
NetBSD 9.0powerpcsdl12-compat-1.2.52nb2.tgz
NetBSD 9.0powerpcsdl12-compat-1.2.52.tgz
NetBSD 9.0powerpcsdl12-compat-1.2.52nb2.tgz
NetBSD 9.0sparc64sdl12-compat-1.2.52.tgz
NetBSD 9.0sparc64sdl12-compat-1.2.52nb2.tgz
NetBSD 9.0sparc64sdl12-compat-1.2.52nb2.tgz
NetBSD 9.0sparcsdl12-compat-1.2.52.tgz
NetBSD 9.0x86_64sdl12-compat-1.2.52.tgz
NetBSD 9.0x86_64sdl12-compat-1.2.52.tgz
NetBSD 9.0x86_64sdl12-compat-1.2.52.tgz
NetBSD 9.0x86_64sdl12-compat-1.2.52nb2.tgz
NetBSD 9.0x86_64sdl12-compat-1.2.52nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.