devel/hs-hie-bios - The NetBSD Packages Collection

Set up a GHC API session

hie-bios is the way to specify how haskell-language-server and ghcide set
up a GHC API session.

Given a Haskell project that is managed by Stack, Cabal, or other package
tools, haskell-language-server needs to know the full set of flags to pass
to GHC in order to build the project. These flags might contain some
compilation options like -O2, but a lot of the time they are package
dependencies such as -package-id directory-1.3.6.0, which also need to be
built beforehand. hie-bios satisfies both these needs.

Build dependencies

pkgtools/mktools pkgtools/cwrappers

Runtime dependencies

devel/hs-optparse-applicative converters/hs-aeson devel/hs-unordered-containers devel/hs-vector converters/hs-base16-bytestring devel/hs-conduit devel/hs-conduit-extra security/hs-cryptohash-sha1 misc/hs-extra devel/hs-file-embed sysutils/hs-hslogger sysutils/hs-temporary devel/hs-unix-compat textproc/hs-yaml lang/ghc92 devel/hs-optparse-applicative converters/hs-aeson devel/hs-unordered-containers devel/hs-vector converters/hs-base16-bytestring devel/hs-conduit devel/hs-conduit-extra security/hs-cryptohash-sha1 misc/hs-extra devel/hs-file-embed sysutils/hs-hslogger sysutils/hs-temporary devel/hs-unix-compat textproc/hs-yaml

Binary packages

OSArchitectureVersion
NetBSD 10.0x86_64hs-hie-bios-0.8.1nb5.tgz
NetBSD 10.0x86_64hs-hie-bios-0.8.1nb5.tgz
NetBSD 8.0x86_64hs-hie-bios-0.8.1nb2.tgz
NetBSD 8.0x86_64hs-hie-bios-0.8.1nb5.tgz
NetBSD 9.0x86_64hs-hie-bios-0.8.1nb2.tgz
NetBSD 9.0x86_64hs-hie-bios-0.8.1nb2.tgz
NetBSD 9.0x86_64hs-hie-bios-0.8.1nb2.tgz
NetBSD 9.0x86_64hs-hie-bios-0.8.1nb5.tgz
NetBSD 9.0x86_64hs-hie-bios-0.8.1nb2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.