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Audience

Preface

The Solaris™ 2.2 user environment is based on the OPEN LOOK® Graphical
User Interface. This manual provides new and experienced users with the basic
information needed to get started with the Solaris user environment (using
OpenWindows™ and DeskSet™ applications). Additional topics covered here
include how to modify the OpenWindows Workspace, how to access
AnswerBook™ to view documents on-line, and Troubleshooting.

This guide should help you become familiar with the basics of the
OpenWindows environment and user interface concepts. The information in
this guide should help you to perform basic OpenWindows tasks, such as:

Displaying and choosing from the Workspace menu

Moving an application icon

Opening and closing an application icon

Pinning and unpinning a pinnable window

Displaying and choosing from an application’s File menu

Choosing exclusive or non-exclusive choice items on a properties window
Selecting items in a scrolling list

Using scrollbars

Selecting multiple objects

XXiX



If you are not familiar with these operations, read Chapter 1, “Introduction to
the Solaris User Environment” for information on how to use the mouse, icons,
windows, and menus. The on-line tutorial Introducing Your Desktop also
provides information about these OpenWindows elements.

Note that context-sensitive help is available for each application. Position the
pointer over the item you want help with, and press the Help key. A pop-up
window is displayed giving detailed information.

How this Guide is Organized

Conventions

XXX

This guide is divided into several major components:

Introduction to OpenWindows, DeskSet, Workspace and on-line help
concepts.

Descriptions of the DeskSet applications. Each tool in the DeskSet has a
separate chapter with descriptions of the tool’s windows, icon(s), controls,
and special features, and step-by-step instructions for accomplishing various
tasks. Each chapter concludes with a description of that tool’s properties
that allow you to customize special features to your own preference. The
more experienced you become, the more likely it is that you will want to
customize features.

® Description of the Workspace properties and how to use them.
® A Troubleshooting section on the Solaris environment—OpenWindows,

DeskSet, and the WorkSpace Properties.

® The AnswerBook appendix provides information on using AnswerBook.
® Glossary entries define concepts that you may need to know as you become

familiar with the Solaris user environment.

The following conventions are used in this guide:

Terms introduced for the first time, variables, and book titles are in italic
type.

Names of buttons, menu items, and settings have initial capitals (for
example, Choose Print from the File menu).

Text that you type is in Courier font.

Text that appears on the screen, such as a file name, is in Courier font.
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® Names of keys on the keyboard have initial capitals (for example, Press the
Return key).

® Names of mouse buttons are referred to by function, not by location, and are
capitalized. For example “Press SELECT” is used, not “Press left.” This
convention is used because the mouse buttons are customizable, so the left
mouse button might not be the SELECT button for everyone. See
Chapter 17, “Customizing the Solaris Environment” and Chapter 18,
“Utilities” to learn how to customize your mouse button function
assignments.

SELECT
ADJUST
MENU

Figure P-1  Default Functions of the Mouse Buttons

The default mouse button function assignments are:
SELECT = the left mouse button
ADJUST = the middle mouse button
MENU = the right mouse button.

® When the entire menu is discussed in the text, or when the default menu
item is discussed, a circle, or default ring, surrounds the default item of the
menu. When you click SELECT on the menu button (without displaying the
menu) the default menu item is chosen.

¢ Illustrations that depict screen images are meant to be representative. For
example software version numbers are not shown in window headers.

¢ Keystroke combinations for keyboard menu equivalents are represented in
the software with the meta <> key. In this document they are represented as
meta + keyboard character. Keyboard accelerators and function keys are
documented here as well. For information on these keys, refer to
Chapter 17, “Customizing the Solaris Environment.”
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® This guide uses the following notation to describe choosing a menu option.
For example: choose Workspace » Programs.

Other Books

For additional information, refer to the following Solaris 2.2 books:
® Solaris 2.2 Advanced User’s Guide

® SunOS 5.2 Setting Up User Accounts, Printers, and Mail

® Solaris 2.2 Basic Installation Guide
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Introduction tothe Solaris User
Environment 1

This chapter provides an introduction to the Solaris™ User environment,
which consists of the OpenWindows environment, and the DeskSet
applications. The DeskSet is a set of default programs—such as an electronic
mail application and a text editor.

The first major section, “Overview of the OpenWindows Environment” on
page 5, describes the elements of your desktop environment (Workspace) and
how to use them. The second major section, “Introduction to the DeskSet
Applications” on page 34, describes how to choose the right application for the
task you need to accomplish. The third and forth major sections talk about
using on-line Help and AnswerBook. You can choose the method of learning
that is most comfortable for you.

Those who have had previous experience with OpenWindows may want to
skip this introductory chapter and move on to the rest of the book where a
chapter is devoted to each of the DeskSet applications and the Workspace
Properties.

Logging in and Logging Out

Before you start, your system must be ready to use. Your system is ready to use
when Solaris 2.2 is fully installed, and the login prompt is on the screen. If
Solaris 2.2 is not installed, refer to the Solaris 2.2 Basic Installation Guide.



Logging In

When you begin working on your system, you will need to log in. Logging in
tells the system who you are and what you have permission to do. Likewise,
when you finish, you will log out so that no one else can access your files
without permission.

Since more than one person can have an account on a single system, each user
must log in using his or her own unique user name and password. Logging in
indicates who is using the system and what files they can access.

To log in:

1. Type your user name at the login prompt and press Return.
The user name tells the system who you are. Your user name should have
been defined during installation. For more information, refer to the Solaris
2.2 Basic Installation Guide. The Solaris operating environment recognizes the
difference between uppercase and lowercase letters, so make sure you type
the user name using the correct case.

The login prompt usually consists of your machine name (assigned as the
Hostname during the installation) followed by the word login:, as shown
in the example in Figure 1-1.

(genius login: johndoe j

Figure 1-1  The login: prompt
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2. Type your password at the Password: prompt and press Return.
You do not see the characters on the screen as you type your password, as
shown in the example in Figure 1-2.

genius login: johndoe
Password:

Figure 1-2  The Password Prompt

-/

If you mistype the user name or password and have already pressed Return,
the system asks you to start over with your user name. See the example in
Figure 1-3.

genius login: johndoe
Password:

Login incorrect.
login:

Figure 1-3 Log in again with your user name

After you type your password, OpenWindows launches automatically ( if a
full installation was performed.)

Note - If OpenWindows does not launch automatically (for example, you may
have OpenWindows configured differently), you can start OpenWindows
manually. If you are unsure, contact your system administrator.

3. To start OpenWindows manually after you login, type openwin and press
Return.

Introduction to the Solaris User Environment 3



Logging Out

When you are done working on the system, you will need to log out. If you are
sharing a system, this allows other people to log in to your computer under their
own accounts.

To log out:

1. You must exit OpenWindows to log out. Press the MENU button and select
Exit.
A Notice appears asking you to confirm that you want to exit from
OpenWindows.

2. SELECT Exit.
Normally, when you exit OpenWindows, the system automatically logs you
out. However, if it does not, go to Step 3.

3. Type exit (or logout) and press Return.
The login: prompt appears, as shown in the example in Figure 1-4. Now
another user can log in under their own account and use the system.

genius$% johndoe
genius login:

Figure 1-4  Type Exit to Log Out
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Overview of the OpenWindows Environment

When you start the Solaris software, you see the Workspace background on
your screen, as well as the DeskTop Intro, described later in this chapter. The
Workspace is the display area for objects such as windows, icons, and menus.
Figure 1-5 shows a portion of the Workspace with several open application
windows. Notice that the windows can overlap each other.

= Mail Tool - /var/mail/egret

(File w)(View v)(Edit v)({Compose v) Mail File:

(Fini_)(Prochain ) (Effacer ) (Repondre v) (Move v )(Copy v)(Load v)
—

1 egret Tue Sep 29 11:29  25/560  Look

2 Mailer-Daemon Fri Oct 9 11:06 35/872 Returned mail:
U 3 mariac@celtic Thu Jan 7 16:52  18/496
Ne[ 4 egret Sat Jan 9 23:42  21/534

"' File Manager : fhightide/egret/Fish

(File ) (view v) (Editv) (GoTor v)

/ hightide egret Fish
[lel 10}
Contains 4 items 881 Mbytes (99%) available

Cod O saimon  [1 swordrish [ Tuna

Text Editor — (NONE) {edited), dir; Zhightide/e]
(File ) (View v) (Edit v) (Find v)

This s a text file created with text editor,

Figure 1-5 Partial View of the Workspace with Three Open Windows
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Windows and Icons

You interact with the applications using the keyboard, the mouse, and an
arrow on the Workspace, called a “pointer,” that moves in correspondence with
the mouse.

Several default applications appear on the Workspace when you start the
Solaris software. Each application runs in its own window. When you use the
OpenWindows environment, you open the applications that you need. You can
use several applications simultaneously, such as electronic mail, your daily
calendar, and a text editor.

Mail Tool - /var/mail/egret 1
(File v)(view v ) (Edit v)(Compose v} Mail File: [g)
(Done )(Next ) Delete J(Reply — v) (Move v)((Copy v){Load v)

1 thief@cici Thu Feb 18 10:42  18/506  Your Move 5
Ue 2 patten@newbirth Thu Feb 18 10:43  46/1282 Project Status
U 3 bgahl@scuba Thu Feb 18 10:50 32/1110 Inbox status p=
I 4 ayers@outhouse Thu Feb 18 10:51  1?2/532  SunU Training Registration
U 5 ayers@outhouse Thu Feb 18 10:51  12/511  vi command summary
Ue 7 marijac@celtic Thu Feb 18 11:00  90/2531 Project Schedule
U 8 hamilton@artemis Thu Feb 18 11:13  22/611  meeting reminder
U 9 abelson@sharonolds Thu Feb 18 11:34  32/1232 Your position paper
M 10 aguablu@cowman Thu Feb 18 13:58  21/647  Summer Collaboration

|

1 11 items, 1 new, 2 deleted |

Figure 1-6  Multimedia Mail Tool Header Window

Closing a Window to an Icon

When a window is not in use, you can close it and keep it on the Workspace for
further use. When closed, an application becomes an icon—a small symbol that
represents the application. If you will not be using that application for some
time, you can quit it entirely—which clears it from the Workspace—and start it
again later. Figure 1-7 shows the icon for the Text Editor application.

(Chapter 3, “Text Editor,” discusses Text Editor in more detail.)
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textedit

Figure 1-7  Text Editor Icon

Opening an Icon to a Window

You can open an application icon (into a window) from its closed icon by
positioning the mouse pointer over the icon and pressing the MENU button
and selecting Open from the Window menu, or by double-clicking SELECT.
With double-clicking, the first click highlights a border around the icon, and
the second click opens it into a window. For information on using the mouse,
refer to “Mouse and Pointer” on page 7.

Mouse and Pointer

The easiest way to access the windows in the Workspace is to use your
mouse—the small electronic device that sits on a pad next to your workstation.
Notice that when you move the mouse, the pointer on the Workspace moves
with you to a new location. Figure 1-8 shows the pointer moving across the
Workspace.

,
Ta
W

>

3
Figure 1-8 Movement of the Pointer by the Mouse

Versions of the Pointer

The pointer changes shape to reflect current position and system activity.
Figure 1-9 shows various pointer types.
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Basic pointer: Appears on Workspace
Busy pointer: System cannot accept input
Duplicate pointer: When user copies an item by dragging

Move pointer: When user moves an item by dragging

l!'i"g"@/

Onek]| ———— Text duplicate (or duplicate and move) pointer: When user
duplicates or moves a portion of text by dragging

Figure 1-9  Examples of Pointer Types

Using the Mouse Buttons

The mouse buttons enable you to control the windows, icons, and menus on
the Workspace. The terminology of the mouse and pointer is as follows:

® Mouse buttons are referred to by function. From left to right these are:
SELECT, ADJUST, and MENU. Figure 1-10 shows the function of each
mouse button. Note that you can change this default arrangement.
Chapter 17, “Customizing the Solaris Environment”, describes how to swap
SELECT and MENU for left-handed use.
SELECT
ADJUST
MENU

Figure 1-10 Functions of the Mouse Buttons

® You click a mouse button by pressing and releasing it quickly.

® You double-click a mouse button by clicking twice quickly (within
approximately half a second or less) without moving the pointer.

® You click SELECT to choose an item.

® You click ADJUST to make a secondary choice or modify what you have
chosen with SELECT.

Solaris 2.2 User’s Guide—May 1993



P~
1]

® You press MENU (and hold) to make a choice from a menu. Throughout this
text, “press” means to press and hold.

® You release the mouse button to initiate the action.

® You move the pointer by sliding the mouse with no buttons pressed.

® You drag the pointer by pressing a mouse button while sliding the mouse.

Pointer and Input Area

Because you can have several windows open on the Workspace at once, the
OpenWindows environment must track which window is currently active. You
can choose between two methods of notifying the window system of the
currently active window or input area: Move Pointer and Click SELECT.

In Move Pointer mode, the window is activated when you move the pointer
onto the window pane. In Click SELECT mode, you must also click SELECT in
the window to designate that window as the input area.

The default mode is Click SELECT. See the section “Setting the Active
Window” on page 500 for information on how to use the Workspace Properties
window to change to Move Pointer mode.

The insert point in a text window changes in appearance depending upon
whether that window is active or inactive. If the insert point is active it looks
like a triangle. If it is inactive, it looks like a dimmed diamond, and you must
move the pointer into the window, and, if in Click SELECT mode, click
SELECT in that window’s work area to activate the insert point. When you
begin typing, the text appears at the insert point. Figure 1-11 shows an insert
point that is active, and one that is inactive.

Active —— & ¢ ———— Inactive
Figure 1-11 Active and Inactive Insert Points
Pointer Jumping
In most cases, you move the pointer by moving the mouse. However, in some

cases, the pointer moves for you and jumps directly to a specific place on the
screen. This is called pointer jumping.
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For example, if you apply a change to the Workspace Properties window, a
pop-up window appears with a warning that this will change a file that you
may have manually customized. The pop-up window asks if you want to make
these changes, and the pointer jumps to the Yes button. You must click SELECT
on one of the choices in the pop-up window before you can do anything else
on the desktop.

Menus and Pushpins

A menu lists the choices you can make from the Workspace or window. For
instance, to start an application, you move the pointer to any location on the
Workspace background and press the MENU button. This displays the
Workspace menu, which includes Programs, Utilities, Properties, Workstation
Info, Help, and the option to Exit the OpenWindows environment.

Figure 1-12 shows the Workspace menu.

Pushpin S— Workspace

Utilities [
Properties...

workstation Info...
Help...

Exit..

Figure 1-12 Workspace Menu

Using the Workspace Menu

There are two ways to display the Workspace menu.

® You can click the MENU mouse button quickly in the Workspace. The
Workspace menu will pop up and stay up until you make a selection or
dismiss the menu by clicking SELECT elsewhere.

® You can press and hold MENU in the Workspace to display the Workspace
menu and then slide the pointer onto an item. With this method the
Workspace menu is dismissed when you release the mouse button.
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Using Submenus

When you display the Workspace menu, the first two items—Programs and
Utilities—each have a hollow triangle next to them, pointing to the right. This
means that there is a submenu of additional choices. To display a submenu,
keep pressing MENU as you drag the pointer to the right at one of the arrows.
Figure 1-13 shows the Programs submenu.

Wor.

| © ks Q
| (Programs d (File Manager... )]
Utilities f§  TextEditor..
Properties.., Mail Tool...

Calendar Manager...

workstation Info..
Help... Command Tool...
Shell Tool...

Exit...
Calculator..,
Performance Meter...
Print Tool...
Audio Tool...
Tape Tool...

Image Tool...
Shapshot...
Icon Editor..,
Binder..,
AnswerBook...

Figure 1-13 Programs Submenu

If you continue to press MENU and drag to the right at Programs, the
Programs submenus is displayed containing a list of default applications
(called DeskSet) available for the OpenWindows environment. To choose an
item from the Programs submenu, press MENU and drag the pointer over to
your choice. When the choice is highlighted, release the mouse button. In a
moment, the application you chose appears on the Workspace. At some point
you may want to customize the order and entries on your programs menu. For
information on how to do this refer to Chapter 17, “Customizing the Solaris
Environment.”
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Pinning a Menu

You can use the pushpin in the upper left corner of the menu to “pin” the
Workspace menu to the Workspace and keep it there indefinitely. Note that
these instructions apply to any menu or window with a pushpin.

Figure 1-14 shows the Workspace menu pinned to the Workspace.

P'ushpln— ©Q Workspace

pinning

the menu
Utilities >
Properties...
workstation Info...
Help...
Exit...

Figure 1-14 Menu Pinned to the Workspace

To pin the menu, press MENU to display the Workspace menu and keep the
button pressed down as you drag the pointer over the pushpin. The pushpin
moves into the hole and the menu stays up.

Choosing from a Pinned Menu

To choose an item from a pinned menu, you position the pointer on the item
and click SELECT.

Dismissing a Pinned Menu

To unpin a menu, just click SELECT on the pushpin again.

Using Window Menus

Windows can have three kinds of menus. Examples of each of the following
menu types are shown in Figure 1-15.

® The Window menu that you access from an abbreviated menu button in the
window header or from the window border.
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® A button menu that you access from a menu button in the window control

area—the portion of a window that contains menu buttons and other

controls.
® A pop-up menu available from the window pane (the bordered area where
window data are displayed).

Abbreviated _____ I'3)

Editor — (NONE) (edited), dir: /hig

htide/e

menu button

(File v) (View v) (Edit ) (Find v)

/ | Undo
Button menu Copy

Paste
Cut

Edit

=

Window pane ___—]
pop-up menu

- Find
/ Extras

This is a text file created with text editor.

Text Pane

View
Edit

>4
>4
o4
>4

Figure 1-15 Three Kinds of Window Menus

Using Window Menus

To choose a menu item:

1. Position the pointer on one of the three window areas:

® A window header’s abbreviated menu button (or the header itself)
¢ A menu button
®* A window pane

2. Press MENU, and drag the pointer down to the right to highlight the item

of your choice.

3. Release MENU.

Introduction to the Solaris User Environment
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Choosing Menu Defaults

Default
menu
selection

Y o —

Most of the menus in the Workspace and windows have default choices. A
default menu item is usually the first item in the menu. It is encircled with a
small black line. The default choice on the Workspace menu, as shown in
Figure 1-16, is the Programs submenu.

© Workspace
utilities b
Properties..,

workstation Info..
Help...

Exit...

Figure 1-16 Default Choice on the Workspace Menu

All menus and submenus have default choices. The default choice under the
Programs submenu is the Command Tool—a UNIX command interpreter shell.
When you choose Programs from the Workspace menu, the Command Tool
appears. (Chapter 6, “Command Tool, Shell Tool, and Console Window,”
discusses Command Tool in more detail.)

Alternatively, if you have a menu pinned, you can click SELECT on the menu
choice to choose the default. For instance, with the Workspace menu pinned
you can click SELECT on Programs to choose the default application,
Command Tool.

Changing the Menu Default

If you find that you often make a menu choice other than the default, you
might want to define that item as the default choice. To change the default
choice:

1. Display the menu to be modified.
Press MENU, and drag the pointer to display that menu.

2. Position the pointer on the default choice and press MENU again.
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. Press the Control key on your keyboard while pressing MENU.

. Drag the pointer up or down until the new default menu item is

highlighted.

. Release the Control key.

. Release the mouse button.

When you click SELECT on that menu, your chosen application is the
default.

Window Controls

Application titte ~ —
listed in the header

Button choices __—

One item can be
chosen at atime _—

Multiple items can
be chosen at once ——

Check boxes ___——]

The basic controls for an application are displayed in control areas within the
base window. An application can have a single control area in a single base

wi

ndow, or may have additional control areas elsewhere in the base window or

subwindows.

Figure 1-17 shows the variety of controls possible for window applications.

|

| ——

—

Base Window R
|_Buttons Menu button (3] Abbreviated

————1 ] menu button

| Exclusive settings IChoice1 | Choice2 |

_’Nonexclusive settings IChoice1 | [Choice2 | |Choice3 |

|_Check boxes [] Choicel i Choice2

|_Text Field: .Path/filg,

ield __—— | | _Slider control
Text field Slider: 63 0 [| ees———— 100 ~ |
| _Scrollbar
| — T | and scrolling
vl window
&
I o

Figure 1-17  Window Controls
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Scrollbars

Some windows contain scrollbars that enable you to scroll though lists or see
previous commands. The Text Editor is an example of a scrolling window. By
default, most scrollbars appear on the right side of scrolling windows,
although you can move them to the left side. See Chapter 17, “Customizing the
Solaris Environment”, for information.

You scroll up incrementally to view previous commands by placing the pointer
on an up arrow in the Scrollbar elevator and clicking SELECT. You can scroll
down again by placing the pointer on the down arrow and clicking SELECT.
You can also press SELECT on the drag area and slide the elevator up or down.
Figure 1-18 shows Command Tool’s scrollbar and its elements.

r‘@ cmdtool - /bin/csh L
Prompt ————H example %, 'E Drag
Elevator area
|l
Scrollbar
| cable
Cable
'_)J/ anchor

Figure 1-18 Command Tool’s Scrollbar
By contrast, the Shell Tool is a nonscrolling window. If you type a long series of

command lines in a nonscrolling window, you cannot see lines that scroll
above the top of the window.
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Abbreviated menu
button

Drag and Drop

Button Menus

Button Menus or Window buttons appear in the control areas of many
applications. Some window buttons provide a single option, and others
provide menus of choices. The Edit submenu in the Text Editor application, for
instance, provides editing options for cutting, copying, and pasting text, as
well as repeating or undoing an edit. Text Editor’s abbreviated menu button, in
the upper left corner, displays options common to most DeskSet applications,
such as Open/Close, and Quit. The Text Editor menu buttons are shown in
Figure 1-19.

Text Editor — (NONB), dir

Menu

N & Edit
Undo o Button
menu
Copy
Paste
Cut

Figure 1-19 Text Editor’s Menu Buttons

There are four buttons at the top of the Text Editor window, each with a hollow
triangle pointing down, indicating that there are further menu choices beneath
each button. You can see these choices by placing the pointer on one of the
buttons and pressing MENU. The window buttons for all of the applications
are discussed in their respective sections.

The OpenWindows drag and drop feature enables you to use your applications
together. To send a file from one application to another, you drag a file (in icon
form) from the first application and drop it on the second application icon or

its drag and drop target—a small rectangle in the application window. (In most
applications, the drag and drop target is in the upper right corner.)
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Empty drag
and drop

An application’s drag and drop target is an empty rectangle if the application
does not currently contain a file. When a file is opened from the application or
dropped onto the drag and drop target, the target changes in appearance.

Figure 1-20 shows an empty drag and drop target and one that contains a file.

target

—_— Drag and
ke/Jayna drop target
e with loaded
0 T e

2]

]
@
kd

Figure 1-20 Drag and Drop Targets

— &

Follow the steps below for any drag and drop operations:

1. Select an object or objects to be dragged.
For example, you might want to select a set of files in the File Manager by
pointing at the first file and clicking SELECT, and then clicking ADJUST on
the additional files. Or you might want to select a section of text from the
Text Editor by pressing SELECT at the start of the desired text, dragging
through the text to be moved, and releasing SELECT.

If you want to drag just one file or the contents of a drag and drop target,
you can skip this first step.

2, Initiate a move by pointing at a file glyph, the shaded area in a drag and
drop target, or a selected object. Then press SELECT and drag the pointer.
If you want to copy the object instead of move it, you can do so by pressing
the Control key on the keyboard before pressing SELECT. Keep the Control
key held down until after the drag is initiated.

3. When the hot spot of the pointer (the tip of the pointer arrow) is at an

appropriate place, drop the selection by releasing SELECT.

The selection is “dropped” at the new location. Depending on the object
being dragged, the location can be an icon, a drag and drop target, the
window of an application, the workspace background, or a text pane.

In many cases you do not need to worry about whether you need to move an
object or copy it. Whenever you use drag and drop to move an object, the
DeskSet applications attempt to do the right thing based on the operation. For
example, if you move a file from the File Manager into the Wastebasket, it is
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actually moved to the Wastebasket. (That is, the file is removed from the
original location.) On the other hand, if you move a file from the File Manager
onto the Print Tool, the file is only copied. The original file remains in its
original location.

If it is not obvious whether an object should be moved or copied, it is moved
unless the Control key is held down while the drag is initiated.

The following paragraphs list some typical drag and drop operations between
the DeskSet applications. See the chapter for each application for more
information about how the application supports drag and drop operations.

File Manager glyphs can be dropped onto the following DeskSet applications:

Mail Tool

Wastebasket

Print Tool

Tape Tool

Text Editor

Icon Editor (if it is an icon file)
Snapshot (if it is a raster or GIF file)
Audio Tool (if it is an audio file)

Mail messages from the Mail Tool Header window can be dropped onto the
following DeskSet applications:

Text Editor

Print Tool

File Manager

Wastebasket

Calendar Manager (with specific format restrictions)

e & o ¢ o

Mail Tool Attachments can be dropped onto these DeskSet applications:

File Manager

Wastebasket

Print Tool

Text Editor

Image Tool

Icon Editor (if it is an icon file)
Snapshot (if it is a raster file)
Audio Tool (if it is an audio file)

Text selections from Text Editor files can be dropped onto these applications:
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Mail Tool

Text Editor

Print Tool

Calendar Manager (with specific format restrictions)
Icon Editor (if it is an icon file)

File Manager

Wastebasket

Command Tool

Text files from the Text Editor drag and drop target can be dropped onto these
applications:

File Manager

Wastebasket

Print Tool

Mail Tool

Calendar Manager (with specific format restrictions)
Command Tool

If an error occurs during a drag and drop sequence, refer to Appendix A,
“Solaris Troubleshooting.”

Drag and Drop Examples

Sometimes an application has a drag and drop target, typically located in the
top right of an application’s control area. The drag and drop target is shown in
Figure 1-21. Note that on a color workstation the drag and drop target will
appear lightly shaded.

[

Figure 1-21 Drag and Drop Target

When you drop an object onto a drag and drop target, the object is loaded into
the application, replacing whatever was currently loaded. For example, if you
drop a file or text selection onto the Text Editor’s drag and drop target, the
entire contents of the Text Editor are replaced by the dropped file or text.
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Some drag and drop targets contain lines to indicate that the entire contents of
the current application can be dragged out of the drop target. For example,
when you drag the lined area from the Text Editor drag and drop target, the
entire contents of the Text Editor are dragged.

Figure 1-22 Drag and Drop Target Containing a Draggable Object

You can sometimes drop an object directly into a pane that contains data in
order to add the object instead of loading it. For example, you might want to
drop text somewhere within a text pane to insert the dropped text into the
existing text of the pane (instead of replacing the existing text, which would
happen if you dropped the text on the drag and drop target). Another common
example is to drop a file onto a folder in the File Manager to add that file to the
folder.

There are many ways to drag and drop files among DeskSet Applications. The
following are several examples.

® You can print a file by dragging it and dropping it onto the Print Tool icon
or its drag and drop target. Figure 1-23 shows Print Tool’s drag and drop
target. Chapter 10, “Print Tool,” discusses Print Tool in detail.
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T [E) Print Tool K
) ) Drag and Drop
Filename: “F target for Print
Copies: 1 &% Tool
Header: &
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[mimes 1 = Information
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Figure 1-23 Print Tool’s Drag and Drop Target

You can delete a file you no longer need by pressing SELECT on the file icon
in File Manager or in the Attachments window of a Multimedia Mail Tool
message, dragging it to the wastebasket icon, and releasing the mouse
button.

You can drag a text file, folder or other icons from File Manager and drop
them on the Workspace to view it.

You can drag files attached to a Multimedia Mail Tool message window and
drop them onto the Workspace: the application with which the file was
created (such as File Manager, Text Editor, Audio Tool, or Icon Editor) is
invoked and the file is opened in the application window. Refer to

Chapter 2, “File Manager”, or Chapter 4, “Multimedia Mail Tool” for more
information about dragging and dropping with these tools.
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Positioning Windows and Pinned Menus

You can position your windows and pinned menus anywhere on the
Workspace, and can move a window or menu in front of other windows. To
move a window to a new location on the Workspace:

1. Move the pointer to the black line that surrounds an open window or
pinned menu, and press SELECT.
Figure 1-24 shows the pointer on a window edge for repositioning.

Press SELECT
on the window

I outline

F"l\

Figure 1-24 Moving an Application Window

2. Drag the pointer across the Workspace to a new location.
A border box the size of the window moves with the pointer.

3. Release SELECT.
The window appears in the new location.

Moving Multiple Windows

You can group windows together so that they move as a unit. For instance, you
may want to arrange several windows on the Workspace in relationship to one
another, and then move the whole arrangement to a new location.

One way to group several windows is to click SELECT on one of the windows
and ADJUST on each additional window. Alternatively, you can drag the
pointer across the Workspace to form a box around the windows you want to
group. You can do this as follows:
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1. Place the pointer in the Workspace at one corner of the set of windows
you want to group.

2. Press SELECT and drag the pointer diagonally to the opposite corner of
the group.
This forms a rectangle around any windows and icons that are fully
enclosed within the border box.

3. Release the mouse button.
The items are selected as a unit.

4. Place the pointer on the edge of one of the grouped windows as described
in the last section, “Positioning Windows and Pinned Menus,” press
SELECT, and drag the pointer to a new location.

The group of windows moves to the new location.

5. To un-group the applications, press SELECT anywhere on the Workspace.

Moving a Window Front or Back
To move a window in back of another window:

1. Move the pointer onto the header of the window you wish to move in
back.

2. Press MENU, drag the pointer to highlight Back.
Figure 1-25 shows the Back button highlighted on a Window menu.
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Choose Back
from the
Window menu

Mail Tool - /var/mail/egret
(File v)(View v)(Edit v)(Compose v) Mail File:
(Finl_) (Prochain ) (Effacer ) (Repondre v) (Move v ){ Copy v)(Load v)

1 egret Tue Sep 29 11:29  25/560  Look N
2 Mailer-Daemon Fri Oct 9 11:08 35/872 Returned mail:
U 3 mariac@celtic Thu Jan 7 16:52__ 18/496 =
Ne[_4 egret Sat Jan 9 23:42  21/534
-'r File Manager : /hightide/egret/Fish

(File v) (view 9) (Edit v) (GoToi v)

/  hightide egret Fish
(G2 [
Contains 4 items 881 Mbytes (99%) available
Cod [ salmon swordFish [ Tuna

=

i

Figure 1-25 Moving a Window in Back of Another Window

3. Release MENU.
That window moves to the rear.

Alternatively, you can use the Front key on your keyboard, which toggles
back/front depending on the location of the window. (If the window is in back
and you position the pointer in that window and press the Front key, that
window moves to the front. But if it is already in front, it moves in back.)

Moving Icons

You position icons in much the same way as you do windows and pinned
menus. To move an icon to a new location, just move the pointer onto an icon,
press SELECT, and drag the outline of the icon to a new location. When you
release the mouse button, the icon appears in the new place. Figure 1-26 shows
an icon and the outline that appears as it is moved.

Introduction to the Solaris User Environment 25



26

Icon border
moves with the
pointer a4 j
\ ?-
S \
textedit.te z

Figure 1-26  Moving an Icon to a New Location

When you first start an application and then close it to an icon the icon appears
in a default location. You can change the default locations by selecting Save
WorkSpace from Utilities or with the Workspace Properties window.

Chapter 17, “Customizing the Solaris Environment,” describes the Properties
window.

Resizing Windows

The corners of windows are the handles you use for resizing. To resize a
window:

1. Position the pointer on one of the window corners.
The pointer turns into a tiny bull’s eye. This means that the pointer is in the
correct location for resizing.

2. Press SELECT and drag the pointer to the desired size.
An outline shows the size of the window.

3. Release SELECT.
Figure 1-27 shows the pointer positioned on a window’s handle for resizing.
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i cmdtool - /bin/csh 4

Ll T+]]

Window border
stretches as the
pointer is moved

/

Resize corner

Pointer changes
=" g appearance during
window resizing

P W

Figure 1-27 Stretching a Window by its Resize Corner

Closing and Quitting Windows

Each window has a Close option in its window menu. You can access this by
placing the pointer in the header or on the window border, holding down the
MENU mouse button, and highlighting Close, as shown in Figure 1-28.
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Choose Close = - -
from the P_—_ cmdtoeol — /bin/csh
Window menu ,.Aﬂr—@m

Full Size
Move
Resize

(CINEX]i

Back
Refresh
Quit

Figure 1-28 Window Menu with Close Highlighted

When you release the mouse button, the window closes to its icon form.
Alternatively, because Close is the default choice in the window menu, you can
click SELECT on the abbreviated menu button in the window header.

The menu in the window header also includes a Quit option. To quit a window
from the Workspace, move the pointer onto the header or the abbreviated
menu button, press the MENU mouse button, and highlight Quit. When you
release the mouse button the window is dismissed from the Workspace and the
application quits.

You start applications from the Workspace menu, which you display by placing
the pointer in the Workspace and holding down the MENU button. To start an
application of your choice, you drag the pointer to the right to display the
Programs submenu, and then to the name of the application. When the name is
highlighted, you release the mouse button. After a moment the application is
displayed on the Workspace. '
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Elements of an Application’s Base Window

Some applications have one window, and others have one or more
subwindows. The primary window that appears when you display an
application is called a base window. Figure 1-29 shows the visual elements of a
simple base window.

Window

b"t')eadef—d————— e Text Editor — (NONE) (edited), dir; /hightide/e | menu
Abbreviate - , - .
menuebutton/ (File v) (View v) (Edit v) (Find v) /

Menu butto

Button menu —

Window pane

Opening, Saving, Inclu

This is a text file created with text editor. 1
b2
©Q  Edit o
[ GE o Toxt Pane T
Undo o __________Scrollbar
Copy View [
Paste Edit >
Cut Find 4
Extras [

Figure 1-29 Base Window with Pop-Up Menus

ding and Attaching Files

Once you begin working with the DeskSet applications, you will at sometime
need to open, save (or rename), include, or attach a file (or document). There is
a standard window that looks very similar from application to application for
performing these tasks throughout the DeskSet applications. Once you learn
the basic elements of this window, you can easily perform these tasks.

DeskSet applications that use this type of window include: Text Editor, Mail
Tool, Command Tool, Shell Tool, Audio Tool, Image Tool, Snapshot, and Icon
Editor.
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Figure 1-30 shows an example of a standard Open window. This window looks
very similar from application to application, except the window header reflects
the current task. For example, you'll see a reference to the application, such as
Text: and the name of the task following it, like Open, Save, Save As, Include
or Attach.

" Text:Open — 94 This menu bar title changes

Allows you to move or go to d i
A f . epending on the task you
another location in your file Type in the path to the folder and press Return, are completing, such as

system (GoTav)e Open, Save, Include, and so

forth
Current Folder:

/hightide/egret/Fish ——————— Il pjsplays the current location

Select a file or folder and click Open, within the file SyStem
[ 50 a5 one Folder 1= The Scrollbar allows you to
[ycod ] scroll through all of the files
[ DesksetDefaults hd and directories within the
Qeel current folder
[0 Floundermail
[Yimage.rs
[} mailfile
[} NoName
[ salmon
) seafood
{ |

Hidden files are the same thing

Hidden Files: [ Hide | Show | as dot files and you can
dentes - choose to hide or show them

These buttons change
with the task you are

performing, for example, —
-open, save, include Ceen) (Caneel | Dismisses the window

L il

Figure 1-30 An example of the Open Window

Note - You can use File Manager to keep track of documents and folders
(directories and files). Refer to Chapter 2, “File Manager”, for information on
how to use it.
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Opening a Document

To open a document from an application:

1.

Choose Open from the File menu.
An Open window similar to the one in Figure 1-30, is displayed.

Select the name of the folder from the scrolling list.

Click SELECT on the name of the folder, then click Open. Or, double-click
on the name of the folder. If it is not displayed, double-click on “Go up one
folder.” You may need to repeat this a few times.

. Choose the folder that contains the document you want to open.

The name of the folder must be displayed under Current Folder. To display
the folder you can:

a. Select the folder from the Go To menu by pressing MENU on Go To,
then choosing the desired folder from the menu.
or

b. Type the path name of the folder in the Go To text field and press
Return, or click SELECT on the Go To button.

When the scrolling list shows the contents of the folder, select the desired
document and click SELECT on Open.
You can also double-click on the name of the document.

Note — You can use the same steps as opening a document for including a file
from Text Editor or Attaching a file from Mail Tool. The result will be an
included or attached file (or document).

Saving a Document

You may need to save (or rename) a document in one of three stages:

® Saving a new and untitled document

Saving an existing document

Saving and renaming an existing document (Save as)
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Saving a New and Untitled Document

The first time you work with a document (or file), you have to give it a name
and save it to a particular location in your file system.

1. Choose Save from the File menu.
Depending on the application you are working in, you see a Save window
similar to the one in Figure 1-31.

"R Text:Save 3

Type in the path to the folder and press Return,

Current Folder:
/hightide/egret/Fish/Seafood

Select a file or folder and click Open Folder.

[#..Go up one folder... ]

O T=]]

) NewFolder

3

Save: Myfile,

Hidden Files: m

(‘Open Folder) (Cancel)

Figure 1-31 An example of the Save Window

2. Choose the folder location for saving the document.
The name of the folder must be displayed under Current Folder.
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. Select the name of the folder from the scrolling list.

Click SELECT on the name of the folder and click Open, or, double-click
on the name of the folder. If it is not displayed, double-click on “Go up
one folder.” You may need to repeat this a few times.

or

a. Type the name of the folder in the Go To text field or click SELECT on
the Go To button and press Return.

b. Select the folder from the Go To menu: press MENU on Go To, then
choose the desired folder from the menu.

Type a name for the document in the text field and SELECT Save.
When the scrolling list shows the contents of the folder, type a document
name and click SELECT on Save.

Saving an Existing Document

To save changes to the contents of an existing file:

4 Choose Save from the File menu.

The document is saved with the same name and in the same folder.

Saving and Renaming an Existing Document

The following procedure saves a file under a name:

1.

Choose Save As from the File menu.
Depending on the application you are working in, you see a Save As
window similar to the one in Figure 1-31.

Choose the folder location for saving the document.
The name of the folder must be displayed under Current Folder. To display
the folder you can:

. Select the name of the folder from the scrolling list.

Click SELECT on the name of the folder, or, double-click on the name of the
folder. If it is not displayed, double-click on “Go up one folder.” You may
need to repeat this a few times.

or
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a. Type the name of the folder in the Go To text field or click SELECT on
the Go To button and press Return.

b. Select the folder from the Go To menu: press MENU on Go To, then
choose the desired folder from the menu.

4. Type a new name for the document in the text field and SELECT Save As.
When the scrolling list shows the contents of the folder, type a document
name and click SELECT on Save.

Note — When you rename a document without making changes to it, you will
have two versions of the document, one with the old name and one with the
new name. If you work with a file on a daily basis, note the name of the one
you are working with so as not to overwrite the wrong one when you save
your work.

Introduction to the DeskSet Applications

34

DeskSet is the collection of applications which come with the Solaris software.
The DeskSet applications are the default set available from the Workspace
Programs submenu.

The following sections discuss the tasks you will most likely perform on a
regular basis, and introduce the applications you need to accomplish those
tasks. Each of the applications is discussed in detail in following chapters.

To start an application:
1. Move the pointer onto the Workspace (the OpenWindows background).
2. Press (and hold) MENU.

3. When the Workspace menu is displayed, drag the pointer to display either
the Programs or Utilities submenu.

4. Drag the pointer down to highlight the application you would like to
start.
When you release the mouse button, the application appears on the
Workspace. Figure 1-32 shows an application being selected from the
Program’s submenu.
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Q
(_Programs d (File Manager.. )]
| Utilities ]  TextEditor.
Properties... Mail Tool...
Calendar Manager...

workstation Info..
Help... Command Tool..

) Shell Tool..,
Exit...

Clock...

Calculator..,
Performance Meter...
Print Tool...

audio Tool...

Tape Tool...

image Tool...
Snapshot...
Icon Editor...
Binder...
aAnswerBook...

Figure 1-32 Choosing an Application

Follow these instructions whenever you want to start a DeskSet application.
The instructions from now on will say :

“choose Workspace » Programs » application” (where application is the
appropriate application name).

Starting DeskSet Applications

You typically access DeskSet applications from the Programs submenu of the
Workspace menu. You access the Workspace menu by pressing MENU with the
pointer anywhere on the background of your DeskSet environment and off of
all applications. When the DeskSet applications are installed on your system,
they are automatically provided as items in the Programs submenu.

You can also start any of the DeskSet applications from a system prompt in a
Command Tool or Shell Tool window by typing the file name. If you want to
continue doing work in the Command or Shell Tool while the DeskSet
application is running, follow the application name with a space and the
ampersand symbol (&). Table 1-1 shows what you should type to start each
DeskSet application.
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Table 1-1 What to Type to Start DeskSet Applications

What you should
Application Name Type
AnswerBook answerbook &

Audio Tool

audiotool &

Binder binder &
Calculator calctool &
Calendar cm &

Manager

Clock clock &
Command Tool cmdtool &
Console cmdtool -C &
File Manager filemgr &

Icon Editor

Image Tool

iconedit &

imagetool &

Mail Tool mailtool &
Performance perfmeter &
Meter

Print Tool

printtool &

Shell Tool shelltool &
Snapshot snapshot &
Tape Tool tapetool &

Text Editor

textedit &

Working with Text

The OpenWindows Text Editor is an application for working within documents
and composing, editing, cutting, copying, and pasting text. Text Editor enables
you to create and compose a new document or open (load) an existing

document into the application for editing. You can also work with text using a
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command line editor (such as vi) in a Command Tool or Shell Tool. For
information on using vi, refer to Solaris 2.2 Advanced User’s Guide. Figure 1-33

shows the Text Editor application window.

Text Editor — (NONE), div; Zhightide/egret

=
(File v) (View v) (Edit v) (Find v)

ARl

L4

L

Figure 1-33 Text Editor Application Window

Managing Your Files
The File Manager application provides a graphical display of the structure of
the folders and documents (directories and files) in your file system. Each file

appears as an icon, as shown in Figure 1-34.

Introduction to the Solaris User Environment

37



38

7 o

(File v) (View v) (Editv) (GoTo:v) o
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Contains 5 items 877 Mbytes (98%) avalilable
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[ cod (3 salmon [ el 3 swordfish 1]
0 Tuna hd
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L Updated folder: no files added or deleted since last update. ¥,

Figure 1-34 File Manager’s Base Window

Opening a File in File Manager

You can open a file or application displayed in the File Manager base window
by pressing MENU on its icon and choosing Open. When you open a text file
icon, for instance, a Text Editor application is started and the chosen file is
opened in the Text Editor window.

Viewing the Contents of a Folder in File Manager

To look at the contents of a folder, you can press MENU on the icon and select
Open, double-click SELECT on the folder icon or press SELECT on it, drag it
into the Workspace, and release the mouse button. The icon opens into a
window pane displaying the items in that folder.
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Moving Files in the File System

You move files from one folder to another by selecting and dragging them with
the pointer (for instance, from the top level of the home directory to a folder
you have opened on the Workspace) or by cutting them from one folder,
opening another folder, and pasting them there.

Dragging and Dropping

File Manager works interactively with the other DeskSet applications. For
example, if you want to listen to an audio file, you can drag it from File
Manager and drop it onto the Workspace.

To delete a file, you can drag it from its location to the Wastebasket icon. To
send a file to the printer, you drag it and drop it on the Print Tool icon. To save
a file or a set of files on a tape for other processing, you can drag files from File
Manager to the Tape Tool application.

Managing Your Time

The OpenWindows environment provides an icon-based Clock program and
an icon-based calendar, called Calendar Manager. Figure 1-35 shows the
Calendar Manager base window.
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Figure 1-35 Calendar Manager Base Window

Calendar Manager is an interactive application that lets you schedule your
appointments and will send you messages about them on request. For instance,
you can request that Calendar Manager beep or send an electronic mail
message to your mailbox to remind you of important meetings, and you can
check the calendars of others on your network.

Printing Your Documents

To print documents, you use Print Tool. Print Tool enables you to print
documents from a variety of formats, including ASCII, trof £, PostScript®
text, and raster images. Figure 1-36 shows the Print Tool application window.
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Filename:
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Header: &1
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Figure 1-36 The Print Tool Application Window

To print a document, you can drag a file icon from File Manager and drop it on
the Print Tool icon or on the open Print Tool drag and drop target. Another
method is to type the file and pathname in the Print Tool text field and click
SELECT on the Print button. You can also send messages and images to the
printer from Multimedia Mail Tool and from Snapshot—an application that

enables you to take pictures of windows and images on your workstation
screen.

Communicating on the Network

Multimedia Mail Tool provides a convenient method of communicating with
others electronically by sending and receiving messages, sound files, and other
data files. It works together with the Calendar Manager application when you
want to set up group meetings and send electronic notification and automatic
reminder messages, and with Audio Tool when you want to send Voice Mail.
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Hidden Files

The Multimedia Mail Tool icon looks like a tiny in-box. The in-box is empty
when there is no mail; it has stacked letters when the mail in the mailbox has
been read, and overflowing letters when there is new mail. Figure 1-37 shows
the Mail Tool icon in its different forms. The icon opens up into a base window
for receiving, composing, and sending electronic mail messages.

%
= &
mailtool mailtool railtool

Figure 1-37 No Mail; New Mail; All Mail Read

Customizing the OpenWindows Environment

You can modify many aspects of the OpenWindows environment, including
the fonts used in applications and menus, the distance you need to drag the
pointer from a menu to open a submenu, and the window and menu colors.
Additionally, if you are left-handed, you may want to remap the keys on the
left and right panels of the keyboard for ease of use.

Chapter 17, “Customizing the Solaris Environment,” provides instructions for
customizing the OpenWindows environment, including WorkSpace Properties,
keyboard and mouse customization.

Hidden files or “dot” files as they are sometimes called, are distinguished in
your file system with a dot (.) in front of them. These files are normally not
visible to you in your home directory and you should not change or delete
these files unless you have specific knowledge about the file.
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Getting Help

There are two kinds of on-line help available: Magnify Help™ for immediate
assistance with an item in the OpenWindows environment, such as a menu or
window element, and the help handbooks for quick reference on the elements
and applications of the OpenWindows environment.

Note — The OpenWindows “more help” facility (Help Viewer) depends on the
X11/NeWS window server. Therefore, it will not work with a non-
OpenWindows server (for example, the MIT X11 server). In particular, clicking
the More button within a Magnify Help window, or choosing Help from the
Workspace menu fails, and the following error message is displayed on the
console:

XView error: NULL pointer passed to xv_set

helpopen: Viewer could not display document: handbooks/...

Magnify Help

When you begin using the Solaris software, you will find that you can choose
from a variety of windows and menus. When you need information on a
particular window, menu, or object, Magnify Help enables you to get
information quickly.

Follow these steps to get on-line help about a window or menu item:

1. Move the pointer to the item (such as a menu) that you want to know
about.

2. Press the Help key on the keyboard.
This is the F1 key on some systems. A help window pops up with
information about that item.

Figure 1-38 shows a Magnify Help window.
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olwm: Help
Window Border

This is the header, footer, or side of a window
that contains an application program.

4 »|

The border thickens when the window is selected.

To select a window, point to the border and
click SELECT.

Figure 1-38 Magnify Help Window

More Help

Most items on the Workspace have associated help handbooks. When an
associated handbook exists, a button labeled “More” appears at the bottom of
the Magnify Help window. To see more help on that topic, click SELECT on the
More button. Figure 1-39 shows a help window with a More button.

cm: Help
Month \iew

This view displays the current month in a format
that allows you to see all of the appointments
for that month.

Resizing the window scales the view as

appropriate, letting you see more appointments
on a given day.

More )

Figure 1-39 Window with More Button

Dismissing a Help Window

A pop-up window is dismissed when you close or quit the application. If you
would like to close the Magnify Help window before you quit the application,
you can click SELECT on the pushpin in the upper left corner of the Magnify
Help window.
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No Help

A small pop-up window appears if no Magnify Help is available, stating that
there is no help for that item. The pointer jumps to the OK button, and you
must click SELECT to continue.

Help Viewer

The help handbooks provide introductory information to guide you through
the OpenWindows environment. These are presented in a concise format in the
Help Viewer. The “Introducing Your Desktop” handbook is a tutorial that
describes basic OpenWindows operations. The other handbooks provide task-
oriented steps on individual topics. In addition, there is a handbook that
describes how to navigate in the on-line help system. You can browse all of the
handbooks in any order you choose.

Desktop Introduction

You can access the introductory handbook, “Introducing Your Desktop” from
the Workspace menu, as follows:

1. Move the pointer onto the Workspace and press MENU.
The Workspace menu appears, as shown in Figure 1-40.

& Workspace

(" Programs >
Utilities >
Properties...

workstation Info..

Help.. |Choose Help

Exit..

Figure 1-40 Workspace Menu
2. Drag the pointer to choose Help.

When you release the mouse button, the Help Viewer appears displaying a
list of handbooks.
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3. Double click SELECT on “Introducing Your Desktop”.

Figure 1-41 shows the Help Viewer selection.

o

Help Viewer

=

Help Handbooks

@ Double-click SELECT on any of the choices below.

Introducing Your Desktop

[About Calendar M%ﬂ

Figure 1-41 Selecting Introducing Your Desktop

The on-line tutorial, “Introducing Your Desktop,” opens in the Help Viewer,

as shown in Figure 1-42.
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Menu buttons
for modifying
what and how _—"]

you view

i

Help Viewer

Introducing Your Desktop

Everything on your screen is part of your desktop, which
includes many features to make your work easier. This
introduction presents the basic skills you need to start using
your desktop.

As you begin this introduction, rest
the mouse on its silveryblue pad, with
the pad horizontal and the mouse cord
pointing away from you

Move the mouse on its pad. Notice how each movement is
reflected by a black, arrow-shaped pointer on the screen.

For most of your work you'll use the left mouse button,
called the SELECT button. Use the mouse to turn this page:
SELECT

4+ Move the pointer over the button above and
click (press and release) the SELECT button once.

dﬁ) Tof 45

Table of Contents

]

Exit

AboutHelp

h "Desktop Intreduction” at 100%

For a description of
how to navigate with
the Help Viewer and
Magnify Help, Double-
Click SELECT here

Figure 1-42 First Page of the Desktop Intro Handbook

Help on Help

You can view a description of how to navigate in the help system. Double-click
SELECT on the “About Help” icon shown in Figure 1-42. (Alternatively, you
can click SELECT once on the icon and then click SELECT on the View menu
button.) This option is available from any help handbook. Note also that there
is Magnify Help (described in “Magnify Help” on page 43) for each element on

the Help Viewer.

Introduction to the Solaris User Environment
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Other Handbooks

You can access help handbooks that describe the DeskSet applications and the
OpenWindows Workspace by following the steps below. Note, however, that if
you are currently displaying the first page of any handbook, you can bypass
these steps by double-clicking SELECT on the More Handbooks icon at the
bottom of the Help Viewer.

To access the help handbooks at any time:

1. Move the pointer onto the Workspace and press MENU.
The Workspace menu appears.

2. Drag the pointer to choose Help.
When you release the mouse button, the Help Viewer displays the help
handbook table of contents that lists handbooks, as shown in Figure 1-43.
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Double-click SELECT on any of the choices below.
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About Binde;
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bout Clock]
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About Tape Too
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I
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About the Workspace|

Figure 1-43 Help Viewer

3. Double-click SELECT on the topic of your choice.
The Help Viewer then displays the table of contents for the selected
handbook.

Quick Access to Help Handbooks

Introduction to the Solaris User Environment

You can accelerate access to a help handbook from any DeskSet application,
icon, or menu by pressing Shift and then Help on your keyboard. As an
example, position the pointer over an area of interest, such as the Mail Tool
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application window, and press Shift-Help. The Help Viewer appears on the
Workspace, displaying the appropriate handbook, in this case “About Mail
Tool.”

Navigating through Handbooks
When you display a particular handbook, you have several choices. You can:
1. Page through the handbook.
2. Double-click SELECT on a topic to access that information quickly.
3. Return to the table of contents of help handbooks.
4. Return to a handbook’s table of contents from within that handbook.

The following sections describe these operations.

Paging through a Handbook

The buttons at the top of the Help Viewer enable you to move backward or
forward, page by page. Clicking SELECT on the Next Page and Previous Page
buttons is equivalent to pressing the PgUp and PgDn buttons on your
keyboard. Figure 1-44 shows the help handbook paging buttons.

Help Viewer

Figure 1-44 Buttons for Paging Through the Handbooks
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The Go Back button gives you the option to go back to the last page viewed.
Click SELECT on the Go Back button to return to wherever you were last. If
you have viewed pages in various parts of a handbook or in different
handbooks, you can retrace your steps by choosing Go Back as many times as
necessary.

The paging features are also available from the Viewer menu, shown in
Figure 1-45.

© viewer

Next Page
Previous Page
Redisplay

Go Back

Figure 1-45 The Viewer Menu

To use the Viewer menu:

1. Position the pointer in the Help Viewer window and press MENU.
The Viewer Menu appears.

2. Move the pointer to the pushpin and pin up the Viewer menu if you want
to keep the menu up for repeated use.
When you release the mouse button, the menu remains.

3. Click SELECT on a menu item to page down, page up, redisplay (refresh)
the window, or go back to your last location.
Alternatively, if you have not pinned the menu, just choose a menu item
using the MENU mouse button.

Note — As with any DeskSet application or pinned menu, you can move the
Viewer menu by positioning the pointer on the menu outline, pressing SELECT
and dragging the pointer to a new location.
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Help Viewer’s/f‘ Help Viewer E

menu button

!—I&pertext
links to topics
within the
handbook

are outlined —____ |

Hypertext icon
returns you to

main table of ____{

contents

‘Using the Handbook Hypertext Links

The help handbooks can be used in a non-linear fashion. When you see an
outlined reference to more information, you can double-click SELECT on that
portion of the text to go to the referenced location. The black outlines indicate
hypertext links. From the main table of contents for the handbooks, you can
access a handbook quickly by double-clicking SELECT on the handbook’s title.
Within a given handbook, you can double-click SELECT on one of the links
within that book to go to that topic. Figure 1-46 shows the hypertext links in
the table of contents for the Calendar Manager help handbook.

(View  v) ((Magnify v) (Previous Page) ((GoBack) ( Next Page}

About Calendar Manager

Double-dick SELECT on any of the choices below.

What Calendar Manager Offers|
Calendar Manager Views|

Bcheduling and Editing Appointments|
———__ Customizing Calendar Manager|
[Printing a Calendar View|

[Browsing Calendars|

Mailing a Calendar Reminder|
[Opening a Mail Message]

More Handbooks
| "About Calendar Manager” at 100% r

Figure 1-46 Table of Contents with Hypertext Links
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Returning to a Handbook’s Table of Contents

When you have chosen a handbook, and selected a topic within that handbook,
you can return to that handbook’s table of contents by double-clicking SELECT
on the Table of Contents icon (see Figure 1-47) at the bottom of the handbook.

Table of Contents J

Figure 1-47 The Table of Contents Icon in a Handbook

Returning to the Main Table of Contents

To return to the main table of contents for all the help handbooks, navigate to
the first page of the current handbook and double-click SELECT on the More
Handbooks icon at the bottom of a page (shown in Figure 1-46).

Closing the Help Viewer

You can close the Help Viewer to an icon until you need it next. To close Help
Viewer, click SELECT on the abbreviated menu button in the upper left corner
of any handbook.

Figure 1-48 shows the Viewer icon.

Figure 1-48 Viewer Icon

Double-click SELECT on the Viewer icon when you want to open it again.
Exiting the Help Viewer

You can exit the Help Viewer from any location by choosing Quit from the
Window menu.
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Double-clicking SELECT on the Exit icon at the bottom of the page of
Introducing Your Desktop handbook displays instructions for quitting the
tutorial handbooks. Figure 1-49 shows the Exit icon.

Exit

Figure 1-49 The Exit Icon in Introducing Your Desktop

On-line Documentation: AnswerBooks

54

As you use your system and its software, you can browse, search, bookmark,
and print from manuals right on your screen in your own on-line Library. Your
Library may contain one or more AnswerBooks, or collections of documents
covering many topics.

In your Library you may find the Solaris 2.2 AnswerBook Administration Guide, a
collection of basic manuals to help get you started using your Sun system.

Note - To give you access to AnswerBooks, your administrator has to install
and configure them for your use. See Solaris 2.2 AnswerBook Administration
Guide for more information.

¢ To open your on-line Library, choose
Workspace»Programs» AnswerBook.
Then refer to Chapter 19, “Using AnswerBooks” for information on how to
use AnswerBooks and your on-line Library.
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File Manager Icon

File Manager 2

File Manager provides a graphical display of the UNIX file system, using icons
that represent directories (folders), files (documents), and applications.

You can use File Manager to find, copy, move, open, close, delete, undelete,
create, and print files. You can start applications from File Manager, and
reorganize your file system by moving or copying files between folders. You
can also use File Manager to link files and to transfer files to other machines.

In addition, the icons representing individual parts of the file system can be
dragged out of the File Manager window onto the workspace or onto other
DeskSet application icons or windows.

The primary icon for File Manager looks like a file folder. The name of the
current directory is displayed beneath the folder, as shown in Figure 2-1.

.................................

Figure 2-1  File Manager Icon
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File Manager Base Windows
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The primary File Manager base window displays your file system and allows
you to manipulate it. The secondary base window is a Wastebasket that you
can use to remove files from your file system. When you start File Manager, the
Wastebasket window is normally started and displayed as an icon. The
Wastebasket is described in the section “Using the Wastebasket” on page 92.

The primary File Manager window, shown in Figure 2-2, provides a set of
controls that you can use to manipulate your file system. The window has a
path pane that displays the file system hierarchy and a scrollable file pane that
displays the contents of the open folder in the path. You can open many
windows from within File Manager, and File Manager works the same way

within each window.

(=) File Manager : hightide/earet

(File v) (view v) (Editv) (GoToi v) .

Path Pane _|

/  hightide egret

Status Bar

File Pane

(el 12}

Contains 8 items

875 Mbytes (98%) ava

Artfiles dead.letter

Fish my_printscript

-+

dead.letter.1

Figure 2-2  Primary File Manager Window
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File Manager File Icons

The files in your file system, by default, are represented by three kinds of icons,
which are similar to application icons on the workspace. Directories are
displayed as folders. Files such as documents, graphic files, and spreadsheet
files are displayed as dog-eared sheets of paper. Executable files (applications)
are displayed as an application icon. Figure 2-3 shows these three file type
icons.

Folder my_file my_printscript

Figure 2-3  Three Types of File Icons

File Manager checks the Binder database for information bound to each file
being operated on. Every file displayed can have its own file type. Each file
type can have its own icon, open method, and print method stored in the
Binder database. When File Manager displays a folder, it gets the information
from the Binder database on how to display and operate on each file.

When a file is not bound to a specific icon, its generic icon is displayed. In the
example shown in Figure 2-4, the files are bound to different application types.
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'—]E] File Manager : /usr/openwin/bin L
(File ) (view v) (Edit v) €
/ usr openwin bin
0ETT) 0
Contains 210 items 351 Mbytes (33%) available
[
book audiocontrol bitmap brushtopbm a
,
es audiotool bldfamily calctool
i &
bm bdftosnf bldrgh capitalize
@n binder bmtoa ce_db_build
e
(-T2} I
L o

Figure 2-4  Data File Icons that also Show the Application Type

You can create your own images for files using the Icon Editor, and bind them
to the File Manager data file icons using the Binder. See the chapters “Icon
Editor” on page 429 and “Binder” on page 451 for more information.

Selecting File Manager Icons

In order to operate on File Manager icons, you first need to select them.

You select a File Manager folder icon in the path pane by moving the pointer
onto it and clicking SELECT.

You select a single icon or group of icons in the file pane by clicking SELECT
on the first icon and clicking ADJUST on each additional icon that you want to
include in a group. Selected icons are highlighted. Exclude an icon by clicking
ADJUST on an icon that is already selected.
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Control Area Menus

You can select an adjacent group of icons by pressing SELECT to define one
corner of a rectangle surrounding the group of files, dragging the pointer to the
opposite corner, and releasing SELECT. You can select an additional group of
icons using the same method with the ADJUST mouse button.

Double-Click Accelerators

You can double-click SELECT on any individual icon to open it.
Double-clicking SELECT on any folder in the path pane or the file pane opens
it and displays its contents in the file pane. Double-clicking SELECT on a data
file starts the application for that data file and usually displays its data.
Double-clicking SELECT on an application icon starts the application.

Panning Through the Tree and File Panes

A feature provided by File Manager is the ability to pan through file panes.
This lets you scroll through the panes without using the scrollbars. Panning is
like “gluing” the contents of a pane to the current pointer, so that when you
move the pointer, the entire contents of the pane moves with it.

You initiate panning by following these steps:
1. Move the pointer to the place where you want to start panning.

2. Press the Meta key on the keyboard, and then press SELECT.
When the pointer changes to the panning pointer (a curved arrow pointing
down), release the Meta key.

3. Drag the pointer to a new location within the pane, and release SELECT.
The contents of the pane move along with the pointer. Repeat these steps if
necessary to reach the desired location.

The control area has four menu buttons: File, View, Edit, and Go To; Go To has
a text field. This section shows each of these controls and provides a brief
introduction to each of the items. Figure 2-5 shows the menu buttons within
the File Manager control area.
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Menu Buttons

Path Pane

File Menu

r'@ File Manager

{File v) (View v} (Editv) (GoTo v) &

/  hightide egret
(G 12

Figure 2-5  File Manager Control Area Menu Buttons

The File menu provides choices that you can use to perform filing functions.

Use Open to open selected folders and files. Open is inactive unless you
have made a selection in the file pane or path pane.

Use Open in Editor to open the file in the Text Editor.

Use Create Document to create a new document.

Use Create Folder to create a new folder.

Use Duplicate to create another version of the selected item(s).

Use Print One to print your selection to your default printer. Print is inactive
unless you have made a selection in the file pane.

Use Print to print selected files using your own print method and specified
printer. You can select the number of copies to print. Print is inactive unless
you have made a selection in the file pane.

Use Find to display a pop-up Window that you can use to find files. See
“Using the Find Pop-up Window” on page 89 for more information.

Use Information to find out information about your file. See “File and
Folder Information” on page 97 for more information.

Use Remote Copy to open a pop-up window for remote transfers. See
“Transferring Files From Your System to Another” on page 85 for more
information.

Use Custom Commands to run your own customized commands, or to pop-
up a UNIX shell that you use like any other Shell Tool. See “Customizing
Your File Manager” on page 99 for information.
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View Menu

® Use Check for Floppy to bring up window, if floppy has been inserted.

¢ Use Quit File Manager to quit the File Manager. This does preserve the way
you had your icons set up in the window.

Note - The following two items are only visible if you are using a floppy disk.

¢ Use Format Floppy to format a floppy in your disk drive. For more
information, see “Using Floppy and CD Media” on page 118.

® Use Rename Floppy to rename the floppy inserted into your disk drive. For
more information, see “Renaming a Floppy Disk” on page 125.

From the Base Window, the View button has a menu with choices for different
ways to view the file system. These are Open Folder View, Large Icon View,
Small Icon View, Icon By Name, Icon By Type, List by Name, List by Type, List
by Size, List by Date, and Cleanup Selection. Refer to “Folder View” on page 62
for information on the Folder View. Otherwise, use these display options to
choose how the contents of the file pane are displayed and sorted:

® Use Large Icon View for viewing icons at regular size. You can move these
icons around in the file pane.

¢ Use Small Icon View for viewing icons at reduced size. You can move these
icons around in the file pane.

¢ Use Icon by Name to sort the large icons alphabetically by name.

® Use Icon by Type to sort the icons in alphabetical groups by file type, with
folders first, followed by files, then by applications.

* As alisting, to show you more information about each individual file.
* Use List by Name to sort the files alphabetically.

* Use List by Type to sort the files in alphabetical groups by file type, with
folders first, followed by files, then by applications.

* Use List by Size to sort the files by size, largest to smallest.
*» Use List by Date to sort the files from newest to oldest.

¢ Use Cleanup Icons for putting all icon(s) in order to the nearest grid point. If
icon(s) are selected, use Cleanup Selection for putting selections in order to
nearest grid point. Each grid point is determined by the width of the largest

' name.
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Edit Menu

Edit has a menu with options for editing.

Use Select All to select all the files in the file pane.

Use Cut to remove selected icons from a folder and place them on the
clipboard. Cut is inactive unless you have made a selection in the File pane.

Use Copy to put a copy of selected icons on the clipboard. Copy is inactive
unless you have made a selection in the File pane.

Use Link to link files together. See “Linking Files” on page 95.

Use Paste to paste the contents of the clipboard at the next available grid
point in File Manager. Paste is inactive unless something is on the clipboard.

Use Delete/Destroy to remove selected file names from a folder, and place
them in the Wastebasket or really delete them, depending on the File
Manager Properties setting. See “Using the Wastebasket” on page 92 for
information about the Wastebasket.

Use Properties to customize your File Manager. See “Customizing Your File
Manager” on page 99 for information.

Go To Menu and Text Field

The Go To menu has choices (that can be set by you in properties) that allow
you to quickly go back to your home directory or to other directories that you
have recently accessed. You can also type the path name of a folder you want
to go to in the Go To text field. See “Using the Go To Text Field and Menu” on
page 87 for more information.

Use Folder View to look at your folder hierarchy. The Folder View opens a
separate window that displays only folders and shows how folders are stored
in the hierarchy. You can open each of your folders into a separate window by
selecting the folder and:

¢ Selecting View »Open Folder View.

Figure 2-6 shows a Folder View.
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Figure2-6  Opening the Folder View

The hierarchical Folder View (tree structure) is another way of showing the
UNIX file system. The analogy between the parts of a tree and the parts of the
file system is often used when describing the UNIX file system. The Folder
View can show all parts of the file system. Alternatively, you can use the Folder
View to start at any directory or folder in the file system.

Root is the top directory in the file system. Under the root are various branches.
For example, Figure 2-7 shows root and the branches that start with the
directories /, home.

Along with the tree analogy, there is a parent/child analogy. The root directory
is the parent directory. A subdirectory is also a parent directory when there are
one or more subdirectories below it. Each subdirectory is a child of the parent
directory that is above it.
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The File menu from the Folder View has the following options: Open (Opens
the children of the selected folder), Open Folder Window (Brings up the File
Manager folder pane), Find, Information, Remote Copy, and Custom
Commands.

The View menu from the Folder View has the following options:

* Use Show Horizontal/Vertical to change the view orientation from
horizontal to vertical or visa versa.

¢ Use Show All Sub Folders to show all folders below the selected folder.
¢ Use Hide Sub Folders to “hide” all sub folders below the selection.

* Use Start Folder View Here to begin showing the folder view from the
selected folder.

* Use Add Parent the parent of the folder selected folder.

Go To can be used the same way as described in “Go To Menu and Text Field”
on page 62.

Folder View Options

The Folder View contains commands that you can use to “prune” the Folder
(or tree) view so that it contains branches of the tree that are useful to you and
hides other folders that you may not need to access.

If you frequently move or copy files between folders, you may find that using
the Folder View allows you to perform more operations using drag and drop,
since more folders can be displayed in the Folder View.

When you open the Folder View window, you can choose the following
options:

¢ Hide Sub Folders

® Show All Sub Folders

¢ Begin Tree Here
® Add Tree’s Parent

Subfolders are folders that are farther down the tree than the current folder.
Figure 2-7 shows a Folder View that contains most of the folders from the root
directory downward.
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Figure 2-7  Example of a Folder View

The following examples show a series of progressions, using each of the view

modification commands from the Folder View.

File Manager

65



Clicking SELECT on the home folder and choosing Hide Subfolders from the
Folder View results in the display shown in Figure 2-8. Compare that display

with the one shown in Figure 2-7.

"= FM: Folder View: Zhightide/egret/root R
(File v) (View v) (GoTol v)
-
- -
v
home v
2
(el 1] {
i home selected .

Figure 2-8  Example of Hiding Subfolders
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Choosing Show Subfolders from the (Folder View) View menu produces the

display shown in Figure 2-9.

=) FM: Folder View: /hightide/egret/ 1
(File v) (View v) (GoTo v}
o
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OceanFish
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Figure 2-9  Example of Showing Subfolders
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With the fish folder selected, choosing Begin Tree Here from the View menu
changes the display as shown in Figure 2-10.

r‘ FM: Folder View: /hightide/egret/root/home/Fish i
(File v) (View v) (GoTo )
— |
&
Bait .
Fish 1
Seafood
—
IEINEY 0
LFish selected i

Figure 2-10 Example of Changing the Beginning Point of a Folder View
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Choosing Add Tree’s Parent from the Folder View adds one folder farther up
the path, and its subfolders, as shown in Figure 2-11.

r@ FM: Folder View: /hightide/egret/root/home !
(File v) (View v} (GoToi v)
—— )
&
d
Seafeod
ﬁ FreshwaterFish
home
NewFolder
OceanFish
-
G i
L home selected K

Figure 2-11 Example of Adding a Parent Folder

Path Pane

The path pane shows your current location in your file system.

Parts of the Path and Folder View

The path displayed in the File Manager window shows only the folders for the
directory and subdirectories that lead to the current folder, which is the folder
that is open. Any folders below it in the tree are subfolders. An example of a
path is given in the window in Figure 2-12, which shows the path for
/root/hightide/egret.
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|
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Path Pane

Figure 2-12 A home Directory in the Path Pane

Path that is Displayed

When you start File Manager for the first time, it displays the path of the
directory from which you started it. The next time you start File Manager, it
remembers your last location before quitting, and you see the things the way
you left them. If you choose File Manager from the Programs submenu, it
displays the path for your home directory. The last folder in the chain is open,
and its contents are displayed in the file pane, as shown in Figure 2-12.

Use the Open Folder item on the Path pane pop-up menu to open a selected
folder.

4 Display the Path pane pop-up menu by moving the pointer on the
background of the Path pane and pressing MENU.

Once a folder has been selected in the Path Pane, all of the Base window
commands are available to you except the following: Duplicate, Print One,
Print, Format Disk, Rename Disk.
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Figure 2-13 Example of a Horizontal Folder View (Tree Structure)

As you move around from folder to folder by double-clicking SELECT to open
each one, Folder View expands to show subfolders and rearranges the other
branches of the file system tree.

After you open a folder, an open folder icon indicates that the folder has been
opened. For example, in Figure 2-13, the folder labelled home has been opened.

You can expand or reduce the number of folders in the Folder View by
choosing View items from the Folder View menu: You can toggle between
showing Horizontal and Vertical views, Show All Sub Folders, Hide Sub
Folders, Start Folder View, and Add (the folder’s) Parent. Once you have
chosen one of these items from the menu, File Manager remembers it. When
you choose Folder View again, the view displayed is the last format that you
chose for the Folder View. See “Customizing Your File Manager” on page 99
for examples of these other kinds of displays.
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File Pane

The file pane displays the contents of the open folder in the path pane. When
you first start File Manager, the file pane displays icons with names beneath
them, as shown in Figure 2-14.
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Figure 2-14 Icons in the File Pane

File Pane Pop-up Menu
To use the File Pane pop-up menu:

¢ Press MENU from within the File Pane.
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Depending on whether you have a folder or file selected, all or some of the
following options are available from this menu: Select All, Cut, Copy, Link,
Paste, Delete, Print One, Print, Cleanup (Selection). For information on Cut,
Copy, Paste and Delete refer to File Menu on page 60. For information on Link,
refer to “Linking Files” on page 95. For information on Cleanup Selection, refer
to “View Menu” on page 61.

Alternative Display Options

You can change the way icons are displayed in the file pane by choosing
options from the View menu and you can change the default displays from the
Properties window. See “Current Folder Settings” on page 110 or “New Folder
Defaults” on page 102 for more information.

Large Icon View

Choosing Large Icon View from the View menu displays a list of standard-size
icons with the name of the icon centered below it as shown in Figure 2-14.
When application images are specified by the Binder, those images are
displayed. You can move these icons around.

Note - Sorting large icons looses all position information for the large icon
view.

Small Icon View

Choosing Small Icon View from the View menu displays a list of small sized
icons with a name centered below it. The small icon show you whether each
file is a folder, data file, or an executable program file. The small icons are
shown in Figure 2-15.

CIFish [ rasterfilers my_printscript

Figure 2-15 File Manager List Display Small
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Note — Small icons do not display custom icon images for files (as displayed in
the Icon View modes).

Icon By Name

Choose Icon By Name if you want to view your icons as large icons ordered
alphabetically.

Icon By Type

Choose Icon By Type if you have several different types of icons in one folder.
The order of icons listed is folder, file (or document), and application or
program.

List By Name

Choosing the List By Name option shows a list of icons and file names, as
shown in Figure 2-16. You can select and operate on small icons in the same

way as for standard-sized icons. These are listed as one entry per line. The
default is icon, name, size, and date.

‘_' File Manager :

(File v) (View v) (Edit v) (GoTo! v) &

/ hightide egret Fish Seafood
[lel o}

Contains 4 items

0 Catch_of __the_Day.ps Feb 17 14:06 76154

[ rish Feb 17 14:06 5504
[ NewFolder Feb 17 14:06 512
[3 saimon Feb 17 14:06 31

Figure 2-16 Example of a List Display
When using the View menu, you can choose to display additional information

about each file such as the Date, Size, Owner, Group, Links, and Permissions.
When displaying any of these file attributes, the display changes to show one
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List By Size

List By Date

Opening Files

item per line. For complete information on file information (or properties),
refer to “File and Folder Information” on page 97. You choose the information
to display by changing the default settings from the Customize View window.
See “New Folder Defaults” on page 102 or “Current Folder Settings” on

page 110 for more information.

Choose List By Size if you want to view your files from the largest file (in KB)
to the smallest file.

Choose List By Date if you want to view your files from the newest (date last
modified) to the oldest date.

When you select and open a data file, the appropriate application is started
and the data of the opened file is displayed in the application’s window. When
you select and open an application or executable file, the application is started.
Executable shell scripts display a Notice asking you if you want to start the
script in a Shell Tool. You can change your properties to have your folders
open into the same window or separate windows. For complete information on
this refer to “General Defaults” on page 101.

From the file pane, you can open folders, files, and applications in the
following ways:

® Dragging and dropping selected folders onto the workspace.

® Dragging and dropping selected files or applications onto the workspace,
then using the menu or double-clicking SELECT on the icon or open
window.

¢ Choose File »Open or double-click SELECT on a data file or application
icon.
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Note - When you open a file or an application from File Manager, you cannot
close or quit it by dragging it back onto File Manager. You quit any window or
icon on the workspace by choosing Quit from the Window menu.

Creating New Files and Folders

You can create new files and folders in the file pane, which puts them in the
folder where they are created.

To create a new file or folder, follow the steps below:

1. Check to be sure you are in the folder where you want to create the new
file or folder.
If necessary, select another folder and click Open.

2. Choose either Create Document or Create Folder from the File menu.
An empty file called NewDocument (for a file) or NewFolder (for a folder)
is created in the file pane. Subsequent new documents or folders are
numbered in sequence. For example, if you create a file called
NewDocument and a file with this name already exists, the new file will be
called NewDocument . 1. The next new document will be called
NewDocument . 2, and so forth. The name of the new document or folder is
highlighted and underlined when it is first displayed, which means it is
ready to be renamed. Figure 2-17 shows a new folder in the file pane.
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(File v) (View v) (Edit v

/  hightide egret Ocean
(Cel L2}

Contains 4 items

Figure 2-17 New Folder in the File Pane

Naming a Document or Folder

When the name of a file or folder is highlighted and underlined, the name is an
editable text field. You can change the name of any folder or file by clicking
SELECT on its name to select it and display an editable text field. You can edit
the contents of this text field in the same way you edit any other text field.
When you have changed the file name, press Return or click SELECT on the
background of the file pane. You can also change the name of a file using the
Information popup window. See “File and Folder Information” on page 97 for
more information.

Moving and Copying Files

You can move and copy icons that are displayed in the File pane using cut,
copy, paste, choosing Duplicate from the File menu, or using the drag and drop
operation.
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Using Cut, Copy, Paste

You can move or copy files within File Manager using the Cut/Copy/Paste
commands. Cut/Copy/Paste commands are provided on the Edit menu, the
File Pane pop-up menu, and as function keys on the keyboard. When you cut
material, it is not deleted. It is put on a clipboard, where it is stored
temporarily. Only one item or group of items is stored on the clipboard at a
time.

Note - If you do another cut without using what is on the clipboard, the
previous information is lost.

Moving or Copying Files and Folders Using Cut and Paste
To move or copy folders and files using the clipboard, follow these steps:

1. Select the file or files you want to copy or move.
The icon is selected. If you want to move a group of files or folders, click
ADJUST on individual icons to add them to the group. If the icon is already
selected, clicking ADJUST deselects it, removing it from the group.

2. Choose Cut or Copy from the Edit menu.
Use Cut, or Copy to copy a file. The file or files are moved or copied to the
clipboard.

An instruction message is displayed in the footer, as shown in Figure 2-18.

P

Copy these file(s) by opening the target folder and selecting ‘Paste’

Figure 2-18 Messages when Files are Cut to the Clipboard

3. Open the folder you want to receive the files.

4. Choose Paste from the Edit menu or the File Pane pop-up menu, or press
the Paste key on the keyboard.
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Using Drag and Drop in File Manager

You can use the drag and drop operation to copy and move files from the
Folder View, path pane, or file pane to the following destinations:

Any icon onto any folder icon in pathpane, file pane, or folder view
Onto the background of any open File Manager file pane

Onto the Wastebasket icon or window

Onto the any folder icon on the workspace

You can use drag and drop between tools such as:

® Onto the Mail Tool Compose icon or window (attachment pane)

® Onto the Text Editor icon, text pane, or drop target

® Onto the icon or drop target of Print Tool, Tape Tool, Icon Editor, Snapshot,
Audio Tool, or any other application supporting the drag and drop.

Moving or Copying Files and Folders Using Drag and Drop

To move or copy a file or folder into another folder within File Manager when
both the source and destination icons are visible, follow these steps:

1. Select the file or folders that you want to move or copy.

2. To move, press SELECT on a selected file and drag the pointer onto the
destination folder. To copy, press the Control key together with SELECT
on a selected file, and drag the pointer onto the destination folder.
Pointed becomes actual icon being dragged. The tip of the arrow defines the
destination of the move operation.

3. Release SELECT.
The file or folder is moved or copied to the new folder.

Dragging and Dropping a Document Icon onto the Workspace

You can drag and drop data file icons from File Manager onto the Workspace.
When you drop the icon onto the workspace, it starts the appropriate
application, and opens the file.
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Dragging and Dropping a Folder onto the Workspace

You can drag and drop individual folders from File Manager onto the
Workspace. When you drop the folder onto the workspace, it is opened, and
the contents of the folder are displayed in a new window. If you switch
frequently between directories, you can use this feature to display the contents
of more than one folder at a time.

To drag and drop a folder onto the workspace, follow these steps:
1. Click SELECT on a folder to select it.
2. Press SELECT and drag the folder onto the workspace background.

3. Release SELECT.
The window is opened, and the contents displayed, as shown in the
example in Figure 2-19.

File Manager : /hightide/

(View v) (Editv) (GoTa v) o

/  hightide egret
3
iom 1 File Man:
Contains 10 ite
r (File v) (View v) (Editv) (GoTo v) 4
Artfiles /  hightide egret Fish
s] 2]
Freh Contains 8 items
— 0 cod Feb 17 14:06 31
(3 DesksetDefaults Feb 17 14:08 2230
mail @ kel Feb 17 1406 ©
@ [ itftip.rs Feb 17 14:06 28192
[ salmon Feb 17 14:06 3
root [ seafood Feb 17 14:06 512
swordfish Feb 17 1406  ©
Bt Tuna Feb 17 14106 ©

Figure 2-19 Folder Opened into a new File Manager Window

4. Close folder to an icon on the WorkSpace.
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Dragging and Dropping Between Tools

You can use drag and drop in the following ways between tools.

Dragging and Dropping a File onto another Application

You can drag and drop a file onto another application outside of File Manager,
regardless of whether the application is displayed as an icon or as an open
window. If you drop a file with an inappropriate format onto a window or
icon, the move or copy is not performed.

When you drop a file onto the drag and drop target or icon of an application,
the file is loaded into the application. Follow these steps to load a file into
another application:

1. In File Manager, click SELECT on the file icon that you want to load.

2. Drag the file onto the application icon or drag and drop target, and release
SELECT.
The file is loaded into the application. Note that when you drag and drop a
file to an application outside of File Manager, the file is always copied. The
original file remains in File Manager. For example, if you move a file from
File Manager to Print Tool, the original file is not deleted after it is printed.

If the application cannot accept the file format, the file is not loaded. When you
drop an icon of an incompatible file type onto an open window, or when you
drop an icon onto an inappropriate location, an error message is displayed in
the footer of the destination window.

Dragging and Dropping Mail onto File Manager

When you receive a mail message, you can drag and drop individual mail
attachments onto File Manager, or you can drag and drop the entire mail
message onto File Manager. See “Mail Tool Attachments” on page 174 for
information about mail attachments.
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Copying Mail Attachments onto File Manager

When you receive a mail message that contains attachments, you can access the
attachments by dragging and dropping any or all of them onto File Manager.
The attachment files are then available for you to use just like any other File
Manager file. You can drag and drop the attachments onto File Manager using
the following steps:

1. Open both File Manager and Mail Tool.

2. Open the folder window in File Manager where you want to put the
attachment(s).

3. In the Mail Tool application, click SELECT on the attachment that you
want to move or copy. Click ADJUST on any additional attachments that
you want to include.

4. Press SELECT and drag the pointer.
A small glyph of the type of file being moved is displayed, as shown in
Figure 2-20.
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e/egret/

(_File v) (View v) f = Mail Tool - [None]

Mail File: (5],
Mail Toel : Compose Message

/  hightide egret

ARE] (Include v) (Deliver v) (Header v) (Clear) ((Attach v)
, . To:
Contains 5 items | Subject:
] =
Fish

Freshwater>

|
OceanFish
NewFolder

Attachments (Edit )
<] [#] :
Updated folder: 4 files of ‘Ba
appointmentapt

Data transfer in progress...

Figure 2-20 Dragging a Mail Attachment onto File Manager

5. Drag the pointer onto the File Manager file pane and release SELECT.
The attachment appears in File Manager with its original name and data

type.

Copying Entire Mail Messages onto File Manager

You can copy an entire mail message to File Manager, including all
attachments. The message and attachments are then combined into one file. If
you drag and drop a mail message onto File Manager that doesn’t have any
attachments, the message is saved as a simple text file. To copy an entire mail
message to File Manager, follow these steps:

1. Open both File Manager and Mail Tool.
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2. Open the folder window in File Manager where you want to put the mail
message(s).

3. In the Mail Tool application, click SELECT on the header of the mail
message to be copied or moved.

4. Press SELECT and drag the pointer.
A small mail file icon is displayed, as shown in Figure 2-21. You can release
the Control key any time after the envelope is displayed.

4 (File v} (View v) (Edit v) (i

/  hightide egret Fish
 [omD)

4 Contains 10 Items 873 Mby
4 D Mail Tool —/var/mail/egr
2 Cod od (File #) (View v) (Edit v)((Compose v) Mail File: (g),_
(Done J(Next ) (Delete) (Reply v) (Move v)(Cop:
- 1 thief@cici Thu Feb 18 10:42  18/508 Yo
Seafood + 2 patten@newbirth Thu Feb 18 10:49  46/1282 Pni
U 3 bgahl@scuba Thu Feb 18 10:50  32/1110 Inl
M U 4 ayers@outhouse Thu Feb 18 10:51  17/532  Su
— 5 ayers@outhouse Thu Feb 18 10:5%1  17/511 i
mailfile + 7 nariac@celtic Thu Feb 18 11:00  90/2531 Pn
8 hamilton@artemis Thu Feb 18 11:13  22/611  ner
9 abelson@sharonolds Thu Feb 18 11:34  32/1232 Yo
N 10 aquablu@cowman Thu Feb 18 13:58  21/647  Sul

Figure 2-21 Dragging a Mail Message onto File Manager

5. Drag the pointer onto the File Manager file pane and release SELECT.
The first time you drag a mail message onto File Manager, the mail message
appears in File Manager as a file called mailfile. If that file already exists,
the mail message appears asmailfile0.If mailfile and mailfile0
already exist, the file is named mailfilel, and so forth.

You can also drag and drop a mail message onto a mail file icon in File
Manager to append the new message to an existing mail file.
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Transferring Files From Your System to Another
To transfer files from your system to another system, follow these steps:

1. Display the Remote Copy popup by choosing Remote Copy from the File
menu.
If you have selected files, your host name (workstation or machine name) is
displayed in the Source Machine Name text field, and the file names are
displayed in the Pathname text field, as shown in Figure 2-22.

Source
Where does the file you want to copy reside?

Machine Name: river

what is the pathname of the file to copy?

Pathname: /hightide/egret/Fish

Destination
Where do you want the file copied?

Machine Name: celtic

What is the final path name of the copled file?

Pathname: /tmp,

{Copy Fle)) ( Cancel)

Figure 2-22  Remote Copy Pop-up Window

2. Type the destination machine name in the Machine Name text field under
Destination.

3. Type the pathname in the Path Name text field under Destination.
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Printing Files

86

4.

Click SELECT on Copy File to initiate the transfer.
While the transfer is in process, the Copy button displays the standard busy
pattern.

To transfer files from another system to your system, you must know the path
and file name of the files you want to transfer. To transfer a file from a remote
machine to your machine, follow these steps:

1.
2.

Type the name of the remote machine in the Source Machine text field.

Type the full path and file name of the file you want to transfer under
Source in the Path Name text field.

Leave the Destination text fields blank, or type your machine name.

Type the path and file name for the file under Destination in the Path
Name text field.

Click SELECT Copy File to start the transfer.

The Copy button is dimmed until the transfer is complete. If there are
problems with the transfer, error messages will appear in the footer of the
current File Manager window.

Click SELECT on the Copy button to start the transfer.

The Copy button is dimmed until the transfer is complete. If there are
problems with the transfer, error messages appear in a pop-up window that
explains the problem.

You can print files from File Manager in three ways:

Select files in the file pane and drag and drop them onto the Print Tool
application. Files are printed using the default print instructions bound to
the icon in the Binder database. See Chapter 10, “Print Tool” for more
information about using the Print Tool and Chapter 16, “Binder” for
information about print bindings.

Select files in the file pane and choose Print (or Print One) from the File
menu or the File Pane pop-up menu. The Print (or Print One) item is
inactive unless files are selected. Print One prints files using the print
method in the Binder database, if it exists. Otherwise, Print prints files using
the default print method from the File Manager Properties window. See
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“Customizing Your File Manager” on page 99 for information about tool
properties and the chapter Chapter 16, “Binder” for information about print
bindings.

® Highlight the Print (or Print One) item from the File menu or the File Pane
pop-up menu, drag right to display the Print submenu, and choose Print to
display the Print Options window. This is useful when you want to print a
file using a method other than the default print method, or if you want to
print a file to a different printer. Figure 2-23 shows the Print window with
an alternate printer specified in the text field. Specify SFILE where you
want the file name to be in your print script.

©Q FM: Print

Print Method: cat $FILE [ mp —lo|Ip

Copies: 1 [&[}

Figure 2-23 Print Popup Window

Finding Files and Folders

File Manager provides three ways to locate folders and files:

® Go To text field and button
® Pattern matching with a string typed in the File Pane
® Find pop-up window

This section describes how to use these methods to find folders and files.

Using the Go To Text Field and Menu

The Go To menu includes a list of the folders that you have accessed since you
started File Manager. Your home folder is the default item on this menu. The
rest of the items on the menu show (a default of) ten of your most recently
accessed folders. You can make the amount of items greater or smaller. You can
change back to any of these folders by choosing the path to the folder from the
Go To menu. You can also add your own items to the menu. For information
on how to make these changes, refer to “Go To Menu Defaults” on page 111.
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When you know the path of the folder you want to open or the path and file
name of a file that you want to select, you can type the path or the path and file
name in the Go To text field. Then either press Return or SELECT the Go To
button.

When a path is typed, the folder specified is opened and its contents are
displayed in the file pane. When a path and file name are typed, the specified
folder is opened, its contents are displayed in the file pane, and the file is
located, scrolled into view, and selected.

Using Pattern Matching to Find Files

You can use wildcard characters to select groups of related files in the currently
displayed file pane by typing a pattern-matching sequence in the Go To text
field or with the pointer anywhere in the File Pane.

Pattern Matching in the Go To Text Field

The star symbol (*) can be used to match any string, so typing * .rs in the Go
To text field and either pressing Return or clicking SELECT on the Go To
button will select all files ending in .rs. Figure 2-24 shows an example of a
file pane with all *.rs files.

File Manager:/hightide/e
(File v) (Miew v) (Edit v) (GoToiv) *rg

/  hightide egret Apps Screenshots
(eI 2]

Contains 80 items

basewindow.rs cmapptfullsize.rs cme

cmaccesslistrs cmbrowser2.rs cmdaybot

Figure 2-24 Using Pattern Matching with Go To to Select Related Files
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Pattern Matching in the File Pane

You can also use pattern matching to find files by moving the pointer into the
File Pane and typing the pattern that you want to match.

The pattern you type is displayed in the footer. As the pattern is typed, all the
files starting with the current pattern are selected. For example, when you type
c, the pattern is c*, and all the files starting with c are selected. If you then
type h, the pattern becomes ch*, and only the files starting with ch are
selected. If you then type a, the pattern becomes cha*, and the files starting
with cha are selected, and so on. To finish the pattern, press Return. If there
are no files that match the pattern, an error message appears in the footer.

Using the Find Pop-up Window

When you do not know or cannot remember the specific location of a folder
or file, or when you want to locate a group of files according to specific
criteria, use the Find pop-up window. To display the Find window, choose
Find from the File menu. The Find pop-up window is displayed, as shown
in Figure 2-25.
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File Type: @

Find in and below folder: /hightide/egret/Fish

Name: [inciuded | Evcluded |
Owner: | Included | Excluded
Modified After: {mm/dd/yy)
Modified Before: (mm/dd/yy)
Search Files Containing $teingy

(e 2]

Figure 2-25 Find Window

Finding Files With the Find Window

To find a specific file or group of files, you can fill in some or all of the text
fields, according to the type of search you want to perform.

Use the File Type setting to specify whether you want to search only folders,
only files, only applications, only executable files or a combination. The
mini-icons displayed in the File Type choice item are the same as the mini-
icons used in the List by... displays, as shown in Figure 2-15.

Use the Find files in and below folders text field to specify where in your file
system you want to start the search. The search begins in the folder you
specify in this text field, and includes all subfolders in that path.

Use the Name text field to specify the file name or pattern you want to
match. Use Included or Excluded to either include or exclude the pattern
from the search.

Use the Owner text field when you want to search for files by owner, or
exclude a particular owner from the search.
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® Use the Modified After or Modified Before text field, or both, to specify a
time frame for the search. You must specify, as a minimum, the month and
day for each of these text fields.

® Use the Search Files Containing String field when you want to find files with
specific contents. For example, to find all files in which the DeskSet product
is specifically named, you would type DeskSet in the text field. If you click
SELECT to turn on the Ignore Case setting, all files with the word “DeskSet”
will be listed in the scrolling list, regardless of how the word is capitalized.

When you have filled in the text fields, click SELECT on the Find button to
start the search. Once you start a search, the Stop button is activated. You can
stop the search at any time by clicking SELECT on the Stop button.

When the search is completed, all files that match the pattern are displayed in
the scrolling list at the bottom of the Find window. If you have more than one
field filled out on the Find window, a file must match the information in all of
these fields for it be listed. Figure 2-26 shows an example of a file content
pattern matching search. File Manager found 37 files containing the specified
string. (Seven of the files found are shown in the figure, the rest are scrolled
out of view.)
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Using the Wastebasket
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e FM: Find o

File Type: IE]]
Find in and below folder: /hightide/egret/Testfpps/493Screenshots
Name: WW'
Owner: [—IWW

Modified after: 01/15/93, (mm/dd/yy)

Modified Before: {mm/dd/yvy)

Seareh Flips Contalning Steiag i

[/hightide/egret/TestApps /493ScreenShots

[ #hightide/egret/TestApps/493Screenshots/fmfloppywindow.rs
[ #hightide/egret/TestApps/493ScreenShots /fmformatdiskrs

[ #hightide/egret/Testhpps /493ScreenShots/fmrenamediskrs
[ #hightide/egret/TestApps/493ScreenShots/fcopenwindow.rs
0 /hightide/egret/TestApps /493Screenshots/fcsavewindow.rs

[ /hightide/egret/TestApps /493ScreenShots /ws3windows.rs

KINET)

L 37 file(s) found

Figure 2-26 Example of a Find

You can select and open one file at a time from the Find window scrolling list.
To select a file, move the pointer onto the line and click SELECT. The line is
highlighted, and the Open button is activated. To open the highlighted file,
click SELECT on the Open button.

The Wastebasket is a temporary storage area for files that you want to discard
and that you probably will delete from your file system. When you start File
Manager, the Wastebasket is automatically created and displayed as an icon.
You can move the Wastebasket anywhere you want on the workspace.

When the Wastebasket is empty, the icon shows an empty wastebasket. After
you have put a file in the Wastebasket, the Wastebasket icon’s appearance is
changed to remind you that at least one file is there. Figure 2-27 shows the
Wastebasket icon when empty and when there are one or more files in it.
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Waste Waste

Figure 2-27 The Wastebasket Icon, Empty and with One or More Files

You can move folders and files to the Wastebasket by selecting them and
dragging and dropping them onto the Wastebasket icon or window, or by
choosing Delete from the Edit menu.

Files that you put in the Wastebasket are stored in a .wastebasket folder in
your home directory.

You can view the contents of the Wastebasket by opening the Wastebasket icon.
A window is displayed with a scrolling pane that shows you the files you have
moved to the Wastebasket. Figure 2-28 shows an example of the Wastebasket
window.

(=) FM: Waste: /hightide/egret/.wastebasket
(View v) (Edit v) (Empty Waste)

‘Waste
I[EAmE
Contains O items 873 Mbytes (98%) ava

Figure 2-28 Wastebasket Window

The Wastebasket window has View, Edit, and Empty Waste functions available.
To access the Wastebasket pop-up menu, move the pointer anywhere in the
Wastebasket window and press MENU. You can use the Wastebasket pop-up
menu to do the following:
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® Use Empty Wastebasket to delete all the files in the Wastebasket. This option
is inactive if the Wastebasket is already empty. '

Waste or Empty Wastebasket on the File pane menu.

/ i Caution - You cannot recover any files that you delete/destroy with Empty

® Use Select All to select and highlight all the files in the Wastebasket. This
option is inactive if the Wastebasket is empty.

® Use Destroy to delete all the selected files in the Wastebasket. This option is
inactive if no files in the Wastebasket are selected.

® Use Undelete to restore the selected files in the Wastebasket. The files are
automatically moved back to their original locations. This option is inactive
if the Wastebasket is empty.

If you quit File Manager and restart it, the new File Manager will not
remember the original locations of files in the Wastebasket. If you choose
Undelete in this case, File Manager sends the message Original
location for <ﬁle> not saved -- please restore manually. See
“Moving or Copying Files and Folders Using Cut and Paste” on page 78 or
“Moving or Copying Files and Folders Using Drag and Drop” on page 79
for information about how to move the file out of the Wastebasket and back
into the desired folder.

® Use Cut to move the selected files from the Wastebasket to the clipboard.
This option is inactive if no files in the Wastebasket are selected.

® Use Copy to copy the selected files from the Wastebasket to the clipboard.
This option is inactive if no files in the Wastebasket are selected.

® Use Paste to move the contents of the clipboard into the Wastebasket.

Creating a New Wastebasket

If you quit the Wastebasket window, you can create a new one by following
these steps:

1. Make sure the File Manager Tool General Defaults Properties Edit Menu
item is “Delete”.
The “Delete” option is the default setting. See “Customizing Your File
Manager” on page 99 for information about setting the File Manager Tool
Properties.
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Linking Files

2. In File Manager, select a folder or file that you want to put into the
Wastebasket.

3. Choose Delete from the Edit menu or the File Pane pop-up menu.
A new Wastebasket is created to contain the files you selected.

A link is a symbolic connection or pointer to a single file that allows you to
access it from more than one directory. You can set up a link to a filein a
restricted directory, allowing access to the file without providing access to the
directory.

The Link option on the Edit menu runs the standard 1n operating system
command. A symbolic link is created when you link files between directories.
When you link files in the same directory, a symbolic link is created. Refer to
the man page for 1n for a complete description.

For example, if you have a file named Marlin in a folder called Fish, you
can link it to another folder called SwordFish. Once the link is established,
you can access Marlin from either folder. Mar1lin has not been copied into
SwordFish; it has been linked with a pointer from one folder to another.

Any editing changes you make to a file with links are reflected in all of the
folders, since there is really only one file, not multiple copies of it.

To use a linked file, you can drag and drop its icon from any folder that the file
is linked to.

Creating a Link

To link files to folders, follow these steps:
1. Select the file (or files) you want to link.

2. Choose Link from the Edit menu or popup file pane menu.
An instructional message is displayed in the footer, as shown in
Figure 2-29, telling you how to proceed.
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(el _I*]

Link these file(s) by opening the target folder and selecting ‘Paste’

Figure 2-29 Instruction Message after a Link is Initiated

3. Open the folder you want to link the file to.

4. Choose Paste from the Edit menu or the File Pane pop-up menu, or press
the Paste key on the keyboard.
The file icon is displayed in the file pane and a message confirming the link
is displayed in the File Manager footer.

Link information is displayed as part of the properties of the file, as shown in
the example in Figure 2-30. See “File and Folder Information” on page 97 for
more information about file properties.

& FM: Infermation

]

Name: Tuna,

Size: 0 hytes
Type: (4] ide/egret/root/home/Fish/Tuna

Figure 2-30 Links Displayed as Part of the File Type Properties.

Removing a Link

You can remove a link by selecting the file and choosing Delete from the Edit
menu or the File Pane menu. Removing a link does not remove the original file.

If you remove the original file without also deleting the link, the icon for the
link changes to display a broken chain. In the example shown in Figure 2-31,
the original file named aliases has been deleted, but the linked file remains.
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| (File v) (View v) (Editv) {

/  hightide egret root hor
NEL

Contains 2 items

]

Salmon  Swordfish

Figure 2-31 A Broken Link

File and Folder Information

Each folder, file and application in your file system has the following
information (also known as properties) associated with it:

® Name

® Ownership

¢ Group

® Permissions (read, write, execute)

You can display these properties for an individual selected file choosing
Information from the File menu. You can change these properties if you own
the file and have the correct permissions set.

The File Information window also displays the following about each file:

® File Size in bytes

File Type

Date the file was last modified

Date the file was last accessed

File Permissions and Information—Owner, Group, World, Owner name, and
Group name

These (more advanced) topics can be accessed by pressing the plus button at
the lower right corner of the Information window. Once the information is
displayed, you can “hide” it by pressing the minus sign at the lower right
corner.

® Method to open file
® Method to print file
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¢ Mount point

® Mounted from

® TFree space

Figure 2-32 shows an example of a File Properties window.

<

FM: Information

Name:

=

Permissions

Size:
Type:
Last Modified:

Last Accessed:

Owner:
Group:

World:

Owner:

Group:

Open Method:
Print Method:
Mount Paint:
Mounted From:

Free Space:

Seafood
16 koytes
directory

wed Jan 20 18:26:02 1993 PST
wed Jan 20 16:30:44 1993 PST

Read Write Execute

M M ™
M O ™
M 0O ™
egret
staff

/hightide
fdev/dsk/c0t0dos4
875,185 kbytes (39%)

@D @&

@

—Advanced Options

Figure 2-32 Example of a File Properties Window

To display the Information window, select a file or a group of files and choose

Information from the File menu.

If the Information window is already showing when you select a new file, the
File Properties information is updated to reflect the properties of the new file.
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If you select more than one file, the Information window shows those
properties that the selected files can share. The document names and specific
document information are not displayed. You can change the permissions for
the group of selected files to be the same by clicking SELECT on the
Permissions check boxes and then clicking SELECT on the Apply button.

Changing Properties and Permissions

Every file and directory has a security system organized around permissions.
Permissions determine which users can read a file, write to (or change) it, or
execute it (applications are executed). You must own the file to change its
permissions. Users are categorized as owner, group, and world.

® Owner designates the owner of the file.
® Group designates the name of a specified group that can access the file.
® World allows access to anyone on your network.

You can change file properties for any file you own (as long as you have
permission to make modifications in the folder containing the file). If you do
not own the file, the write permissions determine whether you can access a file
to change it.

To change file properties, type new information in the text fields of the
Information window. Click SELECT on a check box to either add or remove a
check.

When you have changed the properties, click SELECT on the Apply button to
apply them. The changes take effect immediately.

You can change common properties on more than one file in the same manner.

Customizing Your File Manager

You can customize your File Manager from the Properties menu in the
following ways:

® Customize General Defaults such as open a new folder into a different
window, view the Folder View horizontally (or vertically), change the
Wastebasket to delete or destroy or change the default document name.

® Customize New Folder Defaults

¢ Customize Current Folder Settings
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® (Customize the Go To menu

¢ Create your own custom commands and add them to the Custom
Commands submenu that you access from the File menu.

¢ Customize Advanced settings such as print method, default editor, how you
view floppies and so forth.

These methods are described in the sections that follow.

4 You can access the Properties by choosing Edit » Properties.
The different properties categories are shown in Figure 2-33.

< FM: Properties

Category: eneral Defaults
General Defaults

Open Folder View:

New Folder Defaults

Same - Show Vertical
Current Folder Settings

Properties categories

available Show Horizontal

Go To Menu Defaults

Custom Commands

Edit Advanced Settings
Delet] n the waste window,

Destroy l File is not recoverable.

Applies changes but
does not save them
if you quit File
Manager

Default Document Name: NewDocument

esets to last saved
efault

CApply) (Save as Defaults)

Saves changes as
new defaults

Figure 2-33 File Manager Properties Menu

In addition, you can customize your File Manager (and other DeskSet
applications) with items such as font type and size that can be set in the
Workspace Properties menu. See “Using the Workspace Properties Window”
on page 478 for more information.
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General Defaults

To change the General Default Properties:

4 Choose Properties » General Defaults from Category.
The General Defaults Properties window is shown in Figure 2-34.

Q FM: Properties

Category: General Defaults

Open Folder into: Folder View:
Same Window Show Vertical
Separate Window Show Horizontal

Edit Menu item is:

Delete File is recoverable from the Waste window.

Destroy File is not recoverable.

Default Document Name: NewDocument

CApply) (Save as Defaults) ( Reset)

Figure 2-34 General Defaults Properties Window

¢ Use Open Folder any time you open a folder. You can set the folder to open
it into the same window as your existing folders or have the folder open
into a new window each time.

¢ Use Folder View to lay out your folder structure horizontally or vertically.

® Use Edit Menu item to change the Delete option (default) on the Edit menu.
Delete means delete to Waste window (where files can be recovered, if
necessary.) Destroy means files cannot be recovered. Whatever you set for
delete or destroy is reflected in the Edit menu. The Delete/Destroy setting
allows you to choose whether File Manager deletes files by moving them to
the Wastebasket, or destroys them. See “Using the Wastebasket” on page 92
for more information. If you choose Destroy, files are not moved to the
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wastebasket and are not recoverable once you delete them. On the other
hand, you never need to empty the wastebasket if you choose the Destroy
option.

Note - If you choose the Destroy option (and selected Save as Defaults), this
state is saved when you quit File Manager. Therefore, the next time you start
up the File Manager application, the Wastebasket will not be created because
Destroy is on.

® Use Default Document Name to change the default name of a new
document. This is the name you see when you create a new document.

New Folder Defaults

You can change the default for the way new files or folders are displayed in the
file pane using the New Folder Defaults, shown in Figure 2-35. To display this
window, choose New Folder Defaults from the Properties Category.

4 Choose Properties »New Folder Defaults from Category.

The New Folder Defaults Properties window is shown in Figure 2-35.
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©Q FM: Properties

Category: New Folder Defaults

Default Name: NewFolder

Longest Name: 15 [(a]+]

jcon Layguls

Sort By: Wme IType I Size | Date I

Hidden Files:

Display Files As: mns I List I Content I

Show in List: viaw (antent As:

I Date | | Size i % 1
IOwner J |Group I pAnC g il §
| Links I | Permissions I § BT

€Apply) (Save as Defaults) (Reset)

Figure 2-35 New Folder Defaults Window

Default Name

The current default name (when a new folder is created) is NewFolder. You can
change this to anything you like.

Longest Name

The Longest Name field allows you to choose how many characters (based on
the average width of the characters) of each file name are displayed in the file
pane of File Manager. You can type any number from 0 to 255.

Note - The number of characters actually displayed for each file name may
vary when using variable-width fonts because the width is calculated based on
the width of the average character in the font.
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Names that do not fit within the specified length are followed by a “greater
than” sign (>) to show that the complete name is not displayed. Figure 2-36
shows an example of the file pane with shorter file names set.

r‘@ File Manager: /hightide/egret
(File v) (View v} (Editw) (GoTor v) *rg,

/  hightide egret

el 2]
Contains 27 items 874 Mbytes
I I e R I e
ab_cardca> .desksetde> .mailtool—i> Rid dead.letter mail

L]
ab_library fm .openin—> wastebask> dead.le

— ~ —

-

ter> Testdpps

Figure 2-36  File Pane with Shorter File Names Specified

If you want to see the complete file name, you can click SELECT on the name.
In this example, the file .ab_cardca> is selected, and the full name is
displayed in an editable text field, as shown in the example in Figure 2-37.

r‘ File Manager : /hightide/egret

(File v) (View v) (Edit v) (GoTo v)

/  hightide egret
I[EYNE
Contains 27 items 874 Mbytes (

D

ab_cardca> .desksetde:W_ dead letter mail

ab_library fm .openin—> “wastebask> dead.letter> Testapps

= 'y Em Th e

Figure 2-37 Displaying a complete file name when short names are specified
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Icon Layout

The Icon Layout setting determines whether files in the file pane are listed in
rows (horizontally) or columns (vertically). The default is row order. For
example, if files are sorted alphabetically by Name in rows, they are listed in
from left to right, with the first files on the top row, then the second row, and
so on. If files are sorted alphabetically by Name in columns, they are listed
from top to bottom, with the first files in the left column, then the second
column, etc. Figure 2-38 shows files sorted by Name in rows, and

Figure 2-39 shows the same files sorted in columns.

@ File Manager : /hightide/egret/Fish

((File v) (View v) (Edit v) (

/  hightide egret Fish

I[EImE
Contains 10 items 873 Mbytes (
Seafood Cod DeskSetDefaults Eel Salmon Ss
2 2
Tuna image.rs Floundermail mailfile

Figure 2-38 Icons Listed in Rows (Horizontally) in the File Pane
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r‘ File Manager : /hightide/egre

(File v) (Vilew v) (Edit 7)

/  hightide egret Fish
L=

Contains 10 items

Seafood Tuna

Cod image.rs

5

DeskSetDefaults FlounderMail

Eel mailfile

Salmon

Figure 2-39 Icons Listed in Columns (Vertically) in the File Pane

Sort By Options

The Sort By Options allow you to choose how the files in the file pane are
sorted. You can choose any of the following settings:

® Name, to sort the files alphabetically

® Type, to sort the files in alphabetical groups by file type, with folders first,
followed by files, then by applications

® Size, to sort the files by size, largest to smallest

® Date, to sort the files in reverse chronological order (newest to oldest)
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Hidden Files

The Hidden Files settings allow you to choose whether or not to display
hidden system files (or dot files as they are sometimes called). Hidden files are
usually system or configuration files, and the filename is preceded by a dot (.).
Figure 2-40 shows an example of a listing with hidden files displayed.

File Manag

(File v) (View v} (Edit v) (GoToi v) *fg,

4/ hightide egret
 [ImE]

Contains 27 items

[ b_cardcatalon Jan 19 17:20 11
| [3 .ab_library Jan 191730 1
{|(0 cetables Dec20 1543 5
110 cshre Jan 111432 1
|®l.q Nov24 1124 1t
.desksetdefaults Jan 20 11:18 2
| .fm Jan20 17116 5
1|3 .history Jan20 11:01 1«
|02 .1ogin 0ct23 16:04 1
3 .mailrc Jan 20 11:23 1t
|| 1 mailtool-init Nov 13 10:24 1
i@l .openwin—init Nov 13 10:24 1t
1@ .cpenwin-initsak Oct26 1550 1
[ openwin-menu-pregrams Qct 21 11:28 8¢

Figure 2-40  File Pane with Hidden Files (dot files) Visible

Display Files As

Display Files as lets you determine the default way to display your files in the
file pane. You can choose any of the following settings:

® Icon, to help you identify each file by type

® List, to display more files in the pane and to show you more information
about each individual file, determined by the List Options. Displaying more
files is true only if no list options are set.
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® Content, to display a preview of the contents of icon and raster files. All

other files are displayed as icons.

Show in List

The Properties window option Show in List allow you to choose how much
information is displayed when you display the contents of the file pane as a list

with mini-icons as shown in Figure 2-41.

The list options in Show in List are nonexclusive settings. You can choose none,
some, or all of the options. To set an option, click SELECT to toggle it from off
to on, or from on to off. (Chosen options have a thickened border on
monochrome monitors.) Figure 2-41 shows an example of a list display when

all of the options are chosen.

f’@ File Manager : /hightide/egret

(File ) (View v) (Edit v) (GoTaiv) *rs

/  hightide egret

Cel T}

Contains 27 items

I | K q eqret 1 5
D .ab_library Jan 19 17:30 110 egret staff 1 —rw—r—r—
[ .cetables Dec20 1543 512 egret staff 2 drwsr—sr—x
O .cshre Jan 11 14:32 1392 egret other 1 —rw—tw-r—
.d Nov 24 11:24 1589 sebring staff 1 —rwRrrwrrwx
.desksetdefaults Jan 201118 2230 egret staff 1 —rwRrwRrwx
M .fm Jan 2017116 512 egret staff 9 drwxr—xr—x
.history Jan 20 11:01 148 egret staff 1 —tw=t——t——
D Jogin Oct 23 16:04 1656 egret other 1 —rw-—r—r—
[ .mailrc Jan 20 11:23 1606 egret staff 1 —rwr——r——
D .mailtool~init Nov 13 10:24 132 egret staff 1 —w-—r—t—
.openwin—init Nov 13 10:24 1006 egret staff 1 —rwHr—rr—x
@ .openwin—initBAK Oct 26 15:50 1057 egret staff 1 —rwHr=xr—x
.obehwin—menu—programs Oct 21 11:28 881 eqret staff 1 _—rw—f——r——
(Do

Figure 2-41  File Pane with all of the List Options Set
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View Contents As

View Contents as lets you determine the type of files that you want to display
a preview of when the Display Mode is Content.

View By Content

When your file system contains icon and raster files created by applications,
such as Icon Editor and Snapshot, you can display an image of the contents of
the file in place of the standard data file icon. The images are displayed to scale
in a 64-by-64 pixel square.

Choosing Content as your default Display Mode in the New Folder Defaults
window displays the contents of black-and-white and color icons, rasters, X
bitmap files, or any combination of these. Folders, applications, and other files
are displayed as icons. Figure 2-42 is an example of a Contents file display.

WG| File Manager : /hightide/egret/Fish K

(File v) (view v) (Edit v) & ) o

/  hightide egret Fish
I[amE i
Contains 10 items 873 Mbytes (38%) available

g 170

Seafood Cod DeskSetDefaults Eel Salmon Swordfish

A A

Tuna image.rs Floundermail mailfile

Figure 2-42 Contents File Display
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Note — Choosing to display the contents of icon and raster files can delay the
reading and displaying of other types of files and folders since File Manager
must perform some additional processing to provide the preview.

You can select any or all of the options, as follows:
® Monochrome Icons, to preview black-and-white Sun icons

® Monochrome Images, to preview black-and-white Sun raster and X Bitmap
images

® Color Icons, to preview XPM files

Current Folder Settings

This allows you to change the settings of the current folder. These settings are
identical to the property settings that can be set for a new folder except there is
no Default Name field. For complete information on these settings, refer to
“New Folder Defaults” on page 102.

<o) FM: Properties

Category: Current Folder Settings

Longest Name: 15 (a[v]}

Sort By: | Name |Type I Size l Date I

Hidden Files:

Show in Lish YView Comtent 45

These settings apply to currently active folder window OMLY.

(CApply) (Save as Defaults) (Reset)

Figure 2-43 Current Folder Settings Menu
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Note — The Current Folder Settings window displays the same information for

the active (selected) folder window only. You can use this to change the

settings for the designated active window.

Go To Menu Defaults

This allows you to change the defaults of the Go To menu. You can set the Go
To menu properties to show a trail of the directory paths you last visited, and
you can set up special paths to directories that you visit often. The Go To menu
has several sections divided by spaces. Typically, you see a default label for
home (a label for your home directory pathname), application specific defaults
that include Waste and Folder View, then the paths to the directories you last

visited.

©

FM: Properties

Category: Go To Menu Defaults

Type in the folder’s path and click Add Item.

|

—

The Go To Menu displays the last folders visited.

Display: 10 (&[] Folders

((Save as Defaults ) (‘Reset)

Pathname: /hightide/egret /home/Fish (Add Item )
Menu Label: OtherFiles,
Go To Menu Items:
Edit ¥
Home (——)
MyFiles

Figure 2-44 The Go To Menu Defaults
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® Use Pathname and the Add Item button to add another pathname to the
default Go To menu. This can be in addition to your home directory
pathname. If you add a pathname without a label, then the entire pathname
is displayed in the Go To menu.

® Use Menu Label to create a new name for the specified pathname. You can
add it to the Go To Menu Items scrolling list. This is useful if the pathname
specified is long.

® Use the Edit button to cut; copy; paste—an item before, after, on top or on
bottom of another item; delete an item in the Go To Menu Items default
scrolling list.

¢ Use Display: Folders to indicate how many of the last folders visited should
display by default in the Go To menu.

Custom Commands

The Custom Commands window allows you to create and store commonly
used operating system commands. Once you have added the commands to the
menu, you can use them at any time by choosing them from the Custom
Commands submenu from the File menu.

Creating Custom Commands

Choose Custom Commands category from the Properties menu, as shown in
Figure 2-45. You use this window to add often-used UNIX commands to your
Custom Commands menu. You can even create a command that lets you
specify different options every time the command is chosen.

Note — The Custom Command feature assumes that you have some working
knowledge of the UNIX operating system. If you are not familiar with UNIX or
have problems, you might want to have your system administrator help you
create any desired custom commands.
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o] FM: Properties

Category: (¥) Custom Commands

Type in command to be listed in the Custom Commands menu.

UNIX Command: String Search Add Item

Menu Label: grep $4RG $FILE,

Custom Commands Menu Items:

= Edit ¥
String Search hid Q

PrintScript

[ e ¢

Prompt Window:

Prompt:

Output Window: m

Capply) ((Save as Defaults) (‘Reset)

Figure 2-45 Custom Command Pop-up Window

The scrolling list shows your current custom commands. You use this window
to add, delete, and change the order of your custom commands.

Follow the steps below to add a new custom command to the Custom
Commands Menu Items scroll box. Follow the examples to add a custom
command to search for a particular text string in the selected files or folders.

1. Type the actual UNIX command in the UNIX Command text field.
You can add $SFILE or $ARG to the command to represent the currently
selected file or special arguments (options) that you can specify at the time
you choose the command.

In this example, type grep $ARG S$SFILE in the UNIX command text field.

2. Type the name of the command that you want to appear in the Menu
Label text field.
This Menu Label does not have to be the actual UNIX command. You may
want the command to be something more descriptive.

In this example, type String Search.

3. Add the item.
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4. To prompt for command options, (that is, if you are using $ARG in the
UNIX command), choose Yes on the Prompt Window setting, then type the
prompt label into the first line of the Prompt text field.

If you use a prompt window, when the custom command is chosen from the
Custom Commands menu a window is displayed with the prompt label.
You use this pop-up window to type the command options.

In this example, choose Yes on the Prompt Window setting and type Search
For: in the Prompt text field. When your custom command is chosen from
the Custom Commands window, a window is displayed in which you can
specify the text that you want to search for.

5. If your custom command will create any output, choose Yes on the Output
Window setting.
This causes an output window to be displayed when the custom command
is chosen, where you can see the result of your command.

In this example, you want to choose Yes on the Output Window. Then when
you choose the new custom command from the Custom Commands menu, a
window will be displayed that lists the places the text string is found.

6. Click SELECT on Apply to add the new command to the Custom
Commands scrolling list.

To use the item, select the folders and files where you want to search for text,
choose the String Search command from the Custom Commands submenu, and
type the text string to search for in the window that is displayed. Press
RETURN to quit or SELECT Quit from the output window.

Advanced Settings

You can change the way File Manager behaves and the way it presents certain
information by changing controls in the Advanced Settings window. To display
the Advanced Settings window, choose Advanced Settings from Category.

The File Manager Tool Properties window is shown in Figure 2-46.
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FM: Properties

Category: (¥) Advanced Settings

Print Method:
cat $FILE I mp —lo | In,

Update File System Every:

View Filter Pattern:

5 &) seconds

Follow Symbolic Links:

Default Editor:

Open File Manager window upon insertion of:

CDROM:

Use generic icons for faster display:

Floppy Disk: m

CDROM: | No | ves

(Apply) (Save as Defaults ) (‘Reset)

Figure 2-46  Tool Properties Window

Print Method

The Print Method text field allows you to specify a default UNIX print script
for files that are printed from File Manager that do not have a print method

defined in the Binder database. The print script shown in Figure 2-46 prints

your files in landscape mode on your default printer, using the mp PostScript
pretty printer. If you want to change the print script, make sure to type SFILE

in the script where the file name should be inserted.

File Manager
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View Filter Pattern

The View Filter Pattern text field allows you to specify that only files of a
certain type are displayed in the file pane of File Manager. In the example
shown in Figure 2-47, the filter pattern *.rs shows only the raster files in a
directory, even though other files are there. Note that the header of the window
shows you what filter pattern is set.

r' File Manager : *rs: /hightide/egret/ Apps/ ScreenShots

(File v) (view v) (Edit ¢) (GoTo: v) o

/ hightide egret Apps ScreenShots
(el 1%]

Contains 95 items 874 Mbytes (9

basewindow.rs cmapptfullsizers cmdateoptions.rs

cmaccesslistrs cmbrowser2.rs cmdayboundariesandview.rs

[ P [

Figure 2-47 File Pane with a *.rs Filter Pattern Set

Default Editor

® Use Default Editor to specify what default editor File Manager uses to
display the text of files that are not specifically bound to another
application. If you click SELECT on Other, a text field is displayed in which
you can type the name of a different text editor application. If you specify a
different text editor that does not display its own window, you must specify
that a Shell Tool is started before the text editor.

Note - Running command line programs, such as rm or rlogin, without
specifying a Shell Tool to run the program in can lead to unpredictable File
Manager behavior. Unless a program starts with its own window (such as
textedit or mailtool), prepend shelltool to the program in the Default
Editor text field, as shown in Figure 2-45.
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Update File System

You can set the number of seconds that File Manager checks to see if any items
were added or deleted.

Follow Symbolic Links

If Symbolic Lines is set to No (the default), you see filenames just as you typed
them. For example, in the Go To field. If Symbolic Links is set to Yes, you see
links made across file systems.

Open File Manager Window

Automatically opens the CD window of the CD that has been inserted.

Use Generic Icons

When you insert a Floppy or CD, it can take some time for the icons to display.
If it is not important to you what the icons look like, and/or if you want the
them to display quickly, you can set Yes and a generic representation of the
icon is displayed and is much quicker time.

Customizing Your File Manager Colors

There are two ways to change the File Manager color scheme, as follows:

® To change the colors in the tree and file panes, use the -fg and -bg
command line flags to specify different colors for your foreground
(characters) and background. For example, if you want the tree and file
panes to have blue characters on a gray background, try starting File
Manager in a Command Tool or Shell Tool by typing the following:

filemgr -fg 0 0 255 -bg 127 127 127 &

Each trio of numbers represents red, green, and blue intensities from
0 to 255.

Alternatively, you can specify the actual names of colors instead of the trio
of numbers, as follows:

filemgr -fg blue -bg gray50 &
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To see the available list of color names, look at the file
SOPENWINHOME/lib/rgb.txt.

® If you do not like the colors of the icons displayed in File Manager, use the
Binder with its Color Chooser to change the colors to your liking. See
“Changing a Binding” on page 471 of the chapter “Binder” for information.

File Manager first looks for entries in the Binder database to determine
colors of the icons it displays. If File Manager cannot make contact with the
Binder database, it issues a warning message, and then uses the colors set
up via X resources, described in the filemgr manual page.

Using Floppy and CD Media

File Manager allows you to use removable media such as Floppy Disks or CD-
ROM (Compact disk, read-only memory) on the WorkSpace. You can view
your Floppy disks or CDs if you:

® have a system with at least (1) floppy drive or (1) CD-ROM drive and are
running Solaris 2.2

Refer to the documentation that came with your computer for information on
how to insert a floppy disk or CD into the drive.

Using a Floppy Disk with File Manager

The following explains what to do with your floppy disk once you have
inserted it into your drive. You may encounter these cases when you insert a
Floppy disk:

® The disk is formatted and labeled. In this case you see the window as shown
in Figure 2-48. You can begin using the information on your disk.

¢ The disk is unformatted. Refer to “Reformatting a Floppy Disk” on page 121
for information on formatting a disk.

¢ The disk is formatted and may contain data. If the data is in Macintosh™
format or unknown to this system, you may see the a popup as shown in
Figure 2-53.
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Checking for a Floppy Disk
1. Insert your floppy disk into the disk drive on (or attached to) your
computer.

2. Select Check For Floppy from the File Menu.

If you inserted a formatted, labeled disk, you can move on to “Viewing a File
from the Contents of a Floppy Disk or CD” on page 119.

Note - You do not have to check for CDs.

Viewing a File from the Contents of a Floppy Disk or CD

Once the File Manager window is displayed, you can view the contents of your
floppy disk or CD.

" [%) File Manager : /floppy/ Fish
(File v) (View v) (Edit v) (GoTo: v) 4

&l

Fish

EANET] [
Contains 0 items Eject Disk 1 Mbytes (100%) available

-
3
Ad

fuse |

) riJ

Figure 2-48 The File Manager Floppy Disk Window
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=) File Manager : /cdrom/unnamed_cdrom

(File v) (view v) (Editv) (GoTo v)

unnamed_cdrom

[ EAMES] 0
63 Contains 4 items 16 Mbytes (17%) available

=
——
] ]
bin cdm cdmanager OpenWwindows hd
=
L1 0

Figure 2-49 The File Manger CD Window

1. If necessary, scroll through the contents of floppy disk or CD until you
find the file you want to view.

2. Select the file or folder to be viewed.
3. Choose File »Open.

You can now use File Manager windows and menus. If you close the window
to an icon you see the following for floppy or CD as in Figure 2-50.

(&)

unnamed_cdrom

Fis

Figure 2-50 The Floppy Disk and CD icons

Solaris 2.2 User’s Guide—May 1993



N
1]

Removing a Floppy Disk or CD from the Disk Drive
1. From the floppy or CD window Select the Eject Disk Button.

2. Remove the disk or CD from the drive when it is ejected.
The drive is now free.

Ejecting Unrecognized Data Format CDs

To eject a CD that has an unrecognized data format (such as audio files):
1. Open a Command Tool or Shell Tool.

2. At the prompt type:

eject cdrom

Your disk should now be ejected from the drive.

Reformatting a Floppy Disk

If you are using a diskette for the first time or if you want to format your
diskette, perform the following steps.

1. Insert the floppy disk.
2. Select Check For Floppy from the File Menu.

Note - If you inserted a correctly formatted disk, you see the window on the
WorkSpace as shown in Figure 2-48.

If the diskette is not formatted, you see the window in Figure 2-51 on page
122.

3. Choose Format Floppy from the File menu.
Make sure the floppy window is active.

File Manager 121



i
N

r;Q Format Floppy n

Are you sure you want to format this floppy disk?

WARNING: Formatting will destroy any information on the disk
and is not undoable.

Please select a format: | UNIX
DOS High Density
NEC-DOS Medium Density

Disk Name:

( Format Disk) (Cancel)

Figure 2-51 The Floppy Format Disk Window

If you choose to Format the disk, this is your last chance to Cancel.

4. Click Format Disk.

When the initialization has been complete, you see the File Manager window
on the WorkSpace as shown in Figure 2-48.

Unformatted Floppy

If you inserted an unformatted floppy disk, the following popup displays:
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Unformatted Floppy L

This floppy disk is unreadable. It may be blank
or contain data in an unreadable format.

Do you want to format it?

WARNING: Fermatting will destroy any information on the disk
and is not undoable.

Please select a format: | UNIX
DOS High Density
NEC-DOS Medium Density

Disk Name:

(Format Disk) (Cancel) (Cancel & Eject)

Figure 2-52 Unformatted Floppy Popup

You can choose to:

¢ format the disk, refer to “Reformatting a Floppy Disk” on page 121 for
information on reformatting the disk.
or

® cancel the operation and dismiss the popup.
or

® cancel the operation and eject the floppy.

Note — Macintosh, Sun TAR and Sun BAR formats are not recognized.
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Unlabeled Floppy

If you inserted a floppy disk that is unlabeled, that is there is data on the disk
but is not a recognized format, the following message displays:

) Unlabeled Floppy -ﬁ

This floppy disk is unreadable by the system.
It may contain tar or bar formatted data.

Do you want to format it?

WARNING: Formatting will destroy any information on the disk
and is not undoable.

Please select a format: | UNIX
DOS High Density
NEC-DOS Medium Density

Disk Name:

(Format Disk) (Cancel) (Cancel &Eject)

Figure 2-53 Unlabeled (Unknown Data) Floppy Popup

You can choose to:

® format the disk, refer to Reformatting a Floppy Disk on page 121 for
information on reformatting the disk.
or

® cancel the operation and dismiss the popup.
or

® cancel the operation and eject the floppy.
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Renaming a Floppy Disk
There are times when you would like to change the name of your disk.
1. Insert the disk to be renamed.
2. Select Check For Floppy from the File Menu.

3. Choose Rename Disk from the File menu.
You see the rename disk window.

Please enter the name of the disk.

Disk Name: ,

(Rename Dsk) ( Cancel)

Figure 2-54 The Floppy Rename Disk Window

4. Type a new name for the disk.
You type over the existing disk name and it disappears when you have
finished typing.

5. SELECT the Rename Disk button.

The disk is now ready to be used or ejected.

Dragging and Dropping Files from Floppy Disk or CD to File Manager
1. Open the floppy disk or CD into a window.

2. Select the file or folder icon and drag it from one window to the other.
For information on dragging and dropping, refer to Chapter 1,
“Introduction to the Solaris User Environment.” The file is now copied to
File Manager.
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Copying Files from Floppy Disk or CD to Floppy Disk
You can copy files from a floppy disk (or CD) to another floppy disk.
1. Insert the floppy or CD that contains the files to be copied.
. Select all files to be copied.

. Copy the selected files to a folder in a File Manager window.

2
3
4. Remove that floppy.
5. Insert a new floppy.
6

. Copy the folder to the newly inserted floppy.
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Text Editor Icon

Text Editor 3

The Text Editor is an interactive ASCII text editor. It allows you to create new
files and modify existing files.

This chapter describes how to use the Text Editor. You do not need to know
any special editing commands because the editing commands are available
from the base window. The editing functions provided in this DeskSet
application are also available in the text editing panes of the Console and the
Command Tool, and in the View and Compose windows of the Mail Tool.

4 To open the Text Editor window, choose Workspace » Programs » Text
Editor.

The Text Editor icon shows you as much as it can of the beginning of the file
name. When the file has been edited and you have not saved the changes, the
file name is preceded by a right-angle bracket (>). When there is no file or
when you have created a new file but have not saved it, the icon displays the
words NO FILE. Figure 3-1 shows an example of three Text Editor icons. The
one on the left contains a file named example. The one in the middle contains
a file named example that has been edited but not saved. The one on the right
contains either no file at all or a file that has never been saved.
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Figure 3-1 Text Editor Icons

Text Editor Base Window

128

Control Area \’“ Text Editor ~ (NONE), dir; /hightide/egret T
(File v) (View v) (Edit v) (Find v) D

Text Pane

The Text Editor base window, shown in Figure 3-2, has a control area and a text
pane that you use to compose and edit your text message. The header of the
Text Editor window displays the name of the file you are editing (or the word
NONE when you have not assigned a name to the file), and shows you the
directory where the file is located. When you have made editing changes, the
word “edited” is displayed in parentheses following the file name.

Use the text pane to compose and edit your text. To begin, click SELECT in the
text pane and begin typing. For information on adding, modifying, or deleting
text, see the section Working with Text in Chapter 1, “Introduction to the
Solaris User Environment.” To copy and move text, use the Cut/Copy/Paste
functions from the Edit menu or from the keyboard.

%

T

Ll 3]

Figure 3-2  Text Editor Base Window
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Text Editor Menus

The control area of the Text Editor has File, View, Edit, and Find buttons. These
menu buttons are included as menu items in the Text pane pop-up menu.

Text Pane Pop-Up Menu

File Menu

You display the Text Pane pop-up menu by moving the pointer anywhere onto
the Text pane and pressing MENU. (The Text Pane pop-up menu is also
provided in the text editing panes of the Console, Command Tool, and Mail
Tool applications.)

The commands for each of the items in Text Pane pop-up menu operate in the
same way as the controls in the Text Editor window, described in the following
sections. An additional item on the Text Pane pop-up menu, called Extras, is
also described later in this chapter.

The File menu contains items that you can use to open, save, save as, include
and empty the document for your text files. For complete information on
opening and saving files, refer to Opening, Saving, Including and Attaching
Files” in Chapter 1, “Introduction to the Solaris User Environment.”

Include File

Use the include file to include an existing file into a new text file.

1. Use the Include File item of the File menu to display the Text: Include
window.

2. Locate and include your file.
Include your file in the same manner you would open or save a file. For
detailed information on choosing a file to open or save, refer to Chapter 1,
“Introduction to the Solaris User Environment”.
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View Menu

Empty Document

Use the Empty Document item of the File menu to clear the contents of the text
pane. If you have made editing changes and have not saved them, a Notice is
displayed asking you to confirm or cancel the operation.

Use the View menu item to control the position of the cursor and the way the
line wrap is used. ’

Select Line at Number

Use the Select Line at Number item to display the Text: Line Number window,
shown in Figure 3-3. Type the number of the line that you want selected, and
click SELECT on the Select Line at Number button. The text on the specified
line is selected, and the insert point is moved to the end of the selected text.

© Text:Line Number
Line Number:

{ Select Line at Number)

Figure 3-3  Text: Line Number Pop-up Window

What Line Number?

Use the What Line Number? item of the View menu to locate the line number
where the selected text begins. The line number is displayed in a Notice. When
there is no current selection in the Text Editor window, the Notice displays an
error message instead of a line number.

Show Caret at Top

Use the Show Caret at Top item of the View menu to scroll the document so the
line currently containing the caret is the third line from the top of the text pane.
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Change Line Wrap

The Change Line Wrap submenu provides three choices for line wrapping:
word, character, and clip lines. The text shown in Figure 3-4 is wrapped at a

character, so words are broken at the end of lines.

F fi Text Editor — story, dir; /home/jungle/brenda i

{ File v)

{Edit v) (Find )

Select Line at Number...
What Line Number?
Show Caret at Top

wrinkles and a
ears or so into
nded up in East
¢ fence gates, i
ed. Everyone wa

out a dream I had Tast night. Yo

Wrap at Word

Wrap at Character

Clip Lines

preface this with a reminder that
strange -- I mean, don’t get wei

to work. Based on my
ay this was about 10 v
the usual exit, and e
-ed through the electri
had just recently mov
declared that she had

done some figuring, and this was her 32nd office since bei

ng at the company.

Mot all of us were still here.

Henry had just opened his o

wn phone repair business called Dead Ringers, and John was
considering retirement from the computer business to organi
ze 9 of his friends, his brother, wife, and seven kids into

Figure 3-4  Lines Wrapped at a Character

il

The most commonly used wrapping method is to wrap at the end of words.

The text shown in Figure 3-5 is wrapped at the end of words.
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i Text Editor — story, dir; Fhome/jungle/brenda i

Select Line at Number...

. out a dream I had Tast night. Youl=
What Line Number? eface this with a reminder that
Show Caret at Top istrange -- I mean, don’t get
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wWrap at Word
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wrap at Character

Clip Lines

Not all of us were still here. Henry had just opened his
own phone repair business called Dead Ringers, and John was
considering retirement from the computer business to
organize 9 of his friends, his brother, wife, and seven kids

Figure 3-5 Lines Wrapped at a Word

If you choose Clip Lines, the beginning of each line that ends with a Return is
displayed. In Figure 3-6 each line represents a paragraph because there are no
carriage returns embedded in the lines. Only carriage returns are at the end of
each paragraph. That is,

. Text Editor - story, dir; fhome/jungle/brenda
(Edit v) (Find v)

Select Line at Number..,
what Line Number?
Show Caret at Top

. ut a dream I had last night. ¥

]

i me driving to work. Based on m

wrap at Word B just opened his

I npacked and headed ing. We had ot

Wrap at Character

Next &lison told us 2 rse she was busy

Clip Lines  w

Figure 3-6  Clipped Lines
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Edit Menu

Find Menu

The Edit menu provides standard editing functions, as follows:
¢ Again repeats the last editing action.

® Undo undoes the last editing action or all editing actions, depending on
which item you choose from the Undo submenu.

® Copy stores a copy of the selected text on the clipboard. Only one selection
at a time can be stored on the clipboard. If something is already on the
clipboard and you do a Copy or Cut, the contents of the clipboard are
overwritten with the new information.

® Paste inserts the contents of the clipboard at the insertion point.

¢ Cut removes the selected text and stores it on the clipboard. Only one
selection can be stored on the clipboard at a time.

The Find menu items help you to search for specific text strings, special
characters, and delimiters to find a text string and replace it with another.

Text: Find and Replace

Use Find and Replace to find specific text and replace it through the Text: Find
and Replace window. If you have a current selection, it is automatically
displayed in the Find text field, as shown in the example in Figure 3-7.

-~ Text:Find and Replace

N
:

(Find then Replace ) ("Replace then Find) ((Replace All') all Text

Figure 3-7  Text: Find and Replace Pop-up Window
To find a text string and select it, type the text in the Find field and click

SELECT on the Find button. Click SELECT on the Find button again to find
and select the next occurrence of the text string.
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To replace the current selection with a text string, type the text in the Replace
field and click SELECT on the Replace button. You can use the Replace button
together with the Find button to find a string and then replace it with another,
or separately to replace highlighted text. You can replace a string with nothing
by leaving the Replace text field blank.

If you want to find a text string that contains tabs or carriage returns, select the
text containing tabs or carriage returns in the text pane before you display the
Text: Find and Replace window. You cannot type carriage returns or tabs
directly in the Find or Replace text fields.

The buttons at the bottom of the Find and Replace window combine the find
and replace operations, allowing you to quickly do any of these combinations:

® Use the Find then Replace button to find the text string in the Find text field,
and then immediately replace it with the text string in the Replace text field.

® Use the Replace then Find button to replace the currently selected text with
the text string in the Replace text field, and then immediately find the next
occurrence of the Find text string.

¢ Use the Replace All button to replace all occurrences of the Find text string
with the Replace text string.

You can specify whether you want the find and replace operations to apply to
all of the text, or to restrict the operation to the text between the insert point
and the end of the document. Use the abbreviated menu button at the lower
right corner of the window to select either All Text or To End. The current
setting is listed to the right of the abbreviated menu button, as shown in
Figure 3-7.

Find Selection

Use Find Selection on the Find menu to search the file for another occurrence
of the text string that is highlighted as the current selection. You can search
forward or backward from the insert point by choosing Forward or Backward
from the Find Selection submenu.
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Find Marked Text

Use Find Marked Text on the Find menu to highlight text between a matched
set of delimiters provided as options in the Text: Find Marked Text window,
shown in Figure 3-8.

o~ Text:Find Marked Text
(O~ [~ [ [paJu g r]

(Find Pair) : | Forward | Backward i Expand ]

(Insert Pair) (Remove Pair)

Figure 3-8  Text: Find Marked Text Pop-up Window

You can search and highlight text for any of the matched delimiters provided
as choices in the Text:Find Marked Text pop-up window. Click SELECT on one
of the sets of delimiters, and then click SELECT on the Find Pair button. Use
the Backward or Forward choice to direct the search either backward or
forward from the current insertion point. If you have nested delimiters, such as
matched parentheses in a program’s code, you can use the Expand choice to
select text outward from the current insertion point to the next outer pair of
specified delimiters.

To surround the selected text with the selected delimiters, click SELECT on the
Insert Pair button. To delete a matched pair of delimiters from the selected text,
click SELECT on the Remove Pair button.

Replace Field

The Text Editor pane recognizes any text between the characters |> and <| as
a text field. You can search forward through the text from the insert point to
find and select each field using the Replace |>field<! item of the Find menu.
The Replace |>field<| submenu provides three options: Expand, Next, and
Previous:

® When the caret in the Text Editor pane is between field delimiters, choose
Expand to search in both directions and select the entire field and its
delimiters.

® Use Next to search forward from the insert point and select the next field.

Text Editor 135



1]
(O8]

® Use Previous to search backward from the insert point and select the
previous field.

Extras Menu

There is an additional item on the Text Pane pop-up menu, called Extras, that
is not a button in the Control area (as File, View, Edit, and Find are). This menu
contains some useful filters to format the selected text. You can customize the
Extras menu and define your own set of filters available from the Extras menu.
See “Customizing Your Text Editor” on page 145 for information about how to
define your own set of filters. This section describes the default Extras menu.

Format

Choose Format to reformat selected long lines of text into physical lines of no
more than 72 characters. This is useful, for example, when reading mail with

lines longer than the width of the window. Formatting text before printing is

also useful to make sure the lines will not be truncated by the printer.

Format uses the UNIX fmt command. It does not split words between lines,
and it preserves blank lines and the spacing between words.

Capitalize
Use Capitalize on the Extras menu to capitalize selected text.

® The first item on the Capitalize submenu, abcd->ABCD, capitalizes every
letter of the selected text.

® The second item on the Capitalize submenu, ABCD->abced, turns all the
letters of the selected text into lower case.

® The last item of the Capitalize submenu, abcd->Abcd, capitalizes the first
letter of every selected word. Uppercase letters within a word are not
changed.
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Creating a New File

Shift Lines

Choose the Shift Lines item to insert or remove a Tab character at the
beginning of each line in the selected text. Use the Shift Lines submenu to
specify whether to shift right or left. Shift right inserts a Tab character, and
shift left removes a Tab character.

Pretty-print C

This item uses the UNIX indent command to format C program listings. It
formats the selection according to standard specifications, or to the
specifications of the . indent.pro file if you have one.

Insert Brackets

You can use the Insert Brackets item to quickly insert any of the following type
of brackets around the selected text, depending on which item you choose from

"on

the Insert Brackets submenu: (), [ ], {}, or " "

Remove Brackets

Choose the Remove Brackets item to remove any of the following types of
brackets around the selected text, depending on what item you choose from
the Remove Brackets submenu: (), [],{}, or"".

To create a new file with Text Editor:

1. Choose Workspace » Programs » Text Editor and type a line in the Text
Editor window field, such as:
This is a test file.

2. Press MENU on the File menu button, and select Save.
You see the Text:Save window.

3. Save the file.
For complete information on saving a file, refer to Chapter 1, “Introduction
to the Solaris User Environment.”
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Working with an Existing File

You can open (load) any standard ASCII text file into the Text Editor and then
modify the current file, or change the name of the file to create a new file,
which leaves the original file intact. To load a file from your file system into
Text Editor:

1. Choose File » Open from the Text Editor control area.
You see the Text:Open window.

2. Select and open the file.
The file you have specified is displayed in the Text Editor window. For
complete information on opening a file, refer to Chapter 1, “Introduction to
the Solaris User Environment.”

Saving the Existing File

You can now edit the existing file and either save your changes in that file, or
save it as a new file. To modify the file, see the section, “Editing Files” on
page 139. To save the changes to the existing file, do the following:

4 Choose File » Save from the Text Editor control area.
The file is automatically saved.

Because UNIX does not allow two documents with the same name in one
directory, when you make a copy of a document in the same directory the
original file is automatically saved to a backup file and renamed with a %
suffix. For instance, a file named messages would automatically be
renamed messages%. The next save overwrites the existing backup file
rather than creating a second backup. Figure 3-9 shows the two files
displayed as icons in File Manager.

i

stored.text stored.text®

Figure 3-9  Edited File and Backup File with a % Suffix
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Note - If you do not want to retain the original, delete the file with the % suffix
by pressing SELECT on the icon in File Manager and dragging it to the
Wastebasket.

Saving the Modified File as a New File

Editing Files

To keep the original file intact and create a new file with the modifications, do
the following:

1. Choose File » Save As.
You see the Text:Save As window.

2. Name and save the new file.
The file is stored in the designated directory and file. For complete
information on saving a file, refer to Chapter 1, “Introduction to the Solaris
User Environment.”

Using Text Editor, you can add and delete text from a file, copy text from one
location to be pasted in another, and search for text strings in a file.

Adding and Deleting Text

You can add new text to a file by placing the insert point anywhere in the file
(click SELECT in the desired location) and typing the new text there. Likewise,
you can delete characters by placing the text caret at the end of the character
string you want to delete, and backspacing over those characters.

Another way to delete a character string is to cut it. This places the text string
in a system clipboard, and if you want you can paste it elsewhere. To cut and
paste a text string, do the following:

1. Click SELECT to the left of the first character in the string that you would
like to cut.

2. Click ADJUST to the right of the last character in the string.
The text string is highlighted.
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3.

Press MENU to display the window pane’s pop-up menu, drag the pointer
down to highlight Edit, and to the right to highlight Cut.

The text string is placed in the system clipboard. (Alternatively you can use
the Cut button on the keyboard.)

Move the pointer to the destination where you would like to paste the text
string and click SELECT to position the caret there.

Press MENU to display the window pane’s pop-up menu, drag the pointer
down to highlight Edit, and to the right to highlight Paste.

The text string appears in the new location. (Alternatively, you can use the
Paste button on the keyboard.)

Copying and Moving Text

To copy a section of text, you highlight the line of text using SELECT and
ADJUST, as follows:

1.

Click SELECT to the left of the first character in the string that you would
like to copy.

Click ADJUST to the right of the last character in the string.
The text string is highlighted.

Press MENU to display the window pane’s pop-up menu, drag the pointer
down to highlight Edit, and to the right to highlight Copy.

The text string is placed in the system clipboard. Figure 3-10 shows the Edit
menu. (Alternatively, you can use the Copy button on the keyboard.)

©  Edit
Undo o
Copy
Paste

cut

Figure 3-10 Edit Menu

4. Move the pointer to the place where you want to insert the text and click

SELECT to set the insert point.
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5. Choose Paste from the Edit menu or press the Paste key on the keyboard.

To move text, the steps are similar, except that you choose Cut instead of Copy,
and the selected text is removed from its original location.

Paste the text in a new location by clicking SELECT once on the destination
point, and then choosing Paste from the Edit submenu in the Text Pane menu.
(Alternatively, you can press the Paste button on the keyboard.)

Tips on Cutting and Pasting

® For some it is more convenient to use the Cut and Paste buttons on the
keyboard rather than the Edit menu.

® Clicking SELECT twice on a word highlights that word for cutting or
copying.

® Clicking SELECT three times on a text line highlights the whole line for
cutting or copying.

® Clicking SELECT four times anywhere in the file highlights the entire
contents of the document.

Printing Text Editor Files

Before printing a Text Editor file, you may need to choose Format from the
Extras menu to reformat selected long lines of text into physical lines of no
more than 72 characters. A line of text is defined as ending with a carriage
return. The Text Editor wraps a long line into several displayed lines, so what
looks like several lines on your screen may actually just be one long line.

You print Text Editor files by dragging and dropping the file onto the Print
Tool application. To drag the entire Text Editor file, press SELECT on the text
glyph inside the drag and drop target, drag the pointer to the Print Tool icon or
drag and drop target, and release SELECT. The drag and drop target is the
small shaded box in the upper right corner of the Text Editor or the upper left
corner of the Print Tool.

You can also print Text Editor files the same way you print any file with the
File Manager. Save your Text Editor file using one of the methods described in
the section “File Menu” on page 129. Then select the file in the File Manager,
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Splitting Panes
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and drag and drop it onto the Print Tool or choose Print File from the File

Manager’s File menu. See “Printing Files” on page 86 for more information

about printing files from the File Manager.

The Text Editor pane can be split into two or more panes so that you can view
and edit different parts of the document at the same time. The document itself
is not split, so any editing changes you make in one view are reflected in other

views as well. To split the Text Editor pane:

1. Move the pointer to the top cable anchor of the vertical scrollbar and

press SELECT.

2. Drag the pointer downward into the pane.

A horizontal line is displayed from the left edge of the pane to the center of

the cable anchor to show where the split will occur.

3. Release SELECT.

The pane is now split into two panes, as shown in Figure 3-11.

sometimes dreams are very strange.

Text Editor — story, dir; Zhome/jungle/brenda B
(File v) (View v) (Edit v) (Find v)
I have to tell you guys shout a dream I had last night. vou |[*
were all there. Let me preface this with a reminder that
hd

gates, it was obvious that we had just recently woved.
Everyone was unpacking, and Mary declared that she had done
some figuring, and this was her 32nd office since being at the
company.

Net all of us were still here. Henry had just opened his own
phone repair business called Dead Ringers, and John was
considering retirement from the computer business to organize

Figure 3-11 A Split Text Editor Pane

9 of his friends, his brother, wife, and seven kids intc a
m

R CTB L

|_Move pointer here

Alternatively, you can move the pointer into the scrollbar at the place you want
to split the views, press MENU to display the scrollbar menu, and choose Split

View.

Solaris 2.2 User’s Guide—May 1993



3

Il

One way to remove a split pane is to move the pointer to the top cable anchor
in the pane you want to remove and press SELECT. Then drag the pointer
down until the top and bottom cable anchors overlap, and release SELECT.
Another method is to move the pointer to the place in the scrollbar where the
views are split, press MENU to display the Scrollbar menu, and choose Join
Views.

Drag and Drop Feature

Drag and drop is a method of moving files or selected text into and out of the
Text Editor using only your mouse. Refer to Chapter 1, “Introduction to the
Solaris User Environment” for an overview of the drag and drop feature.

To load a file (overwriting any existing text), you can drag and drop a text file
onto the Text Editor drag and drop target or icon.

To insert text within a Text Editor file, you can drag and drop a file or selected
text to the spot in the text pane where you want the text inserted.

You can drag and drop either selected text or the entire Text Editor file to any
location in the DeskSet environment that accepts ASCII text. The following
sections describe two different ways to drag and drop from the Text Editor
application.

Dragging Selected Text from the Text Editor
To drag a copy of selected text from the Text Editor:

1. Select the text to be copied.
If you want to copy the entire file, quadruple-click SELECT, or drag from the
drag and drop target as described in the next section.

2. Press the Control key on the keyboard and click SELECT.
Once you have clicked SELECT you can release the Control key. Pressing the
Control key assures that the text is copied instead of moved. If you don’t
press the Control key first, the text being dragged will be cut from the
original text.

3. Drag the pointer a short distance.
A text duplicate pointer is displayed, as shown in Figure 3-12, with the first
several characters of the selected text displayed inside the rectangle.
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i Text Editor — story.text.edit (edited), dir; /home/bookhouse/brenda

(File v) (View v) (Edit v) (Find v)

usuyal exit, and ended up in East Peyton Place. As I walked through the electric
fence gates, it was obvious that we had just recently moved. Everyone was
unpacking, and Mary declared that she had done some figuring, and this was her
32nd office since being at the company.

Computet
nto & travell

LI unpacked and headed out for a staff meeting. We had lots to talk about in the

Figure 3-12 Dragging a Copy of Text Editor Text

4. Drag the pointer to the destination or the text and release SELECT.

Dragging Complete Text Editor Files

Text Editor files can be dragged and dropped onto any place in the DeskSet
environment that accepts ASCII files. This operation is always done as a copy.
To drag a complete Text Editor file:

1. Press SELECT on the text glyph inside the drag and drop target.
The text glyph is the figure inside the drag and drop target that represents
the entire text file.

2. Drag the pointer a short distance.
A text file move pointer is displayed, as shown in Figure 3-13.
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Text Editor — storytext.edit, dir; fhome/bookhouse/brenda ‘1

(File v) (View v) (Edit v) (Find v) Den _Pointer and icon

| m—)
Ok, so it started out with me driving to work. Based on my wrinkles and a few
gray hairs, I°d say this was about 10 years or so into the future. I passed

the usual exit, and ended up in East Peyton Place. #As I walked through the
electric fence gates, it was obvious that we had just recently moved. Everyone
was unpacking, and Mary declared that she had done some figuring. and this was

her 32nd office since being at the company.

Figure 3-13 Dragging a Copy of Text Editor Text

3. Drag the pointer to the destination of the text and release SELECT.

Customizing Your Text Editor

There are two files used by the Text Editor that you can modify to customize
the Extras submenu of the Text Pane pop-up menu and to specify function key
mappings. This section describes these two files.

The . text_extras_menu File

You can customize the Extras menu to include your own commands by
modifying the file . text_extras_menu. By default (and depending on how
your system is configured), the Text Editor uses the information found in the
file SOPENWINHOME/1lib/locale/<locale>xview/.text_extras_menu.
<locale> is a subdirectory that contains locale specific text files. The default is
“C”, but may vary depending on the country locale. You can create your own
copy of this file and tell the Text Editor to use it instead of the default in either
of the following two ways:

® Change the value of the .Xdefaults parameter
text .extrasMenuFilename or Text . ExtrasMenuFilename to the path
and file name of your customized file. See the manual page for XvView for
information about the .xXdefaults file.

® Set the environment variable EXTRASMENU to the desired file name.
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If you specify both options, the .Xdefaults parameter will be used.

The standard Extras menu file is
SOPENWINHOME/lib/locale/C/xview/.text_extras_menu and is
shown in Figure 3-14. It will give you ideas about how to implement your own
extras menu file. Once you've created a custom file and indicated where to find
it using one of the previous methods, you can make changes to the file and see
them immediately implemented in the Extras menu. These changes also affect
other text panes in DeskSet applications, such as the Mail Tool Compose

window.

5 Text Editor — text_extras_menu, dir; usr/lib 1
(File v) (View v) (Edit v) (Find v)
@g @(#)text_extras_menu 1.6 82/02/08 SMI ;f
# Copyright (c) 1987 by Sun Microsystems, Inc.
# -
# Text "Extras" menu N
#
“Format" fmt
"Capitalize" MENU

"abcd -> ABCD"  capitalize -u

"ABCD -> abcd" capitalize -1

"abcd -» Abcd"  capitalize -¢
"Capitalize” END

"Shift Lines" MENU
"Right" shift_lines -t 1
"Left" shift_lines -t -1

"Shift Lines" END
"Pretty-print C" indent -st
"Insert §rackets" MENU

£ 3" insert_brackets {
“ [ 1" dinsert_brackets 3
" £ 3" dinsert_brackets
"Mt 7" qnsert_brackets \
"Insert Brackets" END

"Remove Brackets" MENU
" ()" remove_brackets ()
" [ 1" remove_brackets \[ \]
! " remove_brackets {
remove_brackets %" \"
"Remove Brackets" END

HaN som

Figure 3-14 Extras Menu File in /usr/1lib/.text_extras_menu

The name of each Extras menu item is surrounded by double quotation marks.
Each submenu begins with a MENU statement and ends with an END statement.
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To include a backslash (\) character in the .text_extras_menu file—as in
the troff inline font specifications \ £B and \ £ P—you need to use four
backslash characters; for example:

insert_brackets \\\\fB \\\\fP
Alternatively, you can use quotes in place of one pair of brackets; for example:

insert_brackets "\\fB" "\\fp"

The . textswrc File

You can associate filters (programs or routines) with unused function keys by
modifying your own copy of the file . text swrc. When a text selection has
been made and a function key pressed, the selected text is piped through the
filter assigned to that key. The output is then piped back into the text at the
caret, replacing the text that was selected.

If you want to specify your own set of bindings of filter keys to function keys,
you must copy the file /usr/1lib/.textswrc to a file called . textswrc in
your home directory. The Text Editor reads the file . text swrc from your
home directory, if the file exists.

Format of the . text swrc File

List the sample file /usr/1ib/.textswrc to see an example of filters used
with a right-handed keyboard. You can copy this file into your home directory,
then modify it by adding filter bindings to unused function keys.

Here is the basic format of each . textswrc file entry:
key-name FILTER

command-line

A function is assigned to one of the function keys by including a statement like
the following in your . textswrc file:

/*
* Note that:
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* insert_brackets /* */ does NOT work
* double guotes are needed

*/

KEY_TOP(10) FILTER

insert_bracketg "/* v " *x /v

This example shows how to include C language comment markers around a
piece of text. You could enter this example into your . textswrc file, and save
the file. Then, to use this added function, start up a new Text Editor
application. Changes to your . textswrc file are only effective when you
bring up a new Text Editor. Then select the text and press the key. The text will
be replaced with a copy of itself surrounded with “/*” and “*/”. Note the
C-like syntax of comments in the . textswrc file.

When defining a filter in the .textswrc file, remember that the filter must
appear in a directory accessible by your search path. If the command is not
found, or if there is some other failure in the invocation of the filter, no change
occurs in the document.
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Multimedia Mail Tool 4

Multimedia Mail Tool lets you communicate with other people on the network.
You can write, send, and receive electronic mail. When you receive an
electronic mail (“email”) message, you can act upon it in various ways:

® Save the message as a file anywhere in your file system

® Delete the message

¢ Reply to the sender

® Forward the message to another recipient along with your own message

® Print the message.

You can send and receive attachments: audio files, image files, document files,
executable files, or any other files.

Using drag and drop, Multimedia Mail Tool works in combination with File
Manager, Text Editor, AudioTool, Calendar Manager, and other applications to
provide an integrated workspace environment.

For brevity, Multimedia Mail Tool is referred to simply as Mail Tool throughout
the rest of this document.

4 To open Mail Tool, choose Workspace » Programs » Mail Tool.
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How Mail Tool Is Organized

Header Window Icons

No mail icon

No new mail icon

Mail Tool has three key windows:

¢ The Header window is a base window that lists mail messages that you
have received.

¢ The View Message window is a pop-up window where you read your
messages.

¢ The Compose window is a base window for responding to messages or
writing new messages.

Each of these windows is described in detail later in this chapter.

The primary Mail Tool icon, for the Header window that shows you incoming
mail messages, looks like a standard office In-Box. When you don’t have any
mail, the In-Box on the icon is empty. When you have mail that has all been
read, the In-Box contains a neatly stacked set of envelopes. When new mail
arrives, envelopes are placed in the In-Box with the stamped and addressed
side showing. Figure 4-1 shows these views of the mailbox icon.

=&

mailtool mailtool mailtool
1

New mail icon

Figure 4-1 Mail Tool Header Window Icons

The Mail Tool Compose window can also be closed to an icon. See “Mail Tool
Compose Window” on page 159 for a description and picture of the Compose
window icons.

Mail Tool Header Window

150

The window shown in Figure 4-2, provides a set of controls with which you
access other parts of the Mail Tool application, display a list of your electronic
mail messages, and see the status of your mail messages.
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By default, this window shows you a scrolling list of the mail messages in your
In-Box. Each line in the scrolling list of the window represents a single
electronic mail message, and is called the header for the mail message.

(=) Mail Teol - /var/mail/egret R
(File @)(View ¢) (Edit v)(Compose v) Mail File:
(Done )(Next ) (Delete)(Reply  w) ((Move v)(Copy v)(load v)

1 thiefecici Thu Feb 18 10:42 18/506  Your Move =
Ue 2 patten@newbirth Thu Feb 18 10:49  46/1282 Project Status
U 3 bgahl@scuba Thu Feb 18 10:50  32/1110 Inbox status =

Message Headers 4 ayers@outhouse Thu Feb 18 10:51 17/532 SunU Training Registration
U S ayers@outhouse Thu Feb 18 10:51 172511 vi command summary
Ue 7 mariac@celtic Thu Feb 18 11:00 90/2531 Project Schedule
U 8 hamilton@artemis Thu Feb 18 11:13  22/611 meeting reminder
U 9 abelson@sharonolds Thu Feb 18 11:34  32/1232 Your position paper
N 10 aguablu@cowman Thu Feb 18 13:58  21/647  Summer Collaboration
—c

L 11 items, 1 new, 2 deleted R

Figure 4-2  Primary Mail Tool Header Window

Mail Message Headers

Each message header has six fields or columns of information, as follows:

® The first field shows you the status of the mail message:
* An arrow points to current messages (messages currently displayed).
* An N shows you that the message is new.

* A U shows that a message is unread, that is, it has been saved without
having been read.

* A blank is displayed after you have viewed the message.
* A diamond indicates that the message contains attachments.

® The second field contains a message number that is automatically assigned to
messages by the Mail Tool in the order in which they are loaded.

® The third field contains the mail address of the sender of the message.
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® The fourth field contains the day, date, and time the message was received.
If the message is over 11 months old, the year is shown instead of the time.

® The fifth field tells you how big the message is. The first number tells you
the number of lines in the message, and the second number tells you the
number of characters. These numbers include the number of lines and
characters of the full message header, as well as the text of the message.

® The sixth field contains the subject of the message when the person who
sent the message provides a subject line.

Message Header Status Messages

Status messages are displayed at the right side of the footer. These messages
tell you how many messages are in your mail file, how many new messages
you have, and how many you have currently deleted. In Figure 4-2, the status
message tells you there are 4 items, 4 new messages, and 0 deleted messages.

Selecting Message Headers

You can select each message header by moving the pointer onto the line and
clicking SELECT. A selected header has a box around it. To select additional
messages, move the pointer into the line and click ADJUST. If a message is
already selected, clicking ADJUST deselects it.

You can select all the messages sent by or to a particular person or alias,
and/or about a particular subject by using the Mail Tool Find feature.

Mail Tool Controls and Menus

The control area, shown in Figure 4-3, has three groups of controls.

@ Mail Tool — /var/mail/bren
(File w)(View v)(Edit v)(Compose v} Mail File:

(Done J(Next )(Delete)(Reply v) (Move w)( Copy v)(Load v)

Figure 4-3 Mail Tool Control Area

152 Solaris 2.2 User’s Guide—May 1993



4

File Menu

The first four buttons in the top row are the standard Mail Tool menu buttons.
The first four buttons in the bottom row are user-defined accelerator buttons,
which you can customize to represent any of the items available from the
standard menus. The items at the right side of the control area are the Mail File
controls. These include the Mail File abbreviated menu button and text field,
and the Mail File Move, Copy, and Load menu buttons.

The following sections provide a brief description of each of these controls.

The File menu has choices that you use to organize mail messages, print them,
or commit changes (such as deleting and sequentially renumbering messages).

® Use Load In-Box to load and view messages from your In-Box. This is how
you return to the default mail view after you are done viewing a different
mail file. It is also how you can get your new mail in between mail delivery
intervals. See “Organizing Your Mail Messages” on page 186 for more
information about mail files.

® Use Print to print the selected messages. See “Printing Messages” on
page 164 for more information about printing.

¢ Use Save Changes to incorporate changes. See “Saving Changes for Mail
Tool” on page 185 for more information.

® Use Done to incorporate changes and to close Mail Tool to an icon.

¢ Use Mail Files to display a window that helps you organize your mail
messages into separate mail files. See “Organizing Your Mail Messages” on
page 186 for more information about mail files.

The default item of the File Menu is Load In-Box. When you click SELECT on
the File button, your In-Box is loaded.
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View Menu

Edit Menu

The View menu has choices for different ways to view messages and move
between them, and for finding particular mail messages.

Use Messages to view messages with an abbreviated or full header.

Use Previous or Next to view the message before or after the current
message.

Use Sort By to sort messages in your In-Box or mail files. See “Sorting the
Contents of a Mail File” on page 193 for more information.

Use Find to find messages in your In-Box or mail file by sender, recipient,
and/or by subject. See “Saving Changes for Mail Tool” on page 185.

See “Mail Tool View Message Window” on page 156 for more information
about the first three items on the View menu.

The default item of the View menu is Next. When you click SELECT on the
View button, the next message is displayed.

The Edit menu has choices for editing and deleting mail messages and
configuring your Mail Tool from the Mail Tool Properties window.

Use Cut and Copy to put selected messages onto the clipboard. You can then
paste these messages from the clipboard into other windows using the Text
Pane menu. These options are dimmed if you do not have any selected
messages.

Use Delete to delete selected messages. This option is dimmed if you do not
have any selected messages, or are not currently viewing any.

Use Undelete to restore deleted messages. When you save your Mail Tool
changes, deleted messages are really deleted, and can no longer be restored.
The Undelete option is dimmed if you do not have any deleted messages.

Use Properties to customize your Mail Tool. See “Customizing Mail Tool” on
page 197 for information about Mail Tool properties.

The default item of the Edit menu is Delete. When you click SELECT on the
Edit button, the currently selected messages are deleted or the currently
viewed messages are deleted if no messages are selected.
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Compose Menu

The Compose menu has choices for opening Compose windows from which
you can write and send mail messages.

¢ Use New to open a new Compose window.

¢ Use Reply to open a Compose window to respond to a selected message. See
“Replying to a Message” on page 167 for more information.

¢ Use Forward to open a Compose window that includes the selected message
for forwarding. If the message has attachments, the attachments are also
included in the forwarded message.

® Use Vacation to initiate or stop an automatic response to incoming messages
when you are away from your mail. See “Using the Vacation Notifier” on
page 170 for more information about Vacation options.

The default item of the Compose menu is New. When you click SELECT on the
Compose button, a new Compose window is opened.

Custom Mail Tool Buttons

The first four buttons on the second row of the control area are custom Mail
Tool buttons. You can change these buttons to be any of the items on the File,
View, Edit, or Compose menus.

The default items of the custom buttons are Done (from the File menu), Next
(from the View menu), Delete (from the Edit menu), and Reply (from the
Compose menu). See “Header Window Properties” on page 198 for
information about how to change the items on these custom buttons.

Mail File Text Field and Menus

You use the Mail File text field and abbreviated menu button to create and
view mail files, and to store messages into mail files. You use the abbreviated
menu button to choose from all your available mail files. See “Mail File
Menus” on page 188 for information on creating and viewing mail files.

Use the last three buttons on the second row of the control area to move or
copy selected messages into a mail file, or to view (load) a different mail file.
Each of these buttons displays a menu of the most recently used mail files. You
can customize this menu to always include particular mail files. See “Mail File
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Menus” on page 188 for information on creating and viewing mail files. See
“Mail Filing Properties” on page 208 for information about customizing your
mail file menus.

Pop-up Menus

A pop-up menu in the Header pane, called Messages, contains a subset of
controls from the File, View, Edit, and Compose menus. Display this menu by
moving the pointer anywhere in the Header window pane and pressing the
MENU button. Each item on the Messages pop-up menu works the same way
as it does when you choose the same item from a menu button.

The text editing panes in the View Message and Compose windows contain a
pop-up menu with the standard editing commands from the Text Editor. For a
description of the text editing commands, see the chapter “Text Editor” on
page 127.

Mail Tool View Message Window

156

To view a message, double-click SELECT on the header for the message that
you want to display. Alternatively, you can SELECT the message header, and
then choose Messages from the View menu.

A View Message pop-up window is displayed showing the text of the selected
message with an abbreviated message header, as shown in Figure 4-4.
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ro-Dﬂ Mail Tool : View Message 2

|§rom patten@newbirth Thu Feb 78 10:49 PST 1993
ate: Thu, 18 Feb 93 10:49:35 PST

From: patten@newbirth (Robert Patten)

To: egret@river

Subject: Project Status

Cc: otter@dodona

Content-Type: X-sun-attachment
Content-Length: 710

G |

Enclosed is a summary of our current status against
the milestones we established in our last weekly

meeting.
Please make this information available to your
staff.
As a reminder, our next meeting has been postponed
=
Attachments 1 attachment {14 bytes)
‘0 :
weekly.status =1
|

Figure 4-4 View Message Window

The number of the displayed message is always shown in the header of the
View Message window (Message 2 in Figure 4-4).

Once you have displayed a message in a View Message window, any “New” or
“Unread” flags on the message header are cleared, whether or not you have
actually read the message.

The View Message window uses the standard text editing pane and pop-up
menu. You can edit the text in the View Message pane. If you have made
editing changes to the message, a Notice (asking if you want to save the
changes), is displayed when you change messages or dismiss the window.

The View Message window can be split into two or more panes to view and
edit different parts of the mail message at the same time. See Chapter 3, “Text
Editor” for more information.

If the message you are viewing contains attachments, a separate attachment
area is displayed at the bottom of the View Message window. See “Mail Tool
Attachments” on page 174 for information about mail attachments.
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Using the Pushpin in the View Message Window

The View Message window has a pushpin that you can use to pin the window
to the workspace if you want to keep a message (or several messages) visible.

If you do not pin the View Message window, it is reused for subsequent mail
messages that you view. If you do pin the View Message window, a new View
Message window will be displayed for the next message you view, and you
can display multiple View Message windows at the same time.

Viewing the Next or Previous Message

You can view the next message by clicking SELECT on the View button or the
Next button. If the View Message window is displayed but not pinned, the
next message is displayed in the existing View Message window.

Note - Clicking SELECT on the View menu button activates the default item
for the menu. If you have changed the default, you must display the View
menu and choose Next. Also note that the Next button is a custom button, and
may not be available on the header control area if you have changed the value
of this custom button.

To display the previous message, choose Previous from the View menu. You
can also use the up and down arrow keys on your keyboard to display the
previous and next messages. The Mail Tool Header window must be the
currently active window for this to work.

Alternatively, you can always view any message by double-clicking SELECT
on the desired message header.

Viewing Messages With a Full Header

Mail Tool messages are normally displayed with an abbreviated header. To
display a message with the full message header, select the desired message
header and choose Full Header from the Messages submenu of the View menu.
Figure 4-5 shows an example of a full message header.
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C R Mail Tool : View Message 7

From mariac@celtic Thu Feb 18 11:00 PST 1993
eturn-Path: <marjac@celtic>
Received: from celtic.Eng.Sun.COM by river.Eng.Sun.COM (5.0/SMI-SYR4)
id AA00670; Thu, 18 Feb 93 11:00:10 PST
Received: by celtic.Eng.Sun.COM (4.1/SMI-4.1)
id AAC4215; Thu, 18 Feb 93 10:55:09 PST
bate: Thu, 18 Feb 93 10:55:09 PST
From: mariac@celtic (Maria A. Cherem)
Message-Id: <9302181855.AA04215@ce]tic.Eng. Sun.COM>
To: egret@river
Subject: Project Schedule

G0 |

Content-Type: X-sun-attachment
X-Lines: 73

Status: RO

Content-Length: 2010

Here’s the latest Project Schedule.

—
Attachments 1 attachment (1693 bytes)
Ej
[nam )
o

Figure 4-5 Full Message Header

The contents of the abbreviated header are determined by the Hide items on
the Message Window Properties scrolling list. All mail headers are displayed
except those listed in the Hide scrolling list. See “Message Window Properties”
on page 201 for information about customizing your default abbreviated
header with the Hide scrolling list.

Viewing Multiple Mail Messages

If you select multiple mail messages and display them by choosing Messages
from the View menu, a View Message window is opened for each message,
layered one on top of another in numerical order (not in the order that you
selected them).

Another way to view multiple mail messages is to pin an existing View
window, and then double-click SELECT on another mail message header. The
new message will be displayed in a new View window.

Mail Tool Compose Window

Any time you choose an item from the Compose menu (except for Vacation), a
Compose Message window is opened. (The Compose Message window is
simply referred to as the Compose window in the rest of this document.) A
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Compose window operates independently from the Mail Tool Header window.
You can close an opened Compose window to an icon for later use, or keep a
Compose window open while the primary Mail Tool Header window is closed
to an icon. The Compose window icon shows an unsealed envelope, a sheet of
paper, and a label indicating the recipient of the message if the recipient has
been specified. Figure 4-6 shows these views of the Compose icon.

Toimay nan

Figure -6  Compose Window Icon (before and after specifying a recipient)

You can open as many Compose windows as you like at one time, while
replying to or composing several messages concurrently. The Compose
window is shown in Figure 4-7.

r@ Mail Tool: Compose Message i
(Include v) (Deliver v) (Header v) (Clear} ((Attach v)
To:
Subject:

Ce:

G20

Attachments

Figure 4-7 Compose Message Window

The Compose window has its own set of controls that you use to create and
send mail messages:
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The Include menu button provides choices to include selected messages as
part of the message you are composing. It also provides you with a set of
templates for creating different types of messages. See “Template
Properties” on page 213 for more information about templates. If you are
not going to include any attachments, you can use the Include menu to turn
off the Attachments pane at the bottom of the Compose Window, allowing
recipients to see more of the mail message.

The Deliver menu button provides choices for how the Compose window
behaves once the message is sent.

The Header menu button provides choices for the number and type of text
fields that make up the message header. The default choice is Bec, which
allows you to add or delete the blind carbon copy (a copy of the message is
sent to another recipient without the original recipient knowing) field to the
message header. You can add other fields to this menu with the Custom
Fields scrolling list in the Compose Window Properties sheet. See “Compose
Window Properties” on page 203 for more information. The Aliases item
brings up the Alias properties window.

The Clear button clears the contents of the window. Your message is saved
in the file dead. letter whenever you use the Clear button or the Clear
message item from the Compose window’s Deliver menu. See the man page
for mailx (1) for information about dead.letter and the “save” variable.

The Attach menu button brings up Voice, which accesses AudioTool and
allows you to compose a voice message. See Chapter 11, “Audio Tool” for
information about Audio Tool. It also brings up Appt, an appointment
editor window for creating appointments to be used with Calendar
Manager. For information on how to do this, refer to Chapter 5, “Calendar
Manager.”

The Log check box determines whether or not the mail you are composing is
recorded in a file. You specify the file where messages are recorded using
the Mail Tool Properties window. See “Compose Window Properties” on
page 203 for more information.

The Log check box does not appear on the Compose window if you have
not specified a log file name with the Compose Window properties.

The To, Subject, and Cc text fields are used to type the email addresses of
the recipients, the subject of the message, and the email addresses for those
to receive copies of the message, respectively.
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® The text pane of the Compose window is used to type the text of the
message you want to send. The text pane uses the standard text editing
conventions available from the Text Editor. See the chapter “Text Editor” on
page 127 for more information about editing.

The Attachments pane at the bottom of the Compose window is used to add
attachments to your mail. Attachments can be any kind of file, and can be
used to send images, voice mail, documents that retain their word-processor
file formats, Calendar Manager appointments, and so forth. See “Mail Tool
Attachments” on page 174 for information about mail attachments.

Reading Messages

You can tell you have new mail in two ways:

® If Mail Tool is closed, the Mail Tool icon shows the status. An overflowing
in-box means you have new mail.

® If Mail Tool is open, new message headers, preceded by “N” (for New) are
displayed in the Header window. Additionally, a counter in the lower right
corner tracks the number of new messages.

"R Mail Tool : View Message 8

From hamilton@artemis Thu Feb 18 11:13 PST 1993
bate: Thu, 18 Feb 93 11:13: 33 PST

From: ham1]ton@artem1s (Mary "Hacksaw" Hamilton)
To: egret@river v
Subject: meeting reminder
Content-Type: text
Content-Length: 92

UJ

Hi Egret,
Don“t forget our meeting today at 3pm. Marsh Conference Roonm.

Thanks,
Otter

Figure 4-8  Header window
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¢ To read a message, double-click SELECT on the message header.
The header you select is outlined, as shown in Figure 4-9, and the View
Message window displays the message.
i) Mail Tool - /var/mail/egret R
Message status —
g (File v) (View v)(Edit v)(Compose v) Mail File:
Done Next Delete ) ( Repl v Move v )( Copy v )( Load v
Message number (Bore) (et ) (Belte) (Roy__v) (Howe v) (o o) (LGt o) _
in mail queue thiefacici Thu Feb 18 10:42  18/506  Your Move
patten@newbirth Thu Feb 18 10:49 46/1282 Project Status
U 3 bgahl@scuba Thu Feb 18 10:50 32/1110 Inbox status -
Email address U 4 ayers@outhouse Thu Feb 18 10:5t 17/532  SunU Training Registration
of sender 5 ayers@outhouse Thu Feb 18 10:5%  17/511  vi command summary
+ 7 mariac@celtic Thu Feb 18 41:00 9042531 Project Schedule
8 hamilton@artemis Thu Feb 18A1:13 22/611  meeting reminder
9 abelson@sharonolds Thu Feb 1§ 11:34  37/1232 Your positiof paper
10 aguablu@covman Thu Feb 18 13:58 1/647  Summer Collgboration
—c
i / / / 11 items, 1 new, 2 deleted R
A l /
Date and time Number of lines
mail received and characters Subject Number of messages
in the queue
Figure 4-9 Message Headers in the Mail Tool Window
To read a message:
1. If Mail Tool is closed, double-click SELECT on icon.
The Header window is displayed.
2. Double-click SELECT on the header of the message you want to read.
The message is displayed in the View Message window.
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Printing Messages

You can print your mail messages using either Mail Tool or Print Tool.

Printing Mail Messages Using Mail Tool

To print your messages from Mail Tool, select the headers for the messages you
want to print, and choose Print from the File menu. Figure 4-10 shows these
steps.

- Mail Tool - /var/mail/egret
(View v )(Edit v)(‘Compose v) Mail File: (g,

-—1H :)(Delete)(RepIy v) (Move v)(Copy v)(Load v)
Load In-Box ¢ O [ry Thu Feb 16 10:42 18/506  Your Move
Print Ewbirth Thu Feb 18 10:43  46/1282 Project Status ]
ba Thu Feb 18 10:50  32/1110 Inbox status ~]
Save Changes & S [hoce Thu Feb 18 10:51  17/532  SunU Training Registratio
Done rhouse Thu Feb 18 10:51  17/511  vi command summary
- Ttic Thu Feb 18 11:00  90/2531 Project Schedule
Mail Files.. artemis  Thu Feb 18 11:13  22/611  meeting reminder
e Teuesharonolds Thu Feb 18 11:34  32/1232  Your position paper
N [10_aquabTu@cownan Thu Feb 18 13:58  21/647  Summer Collaboration
s

11 items, 1 new, 2 deleted i

Figure 4-10 Printing Multiple Mail Messages

The messages are printed using the print script specified in the Message
Window Properties sheet. See “Message Window Properties” on page 201.

If a message has attachments, the attachments are not printed. A message is
printed that tells you how many attachments the message has.

To print an attachment, open the attachment and print it using the
attachment’s application, or drag the attachment to the Print Tool.
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Printing Mail Messages Using Print Tool
You can use Print Tool to print your mail messages using these steps:

1. With both Mail Tool and Print Tool running, select the headers for the
messages you want to print.

2. Press SELECT and drag the headers until the hot spot of the pointer is on
the Print Tool drag and drop target.
The drag and drop target is the box in the upper left corner of the Print Tool
window.

The pointer changes to a document glyph if you are dragging one mail
header to indicate that what is being dragged is document. The pointer
changes to three document glyphs if you are dragging several mail headers.
In the example shown in Figure 4-11, two files have been selected for
printing.

Mail Tool - /var/mail/egret

(File v)(View v ) (Edit v)(Compose v) Mail File: [¥],
- "

@

1 thiefecici Filename: /tmp/quideEAAA00OE
+ 2 patten@newbirth B3 %
U 3 bgahl@scuba Copies: 1 @ Print
U 4 ayers@outhouse P 1B
3 ayers@outhouse Header: [ Properties...

¢ 7 mariac@celtic

8 hamilton@artemis
9 abelson@sharonol Printer: e :Information.:..

N 10 aguabTu@cowman [mimeo ]

Data transfer in progress 1

0

Figure 4-11 Printing by Using Drag and Drop
3. Release SELECT to drop the headers.

Messages are displayed in the footer of the Print Tool window displaying
the printing status.
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Composing Messages

If a selected mail message has attachments, and the message is dropped on the
Print Tool, the attachments are not printed. A message is printed that tells how
many attachments are with the message. To print an attachment, open the
attachment and print it using the attachment’s application, or drag just the
attachment to the Print Tool.

Your email address is typically your login ID and your machine’s host name,
combined like this: name@host. If there is more than one domain on your
network, you may need to append a domain name to the address as well. For
instance, the name would appear in this format: name@host .domain. Check
with your system administrator to make certain.

Others on your network will typically have the same address format. When
you are certain of your email address, try sending a test message to yourself.

Composing a New Message

166

To compose a new message:

1. In the Header window control area, click SELECT on Compose.
The Compose Message window is displayed.

2. Click SELECT on the To text field, and fill in the message header
information.

* Press Return as you complete each line

* In the To and Cc text fields, separate multiple email addresses with a
comma, a space, or both. For example:
here@machine, there@elsewhere, outside@somewhere

a. Type the topic in the Subject text field, and press Return.

b. If desired, type email addresses of carbon copy recipients in the Cc text
field.
Separate the addresses with a comma, a space, or both.

3. Move to the Text pane either by pressing Return or clicking SELECT in
the Text pane.
The dimmed insert point darkens to indicate it is active.
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4. Type your message.
The Compose window Text pane uses standard text editing functions.

Figure 4-12 shows a sample message.

" =) Mail Tool : Compose Message R

Addressee —_ ] (Include v) (Deliver v} ((Header v) (Clear) ((Attach v)

Message subject

[~ To: user@machinename

[—Subject: Title of the mail message
T user@machinename

Carbon copy line

I

This is where you type the text of the mail message.
You can add an attachment or two if you like.
Make sure you at least fi1l out the sender information

in the To: field,
Text pane ¢

Attachments

KLYl

Attachments —_—
pane

Figure 4-12 Addressing a Message

To include an attachment, see “Sending Mail Attachments” on page 178.
5. To send the message, click SELECT on Deliver.

The message is delivered, and the Compose window closes.

Replying to a Message

Replying to a message is similar to composing a message.
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1.

In the Header window control area, press MENU on Reply.

2. Choose the appropriate item for your recipient(s).

3.

The Compose Message window is displayed. Note the following:

* The To and Subject text fields are filled out.

* A copy of the original message is included only if you chose Reply To
Sender, Include or Reply To All, Include.

Type or edit your message and its header, and send the message.
Refer to the section “Composing Messages” on page 166.

Forwarding Messages to Third-Parties

You can forward a message to another person in two ways, depending on
where you start from:

Forwarding a message from the Header window.

® Including a message from the Compose Message window.

Forwarding a Message

To forward a message from the Header window:

1.

Select the message(s) you want to forward.
* Click SELECT on the first message header.
* Click ADJUST on additional message headers.

Choose Forward from the Compose menu.
The Compose Message window is displayed. Note the following:

* The Subject text field is filled in. You need to fill in the other To text field,
and if desired, the Cc text field.

* The Text pane displays the original message.
* The Attachments pane includes any attachments to the original message..

Type your message, and send the entire new message.
Refer to the section “Composing Messages” on page 166.
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Using Templates

Including a Message
To include a message from the Compose window.
1. Compose your message.

2. In the Header window, click SELECT on the header of the message(s) you
want to include.

3. In the Compose window, choose Bracketed or Indented (as you prefer)
from the Include menu.
Your choice determines the formatting of the original message:

* Bracketed labels the beginning and end of the message.

* Indented indents each line of the message and marks each line with a
greater-than sign (>).

4. To send the message, click SELECT on Deliver.

A template is a file you can include in a mail message that contains text you
frequently use when composing messages. Mail Tool allows you to create your
own template files. You might, for example, want to create a standard table
format for status report information or a standard signature and closing
message. See “Template Properties” on page 213 for information about how to
create and store templates. When you have created a template file and added it
to Mail Tool, it is displayed as an item on the Templates submenu. The menu in
the left margin shows a Templates submenu with three templates.

The default Templates submenu contains only the Calendar template. The
Calendar template creates messages in a form that Calendar Manager
interprets when the message header is dragged and dropped onto the Calendar
Manager. See the chapter “Calendar Manager” on page 221 for more
information.

Any template available from the Templates submenu can be added to a
message at any time while you are composing it. When you choose the item
from the Include menu, the template is inserted at the caret location.

Figure 4-13 shows an example of a signature template.
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= Mail Tool:

(include ¥) (Deliver ¥ ) (Header ¥ }(Clear) //
To: ,//
Subject: A
Cce: /

r

Briana Halvorsen
Technical Writer
Sun Microsystems, Inc.

s

Figure 4-13 Example of a Signature Template

Using the Vacation Notifier

When you are away from your office, you can use the Vacation notifier on the
to each email message you receive.
Mail Tool provides you with a generic message form that you can edit and
customize to suit your individual needs. Figure 4-14 shows the Vacation Setup
pop-up window with the generic message. Choose the Start/Change item on
the Vacation submenu to display the Vacation Setup window.

Compose menu to automatically respond

= Mail Tool : Vacation Setup

ubject: I am on vacation
recedence: junk

Your mail regarding "$SUBTECT" will be read when I
return.

If you have something urgent, please contact...

]

|
&
@

Figure 4-14 Vacation Setup Pop-up Window

You can edit this message in the same way you edit messages in the Compose
window. The string $SUBJECT in the message text automatically extracts the
subject from the message being responded to, and includes it in the reply
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message. The Precedence:;junk line tells the mail delivery agent to set this mail
to a lower priority and not to return any error messages to this mail message.
Figure 4-15 shows an example of a vacation message that has been customized.

r':u:a Mail Tool: Vacation Setup
Subject: I am on vacation
Precedence: junk

I’m on vacation from December 18 through p
December 25. -

DI

Your mail regarding "$SUBJECT" will be read when I
return.

Hope you have a happy holiday season.

Jan

L )

Figure 4-15 Modified Vacation Message

To start the vacation message, click SELECT on the Start button. The word
“Vacation” is displayed in the header of the Mail Tool window to remind you
that the vacation notifier is turned on.

While the vacation notifier is turned on, incoming mail messages are stored in
your In-Box and are readily available when you return to the office. When the
vacation notifier is turned on, it replies to each person who sends mail to you.
Each sender receives a reply from the vacation notifier, but it replies to the
same sender only once in each seven day period.

If your name is listed in a public alias and a message is sent to the alias, the
vacation notifier does not respond to the sender of that message. The vacation
notifier will respond to names included as part of a private alias. See “Alias
Properties” on page 215 for information about mail aliases.

Once you have activated the vacation notifier, the Stop item on the Vacation
submenu is also activated. To stop the vacation notifier and remove the word
“Vacation” from the header, choose Stop from the Vacation submenu.
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Deleting Messages

Undeleting Messages

172

It is a good idea to periodically delete obsolete messages from your In-Box. To
delete one or more mail messages, select the message headers that you want to
delete, then choose Delete from the Edit menu. The selected mail messages are
deleted from the display, and the status message in the footer updates to reflect
the current state of your In-Box, as shown in the example in Figure 4-16.

"= Mail Tool - /var/mail/egret R
File v) (View v)(Edit v)("Compose v) Mail File:
(Done J('Next )(Delete)(Reply %) (Move v)(Copy v)( Load v)
[ 1 thief@cici Thu Feb 18 10:42  18/506 _ Your Move
¢ 2 patten@newbirth Thu Feb 18 10:43 46/1282 Project Status ]
U 3 bgahl@scuba Thu Feb 18 10:50 32/1110 Inbox status <]
U 4 ayers@outhouse Thu Feb 18 10:51  17/532  SunU Training Registratiof
S ayers@outhouse Thu Feb 18 10:51 127511 vi command summary
& 7 mariac@celtic Thu Feb 18 11:00 90/2531 Project Schedule
8 hamilton@artemis Thu Feb 18 11:13  22/611 meeting reminder
9 abelson@sharonclds Thu Feb 18 11:34  32/1232 Your position paper
N 10 agquablu@cowman Thu Feb 18 13:58 21/647  Summer Collaboration
| o
L 11 items, 1 new, 2 deleted i

Figure 4-16 Status Message after Deleting Two Mail Messages

Delete is also the default value of the third custom button. It is also available
from the header pane pop-up menu, described in the section “Pop-up Menus”
on page 156.

As long as you do not incorporate changes to Mail Tool by switching to
another Mail File or by choosing either Save Changes or Done from the File
menu, your deleted messages remain available and you can “Undelete” them.

When there are no deleted messages available, the Undelete item on the File
menu is inactive.

To undelete the message most recently deleted, choose Undelete from the Edit

menu.

To undelete a different message, or to undelete more than one message at a
time, choose From List on the Undelete submenu to display the Undelete
window. The Undelete window contains a scrolling list of messages that you
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Finding Messages

have deleted since you last incorporated changes in Mail Tool. Select the
headers of the messages that you want to undelete, then click SELECT on the
Undelete button.

To save your undeleted messages in your Inbox, click SELECT on Done in the
Mail Tool Message window control area, or choose Save Changes on the File
menu.

To find messages, you can search your In-Box or mail files for messages with a
particular subject, messages that have been sent to or from a specific person, or
both. You can use this feature to find one particular message, or to find a group
of messages. For example, if you come back from vacation and find a lot of
mail messages about a topic you are not interested in, you can find all the
messages about that subject and quickly delete them.

To find a message, first display the Find pop-up window by choosing Find
from the View menu. The Find pop-up window is displayed, as shown in
Figure 4-17.

© Mail Tool : Find Messages
From:
To/Cc:
To:
Cc:
Subject:
{FTnd Forward) ( Find Backward ) (Select All) (Clear)

Figure 4-17 Find Pop-up Window

You can search for messages based on the mail header’s From field, To field, Cc
field, or Subject field, or by any combination of these fields. The Search text
fields are case-insensitive and match partial words and phrases. You do not
need to type a complete sender name, and you can use keywords to match
subjects. For example, typing the name robles in the From text field will find
messages sent by robles@oak as well as manual.robles.
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Mail Tool Attachments

174

To search for messages by sender, type the sender name in the From text field.
Clicking SELECT on the Find Forward button selects the next message header
with the sender name you specify. Clicking SELECT on the Find Backward
button selects the previous message header. Clicking SELECT on the Select All
button selects all message headers with the sender name. A message is
displayed in the footer of the Find Messages window telling you how many
messages are selected.

If you want to find mail sent to a person or alias either directly or by Cc list,
type the name in the To/Cc field. If you only want to find mail sent directly to
a person or alias (but not carbon copied), type the name in the To field. If you
only want to find mail carbon copied to a person or alias (but not sent directly),
type the name in the Cc field.

To search for messages by subject, type a word or phrase in the Subject text
field.

To search for messages by sender, receiver, and by subject, type the appropriate
information in each text field and click SELECT on one of the buttons at the
bottom of the Find window. Only mail messages that satisfy all the conditions
will be found.

Clicking SELECT on Clear removes all the text typed in the Find Messages
window text fields.

A mail message can contain attachments, which are files of any type in their
own file formats. For example, a mail message might contain an image
attachment and an audio attachment, providing an illustration and voice mail.

When a message contains attachments, the View Message pop-up window
displays a separate Attachments pane at the bottom, as shown in Figure 4-18.
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(@) Mail Tool : Compose Message i
(inciude v) (Deliver v) ((Header v) (Clear) (Attach v)
To: mariac@celtic
Subject: Two Files,
Cc:
—
Maria,
Attached are two files that you might find useful. »
=
Attachments 2 attachments {8920 bytes)
1 2 (& E
my_file my_printscript =
L )

Figure 4-18 View Message Pop-up Window with Attachments

You can move attachments to the File Manager or any other application that
accepts files of the attachment’s file type. You can also open the attachments
without moving them out of the Mail Tool. You can add new attachments to a
mail message, delete attachments, or rename them.

Opening Mail Attachments

There are two groups of mail attachments:

® Ordinary attachments, which are bound to their applications. You open
them (and their applications) directly from the Attachments pane. For
example, Calendar Manager appointments, mail messages, icons and
images, voicemail, and executable files.

® Special attachments, which are not bound to their application. You cannot
open these files directly from the Attachments pane. For example, specially-
formatted text files created with desktop publishing software.
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Note - If there are more attachments than can be displayed in one row, you
need to scroll down with the Attachments pane scrollbar to see all the files.

Opening Ordinary Attachments

/N

To open most attachments:

¢ Double-click SELECT on an icon in the Attachments pane.
The message, “Launching...” appears in the message area beneath the
Attachments pane, and in a moment the application opens, and the file is
displayed.

Caution — When starting an executable from the Mail Tool Attachments pane,
you receive a warning message asking if you want to run the executable
program or cancel. Before you click SELECT on “Run it,” make sure you know
what the outcome will be and that the sender is someone you trust.
Executables such as shell scripts can be used to perform operations on the files
in your file system.

Figure 4-19 shows a mail message with a voice mail attachment opened up in
the AudioTool application. See the chapter “Audio Tool” on page 347 for
information about using AudioTool to listen to the message.
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From mariac@celtic Wed Feb 24 15:32 PST 1993
Date: Wed, 24 Feb 93 15:27:07 PST

From: mariac@celtic (Maria A. Cherem)

To: egret@river

Subject: Last Week’s Conversation
Content-Type: X-sun-attachment
Content-Length: 23876

Egret,

Here’s a recording of the short conversation I
had with Rob and Keith Tast week.

p————_GTT¥0

~Maria f@ Audio Tool

(File v) (Edit v) (Volume v}

Attachments

L
= [« > | (o]

Rev Play Fwd Rec

(00 =

Voice Format

Figure 4-19 Mail Message with an Opened Voice Mail Attachment

Note — PostScript attachments are displayed in Image Tool. For complete
information on how to use Image Tool, refer to Chapter 13, “Image Tool.”

Viewing Special Attachments

You will need access (on your system or file server) to the software used to
create the attachment. Also, you probably need to be running the same version
of the software. If you do not have access to the correct software, you might
want to request that the sender convert the file into PostScript format and
resend the file.

To view specially-formatted text files:

1. Copy the attachment into File Manager.
See “Moving Mail Attachments” on page 183.

2. Open the file from the application in which the file was created.
Consult the user manual that came with the application for details.

Multimedia Mail Tool 177



178

Sending Mail Attachments

To include attachments in a mail message you are composing, select the file
icons that you want to include from the File Manager, and drag and drop them
onto the Attachments pane of the Compose window. You can also drag and
drop files or data from the Text Editor or any other application that supports
drag and drop.

Alternatively, you can use the Attachments pane Add Attachments popup to
include attachments in your message, as described in “Adding Mail
Attachments” on page 180.

Follow these steps to drag and drop a file from the File Manager onto Mail Tool
to be included in a mail message:

1. Open the File Manager application and the Mail Tool Compose window
of the message you are sending.
If the Attachments pane is not showing at the bottom of the Compose
window, choose Show Attachments from the Compose window Include
menu.

2. In the File Manager, click SELECT on the file that you want to include as
a mail attachment.
Click ADJUST on any additional files that you want to include.

3. Press SELECT on one of the highlighted files, and drag the pointer to the
Attachments pane of the Compose window, as shown in Figure 4-20.
The pointer changes while the file is being dragged.
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?ngle v) (View v) (Edit v)

/  hightide egret Fish

[ETT3) a
Contains 10 items 872 Mbytes (98%) available
1=
E ’J Mail Tool : Compose Message R

seafood | (include v) (Deliver v) (Header v) (Clear) ((Attach v)

To: mariac@celtic

® Subject: Requested file
Cc:

Tuna

Attached is the file you requested.

g KImE|

Attachments

ifcInyi

Figure 4-20 Selecting a File for dragging onto the Compose Window Attachments Pane

4. Release SELECT.
The file is displayed in the Attachments pane as an icon, and will be
included as part of the mail message.

Note - If you drag and drop a file onto the text area of the Compose window,
the file is included in the text as ASCII text. Some types of files, such as binary
program files, are unreadable in the text pane. If you want to include the file as
a separate attachment in its native format, make sure to drag and drop the file
onto the Attachments pane.

If you drag data that is not a file onto the Attachments pane, the name of the
icon that appears in the Attachments pane is the data type. For example, if you
want to drag and drop the text in the Text Editor pane, you can press SELECT
on the drag and drop target that appears in the Text Editor header, drag the
pointer to the Compose window Attachments pane, and release SELECT. The
new icon in the Attachments pane is named Text.
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Adding Mail Attachments

You can add new mail attachments to a message using drag and drop, as
described in the previous section, or the Add Attachment pop-up window.

Note — Keep in mind that when you add attachments to a mail message, it is
easy to construct very large messages without realizing it.

To add a new mail attachment using the Add Attachment popup window,
follow these steps:

1. Choose Add from the File menu at the top of the Attachments pane.
The Add Attachment popup window is displayed.

2. Select the directory name of the file to be attached.
Alternatively, you can type the path in the Go To text field.

3. Click SELECT on the Add button, as shown in Figure 4-21.
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) Mail Tool : Add Attachment K
Type in the path to the folder and press Return,
@D

Current Folder:
/hightide/egret/Fish
Select a file and click Add
J
4 .Go up one folder.. b
DCod | 5
[ salmon i
[ swordFish
[JTuna
—
Hidden Files:
idey ((Cancel) (Ad)
L )

Figure 4-21 Adding an Attachment with the Add Attachment Popup Window

The file is added to the mail message attachment pane, as shown in
Figure 4-22.
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= Mail Teol : Compose Message

(Include v)) (Deliver v) (‘Header v) (Clear) (Attach v)

To: mariac@celtic
Subject: Requested file
Cc:

Attached is the file you requested.

CIMES|

—c

Attachments 1 attachment (2230 bytes)

1: E

DeskSetDefaults =

L Added 1 attachments for a total of 3k bytes N,

Figure 4-22 Attachment Added to a Mail Message Attachment Pane

Renaniing Mail Attachments

Follow these steps to rename a mail attachment in the View Message or
Compose window Attachments pane:

1. Select the attachment that you want to rename.
You can only rename one attachment at a time.

2. Choose Rename from the Edit menu at the top of the Attachments pane.
The Rename Attachment popup window is displayed.

3. In the Rename Attachment popup window, type the new attachment name
in the Name text field and click select on the Rename button, as shown in
Figure 4-23.

The attachment in the Attachments pane is renamed.
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FE Mail Tool :Rename Attachment

Rename selected attachment to:

Name: new.attachment

(Fenare §

L =

Figure 4-23 Renaming an Attachment in the Rename Attachment Popup Window

Note — The name of an attachment should never contain the slash (/) character.
This can cause confusion between file and directory names.

Moving Mail Attachments

You can drag and drop attachments to the File Manager, or any other
application that accepts files of the attachment’s file type. See “Using Drag and
Drop with Mail Tool” on page 195 for more information.

Alternatively, you can use the Attachment pane’s controls to copy an
attachment to a directory:

1. In the Attachments pane, click SELECT on the attachment to be copied.
The file is highlighted.

2. In the control area of the Attachments pane, choose Save As from the File
menu.
You see the Mail Tool: Save Attachment As popup window, as shown in
Figure 4-24.
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= Mail Tool : Save Attachment As |

Type in the path to the folder and press Return.

Current Folder:
fhightide/fegret/Fish

Select a file or folder and click Open Folder.

[ ..Go up one folder.. |

(KINE]

Save As: Salmor,

Hidden Files:

(Open Folder) (Cancel) (Save)

L -

Figure 4-24 Save Attachment As Popup Window
a. Select the directory and filename to be moved.
Alternatively, you can type the directory name in the Directory text field.

b. Click SELECT on the Save button.
A copy of the file is stored in the specified directory, with the file name
derived from the name of the attachment.

184 Solaris 2.2 User’s Guide—May 1993



H
1]

Deleting Mail Attachments

To delete attachments from a message in the View or Compose window, select
the attachment or attachments you want to delete and choose Delete from the
Edit button in the control area of the Attachments pane.

Use the Undelete item to restore the most recently deleted attachment. This
item is grayed out if there are currently no deleted attachments.

Saving Changes for Mail Tool

To improve system performance, Mail Tool does not automatically save
changes that you make when you close it to an icon. Messages that you have
deleted remain available to you when you open the Mail Tool Header window.

To free up disk space and keep your mail box a manageable size, it is a good
idea to periodically delete obsolete messages and save changes.

You save changes using either Save Changes or Done from the File menu.

® Use Save Changes to commit changes and incorporate new mail without
closing the primary Mail Tool Header window.

® Use Done to commit changes, close the primary Mail Tool Header window
to an icon, and incorporate new mail the next time you open the icon. Using
Done leaves Mail Tool in a condition that lets you read mail using another
mail program without creating conflicts in the mail spooling files.

Mail Tool automatically checks and incorporates new mail messages using a
time period specified from the Mail Tool Properties window. If you have a long
time period set and want to see if you have new mail, you can use Load In-Box
from the File menu. Choosing either Save Changes or Done also checks for new
mail messages. See “Customizing Mail Tool” on page 197 for more information
about Mail Tool properties.

When you quit the Mail Tool application, a Notice is displayed, as shown in
Figure 4-25, asking you whether you want to save changes, quit without saving
changes, or cancel the quit notice.
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The current mail box has been changed
Do you wish to save the changes?

{Save Changes) ( Discard Changes) ((Cancel)

Figure 4-25 Quit Notice

Choosing Save Changes commits the changes and quits Mail Tool. Choosing
Discard Changes discards changes, reincorporating any deleted messages as
part of the In-Box, and quits Mail Tool. Choosing Cancel cancels the quit
operation, and leaves Mail Tool running.

Organizing Your Mail Messages

186

A convenient way to organize your mail is to group related messages together
in a mail file. A mail file is a file that can contain multiple mail messages. If you
view a mail file outside of Mail Tool, it looks like a single file with multiple
mail messages appended to one another. When you view a mail file using Mail
Tool, each separate message header is displayed in the header pane, and you
can view, edit, delete, and respond to each message individually.

You can use the Mail Files pop-up window to create, delete, and rename mail
files and subdirectories of mail files, to add messages to mail files, or to view

mail files. To display the Mail Files window, shown in Figure 4-26, choose Mail
Files from the File Menu.
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) Mail Tool : Mail Files T

Name: ,
(Save v) (load v) ((Create v) (Edit v)

/hightide/egret

[4 ..Go up one folder... |
QD artfiles

(JFish

(CJFolder

(A Testapps

Cafilename

I mail

root

L0

L =l

Figure 4-26 Mail Files Window

The Mail Files popup window contains a scrolling list of all your mail files (or
mailfolders). There are three groups of entries listed in the mailfolder scrolling
list, as follows:

® Double-click SELECT on that entry to display the mail files up one directory
level.

® The next entries in the mailfolder scrolling list are your subdirectories (or
folders) of mail files. You can double-click SELECT on these entries to
display the mail files of each subdirectory.

® The last entries in the mailfolder scrolling list are the regular mail files that
you can load or save messages to.

You specify the directory where the mail files reside in your file structure using
the Mail Filing category in the Properties window. See “Mail Filing Properties”
on page 208 for more information. Any mail files that you create in this
directory are displayed as items in the Mail File menu on the Header window
control area (described in the section “Mail File Menus” on page 188). The
default mail file directory is your home directory. If you want to specify a
different directory, it’s a good idea to do so before you create new mail files.

In addition to using the Mail Files window, you can also create new mail files,
add messages to mail files, or view a mail file using the Mail File menu and the
Move, Copy, and Load menus on the Mail Tool Header window control area.
These menus are described in the next section.
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Mail File Menus

The Mail File menu of the Header window contains a list of files and
subdirectories in your mail file directory, as shown in Figure 4-27. Use this
menu as an easy way to fill in the name of a mail file in the Mail File text field.

v) (Move v) Artfiles/

thiefacici Thu Feb 10:42  18/508

pattenenewhirth  Thu Feb 18 10:43  d4p/12g2| Folder/
bgahl@scuba Thu Feb 10: 32/1110| TestApps/
ayers@outhouse Thu Feb 10: 17/532 | dead.letter

ayers@outhouse Thu Feb 10: 1727511
90/2531 dead.letter.

mariac@celtic Thu Feb 11:

hamilton@artemis  Thu Feb 11: 22/811

dead.letter.2

abelson@sharonolds Thu Feb : 32/1232| edit_undors

aquablu@cowman Thu Feb 13: 21/647 il
418/2437| filename/

mariac@celtic Wed Feb 15:

flip_icons.rs
it_print_windo

it_printpreviw.rs

DeskSetDefaults
Eel
FlounderMail
NoName

Salmon
Seafood/
Swordfish

Tuna.

image.rs
mailfile

Figure 4-27 Mail File Menu Showing Mail Files and Subdirectories of Mail Files

As you access a mail file, it is added to the Move, Copy, and Load menus of the
Header window. Each of these three menus contains an identical list of recently
accessed mail files. The first item on each menu is the entry in the Mail File text
field. If no entry is in the text field, the first item is called Entry, and is

dimmed. Figure 4-28 shows a Copy menu after several mail files have been
accessed, and when there is an entry in the Mail File text field.

Mail Tool - /var/mail/bren

1
status.reports

16:48 | finance

10:09 deskset/mail.tool
130
155
107 todo

ow ,docs

{Compose v) Mail File: [E) status.reports, 7

isc and oWV
shells and
1d Inform
eliverabl

10/45121 requestes

Figure 4-28 Copy Menu with the Most Recently Accessed Mail Files
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If you have a set of mail files that you want to always appear on the Move,
Copy, and Load menus, you can specify these files in the Mail Filing category
of the Properties window. You can also control the maximum height of these
menus. See “Mail Filing Properties” on page 208 for information.

Creating a New Mail File

You can create a new mail file using only the controls on the Header window,
or using the Mail Files popup window:.

Creating a New Mail File Using the Header Window Controls
Follow these steps to create a mail file using only the Header window controls:
1. Select one or more messages to move or copy to the new mail file.

2. Type the name of the new mail file in the Mail File text field on the
Header window, and then click SELECT on the Move or Copy button.
When you just type a file name, such as projectreports, Mail Tool puts
the mail file in the Mail File directory that you specify from the Mail Filing
Properties window. Alternatively, you can type a complete path name, such
as /home/username/projects/projectreports, to put the mail file
somewhere else in your file structure, or you can type a relative path name,
such as projects/projectreports, to put the mail file in a subdirectory
of your Mail File directory.

The new mail file becomes the first and default item of the Move, Copy, and
Load menus.

3. Click SELECT on the Move or Copy button.
The new mail file is created, the selected messages are moved to the new
file, and a message is displayed in the footer of the Header window.

Creating a New Mail File Using the Mail Files Popup Window

Follow these steps to create a new mail file using the Mail Files popup
window:

1. Choose Mail Files from the File menu to display the Mail Files popup
window.
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2. Type the name of the new mail file in the Name text field.
For example, type projectreports to create a project report mail file, as
shown in Figure 4-29.

O Mail Tool : Mail Files K

Name: projectreports,
(Save v) (load v) ((Create v) (Edit )

/hightide/egret

{4 ..Go up one folder.. ]
CArtfiles

QFish

() Folder

() TestApps

Qfilename

mail

QQroot

e

—

y /

Figure 4-29 New Mail File Typed in the Mail Files Name Field

You can also type the name of a new mail file subdirectory if you'd like to
create a subdirectory of mail files.

If you already have a subdirectory where you want to put the new mail file,
you can type a relative path name in the Name field, starting with the
subdirectory. For example, type projects/projectreports to create a
mail file in the subdirectory called projects. Alternatively, you can
double-click SELECT on the projects subdirectory in the scrolling list to
display that mail directory, and then type the name of the new mail file in
the Name field.

3. Choose Mail File or Directory from the Create menu to create the new
mail file or subdirectory.

190 Solaris 2.2 User’s Guide—May 1993



HN
1]

Adding Messages to an Existing Mail File

You can add messages to an existing mail file using only the controls on the
Header window, or using the Mail Files pop-up window. Both of these
methods are described in the following sections.

Adding Messages to a Mail File Using the Header Window Controls

Follow these steps to add messages to a mail file using only the controls on the
Header window:

1. Select the mail headers that you want to move or copy to the mail file.

2. Move or copy the selected messages to an existing or new mail file as
follows:

a. If the desired mail file already exists and is listed in the Move and
Copy menus, simply choose the mail file from the Move or Copy menu.

b. If the desired mail file already exists but is not listed on the Move and
Copy menus, choose the desired mail file from the Mail File menu, and
then click SELECT on the Move or Copy button.

The new mail file becomes the first and default item of the Move, Copy,
and Load menus.

Adding Messages to a Mail File Using the Mail Files Popup
Window

Follow these steps to add messages to a mail file using the Mail Files window:
1. Select the headers of the mail messages that you want to move or copy.
2. Choose Mail Files from the File menu to display the Mail Files window.

3. Select a mail file in the Mail Files window scrolling list.
If the desired mail file is in a subdirectory, double-click SELECT on the
subdirectory to display its contents in the scrolling list.

4. Choose Move Message into Mail File or Copy Message into Mail File
from the Save menu.
The selected messages are moved or copied to the selected mail file.
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Viewing a Mail File

192

You can view the messages stored in a mail file using either the Mail Files
window or the Load menu of the Mail Tool Header window. Once the mail file
is loaded, you access the messages of the mail file exactly the same way as you
access the messages of your In-Box.

To return to the In-Box after you are done viewing a mail file, choose
Load In-Box from the File menu.

Viewing a Mail File Using the Header Window Controls

Follow these steps to view the messages in a mail file using the Header
window controls:

1. If the desired mail file is not already on the Load menu, choose the
desired mail file from the Mail File menu.
Alternatively, you can type the name of the mail file in the Mail File text
field.

2. Choose the mail file from the Load menu on the Mail Tool Header
window.
If the desired mail file is listed in the Mail File text field, you can just click
SELECT on the Load button.

Viewing a Mail File Using the Mail Files Window

Follow these steps to view mail file messages using the Mail Files window:

1. Choose Mail Files from the File menu to display the Mail Files popup
window.

2. Select the mail file that you want to view on the Mail Files popup window
scrolling list.
If the desired mail file is in a subdirectory, double-click SELECT on the
subdirectory to display its contents in the scrolling list.

3. Choose Mail File from the Load menu.
The malil file is loaded into the Mail Tool Header window.

Alternatively, you can just double-click SELECT on the mail file in the Mail
Files scrolling list to load that mail file.
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Editing a Mail File (Emptying, Renaming, Deleting)

You can empty a mail file, rename it, or delete it with the Edit menu of the Mail
Files window.

To empty, rename, or delete a mail file, you first need to select the mail file in
the scrolling list on the Mail Files window. If the mail file is in a subdirectory
below the one displayed on the scrolling list, double-click SELECT on that
subdirectory to display it. If the mail file is in a directory higher up from the
one displayed in the scrolling list, double-click SELECT on the

.. (Goup one folder) folder item until the mail file is in the scrolling list.
When the mail file is in the scrolling list, click SELECT on the mail file to select
it.

To delete a mail file, select the mail file in the Mail Files scrolling list, then
choose Delete from the Edit menu. Mail Tool will give you a notice asking you
to confirm that you really want to delete the mail file.

To empty a mail file, select the mail file in the Mail Files scrolling list, then
choose Empty from the Edit menu. Mail Tool will give you a notice asking you
to confirm that you really want to empty the mail file.

To rename a mail file, select the mail file in the Mail Files scrolling list, type the
new name in the Name field, and then choose Rename from the Edit menu.

Sorting the Contents of a Mail File

You can sort items in your In-Box or the currently viewed mail file by choosing
an item from the Sort By submenu of the Header window View menu:

® Sort by time and date of receipt, placing the most recently received messages
at the bottom.

¢ Sort alphabetically by name of sender. This is useful for grouping together all
the messages from a particular person.

¢ Sort alphabetically by subject of mail, to group together all the messages
about a particular subject.

® Sort by the size of mail messages, from smallest to largest.
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® Sort by the “read” status of the mail. This puts the messages you have read
first, the unread messages next, and the new messages last. This is useful to
group together all your unread mail after you have read your messages in a
non sequential order.

® Sort by the message numbers.

Loading Saved Messages Back into Mail Tool

194

You can load saved messages back into the Mail Tool base window and view
them as you would new mail messages. When you load previously saved
messages, they temporarily replace the current messages contained in your in-
box. ‘

Loading a Message from the Mail Files Directory
If the message you want to view is in the default Folder directory:

1. Press MENU on the abbreviated menu button to the left of the Mail File
text field.
A menu pops up listing the messages in the Folder directory.

2. Drag the pointer to the message you want to load, highlight it, and release
MENU.

3. Choose Load.
All messages saved to that file appear in the Mail Tool base window as
separate messages, just as they did when first received in the In-Box.’

Loading a Message from Another Directory
To load a message saved to another directory:

1. In the Mail Tool base window, type the path to the message file in the text
field.
Use the same path that you used to store it initially.

2. Choose Load.
All messages saved to that file name appear in the Mail Tool base window
as separate messages, just as they did when first received in the In-Box.
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Alternatively, you can drag a file of saved mail from File Manager and drop it
onto the Mail Tool base window. The message or messages in that file will
appear in the base window just as they did when you first received them. This
method is especially helpful if you have forgotten the path to the file.

Loading the In-Box
To reload your In-Box messages:

4 In the Header window, choose Load In-Box from the File menu.
All of the message headers in the In-Box are again displayed in the Mail
Tool Header window.

Using Drag and Drop with Mail Tool

You can use the OpenWindows drag and drop capability to drag mail
messages out to other applications, and to drop information from other
applications onto your Compose window to be included as text or as a
separate attachment. This section gives an overview of the ways you can use
drag and drop with Mail Tool and the other DeskSet applications described in
this guide.

Dragging Mail to Other Applications

You can select single or multiple headers in the Mail Tool window and drag
them to other DeskSet applications. When you drag a mail header, the entire
mail message is moved along with it, including any mail attachments.

You can also select single or multiple mail attachments and move just the
attachments to other applications.
Dragging Message Headers to Other Applications

You can drag and drop message headers onto the File Manager, Text Editor,
Print Tool, Calendar Manager, or any other application that accepts files via
drag and drop.
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To drag and drop a copy of a mail message, select the message header, then
drag the pointer to the destination. A small Text file glyph moves with the
pointer to show that you are dragging a Text file, as shown in the example in
Figure 4-30. When you select multiple message headers, a group of Text glyphs
is dragged with the pointer.

I

f@ ] Mail Teol - /var/mail/egret !
(File v)(Wiew #) (Edit v)(Compose v) Mail File: [g)
(Done J(Next }{Delete)(Reply v} (‘Move v)(Copy v)(Load v}

[T _thief@cici Thu Feb 18 10:42 187506 Your Move
+ 2 patten@newbirth Thu Feb 18 10:49 46/1282 Project Status ]
1] 3 bgahl@scuba Thu Feb 18 10:50 32/1110 Inbox status o
U 4 ayers@outhouse Thu Feb 18 10:51  17/532  SunU Training RegistratinJ
5 ayers@outhouse Thu Feb 18 10:51  17/511  vi command summary
+ 7 mariac@celtic Thu Feb 18 11:00 90/2531 Project Schedule
8 hamilton@artemis  Thu Feb 18 11:13  22/611  meeting reminder
9 abelson@sharonoclds Thu Feb 18 11:34  32/1232 Your position paper
N 10 aquablu@cowman Thu Feb 18 13:58 21/847  Summer Collaboration
c

Figure 4-30 Dragging a Copy of a Message Header

You can schedule appointments in Calendar Manager by using the
Appointment Editor Attachment. See the Chapter 5, “Calendar Manager” for
more information.

Dragging Attachments to Other Applications

You can drag individual attachments onto the following destinations:

® File Manager

® Print Tool (See “Printing Mail Messages Using Print Tool” on page 165.)

® Any application that accepts drag and drop data of the attachment’s file
type. For example, you can drag audio attachments onto AudioTool, Icon
Editor attachments onto Icon Editor, ASCII attachments onto Text Editor,
and so forth. ‘

® A Calendar Manager appointment attachment to Calendar Manager.

To drag and drop attachments onto other applications, follow these steps:
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1. Click SELECT on the attachment to be copied.
Click ADJUST on any additional attachments that you want to drag at the
same time.

2. Press SELECT on one of the highlighted attachments, drag the pointer to
the destination, and release SELECT.

Dropping Files onto the Mail Tool

The Mail Tool Compose and View windows accept dropped files from the File
Manager and Text Editor in the text panes. The Compose and View windows
accept dropped files of any type in the Attachments pane. See the section
“Sending Mail Attachments” on page 178 for more information.

The Header window pane accepts dropped mail files. When you drop a mail
file onto the Header pane, it is loaded into the Mail Tool and becomes the
current mail file.

Customizing Mail Tool

You can customize the properties of Mail Tool from the Mail Tool Properties
window. Display this window by choosing Properties from the Edit menu.

The Properties window has seven categories: Header Window, Message
Window, Compose Window, Mail Filing, Template, Alias and Expert
properties.

To display a particular category of properties, choose the category from the
Category menu located at the top of the Properties window. When you release
MENU, the contents of the Properties window shows the properties you can
set for that category. The new properties take effect immediately in most cases.
In a few cases (such as number of Headers to display in the Header Window
Properties), you must quit and restart Mail Tool before the changes take effect.

You must apply changed properties for each category by clicking SELECT on
the Apply button.
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Header Window Properties

The Header Window properties are shown in Figure 4-31 and described in the
following sections. After you change any of the Header Window properties,
click SELECT on the Apply button to apply them to the Mail Tool application.

Q Mail Tool : Properties

Category: Header Window

Retrieve Every: 300, @3 Seconds
Signal with: 1 [a]+] Beep(s
0 [a]#} Flash(es)
Display: 20  [a[#] Headers
80 [a[¢) Characters wide

Delivery: [ Automatically display headers

[ Show "To: recipient” when mail is from me

Custom Buttons: IDone I Next | Delet;rReply l

Command: & Done

Label: Done

@& =)

Figure 4-31 Header Window Properties

Mail Arrival Properties

Use the Retrieve Every field to determine how often new mail is retrieved. The
default value is 300 seconds, or 5 minutes. You can retrieve mail at any time
between this interval by choosing Load In-Box or Save Changes from the File
Menu.

Use the Signal With fields to determine how Mail Tool signals new incoming
mail. The Beep setting causes Mail Tool to beep the specified number of times.
The Flash setting causes the icon to flash or the Header window to flash,
depending on whether the Mail Tool is closed to an icon or open.’
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Mail Tool Window Size

Use the Display Headers field to determine how many headers are displayed
in your primary Mail Tool Header window. You can increase the setting to
display more headers at one time, or decrease the setting to display fewer
headers to make the Header window smaller.

Use the Display Characters field to determine the width of all Mail Tool panels
and windows.

After you make changes to the Display fields, you need to quit the Mail Tool
application and restart it in order to see the change.

Delivery Properties

If you want Mail Tool to automatically display the headers for incoming mail
messages, check the Automatically Display Headers option. If you do not
choose this option, Mail Tool does not display headers for incoming messages
unless you specifically request them by choosing Load In-Box or Save Changes
from the File menu.

If the Show “To: recipient” ... option is checked, the Mail Tool header of a
message sent by you will display the recipient of the message instead of your
mail address.

Mail Tool Custom Buttons

The first four buttons on the second row of the Mail Tool Header window are
custom buttons. You can change the value of these buttons to be any of the
items from the File, View, Edit, or Compose menus. If there are items on these
menus that you use very frequently, you can change your custom buttons to
activate those commands.

¢ The Custom Buttons choices indicate the current value of the four custom
buttons. You select one of these choices to change the value of that custom
button. '

¢ The Command setting shows you the command of the currently selected
button, that is, what the button does.

¢ The Command menu button provides a menu of all of the available
commands from the File, View, Edit, and Compose menus.
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® The Label text field determines what the custom button says. Usually this is
the same as the command, but it doesn’t have to be. Sometimes the
command is too long to fit in the button, so the Label might be an
abbreviation of the actual command.

To change the value of a custom button, follow the steps below.

1. Select the Custom Buttons choice that you want to change.
The first choice represents the first button on the second row of the Header
window, the second choice represents the second button, and so on.

2. Choose the desired command from the Command menu shown in
Figure 4-32.
The first column in the Command menu displays all the choices available
from the Mail Tool File menu, the second column displays the choices from
the View menu, the third displays the choices from the Edit menu, and the
last column displays the choices from the Compose menu.

] Mail Tool : Properties
Category: Header window

_‘//‘_/_/_/—’_\L\
[ Done [Next] Delete | reply |

Custom Buttons:

Command: (3] pext

Label: Load Messages (menu) Cut New

Print Abbreviated Header Copy Reply (menu)

Save ™ Full Header Delete Reply To Sender

Done Previous Undelete (menw Reply To All

Mail Files Mext Undelete Last Message Reply To Sender, Include
Sort By (menu) Undelete From List Reply To All, include
Sort By Time & Date Properties Forward
Sort By Sender Vacation (menu)

Sort By Subject

Sort By Size

Sort By Status

Sort By Message Number
Find

Figure 4-32 Header Window Properties Command menu

200 Solaris 2.2 User’s Guide—May 1993



4

3. If you want to select a new label to go with the selected command, type a
new label.
Try to keep the label as small as possible in order to keep the custom button
to a reasonable size.

4. Click SELECT on Apply to change the custom button in the primary Mail
Tool Header window.
The custom button on the Mail Tool Header window is changed to the new
label and command. Figure 4-33 shows the Header window with the second
custom button changed to Print.

Mail Tool /
(File v)(View v)(Edit v)((Compose v)
(Done J(Print )(Delete ) (Reply v)

16 mullet@schema Mon Feb 4 08/

Figure 4-33 A New Custom Button (Print) on the Header Window

Message Window Properties

You use the Message Window Properties to specify the number of lines in the
View Message pop-up window text pane, a different print script for printing
messages, and the headers that are not displayed when viewing a message
with abbreviated headers.

To see the Message Window Properties, shown in Figure 4-34, choose Message
Window from the Category menu at the top of the Properties popup window.
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® Mail Tool : Properties

Category: [¥] Message Window

Display: 30 [a[¥] Lines of Text

Print Script: [p -5

Hide: =
message—id d
status -
received
return—path -Delete
X~lines
content—-type
content—length

i
Header Field:

Figure 4-34 Message Window Properties

¢ The Display field determines the number of Lines of Text displayed in each

View Message or Compose window text pane. After you make a change and
click SELECT on the Apply button, you will need to quit the Mail Tool and
start it again for this change to take effect.

The Print Script field determines the script used to print your messages via
the Print item on the File menu or the header pane pop-up menu. The
default print script is 1Ip -s.

The Hide scrolling list determines which headers are not displayed when
you view your messages with abbreviated headers. You can add any header
to this list by typing the header in the Header Field text field, and clicking
SELECT on the Add button.

Use the Add menu to place the header either before or after the currently
selected header. Use the Delete button to delete the currently selected
header, and use the Change button to change the currently selected header
to the text typed in the Header Field text field. '
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Some of the headers that you might commonly want to hide are displayed
in the scrolling list in Figure 4-34. You can add any header to the Hide list
that you see when viewing messages. You can type the header in any case.
For example, adding the header “content-length” hides the headers

“Content-Length”, “content-length”, “CONTENT-LENGTH”, and so forth.

When you have changed Message Window properties, click SELECT on the
Apply button. The Print Script and Hide property settings become effective
immediately.

Compose Window Properties

You use the Compose Window Properties category to customize items on the
Compose window. To see the Compose Window Properties, shown in

Figure 4-35, choose Compose Window from the Category menu at the top of
the Properties popup window.

© Mail Tool : Properties

Category: Compose Window

Included Text Marker: >

Logged Messages File: ~/record

W Log all messages
pDefaults: W Request confirmations

W Show attachment list

Custom Fields: .;n
ﬂ
v
|

[ ]

Header Field:

Default value:

Figure 4-35 Compose Window Properties
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Included Text Marker

Use the Included Text Marker field to specify the characters that precede each
line of an included text message. The default value is “> “. This puts the
right-arrow character at the start of the included message when you choose
Indented from the compose window Include menu. Tabs are not accepted as an
indent character (but spaces are). Figure 4-36 shows the Compose window with
an included message indented with “>".

Note - The right angle bracket is at the start of the included message when you
select Reply to Sender, Include or Reply to All, or Include from the compose
menu in the Header window.

" =) Mail Tool : Compose Message 0

((include v) (‘Deliver v) (Header v) (Clear) ((Attach w)
To: abelson@sharenolds

Subject: Re: Your position paper
Cc:

> From abelson@sharonclds Thu Feb 18 11:34 PST 1993
> Date: Thu, 18 Feb 93 11:33:09 PST

> From: abelson@sharonolds (Kathy aAbelson)

> To: egret@river

> Subject: Your position paper

> Content-Type: text

> Content-Length: 703

>

> Dear Maria,

>

=0

> I vholeheartedly approve your position paper that has been so hotly cont
> gstedlately by other members of the organization. #As we discussed in ou | &

attachments

| 0GD

Figure 4-36 An Indented Included Message

Logged Messages File for Outgoing Mail

If you want to log outgoing mail messages in a file, type the name of the
desired log file in the Logged Messages File text field of the Compose Window
Properties Category. If a log file name is specified, a Log check box appears on
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the Compose window, as shown in Figure 4-36 above. When the Log option is
checked on your Compose window, the message is logged in the log file when
it is sent.

Use the Log all messages setting on the Compose Window Properties Category
to determine whether the Log checkbox on the Compose window is checked by
default.

Viewing the File of Logged Messages
To view the messages you have logged, do the following:

1. In the Mail Tool base window, type the name of the file in which you have
logged your messages in the text field.
Using the example above, for instance, you would type ~/.record.

2. Click SELECT on the Load button.
The messages you have logged will appear in your Mail Tool Base window
(in place of the current mail messages), and each has the message header.

Request Confirmations

If the Request Confirmations setting is checked, a Notice is displayed in the
following cases:

® When you have text or attachments in the Compose window, and you select
Clear on the Compose window control panel, a message is displayed asking
if you really want to clear the Compose window.

® When you have text or attachments in the Compose window, and you quit
the Compose window, a confirmation message is displayed asking if you
really want to quit.

¢ When you have made changes to a message in the View window, and you
then display a new message, unpin the View window, or receive new
incoming mail, a message is displayed asking if you want to save the
changes.
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Caution - If the Request Confirmations setting is not checked, any editing
changes in the View window are automatically incorporated without
notification. If you remove or change the From header of a message. The
message that lost the From header will appear to be lost. You can find it
appended to the previous message.

Show Attachment List

By default, a Compose window includes a pane at the bottom of the text area
where you can add attachments to your message. If you never or rarely use
attachments, you can turn off the Attachments pane for new Compose
windows. Use the Show Attachment List setting of the Compose Window
Properties Category to determine if the Attachments pane is shown by default.

If you turn off the default Show Attachments List setting, you can display the
Attachments pane on an as-needed basis by choosing Show Attachments from
the Include menu of the Compose window.

Compose Window Custom Header Fields

The header of your Compose window always has To, Subject, and Cc fields. In
addition, Bcc is available via the Header menu. You can add custom headers to
the Header menu by adding them to the Custom Fields scrolling list on the
Compose Window Properties category.

Some useful headers that you might want to use are the following:

¢ Precedence: junk — If the mail system cannot send a message with this
header, the message will not be “bounced” back to you. This is handy if you
are sending out a message to a large alias, and you do not wish to receive
notices whenever the message cannot be delivered to an individual.

® Reply-To: email address — When you reply to a message with this header, the
reply is sent to the email address in the Reply-To: header field (instead of
being sent to the sender of the message). \

® Return-Receipt-To: email address — When you send a message with this
header, you will receive a “Return Receipt” from the mail system when the
message is successfully delivered.

To create a custom header field, follow these steps:
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1. Type the label for the field in the Header Field line of the Properties
window.

Do not type a colon following the label. The colon is automatically provided
by Mail Tool.

2. If you want the field to be filled in with a default value, type this value in
the Default Value field.

3. Choose either Before or After from the Add menu to add the new header
field to the scrolling list.

4. To apply the change to Mail Tool, click SELECT on the Compose Windcw
Properties Apply button.

5. To include the new header field in a mail message, choose the item from
the Compose window Header menu, as shown in the menu at the left.
Figure 4-37 shows an example of a custom header field added to the
Compose window.

r' Mail Tool : Compose Message (
(Include v) (Deliver v) (Header v) (Clear) (Voice..) R Log /
To:
Subject: /
Ce: f‘
Reply-To: bren @jungle /
N

Figure 4-37 Example of a Custom Field Added to the Compose Window

To delete a custom field, click SELECT on the item in the Custom Fields
scrolling list, click SELECT on the Delete button, and click SELECT on Apply.

To change a custom field, click SELECT on the item in the Custom Fields

scrolling list, type the new values in the Header Field and Default Value text

fields, click SELECT on the Change button, then click SELECT on Apply.
Automatically Storing Copies of Messages You Send

You can set up Mail Tool so that you record a copy of each email message you
send. To do this, follow these steps:
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1. From the Mail Tool base window, choose Edit » Properties.
A Properties window appears.

2. In the Properties window, position the pointer on the abbreviated menu
button labeled Category, and choose the Compose Window category.
The properties choices for the Compose Window appear in the Properties
window.

3. In the text field labeled Logged Messages File, type the name of a file in
which you would like to log copies of your mail messages.
For instance, to save the mail in an invisible file in your home directory, you
could name the file $HOME/ .mail.save.

Note — SHOME is a variable that points to your home directory. You can also use
the tilde (~) symbol to indicate your home directory.

4. Click SELECT on the Apply button at the bottom of the Properties
window.
Now, when you send a message, a copy is logged in the file you created;
additional messages you send are appended to the end of the file.

Mail Filing Properties

You use the Mail Filing Properties category to choose where your mail files are
stored, and to customize the Move, Copy, and Load m