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PREFACE 

Welcome to Ensemble 2.0! GeoworksEnsemb1e2.o 

includes both a state-of-the-art system software called GEOS® and 

a family of applications that take full use of its power. In 

Ensemble, you will find writing, drawing, scheduling, database, 

and calculating tools that are both powerful and easy to use. 



ABOUT THIS BOOK 

Ensemble is easy to use because all of its tools are based on 
GEOS. With GEOS, all of your options are represented pictorially 
on the screen. You spend less time trying to remember how to do 
things and more time actually doing them. Simply use your 
mouse to move a pointer around on the screen until it points at a 
picture of what you want, then click the mouse button. 

Whether it's a business letter you're writing or some artwork 
you're creating, GEOS is always WYSIWYG (What You See Is 
What You Get). WYSIWYG means that your printed pages look 
just like they do on the screen, freeing you from printer 
guesswork, and saving you time. 

Included with Ensemble are eight accessory applications that are 
designed to you help you in your everyday work. In this book 
you'll find information about the basics of GEOS, and these eight 
applications. Ensemble also includes four applications that you 
can use to create stunning documents. You can read about these 
four applications in Using Geo Write, GeoDraw, GeoCalc, & 
Geo File. 

The first two chapters of this book cover topics that apply to all 
of the applications in this book. If you have never used a GEOS 
application before, you should look in these chapters for 
information that will serve you well in any GEOS application. 

The rest of the book is dedicated to the following eight 
applications: 

• GeoManager. An easy-to-use file and folder manager. 

• GeoPlanner. A yearly calendar and appointment book. 

• GeoDex. A combination address card and automatic dialer. 

•Calculator. An on-screen calculator. 

• Scrapbook. An electronic scrapbook for storing pictures and 
text. 

•Text File Editor. An application for editing DOS text files. 

• GeoComm. A telecommunications application. 

• GeoBanner. A banner-making application. 

• Solitaire. An on-screen version of the Klondike solitaire card 
game. 



Typographical Conventions Used in This Book 

The following printing conventions are used throughout this 
book: 

• Italic type is used to introduce a new term. Italic type is also 
used for book titles and for software titles other than GEOS 
applications. 

• ALL CAPITALS type indicates file names. 

• Boldface is used for the names of keys on the keyboard, such 
as Enter or Insert. 

• When you see two key names with a + symbol between them, 
press both keys at the same time. For example, when you see 
Ctrl+ Esc, you should hold down the Ctrl key while you press 
the Esc key. 

Conventions for Procedures 

Procedures are step-by-step instructions that tell you how to 
perform tasks in Ensemble. Procedures in this book always have 
a boldface heading beginning with the word "to. " Each step in a 
procedure first has you perform an action, which is followed by 
an explanation of Ensemble's response. When you can do a task 
in more than one way, you will see the word "or" on its own 
line, and then an alternate method of completing the step. 

Some procedures consist of one step, while others have multiple 
steps. 

SINGLE-STEP PROCEDURES 

Single-step procedures have a square, black bullet C• ) beside the 
instruction telling you what to do. The following example shows 
a single-step procedure with two alternative ways to do the task. 

To start GeoPlanner (All Levels) 

• Locate the GeoPlanner icon and double-click it. 

or 

Choose GeoPlanner from the Express menu in any GEOS 
application. 

MULTI-STEP PROCEDURES 

Multi-step procedures have sequentially numbered steps that you 
should follow in a specific order. The following example shows 
three steps from a multi-step procedure. 



ALL LEVELS 

To select a day and view its events (All Levels) 

1. If the Calendar window isn't showing, choose Calendar from the 
View menu. The Calendar window appears. 

2. Click to select a day in the Calendar window. The day highlights . 

3. The events for the selected day appear in the Events window. If 
the Events window isn't showing, choose Events from the View 
menu. The Events window appears. 

User Level Notation 

Every procedure in this manual is followed by a parenthetical 
note specifying at which user levels the task can normally be 
accomplished. The following are two examples of procedures 
found in this book: 

To start GeoPlanner (All Levels) 

To show empty days (Level 3) 

In addition, sections are marked with text similar to the one 
shown in the margin at left. This text, because it says "All Levels ," 
indicates that the section applies to all levels in the application. If 
it had said "Level 2, " it would indicate that the section only 
applied to Level 2 of the application. 

"All levels" does not necessarily mean that every procedure in 
that section can be used at all levels. Individual procedures 
within a section may apply to fewer levels than the section itself. 
For instance, a section labeled "All levels" may contain 
procedures that apply only to Level 1, along with other 
procedures that apply to all levels. 

Chapters 1 and 2 - which explain procedures common to many 
applications - assume you are using a three-level application, 
such as GeoDex or GeoPlanner. Not all applications have three 
levels, though. In the cases where an application has fewer than 
three user levels, some features labeled "level 3" in the common 
chapters may actually apply to level 2 in the application itself. 

For more information about user levels in applications, see "User 
Levels" in Chapter 1. 



CHAPTER I 

Application Basics This chapter provides an overview of 

the concepts and skills you need to begin using the GEOS 

accessories described in this manual. It describes those features 

that appear in two or more of the applications. Where a specific 

application has unique features, refer to the chapter that covers 

the application in detail. 



This chapter covers the following topics: 

• Starting and exiting the Ensemble accessories. 

• Working with windows. 

• Working with menus. 

• Working with dialog boxes. 

• Entering and editing text. 

• Selecting a user level. 

• Setting and Saving options. 

• Working with multiple applications. 

For information about working with documents, see Chapter 2. 

WHAT ARE THE ENSEMBLE ACCESSORIES? 

The Ensemble accessories include the following: 

• GeoPlanner. A yearly calendar and appointment book 
application. 

• GeoDex. A combination address card and automatic dialer 
application. 

•Calculator. An on-screen calculator. 

•Scrapbook. An electronic scrapbook for storing pictures and 
text. 

• GeoBanner. A banner-making application. 

•Solitaire. An on-screen version of the Solitaire card game. 

•Text File Editor. An application for editing DOS text files . 

• GeoComm. A telecommunications application. 

Like all GEOS applications, the Ensemble accessories use pictures 
as well as words to represent actions and choices. This makes the 
Ensemble accessories much easier to use than traditional text
based applications. For example, it's much easier to start an 
application by clicking a picture of it than by typing a command 
or searching through lists. 

Another advantage of the GEOS accessories is the consistency 
and similarity of features and functions they share amongst 
themselves and other GEOS applications. This means that when 
you learn to use one GEOS accessory, you're actually learning to 
use many of the functions in other GEOS applications. For 
example, almost every Ensemble application uses similar 



procedures for editing, printing and saving documents. Once 
you 've learned these functions, you can apply the techniques in 
every Ensemble application you use. 

LEARNING MOUSE BASICS 

In any GEOS application you perform tasks by using either a 
mouse or a keyboard. Most tasks, such as selecting, moving, 
opening, and copying, are much easier when you use a mouse, 
like the one shown on the left. 

If you do not have a mouse, you can still accomplish most tasks 
in GEOS applications by using the keyboard. However, some 
tasks, such as drawing and page layout, are impractical using the 
keyboard. 

You can use a mouse with either two or three buttons on it. If 
you have a two-button mouse, these buttons are called left and 
right. If you have a three-button mouse, these buttons are called 
left, middle, and right. In Ensemble, you use only the left and 
right mouse buttons. 

Handling a Mouse 

Put the mouse down on the table top with its buttons facing up 
and its rolling ball underneath. If you are right-handed, place the 
mouse to the right of the keyboard. If you are left-handed, place 
the mouse to the left of the keyboard. The mouse cable should 
extend from the top of the mouse to the computer. Hold the 
mouse by the sides with your index finger resting lightly on the 
mouse buttons. 

Mouse Pointers 

As you move the mouse on your desk or table top, its 
corresponding arrow-shaped mouse pointer moves around the 
screen. For example, if you move the mouse to the right, the 
mouse pointer also moves to the right. If you move the mouse 
up, the mouse pointer moves up. 



As you move the mouse, the mouse pointer changes shape 
depending on what is underneath it. Common mouse pointers 
include the following: 

POINTER MEANING 

~ The arrow pointer is the standard mouse pointer. 
You use it to point to things and select them. 

LiJ The hourglass pointer indicates that Ensemble is 
busy. You must wait until the hourglass pointer 
disappears from the screen before you can take 
further action. 

I The I-beam pointer indicates that you can type or 
edit text. You also use it to select text and to 
choose where the text you type appears. 

~ The do-not pointer indicates that the pointer is not 
in an area of the screen where you can take any 
action. 

~ The help pointer appears in Ensemble online help. 
The pointer indicates that you can jump to the 
section of help text shown by the pointer. For 
more information about using online help, see 
"Using Online Help" in this chapter. 

Pointing 

Pointing means moving the mouse pointer over something, such 
as text, a choice in a list, a picture, or a button. You must point 
to something before you can do anything else with the mouse. In 
the illustration below, the arrow pointer is pointing to the icon, 
or small picture, that represents the Text File Editor application. 

Text File Editor 
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Clicking 

Pressing and releasing a button on the mouse is called clicking. 
You can click either the left or the right mouse button. In this 
manual, when you see the word click, click the left mouse 
button. When you see the word right-click, click the right mouse 
button. Almost all functions in GEOS applications are performed 
using the left mouse button. 

Double-clicking 

Quickly pressing and releasing the left mouse button twice is 
called double-clicking. Double-clicking opens and closes items 
and starts applications; it also selects a whole word when 
working with text. It's important to hold the mouse steady and 
click quickly when you are double-clicking. It may take a little 
practice to become comfortable with this technique. 

Dragging 

Dragging means pointing to something and then pressing and 
holding down the mouse button as you move the mouse. 
Dragging is used to move, resize, and scroll windows, to select a 
range of text, and to move cards in the Solitaire game. Dragging 
is also one way to browse through menus and make menu 
choices. 

In GEOS applications, you sometimes drag with the left mouse 
button and sometimes with the right mouse button. If dragging 
requires the right mouse button, you will be instructed to use it. 
If the instructions do not specify which mouse button to press, 
use the left mouse button. 

USING ONLINE HELP 

ALL L E VE LS One way to get quick answers to your Ensemble questions is to 
use the Ensemble online help . Help is often just a single click 
away - just click a help button, like the one pictured at the left. 
When you are in a dialog box, you will see a button like this 
one. When you click it, you see help text about that particular 
dialog box. 

At the top of application windows, you will see another type of 
help button. Click this button to see help about the application. 
When you click either type of button, the Help window appears: 



This is a brief explanation of the Help s~1ste m. To return to \vhere ~,1ou just v/ere, 
click the Go Back button. 

Th e Help window 

t'-lotice the scroll bar on the right ::;ide of the \vindo'•'· Yo u can click 
the do1,-m arro1.1'° at the bottom of the scroll bar to scroll throLigh the 
te xt in the 111indo11'°. 

You can move the Help 111indow around on the screen b ~1 placing the 
mouse pointer on the title ba.r (that's the horizontal bar at the top of 
the \vindm01 that ha::; the 111ord "Help" centered in ~), holding the 

mouse button dO\v'n and dragging the '1l indO\I'°. 

To make the Help windO\·I go a ·111a:,1, press the Esc key. 

Th e Table of Contents , and th e Contents button 

When the Help window is open, it remains the front-most 
window until you exit Help. Nevertheless, even with the Help 
window open, you can perform actions in other windows and 
dialog boxes by clicking in them. If the Help window is 
obscuring something you want to see, move the Help window 
out of the way by dragging its title bar. You can also uncover 
other screen items by reducing the size of the Help window. See 
"Making a Window Larger or Smaller" in this chapter for more 
about resizing windows. 

Often not all the help text for a topic fits in the Help window. To 
see more help text, scroll through the text using the scroll bars 
on in the Help window. For more information about scrolling 
through windows, see "Scrolling Through a Window" in this 
chapter. You can also increase the size of the Help window to 
see more help text. 

Help screens are organized by topic. Most of the topics are 
centered around common questions about Ensemble. Online 
Help is not an online manual. It is not designed to be read from 
beginning to end, like a novel. It is designed so that you can 
easily jump from topic to topic. This way you can quickly find 
answers to your questions. The buttons at the top of the Help 
window help you move easily between topics. 

To see Help 

• Click a Help button, like those pictured above. 



To get help on how to use the Help window 

• Click the Help button in the title bar of the Help window. 

To jump to another topic 

1. Move the pointer over any text that is underlined and blue (on 
color systems) . The pointer changes to the help pointer, pictured 
at the left. 

2. Click the underlined text. Information specific to that topic 
appears in the help screen. You can go back to the previous 
screen by clicking Go Back. 

To see the major topics for an application 

• Click the Contents button. The Table of Contents help screen 
appears. 

To jump to one of the topics listed in the Table of Contents 
screen, click the underlined text for that topic. 

To return to the previous help screen 

• Click the Go Back button. The previous help screen appears. 

To jump back to an earlier help screen 

1. Click the History button. A drop-down list with your last ten help 
screens appears. 

2. Click the topic you would like to see. The help screen for that 
topic appears. 

To move the Help window 

• Drag the title bar of the Help window. 

To exit Help 

• Click the Exit Help button. The Help window disappears. 

STARTING AND EXITING THE ENSEMBLE ACCESSORIES 

ALL LEVELS Before you can use a Ensemble accessory, you must start it. 
There are two ways to start an application: You can start an 
application by opening it directly, or you can start an application 
by opening a document that was created with the application. 
When you start an application, its window appears ready for use. 
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GeoDex 

ALL LEVELS 

When you are done using an application, you exit it. Exiting an 
application closes its window and frees up system resources. 

Starting an Application by Opening it Directly 

The most common way to start an application is to open it 
directly from its icon. When you start an application from its icon, 
you can use any of the following techniques: 

• Double-dick the icon of the application you want to start. 

• Click to select the icon of the application you want to start, 
then choose Open from the File menu. 

The icons for the GEOS applications are available in the WORLD 
folder in GeoManager. 

To start an application from its icon (All Levels) 

Locate the icon representing the application you want to start and 
double-dick it. The application opens and is ready for use. 

or 

Click to select the icon of the application you want to start, then 
choose Open from the File menu. 

Either way, the application opens and appears in a window. If 
the application has a default document (GeoDex, GeoPlanner, 
and Scrapbook), it opens with that document ready. 

Starting an Application by Opening a Document 

If you know the document you want to work with before you 
start the application, you can start that application by opening the 
document icon instead of the application icon. For example, you 
can start GeoDex by double-clicking the GeoDex document with 
which you want to work. 

To open the document of a DOS program, you need to first open 
the program. A DOS text file which has a .TXT extension as part 
of it its file name is an exception; opening one of these 
documents will open the Text File Editor. 



To start an application by opening one of its documents (A ll 
Levels) 

• Locate the icon representing the document you want to open and 
double-click it. The application starts and automatically opens the 
document. 

or 

0 
l etters Papers Presentations 

ail11 
My Schedule 

Double-click here to start GeoDex 
and open this document. 

Schedules Default Scrapbook 

Click to select the icon of the document you want to open, then 
choose Open from the File menu. 

With whichever method you use , the application opens with the 
selected document ready for use. 



Starting an Application from the Express Menu 

You can start an application from within the current application 
using the Express menu . The Express menu appears when you 
click the Express button at the top of any Ensemble application 
window. 

Click the Express button to see 
the Express menu. 

To start an application from the Express menu (All Levels) 

I ~ 1. Click the Express button. The Express menu appears. 

2. Click Start an Application. A submenu appears with a list of 
applications and a list of application folders. 

3. Click the name of application you would like to start. 

or 

Click one of the folder choices (these have a little arrow next to 
the name). A submenu appears. Choose the name of the 
application from in the submenu. 

The application opens and appears in a window. 

Application Windows 

When you start a GEOS application, it appears in a window, a 
boxed area of the screen in which you work. 



All GEOS applications open as windows that take up a portion of 
the screen. You can move them around the screen; place them 
on top of and behind other windows; and minimize them if 
desired. You can use more than one application at a time, and 
each application you open appears as its own separate, moveable 
window. 

1 Geo Planner window 

Text File Editor window 

Folder window 

ELEMENTS OF A WINDOW 

This section describes the basic topics which pertain to windows. 
For additional information on windows, see "Working With 
Windows" in this chapter. 



This illustration shows a typical GEOS application window: 

[ Window Control button 

I Express button 

I window 

Maximize-Restore button 

Hide button 

Title bar 

Window border 

Scroll bar 

The following elements are common to many GEOS windows: 

• Window Control button. Click to open the Window Control 
menu. Double-dick to close the window. 

•Ex press button. Click to open the Express menu. 

•Title bar. Use to move a window. 

•Menu bar. Click a name to open its menu. 

•Help button. Use to get online help. 

• Minimize button. Click to minimize the window (reduce the 
window to the size of an icon and put it at the bottom of the 
screen). For more information, see "Changing the Size of a 
Window" in this chapter. 

•Maximize-Restore button. Click to make a window full
screen, or to restore it to its normal size. See "Changing the Size 
of a Window" in this chapter. 



Exiting an Application 

You can exit an application at any time, but it's a good idea to 
first save any open documents before you do. If you exit without 
first saving, the application gives you a second chance to save 
your document. 

To exit an application using the File menu (All Levels) 

1. Click the word File on the menu bar. The File menu appears. 

2. Click Exit on the menu. The application closes. 

To exit an application using the Window Control menu (All 
Levels) 

• Double-dick the Window Control button in the upper left corner 
of the application window. The application closes. 

or 

1. Click the Window Control button. The Window Control menu 
appears. 

2. Click Close on the menu. The application closes. 

WORKING WITH MENUS 

ALL LE V ELS An application menu, like a restaurant menu, contains a list of 
choices. When you select a choice from a menu, the application 
initiates a corresponding action. For example, to print a 
document, you choose Print from the File menu. 

This is an example of a typical menu: 

Menu Choices 



Every GEOS application has its own set of menus. The names of 
each menu appear on the menu bar. For example, in GeoDex at 
Level 1, the menu names are as follows: 

• File 

• Edit 

• Options 

You do not see the menu itself until you click on the menu 
name. This is called opening a menu. 

Many GEOS applications share basic features such as opening, 
saving, copying, and printing documents . Applications often have 
similar menus because shared features work the same way in 
each application. Almost every GEOS application has a File, Edit, 
View, and Options menu. Once you know how to use choices 
from these menus in one application, you know how to use 
them in other GEOS applications. 



Choosing From Menus 

When you open a menu, it appears on your screen, and you 
select from it. Menu choices that are not currently available 
appear dimmed; if you select a dimmed menu choice, nothing 
happens. For example, in GeoDex, Copy Record is dimmed until 
you first view an existing record. 

These menu choices are 
currently available. 

If you select these choices, 
nothing happens because they 
are dimmed. 

There are two basic ways to select menu choices in GEOS 
applications: the clicking method and the dragging method. 
These two methods are covered here. For information on using 
the keyboard to select from a menu, see "Using Shortcut Keys" 
and "Using the Keyboard to Select any Menu Choice" in this 
chapter. 

To choose from a menu by clicking (All Levels) 

1. Click the name of a menu on the menu bar and its menu 
appears. 

2. If the choice you want is not on this menu, click the name of 
another menu. The first menu closes and the second appears. 
Continue clicking menu names until you see the choice you 
want. 

3. Click the choice you want. As long as you select an undimmed 
choice, a corresponding action is initiated and the menu closes. 

or 

Close the menu without making a choice by clicking anywhere 
outside the menu. 

To choose from a menu by dragging (All Levels) 

1. Position the pointer over the name of a menu on the menu bar. 

2. Press and hold down the left mouse button and the menu 
appears. Continue to hold down the mouse button as you drag 



the pointer left or right across the menu bar. The menu for each 
menu name appears. 

3. When the menu appears with the choice you want, pause, but do 
not release the mouse button. 

4. Drag the mouse pointer down the list of menu choices in the 
open menu. As you drag through the choices, each choice in 
turn is highlighted. 

5. When the choice you want is highlighted, release the mouse 
button. A corresponding task is initiated and the menu closes (as 
long as you selected an undimmed choice). 

or 

Close the menu without making a choice by dragging the mouse 
pointer outside the menu and releasing the mouse button. 

Using Menu Choices Followed by an Ellipsis 

Some menu choices are followed by an ellipsis (. .. ). If you select 
a menu choice followed by an ellipsis , a dialog box appears so 
you can provide information required for the operation. 

This menu choice has an ellipsis. 

Selecting Menu Choices With Check Boxes or Radio Buttons 

Some menu choices can be turned either on or off. When one of 
these choices is turned on, a small button next to the choice is 
darkened. When a choice is turned off, the button is not 
darkened. There are two types of buttons that can appear in a 
menu: check boxes and radio buttons. Radio buttons come in 



groups of two or more, and only one button in the group can be 
on at any given time. Check boxes can come in any number, and 
any number can be on at a given time. For more about check 
boxes and radio buttons see "Responding to a Dialog Box" in 
this Chapter. 

To select from a group of radio buttons (All Levels) 

• From a group of radio buttons, choose one which is not 
darkened. The menu choice is turned on and the button darkens; 
the previously selected menu item is turned off. 

Click here to tum this choice on ... 

... and tum this choice off. 

To turn on or off a check box choice (All Levels) 

• Select the menu choice. If the menu choice was off, then it is 
now on (darkened). If the menu choice was on, then it is now 
off. 

Ctrl L 
Ctrl E 

Click here to tum this choice on or off 



Using Submenus 

Some menu choices have a right arrow next to them. Selecting 
one of these choices reveals another menu with additional 
choices. This secondary menu is called a submenu. Some 
submenus themselves have submenus; these submenus can also 
have submenus, and so on. You make a choice from a submenu 
in much the same way you do from other menus. 

[ Menu Right arrows 

Submenu 

a.a: ...... 
~-ret Empty llt>eummt.... 

I Second document submenu 

To choose from a submenu by clicking (All Levels) 

1. Open a menu from the menu bar as you normally would. 

2 . Select a menu choice that has a right arrow. The submenu opens. 

3. Select the choice you want from the submenu. The submenu 
closes. 

or 

Close the submenu without making a choice by clicking 
anywhere outside the menu. 

To choose from a submenu by dragging (All Levels) 

While dragging to 1 . Drag to open a menu as you normally would. 
select, hold down the 

2. Drag the pointer down the open menu to a choice that has a 
mouse button until 

right arrow. When the pointer is in the vicinity of the right arrow, you are done with 
the entire procedure. the submenu opens. 



lf you find yourself 
using the same 
menu (or submenu) 
over and over, pin it 
to keep it out in the 
open. 

3. Drag the pointer off of the first menu and onto the submenu. 

4. Drag the pointer down the submenu to the choice you want and 
release the mouse button. Both menus close. 

or 

Close the menu without making a choice by dragging the pointer 
outside the menu and releasing the mouse button. 

Pinning Menus 

You can keep menus from closing after you make a choice. If 
you want to keep a menu open so that you can make a series of 
selections from it, you can pin the menu, the same way you 
would pin a piece of paper to a wall. A pinned menu stays open 
until you close it. You use a pinned menu the same way you 
would use a window. If a pinned menu is on top of something 
you want to see, you can move the pinned menu to another 
location by dragging its title bar. Pinned menus have a Window 
Control button and menu which you can use to close a pinned 
menu. 

D.etete Record 
()fJ~ ~~i;.(~~)n,t 

P(~§'Je ~e~Wfd 

Shift Del 
Ctrl Ins 
Shift Ins 

Click here to pin the edit menu. 

To open and close a pinned menu (All Levels) 

Only menus with push-pins at the top can be pinned open. 

1. Open a menu as you normally would. 

2 . Choose the push-pin at the top of the menu. The menu stays 
open. 



Click here to display a pinned menu's 
menu, or double-click to close the pin 

~][ Edit 
UJldo Alt Backspace 

Cut. Shift Del 

kOPY Ctrl Ins 
l!_aste Shift Ins 

D.elete Record 

Copy Record 
P(~~<tJe RtJ('..Ord 

Window Control 
ned w indow. 

Drag here to move a pinned menu. 

3. To close the pinned menu, double-dick the Window Control 
button. The menu closes. 

Using Shortcut Keys 

If you are familiar with using a keyboard, you may find that 
using shortcut keys speeds up your work. A shortcut key is a 
single keystroke you can use to select a menu choice. Using a 
shortcut key has the same effect as pulling down a menu and 
selecting a menu choice. 

Only the most commonly used menu choices have shortcut keys. 
If a menu choice has a shortcut key, it appears to the right of the 
choice. For example, in the following menu, Shift+ Delete is the 
shortcut key for opening the File menu and choosing Cut. 
Ctrl+Insert is the shortcut key for opening the File menu and 
choosing Copy. 

t-kJ thing ta ~~pdo l~l t f$(~:r;·k s~}a('..t.!' 

Cut Shift Del 
C,,opy Ctrl Ins ·---
l!_aste 
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H.ew Event 
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Shift Ins 

Del 

Ctrl tt 

Ctrl I 

To choose Cut, hold down the 
Shift key and press Delete. 
To choose Copy, hold down the 
Control key and press Insert. 

Most shortcut keys require you to hold down the Ctrl key while 
pressing one or more other keys. Some shortcut keys use the 
Shift key instead of the Ctrl key. 



You can use any 
combination of 

To select a menu choice by using a shortcut key (All Levels) 

1. Open the menu to see if the choice you want has a shortcut key. 
Close the menu. 

2. Press the shortcut key shown on the menu. This has the same 
effect as selecting a menu choice using the mouse. 

After a while you will learn the shortcut keys that you use most 
often, and you will not have to open a menu to see what they 
are. 

Using the Keyboard to Select Any Menu Choice 

At times, it may be easier and quicker for you to use the 
keyboard rather than the mouse to select menu choices. To 
navigate through menus using the keyboard, you can use the 
arrow keys and mnemonics. Mnemonics is a method of using a 
single letter or number to make a menu choice. With arrow keys 
and mnemonics you can use the keyboard to select any menu 
choice. 

To select from a menu using the arrow keys (All Levels) 

1. Press and release the Alt key. The name of the first menu on the 
menu bar is highlighted. 

arrow keys and 
mnemonics to select 2. If this menu is not the one you want, press the Left Arrow key 

or Right Arrow key to move across the menu bar, highlighting 
each name as you move across. 

menu choices using 
the keyboard. 

3. Press the Down Arrow, Spacebar, or Enter key to display the 
menu for the highlighted name. If the choice you want is not on 
the menu, use the Left Arrow and Right Arrow keys to move 
through the other menus. 

4. When the menu you want is displayed, use the Up Arrow and 
Down Arrow keys to highlight your menu choice. 

If your choice has a submenu (indicated by a right arrow next to 
the menu item), you can open it by pressing the Right Arrow. 
When the submenu is open, use the Up Arrow and Down 
Arrow keys to highlight the choice you want. If you want to 
close the submenu without making a choice, press the Left 
Arrow. 

5. When the choice you want is highlighted, press the Spacebar. 
This selects the choice and closes the menu. 

or 

Close the menu without making a choice by pressing Esc. 



To select from a menu using mnemonics (A ll Levels) 

The name of each menu and menu choice has an underlined 
letter. This is typically the first letter of the choice, unless several 
choices on a menu share the same first letter. The underlined 
letter is the one you use to select from a menu using mnemonics. 

1. Hold down the Alt key and press the underlined key in the 
menu name you want. For example, if you want to open the File 
menu, hold down Alt and press the F key. The File menu opens. 

2. Once the menu is open, press the mnemonic of the choice you 
want. For example, to choose Save As from the File menu, press 
the A key. 

le 
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or 

Close the menu without making a choice by pressing Esc. 

NOTE 

It is often convenient to memorize a mnemonic sequence for a 
common menu choice. For instance, you might want to memorize 
Alt+F,O ,D which quickly discards changes in the Text File Editor 
(that is, holding down Alt, then pressing F followed by 0 , then D will 
open the File menu, open the O ther submenu, and choose D iscard 
Changes). 



The Window Control Menu 

The Window Control menu is a special menu that gives you 
control over a window. From this menu you can perform tasks, 
such as closing or maximizing windows. The Window Control 
menu appears when you click the Window Control button in the 
upper-left corner of a window. 

Window Control button 

To use the Window Control menu (All Levels) 

1. Click the Window Control button. The Window Control menu 
appears. For example, the GeoDex Window Control menu is 
shown below. 

Click here to display the Window Control menu. 

GeoDex W indow Control menu 
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2. Click the choice you want from the Window Control menu. The 
corresponding action is initiated and the Window Control menu 
closes. 

or 

Close the menu without making a choice by clicking anywhere 
outside the Window Control menu. 

As with other menus in GEOS, if a choice is dimmed you cannot 
select it. 



To exit an application using the Window Control button (All 
Levels) 

• Double-dick the Window Control button. The application closes. 

WORKING WITH WINDOWS 

ALL LEVELS "Starting and Exiting Applications" at the beginning of this 
chapter explains the how to open and close GEOS windows by 
starting and exiting applications. This section provides 
information about working with windows, including how to 
scroll, resize, and move them. 

Changing the Size of a Window 

You can change the size of windows in different ways. You can 
maximize a window, restore it, minimize it, or make it larger or 
smaller by dragging its edges. You can use these features to do 
the following: 

• See a window or document more clearly. 

• Reduce clutter on your screen. 

• Move something out of the way temporarily. 

MAXIMIZING AND RESTORING A WINDOW 

To maximize a window means to make it full-screen. You use 
the Maximize-Restore button to maximize a window, or to restore 
it to its original size once it has been maximized. The Maximize
Restore button's appearance changes depending on whether or 
not the window is maximized. 

You can also use the Maximize and Restore choices on the 
Window Control menu to maximize and then restore a window. 

To maximize a window (All Levels) 

The Maximize-Restore button must look like the one shown on 
the left if you want to maximize a window. Windows without a 
Maximize-Restore button cannot be maximized. 

Click the Maximize-Restore button in the upper-right corner of a 
window. 

or 

Choose Maximize from the Window Control menu. 



The window enlarges to fill the screen. 

To restore a window after maximiz ing it (All Levels) 

You can restore a window only after you have maximized it. The 
Maximize-Restore button must look like the one shown on the 
left if you want to restore a window. 

• Click the Maximize-Restore button in the upper-right corner of a 
window. 

or 

Choose Restore from the Window Control menu . 

The window is restored to the size it was before it was 
maximized. 

To minimize a window 

• Click the Minimize button. 

or 

Choose Minimize from the Window Control menu . 

The window reduces to an icon, and is placed at the bottom of 
the screen. 
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To restore a minimiz ed window 

• Double-dick the window's icon. 



MAKING A WIND OW LARGER OR SMALLER 

The following procedure allows you to resize a window to the 
exact size you want. You can make a window larger or smaller 
by dragging its borders or its corners. Maximized windows 
cannot be resized. 

To make a window larger or smaller (All Levels) 

1. Point to a border or corner of the window you want to resize. If 
you 're pointing to a border, the pointer changes to the move 

-7 I border pointer, like the one shown on the left. If you're pointing 
to a corner, the pointer changes to the move corner pointer, like 

~ the one shown on the left, below the move border pointer. If the 
pointer does not change to either of these shapes, you cannot 
resize the window. 

2. Drag the border or the corner in the desired direction until the 
window becomes the size you want. If you drag a border, the 
window size changes only on the side of the border you drag. If 
you drag a comer, the two adjoining sides that form the comer 
move at the same time. 

I~ 

Original window position 

Use the move border pointer to change the size of the w indow. 

New location of window 

3. Release the mouse button. The window is resized. 



NOTE 

Each window has a minimum allowable size. If you try to make a 
window smaller than it can go, it will automatically resize itself to its 
minimum size. 

USING THE KEYBOARD TO CHANGE THE SIZE OF A WINDOW 

You can also use the keyboard to change the size of a window. 

To maximize a window using the keyboard (All Levels) 

• If the window is an application window, press Alt+FlO. (If the 
window is a document window, such as those in Text File Editor, 
press Ctrl+FlO.) 

The window enlarges to fill the screen. 

To minimize a window using the keyboard (All Levels) 

• If the window is an application window, press Alt+F9. (You 
cannot minimize document windows.) 

The window shrinks to an icon. 

To restore a window using the keyboard (All Levels) 

• If the window is an application window, press Alt+FS. (If the 
window is a document window, such as those in Text File Editor, 
press Ctrl+F5 .) 

The window restores to its original size. 

To make a window larger or smaller using the keyboard (All 
Levels) 

1. If the window is an application window, press Alt+FS. (If the 
window is a document window, such as those in Text File Editor, 
press Ctrl+FS.) 

The resize border of the window highlights. 

2. Select the border you want to resize by pressing an arrow key. 
For example, press Right Arrow to resize the right border or 
press Up Arrow to resize the top border. A move border pointer 
appears on the border you selected. 

3. Press any of the arrow keys to resize the selected border in the 
corresponding direction. Hold down the Ctrl key while pressing 
the arrow keys to resize in smaller increments. 

4. When the selected border is at the size you want, press Enter. 
The window is resized. 



Moving a Window 

You can move most GEOS windows. Typically, you move a 
window because it's obscuring all or part of another window you 
need to see. You cannot move a maximized (full-screen) 
window. 

To move a window (All Levels) 

1. Position the pointer over the title bar of the window you want to 
move. 

2. Press and hold down either the left mouse button. The pointer 
.....:t.._ changes to a multi-directional arrow, like the one shown on the 
......,.. left. A rectangular outline of the window appears. 

If the pointer does not change to a multi-directional pointer, you 
cannot move this window. 

3. Drag the window outline to another location on the screen. 

I Original window position 

New location of window 

Multi-directional arrow 
over title bar 

4. Release the mouse button. The window appears at the new 
location. 

To move a window using the keyboard (All Levels) 

You can also move a window using the keyboard. 

1. If the window is an application window, press Alt+F7. (If the 
window is a document window, such as those in Text File Editor, 
press Ctrl+F7.) 



The border of the window highlights and a multi-directional 
arrow pointer appears in the center of the window. 

2. Press any of the arrow keys to move the window border in the 
corresponding direction. Hold down the Ctrl key while pressing 
the arrow keys to move in smaller increments. 

3. When the window is at the position you want, press Enter. The 
window is moved. 

Scrolling Through a Window 

Sometimes a document has more information than can fit in its 
window. For example, a full year calendar in GeoPlanner cannot 
completely fit in one window. Scroll bars on both the right side 
and bottom of a window allow you to view more of its contents. 
Using these scroll bars is called scrolling. The vertical scroll bar at 
the right lets you scroll to portions of a document above and 
below the displayed contents. The horizontal scroll bar across the 
bottom lets you scroll to portions of a document to the right and 
left of the displayed contents. 
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Horizontal scroll bar 

A scroll bar includes scroll arrows, paging areas, and a slider. 
Using these elements, you can view the entire contents of a 
window in several different ways. 



Scroll arrow 

Sl ider 

Paging area 

Vertical and horizontal scroll bars work the same way. You are 
much more likely to work with vertical scroll bars than horizontal 
scroll bars. Therefore, the remainder of this section uses a vertical 
scroll bar as an example. 

There are several different ways to scroll through a window. You 
can scroll one line at a time or one window at a time. You can 
also scroll to any relative position in the document. 

The parts of a scroll bar let you view the entire contents of a 
document are as follows: 

• Scroll arrows. Click a scroll arrow to move the contents of a 
window up or down one line at a time. 

• Slider. Drag the slider up or down the scroll bar to see another 
part of the document. 

The length of the scroll bar represents the length of the entire 
document. The length of the slider represents the portion of the 
document that appears in the window. 

The slider also shows you where you are in the document. For 
example , if the slider is at the top of the scroll bar, you are 
looking at the beginning of the document. If you drag the 
slider to the middle of the scroll bar, you are looking at the 
middle of the document. If the slider fills the scroll bar, the 
entire document appears in the window. 

• Paging areas. Click in a paging area to move the document 
one window up or down at a time. The paging areas represent 
the portion of the document that is not visible. 

To scroll one line at a time (All Levels) 

• Click a scroll arrow in the direction you want the window to 
scroll. The contents of the window scroll one line at a time in the 
direction of the arrow. 

To scroll continuously (All Levels) 

1. Point to the scroll arrow for the direction you want the window 
to scroll. 

2. With the pointer over the scroll arrow, press and hold down the 
mouse button. The window scrolls in the direction of the arrow 
until you release the mouse button. 



To scroll one window at a time (All Levels) 

• Click in the paging area above or below the slider in the 
direction you want to scroll. The document scrolls one window 
at a time in the direction you chose. 

To scroll to a relative position (All Levels) 

• Drag the slider to the relative position on the scroll bar you want 
to view. For example, to move to the end of a document, drag 
the slider to the bottom of the scroll bar. 

To scroll a window using the keyboard (All Levels) 

You can also use the keyboard to scroll a window. 

• Press Page Up or Page Down to scroll the window up or down. 

Press Ctrl+Page Up or Ctrl+Page Down to scroll the window 
left or right. 

USING THE EXPRESS MENU 

The Express menu is a special menu that lets you quickly start an 
application, switch between running applications, check your 
printing, or exit directly to DOS. The Express menu works just 
like any other menu in Ensemble. But to see it, instead of 
clicking a menu name, you click the Express button. The Express 
button appears only in the active window (there's always one 
active window, so the Express menu is always available). Here 
are the items you have to choose from in the Express menu: 

• Running Applications Any applications that are currently 
running appear in the Express menu. Choose one to bring the 
application's window to the front. 

• Start an Application brings up a submenu from which you 
can start any Ensemble application in the WORLD folder or one 
of its subfolders. 

• Desk Accessories Any applications that you have put in the 
Desk Accessories folder appear here. For more about using the 
Desk Accessories folder, see "Working With Multiple 
Applications" in this chapter. 

• Printer Control Panel opens the Printer Control Panel dialog 
box where you can see what documents you have currently 



printing or waiting to print. You can also cancel the printing of 
any document. 

• Go to GeoManager Brings the GeoManager window to the 
front, making it the active window. 

• Exit to DOS shuts down Ensemble and returns you to the DOS 
prompt. 

To switch between running applications 

1. Click the Express button. The Express menu appears. 

2. Choose the application's name from the Express menu. The 
application's window immediately comes to the front , making it 
the active window. 

To start an application 

1. Choose Start an Application from the Express menu. A submenu 
appears with a list of folders and applications in the WORLD 
directory. 

2 . Choose the application from the submenu. 

or 

Choose one of the folder names. A submenu appears with a list 
of applications in that folder. Click one of the application names. 

The menu disappears and the application starts. 

To monitor your printing 

• Choose Printer Control Panel from the Express menu. The Printer 
Control Panel appears. Use it to monitor your printing and cancel 
documents that are waiting to print. See "Checking and Canceling 
Printing Documents" in Chapter 2 for more information about the 
Printer Control Panel. 

To return to GeoManager 

• Choose Go to GeoManager from the Express menu. The 
GeoManager window comes to the front, making it the active 
window. 

To exit directly to DOS 

• Choose Exit to DOS from the Express menu. Ensemble shuts 
down. 



WORKING WITH DIALOG BOXES 

ALL LEVELS When an application needs more information from you or needs 
to alert you to something, a dialog box appears. There are two 
major types of dialog boxes. 

The first type of dialog box functions like other windows. This 
type has a title bar, which you can use to move the dialog box, a 
Window Control button, and a Window Control menu. You can 
keep this type of dialog box open and switch between it and 
other windows. An example of this type of dialog box is the 
dialog box that appears after you choose Page Size from the File 
menu . 

W indow Control button Title bar 

The second type of dialog box requires a response from you 
before you can continue. These dialog boxes have a thick solid 
border, and the mouse pointer changes to a do-not pointer if you 
move it outside the dialog box. An example of this type of dialog 
box is the one that appears after you close a document that you 
have not saved. You cannot take any other action until you 
respond to this dialog box. 

Do-not pointer 

There are various ways for you to enter information and make 
choices in dialog boxes. Some of these include: 

• Radio buttons. Use radio buttons to select one choice from a 
group of choices. 



•Check boxes. Use check boxes to turn choices on or off. 

• Text entry boxes. Use text entry boxes to type in the 
appropriate text. 

•Value selectors. Use value selectors to change a value. 

• Lists. Use lists to select one or more items. 

Responding to a Dialog Box 

To respond to a dialog box, you select options and type text in 
text entry boxes. When you have finished, you click one of the 
buttons at the bottom of the dialog box to apply what you have 
set or chosen and continue. 

To select a radio button (All Levels) 

Radio buttons appear in groups of two or more. Like the buttons 
on an old car radio, one - and only one - button in a group of 
radio buttons can be selected. Clicking one radio button turns on 
that button and turns off any other buttons in the group. 

• Click one radio button in a group. The radio button darkens to 
show it's selected. If you make a mistake, simply click the correct 
radio button. 

To select or deselect a check box (All Levels) 

A check box allows you to select and deselect an option. When a 
check box is darkened, the item is selected and on; otherwise it 
is deselected and off. Check boxes are like light switches; 
clicking a check box switches the box from on to off or from off 
to on. Unlike radio buttons, you can select more than one check 
box in a group. 

• Click an empty check box. The check box darkens, indicating 
that the item is selected. Click the check box again to turn it off. 

To enter text in a text entry box (All Levels) 

You enter text in a text entry box by typing. For information 
about entering and editing text, see "Working With Text" in this 
chapter. 

1. If the insertion point (a blinking vertical line) is not blinking in 
the text entry box or if the name in the box is not highlighted, 
move the mouse pointer to the text entry box and click. The 
insertion point appears in the box. 
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2. Type text in the box. If you make a mistake, use the Backspace 
key to erase as many characters as necessary and then type the 
correct text. 

To change a value in a value selector (A ll Levels) 

A value selector has up arrow and down arrow buttons for 
moving through options or increasing or decreasing a value (a 
number). 

• Click the up arrow button to move to the next item or increase 
the value. Click the down arrow button to move to the previous 
item or decrease the value. 

• 

1. 

2 . 

or 

If the insertion point is blinking in the value selector, type the 
appropriate value in the box. If the insertion point is not in the 
box, move the pointer to it and click. Then, type the appropriate 
value. If you make a mistake, press Backspace to erase the 
number, and then type the correct value. 

To select an item from a scrolling list (All Levels) 

In dialog boxes , you often need to select an item from a list. 
There are two types of lists in dialog boxes: scrolling lists and 
drop-down lists. A scrolling list is already open when the dialog 
box appears. 

Click the item you want to select. The selected item is 
highlighted. If the list contains more items than can fit in the 
window, click the scroll arrow buttons to display other portions 
of the list, then make your selection. 

To select an item from a drop-down list (All Levels) 

A drop-down list looks like a regular button with a horizontal 
mark on the right side of the button. The current selection in the 
list is shown on the button. To choose a new selection, click the 
button to see the list. 

Click the drop-down list button. The list drops down so that you 
can make a different selection. 

Select the item you want from the list. The item is selected, and 
the drop-down list closes. 

To initiate an action by clicking buttons (A ll Levels) 

Every dialog box has buttons that initiate actions when you click 
them. If a button label is followed by an ellipsis (. .. ), clicking it 



leads to another dialog box. Common dialog box buttons include 
the following: 

•Apply. Applies the current settings but leaves the dialog box 
open so you can continue to adjust the settings. 

•Close. Closes the dialog box. The current settings are applied 
only if you have previously used the Apply button. 

• Reset. Resets the box to its original settings, undoing any 
changes you have made. 

• OK. Applies the current settings and closes the dialog box. 

•Cancel. Closes the dialog box without applying your changes. 

• Stop. Ends the task in progress at the next possible stopping 
place. 

• Yes. Answers yes to the question in the dialog box. The dialog 
box closes. 

• No. Answers no to the question in the dialog box. The dialog 
box closes. 

Using the Keyboard to Respond to a Dialog Box 

You can use the keyboard to respond to a dialog box. When you 
do this, you move a dotted selection cursor to different items and 
select them. 

To use the keyboard to respond to a dialog box (All Levels) 

1. To move from one group of options to another group, press the 
Tab key. To move backward, hold down the Shift key and press 
the Tab key. When the selection cursor is in a group, use the 
arrow keys on the keyboard to move from item to item. 

2. To select or deselect a check box, move the selection cursor to 
the item and press the Spacebar. 

3. When you finish setting items, select one of the buttons at the 
bottom of the dialog box. 

One button has a thick border around it. If this is the button you 
want to select, press Enter. 

or 

Either press Tab or Shift+Tab until the button you want to select 
is surrounded by a thick border. Then press Enter. 



NOTE 

Items in dialog boxes often have mnemonics. Pressing a mnemonic 
highlights a group or selects an item. If typing would enter characters 
into the text entry box, hold down the Alt key and type the 
mnemonic. 

WORKING WITH TEXT 

AL L LEVELS When you use most GEOS applications, you enter text. The 
whole document may be based on text, such as in Text File 
Editor, or you may simply enter text in text entry boxes, such as 
in GeoDex. The techniques for using text are the same no matter 
which application you use. Once you have entered text, you can 
make changes to it. 

Entering Text 

Whatever letters, numbers, and symbols you type at the keyboard 
appear in the document with which you are working. 

TEXT ENTRY BOXES 

In some text entry boxes, such as the Index area in GeoDex, the 
words scroll on the left when they extend beyond the limit of the 
box. 
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You can move to the right or left in a text entry box by pressing 
either the Right Arrow or Left Arrow. You can move to the 
beginning or end of a text entry box by pressing the Home or 
End key respectively. 

TEXT AREAS 

When you type in text window areas, such as in Text File Editor, 
the words that go beyond the end of a line automatically wrap 
down and continue on the next line. This feature is called word 
wrap. Word wrap means that you do not have to press the Enter 
key to start a new line of text. This keeps the lines and sentences 
together in the same paragraph. When you are ready to begin a 
new paragraph, press the Enter key. 



Jf there is no text in 
the text area, you 
cannot move the 
insertion point. 

Be sure that Num 
Lock is off (the Num 
Lock light on the 
keyboard is not lit) if 
you want to use the 
numeric keypad to 
move the insertion 
point. 

Positioning the Insertion Point 

The insertion point is the blinking vertical line that indicates 
where the characters you type appear on the screen. While you 
are typing, the insertion point moves to the right, appearing after 
the last character, and any characters already on the line move to 
the right also, to make room for the new characters. When you 
need to make changes to something you have already typed, you 
can move the insertion point anywhere in the text. 

To move the insertion point with the mouse (All Levels) 

1 . Move the mouse pointer to the location where you want to start 
inserting text. 

2. Click the mouse button. The insertion point moves to the new 
location. 

Rddressl 

To move the insertion point with the keyboard (All Levels) 

You can press keyboard keys to move the insertion point. For 
example, pressing the Left Arrow key moves the insertion point 
one character to the left. Pressing the Home key moves the 
insertion point to the beginning of the current line. The 
following table shows the key combinations for moving the 
insertion point. 

• Home. Moves the insertion point to the beginning of the 
current line. 

• Ctrl+Home. Move the insertion point to the beginning of the 
document. 

• End. Moves the insertion point to the end of the current line. 

• Ctrl+End. Moves the insertion point to the end of document. 

• Arrow Keys. Moves the insertion point one character or line in 
the direction of the arrow. 

• Ctrl+Arrow Key s. Moves the insertion point to the next 
beginning or ending of a word in the direction of the arrow. 

Entering Characters 

Once the insertion point is where you want it, you simply type 
and the characters appear on the screen. Press the Enter key 
when you want to start the next paragraph or when you finish 
entering text in a text entry box. When you add or delete words 



Not every application 
supports all special 
characters. if a 
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to existing text, the text in the remainder of the paragraph 
readjusts automatically. 

Deleting Text As You Type 

If you make a mistake while typing a word, you can press the 
Backspace key to erase characters to the left of the insertion 
point. You can also press the Delete key to erase characters to 
the right of the insertion point. 

Typing Numbers 

You can use either the alphanumeric part (the main part) of the 
keyboard or the numeric keypad to type numbers. If you are 
using the numeric keypad, be sure that Num Lock is on (the 
light on the keyboard is lit) so that you can enter numbers rather 
than move the insertion point in the direction of the arrows. 

Typing Special Characters 

You can type special characters such as a bullet ( •) and an em 
dash (-) with special key sequences. You can also type foreign 
accents such as e. 

To type a bullet (All Levels) 

Hold down the Ctrl and Alt keys and type an 8 . 

To type an em dash (All Levels) 

Hold down the Shift, Ctrl, and Alt keys and type a hyphen(-) . 

To type an e (All Levels) 

• Hold down the Ctrl and Alt keys and type an e twice. 

For a complete list of the key sequences for special characters, 
see Appendix B. 

Working in Insert or Overstrike Mode 

The method for entering text described in this manual is called 
insert mode. That is, the characters you type appear at the 
insertion point, pushing all existing characters to the right to 
make room for the new characters. You can use the Look & Feel 
section of Preferences to enable overstrike mode, where the 
characters you type replace the characters to the right of the 
insertion point. This feature is normally disabled, but if you 



enable it with Preferences, you can use the Insert key to switch 
between insert and overstrike modes. For more information on 
enabling the Insert key to switch between insert and overstrike 
modes, see Appendix A. 

Selecting Text 

When you want to make changes to text, for example rewording 
a sentence in GeoWrite or changing an address in GeoDex, you 
must first select the text you want to change. Selected text 
appears highlighted. 

V..1he n you want to make c ha.n..ge::: , for example 
rewording a sentenc e in Geo Write or cha.n..giri..g a.n 
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You can use a mouse or a keyboard to select text. 

To select text with a mouse (All Levels) 

1. Move the mouse pointer to the word, line, or paragraph you 
want to select. 

2. Press and hold the mouse button and drag the mouse across the 
text until what you want to select is highlighted. Then release the 
mouse button. 

or 

Click at the beginning of the text, hold down the Shift key, and 
click at the end of the text. 

or 

Position the pointer over the text you want to select and quickly 
click the appropriate number of times: 

2 Clicks Selects a word, but not the space after the word 

3 Clicks Selects a line 

4 Clicks Selects a paragraph 

5 Clicks Selects the entire document 

The text you want to delete, replace, or change is selected. 

On the last click, if you continue holding down the mouse 
button rather than immediately releasing it, you can drag to select 
additional words, lines, or paragraphs at a time. 



I.I you are using the 
arrow keys on the 
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To extend or reduce the selection (All Levels) 

You may want to change the amount of text you have selected. 

1. While a selection is already highlighted, press and hold down the 
Shift key. 

2. Click where you want to extend or reduce the selection. 

Shift-click at this location to extend the selection. , 

Position the you wantlto select 
and quickly click the appropriate number of times. 

To use the keyboard to select text (All Levels) 
If you are a fast typist, you may not want to take your hands off 
the keyboard to select text. The table below shows how to select 
text by using two or more keys at the same time. You can use 
these keys in any combination to extend or reduce a selection 
you have already made. 

• Shift+ Home. Selects from the insertion point to the beginning 
of the line. 

• Ctrl+Shift+Home. Selects from the insertion point to the 
beginning of the document. 

• Shift+ End. Selects from the insertion point to the end of the 
line . 

• Ctrl+Shift+End. Selects from the insertion point to the end of 
the document. 

• Shift+Right or Left Arrow. Selects one character in the 
direction of the arrow. 

• Ctrl+Shift+Right or Left Arrow. Selects from the insertion 
point to the nearest beginning or ending of a word in direction 
of the arrow. 

• Shift+Up or Down Arrow. Selects from insertion point one 
line in the direction of the arrow. 

• Ctrl+Shift+Up or Down Arrow. Selects to beginning or end of 
the current paragraph. 

Canceling a Selection 

If you change your mind after making a selection, you can cancel 
the selection by clicking anywhere in the text area or by pressing 
one of the arrow keys. 



Replacing Text 

The fastest way to replace text is to select it and then type the 
new entry. 

1 . Select the word or words you want to replace. 

2. Type the replacement text. The new text replaces the original 
text. 

Cutting, Copying, and Pasting 

You can move text around within your document, as if you were 
cutting and pasting with scissors and glue. 

When you select text, you can cut it to move it elsewhere or 
copy it to paste a replica of it in another place. The selection you 
copy or cut is placed on the clipboard, an electronic holding 
space. When you choose Paste from the Edit menu, the contents 
of the clipboard are pasted into the active document. The active 
document can be the document that contains the original 
selection, another document in the same application, or another 
document in another application. 

When you copy or cut a selection to the clipboard, it replaces 
whatever is currently on the clipboard. 

To move a selection (All Levels) 

When you move a selection, you remove or cut it from its 
original location and paste it into another location. 

1. Select the item or text you want to move. 

2 . Choose Cut from the Edit menu. The item is removed from your 
document and placed on the clipboard, replacing any item 
already there. 

3. Move the insertion point to the location where you want the item 
to appear. 

4. Choose Paste from the Edit menu. The contents of the clipboard 
are inserted into the document, and the pasted text appears at 
the insertion point. 

To copy a selection (All Levels) 

If you want to leave an item in its original location and also 
insert it somewhere else, use Copy instead of Cut. 

1. Select the item or text you want to copy. 



Since drag and drop 
doesn 't use the 
clipboard, the 
contents of the 
clipboard remain 
intact. 

2. Choose Copy from the Edit menu. The item remains in your 
document and also goes to the clipboard, replacing any other 
item on it. 

3. Move the insertion point to the location where you want the item 
to appear. 

4. Choose Paste from the Edit menu. The contents of the clipboard 
are inserted into the document. 

NOTE 

When you paste an item into a document from the clipboard, the 
item also remains on the clipboard unless you replace it. Therefore 
you can continue to paste the same item from the clipboard to 
multiple locations in your document. 

To replace one block of text with another (All Levels) 

1. Select the block of text you want to replace the existing text. 

2. Choose Copy or Cut from the Edit menu. The text is placed on 
the clipboard. 

3. Select the block of text you want to replace . 

4. Choose Paste from the Edit menu. The selection is replaced by 
the contents of the clipboard. 

Dragging and Dropping 

The drag and drop feature provides a quick way to move or copy 
text without using the clipboard. 

To move or copy a selection with drag and drop (A ll Levels) 

1. Select the text you want to move or copy. 

2. Move the mouse pointer over the selected text. 

3. Press and hold down the right mouse button. The pointer 
changes to the drag and drop pointer. 

4. Drag the pointer so that it is over the location where you want to 
move or copy the selection. 

5. Release the right mouse button. The selected text is moved or 
copied to the new location. 

NOTE 

Normally, you just let GEOS decide whether the drag and drop 
should be a move or a copy, depending on whether you drag the 
pointer to somewhere in the same document or to somewhere in a 



different document. As you drag, the square at the tail end of the 
pointer indicates whether the drag and drop will be a move or a copy: 
If the square is hollow, it will be a move; if the square is filled , it will 
be a copy. 

You can always change a move to a copy or a copy to a move by 
holding down either the Ctrl or the Alt key while performing the 
drag and drop: 

• Press and hold down the Ctrl key to force a copy. The square 
at the end of the pointer is filled to indicate the selection will 
be copied. 

• Press and hold down the Alt key to force a move. The square 
at the end of the pointer is hollow to indicate the selection will 
be moved. 

Do not release the Ctrl or the Alt key until after you have released 
the right mouse button. 

Deleting Text 

You can delete text from any document. 

To delete items (All Levels) 

1. Select the text you want to delete. 

2. Press the Backspace or Delete key. 

or 

Choose Cut from the Edit menu. 

or 

Hold down Shift and press Delete, which is the shortcut key for 
Cut. 

The selection is deleted. 

NOTE 

Those methods that delete items by cutting place the selection on the 
clipboard. You can paste the selection from the clipboard to another 
location as long as you haven 't cut or copied another item to the 
clipboard. 

To delete text by using the keyboard (All Levels) 

As long as no text is selected, you can use the following 
keystrokes to delete text: 

• Backspace. Character to the left. 

• Delete. Character to the right. 



• Ctrl+Backspace. From insertion point to beginning of word. 

• Ctrl+Delete. From insertion point to end of word. 

• Shift+Ctrl+Backspace. From insertion point to beginning of 
line. 

• Shift+Ctrl+Delete. From insertion point to end of line. 

Using Undo 

Sometimes you may delete some text or change the way it looks 
and immediately decide that it was not what you wanted. If you 
have not done anything else, you can choose Undo from the Edit 
menu to restore the text to its last condition. Undo undoes the 
last editing you did. 

Once you choose Undo, its name on the Edit menu changes to 
Redo so that you can undo what was undone. 

Not all applications include Undo, and not all operations can be 
undone. 

To undo your last editing operation (All Levels) 

• Choose Undo from the Edit menu. If the item is dimmed, then 
your last operation cannot be undone. 

The text you are working on reverts to the way it was before 
your last editing operation. 

NOTE 

Undo does not restore any changes to the cl ipboard. For instance, 
choosing Cut from the Edit menu will replace the contents of the 
clipboard so that even Undo will not bring them back. 



USER LEVELS 

Using Keyboard Shortcuts for Editing 

As your proficiency increases, you may find you want to use edit 
functions without lifting your hands from the keyboard. You can 
use the following shortcut keys to edit: 

I EDIT FEATURE r KEY SEQUENCE 

I Undo r Alt+Backspace 

Cut I Shift+ Delete 

Copy I Ctrl +Insert 

Paste J Shift+ Insert 

Delete J Delete 

You can make many of the GEOS applications as simple or 
sophisticated as you want. Typically, the more functions an 
application has , the more difficult it is to learn. In GEOS 
applications you can start using an application at a simple, basic 
level. As you gain experience and are comfortable with it, you 
can add more functions by changing the user level. 

Each GEOS application has a number of levels appropriate to its 
size. Applications such as GeoDex have three user levels; simpler 
applications such as the Scrapbook have two user levels. 
Applications used for a specific task, like Calculator or 
GeoComm, have no user levels at all. 

The following is a general description of each user level: 

•Level 1, Introductory Level. Level 1 is for first-time users. It 
includes the application's simplest features. Use Level 1 to learn 
the basic operation of the application. 

• Level 2, Beginner Level. Level 2 is for users who are 
comfortable with Level 1 and want to use more of the 
application's capabilities. Level 2 is also designed for infrequent 
users or those with simple requirements. If these are your 
needs, you may not need to move beyond Level 2. 

• Level 3, Intermediate Level. Level 3 is for users familiar with 
basic operations who want to learn a few complex functions 
and procedures. Level 3 includes as much functionality as 



possible without seeming overwhelming. None of the 
applications in this manual have more than three user levels. 

• Level 4, Advanced Level. Level 4 is for people who use an 
application every day. It includes all the application's functions 
and features as well as advanced shortcuts to complete 
common tasks. Level 4 is the most powerful and complex level. 
None of the applications in this manual have a fourth level. 

The first time you start an application with multiple user levels, 
the application will start at Level 1. For information about 
changing your user level, see "Verifying, Changing, and Saving 
Your User Level" in this chapter. 

If you are using an application with fewer than three user levels, 
the highest level of an application may include a common task 
which is listed as being at a higher level in this chapter and 
Chapter 2. For example, a common task available at Level 3 in 
GeoPlanner would be available at Level 2 in Scrapbook, because 
Scrapbook only has two levels. 

Differences From Level to Level 

Within an application, the user levels build on one another. For 
example, Level 2 has all the features of Level 1 plus new features 
available at Level 2. Sometimes, when moving from a lower level 
to a higher level, the menu bar is rearranged to accommodate all 
the additional features of the new level. In this case, all the 
features from the previous level are still available, but they are 
organized differently across the menu bar. 

NOTE 

T he same function may be avai lable at different user levels in different 
applications. For example, the ability to discard changes in a GeoDex 
document does not appear until Level 3 of GeoDex. However, 
because Scrapbook only has two user levels, the ability to discard 
changes appears at Level 2. 

Verifying, Changing, and Saving Your User Level 

You can change or verify your user level both while doing work 
in the application or while the New/ Open dialog box is on 
screen. 



ALL LEVELS 

To verify or change your user level (All Levels) 

1. If the ew / Open dialog box is on screen, click the User Level 
button. Otherwise, choose Change User Level from the Options 
menu. 

The Change User Level dialog box appears. The highlighted 
button indicates the level at which you are currently working. 

General-pur·pose word processing. 

FuH-featured word processing with 
simple page layout and graphics. 

Desktop publishing and advanced word 
processing. 

2. Click a button for a different user level if you want to change 
levels; then, click OK. Your user level is changed for the current 
session unless you change it again. 

or 

Click Cancel if the current level is the one you want to work at. 
Your user level is unchanged. 

3. If you always want the application to start at the user level you 
have just selected, choose Save Configurations from the Options 
menu. (If the New/ Open dialog box is on screen, you will need 
to close the dialog box before you can choose from the Options 
menu.) 

When you save the configuration of an application, your user 
level and other options are remembered after you exit the 
application. For more information about saving your 
configuration, see "Setting Options and Saving Your 
Configuration" later in this chapter. 

Fine Tuning Your User Level 

Besides using the preset user levels, you can create your own 
customized user level. Each application has a set of fine tune 
features that you can turn on or off. Typically, Level 1 has the 



fewest fine tune features turned on; Level 4 has the most features 
turned on. 

The features you can fine tune vary from application to 
application. For more information about which features you can 
fine tune in each one, see the chapters in this manual that 
explain that application. 

To fine tune a user level (All Levels) 

1. If the New/ Open dialog box is on screen, click the User Level 
button. Otherwise, choose Change Level from the Options menu. 

The Change User Level dialog box appears. 

2. To see which features comprise a user level, click that user level 
and then click Fine Tune. The Fine Tune dialog box appears. The 
set of fine tune features that are turned on and off defines the 
user level you selected. 

_J §.eoPlanner Button 
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3. To change the available fine tune features, click the features in 
the Fine Tune dialog box to turn them on or off. Selected 
features have a darkened check box. 

4. When you finish selecting and deselecting features, click OK. The 
Change User Level dialog box reappears. If the fine tune changes 
you made coincide with a pre-defined user level, that button is 
highlighted. If the changes you make do not coincide with a pre
defined user level, none of the user level buttons is highlighted. 

5. Click OK to return to the document at the user level you have 
defined. 



SETTING OPTIONS AND SAVING YOUR CONFIGURATION 

ALL LEVELS 

Some applications 
have Save Options 
rather than Save 
Configuration. 

You can use the Options menu to configure a GEOS application 
the way you want it. For example, you can use the Options 
menu to set the user level and any application-specific options. 

After you have changed options in an application, you can save 
that configuration so that it is in effect each time you start the 
application. If you want to change the options in an application 
back to their original settings, you can reset the configuration. 

Consult the chapters for specific applications to learn about the 
unique features available on the Options menu. 

To save the application configuration (A ll Levels) 

1. Set the options you want on the Options menu. 

2. Choose Save Configuration from the Options menu (or, in some 
applications, choose Save Options). All options you have set are 
saved so that they will be in effect each time you start the 
application. 

To reset the configuration (All Levels) 

• If you want change the options in an application back to their 
original settings, choose Reset Configuration from the Options 
menu. 

WORKING WITH MULTIPLE APPLICATIONS 

ALL LEVELS As you become more familiar with GEOS applications, you may 
want to use more than one application at a time. For example, 
you might be using the Text File Editor to write a note and need 
to use GeoDex to look up an address. You could then start 
GeoDex without closing the Text File Editor. 



Application windows "stack" up with the active one on top. The 
title bar of the active window is highlighted. 

You can resize the application windows so that you can see 
edges of each open application. Then, you can move between 
documents and applications by clicking the window. 

You can also use the Desk Accessories folder (in the WORLD 
directo1y) to make some applications always remain in front of 
others. 

NOTE 

You can open as many applications as you want, though you aren't 
likely to need very many applications open at one time. Since every 
open application uses some of the computer's memory, you should 
open only those appl ications t hat you want to use. If you have several 
applications open and your computer seems to be running slower 
than it normally does, t ry exiting from a few of them and see if that 
improves system performance. 



To work with multiple applications (All Levels) 

1. Open the first application. The application opens, partially filling 
the screen . 
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2. Open the second application. The application opens on top of 
the first application window. At this point, you can resize or 
move the windows so that you can see corners of the window. 
Then, you can simply click the window and that application 
comes to the top of the stack. 

It is not necessary to resize windows to switch between them. 
You can switch between open applications using the Express 
menu. See "Using the Express Menu" in this chapter. 

To work with multiple applications using the Express menu (A ll 
Levels) 

Once you have an application open, you can open or switch to 
any other application in the WORLD folder. 

1. Click the Express button, which is located next to the Window 
Control button on the left side of the title bar of the current 
application. The Express menu appears. 

2. Choose Start an Application to see a list of applications you can 
start. Click the application you want to start. The application 
starts. 

You can switch between an application and any other application 
you can see on the screen by clicking the desired window. You 
can also switch to an application by selecting its name from the 
Express menu. 



To make an application always remain in front of others 

1. Place the application in the Desk Accessories folder (in the 
WORLD folder). 

2. Start the application either by double-clicking its icon or by using 
the Express menu. The application starts. 

The application's window remains in front of other applications 
even if you click in another application's window - provided 
the other application is not also in the Desk Accessories folder. If 
you click in the window of another desk accessory, its window 
comes to the front. 





CHAPTER 2 

Document Basics Some GEOS applications work with 

documents , others do not. This chapter provides an overview of 

the concepts and skills you need to begin using documents with 

the GEOS accessory applications. 



At the end of this chapter you will know how to do the 
following: 

• Create and save new documents. 

• Open and close existing documents. 

• Use standard file selectors. 

• Print documents. 

• Back up and restore documents. 

• Manage documents. 

For more specific information about working with documents in 
a particular application, refer to the chapter that covers that 
application. 

This chapter assumes you are familiar with the information 
covered in Chapter 1, which provides an overview of the skills 
you need to use any GEOS application. 

WHAT ARE DOCUMENTS? 

MEM02 .T>::T 

A document is a holding place for information. For example, you 
can use GeoDex to organize your names and addresses, which 
will be stored in a GeoDex document, or you can use 
GeoPlanner to track your appointments , which will be placed in 
a GeoPlanner document. Documents appear as icons like the one 
at the left, usually in your DOCUMENT folder, although you may 
put them in other places, such as in a class folder or on a floppy 
disk. 

GeoDex, GeoPlanner, and Scrapbook have startup documents. A 
startup document opens automatically when you start the 
application. When you start these applications you see the 
application's default startup document. The name of the default 
startup document varies, depending on the application. In 
GeoDex the default startup document is called "First Address 
Book"; in GeoPlanner it is called "My Schedule"; and in 
Scrapbook it is called "Default Scrapbook". 

Text File Editor edits DOS text files. A DOS text file is a type of 
DOS data file used and created by DOS applications and 
courseware. It contains only text. You can identify DOS text files 
by the blank document icon and a .TXT extension that is often 
part of their file names. Examples of DOS text files with which 
you may be familiar include the following: 



• A report you create and save with the Reports function on a 
class folder in Ensemble. 

• A text file you save from a communications program, such as 
GeoComm. 

• A DOS batch file. 

• A GeoComm script file. 

GEOS applications that do not work with documents include the 
Calculator, GeoComm, Solitaire, and GeoBanner. For example, 
when you use the Calculator you perform numeric calculations, 
but you don't create a document for saving those calculations. 

CREATING AND OPENING DOCUMENTS 

AL L LEV E LS You can create new documents and open existing ones using 
choices on the File menu. Creating a new document is like 
starting with a blank piece of paper or an empty address book or 
day planner. You can create new documents whenever the need 
arises. Once you've created additional documents and saved 
them, you can open them at any time to view or edit the 
information they contain. 

The New/Open Dialog Box 

Whenever you want to create a new document or open an 
existing one, you see a variation of the New/ Open dialog box. 
The New/ Open dialog box is the dialog box which lets you 
create and open documents from within an application. Each 
application may have a different New/ Open dialog box, but in 
every application they function in similar ways. 
When working with an application that has a startup document, 
such as GeoDex or GeoPlanner, you do not normally see the 
New/ Open dialog box. You must first close the current 
document without closing the application or choose New/ Open 
from the File menu. 



Tbe particular 
buttons that appear 
in the New/ Open 
dialog box depend 
on the application 
you are using and its 
current user level. 

This is the New/ Open dialog box in GeoPlanner: 

Click here to exit an appl ication. 

Click here to open a 
new, empty document. 

Cl ick here to open the 
default document. 

Cl ick here to open an 
existing document. 

Click here to view or 
change your user level. 

The New/ Open dialog box appears whenever there is no 
document open in an application or when you choose 
New/ Open from the file menu. It provides buttons for creating 
and opening documents. A New/ Open dialog box may have any 
of the following buttons: 

•New. Click the New button to create a new, empty document. 
For more information, see "Creating a New Document" later in 
this section. 

• Open. Click the Open button to locate and open a document 
which already exists. For more information, see "Opening an 
Existing Document" later in this section. 

•Open Startup. In an application which has a startup document, 
click Open Startup to open the startup document. For more 
information on startup documents, see "Opening the Startup 
Document" later in this section. 

• Import. Click the Import button to create a new document by 
reading in information from another application, such as a DOS 
word processor. Of the applications in described in this manual, 
only Geo Dex has an Import button on its New / Open dialog 
box. For more information, see "Importing and Exporting" in 
this chapter. 

• Change User Level. Click the Change User Level button to 
change the application user level directly from the New/ Open 
dialog box. This is the same as choosing Change User Level 
from the Options menu. by changing user levels you specify 
how simple or complex you want the application to be. For 
more information, see "User Levels" in Chapter 1. 



•Exit or Cancel. If there are no documents open in the 
application, you can click the Exit button to exit the application 
directly from the dialog box. If there is a document open, then 
this button becomes Cancel. Click Cancel to close the 
New/ Open dialog box and return to the open document. 

NOTE 

In GeoDex, GeoPlanner, and Scrapbook you only work with one 
document at a t ime. Therefore, you must first close the current 
document before working with a new one. 

Text File Editor allows you to work with more than one document at 
a time; you do not need to close the current document before 
opening or creating a new one. You can switch between the open 
documents using functions on the Window menu. For more 
information, see "Working With DOS Text Files" and "Working 
W ith Multiple Documents" in Chapter 8. 

Creating a New Document 

When you want to create a new, empty document, you use the 
New/ Open choice on the File menu. 

To create a new document (All Levels) 

This procedure works in GeoDex, GeoPlanner, and Scrapbook; 
you can also use it in Text File Editor for working with one 
document at a time. 

1. Choose Close from the File menu. If you have unsaved changes 
in the current document, you will be asked if you want to save 
or discard them. 

The New/ Open dialog box appears. 

2. Click the ew button. A new document appears. 

The new document is labeled "Untitled" (or "BLANK" in the case 
of Text File Editor). You will need to give it a name when you 
save it. See "Saving Documents" in this chapter for more 
information on saving documents. 

Opening an Existing Document 

An existing document is one that you have previously created 
and saved. You can open an existing document at any time to 
view or change the information it contains. 

Throughout GEOS applications you will encounter variations of a 
particular dialog box, called the standard file selector. This dialog 



Double-click the 
name to open it 
immediately. 

box appears whenever you need to open, locate, save, copy, or 
move documents. 

To open an existing document, you use a standard file selector. 
The following procedure explains the easiest way to use the file 
selector controls to find an existing document in your 
DOCUMENT folder . If you need to change folders or disks to 
locate the document you want to use , see "Working with 
Standard File Selectors" in this chapter. 

To open an existing document (All Levels) 

This procedure works in GeoDex, GeoPlanner, and Scrapbook; 
you can also use it in Text File Editor for working with one 
document at a time. 

1. When the ew/ Open dialog box appears, click the Open button. 
A standard file selector appears: 

.. . 

Click here to exit the application. 

Click here to open a new, 
empty document. 

Click here to open an 
existing document. 

2. Make sure the name of your DOCUMENT folder is highlighted. If 
it isn't, click the Go To Document button. This displays a list of 
existing documents and folders in your DOCUMENT folder that 
can be opened by this application. 

3. Select the name of the document you want to open. If the 
document has document notes, they appear in the Notes field . 

4. Click the Open button. 

The dialog box closes and the selected document appears. 

If you have previously set a password for the document, you will 
be asked to enter the password. For more information on setting 
a password, see "Setting and Removing a Document Password" in 
this chapter. 

THE NOTES FIELD 

When opening a document in Level 3 of an application, a Notes 
field appears at the bottom of the file selector. When you select a 



This procedure does 
not apply to Text File 
Editor, which does 
not have a startup 
document. 

document in the list, its notes appear in the otes field. Not all 
documents have document notes. For information on setting and 
changing document notes, see "Editing Document Notes" in this 
chapter. 

THE TYPE INDICATOR AND THE FOR EDITING OPTION 

When opening a document in Level 3 of an application, a type 
indicator and a For Editing option appear below the list of files. 
When you select a document in the list, the type indicator shows 
the type of document selected. The status of the For Editing 
option updates, depending on the type of document selected: 

• Normal. If you select a normal document, the For Editing 
option becomes checked, anticipating that you want to make 
changes to the document. 

• Public. If you select a Public document, the For Editing option 
becomes unchecked, anticipating you won't be making changes 
to the document. 

•Read-Only. If you select a read-only document, the For Editing 
option becomes dimmed. You cannot open a read only 
document for editing. 

For more information on the document types, see "Setting the 
Document Type" in this chapter. 

To change the For Editing option in the Open dialog box (Level 4) 

1. In the Open file selector, select a document in the list. The For 
Editing option updates , depending on the document type . 

2 . Click to change the For Editing option. When checked, you can 
edit the document. When unchecked, any changes you make 
must be saved to a document with a different name. 

3. Click Open. The document opens. 

Opening the Startup document 

GeoDex, GeoPlanner, and Scrapbook have startup documents 
which open automatically when you start the application. If you 
close the startup document without closing the application, the 
New/ Open dialog box appears. The New/ Open dialog box for 
these applications has an Open Default button which can open 
the startup document. 



To open the startup document (All levels) 

• When the New/ Open dialog box appears, click the Open Startup 
button. The startup document opens. 

In GeoDex, the default startup document is First Address Book; 
in GeoPlanner, it is My Schedule; and in Scrapbook, it is Default 
Scrapbook. You can change which document to open as the 
default. For more information on changing the startup document, 
see "Setting the Startup Document" in this chapter. 

Opening a Document by Its Icon 

You can open a document by opening its icon. That is, you can 
locate a document's icon and double-click it. Double-clicking a 
document icon opens the appropriate application with the 
document ready for use. For example, you can start GeoDex by 
double-clicking a GeoDex document with which you want to 
work. Documents are normally stored in your DOCUMENT 
folder , but this technique works no matter where a document is 
stored. 

To open a document by its icon (All Levels) 

• Locate the icon representing the document you want to open and 
double-click it. The application starts and automatically opens the 
document. 
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or 

Double-click here to start 

I 

GeoDex, and open this 
document. 

Click to select the icon of the document you want to open, then 
click Open Item at the bottom of the window. 

or 

Right-click the icon of the document you want to open. When 
the pop-up menu appears, choose Open. 



With whichever method you use, the application opens with the 
selected document ready for use. 

SAVING DOCUMENTS 

A LL LE V EL S Saving a computer document is different from saving a piece of 
paper on which you have written something. Anything written 
on a piece of paper is automatically saved unless you throw the 
paper away. However, a computer document is not saved until 
you take an action to save it. Saving a computer document means 
recording the document on a permanent storage medium such as 
a fixed disk. Your DOCUMENT folder is such a place; ordinarily, 
you will want to save documents in your DOCUMENT folder. 

You should save a document periodically as you work on it; for 
instance, whenever you come to a good stopping point. It's also 
good practice to save a document before you print it, before you 
make a significant change to it , and as soon as you 've finished 
any work you wouldn't want to redo. However, should you 
forget to save your document, GEOS applications have a 
safeguarding feature which protects you from losing changes 
before you've had a chance to save them. For more information, 
see "Safeguarding a Document" in this chapter. 

Typically, when you 're finished working on a document, you 
save it, and then you close the document. If you want to work 
on another document using that application, you can open a 
different document. Otherwise, you close the application. For 
more information on closing documents and applications, see 
"Exiting an Application" in this chapter. 

The first time you save a document, you have to name it. The 
best way to name a document is to describe its contents so that 
you can recognize the document by its name. For example, a 
letter you write to your friend Karen might be named "Karen 
1/ 11/ 92". A Christmas card you designed might be named 
"Christmas Card 1991." 

Naming a Document 

The first time you save a document, you must name it. Some 
applications , such as the Text File Editor, can create DOS 
documents; these documents must have a DOS file name. If you 
need to use a DOS name, the application you're using will 
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specify this. However, most documents use GEOS document 
names , which are more flexible. 

NAMING A GEOS DOCUMENT 

There are some rules to follow when you name a GEOS 
document. The name can be up to 32 characters long, and may 
contain both upper- and lower-case characters. For example, you 
could name a document "Seva's Birthday Card" or "Seating Chart 
for Class 12/ 4/ 93". Each space you type (by pressing the 
Space bar) counts as one character. 

NAMING A DOS FILE 

There are also rules to follow when you name a DOS file. DOS 
files can be up to eight characters long, optionally followed by a 
period and three more characters. The optional three characters 
following a DOS file name are called the extension. The 
extension usually indicates the type of data the file contains. 
While no standard is enforced, a DOS text file , for instance, such 
as one created with Text File Editor, should be given a .TXT 
extension to be consistent with other DOS files of the same type . 

DOS file names can only contain the letters A through Z, the 
numbers 0 through 9, and the following special characters: 

underscore - [caret I§ dollar sign $ tilde I: I exclamation point ! number sign 

percentage sign % ampersand I& 
hyphen I - braces I 1} 

parentheses () at sign I@ 
I apostrophe I grave accent l' 
No other special characters are permitted. 

DOS names cannot contain spaces, commas, backslashes, or 
periods (except the period following the first eight characters) . 
The letters are always converted to upper case. 

The following are examples of valid DOS names: 

• TO_DO 

• RACHELl.TXT 

• ASSIGNMT.DOC 



On the other hand, the following names are not acceptable for 
DOS documents: 

• TO DO (Includes a space) 

• MEMOTOPEDRO (Too many letters) 

• MEMO.EARVIN (More than three letters following the period) 

Using Save 

The simplest way to save a document is to choose Save from the 
File menu. If the document already has a name, Save will save 
any changes to that document. The document does not yet have 
a name, Save will ask you to name the document. 

To save changes to a document that already has a name (All 
Levels) 

Many documents you work with will already have a name. For 
instance, the startup documents you use in GeoDex, GeoPlanner, 
and Scrapbook already have a name. To save any changes to one 
of these documents , you simply choose Save from the File menu. 

• Choose Save from the File menu. Any changes you 've made are 
saved, and you are immediately returned to the open document. 

If the Save choice is dimmed it means there are no changes to 
save. 

To save an Untitled document for the first time (All Levels) 

When you create a new document it is temporarily called 
"Untitled. " To save it , you must give it a name. 

The Save As file selector appears when you t1y to save the 
document. The following procedure explains the easiest way to 
use standard file selector controls to name the document and 
save it in your DOCUMENT folder. If you want to save the 
document somewhere else, see "Working with Standard File 
Selectors" in this chapter. 



LEVEL 3 

1. Choose Save from the File menu . A standard file selector appears 
with a New Name text entry box: 

Type the new name here. 

Your document w ill be saved 
in the folder listed here. 

2. Make sure the DOCUMENT folder is highlighted in the list. If it 
isn't, click Go To Document. This saves the document in your 
DOCUMENT folder. 

3. Type a document name in the New Name text entry box. 

4. Click Save to save the document using its new name. You return 
to the open document, and its name appears in the title bar. 

Using Save As 

You can save a document under a different name using the Save 
As choice on the File menu. When you choose Save As, you 
create a new version of the document and give it a new name. 

Save As serves many useful purposes. For example, suppose you 
wrote a resume last year and named it "Resume 1992". This year 
you want to revise the information, but you also want to keep 
the original intact so you can ref er to it. You could open 
"Resume 1992" and immediately save it as "Resume 1993". The 
original document, "Resume 1992", is preserved on disk and 
"Resume 1993" appears in the document window so that you can 
change it appropriately to emphasize your new ideas for the 
class. 

When you choose Save As, a standard file selector appears. The 
following procedure explains the easiest way to use standard file 
selector controls to save the document in your DOCUMENT 
folder. If you want to save the document somewhere else, see 
"Working with Standard File Selectors" in this chapter. 



AL L LEVELS 

To save a document under a different name using Save As (Level 
3) 

1. Choose Save As from the File menu. A standard file selector 
appears with the current name of the document in the New 
Name text entry box. 

Type the new name here. 

Your document w ill be saved 
in the folder listed here. 

2. Make sure the DOCUMENT folder is highlighted in the list. If it 
isn't, click Go To Document. This saves the document in your 
DOCUMENT folder. 

3. Type the new name, which replaces the current name of the 
document. The new name appears in the text entry box. 

4. Click Save to save the document using its new name. The 
original document is closed and remains as you last saved it. Any 
recent, unsaved changes are saved to the new version only, 
which appears in the window ready for editing. If you continue 
editing the version on the screen, you are editing the new 
document. 

Safeguarding a Document 

GEOS periodically takes a "snapshot" of documents you have 
open so that you are protected in the event of a mishap, such as 
a power outage. This is called document safeguarding and it 
happens automatically in Ensemble. 

If something happens and you are afraid you 've lost work (you 
accidentally turn off your computer before logging out, for 
instance), document safeguarding may have protected your work. 

To get your work back, you don't need to do anything special. 
Simply open the document you were working on. If there are 
unsaved changes in the document, and document safeguarding 
was able to protect them, a dialog box will appear letting you 



know the document has unsaved changes. Respond to the dialog 
box and then choose Save from the File menu to make the 
changes permanent. 

If you want to change how often your documents are 
safeguarded, or if you want to turn off document safeguarding 
altogether, you can do so with settings in Preferences. For more 
information, see Appendix A. 

NOTE 

Document safeguarding only applies to GEOS documents. If you're 
working with a DOS files, such as those created with the Text File 
Editor, it is a good idea to save your document with the Save choice 
every I 0 minutes or so. 

Document safeguarding is different from the "auto save" feature 
found in many DOS applications. Document safeguarding takes a 
temporary "snapshot" of your changes, but does not permanently 
save them to your document. Only the Save command will make 
changes permanent. This means that you control when the document 
is permanently updated. 

CLOSING DOCUMENTS 

ALL LEVELS When you close a document, you remove it from the screen; 
though, the application remains open. You may want to close a 
document but not its application so that you can create or edit 
another document in that application. 

It is safest and best to save a document before closing it. This 
way you are guaranteed that all your changes have been saved. 
Fortunately, if you forget to save your document before closing 
it, you will get one last chance to save your changes before the 
document closes. For more information about saving a 
document, see "Saving Documents" in this chapter. 

To close a document (All Levels) 

• Choose Close from the File menu. If there are unsaved changes 
in the document, you will be asked if you want to save the 
changes. 

The document is closed. If there are no more open documents , 
then the New/ Open dialog box appears. 



WORKING WITH STANDARD FILE SELECTORS 

ALL LEVELS 

ALL LEVELS 

A standard file selector is a special type of dialog box that 
appears whenever an application needs to know where to store a 
file you want to save, copy, or move, or where to find a file with 
which you want to work. Although different file selectors contain 
slightly different text , depending on what you are doing, they 
generally look and operate the same way. Common standard file 
selectors appear when you want to select an existing document 
to open, when you want to save a new document (or save an 
existing document under a new name), or when you want to 
create a copy of a document. 

Simple Procedure 

It's easiest to store documents in your DOCUMENT folder. By 
doing so, you avoid the trouble of changing folders and drives in 
the standard file selector. You simply go straight to your 
DOCUMENT folder, which is where GEOS applications assume 
you are storing and retrieving documents. 

The procedures for the easy way to use standard file selectors are 
documented in "Opening an Existing Document" and "Saving 
Documents" in this chapter. 

Complex Procedure 

If you need to store or retrieve documents on another drive or in 
a folder other than your DOCUMENT folder, you can use a 
standard file selector to open and close folders and select files on 
any drive or direct01y to which you have access. 



The following illustration shows the Open file selector in Text 
File Editor, which is a example of the standard file selector: 

Path drop-down list 

Go To Document button 

I Path arrow button 

Open folder 

Folder and file list 

The buttons in a standard file selector are as follows: 

•Path drop-down list. Use this drop-down list to open, close, 
and change to other folders. 

• Go To Document button. Use this button to move 
immediately to your DOCUMENT folder. 

• Folder and file list. This list shows the open folder and its 
contents. se this list to select a folder or a file. 

• Open folder. The open folder is the one at the top of Folder 
and File list. The contents of the open folder are shown below 
it in the list. 

• Drives drop-down list. Use this drop-down list to change 
from one disk drive to another. The button always shows the 
name and drive letter of the disk containing the current folder. 



THE PATH DROP-DOWN LIST 

When you click the Path button, the Path drop-down list 
appears. This list shows the folders you moved through to get to 
the current folder. For example, if the current folder is the 
DOCUMENT folder, the Path drop-down list might look like the 
following: 

The folder at the bottom of the drop-down list is the current 
folder. If you had a folder named "LETTERS" inside your 
DOCUMENT folder and you selected that folder, the Path drop
down list might look like the following, with "LETTERS" as the 
current folder: 

You can open the Path drop-down list to see the current folder 
in relation to other folders. You can also click a folder in the Path 
drop-down list to move directly to that folder. 

MOVING THROUGH FOLDERS 

You can move through folders in the following ways when you 
use a file selector: 

• Open a folder. 

• Close a folder. 

• Move to the DOCUMENT folder. 

• Move to another folder. 

• Change to another drive and display its contents. 

To open a folder (All Levels) 

1. In the Folder and File list, locate the name of the folder you want 
to open. If necessary, use the scroll bar to see more of the list. 

2 . Double-click the name of the folder. 

or 



Select the name of the folder and then click the Path button. The 
Path drop-down list appears and the selected folder appears as 
the last item in the Path: Click it. 

The folder opens and its name appears at the top of the Folder 
and File list. The available contents of the open folder appear 
beneath its name. 

To close a folder (All Levels) 

1. At the very top of Folder and File list, locate the open folder. If 
necessary, use the scroll bar to see the top of the list. 

2. Double-dick the name of the open folder. 

or 

Click the Path button to display its drop-down list. From this list, 
click the name of the folder above the folder you want to close. 

The open folder closes and the folder above it becomes the 
current folder. Its name appears at the top of the File and Folder 
list. 

To move directly to your DOCUMENT folder (All Levels) 

• Click the Go To Document button. The DOCUMENT folder 
appears at the top of the Folder and File list. Its available 
contents appear beneath its name in this list. 

To change to another drive (All Levels) 

1 . Click the Drives button to display its drop-down list. The list 
shows all the disk drives available on your computer. 

Drives are labeled with letters, such as Drive A or Drive C, and 
names. The letters A and B typically represent floppy disk drives. 
Hard disks, hard disk partitions, and other disk devices appear 
with other letters, usually starting with the letter C and 
proceeding through the alphabet. 

2. From this list select the drive that you want to access. 

The contents of the disk appear in the Folder and File list. 

To move to another folder in the path (All Levels) 

1. Click the Path button to display its drop-down list. A list of 
folders appears. 

2. Click the name of the folder you want to access. The path list 
closes and the name of the selected folder appears at the top of 
the Folder and File list; its contents appear beneath it. 



PRINTING DOCUMENTS 

ALL LEVELS Typically, you print documents from within an application by 
choosing Print from the File menu. This section explains many 
common printing features and functions. However, the specific 
printing options you see will depend on the application and 
printer you're using. 

Printing With Standard Settings 

The Print dialog box comes with standard settings that work well 
to print most documents. The standard settings assume you want 
to print one copy of an entire document on 8.5" by 11" paper. If 
the standard settings do not meet your needs, see "Printing With 
Customized Settings" in this chapter. If you are using a color 
printer, you may also want to review "Tips for Users of Color 
Printers" in this section. 

To print a document with standard settings (All Levels) 

1. Choose Print from the File menu. The Print dialog box appears. 

2. Click the Print button at the bottom of the dialog box. A message 
appears informing you that your document is printing. The 
document prints with the standard settings. 

Printing With Customized Settings 

The Print dialog box allows you to set various printing options 
before you print a document. The available settings vary by 
application and by printer. Following is a typical Print dialog box 
with some common options: 

The Print dialog box is typically divided into two sections: Printer 
Options and Document Options. Depending on your application 
and printer, your Print dialog box may also have other sections. 



When printing on a 
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•Printer Options. Includes items such as the selected printer, 
paper width and height, paper source, and advanced printer 
options. 

• Document Options. Includes items such as print quality and 
number of copies. 

CHANGING DOCUMENT OPTIONS 

The following procedure explains how to change the most 
common Document Options. The printer and application you 're 
using determine which of these options are available to you. 

To change Document Options (All Levels) 

1. Choose Print from the File menu The Print dialog box appears. 

2 . Fill in the dialog box, selecting from the Document Options 
section as follows: 

Print QualHuc 

Print Quality. Click the radio button that represents the print 
quality you want to use. High quality produces the most 
professional looking documents, but it takes longer to print than 
if you use low quality. Low quality prints much more quickly but 
produces draft quality documents. Typically, you would want to 
print at low quality when you are working on drafts and printing 
speed is important. Select high quality to print final documents. 

Tex t Only. Text Only is the fastest way to print a draft because it 
uses an approximation of the fonts you see on screen and does 
not print any graphic images. Select the Text Only option if you 
want to get a printout of a document quickly. 

Number of Copies. If you want to print more than one copy, 
change the number of copies by clicking the arrow buttons or 
typing a number in the Number of Copies box. 

Collate. If you are printing multiple copies and you want them 
collated, check collate. When you collate copies of a document, 
one copy of the entire document is printed before the second 
copy is printed. Collating a document may require more time 
than not collating it. If you do not collate multiple copies, all 
copies of page 1 print before all copies of page 2, and so on. 

3. Click Print if you're ready to print the document with the new 
settings. If you want to change Printer Options before you print, 



see "Changing Printer Options" in this chapter. If your Print 
dialog box includes other options, see the chapters for the 
application you're using. 

CHANGING PRINTER OPTIONS 

You are not likely to need to change Printer Options very often. 
Typically, you only change Printer Options, including size, type, 
and layout, if you change the paper in your printer. 

The printer options must always reflect the actual physical setup of 
your printer. That is, regardless of the size of your document, if 
your printer is set up with 8.5'' by 11 11 paper, the paper size in 
Printer Options must be 8.5 11 by 11 11

• You can use the Page Size 
from the File menu to specify the size of your spreadsheet. 

The four following procedures explain how to print to a different 
printer, change paper options, change the paper source, and 
print to a file . As long as you understand these procedures, you 
can change these options if necessary. You should, however, 
consult with your computer system manager if you need to 
change printer options you do not understand. 

To print to a different printer (All Levels) 

1. Choose Print from the File menu The Print dialog box appears. 

2. In the Printer Options section of the dialog box, locate the 
Printer option. Make sure the printer you want to use is selected. 
If it is not, use the drop-down list to select it. 

You need to have previously added this printer to your list using 
Preferences. For more information an Preferences, see Appendix 
A. 

3. Click Print if you're ready to print the document to the current 
printer. If you want to change paper options, change the paper 
source, or print to a file , see the following procedures. If your 
Print dialog box includes other options, see the chapters that 
describe the particular application you're using. 

To change paper options (All Levels) 

1. Choose Print from the File menu The Print dialog box appears. 
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2. Make sure the printer you want to use is selected. If it is not, use 
the drop-down list to select it. 

3. Click the Options button that is below and to the right of the 
printer selection. The Options dialog box appears. It will look 
similar to the following, though it will vary depending on the 
printer you selected: 

Use these options to change the configuration of uour 
printer. These will not affect the tauuut of uour document. 

Type of Paper in Printer: + PaP-e Envelope 

Size of Paper in Printer: 

Print To: +Printer v file 

Paper Source: 

4. Fill in the dialog box, changing the options you want, as follows: 

Ty p e of Paper. Change the paper type if it is incorrect. 

Size of Paper. If the selected paper size is not the size of the 
paper in your printer, select the correct size from the paper size 
list. 

Width and Height. If you want to use a custom paper size that is 
not included in the paper size list, use the Width and Height 
value selectors to enter the width and height of the paper you 
want to use. 

Paper Feed. Select either portrait or landscape paper feed, 
depending on the direction of the paper in the paper tray - not 
the layout that you have selected in the application. (In other 
words, if you set up your document with a landscape orientation, 
you do not need to alter the Paper Feed option; this option 
should only be changed if the paper feeds into the printer in an 
unusual manner.) Portrait layout is a page printed so that, as you 
read it , the width of the page is less than its height. A horizontal 
layout is called landscape. 

5. Click OK if you want the changes you've made to remain in 
effect for the current session. 



or 

Click Save Options and then click OK if you want the changes to 
remain in effect every time you print on this printer from now 
on. You can, of course, return to the Options dialog box 
whenever you want and change any of these options again. 

You return to the Print dialog box. 

6. Click Print if you're ready to print the document with the new 
settings. If you want to print to a file or change the paper source, 
see the following procedure. If your Print dialog box includes 
other options, see the chapters that describe the particular 
application you're using. 

NOTE 

You should only change the printer settings in the Options dialog box 
when they do not match the physical settings on your printer. 

To change the paper source (All Levels) 

You can also use Printer Options to change more advanced 
options, such as printing to a file and changing the paper source. 
If you want to change other advanced options, consult your 
computer system manager. 

1. Choose Print from the File menu. The Print dialog box appears . 



With some printers, 
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2. Make sure the printer you want to use is selected. If it is not, use 
the drop-down list to select it. 

3. Click the Options button that is below and to the right of the 
Printer selection. The Options dialog box appears. It will look 
similar to the following , though it will vary depending on the 
printer you selected: 

Type: 

Size: 

Timeout (sec): 

Print To: 

Symbol Set: 

I 

Select the paper source from 
the drop-down list. 

4. Use the Paper Source drop-down list to select the location of the 
paper you want to use. The available options depend on the 
printer you 're using. 

5. Click OK if you want the change you've made to remain in effect 
for the current session. 

or 

Click Save Options and then click OK if you want the change to 
remain in effect every time you print on this printer from now 
on. You can, of course, return to the Options dialog box 
whenever you want and change the paper source again. 

You return to the Print dialog box. 

5. Click Print if you 're ready to print the document with the new 
settings. If you want to print to a file, see the following 
procedure. If your Print dialog box includes other options, see 
the chapters that describe the particular application you 're using. 

To print to a file (All Levels) 

Printing a document to a file creates a DOS file with all of the 
information that would have been sent to the printer, including 



all printer and graphic codes. This is especially useful when you 
want to have a document printed by a service bureau, such as 
when you want to create a PostScript file for a high-resolution 
phototypesetter. Printing to a file usually creates an extremely 
large file unless you're printing a PostScript file or are printing 
with the Text Only setting. One page of a complicated document 
can require over one megabyte of disk space. Make sure you 
have sufficient space before you print a document to a file. 

1. Choose Print from the File menu. The Print dialog box appears. 

2. Make sure the printer for which you want to create a file is 
selected. If it is not, use the drop-down list to select it. 

You need to have previously added this printer to your list using 
Preferences. For instance, if you want to create a file for a 
PostScript printer, you will need to first install a Postscript printer 
selection using Preferences even if you don't have that printer 
physically attached to your computer. For more information on 
Preferences, see Appendix A. 

3. Click the Options button that is below and to the right of the 
Printer selection. The Options dialog box appears. 

4. Click the Print to: File radio button. A black dot appears in the 
middle of the File radio button. 

Print To: Fie 

Select to print to a printer or file. 

5. Click OK if you want the change you've made to remain in effect 
for the current session. 

or 

Click Save Options and then Click OK if you want the change to 
remain in effect every time you print on this printer from now 
on. You can, of course, return to the Options dialog box 
whenever you want and change printing to a printer again. 

You return to the Print dialog box. 



When the Print to 
File option is set, the 
Print button 
becomes Print to File 
to remind you of the 
change. 

6. Click the Print to File button at the bottom of the Print dialog 
box. The Print to File dialog box appears: 

Enter DOS file name here. 

7. Use the file selector to select the folder where you want to store 
your file. For more information, see "Working with Standard File 
Selectors" in this chapter. 

8. Type the name of the file in the text entry box. You must use a 
DOS file name. For more information, see "Naming a DOS File" 
in this chapter. 

9. Click Print to File. A message appears informing you that your 
document is being printed to a file. You then return to your 
document. 

TIPS FOR USERS OF COLOR PRINTERS 

None of the applications in this manual support color printing, 
although other GEOS applications do, which is why all the color 
printing options are preserved. If you have a color printer that 
you are using with Ensemble, and you have configured it to print 
in color using Preferences, you may want to install the black and 
white printer selection for that printer using Preferences. 

You can tell that a printer is configured for color by looking at 
the name that appears on the Printer drop-down list in the Printer 
Options section of the Print dialog box. If it has the word "color" 
in parentheses at the end of its name, then it is it is a color 
printer configured to print in color. If it has "b/ w" in parentheses, 
then it is a color printer configured to print in black and white. If 
it has neither, then it is not recognized as a color printer. 

You can set up both the b/ w and color versions of the printer 
selection and simply choose which one you want from the pop
down list. When printing black and white documents , it is much 
faster to use the b/ w version of the printer selection. 

For more information on selecting and installing printers, see 
Appendix A. 



Checking and Canceling Printing Documents 

If you want to check the list of your print jobs or cancel a print 
job, choose Printer Control Panel from the Express menu. 

Ensemble keeps track of all the requests you make to print 
documents in a list called the print queue. Documents that you 
send to the printer are called jobs. You can send any number of 
jobs to a printer as you like. You do not need to wait for one job 
to finish printing before you send another. As soon as the printer 
assigned to you by your computer system manager is finished 
printing one document, it starts printing the next document in 
the list. 

You can easily check the status of files in the print queue. To see 
a list of files being sent to a local printer(one that is directly 
connected to your workstation by a cable) , use the Printer 
Control Panel. To see a list of files being sent to a network printer 
(one that is shared by many users across a network) , use the 
software supplied with the network. 

NOTE 

When a file is sent to a network printer, it briefly appears in the local 
print queue while it is being t ransferred to the network print queue. 
When checking the print status of a document, you may want to look 
in both queues. 

To see the print queue for your local printer 

• Choose Printer Control Panel from the Express menu. The Printer 
Control Panel list appears: 

To move a document to the front of the local print queue 

1. Choose Printer Control Panel from the Express menu. The Printer 
Control Panel list appears. 

2. Select the document you want to print after any documents that 
are currently printing. 



3. Click Make ext. The document you selected moves up the list 
to the next available spot. 

To move a document to the end of the local print queue 

1. Choose Printer Control Panel from the Express menu. The Printer 
Control Panel list appears. 

2. Select the document you want to print after all others. 

3. Click Make Last. The document you selected moves to the end of 
the list. 

To remove a document from the local print queue 

1. Choose Printer Control Panel from the Express menu . The Printer 
Control Panel list appears. 

2. Select the document you want to remove. 

3. Click Cancel Document. If it is not already printing, the 
document you selected is removed from the list. 

BACKING UP AND RESTORING DOCUMENTS 

LEVELS 2- 3 To back up a document means to make a quick copy of the 
document in its current state. When you restore a document, you 
replace the current document with its most recent backup. 

You can make backup copies of documents by hand, using the 
Copy function GeoManager, for instance, but it is much easier to 
use the backup features found on the Backup submenu of the 
File menu. 

Backing up is like freezing a copy of a document in time. When 
you save a document, any changes you've made are saved to 
disk, but the changes are only saved to the current version, not 
to the backup copy. This way, if you restore from a backup copy, 
the document reverts to exactly as it was when you backed it up , 
even if you have saved your document many times between now 
and when you last backed it up. 

BACKING UP A DOCUMENT 

Backing up is particularly useful if you are about to make a 
significant change to a document. It lets you keeps a copy of the 
current version to protect you if you regret the change. The 
backup feature makes a copy of the current version of a 



document and keeps it in a special location on the network 
server. Each backup you save replaces your most recent backup. 

To back up a document (Levels 2-3) 

Each time you select Make Backup, you create a backup of the 
current version of the document, which overwrites the previous 
backup. 

1. Choose Backup from the File menu. The Backup submenu 
appears. 

2. Choose Make Backup. A message appears, indicating a copy is 
being made. This message disappears as soon as the backup is 
completed. 

RESTORING FROM A BACKUP 

Restore from Backup recovers the most recent backup copy of a 
document created by using Backup. This choice is only available 
if you have created a backup by choosing Backup from the File 
menu. When you restore from a backup, the previously backed 
up version of the document ove1writes the current version of the 
document. Use Restore from Backup if you want to revert to the 
previously backed up version. 

When you restore a backup, it replaces your current document, 
so be sure this is what you want to do. 

To restore from a backup (Levels 2-3) 

1. If it's not already open, open the document you want to restore 
to its most recently backed up version. 

2. Choose Backup from the File menu. The Backup submenu 
appears. 

3. Choose Restore From Backup. A confirmation message appears . 

4. Click Yes. The most recent backup appears in the document 
window. 

NOTE 

You may still be able to recover a backup even if all original copies of 
the document have been destroyed. Backup copies of your documents 

are stored in the special folder 

\GEOWORKS\USERDATA\BACKUPS. 



IMPORTING AND EXPORTING 

LEVELS 2-3 

Available in GeoDex 
and Scrapbook. 

You can import and export information to and from other 
applications. For example , you can create an address file in 
GeoDex and export it for use in dBASE or any other application 
which can use dBASE files, or you can import a WordPerfect file 
into Scrapbook for saving as a scrap. 

GeoDex can import and export the following database, 
spreadsheet, and address book formats: 

• dBASE 

• Lotus 123 

• Comma delimited entries 

Scrapbook can import the following word processing formats: 

• ASCII 

• DisplayWrite 

• HebrewWrite 

• Lotus 1-2-3 as text 

• Microsoft Word (DOS version) 

• Multimate 

• RTF (Rich Text Format) 

• Signature 

• Word Perfect 

• Wordstar 

• XyWrite 

Additionally, Scrapbook can import the following graphic bitmap 
formats: 

• BMP 

• CLP 

• GIF 

• PCX 

• TIFF 

For more information on importing and exporting address book 
and database and spreadsheet formats with GeoDex, see 
"Importing and Exporting Address Books" in Chapter 5. For more 
information on importing word processing and graphic formats 
with Scrapbook, see "Working with Scraps" in Chapter 7. 



MANAGING DOCUMENTS 

LEVELS 2-3 Once you begin accumulating documents, you may find that you 
need to do a little housekeeping. You may want to change the 
name of a document, or you may want to set your own 
specifications for a document. This section describes how to 
manage your documents using various choices found on the 
Other submenu of the File menu. The Other submenu lets you 
do the following: 

• Copy a document 

• Export a document 

• Discard changes in a document 

• Rename a document 

• Edit document notes 

• Set the document password 

• Set the document type 

• Set the startup document 

Export is briefly described in "Importing and Exporting" in this 
chapter and in detail in the chapters of applications with 
importing and exporting capabilities. 



LEVELS 2-3 

Using Copy To 

When you use Copy To, you create a copy of the current version 
of a document and give it a new name. The document with the 
new name is saved to disk and you are left editing the original. 
This is in contrast to Save As, which saves all of your changes to 
the document with a new name and closes the original document 
without saving any changes to it. The following table summarizes 
the difference between Save As and Copy To: 

I FEATURE 1 COPY TO r SAVE AS 

Saves changes to a yes yes 
document using a new 
name. 

Reverts the original no yes 
document to its last 
saved version. 

Leaves you editing the 

I 
no 

I 

yes 

I copy. 

Leaves you editing the 

I 
yes no 

I original. 

Copy To can be used for several purposes: 

• If you are writing a report and want to keep progressive copies 
so that you can revert to an earlier one if you need to, use 
Copy To. You could save the report at 8 am and name it 
REPORT 8 AM. Then you could use Copy To to save a copy of 
the report every two hours, naming the first copy REPORT 10 
AM, the second one REPORT 12 PM, and so on. Using the Copy 
To function , you continue editing the original version 
whenever you make a copy. But you also have the option of 
reverting to an earlier version if you want to. 

• If you are drawing a greeting card that you want to personalize, 
use Copy To. For example, you could make one standard card, 
personalize it for Ellen, and then save it. A copy of Ellen's card 
is saved and you continue to work on it. Personalize the 
original card for Ann and then use Copy To. This saves Ann's 
card. You can continue this process indefinitely, until you have 
personalized all your cards without fear of losing any of them. 



• If you are working on a document and want to give a copy to a 
friend. You use Copy To to place a copy on a network server 
for your friend to use, or you could place a copy on a floppy 
disk and give the disk to your friend. 

To copy a document using Copy To (Levels 2-3) 

When you copy a document, the standard file selector appears. 
The following procedure explains the easiest way to use the 
standard file selector controls to save a copy of a document in 
your DOCUMENT folder. If you want to copy the document 
somewhere else , see "Working with Standard File Selectors" in 
this chapter. 

1 . Choose Other from the File menu. The Other submenu appears. 

2. Choose Copy To. The copy file selector appears with the name of 
the document in the ew Name text entry box. 

The illustration below shows a typical example of a copy file 
selector: 

DOCUMENT 

Type the new name here. 

3. Make sure the DOCUMENT folder is highlighted. If it isn't, click 
the Go To Document button. This copies the document to your 
DOCUMENT folder. 

4. Type the name you want to use for the copy. You can use 
Backspace or Delete to edit the name. The new name appears 
in the text entry box. 

5. Click Copy To to make a copy of the document using its new 
name. The document with the new name is saved and closed, 
and the document with the original name remains in the 
document window. 



LEVEL 3 

If Discard Changes is 
dimmed, y ou have 
made no changes 
since the last time 
you saved. 

LEVELS 2-3 

Discarding Changes 

Occasionally, you may make changes to your document that you 
do not like. Use Discard Changes on the File menu to undo 
changes you want you hadn't made. Discard changes restores a 
document to its last saved version, eliminating any changes 
you 've made since you last saved it. 

You can put this feature to good work when you want to 
experiment. For example, if you want to rearrange your address 
book, you can save it before you begin the experiment, then if 
you don't like what you 've done to the information, you can use 
Discard Changes to go back to the original. 

To discard changes (Level 3) 

1 . Choose Other from the File menu. The Other submenu appears. 

2. Choose Discard Changes. A dialog box appears asking you if 
you're sure you want to discard all the changes you have made 
to the document since you last saved it. 

3. Click Yes, and the last saved version appears in the window. All 
changes since then are erased permanently. 

Renaming a Document 

When you rename a document, you change its name. You may 
want to rename a document so that its name more closely 
identifies its contents or purpose. You may also want to rename a 
document if you want to use its original name for another 
document. You cannot rename an untitled document. You must 
first save the document and give it a name. 

If the Rename choice is dimmed, either you have not yet saved 
the document or it is a read-only document. For more 
information about read-only documents , see "Setting the 
Document Type" in this chapter. 

To rename a document (Levels 2-3) 

1 . Choose Other from the File menu. The Other submenu appears. 

2. Choose Rename Document. The Rename Document dialog box 
appears with the document's current name in the New Name text 
entry box. 



LEVELS 2-3 

3. Type the new document name. You can use Backspace or 
Delete to edit the name. The new name appears in the New 
Name text entry box. 

Type the new document name here. 

4. Click the Rename button. The dialog box closes and the new 
name appears in the title bar. 

Editing Document Notes 

You can add document notes to any GEOS document. Document 
notes consist of information you might want to record about your 
document that you think is important to remember. For example, 
you can use document notes to keep a revision history of a 
document. If someone else modifies the document, they can read 
your notes and add their own. 

Notes accompany a document, but they are not an integral part 
of the body of the document. You can see a document's notes in 
the file selector box whenever you open an existing document. 
You cannot add document notes to DOS data files , including 
DOS text files edited with Text File Editor. 

You cannot add document notes to an untitled document. You 
must first save the document and give it a name. 

To create, view, or edit document notes (Levels 2-3) 

1. Choose Other from the File menu. The Other submenu appears. 

2. Choose Edit Document otes. A dialog box appears: 

Type or edit document notes here. 



LEVEL 3 

Make sure you 
remember the 
document 's 
password. You 
cannot open the 
document without it. 

3. Type your new document notes or edit the existing ones. Notes 
can be up to 100 characters long. Then click Set Document 
Notes. 

or 

If you are just viewing the document notes, click Cancel when 
you are done. 

The dialog box closes and you return to the document. 

Setting and Removing a Document Password 

A document may contain personal information that you want to 
prevent others from viewing by giving it a password. For 
example, you can keep your GeoDex address book private by 
setting a password. If you give a document a password, anyone 
who tries to open the document must first enter its password. A 
document password can contain up to 32 characters. 

You cannot set a password for an untitled document. You must 
first save the document and give it a name. 

To add or change a document password (Levels 3) 

1. Choose Other from the File menu. The Other submenu appears. 

2. Choose Set Document Password. A dialog box appears. 

Type password here. 

3. Type the password you want to use for the document. The 
password you type is case-sensitive and space characters and 
punctuation count. For example, the password "Legion Pier" 
would be different from the password "legion pier", as would the 
password "Legion-Pier! 

4. Click Change Password. A confirmation message appears. 

5. Click Yes to confirm that you want to add a password to protect 
the document. Once the password is added, the document 
cannot be opened without entering its password. The dialog box 
closes and you return to the document. 



LEVEL 3 

The next time you open the document, you will be asked to 
enter the password. If you do not enter the password correctly, 
you cannot open the document. 

To remove a password (Levels 3) 

1. Open a password-protected document. You must use the correct 
password to open the document. 

2. Choose Other from the File menu. The Other submenu appears. 

3. Choose Set Document Password. A dialog box appears, with no 
password shown. 

4. Without making any change to the blank Password box, click 
Change Password. The password is removed from the document. 
The dialog box closes and you return to the document. From 
now on, you do not have to enter a password to open this 
document. 

Setting t he Startup Document 

GeoDex, GeoPlanner, and Scrapbook have startup documents 
that are opened automatically when you start the application. 
Normally in GeoDex the startup document is called "First Address 
Book"; in GeoPlanner it is called "My Schedule"; and in 
Scrapbook it is called "Default Scrapbook." If you want, you can 
set a document with a different name to be the startup 
document. 

To change the startup document (Level 3) 

1. Open the document you want to make the startup document. 

2 . Choose Other from the File menu. A submenu appears. 

3. Choose Empty Document from the Other submenu. Another 
submenu appears. 

4. Choose Set Startup Document from the Empty Document 
submenu. A confirmation message appears. 

5. Click Yes. The next time you start this application, the document 
you set as the startup document will open automatically. 

To again use the original startup document (Level 3) 

1. In any open document, choose Other from the File menu. A 
submenu appears. 

2. Choose Empty Document from the Other submenu. Another 
submenu appears. 
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3. Choose Reset Startup Document from the Empty Document 
submenu. A confirmation message appears. 

4. Click Yes. The startup document is reset to its default. 

Setting the Document Type 

Document type refers to the type of access that you give a 
document. For example, you can specify whether a document 
can be edited or is read-only. A read-only document is a one that 
can be viewed but not edited. Document types includes the 
following: 

• Normal. The document can be viewed and edited. The For 
Editing option in the Open file selector is checked by default. 
Normal documents are, therefore, routinely opened for editing. 
You can open a Normal document read-only by deselecting the 
For Editing choice in the Open file selector. 

• Read-Only. The document can be viewed but not edited. The 
For Editing option in the Open file selector is dimmed and 
cannot be selected. You can set a document read-only when 
you don't want yourself or others to accidentally edit it. The 
only way to edit a read-only document is to deselect the Read
Only option by choosing Attributes from the object's pop-up 
menu on the desktop. For more information on file attributes, 
see Chapter 3. 

• Public. The document can be viewed and edited. However, a 
public document is not normally opened for editing because 
the For Editing option in the Open file selector is unchecked by 
default. If you want to edit a public document, you must open 
the document from within the application by choosing 
New/ Open from the File menu and then clicking the Open 
button. After selecting the document in the Open file selector, 
you must select the For Editing option if you want to edit the 
document. Setting the type of a document to Public is useful, 
for instance, if you want to place a copy of a document on a 
network server for others to view and edit, but you want to 
minimize the chances of anybody editing it accidentally. A 
public document also has the advantage of allowing one 
person to open it for editing while others are viewing it. 

To change a document type (Level 3) 

1. Choose Other from the File menu. The Other submenu appears. 



ff the For Editing 
option is dimmed, 
then this document 
cannot be edited. 

2. Choose Set Document Type. A dialog box appears: 

3. Select the radio button that describes the document type you 
want to use for this document. 

4. Click Change Type. The document is immediately changed to the 
document type you selected, the dialog box closes, and you 
return to the document. 

To use the For Editing option in the Open dialog box (Level 3) 

At the highest user level of an application, w hen you select a 
document to open, a For Editing option appears below the file 
list in the file selector dialog box. The status of the For Editing 
option changes depending on the type of document selected. 

1. In the folders and files list, select the name of a document. The 
For Editing option becomes checked or unchecked depending 
on the type of document you selected. 

2. Click to change the For Editing option if you want. When 
checked, you can edit the original document. When unchecked, 
any changes you make will not be saved to the original 
document, but must be saved to a document with a different 
name. 

For more information using the For Editing option with the Open 
feature , see "Opening an Existing Document" in this chapter. 





CHAPTER 3 

Geo Manager You can use GeoManager to perform all your file 

and disk management tasks just by pointing and clicking your 

mouse , without having to understand how to use cryptic DOS 

commands. GeoManager shows files as icons (small pictures). 

Instead of typing commands, you use these icons to open files 

and perform management tasks. For instance , you can move a 

file simply by dragging its icon to its new location. 



This chapter shows you the various ways you can use 
GeoManager to help you with file management. File management 
tasks include moving and copying a file or folder, printing a file , 
and removing and recovering a file or folder. If you are using a 
mouse, you can accomplish many of these tasks by simply 
selecting a file or folder and dragging it. 

This chapter provides step-by-step procedures for accomplishing 
these tasks, as well as the following: 

• Starting applications and opening documents 

• Creating folders 

• Viewing information about files and folders 

• Changing file and folder attributes 

• Formatting, naming, and copying whole diskettes 

• Renaming fixed disks 

GeoManager has no user levels. 

THE GEOMANAGER WINDOW 

GeoManager starts automatically as soon as you start Ensemble. 
Normally, you do not need to exit GeoManager. If you do exit 
GeoManager, however, choose Go To GeoManager from the 
Express menu to start it up again. 
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The GeoManager window tells you much about the folder you're 
in and what it contains. It also gives you ways to quickly access 
other folders and disks. The GeoManager window consists of 
three separate areas: 

• Information bar. The information bar displays the folder path 
name, the number of files and folders currently appearing in 
the folder window, the amount of disk space in bytes 
(characters) used by the files shown, and the amount of space 
remaining on the disk containing the folder. 

• Folder Window. This area shows the contents of the currently 
opened folder. (The name and path of the folder appears in the 
Information Bar.) You can choose to have this area show more 
than one folder at a time; see "Working With Multiple Folders" 
later in this chapter. 

• Tool Area. These buttons give you easy access to disk drives, 
special folders, and common operations. 

Each of these areas are described below. 

THE FOLDER WIND OW 

Folders store things you work with, such as documents, 
applications, and other folders. When you use a standard office 
filing cabinet, you use manila folders to organize your documents 
within it. On your hard disk, you use folders for the same 
purpose, organizing your documents and files. 

The folder window shows the contents of the currently opened 
folder. The small pictures are called icons, and represent items 
you can work with in GeoManager - such as documents and 
folders. When you want to perform tasks with a document or 
folder, you take some action with its icon. For instance, to open 
a folder, you double-dick its icon. 

There are several kinds of icons that appear in the window: 

GEOS Application Icons . These represent GEOS applications. 
(The icon for GeoDex is shown at left.) You can double-dick a 
GEOS application icon to start the application. For more about 
doing this, see Chapter 1. 

DOS Application Icons . Icons like this represent DOS 
executables-that is, DOS applications that you can run. These 
files usually encl in .EXE, .BAT, or .COM. You can double-dick a 
DOS application icon to run it. See "Launching a DOS application 
or Batch File" in this chapter. 

GEOS Document Icons. Each type of GEOS document has a 
unique icon. This icon usually contains the icon of the 
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application used to create the document. If you double-dick the 
icon, the application starts and automatically opens the 
document. 

DOS File Ico ns. This icon indicates that the file was created 
using a DOS application. Note that if the file name ends in .EXE, 
.BAT, or .COM, it appears in GeoManager as a DOS application 
icon. 

Folder Icons. Folder icons in the folder window represent 
directories on your disk drives. The terms "folder" and "directory" 
are often used interchangeably, in much the same way that "file" 
and "document" often are. 

DOS users should note that although folders correspond to DOS 
directories, their names do not have to conform to the DOS 
naming standard-folder names can be as long as 32 characters, 
and contain upper and lower case letters. 

THE TOOL AREA 

The Tool Area contains buttons that you can use to easily work 
with special Ensemble folders , as well as quickly change the way 
folder windows are presented within the Geo Manager window. 

Wastebasket button 

Full-Sized and Overlapping 
buttons Disk drive buttons 

WORLD folder button, DOCUMENT 
folder button, and DOSROOM folder 
button 

In the Tool Area are the following buttons: 

Wastebasket. Click this to see the contents of the Wastebasket. 
You can also drag folders and files onto this button to throw 
them away. 

Full-Sized and Overlapping Windows. These buttons control 
the number of folders that you can view at the same time. When 
Full-Sized is selected, you can only see one folder at a time. 
When Overlapping is selected, you can view several different 
folder windows at the same time, and drag icons from one to the 
other. 

WORLD, DOCUMENT, and DOSROOM folders. Click these to 
open their respective folders . You can also copy and move 



documents and folders to these folders by dragging the icons 
onto the appropriate button. 

Disk drive buttons. Every disk drive available on your computer 
is represented by a button. A floppy disk button appears for each 
floppy disk drive attached to your computer and a hard disk 
button appears for each hard disk. Additional buttons appear if 
you have a RAM disk, ROM disk, or other type of disk device 
(such as a network drive) available to your computer. Clicking a 
button opens the root folder of the corresponding drive; 
similarly, dragging document and folder icons onto a button 
copies the items to the root folders of the drive. 

Disks are identified by a single letter (always followed by a 
colon). This letter appears on the button. Usually, "A: " and "B:" 
are the names of the floppy disk drives on your computer. "C: " 
and "D:" are usually hard disk drives. The rest of the letters are 
usually RAM drives, network drives, and other storage devices 
attached to your computer. 

THE INFORMATION BAR 

The Information Bar at the top of the folder window shows 
information about the folder, and the drive on which it's located. 

Open Parent Folder button 

DOS Path of folder 

Number of icons in the folder 

· ... c.(Unr-.ect1) \GeoWor1c:s\OOCUMEltT - 10 items (19,512 bgtes) of 10. 782,336 bytes free. 

Total size of icons 

Free space on drive 

Open Parent Folder button. Click this button to quickly open 
the folder that contains the current folder (its parent folder). 

Number of icons in the folder. This is the number of items 
contained in the folder. If you 've selected one or more icons, this 
changes to show how many icons are selected. 

Total size of icons. This is the total size of all the document 
icons in the folder. The amount is expressed in bytes, or 
characters. If you've selected one or more icons, the figure 
changes to show the total size of all the selected icons. Note that 
this total does not include the size of items contained within any 
folders in this folder. 



Free space on drive. This figure shows the amount of space 
remaining on the drive that contains this folder. 

DOS Path of folder. This shows all the folders you went 
through to reach the current folder. Reading from right to left, it 
starts with the current folder. It then shows the parent folder. 
Then the folder that contains that folder (the parent of the parent 
folder), and so on until it reaches the top folder (the root folder) 
of the drive. Backward slashes ("\ ") separate each folder name. 

Reading a path is a little like reading an address. For instance, if 
you have a file named "1 Elm Street" in the folder "Ourtown," 
which is in the folder "Arkansas," on the disk named "USA," the 
path name to "1 Elm Street" would read: 

USA \ Arkansas \ Ourtown \ 1 El m Street 

WORKING WITH DOCUMENT AND FOLDER ICONS 

•• 

The small pictures in the folder window are called icons. Icons 
represent items you can perform actions on, such as applications, 
documents, and folders. When you want to perform tasks with a 
document or folder, you take some action on its icon. 

Selecting Icons 

Before you can do something with a document or a folder, you 
must first select its icon. 

To select an icon 

Move the mouse pointer over the icon and click. The icon 
highlights to show that it is selected, like the icon at left. 



To select multiple icons by clicking 

1. Press and hold down the Ctrl key, and then click each icon you 
want to select, while still holding down the Ctrl key. Each icon 
you select is highlighted. 

GeoManager 
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Selected icons 

2. You can deselect (unhighlight) an icon by clicking it again while 
still holding down the Ctrl key. Other selected icons stay 
selected. 

3. Release the Ctrl key. The icons you have selected remain 
highlighted . 

At this point, you can press the Ctrl key again and continue to 
select and deselect as you like. As long as you press the Ctrl key, 
your selection will continue where you left off. 

To select multiple icons by dragging 

1. Move the mouse pointer slightly above and to one side of the 
icons you want to select, and then press and hold down the left 
mouse button. 

2. With the left mouse button held down, move the mouse down 
and across the icons until an outline box surrounds the icons you 
want to select: 

GeoDex 

.~~.r.~.~~.??.k. 

............. ~, 

~ I 
Solitaire ................................................. , 

Outline box 

3. Release the mouse button when the outline box completely 
surrounds the icons. The icons you select are highlighted. 
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At this point, you can press the Ctrl key and continue to select 
and deselect as you like. As long as you press the Ctrl key, your 
selection will continue where you left off. 

Dragging Icons 

You can move and copy files and folders by simply dragging the 
icons with the mouse and dropping them where you want them 
to go. For example, when you drag a document icon to the 
DOCUMENT button, a copy of the document is placed in your 
DOCUMENT folder. When you drag a document to a folder icon, 
the document is moved to that folder. 

To drag an icon 

With the mouse pointer over the icon you want to move, press 
the right mouse button and hold it down. A small outline appears 
on top of the icon. 

2. With the right mouse button still held down, drag the mouse to 
move the outline on the screen to the location you want. 

3. Release the mouse button. The icon appears in the new location. 

To drag multiple icons 

1. Select all the icons you want to drag. 

2. Move the mouse pointer directly over one of the highlighted 
icons, and then press and hold down the right mouse button. A 
small outline appears on top of the icon. 

3. With the right mouse button held down, drag the mouse so that 
the pointer on the screen moves the small outline to the location 
you want. Then, release the mouse button. All the icons appear 
in the new location. 

STARTING APPLICATIONS 

Starting applications and opening documents are discussed in 
detail in Chapter 1. 

Starting GEOS Applications 

GEOS applications start in a window. You can have several 
applications going at the same time, each with its own window. 



To start a GEOS application 

• Locate the icon representing the application you want to use and 
double-click it. The application starts. 

To start a GEOS application by opening a document 

• Locate the icon representing the document you want to use and 
double-click it. The corresponding application starts, and the 
document opens. 

Starting DOS Applications 

There are several ways you can start a DOS application from 
Ensemble. You can start the file by double-clicking the icon that 
represents the executable file of the DOS application (the 
executable usually has a .EXE, .BAT, or .COM extension). This 
can involve moving through many folders - sometimes a time
consuming process. Another way is to double-dick the launcher 
icon for the program. To do this, you must first create the 
launcher icon itself. Once you've done that, though, you can 
place the launcher icon in a readily accessible folder, like the 
DOSROOM folder. See "Creating a DOS Application Launcher, " 
below, for more information about DOS launcher icons. 

To start a DOS application using its launcher icon 

1. Double-dick the launcher icon (usually in the DOSROOM 
folder). Depending on the launcher's settings, you may have to 
respond to some dialog boxes. 

The GeoManager window temporarily closes and the DOS 
application or batch file launches. When you quit the DOS 
application or batch file , you may (depending on your launcher's 
settings) see a message that lets you return to Ensemble or go 
directly to DOS. When you return to Ensemble, you'll find 
everything just as you left it. 

To start a DOS application or batch file directly 

1 . Open the folder that contains the DOS application or batch file 
you want to launch. 

2 . Double-dick the file 's icon, or select the file and choose Open 
from the File menu. 

You can start a DOS application or batch file directly from 
GeoManager. GEOS temporarily shuts down while the DOS 
application or batch file runs. When you quit the DOS 



application, or the batch file finishes, GEOS starts up again 
automatically, exactly as it was before. 

Creating a DOS Application Launcher 

If you often use DOS applications or batch files, you will find it 
helpful to create launchers for them. A launcher is a custom icon 
that corresponds to the DOS program; when you double-dick the 
icon, GEOS shuts down and runs the program. 

Unlike the GEOS applications in the WORLD folder, DOS 
applications are rarely collected into one folder on a disk - each 
DOS application usually has its own, separate folder. A DOS 
application often will not work unless it remains in this folder, 
surrounded by other specific files. This means that most DOS 
applications are stuck in one place - you cannot collect them in 
the WORLD folder. When you want to start the application, you 
have to open folder after folder until you have located the 
program's icon. 

If you create a launcher for the application, however, you can 
place the launcher in the WORLD folder (or DOSROOM folder) 
where it's readily available. To start the DOS application, you 
simply open the WORLD folder and double-dick the launcher 
icon. 

To create a DOS application launcher 

1. Choose Create Launcher from the Utilities menu. A file selector 
appears. 

2 . Using the file selector, select the name of the executable file for 
the DOS application. The name of a DOS executable is usually 
the command you type (at the DOS prompt) to run the program, 
plus a .EXE, .BAT, or .COM file extension. 



3. Click Use This File. A dialog box appears: 

"~-------.....command line Options------~11 • 

+ tto Command line Options 
d !.sk For Options Each Time 

v ~ecify Options ttow 

Rsk Befor·e Returning? + Yes v tto 

Place launcher in: "t !!OSROOM Folder 

Y.se These Settings ] gptions ... 

4. Choose the icon you would like use for the launcher by clicking 
to select one of the icons in the Icon list. Use the scroll bar to see 
more icons in the list. 

5. Type the name that you want to appear under the icon in 
GeoManager. The default name is the name of the DOS 
executable file without its extension. The name can be as long as 
32 characters. 

6. Change these options if you would like to customize the 
launching process: 

Prompt for a single file? Some programs allow you to specify a 
file you'd like to open in the command line. Turn this option on 
if you would like to specify a file using a file selector. When the 
option is on, GEOS presents a file selector when you double
click the launcher icon. The path name for the file you select is 
placed on the command line along with the other options. 

No Command Line Options. This is the default setting. Click 
this if you want GEOS to run the DOS application without any 
command line options. 

Ask For Options Each Time. Click this radio button if you want 
GEOS to prompt you for command line options whenever you 
launch this DOS application. Also, when you click this button, 
the Options text field becomes available. If you want, you can 
type options in this text field. Text you type in this field appears 
in a dialog box whenever you start the application. You can 
change the command line options in the dialog box. 



Specify Options Now. Click this if you want GEOS to use the 
same command line options every time. When you click this 
button the Options text field becomes available. Type the options 
you would like in this field. 

Confirm Arguments Before Running. When on, a dialog box 
appears just before GeoManager starts the DOS application. All 
the command line options you have specified appear in the text 
field of this dialog box. You can check the options, and edit 
them if you like, before the command is carried out. When off, 
the dialog box does not appear. 

Ask Before Returning. When on, you are presented with a 
message after you exit the DOS application, asking if you want to 
return to GEOS. When off, no n1essage appears - you are 
returned immediately to GEOS as soon as you exit the DOS 
application. 

7. Select where you want the launcher icon to appear when you are 
finished. To put the icon in the WORLD folder, click the WORLD 
button. To put the icon in the DOSROOM folder, click the 
DOSROOM button. 

8. Click the Options button if you would like to further customize 
the launching process. A dialog box appears: 

Change the options to your liking. 

Starting Folder. Type the path of the folder where you would 
like the DOS application to save its files. If you type something 
here, your application will act as if you had started the 
application from this folder. For instance: C:\DOSFILES. 

File To Check. Type the path name of a file . GeoManager 
checks to make sure this file exists before attempting to run the 
application. This file is often a batch file (ending in the extension 
.BAT). This option is rarely needed. 

Second File To Check. Type the name of another DOS file . 
GeoManager checks to make sure this file exists before 
attempting to run the application. Typically, this file is an 
executable (ending in the extension .COM or .EXE) contained in 
the batch file mentioned above. This option is rarely needed. 



9. Click OK when done with the options. In the Create Launcher 
dialog box, click Use These Settings when you are satisfied with 
the current settings. The dialog box disappears and the DOS 
launcher icon appears in the folder you specified. 

To change a DOS launcher's settings 

1. Select the icon for the DOS launcher you want to change. 

2. Choose Edit Launcher from the Utilities menu. The DOS Launcher 
Settings dialog box appears . 

3. Change the settings to your liking. This dialog box is identical to 
the DOS Launcher Settings dialog box explained in "To create a 
DOS application launcher," above. 

4. Click Use These Settings when you are satisfied, or click Cancel 
to discard your changes. 

To remove a DOS application launcher 

• Drag the launcher icon to the Wastebasket. The launcher icon is 
moved to the Wastebasket, where it remains until you empty the 
Wastebasket. 

OPENING FOLDERS 

Note that the corresponding DOS application is not deleted. 

In GeoManager, folders look like little manila folders , like the 
one pictured at left. To see the contents of a folder, you open it 
so that the contents of the folder appear in a window. When you 
open a folder its name is added to the list of open folders in the 
Window menu. When you start Ensemble for the first time, 
GeoManager automatically opens the WORLD folder. 

The folder you are working with is called the current or active 
folder. The active window is the one with its title bar highlighted, 
and its name is selected in the Window menu. 

To open a folder 

• Double-click the folder's icon. 

or 

Select the folder's icon and choose Open from the File menu. 

The folder opens and its contents display in a window. (Its name 
is also added to the list of folders on the Window menu.) 



COMPRESSING THE FOLDER DISPLAY 

The Compress Display option changes the spacing of icons in the 
folder window. Turning it on will bring the icons closer together, 
so that more of them can fit in a window. Turning it off returns 
them to their normal spacing. 

To turn the Compress Display option on or off 

• Choose Compress Display from the View menu. If the option is 
off, this turns it on. If it 's on, this turns it off. 

SORTING THE CONTENTS OF FOLDERS 

In addition to being able to view size, type, and date information 
about files and folders, you can also sort the icons in the folder 
window. 

To sort the contents of folders 

1. Open a folder. 

2. Choose Sort By from the View menu. A submenu appears, listing 
a variety of sort options: 

Uiew 
v ttames Only 
v Names and ll,etails 
i+ Lcons 

~ort By 

_J Show H.idden Files 
_J kompr ess Display 

Sort By 

v !lOS Extension 
v !:1odification Date and Time 
v ~eation Date and Time 

v~ze 

v DOS Order 

I 

Choose one to sort the 
contents of the current fo lder 

The menu lets you sort the icons in different ways: 

Name. This sorts the contents of the folder alphabetically by the 
entire DOS name. 

DOS Extension. This sorts the contents of the folder 
alphabetically by the one-to-three letter suffix appearing after a 
period in the DOS name for the file or folder. 

Mod ification Date and Time. This sorts the contents of the 
folder by date and time of last modification in reverse 
chronological order. 

Creation Date and Time. This sorts by date and time of creation 
in reverse chronological order. 



Size. This sorts the contents of the folder in ascending size. 

DOS Order. This sorts the contents of the folder in the same 
order as in DOS. 

3. Choose a sort option. The contents of the folder appear in the 
new sort order. 

For example, here are the results of sorting by Date and Time: 

QID QID m QID 
l May 7 Report April 15 Report March 5 Report J an 1 0 report 

VIEWING FILES AND FOLDERS AS A U ST 

You can choose to view the contents of a folder as an 
alphabetized word list rather than as icons. Of the three options 
for switching between icons and lists, the highlighted option is 
the one currently in effect for the current folder. 

To change the current viewing option 

1. Open the folder you want to change. 

2. Choose the option you want from the View menu . Your choices 
are: 

Names Only Shows the contents of the folder as a list of very 
small icons with the name on the right (instead of below). This 
view is especially useful if you have a lot of files in a folder and 
want to see as many as possible without scrolling. 

Names and Details Also shows the contents of the folder as a 
list of small icons but with the name, size, modification date, and 
attributes to the right of the icons. Each file attribute is 
represented by a single letter: Read-Only (R), Hidden (H), System 



(S), and Archive (A). For more information about file attributes, 
see "Changing DOS File Attributes" earlier in this chapter. 

Icons The standard option. Shows the contents of the folder as 
file or folder icons, with the name below the icon. 

For example, this is what a folder looks like when you've set the 
view to with Names and Details: 

lfil May 7 Report 
lfil April 15 Report 
lfil March 5 Report 
rn Jan 1 0 report 

SHOWING HIDDEN FILES 

6 ,440 11 :30 :52 PM 04/22 / 93 
6 ,440 11 :30 :34 PM 04/22 / 93 
6 ,440 11 :30 :16 PM 04 /22 / 93 A 
6,760 11 :29 :54 PM 04 /22 /93 A 

Files with their Hidden or System attribute set do not 
automatically appear in the folder window. To see these files, 
and have them included in the file size count at the top of the 
window, you must first turn on the Show Hidden Files option. 
When the Show Hidden Files option is turned off, these files 
disappear again. 

To turn the Show Hidden Files option on or off 

• Choose Show Hidden Files from the View menu. The option 
turns on or off. 

Opening the WORLD, DOCUMENT, and DOSROOM 
Folders 

Ensemble has three special folders: WORLD, DOCUMENT, and 
DOSROOM. The WORLD folder contains GEOS applications, the 
DOCUME T folder contains documents (data files created with 
GEOS applications), and the DOSROOM folder contains DOS 
application launchers. 



DOSROOM folder 

I DOCUMENT folder 

WORLD folder 

To open the WORLD, DOCUMENT, or DOSROOM folders 

• Click either the WORLD folder button, the DOCUMENT folder, or 
the DOSROOM folder button at the bottom of the GeoManager 
window. The appropriate folder opens and its contents display in 
the window. 

Opening a Parent Folder 

You can open the parent folder of the current folder by clicking 
the Parent Folder button on the Information Bar. A parent folder 
is the folder that contains the current folder. When you move up 
as far as the root folder, the Parent Folder button dims to indicate 
that the current folder has no parent. 

To open the parent folder 

• Click the Parent Folder button at the left end of the Information 
Bar. The parent folder opens, becoming the current folder. 

Opening a Folder on Another Disk 

You can open folders on another disk by clicking the appropriate 
drive button. 

To open a folder on another disk 

1. If the other disk is a floppy disk, insert the floppy in a floppy 
disk drive. 

2. In the Tool Area, click the drive button for the floppy disk, hard 
disk, or device you want to view. 

GeoManager opens the root folder (main folder) of the disk. 

Opening Your BACKUP Folder 

Whenever you use the Make Backup function in an application, 
the backup document is saved into the BACKUP folder. If you 
need to open a backup document directly, you do so by double
clicking the document's icon in this folder. 



To open the BACKUP folder 

• Choose Go to Backup from the Utilities menu. 

WORKING WITH MULTIPLE FOLDERS 

Initially, you view folders one at a time in the GeoManager 
window. Each folder you open fills the window, covering up any 
folder that previously appeared there. There is a way, however, 
to view many folders simultaneously as smaller, overlapping 
windows. You can then move and resize these windows to your 
liking. It's also easier to move files when you have overlapping 
windows. (See "Moving and Copying Files and Folders" later in 
this chapter.) 

IJ 0 
Calculator 

Ga ~ 
Clock Geo Banner 

~~ 
G•oCalc GeoComm 

G:J y 
GeoDex GeoDr-aw 

§ [[J] 
GeoPlanner-

The names of all open folders appear in the Window menu. You 
can use this menu to switch between one folder and another. 
You can also set the display of the folders to Full-Sized, 
Overlapping, or Tile. 

When the display is full-sized and you have more than one folder 
open, you can only see the one on top, like seeing only the top 
page on a stack of reports sitting on your desk. You can switch 
between folders by choosing the name of the folder you want to 
be on top from the Window menu. 

Overlapping folders are stacked so that you can see the upper 
left corner of the folder. You can also choose to display the 



folders tiled, where the folders are side-by-side. You can resize 
and move overlapping folders in the application window. 

Overlapping w indows 

01 0 0 
Graphics Letter-s Desk Accesorles 

0 0 I] 
Papers PP-esentatfons Calculator 

0 4iID em 
Schedules Default Scrapbook Clock 

~ • W?V 
First Address Book GeoFile Untitled 

cG1D QI!] 
My Schedule 

To switch folders using the Window menu 

• Choose the folder's name from the list of open folders names in 
the Windows menu . The folder you specified appears on the top 
of the stack and its title bar is highlighted. 



To view folders as overlapping windows 

• Click the Overlapping button , or choose Overlapping from the 
Window menu. 

Im] • 
To view folders as full-sized windows again 

Click the Full-Sized button or choose Full-Sized from the Window 
menu. Alternatively, click the Maximize button on any of the 
overlapping windows. 

To tile f alders 

• Choose Tile from the Window menu. You must have already 
opened all the windows you wish to tile. 

The folder windows automatically switch to overlapping and 
resize so that they all fit into the application window. 

To switch between folders by clicking their windows 

To switch between folders by clicking their windows, the folders 
must be visible; therefore , they must be overlapping or tiled. 

• Click somewhere in the folder you want. The folder you clicked 
appears on the top of the overlapped stack or is highlighted in a 
tiled display. 

To switch folders using Next on the Window Control menu 

1. Click the Window Control button on the folder window. The 
Window Control menu appears. 

2. Choose Next from the menu. The next folder appears on the top 
of the stack and its title bar is highlighted. 

Repeat this step, selecting the next folder, until the folder you 
want to work with is on top. 

CREATING A NEW FOLDER 

You can create a new folder inside any open folder. The new 
folder is empty until you move or copy items into it. 

To create a new folder 

1. Open the folder in which you want to place the new folder. If 
the folder is already open, make it active . 



2. Choose Create Folder from the File menu. A dialog box appears 
asking you to name the new folder: 

3. Type the name for the folder. You can use any characters, and 
the name can be as long as 32 characters. 

4. Click Create. A new folder appears in the current folder. 

RENAMING A FILE OR FOLDER 

The name that you give a folder or file is not necessarily 
permanent. You can change it at any time using the Rename 
button. 

To rename an item 

1. Select the item (or items) you want to rename. 

2. Choose Rename from the File menu. A dialog box appears: 

3. Enter the new name in the box. 

4. Click Rename to apply the new name. If a file with the same 
name already exists, a dialog box asks you to type a different 
name. 

If you've selected several items, you get a separate dialog box for 
each item. Click Next to leave the name of the current item 
unchanged and go on to the next. Click Cancel to close the 
dialog box without renaming the remaining selected files. 



Moving and Copying Files and Folders 

The easiest way to move or copy a file or folder is to drag it to its 
destination (using the right mouse button) . Dragging an item to a 
folder on the same disk moves the item to that folder, while 
dragging it to another disk copies the item. But you can always 
force a move operation by holding down the Alt key while you 
drag the item, or force a copy by holding down the Ctrl key. 

You can tell what GeoManager is going to do by the pointer that 
you see as you drag the item: 

Pointer r Meaning 

[\ An unfilled square on the arrow indicates that the 
items will be copied. 

~ 
A filled square on the arrow indicates that the items 
will be moved. 

~ 
I 

The circle-slash indicates that you cannot move or 
copy the item to this destination. 

When you move or copy more than one item, a dialog box 
appears showing you the progress of the operation. If you want 
to halt the move or copy operation, click Stop. The operation 
stops after finishing with the current file. 

To move or copy one or more items by dragging 

1. Select the item or items you want to move or copy. 

2. Position the pointer over one of the selected items and hold 
down the right mouse button. The pointer changes to indicate 
whether you are dragging a single item or several items. 

3. Drag the pointer and position it over one of the following 
(according to where you want to move or copy the items): 

• A folder icon in a folder window. The items are placed in that 
folder. 

• Any area of a folder window, but not over a folder icon. The 
items are placed in the folder corresponding to the window. 

• The Parent Folder button on a folder window. The items are 
moved to the parent folder, one level up in the folder 
hierarchy. 

I 

I 



• Over one of the disk drive buttons at the bottom of the 
GeoManager window. The items are copied to the root folder 
of the disk currently in that drive. 

• Over one of the special folder buttons (Wastebasket, WORLD, 
DOCUMENT, or DOSROOM) at the bottom of the GeoManager 
window. 

4. Release the right mouse button. The item is copied or moved 
accordingly. 

To move an item using the Move command 

1. Select the item (or items) you want to move. 

2. Choose Move from the File menu. A file selector appears. Use it 
to find and open the destination folder. 

3. Click Move to move the files into the folder. 

To copy an item using the Copy command 

1. Select the item (or items) you want to copy. 

2. Choose Copy from the File menu. A file selector appears. Use it 
to find the destination folder. 

3. Click Copy to copy the files into the folder. 

DUPLICATING A FILE OR FOLDER 

You can make copies (exact in all but name) of both files and 
folders. For example, you may want to duplicate a document file 
before making extensive changes to it, in order to have a backup 
copy of the original. 

To duplicate an item 

1. Select the item (or items) you want to duplicate. 

2. Choose Duplicate from the File menu. A dialog box appears: 



3. Type in a name for the duplicate. If you don't, the copy will be 
named "Copy of (file or folder name) ." 

When you duplicate many items, you 're given a chance to 
change the name of each copy. Clicking Next skips the current 
item altogether. Clicking Cancel closes the dialog box without 
duplicating the remaining items. 

4. Click Duplicate. A duplicate of the selected item (or items) 
appears in the same folder as the original. 

5. If you're duplicating more than one item, the name of the next 
item appears in the dialog box and the whole process repeats. 

DELETING A FILE OR FOLDER 

There are times when you need to make room on your hard disk 
(or floppy disks , for that matter) by deleting files or folders you 
no longer need. Deleting files with GeoManager is a two step 
process. The first step is to throw the document or folder away, 
by placing it in the Wastebasket. 

GeoManager's Wastebasket works much like a real Wastebasket. 
Items you throw away remain in the Wastebasket until you 
empty it. That way, you can recover items from the Wastebasket 
by pulling them out before the Wastebasket is emptied. The 
Wastebasket is automatically emptied when you exit to DOS. 

Once you empty GeoManager's Wastebasket, everything in it is 
deleted. Deleting a file removes the file from your disk, so be 
careful to delete only those files you know you won't need later. 

You can delete files in one step by using the delete command in 
the file menu , but it is much safer to throw them in the 
Wastebasket first. 

To throw away an item by dragging it to the Wastebasket 

1. Select the item (or items) you want to throw away. 

2. Position the pointer over the selected item (or one of the items, if 
several items are selected). Hold down the right mouse button 
and drag the item to the Wastebasket. 

If the Confirm Delete option is turned on, a dialog box appears 
asking you to confirm each deletion. Click Yes to delete the item; 
click No to leave it untouched and move on to the next (if you're 
deleting several). Click Cancel to close the dialog box without 
deleting the additional items. 



To view the contents of the Wastebasket 

• Click the Wastebasket button. The Wastebasket window appears, 
showing you any files or folders you have placed in the 
Wastebasket. 

irst Address Book Georile Untitled 

To delete specific items in the Wastebasket 

1 . Click the Wastebasket button. The Wastebasket window appears. 

2. Select the files and folders that you want to delete. 

3. Choose Delete from the File menu . The files you selected are 
deleted. 

To delete all items in the Wastebasket 

1. Click the Wastebasket button. The Wastebasket window appears . 

2. Choose Wastebasket from the file menu. A submenu appears. 

3. Click Empty Wastebasket. All the files and folders in the 
Wastebasket are deleted. 

To recover items from the Wastebasket by dragging 

1. Click the Wastebasket button. The Wastebasket window appears. 

2. Select the files and folders that you want to recover. 

3. Click one of the selected files and drag the files to another folder 
or to one of the folder buttons at the bottom of the GeoManager 
window. 

4. The fil es are removed from the Wastebasket and placed in the 
folder you dragged them to. 

To recover itemsfrom the Wastebasket using the File menu 

1. Click the Wastebasket button. The Wastebasket window appears. 

2. Select the files and folders that you want to recover. 



3. Choose Wastebasket from the File menu. A submenu appears. 

4. Click Recover. A file selector appears. 

5. Use the file selector to select a destination for the recovered files 
(the default is the DOCUMENT folder), and click Recover when 
you are satisfied. 

6. The files are removed from the Wastebasket and placed in the 
folder you specified in the file selector. 

To delete an item using the Delete command 

This method does not place files in the Wastebasket - it deletes 
them outright. Deleting a file removes the file from your disk, so 
be careful to delete only those files you know you won't need 
later. 

1. Select the item (or items) you want to delete. 

2. Choose Delete from the File menu. 

VIEWING INFORMATION ABOUT FILES AND FOLDERS 

You can view the following information about files and folders: 

• GEOS and DOS names 

• DOS location 

• Size 

• Creation and last modification dates and times 

• Creator and file owner 

• DOS and GEOS file types and attributes 

• User notes 

To view i11formation about.fUes and folders 

1 . Select one or more files and folders. 

2. Choose File Information from the File menu. A submenu appears . 



3. Click Get Info. A dialog box appears displaying information 
about the first file or folder you selected: 

Harne: Papers 
DOS Harne: PAPERS 

Path: C:[Unnamed1] \GeoWor-ks\DOCUMEl'IT 
10:16:06 PM 04/22193 

Created: 10:16:06 PM 04122193 

File Size: 26,080 
File Owner: -

File Type: Folder· 
Release: 0.0 0-0 

You can enter notes a:,out the 
fi le or folder here. 

Name. This is the GEOS name for a file or folder. 

DOS Name. This is the DOS name for the file or directory that 
corresponds to your GEOS file or folder. DOS names are eight 
characters with a three character extension and may or may not 
correspond to the name that appears in GEOS. 

Path. This is the location of the file. 

Last Modification. This is the time and date of the last change 
that was made to the file or folder. 

Created. This is the time and date that the file or folder was 
created. 

Attributes. These are abbreviations for DOS or GEOS options 
that have been set on a file. If a particular attribute is attached to 
that file , it appears as one of the following letters: 

• Archive (A). This attribute is used as a flag by some DOS 
commands. See your DOS manual for more information about 
the Archive attribute. 

• Directory (D). This indicates that the item is a DOS directory, 
which appears as a folder in Ensemble. 

• Hidden (H). This indicates that DOS does not display the file or 
folder in a directory list. 

• Read-Only (R). This indicates that you cannot modify the file or 
folder. 

• System (S). This indicates that this is a special-purpose file or 
folder for use by DOS. 



• Template (T). This indicates that this is a GEOS application 
template. See the Using Geo Write, GeoDraw, GeoCalc, & GeoFile 
for information about templates. 

File Size. This is the number of bytes in the file or folder. 

Creator. This is the name of the application with which a file 
was created . 

File Owner. This shows the file owner's name if the computer is 
attached to a network that supports this field. 

File Type. This identifies the system function of the file or 
folder. File types include the following: 

• Executable. This indicates that the file is a GEOS application. 

• Data File . This indicates that the file is a GEOS data file. 

• VM File. This indicates that the file is a GEOS data file that uses 
the G EOS virtual memory storage system. 

• J<older. This indicates that the item is a folder or DOS directory. 

• l .X VM File. This is a VM data file from an older version of 
GEOS. 

• DOS File . This indicates that the file is a DOS data file or 
executable. 

Release. This is an internal version number displayed for GEOS 
applications only. More recent releases of an application have 
higher release numbers than olde r releases. 

User Notes. You can type your own notes in this text box. If the 
file is a GEOS file and it is not read only, you can type comments 
about the file or folder in the User Notes area. You can only 
change the User Notes in this dialog box. 

4. Click either OK or Cancel to close the dialog box. 

or 

If you selected several items for which you wanted to view 
information, click Next to see information about the next selected 
file or folder. 

Changing File and Folder Attributes 

You can set a number of options or attributes on files and folders 
that will alter the way you use them with DOS or GEOS 
applications. Only very experienced DOS and GEOS users should 
change these attributes. 

There is one attribute you may find useful for protecting special 
files or folders . You can set the Read-Only attribute on a file or 



folder so that you can view it but not modify it in any way. 
Setting the Read-Only attribute on a file or folder means you 
cannot edit it, throw it away, or move it (but you can delete it 
with the Delete choice on the File menu) . 

To change.file and folder attributes 

1. Select one or more files and folders. 

2. Choose File Information from the File menu. A submenu appears. 

3. Click Change Attributes. A dialog box appears: 

ii 1 · I 

Current Folder is C:(Unnamedl J \GeoWorks\OOCUMEtlT 

Change Attributes: First Address Book 

B.ead Only • Hrchive H;dden ~stem 

tJ TmnJJlate 

4. Change the attributes to your liking. 

Archive (A). This attribute is used as a flag by some DOS 
commands. See your DOS manual for more information about 
the Archive attribute. 

Directory (D). This indicates that the item is a DOS directory, 
which appears as a folder in Ensemble. 

Hidden (H). This indicates that DOS does not display the file or 
folder in a directory list. 

Read-Only (R). This indicates that you cannot modify the file or 
folder. 

System (S). This indicates that this is a special-purpose file or 
folder for use by DOS. 

Template (T). This indicates that this is a GEOS application 
template. See the Using Geo Write, GeoDraw, GeoCalc, & GeoFile 
for information about templates. 

The attributes are applied or removed, depending on what 
choices you made. For more information these attributes , see 
"Viewing Information About Files and Folders" in this chapter. 

5. Click Change to apply the attributes to the file or folder. 

or 

Click Next to change attributes on the next selected file or folder. 



USING THE FOLDER TREE 

One of the best ways to see the folder structure of a disk is to 
view the organization as an upside down "folder tree. " It's upside 
down because the root folder of the disk is at the top of the tree. 
Folders directly under the root folder form the main branches, 
their subdirectories branch off from there, and so on. Using the 
Tree menu , you can see this structure on your computer screen. 
Here is the tree window for a typical disk: 

You control how much of the folder tree is displayed by 
expanding or collapsing the branches (folders) of the tree. 
Expanding a folder displays its subdirectories; collapsing a folder 
hides them. A plus sign indicates that a folder can be expanded. 
A minus sign indicates that a folder is already expanded. 

The Tree window does not show the files within a folder. You 
can, however, view a folder's files by double-clicking the folder 
name. You can also perform all folder management tasks (such 
as creating, copying, or moving folders) from within the Tree 
window. You can click the folder name to select it, then choose 
the command you want from the File menu. Or just drag (with 
the right mouse button) a folder from the Tree window to move 
or copy it into another folder. 

To open the Tree window 

• To display the contents of the current drive, choose Show Tree 
Window from the Tree menu. The tree for the current drive 
appears. 

To expand all folders in the tree 

• Choose Expand All from the Tree menu. This shows every folder 
within eve1y other folder on the current drive. 



To expand the next folder level 

G.:] • Click the plus ( +) sign next to the folder you want to expand. 

or 

Click to select the name of the folder you want to expand (do 
not click the plus or minus sign) and choose Expand One Level 
from the Tree menu. 

To expand all folders within a branch 

1. Click to select the name of the folder you want to expand (do 
not click the plus or minus sign). 

2. Choose Expand Branch from the Tree menu. This shows you 
every folder within every other folder inside of the selected one. 

To collapse all folders within a branch 

B • Click the minus(-) sign next to the folder you want to collapse. 

or 

Click the name of the folder you want to collapse (not the plus 
or minus sign) and choose Collapse Branch from the Tree menu. 

To display the folder tree for another disk 

1. Choose Tree Drive from the Tree menu. A cascade menu appears 
listing the drives connected to your computer. 

2. Click the drive you want to display. The Tree window changes to 
show the contents of the selected drive . 

To return to the regular GeoManager window 

• Choose Close from the Window menu. This closes down the 
Tree window and shows you one of the next open folders . 

or 

Choose the name of one of the open folders from the Window 
menu . This makes this folder the current one, effectively hiding 
the Tree window behind it. 

MANAGING DISK DRIVES 

The Disk menu lets you perform the following disk management 
tasks: 

• Copy a disk's contents onto another disk 



• Format a disk so that it can be used 

• Rename a disk 

• Rescan any drives needed to update the contents of the open 
folders 

• View the contents of a disk 

The disk name can be from 1 to 11 characters long. You can use 
both numbers and letters in the name. For example, 
"LETTERS_12". 

Formatting a Floppy Disk 

An unformatted disk is like a library with no shelves - there's 
nowhere to put the books. Before you can store anything on a 
disk, then, you must format it. When you format a disk, you 
build the shelves so the computer has an organized framework in 
which to store information. 

To see if a disk has already been formatted, insert it into a floppy 
disk drive and click the appropriate floppy disk drive button. If a 
dialog box appears telling you that the disk is unreadable, you 
know the disk needs formatting (or it was not formatted on an 
IBM PC or compatible). 

To format a floppy disk 

1. Insert the floppy disk into one of the disk drives. 

2 . Choose Format Disk from the Disk menu. A dialog box appears: 

3. Click the drive that contains the floppy disk. 

4. Click the option for the disk capacity you want. 

5. Click OK. A dialog box appears requesting a name for the disk. 
Type a name for the disk (1 to 11 characters long), and click 
Format. GeoManager formats the disk according to the options 
you specified. A message lets you know how the formatting is 
proceeding and when it is complete. 



NOTE 

If, for security reasons, you need to zero out every bit on the disk, 
you should turn quick format option off. To do this, before you 
format a disk, select Show Advanced Disk Options from the Options 
menu. When you format a disk, you will see the Quick Format option 
in the Format D isk dialog box. Click No, to turn quick format off. 
When quick format is off it takes longer for your disks to format, but 
every bit of information is erased. All other formatting steps are the 
same as described above. 

Copying a Floppy Disk 

The Copy Disk command on the Disk menu lets you create an 
exact duplicate of a floppy disk. The original disk is called the 
source disk and the duplicate disk is called the destination disk. 
Because GeoManager makes an exact duplicate of the source 
disk, the destination disk must be the same size as the source 
disk. This means you cannot duplicate a 3.5 inch disk onto a 5.25 
inch disk, or vice versa. Also note that, d uring a disk copy, 
GeoManager writes over all files that are on the destination disk. 
Be absolutely sure your destination disk contains nothing you 
want to keep. 

To copy a floppy disk 

1. If you haven't done so already, label the source and destination 
disks so you don't inadvertently confuse them. 

2. Choose Copy Disk from the Disk menu. A dialog box appears: 

3. Click to select the source drive and the destination drive . If you 
have only one drive, drive A appears as both the source and 
destination drive . (You can do it with only one disk drive , 
though you'll have to exchange disks in the drive.) 

4. Click Copy. 

5. GeoManager tells you whenever you need to insert a new disk. 
Follow the instructions on the screen. 



NOTE 

If you have turned Advanced Disk Options on (in GeoManager's 
Options menu), you will see the Memory Usage option in the Copy 
Disk dialog box. You can use this to change the amount of memory 
GeoManager uses for the copy operation. Click High for faster 
copying, and low for slower copying using less memory. 

Renaming a Disk 

You can easily change the name of a floppy disk. You named the 
disk, remember, when you formatted it (see "Formatting a Floppy 
Disk,'' earlier). 

To rename a disk 

1. Choose Rename Disk from the Disk menu. A dialog box appears: 

elect drive for disk rename: 
A: B: •t: 

[UIVlamed1] 

2 . Click to select the drive that contains the disk you want to 
rename. 

3. In the "To" area, type a new name for the disk. 

4. Click Rename to rename the disk. 

Rescanning 

It's possible for a folder display to become out of date. This can 
happen in two different situations: 

• You're working with a floppy disk, and you eject it from your 
floppy disk drive and you add a file to it on another machine. 
When you stick it back in the drive , the GeoManager window 
doesn 't show the new file 

• You're using a network drive and somebody else adds or 
removes files from it. These changes don't appear in the 
Geo Manager window. 

In both these situations, GeoManager doesn 't know that the 
contents of the disk in question have changed, so it doesn 't 
update the window. Fortunately, it's easy to remedy the situation: 
All you need to do is rescan the drive. 



To rescan 

• Choose Rescan Drives from the Disk menu. GeoManager rereads 
the contents of all displayed disks (that is, disks whose folders 
appear in the Window menu) , updating any folder windows if 
necessary. 

CLOSING FOLDERS 

A folder remains open until you specifically close it. If you open 
many folders , you should periodically close the ones you aren't 
using. This frees additional computer memo1y. 

If you close the only open folder, the GeoManager window will 
then be empty. At this point you should click one of the drive 
buttons (or the WORLD and DOCUMENTS buttons) along the 
bottom of the window to open a new folder. 

To close the current folder 

• Choose Close from the Window menu. The window of the 
current folder closes. If you are viewing folders as overlapping 
windows, you could do this by simply double-clicking the 
Control button of the overlapping window you wish to close. 



To close all open f alders 

• Choose Close All from the Window menu. All the folder 
windows close. 

CHANGING GEOMANAGER OPTIONS 

Here are some options you can turn on (or off) to customize 
GeoManager to your liking. Once you're satisfied with your 
settings, save them so that they will apply the next time you start 
GeoManager. The GeoManager Options appear in the Options 
menu: 

When options are turned on, they are selected in the menu. 
When a confirmation option is deselected (turned off), no 
confirmation message appears when you perform the action. 

NOTE 

Remember, when you delete or replace a file, you cannot undo the 
operation if you change your mind. We suggest you leave 
confirmation options on unless you're very experienced with the 
system. Most of them warn you of actions that cannot be undone. 

Warnings on Delete/Throw Away. Click this to a submenu 
with the following options. We suggest that you leave these 
options on. When they are off, you are not given a warning that 
you are about to delete a file or files. 

• Single Warning. When on, this option displays a single 
confirmation message before you delete a group of files. 

• Warning for Each Item. When on, this option displays a 
confirmation message before you delete each file in a group. 

• Read-Only Files. When on, this option displays a confirmation 
message before you delete a Read-Only file. For more 



information about Read-Only files , see "Changing DOS File 
Attributes ," earlier in this chapter. 

• GEOS Executable Files. When on, this option displays a 
confirmation message before you delete a GEOS application. 

Warn on Overwrite. When on, this displays a confirmation 
message before you copy or move a file to a folder that already 
contains another file with the same name. When this option is 
off, you risk unknowingly overwriting files in the destination 
folder. 

Warn on Emptying Wastebasket. When on, this option 
displays a confirmation message whenever you empty the 
wastebasket. 

Hold Items in Wastebasket. When on, any file that you drag to 
the wastebasket remains there until you empty the wastebasket 
or exit to DOS. When off, files are deleted as soon as you drag 
them to the wastebasket. 

Minimize GeoManager on Run. When on, this option causes 
GeoManager to shrink to an icon when you run another 
Ensemble application. With this option off, the GeoManager 
window remains open when you run another Ensemble 
application. 

Tile Vertically. This option only takes effect when you choose 
Tile from the Window menu. When on, GeoManager tiles folders 
from top to bottom of the GeoManager window. When you have 
a lot of folder windows open, GeoManager may do this in 
several columns of windows. When off, GeoManager arranges 
the window from left to right. 

Ask Before Returning to GEOS. This only applies when you 
run a DOS program from GeoManager. When this is on, you 
have to press Enter when you exit from this DOS application 
before Ensemble will start up again. (At this point, you can 
alternatively choose to return to DOS, instead of starting 
Ensemble.) 

Show Advanced Disk Options. Turn this option on to see 
advanced options in the Copy Disk and Format Disk dialog 
boxes. For more information, see "Managing Disks" in this 
chapter. 

Conf1rm When Exiting GeoManager. When on, a dialog 
appears when you exit GeoManager. The message gives you the 
option to simply exit GeoManager, Exit to DOS, or Cancel. Note 
that this option does not eliminate the "Are you sure you want to 
exit?" confirmation dialog box when you exit to DOS. 



Drive Locations. Allows you to move the drive buttons around 
GeoManager, or hide them. There are three options: 

• In Tool Area. This is the usual location for the drive buttons. 
The buttons are immovably placed at the bottom of the 
GeoManager window. 

• Floating. The drive buttons appear in a separate window that 
you can move and resize independent of the GeoManager 
window. 

• Hidden . Hides the drive buttons from view. You can see the 
drive buttons again by choosing either of the other two drive 
location options. 

To turn an option on or off 

• Choose the option from the Options menu. If the option is 
currently on, choosing it turns it off. And vice versa. 

To save the current options and make them permanent 

• Choose Save Options from the Options menu. 

UPDATING l .X DOCUMENTS FROM OLDER GEOWORKS PRODUCTS 

chat"t 

If you cannot open one of your older GEOS documents, it may 
need to be updated. One way to recognize older GEOS files is by 
their icon, pictured at the left. To open the file , try updating it 
before opening it. 

To update a GEOS document from an older Geo Works product 

1. Select the document or documents you want to update . 

2. Choose Update 1.x Document from the Utilities menu. If the 
document was from an older version of Ensemble, a dialog box 
appears showing the progress of the update. Documents that do 
not need to be updated are not affected. 

EXITING GEOMANAGER 

The Exit command closes GeoManager. ormally you never exit 
GeoManager, but if you are running several additional 
applications and notice that your system is running slowly, you 



can exit GeoManager to free up some memory on your 
computer. 

To close GeoManager 

1. Choose Exit from the File menu. A dialog box appears: 

2 . Click one of the buttons: 

Exit GeoManager. The GeoManager application closes. If 
another Ensemble application is currently open, you see the 
open application. If no other Ensemble applications are open, 
you exit immediately to DOS. 

Exit to DOS. You exit to DOS. 

Cancel. GeoManager is not closed. 

To restart GeoManager 

• Choose Go to GeoManager the Express menu of any application. 
Geo Manager restarts. 





CHAPTER 4 

Geo Planner GeoPlanner is an automated appointment book that 

combines a yearly calendar and scheduler in one easy-to-use 

application. With GeoPlanner, you can schedule appointments, 

set alarm reminders for yourself, and print your calendar and 

events. 



This chapter describes how to do the following: 

• View a calendar. 

• View and schedule appointments and meetings as events. 

• Set alarm reminders for important events. 

• Use GeoDex information to schedule events. 

• Print events and your calendar. 

This chapter assumes you are familiar with the information 
covered in Chapter 1 which provides an overview of the skills 
you need to use any GEOS application. 

GeoPlanner has three user levels. For more information about 
changing user levels, see Chapter 1. See "User Levels in 
GeoPlanner" in this chapter. 

STARTING GEOPLANNER 

tmlJ -
-

GeoPlanner 

The GeoPlanner icon looks like the illustration at the left. You 
can find the GeoPlanner icon in the WORLD folder. 

To start GeoPlanner (All Levels) 

• Locate the GeoPlanner icon and double-dick it. 

or 

Start it from the Express menu. 

The GeoPlanner window appears. 
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In Level I , only the Calendar 
window appears. 



In Level 1, you only see the Calendar window when you start the 
application. You can switch to the Events window, but you never 
see both at the same time. In Level 2 and Level 3 you see both 
the Calendar window and the Events window side by side. 
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In Level 2 and Level 3, the Events window 
appears next to the Calendar window. I 

When you start GeoPlanner, the default calendar appears in the 
GeoPlanner window. If you haven't scheduled any events in it 
yet, the calendar is empty. For more information about the 
default calendar, see "Using the Default Calendar" in this chapter. 

For more information about starting GEOS applications and using 
the Express menu, see Chapter 1. 

USER LEVELS IN GEOPLANNER 

There are three user levels in GeoPlanner: 

• Level 1 shows only one window at a time and presents 
simplified menus and task selections. 

• Level 2 shows both the Calendar window and the Events 
window and presents more menu choices and task selections, 
including searching. 

• Level 3 shows both the Calendar window and the Events 
window and lets you perform all of the tasks possible in 
GeoPlanner, including setting repeating events and linking to 
Geo Dex. 

For more information about changing and saving user levels, see 
Chapter 1. 

Anytime you change your user level, you can use the following 
procedure to reset GeoPlanner back to Level 1. 



To reset your user level to Level 1 (All Levels) 

• Choose Reset Configuration from the Options menu. 

USING THE DEFAULT CALENDAR 

My Schedule is the document that automatically opens when you 
initially start GeoPlanner. If you have not scheduled events in 
this default calendar, the document is empty. If you have already 
scheduled events, you can view and change them. 

If you want to just view the calendar or start scheduling events 
now, you can use the default calendar. If you plan to keep more 
than one calendar, you may want to create new GeoPlanner 
documents. For more information about viewing the calendar 
and scheduling events, see "Viewing the Calendar" and 
"Scheduling Events" in this chapter. For more information about 
creating new scrapbooks, see "Working With Documents" in this 
chapter. 

You use the default calendar in the same way you use any 
GeoPlanner document, viewing different days, months, and 
years, and scheduling events. 

VIEWING THE CALENDAR 

A LL LEVELS The Calendar window always contains a whole year, January 
through December. Normally you see only one month at a time, 
which is the single-month view. If you resize the GeoPlanner 
window, the month display gets larger or smaller to fit. You can 
scroll the window to see the other months in the year, and you 
can change the year over which you are scrolling, but you never 
see more than one month at a time. The current day of the 
month is always enclosed in a black border. 



Time of day 
(current time) 
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Click to change the year 
in the window. 

Scroll the window to see 
other months. 

Today's date has a black border. 

In Level 2 and Level 3, the Events window 
appears next to the Calendar window. 

In Level 3 you can switch the Calendar window to the full-year 
view, which rearranges the display so that many months can be 
seen at one time. If you resize the GeoPlanner window in this 
view, the months remain at their smallest size, but you see more 
or less of the year depending on whether you make the window 
larger or smaller. 

Viewing Different Months 

You can scroll the Calendar window to see different months in 
the year. Scrolling to the left views previous months. Scrolling to 
the right views subsequent months. In Level 3, if you 've switched 
to the full-year view, you can also scroll up and down. 

To view different months (All Levels) 

• Using the horizontal scroll bar at the bottom the Calendar 
window, scroll left to see previous months. Scroll right to see 
subsequent months. 

The appropriate month appears in the window. 

Viewing Different Years 

You can view different years in the Calendar window. You can 
view any year from 1900-9999. 



LEVEL 3 

To view different years (All Levels) 

• Click the up or down arrow buttons next to the Year box until 
you see the year you want. The Year box is located above the 
Calendar window. 

or 

Double-click in the Year box and edit the year shown. Then 
press Enter. 

The window shows the calendar for the year you selected. 

Switching to the Full-Year View 

ormally you see a month at a time in the Calendar window. 
This is the single-month view. In Level 3 you can switch to the 
full-year view, where you see as many months as will fit in your 
window. If you resize the GeoPlanner window large enough, 
you can see an entire year in the Calendar window. 

To switch to the full-year view (Level 3) 

1. Choose Full Year from the View menu. The calendar shrinks so 
that more than one month can appear in the window. 

2. Use the scroll bars to view any additional months that don't fit in 
your window. 

or 

Resize the window to see more months at a glance. You can click 
the Maximize button on the title bar to quickly enlarge the 
window to full-screen. 

To switch back to the single-month view (Level 3) 

• Choose Single Month from the View menu. The calendar for a 
single month displays. 

SELECTING AND VIEWING EVENTS 

ALL LEVELS Like an appointment book, GeoPlanner keeps track of weekly 
meetings, important appointments, and special dates . All of these 
things are called events. You can use events in GeoPlanner to 
track important dates in your daily schedule, like business 
meetings , and you can schedule dates far in advance, like 
birthdays and vacations. You can also add alarms that sound off 
at the time and date of the scheduled event. If you have events 



To view to the Events 
window in Level 1, 
choose Events from 
the View menu. 

that occur on a regular basis, such as a class you teach every 
Thursday or a birthday you want to remember eve1y year, you 
can specify repeating events to schedule these automatically. 

You schedule events in the Events window. In Level 1, you 
switch between the Calendar window and the Events window 
but you don't work with both at the same time. In Level 2 and 
Level 3, you see both the Calendar window and the Events 
window side-by-side. The following illustration shows the Events 
window and the Calendar window together as they appear in 
Level 2 and Level 3: 
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Click a day in the Calendar w indow 
to select it and view its events. 

Click to show the next and previous day's events. 

I This text shows the date of the selected 
day. Its events appear in the window. 
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Selected day: this day's events 
appear in the Events w indow. 

Today's date has a thick black border. 

I 

The small triangle ind icates that there 
are events scheduled on this day. 

Switching Between the Calendar Window and the Events 
Window 

In Level 1 you are either viewing the Calendar window or the 
Events window, but not both. You switch between the two 
windows by choosing from the View menu. 

In Level 2 and Level 3, you see the Calendar window and the 
Events window side-by-side. However, if you prefer, you can 
choose to view only one window at a time and switch between 
them as you would in Level 1. Showing only one window at a 



Click a day in the 
Calendar window to 
view its events. 

time lets you work with the Calendar window or the Events 
window without taking up space for both. 

To view the Events window (All Levels) 

• Choose Events from the View menu. 

The Events window appears. 

To view the Calendar window (A ll Levels) 

• Choose Calendar from the View menu . 

The Calendar window appears. 

To show only one window in Level 2 or Level 3 (Levels 2-3) 

On the View menu, when both windows are showing, the Both 
choice is on (black). When only one window is showing, Both is 
off. 

• Choose Both from the View menu. The Both button changes to 
off and one of the windows disappears. 

To return to viewing both windows, choose Both from the View 
menu again. The Both button changes to on and one the other 
window reappears. 

Selecting a Day and Viewing its Events 

You can view a day's events by clicking that day in the Calendar 
window and then looking in the Events window. You can also 
view the next and previous day's events by clicking the up and 
down arrow buttons at the top right of the Events window. 
Finally, you can use choices on the Quick menu to see today's 
events or jump to a particular date and see its events. 

To select a day and view its events (All Levels) 

1. If the Calendar window isn't showing, choose Calendar from the 
View menu. The Calendar window appears . 

2. Click to select a day in the Calendar window. The day highlights. 

3. The events for the selected day appear in the Events window. If 
the Events window isn't showing, choose Events from the View 
menu. The Events window appears. 

To view events on the next or previous day (All Levels) 

After viewing the events for a particular day, you can easily view 
the events for the next or previous day. 



• With the Events window showing, click the up or down arrow 
buttons located at the top right side of the Events window. The 
up arrow selects the previous day and the down arrow selects 
the next day. As the selected day changes, events for that day 
appear in the Events window . 

...._Mon_..... _Mer....,...._29..;... _1993 _____ =:::.11~ - Click to show the next and 
previous day's events. 

Selected day 

To view today 's events (All Levels) 

After working with another day's events you may want to jump 
quickly back to today and view today's events. 

• Choose Today from the Quick menu. 

Today becomes the selected day and its events appear in the 
Events window. If the Events window isn't showing, choose 
Events from the View menu. The Events window appears. 

To view events on a particular date (All Levels) 

When you know the exact date for which you want to view 
events, you can jump to that date quickly without looking for it 
on the calendar. 

1. Choose Go to Date from the Quick menu. A dialog box appears. 

2. In the dialog box, type a date. If there is already a date in the 
dialog box, you can press Backspace to erase it. The date you 
type must be in the format Month/ Day/ Year. For example, to 
view the events for Februa1y 23, 1993 you would type 
2/23/1993. 

3. Click Go To. The date you typed becomes the selected day and 
its events appear in the Events window. If the Events window 
isn't showing, choose Events from the View menu. 

4. If you want to see a different day's events, click in the text box 
and repeat steps 2 and 3. 

5. Click Close to close the dialog box. 



LEVEL 3 

Selecting a Range of Days and Viewing Their Events 

In Level 3, you can view a summa1y of events over a range of 
days. For instance, you can see all the events for this week or 
this quarter. The following illustration shows an example of a 
week's worth of event's in summa1y form: 

Click to see events in the 
previous and next range of days. 

These are the dates over which 
events are being summarized. 
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The range of dates are highlighted 
in the Calendar window. 

A summary of events over the selected 
range appears in the Events window. 

You can select any range of days in the year and view a summary 
of those events. Once you have selected a range, you can also 
view the previous and next range of days. 

To view a summary of events over a range of days (Level 3) 

1 . Drag to select a range of days in the Calendar window. If you 
drag outside of the Calendar window, the window scrolls and 
you can extend the selection to adjacent months. 

or 

Choose one of the following from the Quick menu: 

•This Week. Selects all days in this week. 

• This Weekend. Selects the current or upcoming Saturday and 
Sunday. 

• This Month. Selects all days in this month. 

•This Quarter. Selects all days in this calendar quarter Quarters 
run January through March, April through June, July through 
September, and October through December. 

•This Year. Selects all days in this year. 



The selected range is highlighted in the Calendar window and its 
events appear in the Events window. If the Events window isn't 
showing, choose Events from the View menu. 

In the Events window, only those days which have events 
scheduled are shown in the summary. If there are no events in 
the range, the Events window shows " o Events ." 

If you wish to have all dates shown in the summary, even those 
days on which there are no events, you can change your 
GeoPlanner preferences to show empty days . For more 
information on showing empty days, see "Changing GeoPlanner 
Preferences" in this chapter. 

SCHEDULING EVENTS 

ALL L E V EL S GeoPlanner makes it easy to schedule events. You simply select 
the day of the appointment, select a time in the Events window, 
and then type a description of the event. Once you've scheduled 
an event, you can change it or remove it as well. 

The Events window provides a list of times called the day 
template. Normally the day template shows times from 8:00 a.m. 
to 6:00 p.m. in 30-minute intervals. In Level 3 you can change the 
times shown in the day template or turn the day template off 
entirely. For more information on changing the day template , see 
"Changing GeoPlanner Preferences" in this chapter. 

Scheduling an Event Using the Day Template 

The easiest way to schedule an event is to select a day, and then 
select a time from the day template. 

To schedule an event by selecting from the day template (All 
Levels) 

1. Select the day on which you want to schedule an event. 

lfthe Events window 2. You may select a day using any method, such as by clicking in 
isn't showing, choose the Calendar window or by using the up and down arrows at the 
Events/ram the View top right of the Events window. 
menu. 



3. In the Events window, select a time from those provided in the 
day template. A border appears around the event, divided into a 
time area and a description area. 

uo:au nr1 
b,9:00 AM 

9:30 AM 
b, 1 :00 AM 
(1 1 ·"tOllM 

Time of event Description area 

4. Click inside the description area, and then type a description of 
the appointment, meeting, or date. If you type more than one 
line, words wrap at the edge of the Events window. Press Enter 
in the description area to start a new paragraph. The appointment 
description is automatically added to your schedule. 

I 15 ..-1 5. When you next view the Calendar window, a triangle appears in 
the date box for the date to which you added the event, like in 
the example on the left. The triangle shows that an event is 
scheduled for that day. 

Changing a Scheduled Event 

You can change the scheduled time for an event or the details in 
its description. 

To change a scheduled event (All Levels) 

1. In the Events window, locate the event you want to change. 

2. If you want to change the time, click in the time area. Delete the 
existing time and type a new time in HH:MM format. Use AM or 
PM to specify a.m. or p.m. For example, you can type 8:15 AM 
for a new time. 

3. If you want to change the description, select the text in the 
description area, and then type the new information. 

If at any point you suddenly realize that you made a change you 
wish you hadn't, choose Undo from the Edit menu before you 
do any other task. 

NOTE 

When you change t he time of a scheduled event, it does not change 
its place among the other times in the Event window and may appear 
missorted until you fi rst view another day's events and then return to 
this day. For instance, if you change a 9:00 appointment to I I :00, the 
event will remain sorted in its original slot between 8:00 and I 0:00 
until you view another day's events. The next time you come back and 



view this day's events, the I I :00 event will be properly sorted 
between I 0:00 and 12:00. 

Removing a Scheduled Event 

If an appointment or meeting is canceled, you can easily remove 
the event from your schedule. 

To remove a scheduled event (All Levels) 

1. In the Events window, click the event you want to remove. 

2. Choose Delete Event from the Edit menu. The event is removed 
from the Events window. If there are no more events scheduled 
for that day, the triangle is removed from the Calendar window. 

If you suddenly realize that you deleted the wrong event, choose 
Undo from the Edit menu before you do any other task. 

Adding Events Between Two Scheduled Events 

There may be times when your daily schedule is loaded, but you 
need to squeeze in one more appointment. Since all of the time 
slots are filled , you need to schedule the appointment between 
two existing scheduled events. For example, if you have 
meetings scheduled for 11:00 and 11:30, you can schedule 
another meeting for 11:15 even though there is no 11:15 slot 
currently shown. 

To add an event between two scheduled events (All Levels) 

1. In the Events window, select a time slot after which you want to 
fit another event. 

2. Choose New Event from the Edit menu. The new event appears 
with its time highlighted. GeoPlanner picks a time halfway 
between the preceding event and the next one. 

3. Edit the time if the one shown is not correct. Be sure the time 
you type is in the HH:MM format. For example, you can type 
8:15 AM for a new time . 

4. Press Tab or click in the description area, and then type a 
description for the event. 

Adding an Event at a Particular Time 

You may wish to schedule an event at a time that does not 
appear on the day template , such as an early morning or late 
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evening appointment. You can also schedule an event with no 
specific time. 

To add an event at a particular time (All Levels) 

1. Select the day on which you want to schedule an event. 

2. Choose New Event from the Edit menu. The new event appears 
in the Events window and its time highlighted. 

The Events window appears if it was not already showing. 

3. Edit the time if the one shown is not correct. Be sure the time 
you type is in the HH:MM format. For example, you can type 
11:50 PM for a new time .. 

or 

If you want to schedule an event with no specific time, delete the 
text in the time area. 

4. Press Tab or click in the description area, and then type a 
description for the event. 

NOTE 

The new event will not appear in its proper sorted place among other 
t imes in the Event window until you first view another day's events. 
When you view another day's events, and then come back, the events 
appear chronologically; events which do not have a t ime appear at the 
top of the list. 

Adding Events With the Day Template Off 

In Level 3, you can turn off the day template. When the Day 
Template is off, you see only the scheduled events for the days 
you select in the Calendar window. If no events are scheduled, 
the Events window shows "No Events" at the top. For 
information on turning off the day template , see "Changing 
GeoPlanner Preferences" in this chapter. 

To add an event with the day template off (Level 3) 

1. Select the day on which you wish to schedule an event. 

2. Choose ew Event from the Edit menu. An empty event slot 
appears in the Events window under the selected date. The time 
portion is highlighted 

The Events window appears if it was not already showing. 

3. Edit the time if the one shown is not correct. Be sure the time 
you type is in the HH:MM format. For example, you can type 
10:00 AM for a new time .. 



4. Press Tab or click in the description area, and then type a 
description for the event. 

Copying Event Descriptions 

You can use the Copy function on the Edit menu to copy a block 
of text from one event and paste it onto another. This is handy 
when you are scheduling the same sort of event on many 
different days. 

To copy part qf an event description (All Levels) 

1. Select the text you want to copy. 

2. Choose Copy from the Edit menu. 

3. Locate the area where you wish to place the copied text. This can 
be any event on a different day or the same day. You can create 
a new event if you want. 

4. When you come to the place where you want to place your 
duplicate text, click to place the insertion point, then choose 
Paste from the Edit menu. The information is pasted at the 
location of the insertion point. 

For more information about copying and pasting, see Chapter 1. 

SCHEDULING REPEATING EVENTS 

LEVEL 3 You might have events that happen regularly, such as school 
board meetings every Thursday at 4:00. In GeoPlanner, you only 
need to schedule the event once. GeoPlanner then remembers to 
schedule these meetings for you every Thursday at 4:00. 

Repeating events are useful for appointments that occur at 
regular intervals . Examples of repeating events can be a birthday, 
a weekly meeting, a holiday that falls on the same day every 
year, or a reminder that parent-teacher night is the second of 
each month. 

You can schedule an event that repeats in one of the following 
ways: 

• Weekly. A weekly event occurs on the same day every week, 
such as eve1y Wednesday. 

• Monthly by date. A monthly by date event occurs every month 
on the same numbered day, such as the first or the fifteenth of 
every month. 



• Yearly by date. A yearly by date event occurs once a year on 
the same date , such as a birthday or a holiday. 

• Monthly by day. A monthly by day event occurs every month 
on the same day of a particular week, such as every third 
Sunday. 

• Yearly by day. A yearly by day event occurs once a year on 
the same day of a particular week in a particular month, such as 
the first Sunday in March. 

When you schedule a repeating event, it appears in the Events 
window on the days for which it applies. The letter R next to the 
event indicates that it is a repeating event. 

J....:.,. £:.au rr1 
f:,. 3:00 PM 
R 3:00 PM Salsa dance lesson 
f:,. 3:30 PM 
f\ <1.nn PM 

The letter R indicates this 
is a repeating event. 

NOTE 

Repeating events do not have alarms. If you wish to set an alarm for a 
repeating event, you must set the alarm for each occurrence 
individually. You can do this by clicking the letter R at the left side of 
the event in the Events window. You can also edit an individual 
occurrence of a repeating event, changing its text description or time. 
Once you set the alarm or edit the event, that particu lar occurrence 
is no longer considered a repeating event, but is now just one of the 
regular events for that day. The letter R next to the event becomes a 
bell to indicate this change. All other occurrences of the repeating 
event are unaffected. 

To schedule a weekly repeating event (Level 3) 

A weekly event occurs on the same day eve1y week, such as 
every Wednesday. 

1. Choose Repeating Events from the Utilities menu. A dialog box 
appears. 

I
M1§!1,, liLtM 
Weekly Meeting 
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2. Click New. Another dialog box appears. 

3. Select Weekly. 

4. Select the check boxes for the day or days that your weekly 
event occurs. 

5. If you wish to give the event a specific time, type the time in the 
Time box. Use the HH:MM format, and type AM or PM. 

6. Type a brief description of the event in the Event box. 

7. Select Forever if your event should repeat indefinitely. 

or 

Select From if your event is of limited duration and should only 
repeat over a specific time period. Edit the start and end dates as 
appropriate. 

8. Click OK. The original dialog box appears. 

9. Click Close when you are finished. The weekly repeating event 
appears in the Events window at the time and day you specified. 
The letter R next to the event indicates that it's a repeating event. 

To schedule a monthly or a yearly event by date (Level 3) 

A monthly by date event occurs every month on the same 
numbered day, such as the first or the fifteenth of every month. A 
yearly by date event occurs once a year on the same date, such 
as a birthday or a holiday. 

1. Choose Repeating Events from the Utilities menu. A dialog box 
appears. 

2. Click New. Another dialog box appears. 

3. Select Monthly if you are scheduling a monthly event by date . 

or 



Select Yearly if you are scheduling a yearly event by date. 

4. Select Date. 

5. Select Last if your event occurs on the last day of the month. 

or 

Select Date, and then type the date of your event. You can also 
use the up or down arrow buttons to change the date . 

6. If you are scheduling a yearly event, use the up or down arrow 
buttons to select the month your event occurs. (Skip this step if 
you are scheduling a monthly event.) 

7. If you know the time of the event, type it in the Time box. Use 
the HH:MM format, and type AM or PM. 

8. Type a brief description of the event in the Event box. 

9. Select Forever if your event should repeat indefinitely. 

or 

Select From if your event is of limited duration and should only 
repeat over a specific time period. Edit the start and end dates as 
appropriate. 

10. Click OK. The original dialog box appears. 

11. Click Close when you are finished . The monthly or yearly event 
appears in the Events window at the time and day you specified. 
The letter R next to the event indicates that it's a repeating event. 

To schedule a monthly or a yearly event by day of the week (Level 
3) 

A monthly by day event occurs every month on the same day of 
a particular week, such as every third Sunday. A yearly by day 
event occurs once a year on the same day of a particular week in 
a particular month, such as the first Sunday in March. 

1 . Choose Repeating Events from the Utilities menu. A dialog box 
appears. 

2. Click New. Another dialog box appears. 

3. Select Monthly if you are scheduling a monthly event by day of 
the week. 

or 

Select Yearly if you are scheduling a yearly event by day of the 
week. 

4. Select Day of Week. 



LE VEL 3 

5. If you are scheduling a yearly event, use the up or down arrow 
buttons to select the month your event occurs. (Skip this step if 
you are scheduling a monthly event.) 

6. Click the up or down arrow buttons in the Day of Week box to 
select the day of the week that your event occurs. For example, 
you can select the second day of the week here. 

or 

Click the up or down arrow buttons to select a specific day of the 
week. 

7. If you know the time of the event, type it in the Time box. Use 
the HH:MM format, and type AM or PM. 

8. Type a brief description of the event in the Event box. 

9. Select Forever if your event should repeat indefinitely. 

or 

Select From if your event is of limited duration and should only 
repeat over a specific time period. Edit the start and end dates as 
appropriate. 

10. Click OK. The original dialog box appears. 

11. Click Close when you are finished. The monthly or yearly event 
appears in the Events window at the time and day you specified. 
The letter R next to the event indicates that it's a repeating event. 

Changing a Repeating Event 

If your scheduled repeating event changes at any time, you can 
modify the event to reflect the new changes. 

To change a scheduled repeating event 

1. Choose Repeating Events from the Utilities menu. A dialog box 
appears. 

2. Select the event you want to change from the list, and then click 
the Change button. Another dialog box appears. 

3. Make the necessary changes in the dialog box. For details , refer 
to the previous procedures in this section. 

4. Click OK. The original dialog box appears. 

5. Click Close when you are finished. The changes are reflected in 
the Events window. 
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NOTE 

Only unaltered occurrences of the repeating event are changed in the 
schedule. Individual occurrences which you have edited, or for which 
you have set an alarm, will remain intact. 

Removing a Repeating Event from the Calendar 

If your repeating event is no longer part of your schedule , you 
can remove the event. 

To remove a repeating event 

1. Choose Repeating Events from the Utilities menu. 

2. Select the name of the event you want to remove from the list, 
and then click Delete. 

3. Click Close when you are finished. The event is removed from 
your schedule. 

NOTE 

Only unaltered occurrences of the repeating event are removed from 
the schedule. Individual occurrences which you have edited, or for 
which you have set an alarm, will remain intact. 

ADDING ALARM REMINDERS TO EVENTS 

LEVELS 2 - 3 Alarms in GeoPlanner are just like the alarms you set on your 
watch or your alarm clock. If you have an urgent appointment 
that you don't want to forget, you can set an alarm for that 
specific event. When the alarm goes off, you hear a beeping 
noise , and you see a dialog box containing a description of the 
event. You can set as many alarms as you need. 

NOTE 

Alarms only go off while GeoPlanner is running. If you exit 
GeoPlanner you are not notified of alarms which would have 
otherwise gone off. You can minimize the GeoPlanner window, so 
that it is out of the way, but have it continue monitoring alarms by 
cl icking the Minimize button. For more information on minimizing an 
application window see "Working With Windows" in Chapter I. 



6, Alarm is off 

4 Alarm is on 

Turning an Alarm On or Off 

In Level 2 and Level 3, each event in the Events window has a 
bell icon to the left of its time. The bell icon indicates whether or 
not the event has an alarm set. When the bell is filled, an alarm is 
set. Otherwise, the bell is unfilled and no alarm is set. If the letter 
R appears where the bell would normally be, then that event is a 
repeating event and has no alarm. 

To tum an alarm on or off (Levels 2-3) 

1. Select the event for which you want to set the alarm. 

An event must have 2. Click the bell icon to the left of the event time to tum on the 
text in its description alarm. A solid-colored bell indicates that an alarm is set. Click the 
area before you can bell again to remove the alarm. 
turn on its alarm. 

or 

Choose Alarm Settings from the Edit menu. When the dialog box 
appears, select the On option next to Alarm Is; then click OK. 

NOTE 

A repeating event does not normally have an alarm. If you wish to set 
an alarm for a repeating event, click the R to the left of the event. 
The R will become a filled bell and the alarm will be set. Once you set 
an alarm for a particular repeat ing event, that occurrence of the event 
is no longer considered a repeating event, but is now just one of the 
regular events for that day. 

Responding to Alarms 

When an alarm goes off, you see a dialog box containing a 
description of the event. Normally, you also hear a beep. The 
following is an example of an alarm that has gone off: 

-= -= -= ·-"'°'- -----= --- -- -"'"' 

Event occurs: Mon, Apr 5, 1993 12100 PM 

1~vent: CaU Mom to check what time to pick up 
l!.. the kids 

To respond to an alarm (Levels 2-3) 

• Click Close to close the dialog box and dismiss the alarm. 

or 

Click Snooze to close the dialog box temporarily. The alarm goes 
off again five minutes later. 



LEVELS 2-3 

Changing an Alarm's Date, Time, and Sound 

Alarms normally go off at the time of the scheduled event, but 
you can set an alarm to go off at a different date or time. For 
example, if you have a meeting scheduled for 11 :00, you can set 
the alarm for that event to go off 10 minutes earlier, at 10:50, to 
give you enough time to get to the meeting; or, if you have an 
early morning appointment on a Monday, you can set the alarm 
to go off on Friday to remind you before the weekend. 

You can also change the sound an alarm makes when it goes off. 
The loudness of your alarm can be changed to levels called 
"Silent," "Quiet," "Normal,"or "Panic ." If you set the alarm sound 
to Silent, you do not hear an actual alarm, but the dialog box 
appears. 

NOTE 

If you have turned off sound for all of Ensemble using Preferences, all 
alarms are silent regardless of their settings. For more information on 
Preferences, see Appendix A 

To adjust the alarm date, time, and sound for an event (Levels 
2-3) 

An event must have text in its description area before you can 
change its Alarm Settings. 

1. In the Events window, select the event whose alarm you wish to 
adjust. 

2. Choose Alarm Settings from the Edit menu. A dialog box appears. 

ent blformation'===~nm 
Times 8:00 AM 

3. If you want to change the date and time of the alarm, edit the 
Date and Time under Alarm Information. You must type the date 
in MM/ DD/ YY format and the time in HH:MM format. For 
instance, you could type 2/ 15/ 93 for the date and 8:22 AM for 
the time. 



The date and time of the alarm you set determines when the 
alarm will go off; it does not affect the date and time of the 
event. 

4. If you want to change the alarm sound, click the down arrow 
beside Alarm Sound, and then choose a sound level from the 
drop-down list that appears. The new sound level shows next to 
Alarm Sound. 

5. Make sure the alarm is on; if it is off, select On next to Alarm Is . 
This is the same as selecting the bell in the Events window. 

6. Click OK when you are finished. The dialog box goes away and 
the event retains its new alarm settings. 

In Level 3, you can adjust the alarm time for all events so that 
every alarm will precede its event by a specified number of 
hours, minutes, and days. This is often easier than adjusting the 
alarm for each event individually. For information on adjusting 
the date and time for all alarms, see "Changing GeoPlanner 
Preferences" in this chapter. 

FINDING SPECIFIC EVENTS 

LEVELS 2-3 You can search for specific events in GeoPlanner. This can be 
useful if you want to see a list of meetings you have scheduled 
with a particular person. For example, if you want to see all 
meetings with Ms. Jones , you can search for "Jones". 

Searching is also helpful if you know you have a meeting with a 
specific person but cannot remember the date. You could simply 
search for the person's name. 

To search for specific events (Levels 2-3) 

1. Choose Find from the Utilities menu. A dialog box appears: 

2. Type the text you want to search for. 

3. Click Find Next. The search starts on the current day and goes 
forward. If no matches are found , you are asked if you want to 
search past events. Click OK. The first event that matches the 
search text appears highlighted in the Events window. 



If there is no match for the specified text, then GeoPlanner 
informs you that no match was found . 

4. Click Find Next if you want to find more events that match the 
search text. 

or 

Click Close if you are finished searching. 

LINKING TO GEODEX 

LEVEL 3 

If the GeoDex 
Lookup choice is 
dimmed, then you 
have not selected 
any text. 

You can search your GeoDex address cards for information that 
might be useful in events you are scheduling. For example, if 
you have a meeting scheduled today with John Cormick and 
want to call him to confirm the time, you can quickly get his 
phone number from your GeoDex address cards. For more 
information on using GeoDex, see Chapter 5. 

To search for GeoDex information using GeoPlanner (Level 3) 

1. Select any text in the event description. 

2. Choose GeoDex Lookup from the Utilities menu. You see the 
GeoDex window and the first address card that matches the text 
you selected in GeoPlanner. The GeoDex Find dialog box is 
open as well. 

3. If you find the information you want in the first card, click 
anywhere inside the GeoPlanner window to return to 
GeoPlanner. 

or 

If you want to continue searching for the selected text in 
GeoDex, click Find Next in the Find dialog box to find the next 
card that matches the selected text. 

NOTE 

The GeoDex window will remain open until you close it. There is no 
need to close it right away, especially if you intend to do another 
lookup. When you are ready to close it, choose Exit from the File 
menu in GeoDex or double-click its window control button. 



PRINTING YOUR EVENTS OR CALENDAR 

ALL LEVELS You can print a monthly calendar, a yearly calendar, or your 
scheduled events. 

Only the steps which are unique to printing in GeoPlanner are 
covered here. For general information about printing, see 
"Printing Documents" in Chapter 2. 

To print a monthly calendar (All Levels) 

You can print a full-page calendar for any month. You can also 
include the first few lines of events for each day. 

1. Choose Print from the File menu. The following dialog box 
appears: 

Click to select another printer. 

Enter the number of copies to print. 
I 
Click to print only text, with no graphics. 

I Select a print quality. 

2. In the GeoPlanner Print Options portion of the dialog box, click 
the button next to the words "Will Print. " A drop-down list 
appears. 

3. From the drop down list, select Month. The choice appears on 
the Will Print button. 

4. If you want to print the first few lines of events for each day, 
select Include Events. 

or 



LEVELS 2-3 

If you want to print a blank calendar, make sure the Include 
Events option is off. 

5. Click the up or down arrow buttons to select the month you 
want to print. 

6. Click the up or down arrow buttons to select the year for the 
month you want to print. You may also edit the number in the 
Year box. 

7. Click Print when you are finished. A calendar of that month 
prints. 

To print a yearly calendar (All Levels) 

1. Choose Print from the File menu. A dialog box appears. 

2 . In the GeoPlanner Print Options portion of the dialog box, click 
the button next to the words "Will Print. " A drop-down list 
appears. 

3. From the drop down list, select Year. The choice appears on the 
button. 

4. Click the up or down arrow buttons, or edit the number shown, 
to select the year you want to print. 

5. Click Print when you are finished . A calendar of that year prints. 

To print the Events window (All Levels) 

You can print the contents of the Events window. 

1. Select the day whose events you want to print. In Level 3, you 
can select a range of days. 

2. Choose Print from the File menu. A dialog box appears. 

3. In the GeoPlanner Print Options portion of the dialog box, click 
the button next to the words "Will Print. " A drop-down list 
appears. 

4. From the drop-down list, select Events Window. The choice 
appears on the button. The date of the Events window that will 
be printed appears below it. 

5. Click Print when you are finished. The contents of the current 
Events window prints. 

Changing the Page Size 

Before you print, you may want to use the Page Size dialog box 
to change dimensions of your calendar. Normally, GeoPlanner 
prints its documents at 8.5" by 11". You can change the page size, 



for instance, to print a poster-sized calendar across multiple 
sheets of paper. 

Page Size refers to the size and layout of the final document you 
wish to print. This does not have to correspond to the actual 
paper in your printer. For example, you may create a poster that 
measures 20" by 4011

• However, the paper in your printer may be 
8.5" by 11 ". In the Page Size dialog box, you specify the size of 
your document, which is 20" by 40". In the Print dialog box, you 
specify 8.5" by 11". GeoPlanner calculates the number of 8.5" by 
11 11 pages required to print your document and prints it over 
several pages which you can assemble into a poster. If you 
choose a page size which is smaller than the paper in your 
printer, GeoPlanner prints pages at the size you specify centered 
on the paper, which you can cut down to size. 

You can also use the Page Size dialog box to specify a different 
size page when your printer supports different sizes of paper. To 
correctly print on the different size of paper, you must also 
change the paper Width and Height in the Printer Options 
section of the Print dialog box. 

A .,., 



To change Page Size options (Levels 2-3) 

1. Choose Page Size from the File menu. The Page Size dialog box 
appears: 

Click here to select paper type. 

I Select page size from list. 

I Select portrait or landscape layout. 

I . . 
D isplays height of selected page. 

I . . 
Displays width of selected page. 

Set left, top, right, and bottom margins. 

2. Fill in the dialog box, changing the options you want: 

•Type. Choose Paper or Envelope. When printing in 
GeoPlanner, Paper is probably the desired choice. 

• Size. Select a page size from the scrolling list. The scrolling list 
contains all common paper or envelope sizes. 

• Width. Displays the width of the page size you have selected. 
Can also be used to set a custom page width. 

•Height. Displays the height of the page size you have selected. 
Can also be used to set a custom page height. 

•Paper Layout. Select portrait or landscape layout. 

3. Click Apply to apply the settings to the current document. The 
current settings are applied to your document, but the Page Size 
dialog box remains open. 

4. If these are the settings you want to use, click Close. 



SAVING AND EXITING 

ALL LEVELS If you've made changes or additions to your calendar and want 
to make the changes permanent, you can do this by saving your 
document. 

When you are done using GeoPlanner, you should exit it. Exiting 
an application closes its window and frees up system resources. 
You should save your document before exiting, but if you forget 
GeoPlanner will give you one last chance to save your changes. 

To save changes to your document (All Levels) 

• Choose Save from the File menu . GeoPlanner saves your changes 
and returns you to the document. 

For more information about saving changes, see "Saving 
Documents" in Chapter 2. 

N OTE 

GeoPlanner automatically safeguards your calendar while you are 
working on it. In the event of a power failure or other problem, your 
work is probably safe even if you haven 't used the Save menu choice. 
By adjusting the Document Safeguarding Time in the Look & Feel 
section of Preferences, you can control how frequently this 
safeguarding takes place. For more information, see Appendix A 

To exit GeoPlanner (All Levels) 

• Choose Exit from the File menu. 

or 

Double-click the window control button, located in the top left 
corner of the GeoPlanner window. 

The GeoPlanner window closes and the application exits. If you 
have unsaved changes in your document, GeoPlanner will ask if 
you want to save those changes. 

WORKING WITH DOCUMENTS 

AL L LEVELS GeoPlanner provides a standard document called "My Schedule" 
in your Document folder. Whenever you start GeoPlanner, this 
document opens automatically, making it easy to keep all of your 
appointments in one place. If you keep just one calendar, you 
should use this document. 



Before you create a 
new calendar you 
must first save and 
close the current 
one. 

My Schedule 

However, you may want to keep additional calendars. For 
instance, you may find it easier to keep business contacts in one 
calendar and keep friends and family in another. You can use 
GeoPlanner to track these calendars as well. 

Creating a New Calendar 

It is easy to create a new Calendar document from within 
GeoPlanner. The basic procedure is covered here. For more 
information about creating and naming a new calendar 
document, see Chapter 2. 

To create a new calendar document (All Levels) 

1. Choose Close from the File menu. If you have unsaved changes 
in the current calendar, you will be asked if you wish to save or 
discard them. 

The New/ Open dialog box appears. 

2. Click the New button. A new calendar appears. 

3. You must add one or more events to the new calendar before 
you can save it and give it a name. An easy way to do this is to 
choose New Event from the Edit menu. 

4. After adding an event, choose Save from the File menu. A 
standard file selector dialog box appears. 

5. Use the file selector controls to select the folder in which you 
would like to save the new document. To select your Document 
folder, click the Go To Document button. 

6. Type a name for the document in the New Name area; then click 
Save. The new document is saved with the name you provided. 
You are returned to GeoPlanner with that document open. 

Opening Calendar Documents 

A GeoPlanner document appears as an icon, normally in your 
Document folder, like the example at the left. You can choose 
which calendar you want to work with by opening its icon. You 
can also open a document from within GeoPlanner. 

To open a GeoPlanner document using its icon (All Levels) 

1. Locate the icon of the GeoPlanner document you wish to open. 

2. Double click the document icon. GeoPlanner starts and opens 
that document. 



To open a GeoPlanner document from within GeoPlanner (All 
Levels) 

1. Choose Close from the File menu. If you have unsaved changes 
in the current calendar, you will be asked if you wish to save or 
discard them. 

The New/ Open dialog box appears. 

2. Click the Open button. A standard file selector dialog box 
appears. 

3. In the list, select the GeoPlanner document you wish to open. 
Use the standard file selector controls to change to a different 
folder if necessary. 

4. Click Open. The document opens and you are returned to 
Geo Planner. 

SEITING ANOTHER STARTIJP DOCUMENT 

Normally, when you start GeoPlanner directly, you open the "My 
Schedule" calendar. This is the default startup document. In Level 
3 of GeoPlanner you can set another calendar document to use 
as your startup document. For more information, see Chapter 2. 

To make another document your startup document (Level 3) 

1. Open the GeoPlanner document that you want to be your startup 
document. 

2. Choose Other from the File menu. 

3. Choose Empty Document from the submenu, and then choose 
Set Startup Document from the next submenu. A confirmation 
message appears. 

4. Click the Set Startup button to make the document the new 
startup document. 

To reset the def a ult startup document (Level 2) 

1. Choose Other from the File menu. 

2. Choose Empty Document from the submenu, and then choose 
Reset Startup Document from the next submenu. A confirmation 
message appears. 

3. Click the Reset Startup Document button to reset "My Schedule" 
as the startup document. 



L.ocument Management 

1 l' n you work with documents, you use features on the File 
1 11 u. In Level 1 of GeoPlanner, the File menu lets you perform 

following operations: 

~ 1 ate a new document 

>pen an existing document 

.1 ve a document 

a Close a document 

In Level 2 and Level 3, you see additional features on the File 
menu that let you perform the following operations: 

•Back up and restore a document 

• Make a copy of a document 

• Discard changes 

111 Rename a document 

• Edit docu ment notes 

• Set or remove a document password 

• Set a different startup document 

~ Set the document type 

For more information on file management and working with 
documents, see Chapter 1. 

CHANGING GEOPLANN ER PREFERENCES 

LEVEL 3 GeoPlanner has many preferences you can set in Level 3. 

You can change the way the Events window appears, such as by 
tu rning off the day template or by customizing the times which 
are shown . You can also change what you see when you start 
GeoPlanner, and you can specify whether GeoPlanner should 
switch from one day to the next at midnight. 



LEVEL 3 

You change Geo Planner preferences in the Change Preferences 
dialog box, which is shown in following illustration: 

Uiew On Start-Up: 

llwaus Show Todau's Date on Start-Up 
At MldniOht. Automaticellg SWitch to ttew Dav 

You can make your preferences permanent by choosing Save 
Configuration from the Options menu. 

Customizing the Day Template 

The day template is the list of times in the Events window that 
makes it easy to schedule events. The day template normally 
starts at 8:00 a.m. and ends at 6:00 p.m., incrementing in 30-
minute intervals. You can change the starting and ending times 
as well as the amount of time between each event. You can also 
turn off the day template entirely. 

To change the start or end times.for the day's events (Level 3) 

1. Choose Change Preferences from the Options menu. A dialog 
box appears. 

2. Highlight the current start time for the day's events, and then 
type a new time. Use the HH:MM format. For example, you can 
type 7:00 for a new start time. 

or 

Highlight the current end time for the day's events, and then type 
a new time. Use the HH:MM format. For example, you can type 
5:30 for a new end time. 

3. Click OK when you are finished. The day template in the Events 
window shows the new start and end times for the day's events. 
The day template must be on for you to see this change. 

4. If you want to make the changes permanent, choose Save 
Configuration from the Options menu. 



LE V E L 3 

L EVEL 3 

To change the amount of time between events (Level 3) 

1. Choose Change Preferences from the Options menu. A dialog 
box appears. 

2. Highlight the interval time, and then type the number of minutes 
you want between events. 

or 

Click the up and down arrow buttons until you see the time 
interval you want. 

3. Click OK when you are finished. The day template in the Events 
window shows the new interval time. The day template must be 
on for you to see this change. 

4. If you want to make the changes permanent, choose Save 
Configuration from the Options menu. 

Turning Off the Day Template 

When you turn off the day template, only scheduled events 
display in the Events window; the Events window is otherwise 
blank. With the day template off, you see more events in the 
Events window, but it can be more difficult to schedule new 
events . For information on scheduling events when the day 
template is off, see "Adding Events With the Day Template Off" 
in this chapter. 

To turn off the Day Template (Level 3) 

1. Choose Change Preferences from the Options menu. A dialog 
box appears. 

2. Deselect the Day Template option. The check box becomes grey. 

3. Click OK when you are finished. The day template no longer 
appears in the Events window. 

4. If you want to make the setting permanent, choose Save 
Configuration from the Options menu . 

You can turn the day template back on by repeating these steps, 
reselecting the Day Template option. 

Showing Empty Days When Viewing a Range 

When you select a range of days, the Events window shows all 
events occurring during the range, listed by day. When a day has 
no scheduled events, it is considered "empty" and is normally not 
shown in the Events window. If you want to see the dates for all 
days in a range, even those days which are empty, you can select 



LEVEL 3 

the Show Empty Days option from the Change Preferences dialog 
box. 

To show empty days (Level 3) 

1. Choose Change Preferences from the Options menu. A dialog 
box appears. 

2. Select Show Empty Days. The check box turns black. 

3. Click OK when you are finished. Now when you select a range 
of days, the Events window lists dates for all days you have 
selected. 

4. If you want to make the setting permanent, choose Save 
Configuration from the Options menu. Otherwise, the change 
persists until you exit GeoPlanner. 

You can deselect the Show Empty Days option so that empty 
days are again hidden by repeating these steps, but clicking the 
option again so that the check box turns gray. 

Setting the Alarm Time for All Events 

Alarms normally go off at the time of the scheduled event. You 
can change the alarm settings of any individual event so that the 
alarm goes off earlier than the scheduled time. If you do this 
often, you may prefer to have all alarms precede their events by 
some specified number of minutes , hours , or even days. You can 
use Reminder Precedes Event Time By section of the Change 
Preferences dialog box to specify a time. When you schedule 
new events, GeoPlanner will use this preference to determine the 
initial alarm time, though you can still adjust each alarm 
individually. 

To adjust the alarm time for all events (Level 3) 

1. Choose Change Preferences from the Options menu. A dialog 
box appears. 

2. In the Reminder Precedes Event Time By section, change the 
Minutes, Hours, or Days shown. Click the up and down arrows, 
or click in each box and edit the numbers. 

3. Click OK when you are finished. Events you now schedule will 
now have an alarm time that precedes the event by the specified 
number of Minutes , Hours, and Days. 

4. If you want to make the setting permanent, choose Save 
Configuration from the Options menu. Otherwise, the change 
persists until you exit GeoPlanner. 



LEVEL 3 

LEVEL 3 

Changing What You See When You Start GeoPlanner 

In Level 3, GeoPlanner starts with both the Calendar window 
showing and the Events window showing. Today is selected. 
You can choose to have only the Calendar window or only the 
Events window showing when GeoPlanner starts, and you can 
have GeoPlanner show the last selected day instead of today. 

To change what you see when you start GeoPlanner (Level 3) 

1. Choose Change Preferences from the Options menu. A dialog 
box appears. 

2. If you want to change which windows you see when start 
GeoPlanner, select one of the following View on Start-Up options 
in the General Preferences section of the dialog box: 

Calendar Only. Select this option if you want GeoPlanner to 
start with only the Calendar window showing. 

Events Only. Select this option if you want GeoPlanner to start 
with only the Events window showing. 

Both. Select this option if you want to see both windows when 
GeoPlanner starts, which is the default. 

3. If you want to change which date you see when you start 
GeoPlanner, click Always Show Today's Date on Start-Up to 
select or deselect this option. When selected, GeoPlanner shows 
today's date when you start. When deselected, GeoPlanner 
shows the date you were viewing when you last closed the 
calendar instead of today's date. 

4. Click OK when you are finished. The dialog box closes. 

5. Choose Save Configuration from the Options menu. The changes 
are saved for the next time you start GeoPlanner. 

Automatically Switching Days at Midnight 

Usually, if you are using GeoPlanner past midnight, GeoPlanner 
automatically changes the selected day at midnight. You can turn 
off this feature so that GeoPlanner never changes the day while 
you are using the application. 

To stop GeoPlanner from changing the day at midnight (Level 3) 

1. Choose Change Preferences from the Options menu. A dialog 
box appears. 



2. In the General Preferences section, <I 1. I 

Automatically Switch to a New Day. Thl 
gray. 

3. Click OK when you are finished. 

vlidnight, 
'1eck box becomes 

4. If you want to make the setting permanent, choose Save 
Configuration from the Options menu. Otherwise, the change 
persists until you exit GeoPlanner. 

You can go back to having GeoPlan 
midnight by repeating these steps , ( 
Automatically Switch to a ew Day ' 
is black. 

FINE TUNING YOUR USER LEVEL 

~e the day at 
' At Midnight, 

'-.1 that the check box 

In addition to changing to another, pre-defined user level, you 
can also customize a user level. For example, in Level 1 you see 
only the Calendar window. At first , yo u may find this helpful, but 
as you work with GeoPlanner, you may want to see the Events 
window at the same time. You can adc. functionality like this 
without having to move to a higher level. This is called fine 
tuning your user level. 

For more information about fine tuning yuur user level, see 
Chapter 1. 



The GeoPlanner fine-tuning options are described in the 
following table: 

I FINE-TUNING OPTION DESCRIPTION 

Select Multiple Days Lets you select more than one day in the 
Calendar. 

Page Size Lets you define the size, width, height, 
layout, and type of paper for your 
printed calendar. 

Alarms Lets you set an alarm to remind you of 
appointments or special events. 

View Both At Once Lets you see both the Calendar and 
Events windows at the same time. 

Different Month Lets you view the months of your 
Views calendar in different ways. For example, 

you can view a single month or an 
entire year. 

Preference Settings Customizes different features in 
GeoPlanner. For example, you can set 
an event start and end time. 

Quick Go Back Lets you go to the previous place in 
your calendar. 

Repeating Events I Lets you define events that occur 
regularly in your schedule. 

Find Lets you find specific dates and events 
in the Events window. 

GeoDex Lookup Lets you look up information in your 
GeoDex address cards. 



CHAPTER 5 

Geo Dex GeoDex is your electronic address and telephone 

directory. It is much more versatile than a handwritten address 

book. You can use Geo Dex to store addresses and telephone 

numbers, as well as notes and reminders. 



STARTING GEODEX 

ALL LEVELS 

De:=< 

• 

You can also use GeoDex to look people up by their first or last 
name, and to identify people in your directory who live on the 
same street or share an interest of yours. With GeoDex, you can 
keep separate directories for personal contacts and business 
contacts , print lists of names and telephone numbers, and 
automatically dial your phone calls (if you have a modem). 

GeoDex has three user levels. For more information about 
changing user levels, see Chapter 1. For more information about 
the user levels in GeoDex, see "User Levels in GeoDex" in this 
chapter. 

This chapter describes how to do the following: 

• Create, edit, and save GeoDex cards. 

• Add notes to cards. 

• Merge GeoDex files from one address book to another. 

• Import and export GeoDex information. 

• Automatically see a certain view on startup. 

• Perform basic and advanced searches through cards. 

• Print your address book information . 

• Dial phone numbers using GeoDex (if you have a modem). 

This chapter assumes you are familiar with the information 
covered in Chapter 1 which provides an overview of the skills 
you need to use any GEOS application. 

The GeoDex icon appears in the WORLD folder of GeoManager 
and looks like the example at the left. You can start GeoDex 
either from GeoManager or from the Express Menu that appears 
in all GEOS application windows. 

To start GeoDex (All Levels) 

Locate the GeoDex icon and double-click it. 

or 

Choose GeoDex from the Express Menu in any GEOS 
application. 



The GeoDex window appears: 

When you start GeoDex, the first card in the default address 
book appears in the GeoDex window. If you haven't stored any 
information, the card is blank. For more information about the 
default address book, see "Using the Default Address Book" in 
this chapter. 

For more information about starting GEOS applications, see 
Chapter 1. 

USER LEVELS IN GEODEX 

There are three user levels in GeoDex, as follows: 

• Level 1 presents simplified menus and task selections. 

• Level 2 adds the Notes button and the Utilities menu . 

• Level 3 adds the GeoPlanner button and the View menu , and 
lets you perform all the tasks possible in GeoDex. 

For more information about changing and saving user levels, see 
Chapter 1. 

Anytime you change your user level, you can use the following 
procedure to reset GeoDex back to Level 1. 

To reset your user level to Level 1 (Both Levels) 

• Choose Reset Configuration from the Options menu. 



USING THE DEFAULT ADDRESS BOOK 

First Address Book is the document that automatically opens 
when you initially start GeoDex. If you have not added any cards 
to this default address book, the document is empty. If you have 
already scheduled events , you can view and change them. 

If you want to start adding cards now, you can use the default 
address book. If you plan to keep more than one address book, 
you may want to create new GeoDex documents. For more 
information about adding cards, see "Working With Cards" in this 
chapter. For more information about creating new address books, 
see "Working With Documents" in this chapter. 

You use the default address book in the same way you use any 
GeoDex document. 

WORKING WITH CARDS 

ALL LEVELS Geo Dex documents are ref erred to as address books. Address 
books contain a series of cards, or records, much like the cards in 
a real card file . Each card contains the name, address, phone 
numbers, and notes you enter for each person. On the screen, 
each record looks like a Rolodex® card. Once you fill in the 
blanks, GeoDex stores the card as a record in your address book. 

The first time you use GeoDex, it automatically creates a 
document called "First Address Book" in your DOCUMENT 
folder. You can start entering names , addresses, and phone 
numbers in this address book right away. If you want to create 
other address books, use the New/ Open choice on the File 
menu. For information about creating other address books, see 
"Creating a New Document" in Chapter 1. 



Creating and Adding New Cards 

You can easily create new cards and add them to your address 
book. You start with a blank card and then type information into 
three fields: the index field , the address field , and the phone 
number field. The following illustration shows these fields: 

Flip to cards by letter (index tabs) . 

Fl ip to cards that aren't grouped under a letter. 

Address field 

Phone number field 

Phone name field 

I Use to scroll through phone numbers. 

To add cards to y our address book (All Levels) 

Fl ip to another caret 

File current card 
and create a new 
blank card. 

Click to dial the 
displayed phone 
number. 

1. Click the New button. GeoDex displays a blank card with the 
insertion point positioned in the index field . 

2. If you're adding a card for a person, type the person's name in 
the index field in last-name, first name order. GeoDex uses the 
index field to sort cards in alphabetical order. So, for example, 
type Adams, Chuck, not Chuck Adams. Be sure to type a 
comma after the last name. 

or 

If you're adding a card for a company, type the company name 
as you want it to appear in an alphabetical list. For example, type 
The ABC Corporation or ABC Corporation, depending on 
whether you want to store the card under "T" or "A. " 



3. Press Enter. The name you typed in the index field is copied to 
the first line of the address field automatically and the insertion 
point is placed after the last character. If you typed a last name 
and first name separated by a comma in the index field, then the 
two name switch places as they are copied. For instance, "Adams, 
Chuck" in the index field becomes "Chuck Adams" in the address 
field. 

4. If you want to modify the name as it appears in the address 
field - by changing "Chuck" to "Charles," for example - you 
can use Backspace to delete the incorrect text, and then enter 
the revised name. 

4. Press Enter again, and then type the address information. Press 
Enter at the end of each line of the address. The address field 
scrolls to accommodate long addresses. 

5. Move to the phone number field by pressing Ctrl+Tab four 
times, or by clicking in the field with the mouse. 

6. Enter a home phone number if you want. GeoDex also provides 
a place for you to record several different phone numbers for 
each name in your address book. The first number displayed is 
the HOME number. Press Enter or click the arrow buttons to see 
other phone number categories, OFFICE, CAR, and FAX. There is 
also a blank line where you can enter another type of number if 
you want. For more information on adding or changing phone 
types, see the procedures following this one . 

If you have a modem attached to your computer and you want to 
use GeoDex to dial your phone calls automatically, you need to 
follow a few guidelines when you enter phone numbers. For 
more information, see "Tips for Modem Users" in this chapter. 

7. To save this card and create a new one, click the New button. 
GeoDex automatically stores the card you just created 
alphabetically behind the appropriate index tab. Names that don't 
begin with letters, such as "3 Star Plumbing," are stored behind 
the index tab labeled with an asterisk (*). 

ADDING AND CHANGING PHONE TYPES 

Each address card can have up to seven phone numbers stored 
along with it. GeoDex provides four standard categories -
HOME, OFFICE, CAR, and FAX - which you can change on a 
card-by-card basis or add your own. 



Previous 

To add a phone type to the current card (All Levels) 

1. Click the up and down arrows next to the phone field until you 
see an empty entry in the phone list. If there are no empty entries 
in the phone list, then this card already has seven phone 
numbers. 

2. Click in the phone type field. The insertion point appears . 

3. Type a name for the phone type. For example, you could type 
800 to represent an 800 number or you could type HOME 2 to 
identify a second home number. 

4. Press Tab or click in the phone number field. The insertion point 
appears in the phone number field. 

5. Type the phone number. The new phone number and type are 
now a part of the card. 

You can repeat these steps until the card has a total of seven 
phone numbers. 

To change a phone type on the current card (All Levels) 

1. Click the up and down arrows next to the phone field until you 
see the entry you want to change. 

2. Click in the phone type field. The insertion point appears. 

3. Edit the existing phone type . You can press Delete or 
Backspace repeatedly and then type the new name for this 
ent1y. 

4. Press Tab or click in the phone number field. The insertion point 
appears in the phone number field. 

5. Type the phone number. The phone number and type are now a 
part of the card. 

Flipping Through Cards 

You can flip through the cards in your address book using the 
ext and Previous buttons. You can also jump quickly to a 

particular letter by clicking the appropriate index tab. The cards 
are indexed alphabetically, with non-alphabetic entries stored 
under the asterisk (*) tab. You can start flipping through cards 
from any point; just click an index tab if you want to start with a 
particular letter. If you reach the end of the cards, click Next to 
continue from the beginning. Likewise, if you 're at the beginning, 
click Previous to continue from the end. 



Editing Cards 

To make changes in cards, locate the card you want to change by 
clicking the appropriate index tab, then clicking the Next button 
until the card you want appears. Change text by selecting it with 
the mouse and replacing it with new text, the same way you 
would change text in any GEOS application. For more 
information about editing text, see Chapter 1. 

You can undo a change by choosing Undo on the Edit menu 
before you do any other task. The card will revert to its original 
form. 

Copying Cards 

It's convenient to copy cards when you want to be able to store 
several different names at the same address, or when a person 
has more than one address that you want to keep track of, such 
as a home and a business address. You can save yourself some 
typing time by using the Copy Record choice on the Edit menu 
to copy the card with the basic information. Then, you can edit 
the copy. 

To copy a card (All Levels) 

1. Flip through your address book until the card you want to copy 
is displayed. 

2. Choose Copy Record from the Edit menu. 

3. Click the ew button to display a blank card. 

4. Choose Paste Record from the Edit menu. The information from 
the old card is pasted to the new card. Use the usual text editing 
techniques to modify the duplicate card, if necessary. 

To copy part of a card (All Levels) 

You can also use the Copy function on the Edit menu to copy a 
block of text from one card and paste it onto another. This is 
handy when you are entering a series of names all in the same 
city, for example. 

1. Select the text you want to copy. 

2. Choose Copy (not Copy Record) from the Edit menu . 

3. Click the New button to create a new card, and then enter any 
new information you want. 

4. When you come to the place where you want to place your 
duplicate text, choose Paste (not Paste Record) from the Edit 



LEVELS 2-3 

menu. The information is pasted where you want on the new 
card. 

For more information about copying and pasting, see Chapter 1. 

Deleting Cards 

From time to time, you may want to clean up your address books 
by deleting cards you no longer need. 

To delete a card from your address book (All Levels) 

1. Flip through your cards until you find the card you want to 
delete . 

2. Choose Delete Record from the Edit menu. The card is removed 
from your address book. 

You can undo a delete by choosing Undo from the Edit menu 
right after you delete. 

Adding Notes to Cards 

Each GeoDex card can contain notes about the person or 
company shown on the card. Notes are useful for keeping track 
of birthdays, children's names, business associates' names, special 
interests , and any other information you like. Use the Notes 
button to add notes to cards. 

Click here to add notes to a ! 
card in Level 2 and Level 3. 



To add notes to a card (Levels 2-3) 

1. Click the Notes button. A small window appears in which you 
can type the note: 

2. Type any information you like. 

3. Click Close to close the window. The note is attached to the 
current card. 

To review the notes for a card (Levels 2-3) 

• When you want to view or edit your notes for the current card, 
click the Notes button. 

SEARCHING THROUGH CARDS 

L EVELS 2 - 3 

LEVEL 2 

GeoDex allows you to search for cards containing information 
that you specify. For example, you can find all the cards 
containing Ehn Street, or all the cards containing area code 203. 

Two levels of search capability are available: 

• Level 2 provides a basic search capability. 

• Level 3 provides more advanced searching, allowing you to 
specify more options to narrow your search. 

Basic Searching 

In Level 2, you can do a basic search through your cards for such 
items as names, ZIP codes, street names, and phone numbers. 

GeoDex will search through all areas of the card, including the 
index field, the address field , the phone fields , and the Notes 
box. 



LEVEL 3 

To perform a basic search (Level 2) 

1. Choose Find from the Utilities menu. The Find dialog box for 
Level 2 appears: 

2. Enter the letters or numbers you want to find in the Find field. 

3. Click Find Next. GeoDex displays the first card containing the 
specified text. The text that GeoDex found is highlighted in the 
displayed card. If there is no match for the specified text, 
GeoDex informs you that no match was found. 

The text you search for is not case-sensitive. You don't need to 
wony about using uppercase and lowercase letters exactly as 
they appear in your cards. For example, if you search for 
"adams", GeoDex finds "Adams". 

4. Click the Find Next button again if you want to search for more 
matching entries. 

or 

Click Close when you are done searching. 

Advanced Searching 

In Level 3, you can set additional options to control how GeoDex 
searches for information, but the basic search procedure remains 
the same. 

To perform an advanced search (Level 3) 

1. Choose Find from the Utilities menu. The Find dialog box for 
Level 3 appears. 



LEVEL 3 

2. Fill in the dialog box, typing the text you want to search for in 
the Find field, and choosing the options you want. The search 
normally looks in all fields, but by turning off some of the check 
boxes in the dialog box, you can optionally disable searching in 
one or more fields - Addresses, Notes, or Phone Numbers. For 
example, there is no point in searching address fields or notes if 
you are only looking for people in the 203 area code. By turning 
off the check boxes for Addresses and ates, you can restrict the 
search to the phone number fields (and the index field , for 
which you cannot disable searching) . 

Select or deselect these options to specify 
fields in which the search will occur. 
Remove all three check marks to search 
only the index field . 

3. Cli ck Find Next. GeoDex displays the first card containing the 
specified text. The text that GeoDex found is highlighted in the 
displayed card. If the text was found in the Notes box, the Notes 
box opens automatically and the text is highlighted. If there is no 
match for the specified text, GeoDex informs you that no match 
was found. 

4. Click the Find Next button again if you want to search for more 
matching entries. 

or 

Click Close when you are done searching. 

Setting Sort Options 

At Level 3, you can set sort options for search operations. 

To set sorting options (Level 3 ) 

1. Choose Sorting Options from the Options menu. A dialog box 
appears: 
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G ann ... 

The dialog box offers a choice between the following two sorting 
options: 

Include Spaces and Punctuation. This option includes spaces 
and punctuation marks when determining the ordering of your 
cards. With this option "Hill-Warner, Mary" would appear in front 
of "Billings, David" because the fifth character in "Hill-Warner", 
the hyphen, has a higher alphabetic precedence than the "i" in 
"Billings" 

Ignore Spaces and Punctuation (Phone Book Order). This 
option does not include spaces and punctuation marks when 
sorting. This is the default setting, which sorts your cards in a 
way more like a phone book. For instance, "Billings" would 
appear in front of "Hill-Warner" because, by ignoring 
punctuation, "Hill-Warner" is seen as "Hillwarner" for sorting 
purposes. 

2. If the setting is the way you want, click Close. 

or 

Change the setting and click Apply; then click close. A dialog 
box appears asking if you want to resort the database. Click Yes. 

Linking to GeoPlanner 

If you are searching for a name that also happens to be in your 
GeoPlanner calendar, the Search function activates the 
GeoPlanner button. This is useful , for instance, if you are looking 
at Maria Fitzpatrick's address card and want to know when your 
next meeting with her is scheduled. 

To search for text in GeoPlanner (Level 3) 

1. Select the text you want to search for in GeoPlanner. The 
GeoPlanner button becomes available. (If the GeoPlanner button 
is dimmed, then you have not selected any text.) 

2. Click the GeoPlanner button. You see the GeoPlanner window 
and the first event that matches the text you selected in GeoDex 
is shown highlighted. The GeoDex Find dialog box is open as 
well. 

If there is no match for the specified text, then GeoPlanner 
informs you that no match was found. 

3. If you find the information you want in the first card, click 
anywhere inside the GeoPlanner window to return to 
GeoPlanner. 

or 



If you want to continue searching for the selected text in 
GeoDex, click Find Next in the Find dialog box to find the next 
card that matches the selected text. 

NOTE 

The GeoDex window will remain open until you close it. There is no 
need to close it right away, especially if you intend to do another 
lookup. When you are ready to close it, choose Exit from the File 
menu in GeoDex or double-click its window control button. 

DIALING PHONE NUMBERS 

ALL LEVELS 

LEVELS 2 - 3 

If you have a modem connected to your computer, GeoDex can 
dial your telephone numbers for you. Before you dial with 
GeoDex, be sure to review the "Tips for Modem Users" section in 
this chapter. 

Using the Dial Button 

To have GeoDex dial a phone number (All Levels) 

1. Flip to the card containing the phone number you want to call. 

2. Click the Dial button. A dialog box appears asking if you are sure 
you want to dial this number. 

3. If the number is incorrect, you can click in the field and edit it 
now. 

4. Click Dial to place your call. If your modem has a built-in 
speaker, you hear the dial tone , the number being dialed, and 
the ringing tone (or a busy signal). 

5. As soon as the modem finishes dialing the number, pick up the 
handset of your phone and click the Talk button. Clicking Talk 
transfers the call from your modem to your telephone. Until you 
click Talk, the person who answers the phone cannot hear you 
speaking. 

Using Quick Dial 

At Levels 2 and 3, the Quick Dial option appears on the Utilities 
menu. When you choose Quick Dial, GeoDex displays a list of 
your 10 most frequently called people, along with a list of your 
10 most recently called people. 



LEVEL 3 

To Quick Dial a phone number (Levels 2-3) 

1. Choose Quick Dial from the Utilities menu. The following dialog 
box appears: 

2. Click the name you want to call. GeoDex dials the number. Be 
sure to pick up the phone handset and click Talk before the 
person you are calling answers. 

Setting Dialing Options 

If you are working at Level 3, you can set certain dialing options. 
Setting dialing options can save you keystrokes as you enter the 
phone numbers in your address book. For example, if there is a 
special number that you must always dial before each number, 
such as an access code for an outside line, you can enter it 
before every number, or you can have GeoDex automatically 
place it in front of eve1y number by entering it in the Long 
Distance Prefix box in the Dialing Options window. 

To set dialing options (Level 3) 

1. Choose Dialing Options from the Options menu. A dialog box 
appears: 

When Dialing v Choose From List of Phone Numbers 
• Rlways Dial Displaged Phone Humber 



2. Select the options you want from the dialog box. 

Long Distance Prefix. Use this box to enter the following 
access codes: the number 1 followed by the area code (which is 
entered in parentheses), a + sign before international phone 
numbers, any dialing sequence needed for a long-distance 
service, and any comma needed for a brief pause in the dialing. 
For more information about these access codes, see "Tips for 
Modem Users" in this chapter. 

Current Area Code. Use this box to store the area code of the 
place from which you are calling. This is the number that is error
checked when you are making a long distance call. If the number 
you are about to dial has the same area code as the number in 
this box, GeoDex ignores the area code and dials the number 
without it 

Assumed Area Code. This box stores the area code that GeoDex 
attaches to the beginning of the phone number that is about to 
be dialed if that phone number does not have an area code 
specifically entered. For example, if your card shows 123-1234, 
and you have 203 in this field, GeoDex dials (203)123-1234, no 
matter what. 

When Dialing. Select one of the two radio buttons to set which 
phone number GeoDex dials, as follows: 

• Choose from List of Phone Numbers . With this option selected, 
GeoDex displays a dialog box when you click the Dial button. 
The dialog box lists the available phone numbers for the name 
on the current card and asks you to select a phone number to 
dial. 

• Always Dial Displayed Phone Number. With this option 
selected, GeoDex dials the number displayed on the current 
card. This option is the default. 

Confirm Number Before Dialing. This option displays a dialog 
box asking you to make sure that the number GeoDex is about 
to dial is the correct number. It 's best to leave this option 
selected and confirm the number being dialed each time, to 
avoid dialing wrong numbers. 

Reset Modem Before Dialing. This option sends a signal to 
your modem to clear any phone numbers before the modem 
dials the next phone number. 



CHANGING VIEWS 

LEVEL 3 

Tips for Modem Users 

If you have a modem attached to your computer and plan to use 
GeoDex to dial phone calls for you, use the following guidelines 
when you enter phone numbers: 

• Omit the area code for local numbers . 

• Always place area codes within parentheses; for example, 
(503). 

• Always begin an international phone number with the + sign. 

• For long-distance calls, include the 1 and the area code, as in 
this example: 1( 4 15)555-1212. 

• If the number needs a special dialing sequence to access a long 
distance service, enter the sequence preceding the regular 
number, as in this example: 10288-1(202)555-1212. 

• Place a comma followed by a space anywhere in the phone 
number where you want a brief pause in the dialing sequence. 
This is actually a modem feature; it won't work with all 
modems, and different models delay for different amounts of 
time. Check your modem owner's manual for more information 
about this feature. It is especially useful in cases where you 
must dial an outside line access code and wait for the second 
dial tone; for example: 9 , 555-1212. When this dialing 
sequence is required before each number, use the Long 
Distance Prefix dialing option described in "Setting Dialing 
Options" in this chapter. 

• You can note on a Geo Dex card an extension number that you 
must enter manually to get through to someone. Since GeoDex 
ignores numbers after "e" or "E", when you type ext. followed 
by the extension number, GeoDex does not dial the extension. 
For example, if your card shows 34 5-6789 ext. 123 , GeoDex 
dials 345-6789. Then, you manually enter 123 at the appropriate 
time. 

If you have not done so yet, you must use Preferences to specify 
which communications port your modem is using. For more 
information on Preferences, see Appendix A. 

You can use the View menu when you work in Level 3 of 
GeoDex. The View menu gives you choices about how GeoDex 



PRINTING 

A LL L EVE LS 

displays your address book. You can choose from the following 
views: 

•Card View. This view is the only display at Levels 1 and 2. 

• Browse View. This view displays an alphabetical list of names 
and lets you scroll through it. 

•Both View. This displays both a card view and a browse list. If 
you click on a name in the browse list, GeoDex displays the 
card for that name. 

Double-clicking a letter tab in Card View brings up the Both 
View display. Double-clicking a name from the list in Browse 
View also brings up Both View. 

If you prefer Browse View or Both View, you can choose to have 
GeoDex automatically display that view. 

To change the startup view in the GeoDex window (Level 3) 

1. Choose View on Startup from the Options menu. 

2. Choose either Card View, Browse View, or Both View, whichever 
view you want to see when you start GeoDex. 

3. Choose Save Configuration from the Options menu. The next 
time you start GeoDex, you will see that view. 

When you print with GeoDex, you print just the information in 
your address book, not the card design that appears in the 
window. GeoDex allows you to print the information that is 



currently displayed on screen as a card, or a list of either 
addresses and phone numbers or just phone numbers. 

At Levels 2 and 3, you can also print any notes that are associated 
with cards. 

To print with GeoDex (All Levels) 

This procedure describes the printing options that are unique to 
GeoDex. For more information about printing, see Chapter 2. 

1. Open the address book you want to print. 

or 

Flip to the card you want to print. 

2. Choose Print from the File menu. The Print dialog box appears: 

This option is only available in 
Level 2 and Level 3. 

3. Fill in the Printer Options and Document Options sections of this 
dialog box as described in Chapter 2. 

4. Fill in the Print Options section of the dialog box, using the 
options you want. 

Current Record. This option prints the information that is 
currently displayed on screen as a card. 

All Records - Addresses and Phone Numbers. This option 
prints a list of the index fields, addresses, and phone numbers 
from all cards in your address book. 

All Records - Phone Numbers Only. This option prints a list of 
only the index fields and phone numbers from all cards in your 
address book. 



Print Notes. This option appears for Levels 2 and 3 only. When 
checked, this option prints the notes associated with your cards 
when you are printing with the All Records - Addresses and 
Phone Numbers option. The notes are inserted between the 
addresses and phone numbers in the printed list. 

5. Click Print. If you are printing either with the All Records -
Addresses and Phone Numbers option, or with the All Records -
Phone Numbers Only option, a list of the items you specified 
prints. Notes are inserted in the list if you are printing with the 
Print Notes option. 

or 

If you are printing with the Current Record option, the 
information from the card currently on screen prints. 

SAVING AND EXIT ING 

ALL L E V E LS If you've made changes or additions to your address book and 
want to make the changes permanent, you can do this by saving 
your document. 

When you are done using GeoDex, you should exit it. Exiting an 
application closes its window and frees up system resources. You 
should save your document before exiting, but if you forget 
GeoDex will give you one last chance to save your changes. 

To save changes to your document (All Levels) 

• Choose Save from the File menu. GeoDex saves your changes 
and returns you to the document. 

For more information about saving changes, see "Saving 
Documents" in Chapter 1. 

NOTE 

GeoDex automatically safeguards you r address book while you are 
working on it. In the event of a power fa il ure o r other problem, you r 
work is probably safe even if you haven't used the Save menu choice. 
By adjusting the Document Safeguarding Time in the Look & Feel 
section of Preferences, you can control how frequently th is 
safeguarding takes place. For more information, see Appendix A 

To exit GeoDex (All Levels) 

• Choose Exit from the File menu. 



or 

Double-dick the window control button, located in the top left 
corner of the Geo Dex window. 

The GeoDex window closes and the application exits . If you 
have unsaved changes in your document, GeoDex will ask if you 
want to save those changes. 

WORKING WITH DOCUMENTS 

ALL LEVELS 

Before you create a 
new address hook 
you must first save 
and close the current 
one. 

GeoDex provides a standard document called "First Address 
Book" in your DOCUMENT folder. Whenever you start GeoDex, 
this document opens automatically, making it easy to keep all of 
your addresses in one place. If you keep just one address book, 
you should use this document. 

However, you may want to keep additional address books. For 
instance, you may find it easier to keep business contacts in one 
address book and keep friends and family in another. You can 
use GeoDex to track these address books as well. 

Creating a New Address book 

It is easy to create a new Address book document from within 
GeoDex. The basic procedure is covered here. For more 
information about creating and naming a new document, see 
Chapter 2. 

To create a new address book document (All Levels) 

1. Choose Close from the File menu. If you have unsaved changes 
in the current address book, you will be asked if you wish to 
save or discard them. 

The New/ Open dialog box appears. 

2. Click the New button. A new address book appears. 

3. You must add one or more cards to the new address book 
before you can save it and give it a name. 

4. After adding a card, choose Save from the File menu. A standard 
file selector dialog box appears. 

5. Use the file selector controls to select the folder in which you 
would like to save the new document. To select your 
DOCUMENT folder, click the Go To Document button. 

C ">I 



A LL L E VELS 

First Address Book 

6. Type a name for the document in the New Name area; then click 
Save. The new document is saved with the name you provided. 
You are returned to GeoDex with that document open. 

Opening Address Book Documents 

A GeoDex document appears as an icon, normally in your 
DOCUMENT folder, like the example at the left. You can choose 
which address book you want to work with by opening its icon. 
You can also open a document from within GeoDex. 

To open a GeoDex document using its icon (All Levels) 

1 . Locate the icon of the GeoDex document you wish to open, 
usually in your DOCUMENT folder. 

2. Double click the document icon. GeoDex starts and opens that 
document. 

To open a GeoDex document from within GeoDex (All Levels) 

1. Choose Close from the File menu. If you have unsaved changes 
in the current address book, you will be asked if you wish to 
save or discard them. 

The New/ Open dialog box appears. 

2. Click the Open button. A standard file selector dialog box 
appears. 

3. In the list, select the GeoDex document you wish to open. Use 
the standard file selector controls to change to a different folder 
if necessary. 

4. Click Open. The document opens and you are returned to 
Geo Dex. 

SETTING ANOTHER STARTIJP DOCUMENT 

Normally, when you start GeoDex directly, you open the "First 
Address Book" document from your DOCUMENT folder. This is 
the default startup document. In Level 3 of GeoDex you can set 
another address book document to use as your startup 
document. Fore more information, see Chapter 2. 

To make another document your startup document (Level 3) 

1. Open the GeoDex document that you want to be your startup 
document. 

2. Choose Other from the File menu . 



LEVELS 2 - 3 

3. Choose Empty Document from the submenu , and then choose 
Set Startup Document from the next submenu. A confirmation 
message appears. 

4. Click the Set Startup button to make the document the new 
startup document. 

To reset the def a ult startup document (Level 2) 

1. Choose Other from the File menu. 

2. Choose Empty Document from the submenu, and then choose 
Reset Startup Document from the next submenu. A confirmation 
message appears. 

3. Click the Reset Startup Document button to reset "First Address 
Book" as the startup document. 

Merging Two Address Books 

Merging GeoDex files is useful for placing information from one 
address book into another. You can only merge whole address 
books. 

To merge two GeoDexfiles (Levels 2-3) 

1. With one of the documents open, choose Other from the File 
menu. A submenu appears. 

2. Choose Export Document from the submenu. The Export dialog 
box appears: 

3. Click Export to Clipboard. The information in this address book 
is stored on the clipboard. 

4. Close the current document and open the address book 
document into which you want to merge the first document. For 
more information about opening a document, see "Opening 
Address Book Documents" in this section. 



5. Choose Paste Record from the Edit menu. The entire address 
book you exported to the clipboard will be pasted into your 
current address book. 

File management 

When you work with documents, you use features on the File 
menu. In Level 1 of GeoDex, the File menu lets you perform the 
following operations: 

• Create a new document 

• Open an existing document 

• Save a document 

• Close a document 

In Level 2 and Level 3, you see additional features on the File 
menu that let you perform the following operations: 

• Back up and restore a document 

• Make a copy of a document 

• Discard changes 

• Rename a document 

• Edit document notes 

• Set or remove a document password 

• Use another startup document 

• Set the document type 

For more information on working with documents, see 
Chapter 2. 

SAVING AND EXITING 

ALL LEVELS If you've made changes or additions to your address book and 
want to make the changes permanent, you can do this by saving 
your document. 

When you are done using GeoDex, you should exit it. Exiting an 
application closes its window and frees up system resources . You 
should save your document before exiting, but if you forget 
GeoDex will give you one last chance to save your changes. 



To save changes to your document (A ll Levels) 

• Choose Save from the File menu. GeoDex saves your changes 
and returns you to the document. 

For more information about saving changes, see "Saving 
Documents" in Chapter 2. 

NOTE 

GeoDex automatically safeguards your address book while you are 
working on it. In the event of a power failure or other problem, your 
work is probably safe even if you haven't used the Save menu choice. 
By adjusting the Document Safeguarding Time in the Look & Feel 
section of Preferences, you can control how frequently this 
safeguarding takes place. For more information, see Appendix A 

To exit GeoDex (A ll Levels) 

• Choose Exit from the File menu. 

or 

Double-click the window control button, located in the top left 
corner of the GeoDex window. 

The GeoDex window closes and the application exits. If you 
have unsaved changes in your document, GeoDex will ask if you 
want to save those changes. 

IMPORTING AND EXPORTING ADDRESS BOOKS 

LEV E LS 2-3 

Importing Other Address Books 

You can import address files , such as mailing lists, from some 
database and spreadsheet application programs, and turn them 
into GeoDex address books. The application formats you can 
import are the following: 

• CSV (comma separated value) 

• dBase III 

• dBase IV 

• Lotus 1-2-3 versions 

To import an address file (Levels 2-3) 

1 . Choose Close from the File menu to close the current address 
book. The New/ Open dialog box appears. 



2. Click the Import button. A dialog box appears: 

3 . Fill in the dialog box, changing the options you want: 

Use the standard file selector controls at the left of the dialog box 
to select the file you want to import. For more information about 
using file selectors, see Chapter 2. 

Formats. If you know the format of the file you want to import, 
you can select it from the Formats list. Then, the file extension 
appears in the File Mask box and only files with that extension 
are displayed in the file selector. If you don't know the file 's 
format, select No Idea (Auto-Detect) in the Formats box. 

File Mask. When you choose a format from the Formats list, the 
file mask updates automatically. A file mask is like a filter that 
separates the specified type of file . For example, if you choose 
the dBase III format, the file extension is .DBF, and the file mask 
is *.DBF. The file mask tells the file selector to display all files 
with the extension .DBF. You can enter a new file mask directly 
into this field to change which files are shown in the list. For 
more information about file extensions, see Chapter 2. 



Mapping correlates 
fields from the.file 
you are importing to 
fields in GeoDex. 

4. Click the Map Import Fields button. The Map Import Fields dialog 
box appears: 

I In the Source list, click a field 
name to map from a fi le. 

I I In the destination list, cl ick the GeoDex 
I J field name to which you want to map. 

Field 3 
field 4 

1 This list shows the pairs of 
fields you've mapped. 

I Click this button if you make a mistake. 

I 
Click this button for each pair of 
fields you've selected to map. 

5. Select one field in the Source list and one corresponding field in 
the Destination list and click Map. The correlation is added to the 
Map List. 

For example, you can map Field 3 in the Source List to the 
GeoDex Addr_Field (address field) in the Destination list. 

7. Repeat step 5 until you have mapped all the fields you want. 
Select from the Map List and click UnMap to change any map 
pairs you have designated incorrectly. 

8. When you have mapped all the fields you want, click Done. The 
Import dialog box reappears. 

9. Click Import. A message appears telling you that the import is in 
progress. If the file is very large, it could take several minutes to 
import. You cannot interrupt this process. 

When the import is finished, you are returned to GeoDex with 
the imported address book open. If the imported file meets your 
satisfaction, you can save the document and give it a name. For 
more information on saving and naming new documents, see 
"Saving Documents" in Chapter 2. 



LEVELS 2-3 

Exporting a GeoDex Document 

You can export GeoDex information to other applications. For 
example, if you have a mailing list in dBase III, you can export 
GeoDex information in a format so that it can be used in the 
dBase III mailing list. Some word processors that support mail 
merge can use address information exported in the CSV (comma 
separated value format). You can export to the following formats: 

• CSV (comma separated value) 

• dBase III 

• dBase IV 

• Lotus 1,2,3 

• Quattro Pro 

Exporting converts the information in your current address book 
to the selected format, and stores it in a separate file. This does 
not affect the information saved in your address book. 

To export an address book (Levels 2-3) 

1. Choose Other from the File menu. A submenu appears. 

2. Choose Export Document from the submenu. A dialog box 
appears: 

3. Fill in the dialog box, changing any options if necessary. 

Use the standard file selector controls at the left side of the dialog 
box to select the folder where you wish to place the exported 
file. For more information about using file selectors, see 
Chapter 2. 

Formats. Select from this list to specify the format of the file you 
will create when exporting. The information in GeoDex will be 
exported in the selected format. 



Mapping correlates 
fields from GeoDex 
to fields in the file 
you are exporting. 

New File Name. Type a name for the export file in this box. 
GeoDex provides the correct three-letter extension for the format. 
For more information about file extensions, see Chapter 2. 

4. Click the Map Export Fields button. The Map Export Fields dialog 
box appears: 

5. Select one field in the Source list and one corresponding field in 
the Destination list to correlate the field information from the 
address book to the new file format. For example, you can map 
the GeoDex address field to Field 3. 

6. Click Map. 

7. Repeat steps 5 and 6 until you have mapped all the fields you 
want. Select from the Map List and click UnMap to change any 
map pairs you have designated incorrectly. 

8. When you have mapped all the fields you want, click Done. The 
Export dialog box reappears. 

9. Click Export. A message appears telling you that the export is in 
progress. If the file is very large, it could take several minutes to 
import. You cannot interrupt this process. 

FINE TUNING YOUR USER LEVEL 

In addition to choosing a particular user level, you can customize 
a user level. For example, you may want to add notes to cards at 
Level 1. By fine tuning Level 1, you can add the Notes button so 
that you can add notes to cards at this level. 

For more information about how to fine tune your user level, see 
Chapter 1. 



The GeoDex fine-tuning options are described in the following 
table: 

FINE-TUNING OPTION DESCRIPTION 

otes Button This option displays the Notes button 
so you can add notes to your cards. 

GeoPlanner Button This option displays the GeoPlanner 
button so you can start GeoPlanner and 
search for text you specify. 

Utils Menu This option displays the Utilities menu. 

View Menu This option displays the View menu. 

Search Options This option displays the Search options 
for the Find dialog box. When you 
select this option in Level 2, you add 
the Search options to the Find dialog 
box. When you select this option in 
Level 3, you remove the Search options 
from the Find dialog box. 

Sorting Options This option displays the Sorting 
Options choice on the Options menu . 

Dialing Options This option displays the Dialing 
Options choice on the Options menu. 



CHAPTER 6 

Calculator The Calculator application puts a versatile calculator on 

your computer desktop. You can use your online calculator to do 

standard calculator tasks, like adding, subtracting, multiplying, 

dividing, and computing percentages. You can store the results in 

the Calculator's memory or paste them into other applications , 

such as GeoComm or Text File Editor. You can perform metric to 

English conversions, use trigonometric functions , and customize 

the calculator to your liking. 



This chapter describes how to do the following: 

• Use the different buttons on the calculator. 

• Make basic calculations, such as addition and subtraction. 

• Store numbers in the calculator's memory. 

• Customize your calculator's format and function. 

• Convert numbers from one type of measurement to another. 

The Calculator does not have user levels. 

ST ARTING THE CALCULATOR 

Calculator 

The Calculator icon appears in the WORLD directory of 
GeoManager and looks like the example at the left. You can start 
Calculator either from GeoManager or from the Express menu 
that appears in all GEOS application windows. 

To start the Calculator 

• Locate the Calculator icon and double-click it. 

or 

Choose Calculator from the Express menu in any GEOS 
application. 

The Calculator window appears. The Calculator window looks 
like a standard desktop or hand-held calculator. 

I Readout bar 

Paper tape 

Keyboard 

The Calculator window includes a Menu bar, readout bar, 
buttons, and paper tape . The buttons work much like the keys 
on a real calculator. The numbers and results are displayed in the 
readout bar. The white area just to the right of the buttons works 



like a desktop calculator's paper tape; as you enter a transaction, 
the numbers appear on the "paper. " 

For more information about starting GEOS applications and using 
the Express menu, see Chapter 1. 

BASIC CALCULATOR FUNCTIONS 

You can perform a wide range of functions with the Calculator. 
This section explains: 

• How to use the Calculator's buttons 

• How to enter a calculation using numbers and operators 

• How the Calculator computes your calculation 

• How to handle error conditions 

You can do the following calculations with the basic Calculator: 
addition, subtraction, multiplication, division, percentage, square 
root, numbers squared, and inversion. You can also make 
measurement conversions, store numbers in memory, perform 
complex trigonometric functions , and customize the look of the 
Calculator. These features are described in later sections of this 
chapter. 

The Calculator has two modes you can use: standard or RPN 
(Reverse Polish Notation). The standard mode, sometimes 
ref erred to as Infix, provides the basic format found on most 
calculators, and you use straightforward procedures to enter your 
calculations. The RPN (Reverse Polish Notation) mode offers an 
efficient way to enter complex equations, but it requires different 
entry procedures than those for a standard calculator. For more 
information on calculator modes, see "Using the RPN Mode" later 
in this chapter. 

Using the Calculator's Buttons and Keys 

Before performing a calculation, familiarize yourself with the 
buttons that appear in the Calculator window. Some of the 
Calculator's buttons have keyboard equivalents-keyboard keys 
that you can press to perform the same action as clicking a 
button with the mouse. The tables below briefly describe each 
button on your calculator, including a keyboard equivalent for 
each button. 



DELETE AND CLEAR BUTTONS 

The following buttons are used to delete or clear your entry. 
They are located just to the right of the readout bar. 

BUTTON l KEYBOARD KEY [FUNCTION 

C/ CE Ctrl+C Click once to reset the current 
number to zero; click again to 
reset any operations in progress 
and clear the operations from 
memo1y. 

Backspace Backspace ( f--) Click the Backspace button or 
(f--) press the Backspace key to 

erase the number to the left of 
the cursor. Press the Delete key 
to erase the number to the right 
of the cursor. Press either key 
or click the Backspace button to 
erase any digits you have 
selected. 



CALCULATION BUTTONS 

The following buttons are used to enter calculations. 

BUTTON KEYBOARD KEY FUNCTION 

0 through 9 0 through 9 Digits used to create numbers 
needed for a calculation 

I Divide 

* * Multiply 

- - Subtract 

+ + Add 

= = or Enter Equals (for standard mode 
only) 

() () Parentheses (for standard 
mode only) 

EE E Enter E (for entering numbers 
in scientific notation) 

1/ x Ctrl+l Reciprocal 

x2 Shift+2 Number squared 

'1x Ctrl+2 Square root 

% O/o Percent 

Decimal 

+/ - Ctrl+- Change Sign 
(If the number has an E in it, 
the sign of the exponent is 
changed.) 



MEMORY BUITONS 

The following buttons are used with the Calculator's active 
memory function. For more information on active memory, see 
"Using Memory" later in this chapter. 

1 BUTTON 1 KEYBOARD KEY r FUNCTION 

STO I [ r Store in memory. 

RCL I ] Recall from memory. 

M+ M Add the number displayed in the 
readout bar to the number stored 
in active memory. 

M- Ctrl+M Subtract the number displayed in 
the readout bar from the number 
stored in active memory. 

Performing Calculations 

You enter both numbers and operators for each mathematical 

I 
I 

task you perform with the Calculator. The numbers you enter are 
the figures to be computed. The operators are symbols (such as + 
for addition) that are used to request a particular type of 
calculation. 

An operation refers to the combination of an operator with 
numbers. For example, 100 + 200 is an operation. A simple 
calculation consists of only one operation. However, a 
calculation can consist of as many operations as you need. For 
example, you may need to know the result of 100 + 200 X 5. This 
calculation consists of more than one operation (multiplication 
and addition). In calculations with multiple operations, you can 
explicitly tell the Calculator which operation to do first. For an 
explanation of how to do this , see "Understanding the Hierarchy 
of Operations" later in this chapter. 

NOTE 

The following procedures describe how to perform a calculation with 
a standard calculator. If you use an RPN (Reverse Polish Notation) 
calculator, see "Customizing Your Calculator" later in this chapter. 

To do a calculation 

1. Enter all numbers and operators of your calculation. 

For example: 1200 X 160 

2.5 x 16 + 22 



14 - 12 x (8.5 - 2.2) 

2. Click the = button or press Enter. The result appears in the 
readout bar. 

NOTE 

Press the Enter key only once. If you press twice and a previous 
operation is stored in memory, the Calculator will apply this 
operation to your result. Only those operations which apply one 
number to another are stored and repeated in this way (such as +, -, 

*• and + ). 

USING THE MOUSE 

You can use the mouse in the Calculator much like you use it in 
other desk accessories. In addition to using the mouse to click 
buttons and select menu items, you can use it to edit the 
numbers in the readout bar. sing the mouse , you can select 
digits in the display, and move the insertion point. For instance, 
if you entered the number 124, but meant to enter 14, you could 
drag select the 2 and click the Backspace button to delete it. 

USING THE KEYBOARD 

You may find it easier to use the keyboard for entering numbers. 
If you are using the numeric keypad, be sure that the Num Lock 
key is on (the Num Lock light is lit). 

USING CUT AND PASTE 

You can copy calculation results to other GEOS applications. You 
can also select and copy numbers from another document and 
paste them into the Calculator's readout bar. For cut and paste 
techniques , see "Working with Text" in Chapter 1. 

Understanding the Hierarchy of Operations 

When you enter calculations that include more than one 
operation, the Calculator performs the operations in the 
following sequence: 

• First, any numbers or expressions enclosed in parentheses 

• Second, multiplication and division 

• Third, addition and subtraction 

If you enter arithmetic functions that have the same precedence 
(such as 2 + 5 - 1), the operations are performed from left to 
right. 



USING MEMORY 

The final result of your calculation will always reflect the above 
sequence. For example, if you enter 3 + 4 X 6, the result is 27 
(not 42). This result is based on 3 + 24 (the Calculator performed 
the multiplication before it performed the addition). 

Parentheses can be used to ensure that a particular operation is 
performed first. For example, you could enter (3 + 4) X 6. The 
computer will do the parenthetical operation first: 3 + 4 = 7. After 
that, the computer will perform the multiplication: 7 X 6 = 42. 

NOTE 

If you do computations that include a number of operations, you may 
want to learn about the RPN (Reverse Polish Notation) calculator. 
RPN calculators need no parentheses, simplifying complex 
calculations. For information about this type of calculator, see 
"Customizing You r Calculator" later in this chapter. 

Handling Error Conditions 

When the Calculator is unable to perform a calculation, the word 
Overflow appears in the readout bar. This can happen if you try 
to perform a function not allowed by the Calculator, such as 
dividing by zero. When Overflow is displayed, you can clear it 
using one of the following methods 

To clear an error 

• Click the C/ CE button to clear the number. This clears the error 
but retains any operations in memory for the calculation in 
progress. 

or 

Double-click the C/ CE button to clear the number and delete all 
previous operations for the calculation in progress. 

You can save the results of your calculation using Calculator's 
built-in memo1y. The memo1y function allows you to temporarily 
store numbers during the current work session. 

There are two types of memo1y: active and register. Active 
memo1y is used to store the number displayed in the readout bar. 
You can add to, subtract from, or recall a number stored in active 
memo1y. For example, active memo1y is a convenient way to 



keep track of your current bank balance as you write checks. 
Simply store your bank balance in active memory, then deduct 
the amount for each check from the balance. 

If you need to store more than one figure in memory, you can 
use register memory. Registers allow you to store up to seven 
additional numbers in the Calculator's memory. The registers 
have default names: Register 1, Register 2, Register 3, and so on. 
You can change the names to describe the type of value you are 
entering into the registers. For example, you can rename Register 
1 "Savings Account" and Register 2 "Money Market Account. " 

Active and register numbers can be viewed in the Calculator's 
Memory box. The Memory box consists of eight rows in which to 
store numbers. The first row is reserved for active memory; the 
seven rows that follow are used for register memo1y: 

I 

Click STO button to 
copy number from 
readout bar to here. 

Rctive Memory 

IRegistert 

Use to store number in 
register memory. 

Use to send number to 
Calculat or. 

Addit ional numbers can 
be stored in registers. 

You can leave the Memory box open while you work w ith the 
Calculator. Drag its title bar to move it out of the way if 
necessary. 



The following table summarizes how to use active memory and 
register memory. 

I TYPE OF MEMORY I FUNCTION 

Active The number displayed in the readout bar 
can be copied directly to active memory. 

Only one number can be stored at a time. 

The stored number can be updated using 
the 
M-/ M+ (subtract/ add keys). 

The title name (i.e., Active Memory) 
cannot be changed. 

Register Numbers can only be edited using the 
Memory box. 

Numbers can be entered directly or by 
using Quick Copy. 

Up to seven numbers can be stored. 

Title names (e.g., Registerl) can be 
changed and saved for the next work 
session. 

Using Active M emory 

You use Active memory as quick, temporary storage for numbers 
copied directly from the readout bar. The following procedures 
describe how to store, update , and recall numbers from active 
memory. 

To store a number in active memory 

1. Display a number in the readout bar. 

2. Click the STO button to store the displayed number in active 
memo1y. 

Example: If 100 is displayed and you click STO, the Calculator 
stores the number 100 in active memory. 

To add to or subtract from a number stored in active memory 

1. Store the number you want to update in active memory. (To do 
this, follow the steps described in the previous procedure.) 

2. Display the amount you want to add or subtract in the readout 
bar. You can enter the number directly or display it as the result 
of a calculation. 



3. Click M+ to add or M- to subtract the amount. 

Example: 100 is currently stored in active memo1y and you want 
to add 50. To do this , enter 50 in the readout bar and press M+; 
the Calculator changes the number stored in active memory to 
150. 

Example: 150 is currently stored in active memo1y and you want 
to subtract 20. To do this , enter 20 in the readout bar and press 
M- ; the Calculator changes the number in active memory to 130. 

To recall numbers.from active memory 

• Click RCL. The number in active memory is copied to the readout 
bar. 

Using Register Memory 

Registers provide storage for up to seven numbers in the Memory 
box. The following procedures describe how to store, update , 
and recall register numbers. 

You can work with the Memory box while using the Calculator, 
opening and closing it at your convenience. 

To work with the Memory box while Using the Calculator 

1. Choose Memory from the Options menu. The Memory box 
appears. 

2. Follow the steps in other procedures in this section to store a 
number in a register, recall a number stored in a register, or 
rename a register. 

3. If you want to work with the Calculator window, move the 
Memo1y box out of the way by dragging its title bar. 

4. You can keep the Memo1y box around if you want to continue 
working with it. 

or 

Click Close to close the Memory box. 

To copy a number from the readout bar and store it in a register 

1. Use the Calculator to display the number that you want to store. 

~ 2. 
ll:!!..J 

You can enter the number directly in the readout bar, or display 
the number as the result of a calculation. 

In the Memo1y box, click the Get from Calculator button 
(pictured at left) located next to the register that you want to use 



for storage. The number is copied from the readout bar to the 
register. 

The number is stored in the register until you exit the Calculator, 
or until you store a different number in that register. 

To type a number into a register 

• In the Memory box, select one of the register boxes; then type a 
new number or edit the number that is already there. 

The number is stored in the register until you exit the Calculator, 
or until you store a different number in that register. 

To change the name of a register 

Double-click or drag l . 
in the name box to 

In the Memory box, select the name of the register you want to 
change and edit the text shown in the box. For example, you 
may want to change the name of Registerl to "Savings Account" 
or "Car Payment. " 

select the name and 
edit it quickly. 

2. To make your changes permanent, choose Save Options from the 
Options menu. The names are saved for the next work session. 
The next time you open the Calculator application, the names 
you have saved will be displayed in the Memory box. For more 
information on saving options, see "Customizing Your Calculator" 
in this Chapter. 

To recall a number stored in a register 

~ · L::..J 
In the Memory box window, click the Send to Calculator button 
(pictured at the left) located next to the register with the number 
you wish to recall . The number is copied from the register to the 
readout bar. 

CUSTOMIZING YOUR CALCULATOR 

You can change the look and feel of the Calculator to match 
your particular needs. This section describes how to do the 
following: 

• Use the RP (Reverse Polish Notation) calculator mode 

• Use the scientific extensions, including trigonometric functions 

• Choose between regu lar and scientific notations, and specify 
how decimal places are shown 

• Hide the paper tape 



Once you've customized the Calculator, you can save your 
settings for the next time you start the Calculator. 

For instance, you may prefer to hide the paper tape to make the 
Calculator window smaller and take up less space on your 
screen; or, you may wish to have the scientific extension buttons 
always showing so that you can perform trigonometric 
calculations at any time. Once you've found settings you like, 
you can choose Save Options from the Options menu to save 
them for your next use. 

To customize the Calculator 

1. Choose Customize from the Options menu. The Customize dialog 
box appears: 

2. Select options in the dialog box (as described in procedures later 
in this section) and then click Apply. The Calculator changes to 
reflect your settings. 

3. You can keep the Customize dialog box around to make other 
changes 

or 

Click Close to close the dialog box. 

4. If you only want to keep your settings for the current work 
session, continue using the Calculator as you normally would. 
When you exit the Calculator, the settings are restored to their 
previous state. 

or 

To save your changes, choose Save Options from the Options 
menu at any time before you exit the Calculator. The choices you 
have made are saved for next time you open the Calculator 
application. 



Using the RPN Mode 

Calculator mode refers to the keyboard layout and how 
calculations are entered. Two different modes are available with 
the Calculator: standard (Infix) and RPN (Hewlett-Packard style). 
The standard mode is described and illustrated in "Basic 
Calculator Functions" earlier in this chapter. The RPN mode is 
shown below. 

[lie ~dit !}ptions ~onvert 

The RPN calculator offers an efficient way to enter complex 
calculations using a method similar to that found on many 
Hewlett-Packard calculators, especially those models targeted at 
the mathematics and scientific community. RP calculations are 
performed in a way that is different from how you enter 
calculations on a standard calculator. First, you enter the 
numbers, then you perform an operation. For instance, if you 
want to add two numbers, such as 8 and 5, you first enter 8, 
followed by 5, and then perform the addition operation. As you 
enter numbers they are "pushed" onto a stack; they are later 
"popped" off the stack and used in operations. 



The buttons on the RPN calculator are basically the same as those 
on the standard calculator with the following differences: 

1 BUTTON 1 KEYBOARD KEY r FUNCTION 

Enter = or En ter Place - or "push" - the 
number on the readout bar onto 
the stack. You perform 
calculations by typing the first 
number, clicking Enter, typing 
the second number and then 
clicking an arithmetic function. 

x<>y x Exchange the number in the 
readout bar with the top number 
on the stack. This is useful in 
switching the order of numbers 
to be subtracted or divided. 

Roll R Roll the numbers up the stack by 
one place-the top number goes 
to the bottom of the stack. This is 
useful for seeing what numbers 
are in the stack. 

CLx Ctrl+C Click once to erase the number 
you are currently entering. Click 
twice to clear the entire stack. 

You otherwise use the same keys on the keyboard and click the 
same buttons in the Calculator window to activate the RPN 
calculator. 

To switch between the standard and RPN calculator modes 

1. Choose Customize from the Options menu. The Customize box 
appears: 

I'' Mode~v RPtl (HP-Style)~' 
+ Infix (Standard) 

Notation: 

Extras: 

•if Scientific ( 1.2 E +4) 
+ Regular (12000) 

[ii ru Decimal Places 

_J Scientific Extension 

• Wot·ksheets 
• Papertape 

L I IC' 



2. Select the Mode that identifies the type of calculator you want 
(standard or RPN) . 

3. Click Apply. The calculator buttons change to represent the type 
of calculator you chose. 

4. You can keep the Customize dialog box around to make other 
changes 

or 

Click Close to close the dialog box. 

To peiform an RPN calculation 

1. Enter the first number, as you would for a standard calculator. 

2. Click Enter to "push" the number onto the stack. 

3. Enter the second number. Do not click Enter this time. 

4. Click the arithmetic function you want. The result shows in the 
readout bar. You can then use this result as the first number in 
another calculation. 

NOTE 

Do not click Enter after typing the second number. This will both 
store the number on the stack and leave it on the display. If you click 
an operation, the operation will use the number on the display and 
the top number on the stack-the same number. 

EXAMPLES OF RPN CALCUIATIONS 

In order to get a feel for how RPN calculations work, it helps to 
look through some examples. Notice that in each of these 
calculations, the approach, generally, is to enter values first 
(pushing them on the stack) and then to perform operations in 
order of precedence, from highest precedence (innermost 
parentheses) to lowest precedence. Also notice that Enter is only 
pressed between successive numbers . When the last number in a 
group is reached, the operator button is pressed instead of the 
Enter button. 



Example: Calculate 3 + 36 + 6 

1 BUTTON PRESSES r DISPLA y 

13, Enter [ 3 

136, Enter 136 

l,_+ ___ [,_9 __ _ 

Example: Calculate (10 + 2) x (53 -2) 

1 BUTTON PRESSES r DI SP LA y 

I 10, Enter [ 10 

1:-2-, +-----, 12 

1:-5-3,-E-n-te-r ---1 53 

l_2,_-___ ,_51 ____ , 

l_x _____ [_61_2 ___ _ 

Example: Calculate 1032 + (15 - 12 x (9 + 3)) 

1 BUTTON PRESSES r DISPLA y 

I 1032, Enter [ 1032 

,_15_,_E_n_t_e_r ___ ~l,_1_5 ______ _ 

12, Enter I 12 

l
1

_9_, -E-nt-er----,,_9~~~~~~ 

13, + \ 12 

I x 144 

l,_-~~~-l,_-1_29~~~-
.___I + ___ l,_-s __ _ 

Choosing Regular or Scientific Notation 

Two different notation styles are available: regular (for standard 
calculations) and scientific (for extremely large or small 
numbers). Use the regular style if you want to enter numbers in 
the standard way. For example, if you enter 0.2 X 0.2 in the 
regular style the result is .04. Use the scientific style when you 
require a numerical shorthand for very large or small numbers 



that would be difficult to view on the display bar. For example, if 
you enter 0.2 X 0.2 with scientific style selected, the result is 
4.0000E -02; in other words, 4 X 10 to the power of -2. 

To choose a notation style 

1. Choose Customize from the Options menu. The Customize box 
appears: 

Notation: v- Scientific (1.2 E+4) 
• Regular (12000) 

0 ru Decimal Places 

2. Select the Notation radio button that identifies the notation style 
you want (Scientific or Regular). 

3. Click Apply. The calculator will display the results of new 
calculations in the notation you specify. 

4. You can keep the Customize dialog box open to make other 
changes 

or 

Click Close to close the dialog box. 

Changing the Decimal Places Displayed 

The Calculator stores 12 decimal places internally for each 
number, but normally displays only the significant digits. For 
example, the number 3.4534 displays as 3.4534 and not 
3.453400000000. 

If you desire, you can specify the exact number of decimal places 
to be displayed in your calculations, from 1 to 12. For example, if 
you are doing calculations with dollars and cents, you may want 
to set the number of displayed decimal places to 2. All values will 
then be rounded to two decimal places when displayed. 

Regardless of the number of decimal places displayed, each 
number is stored internally with the full 12-digits of accuracy. 



To change the number of displayed decimal places 

1. Choose Customize from the Options menu. The Customize box 
appears: 

, 7 Scientific (1.2 E+4) 
+ Regular (12000) 

ro-- 00J Decimal Pl&ees 

2. Click the Up or Down arrow buttons to display the number of 
decimal places you want for your calculations. A value of 0 (zero) 
specifies that the Calculator should display all significant digits. 

3. Click Apply. The calculator will display the results of new 
calculations with the precision you specify. 

4. You can keep the Customize dialog box around to make other 
changes 

or 

Click Close to close the dialog box. 



Using the Scientific Extension 

You can expand your calculator (in both the RPN and standard 
mode) to include scientific functions by showing the scientific 
extension. The scientific extension provides additional buttons 
which enable you to do complex trigonometric calculations, 
exponents, factorials, and logarithms. 

Express angles in degrees, 
radians, or gradians. 

Ejle ldit Qptions konvet·t 

Click here to switch 
trigonometric functions 

to their inverse. 

Scientific extension to 
the calculator. 

At the top of the scientific extension are the following options 
that affect trigonometric calculations. 

I OPTION I KEYBOARD KEY [ FUNCTION 

DEG Ctrl+D Select from this group of radio 
RAD Ctrl+R buttons to specify whether 
GRD Ctrl+G trigonometric angles are 

expressed in degrees, radians, or 
grads. 

Inv Ctrl+I Select this option to switch the 
trigonometric buttons to their 
inverse. For instance, when this 
option is on, the sine (sin) 
function becomes an inverse sine 
(sin-1). 



The following buttons are available with the scientific extension. 

1 BUTTON 1 KEYBOARD KEY r FUNCTION 

In x I Recall the value for the 
mathematical constant PI. 

e u Recall the value for the 
mathematical constant e 
(Euler's constant). 

sin (or sin-1) 

Is 
Calculate the sine (or inverse 
sine) of the number in the 
readout bar. 

cos (or cos-1) c Calculate the cosine (or 
inverse cosine) of the 
number in the readout bar. 

tan (or tan-1) T Calculate the tangent (or 
inverse tangent) of the 
number in the readout bar. 

ln N Calculate the natural 
logarithm of the number in 
the readout bar. 

log L Calculate the logarithm (base 
10) of the number in the 
readout bar. 

Ix' I ! (Shift+ 1 ) I Calculate the factorial of the 
number in the readout bar. 

eX Ctrl+U Raise the constant e to the 
power shown in the readout 
bar. This is the inverse 
natural log. 

10x Ctrl+L Raise 10 to the power shown 
in the readout bar. This is 
the inverse logarithm. 

yX /\ (Shift+6) Raise the value in the 
readout display to the power 
of the next value entered. 
(Enter the first value, click 
yx; enter the second value, 
click =.) 

r- A lr-lllATf"'\D l. _"JI 



To show the scientific extension 

1. Choose Customize from the Options menu. The Customize box 
appears: 

v Scientific ( 1.2 E +4) 
+ Regular (12000) 

~ 00 Decimal Places 

.J Scientific Extension 
• Worksheets 
• .Papertape 

2. In the Extras section, click Scientific Extension so that the check 
box is darkened. 

3. Click Apply. The calculator buttons change to show the scientific 
extension. 

4. You can keep the Customize dialog box around to make other 
changes 

or 

Click Close to close the dialog box. 

To remove the scientific extension, follow these steps again, only 
this time click the Scientific Extension option so that the check 
box is off. 

To calculate the sine, cosine, or tangent of an angle 

The sin, cos , and tan buttons calculate the sine, cosine, or 
tangent of the supplied angle. 

+ oEG v RAD v GRD 1. Select the units in which you wish to specify the angle: DEG, 

T7w Inverse sine, 
cosine, and tangent 
are sometimes 
referred to as 
arcsine, arccosine, 
and arctangent. 

RAD, or GRD. 

2. Enter a value for the angle in the selected units. 

3. Click one of the trigonometric buttons: sin, cos, or tan. 

4. The result appears in the readout bar. 

To calculate the inverse sine, cosine, or tangent of an angle 

When the Inv option is checked, the sin, cos, and tan buttons 
become their inverse: sin-1, cos-1 , and tan-1. These buttons now 
calculate the inverse sine, inverse cosine, or inverse tangent. The 
result is expressed as an angle . 



1. Select the units in which you wish to see the result: DEG, RAD, 
or GRD. 

2. Enter the value you want to use in the calculation. 

_J Inv 3. Click the Inv check box. The sin, cos, and tan buttons change to 
show their inverse functions. 

4. Click one of the inverse trigonometric buttons: sin-1, cos-1, or 
tan-1. 

5. The result appears in the readout bar, expressed in the units 
specified in step 1. 

To raise one number to the power of another 

You can use the yx button to raise one number to the power of 
another. 

1. Enter the first number and click the yx button. For instance, if 
you wanted to calculate 105, you would enter 10 in the readout 
bar. 

2. Enter the exponent, the power to which you wish to raise the 
first number. 

3. Click the = button. The result appears in the readout bar. 

Hiding the Paper Tape 

You can hide the paper tape to make your Calculator window 
smaller and take up less space on your screen: 

To hide the paper tape 

1. Choose Customize from the Options menu. The Customize box 
appears. 

2. In the Extras section, click Paper Tape to turn it off. 

3. Click Apply. The paper tape disappears. 

4. You can keep the Customize dialog box around to make other 
changes 

r t.i rl II A T()R 6.23 



or 

Click Close to close the dialog box. 

To again show the paper tape, follow these same steps, only this 
time click the Paper Tape option so that the check box is 
darkened again. 

CONVERTING MEASUREMENTS 

The Calculator provides a handy way to convert one type of 
measurement, such as gallons, to another type of measurement, 
such as liters . The list below shows the types of conversions 
available: 

• Inches H Centimeters 

• Feet H Meters 

• Miles H Kilometers 

• Gallons H Liters 

• Pounds H Kilograms 

• Kilograms H Pounds 

• Fahrenheit H Celsius 

• Degrees H Radians 

To perform a conversion 

1 . Enter the number you want to convert in the readout bar. 

2. Choose the conversion from the Convert menu. If a submenu 
appears choose the conversion from the submenu. A submenu 
appear? for all conversions except Degrees/ Radians conversions. 

The conversion is immediately applied and displayed on the 
readout bar. 



CHAPTER 7 

Sera p book The Scrapbook application gives you a place to store 

graphics and bits of text so that they are available at a moment's 

notice. A GEOS scrapbook, like its real world counterpart, is a 

document that has pages where you paste scraps. Scraps are the 

notes , pictures , and other items that you store in the scrapbook. 



The advantage of a GEOS scrapbook over a real scrapbook is 
that you can quickly copy items from a GEOS scrapbook to other 
GEOS documents . Simply open the appropriate scrapbook, go to 
the page where the scrap is stored, and copy the item to the 
Clipboard. From there, you can paste it into the document. 

The Scrapbook application has two user levels. For more 
information about changing user levels, see Chapter 1. For more 
information about the user levels in this application, see "User 
Levels in Scrapbook" in this chapter. 

This chapter describes how to do the following: 

• Create and view scrapbook documents . 

• Cut and copy items from a scrapbook to another application. 

• Add items to a scrapbook from other applications. 

• Use multiple scrapbooks. 

• Secure your scrapbook. 

This chapter assumes you are familiar with the information 
covered in Chapter 1, which provides an overview of the skills 
you need to use any GEOS application. 

STARTING THE SCRAPBOOK 

ALL LEVELS 

Si::t-.:ipbook 

• 

The Scrapbook icon usually appears in the WORLD folder in 
GeoManager and looks like the example on the left. You can 
start Scrapbook either from GeoManager or from the Express 
menu. 

To start the Scrapbook application (All Levels) 

Locate the Scrapbook icon and double-dick it. 

or 

Choose Scrapbook from the Express menu in any application. 



The Scrapbook window appears: 

This area is the View box. It 
shows pages in the scrapbook. 

Cl ick to go to the previous or 
the next page in the scrapbook 

Click to go to a specific page in the scrapbook. 

I The name of the page appears here. 

When you start Scrapbook, the default scrapbook appears in the 
Scrapbook window. If you haven't stored any scraps in it yet, the 
scrapbook is empty. For more information about the default 
scrapbook, see "Using the Default Scrapbook" in this chapter. 

For more information about starting GEOS applications and the 
Express menu, see Chapter 1. 

USER LEVELS IN SCRAPBOOK 

Anything labeled 
Level 3 in Chapter 1 
is available in Level 
2 of Scrapbook 
because Scrapbook 
has only two user 
levels. 

There are two user levels in Scrapbook: 

• Level 1 is the easiest to use and includes most features that you 
will need to store and retrieve items in a scrapbook. 

• Level 2 allows you to import items from applications outside of 
Ensemble, go to a specific page in a scrapbook, and paste items 
at the end of a scrapbook document. 



For more information about changing and saving user levels , see 
Chapter 1. 

Anytime you change your user level, you can use the following 
procedure to reset the Scrapbook back to Level 1. 

To reset your user level to Level 1 (All Levels) 

• Choose Reset Configuration from the Options menu. 

USING THE DEFAULT SCRAPBOOK 

Def a ult Scrapbook is the document that automatically opens 
when you initially start the Scrapbook application. If you have 
not copied any scraps into the default scrapbook, the document 
is empty. If you have already entered scraps, the contents of the 
first page are displayed in the View box. 

If you want to start storing scraps now, you can use the default 
scrapbook. If you plan to keep a large collection of scraps, you 
may want to create new scrapbooks. For more information about 
working with scraps, see "Working with Scraps" in this chapter. 
For more information about creating new scrapbooks, see 
"Working With Documents" in this chapter. 

You use the default scrapbook in the same way you use any 
scrapbook document. You can flip through the scrapbook pages, 
and you can cut and paste items to and from its pages. 

PAGING THROUGH A SCRAPBOOK 

ALL LEVELS 

e.:reuious ) ttext I 

You can quickly flip through the pages of a scrapbook to scan its 
contents, or you can go directly to a specific page. 

Using the Next and Previous Buttons 

Use the Next and Previous buttons to go page by page through a 
scrapbook. 

To niove to the next page (All Levels) 

• Click Next to go to the next page. If you are on the last page, the 
Next button takes you to the first page. 



§.o to Page ... 

To move to the previous page (All Levels) 

• Click Previous to go to the previous page. If you are on the first 
page, the Previous button takes you to the last page. 

Using Go to Page 

In Level 2, you can use the Go to Page button to jump to a 
specific page in a scrapbook. 

To use Go to Page (Level 2) 

1. Click the Go to Page button. The Go to Page dialog box appears: 

2 . Click the page number or page name that you want to view. 
Then click the View Page button to display the page in the 
Scrapbook window. 

or 

Double-click the page number or page name to display the page 
immediately in the Scrapbook window. 

3. Click Close when you are finished. (You can also drag the dialog 
box to the corner of the screen so you can refer to it later.) 

WORKING WITH SCRAPS 

ALL LEVELS You can copy scraps of both images and text from most GEOS 
applications to your scrapbook. For example, you can use a 
drawing application to design a letterhead, then copy it to your 
scrapbook so that it's easily available when you want to use it in 
your word processor. At Level 2, you can also import scraps from 
non-GEOS applications. For more information about importing, 
see "Importing from Other Applications" in this chapter. 

Once you have learned the techniques for working with scraps, 
you can create your own scrapbook. Eventually, you may want 



to have more than one scrapbook. This section describes how to 
do the following: 

• Add a scrap to a scrapbook document. 

• Copy a scrap to other applications. 

• Delete a page of scraps. 

• Name a page of scraps. 

• Import scraps from a DOS application. 

Adding a Page to a Scrapbook 

When you paste an item from another application to your 
scrapbook, you automatically add a new page to the scrapbook. 

To add a page to a scrapbook (All Levels) 

1. Within an application, copy the item to the Clipboard as you 
usually do. For more information about how to copy items, see 
Chapter 1. 

2. Click the Scrapbook window to make it active . You can, 
alternatively, choose Scrapbook from the Express menu. 

3. Choose Paste from the Edit menu. The scrap appears on a new 
page in front qfthe current page. This pushes all subsequent 
scraps back one page. 

NOTE 

If you want to insert the scrap on another page, use the Previous or 
Next button to go to the page that you want to follow the new scrap. 
For example, if you want to add a scrap to page 3 of the scrapbook, 
go to page 3. When you paste in the scrap, the new page becomes 
page 3 and the old page becomes page 4. 

To add a page to the end qf a scrapbook (Level 2) 

1. Copy the scrap to the Clipboard. 

2. Click the Scrapbook window to make it active. You can, 
alternatively, choose Scrapbook from the Express menu. 

3. Choose Paste at End from the Edit menu. The scrap is pasted on 
the last page of the scrapbook. 

Copying a Scrap to Other Applications 

You can copy any item from a scrapbook to another application 
that allows you to paste something from the Clipboard. For 



example, you can copy a letterhead from Scrapbook into a word 
processor, and then type your correspondence. 

To copy from Scrapbook to other applications (All Levels) 

1. Go to the scrapbook page that has the scrap you want to cut or 
copy. 

2. Choose Cut or Copy from the File menu. 

• The Cut choice places the scrap on the Clipboard and deletes it 
from the scrapbook. 

• The Copy choice copies the scrap to the Clipboard and leaves a 
copy of it in the scrapbook. 

3. Open the document in the application to which you are copying 
the scrap. 

4. Place the insertion point where you want to paste the scrap on 
the page. 

5. Choose Paste from the application's Edit menu. The scrap is 
pasted into the document. 

Deleting a Page 

You can easily delete a page that you no longer need. A deleted 
page is not stored on the Clipboard, but you can retrieve it. 

To delete a page from a scrapbook (All Levels) 

1. Go to the page that you want to delete. 

2. Choose Delete from the Edit menu. 

The page is deleted from the scrapbook. 

NOTE 

When you delete a page, it is not copied to the Clipboard. 

To retrieve a deleted page (All Levels) 

This retrieval method restores the document to the way it was 
before any changes (including the page deletion) were made. In 
other words , all changes made during the current work session 
are cleared. For this reason , you should only perform this 
procedure if it is very important to retrieve the delete page. 

1. Choose Other from the File menu. A submenu appears. 

2. Choose Discard Changes from the submenu. A confirmation 
message appears. 



ALL LEVELS 

LEVEL 2 

3. Click Yes. The scrapbook is restored to the previously saved 
version. 

Naming a Page 

You can assign a name to each page in a scrapbook. Page names 
are used to describe the type of scrap stored on the page and can 
be helpful when you want to locate particular items in a large 
scrapbook. Page names are shown in the Name box at the 
bottom of the Scrapbook window; the names are also listed in 
the Go to Page dialog box. Names may be up to 32 characters 
long. 

To name a page (All Levels) 

1. Locate the page that you want to name. 

2 . Click in the Name box, and then type a descriptive name for the 
page. 

Importing a Scrap from a DOS Application 

You can import images from other DOS applications to a 
scrapbook. An item is imported when it is transferred from a non
GEOS application to a GEOS application. For example, you can 
import text or images that are in TIFF, PCX, Quattro Pro EPS, or 
Word Perfect formats to your scrapbook. 

To import an item from another application (Level 2) 

1. Open the scrapbook in which you want to place the image. 

2 . Locate the page that you want to follow the imported page. 



3. Choose Import Scrap from the File menu. A dialog box appears: 

Select the file you want to import. 

tto Idea {Auto-Detect) 

Click to import the file. I 

Select the format of the imported file. 

4. Select the format (TIFF, PCX, Word Perfect, and so on) of the 
image you are importing. All files matching the format you 
selected are listed to the left of the formats. 

5. Locate and select the name of the file you want to import. Switch 
disk drives and folders as needed. 

6. Click the Import button. It may take several seconds for the 
image or text to be imported and placed in the scrapbook. 

If the file is very large , it could take several minutes to import. 
You cannot interrupt this process. 

SAVING AND EXITING 

ALL LE V EL S If you 've made changes or additions to your scrapbook 
document and want to make the changes permanent, you can do 
this by saving your document. 

When you are done using Scrapbook, you should exit it. Exiting 
an application closes its window and frees up system resources. 
You should save your document before exiting, but if you forget 
Scrapbook will give you one last chance to save your changes. 

To save changes to your document (All Levels) 

• Choose Save from the File menu. Scrapbook saves your changes 
and returns you to the document. 



For more information about saving changes, see "Saving 
Documents" in Chapter 2. 

NOTE 

Scrapbook automatically safeguards your scrapbook document while 
you are working on it. In the event of a power failure or other 
problem, your work is probably safe even if you haven't used the Save 

menu choice. By adjusting the Document Safeguarding Time in the 
Look & Feel section of Preferences, you can control how frequently 
this safeguarding takes place. For more information, see Appendix A 

To exit Scrapbook (All Levels) 

• Choose Exit from the File menu . 

or 

Double-click the window control button, located in the top left 
corner of the Scrapbook window. 

The Scrapbook window closes and the application exits . If you 
have unsaved changes in your document, Scrapbook will ask if 
you want to save those changes. 

WORKING WITH DOCUMENTS 

ALL L E V E LS Scrapbook provides a standard document called "Default 
Scrapbook" in your DOCUMENT folder. Whenever you start 
Scrapbook, this document opens automatically, making it easy to 
keep all of your appointments in one place. If you only need one 
scrapbook document, you should use this document. 

However, you may want to keep additional scrapbook 
documents around. For instance, you may find it easier to keep 
your scraps organized by project or by subject matter. 

Creating a New Scrapbook Document 

It is easy to create a new Scrapbook document from within 
Scrapbook. The basic procedure is covered here. For more 
information about creating and naming a new document, see 
Chapter 2. 



Before you create a 
new scrapbook 
document you must 
first save and close 
the current one. 

01 
~ 

Default Scr.:ipbook 

To create a new scrapbook document (All Levels) 

1. Choose Close from the File menu. If you have unsaved changes 
in the current scrapbook document, you will be asked if you 
wish to save or discard them. 

The New/ Open dialog box appears. 

2. Click the New button. A new scrapbook document appears. 

3. You must add one or more scraps to the new scrapbook 
document before you can save it and give it a name. 

4. After adding a scrap, choose Save from the File menu. A standard 
file selector dialog box appears. 

5. Use the file selector controls to select the folder in which you 
would like to save the new document. To select your 
DOCUMENT folder , click the Go To Document button. 

6. Type a name for the document in the New Name area; then click 
Save. The new document is saved with the name you provided. 
You are returned to Scrapbook with that document open. 

Opening Scrapbook Documents 

A Scrapbook document appears as an icon, normally in your 
DOCUME T folder, like the example at the left. You can choose 
which scrapbook document you want to work with by opening 
its icon. You can also open a document from within Scrapbook. 

To open a Scrapbook document using its icon (All Levels) 

1. Locate the icon of the Sera pbook document you wish to open, 
usually in your DOCUMENT folder. 

2. Double click the document icon. Scrapbook starts and opens that 
document. 

To open a Scrapbook document from within Scrapbook (A ll Levels) 

1. Choose Close from the File menu . If you have unsaved changes 
in the current scrapbook document, you will be asked if you 
wish to save or discard them. 

The New/ Open dialog box appears. 

2. Click the Open button. A standard file selector dialog box 
appears. 

3. In the list, select the Scrapbook document you wish to open. Use 
the standard file selector controls to change to a different folder 
if necessary. 



4. Click Open. The document opens and you are returned to 
Scrapbook. 

SETIING ANOTHER STARTUP DOCUMENT 

Normally, when you start Scrapbook directly, you open the "My 
Schedule" scrapbook document from your DOCUME T folder. 
This is the default startup document. In Level 3 of Scrapbook you 
can set another scrapbook document to use as your startup 
document. For more information, see Chapter 2. 

To make another document your startup document (Level 3) 

1. Open the Scrapbook document that you want to be your startup 
document. 

2. Choose Other from the File menu . 

3. Choose Empty Document from the submenu , and then choose 
Set Startup Document from the next su bmenu . A confirmation 
message appears. 

4. Click the Set Startup button to make the document the new 
startup document. 

To reset the def a ult startup document (Level 2) 

1. Choose Other from the File menu. 

2. Choose Empty Document from the submenu , and then choose 
Reset Startup Document from the next submenu. A confirmation 
message appears. 

3. Click the Reset Startup Document button to reset "My Schedule" 
as the startup document. 

Document Management 

When you work with documents , you use features on the File 
menu. In Level 1 of Scrapbook, the File menu lets you perform 
the following operations: 

• Create a new document 

• Open an existing document 

• Save a document 

• Close a document 

In Level 2, you see additional features on the File menu that let 
you perform the following operations: 

• Back up and restore a document 

• Make a copy of a document 



• Discard changes 

• Rename a document 

• Edit document notes 

• Set or remove a document password 

• Set a different startup document 

• Set the document type 

For more information on file management and working with 
documents, see Chapter 2. 

FINE TUNING YOUR USER LEVEL 

In addition to choosing a particular user level, you can customize 
a user level. For example, you may want to keep your menus as 
short as possible, but still be able to import scraps from 
applications outside of GEOS. In this case, even at Level 1 you 
still have the ability to import scraps. By fine-tuning Level 1, you 
can keep the Import Scrap option listed on the File menu. 

For more information about how to fine-tune your user level, see 
Chapter 1. 

The Scrapbook fine-tuning options are described in the following 
table: 

I FINE-TUNING OPTION I DESCRIPTION 

Go to Page Dialog This allows you to go directly to a 
specific page in a scrapbook 
document. 

Importing This allows you to import text and 
images from non-GEOS applications to 
a scrapbook document. 

Paste At End I This allows you to paste a scrap at the 
end of a scrapbook document. 



CHAPTER 8 

Text File Editor You can use Text File Editor to make quick 

notes , to view "readme" files that often come with applications, 

and to read documentation that comes with public domain 

software. Text File Editor is a simple editing program that allows 

you to read, write , and edit DOS text files. 



Text File Editor is not a full-featured word processing program, 
but a program you may want to use to write notes that can be 
read by people who are not using GEOS applications, since 
almost every word processing application can open DOS text 
files. DOS text files contain plain text without special formatting 
like boldfacing, adjustable tabs, and page breaks. 

Text File Editor has no user levels. Therefore, the user level 
designations in Chapter 1 do not apply to Text File Editor, even 
though the tasks themselves may. 

This chapter describes how to do the following: 

• Enter and edit text in Text File Editor. 

• Change the size of text displayed in the Text File Editor 
window. 

• Print a Text File Editor document. 

• Work with Text File Editor documents. 

This chapter assumes you are familiar with the information 
covered in Chapter 1, which provides an overview of the skills 
you need to use any GEOS application. 

STARTING TEXT FILE EDITOR 

T >?;d Fil>? Editot-

The Text File Editor icon looks like the example at the left. 

To start Text File Editor 

1. Locate the Text File Editor icon and double-click it. Text File 
Editor opens and displays the New/ Open dialog box. 



I 

I Click here to create a new document. 

Click here to open an existing document. 

2. Click the appropriate button to either create a new document or 
open an existing document. For more information about creating 
new documents and opening existing ones, see "Working With 
DOS Text Files" in this chapter. 

If you select the New button, a document named "Blank" (plus 
an optional number if there is already a blank document) appears 
in a document window. You enter and edit text in the document 
window, which has its own title bar and window control button 
inside the Text File Editor window. 
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I Enter text here. 



For more information about starting Ensemble applications, see 
Chapter 1. 

USING TEXT FILE EDITOR 

Text File Editor is simple to use . However, it is not a full-featured 
word processing program. You may want to use a word 
processing application, like Geo Write, if you need the following 
features: 

• Adjustable left and right margins 

• Adjustable tab stops 

• Text styles and fonts 

• Justification 

• Line spacing 

• Page breaks 

• Rulers 

• Graphics 

• Document safeguarding 

In Text File Editor, you enter and edit text just as you would in 
any GEOS application. For detailed information on entering and 
editing text, see "Working With Text" in Chapter 1. 

As you type on the computer keyboard, characters appear at the 
insertion point. The insertion point is the blinking vertical line 
that indicates where characters you type will appear. On a blank 
page, the insertion point appears at the upper-left corner. 

To move the insertion point and begin editing text in a new 
place, simply click in the document window. You can also select 
text you want to work with by dragging with the mouse or using 
the keyboard. You can select the whole document by choosing 
Select All from the Edit menu. 

Once you have selected text, you can type new text to replace 
the selection, or you can use the following menu choices on the 
Edit menu: 

• Cut 

• Copy 

• Paste 

• Delete 



If you mistake while editing, you can correct it by choosing 
Undo from the Edit menu before performing any other task. 

Word Wrap and Line Endings 

When your text reaches the right edge of the window, it wraps 
automatically to the next line. This feature is called word wrap. 
Word wrap means that you don't have to press the Enter key 
(the Return key on a typewriter) to start a new line of text. This 
keeps the lines and sentences together in the same paragraph. 
When you are ready to begin a new paragraph , you press the 
Enter key. 

If you change the width of the window, text wraps at the new 
window edge. If there is more text than can fit in the window, 
use the scroll bar to see different parts of the document. 

Text wraps at the edge of a window. ~ 

1at ter u1hat size the window is , I 
, h is is cm examp I e of a sentence that •.u i I I ' Wt' ap around a w i ndoui no 1 

NOTE 

DOS text files are often line-oriented, which means each line is kept 
apart from the others by pressing Enter at the end of each line, 
instead of pressing Enter only at the end of each paragraph. An 
example of a line-oriented text file is a report you 've generated using 
Ensemble. Each line of the report is separated from every other line. 
Another example is a DOS batch file , where each line is a separate 
DOS command. You may find it easier to edit one of these files by 
resizing the Text File Editor window so that it is as wide as possible. 
This way you can see where lines end because Enter has been 
pressed and not be confused by where Text File Editor is wrapping 
them. 



CHANGING THE TEXT SIZE 

Text size is 
measured in 
typographical units 
called points. 9 
points is 1/8". 

You can change the size of the text displayed in any Text File 
Editor document. You can make the text larger to reduce eye 
strain. Text File Editor provides three sizes of text, as follows: 

• 9 point 

• 12 point 

• 14 point 

Text File Editor displays all the text in a document at the same 
size. If you choose a different size , all the text in the document 
changes to the size you select. The size setting stays in effect 
even if you close one document and open another. Regardless of 
the text size you choose, Text File Editor always prints 
documents using the built-in fonts in your printer. 

To change the text size 

• Choose a new size from the Sizes menu. All text in the document 
changes to the new size. 

CHECKING YOUR SPELLING 

Checking your spelling is a good way to find misspelled words 
and to look for typographical errors. Ensemble has an electronic 
dictionary of 100,000 words it checks to look for mistakes. When 
the spelling checker finds a word in your document that is not in 
the dictionary, it displays it in the Check Spelling dialog box and 
lets you decide what to do with it. 

To check the spelling of a word or block of text (Level 1) 

You can check the spelling of a single word, a block of text, or 
the text in the entire document. To check the entire document, 
start with step 2. 



1. Select the word or block of text you want to check. 

2 . Choose Check Spelling from the Edit menu. A dialog box 
appears. The first misspelled word (or word that is not in the 
Ensemble dictionary) appears in the Change to: box. 

Status: Misspelled or unknown word 

iThe mating pattern of the natiue ""flugenheld"" bird is one of 
obscure ritual and many loud noises, particularly by the 
male when he finds a suitable f e ... 

Change iT o: IWWlll1iltillL 

3. Type the word correctly and click the Replace button. Use this 
method if you think the word is misspelled and you don't think 
the spelling checker will know the word. The spelling checker 
replaces the word with the new spelling and proceeds with its 
checking. 

or 

Click the Skip button. Use this for special words that appear in 
your document that you do not want to add to your User 
dictionary. The spelling checker skips the current word and 
proceeds with its checking. 

or 

Click the Suggest button. Use this method to have the spelling 
checker look in the dictionary for words that are similar. When 
the suggestions appear, click the spelling you want to use and 
then click the Use This Suggestion button. If no suggestion is 
appropriate, click the Cancel button, then type the word correctly 
in the Change to: box. The spelling checker replaces the word 
with the new spelling and proceeds with its checking. 

4. When you are finished checking the spelling of the selection or 
of the entire document, a message window appears. Click OK to 
continue. 

NOTE 

At higher user levels, you can add special words to a User dictionary. 



FINDING AND REPLACING TEXT 

You can use find and replace to quickly find a word or phrase in 
your document and, optionally, to replace it with a different 
word or phrase. You can also replace all occurrences of a word 
or phrase in a document. 

Searching for Text 

You can search for any sequence of numbers, letters, spaces, and 
other printable characters (such as punctuation marks). 

To search for text 

1. Choose Find and Replace from the Edit menu, or press F6. A 
dialog box appears: 

l!I find and Replace 

find: 

Replace With: 

~ecial Charncter-s ~I _J !gnore Case/Accents .J tlatch Partial Words 

2. Type the text you want to search for. 

3. Click either Find Next or Find Previous. The search starts from 
the insertion point forward or backward. 

• If Text File Editor finds a match, it highlights the text in the 
document. You can stop the search here, or you can click Find 
Next or Find Previous to resume the search for another match. 

• For fo1ward searches, if Text File Editor reaches the end of the 
document, it starts searching from the beginning. For backward 
searches, if Text File Editor reaches the beginning of the 
document, it starts searching from the end. If Text File Editor 
cannot find the search text in the document, a message appears 
to that effect. Click OK to close the message dialog box. 

4. Click Close to close the dialog box. 

Replacing Text 

You can replace any search text with different text. 



To replace text 

1. Choose Find and Replace from the Edit menu , or press F6. The 
Find and Replace dialog box appears. 

2. Type the text you want to search for. You can search for any 
combination of numbers, letters, spaces, and other printable 
characters (such as punctuation marks). 

3. Enter the text that will replace the search text. 

4. Click Find Next or Find Previous. Text File Editor starts the 
search from the insertion point forward or backward. If Text File 
Editor finds a match , it highlights the text in the document. You 
have the following choices: 

• You can replace one occurrence of the selected text. To do this , 
click Replace. You can stop the search here , or you can click 
Find Next to resume the search for another match. 

• You can replace all occurrences of the search text with the 
replacement text. To do this , click Replace All. A dialog box 
appears asking if you want to replace all occurrences. Click Yes 
to continue, or click No to abandon the operation. 

• Replace in Selection is the same as Replace All , except that it 
replaces all occurrences only within selected text. 

For forward searches, if Text File Editor reaches the end of the 
document, it starts searching from the beginning. For backward 
searches, if Text File Editor reaches the beginning of the 
document, it starts searching from the end. If Text File Editor 
cannot find the search text in the document, a message appears 
to that effect. Click OK to close the message dialog box. 

5. Click Close to close the dialog box. 

Using Wild Cards and Special Characters 

You can use wild cards and special characters when you search 
and replace text. 

A wild card is a symbol that substitutes for a single character (?) 
or a series of characters (*). You can use wild cards to search for 
words or phrases that are similar or have slightly different 
spellings. 

For example, if you want to find any word that begins with 
"math" (such as math, mathematics, mathematical, and so on) , 
you can use the Multiple Characters wild card in your search text 
("math*"). Similarly, if you want to find any occurrence of the 
words "affect" and "effect", you can use the Any Character wild 
card in your search text ("?ffect"). 



You can also search and replace special characters in your 
document: graphics, special text, tabs, carriage returns , and page 
breaks. 

To use wild cards and special characters 

1. Choose Find and Replace from the Edit menu, or press F6. The 
Find and Replace dialog box appears . 

2. Click Special Characters. A drop-down list appears: 

:;wecial Characters 

1!1- Match Multiple ~acters 
Iii - Match Any Character 

'f -Graphic or s..eae1 Text 

•I-Tab 

tt[ - Carriage Return 

<)- Page Break 

3. Select the wild card(s) and special character(s) you want to 
search for. 

Match Multiple Characters. This option adds the Multiple 
Character wild card to the Find text. It allows you to match text 
where the beginning or end of the text might vary (such as 
"professor" and "professional"). 

Match Any Character. This option adds an Any Character wild 
card to the Find text. It allows you to match text where one or 
more characters might vary (such as "arise" and "arose"). 

Graphic or Special Text. This option adds a character to search 
for any graphic object or any special text character (dates, times, 
numbers, and so on) to the Find text. 

Tab. This option adds a tab character to the Find or Replace With 
text. 

Carriage Return. This option adds a carriage return character to 
the Find or Replace With text. 

Page Break. This option adds a page break character to the Find 
or Replace With text. 

Ignore Case/ Accents. This is a special character option that 
instructs Text File Editor to find every occurrence of the search 
text, ignoring uppercase, lowercase, and accent marks . For 
example, if the search string is "Dog", Text File Editor could find 
matches for "Dog" and "dog". 

Match Partial Words . This is a special character option that 
instructs Text File Editor to search for a portion of a word. For 



example, if the search string is "print" , Text File Editor could find 
matches on "print", "sprinter", "reprint", and so on. 

4. Click Find Next or Find Previous to search the document for the 
search text, and click Replace or Replace all to replace the search 
text with the replacement text. 

5. Click Close to close the dialog box. 

PRINTING A DOS TEXT FILE 

In Text File Editor, you choose Print from the File menu to print 
a document, just as you would in any GEOS application. 
However, you should be aware of the following two differences 
when printing Text File Editor documents: 

Line Length. The length of a line in the printed document is not 
always the same as the length of the same line shown in the Text 
File Editor window. In the Text File Editor window, text wraps at 
the right edge of the window. When you print, however, text 
wraps at the right edge of the page. (However, if you end a line 
by pressing Enter, this line ending is preserved when you print 
the document.) 

This difference in line length occurs because Text File Editor 
always prints documents using the printer's built-in fonts. 
Although a built-in font may be a different size from the font in 
your document, documents printed using built-in fonts print very 
quickly. 

Text Size. The size of printed text may be different from the size 
of the text displayed in the Text File Editor window. Regardless 
of the text size you choose from the Sizes menu, Text File Editor 
always prints documents using the built-in fonts in your printer. 

For more information about printing in Ensemble applications, 
see Chapter 2. 

WORKING WITH DOS TEXT FILES 

Working with DOS text files in the Text File Editor is similar to 
working with documents in other GEOS applications. However, 
there are some differences you should be aware of: 



Document Safeguarding. Document safeguarding works only 
with GEOS files , not DOS files . Since Text File Editor documents 
are DOS files , they are not protected by document safeguarding. 
Be sure to save your Text File Editor documents often. 

DOS File Names . All documents you create with Text File Editor 
are DOS text files. Therefore, when you save them, you must 
give them names that follow the DOS rules for naming files. DOS 
file names can be up to eight characters long, optionally followed 
by a period and three more characters. You may want to use 
"TXT" following the period to indicate your file is a text file. You 
cannot include spaces in a DOS file name. For more information 
about DOS file names , see Chapter 2. 

Multiple Documents. Text File Editor is unlike other 
applications in this manual in that it allows you to open more 
than one document at a time and switch between them, all 
within the same Text File Editor application. 

Saving a DOS Text File 

If you've made changes or additions to a DOS text file and want 
to make the changes permanent, you can do this by saving your 
document. In Text File Editor, you choose Save from the File 
menu to save a document, just as you would in any GEOS 
application. 

To save changes to a DOS text File 

• Choose Save from the File menu. Text File Editor saves your 
changes and returns you to the document. 

For more information about saving changes, see "Saving 
Documents" in Chapter 2. 

Creating a DOS Text file 

It is easy to create a new Text File Editor document from within 
Text File Editor. The basic procedure is covered here. For more 
information about creating and naming a new DOS text file , see 
Chapter 2. 

Unlike other applications, such as GeoDex and GeoPlanner, you 
do not need to close the current document before you can create 
a new document in Text File Editor. Text File Editor lets you 
work with more than one document at a time. For more 
information on using more than one document at a time, see 
"Working With Multiple Documents" in this chapter. 
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To create a new DOS text file document (All Levels) 

1. Choose New/ Open from the File menu. 

The New/ Open dialog box appears. 

2. Click the New button. A new DOS text file appears . 

3. You must type at least one character into the text file before you 
can save it and give it a name. 

4. After typing one or more characters , choose Save from the File 
menu. A standard file selector dialog box appears. 

5. Use the file selector controls to select the folder in which you 
would like to save the new document. To select your Document 
folder, click the Go To Document button. 

6. Type a name for the document in the New Name area; then click 
Save. The new document is saved with the name you provided. 
You are returned to Text File Editor with that document open. 

Opening DOS Text Files 

A DOS text file appears as an icon, normally a .TXT extension, 
like the example at the left. You can open a DOS text file from its 
icon if it has a .TXT extension. You can also open a document 
from within Text File Editor. 

Because Text File Editor lets you work with more than one 
document at a time, you do not need to close the current 
document before you can open another document in Text File 
Editor. For more information on using more than one document 
at a time, see "Working With Multiple Documents" in this 
chapter. 

To open a Text File Editor document using its icon (All Levels) 

1. Locate the icon of the Text File Editor document you wish to 
open. 

2 . Double click the document icon. Text File Editor starts and opens 
that document. 

To open a DOS text file from within Text File Editor 

1 . Choose New/ Open from the File menu. The New/ Open dialog 
box appears. 

2. Click the Open button. A standard file selector dialog box 
appears. 



3. In the list, select the Text File Editor document you wish to open. 
Use the standard file selector controls to change to a different 
folder if necessary. 

4. Click Open. The document opens and you are returned to Text 
File Editor. 

Working With Multiple Documents 

Text File Editor allows you to have many documents open at 
once. The names of all open documents are in the Window 
menu. By opening multiple documents, you can check references 
in different documents and copy and paste information between 
them. Each document window you open has its own title bar and 
window control button. The window control button on 
document windows works very much the same as the window 
control button on application windows. You can click the 
window control button to see the window control menu; and 
you can double-dick the window control button to close that 
window. 

W indow contro l button for the document window 

Title bar for the document w indow 
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You can use choices on the Window menu to switch between 
one document and another. You can also set the display of the 
documents to Full-Sized or Overlapping. 

When the display is full-sized and you have more than one 
document open, you can only see the one on top, like seeing 
only the top page on a stack of reports sitting on your desk. You 



can switch between documents by choosing the name of the 
document you want to be on top from the Window menu. 

Overlapping documents are stacked so that you can see the 
upper left corner of the document. You can also choose to 
display the documents tiled, where the documents are side-by
side. You can resize and move overlapping documents in the 
application window. 
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To open multiple documents 

1. Open the first document in the usual way. 

2. Choose New/ Open from the File menu. The New/ Open dialog 
box appears. 

3. Open a second document. The second document displays on top 
of the first. 

To switch documents using the Window menu 

1. Open the number of documents you want to use. The 
documents can be displayed as full-sized windows. 

2. Choose the document's name from the list of open documents 
names in the Windows menu. The document you specified 
appears on the top of the stack (or is highlighted in a tiled 
display). 

To switch documents using Next on the window control menu 

1. Click the window control button on the document window. The 
window control menu appears. 



2. Choose ext from the window control menu. The next document 
appears on the top of the stack (or is highlighted in a tiled 
display). 

Repeat this step, selecting the next document, until the document 
you want to work with is on top. 

To change the window display mode using the Window menu 

1. Open the number of documents you want to use . 

2. Choose a display option from the Window menu. 

Overlapping. The documents stack up, showing the upper left 
corner of each document. Click any part of a document to make 
it the active document. 

Full-Sized. Each document is displayed at full-size in the 
document window. Use the Window menu to switch between 
documents. 

The document windows redisplay in the new mode. 

To tile documents 

1. Open the number of documents you want to use . 

2. Choose Tile from the Window menu. 

The document windows automatically switch to overlapping and 
resize so that they all fit into the application window. 

To change.from full-sized to Overlapping using the document 's 
window control menu 

1 . Click the window control button on the document window. The 
window control menu appears. 

2. Choose either Maximize or Restore . 

Maximize. If the window display is in Overlapping mode, 
choosing Maximize will make the document windows full-sized 
and switch into Full-Sized mode. 

Restore. If the window display is in Full-Sized mode, choosing 
Restore will switch the display into Overlapping mode. 

The document windows redisplay in the new mode. 

To switch between documents by clicking their windows 

To switch between documents by clicking their windows, the 
documents must be visible; therefore , they must be overlapping 
or tiled. 



• Click somewhere in the document you want. The document you 
clicked appears on the top of the overlapped stack or is 
highlighted in a tiled display. 

Document Management 

When you work with documents, you use features on the File 
menu. In Text File Editor, as in other GEOS applications, the File 
menu lets you perform the following operations: 

• Create a new document 

• Open an existing document 

• Save a document 

• Close a document 

• Back up and restore a document 

• Make a copy of a document 

• Discard changes 

• Rename a document 

• Edit document notes 

• Set or remove a document password 

• Set a different startup document 

• Set the document type 

For more information on file management and working with 
documents, see Chapter 2. 

EXITING TEXT FILE EDITOR 

When you are done using Text File Editor, you should exit it. 
Exiting an application closes its window and frees up system 
resources. You should save your document before exiting, but if 
you forget Text File Editor will give you one last chance to save 
your changes. 

To exit Text File Editor 

• Choose Exit from the File menu. 

or 

Double-dick the window control button, located in the top left 
corner of the Text File Editor window. 

n 1-r 



The Text File Editor window closes and the application exits. If 
you have unsaved changes in your document, Text File Editor 
will ask if you want to save those changes. 



CHAPTER 9 

GeoComm If your workstation has a modem, you can use 

GeoComm, the communications application , to communicate 

with other computers, online services, bulletin board systems, 

and mainframe computers at colleges and corporations. You can 

also share information with a variety of other computer users, 

from individual friends and colleagues to users on world-wide 

computer networks. 



You do not need to have previous experience with data 
communications to use GeoComm. Data communications is the 
capability a computer has to communicate and exchange 
information with another computer. You'll learn fundamental 
concepts that make using GeoComm easy as well as fun. 

The GeoComm application does not have user levels. 

This chapter describes how to do the following: 

• Get started using GeoComm. 

• Establish various modem, terminal, and window settings. 

• Dial phone numbers and hang up. 

• Perform various interactions with other computers and online 
services. 

• Use scripts to automate various tasks. 

This chapter assumes you are familiar with the information 
covered in Chapter 1. Chapter 1 provides an overview of the 
skills you need to use any GEOS application. 

WHAT IS GEOCOMM? 

GeoComm is an application that allows your computer to 
communicate with another computer or with an online service 
over standard telephone lines by means of a modem. A modem is 
a hardware device attached to your computer that translates the 
various telephone and computer signals that enable your 
computer to "talk" to another computer. 

STARTING GEOCOMM 

GeoComm 

In GeoManager, the GeoComm icon looks like the example at 
the left. GeoComm is one of the GEOS desk accessories. That 
means you can start GeoComm either from GeoManager or from 
the Express menu that appears in all GEOS application windows. 

To start GeoComm 

• Locate the GeoComm icon and double-click it. 

or 



Choose GeoComm from the Express menu in any GEOS 
application. 

The GeoComm window appears . 

I Cursor 

The GeoComm window is where you send and receive 
messages. After you connect to another computer, anything you 
type is sent to the other computer. Any messages sent to you by 
the other computer also appear in the GeoComm window. 

When you first open the GeoComm window, the cursor, a 
rectangular box, is displayed in the top left comer. At this point, 
it is hollow. The cursor changes from hollow to solid, depending 
on what tasks are taking place. 

I When the cursor is solid, generally it means what you type is 
displayed in the GeoComm window and is sent to the computer 
you are connected to. 

D When the cursor is hollow, generally it means what you type is 
not sent to the other computer. You could be filling in a dialog 
box or receiving information from another computer. 

CHOOSING THE PROTOCOL SETTINGS 

When you first open GeoComm, the Protocol Options dialog box 
appears automatically. Protocol is a set of rules established 
between two devices that allow and govern the orderly exchange 



of information. You use this dialog box to select the protocol 
settings for your modern. The modem's protocol settings tell your 
modem such things as how fast to transmit information, which 
communications port to use on your computer, and what type of 
phone line you have. 
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The settings you see selected in the Protocol Options dialog box 
are the default settings; that is, every new GeoComrn application 
starts with these settings. GeoCornrn obtains the default settings 
from the Modern settings located in the Preferences application. 
For more information about the Preferences application, see 
Appendix A. 

The protocol settings you choose must match those of the 
computer to which you want to connect, so find out what 
settings that computer is using. 

To choose the protocol settings 

1 . Fill in the dialog box, changing the settings as necessary. 

Modem Port. The modern port is the serial port on your 
computer used by your modem (for example, COMl) . 

Baud Rate . The baud rate is the rate of speed at which your 
modem can send and receive information. Examples of baud 
rates are: 300, 1200, 2400, 9600 and 19200. The most commonly 
used baud rates are 1200, 2400, and 9600. In most cases, you can 
just set the maximum rate for your modern, and the other system 
will match that rate . 

Data Bits . Data bits are the number of bits that form a character. 
The most common setting is 8. 

Parity. Parity is an error-checking mechanism used to ensure 
error-free transmission of information. The most common setting 
is None. 



The Preferences 
application is 
described in 
Appendix A. 

Stop Bits . Stop bits help a computer figure out when to send or 
receive a character. The most common setting is 1. 

Handshake . Choose Software (XON/XOFF), and GeoComm will 
monitor the flow of information from the other computer. This 
ensures that you receive all the information sent to you by the 
other computer. 

2. Click Apply to save your settings. 

3. Click Close to close the dialog box. 

To change the d~f a ult protocol settings 

Each time you open GeoComm, the Protocol dialog box is 
displayed so you can change the settings to suit your particular 
needs. If you want the settings you choose to be permanent, 
change them using the Preferences application. When you open 
GeoComm anytime after doing this , the Protocol dialog box is 
not displayed. 

1. Locate the Preferences icon and double-dick it. 

2. Click the Modem icon to open it. The Modem Options dialog 
box appears: 

Use these options to insteH end configure your modem. 

Modem 

Serial Port: v- Hone + COM 1 v COM 2 v COM 3 · .. ··CUM 4 

Diel Type: + Tone v Pulse 

3. Fill in the dialog box, changing the settings to match those you 
made in the Protocol Options dialog box in GeoComm. 

4. Click OK to save your changes. The dialog box closes. 

5. Click Close to close the Preferences application. 

6. Click the GeoComm window to activate it again .. 

CHOOSING THE TERMINAL SETTINGS 

You can make your copy of GeoComm emulate (or act like) 
many other terminals. A terminal is a computer that does not do 
its own computing - another computer does the work. Often, 



terminals are not computers in themselves. They are merely a 
keyboard and a monitor (and sometimes a mouse) that is 
connected to a central computer. The central computer provides 
the processing capabilities for that terminal and many others. 

There are several standard types of terminals - TTY, VT52, 
VTlOO, WYSESO, and ANSI - that GeoComm can emulate. The 
emulation, however, is not complete. You may find that some 
features do not work as you would expect with a particular type 
of terminal. Despite this , the terminal emulation should be 
adequate for most situations. 

The value of being able to emulate another terminal is that a 
great many online services that you may want to talk to are 
written to support these terminals rather than your PC. When you 
sign up to use these services, they will tell you if you need to 
emulate a specific terminal in order to use the service. 

The Terminal Options dialog box contains special choices that 
allow you to specify the behavior of your terminal. 

To establish the terniinal settings 

1. Choose Terminal from the Options menu . A dialog box appears: 

2. Fill in the dialog box, changing the settings as necessa1y. 

Select Terminal. Select the type of terminal you need from the 
list. 

Duplex. The Du pl ex setting controls the way information flows 
between two computers. At full duplex, information can flow 
between two computers at the same time. At half duplex, 
information can flow only in one direction at any given time. 

If you do not know if you need full or half du pl ex, simply type a 
few characters on your screen. If what you type appears twice on 
your screen, you need full duplex, so choose Full (full echo). 
Otherwise, choose Half (local echo). 



You must be actively connected to another computer to test the 
duplex setting. For more information about connecting to 
another computer, see "Dialing and Hanging Up" in this chapter. 

Wrap Lines at Edge. This setting allows you to display all the 
text you are receiving. If you have this option selected, long lines 
of text will break at the edge of your screen and continue on the 
next line. If you do not select this option, lines of text that go 
beyond your screen's edge do not display. However, if you 
capture this text to a DOS file , you capture all the text, even the 
text that did not fit on your screen. 

Auto Linefeed. This setting converts each incoming carriage 
return (end of line) with a carriage return and new line. 
Otherwise, each new line of incoming text overwrites the last 
line. If all your incoming lines display as double-spaced text, do 
not choose Auto Linefeed (unless you prefer double spacing). 

Host Code Page. This setting allows you to choose a language 
for your text. When you select this option, a dialog box with a 
list of languages appears. Choose the appropriate language from 
the list. 

3. Click OK to save your terminal settings. 

or 

Click Close to close the dialog box without making any changes. 

The dialog box closes and you are returned to the GeoComm 
window. 

CONFIGURING YOUR MODEM 

Before you can use your modem, you need to set up, or 
configure, your modem to work with your telephone equipment 
and your PC. The Modem settings work only with Hayes®
compatible modems. Hayes is a popular modem that is 
recognized as an industry standard. 

NOTE 

If you r modem is not Hayes-compatible, see your modem manual for 
the proper sett ings. 



To configure your modem 

1. Choose Modem from the Options menu. A dialog box appears: 
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2 . Fill in the dialog box, changing the settings as necessary. 

Phone Type . This setting identifies your phone line as being 
either Touch Tone or Rotary. If you have a push-button phone, 
you probably have Touch Tone service. If you have a rotary-dial 
phone, you probably have Rotary service. 

Modem Speaker. This setting controls whether or not you hear 
signals your modem is processing. Select one of the Modem 
Speaker settings: 

• On Until Connect. This setting allows you to make sure your 
modem is successfully dialing and connecting to the computer 
your are calling. You will be able to hear the dial tone, the 
phone number being dialed, and the connection being made. 
After the connection is made, the speaker is off. 

• On Unless Dialing. The setting allows you to hear your modem 
calling another computer. Your modem speaker is on only 
when waiting for the other computer to answer. 

• Always On. This setting allows you to have your speaker on at 
all times. 

• Always Off This setting allows you to have your speaker off at 
all times. 

Speaker Volume . This setting allows you to control the modem 
speaker volume. Choose High, Medium, or Low. 

3. Click OK to save your modem settings. 

or 

Click Close to close the dialog box without making any changes. 

The dialog box closes and you are returned to the GeoComm 
window. 



CHANGING WINDOW SETTINGS 

You can control the size of the GeoComm window to display as 
much or as little information at a time as you want. You can also 
adjust the size of the text displayed in the GeoComm window. 

To change the window size using the Window Size dialog box 

1. Choose the Window Size option from the View menu. A dialog 
box appears: 

2. Fill in the dialog box, changing the settings as necessary. 

Window Lines . This sets the number of lines your computer 
screen can display in the window. You can choose any number 
from 1 to 24. 

Window Columns . This sets the number of columns your 
computer screen can display. You can choose any number from 1 
to 80. 

If your computer screen only supports fewer than 24 lines and 80 
columns, you will see only what your screen can display. 

3. Click Apply to save your changes. 

or 

Click Reset to return to your original settings 

GeoComm resizes the window according to your settings . 

4. Click Close to close the dialog box. 

Changing the Text Size 

You can increase or decrease the size of text (the font) displayed 
on the GeoComm window. Anytime you open GeoComm, the 
small font is always in effect. Changing it to the larger font can 
make it easier to read. 

To change the font size 

1. Open the View menu. 

2. Select either Large Font or Small Font. GeoComm resizes both the 
text and the window to the new size. 



NOTE 

This feature affects all text in the window. You cannot change the 
font size of individual words or sentences. 

DIALING AND HANGING UP 

Once you have chosen your protocol, terminal, and modem 
settings, you are ready to communicate with another computer. 
This section describes how to dial the phone number as well as 
how to hang up when you are finished with your communication 
session. 

Eventually, you may want to automate certain tasks that you 
need to do to set up for and initiate a communication session. 
For example, you may want to have the phone number dialed 
automatically, or you may want to have your computer hang up 
automatically. This section introduces how to create and run a 
script, a file you create that performs these tasks for you. For 
more information about writing scripts, see "Using the GeoComm 
Scripting Language" in this chapter. 

Using Quick Dial 

The Quick Dial option makes it easy to dial the phone number of 
another computer. 

To use Quick Dial 

Before you dial , make sure you 've made any necessary changes 
to the protocol , terminal, and modem settings as discussed in this 
chapter. 

1. Choose Quick Dial from the Dial menu. The following dialog 
box appears: 

2 . Enter the number you want to dial, and then click Dial. 
Depending on how you have your modem speaker set, you may 
hear your modem dialing and making the connection to the 
other computer. For more information about the modem speaker, 
see "Configuring Your Modem" in this chapter. 



If you need to access an outside phone line (for example, by 
dialing "9") , you need to tell the modem to pause for a moment 
before it dials the phone number. This is indicated with a comma 
in the phone number. For example, "9,5551212" tells the modem 
to dial 9 first to get an outside line, then pause, and then to dial 
5551212. 

When the connection has been made, CONNECTED is displayed 
in the GeoComm window. 

3. Once your computer is connected to the other computer, click 
Close to close the Quick Dial dialog box. 

Hanging Up 

When you are finished communicating with another computer, 
you need to hang up. 

To hang up 

If you dial into a computer system that requires you to log in 
(such as a bulletin board or online service) , you often must log 
out before you hang up. If you don't log out first, you may 
continue to billed for your online time. 

1. Choose Hang Up from the Dial menu . A confirmation message 
appears. 

2. Click Yes to hang up. 

Using Scripts 

GeoComm allows you to automate many of the commands that 
you otherwise have to type manually to communicate with 
another computer. 

For example, you can write a script that instructs your computer 
to dial a phone number, provide the necessa1y configuration 
information to establish a connection, and log you into an online 
service. 

Scripts are useful if you subscribe to several communications 
services, each of which may require different settings to your 
modem. Instead of reestablishing your modem settings each time, 
you just run the script. 

Scripts eliminate typing errors and are faster than commands you 
enter from the keyboard. 

GeoComm comes with several sample scripts that you can use to 
see how a script works . You can also modify these sample scripts 



to suit your particular communication needs. The sample scripts 
are in the folder \GEOWORKS\ USERDATA \COMMACRO. 

To create a script 

1. Use Text File Editor to create a text file containing your script 
commands. For more information about Text File Editor, see 
Chapter 8. For a list of the script commands, see "Using the 
GeoComm Scripting Language" in this chapter. 

2 . Save the file with a valid DOS file name with the extension .MAC. 
For example, MYSCRIPT.MAC is a valid script name. 

3. Place this file in \GEOWORKS\ USERDATA \COMMACRO. You 
are now ready to run the script. 

To run a script 

1. Choose Scripts from the Dial menu. The following file selector 
appears: 

2. Select the script you want to run. 

3. Click Run. The Script Display window appears and displays each 
line of the script as your computer executes it. This gives you a 
progress report on your script. 

NOTE 

If your script stops abruptly, it may be because you made an error in 

the script. 



To stop a script 

• Click Stop Running Script to stop the script and return to the 
GeoComm window. 

SHOWING LINE STATUS 

The Show Line Status option allows you to monitor the quality of 
your connection. In other words, Show Line Status allows you to 
"see" how good the connection is. Data communication is similar 
to a regular phone call in that sometimes the connection is "bad" 
- there is a lot of noise on the line. Usually, you just need to 
hang up and redial to correct the situation. Based on information 
provided from Show Line Status, you may decide that the quality 
of the connection is poor. In that case, you can hang up and try 
again later. 

To monitor the line connection quality 

• Choose Show Line Status from the Options menu. The following 
status window appears: 

The line status errors monitored by GeoComm are the number of 
errors in reading the message being received or writing the 
message being sent. Specifically, GeoComm checks the parity bit 
(see "Choosing the Protocol Settings") for transmission errors in 
each block (or frame) of information received or sent. 

GeoComm automatically tracks and counts these errors during 
your communication sessions. It is normal to have a small 
number of errors. However, if you see hundreds of errors 
encountered during a session, consider hanging up and retrying 
your connection. 

To reset the counters to zero errors 

It is a good idea to reset the counters every time you start a 
communication session. Othe1wise, the error count for the 
current session will be added to any existing values . This results 



in an inaccurate count of the number of errors in the current 
session. 

1. Click Reset Counters. The counters are all reset to zero values. 

2 . Click Close to close the window and return to the GeoComm 
window. 

SENDING A BREAK SIGNAL 

At some point during send or receive operations at your terminal , 
you may want to send a break signal. A break signal interrupts 
some command you 've entered or some process taking place. 

As an analogy, you may be familiar with the Type command in 
DOS. If you've used this command to display the contents of a 
long file , you probably decided to interrupt the command 
because it was taking too long for the file to finish displaying. To 
do this , you press Ctrl + C. A break signal is similar to Ctrl + C, 
except that it takes effect immediately. 

To send a break signal 

• During an operation in GeoComm that you want to interrupt, 
hold down Ctrl and press the Pause (or Break) key. Whatever is 
displaying in the window is stopped. 

NOTE 

A break signal does not work if your terminal is set to half duplex. 

SENDING INFORMATION 

GeoComm allows you to send various types of information to 
another computer, from brief messages that you type to the 
receiving computer to complex computer applications or text files 
that you have stored on your disk or a diskette. 

There are four ways to send information to another computer: 

• Typing and sending a message using the Message choice on the 
Edit menu. Use this method when your messages are brief and 
spontaneous, and when you want to send them to the other 
computer immediately. 



• Sending text that you have copied into the clipboard. Use this 
method when you have a file that you've created in a GEOS 
application, and you want to send information from that file to 
the other computer. 

• Sending a DOS text file. Use this method when you want to 
send a DOS text file . 

• Sending files using XMODEM. Use this method when you are 
sending entire files , large amounts of information, or 
applications to another computer. It provides error-checking to 
ensure your files or applications arrive intact. 

Sending Brief Messages 

The Message option on the Edit menu allows you to create brief 
messages either offline (meaning you are not connected to 
another computer) or while you are connected to another 
computer. It gives you time to compose and edit your message 
before sending it. 

The Message choice does not perform error checking. In other 
words , using Message does not guarantee that all your characters 
are reaching the other computer. This is usually not a problem 
for short text files messages like: "Hello, how are you?" If a 
message this brief gets corrupted by a poor connection and 
arrives "Hello, how are ?ou" the receiving party can probably still 
decipher it. 

However, it is not acceptable for sending long files and large 
amounts of information. Suppose you are sending your income 
tax figures to your accountant and the number that represents 
your gross income is corrupted. What started out as "35,000.00" 
may have arrived as "$&5*#00.00. " Your accountant is not likely 
to figure this out. To send long files, use the XMODEM protocol 
discussed in "Sending DOS Text Files Using XMODEM. " 

To compose and send a brief text message 

1. Select Message from the Edit menu. The following dialog box 
appears: 



2. Type your message in the dialog box as you would any text. 

3. Edit the text as needed. 

4. Click Send when you are ready to send your message. GeoComm 
both displays the message in your window and sends it to the 
receiving computer, where it displays in that computer's window. 

5. Click Close to return to the GeoComm window. 

Sending Text Using the Clipboard 

You can copy text from other GEOS applications and send it to 
another computer. For example, suppose you have an 
announcement that you have written using Text File Editor. You 
can open the appropriate Text File Editor file and copy the 
message to the clipboard. Then, you can paste the contents of 
the clipboard into the GeoComm window. When you do this , 
GeoComm sends the text to the other computer just as if you had 
typed it directly into GeoComm. 

NOTE 

This method of sending text works w ith GEOS appl ications, not w ith 
regular DOS applications. 

To send the contents of your clipboard 

1. Open the file containing the text you want to send. 

2. Select the text you want to send. 

3. Use the Copy command to copy the text to your clipboard. 

4. Click the GeoComm window to make it active. 

5. Choose Paste from the Edit menu. GeoComm pastes the contents 
of your clipboard onto the GeoComm window and sends it to 
the other computer. 

Sending DOS Text Files 

This option allows you to send entire DOS text files that you 
have saved on your hard disk or perhaps on a diskette. This 
method does not perform error-checking, so there is no 
guarantee that the information will arrive error-free. 

NOTE 

This method of sending text is for files created in DOS applications, as 
well as in Text File Editor. 



To send an existing DOS text file 

Before sending an existing DOS text file, it is good practice to 
verify whether or not the receiving computer requires linefeeds. 
Linefeeds prevent text from typing over itself. 

1. Choose Type From Text File from the File menu . The following 
file selector appears: 

2. Locate and select the DOS file you want to use. 

3. Select Strip Linefeeds from Text if the computer you are 
connected to does not need linefeeds after carriage returns. Most 
computers need linefeeds, so you will normally not need to 
select this option. 

4. Click Type when you are ready to send the DOS file. 

GeoComm displays a status window to show how your file 
transfer is proceeding. When the file transfer is completed, 
GeoComm returns to the GeoComm window. 

Sending Text Files Using XMODEM 

The XMODEM protocol is a method of transmission that you can 
use to send entire files and large amounts of information to 
another computer. The advantage of using XMODEM is that it 
detects a transmission failure, and it resends the information. 

NOTE 

Before you can use XMODEM to transfer files, verify that the other 
computer is set up to receive an XMODEM transfer. Do this by 
calling before you establish your connection or, once you are 
connected, by sending a message to the receiving computer indicating 
that you want to use XMODEM. 

To send a file using XMODEM 

1. Establish the connection with the computer to which you want to 
send a file using XMODEM. 



2. If necessa1y, make sure the receiving computer is ready to receive 
a file using the XMODEM protocol. 

3. Choose Send XMODEM from the File menu. The Send XMODEM 
file selector appears: 

4. Locate and select the file you want to use. 

5. Select the size of the data packet. Large files are broken up into 
small data packets to facilitate being transferred to another 
computer. The recommended selection is 128 bytes. 

6. Click Send. The Send XMODEM Status window appears and 
shows the progress of the transfer, reporting any errors. 
XMODEM automatically resends those portions of the 
transmission that have errors . However, if the error count 
increases suddenly, you probably have a problem in the phone 
line and may want to ret1y the transmission later. 
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RECEIVING INFORMATION 

This section describes how to receive information sent to you 
from a remote computer during a communication session. You 
can receive the types of messages and files discussed in "Sending 
Information" in this chapter. 

You should always disable call waiting when using the phone 
line for data communication. Failure to do so may cause the 
other computer to disconnect if someone else tries to call while 



you 're connected. To find out how to disable call waiting, 
consult your local telephone company. 

Before you receive information, it is a good idea to determine 
what you intend to do with it. Depending on the type and 
volume of information, there are various ways to accept, store, 
and save it, including the following: 

• Scrolling through the text as it arrives without saving it. 

• Copying the text to a file 's clipboard. 

• Saving the text in a text file. 

Scrolling Through the Text Displayed in the Window 

As the text arrives at your computer and is displayed in the 
window, the first part of the text may scroll off the screen. If the 
message is longer than 175 lines , consider copying it to the 
clipboard. See "Copying Text to the Clipboard" in this chapter. 

To scroll through the text on your window 

• Click the up or down arrow on the scroll bar. 

Copying Text to the Clipboard 

If you want to save small amounts of text that appear in your 
window, use the Copy and Paste commands to paste the text into 
another GEOS application file, such as a Text File Editor file. You 
can copy and paste information a screenful at a time, or you can 
wait until the entire message has arrived, as long as the message 
does not exceed 175 lines of text. 

NOTE 

Only the last 175 lines of text received are saved. If the message 
exceeds 175 lines, newly arriving text w rites over the text that has 
already arrived. For a method of captu ring more than 175 lines of 
text, see "Saving Text in a File" in this chapter. 

To copy text from your clipboard to a file 

1. Select the text in the GeoComm window that you want to copy. 
You can select text using the mouse , the same way you would 
select text in Text File Editor, for example. For more information 
about selecting text, see Chapter 1. 

2. Choose Copy from the Edit menu. 

3. Open the desired file and place the insertion point where you 
want to insert the text. 



4. Choose Paste from the Edit menu. The text is pasted into the file. 

Saving Screen and Scroll-back Buffer Text to a File 

GeoComm saves the last 1 75 lines of text in the scroll-back 
buffer. This is an area that stores the text that scrolls off the 
screen out of view. GeoComm stores the information in the 
scroll-back buffer so that you can redisplay it by scrolling back 
through the window. Otherwise, all the text that scrolls off your 
screen would be lost. By saving text in a file , you can prevent the 
loss of incoming text. 

To save the contents of your screen and scroll-back buffer 

1. Choose Save Buffer from the File menu. The Save Buffer file 
selector appears: 
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2. Locate and select the directory you want. 

3. Type a DOS file name (a DOS file name contains up to eight 
letters or numbers , following by a period, then a three-letter 
extension). For more information about DOS file names , see 
"Naming a Document" in Chapter 2. 

4. Select saving only what you see on your screen (Screen Only). 

or 

Select saving only what is hidden in the scroll-back buffer (Scroll
back Buffer Only). 

or 

Select saving both (Scroll-back Buffer and Screen). 

5. Click OK to save the text to the file you have specified. 

Saving Text in a File 

You can "capture" all incoming text as it arrives and have it 
placed in a file immediately. Since GeoComm usually saves only 
the most recently received 175 lines of text that displays in the 



window, this method of saving text ensures that all the text is 
saved in the file you specify. It is also faster than using the Copy 
and Paste method. 

To save all incoming text to a file 

You need to be set up before you can start capturing incoming 
text to a file. 

1. Before text you want to save starts arriving in the window, 
Choose Capture to Text File from the File menu. A file selector 
appears: 

• End Lines With CR/l.F 

2. Locate and select the directory you want. 

3. Type a DOS file name (a DOS file name contains up to eight 
letters or numbers, following by a period, then a three-letter 
extension) . For more information about DOS file names, see 
"Naming a Document" in Chapter 2. 

4. Select End Lines with CR/LF if you want the end of each line to 
contain a carriage return and linefeed. If you are unsure, it is a 
good idea to select it. 

5. Click Capture to start saving screen text. GeoComm displays a 
status window to report this activity while you are online: 

6. Click Done in the Capture Status window when you are finished 
capturing text. 



Saving Text Files Using XMODEM 

You can receive text files and be assured that they arrive without 
transmission errors. The other available choices for receiving files 
do not provide error checking or correction. 

NOTE 

Before you can use XMODEM to receive files, verify that the other 
computer is set up to send files using XMODEM. Do this by calling 
before you establish your connection or, after connecting, by sending 
a message to the sending computer indicating that you want to use 
XMODEM . Also, find out what error-checking mechanism is 
supported, Checksum or CRC. 

To receive a file using XMODEM 

1. Establish the connection with the computer from which you want 
to receive a file using XMODEM. 

2. If necessary, send a message telling the sending computer that 
you want to use the XMODEM protocol. 

3. Choose Receive XMODEM from the File menu. The Receive 
XMODEM file selector appears: 

4. Locate and select the directory you want. 

5. Select the type of file you are receiving. You have the following 
two choices: 

• Text. Select this if the file you are receiving is a basic DOS text 
file (straight ASCII). 

• Binary. Select this if the file you are receiving is more complex, 
like a Word Processor, or a Graphic file (not straight ASCII). 

6. Select the type of error checking to be performed by XMODEM. 
There are two choices, each of which ensures error-free file 
transfer: 



• Checksum. This is a simple method of checking for file 
corruption during sending and receiving. 

• CRC (Cyclic Redundancy Check). CRC is more sophisticated 
than Checksum. It is a good idea to select it if the sending 
computer supports it. 

7. Type the name of the file you want the text saved to. The name 
should be appropriate for the type of file you are expecting. (For 
example, a DOS text file would have a .TXT extension.) 

8. Click Receive. The Receive XMODEM Status window appears: 

Schedule 

0 

The Receive XMODEM Status window shows you the progress of 
the transfer. If errors increase dramatically, you may have a poor 
line connection. In that case, consider canceling the transfer and 
trying again later. 

USING THE GEOCOMM SCRIPTING LANGUAGE 

You can package a series of commands into one file , called a 
script. You then use this file to instruct GeoComm to perform a 
series of tasks. This means that you do not need to respond to 
prompts or worry about mistyping information. 

For example, suppose you use your GeoComm application to 
connect to a subscription service to receive a file that lists 
statistical information. Every day, you open GeoComm, select the 
Quick Dial option, enter the same phone number, and respond 
to requests for the same information. 

You can simplify this process by writing a script that 
automatically dials the phone number, logs into the service, 
receives the file, and places it in the proper location on your 
computer, then logs out and hangs up. You don 't need to wait 
around to respond to prompts or to log out. 

This section introduces the script language commands. In many 
cases, each command is the equivalent of a menu choice. 



For more information about how to create and run a script, see 
"Using Scripts" in this chapter. 

Script Syntax Guidelines 

All GeoComm scripts must follow specific guidelines for syntax 
(the "grammar" for the commands) and treatment of text. These 
guidelines are: 

• All GeoComm commands must be in upper case; for example, 
CLEAR, DIAL, E D. 

• All commands are case sensitive (if a capital A is required, you 
cannot use a lower case a). 

• Words shown enclosed in angle brackets ( < >) are place 
holders for the actual words you need to type; for example, 
where you see <baud>, you type the actual baud rate , such as 
2400. Do not include the angle brackets. 

• A line that starts with a colon is treated as a label or comment. 
This means that GeoComm displays the contents of that line , 
but it does not attempt to process or execute anything. 

Script Commands 

The script commands are listed below in alphabetical order. If 
available, the equivalent menu choice or other function is 
provided to help you visualize what happens when you use a 
command. 

You will see a few examples of how these commands are 
actually used. It is good practice to start with a simple script, then 
build on it by adding more commands. Try to see if you can 
build a script that performs an entire communications session 
from dialup to hangup without requiring your intervention. For 
more information about running your scripts, see "Using Scripts" 
in this Chapter. 

:<!ABEL> 

Any line beginning with a colon is treated as a label (although 
the colon isn't actually part of the label). Use the GOTO 
command to jump to a label line. Labels can be in upper or lower 
case, but you must be consistent. If you have label defined as 
":GoHere'', you must refer to exactly the same way in GOTO 
statements ("GOTO GoHere"). Here 's a sample label line: 

: JumpToThisLabel 



ABORT 

GeoComm goes to this special label when you click Stop in the 
Script Display window. The word "ABORT" must be all 
uppercase. This is how the abort label should appear in your 
scripts: 

: ABORT 

BELL 

This command sounds a beep. Use this in your script to alert you 
of an activity that is taking place or one that has completed. For 
example: 

BELL 

CLEAR 

This command clears the Script Display window. For example: 

CLEAR 

COMM <BAUD-DATABITS-PARITY-STOPBITS-DUPLEX> 

This command allows you to specify the baud rate, data bit 
value, parity setting, stop bit value , and duplex settings all on 
one line. 

This command is the equivalent of specifying Baud Rate, Data 
Bits, Parity, and Stop Bits in the Protocol dialog box and of 
specifying Duplex in the Terminal Options dialog box. For more 
information, see "Choosing the Protocol Settings" and "Choosing 
the Terminal Settings" in this chapter. 

For example, if you 're using a 2400 baud line with eight data bits , 
no parity, and one stop bit, you would put this command in your 
script (put dashes between settings): 

COMM 2400-8-N-1-FULL 

DIAL "<NUMBER>" 

This command dials the phone number you specify after DIAL. 
The phone number must be enclosed in quotation marks. Use 
commas to make GeoComm pause in the dialing. For more 
information, see "Dialing and Hanging Up" in this chapter. 

To dial 9 (for an outside line), a pause, and then 555-1212, you 
would put the following line into your script: 

DIAL " 9 , 555 - 1212 " 



END 

This command stops the script and returns control to you . It does 
not jump to the :ABORT label. Use this command to continue 
manually what the script has started for you. 

This is useful for beginning script users as a way to implement a 
basic script to see how one works. For example: 

DIAL " 9 , 555-1212 " 
END 

This script dials the phone number, 9,555-1212, then returns the 
GeoComm window back to you just as if you had used the 
Quick Dial option on the Dial menu. 

GOTO <LABEL> 

This command instructs GeoComm to go to the line specified by 
the label. You can use the GOTO command to jump to specified 
label lines (lines that begin with a colon). You must enter the 
GOTO label commands exactly the way you typed the label (be 
sure to leave off the colon, though). For example, the following 
line: 

: JumpToThisLabel 

must be referred to in a GOTO command as: 

GOTO JumpToThisLabel 

MATCH <TEXT> GOTO <LABEL> 
PROMPT <NUMBER> 

The MATCH and PROMPT commands work together to make 
GeoComm perform some action based on text received from 
another computer. 

First, the MATCH command makes GeoComm look for <text> in 
the text that is transmitted by the other computer. You can 
specify many MATCH commands but after them all , you must 
include a PROMPT command. 

The text for the MATCH commands must be entered inside 
quotation marks (" "). 



The PROMPT command specifies the amount of time your 
computer waits for the sending computer to supply the 
MATCHing text. PROMPT time values are in sixtieths of a second. 
(That is, 3600 sixtieths is a minute.) If the MATCH command is 
satisfied within the time specified in the PROMPT command, the 
script goes to the given label. Otherwise, GeoComm goes to next 
line in the script. For example : 

MATCH "password? " GOTO DoPass 
MATCH " System is down " GOTO SystemDown 
PROMPT 3600 
PRINT "No Response " 

The first MATCH command looks for the text "password?" from 
the remote computer. If the text is sent, the script goes to the 
label "DoPass", otherwise it continues with the next l\!IA TCH 
statement. If the second MATCH is made, the script goes to the 
label "SystemDown." If neither condition is met in the allotted 
minute (PROMPT 3600), the script prints "No Response" in the 
Script Display window. 

PAUSE <NUMBER> 

This command causes GeoComm to pause for the amount of time 
specified. The number value is in sixtieths of a second. The 
default is 60, or one second. To have your script pause for one 
minute, use the following line: 

PAUSE 3600 

PORT <PORT> 

This command instructs GeoComm to use the Com port 
specified. (This is a serial port on your computer where your 
modem is connected) 

This command is the equivalent of specifying Modem Port in the 
Protocol dialog box. For more information, see "Choosing the 
Protocol Settings" in this chapter. The following command tells 
GeoComm to use Com port 2: 

PORT 2 

PRINT <TEXT> 

This command instructs GeoComm to print <text> in your Script 
Display window. This message is not sent to the other computer. 
Use this command as an indication of what the script is doing. 
You can have as many PRINT statements in your scripts as you 
want. 



To force carriage returns after the text display, enter ",CR" at the 
end of each line , or add another print command: 

PRINT CR 

For example: 

PRINT nEnter Password Naw n , CR 
PRINT nPassword :n 

This displays on your screen as: 

Enter Password Now 
Password : 

PULSE 
TONE 

These commands cause GeoComm to use tone or pulse dialing 
when it dials a phone number. Otherwise GeoComm uses 
whatever you have set in your Modem settings. For more 
information, see "Configuring Your Modem" in this chapter. To 
force your script to use pulse dialing, use the following 
command: 

PULSE 

SEND <TEXT> 

This command sends the specified text to the other computer. 
Use a ",CR" at the end of the text if you want to insert a carriage 
return after the text. For example, to send the word "password" 
followed by a carriage return to the other computer, you would 
put the following line in your script: 

SEND npassword " , CR 

TERM <TERMINAL TYPE> 

This command instructs GeoComm to emulate the type of 
terminal specified. Valid terminal types are TTY, VT52, VTlOO, 
WYSESO, ANSI, IBM3101, and TVI1950. 

This command is the equivalent of specifying Select Terminal in 
the Terminal Options dialog box. For more information, see 
"Choosing the Terminal Settings" in this chapter. For example, to 
make GeoComm emulate a standard TTY terminal, you would 
put this command in your script: 

TERM TTY 



CHAPTER I 0 

Geo Banner GeoBanner provides an easy way to create banners 

for any occasion. The banner is printed on multi-page paper that 

you can hang over the window, on the wall, or across the door. 



You can print your banner using either a single-sheet feed or a 
continuous-feed printer (that is, the pages are connected by a 
perforation). However, because of their length, banners print best 
on continuous-feed paper. 

The GeoBanner application does not have user levels. 

This chapter explains how to do the following: 

• Create a banner. 

• Format the text of the banner by changing fonts and styles and 
by adding special effects and borders . 

• Print the banner. 

This chapter assumes you are familiar with the information 
covered in Chapter 1. Chapter 1 provides an overview of the 
skills you need to use any GEOS application. 

STARTING GEOBANNER 

<A/v The GeoBanner icon looks like the example at the left. 

Cieo8anner To start GeoBanner 

• Locate the GeoBanner icon and double-click it. For more 
information about starting GEOS applications, see Chapter 1. 

The GeoBanner window appears. 

Type your banner message in this box. 

Your message displays here as a banner. 

ample 
Use the scroll arrows to show 
different parts of your banner. 



When you start GeoBanner, a box appears above a display area 
in the GeoBanner window. You can type your banner message 
in the box and see the message instantly displayed as a banner in 
the display area. 

CREATING A BANNER 

GeoBanner cannot 
preview very long 
banners in their 
entirety. Tbese long 
banners will still 
print correctly, 
however. 

You can use GeoBanner to create a banner for a party, a holiday, 
or any special occasion. For example, you may want to design a 
simple birthday banner or an elaborate Welcome Home sign. 
This section describes how to create a simple banner with the 
default typeface (URW Roman). If you want to change the 
typeface or add special effects, see "Formatting a Banner" in this 
chapter. 

To create a banner 

• Enter the text for the banner in the Banner Message box. As you 
type in the box, the letters also display in the Sample Banner 
area. 

Here is a Happy Birthday banner. 

_J 

Most banners will not fit entirely in the window, like the example 
shown above. Click the scroll bar to view the rest of the message. 



If you do not want to make any formatting changes, the banner 
is ready to print. For more information about printing, see 
"Printing a Banner" in this chapter. 

FORMATTING A BANNER 

Font and style 
changes apply to the 
entire banner. 

You can select a variety of format options for your banner. For 
example, you can change the font, change the style, enclose the 
message within a border, or apply a special effect. 

To change the font 

A font is a typeface, the design of the individual alphabetic and 
numeric characters. Some fonts like URW Sans are very plain, 
while others are ornate, like Sather Gothic. Ensemble comes with 
several different fonts you can use for your banner. 

• Choose a new font from the Fonts menu. The font is applied to 
all text in the banner. The Sample Banner changes to show the 
new font. 

or 

Choose Font Viewer from the Fonts menu, and then select a font 
from the list. The font is applied to the sample letters and 
numbers at the bottom of the dialog box to give you a preview 
of how it looks. Click Apply to apply the font to all the text in 
the banner. The Sample Banner changes to show the new font. 
Click Close to exit the dialog box when you have selected a font 
that you like. 



To change the style 

When you change a style, you make the text boldface, italic, 
underlined, or any combination of the three. You can also 
change back to Plain Text, which removes all text styles. 

• Choose a new style from the Styles menu. The styles you select 
are applied to all text in the banner, and the Sample Banner 
changes to reflect the new style. Add any other styles that you 
want. 

To remove a style 

• Select the choice you want to remove. The check box changes 
from black to gray, and the style is removed. To remove all 
styles , choose Plain Text. 

To add a special effect 

You can use any one of the following special effects to give your 
text a shadow or a three-dimensional look: 

•Small Shadow adds a shadow that makes the letters appear to 
float over the page. 

•Large Shadow adds a shadow that makes the letters appear to 
float higher off the page. 

• Fog adds a soft, blurry shadow behind the letters. 

• 3D Effect adds a three-dimensional shadow behind the letters . 

•No Effect removes any special effect from the letters. 

• Choose a new effect from the Effects menu. The Sample Banner 
changes to show the new effect. 

To add a border 

When you add a border, you change the banner in the following 
ways: 

•Thin Border encloses the banner message in a thin box. 

• Wide Border encloses the banner message in a wider box. 

• Double Border encloses the banner message in two thin 
boxes. 

•No Border removes all borders from the banner message. 

• Choose a border from the Borders menu. The Sample Banner 
changes to show the new border. 



PRINTING A BANNER 

The banner that is displayed in the Sample Banner area shows 
exactly how it will appear when you print it. 

You can print your banner on any printer using either 
continuous-feed paper or single sheets of paper. If you are 
printing your banner on single sheets of paper, you will have to 
tape the sheets together. The number of pages you see on the 
screen may vary from the number of single pages actually 
printed. This is because some printers automatically apply a 
margin to each side of the printed page. 

To print a banner 

1. Choose Print from the File menu. The print dialog box appears. 

2 . Click Print. The banner prints . 

NOTE 

The printer always prints with low print-quality to keep your printer 
from overheating. 



CHAPTER 11 

Solitaire This version of Solitaire looks and plays the same as 

the game with real cards. With the this version of the game, 

however, the computer shuffles and deals the cards for you - 11 

you have to do is play the game! 



Solitaire has no user levels, but it does have three playing levels. 
For more information about the playing levels in this game, see 
"Setting the Playing Level" later in this chapter. For the rules of 
Solitaire, see any standard book on card games, or try playing 
Solitaire at the beginner level. 

STARTING SOLITAIRE 

Solitaire 

The Solitaire icon looks like the example at the left. 

To start Solitaire 

1 . Locate the Solitaire icon and double-click it. 

The Solitaire window appears: 

Click to see the next card. 

Your score shows here if you 
are playing a scoring game. 

Your elapsed time shows here if 
you are playing a timed game. 

2. To start the game, drag any card to a new location. 

or 

Click the deck to see a new card. 

For more information about starting an application, see 
Chapter 1. 



PLAYING THE GAME 

You drag cards to move them from stack to stack, and you click 
on face-down cards to flip them over. For more information 
about clicking and dragging, see Chapter 1. 

To start a new game 

You can re-deal the deck of cards at any time. When you re-deal, 
you start a new game. 

• Choose Re-Deal from the Game menu. 

To move a card to a new location 

• Drag the card to a new location. If you've made a legal move, the 
card appears in its new location. Otherwise it returns to its 
original location. 

SHORTCUT 

Double-click a card in one of the seven lower stacks to send it to o ne 
of the fou r upper stacks- that is, if it's a legal move. 

To flip a card 

• Click once on the card. If it's in one of the seven lower stacks, a 
single card flips . If you click the deck, either one, two, or three 
cards flip - depending how you set your options. 

To undo a mistake 

If you make a move and change your mind, you can move the 
card back. 

• Choose Undo from the Game menu. The card returns to its 
original location. 

Automatically Finishing a Game 

You win a Solitaire game when you have flipped over all of the 
face-down cards and you have played all of the cards in the 
deck. When this happens, the Auto Finish button changes from 
gray to black. At this point you can manually move all the cards 
into the upper four piles, or you can simply click the Auto Finish 
button - all of the cards in the lower stacks automatically move 
to the four upper stacks. 



SETTING THE PLAYING LEVEL 

Setting a playing level determines how much assistance you get 
as you play the game. You receive progressively less assistance as 
you move from the beginning level to the most advanced level. 

Solitaire has the following three playing levels: 

• Beginner level. This playing level guides you when you drag 
cards to a new location. If you click a card, possible locations 
for that card appear highlighted. You can move cards back from 
the four upper stacks to the seven lower stacks - something 
you can't do at higher levels. You can also move parts of a 
face-up stack to another stack. For example, if you have a 
sequence of six cards on a particular pile , you can move the 
last three face-up cards to a new location. 

• Intermediate level. At this level you don't get help with 
possible moves. Also you can't move cards back from the four 
upper stacks to the seven lower stacks, though you can still 
move parts of a face-up stack to another stack. 

• Advanced level. Standard Solitaire with no help and no 
cheating. 

To change the playing level 

• Choose Level of Play from the Options menu, and then select a 
level from the submenu. When you change the playing level 
during a game, you are asked if you want to start a new game. 

CHANGING THE SCORING 

Solitaire has the following scoring options: 

• Standard (Timed) and Standard (Untimed). In Standard 
(Timed), you lose points for the time you spend deciding 
where to move a card. In Standard (Untimed), you are not 
penalized for taking time to make decisions. Standard (Timed) 
and Standard (Untimed) games are scored as shown in the 
following table: 



I 1FYOU ... 

I Let ten seconds pass 

I 
Move a card to one of the 
four upper stacks 

I 
Flip a card in the lower 
stacks 

Move a card from the 
discard deck to one of the 
lower stacks 

I
-Start through the discard 
deck again (one-card draw) 

I 
Start through the discard 
deck again (two-card draw) 

Start through the discard 
deck again (three-card 
draw) 

r YOU GET ... 

I -1 point 

I + 10 points 

+5 points 

+5 points 

1

-30 the first two times; -60, -90, 
and so on, each time thereafter 

1

-20 the first three times; - 40, -60, 
and so on, each time thereafter 

-10 the first four times; -20, -30, 
and so on, each time thereafter 

•Vegas. In this scoring option, your game starts when you 
choose Re-Deal from the Game menu. You start each Vegas 
game already 52 points in the hole, and for each re-deal you 
lose another 52 points. For each card you successfully move to 
an upper stack, you receive five points . Points are cumulative 
from game to game. You are also limited to how many times 
you can go through the discard deck: only once with one-card 
draw; twice with two-card draw; and three times with three
card draw. 

• Countdown. In this scoring option, you play against the clock. 
Your goal is to score as many points as possible in seven 
minutes. You can change the allotted time using the Set 
Countdown Time option in the Options menu. For more 
information about changing your Solitaire options, see 
"Changing Other Options" later in this chapter. 

• No Scoring. In this scoring option, you simply play the game 
until you win or are ready to stop. You do not receive any 
points, nor are you penalized any points. In addition, elapsed 
time is not shown when you choose No Scoring. 

To change the scoring 

1. Choose Scoring from the Options menu. A submenu appears. 

2. Select a choice from the Scoring submenu. 



CHANGING THE NUMBER OF CARDS DRAWN 

You can draw either one, two, or three cards at a time from the 
deck. The choice you make affects your scoring if you are using 
Standard scoring, and affects how many times you can go 
through the deck if you are using Vegas scoring. For more 
information, see "Changing the Scoring" earlier in this chapter. 

To change the number of cards drawn 

1. Choose Draw How Many Cards? from the Options menu. A 
submenu appears. 

2 . Select a choice from the submenu. 

CHANGING OTHER OPTIONS 

In addition to choosing a playing level and a scoring method, 
you can also set other playing options. These options appear in 
the Options menu and are summarized in the following table: 

THIS OPTION ... r DOES THIS ... 

Change Card Backs Opens a dialog box where you can 
choose different artwork for the backs of 
the playing cards. 

Set Countdown Opens a dialog box that lets you specify 
Time the number of minutes and seconds 

allowed for Countdown scoring. 

Outline Dragging I Shows only the outline of the card as you 
drag it. 

Full Card Dragging Shows the full card as you drag it. 

Fade Cards Fades the cards as they are dealt. When 
you turn off Fade Cards, the cards appear 
immediately. If you are playing a timed 
game, you may want to leave this option 
off since it slows down the game. 

I 



APPENDIX A 

Changing your Preferences The Preferences 

application allows you to tailor your computer to meet your 

specific needs and likes. For example, if you like your mouse 

speed faster than it currently is, you can adjust the mouse 

acceleration speed by changing Mouse options. This chapter 

explains how to change various options on your computer so 

that each time you use Ensemble or any of the Ensemble 

applications, the options are automatically set. 



You can change the following options: 

• Computer 

• Video 

• International 

• Text 

• Mouse 

• Modem 

• Printer 

• Keyboard 

• Look and feel 

• Date and time 

• Sound 

• Background 

• Lights Out 

• GEOS internal options 

• Task Switching 

• Fonts 

STARTING PREFERENCES 

g 
Preferences 

The Preferences icon appears in the WORLD directory of 
GeoManager and looks like the example at the left. You can start 
Preferences either from GeoManager or from the Express menu 
that appears in all GEOS application windows. 

To start Preferences 

• Locate the Preferences icon and double-click it. 

or 

Choose Start an Application from the Express menu in any GEOS 
application. Then, from the ensuing submenu, choose 
Preferences. 



The Preferences window appears: 

For more information about starting GEOS applications and using 
the Express menu, see Chapter 1. 

CHANGING YOUR PREFERENCES 

This section shows you how to change each of the available 
options in the Preferences application. 

Changing the Computer Options 

Only advanced users should change the Computer options. Use 
the Computer options if you have additional memory or unusual 
port configurations. 

To change the computer options 

1. Open Preferences. 

2 . Click the Computer button. A dialog box appears: 



.....------ ~~ ge the ExtraMemory Type to make use~ of additionaiffiemory. 
ge the Interrupt Levels if your computer has unusual port 

figurations. 

3. Fill out the dialog box, changing the options as necessary. 

Select the check boxes at the top of the dialog box for each type 
of additional memory your computer contains. 

Serial Ports. Click the up and down arrows to change the 
interrupts for your serial ports , or turn them off. 

A question mark appears next to the interrupt number until 
Ensemble has verified that the port exists and that the interrupt is 
correct. 

Parallel Ports. Select the appropriate radio buttons to configure 
your parallel ports. 

4. Click OK when you are finished. A dialog box asks you to 
confirm restarting Ensemble so that changes can take effect. Click 
Yes to restart. 

or 

Click Reset to change all of the Computer options to their original 
settings. 

Changing the Video Options 

Use the Video options if you need to change how your video 
adapter is set up. Your video adapter is the type of graphic 
display your computer uses (for example, VGA, CGA, EGA, and 
so on). 

To change the type of video adapter 

1. Open Preferences. 



2. Click the Video button. A dialog box appears: 

Use these options to change the configuration of your-video 
adapter. 

""'""""'='"-=~,,,_ yype of video adapter:""'~ -==:--==, 

Current adapter: 
UGR: 640x480 16-color 

3. Click the Change button if the current adapter shown is incorrect. 

A dialog box appears with a list of available video types. 

4. Select a video type from the list, and then click OK. 

The Video dialog box reappears. 

5. Click OK when you are finished. A dialog box asks you to 
confirm restarting Ensemble so that changes can take effect. 

Click Yes to restart. 

or 

Click No, then click Reset to change the video adapter back to its 
original setting. 

6. If you chose to restart Ensemble, you will see a series of test 
screens to ensure that you have chosen the correct settings. If the 
display is jumbled, or stays blank for longer than two minutes, 
press FlO to return to the original video settings. 

Changing the International Options 

Use the International options if you want to change the standard 
formats for the currency, the numbers, the date , the quotation 
marks , and the time for a country other than the United States. 

To change the currency.format 

1. Open Preferences. 



2. Click the International button. A dialog box appears: 

Use these options to change your time and date display 
formats, currency and number formats, and other default 
characters. 

Choose fm·mat to edit 

Humber 
Quotation marks 
Long date 
Short date 

=~~===Examples:,.---==o:-:---::i 

-$13.22 

3. Select Currency from the list, and then click Edit. A dialog box 
appears: 

·--= -= -= -= -~ -= -= 

- Edit Cun-ency format: 

Symbol & ttegatiue Placement: -$199.00 ~1 
Space around symbol: $1or1$ ""I 

Symbol: w-:-
Leading zet·o: ~ 

Decimal Digits: ri ro ,, 

Example: -$13.22 
rr ~ ,~ . = ... ""''""'-

Cancel I 
= 

iJ ·= 

== ::::: :=::::::::,. = 

4. Fill out the dialog box, changing the following options as 
necessary: 

Symbol and Negative Placement. This option changes the 
placement of the currency symbol and negative sign. Click the 
button to the right of "Symbol & Negative Placement. " A drop
down list appears. Select a choice from the list. Your selection 
appears in the button, and the example at the bottom of the 
dialog box changes accordingly. 

Space Around Sy mbol. This option sets the distance between 
the symbol and the value. Click button to the right of "Space 
Around Symbol. " A drop down list appears. Select a choice from 
the list. Your selection appears in the button, and the example at 
the bottom of the dialog box changes accordingly. 

Symbol. This option sets a new currency symbol. Highlight the 
existing symbol and type in a new symbol. For a list of characters 
you can use and how to type them, see Appendix B. 



Leading Zero. This option adds a zero before the currency 
format. Click the button to the right of "Leading Zero. " A drop
. down list appears. Select a choice from the list. 

Decimal Digits. This option sets the standard number of decimal 
places. Click the up and down arrows to change the decimal 
digits. 

5. Click OK when you are finished changing the currency format. 

or 

Click Cancel to keep the original settings. 

The International dialog box reappears. 

6. Choose another format to edit. 

or 

Click Close. 

7. If you have changed any of the International options, a dialog 
box appears requesting you to restart Ensemble so that the 
changes can take effect immediately. 

Click Yes to restart Ensemble. 

or 

Click No to delay your changes until the next time you log in to 
Ensemble. 

To change the numbers format 

1. Open Preferences. 

2. Click the International button. A dialog box appears . 

3. Select Number from the list, and then click Edit. A dialog box 
appears: 

=-=-=- -= ..:.:.....:::::. -=- ..:.:...:: 

.'" ·"'"' ~ 

Edit Number format: 

1 000 separator: J, 
Decimal separaton r 
Decimal Digits: f2f-D 
Leading zer·o: ,l .99 :3 
List separaton r 
Measurement system: English .._., 

Example: 13,145.22 in 

t I J!klil Cancel I iJ 
::=:: :::.:·· :::::::= = = ~ = == 

4. Fill out the dialog box, changing the following options as 
necessary: 



1000 Separator. This option sets a character that is used to 
separate thousands (for example, the use of commas in 
1,000,000). Type a character in the box. 

Decitnal Separator. This option sets a character that is used as a 
decimal point. Type a character in the box. 

Decitnal Digits. This option changes the number of decimal 
places. Use the up and down arrows to change the decimal 
digits. 

Leading Zero. This option turns the leading zero on or off. Click 
the button to the right of "Leading Zero. " A drop-down list 
appears. Select a choice from the list. 

List Separator. This option sets the character that you see as the 
separator in a series of numbers (for example, the use of commas 
in "1, 2, 3") . Type a character to be used as the list separator. 

Measurement System. This option changes the measurement 
system to Metric or English. Click the button to the right of 
"Measurement System." A drop-down list appears . Select a choice 
from the list. 

5. Click OK when you are finished editing the numbers format. The 
International dialog box reappears. 

6. Choose another format to edit. 

or 

Click Close. 

7. If you have changed any of the International options, a dialog 
box appears requesting you to restart Ensemble so that the 
changes can take effect immediately. 

Click Yes to restart Ensemble. 

or 

Click o to delay your changes until the next time you log in to 
Ensemble. 

To change the quotation marks format 

1. Open Preferences. 

2. Click the International button. A dialog box appears. 



3. Select Quotation Marks from the list, and then click Edit. A dialog 
box appears: 

Edit Quotation marks format: 

First single quote: r 
Last single quote: EJ 

First double quote: " 

Last double quote: f1 
Example: '123' "456-

Cancel I ~ 

4. Fill out the dialog box, changing the following options as 
necessary: 

First Single Quote, Last Single Quote, First Double Quote, 
Last Double Quote. Each option sets the symbol you want to 
use for one of the four quote marks . Type the symbols you want 
in the appropriate boxes. 

5. Click OK when you are finished editing the format of quotation 
marks . The International dialog box reappears . 

6. Choose another format to edit. 

or 

Click Close. 

7. If you have changed any of the International options, a dialog 
box appears requesting you to restart Ensemble so that the 
changes can take effect immediately. 

Click Yes to restart Ensemble. 

or 

Click No to delay your changes until the next time you log in to 
Ensemble. 

To change the long date.format 

You can edit the long date format or the short date format. The 
long date format shows the day of the week, month, year, and 
date . The short date format shows only the month, day, and year. 

1. Open Preferences. 

2 . Click the International button. A dialog box appears. 



3. Select Long Date from the list, and then click Edit. A dialog box 
appears: 

~ I 

4. Fill out the dialog box, changing the Format Elements options as 
necessary. With each option, click the button for the item you 
want to change. A drop down list appears. Select the desired 
format from the list. 

5. In each of the separator boxes, type a character you want to 
appear as the separator between the elements (for example, the 
use of slashes in Mon/ 01/ 01/ 93). 

6. Click OK when you are finished editing the long date format. 
The International dialog box reappears. 

7. Choose another format to edit. 

or 

Click Close. 

8. If you have changed any of the International options, a dialog 
box appears requesting you to restart Ensemble so that the 
changes can take effect immediately. 

Click Yes to restart Ensemble. 

or 

Click o to delay your changes until the next time you start 
Ensemble. 

To edit the short date format 

1. Open Preferences. 

2. Click the International button. A dialog box appears. 

3. Select Short Date from the list, and then click Edit. A dialog box 
appears: 

Edit Short date for:mat~ 

.-.1 
Example: 3/9/94 



4. Fill out the dialog box, changing the Format Elements options as 
necessary. With each option, click the button for the item you 
want to change. A drop down list appears. Select the desired 
format from the list. 

5. In each of the separator boxes , type a character you want to 
appear as the separator between the elements (for example, the 
use of slashes in 01/ 01/ 93). 

6. Click OK when you are finished editing the short date format. 
The International dialog box reappears . 

7. Choose another format to edit. 

or 

Click Close. 

8. If you have changed any of the International options, a dialog 
box appears requesting you to restart Ensemble so that the 
changes can take effect immediately. 

Click Yes to restart Ensemble. 

or 

Click No to delay your changes until the next time you log in to 
Ensemble. 

To edit the time format 

1. Open Preferences. 

2. Click the International button. A dialog box appears. 

3. Select Time from the list, and then click Edit. A dialog box 
appears: 

4. Fill out the dialog box, changing the Format Elements options as 
necessa1y. With each option, click the button for the item you 
want to change. A drop down list appears. Select the desired 
format from the list. 

5. In each of the separator boxes, type a character you want to 
appear as the separator between the hours, minutes, and seconds 
(for example, the use of colons in 12:35:30). 



6. Click OK when you are finished editing the time format. The 
International dialog box reappears. 

7. Choose another format to edit. 

or 

Click Close. 

8. If you have changed any of the International options, a dialog 
box appears requesting you to restart Ensemble so that the 
changes can take effect immediately. 

Click Yes to restart Ensemble. 

or 

Click o to delay your changes until the next time you log in to 
Ensemble. 

Changing the Text Options 

se the Text options if you want to change spell-checking 
options, edit the user dictionary, or choose a new main 
dictiona1y. You can also turn smart quotes on or off in this dialog 
box. Unless you specify otherwise, Ensemble applications use 
straight quotation marks (11 

" or ' '). When you turn smart quotes 
on, typographer's quotation marks appear(" " or ' ').Any 
quotation marks you have already typed with smart quotes off do 
not change when you turn this option on. 

To change smart quotes and spell-checking options 

1. Open Preferences. 

2. Click the Text button. A dialog box appears: 

Change these options to configure 
the system-wide text functions like 
Spell Checking. 

Smar·t Quotes: On + Off 

r.:----==-----,;--:;;-----SpeU Checker Options---------.i 

Automatically Suggest Spellings: 

Automatically Start Checking Selected Text: 

v Yes ~Ho 

+ Yes Ho 

Reset Skipped Words List when SpeU Check Complete: + Yes ,7 Ho 

3. Fill out the dialog box, changing the following options as 
necessary: 



Smart Quotes. This option turns on typographer's quote marks 
for text. Click the radio buttons to turn smart quotes on or off. 

Automatically Suggest Spellings. Clicking Yes for this option 
lets the Spelling Checker suggest corrections for spelling errors. 

Automatically Start Checking Selected Text. Clicking Yes for 
this option lets the Spelling Checker automatically start checking 
text you have selected. 

Reset Skipped Words List When Spell Check Complete. 
Clicking Yes for this option lets the Spelling Checker skip all 
occurrences of misspelled words for one spell-checking 
operation. You must also click Skip All in the Ensemble Spelling 
Checker in order for this option to work. 

4. Click OK when you are finished changing smart quotes or spell
checking options. 

or 

Click Reset to change smart quotes or spell-checking options to 
their original settings. 

To edit your user dictionary 

Your user dictionary is a dictionary that contains words you add 
to it. These words typically do not appear in the main dictionary 
for the Spelling Checker; rather, you add them to a special 
dictionary to expedite spell-checking. 

1. Open Preferences. 

2. Click the Text button. A dialog box appears. 

3. Click the Edit User Dictionary button. A dialog box appears: 

4. To add a new word, type the new word in the box, and then 
click Add New Word. 

or 



To remove a word from your user dictiona1y, select the word 
from the list , and then click Delete Selected Word. 

5. Click Close when you are finished editing your user dictiona1y. 
The Text dialog box reappears. 

6. Click OK when you are finished. 

or 

Click Reset to change your user dictiona1y to its original entries. 

To choose another main dictionary 

1. Open Preferences. 

2. Click the Text button. A dialog box appears. 

3. Click the Choose New Main Dictionary button. A dialog box 
appears: 

Select new dictionan1: 
· ·ffie.Fican E"il 1isti ······ · ··· ·· ···· · · ·· · ·· 

BFitish - ise English 
BFitish -ize English 

English with standaFd AmeFicen speHings (e.g. 
""behauioF"", ""centeF"", end ""oFganize""). 

4. Select a new dictiona1y from the list. 

5. Click Use This Dictionary. The Text dialog box reappears. 

6. Click OK when you are finished. A dialog box asks you to 
confirm restarting Ensemble so that changes can take effect. 

Click Yes to restart. 

or 

Click No, then click Reset to change the dictionary name back to 
its original setting. 

C hanging the Mouse Options 

Use Mouse options if you want to change your mouse 
acceleration or the double-click time. In addition, you can 
change the type of mouse you have. 

Mouse acceleration determines how far the mouse pointer moves 
when you quickly move your mouse. The double-click time 



determines how fast you need to double-click to initiate an 
action. 

To change double-click time and mouse acceleration 

1. Open Preferences. 

2. Click Mouse. A dialog box appears: 

House 

3. Fill out the dialog box, changing the options as necessary. 

Double Click Time. This option lets you select the double-dick 
time interval you want. Once you select one of the radio buttons, 
you can test how fast or slow you need to double-click with the 
Double Click Test button. When you double-dick the button at 
the correct speed, the button flashes and your computer beeps. 

Mouse Acceleration. This option lets you select the mouse 
acceleration speed you want. A slow setting moves the pointer 
the same distance as the mouse. With a fast setting, the mouse 
pointer moves further when you quickly move your mouse. 

4. Click OK when you are finished. 

or 

Click Reset to change the mouse acceleration and double-dick 
options to their original settings. 

To change the type qf mouse 

If you are not sure what type of mouse you are using, check the 
documentation you received with your mouse. 

1. Open Preferences. 

2. Click Mouse. A dialog box appears. 

A 11!" 



3. Click the Change button if the type of mouse currently shown is 
incorrect. A dialog box appears: 

Change 

=-~-=--='="~~-Mouse•~-=~-=-"'==~~~ 

Kraft Serial Mouse (Microsoft Mode} 
Laser 3-button (Microsoft Mode} 
Laser 3-button Serie! (Mouse Systems Mode} 
Logitech 2-button Serial 

4. Fill out the dialog box, changing the following options as 
necessary: 

Mouse. Select a mouse from the list. 

Serial Mouse Port. Select a serial mouse port for your mouse 
when one is required. This option is dimmed if it does not apply 
to the kind of mouse you have selected. 

Interrupt Level. Click the up and down arrows to set an 
interrupt level. If the Interrupt Level box is dimmed, you are 
using a mouse that does not require you to specify an interrupt 
level. 

5. Click OK. The Mouse dialog box reappears. 

6. Click OK when you are finished. A dialog box asks you to 
confirm restarting Ensemble so that changes can take effect. 

Click Yes to restart. 

or 

Click No, then click Reset to change the type of mouse back to 
the original setting. 

7. If you chose to restart Ensemble, you will see a test screen to 
ensure that you have chosen the correct settings. If your mouse 
does not appear to function, press FlO to return to the original 
mouse settings. 

Changing the Modem Options 

Use the Modem options if you want to change your modem 
settings. You can change the serial port of your modem, the dial 
type (touch-tone or pulse), and the speed and format options 
(baud rate, parity, stop bits, and so on). For more information 
about baud rate, parity, and so on, refer to your modem manual. 



Before you can use your modem, you need to be sure to identify 
the communication port and port speed. Refer to your modem 
manual for more information. 

To change the modem serial port and dialing method 

1. Open Preferences. 

2. Click the Modem button. A dialog box appears: 

Modem 

· ... ·fOM 4 

3. Fill out the dialog box, changing the following options as 
necessa1y. 

Serial Port. Click to select a new serial port for your modem. 

Dial Type. Click the appropriate dial type (tone or pulse). 

4. Click OK when you are finished. 

or 

Click Reset to change the serial port and dial type to their original 
settings. 

To change the modem speed and format options 

1. Open Preferences. 

2 . Click the Modem button. A dialog box appears. 

3. Click Speed and Format Options. A dialog box appears: 

- ; ., 

300 v· 600 v 1200 2400 v 4800 v· 9600 + 19~0j 
Mark ,,. Hone 

2 

Handshake: Hone .:.J Hardware • Software (XOH/XOFF) 

fo\~ 'dHUlr(~ H(mdsh~~l<il'lj'} Opti~mt\( 

~:Hnp RmHote: ,..; nm .. .J fH~:I 
. ..iHSR 



4. Fill out the dialog box, changing the following options as 
necessary: 

Baud rate. The baud rate is the speed at which data is 
transmitted between your computer and the remote system. Click 
the radio button for the correct speed. 

Parity. The parity setting is used for error-checking during 
transmission. Click the radio button for the correct parity setting. 

Word Length. The word length determines the number of bits 
used to convey each character transmitted. Click the radio button 
for the correct length. (The term data bits is sometimes used to 
refer to the word length.) 

Stop Bits. The stop bits are used to indicate the end of each 
character as it is transmitted. Click the radio button for the correct 
number. 

Handshake. When handshaking is enabled, Ensemble 
communications software such as GeoComm can control the flow 
of information in and out of the computer. Click to select the 
option appropriate to your modem. 

When hardware handshaking is enabled, you can set the 
following options: 

Stop Remote. This option lets you select the appropriate method 
to start data flowing out of your computer. 

Stop Local. This option lets you select the appropriate method to 
start data flowing into your computer. 

5. Click OK. 

or 

Click Reset to change all of the format and speed options to their 
original settings. 

The Modem dialog box reappears. 

6. Click OK when you are finished making changes. 

or 

Click Reset to change all modem options to their original settings. 

Changing the Printer Options 

Use the Printer options if you want to install a different printer or 
make changes to the current printer options. You can also test 
your connected printers. 

You can set up a printer to format your text in the way that best 
meets your printing needs. This is especially convenient if you 



lf you type a letter, 
the Printer list 
immediately scrolls 
to the first printer 
name that begins 
with the letter. 

print envelopes and labels, or use a number of different paper 
sizes. 

To add a new printer 

1. Open Preferences. 

2 . Click the Printer button. A dialog box appears, listing all the 
possible types of printers you can use: 

Use these options to install, configur·e, and test your 
printer (or printers). 

Printers Installed: 

Canon LBP-8 Merk Ill (PostScr·ipt) on LPT3 
HP Leser Jet HP on LPT3 

Def eult Printer: 
HP Laser Jet HP on LPT3 

3. Click New to add a new printer. A dialog box appears: 

Type of Device + Printer · ... · PloHm' ... · fm<. · .... Cmrn~ra .... · iHh\~l 

11 · •1 I 

Adobe LJ II Cart w/Type Cart 1 (Posts cript) 
Adobe LJ II Cart w/Type Cart 2 (Postscript) 
REG Olympia HP 136-24 (Epson Mode) 
REG Oly l!i P 136-2 4 (IBM Mode} 

Printer Harne: 

Port: 

PT1 (parallel) 

4. Fill out the dialog box, changing the following options as 
necessary. 

Type o f Device. In Ensemble, this option is always set to Printer, 
and cannot be changed. 

Printer. Select the type of printer you are adding. The selected 
printer appears in the Printer Name box. 

Port. Select a port for the new device , if necessary. 

5. Click OK. The Printer dialog box reappears. 

or 

Click Reset to change back to the original printer and port. 



6. Click Close when you are finished adding a new printer. 

To change the settings for an installed printer 

After you install a printer, you can change the type of device, the 
port the printer is connected to, and the printer name. 

1. Open Preferences. 

2 . Click the Printer button. A dialog box appears. 

3. Select the printer name you want to change from the Printers 
Installed list. 

4. Click Edit. A dialog box appears. This dialog box is identical to 
the dialog box you see when you install a new printer. 

5. From the Printer list, select the name of the printer you are 
changing. The selected printer appears in the Printer Name box. 

6. Select a new port from the list, if necessary. 

7 . Click OK. The Printer dialog box reappears. 

or 

Click Reset to change back to the original printer and port. 

8. Click Close when you are finished changing an installed printer. 

To delete an installed printer 

1. Open Preferences. 

2. Click the Printer button. A dialog box appears. 

3. Select from the Printers Installed list the printer name you want to 
delete. 

4. Click Delete. The printer is removed from the list of installed 
printers. 

5. Click Close when you are finished deleting an installed printer. 

WARNING 

Use the delete button with extreme care. When you click the Delete 
button to delete a printer, the printer is immediately removed from 
the list without any confirmation from you. 

To test a currently installed printer 

1. Open Preferences. 

2. Click the Printer button. A dialog box appears. 

3. Select from the Printers Installed list the printer name you want to 
test. 



Ibe Width and 
Height settings are 
exchanged when 
you choose a 
landscape Paper 
Layout. 

4. Click Test. The selected printer should begin printing the test 
page. 

5. Click Close when you are finished testing a printer. 

To change the def a ult paper size 

Default sizes include the type of paper you are printing to, the 
size of the paper, the paper layout, and the margins of the paper. 

1. Open Preferences. 

2. Click the Printer button. A dialog box appears. 

3. Click Default Sizes. A dialog box appears: 

Size: S Letter 

4. Fill out the dialog box, changing the following options as 
necessary: 

5. 

6. 

Type. This option lets you select whether you are printing to 
paper, or envelope. 

Size. This option is a list of paper sizes. Select the appropriate 
size from the list. 

Paper Layout. This option lets you select the orientation of the 
paper. 

Width. This option lets you set the width of the pa per. Type the 
width in the box. 

Height. This option lets you set the height of the paper. Type 
the height in the box. 

Margins. These options let you set margins for the paper. Type 
the left, right , top , and bottom margins in the appropriate margin 
boxes. 

Click OK. The Printer dialog box reappears. 

Click Close when you are finished changing default paper sizes. 



To change the serial port options 

You can change the serial port options only if you specify a COM 
port as the printer port. 

1. Open Preferences. 

2. Click the Printer button. A dialog box appears. 

3. Click Edit. A dialog box appears. 

4. Select a COM port printer. 

5. Select a COM port. 

6. Click Serial Port Options. A dialog box appears: 

Port Options For: IBM 4019 (39 Fonts) (Postscript) u52.1 on COM2 

Baud Rate: v 300 v 600 ,7 1200 v 2400 'V" 4800 v 9600 + 19200 

Parity: + Euen v Odd Space v Mark Hone 

Word Length: / 5 v 6 +.7 v- 8 

Stop Bits: + 1 "·" i S 2 

Handshake: Hone Hardware ,Ii Software (XOtf/XOFF) 

!hffdmm·,_~ H•.,..idslwl<:ln9 O!>hmmi 

!:!hw Remote, 

7. Fill out the dialog box, changing the following options as 
necessary: 

Baud rate. The baud rate is the speed at which data is 
transmitted between your computer and the remote system. Click 
the radio button for the correct speed. 

Parity. The parity setting is used for error-checking during 
transmission. Click the radio button for the correct parity setting. 

Word Length. The word length determines the number of bits 
used to convey each character transmitted. Click the radio button 
for the correct length. (The term data bits is sometimes used to 
refer to the word length.) 

Stop Bits. The stop bits are used to indicate the end of each 
character as it is transmitted. Click the radio button for the correct 
number. 

Handshake. When handshaking is enabled, Ensemble can 
control the flow of information in and out of the computer. Click 
to select the option appropriate to your modem. 

When hardware handshaking is enabled, you can set the 
following options: 



Stop Remote. This option lets you select the appropriate method 
to start data flowing out of your computer. 

Stop Local. This option lets you select the appropriate method to 
start data flowing into your computer. 

8. Click OK. 

or 

Click Reset to change all of the options to their original settings. 

The Printer dialog box reappears. 

9. Click OK when you are finished making changes. 

or 

Click Reset to change all printer options to their original settings. 

Changing the Keyboard Options 

Use the Keyboard options to change the keyboard delay, 
keyboard repeat rate, and the type of keyboard you are using. 
Keyboard delay specifies the amount of time you can hold down 
a key before another letter appears on your screen. Keyboard 
repeat rate defines how fast a character (or space) is repeated 
while you hold down a key. 

To change the Keyboard options 

1. Open Preferences. 

2 Click the Keyboard button. A dialog box appears: 

Keyboard 

~Use-these options to choo se yoor desired ke yboar·dmapping and set 
the keyboard sensitiuity. 

~----Key Options----~, 

[J Right Alt key functions like Ctrl+Alt 

3. Fill out the dialog box, changing the following options as 
necessary: 



Keyboard Delay. This option sets the amount of time you can 
hold down a key before another character appears. Select the 
keyboard delay you want. 

Keyboard Repeat Rate. This option sets how fast a character or 
space is repeated while you hold down a key. Select the repeat 
rate you want. 

Key Options. These options redefine various key combinations. 
Select check boxes for any key options you want. 

Keyboard. This is a list of various keyboards. Use the scroll 
arrows to see additional keyboard names, and then click to select 
a new keyboard. 

4. Click OK when you are finished. If you have changed the kind of 
keyboard, a dialog box asks you to confirm restarting Ensemble 
so that changes can take effect. 

Click Yes to restart. 

or 

Click No, then click Reset to change the keyboard options back 
to its original setting. 

Changing the Look & Feel Options 

Use the Look & Feel options if you want to change the size of 
your system text. You can also use the Look & Feel options to 
safeguard your document, and to set the typeover mode. 

To change the system text size 

System text is the text you see in menus, menu bars, window title 
bars, and dialog boxes. 

1. Open Preferences. 

2. Click the Look & Feel button. A dialog box appears: 

l lri":::::miiiiim:i; The Font Size determines the slzeof text in menus and 
dialog boxes. Document Safeguarding controls how 

·~~~~ frequently applications back up your document. 



3. Select a font size for your system text. 

4. Click OK when you are finished. A dialog box asks you to 
confirm restarting Ensemble so that changes can take effect 
immediately. 

Click Yes to restart. 

or 

Click No, then click Reset to change the system text size back to 
its original setting. 

To safeguard documents 

When you safeguard documents by turning on the Safeguard 
option, temporary copies of documents are saved. A power surge 
could cause you to lose the document you are working with. 
Safeguarding keeps a copy of your document so that when you 
restart the computer, the last-saved safeguarded copy appears. 

1. Open Preferences. 

2. Click the Look & Feel button. A dialog box appears. 

3. Click the On button to turn the safeguarding option on. 

4. In the Time box, type the number or minutes between each 
safeguard backup. The number of minutes you enter determines 
how often your documents are saved. 

5. Click OK when you are finished. 

or 

Click Reset to change the safeguarding options to their original 
settings. 

To change the typeover mode 

Typeover mode determines whether or not you are able to toggle 
between typeover mode and insert modes while working in 
Ensemble. Use the Insert key to toggle between the two modes. 

1. Open Preferences. 

2. Click the Look & Feel button. A dialog box appears. 

3. Click Via Insert Key to allow for toggling of typeover and insert 
modes. 

or 

Click Always Disabled to use insert mode all of the time. 

4. Click OK when you are finished. 

or 

Click Reset to change the typeover option to its original setting. 



Changing the Date and Time Options 

Use the Date & Time options if you want to change the date and 
time that you currently see on your computer. If you have 
changed the date and time format in International options, you 
must enter your new date and time in the correct format. 

To change the date and time of your computer 

1 . Open Preferences. 

2. Click the Date & Time button. A dialog box appears, showing 
today's time and date: 

~ 
l~~I 
Date & Time 

Change these options to sef your 
computer's built-in clock. 

3. Fill out the dialog box, changing the following options as 
necessary: 

Date. This option sets the date for the built-in clock on your 
computer. Type the date in the box. 

Time. This option sets the time for the built-in clock on your 
computer. Type the time in the box. 

4. Click OK when you are finished. 

or 

Click Reset to change the date and time to the original settings. 

Changing the Sound Option 

Use the Sound option if you want to hear sounds for various 
errors and alarms in Ensemble applications and in Ensemble. 

To change the sound option 

1. Open Preferences. 



2. Click the Sound button. A dialog box appears: 

The sounds produced by applications for errot·s, alarms, and other 
r·easons can be turned on and off. 

3. Click On to turn on sound for various errors and alarms in 
Ensemble applications and in Ensemble. 

or 

Click Off to turn off sound in Ensemble applications and in 
Ensemble. 

4. Click OK when you are finished. 

Changing Ensemble's Background 

You can fill the background - the gray area behind all the 
windows - with a picture. Ensemble comes with several 
different background pictures , or you can create your own. 

To change the workspace background 

1. In the Preferences window, click Background. The Background 
dialog box appears: 

Choose a new backgrou nd from the list beiOw. 
Click OK to see the new background. 

2. Select the name of the background picture that you want from 
the Backgrounds Available list. 

3. Select the way you want to place the background on the screen: 

Place graphic in upper-left of screen. The left edge of the 
picture is placed against the upper left edge of the screen. 



Place graphic in center of screen. The picture is centered on 
the screen. If it is smaller than the screen, then the surrounding 
area is filled with the regular solid background. 

Tile graphic to fill screen. The picture is repeated across and 
down the screen, covering the entire screen the way tiles cover a 
wall. 

4. Click Apply to make the current picture your workspace 
background. The background immediately changes. (To see the 
results, it helps to first minimize all the application windows, 
including GeoManager.) 

5. If you don't like the background picture, choose another and 
click Apply. 

6. Click Close when you finish . 

ADDING COLOR TO BACKGROUND IMAGES 

You can add some color to your black-and-white background 
images by clicking one of the color squares. 

To change the color of your background 

1. In the Preferences window, click Background. The Background 
dialog box appears . 

2. Click one of the Background Color buttons to select the desired 
color for the background. This option will not appear if you have 
a black and white monitor. 

3. Click Apply. The background changes color. 

This setting only affects black-and-white background images (or 
the standard solid background). The color black is replaced with 
the chosen color, giving you, for example, a red-and-white 
image. Or a blue-and-white image. 

CREATING A BACKGROUND IN GEODRA W 

Anything that you can create in GeoDraw can become a 
background image. 

To create a background picture using GeoDraw 

1. Create a picture in GeoDraw. 

2. Select all of the objects in the picture. You can drag to select the 
objects, or hold down the Control key and select them 
individually, or - easiest of all - choose Select All from the Edit 
menu. 



3. Choose Copy from the Edit menu. This copies the picture to the 
clipboard. 

4. Switch to Preferences and click Background. The Background 
dialog box appears. 

5. Click Get Background From Clipboard. A dialog box appears 
asking you to enter a file name. 

6. Enter a name and click OK. This copies the picture from the 
clipboard to the new file , and also immediately displays it as the 
background. The file name appears in the Backgrounds Available 
list, so you can select this picture again at a later date . 

Changing Screen Saver Options 

Lights Out saves your monitor from a condition called screen 
burn-in. If you leave the same picture on your screen long 
enough, it will eventually burn in to the surface of your screen. 
A burnt-in image on a screen never goes away, even when your 
monitor is off. This is where Lights Out comes in. Leave your 
computer idle for a while and Lights Out changes the picture on 
your screen before it becomes permanent. 

Lights Out comes with a variety of colorful, and sometimes 
comical, screen savers to make the whole process a little more 
interesting. Of course, your screen gets its best protection when 
you use the Blank screen saver - which simply blacks out your 
screen. 

You can also choose to lock your screen against uninvited guests 
using the password protection feature . 

To turn on automatic screen saving 

1. Open Preferences. 

2. Click the Lights Out button. A dialog box appears: 



Select the way you want your screen saved. 

Lights Out 

~cr·een Seven Default Screen Blenker 
Blank 
Bobbin 
Circles 

ribble 

Off 

3. Change the options in the dialog box as necessary: 

Screen Saving. Click the On button to turn on screen saving. 
This enables both automatic screen saving (where the screen 
saver starts after you leave your computer idle), and manual 
screen saving (where you start the screen saver yourself). Click 
the off button to turn off the screen saver. 

Time (minutes). Using the arrow buttons to change the time in 
minutes. Lights Out will wait this long to blank your screen after 
the last keystroke or mouse movement. 

Screen Savers. Click to select one of the screen savers in the 
Screen Saver list. If the screen saver has its own options, a button 
appears with the name of the screen saver on it. Click the button 
if you want to change any of the options for that screen saver. 

4. Click OK The Lights Out dialog box closes. Now, when you 
leave your computer unused for a while, Lights Out will 
au tomatically start the screen saver. 

To stop the screen saver, and return to your work, move the 
mouse , press a mouse button, or press a key on the keyboard. 

To manually start a screen saver 

1. Tum on automatic screen saving as described above. 

2. Choose Screen Saver from the Express menu. The screen saver 
starts after a couple of seconds. 

To stop the screen saver, and return to your work, move the 
mouse, press a mouse button, or press a key on the keyboard. 

CHANGING THE GENERAL OPTIONS 

If you have a sensitive mouse-one that responds to the slightest 
movement - your screen may spontaneously "wake up" 



(unblank) with every imperceptible movement of your desk. You 
can avoid this problem by telling Lights Out to not wake up 
when the mouse is moved, but to wake up only if a key is 
pressed or a mouse button is pressed. 

To change the general options 

1. Open Preferences. 

2. Click the Lights Out button. The Lights Out dialog box appears. 

3. Click the General Options button. The General Options dialog 
box appears: 

-=-
•i.• • I 

" F 

~ Wakeup Options = 

i 
• Wa!fe on key pr·esse 
• Wake on mouse mo~ement 
• Wake on mouse !;tutton presses 

Miscellaneous Options - . ...,,,,,.-

R_educe priority when saving screen 

I 
_J Disable blanking when mouse is in lower right corner ; 

Consume key m-esses when unblanking 

,2!<J .E~~ Cancel I 
-=-

4. Change the wake-up choices to your liking: 

Wake on key presses. The screen saver stops if you press a key 
on the keyboard. 

Wake on mouse movemen t. The screen saver stops if you 
move the mouse. 

Wake on mouse button presses. The screen saver stops if you 
press a mouse button. 

As an example, to solve the sensitive mouse problem, you would 
click to turn off the Wake on Mouse Movement button, but leave 
the other two on. If you turn all three off, you can still unblank 
the screen by pressing a key on the keyboard. 

5. Change the Miscellaneous Options to your liking: 

Reduce priority when saving screen. The Lights Out screen 
savers can slow down your printing, especially if you're doing 
high-quality printing. When this option is on, the screen saver 
takes a back seat to the printing job - the animation will be a 
little clunkier, but you'll have your printed document much 
faster. 

Disable blanking when mouse is in lower right corner. If 
you're just looking at information on the screen (and you don't 
want Lights Out to interrupt you) you may want to temporarily 



disable screen saving. When this option is on, you can do this by 
placing the pointer in the lower-right corner of the screen. (If the 
pointer is anywhere else on the screen, Lights Out will blank 
your screen as usual.) 

Consume key presses when unblanking. If you 're apt to press 
the Enter key or spacebar to unblank the screen, you will 
probably want this option on. When on, the keypress that 
unblanks your screen is ignored, except one purpose: 
unblanking the screen. Otherwise, you may unexpectedly 
activate a button, type a character into your document. 

6. Click OK. 

7. Click OK in the Lights Out dialog box. 

USING PASSWORD PROTECTION 

Lights Out can also protect your computer by "locking out" 
uninvited guests. When your screen is locked, Lights Out waits 
for you to enter the correct password (which you define earlier) 
before it unblanks the screen. If you want Lights Out to always 
lock your screen whenever it kicks in , click the Automatic button 
in the Password Options dialog box. Othe1wise the screen will 
lock only if you choose Security Lock from the Express menu . 

To set the password 

1. Open Preferences. 

2. Click the Lights Out button. The Lights Out dialog box appears. 

3. Click the Password Options button. The Password Options dialog 
box appears: 

!;_onfi,-m: le==== 
v 8,utomatic (eue,-y time sc,-een is saued) 
• ttanual (must use Security Lock button) 

4. Enter your password in the Password field. You won't see your 
password as you type it - you 'll only see asterisks (this prevents 
someone from reading your password over your shoulder) so 
type carefully. Enter your password again, but this time in the 
Confirm Entiy field. Again, type carefully. 

5. Click OK. 



6. Click OK in the Lights Out dialog box. The Lights Out dialog box 
closes. 

NOTE 

If the Security Lock choice does not appear in the Express menu, your 
password and its confirmation did not match exactly. Try setting your 
password again. 

To enable automatic password protection 

• In the Password Options dialog box, click the Automatic button. 

To manually lock the screen. 

• Click the Lock Screen button in the Lights Out window. This 
saves the screen the same way clicking "Save Screen" does, 
except for one important difference: You have to use your 
password to unlock the screen (see "To unlock a locked screen," 
next). 

To unlock a locked screen. 

• Move the mouse or hit a key. A smaller rendition of the screen 
saver appears, along with a place for you to enter a password. 
Enter your password and then press Enter. You will be returned 
to your regular screen. 

Changing Font Options 

The Font Options allows you to change what fonts appear in 
your application menus and Font drop-down lists . Unless you 
add fonts to your system, or you want to change your font 
menus , you should never need to use this Preferences module. 

You can change the font menus and lists for all applications, or 
individual applications. When you start an application, Ensemble 
first checks to see if you have made changes to the font menu for 
that application. If so, it uses those settings . If not, it checks to 
see if you have made changes to the system-wide font menus. If 
you have done neither, it uses the original default settings - the 
settings of the new product. 

NOTE 

Changes you make with the Fonts module only affect applications 
when they start. If you have applications open when you make 

changes, you w ill need to restart those applications to see any font 

changes take effect. 



To add a f ant to the font menu or drop-down list for all 
applications 

1. Open Preferences. 

2. Click the Fonts button. The Fonts dialog box appears: 

...------,.-- Configm-e the font lists on the Tool Bar and the Font menu of your 
applications. Drag and drop the name of a font with the right mouse 
button. 

Configure font menus for: System Default. 

On Tool Bar: Ruailable Fonts: 

Aero Extended 
Alfredo Heauy 
Army 
Art Nouueau 

! Aubade 
'~·· 1 Aubade Condensed 
~ Callalily 

Canterbur y 
Cartoon 
Cooperstown 

-~'.'!.:.~.'.:.!·:onu AaBbCc 123 

~ Choose Application ... I 

On Font Menu: 

3. Click to select the font you want add in the Available Fonts list. 

4. Click the right arrow button to add the font on the On Font 
Menu list or click the left arrow button to add the font to the On 
Tool Bar list. The font appears in the appropriate list. 

5. Click OK. The font will appear in the menus or tool bar lists for 
all applications. 

To add a font to the font menu or drop-down list for a specific 
application 

1. Open Preferences. 

2. Click the Fonts button. The Fonts dialog box appears. 

3. Click the Choose Application button. A dialog box appears: 

4. Click to deselect (turn ofD the System Default check box. The file 
selector on the right side of the dialog box lights up. 



5. Use the file selector to find and select the application you want 
to change. 

6. Click OK. The dialog box disappears. In the Font dialog box, the 
name after the words "Configure font menus for: " changes to the 
name of the application that you selected. 

7. Click to select the font you want add in the Available Fonts list. 

8. Click the right arrow button to add the font on the On Font 
Menu list or click the left arrow button to add the font to the On 
Tool Bar list. The font appears in the appropriate list. 

9. Click OK. The font will appear in the menus or tool bar lists for 
the you selected. 

To remove a font the font menu or drop-down list 

1. Open Preferences. 

2 . Click the Fonts button. The Fonts dialog box appears: 

3. Click the Choose Application button. A dialog box appears. 

4. To remove the font from the menus or lists for all applications, 
click to Select (turn on) the System Default check box. To 
remove the font from the lists for a specific application, turn off 
the System Default button and choose the application you want 
to change from the file selector. 

5. Click OK. The dialog box disappears. 

6. Click to select the font you want to remove in the On Font Menu 
list or the On Tool Bar list. 

7. Click the Remove Font button below the list. The font is removed 
from the list. 

8. Click OK. The font is removed from the font menus or tool bar 
lists. 

To rearrange the order of fonts on a font menu or drop-down list 

1. Open Preferences. 

2 . Click the Fonts button. The Fonts dialog box appears . 

3. Using the right mouse button, drag a font in the list from its old 
location to a new location in the list. The font name appears in 
its new location. 

4. Click OK. 



To reset your font menus or drop-down lists to their original state 

• Remove all the fonts in the On Font Menu list. You can do this 
for either a single application or for all applications by following 
the appropriate procedures above. 

Changing Internal Options 

The GEOS button lets you change internal options. You should 
not change any Ensemble internal options unless directed to do 
so by an authorized GeoWorks customer service technician. 
Incorrectly changing any of these options can seriously degrade 
the performance of Ensemble. 



APPENDIX B 

Special Characters With GEOS applications, you can use many 

special characters that you won't find on an average typewriter -

or on your keyboard, for that matter. 



You can use the following types of special characters: 

• Foreign language characters 

• Foreign-language accents 

• Typographical symbols 

• Punctuation marks 

• Currency and numeric symbols 

• Mathematical symbols 

This appendix includes a table for each type of special character. 
The tables show how to type all the available special characters. 

To type a character shown on this list 

• Find the character you want in one of the tables, and then press 
the key combination shown in the column labeled "Keys." 

In the "Keys" column, a plus sign ( +) means hold down the first 
set of keys while pressing the second; the word "then" means 
just the opposite - release the first set before typing the second. 

FOREIGN LANGUAGE CHARACTERS 

Char Name Keys 

A uppercase A acute accent Ctrl+Alt+e then Shift+a 

A uppercase A dieresis accent Ctrl+Alt+u then Shift+a 

A. uppercase A grave accent Ctrl+Alt+' then Shift+a 

A uppercase A circumflex accent Ctrl+Alt+i then Shift+a 

A. uppercase A tilde accent Ctrl+Alt+n then Shift+a 

A uppercase A ring accent Shift+Ctrl + Alt+a 

a lowercase a acute accent Ctrl+Alt+e then a 

a lowercase a dieresis accent Ctrl+Alt+u then a 

a lowercase a grave accent Ctrl+Alt+' then a 

a lowercase a circumflex accent Ctrl+Alt+i then a 

a lowercase a tilde accent Ctrl+Alt+n then a 

a lowercase a ring accent Ctrl+Alt+a 

<:= uppercase C cedilla accent Shift+Ctrl+ Alt+c 



\: lowercase c cedilla accent Ctrl+Alt+c 

:E uppercase E acute accent Ctrl+Alt+e then Shift+e 

E uppercase E dieresis accent Ctrl+Alt+u then Shift+e 

:E uppercase E grave accent Ctrl+Alt+' then Shift+e 

E: uppercase E circumflex accent Ctrl+Alt+i then Shift+e 

e lowercase e acute accent Ctrl+Alt+e then e 

e lowercase e dieresis accent Ctrl+Alt+u then e 

e lowercase e grave accent Ctrl+Alt+' then e 

e lowercase e circumflex accent Ctrl+Alt+i then e 

uppercase I acute accent Ctrl+Alt+e then Shift+i 

uppercase I dieresis accent Ctrl+Alt+u then Shift+i 

uppercase I grave accent Ctrl+Alt+' then Shift+i 

uppercase I circumflex accent Ctrl+Alt+i then Shift+i 

lowercase i acute accent Ctrl+Alt+e then i 

lowercase i dieresis accent Ctrl+Alt+u then i 

lowercase i grave accent Ctrl+Alt+' then i 

lowercase i circumflex accent Ctrl+Alt+i then i 

N uppercase N tilde accent Ctrl+Alt+n then Shift+n 

ii lowercase n tilde accent Ctrl+Alt+n then n 

6 uppercase 0 acute accent Ctrl+Alt+e then Shift+o 

b uppercase 0 dieresis accent Ctrl+Alt+u then Shift+o 

6 uppercase 0 grave accent Ctrl+Alt+' then Shift+o 

6 uppercase 0 circumflex accent Ctrl+Alt+i then Shift+o 

6 uppercase 0 tilde accent Ctrl+Alt+n then Shift+o 

0 uppercase 0 slash Shift+Ctrl+ Alt+o 

6 lowercase o acute accent Ctrl+Alt+e then o 

b lowercase o dieresis accent Ctrl+Alt+u then o 

6 lowercase o grave accent Ctrl+Alt+' then o 

6 lowercase o circumflex accent Ctrl+Alt+i then o 



6 lowercase o tilde accent 

0 lowercase o slash 

u uppercase U acute accent 

D uppercase U dieresis accent 

D uppercase U grave accent 

0 uppercase U circumflex accent 

u lowercase u acute accent 

Lt lowercase u dieresis accent 

u lowercase u grave accent 

ll lowercase u circumflex accent 

y uppercase Y dieresis accent 

y lowercase y dieresis accent 

IE uppercase l.E diphthong 

~ lowercase ae diphthong 

CE uppercase OE diphthong 

ce lowercase oe diphthong 

dotless i 

fS German double s 

Q ordmasculine 

ordfeminine 

FOREIGN-LANGUAGE ACCENTS 

Char Name 

acute 

circumflex 

grave 

dieresis 

Ctrl+Alt+n then o 

Ctrl+Alt+o 

Ctrl+Alt+e then Shift+u 

Ctrl+Alt+u then Shift+u 

Ctrl+Alt+' then Shift+u 

Ctrl+Alt+i then Shift+u 

Ctrl+Alt+e then u 

Ctrl+Alt+u then u 

Ctrl+Alt+' then u 

Ctrl+Alt+i then u 

Ctrl + Alt+u then Shift+y 

Ctrl+Alt+u then y 

Shift+Ctrl+Alt+' 
(apostrophe) 

Ctrl+Alt+' (apostrophe) 

Shift+Ctrl+ Alt+q 

Ctrl+Alt+q 

Shift+Ctrl+ Alt+i 

Ctrl+Alt+s 

Ctrl+Alt+O (zero) 

Ctrl+Alt+9 

Keys 

Ctrl+Alt+e then Spacebar 

Ctrl+ Alt+i then Spacebar 

Ctrl+Alt+' then Spacebar 

Ctrl+Alt+u then Spacebar 



tilde 

macron 

breve 

dot accent 

caron 

ring accent 

Hungarian umlaut 

ogonek 

cedilla 

TYPOGRAPHICAL SYMBOLS 

Char Name 

t dagger 

9f 

® 

© 

TM 

0 

PUNCTUAT ION MARKS 

double dagger 

section 

paragraph 

registered trademark 

copyright 

trademark 

bullet 

centered period 

lozenge 

Char Nam e 

question down 

exclamation down 

Ctrl+Alt+n then Spacebar 

Shift+Ctrl+ Alt+w 

Shift+Ctrl + Alt+z 

Shift+Ctrl + Alt+d 

Shift+Ctrl + Alt+s 

Shift+Ctrl + Alt+r 

Shift+Ctrl + Alt+u 

Shift+Ctrl + Alt+y 

Shift+Ctrl+ Alt+e 

Keys 

Ctrl+Alt+t 

Shift+Ctrl+ Alt+t 

Ctrl+Alt+6 

Ctrl+Alt+7 

Ctrl+Alt+r 

Ctrl+Alt+g 

Ctrl+Alt+2 

Ctrl+Alt+8 

Shift+Ctrl+Alt+O (zero) 

Shift+Ctrl + Alt+v 

Keys 

Shift+Ctrl+Alt+/ 

Ctrl+Alt+l 



ellipsis 

non-breaking space 

soft hyphen 

en dash 

em dash 

typographer's open quotes 

typographer's close quotes 

open single quote 

close single quote 

double quote low 

single quote low 

opening guillemot 

closing guillemot 

opening single guillemot 

closing single guillemot 

CURRENCY AND NUMERIC SYMBOLS 

Char Name 

¢ cent 

£ pound sterling 

¥ yen 

0 general currency 

f florin 

I fraction 

0 degree 

%0 per thousand 

Ctrl+Alt+; 

Alt+Spacebar 

Ctrl+- (hyphen) 

Ctrl+Alt+- (hyphen) 

Shift+Ctrl+Alt+- (hyphen) 

Ctrl+Alt+[ 

Shift+Ctrl+ Alt+[ 

Ctrl+Alt+] 

Shift+Ctrl +Alt+] 

Shift+Ctrl+ Alt+; 

Shift+Ctrl+Alt+l 

Ctrl+Alt+\ 

Shift+Ctrl+Alt+ \ 

Shift+Ctrl+Alt+< 

Shift+Ctrl+Alt+> 

Keys 

Ctrl+Alt+4 

Ctrl+Alt+3 

Ctrl+Alt+y 

Shift+Ctrl+Alt+4 

Ctrl+Alt+f 

Shift+Ctrl+Alt+3 

Shift+Ctrl+ Alt+8 

Shift+Ctrl +Alt+ 5 



MATHEMATICAL SYMBOLS 

Not all the mathematical symbols are available in eve1y font. If 
your font doesn't have a character you need, use the URW 
SymbolPS font instead for that one character. 

Char Name Keys 

-:f. not equal Ctrl+Alt+= 

approximately equal Ctrl+Alt+x 

~ less than or equal Ctrl+Alt+, (comma) 

;::: greater than or equal Ctrl+Alt+. (period) 

± plus/ minus Shift+Ctrl +Alt+= 

division Ctrl+Alt+/ 

infinity Ctrl+Alt+S 

integral Ctrl+Alt+h 

logical not Ctrl+Alt+l 

'1 radical Ctrl+Alt+v 

TI Pi Shift+Ctrl+ Alt+p 

7t pi Ctrl+Alt+p 

~ Delta Ctrl+Alt+j 

p mu Ctrl+Alt+m 

a partial differential Ctrl+Alt+d 

Q Omega Ctrl+Alt+z 

L Sigma Ctrl+Alt+w 



IND EX 

1 
1000 Separator option A.8 

A 
ABORT com mand , GeoComm 9.25 
Accele ration option A.1 5 
accessories 1.2 to 1.13 
Alt key 1.21, 1.28, 1.37, 1.44 
app lica tio ns 1.1 Lo 1.13 

accesso ries 1.2 
configuring 1.50 
DOS 3.9 

see also DOS applica tions 
exiting 1.13, 1.24 
mu ltiple 1.50 to 1.53 
opening directly 1.8 
opening with a document 1.8 
starting 1.8, 3.8 to 3. 13 
starting GEOS 3.9 
using launcher icons 3.9 
window 1.10 to 1.13 , 3.8 

Apply button 1.36 
Archive attribute 3.29 
arrow keys 1.27, 1.36, 1.38, 1.41 

using in menus 1.21 
Ask Before Retu rning launcher o ption 3.12 
Ask Before Returning to GEOS o ption 3.37 
Ask For Options Each Time launcher o ption 3.11 

B 
Backspace key 1.34, 1.39, 1.44 
Baud Rate modem option A.18 
Baud Rate printer option A.22 
BELL comma nd , GeoComm 9.25 
bu llet character 1.39 
buttons 

Apply 1.36 
Calculato r 6 .2, 6.3, 6.5, 6.8, 6. 15 
Cancel 1.36 

c 

Close 1.36 
Dial 5.14 
disk drive 3.5 
Express 1.10, 1.1 2 
Full-Si zed 3.4 
Help 1.12 
information 3.5 
International A.6 
Maximize-Restore 1.12 , 1. 24 
memory, Calcu lator 6.6 
Minimize 1.12 
mouse, left 1.15 , 1.28, 3.7 
mouse, right 3.8, 3.22 
OK 1.36 
Overlapping windows 3.4 
Path arrow 2.17 
Reset 1.36 
Restore 1.24 
Sto p 1.36 
Video A.5 
Wastebasket 3.4, 3.24 
Window Contro l 1.12, 1.13, 1.19, 1.20, 1.23 to 

1.24, 1.33 

C! CE button, Calculator 6.8 
Calculator 

active memory 6.8 to 6. 11 
basic functions 6.2 to 6.8 
buttons 6.3 
buttons, RPN calculator (table) 6.1 5 
C/ CE button 6.8 
calculating 6.6 to 6.8, 6. 16 
Clea r button 6.4 
converting measurements 6.24 
customizing 6. 12 to 6.24 
decimal places 6. 18 
Dele te button 6.4 
e rror conditions 6.8 
hierarchy of opera tions 6.7 
keyboa rd shortcuts (table) 6.4, 6.6, 6. 15 , 6.20 

to 6.22 
keys 6.3, 6.7 



memory box 6.9, 6. 11 
memory buttons 6.6 
mo use usage 6.7 
paper rape 6.2, 6.1 2, 6.23 
readout bar 6.1 , 6.2, 6.4, 6.24 
register me mo1y 6.8, 6. 11 to 6. 12 
regular nota tion 6. 12, 6. 17 
RP mode 6.3, 6.6, 6.8, 6.1 2, 6. 14 to 6. 17 
scientific exte nsion 6. 12, 6.20 to 6.22 
scientific notation 6. 12, 6. 17 
standard mode 6.3, 6.6, 6. 14 
starting 6.2 
switching, RPN and standard mode 6. 15 
trigonometric functions 6.1 2, 6.20, 6.22 
window 6. 2 

Cancel button 1.36 
check boxes 1.33, 1. 34 
check boxes in menus 1.16 to 1.17 
checksum 9. 23 
CLEAR command, GeoComm 9.25 
cl icking 1.8, 1.9, 1.15 , 1.18, 1.35, 1.40 
cl ipboard 1.42 
collapsing branches 3.30 
COMM command, GeoComm 9. 25 
Compress Display option 3. 14 
Computer options A.3 to A.4 

ports A.4 
configuring applications 1.50 
Confirm Argume ms Before Running launcher option 

3. 12 
Confirm When Exiting GeoManager option 3.37 
Control (Ori) key 1.20, 1. 28, 1.31, 1.44 
Copy 1.42 
Copy command 3.23 
Copy Disk command 3.33 
Copy To 2.32 to 2.34 
Copy, shortcut key 1.20 
copying 3.22 
cop ying fil es 3.8 
copying floppy disks 3.33 
CR/LF, GeoComm 9.21 
CRC (Cyclic Redu11dancy Check) , GeoComm 9.23 
Creation Date and Time sort option 3. 14 
Cut 1.42 , 6.7 
Cut, shortcut key 1. 20 

D 
Date and Time optio ns A.26 
Date options A.26 
Decimal Digits option A.7, A.8 
Decimal Separator option A.8 
Delete command 3.26 
Delete key 1.44 

deleting 3.24 to 3.26 
files 3.24 
fo lde rs 3.24 
warning 3.36 

deleting installed printers A.20 
de leting text 1.44 
deselecting icons 3.7 
Desk Accessories fo lder 1.53 
destination disk 3.33 
Dial button 5.14 
DIAL command, GeoComm 9.25 
Dialing Method modem option A.17 
dialog boxes 1.33 to 1.37 

Apply butto n 1.36 
Cancel button 1.36 
check boxes 1.33, 1. 34 
clicking 1.35 
Close button 1.36 
Do-not pointer 1.33 
drop-down list 1.35 
ellipsis in 1.35 
keyboard response 1.36 
mne monics 1.37 
New/ Open 2.3 
OK button 1.36 
Print 2. 19 
radio buttons 1.33, 1.34 
Reser button 1.36 
scro lling list 1.35 
Stop button 1.36 
text entry 1.34 
value selecto r 1.33, 1.35 

Directory attribute 3. 29 
disk devices 3.5 
d isk drive buttons 3. 5 
disk drive le tte rs 3.5 
disks 

ide ntifying 3.5 
opening folders 3. 17 

Do-not pointer 1.33 
DOCUMENT folder button 3.4 
documents 

backing up 2.28 to 2.30 
closing 2 .14 
copying 2.32 to 2.34 
creating 2.3 to 2.9, 2.5 
description 2. 1 to 2.3 
d iscarding changes 2.34 
DOS programs 1.8 
DOS text fil es 2.2 
expo rting 2.30 
icons 2. 2, 2.8 
importing 2.4, 2.30 
naming 2.9 to 2.14 



notes 2.35 
opening 1.8, 2.3 to 2.9, 2.5 to 2.9 
optio ns 2.20 
password for 2.36 
printing , custom 2. 19 to 2.27 
printing, standard 2.19 
renaming 2.34 
restoring 2.28 to 2.30 
sa feguarding 2.13 
saving 1.13, 2.9 to 2. 14 
startup 2.2 , 2.4, 2.7 to 2.9 
startu p, setting 2.37 
Text File Editor 2.2 
type 2.7 
ty pe, setting 2.38 

DOS file extensio ns 3.9 
DOS applica tions 

changing launche r settings 3. 13 
creating launcher icons 3. 10 to 3. 13 
removing launcher icons 3. 13 
starting 3.9 
starting directly 3.9 
starting with launcher icons 3.9 

DOS Extension sort option 3.14 
DOS file attributes 3.27 
DOS fil e extensions 2.10, 3.10 
DOS fi le icons 3.4 
DOS file names 2.10, 8 .1 2 
DOS Order sort option 3. 15 
DOS text fil es 1.8, 2.2, 2. 14, 8. 1, 8.11 to 8. 14, 9.1 5 
DOS text files, sending 9.16 
DOSROOM folder button 3.4 
double-clicking 1.8, 1.13 
d ragging 1.15 , 1.18, 3.8, 3.22 

multipl e icons 3.8 
dragging and dropping 1.43 
Drive Locations optio n 3.38 
drives 

network 3.34 
drop-down list 1. 35 
duplicating 3.23 

E 
e llipsis in dialog boxes 1.35 
e ll ipsis in menus 1.16 
e m dash , typing 1.39 
END command, GeoComm 9.26 
Ensemble 

starting 3. 13 
Enter key 1.21 , 1.37, 1.38 
Escape (Esc) key 1.21 
exiting applications 1.13 
exporting documents 2.30 

Express butto n 1.10, 1.12 
Express menu 1.31 to 1.32, 1.52 , 5.2 , 6.2, 7.2, A. 2 

F 
fil e management 3.2, 3.24, 3.31 
file names 

DOS 2.10 
GEOS 2.10 

fil e selecto r 2.6, 2. 12, 2.15 to 2.19 
fi le selector d ialog boxes 

fil es 

buttons 2.16 
changing drives 2. 18 
changing fo lders 2.17 
changing paths 2. 17 

batch 3.9 
changing attributes 3.28 to 3.29 
copying 3.22 
de le ting 3.24 
duplicating 3.23 
getting information abo ut 3.26 
moving 3.22 
protecting 3.28 
renaming 3.21 
types 3.28 
user notes 3.28 

finding and replacing text, Text File Editor 8 .8 to 
8. 11 

fl oppy disks 
copying 3.33 
formatting 3.32 
renaming 3.34 
rescanning 3.34 
security while formatting 3.33 

folder 
root 3.17 
WORLD 3.1 0 

folde r window 3.3 to 3.4 
folder window, GeoManager 3.3 
fo lders 2.17 to 2. 19, 3.3 

changing attributes 3.28 to 3.29 
closing 2. 18, 3.35 
collaps ing within a branch 3.31 
compressing display 3. 14 
copying 3.22 
creating new 3.20 
deleting 3.24 
displaying tree fo r another disk 3.31 
DOS applicatio ns 3. 10 
DOS path 3.6 
dragging 3.22 
duplicating 3.23 
expanding 3 30 



next level 3.31 
within a branch 3.31 

getting information about 3.26 
Home 2.2 , 2.6, 2.8 
minus sign 3.30 
moving 3.22 
number o f icons 3.5 
o pening 2.17, 3.13, 3. 16 

on other disks 3. 17 
parent 3.17 

parent 3.5 
plus sign 3.30 
protecting 3.28 
re naming 3.21 
root 3.5 
showing hidden fil es 3. 16 
sort options 3. 14 
sorting contents 3. 14 
stacked 3. 18 
switching 3. 19 

be tween 3.18 
clicking windows 3. 20 
Window Control menu 3. 20 

tiled 3.18 
tiling 3.20 
tool area 3.4 
tree 3.30 
tree window 3.30 
viewing 3.20 

as list 3.15 
multipl e 3.18 
o ptions 3 15 

WORLD 3.13 
foot fo lde r 3.6 
For Editing option 2.7 
format 3.32 
Format Elements options A.11 
formatting 

fl oppy disks 3.32 
Ful l-Sized button 3.4 
Fu ll -Sized window 3. 18 

G 
GeoBanner 

borders 10.5 
creating 10.3 
formatting 10.4 
printing 10.6 
special effects, text 10.5 
starting 10.2 
text font 10.4 
text style 10.5 
window 10.2 

GeoComm 
auto linefeed 9.7 
baud rate 9.4 
checksum 9.23 
CR/ LF 9.21 
CRC (Cycl ic Redundancy Check) 9.23 
cursor 9.3 
data bits 9.4 
description 9.2 
dialing 9.10 to 9.13 
duplex 9.6 
handshake 9.5 
hanging up 9. 11 
host code page 9.7 
line status 9.13 to 9.14 
lines pe r screen 9.9 
modem 9.2 
mode m configuration 9.5, 9.7 to 9.9 
modem port 9.4 
modem speaker 9.8 
parity 9.4 
phone type 9.8 
protocol setings 9.3 to 9.5 
Quick Dia l 9.10 to 9. 11 
receiving 

copying text to the clipboard 9. 19 
CRC 9.22 
fil e types 9.22 
info rmatio n 9. 18 to 9.23 
using XMODEM 9.22 

saving screen text 9.20 
saving scro ll -back buffer text 9.20 
saving text 9.20 
saving text, using XMODEM 9.22 
script commands 9.24 to 9.28 

ABORT 9.25 
BELL 9.25 
CLEAR 9.25 
COMM 9.25 
DIAL 9.25 
END 9.26 
GOTO 9.26 
label 9.24 
MATCH 9.26 
PAUSE 9.27 
PORT 9.27 
PIUNT 9.27 
PROMPT 9.26 
PULSE 9.28 
SEND 9.28 
TERM 9.28 
TONE 9.28 

scripts 9.11 to 9.13 , 9.23 to 9.28 
creating 9.12 



running 9.12 
stopping 9. 13 
syntax 9.24 

sending 
break signal 9. 14 
brief messages 9. 15 
DOS text fil es 9. 15 , 9.1 6 
files using XMODEM 9.15 , 9. 17 to 9.18 
information 9.14 
text on clipboa rd 9. 15, 9. 16 

stop bits 9.5 
terminal emulation 9.5 
terminal settings 9.6 to 9.7 
text size 9.9 
window 9.3 
window settings 9.9 
wrap lines 9.7 

Geo Dex 
address book 5.4 

creating 2.5, 5.21 to 5.22 
defau lt 5.4 
exiting 5.20, 5.24 
exporting 5.28 to 5.29 
importing 5.25 to 5.28 
merging 5.23 
ope ning 5.22 
saving 5.20, 5.24 
sorting 5.12 to 5. 13 

areacode 5.16, 5.17 
cards 

adding 5.5 to 5.7 
adding notes to 5.9 to 5.10 
copying 5.8 
creating 5.5 to 5.7 
deleting 5.9 
editing 5.8 
fi elds 5.5 
flipping through 5.7 
modem 5.6 
phone type 5.6 to 5.7 
searching, advanced 5.11 
sea rching, basic 5.10 

changing views 5.17 to 5. 18 
defa ult address book 2.2 
dia li ng phone numbers 5.14 

Dial butto n 5.14 
dialing options 5. 15 
Quick Dial 5. 14 

exiting 5.20 to 5.21, 5.24 
exporting 5.28 to 5.29 
fie lds 5.5 
impo rting 5.25 to 5.28 
linking to GeoP lanner 5.13 
long distance prefi x 5.16, 5.17 

mode m use rs 5.6, 5.14, 5.16, 5.17 
printing 5.18 
Qu ick Dial 5.14 
safeguarding 5.20 , 5.25 
saving 5.20 to 5.21 , 5.24 
sorting 5.12 to 5.1 3 
starting 5.2 
startup docume nt 2.2 , 2.7, 2.11, 2.37, 5.22 to 

5.23 
user leve l 5.3 
user level, fine tuning 5.29 
window 5 3 

GeoManager 
customizing 3.36 to 3.38 
exiting 3.38 
freei ng memo1y 3.38 
restarting 3.39 
starting w indow 3.2 to 3.6 
window areas 3.3 

GeoPlanner 
alarm reminde rs 4.20 to 4.23, 4.35 

cha nging date, time . sound 4.22 to 4.23 
repeating events 4.21 
responding to alarms 4.21 
turn ing on and off 4.21 

creating documents 2.5 , 4.29 to 4.30 
day template 4. 11 to 4. 12 

add ing events 4. 14 
customizing 4.33 to 4.34 
sched uling events 4. 11 to 4. 12 
turning off and o n 4.34 

default ca lendar 2.2 , 4.4 
empty days 4.34 
exiting 4.29 
finding specifi c events 4.23 to 4.24 
linking to GeoDex 4.24 
opening documents 4.30 
preferences, setting 4.32 to 4.37 
printing ca le ndar 4.25 Lo 4. 29 
printing ca le ndar, page size 4.26 ro 4.29 
printing events 4.26 
repea ting e ve nts 4. 15 to 4.20 

a larms 4.21 
changing 4. 19 
removi ng 4.20 
sched uling 4. 15 to 4.19 

safeguard ing 4.29 
saving 4.29 
sched uled events 

adding 4. 13 
changing 4. 12 
removi ng 4. 13 

scheduling events 4. 11 to 4. 15 
copying event description 4. 15 



day template 4 .1 1 to 4.12 
particular time 4.13 
repeating 4.15 to 4. 19 

sea rching events 4.23 to 4.24 
starting 4.2 to 4.3 
sta rtup document 2.2 , 2.7, 2.11 , 2.37, 4.31 , 4.36 
switching days at midnight 4.36 
switch ing, ca le ndar and events 4 .3 , 4.7 
user level 4.3 
user level, fine tuning 4.37 
viewing ca le ndar 4.4 to 4.6 

full-year 4.5 , 4.6 
months 4.5 , 4.6 
years 4.5 

viewing events 4.6 to 4.11 , 4.34 
days 4.8 to 4.11 

GEOS file attributes 3.27 
GOTO command, GeoComm 9.26 

H 
Handshake modem option A.18 
Handshake printer option A.22 
Hardware Options application 

Computer options A.3 to A.4 
Date and Time options A.26 
Keyboard options A.23 to A.24 
Modem options A.1 6 to A.18 
Mouse options A.14 to A.16 
Printer options A.18 to A.23 
Video options A.4 to A.5 

Help 1.5 
Help button 1.12 
Hidden attribute 3.16, 3.29 
Hold Items in Wastebasket option 3.37 
Home folder 2.2 , 2.6 , 2.8 

I 
icons 3.3 , 3.6 

creating laun cher 3.10 
deselecting 3.7 
document 1.8, 2.2 
DOS applicat ions 3.3 
DOS filess 3.4 
double-clicking 1.8 
dragging 3.8 
dragging multiple 3.8 
fo lder 3.4 
GEOS applications 3.3 
GEOS documents 3.3 
launcher 3.9 
selecting 3.6 
selecting multiple 

by clicking 3.7 
by dragging 3.7 

total size 3.5 
types 3.3 
using 2.8 

importing documents 2.4, 2.30 
information bar 3.3 

buttons 3.5 
e lements 3.5 

Insert key 1.39 
insert mode 1.39 
insertion point 1.34, 1.38, 1.41, 8.4 
Inte rnational button A.6 
Internationa l options A.5 to A.1 2 

K 
key 

currency format A.5 
Fo rmat Eleme nts A.11 
long date format A.9 
numbers format A.7 
quotation marks format A.8 
short date format A.10 
time format A.11 

Alt 1.21 , 1.28, 1.37, 1.44 
arrow keys 1.21 , 1.27, 1.36, 1.38, 1.41 
Backspace 1.34, 1.39, 1.44 
Calculator 6.3 
Control (Ctr! ) 1.28, 1.31, 1.44 
Dele te 1.44 
Enter 1.21 , 1.37, 1.38 
Escape (Esc) 1.21 
Insert 1.39 
Num Lock 1.39, 6.7 
shortcuts see sho rtcut keys 

keyboard 
maximizing windows 1.27 
minimizing windows 1.27 
mnemonics in men us 1.21 to 1. 22 
moving windows 1. 28 
restoring windows 1.27 
scrolling windows 1.31 
sizing windows 1.27 
using in dialog boxes 1.36, 1.37 

Keyboard options A.23 to A.24 
Key A.24 

L 

Keyboard A. 24 
Keyboard Delay A.24 
Keyboard Repeat Rate A.24 

launcher icon 3.9 



launcher icons 
custom options 3. 12 
location 3. 12 
o ptions for creating 3. 11 
see also DOS applica tions 

Leading Zero o ption A.7, A. 8 
left mouse button 1.15 , 1.28 
lines per screen 9.9 
linking 

GeoDex to GeoPlanner 5.13 
GeoPlanner to GeoDex 4.24 

List Sepa rator option A.8 
Long Date Format option A.9 
Look and Feel options A.24 to A.26 

Safeguard A.25 

M 

System Text Size A.24 
Typeover Mode A.25 

Ma in Dictionary option A.14 
managing documents 2.31 
MATCH command , GeoComm 9. 26 
Maximize-Resto re butto n 1.12 
maximizing windows 1. 24, 1.27 
Measurement System option A.8 
me mory box, Calculator 6.9, 6.11 
menu bar 1.12, 1.14, 1.15 
me nus 1.13 to 1. 24 

a rrow keys in 1. 21 
check boxes in 1.16 to 1.17 
cho ices in 1.14 
choosing 1.15 to 1. 24 
dimmed choices 1.15 
dragging in 1. 15 
e lli psis in 1.16 
Express 1.10, 1.52, 5.2, 6.2, 7. 2, A.2 
keyboard usage in 1. 20 to 1.22 
mnemonics 1.21 to 1.22 
opening 1.14, 1.15, 1. 21 
pinning 1.19 
radio buttons in 1.16 to 1.17 
submenus 1.18 to 1.19 
Window Control 1.13, 1. 20, 1.23 to 1.24 , 1.33 

Minimi ze button 1.12 
Minimize GeoManager on Run o ption 3.37 
minimizing w indows 1. 27 
mnemonics 1.21 to 1.22, 1.37 
modem 5.6, 5. 14, 5.16, 5.17 
Modem options A.16 to A.18 

Baud Rate A.18 
Dialing Method A.17 
Format A.17 
Handshake A.18 

Modem Speed A. 17 
Parity A.18 
Seria l Po rt A.17 
Stop Bits A. 18 
Stop Loca l A.18 
Sto p Remote A.18 
Word Length A. 18 

Modification Date and Time sort option 3. 14 
mouse button , left 1.1 5, 1. 28, 3.7 
mouse button, right 3.8, 3.22 
Mouse options A.14 to A. 16 

Acceleratio n A.15 
Interrupt Level A. 16 
Time Accele ration A.15 
Type A.15 

mouse pointer 1.16, 1. 28 
mouse, using 1.3 
Move command 3.23 
moving 3.22 
moving files 3.8 

N 
Name sort optio n 3. 14 
Na mes and Details view o ption 3.1 5 
Names view optio n 3. 15 
network drive 3.5, 3.34 
New/ Open dialog boxes 2.3 
No Command Line Options launcher o ption 3.11 

um Lock key 1.39, 6.7 

0 
OK button 1.36 
option applications (list) A. 1 
overlapping w indows 3. 18 
Overlapping windows button 3.4 
overstrike mode 1.39 

p 
page size, calendar 4.26 to 4. 29 
paging area 1. 29 
paper layout 2.22 
Paper options 

Height A.21 
Layout A.21 
Margins A.21 
Size A.21 
Type A.21 
Width A.21 

Parity modem option A. 18 
Parity printer option A.22 
password, documents 2.36 



Paste 1.42, 1.43 , 6.7 
pathname 3.6 
PAUSE command, GeoComm 9.27 
pinning menus 1.19 
pointe r 1.16, 1.26, 1.28 
pointers 

types 3.22 
PORT command , GeoComm 9.27 
PostScript fil e , saving to 2.24 to 2.26 
Preferences 

starting A.2 
window A. 3 

PRINT command , GeoComm 9.27 
Printer options A.18 to A.23 

Defa ult Paper Size A.21 
deleting installed printers A.20 
installed printe r settings A.20 
New Printe r A.19 
Port A.19 
Serial Port settings A.22 
testing installed printer A.20 
Type A.19 

printing 
calendar 4.25 to 4.29, 4.26 
canceling 2.27 
changing printe rs 2. 21 
checking print jobs 2.27 
colo r 2.26 
creating a DOS fil e 2.24 to 2.26 
custom 2. 19 to 2.27 
events 4.26 
Options dialog box 2.24 
paper options 2.21 to 2.24 
print quality 2.20 
standard 2.19 

PROMPT command, GeoComm 9.26 
Prompt For a Single File launcher option 3. 11 
PULSE command , GeoComm 9.28 

Q 
Quick Dial, GeoComm 9. 10 to 9.11 
Quick Dial, GeoDex 5.14 
qu ick format option 3.33 
Quotation Marks option A.9 

R 
radio buttons 1.33, 1.34 
radi o buttons in me nus 1.16 to 1.17 
RAM disk 3.5 
Read-Only attribute 3.29 
readout bar see Calculato r: 
Redo 1.45 

rescanning fl oppy disks 3.34 
Reset button 1.36 
restoring windo s 1.24, 1.27 
ROM disk 3.5 
root folder 3 .1 7 
RPN mode see Calculator 

s 
Safeguard option A.25 
safeguarding 2.13 , 4.29, 5.20, 5.25, 7.1 0, 8 .1 2 
Save 2.11 to 2.12 
Save As 2.12 to 2.13, 2.32 
saving 

configuration 1.50 
docume nts 2.9 to 2.14 

Scrapbook 
adding 7.6 
copying to other app lica tions 7.6 
crea ting 7. 10 
creating documents 2.5 
default 2.2 , 7.4 
de leting 7.7 
exiting 7.10 
Go to Page 7.5 
importing from DOS applications 7.8 
naming 7.8 
Next butto n 7.4 , 7.6 
opening 7 .11 
paging through 7.4 
Previous button 7.4, 7.6 
retrieving a de leted page 7.7 
safeguarding 7.10 
saving 7.9 
scraps 7.5 
starting 7.2 
startup document 2.2, 2.7, 2. 11 , 2.37, 7. 12 
user level, fine tuning 7. 13 
user levels 7.3 
window 7.3 

scripts see GeoComm 
scroll arrows 1. 29 
scroll bar 1.1 2, 1. 29 
scrolling list in dialog boxes 1.35 
scrolling through a window 1.29 to 1.31 
selecting 

ca nceling a selection 1.41 
extending a selection 1.41 
from a menu 1.15 to 1. 24 
icons 3.6 
icons, dragging 3.7 
multiple icons, cl icking 3.7 
redu cing a selection 1.41 
text 1.40 to 1.42 



SEND command , GeoComm 9.28 
Serial Port modem options A.17 
Serial Po rt mouse option A.16 
Short Date Format option A.10 
shortcut keys 1.20 to 1.22, 1.28 

Ca lculator 6.4, 6.6, 6. 15, 6.20 
Copy 1.20 
Cut 1.20 
Redo 1.45 
Undo 1.45 

Show Advanced Disk Options 3.37 
Size sort option 3. 15 
slider 1.29 
Smart Quotes option A.12 
Solitaire 

cards, number drawn 11.6 
finishing automatically 11.3 
playing 11 .3 
playing level 11.4 
scoring 11.4 
starting 11 .2 
undo 11.3 
window 11.2 

Solitia re 
options 11.6 

Sound options A.26 
source disk 3.33 
Space Around Symbol option A.6 
Spacebar 1.21 , 1.36 
specia l characters 

currency and numeric symbols B.6 to B.7 
foreign language B.2 to B.4 
foreign-language accents B.4 to B.5 
mathematical symbols B.7 
punctuation marks B.5 to B.6 
typing 1.39 
typographical symbols B.5 

specia l characters, bullet 1.39 
specia l characters, em dash 1.39 
Specify Options Now la uncher o ption 3.12 
spell checking 8.6 to 8.8 
Spell-checking options A.12, A.13 
standard file selector see fil e selector 
standard mode see Calculator 
startup documents 2.11 
Stop Bits modem option A.18 
Stop Bits printer option A.22 
Stop button 1.36 
Stop Local modem option A.18 
Stop Local printer option A.23 
Stop Remote modem option A.18 
Stop Remote printer option A.23 
subrnenus 1.18 to 1.19 
Suggest spellings option A.13 

Symbol and Negative Placement option A.6 
Symbol option A.6 
System attribute 3.16, 3.29 
System Options application 

International options A.5 to A.12 
Look and Feel options A.24 to A.26 
Mouse options A.14 to A.16 
Sound options A.26 
Text options A.12 to A.14 

System Text Size option A.24 

T 
Teacher Library 2.8 
Template attribute 3.29 
TERM command , GeoComm 9.28 
terminal emulation, GeoComm 9.5 
te rminal settings, GeoComm 9.6 to 9.7 
testing installed printers A.20 
text 1.37 to 1.46 

copying 1.42, 1.43 
cutting 1.42 
de leting 1.44 
deleting with key combinations (table) 1.44 
dragging and dropping 1.43 
editing w ith keyboard shortcuts (table) 1.46 
entering characters 1.37, 1.38 
entering in dialog boxes 1.33, 1.34 
insert mode 1.39 
insertion point, key combinations (table) 1.38 
insertion point, mouse 1.38 
moving 1.42, 1.43 
naming DOS text files 2.10 
overstrike mode 1.39 
pasting 1.42 
Redo 1.45 
replacing 1.42 , 1.43 
select ing 1.40 to 1.42 
selecting w ith key combinations (table) 1.41 
selecting with mouse 1.40 
specia l characters see special characters 
undo 1.45 
word wrap 1.37 

Text File Editor 1.8 
changing text size 8.6 
creating documents 2.5, 8.12 
DOS fil e names 8.12 
DOS text fil es 2.14 , 8. 1, 8.11 to 8.14 

crea ting 8.12 
naming 8.12 
opening 8.13 to 8.14 
printing 8.11 
saving 8. 12 

exiting 8.17 



findin g and replacing text 8.8 to 8.11 
insertion point 8.4 
line endings 8.5 
multiple documents 2.5, 8. 12, 8. 14 to 8. 17 
naming 2.9 
printing 8. 11 
replacing text 8.8 
safeguarding 8.12 
saving documents 2.14 
searching fo r special characters 8.9 to 8.11 
searching for text 8.8 
spell checking 8.6 to 8.8 
starting 8.2 
switching documents 8.15 to 8.17 
TXT extension 8.12 , 8.13 
user dictionary 8.7 
wild cards 8.9 to 8.11 
w indow 8.3 
word wrap 8.5 

Text options A.12 to A.14 
Main Dictionary option A.14 
Smart Quotes A. 12 
Spell-checking A.12 
User dictionary optio n A.13 

Ti le Vertically option 3.37 
Time Acceleration mouse option A.15 
Time Format option A.11 
Time o ptions A.26 
title bar 1.12, 1.19, 1.28, 1.33 
TONE command , GeoComm 9.28 
tool a rea 3.4 to 3.5 
tool area, GeoManager 3.3 
TXT extension 1.8, 2.2, 8.12 
Type of Printer Device option A.19 
Typeover Mode option A.25 

u 
Undo 1.45 
updating GEOWORKS products 3.38 
User dictionary option A.1 3 
user levels 1.46 to 1.50 

changing 1.47, 2.4 
differences in 1.46 to 1.47 
fine tuning 1.48 to 1.50, 4.37 , 5.29, 7.13 
GeoDex 5.29 
GeoPlanner 4.3, 4.37 
saving 1.48 
Scrapbook 7. 13 
verifying 1.47 

User Options application 
Look and Feel options A.24 to A.26 
Mouse options A.1 4 to A.16 
Sound options A.26 

v 
value selector 1.33, 1.35 
Video button A.5 
Video options A.4 to A.5 

changing adapter A.4 
testing video adapter A.5 

view options, windows 3.15 

w 
Warn on Emptying Wastebasket option 3.37 
Warn on Ove1write option 3.37 
Warnings o n De lete/Throw Away option 3.36 
Wastebasket 

de let ing all 3.25 
de le ting selected items 3.25 
recovering items by dragging 3.25 
recove ring items using File menu 3.25 
viewing contents 3.25 

Wastebasket button 3.4, 3.24 
win does 

full -size view 3.20 
window 

Control button 1.20 
Window Control button 1.12 
w indows 1.24 to 1.31 

applications 1. 10 to 1.13 
buttons 1.1 2, 1.23 to 1.24, 3.4 
Control button 1.12, 1.13, 1.19, 1.23 to 1.24, 

1.33 
Control menu 1.23 to 1.24, 1.33 
e le me nts 1.11 
maximi zing 1.12, 1.24, 1.27 
minimizing 1.11 , 1.27 
moving 1. 28 to 1. 29 
overlapping 3. 18 
overlapping fo lders 3.20 
resizing 1. 24 to 1.31 
restoring 1.12, 1.24, 1.27 
scrolling 1.29 to 1.31 
switching between folders 3.18 
tree 3.30 

Word Length modem o ption A.18 
Word Length printer option A.22 
word wrap 1.37 
WORLD fo lder button 3.4 

x 
XMODEM 9. 15, 9.17 to 9. 18, 9.22 
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