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Preface 

ARTLINE, Version 2.0 is an easy-to-use program that gives you the 
f1.. sophistication of professional illustrating tools in the PC envi
ronment. Whether you are designing advertising graphics, business 
presentations, or technical illustrations, Artline can meet your 
needs-quickly and efficiently. 

This documentation package helps you become productive 
immediately. This Artline Installation/ Startup guide ex
plains how to install Artline; the 'A.rtline Tutorial contains 
exercises with step-by-step instructions that show you 
how to create graphics with Artline; the Artline Utilities 
Guide describes several programs that enhance the text 
and output capabilities of Artline, and the Artline User 
Reference Guide describes the use of every Artline compo
nent and tool. 

Each manual contains a comprehensive Table of Contents 
and an Index to help you find what you need quickly. 

About this Guide 

Chapter 1 

Chapter 1 explains what you should do before you begin 
installing Artline, and provides an overview of the instal
lation process. Also in this chapter are instructions on 
how to use the Setup installation program and a descrip
tion of the kind of help that Setup provides during instal
lation. 
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Chapter 2 

Chapter 2 tells you how to install Artline on your system. 

Chapter 3 

Chapter 3 tells you how to start and exit Artline from: 

o the operating system command line; 
o the GE~/3 Desktop; 
o ViewMAX®; 
o Microsoft Windows/286®; 
o Microsoft Windows/386®; 
o Microsoft Windows 3.0®. 

Chapter 3 also contains instructions on customizing 
Windows PIF files and tips on improving program perfor
mance. 

Appendix A 

Appendix A lists some of the Setup messages that you 
might encounter while installing Artline. 

Appendix B 

Appendix B contains information about using files cre
ated with GEM Artline. 

Appendix C 

Appendix C describes how to configure Xerox Ventura 
Publisher® to work with Artline. 

Appendix D 

Appendix D contains a blank Artline configuration table 
that you can fill in with the specific information about 
your system. 



Assumptions 

Assumptions 

This guide assumes that you are familiar with the basic 
operations of your operating system. If you have ques
tions about these operations, refer to your system's man
ual. 
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Ins-tallation Overview 

THIS chapter discusses: 

o how to prepare for installation; 
o how Setup works and how to use Setup screens; 
o how Setup provides help during installation. 

Before You Begin 

Check the Package Contents 
In addition to the set of master diskettes, check that your 
Artline package contains: 

o Artline User Reference Guide 
o Artline Utilities Guide 
o Artline Clip Art Gallery 
o Customer Support Guide 
o Software License Agreement 

Back Up Your Master Disks 
Use your operating system's DISKCOPY command to 
make copies of the Artline master diskettes. For example, 
the following command copies the contents of the diskette 
in drive A to a diskette in drive B: 

DISKCOPY A: B: .J 

Store the original diskettes in a safe place, and use the 
backup copies to run the installation program. 

1-1 



Before You Begin 
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Register Your Software 

Complete the registration card (you will find this in the 
documentation tray in your package) and mail this to 
Digital Research® to register your software. This will enti
tle you to technical support and place you on the mailing 
list for future product upgrade and discount offers. 

Prepare Your System 

You need at least 430 Kb of free system memory (RAM) 
to install Artline. (You might need to remove memory
resident programs to make this system memory avail
able.) In addition, you must have at least 3.5 Mb of free 
space on your hard disk; additional disk space is required 
if you intend to load the clip art files. 

If you have DR DOSTM, it must be version 3.41 or later. If 
you are using MSTM-DOS or PC DOS, it must be version 
3.1 or later. 

Gather Hardware Information 

Before you ;;tart installing Artline, gather the following in
formation so you are ready when Setup asks for it: 

o the drive letter of the floppy diskette drive (source 
drive) where you will insert the Artline diskettes; 

o the drive letter of the hard disk drive where you want 
Artline installed; 

o the name of the subdirectory where you want Artline 
installed; 

o the name of your graphics card and display type; 
o the name of your mouse or other pointing device and, 

for serial mice, the mouse port identification (ID); 
o the name of your printer and printer port ID; 
o the name of your plotter type and plotter port; 
o the name of your camera type and camera port. 

For more information about port identifications, see 
About Communications Ports later in this chapter. 

Artline Installation/Startup 



Before You Begin 

Setup provides a series of help screens that provide de
tails about the device and system configuration informa
tion that it requests. You can usually obtain hardware 
model information from the labels on your equipment. If 
you are unsure about a product name or type, consult 
your hardware documentation or computer dealer. 

The following table is an example hardware configura
tion. Appendix D contains a blank form of this table: fill it 
in with the information for your system, and have it acces
sible during the installation process for convenient refer
encing. 

Device Type Device Name 

VDT - Graphics Display Type IBM® VGA I6-color 

Pointer Device (Mouse) ID / Port # Microsoft® serial mouse / COMI 

Printer I - Printer ID / Port # HP LaserJet Series II / LPTI 

Printer 2 - Printer ID / Port # Epson® FX-80 / LPT2 

Plotter ID / Port # Not used 

Camera ID / Port # Not used 

NOTE: Mter the installation is complete and you find that you 
specified the wrong device, don't worry-it will not harm 
your system- but the device won't function. You can correct 
the error by following the instructions in "Changing an 
Existing Configuration" in Chapter 2. 
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How Setup Works 

About Communications Ports 

If you are using a printer, a non-bus mouse or other pe
ripheral device, it is physically attached to a communica
tions port located at the back of your computer. Setup 
asks you for the number of each port you use. 

There are two types of communications ports: 

o A serial port is identified by the prefix COM followed 
by a number-usually 1 or 2 (COMl, COM2, etc.). 

o Aparallel port is identified by LPT, followed by a num-
ber, again typically 1 or 2 (LPTl, LPT2, etc.). 

If you choose a parallel device, Setup offers you a range of 
LPT port numbers from which to choose. Likewise, if you 
choose a serial device, Setup offers you a range of COM 
port numbers from which to choose. Unless you are using 
multiple parallel or serial devices, you should choose the 
first number ID on the list, (COMI or LPTl). 

How Setup Works 

1-4 

Artline works with a variety of computer types which can 
be connected to different printers, display monitors, point
ing devices, and other equIpment. To communicate with 
each type of device, Artline uses specific software pro
grams called drivers. Setup asks you to identify the de
vices connected to your system to determine your specific 
hardware configuration. 

Mter you enter the required information, Setup installs 
the appropriate drivers and builds and installs the neces
sary supporting applications on your hard drive. Mter 
you finish Setup, the installation process is complete and 
you are ready to start Artline. 

Artline Installation/Startup 



Title Bar ---

Help Bar 

How Setup Works 

Setup Screens 

Pages 

Setup uses three kinds of screens to communicate and re
quest information: 

o pages 
o menus 
o dialogs 

Pages contain explanatory text. The first Setup screen is 
an example ofa page: 

[ Installation Notes = 56% ]----------------------. 
Artline 2.B INSTALLATION 

Digital Research Inc. Copyright (c) 199B 

INTRODUCTION: 

UelcoMe to the Artline Installation PrograM. This prograM uill lead 
you through the various stages necessary for a cOMplete Artline 
installation. You can use this prograM to perforM a brand-neu installation 
of Artline or to change an existing installation. 

F1: Help t and I scroll text Esc: Previous Enter: Continues 

Scroll 
Arrows 

1_ 

The title bar at the top of the page displays the subject of 
the page and the percentage of the information contained 
in the screen. 

The scroll arrows on the right of the page show the loca
tion of the text within the window. Use the arrow keys to 
scroll the text one line at a time and the PgUp and PgDn 
keys to scroll by screens. 

The Help bar at the bottom of the page lists instructions 
for using the page. 

If you have a printer attached to port LPTl, you can print 
the contents of any page by pressing either p or P. 
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How Setup Works 

Menus 

Menu Window 

Directions Window -

A Setup menu lists options you can choose. The following 
is a sample menu: 

[ Select PriMar~ Pointer Device ]--------------------. 
Ho Mouse <Ho> 
Bus Mouse/Requires MOUSE.COM 
IBM Personal S~steM/2 Mouse 
Microsoft Serial Mouse (RS232) 
Mouse S~steMs PC Mouse/SuMMaMouse/CoMpatibles 
SUMMasketch 961 Cursor-T~pe Tablet 
SUMMasketch 961 St~lus-T~pe Tablet 
SUMMasketch 12B1 Cursor-T~pe Tablet 
SUMMasketch 12B1 St~lus-T~pe Tablet 
SUMMagraphics MM1B12 Cursor-T~pe Tablet 
SUMMagraphics MM1B12 St~lus-T~pe Tablet 

Select here to Continue to next Menu. 

<No> 
<No> 
<No> 
<No> 
<No> 
<No> 
<No> 
<No> 
<No> 
<No> 

Directions ]-------------------------~ 

Press Enter to select the highlighted iteM if ~our cOMputer is not 
equipped uith a Mouse. Instead of a Mouse, ~ou use the cursor control 
ke~s to perforM operations such as cursor MoveMent, dragging, and 
clicking. 

Help Bar jIit~~~~i:%tfM_t. •• ~.I.~'tlli&&.?!fi.~iI_i1I;ttl§M~[{r.~iMt!W$fk1t&l%«&1%Ww&UfuifiIM -

1-6 

F1: Help Esc: Previous Enter: Selects IteM rl: Cursor Ctrl End: Last Line 

The menu window lists the menu entries. Use the arrow 
keys to scroll through them. As you scroll, each entry 
becomes highlighted. To choose a highlighted entry, press 
Enter. 

The directions window explains your options for each 
menu entry. 

The Help bar at the bottom of the menu lists instructions 
for using the page menu. 

Artline Installation/Startup 



Dialogs 

How Setup Works 

Setup uses dialogs to request additional information 
about a preceding menu selection. The dialog below is dis
played after you choose a printer; it asks you to identify 
the port to which the printer is connected. 

Select Printer(s) J----------------------. 
Displa~ Current Selections 
Epson LQ-Series Printers 
HP DeskJet[+] Printer 
HP LaserJet II, Bit-Mapped 
HP LaserJet II, Softfonts 
HP PaintJet Printer, 8 colors 
HP PaintJet XL Printer 

<tlo> 
<tlo> 
<tlo> 
<tlo> 
<tlo> 
<tlo> 

Fl: Help Esc: Previous Enter: Selects and Continues tl: Cursor Ctrl 
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Getting Help 

Getting Help 

1-8 

Setup provides three levels of Help: 

o Item Description 
o Context Help 
o Keyboard Commands 

Item Descriptions 

Like the Directions window associated with menus, each 
Item Description explains your options for a selected item 
on the screen. 

Context Help 

Press Fl to access Context Help, which explains your op
tions or the objectives of the current menu or screen. 

Keyboard Commands 

Press Fl a second time to access Keyboard Commands 
Help. This screen lists all the commands that can be per
formed by pressing one or more keys simultaneously. 

Exiting Help 

To exit Help at any time, press Enter. 
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Installation 

THIS chapter describes: 

o the Setup program, how it works, and what it does; 

o step-by-step instructions for installing Artline; 

o how to change an existing Artline configuration; 

o the directories that Setup creates on your disk. 

The Setup Program 

To install Artline on your system, you run the Setup pro
gram. Setup creates the Artline directories on the hard 
disk drive you specify, and installs the necessary files into 
these directories. Setup can be run from any floppy drive 
and can write files into any valid hard disk directory that 
you specify. 

Setup can also install special driver packs for certain de
vices that are not listed specifically. Contact the Digital 
Research Technical Support Department if you have a de
vice that is not listed in the Setup menus during the in
stallation. 
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What Setup Does 

What Setup Does 

Helpful Hints 

2-2 

When you run Setup, you accomplish two basic steps: 

o you define your software configuration, that is, the 
hard disk drive and directories in which you want Art
line and related files to reside; 

o you define your hardware configuration, that is, the 
type of screen display, mouse, printer, etc., that you 
have in your system. 

Given this information, Setup can build the necessary 
files and install them on your system. 

Throughout the installation process, you will see <Yes> or 
<No> on the right side of the installation screen. You can 
change these with the space bar. If you make a mistake 
and accidently set a selection to <Yes>, you can change it 
back to <No> by pressing the Del key. The End key re
turns you to the "Select Here to Continue" selection. If 
you want to back up one menu, press the Esc key. Press
ing the Home key returns you to the top of the option list. 
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Starting and Exiting Setup 

Starting and Exiting Setup 

To begin installation: 

[] Insert the disk labeled Installation Disk into the 
source drive. The source drive can be any floppy disk 
drive that is media-compatible with the installation 
disks. 

For example, if you want to use the A drive as the 
source, type: 

A:.J 

SETUP .J 

or 

A:SETUP .J 

If the source drive is B, then type: 

B:.J 

SETUP .J 

or 

B:SETUP .J 

NOTE: If you are using a plasma or LCD two-color display with a 
color emulation mode, use the 1M monochrome switch. For 
example, if your source drive is A, then type: 

Installation 

A:SETUP 1M .J 

You will see the following screen momentarily as the 
Setup program loads. 

[ Working ]--------------. 
Loading control file: A:\IHSTALL.CFG 
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Starting and Exiting Setup 

When Setup is finished loading, the Artline Installation 
screen appears. 

[ Installation Notes = 56% ]----------------------. 
Artline Z.B INSTALLATION 

Digital Research Inc. Cop~right (c) 199B 

INTRODUCTION: 

WelCOMe to the Artline Installation PrograM. This prograM uill lead 
~ou through the various stages necessar~ for a cOMplete Artline 
installation. You can use this prograM to perforM a brand-neu installation 
of Artline or to change an existing installation. 

F1: Help t and I scroll text Esc: Previous Enter: Continues 

[]] Use the arrow keys or PgUp or PgDn to page 
through the information in this screen. When you are 
ready to continue, press Enter. 

[]] After you have read the installation instructions, 
press Enter. 
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Starting and Exiting Setup 

Setup displays the Select Installation Mode Menu. 
"New Installation" is pre-set to <Yes>, and the "Select 
Here to Continue to next menu." bar is highlighted. 
Press Enter to select it. 

NOTE: Once you begin the installation, you can stop Setup at any 
time and immediately return to the operating system com
mand line without installing Artline, by pressing 
Alt-X. 
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Starting and Exiting Setup 
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Define your software configuration: 

OJ Use the arrow keys to highlight the entries in this 
menu. To select an entry, highlight it, then press 
Enter. Setup displays the Source and Destination 
paths menu. 

urce on p 
Change ~our Source Drive A:\ 
Change ~our Destination Drive C:\ 
Change ~our Application Path C:\ARTLIHE\ 
Change ~our Fonts Path C:\ARTLIHE\FOHTS\ 
Do ~ou have GEM Desktop on ~our s~steM? <Ho> 
Path to GEM/3 Desktop C:\GEMAPPS\GEMSYS\ 

Select here to Continue to next Menu. 

[]] To change an entry, select it, press Enter, then type 
the full path name of the new directory. To accept all 
entries select the Continue bar using the End key, 
and press Enter . 

. []] If you have an existing GEM/3 Desktop installed on 
your system, use the arrow keys to highlight "Do you 
have an existing GEM/3 Desktop", press the space 
bar to change <No> to <Yes>, and then type the cor
rect path to the existing GEM/3 Desktop on the next 
line. This will allow you to start Artline from the 
GEM/3 Desktop (see page 3-2). 

NOTE: Setup will not alter your existing GEM/3 Desktop. 
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Starting and Exiting Setup 

Define your hardware configuration: 

[IJ When Setup displays the Select Screen(s) menu, iden
tify your computer's display type. 

Display Current Selections 
AT&T MonochroHe Card 
GENIUS Full Page 
Genoa Super UGA Card 
Hercules Graphics Card/MonochroHe PC display 
IBM UGA, 16-Color 
IBM EGA Card & 16-Color Display 
IBM UGA MonochroHe 
Load Additional 4.8 Screen Driver Packs ..• 

Select here to Continue to next Henu. 

[]J Choose the entry for your display monitor or for a 
compatible model. The directions listed for each entry 
are explained in the directions box to help you choose 
the correct monitor. 

If the monitor type that you are using is not on the 
list, select "Load additional 4.0 Screen Driver Packs" 
and press Enter. If you do not have the current 4.0 
screen driver pack, contact Digital Research Techni
cal Support. 

[]J You can select as many display monitors as you in
tend to use. If you select multiple displays, Setup 
asks you to identify the primary display. The primary 
display is the one you use most often. When you start 
Artline, it loads the driver for this screen automati
cally. Use the Del key to change a previously-selected 
<Yes> to <No> and the space bar or Enter to change 
from <No> to <Yes>. 
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Starting and Exiting Setup 
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[]] To continue, press End to highlight the Continue bar, 
then press Enter. Setup displays the Select Primary 
Pointer Device menu. 

Select PriHar~ Pointer Device 
No Mouse <No> 
Bus Mouse/Requires MOUSE.COM 
IBM Personal S~steH/2 Mouse 
Microsoft Serial Mouse (RS232) 
Mouse S~steHs PC Mouse/SuHHaHouse/CoHpatibles 
SUHHasketch 961 Cursor-T~pe Tablet 
SUHHasketch 961 St~lus-T~pe Tablet 
SUHHasketch 1281 Cursor-T~pe Tablet 
SUHHasketch 1281 St~lus-T~pe Tablet 
SUHHagraphics MM1B12 Cursor-T~pe Tablet 
SUHHagraphics MM1B12 St~lus-T~pe Tablet 

Select here to Continue to next Henu. 

<No> 
<No> 
<No> 
<No> 
<No> 
<No> 
<No> 
<No> 
<No> 
<No> 

Directions ]--------------------------------------------------------~ 

Press Enter to select the highlighted iteH if ~our cOHputer is not 
equipped with a House. Instead of a House, ~ou use the cursor control 
ke~s to perforH operations such as cursor HoveHent, dragging, and 
clicking . 

• ~.JtI'&~~~ .. _~fi:~_,.Im~i_ .... fJM~ .. ~~oo; .. i 
F1: Help Esc: Previous Enter: Selects IteH fl: Cursor Ctrl End: Last Line 

[]] Choose your mouse type or other pointing device. If 
you choose a mouse that connects to a port, Setup dis
plays the Ports List menu. 

Select PriHar~ Pointer Device 
No Mouse 
Bus Mouse/Requires MOUSE.COM 
IBM Personal S~steM/2 Mouse 
Microsoft Serial Mouse (RS232) 

SUHHasketch 961 
SUMHasketch 961 
SUHHasketch 1281 
SUMHasketch 1281 
SUHHagraphics MM1B12 
SUHHagraphics MM1812 

<No> 
<No> 
<No> 
<No> 

<No> 
<No> 
<No> 
<No> 
<No> 

Select here to Continue to next Henu. 

Directions 

Press Enter to select the highlighted iteH if ~our House is an~ of 
the above, or if it is a "generic" House. If ~ou are unable to deterHine 
the naHe and Hodel of ~our House, ~ou are probabl~ using a generic serial 
House and should choose this entr~. 

Il~B~k - .. ~ <, M".. ~~~'_t 
F1: Help Esc: Previous Enter: Selects and Continues fl: Cursor Ctrl 
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Installation 

Starting and Exiting Setup 

[]] Choose your mouse port ID, then press Enter. When 
Setup redisplays the Select Primary Pointer menu, 
the port ID is displayed to the right of the device 
name. 

[I] To continue, press End to highlight the Continue bar, 
then press Enter. Setup displays the Select 
Printer(s) menu. 

Select Printer(s) ]---------------------.11 
Displa~ Current Selections 
Epson LQ-Series Printers 
HP DeskJet[+] Printer 
HP LaserJet II, Bit-Mapped 
HP LaserJet II, Softfonts 
HP PaintJet Printer, 8 colors 
HP PaintJet XL Printer 
MonochroMe PostScript Printers 
Color PostScript Printers 
~pple Laseruriters 
Toshiba P321, P341, or P351 Printer 
Load ~dditional 4.8 Printer Driver Packs ••. 

Select here to Continue to next Menu. 

<No> 
<No> 
<No> 
<No> 
<No> 
<No> 
<No> 
<No> 
<No> 
<No> 

[ Directions ]-------------------------, 

Press Enter to accept ~our printer driver selections and continue 
uith the ~rtline installation. 

Fl: Help Esc: Previous Enter: Continues Install 
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Starting and Exiting Setup 
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[]] Choose the entry for your printer or for a compatible 
printer. Setup then displays the PrinterCs) Ports 
menu: 

Select Printer(s) 
Display Current Selections 
Epson LQ-Series Printers 
HP DeskJet[+] Printer 
HP LaserJet II, Bit-Mapped 
HP LaserJet II, Softfonts 
HP PaintJet Printer, 8 colors 
HP PaintJet XL Printer 

<No> 
<No> 
<No> 
<No> 
<No> 
<No> 

<No> 
<No> 
<No> 

Fl: Help Esc: Previous Enter: Selects and Continues t!: Cursor Ctrl 

[ill Highlight the port ID for the printer and press 
Enter. The Icon Name Editor menu appears. 

Select Printer(s) ]-----------------------------------------------,m 
Display Current Selections 
Epson LQ-Series Printers 
HP DeskJet[+] Printer 
HP LaserJet II, Bit-Mapped 
HP LaserJet II, Softfonts 
HP PaintJet Printer, 8 colors 
HP PaintJet XL Printer 

<No> 
<No> 
<No> 
<No) 
<No> 
<No> 

Color PostScri <No> 
Apple Laseruri <No> 
T [ I con NaMe ]------------------------------------------------..... > 
L [PostScript ] 

Use the follouing keys to edit the displayed string: 

[D Esc (the Escape key) 
Enter (the Return key) 
Backspace key 

p Ctrl-U (Ctrl + U) 
f 
i 

Cancel editing uithout saving changes. 
Accept the string as it appears. 
Delete character preceding cursor. 
Clear entire string. 

dL-________________________________________________________ --J 

Esc: Cancel edit. Enter: Accept edit. 
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Starting and Exiting Setup 

This dialog displays the label of the icon that Artline 
uses to represent the printer you selected. To change 
the name, press Ctrl-U, then type in a new name up 
to 12 characters long. Press Enter to complete your 
selection. 

110 I To continue, press End to highlight the Continue bar, 
then press Enter. Setup displays the Select Plotter(s) 
screen. 

[IT] If you do not want to install a plotter, just press 
Enter. Plotter drivers are only available in a 4.0 
Driver Pack. Insert the plotter driver pack you want 
into the source floppy drive, then use the arrow keys 
to highlight "Load Additional 4.0 Plotter Driver 
Packs" and press Enter. 

Setup prompts you to select the plotter you want to 
install. Use the arrow keys to highlight your selection 
and press Enter. 
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1121 To continue, press End to highlight the Continue bar, 
then press Enter. Setup displays the Select Cam
era(s) screen. 

1131 If you do not want to install a camera, just press 
Enter. To install a MAGICorp® camera, use the 
arrow keys to highlight it, press the space bar to 
change to <Yes>, press End and then press Enter to 
continue. 

To install a 4.0 Camera Driver Pack, use the arrow 
keys to highlight "Load Additional 4.0 Camera Driver 
Packs" and press Enter. 

Setup prompts you to select the camera you want to 
install. Use the arrow keys to highlight your selection 
and press Enter. 
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1141 To continue, press End to highlight the Continue bar, 
then press Enter. Setup displays the Artline Utilities 
& Clip Art screen. 

~: . 

ine ties & 
Font Conversion Utilities 
SaMple Clip Art frOM 3G Graphics 
SaMple Clip Art frOM Acebo 
SaMple Clip Art frOM ArtRight 
SaMple Clip Art frOM DreaM Maker Softuare 
SaMple Clip Art frOM Marketing Graphics 
SaMple Clip Art frOM Metro IMageBase 
SaMple Clip Art frOM One Mile Up 
SaMple Clip Art frOM T/Maker 

Select here to Continue to next Menu. 

1151 If you want the font conversion utilities and Clip Art 
just press Enter to continue. 

NOTE: The sample Clip Art requires the following amounts of 
disk space: 

3G Graphics 
Acebo 
ArtRight 
Dream Maker Software 
Marketing Graphics 
Metro ImageBase 
One Mile Up 
TlMaker 

800Kb 
200Kb 
400Kb 
600Kb 
275 Kb 
600Kb 
1Mb 
800Kb 

1161 If you do not need the font conversion utilities or the 
Clip Art, you can choose to de-select them by high
lighting the item with the arrow keys, then changing 
<Yes> to <No> using the Del key. 
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1171 To continue, press End to highlight the Continue bar, 
then press Enter. Setup displays the Review/Change 
Selections screen. 

Install program files onto your system: 

[1J Display or alter your selections, then press End to 
choose the Continue bar and press Enter to continue. 

Setup now begins to copy the Artline application and 
all related files onto your system. 

[}] Insert the installation disks that Setup requests. The 
number of disks you need to insert depends on the 
particular display screens, printers, plotters, etc. that 
you have selected. 

[]] When Setup finishes copying files, the installation is 
complete. Remove the installation disks from the 
source drive and store them in a safe place. 

[i] You are now ready to run Artline. Refer to Chapter 3, 
"Starting and Exiting Artline", for instructions on 
how to start and exit Artline. 
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Changing an Existing Configuration 

Changing an Existing Configuration 

Installation 

The process for changing an existing setup is almost iden
tical to a new installation. The only difference is that in
stead of using Setup from the source drive, you use 
AlSetup from the hard disk. For example, if you installed 
Artline on drive C, to change an existing configuration, 
type: 

C :\ALSETU P .J 

Setup then displays the Select Installation Mode Menu. 
"Change Existing Installation" is set to <Yes>. Press 
Enter to continue. Remember to use the Del key if you 
want to change <Yes> to <No>. 

When you change an existing configuration, AlSetup will 
ask you only for the disks that pertain to the software 
that changes. For example, AlSetup will not ask you to in
sert any disks if you change the mouse or a communica
tions port. 
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Installation Results 

NOTE: If for some reason your initial installation is stopped before 
Setup completes copying all the files onto your hard disk, 
you should run Setup again from the floppy diskette drive, 
and set "Change Existing Installation" to <Yes>. Select the 
same choices again, and insert the proper diskettes when 
Setup asks for them. Setup will again start copying files 
from the place where it was interrupted. 

Installation Results 

2-16 

The figure below illustrates the directory structure Setup 
installs on your hard disk. The files that are in each direc
tory vary according to the different hardware choices you 
made during the installation. 

C:\ 
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Starting and E)(iting 
Artline 

THIS chapter explains how you start and exit Artline. At this 
point, you should have completed the installation process and 

exited Artline Setup. You are now ready to start using Artline. 

This chapter describes starting Artline from: 

o the operating system command line; 
o the GEMl3 Desktop; 
o ViewMAX; 
o Windows/286, Windows/386, or Windows 3.0. 

This chapter also describes: 

o customizing Windows PIF files; 
o exiting Artline; 
o tips for improving program performance. 

Starting from the Command Line 

To start Artline from the operating system prompt, 
change to the drive on which you installed Artline and 
then go to the root directory. For example, if you installed 
Artline on drive C, you would enter these commands: 

C:.J 

CO\.J 

To start Artline, type this command: 
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Starting from the GEM Desktop and ViewMAX 

ARTLINE -1 

To start Artline and load a file, type this command: 

ARTLINE <filename.GEM> -1 

where <filename.GEM> is the file you want to load. The 
GEM extension is required. If the file is not in the default 
directory, you must include the full directory path. For ex
ample, to start Artline and load FIGURE3.GEM in the 
subdirectory \PROJECTl on drive C, type this command: 

ARTLINE C:\PROJECT1\FIGURE3.GEM -1 

NOTE: When typing operating system directory names on the com
mand line, be sure to use a backslash (\), not the slash (I). 

Starting from the GEM Desktop and ViewMAX 

D 
ARTLINE2.APP 

ARTLINE.BAT 

3-2 

If you told Setup that you have the GEM Desktop and 
gave the correct path information, you can start Artline 
from the GEM Desktop. You can also start Artline from 
ViewMAX, the graphics interface in DR DOS 5.0. 

To start Artline from the GEM Desktop: 

OJ Start the GEM Desktop as you normally do. 

[]] Open the GEMAPPS directory on the drive on which 
the GEM Desktop is installed. 

[]] Double-click on the icon for the file ARTLINE2.APP. 

To start Artline from ViewMAX: 

OJ Start View MAX as you normally do. 

[]] Switch to the root directory of the drive on which you 
have installed Artline. 

[]] Double-click on the icon for the file ARTLINE.BAT. 
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Starting from Windows 

Notes on Starting Artline from the GEM Desktop and 
ViewMAX 

o When you start Artline from the GEM Desktop or 
ViewMAX, you will see a momentary "blackout" on the 
screen as the transition occurs from your GEM 
Desktop or View MAX system software to the Artline 
system software. 

o Memory-resident programs (TSR's) can reduce avail
able memory so that you cannot start Artline from the 
GEM Desktop or ViewMAX. If you receive an alert say
ing there is not enough memory to start Artline, return 
to the operating system command line, remove any 
TSR's, and try again. If you still get the "not enough 
memory" alert, you must start Artline from the com
mand line. 

o Always start the GEM Desktop or ViewMAX first, and 
then start Artline. Do not try to start the GEM 
Desktop or ViewMAX from Artline with the To App 
command. 

Starting from Windows 

Because Artline was not specifically designed to run 
under Microsoft Windows, you must use a Program Infor
mation File (PIF), which contains the application name, 
its path, and various other parameters. 

You can start Artline from the Windows Executive by 
using one of the associated PIF files that was copied onto 
your hard disk during Setup. 

Windows/286 
If you are using Windows/286, use the operating system's 
COpy command to copy AL286.PIF from the \ARTLINE 
directory on the drive where you installed Artline to your 
\ WINDOWS\PIF directory. 
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To start Artline from Windows/286: 

[]] Double click on the AL286.PIF icon in the 
\ WINDOWS \PIF directory. 

[1] Artline closes out Windows and then runs. Upon exit, 
it reloads Windows. Although AL286.PIF has been 
configured to provide the best performance, you can 
modify this file to suit your requirements. You will 
need to modify AL286.PIF if you did a non-standard 
installation (installed the files on drive D: \ or 
changed the names of directories). To modify 
AL286.PIF, follow the instructions in your Windows 
documentation. 

Windows/386 

If you are using Windows/386, use the operating system's 
COpy command to copy AL386.PIF from the \ARTLINE 
directory on the drive where you installed Artline to your 
\ WINDOWS\PIF directory. 

To start Artline from Windows/386: 

[]] Double click on the AL386.PIF icon in the 
\ WINDOWS\PIF directory. 

[1] Artline closes out Windows and then runs. Upon exit, 
it reloads Windows. Although AL386.PIF has been 
configured to provide the best performance, you can 
modify this file to suit your requirements. You will 
need to modify AL386.PIF if you did a non-standard 
installation (installed the files on drive D: \ or 
changed the names of directories). To modify 
AL386.PIF, follow the instructions in your Windows 
documentation. 

CAUTION: If you are using a serial mouse, Windows/386 releases the 
serial port to any application configured as Exclusive and is 
then unable to regain control when you quit that application 
because Windows no longer detects the serial mouse. 
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To ensure correct mouse function after re-starting 
Windows: 

IT] Configure and save the .PIF file. 

[]] Return to Windows. 

[ill Quit Windows. 

[] Start Windows again. 

Windows 3.0 

If you are using Windows 3.0, use the operating system's 
COPY command to copy AL30.PIF from the \ARTLINE 
directory on the drive where you installed Artline to your 
\ WINDOWS directory. 

To start Artline from Windows 3.0: 

IT] Double click on the AL30.PIF icon in the 
\ WINDOWS directory. 

[]] Artline closes out Windows and then runs. Upon exit, 
it reloads Windows. Although AL30.PIF has been con
figured to provide the best performance, you can mod
ify this file to suit your requirements. You will need 

Exiting Artline 

to modify AL30.PIF if you did a non-standard installa
tion (installed the files on drive D: \ or changed the 
names of directories). To modify AL30.PIF, follow the 
instructions in your Windows documentation. 

To exit Artline, choose the Quit command from the File 
menu. If you started Artline from the operating system 
command line, you will return there upon exiting. If you 
started from the GEM Desktop, you will return to the 
Desktop; if you started from Windows, you will return to 
Windows. 
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Improving Program Performance 
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The time it takes Artline to load and install depends on 
many factors including: 

o type of system processor (8088,80286,80386,80486 
etc.); 

o speed of the system processor; 

o amount of memory available; 

o types of drives installed; 

o amount of disk cache; 

o size of BUFFERS allocation; 

o optimization of hard disk drive. 

If Artline fails to load because of insufficient memory, you 
might need to remove any memory-resident terminate 
and stay resident (TSR) programs running in the back
ground. 

Disk caching can improve the performance of Artline. 
However, if the cache program uses memory from the 
lower 640 Kb used by DOS, it might interfere with Art
line. If this occurs, disable the cache program and try run
ning Artline again. 

Since Artline spools data to the disk, it is important to 
make sure there is at least 1 megabyte of disk space avail
able on the drive where Artline is installed. Artline can 
use up to 4 Mb, ifit is available. 

Optimization of the hard disk drive is an important main
tenance operation that should be performed regularly to 
reduce the fragmentation of the drive that results from 
normal operation. There are many utility programs avail
able for performing disk maintenance and optimization. 
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Messages 

THIS appendix contains some of the messages you might receive 
while running the Artline Setup program, and suggest the action 

you should take if you receive the message. 

WARNING! 
The program was unable to find the specified files. This installation session will con
tinue, but may fail because these files were not copied. Contact the Digital Research 
Technical Support Department with the failed file specifications below for a possible 
workaround. 

Below are the files that were not found: 

If you receive this message, first make sure the files on the diskette 
are the same as those on the master diskette. If they are not, make a 
new copy of the master diskette and try installing again. If the files 
are missing from the master diskette, contact Digital Research Tech
nical Support for a replacement. 

WARNING! 
Bad Directory Entry in <filename>. It is highly recommended that you contact the 
Technical Support Department at Digital Research for a replacement disk. 
Press ALT-X now. 

If you get this message, the most likely reason is that the data on 
the diskette is corrupt. Make a new copy of the master diskette and 
try the installation again. If that fails, try using the master diskette. 
If that fails, then the master diskette is bad and you should contact 
Digital Research Technical Support for a replacement. 
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WARNING! 
This installation session may not know your complete installation. If you have an exist
ing installation that you wish to change, execute this program from your existing 
installation rather than from your original disk set. 

You might get this message if you attempt to reinstall Artline or 
change an existing configuration by running Setup instead of 
ALSETUP.BAT from the hard disk directory where you installed Art
line. 
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Using GEM Artline Files 

ARTLINE, Version 2.0 can import and edit files created with 
~ GEM Artline, with one exception. If you attempt to load a GEM 
Artline file that contains text, Artline, Version 2.0 will display the 
following alert: 

One or ~ore fonts used in this file are 
not available in the AF4 for~at. 
Substitute other fonts, or convert 
the text ele~ents to curves? 

Substitute 

Convert 

You can choose to substitute the font or convert the text 
to curves. If you convert the text to curves, you will not be 
able to edit it again. In either case, once a GEM Artline 
file is saved by Artline, Version 2.0, it cannot be opened by 
GEM Artline. 

NOTE: GEM Artline cannot load files created with Artline, Version 
2.0. 
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Using Artline Files 
in Ventura Publisher 

THIS appendix describes how you can use Artline files with GEM 
versions of Ventura Publisher. 

Artline File Formats 

Artline can create graphics files in either of two formats: 

D EPSF-Encapsulated PostScript® (EPS file extension) 
D GEM (GEM file extension) 

EPSF Files 

You can import Artline EPSF files directly into Ventura 
Publisher frames. However, note the following about 
EPSF files: 

D An EPSF file tends to be considerably larger than a 
GEM file version of the same picture. 

D An EPSF file cannot be viewed in Ventura unless you 
save it in Artline with a TIFF preview. In that case, 
Ventura converts the TIFF preview to an IMG file and 
loads it into the frame. You see the IMG version of the 
picture on the screen, usually at significantly lower res
olution than the original. 

D Ventura files containing EPSF files must be printed on 
a PostScript printer. 
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GEM Files 

In addition to being smaller than EPSF files, Artline 
GEM files can be printed on non-PostScript printers and 
can be displayed directly on the screen. However, the Art
line system software is a later version than Ventura's, and 
Artline GEM files will not load correctly in Ventura un
less you run a program called VPSETUP. (The Artline in
stallation placed it on your hard disk.) VPSETUP creates 
the necessary files for starting Ventura and copies the Art
line system software to the VENTURA directory. 

NOTE: VPSETUP does not affect your original Ventura installa
tion. You can still start Ventura with the old batch file, 
without loading the Artline system software. 

Running VPSETUP 

C-2 

To run VPSETUP: 
OJ On the drive where you installed Artline, type these 

two commands from the command line to switch to 
the SETUP subdirectory and then start VPSETUP: 

CD \ARTLlNE\SETUP .J 

VPSETUP .J 

VPSETUP functions just like SETUP. Make your selec
tions and then insert the disks that are requested. 

Note that you can create two batch files, one that starts 
the Ventura base edition and another that starts the 
Professional Extension. 

o VPDRLBAT starts the Ventura base edition. 
o VPPDRLBAT starts Ventura Professional Extension. 
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Starting Ventura 

VPSETUP places the batch files in the root directory of 
the drive on which Ventura is installed. 

To start Ventura: 

[]] Switch to the root directory of the Ventura drive. 

l]] To start the base edition, type: 

VPDRI.J 

To start the Professional Extension, type: 

VPPDRI.J 

As Ventura loads, you will see the following message: 

Inserting DRI system software 

When you quit Ventura, you will see this message: 

Restoring Ventura software 

If for any reason Ventura stops before its system software 
can be restored (for example, in the event of a power fail
ure), restart Ventura using VPDRI or VPPDRI. When 
you quit Ventura, the original system software will be 
restored. 
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Hardware 
Configuration Form 

The following table is a blank form that you can use to 
keep track of your hardware configuration. Fill it in with 
the information for your system. 

HINT: Use a pencil so you can change the entries if you change 
hardware. 

Device Type Device Name 

VDT - Graphics Display Type 

Pointer Device (Mouse) ID / Port # 

Printer 1 - Printer ID / Port # 

Printer 2 - Printer ID / Port # 

Plotter ID / Port # 

Camera ID / Port # 
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A 
AL286.PIF, 3-3 
AL30.PIF, 3-5 
AL386.PIF, 3-4 
available memory, 3-6 

B 
backup disks, 1-2 
buffers allocation, 3-6 

c 
camera device, 2-12 
changing your configuration, 1-3,2-15 
Clip Art files, 2-13 
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G 
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H 
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K 
keyboard command, 1-8 

L 
LCD display, 2-3 
LPTI-parallel port, 1-4 

M 
menu window, 1-6 
Microsoft Windows, 3-3 
mouse 

mouse port ID, 2-9 
non-bus mouse, 1-4 

N 
non-bus mouse, 1-4 
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p 
parallel port, 1-4 
performance, 3-6 
PIF file, 3-3 
plasma display, 2-3 
plotter device, 2-11 
primary display device, 2-7 
primary pointer device, 2-8 
printer device, 2-10 
printer icon, 2-11 
printer port ID, 2-10 
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Program Information File (PIF), 3-3 

R 
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serial mouse, 3-4 
serial port, 1-4 
Setup program, 2-1 
Setup screen, 1-5 
software configuration, 2-2 
special driver pack, 2-1, 2-7, 2-11 
starting Artline 

from command line, 3-1 
from GEM Desktop, 3-2 
from View MAX, 3-3 
from Windows, 3-3 

system processor, 3-6 

T 
terminate and stay resident (TSR) program, 
1-2, 3-3, 3-6 
title bar, 1-5 
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Ventura compatibility, C-l 
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Windows/286, 3-3 
Windows/386, 3-4 
Windows 3.0, 3-5 
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Preface 

Preface 

WELCOME to Artline®, Version 2.0, a powerful illustration pro
gram from Digital Research® for IBM® and compatible com

puter systems. Artline provides full color and PANTONE color 
support, and a full set of drawing and text manipulation tools. With 
Artline you can: 

o create sophisticated graphic illustrations; 
o print to PostScript® and non-PostScript output devices; 
o autotrace scanned images interactively; 
o create color separations; 
o customize tools to perform a set of steps you specify; 
o access a wide variety of fonts from different vendors; 
o convert pictures to a variety of formats; 
o incorporate pictures made in a variety of formats. 

TheArtline User Reference Guide gives complete and de
tailed instructions for all of Artline's functions. It also 
lists the key features that are new in Artline, Version 2.0. 

You can run Artline from several different operating sys
tems and window management programs. The Artline In
stallation / Startup guide gives complete installation and 
start-up instructions for each configuration. 
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What You Should Know 

What You Silouid J(now 

This tutorial makes the following assumptions: 

o Artline, Version 2.0 is installed on your computer. 

o You know how to start Artline from your system. 

o Artline is in its default state-the way it appears when 
you first install it. 

o You know what the following terms mean: 

- disk drive 
- system prompt 
- file 
- filename 
- filename extension 
- directory 

About This Tutorial 

x 

This tutorial takes you step-by-step through most of the 
features of Artline, using simple examples designed to con
vey a concept in as few steps as possible. You can then 
apply the concept to your own designs. The tutorial is de
signed to show graphic illustrators new ways to accom
plish traditional tasks. 

Initially, each step is described in full detail, but later in 
the tutorial it is assumed that you are more familiar with 
Artline and the steps are more briefly stated. 

If you are familiar with Artline or other graphics pro
grams, you might want to just skim chapters 1 and 2 for 
concepts you want to review and some that are new to 
Artline, Version 2.0. 

If you want to learn about drawing and editing curves 
you can do the exercises in chapters 4 and 5 at any time. 
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Preface 

About This Tutorial 

o Chapter 1 contains an introduction to Artline screen 
components, mouse techniques, tools, menus, and dia
logs. This chapter also shows you how to use some of 
the drawing tools, and how to select, move, resize, copy, 
and delete elements. 

o Chapter 2 shows you how to set up your workspace, 
use some of the drawing tools, create a picture, create 
a new fountain fill, save, and print. This chapter pres
ents important concepts about selecting elements in 
stacks, using the grid, and using menu commands. 

o Chapter 3 shows you how to use most of Artline's excit
ing features for creating special effects with text and el
ements. If you are familiar with the techniques for 
using the mouse and menus, and for selecting tools 
and elements, you can do the exercises in this chapter 
at any time. 

o Chapter 4 shows you how to draw lines and curves 
with the Quill tool, and Chapter 5 shows you how to 
edit lines and curves with the Plane tool. If you are fa
miliar with Artline basics you can do the exercises in 
chapters 4 and 5 at any time. 

o Chapter 6 teaches you how to use the interactive 
autotrace feature to trace a bit-image file. You can do 
the exercises in this chapter at any time, but because 
Artline automatically makes curves while tracing, the 
exercises do build on Chapters 4 and 5. 

o Appendix A shows the picture and name of each tool in 
the standard toolbox. You can use this page for refer
ence. 

This tutorial does not attempt to cover all of the aspects 
of a feature, nor all of the features of Artline. These are 
described in the Artline User Reference Guide. 

For a thorough introduction to the basic concepts and fea
tures of Artline, read Chapter 1 in the Artline User Refer
ence Guide. 
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If Your Version Is Customized 

If Your Version Is Customized 

xii 

Because Artline allows you to create your own color files 
and toolboxes, it is possible your version of Artline has 
been customized. If so, your toolbox might look different 
from the one in this tutorial. 

In most cases you can proceed with the instructions given 
here because the function of each standard tool remains 
the same. However, if your tools appear to be so altered 
that you cannot follow the instructions, you can reset Art
line to the default configuration. Refer to Chapter 13, 
"Tools Manager," in the Artline User Reference Guide for 
instructions on how to do that. 
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Getting Acquclintecl 

THIS CHAPTER teaches you the basics of using Artline. It is de
signed to allow you to experiment with Artline and become famil

iar with some of its most important features. Do not worry if your 
screen looks different from the screens in this tutorial. By practic
ing the techniques described in this chapter, you will be able to fol
low all of the exercises in this book. 

For an in-depth discussion of all basic techniques, refer to 
Chapter 1 of the Artline User Reference Guide. 

For the exercises in this chapter, start Artline according 
to the instructions in the Artline Installation / Startup 
guide. When Artline appears on your screen, you are 
ready to begin. 

The exercises in this chapter will take you about half an 
hour to complete. 

What is in this chapter: 

o Artline screen components 
o using the mouse, menus, and tools 
o selecting, moving, resizing, and copying elements 
o changing the magnification 
o exiting Artline 
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Artline Screen Components 

Artline Screen Components 

The following discussion assumes Artline is in its default 
configuration, with the default view and toolbox. 

When you start Artline, your screen looks like this: 

drawing surface -111-+-------+ 
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surround --!-~~ .. 

scrollers 

Menu Bar 

Title Bar 

The top line of the screen is called the menu bar. It dis
plays the names of the menus. 

The menu commands are fully described in the Artline 
User Reference Guide, Chapters 3 through 9. 

The title bar displays the name of the currently displayed 
picture and picture layer. If you have not yet saved the 
picture, the title bar reads "UNTITLED - Default Layer." 
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Toolbox 

Artline Screen Components 

Once you save a picture, the title bar displays its 
filename. When you create or display a new layer, the 
title bar displays the layer name. In this tutorial you use 
the default layer only. 

Layers are explained in Chapter 10 of the Artline User 
Reference Guide. 

The toolbox contains the icons that represent the Artline 
tools. You will learn how to use all of the tools as you com
plete the exercises in this tutorial. Chapter 2 of the 
Artline User Reference Guide describes each tool in detail. 

Workspace and Drawing Surface 

The workspace is the part of the screen that is enclosed by 
the title bar, the toolbox, and the scrollers. It is like a 
frame through which you view the drawing surface, on 
which you create and edit pictures. Depending on the 
view, the drawing surface can be larger or smaller than 
the workspace. 

The drawing surface represents one printed page and, in 
many ways, you can think of it as a sheet of paper. You 
determine its shape and size when you set up the page 
layout, and you determine how much of it is visible when 
you use the view and magnification tools. In other words, 
the size of the drawing surface in relation to the work
space can change, depending on the page layout and mag
nification level. 

When you first start Artline, the drawing surface is set to 
full view (it is entirely visible in the workspace) and the 
page layout is set to landscape, which makes the drawing 
surface wider than it is tall. 

The surround, described in Chapter 1 of the Artline User 
Reference Guide, is the part of the workspace that is not 
covered by the drawing surface. It is visible when the 
drawing surface is smaller than the workspace. 
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Using the Mouse 

Using the Mouse 

This section tells you about the mouse, which you use in 
some way in almost all program operations. 

Moving the Pointer 

To move the mouse 
without moving the 
pointer, pick it up first. 

Clicking 

The small black arrow on your screen is the pointer; it 
moves when you move the mouse. You use the pointer to 
select tools and elements, and to choose menu commands. 
Practice moving it. 

In Artline, you use only To click means to press and immediately release the 
the left button of the mouse button. 
mouse. 
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You click to make selections on the screen. 

Dragging 

To drag means to press and hold the mouse button down 
while you move the mouse. You use this technique to: 

o draw lines and shapes with the drawing tools; 
o resize elements; 
o move elements around the drawing surface; 
o select groups of elements. 

Double-Clicking 

To double-click means to press and release the mouse but
ton twice in rapid succession. You use this technique to: 

o display options for tools that have them; 
o display element information for selected elements; 
o display Combine menu dialogs for combined elements; 
o quickly select and exit from the I tern Selector. 
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Selecting Tools 

Selecting Tools 

• Selector tool 
selected 

Selector tool 
not selected 

Refer to Appendix A for the name and icon for each tool in 
the standard toolbox. 

When you start the program, the Selector tool (shown at 
the left) is highlighted in the toolbox, showing that it is se
lected, or ready for use. 

When the Selector is active, the mouse pointer shape is 
an arrow. You use the Selector tool to select, move, and re
size elements on the drawing surface. 

The pointer assumes different forms, depending on which 
tool is selected. 

The mouse pointer is always an arrow when it is over the 
toolbox and the menus, no matter what tool is currently 
selected. 

To select a tool, you click on it. 

Drawing a Rectangle 

The Rectangle tool 
makes rectangles and 
squares. 

Rectangle tool 

You use the dragging technique to draw with the 
Rectangle, Circle, Rounded Rectangle, and Line tools. 
For this exercise you will draw a rectangle. 

To draw a rectangle: 

[JJ Click on the Rectangle tool to select it, then move the 
pointer onto the drawing surface. The pointer 
changes to a cross to show that the Rectangle tool is 
selected. 

[]] Place the cross near the upper left corner of the 
screen, where it will define the upper left corner of 
the rectangle. 
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Drawing a Rectangle 

1-6 

[]] Hold the mouse button down and drag the cross diag
onally (down and to the right), away from the start
ing point. 

As you drag, Artline displays an outline of the rectan
gle you are drawing. If you move the pointer back to
ward the starting point, the outline shrinks. Make 
the rectangle cover about one quarter of the drawing 
surface. 

[]] Release the mouse button. The rectangle is drawn on 
the screen, and is enclosed in a selection frame, a 
frame with solid boxes at the midpoints and corners. 

The selection frame indicates that an element is se
lected. 

-

I 

-
If your rectangle is not to your satisfaction, you can erase 
it while it is still selected, then draw a new one. 

To erase the selected rectangle: 

Press Alt-E. That is, hold down the Alt key while you 
press E. The selected rectangle disappears. 
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Selecting Elements 

Selector tool 

There are several ways to select elements on the drawing 
surface. Here are the two basic methods. Try each one. 

To select the rectangle with the Selector tool: 

[]] Click on the Selector tool. 

[1] Click in the rectangle. 

The selection frame surrounds the rectangle. 

[]] Click outside the rectangle to de-select it. 

To select the rectangle by dragging: 

[]] Click on the Selector tool, if it's not already selected. 

[1] Place the pointer outside the rectangle, at the top left 
corner. 

[]] Hold down the mouse key and drag diagonally to out
side of the bottom right corner. As you drag, a dotted 
rectangular outline expands to show you the area you 
are enclosing . 

.................................................................................................................................... Jt.. 

[] When the outline completely surrounds the rectangle, 
release the mouse button. 

The selection frame surrounds the rectangle. 
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Moving Elements 

De-selecting Elements 

To de-select is to remove the selection frame from an 
element. 

To de-select an element, click on an empty area of the 
workspace. The selection frame disappears. 

If you accidentally make a tiny rectangle when you 
click to de-select the first one, you can use the Alt-E 
key combination to erase it. 

Moving Elements 

Selector tool 
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To move the rectangle: 

[IJ Select the rectangle. 

[1] Place the pointer in the interior of the rectangle. 

[]] Press the mouse button until the pointer becomes a 
hand. The hand shows you that you can move the 
whole element. 

[]] Drag the rectangle to a new location. 

As you drag, a dotted outline of the selection frame 
moves with the hand. 

[}] Release the mouse button. 

The rectangle is in the new location. 
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Moving Elements 

Moving and Copying Elements 

Artline provides many ways to copy an element. One way 
is to press the Shift key while dragging. This technique is 
called Shift-dragging. 

To move and copy the rectangle: 

[]] Select the rectangle if it's not already selected. 

[]] Place the pointer in the middle of the rectangle. 

[[] Press the Shift key first, and hold it down while you 
drag the rectangle to a new location. When you start 
dragging, the pointer changes to a hand, and a copy 
of the rectangle moves with the hand. 

[] Select and delete all but one rectangle. 
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Resizing Elements 

Resizing Elements 

Selector tool 
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At the corners and in the middle of each side of a selec
tion frame are small boxes called handles. You use the 
handles to resize selected elements. 

To resize the rectangle: 

[] If the rectangle you drew in the preceding section is 
not already selected, click on the Selector tool, then 
click on the rectangle to select it. 

[]] Place the pointer on top of the bottom right corner 
handle and press the mouse button until the pointer 
changes to a pointing finger. The pointing finger 
shows that you can drag a handle. If you see the 
hand, try again. 

[]] Drag the handle down and to the right diagonally. 

As you drag, the rectangle changes size. 
,. -

•• 

• -

[]] Drag a middle handle up, down, left, and right. The 
rectangle changes in width or height. 

You can drag any corner handle horizontally, verti
cally, and diagonally. You can drag any middle han
dle horizontally and vertically. 
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Using Menu Commands 

Using Menu Commands 

Undo +U 

Cut 
COP!J 
Paste 
Delete 

---------------------Select All 
I I 

Clone 

Move .. . 
Rotate .. . 
Scale .. . 

Re eat +f1 

Many menu commands act on selected elements. When 
no element is selected, these commands are dimmed to 
show they are unavailable. 

For this exercise, make sure the rectangle is selected. 

To choose a menu command: 

[JJ Click on the menu name to display a menu. For this 
exercise, click on the Edit menu. 

[]] When the Edit menu drops down, move the pointer 
through it to highlight each of the commands. 

[ill When you highlight the Duplicate command, click 
the mouse. 

The duplicate appears beneath and to the right of the 
original rectangle. To separate them, drag the se
lected element away. 

Using the Repeat Command 

The Repeat command lets you repeat the last action you 
performed, in this case, moving the rectangle. 

To repeat the move: 

[JJ Make sure the rectangle is selected. 

[]] Choose the Repeat command from the Edit menu. 
The rectangle moves again. 

Using the Delete command 

You can delete any element that is selected. 

To delete the copied rectangle: 

[JJ Make sure the rectangle is selected. 

[]] Choose the Delete command from the Edit menu. 

The second rectangle disappears from the screen. 

Getting Acquainted 1-11 



Using Menu Commands 
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Undoing the Delete command 

You can undo many actions you take with Artline. Some 
actions cannot be undone, in which case the Undo com
mand is dimmed. 

To undo the delete and redisplay the rectangle: 

Choose the Undo Delete command from the Edit menu. 

The deleted rectangle reappears. 

The exact name of the Undo command changes according 
to the action you have just taken. 

To redraw the screen: 

Sometimes, after a lot of editing, you might want to com
pletely redraw the screen. To do this, press the Esc 
(Escape) key. 

Using Keyboard Shortcuts 

Some menu commands have a keyboard shortcut-a 
combination of key strokes that chooses the command. 

In a previous exercise, you duplicated a rectangle by 
choosing the Duplicate command from the Edit menu. 
In this exercise, you'll duplicate a rectangle with the key
board shortcut for the Duplicate command. 

The keyboard shortcuts are listed in the menus on the 
right of the command name. 

D Diamond ( • ) indicates the Alt key. 
D Caret (A) indicates the Ctrl key. 
D Up-arrow en,) indicates the Shift key. 
D Function keys are listed as FI, F9, FlO. 
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About Copying Elements 

To use the keyboard shortcut: 

[]] Select the rectangle. 

[]] Type Alt-D: hold down the Alt key as you type the 
letter D. 

The element is duplicated beneath and to the right of the 
original. To separate them, drag the selected element 
away. 

Continuing to hold down Alt-D creates multiple dupli
cates. If you do this, you can select them for deletion by: 

o dragging to select a group of them; 
o choosing the Select All command from the Edit menu. 

About Copying Elements 

The Cut command 
removes the element 
and places it in mem
ory for future pasting. 

You have already used the Duplicate command, the 
Alt-D keyboard shortcut, and the Shift-drag technique to 
copy elements. 

Artline provides two additonal commands to copy ele
ments, depending on the purpose. 

The Copy command places a copy of the selected element 
in memory. You can then use the Paste command to 
paste it into the same picture, or into another picture that 
you open, or into another layer. Layers are described in 
Chapter 10. If you paste into the same picture or layer, 
the Paste command places the copy on top of the original 
element, so you must drag the copy away to see it. 

The Clone command creates a copy of the selected ele
ment and places it on top of the original. You must drag 
the copy a way to see the original. 
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Drawing Lines 

Drawing Lines 

Line tool 
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You draw, move, and resize rectangles, squares, ellipses, 
circles, and rounded rectangles exactly the same way. Be
cause a line has only one dimension, you manage it in a 
slightly different way. 

To draw a line: 

[] Select the Line tool. The pointer changes to a cross. 

[]] Place the crosshair on the left side of the drawing sur
face, and drag horizontally to the right side. As you 
drag, adjust the line up or down to try to make it ex
actly horizontal, although it does not need to be for 
this exercise. When the line is about two thirds of 
the screen in length, release the mouse button .. 

The selection frame surrounds the line. 

[]] Click on the Selector tool. 

[]] To make the line longer or shorter, press on one of the 
end handles until you see the pointing finger, then 
drag toward the edge or toward the middle of the 
drawing surface. The line shortens or lenghtens. 

[]] To move the line, place the pointer on top of the line, 
but not on a handle, and press until you see the hand. 
Then drag the line to a new position. 

If you press on the middle handle, you get the point
ing finger. For lines, dragging the pointing finger 
from the midpoint handle simply moves the line half 
the distance you drag. 

You can duplicate or delete the line just as you would 
any other element. 
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Using Dialogs 

Menu commands followed by three dots display a dialog, 
a box into which you can type data or choose options. 
Double-clicking on an element, a group of elements, and 
some tools also displays a dialog for setting options. 

Setting Preferences 

You can place the 
pointer in the title bar 
of a dialog and drag to 
move it around the 
screen. 

You can use the Preferences command to set five Artline 
functions to suit your needs: 

o automatic backups 
o opening settings 
o menu operation 
o redraw speed 
o double-click speed 

To set preferences: 

W Choose the Preferences command from the Options 
menu. 

Artline displays the Global Preferences dialog. 

Global Preferences 
Make Backups Of Open Files With -

[8J Picture Files @ Colors On 
[8J Tools Files o Colors Off 
[8J Color Files o Current Settings 

Menus Redraw Speed - Double-Click -
o Drop-Down o Quality o Slow 
@ Pull-Down @ Auto @ MediuM 

o Fast o Fast 

I OK I I Cancel I 

Chapter 9 of the Artline User Reference Guide de
scribes the Preferences and Save Preferences 
commands in detail. 
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Using Dialogs 

Artline pictures have a 
file extension of .GEM. 
Backup pictures have 
a file extension of 
. $EM. 

You click on check boxes and radio buttons to turn 
options on and off. 

- Check boxes in a section indicate you can turn on 
as many options as you like. 

- Radio buttons in a section indicate you can choose 
only one of the options at a time. 

[]] Under Make Backups Of, if there is not already an X 
in the box next to Picture Files, click to place one 
there. This will cause Artline to make a backup of 
any picture you make . 

~ Under Menus, click on the radio button next to the 
kind of menu you prefer. 

- Drop-Down menus means you just move the 
mouse pointer over the menu name to display a 
menu. 

- Pull-Down menus means you must click or hold 
down the mouse button on the menu name to dis
playa menu. 

[!] Under Redraw Speed, click on Quality. This displays 
the best screen picture, but takes longer to draw. For 
highly detailed pictures, you might want to use Fast. 

You can also open files with Colors Off to display com
plex pictures faster. 

You can change your double-click speed if you want. 

[]] Click on OK or press .J to exit the dialog. 

Notice that you can click on Cancel to exit a dialog 
without making any changes. 

You can also press the Esc (Escape) key to cancel a 
dialog. 

Your preferences are now in effect until you quit this ses
sion of Artline. 

NOTE: Preferences are active for the current session only. To keep 
them active for subsequent sessions you must choose the 
Save Preferences command from the Options menu. 
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Using Dialogs 

Setting Tool Options 

Double-clicking on some tools opens a dialog that allows 
you to set options for the way in which the tool functions. 

For example, you might have had difficulty drawing a hor
izontalline in the preceding section. You can use the Line 
Options dialog to set the angle at which lines are drawn. 

To set Line tool options: 

When a dialog field is 
highlighted, you can 
change its value by typ
ing in a new value. As 
you type, the value ap
pears in the field. 

Press the Shift key 
while you drag to 
change the value by 
one degree. 

[]] Double-click on the Line tool. The Line Options dia
log appears. 

The Snap Angle field is highlighted and contains the 
number 0 (degrees). 

[]] Type the number 30 (degrees). The number appears 
in the box. Press Backspace to clear the field. 

You can press the plus (+) and minus (-) keys on the 
numeric keypad to increase or decrease the value by 
ten degrees. Hold down the Shift key while you 
press the key to change the value by one degree. 

Alternatively, you can place the pointer anywhere in 
the Snap Angle field and press the mouse button to 
display a pop-up slider that you can drag up and 
down to change the value. The slider shows the range 
of acceptable values for that field. 

Snap Angle 

OK 

Leave the value set to 30 degrees. 

[}] Click on OK or press.J to exit the Line Options dialog. 

[]] Practice drawing some horizontal, vertical, and diago
nallines. Artline constrains them to 30° angles. 
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Changing the Magnification 

Changing the Magnification 

~ 
~ 
View tool 
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This section shows you how to change the magnification 
level of a picture. 

For this exercise, be sure to have one or two rectangles in 
the center area of the drawing surface. You can keep the 
line in the picture also. 

You can use any of the following tools to change the mag
nification: 

o View tool 
o Magnifier tool 
o magnification keys 

Note that the View menu contains commands to display 
and hide items such as rulers, grids, colors, and even 
tools, but this menu does not change the magnification 
level or location of a picture on the drawing surface. 

Artline opens pictures in Full View, which means you can 
see the whole drawing surface. The view size has no ef
fect on the size of the printed picture, but it does affect 
how much of the drawing surface you see on the screen. 

NOTE: When you magnify the view, elements appear very large, but 
you are looking at a very small portion of the drawing 
surface. The drawing surface extends beyond the work
space, and elements that are selected on the part you cannot 
see can be affected by the next action you take. 

Using the View Tool 

The View tool lets you choose from three view sizes: 

o Full View 
o Normal View 
o Reduced View 

You can also compose your own view and name it using 
the New View command in the View tool pop-up menu. 
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Full Uiew 

Reduced Uiew " 
New Uiew ... 

Changing the Magnification 

To select a view size: 

[]] Click on the View tool in the toolbox. A pop-up menu 
appears. 

[]J Click on Normal View. 

Your rectangle or line appears enlarged. It is possible 
that now you can see only part of it in the workspace. 
You can move it to the center if you wish. 

[l] Click on the View tool again, but this time choose Re
duced View from the View tool pop-up menu. 

The drawing surface is now quite reduced. 

[!] Choose Full View from the View tool pop-up menu. 

The drawing surface is returned to its original state. 

Using the Magnifier 

Magnifier 

The larger the selector 
box, the lower the 
magnification level. 

With the Magnifier you can magnify or reduce the view. 

To magnify the view: 

[]] Select the Magnifier tool. The pointer becomes a mag
nifying lens. 

[]J Place the lens at the center of the area that you want 
to magnify. Try magnifying a corner of the rectangle. 

[l] Drag the lens outward from the point you selected. 

As you drag, a selector box, which previews the new 
view area, expands. 
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Changing the Magnification 

[]J Release the mouse when the outline encloses the cor
ner. The element is magnified. You now see just the 
corner of the rectangle. 

If you magnify an empty area of the drawing surface, you 
will not see the rectangle, because it occupies a part of the 
drawing surface that extends beyond the workspace. 

To reduce the view: 

[] Select the Magnifier. 

[]] Click the pointer anywhere inside the workspace. 

The view is reduced. 

To return to Full View: 

Double-click anywhere in the workspace. 

The drawing surface is now back in Full View. 

Using the Magnification Keys 

You can use the 
magnification keys 
when any tool is 
selected. 

The magnification keys 
always display the 
center of the drawing 
surface. 
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The magnification keys are the plus (+) and minus (-) 
keys on the numeric keypad. They allow you to increase 
and decrease the magnification one level at a time. 

D To magnify the view by one step, press the plus key 
once. You can magnify the drawing surface beyond 
Normal View. 

D To reduce the view by one step, press the minus key 
once. You can move to a drawing surface one size 
smaller than Reduced View. 

Try magnifying and reducing your view of the rectangle. 

Notice that in high magnification the rectangle can be
come so large that its borders extend beyond the work
space into another portion of the drawing surface. 

The next section shows you how to move the rectangle 
back into the workspace. 
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Moving Around the Screen 

Moving Around the Screen 

~ 
~ 
View tool 

This section shows you how to display different parts of 
the drawing surface on your screen, when the whole page 
is not visible, such as in Normal View. 

For this exercise, choose Normal View from the View 
tool pop-up menu. 

You can use the scrollers to bring various parts of your pic
ture into view. The Artline screen contains one horizontal 
and one vertical scroller. 

Each scroller contains: 

o two scroll arrows 
o one slider 

Using the Scroll Arrows 

To scroll the picture by small increments, click on the up 
arrow or the down arrow on the vertical scroll bar or on 
the left or right arrow on the horizontal scroll bar. 

Using the Slider 

To scroll the picture by an increment of your choice, drag 
the slider up or down in the vertical scroll bar, and left or 
right in the horizontal scroll bar. 

If the slider spans the entire length of the scroll bar, you 
are already looking at the whole drawing surface, such as 
in Full View or Reduced View, and you cannot scroll. 
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Exiting Artline 

Exiting An-lille 

Artline always displays 
this dialog when you 
edit, then choose New 
or Quit without saving 
changes. 
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When you exit Artline, you return to the directory from 
which you started. 

If you are going on to Chapter 2 without exiting, you need 
to reset your screen to Full View and clear it of all 
elements. 

To reset Artline to the default view: 

Choose Full View from the View tool pop-up menu. 

To clear the screen using menu commands: 

[] Choose the Select All command from the Edit menu. 

Selection frames appear around all the elements on 
your screen. 

[ill Choose the Delete command from the Edit menu, or 
press Alt-E. 

All the elements disappear. 

To clear the screen using the New command: 

[] Choose the New command from the File menu. 

Artline displays the Abandon/Save alert. 

Abandon/Save changes 
to this picture? 

[]] Click on Abandon. 

Abandon 

Save 

Cancel 

A new UNTITLED screen is displayed. 

Note that you can click on Cancel to return to the 
drawing surface. 
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Exiting Artline 

To exit Artline: 

[JJ Choose the Quit command from the File menu, or 
Press Ctrl-Q (hold down the Ctrl key while you 
press Q). 

Artline displays the Abandon/Save alert shown pre
viously. 

[]J Click on Abandon. 

Artline quits and returns you to the directory from 
which you started. 

What You Learned 

You now know how to: 

o start and quit Artline; 
o use the mouse; 
o select elements, tools, and menu commands; 
o draw lines and rectangles; 
o move, copy, resize, delete, and undelete elements; 
o use keyboard shortcuts; 
o use dialogs; 
o change the view of the drawing surface. 

The next chapter shows you, step-by-step, how to: set up 
the workspace; use more of the drawing tools to create a 
picture; group and ungroup elements; change line width, 
color, and pattern; name and save your picture; and print 
your picture or display it on the screen. 
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Basic Drawing 
Techniques 

THIS CHAPTER shows you how to set up the workspace, draw a 
picture, save the file, and print. 

The exercises in this chapter will take about half an hour 
to complete. 

What is in this chapter: 

o setting the page layout 
o setting up the workspace 
o identifying the tools 
o drawing a true square and circle 
o using the Scale and Rotate commands 
o saving your picture 
o more about selecting elements 
o grouping and ungrouping elements 
o changing line width, line color, and fill color 
o creating a fountain fill 
o printing with PostScript 
o printing with Output 
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Setting the Page Layout 

Setting the Page Layout 

A shadowed field with 
an arrow indicates a 
pop-up menu. 

2-2 

It's good practice to set the page layout before you begin 
to draw. Artline is probably already set to the following 
defaults, but this exercise shows you how to use the Page 
Layout dialog. 

To set the page layout: 

[] Choose Page Layout from the File menu, or type 
Ctrl-S. 

The Page Layout dialog appears. 

Page La90ut 
Page 
Size I Letter 1·1 
11.00 )( 8.50 ::lnch 

Orientation I Landscaee 1·1 
Unit of Measure I Inches 1·1 

Marks 
[] Registration Marks [] Trifll Marks 

Offsets: Horizontal IID!I!I inch 

Vertical I B.BOI inch 

I OK I I Cancel I 

[]] In the Page Layout dialog, choose Letter in the Size 
pop-up menu. 

[1] Choose Landscape in the Orientation pop-up menu. 

[]] Choose Inches in the Unit of Measure pop-up menu. 

[§] Click on OK or press .J to exit the dialog. 

The drawing surface reflects the changes you made to the 
page layout. 

Registration marks, trim marks, and offsets are described 
in Chapter 3 of the Artline User Reference Guide. 
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Setting up the Workspace 

Setting up the Workspace 

Most of the commands in the View menu are toggles that 
turn certain commands on and off. 

When an item is turned To turn on the item, you choose the command. To turn off 
on, an arrow appears the item, you choose the command again. 
to the left of the 
command name in the 0 You use the Image command to show and hide bit-
View menu. image files when you are using the Autotrace tool. 

o You can turn off the Colors and Fountains com
mands while you are editing complex pictures to make 
screen drawing faster, and to better see the outlines of 
your elements. Elements with fountain fills display 
"Fa's" when fountains are turned off. For this chapter, 
leave colors and fountains turned on. 

o You can use the Status Line command to display the 
status line, which shows the default fill and line color, 
selected tool, number of selected elements, and other 
parameters depending on the tool that is selected. The 
default fill color is hollow; the default line color is 
black. 

o The Guide Lines command displays a horizontal and 
a vertical line that intersect in the center of the work
space. You can drag the guide lines or use the Set 
Guide Lines command to change their position. You 
can use the guide lines to align elements; you can use 
the intersection as a rotation point. 

o You can use the Toolbox command to turn off the tool
box to make more room in the workspace. While you 
are doing the exercises in this tutorial leave the Tool
box turned on. 

The following exercises use the remaining commands in 
the View menu. 
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Setting up the Workspace 

Setting the Grid 

Type directly into the 
highlighted field, or 
use the pop-up slider. 

The grid allows you to align objects precisely. 

To set the grid: 

[]] Choose Set Grid from the View menu. 

The Set Grid dialog appears. 

Set Grid 
Spacing 
Uertical I 0.251 inch 

Horizontal I~I inch 

I OK I I Cancel I 

~ Under Spacing, enter 0.25 (inches) for the Vertical 
spacing. 

[]] Click in the Horizontal field to highlight it, and enter 
0.25 for the Horizontal spacing. 

[]] Click on OK or press .J to close the dialog. 

[]] Display the View menu again and choose Grid. 

Dots appear on the screen at .25 inch intervals. The 
vertical and horizontal rows of dots cross at one inch 
intervals. 

Turning on the Rulers 
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The rulers help you to accurately judge the size of your 
drawing. 

To turn on the rulers: 

Choose Rulers from the View menu. 

The rulers appear at the top and left sides of the 
workspace, in one-inch increments. 

You are now ready to draw. 
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Using Basic Drawing Tools 

Using Basic Drawing Tools 

In this section, you'll draw this picture using these tools: 

o Rectangle and Circle tools 
o Scale and Rotate menu commands 
o Line Width, Line Color, Fill Color, and Fountain tools 

Correcting Mistakes 

You can cancel certain commands by choosing Undo from 
the Edit menu. 

If you are dissatisfied with the wayan element appears, 
select the element and choose the Delete command from 
the Edit menu, or press Alt-E to erase it and start over. 
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Using Basic Drawing Tools 

Drawing a True Square 

Rectangle tool 

The Ctrl key constrains 
the rectangle to a 
square. 

You can also double
click on the Rectangle 
tool and check Draw 
Squared in the Rectan
gle Options dialog to 
draw a true square. 
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When drawing measured lines or curves, it is helpful to 
use the Snap to Grid command, which causes elements 
to align with the nearest grid point. For this exercise, 
choose Snap to Grid from the View menu. 

You start by drawing the largest square in the picture on 
page 2-5. 

To draw a true square: 

IT! Select the Rectangle tool. 

The pointer becomes a crosshair. 

[]::I Place the crosshair on the drawing surface next to 
the grid point located at 2" on the vertical ruler and 
2" on the horizontal ruler. You will be drawing a four
inch square. 

[]] Hold down the Ctrl key and drag the crosshair away 
from the grid point. 

As you drag, an outline previews the square that you 
are drawing. 

[±] Release the mouse button when the square is 4" tall 
by 4" wide, at the grid point located at 6" on the verti
cal and horizontal rulers. 

Leave the square selected. 
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Using Basic Drawing Tools 

Scaling the Square 

You can now use the Scale command to make the smaller 
square. 

To make the smaller square: 

OJ Choose the Scale command from the Edit menu. 

[]] The Scale Elements dialog appears. 

Uniform and Selection Center are already turned on. 

Scale Elefllents 
Scale 
@ Uniforfll o Non-Uniforfll 

Size jlh1\% 
Relative To 
@ Selection Center 

[gJ Make Cop~ 

o ThuMbtack 
o Guide Lines 

I II Cancel I OK 

[]] In the Size field, type 75 (%), or use the pop-up slider. 

[±] Click in the Make Copy box to turn it on. An X ap
pears in the box. 

[§] Click on OK or press.J to exit the dialog. 

A copy of the square, scaled to 75% of its original size, 
appears inside the original square, with the selection 
frame around it. Leave it selected. 

-I - - - - - - - - - - -
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Using Basic Drawing Tools 
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Rotating the Square 

You can make a diamond with the Line tool or the Quill 
tool, but it is easiest to simply rotate a square. 

Make sure the second square is still selected. 

To make the diamond: 

[JJ Follow steps 1 through 4 above to scale and copy the 
second square, but this time scale it to 70%. 

You now have a third square selected, inside the 
other two. 

[]] With the new square selected, choose the Rotate com
mand from the Edit menu. 

The Rotate Elements dialog appears. 

Rotate EleMents 
Rotate Around 11I~~lo Rotation Angle 

@D Selection Center 
o ThuMbtack D Make COP!J 
o Guide Lines 

I I OK I Cancel I 

~ Leave Selection Center turned on. Type 45 (degrees) 
in the Rotation Angle field. Do not make a copy. 

QJ Click on OK or press.J to exit the dialog. 

Notice that the diamond's selection frame is in the same 
place as the selection frame for the second square. 

You will now add the last element, the circle. 
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Using Basic Drawing Tools 

Drawing a True Circle 
The Circle tool draws 
ellipses and circles. 

Circle tool 

Ctrl-drag draws true. 
Shift-drag draws from 
center. 

Next draw the circle inside of the diamond. To place the 
circle correctly, draw it from the center, instead offrom 
the upper left starting point. 

To draw a true circle from center: 

[I] Click on the Circle tool. The pointer becomes a cross. 

[1] Place the cross on the drawing surface at the exact 
midpoint of all the polygons-the grid point that in
tersects at 4" on the vertical ruler and 4" on the hori
zontal ruler. 

~ Hold down the Ctrl and Shift keys, then drag the 
cross away from the center in any direction. You will 
be dragging to the inside edge of the diamond. Be
cause the grid snap is on, you need to drag a small 
distance before you see the circle. As you drag, an 
outline previews the circle. 

[±] Release the mouse button when the circle is as close 
to the inside edge of the diamond as it can get, but be
fore it snaps to the outside of (or gets bigger than) the 
diamond. (It might not quite touch the sides of the di
amond on the screen.) 

The selection frame now surrounds the circle . 

. ~ . 

. ~ 
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Saving Your Work the First Time 

Saving Your Work the First Time 
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To save your picture in a file you must give it a name. 

To name and save a picture: 

OJ Choose the Save As command from the File menu. 

The Item Selector dialog appears. 

; Ite/ll Selector .. _ 
Directory: 
C:\ARTLINE\ARTWORK\*.GEM~ ________________________ ___ 

MI *.GEM 

BRIDGE .GEM 
HOUSE .GEM 
MOONMAN • GEM 
PLANE .GEM 
VIOLIN • GEM 
YACHT .GEM 
--'-
--'-
---

. 
~ 

-.. 

Selection: DRAWTEST. GE~ 

oq 
~ 

The Directory line shows you the current drive, direc
tory path, and a wildcard file specification, * .GEM, 
which means files with the .GEM filename extension 
are currently displayed in the directory window. 

Artline creates picture files with the . GEM extension 
only. 

The directory window displays the names of directo
ries (marked with a diamond) and files in the current 
directory, in this case, ARTLINE\ARTWORK. 

The cursor is on the Selection line. 

[]] Type a name for your picture, such as DRA WTEST. 

Artline automatically supplies the .GEM extension, 
so you do not need to type it. If you type the period, it 
is automatically placed before the filename extension. 
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Saving Your Work the First Time 

If you try to enter a different extension, Artline 
displays an alert asking you to re-enter the name. 

[]] Click on OK or press.J to exit the Item Selector. 

Artline displays a spinning ball while saving a file. 

Your picture is now in the file DRAWTEST.GEM in 
the ARTLINE\ARTWORK directory, and its name 
appears in the title bar of the Artline window. 

For detailed instructions on using the Item Selector, 
see Chapter 1 in the Artline User Reference Guide. 

NOTE: The next time you want to save changes, you need only 
choose the Save command from the File menu. Artline 
automatically saves your file under the name in the title bar. 

If you want to save a version under a different name, choose 
the SaveAs command again, and give the picture a different 
name, such as DRAWTST2.GEM. 

If you want to revert to the last saved version, choose the 
Abandon command from the File menu and do not save 
changes in the Abandon/Save alert. 
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More About Selecting Elements 

More About Selecting Elements 

The F4 function key 
selects the next ele
ment down in the stack. 

Ctrl-click selects the 
bottom element of the 
stack. 
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Elements are placed in a stack, in the order in which you 
create them, with the first-drawn element at the bottom 
of the stack, and the last-drawn element at the top of the 
stack. 

For the next exercise, click on the Selector tool. 

To practice selecting elements: 

[I] Click outside the design so that no element is se
lected. 

[]] Click in the circle to select the circle. The selection 
frame surrounds the circle. This is the top element. 

[]] Press F4 on the function keypad to select the next ele
ment down in the stack, in this case the diamond. 
The selection frame surrounds the diamond, which 
has the same boundaries as the smaller square. 

[]] Press F4 again to select the next element down, in 
this case the smaller square. Notice that the selec
tion frame appears in the same place. This is 
because the outer edges of the diamond are in the 
same place as the edges of the square. 

[]] Press F4 again to select the outer square. The 
selection frame moves to the outside of the design. 

Pressing F4 again de-selects the design, because 
there are no more elements under the large square. 

Here are some rules for selecting elements: 

o To select the top element of a stack, click on it. 
o To select the bottom element of a stack, place the 

pointer over the element, then press the Ctrl key 
while you click. When you start at the bottom, F4 
selects the next element toward the top of the stack. 

o To select more than one element at a time, click on the 
first element, then Shift-click on the next and 
subsequent elements. 
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Grouping Elements 

o To select more than one overlapping element at a time, 
click on the first element, then press Shift-F4 to select 
additional elements. 

o To select many elements, drag a selector box around 
the elements. 

o To de-select one selected element in a group of selected 
elements, Shift-click on the element. 

o To select all the elements on the drawing surface, 
choose the Select All command from the Edit menu. 
The Selector tool need not be selected to do this. 

Practice selecting the elements in this stack until you feel 
comfortable with a few of the methods. 

NOTE: When the selection frame for one element is in exactly the 
same place as the selection frame for another element, the 
selection frames seem to disappear. This is because they 
are actually two frames on top of one another and they 
cancel each other out. The elements are nevertheless se
lected. You can prove this by selecting all the elements, then 
dragging to move them. All the elements move. 

Grouping Elements 

When you group elements, the individual elements 
become one grouped element. Any change you make to a 
grouped element affects all the elements in the group. 
The individual elements cannot be modified until you 
ungroup the element. 

To group elements: 

OJ Choose Select All from the Edit menu or type the 
keyboard shortcut Alt-S. Or, you can drag a selector 
box around the outside of the elements. 

All the elements in the picture are selected. 
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Changing the Line Width 

[]] Choose Group from the Element menu or type the 
keyboard shortcut Alt-M (for Make Group). 

[]] When the elements are grouped, their selection 
frames are replaced by a single frame around the 
picture. 

Chapter 6 of the Artline User Reference Guide 
discusses the attributes of grouped elements in detail. 

Changing the Line Width 

Line width tool 

2-14 

It is easiest to change the line width of many elements at 
once when they are grouped. 

For this exercise, make sure the now grouped element is 
selected. 

Make sure also that colors and fountains are turned on in 
the View menu. When colors are turned off, you cannot 
see a thick line. 

To change the line width: 

ITJ Click on the Line Width tool to display the pop-up 
menu. 

This menu provides line widths ranging from No Out
line to a custom option in which you can enter your 
own line width. 

No Outline 
8.883 inch 
8.887 inch 
8.815 inch 
8.823 inch 
8.831 inch 
8.839 inch 
8.847 inch 
8.855 inch 
Attributes ... 
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Changing the Line Width 

line Attributes 

Width 1_llltll inch 

Caps 0 < •• ) 0 Joins o. 
@ c:::J @ o. 
0 I· .10 @. 
o <; i> 0 

Pattern 1--1·11 OK I Cancel I 

[]] Choose the Attributes command from the bottom of 
the menu. The Line Attributes dialog appears: 

[}] Type 0.07 (inches) in the Width field. (This is the 
smallest width that makes a visible difference in Full 
View on a VGATMmonitor.) 

[::±] You can press on the Pattern pop-up menu to peruse 
the available line patterns, but for this exercise leave 
it set to the solid line. 

Caps and Joins are discussed in Chapter 2 of the Art
line User Reference Guide. 

[]] Click OK or press .J to exit the dialog. 

The element now looks like this: 
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Changing the Line C%r 

Changing the Line Color 

[]] 
Line Color tool 

While the element is grouped, you can change the line 
color of all the lines at once. Make sure the element is se
lected. 

To change the line color: 

OJ Click on the Line Color tool to display the color pal-
ette. ~---

- If you are using a monochrome monitor, you will 
see a palette containing shades of gray. 

- If you are using a color monitor, you will see a pal
ette of colors. 

~ Move the pointer over the colors. As a color is se
lected, a black border surrounds it, and its name ap
pears at the top of the color palette. 

[]] Click on the color Blue. The palette disappears and 
the lines turn blue, (or a dark gray pattern in mono
chrome). 

Leave the element selected. 

Ungrouping elements 
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To change the fill color of individual elements in the de
sign, it is necessary to ungroup it. 

To ungroup the design: 

Choose the Ungroup command from the Element menu, 
or use the keyboard shortcut Alt-B (Break Group). 

The selection frames appear around the individual ele
ments. Note that you see parts of the double selection 
frame surrounding the diamond and the small square. 
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Adding Fill C%r 

Adding Fill Color 

II 
Fill Color tool 

Make sure the Selector tool is selected. 

Click outside the design to de-select all the elements. 

When you select the Fill Color tool, you will see a palette 
of gray shades on a monochrome monitor, and a palette of 
colors on a color monitor. 

To color the design: 

[JJ Click on the circle to select it. 

[ill Click on the Fill Color tool to display the color palette. 

[]J Click on Cyan Light -1. The palette closes, and the 
circle is filled with the color. 

[] Press F4 to select the diamond, and repeat steps 2 
and 3 to color the diamond Yellow Light -1. 

!]] Press F4 to select the smaller square, and repeat 
steps 2 and 3 to color it Cyan Dark + 1. 

[]] Press F4 to select the larger square, and repeat steps 
2 and 3 to color it Magenta, or Magenta Light -3 if 
you are using a monochrome monitor. 

The design now looks similar to the picture at the begin
ning of this chapter. 
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Creating a Fountain Fill 

Creating a Fountain Fill 

~ ~ 
Fountain tool 
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A fountain is a gradual blending of one color into another. 
Artline gives you some preset fountains from which to 
choose, or you can create your own. 

To create a fountain fill: 

[}] Select the circle in the center of the picture. 

[ill Click on the Fountain tool to display the preset pal
ette of fountains. 

[]] Click on Add Fill at the bottom of the palette. 

The Add Fill dialog appears. 

[ Gradation 
@ Even 

Special ... 

o Log 

Add Fill 

IoIh1te 

Black 

r T9pe 
~ Radial 

Angle 00° 

@ Linear 

OK I I Cancel I 

[] Press on the bottom color box showing Black to dis
play the pop-up palette of colors, move the pointer 
down to the arrow next to more to scroll through the 
palette, and highlight Cyan Light -1. 

Cyan now appears in the bottom color box, and the 
sample fill shows a fountain from Cyan to White. 

[]] Press on the White color box at the top and repeat 
step 3, but this time highlight Magenta. 

Magenta fills the top color box, and the sample fill 
shows a fountain from Cyan to Magenta. 
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Creating a Fountain Fill 

[]] Place the pointer on the arrow tip in the sample box 
and press. The pointer changes to a crosshair. 

[1J Drag clockwise or counter clockwise until the arrow 
tip is pointing to a corner. Notice that the number of 
degrees in the Angle field changes automatically as 
you drag. 

[]] Release the mouse button. The linear fountain fills 
the example box at the new angle. 

[]] Drag the pointing arrow to the opposite corner. The 
bottom and top colors reverse in order in the sample, 
but remain the same in the color boxes. 

110 I Under Type, click on Radial. The example shows a ra
dial fountain fill made with the selected colors. 

[TIJ Under Gradation, click on Log (Logarithmic). The ex
ample shows a radial fountain fill with a logarithmic 
gradation. 

Chapter 12 of the Artline User Reference Guide de-
o scribes the Special Postscript fill options you can set 
from this dialog. 

1121 Click on OK or press.J to exit the dialog. 

The new fountain fills the circle. 

1131 Press F4 twice to select the smaller square. 

1141 Click on the Fountain tool to display the fountain list. 

Your new fill appears in the list, with the default 
name of Fill # 10. 

1151 Click on Fill # 10 to color the smaller square with 
your new fountain. The diamond and circle are re
drawn after the smaller square is filled. 

The new fill remains associated with this picture file, and 
does not appear in the default Artline fountain palette 
that is loaded when you choose the New command, or 
when you restart Artline. 

Creating, loading, merging, and saving color files is de
scribed in Chapter 12 of the Artline User Reference Guide. 
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Saving Your Work 

Saving Your Work 

To save your picture under a new name: 

[JJ Choose Save As from the File menu or type Ctrl-M. 

[]] When the Item Selector appears, type the new 
filename on the Selection line. 

IT] Click on OK or press .J. 

To save your picture under its existing name: 

Choose Save from the File menu or type Ctrl-V. 

Artline displays the spinning ball while saving. 

Printing Your Picture 
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Artline provides two ways to print your pictures: 

o PostScript command 
o To Output command 

You can use the PostScript command to: 

o print your picture directly to a PostScript printer; 

o make color separations; 

o output standard PostScript to a File, which creates a 
file that you can print from the operating system Print 
and Copy commands, or send to a phototypesetter; 

o output the picture to Encapsulated PostScript File for
mat (EPSF), which you can use to import into or print 
from other applications. 

Artline Tutorial 



Printing Your Picture 

The To Output command starts the Output program. 
You can use Output to: 

o print directly to a printer; 
o make a list of files to print all at once; 
o display files on the screen in a slideshow effect; 
o make transparencies with a camera. 

Chapter 3 of the Artline User Reference Guide describes 
the PostScript command extensively, and the Artline 
Utilities Guide describes the To Output command in de
tail. 

If your computer is connected to a PostScript printer, you 
can follow the steps in the section "Printing from the Post
Script Command" to print directly from that command. 

You can use the To Output command to print to a PostS
cript printer, a non-PostScript printer, or to the screen. 

If your computer is not connected to a printer, you can 
skip this section, or you can follow the instructions in the 
next section to display your picture on the screen. 

The section entitled "PostScript Command" in Chapter 3 
of the Artline User Reference guide tells you how to out
put your picture to a file that you can print on someone 
else's printer. 

Printing from the Output application 

In this exercise, you will use the To Output command to 
print the picture you created in this chapter. 

Be sure to save your picture before you begin. Otherwise, 
Artline displays the Abandon/Save alert, to which you 
must respond accordingly. 
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Printing Your Picture 
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To start Output: 

Choose To Output from the File menu or type the key
board shortcut Ctrl-U. 

The Output program loads into memory and displays the 
Output screen. 

The FILES TO PRINT window contains the name of the 
picture you just saved in Artline. 

The Pictures window is similar to the Artline Item 
Selector. 

To select an output device: 

The Devices window contains icons representing the 
screen and printer that you installed during Setup. The 
illustration above shows the PostScript printer icon in 
this window. 

D If you have more than one printer installed, click on 
the icon representing the one you want to use. 

D If you want to display on the screen, click on the screen 
icon. You do not need to set any screen options at this 
time. 
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Printing Your Picture 

Before you print on paper, you need to set the scaling and 
page size options, to ensure that your picture prints 
correctly. 

To set the scaling options: 

IT1 Click on the printer icon to highlight it. 

[]] Choose Page scale from the Options menu. 

[]] In the Printer Page Scale Options dialog, click on the 
Scale to page icon. 

[] Click on OK or press .J to exit the dialog. 

To set the page size options: 

IT1 Choose Paper Size from the Preferences menu. 

In the Printer Preferences: Paper Size dialog: 

[]] Choose the paper size that matches the paper in your 
printer. Many printers use Letter size (8.5 x 11.0 
inches.) 

[]] Press.J to exit the dialog. 

You are now ready to print. 

To print to the screen or printer: 

Click on the Start button in the upper left corner of the 
Output window. 

Output begins printing to the output device you selected. 

o To exit from a screen display, press the Esc (Escape) 
key. 

o To return to Artline, choose the To Artline command 
from the File menu. You can abandon changes to the 
.LIS file (a file you can create that contains the names 
of the pictures listed under Files to Print.) 

Output quits and Artline reloads and displays your pic
ture once again. 
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Printing Your Picture 
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Printing from the PostScript Command 

It is not necessary to save your file before choosing the 
PostScript command, but it is recommended. 

To print with PostScript: 

[JJ Choose the PostScript command from the File menu. 

The PostScript® Output dialog appears. 

PostScript® Out[ut 

r Device 
~ Output to 1 LPT 1 1·1 ~ of copies 1 .. 1 I 

Printer Paper 
Size 1 Letter 1.11 Portrait '·1 11.00 )( 8.S0Snch 

Scaling @ Fit to Paper 0 ~% 

Options 
Separation 1 None 1·1 I I OK 
1 Screen 0etions .•• 1 I Caned I 

In the Device section: 

~ Next to Output to, press on the pop-up menu to dis
playa list of printer ports. Choose the port name to 
which your printer is attached. 

~ N ext to # of copies, leave 1 selected, or enter a differ
entnumber. 

In the Printer Paper section: 

[]] Next to Size, choose a paper size that matches the 
paper in your printer. 

[§] Choose Landscape from the second pop-up menu. 

[§] Click on Fit to Paper. 

The Options section is explained in detail in Chapter 
3 of the Artline User Reference Guide. 

[] Click on OK or press -l to exit the dialog. 
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Printing Your Picture 

What You Learned 

You now know how to: 

o set the page layout; 
o set up the workspace; 
o use the grid; 
o draw true squares and circles; 
o select multiple elements and elements in stacks; 
o save your pictures; 
o use the Scale, Rotate, Group, and Ungroup commands; 
o use the Line Width, Line Color, Fill Color, and 

Fountain tools; 
o print your pictures. 

The next chapter shows you how to use all of the com
mands in the Combine menu to create interesting effects 
with text and elements. These are some of Artline's most 
powerful features. The exercises are designed to teach 
you the concepts through simple examples. 
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Working With Text 
and OJrher Elements 

THIS CHAPTER shows you how to use more of the tools and the 
commands in the Combine menu to create special effects with a 

combination of text and elements. 

All of the commands and tools are fully described in the 
Artline User Reference Guide. 

The commands in the Combine menu are described in 
Chapter 8 of the Artline User Reference Guide. 

What is in this chapter: 

o blending elements 
o placing text along a path 
o masking elements 
o converting text to curves 
o merging elements 
o using the rolling pin 
o rotating elements 
o using the thumbtack 
o flipping elements 
o shadowing text 

3-1 



Preparing the Workspace 

Preparing the Workspace 

3-2 

For all of the exercises in this chapter: 

o Start Artline, or choose the New command from the 
File menu to start with a new drawing surface. 

o Choose Full View from the View tool pop-up. 

o Choose Page Layout from the File menu; set the Page 
Size to Letter, the Orientation to Landscape, and the 
Unit of Measure to Inches. 

o Turn on Colors and Fountains in the View menu. 

o Turn on Rulers in the View menu. 

o Turn off Snap to Grid in the View menu. 

o Choose Preferences from the Options menu and set 
the Redraw Speed to Quality. 

o If you like working with the status line, turn it on in 
the View menu, but it is not necessary for these 
exercises. 

o After each exercise, clear the screen and keep the same 
settings listed here. If you like the examples you make 
in this chapter, you can save them. 

Each exercise in this chapter will take about ten or fifteen 
minutes to complete. 
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Blending Elements 

Blending Elements 

You cannot blend ele
ments containing 
fountains. 

Artline blends from the 
bottom element on the 
stack to the top ele
ment. 

Artline lets you blend one shape and its color into an
other. This exercise shows you how to use the Blend com
mand to do this. 

To blend two elements: 

[] Draw a rectangle in the bottom left corner of the 
screen, about 1.5 inches wide and 1 inch tall. 

[]] Click on the Fill Color tool to display the color palette 
and choose Magenta. Do not use the Fountain tool. 

[]] Draw a circle in the upper right corner of the screen, 
about 1 inch in diameter. 

[±] Color the circle Cyan. 

[]] Select the square, then Shift-click to select the circle. 

o 
[]J Choose the Blend command from the Combine 

menu. The Blend Elements dialog appears. 

Blend Elertlents 

~ of Steps: 

[] Reverse Curve Direction 

OK I I Cancel I 
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Blending Elements 

3-4 

[1J In the # of Steps field, type 25. 

[]] Click on OK or press .J to exit the dialog. 

The square blends into the circle, and magenta grad
ually blends into cyan, in 25 steps. 

[]] While the new element is selected, choose the Split 
Element command from the Combine menu. 

The square and circle are once again separate. You can re
peat steps 6 through 8 to blend them again. 

NOTE: To redisplay the Blend Elements dialog and modify the 
number of steps, use the Selector tool to double-click in the 
selection frame of the blended element. 

If another tool is selected, you can hold down the Alt key 
while you double-click in the selection frame, to redisplay 
the Blend Elements dialog. 

You can save this picture, or simply clear the drawing sur
face for the next exercise. 

To clear the drawing surface: 

Choose the New command from the File menu. 

If you made changes and did not save your picture, re
spond appropriately to the Abandon/Save alert. 
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Placing Text Along a Path 

Placing Text Along a Path 

Artline lets you place text along a selected path that you 
create, for example, a curve or a circle. 

In this exercise you will make this picture: 

Drawing the Path 

If you start drawing 
with the Quill tool, 
choose New and start 
over. Chapter 4 
teaches you how to 
use the Quill tool. 

To start, you will use the Sketch tool to make the path. 
The Sketch tool lets you draw freely, as if you were sketch
ing with a pencil. 

To draw the path: 

Sketch tool 

When you release the 
mouse button, the line 
disappears briefly while 
Artline constructs the 
curve. 

[]] Select the Sketch tool. The pointer changes to a 
cross. If you see a crosshair in a circle, you have se
lected the Quill tool. Select the Sketch tool instead. 

[]] Place the cross on the grid point at the intersection of 
3 on the vertical ruler and 1 inch on the horizontal 
ruler. 

[]] Press the mouse button down and begin dragging to 
make the downward curve, and then the upward 
curve. 

[]] Release the mouse button at the end of the curve, on 
the right side of the drawing surface. 

The spinning ball is displayed, and then the line appears 
on the drawing surface, surrounded by the selection 
frame. 
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Placing Text Along a Path 

Text tool 

3-6 

This might take some practice. If you are not satisfied, de
lete the line and start over. It is not necessary for your 
path to look just like the path in the picture. 

Chapters 4 and 5 show you how to draw curves with the 
Quill tool and edit them with the Plane tool. 

Remember that you can move the line when it is selected. 

When you have a path you like, go on to the next step. 

[]] Select the Line Width tool and choose 0.078 inch 
from the pop-up menu. The line becomes wider to re
flect the new setting. 

You can save your work to this point, then continue with 
the next series of steps. 

NOTE: It is a good idea to save your picture at the end of a series of 
steps that is followed by another series of steps. This way, 
if you do not know how to fix an error, you can revert to the 
last saved version and re-start the next series without 
beginning the whole exercise from scratch. 

Creating the Text 

Artline provides a variety of typefaces, styles, and sizes 
for you to use when working with text. This exercise 
shows you how to use the Text tool to create text. 

To create the text: 

!JJ Click on the Text tool to select it. The pointer 
changes to an I -beam text cursor. 

[]] Move the text cursor onto the drawing surface, away 
from the path you just made, and click. The Create 
Text Element dialog appears. Fill it out as shown. 
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Placing Text Along a Path 

Create Text Ele~ent 

Font 

Size 

Align 

1 Scholar Nor~al 

1 72 I ... ' pts on 

IRoller (Daste~ 

1 72 

o Auto Kerning 

Sample LQ!L~ I Cancel I 

This dialog is discussed in greater detail in Chapter 2 
of the Artline User Reference Guide. 

[]] Press on the Font pop-up to display a list of fonts, 
move the pointer down until Scholar Normal is 
highlighted, then release the mouse button. 

"Scholar Normal" now appears next to Font in the dia
log. 

Note the word "Sample" under the Text window. 
Sample is always displayed in one point size, but the 
typeface changes to match the font showing in the 
Font field. 

[]] Press on the Size pop-up and choose 72 (points). The 
number 72 appears in the Size field. (Changing the 
text size is unnecessary, but it makes it easier to read 
the text.) 

[]] Type Roller Coaster in the text window. If you 
make a mistake, you can use the Backspace, Delete, 
and arrow keys to move the cursor and correct the 
mistake. 

Do not press Enter after you type the line, because 
that will move the cursor to the second line in the 
text window, instead of exiting the dialog. 
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Placin{J Text Along a Path 

To edit the text, select 
it, then double-click to 
redisplay the Create 
Text Element dialog. 

[]] Click on OK to exit the dialog. The words "Roller 
Coaster" appear on the drawing surface in 72 point 
Scholar N onnal, and are surrounded by the selection 
frame. 

Notice that the text is outlined. Artline lets you fill 
text with colors and fountains, and set the line color 
and width. 

[1J With the text selected, click on the Fill Color tool and 
select Light Gray. The text is filled with Light Gray. 

Combining the Text and Path 

3-8 

To complete the placement of the text, you must select the 
text and the path, then use the Text Along Path com
mand in the Combine menu. 

To combine the text and path: 

[] Click on the Selector tool and drag a selector box 
around the path and the text. 

[]] Choose the Text Along Path command from the 
Combine menu. The Text Along a Path dialog ap
pears. 

Text ~long a Path 
Text Scaling 
a None 
a Change Spacing to Fit 
~ Change Size to Fit 

Options 
!8l Show Path 
!8l Rotate Text around Path 

I OK I I Cancel I 

Artline Tutorial 



To re-display the Text 
Along a Path dialog, 
double-click on the 
selected element. 

Placing Text Along a Path 

[]] Under Text Scaling, click on Change Size to Fit. 

- Change Spacing adds or deletes space between 
characters, but does not change the point size. 

- Change Size changes the point size to fit the path. 

[!] Under Options, click on Show Path. 

- Show Path includes the path with the element. 

- Rotate Text around Path orients each character ac-
cording to the curve or angle of the path. This is 
the default. Leave it checked. 

When this option~~not checked, the characters fol
low the path, but are all upright. 

[]] Click on OK or press.J to exit the dialog. 

The text ,is combined with the path, and the selection 
frame surrounds the combined element. 

The best way to see the differences in the options is to re
display the Text Along a Path dialog and try them. 

Splitting Text Along a Path 

While the combined element is selected, you can choose 
the Split Element command from the Combine menu to 
separate them again. 

Selecting with the Alt key 

Most of the time you can select an element without first 
clicking on the Selector t~?l. 

o To select an element~li~n a different tool is selected, 
hold down the Alt key while you click on the element. 

o To select a second element, press Alt while you Shift
click. 

Clearing the Drawing Surface 

To clear the screen for the next exercise, choose New from 
the File menu and respond appropriately to the Aban
don/Save alert. 
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Masking Elements 

Masking Elements 
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Artline lets you place an element on top of a particular 
pa ttern or design so the design shows through. This ef
fect is called masking. In the following exercise, you will 
use the Mask command to make this picture: 

Creating the Text 

You begin by making the text to contain the design. The 
text, in this case, is the mask element. The design is the 
mask background. 

To make the text: 

IT] Click on the Text tool, then click in the center of the 
drawing surface to display the Create Text Element 
dialog. Fill it out as shown. 

Font 

Size 

Align 

Create Text Elenent 

1 Advantage Bold 

1 140 I'" pts on 1140 

D Auto Kerning 

Sample I OK ~ I Cancel I 

[]] In the Font pop-up, choose Advantage Bold. 
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Masking Elements 

[]] In the size pop-up, choose Custom, type 140 points 
in the New Size field, then click on OK. 

[!] In the text window, type MASK. Use all capital 
letters. 

[[] Click on OK to exit the dialog. 

The word "MASK" appears on the drawing surface in 
140 point Advantage Bold. 

Converting Text for Masking 

Once you convert text 
to curves, you can no 
longer edit it as text. 

In order to use text as a mask element, you must change 
it into a single non-text element. To do this, first convert 
it to curves, and then merge it into one element. 

To convert text to a single non-text element: 

[]] Select the text. The selection frame surrounds it. 

[]] Choose the Convert to Curves command from the 
Combine menu. The text is now grouped. You cannot 
use grouped text as a mask element. 

[]] Choose the Ungroup command from the Element 
menu. A selection frame surrounds each letter. 

[!] Choose the Merge Elements command from the 
Combine menu. A selection frame surrounds the now 
merged element-a single graphic element equiva
lent to elements drawn with the other tools. 

NOTE: You can use the Split Element command to split merged 
elements. When you split merged text, letters such as "i" 
and "0" that are composed of two parts are split into separate 
elements. 

Now you are ready to make the pattern to display inside 
the text-the mask background. 
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Masking Elements 
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Making the Mask Background 

The mask is made from five rectangles arranged in a col
umn. Later, each is filled with a different color, and all 
five are set to No Outline. Before you add the color and 
remove the outline, the result looks like this: 

To make the design for the mask element: 

[]] Click on the Rectangle tool, then draw a rectangle 
about 0.5 inch high and 5 inches long. Leave the rec
tangle selected. 

[}] Choose the Element Info command from the Ele
ment menu. The Element Settings dialog appears. 

Elel!lent Settings 
Position & Size 
Vertical ~ Width ~ 
Horizontal ~ Height ~ 

This elel!lent has 5 points. 

I OK II Cancel I 

- The Vertical and Horizontal fields show the ruler 
settings for the upper left corner of the rectangle. 

- The Width and Height fields show the width and 
height of the rectangle. 

You can use these fields to set an element to an exact 
measurement. 

(The number of points refers to the number of anchor 
points, which are discussed in Chapters 4 and 5.) 
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Masking Elements 

[}] In the Width field, type 5.0. In the Height field, type 
0.5. This sets the rectangle to exactly 0.5 inch by 5 
inches. 

[]] Click on OK or press.J to exit the dialog. 

The rectangle adjusts to the exact measurement. 

[]] Choose the Move command from the Edit menu. The 
Move Elements dialog appears. 

Move Elelllents 

Horizontal 

Vertical 

t8l Make COP!I 

~ inch 

~ inch 

OK I I Cancel I 

- Leave the Horizontal field set to 0.0. 

- In the Vertical field, type 0.5 inches. 

- Click on Make Copy. 

- Click on OK to exit the dialog. 

The copy appears under the original. Leave it se
lected. 

[ill Choose the Repeat command from the Edit menu, or 
type Alt-Fl. A third rectangle appears under the sec
ond one. 

[1J Choose the Repeat command two more times, to 
make a total of five rectangles. 

The rectangles should be touching each other, flush 
against each other, making a vertical column. 

Now you are ready to color the rectangles. This is a 
good time to save your work so far. 

Working With Text and Other Elements 3-13 



Masking Elements 
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Coloring the Rectangles 

A mask background cannot contain a fountain. It can, 
however, contain a blend. For this background you color 
each rectangle individually. You will be using the Selector. 

To color the rectangles: 

[]] Click on the top rectangle to select it. 

[]] Click on the Fill Color tool and choose Cyan Light -l. 

[]] Color the second rectangle Cyan Dark + l. 

QJ Color the third rectangle Magenta. 

[]] Color the fourth rectangle Blue. 

[ill Color the bottom rectangle Blue Dark +2. 

[1] Select all the rectangles and choose Group from the 
Element menu. 

The rectangle is colored and grouped, but it still has 
black lines (or whatever default line color is current 
in the Line Color palette) around all the component 
rectangles. 

[]] With the grouped rectangle selected, click on the Line 
Width tool and choose No Outline from the pop-up. 
This turns off the outlines around the rectangles. 

Resizing the Text 

You should now make sure the text fits inside the colored 
rectangle, and that it includes all of the colors, before you 
combine the text with the rectangle. 

To check the text: 

[]] Drag the text so that it is centered inside the rectan
gle group. 

Because you made the text first, it is underneath the 
rectangle, but you can still see its selection frame. 
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You can use Ctrl-click 
to select the element 
on the bottom of the 
stack. 

Masking Elements 

[]] With the text selected, choose the Bring to Front 
command from the Element menu. You can now see 
the text. 

~ Adjust the text so it includes all the colors, but is not 
larger than the colored rectangle. 

Ifit is too small to include all the colors, or too large, 
you can drag one of the object handles on the selec
tion frame to change the size. 

- The middle handles change the height or width. 

- The corner handles change the height and width. 

Combining the elements 

When Draw Mask Ele
ment is checked, you 
can see the outline of 
the text. 

You are now ready to combine the elements into the mask. 

To create the mask effect: 

W Drag a selector box around both elements to select 
them. Selection frames surround both elements. 

[]] Choose the Mask command from the Combine menu. 
The Mask Elements dialog appears. 

Mask Ele(l1ents 

[] Draw Mask Ele(l1ent 

OK I I Cancel I 

~ Click on OK or press.J to Exit the dialog. 

The text now appears in the five colors of the rectangle, 
and you have created the mask effect. 

You can double-click on the selected mask to re-display 
the Mask Elements dialog. 

To restore the masked element into its original compo
nents, choose the Split command from the Combine 
menu. 

Choose the New command and respond appropriately to 
the Abandon/Save alert. 
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Merging Elements 

Merging Elements 
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Artline lets you merge two or more elements into a single 
element. 

o When there are an odd number of layers overlapping, 
the areas where the original elements overlap become 
solid. 

o When there are an even number of layers overlapping, 
the areas where the original elements overlap become 
hollow. 

NOTE: Hollow means that the object has no fill color, so you can see 
through it to whatever is underneath. This can be other fill 
colors or lines, or the drawing surface on your screen, which 
ultimately represents the film or paper on which you print. 

You have already used the Merge Elements command to 
merge text into a single element. 

Here is a simple exercise to show you the effect ofmerg
ing three elements-a large rectangle, a circle, and a 
smaller circle inside the first. You will make this picture: 

There are many ways to draw and color the lines and 
curves in this picture, but merging is the simplest way to 
do it. 
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Drag with the Selector 
tool, or press Shift·F4 
to select overlapping 
elements. 

Merging Elements 

To merge three elements: 

[I] Draw a rectangle like the one in the picture. 

[]] Draw the larger circle, about the same size as the one 
in the picture. Make sure it overlaps the rectangle 
about half way. 

[]J Draw the smaller circle inside the larger circle, also 
overlapping the rectangle half way. 

[±] Select all three elements, then click on the Fill Color 
tool and select Black. All three elements are now 
black. 

em While the three elements are selected, choose the 
Merge Elements command from the Combine menu. 

The three elements are combined into a single merged ele
ment. 

To clear the drawing surface for the next exercise, choose 
the New command from the File menu and respond ap
propriately to the Abandon/Save alert. 
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Using the Rolling Pin with Text 

Using the Rolling Pin with Text 

Text tool 

3-18 

Artline lets you use the Rolling Pin to skew or distort ele
ments. You can create interesting effects with text, place 
diagonally oriented colors on a masking background, or 
create other pictorial effects. 

In this exercise, you will use the Rolling Pin on text to 
make something like this picture: 

Creating the Text 

You start by creating the text. 

To create the text: 

[] Click on the text tool, then click in the drawing sur
face to display the Create Text Element dialog. 

~ Fill out the dialog like this: 

- Choose a font from the Font pop-up, or leave the 
default font selected. 

- Choose 72 points from the Size pop-up, so the text 
will be large enough to see the effects easily. 

- Type Rolling Pin in the text box. 

[[] Click on OK to exit the dialog. 

The text appears on the drawing surface. 

[!] With the text selected, click on the Fill Color tool and 
choose a color from the color palette. The text is col
ored. 

[]] Click on the Line Color tool, and choose another color 
for the outlines around each letter. 
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Rolling Pin 

Using the ROiling Pin with Text 

Converting Text to Curves 

To use text with the Rolling Pin, you must first convert it 
to curves. 

To convert the text to curves: 

[]] Select the text ifit is not already selected. 

~ Choose the Convert to Curves command from the 
Combine menu. The text changes to curves. 

Using the Rolling Pin 

Now you can use the Rolling Pin to skew the text like the 
picture. 

To skew the text: 

[]] Click on the Rolling Pin tool. 

~ Place the pointer over the handle in the upper right 
corner of the selection frame. 

[ill Drag the handle diagonally about one inch toward 
the upper right corner of the screen. 

The selection frame extends out at an irregular 
angle, indicating the degree to which the text will be 
skewed. 

The text now looks something like the picture at the 
beginning of this section. 

You can experiment with the Rolling Pin to learn its 
effects. 

o You can drag a corner handle vertically, horizontally, or 
diagonally. Dragging a corner handle diagonally skews 
the text in two directions at once-for example, up and 
to the right, or down and to the left. 

o You can drag midpoint handles horizontally or 
vertically, but not diagonally. 
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Rotating Elements 

Roi"ai"illg Elemer,1"s 

Rotator tool 
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Artline gives you several ways to rotate elements. You 
have already used the Rotate command to rotate a 
square in Chapter 2. This section shows you how to use 
the Rotator tool and the Thumbtack to rotate elements. 
In this exercise you first practice rotating this ellipse: 

c: ~ ---------------------

Using the Ro1"a1'or Tool 

To rotate an ellipse: 

[] First, draw a horizontal ellipse about 4.5 inches long 
and 0.5 inch high in the center of the workspace. 

[]J You can use the Element Info command to precisely 
set the measurement if you like. Leave the ellipse se
lected. 

[]] Double-click on the Rotator tool to display the Rota
tor Options dialog. 

Rotator Options 
Rotate Around Rotate Elelllents As -

@D Selection Center @D Selection Frallles 
o Thulllbtack o Outlines 
o Guide lines 

Rotation Angle 'aMlo I OK I I Cancel I 

- Under Rotate Around, click on Selection Center, if 
it is not already selected. 

Selection Center rotates an element around the 
center of its selection frame. 
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Rotating Elements 

- In the Rotation Angle field, type 36 (degrees). 
This means the element can only be rotated in in
crements of 36 degrees. (When this field is set to 
0° you can rotate an element freely.) 

- Under Rotate Elements As, click on either choice. 

Selection Frames displays the element's selection 
frame as you rotate it, and draws quickly. 

Outlines displays the element's outline as you ro
tate it, and can take longer to draw. 

[]] Click OK or press.J to exit the dialog. 

The Rotator Options are now set. 

[]] Click on the Rotator tool to select it. The pointer 
changes to an arrowhead. 

[§] Move the pointer to just above the top middle handle 
of the selection frame. (The pointer does not have to 
be on top of the ellipse or the handle to rotate it.) 

[1J Press down on the mouse button. A line appears be
tween the center of the selection frame and the 
pointer. 

[§] Drag the line clockwise until a new selection frame or 
outline appears, then release the mouse button. 

The ellipse snaps into the new position. 

Note that the new selection frame or outline appears 
only after you drag the line clockwise (or counter
clockwise) at least 36 degrees. 

[ill Practice doing this until the ellipse is horizontal 
again. Make sure the ellipse is selected. 
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Rotating Elements 

To de-select the 
ellipse, click on the 
Selector tool, then click 
outside the ellipse. 

Now you can use the Rotator tool to copy and rotate, to 
make this picture: 

You can also use the Rotate menu command (with Make 
Copy turned on) to accomplish the same thing, but for 
this exercise use the Rota tor tool. 

To rotate and copy the ellipse: 

3-22 

OJ Repeat steps 5 through 7 above, but this time press 
the Shift key while you drag the line, to copy and ro
tate the ellipse. 

A second ellipse appears in the new position. 

[]] Shift-drag three more times, or choose the Repeat 
command from the Edit menu three times, until you 
have a total of five ellipses rotated around center, as 
shown in the picture. 

The remaining steps in this sequence are to remind you 
about coincident selection frames. 

[]] Click on the Selector tool, then select each ellipse indi
vidually. 

Because the selection frames for two pairs of the ellip
ses are in exactly the same place, it looks like two el
lipses are selected. The status line shows you that 
one ellipse is selected. 

Artline Tutorial 



Rotating Elements 

[]] Choose Select all from the Edit menu. 

Notice that a selection frame appears briefly around 
each element and ultimately appears around only the 
horizontal ellipse. This is because the selection 
frames for the other two pair cancel each other out. 

[§] Choose Group from the Element menu. The selec
tion frame surrounds the entire design. 

Move this picture to one side of the drawing surface 
so you can compare rotating around the center to ro
tating with the Thumbtack. 

You are now ready to learn to use the Thumbtack to 
set a rotation point. 

Using the Thumbtack 

The Thumbtack lets you rotate an element around a spe
cific point other than the element's center. 

You can also rotate an element around the intersection of 
the guide lines. 

In this exercise you will make this picture: 
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Rotating Elements 

To rotate around the Thumbtack: 

Thumbtack 

3-24 

[]] Draw another ellipse, this time about 2.5 inches long 
and about 1 inch high. Again, you can use the Ele
ment Info command to set precise measurements. 

[ill Click on the Line Width tool and choose 0.078 inch 
from the pop-up menu. This makes the outline of the 
elli pse easier to see. 

[]] Double-click on the Rotator tool to display the Rota
tor Options dialog, select Thumbtack, then click on 
OK. 

The Rotator is now set to rotate around the Thumb
tack. 

[±] Click on the Thumbtack tool. 

[]] Move the pointer to a little below and left of center of 
the ellipse, as shown in the picture, then click to 
place the Thumbtack on the drawing surface. 

- To move the Thumbtack, click on it while the 
Thumbtack tool is selected. It disappears. Click 
again where you want to place it. It reappears. 

- To remove the Thumbtack, click on it while the 
Thumbtack tool is selected. 

Make sure the ellipse is still selected. 
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Rotating Elements 

[]] Click on the Rotator tool. 

[1] Press the Shift key while you drag the rotation line 
clockwise at least 36 degrees, then release the mouse 
button. 

A copy of the ellipse appears as before, but this time 
it is offset from center and is rotating around the 
Thumbtack. 

[§J Shift-drag or use the Repeat command in the Edit 
menu to repeat step 7 eight more times, to complete 
the circle of ten ellipses. 

If you want to group the ellipses, choose Select All from 
the Edit menu, Shift-click on the first picture to de-select 
it, then choose Group from the Element menu. 

You are now ready to save or abandon changes to clear 
the drawing surface for the next exercise. 
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Creating a Mirror Effect 

Creating a Mirror Effect 
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You can use the Flipper tool to flip elements or flip and 
copy elements at an angle you control. 

In this exercise, you copy and flip to make this picture. 

To create the text: 

Start by creating the text. 

[]] Click on the Text tool, then click in the center of the 
drawing surface and fill out the Create Text Element 
dialog like this: 

- Choose Advantage Bold from the Font pop-up 
menu. 

- Choose Custom from the Size pop-up and type 140 
(points), then click on OK. 

- Type MIRROR in all capital letters in the text 
window. 

- Click on OK to exit the dialog. 

Leave the text selected. 

[]] Click on the Selector tool, place the pointer inside the 
selection frame, press until you see the hand, and 
move the text to the center of the workspace. 
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Flipper tool 

Fill Color tool 

To flip and copy the text: 

[]] Click on the Flipper tool. 

Creating a Mirror Effect 

[]] To show Artline a line to flip an element across, you 
drag a flip line. Place the pointer on the bottom line 
of the text, approximately in the center (in this case, 
between the two R's). 

[]] Press the Shift key while you drag horizontally. The 
flip line extends from the pointer in two directions. 
When the flip line is long enough, a selection frame 
appears showing where the copy will be placed. 

If you don't like the position of the preview, make the 
flip line shorter. When the preview disappears, re
lease the mouse button. 

Artline displays an alert stating the flip line is too 
short. Click on OK and start over. 

[] When the preview is visible, release the mouse 
button. 

The copy appears in a mirror image under the origi
nal. 

To color the design: 

[]] Select the original word, click on the Fill Color tool, 
and color it Black. 

[]] Select the mirrored second word, click on the Fill 
Color tool, and color it Light Gray. 

To clear the drawing surface for the last exercise in this 
chapter, choose the New command from the File menu 
and respond appropriately to the Abandon/Save alert. 
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More Special Text Effects 

More Special Tex"t Effects 
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This exercise shows you how to make this picture by creat
ing text, filling it with a fountain, and then creating a 
shadow effect. 

Creating the Text 

First, you need to create the text. 

To create the text: 

[]J Click on the text tool, and then click in the center of 
the drawing surface to display the Create Text Ele
ment dialog. 

- Choose Advantage Bold from the Font pop-up. 

- Choose Custom from the Size pop-up, type 140 
(points) in the New Size field, and click on OK. 

- Type SHADOW in the text window. Use all capital 
letters. 

- Click on OK to exit the dialog. 

The text appears on the screen with the selection 
frame around it. Leave it selected. 

[]] Click on the Selector tool, place the pointer inside the 
selection frame, press until you see the hand, and 
move the text to the center of the drawing surface. 
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More Special Text Effects 

~ Click on the Fountain tool to display the Fountain 
list, and select one of the preset fountains. 

The text fills with the fountain. Leave the text se
lected. 

[]] Choose the Duplicate command from the Edit menu. 
The duplicate appears below and to the right of the 
original, with the selection frame around it. Because 
you made it last, the duplicate overlaps the original. 
Leave it selected. 

[§] Click on the Fill Color tool to display the color pal
ette, and select Black. The duplicate fills with black. 

[]] Choose the Send to Back command from the Ele
ment menu. The picture now looks like this: 

The black duplicate is now in back of the original, or 
on the bottom of the stack. Leave it selected. 

This is a good time to set the Selector tool options to move 
the element as an outline instead of as a selection frame. 
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More Special Text Effects 
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Setting Selector Tool Options 

You can set Selector tool options to let you move objects 
more precisely. 

To set Selector tool options: 

OJ Double-click on the Selector tool. 

The Selector Options dialog appears. 

Selector Options 
Move EleMents As 
~ Selection FraMes 
o Outlines 

Handle Size g pixels 

I OK I I Cancel I 

The choices are: 

- Move Elements As Selection Frames means you 
see just the rectangular outline of the selection 
frame when you move an element. This is the fast
est method. 

- Move Elements as Outlines means you see the ac
tual outline of the object you are moving, which 
can take longer to draw, but allows you to place ob
jects more accurately. 

- Handle Size refers to the number of pixels in a han
dle. You can change this value if, for example, you 
want to make handles larger. 

~ Click on Outlines. 

[]] Click on OK or press.J to exit the dialog. 

Artline Tutorial 



More Special Text Effects 

Moving the Duplicate 

You can now easily perform the final step of the design, 
which is to move the shadow into place. 

To move the shadow: 

[JJ Click on the Selector tool, if it is not already selected. 

[]] Place the pointer inside the selection frame of the 
black copy, and move it up and to the left, to its final 
location as shown in the completed picture. 

Because the Selector is now moving elements as out
lines, it is easier to see exactly where to place the du
plicate. It might take several moves to place the 
black copy exactly where you want it. 

The result now looks similar to the picture. 

What You Learned 

You now know how to: 

o blend elements; 
o create, size, and move text; 
o place text along a path; 
o mask elements; 
o merge elements; 
o flip elements; 
o rotate elements; 
o use fountain fills with text; 
o shadow text. 

The next chapter shows you how to use the Quill tool to 
draw precise lines and curves. 
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More Special Text Effects 
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Drawing Lines and 
Curves with the Quill 

Ylf1HIS CHAPTER shows you step-by-step how to use the Quill tool 
JL to draw line segments, angles, and curves. 

When you want to draw a single line, it is easiest to use 
the Line tool. When you want several connecting line seg
ments, such as in a polygon, or when you need to fill an 
area created by line segments, it is more efficient to use 
the Quill tool. 

You can use the Sketch tool to draw the same curves as 
you draw with the Quill tool, but they will probably not be 
as smooth. You have already used the Sketch tool to cre
ate a curved segment in the section "Placing Text Along a 
Path" in Chapter 3. 

Chapter 5 shows you how to use the Plane tool to edit 
lines and curves. 

The exercises in this chapter will take about half an hour 
to complete. 

What is in this chapter: 

o drawing line segments 
o drawing polygons 
o drawing simple curves 
o drawing compound curves 
o adding a line to a curve 
o adding a curve to a line 
o changing the direction of a tangent line 
o tracing an ellipse 
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Drawing Line Segments and Polygons 

For all the exercises in this chapter: 

o Choose the Preferences command in the Options 
menu and set Redraw Speed to Quality. 

o Choose the New command from the File menu to clear 
the drawing surface. 

o Turn off Colors in the View menu. 
o Turn on Rulers in the View menu. 
o Choose Set Grid from the View menu, and ensure that 

vertical and horizontal spacing is set to 1 inch. 
o Turn on Grid in the View menu. 
o Turn on Snap to Grid in the View menu. 
o Click on the View tool and choose Full View. 

In this chapter you make small sample line segments and 
curves to learn how to use the Quill tool. You do not need 
to save any of the pictures; you can if you want to. 

After each exercise you can choose New, unless you are 
directed otherwise. 

Drawing Line Segments and Polygons 

Quill tool 

4-2 

This section shows how to use the Quill to: 

o draw line segments 
o draw polygons 

To draw a line segment: 

You click on the beginning and endpoints of the line and 
Artline draws the line between the two points. 

OJ Select the Quill tool and move the pointer onto the 
workspace. The pointer changes to a crosshair (cross 
within a circle). 

[]] Click in the workspace. Artline places a small hollow 
box at the point where you clicked. This is the first 
anchor point of the line. It marks where the line be
gins. 
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Artline will continue cre
ating lines until you 
double-click. 

Drawing Line Segments and Polygons 

The crosshair becomes a plain cross to indicate that 
the Quill is active, and that you have started to draw. 

[]] Click at the point where you want the line to end. A 
second hollow box appears, marking the second an
chor point, and Artline draws the line between the 
two points. 

[i] Double-click anywhere on the drawing surface to com
plete the line. This tells Artline you are finished 
drawing this element. 

[}] A selection frame surrounds the line, the cross reverts 
to a crosshair, and you can start a new element with 
the Quill. 

The line you drew begins and ends with anchor points. 
The line between these points is called a segment. 

In the next exercise, you use the Quill to draw a triangle. 

You can use the Line tool or the Quill tool to draw a trian
gle. With the Line tool, you must make three separate 
lines, or elements. Then, to fill the triangle, you must 
join the corners to make one element. With the Quill 
tool, the triangle is already one element containing three 
line segments, so it is more efficient to use the Quill to 
make a triangle. 

To draw the triangle: 

Artline snaps to the 
nearest grid point. 

[] Select the Quill tool. The pointer becomes a crosshair 
(cross within a circle). 

[]] Click at the points where you want the corners to be. 
Each time you click, a new corner point and straight 
line is added to the last one you drew. 

- To cancel the first corner point, double-click. The 
corner point disappears and the cross reverts to 
the crosshair. 

- To delete a corner point, press the Backspace key. 
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Drawing Simple Curves 

When two straight lines 
are joined at an angle 
by an anchor point, the 
point is called a corner 
point. 

NOTE: 

[ill Complete the element by double-clicking. 

The cross reverts to the crosshair, indicating that the 
Quill is active, but not in the process of drawing an el
ement. The triangle is complete. 

If you draw with the Quill and then choose another tool 
without first double-clicking to end the Quill element, then 
select the Quill again, anything you draw connects to the 
endpoint of the unfinished element. This can result in some 
unexpected line segments. Furthermore, you cannot select 
an unfinished Quill element. You must select the Quill and 
double-click to complete the element; then you can select it. 

Drawing Simple Curves 
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A simple curve flows in one direction, like a U. A com
pound curve flows in two directions, like an S. In this ex
ercise you connect many simple curves to make this 
picture: 

Drawing curves electronically is different from drawing 
them freehand. It will take some practice to get the feel 
of it. These exercises are designed to show you the princi
ples so you can create your own designs. 

When you draw a curve, Artline uses special anchor 
points to determine the size and direction of the curve. 

The length of a straight line is determined by the distance 
between the starting and ending anchor points. 
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A tangent line inter
sects with a curve at 
the tangent point. 

To cancel the first 
tangent point, double
click. 

To delete a tangent 
point, press the Back
space key. 

Drawing Simple Curves 

Similarly, the distance between the starting and ending 
points of a curve is also determined by the distance be
tween the starting and ending anchor points, but in a 
curve these are special anchor points called tangent 
points. 

For the following exercise: 

o Choose New from the File menu to clear the screen. 

o Make sure Colors is turned off and Snap to Grid is 
turned on, which makes this particular learning exer
cise easier to manage. 

To draw simple curves: 

[}] Select the Quill. The pointer changes to a crosshair 
(cross within a circle). 

~ Move the crosshair onto the grid point located at 4 
inches on the vertical ruler and 2 inches on the hori
zontal ruler. 

[[] Press and hold down the mouse button to set the first 
tangent point. Do not release the mouse button yet. 

l]] Drag straight down one inch to the grid point at 5 
inches on the vertical ruler and 2 inches on the hori
zontal ruler. As you drag, a line extends from the tan
gent point an equal distance in both directions. 
Points, called direction points, are at each end of the 
tangent line. 

[]] Before you release the mouse, the line looks like this: 

I • + 

[ill Release the mouse. 

[] The bottom portion of the tangent line remains, be
cause you dragged downward. 

Drawing Lines and Curves 4-5 



Drawing Simple Curves 

The height of the curve 
is determined by the 
length of the tangent 
line. 

The line now looks like this: 

[]] Place the cross one inch to the right of the first tan
gent point, on the grid point at 4 inches on the verti
cal ruler and 3 inches on the horizontal ruler. 

[]] Drag upward one or two inches, still holding the 
mouse button. As you drag the tangent line, the 
curve forms between the two tangent points. The far
ther you drag, the longer the line, and the deeper the 
curve. Drag back toward the starting point to 
shorten the curve. Still holding down the mouse but
ton, drag toward the right and then the left, to see 
what happens to the curve. As you drag a direction 
point, the curve changes direction. 

1101 Drag to the grid point at 3 inches on the horizontal 
and vertical rulers and release the mouse button. 
The curve now looks like this. 

[]I] Place the cross one inch to the right, near the grid 
point at 4 inches on the vertical and horizontal rulers. 

1121 Drag downward one inch, to the grid point at 5 
inches on the vertical ruler, and 4 inches on the hori
zontal ruler. Release the mouse button. 
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Drawing Simple Curves 

The curve now looks like this. 

H 
Vi 

~ 

1131 Move the cross one inch to the right and drag upward 
one inch. Release the mouse button. The curve now 
looks like this. 

~J 
. . ... ... 

1141 Double-click to close the curve. The cross reverts to 
the crosshair, and the selection frame surrounds the 
element. It now looks like this: 

The picture is almost complete. The next section shows 
you how to de-select an element while the Quill is active, 
and how to re-open an element drawn with the Quill. 

To de-select the element: 

Click on the Selector tool, then click outside the element. 
The element is de-selected. 
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urawing Compound Curves 

To re-open the element: 

[]] Click on the Selector tool if it is not already selected. 

~ Click on the element to select it. 

[]] Click on the Quill tool. 

[}] Double-click on the selected element. The selection 
frame disappears, the crosshair changes to a cross, 
and tangent lines and direction points appear around 
the last curve you drew. The picture looks just like it 
did before you closed the element in step 14. 

[ill Move the cross to the grid point one inch to the right 
of the last tangent point, then add two more curves in 
the same pattern. 

[]] Double-click to complete the picture. 

If you try this exercise with Snap to Grid turned off, you 
will be surprised at the versatility of the curves you 
create! 

Drawing Compound Curves 
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This exercise shows you how to draw a series of com
pound curves, like these: 

Choose the New command to clear the screen and re
spond appropriately to the Abandon/Save alert. Use the 
same settings as the last section, making sure that Snap 
to Grid is turned on and Colors is turned off in the View 
menu. 
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If the pointer is a cross, 
double-click to get the 
crosshair. 

To cancel the first 
tangent point, double
click. 

To delete a tangent 
point, press the Back
space key. 

Drawing Compound Curves 

To draw compound curves: 
ITJ Select the Quill tool. The pointer changes to a 

crosshair. 

~ Move the crosshair onto the grid point at 4 inches on 
the vertical ruler and 2 inches on the horizontal ruler. 

~ Press and hold down the mouse button to set the first 
tangent point. Do not release the mouse button yet. 

[]] Drag straight down one inch to the grid point at 5 
inches on the vertical ruler and 2 inches on the hori
zontal ruler. As you drag, the tangent line extends 
from the tangent point an equal distance in both di
rections, and the direction points appear at each end 
of the line. The line looks just the same as in the first 
exercise. 

em Release the mouse. The bottom portion of the tan
gent line remains, because you dragged downward. 

[§] Place the crosshair one inch to the right of the first 
anchor point, at the grid point at 4 inches on the verti
cal ruler and 3 inches on the horizontal ruler. 

[1] Drag downward again one inch, and release the 
mouse button. 

This time Artline makes a compound curve, because 
you dragged two tangent points in the same direction. 

The curve now looks like this: 

[]] Place the cross one inch to the right, on the grid point 
at 4 inches on the vertical and horizontal rulers. 
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Drawing Compound Curves 
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[]J Drag downward again one inch, to the grid point at 5 
inches on the vertical ruler, and 4 inches on the hori
zontal ruler, and release the mouse button. 

The curve now looks like this: 

. ,j 
~(r .. .. 

110 I Move the cross one inch to the right and drag down
ward one inch again. Release the mouse button. 

The curve now looks like this: 

lliJ Double-click to close the curve. The cross reverts to 
the crosshair, and the selection frame surrounds the 
element. 

To make a compound curve that moves in the opposite di
rection, repeat this exercise, but drag upward each time. 

Be sure to double-click to end the last element. 
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Connecting a Line to a CUNe 

Connecting a Line to a Curve 

To cancel the first 
tangent point, double
click. 

To delete a tangent 
point, press the Back
space key. 

Choose the New command from the File menu to clear 
the screen again, making sure that Colors are still 
turned off and Snap to Grid is on in the View menu. 

In the next exercise you make this figure to learn how to 
add lines to curves and curves to lines. 

To draw a line after a curve: 

IT] Select the Quill. The pointer changes to a crosshair. 

[]] Move the pointer to the grid point at 4 inches on the 
vertical ruler and 2 inches on the horizontal ruler. 

[]] Drag straight down one inch to the grid point at 5 
inches on the vertical ruler and 2 inches on the hori
zontal ruler, and release the mouse button. 

[]] Place the crosshair one inch to the right of the first 
anchor point, at the grid point intersecting at 4 
inches on the vertical ruler and 3 inches on the hori
zontal ruler. 

[]] Drag upward one inch to make a simple curve, then 
release the mouse button. 

The curve now looks like this: 
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l.,-onnecTlng a Line to a C;UNe 

To start over, press 
Backspace, then click 
to replace the line seg
ment. 

4-12 

[]] Place the cross one inch to the right, near the grid 
point at 4 inches on the vertical and horizontal rul
ers, and click to set the endpoint of the line segment. 
Do not drag. 

Artline draws a line between the last tangent point 
and the endpoint of the line. The direction point for 
the last curve remains. The figure now looks like this: 

[1] Move the cross to another point and click, to set an
other endpoint and draw another straight line. 

[§] Press the Backspace key to erase the last straight 
line and return to the figure shown in the last picture. 

Keep the curve and line just as it is and go on to the next 
section to learn how to add a curve to a line. 

To add a curve to a line segment: 

OJ Press down the Alt key, place the cross near the end
point of the line, and press the mouse button. A direc
tion point appears. 

[]] Drag the direction point downward one inch to the 
grid point at 5 inches on the vertical ruler and 4 
inches on the horizontal ruler, and release the mouse 
button. 

This creates a tangent line and changes the endpoint 
of the line to a tangent point like the ones in the pre
vious exercises. 

The picture now looks like this: 
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A curve meets a line at 
a junction point. 

Connecting a Line to a CUNe 

[]J Place the cross on the grid point at 4 inches on the 
vertical ruler and 5 inches on the horizontal ruler, 
and drag upward one inch, to the grid point at 3 
inches on the vertical ruler and 5 inches on the hori
zontal ruler. As you drag, a curve like the first curve 
appears. Release the mouse button. 

The picture now looks like this: 

~J 
. . .. .. 

[]] Double-click to close the element. The cross reverts 
to a crosshair and the selection frame surrounds the 
element. 

o:a 
To de-select the element, click on the Selector tool, then 
click outside the element. 

The next section shows you how to change the direction of 
a tangent line. You can skip it and go directly to the sec
tion "Tracing an Ellipse," if you want to practice drawing 
with the Quill without the grid snap. 
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Changing the Direction of a Tangent 

Changing the Direction of a Tangent 

Press Backspace to 
back up one anchor 
point. 

4-14 

Choose the New command to clear the screen again, and 
ensure that the settings for this chapter are still in effect. 

In this exercise you make this picture to learn how to 
change the direction of a tangent line that will affect the 
direction of the next curve. 

To make the symbol: 

ITJ Select the Quill tool. 

[]] Move the crosshair onto the grid point at 4 inches on 
the vertical ruler and 2 inches on the horizontal ruler. 

[]J Drag'downward one inch, to set the first tangent line, 
and release the mouse button. The lower direction 
point remains on the workspace. 

[]] Place the cross on the grid point at 4 inches on the 
vertical ruler and 3 inches on the horizontal ruler. 

[]] Drag upward one inch and release the mouse button, 
to set the second tangent line and create the first 
curve between the two tangent lines. The picture 
again looks like this: 
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Changing the Direction of a Tangent 

[]] Place the cross over the top direction point, the one lo
cated at 3 inches on the vertical and horizontal rulers. 

[}] Hold down the Alt key, and drag the direction point 
one inch clockwise to below and to the right of the 
grid point located at 4 inches on the vertical and hori
zontal rulers. Release the Alt key and the mouse but
ton. The picture now looks like this: 

o 0 t 

M ... ... 

[ill Place the cross on the grid point located at 3 inches 
on the vertical and horizontal rulers. 

[ill Press and hold down the mouse button to set a tan
gent point, then drag to the left one inch to make the 
second curve. Release the mouse button. The picture 
now looks like this: 

110 I Place the cross over the leftmost direction point, on 
the grid point at 3 inches on the vertical ruler, and 2 
inches on the horizontal ruler. 

ITI] Hold down the Alt key, and drag the direction point 
clockwise one inch, to the grid point at 2 inches on 
the vertical ruler and 3 inches on the horizontal 
ruler. Release the Alt key and the mouse button. 
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Changing the Direction of a Tangent 
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The picture now looks like this: 

: I\t 
U

Lt 

1121 Place the cross just below and to the right of the grid 
point located at 3 inches on the vertical ruler and 2 
inches on the horizontal ruler. 

1131 Drag downward one inch to make the third curve. 

H 

L? 
1141 Place the cross over the lower direction point, the one 

located at 4 inches on the vertical ruler and 2 inches 
on the horizontal ruler. 

~ Hold down the Alt key, and drag the direction point 
one inch to the left and upward, to the grid point at 3 
inches on the vertical ruler and 1 inch on the horizon
tal ruler. Release the AU key and the mouse button. 
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Changing the Direction of a Tangent 

1161 Place the cross on the first tangent point, the one at 4 
inches on the vertical ruler and 2 inches on the hori
zontal ruler. Drag to the right one inch, to make the 
fourth curve. Release the mouse button. 

11 71 Double-click to close the element. 

To de-select the element, click on the Selector tool, then 
click outside the element. 
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Tracing an Ellipse 

Tracing an Ellipse 

Double-click on the se
lected element to dis
play the Element 
Settings dialog. 

One of the best ways to learn to draw with the Quill is to 
trace existing curves. The idea is to use as few points as 
possible to accomplish the task. 

In this exercise you draw and trace an ellipse to get the 
feel of placing tangent points and drawing curves without 
the grid snap. 

For this exercise, choose New, then turn the Snap to 
Grid command off in the View menu. Leave all the other 
settings the same. 

To draw the ellipse: 

[IJ Click on the Circle tool to select it. The pointer 
changes to a cross. 

[1] Place the cross on the drawing surface and drag an el
lipse that is about 7 inches long and 3 inches high. 
You can use the Element Info command in the Ele
ment menu to help you. Place th~ ellipse in the cen
ter of the drawing surface, and de-select it, so it looks 
like this: 

To trace the ellipse: 

[IJ Click on the Quill tool to select it. The pointer 
changes to a crosshair (cross within a circle). 

Double-click to start [1] Move the crosshair to the top center of the ellipse. 
over. Align the horizontal line of the crosshair exactly on 

top of the ellipse, in the middle, and drag a tangent 
line to the right about one inch, so it looks like this: 
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Press Backspace to 
back up one point. 

Tracing an Ellipse 

[]] Place the cross on the right side of the ellipse, so the 
vertical line of the cross is exactly on top of the el
lipse, in the middle. Drag straight down to set an
other tangent line and create the first curve. Drag 
until your curve is as close to a copy of the ellipse as 
you can make it. It might take you a few tries to do 
this. The ellipse looks something like this: 

Note that when the Snap to Grid command is off, 
the tangent point appears exactly where you click. 
Note also how the curve changes as you drag the tan
gent line. 

[!] Move the crosshair to the bottom center of the ellipse. 
Align the horizontal line of the crosshair exactly on 
the ellipse, in the middle, and drag a tangent line to 
the left about one inch, so it looks like this: 

o 
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Tracing an Ellipse 
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[]] Place the cross on the left side of the ellipse, so the 
vertical line is exactly on top of the ellipse and oppo
site the point on the right. Drag upward to set the 
third tangent line, so the ellipse looks something like 
this: 

Note how you are placing tangent points along the 
path, following the direction of the curve from its 
starting point toward its finish. 

[§] Place the cross on the top again, where you placed 
the first tangent point, and again drag to the right 
about an inch, so the ellipse looks like this: 

[] 

[]] Double-click to finish the curve and return to the 
crosshair. 
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Tracing an Ellipse 

Using Fill Color with Open and Closed Elements 

When you start Artline or choose the New command from 
the File menu, the default fill color is Hollow, and the de
fault line color is Black. The default fill and line colors 
are displayed in two boxes on the left side of the status 
line. The fill color is on top; the line color is on the bottom. 

Any element you draw automatically has these default col
ors, until you select the element and choose a different 
color. 

You can set your own default color by choosing it in the 
color palette when no element is selected on the drawing 
surface. The default stays in effect until you restart Art
line. 

Keep the following in mind when drawing with the Quill 
and Sketch tools: 

o When the Fill Color palette is set to hollow, elements 
are not filled with any color or pattern. Hollow means 
the element is transparent and you can see through it. 

o When the Fill Color palette is set to any color, any ele
ment you make is automatically closed and filled, until 
you select the element and set it to Hollow in the Fill 
Color palette. 
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Tracing an Ellipse 

What You Learned 

4-22 

You now know how to use the Quill to: 

o set line endpoints, and draw lines and polygons; 
o set tangent points and tangent lines; 
o draw simple and compound curves; 
o correct mistakes; 
o change from lines to curves and vice versa; 
o change the direction of a tangent. 

You can also identify tangent lines, direction points, and 
the following types of anchor points: 

o tangent point: between two curves; 
o corner point: between two straight lines; 
o junction point: between a straight line and a curve. 

The next chapter shows you how to use the Plane tool to 
edit all elements in Artline. 
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Editing Curves 

THIS CHAPTER shows you how to use the Plane tool to edit ele
ments you create in Artline. In Chapter 4 you learned how to 

draw lines and curves with the Quill tool, and how to identify anchor 
points, tangent lines, and direction points. The Plane tool lets you 
modify all these components of an element. 

The exercises in this chapter center around editing an 
ellipse. By the time you are done editing the ellipse you 
will be able to use the Plane tool and all of the commands 
in the Plane tool pop-up menu. The exercises in this chap
ter will take about forty-five minutes to complete. 

For all of the exercises in this chapter: 

o Turn Grid off in the View menu. 
o Turn Colors off in the View menu. 
o Turn Snap to Grid off in the View menu. 
o Choose Full View from the View tool pop-up menu. 
o Choose Preferences from the Options menu and set 

Redraw Speed to Quality. 

What is in this chapter: 

o selecting and moving anchor points 
o editing tangent lines 
o using the commands in the Plane tool pop-up menu 
o making an equilateral triangle 
o making a 90° arc 
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Editing an Ellipse 

5-2 

In this exercise you draw an ellipse and practice basic ed
iting with the Plane tool. 

To draw the ellipse: 

[] Select the Circle tool. 

[]J Place the cross in the middle of the drawing surface. 

[]] Hold down the Shift key while you drag horizontally, 
to draw an ellipse from center. Make the ellipse 
about 6 inches long and 3 inches wide. You can use 
the Element Info command to set the exact measure
ments. 

[] Release the mouse button. The ellipse appears sur
rounded by the selection frame, and looks like this: 

em Choose Save As from the File menu. The Item Selec
tory appears. Type ELLIPSE.GEM on the Selection 
line. The picture will be saved in the directory listed 
on the Directory line. Click on OK 

After learning several editing operations on this el
lipse, you will abandon those edits and revert to the 
picture you just saved. You can, however, abandon 
your current edits on the ellipse at any time during 
this tutorial, in order to return to the original shape. 
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Selecting Anchor Points 
When you select an element with the Plane tool, you see 
its anchor points, not its handles. When all of an 
element's anchor points are selected, you can move the ele
ment by dragging one of the anchor points. 

To select and move the ellipse with the Plane: 

You can also use the 
Plane tool to drag a 
selector box around 
the ellipse. 

Anchor POints are solid 
when selected and hol
low when not selected. 

Editing Curves 

OJ Click on the Plane tool to select it. The selection 
frame disappears, and the cross changes to the 
pointer. 
Press the AIt key while you click on the ellipse, to se
lect it with the Plane tool. Four anchor points ap
pear, and the ellipse looks like this: 

Because the ellipse is created from four curves and no 
straight lines, all of these anchor points are tangent 
points. 

The tangent point at the top of the ellipse is larger 
than the others because it is, in fact, two overlapping 
tangent points-the beginning point of the ellipse 
and the endpoint of the ellipse. 

[]] Place the pointer over anyone of the tangent points 
and press the mouse button. The pointer changes to 
an arrowhead and the tangent points disappear. 

5-3 



Editing an Ellipse 

You can use the Undo 
command to undo the 
last move or edit. 

If you do not press on one of the selected tangent 
points, the ellipse becomes de-selected. Press Alt and 
click on the ellipse to select it again, then repeat step 
3. If you see tangent lines, de-select, re-select, and re
peat step 3. 

[]] Drag in any direction. The ellipse changes to a dot
ted line, and its dotted outline moves as you drag. 
The entire ellipse moves because you selected all of 
the tangent points. 

. ................ . 
.......... 

.. ' , 
'''\. .,/ A. 

./ ....... :'::. 
.,.::: ....................... _ ...... _........ ......... . ... 

.................................. 

[]] Still holding down the mouse button, drag it back to 
the center of the drawing surface. 

[]] Click away from a tangent point to de-select the 
ellipse. 

To select anchor points by dragging: 
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[]] Drag a selector box around the top tangent point only. 
I t is selected; the three other points are identified by 
hollow squares, which show they are not selected. 

[1] Drag a selector box around the left tangent point. 
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The left-hand point is selected. 

Its tangent line and direction points are displayed. 

The tangent points on either side of the selected 
point are identified by a hollow box, and show the 
tangent line and direction point closest to the se
lected tangent point. 

[]J Drag a selector box around the bottom tangent point, 
and then around the right-hand tangent point. 

Note that all but the top tangent point behave the 
same way. You will learn more about the top point 
later. 

Moving Curves 

You can select an anchor point and drag it to change the 
shape of a curve on both sides of the point. To drag the 
top of the ellipse, you must select both the starting and 
endpoint together. When you select more than one point 
at a time, you do not see the tangent line for an individ
ual point. 

To move the ellipse from the top: 

Editing Curves 

[] Drag a selector box around the top point again. 

[]] Place the pointer over the top point and press the 
mouse button. Do not release the mouse button yet. 
The pointer changes to an arrowhead. 

[]] Drag the top of the ellipse in every direction. The 
original shape remains on the drawing surface, while 
a dotted outline shows the new shape as you drag. 
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Note that dragging affects the curves on either side of 
the tangent point you are dragging, and that the bot
tom curves remain stationary . 

........................ 

. ...... . 
..... 

... 
i::········,,· .... .. ....... . 

.................. A, ....................... . 
................ 

[]] Drag back to the starting point and release the 
mouse button. 

To move two curves: 

You can click and Shift
click on anchor points 
to select them with the 
Plane tool. 

[IJ Drag a selector box around the top and the bottom 
tangent points. The two points are selected. 

[]] Again drag the top point in every direction. 

~ This time note how all the curves are affected, be
cause all of the curves are adjacent to a selected tan
gent point. 

( .. ~:: ........... ~::::::~.::::::.~.:::::::.;.' ... ':::::::::::: .. =::::::::: .. ~.::::: .... ~.:.:::::::::::::::::::::::::::::::::: .. :::::: .......... . 
......... : ...... 

\:/ 

! /1 
/\........ . ........... -.•••.• , .... . 

. ~~ 

.i "" .. _ .................... _ .............. -.. 
(, ........... _ .. _ ....... __ ~.~~::::: .. : ... ~~ .... m-:::: ... _ .. _._._ ............... -_ ............ . 

[]] Drag back to the original shape and release the 
mouse button. 

Editing Tangent Lines 
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You can edit curves by dragging two or more selected an
chor points, as you did in the previous exercise. You can 
also drag a single selected anchor point that is displaying 
a tangent line and direction points. 
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Finally, you can edit curves by dragging the direction 
points at the ends of a tangent line. 

To edit a tangent line: 

Editing Curves 

[] Drag a selector box around the right-hand tangent 
point. The solid box appears to show the point is se
lected, and its tangent line and direction points ap
pear. 

[]] Place the pointer directly over the selected anchor 
point (solid box), and press on the mouse button to 
display the arrowhead. 

[]] Drag the anchor point to the left and right, noting the 
two curves that are affected, and the two that remain 
stationary. The figure might look something like this: 

GJ Drag back to the original shape and release the 
mouse button. 

[]] Place the pointer over the top direction point, press 
the mouse button, and drag the direction point to the 
left, to the right, up, and down. Notice how the curve 
changes as you drag the direction point . 

...... -!.'!!:::::.:.:.:::.:::::~~.: .. :::: .. ' ........... \ .. J 

........... \1 
....... :~ 

• 
~"';;;L_~:,)l 

1 
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[]] Drag it back to its original position and release the 
mouse button. 

When you dragged the direction point, both sides of the 
tangent line changed in length equally. This is true of a 
symmetric tangent. A tangent is always symmetric unless 
it is broken. 

Breaking a Tangent Line 

To undo an edit, 
choose the Undo Edit 
command from the Edit 
menu. 
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You can break a tangent line in order to move one side of 
it independently from the other. 

To break the tangent line: 

OJ Place the pointer over the top direction point again, 
but this time hold down the Alt key while you drag 
the direction point all around. 

Notice that now only the top part of the tangent line 
moves as you drag. 

[]] Drag the direction point so the tangent line is at an 
angle and release the Alt key and mouse button. 

From now on, until you change it, the tangent is bro
ken. You do not need to press the Alt key again to 
drag it separately. 

[[] Drag the bottom direction point in different direc
tions. It too remains separate. Leave the bottom tan
gent line at an angle to the top tangent line. 
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,l 

C=:J\\ 
To change the tangent from broken to symmetric: 

Add Point 
Delete Point 

:IOO{)ooc»>:)OO(.»OCloOOC)OOC)OO()OOC)OO()OO()OOC)OO()OO(m 

to Line 
to Curve 

)OO(»OC)OOC»OC»OC)OOC)OOC)OO()OO()OOC)OOC)OOC)OOC»OC* 

Split 
Join 

)OOC)OOC)OO()OOC)OOC)OOC)OOC)OOC)OOC»oc»«)OOC)OOC)OOCm 

SY(Il(lletric 
S(Ilooth 

)OOC)OOCX«)OOC)OOC»O()OO()OO(»>::>OOC)OOC)OO(.)OO()OOC»>: 

Align Vert. 
Align Hor. 

The path of a curve 
runs from the starting 
point toward the end
point. 

Editing Curves 

ITl With the right-hand tangent still selected, move the 
pointer away from the ellipse and double-click to dis
play the Plane tool pop-up menu. 

It appears in the workspace where you double-click. 
The appearance of the ellipse changes like this: 

The tangent line and direction points disappear. 

- The solid box shows the selected tangent point. 

- The hollow boxes show the other tangent points on 
the element. 

The dotted line shows the curve that is between 
the selected tangent point and the next tangent 
point on the path. This is the curve that can be af
fected by commands in the Plane tool pop-up. 

\]] Choose the Symmetric command from the Plane tool 
pop-up menu. 

The pop-up disappears, and the tangent lines reap
pear. The selected tangent line is returned to a 
straight line. 

j 
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[]] Drag one of the direction points again. The curve is 
restored to its unbroken symmetric state; both sides 
are the same length, and when you drag one side, the 
other side moves too. 

Separating Overlapping Points 

To edit one point in an overlapping pair, you must select it 
separately. For this exercise, you revert to the original 
ellipse that you drew. 

Choose the Abandon command from the File menu and 
click on Abandon in t~e Abandon/Save alert. Artline dis
cards the current picture and displays the original 
ELLIPSE.GEM in the workspace. Make sure the Plane 
tool is selected. 

To separate the starting and endpoints: 

[] Click on the top tangent point. The ellipse looks like 
this: 

Note the following about the starting point: 

- When you drag around the starting point, you see 
both the starting point and the endpoint selected. 

- When you click on the starting point, you see the 
tangent line of the starting point only. This is be
cause the starting point is on top of the endpoint, 
and the starting point is selected when you click. 

~ Place the pointer over the selected tangent point
the solid box-and press the mouse button. The 
pointer changes to the arrowhead. 
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Editing an Ellipse 

QJ Drag the tangent point up about an inch, still press
ing the mouse button. The ellipse now looks like this: 

A, ............................... . 
........ 

............................... ..... 

............... ::::::::.~<.\ 

I]] Release the mouse button. The ellipse now looks like 
this: 

Note that the starting point is identified by a larger 
tangent point than the endpoint. 

Click on the smaller tangent point to the left-the 
endpoint of the ellipse, to display the endpoint tan
gent line. The ellipse now looks like this: 
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You can use the left 
and right arrow keys to 
move through anchor 
points from start to end 
and back. 
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[]] Drag the endpoint to a new position and release the 
mouse button. 

[1J Drag the endpoint to meet with the starting point of 
the ellipse. You see the solid box (selected endpoint) 
inside the hollow box (de-selected starting point). 

( 
............................ . 

... 
I 

[]] Click on the right side of the tangent point to select 
the starting point and its tangent line. The ellipse 
looks like this: 

At this point, the starting point is on top again. 

Because you are manually placing them together, they 
might not be exactly aligned, and they might look slightly 
different from the picture. 

To select the endpoint now you must use the right arrow 
key to move through the tangent points along the ellipse 
from start to end. When the endpoint is selected, you can
not use the right arrow key to select the starting point. 
You must use the left arrow key to move back through the 
tangent points to the start of the ellipse. 
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Joining Overlapping Points 

You can use the Join Points command to bring the first 
and last points of an element together, or to join two sepa
rate points into one. 

o If the points are on the same element, one point is 
placed on top of the other. 

o If the points are on different elements, they become 
one point. 

When you join the starting point and the endpoint, the 
Join Points command aligns the points on top of one an
other, but does not physically join them. 

To join the starting point and endpoint: 

Editing Curves 

[]] Drag a selector box around only the top two tangent 
points. The selected points look a little different than 
when you first started because you have moved them. 

[]] Double-click away from the ellipse to display the 
Plane tool pop-up. 

[]] Choose the Join Points command. The pop-up dis
appears, and the top two tangent points appear just 
as they did when you selected them in the first exer
cise. 

[]] Double-click to display the Plane tool pop-up again. 
Note that the Join Points command is still avail
able. This is because the starting point and endpoint 
of an element, even an apparently closed element, are 
always separate points. 

Once the two points are joined you can select only the top 
one again, unless you use the arrow key, or drag one away 
from the other. 
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Splitting a Point 

The Split Point command splits a single selected point 
into two points. The element that contained the point is 
split into two elements that can be separately selected, 
moved, rotated, and so on. This command is available for 
any single point, except for an element's beginning and 
endpoints. 

To split a point: 

[]] Click on the right-hand tangent point to select it. 
The ellipse now looks something like this: 

[]] Double-click to display the Plane tool pop-up and 
choose the Split Point command. The element now 
looks like this: 

The right hand tangent point is now split. The split 
creates another curve, another endpoint, and another 
starting point in the figure. 

The selected tangent point is large because it is now 
the starting point of one element and the endpoint of 
another element. The tangent line for one end is 
showing. 

Artline Tutorial 



Editing Curves 

Editing an Ellipse 

[]] Press the left arrow key to move to the starting point 
for the new curve. 

[]] Press the right arrow key to return to the endpoint of 
the new curve. 

Because there are now two distinct curve segments, 
you must drag a selector box or click to select points 
on the other segment. You cannot move through all 
of the points in the figure with the arrow keys, as be
fore. 

You can now move the direction point of the split tan
gent separately, or drag the tangent point away. 

[]] Drag the tangent point to the right about one inch, so 
the figure looks something like this: 
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Joining Two Points 
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These two points are now on different elements, so joining 
them will create one point. 

To join two points: 

[]] Drag a selector box around the two points at the 
right, so the figure looks something like this: 

[]] Double-click to display the Plane tool pop-up, and 
choose the Join Points command. 

The two points are once again joined, and the figure 
looks something like this: 

-~// 

.. -.~ 
Note that the tangent lines are broken, and that you 
can drag the direction points separately. 

[]] To return them to a symmetric condition, choose the 
Symmetric command from the Plane tool pop-up. 

The tangent line is once again straight, both sides are 
the same length, and dragging one direction point 
causes the other one to move an equal distance in the 
opposite direction. 
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Deleting a Point 

The Delete Point command deletes the selected point. 

To delete a point: 

Editing Curves 

[] With the right-hand tangent point still selected, dou
ble-click to display the Plane tool pop-up. The dotted 
line appears between the selected point and the next 
point on the path. 

[]] Choose the Delete Point command. 

The point disappears entirely, the curve becomes con
tinuous from the starting point to the tangent point 
on the bottom, and the figure now looks like this: 

[]] Click on the top tangent point-once again the only 
starting point. The tangent lines appear for the top 
and the next point toward the end of the curve, which 
is now the bottom point. 

[±] Click on the bottom point. Tangent lines appear for 
the bottom and for the points on either side of it. 

(. . ....................................... .. 

~.--------------. 
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Note that the bottom tangent lines are now different 
lengths, and you can drag either direction point sepa
rately. 

[]] Click on the left-hand tangent point. It is unchanged. 

Adding a Point 

The Add Point command adds a new point to an ele
ment, located at the midpoint of the dotted line. 

To add a new point: 

OJ Click on the top tangent point. 

[]] Double-click to display the Plane tool pop-up. The 
dotted line appears between the selected starting 
point and the next point along the path. 

[]] Choose the Add Point command. The right-hand 
tangent point reappears between the two points, and 
it is symmetric. 

Converting to a Line 

The to Line command converts the dotted line from a 
curve to a straight line, and is available only when the 
dotted line is a curve. 

With the right-hand tangent point still selected, choose 
the to Line command from the Plane tool pop-up. The 
figure now looks like this: 

--~ 

The curve along the dotted line is converted to a line, cre
ating junction points on the right and on the bottom. 
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Recall from Chapter 4 that a junction point joins a 
straight line to a curve, and has one direction point. 

Converting to a Curve 

The to Curve command converts the dotted line from a 
straight line to a curve, and is available only when the 
dotted line is a straight line. 

To convert to a curve: 

Editing Curves 

[I] Select the right-hand tangent again. 

[]] Choose the to Curve command from the Plane tool 
pop-up. The figure looks something like this: 

.~ 
Ii /.,.. 

•. , 

The little points on the line are direction points that 
you can drag to shape the converted line into the 
curve you want. 

[]J Drag each direction point until the line is curved on 
both sides, and it looks something like this: 

~ -~ ....................• 

+~.~ 
........................• 
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Smoothing a Transition 

The Smooth command removes the angle between curves 
at a broken tangent, or between a curve and a line at a 
junction point, but does not change the broken or unequal 
status of a tangent line. 

With the bottom tangent point selected, choose the 
Smooth command from the Plane tool pop-up. 

The broken tangent line becomes one straight tangent 
line, but each side remains a different length, and you 
can still move each side separately. 

Aligning Anchor Points 

The Align Vert. and Align Horiz. commands align se
lected anchor points vertically or horizontally. 

To align anchor points: 

OJ Drag a selector box, or click and Shift-click with the 
Plane tool, to select the three rightmost tangent 
points, as shown in the picture: 

[]] Choose the Align Vert. command from the Plane tool 
pop-up. The three selected points are aligned verti
cally with the selected point nearest the starting 
point, like this: 
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Editing an Ellipse 

[]] Choose the Undo Align command from the Edit 
menu. The figure is returned to its previous shape. 

[!] Drag a selector box, or click and Shift-click to select 
the three bottom most tangent points, as shown in 
the picture: 

[]] Choose the Align Horiz. command from the Plane 
tool pop-up. The three points align horizontally with 
the first selected point nearest the element's starting 
point, as shown in this picture: 
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Drawing a 90° Arc 
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This exercise shows another way to use Artline's elec
tronic tools to accomplish a task. Traditionally, to draw 
an arc, you use a compass, a protractor, and a ruler or T
square. The easiest way to draw a 90° arc in Artline is to 
select and copy one quarter of a circle. 

To make a 90 0 arc: 

OJ Select the Ellipse tool. 

[]] Press the Shift and Ctrl keys to draw a true circle 
from center. 

QJ Select the Plane tool. 

[i] Drag a selector box around the right-hand and bot
tom two points, so the circle looks like this: 

[]] Choose the Duplicate command from the Edit menu. 
The arc appears below and to the right of the circle. 

To make an arc of any degree, use the Line and Rotate 
tools to create an angle, then use the Quill to set tangent 
points perpendicular to the radii of the angle. The next 
exercise shows you how to create an angle. 
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Drawing an Equilateral Triangle 

To make an equilateral triangle, one in which all sides are 
of equal length and each angle measures 600

, you must 
copy and rotate a straight line. 

For this exercise, it is helpful to: 

o turn on the grid (set to 1 inch) in the View menu; 
o turn on Snap to Grid in the View menu. 

Decide the length you want each side of the triangle to be. 
For this exercise, use four inches. 

To draw an equilateral triangle: 

The Shift key draws a 
line from center. The 
Ctrl key constrains it to 
a straight line. 

Editing Curves 

[I] Select the Line tooL The pointer changes to a cross. 

[]] Place the cross in the center of the workspace, and 
about two thirds of the way down. Press the Shift 
and Ctrl keys while you drag horizontally, until you 
have a straight line four inches long, like this: 

[1] Click on the Thumbtack, move the pointer to the 
right end of the line, and click to place the thumbtack 
like this: 

[II Double-click on the Rotator tool to display the Rota
tor Options dialog. 

- Under Rotate Around, click on Thumbtack. 

- Under Rotation Angle, type 60 (degrees). 

- Click on OK or press .J to exit the dialog. 

[ill Click on the Rotator tool. The pointer changes to an 
arrowhead. 



Drawing an Equilateral Triangle 

[]] Move the arrowhead to the left end of the line, hold 
down the Shift key, and drag cloGkwise until you see 
the dotted line representing the copy appear on the 
right side of the triangle, then release the mouse but
ton. The figure now looks like this: 

[}] Click on the Selector tool and select the bottom line. 

[]] Click on the Thumbtack tool, then click on the 
thumbtack to remove it from the drawing surface. 

[ill Click on the left end of the bottom line, to place the 
thumbtack there. The figure looks like this: 

110 I Click on the Rotator tool. The pointer changes to an 
arrowhead. 

[TIJ Move the arrowhead to the right end of the line. 
Hold down the Shift key while you drag the right 
end of the line counter clockwise, until you see the 
dotted copy appear at the left side of the triangle, 
then release the mouse button. The figure now looks 
like this: 
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1121 Click on the Thumbtack tool, then click on the thumb
tack to remove it from the drawing surface. 

1131 Click on the Selector tool, then click outside the trian
gle to de-select it. It looks like this: 

If you want to color the triangle, you must join the cor
ners so the triangle is one element instead of three. 

To join the corners of the triangle: 
Recall that corner 
points have no tangent 
lines. 

Editing Curves 

[]] Click on the Plane tool, then drag a selector box 
around the anchor points at the bottom left corner of 
the triangle, which will become one corner point 
when joined. 

[]] Double-click away from the triangle to display the 
Plane tool pop-up menu, and choose the Join Points 
command. The points at the bottom left of the trian
gle are joined into one corner point. 

[]] Repeat steps 1 and 2 for the bottom right corner. 
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The top of the triangle is now a starting and end
point. Therefore, the triangle is now one element-a 
polygon-and you can fill it. 

However, you might want to join the top points any
way, just to make it neater. 

[:±] Click on the Selector tool, turn Colors on in the View 
menu, or press the FlO function key. 

[]] Click on the Fill Color tool and select a color from the 
color palette. The triangle is filled with the color. 

What You Learned 

You now know how to use the Plane tool and the Plane 
tool pop-up menu to: 

o select anchor points; 
o move anchor points; 
o edit tangent lines; 
o break a tangent line; 
o separate and bring together overlapping points; 
o split and join points; 
o add and delete points; 
o convert to lines and curves; 
o smooth junctions and other curve transitions; 
o align anchor points. 
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Autotracing Images 

A RTLINE'S interactive autotracing feature lets you load a bit
~ image file, such as those created in paint and scanning pro

grams, and automatically trace the image, creating a picture in 
Artline's format. Chapter 11 of the Artline User Reference Guide 
discusses autotracing in detail. 

In this chapter you load an image file and practice using 
many of Artline's autotracing features. 

For the exercises in this chapter: 

o Choose the New command from the File menu and re
spond appropriately to the Abandon/Save alert, if it ap
pears. 

o Choose the Page Layout command from the File 
menu and choose Landscape from the Orientation pop
up menu. 

o Choose Full View from the View tool pop-:-up menu. 

The exercises in this chapter will take about twenty 
minutes to complete. 

What is in this chapter: 

o loading the image 
o setting the image options 
o autotracing the image 
o finishing the picture 
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Loading the Image 
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To autotrace an image, you must first load the image you 
want to trace. The image appears on the screen, but is 
not part of the picture file and remains unchanged in its 
original file. Artline comes with an image file called 
EAGLE.IMG that you use in this exercise. 

To load the eagle: 

[] Choose the Load Image command from the Image 
menu. The Item Selector appears . 

• _11 __ IteM Selector '-I •• ,lt!lll 
Director!,!: 
C:\ARTLINE\IMAGES\*. IMGJ*.PCX J*. TIF _____ _ 

H *.IMG *.PCX *.TIF 

EAGLE .IMG Selection: EAGLE .IM~ 

DL~ 
I Cancel I 

The directory line shows you: 

- the current drive-the one on which Artline is in
stalled; 

- the current directory path, in this case 
ARTLINE\IMAGES; 

- the image file formats that Artline can load, identi
fied by their filename extensions: IMG, PCX, and 
TIF. 

The directory window shows the names of any files in 
the current directory with these extensions. 
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You can double-click 
on EAGLE.IMG in the 
directory window to 
open the file. 

Setting Image Options 

[]] Click on the name EAGLE.IMG in the directory win
dow, or type the name on the Selection line, so it 
looks like the picture. 

[]] Click on OK or press.J to exit the Item Selector. 

After a few moments, the eagle appears in the upper 
left-hand corner of the workspace. 

Setting Image Options 

You can set some options to change the colors, scaling, 
and position of the image in the workspace. 

To set the image options: 

IT] Choose the Image Options command from the 
Image menu. The Image Options dialog appears. 

Fill in the dialog as shown in the picture. 

llilage Options 
Colors & Patterns 
llilage =-:!1 Background c:::::EI 
Pattern mWii!!!!!!!!HI .1 

Scaling 
@ Un if 0 rlil 0 Non-Uniforlil 

Size Iml% 
Offsets 
Horizontal []}[] inch 

DLJ 
Vertical []}[] inch 

I Cancel I 
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Setting Image Options 

For accurate tracing, 
Scaling and Offset val
ues must be exactly 
the same each time 
you load the image. 

6-4 

Under Colors and Patterns: 

- If you have a color monitor, choose Cyan from the 
Image pop-up menu. 

- If you have a monochrome monitor, leave the 
Image set to black and choose the bottom (lightest) 
pattern from the Pattern pop-up. 

Under Scaling: 

- Leave Uniform selected. 

- Type 200 (%) in the Size field, or use the pop-up 
slider. 

Under Offsets: 

- Type 0.5 inch in the Horizontal and Vertical fields. 

~ Click on OK or press .J to exit the dialog. 

The image is enlarged, appears in a light pattern, 
and is offset 0.5 inch from the top and left borders of 
the workspace. 

The current settings in the Image Options dialog are 
saved as defaults when you choose the Save Prefer
ences command. 

If you intend to stop, save your picture, and continue the 
exercise later, choose the Save Preferences command 
from the Options menu. 
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Setting Tracing Options 

Setting Tracing Options 

Trace tool 

You can set tracing options to specify the type of image 
and the precision you want to use when tracing. In gen
eral, it is best to use the lowest precision that still repro
duces the shape; otherwise the element outline might 
look too busy, and there may be needless anchor points 
and curves that can get in the way when editing the 
traced outline. 

To set tracing options: 

[] Double-click on the Trace tool. The Tracing Options 
dialog appears: 

Tracing Options 
blage 

T!,Ipe o Gra!,lscale @ Line Art 

Gap Size @·······o··'!.....··· O··v· O·~· 

Tillling C]J illS 

Precision C][] 

I OK II Cancel I 

Fill it out like the picture. 

- Click on Line Art. This is for images that contain 
only solid areas of black and white. Grayscale is 
for images that contain different shades' of gray. 

- Leave Gap Size set to the first option-zero pixels. 
This means Artline will follow all of the pixels and 
not skip over any tiny irregularities. This is fine 
for the eagle, which does not have many irre~lari
ties. 

- Leave Timing set to 0 milliseconds. This option de
termines how long autotrace waits before starting 
the next curve segment. 
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Autotracing the Image 

- Type 30 (%) in the Precision field, or use the pop
up slider or the + and - keys on the number key 
pad. This is enough for the eagle. A higher preci
sion adds needless curves to the element, and a 
very high precision causes autotrace to exceed its 
point limit before the end of the trace. 

[]] Click on OK or press .J to exit the dialog. 

Autotracing the Image 

Trace tool 

6-6 

If you are tracing the outside of an image, the tracing line 
moves clockwise. If you are tracing inside an image, the 
tracing line moves counter-clockwise. 

To autotrace the eagle: 

OJ Click on the Trace tool to select it. The pointer 
changes to a cross. 

[]] Place the cross in the white space just above the ''V'' 
between the eagle's wings. 

QJ Click to start autotracing. Artline displays the spin
ning ball while computing the curves. 

If you click too far from the image, Artline displays 
the "Cannot find tracing image" alert. Click on OK 
and try again. 

When the spinning ball stops, you see the black out
line of the eagle and the Preview Curve dialog ap
pears. 

GJ 38 % [B 
Trac(!: f"r(!:c::l.:s:::I.on 

You can use this dialog to change the precision and re
trace, or to cancel the tracing. 
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Autotracing the Image 

[]] Click on OK to accept the tracing. 

The dialog disappears, and a selection frame sur
rounds the tracing. 

[]] Click on the Selector tool, then click outside the selec
tion frame to de-select the traced eagle. 

If you click outside the element with the Autotrace 
tool, Artline displays the "Cannot find tracing image" 
alert. Click on OK and repeat step 5. 

[]] Choose the Image command from the View menu, or 
press the F9 function key, to hide the image and view 
the tracing. 

[]] Press F9 to display the image again. 
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Autotracing the Image 

l]] Click on the Autotrace tool, then click in the oval 
space between the eagle's legs. 

The oval is traced, and the Preview Curve dialog ap
pears again. 

[]J Click on OK to accept the tracing. 

The next part of this exercise shows you how to stop the 
autotracing by pressing the spacebar, add and delete 
points, continue tracing, and look at the anchor points 
with the Plane tool. 

Because the border is slightly irregular, you can enlarge 
the gap size and reduce the precision to create a 
straighter edge on the border. 

To trace the border: 

OJ Double-click on the Autotrace tool. The Tracing Op
tions dialog appears. 

- Type 500 (milliseconds) in the Timing field. This 
slows the trace so you can manually interrupt it to 
do this exercise. 

- Type 0 (%) in the Precision field. 

[1J Click on OK or press .J to exit the dialog. 

[]] Click on the Autotrace tool. The pointer changes to a 
cross. 

[±] Place the cross on the outside border, over the top left 
edge, and click to start the autotrace. 

[§] Watch carefully, with your finger on the spacebar. 
When you see the first part of the outline appear, 
press the spacebar. 

The tracing stops and the Preview Curve dialog ap
pears. You can drag the title bar to move it away 
from the tracing area, but leave it on the screen. 

[§] Press the Tab or right arrow key to add the next 
point. Press the Backspace or left arrow key to delete 
the last point. 
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Plane tool 

Autotracing the Image 

[IJ There is no need to change the precision here, so click 
on "Go on" to continue tracing. 

[]] Click on OK to accept the tracing. 

The tracing completes and the border appears with 
its selection frame. 

The next two steps show how you can edit the curves 
drawn with the Trace tool just like those drawn with the 
Quill or Sketch tools. 

[ill Click on the Plane tool. The selection frame disap
pears. 

110 I Place the pointer on the outer border, hold down the 
Alt key, and click to display the anchor points. The 
picture looks like this. 

The anchor points on the corners are tangent points. 
You can edit these points later if you wish. 
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Autotracing the Image 

6-10 

[IT] Click on the Autotrace tool. 

1121 Place the cross on the inside border, under the top 
left edge, and click to start the autotrace. 

1131 When the Preview Curve dialog appears, click on OK. 

1141 Click on the Selector tool, then click outside the 
image to deselect it. 

IT§] Press F9 to hide the image. 
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Finishing the Picture 

Finishing the Picture 

You can now color the picture if you like. This exercise re
views selecting elements in stacks, and using fill colors, 
which you learned in Chapter 2. 

If you autotraced the borders in a different order, or if you 
select and color the elements in a different order than 
listed here, use the Selector tool and the Send to Back 
and Send to Front commands in the Element menu to 
organize the stack so the fills show correctly. 

Recall that you drew the eagle first, so it is on the bottom 
of the stack of elements. 

To color the picture: 

[]] Turn on Colors in the View menu. 

[]] Press the Ctrl key and click on the eagle to select it. 

[ill Click on the Fountain tool and choose Gray from the 
list. The eagle is filled with a gray fountain. 

[±] With the eagle still selected, choose the Bring to 
Front command from the Element menu. This pre
vents the border fills from covering the eagle. 

[]] Click on the inner border to select it. 

[ill Click on the Fill Color tool and choose White. 

The inner area appears to remain the same, but it 
has changed from Hollow to White. If you leave it hol
low, the outer border's dark gray fill will show 
through it and obscure the eagle. 

[1J Click on the outer border to select it. 

[§] Click on the Fill Color tool and choose Dark Gray 
from the color palette. The outer border is filled with 
dark gray, and because it was made before the inner 
border, it is underneath it and does not cover it. 

[]] Deselect the border, and the picture looks like this: 
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Finishing the Picture 

6-12 

You have now completed the autotracing exercise. 
You can save the picture if you like. The original 
image is not saved with the file and remains un
changed. 

What You Learned 

You now know how to: 

o load an image file; 
o change the color and pattern of the image; 
o show and hide the image you are tracing; 
[] scale the image; 
o move the image on the workspace; 
o set tracing precision, gap size, and timing; 
o autotrace an image; 
o stop, add and delete points, reset the precision, and 

continue the autotrace. 
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Conclusion 

Conclusion 

This concludes the Artline tutorial. If you have completed 
the exercises in this book, you know how to use all of the 
tools and almost all of the commands in Artline. 

You have the experience you need to use Artline comfort
ably. You have the confidence to explore the many and 
varied artistic effects you can create with Artline, because 
you know how to create and manage elements on the 
drawing surface, how to create and undo effects until you 
see the one you want, and how to open, save, and print 
your pictures. 

TheArtline User Reference Guide discusses every Artline 
tool and menu command in detail. 
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Conclusion 
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Standard Tools 

ARTLINE comes with these standard tools. 

Selector Layer tool 

View tool Magnifier 

Quill Sketch tool 

Trace tool Text tool 

Rectangle tool Circle tool 

Rounded Rectangle tool Line tool 

Fill Color tool Fountain tool 

Line Color tool Line Width tool 

Rotator Plane 

Thumbtack Flipper 

Rolling Pin 

A-l 





Inde)( 

A 
Abandon command, 2-11, 5-10 
Abandon/Save alert, 1-22 
Add Fill dialog, 2-18 
Add Point command 

in Plane tool pop-up, 5-18 
alert 

Abandon/Save 
Cannot find tracing image, 6-6 

Align Horiz. command 
in Plane tool pop-up, 5-20 

Align Vert. command 
in Plane tool pop-up, 5-20 

Alt key 
for selecting, 3-9 
symbol for, 1-12 
to break tangent, 5-8 
to change tangent, 4-15 
with Plane tool, 5-3 

Alt-E to erase, 1-6 
anchor point, 4-2 
anchor points 

aligning, 5-20 
selecting, 5-3 

angles 
making with lines, 5-23 
setting for lines, 1-17 

arc (90°) 
drawing, 5-22 

arrow keys 
to select anchor points, 5-12 
with autotrace, 6-8 

arrows 
in menu, 2-3 
in window borders, 1-21 

ARTLINE\IMAGES directory, 6-2 
ARTLINE\ARTWORK directory, 2-10 
Attributes 

in Line Width pop-up, 2-15 
Auto redraw speed, 1-16 
autotracing images, 6-2 

B 
Backspace 

to cancel anchor point, 4-5 
backup 

Artline files, 1-16 
Blend command, 3-3 
Blend Elements dialog, 3-3 
blending elements, 3-3 
Bring to Front command, 3-15 
broken tangent, 5-8 

c 
Cannot find tracing image alert, 6-6 
check box in dialogs, 1-16 
Circle tool, 2-9 
circles 

drawing, 2-9 
click 

with mouse, 1-4 
Colors command, 2-3 
commands 

Abandon, 2-11, 5-10 
Blend, 3-3 
Bring to Front, 3-15 
Clone, 1-13 
Colors, 2-3 
Convert to Curves, 3-11 
Copy, 1-13 
Delete, 1-11, 2-5 
Duplicate, 1-11 
Element Info, 3-12 
Fountains, 2-3 
Group, 2-14 
Guide Lines, 2-3 
Image, 6-7 
Image Options, 6-3 
in View menu, 2-3 
keyboard shortcuts, 1-12 
Load Image, 6-2 
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Mask, 3-15 
Merge Elements, 3-11 
Move, 3-13 
New, 1-22 
Page Layout, 2-2 
Paste, 1-13 
PostScript, 2-20 
Preferences, 1-15 
Quit, 1-23 
Repeat, 1-11 
Rotate, 2-8 
Rulers, 2-4 
Save As, 2-10 
Save Preferences, 1-16, 6-4 
Scale, 2-7 
Select All, 2-13 
Send to Back, 3-29 
Set Grid, 2-4 
Snap to Grid, 2-6 
Split Element, 3-9, 3-11, 3-15 
Status Line, 2-3 
Text Along Path, 3-8 
To Output, 2-21 
Toolbox, 2-3 
Undo, 1-12,2-5 
Ungroup, 2-16 

Convert to Curves command 
with text, 3-11 

Copy command, 1-13 
copying elements, 1-9 
corner point, 4-3 
Create Text Element dialog, 3-6 
Ctrl-click to select, 2-12 
curves 

compound, 4-8 
connect to line, 4-12 
convert to line, 5-18 
drawing, 4-4 
editing, 5-2 
moving with Plane, 5-5 
simple, 4-4 

Ctrl key 
symbol for, 1-12 
to draw a square, 2-6 
to draw circles, 2-9 

Index-2 

D 
default 

fill and line color, 2-3 
screen settings, 1-3 
setting fill and line color, 4-21 

Delete command, 1-11 
Delete Point command 

in Plane tool pop-up, 5-17 
de-selecting elements, 1-8 
dialogs 

Add Fill, 2-18 
Blend Elements, 3-3 
Create Text Element, 3-6 
dragging, 1-15 
Element Settings, 3-12 
entry fields in, 1-17 
Global Preferences, 1-15 
Image Options, 6-3 
Item Selector, 2-10, 6-2 
Line Attributes, 2-15 
Line Options, 1-17 
Mask Elements, 3-15 
Move Elements, 3-13 
Page Layout, 2-2 
pop-up slider in, 1-17 
Preview Curve, 6-6 
Rotate Elements, 2-8 
Rotator Options, 3-20 
Scale Elements, 2-7 
Selector Options, 3-30 
Text Along a Path, 3-8 
Tracing Options, 6-5 
using, 1-15 

diamond 
for Alt key, 1-12 
in Item Selector, 2-10 

direction point, 4-5 
Directory line 

in Item Selector, 2-10 
double-click 

to cancel first anchor point, 4-5 
to end Quill element, 4-4 
to set tool options, 1-17 
with mouse, 1-4 



drag 
dialogs, 1-15 
to select, 1-7 
to select anchor points, 5-4 
with mouse, 1-4 

drawing 
arcs, 5-22 
circles, 2-9 
curves, 4-4 
ellipses, 3-20 
equilateral triangle, 5-23 
lines, 1-14,4-2 
polygons, 4-2 
squares, 2-6 

drawing surface, 1-3 
Duplicate command, 1-11 

E 
EAGLE.IMG file, 6-2 

editing 
curves, 5-2 
tangent lines, 5-6 

Element Info command, 3-12 
Element Settings dialog, 3-12 
elements 

blending, 3-3 
copying, 1-9, 1-13 
de-selecting, 1-8 
grouping, 2-13 
in stacks, 2-12 
masking, 3-10 
merging, 3-16 
moving, 1-8 
open and closed, 4-21 
resizing, 1-10 
rotating, 3-20 
selecting, 1-7,2-12 
sizing, 1-10 
ungrouping, 2-16 

ellipse 
editing, 5-2 
tracing, 4-18 

endpoint 
of ellipse, 5-10 

EPSF format, 2-20 
erase 

keyboard shortcut, 1-6 

Escape key 
to cancel a dialog, 1-16 
to redraw screen, 1-12 

exiting 
Artline, 1-22 

F 
F4 function key 

to select elements, 2-12 
Fast 

redraw speed, 1-16 
fields 

in dialogs, 1-17 
filename 

in title bar, 1-3 
files 

printing, 2-20 
saving, 2-10 

fill color 
hollow, 4-21 
with monochrome monitor, 2-17 

Fill Color tool, 2-17 
Flipper tool, 3-26 
Fo's 

with fountains, 2-3 
Fountain tool, 2-18 
fountains 

Fo's in, 2-3 
in elements, 2-18 
in text elements, 3-28 

Fountains command, 2-3 
Full View, 1-19 
function keys 

F4 to select, 2-12 
in menus, 1-12 

G 
GEM filename extension, 2-10 
Global Preferences dialog, 1-15 
Group command, 2-14 
grouping elements, 2-13 
Guide Lines command, 2-3 

Index-3 



H 
handles 

on selection frame, 1-10 
hollow 

fill color, 4-21 

Image command, 6-7 
Image Options command, 6-3 
Image Options dialog, 6-3 
IMG file extension, 6-2 
Item Selector dialog, 2-10 

with Image files, 6-2 

J 
Join Points 

with starting and endpoint, 5-13 
Join Points command 

in Plane tool pop-up, 5-13 
joining 

corners, 5-25 
junction point, 4-13 

K 
keyboard commands 

using, 1-12 
keys 

Alt, with tangent, 4-15 
arrow, 5-12 
Ctrl, 1-12 
Ctrl-click to select, 2-12 
Ctrl with Circle tool, 2-9 
Escape, 1-12, 1-16 
F 4 function key, 2-12 
for menu commands, 1-12 
plus and minus with Magnifier, 1-20 
plus and minus with pop-up slider, 1-17 
Shift-F4 to select, 2-13 
Shift to draw from center, 2-9 
Shift with pop-up slider, 1-17 
Shift-click to select, 2-12 
symbols for, 1-12 

Index-4 

L 
Landscape 

in Page Layout dialog, 2-2 
layer name 

in title bar, 1-3 
Line Attributes dialog, 2-15 
Line Color tool, 2-16 
Line tool 

options, 1-17 
vs. Quill tool, 4-1 

Line Width pop-up 
No Outline in, 3-14 

Line Width tool, 2-14 
lines 

drawing, 1-14,4-2 
connect to curve, 4-11 
convert to curve, 5-19 
setting angles for, 1-17 

Load Image command, 6-2 

M 
magnification 

keys, 1-20 
tools, 1-18 

Magnifier tool, 1-19 
mask background, 3-12 
Mask command, 3-15 
mask element 

text as, 3-11 
Mask Elements dialog, 3-15 
masking elements, 3-10 
menu bar, 1-2 
menu commands 

using, 1-11 
menus 

drop-down, 1-16 
pull-down, 1-16 

Merge Elements command, 3-11, 3-16 
merging elements, 3-16 
minus key 

with Magnifier, 1-20 
with pop-up slider, 1-17 

mirror effect 
with text, 3-26 

monochrome monitor 
with fill colors, 2-17 



mouse, 1-4 
click, 1-4 
double-click, 1-4 
drag, 1-4 
shift-drag, 1-9 

Move command, 3-13 
Move Elements dialog, 3-13 
moving elements, 1-8 
moving elements 

with the Plane tool, 5-3 

N 
New command, 1-22 
No Outline 

in Line Width pop-up, 3-14 
Normal View, 1-19 

o 
options 

p 

Line tool, 1-17 
Selector tool, 3-30 
Trace tool, 6-5 

Page Layout command, 2-2 
Plane tool, 5-3 
Plane tool pop-up menu, 5-9 
plus key 

with Magnifier, 1-20 
with pop-up slider, 1-17 

point 
adding, 5-18 
anchor, 4-2 
corner, 4-3 
deleting, 5-17 
direction, 4-5 
junction, 4-13 
overlapping, 5-10 
starting and endpoint, 5-10 
tangent, 4-5 

pointer, 1-4 
points 

joining, 5-13, 5-16 

polygons 
drawing, 4-3 

pop-up slider 
in dialogs, 1-17 

PostScript command, 2-20 
Preferences command, 1-15 
Preview Curve dialog, 6-6 
printing pictures, 2-20 

Q 
Quality redraw speed, 1-16 
Quill tool, 4-2 

vs. Line and Sketch tools, 4-1 
Quit command, 1-23 

R 
radio buttons in dialogs, 1-16 
rectangle 

drawing, 1-5 
Rectangle tool, 1-5 
redraw screen, 1-12 
Redraw speed 

setting, 1-16 
Reduced View, 1-19 
Repeat command, 1-11 
reset screen defaults, 1-22 
resizing 

elements, 1-10 
text, 3-14 

Rolling Pin tool, 3-18 
Rotate command, 2-8 
Rotate Elements dialog, 2-8 
rotating elements, 3-20 
Rotator Options dialog, 3-20 
Rotator tool, 3-20 
rulers 

turning on, 2-4 
Rulers command, 2-4 
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s 
Save As command, 2-10 
Save Preferences command 

with Image Options dial~g, 6-4 
with Preferences dialog, 1-16 

saving pictures, 2-10 
Scale command, 2-7 
Scale Elements dialog, 2-7 
screen 

clearing, 1-22 
components, 1-2 
defaults, 1-22 
menu bar, 1-2 
redraw, 1-12 
startup, 1-2 
title bar, 1-2, 1-5 

scroll bars 
in window borders, 1-21 

scrollers 
in window borders, 1-21 

Select All command, 2-13 
selecting 

anchor points, 5-3 
by dragging, 1-7 
elements, 1-7, 2-12 
with Ctrl-click, 2-12 
with Selector tool, 1-7 
with the Alt key, 3-9 

selection frame 
on rectangle, 1-6 

Selector Options dialog, 3-30 
Selector tool, 1-5 
Selector tool options, 3-30 
Send to Back command, 3-29 
Set Grid command, 2-4 
shadow effect 

with text, 3-28 
Shift key 

in pop-up slider, 1-17 
symbol for, 1-12 
to draw from center, 2-9 

Shift-click 
to select, 2-12 

Shift-drag 
with mouse, 1-9 

Shift-F4 
to select, 2-13 

Sketch tool, 3-5 

Index-6 

vs. Quill tool, 4-1 
slider 

in window border, 1-21 
Smooth command 

in Plane tool pop-up, 5-20 
Split Element command 

with mask, 3-15 
with merged text, 3-11 
with text along a path, 3-9 

Split Point command 
in Plane tool pop-up, 5-14 

square 
drawing, 2-6 

stacks 
of elements, 2-12 

starting point 
of ellipse, 5-10 

starting screen, 1-2 
Status Line command, 2-3 
surround, 1-3 
symbols for keys, 1-12 
Symmetric command 

in Plane tool pop-up, 5-9, 5-16 
symmetric tangent, 5-8 

T 
tangent 

broken, 5-8 
changing direction of, 4-14 
symmetric, 5-8 

tangent line, 4-5 
tangent lines 

editing, 5-6 
tangent points, 4-5 
text 

as mask element, 3-11 
fountains in, 3-28 
mirror effect with, 3-26 
resizing, 3-14 
skewing, 3-18 
with shadow, 3-28 

Text Along a Path dialog, 3-8 
Text Along Path command, 3-8 
Text tool, 3-6 
Thumbtack tool, 3-23 



title bar, 1-2 
filename in, 1-3 
layer name in, 1-3 

to Curve command 
in Plane tool pop-up, 5-19 

to Line command 
in Plane tool pop-up, 5-18 

tool options 
setting, 1-17 

toolbox, 1-3 
Toolbox command, 2-3 
tools 

Circle, 2-9 
Fill Color, 2-17 
Flipper, 3-26 
Fountain, 2-18 
Line Color, 2-16 
Line Width, 2-14 
Magnifier, 1-19 
Plane, 5-3 
Quill, 4-2 
Rectangle, 1-5 
Rolling Pin, 3-18 
Rotator, 3-20 
Selector, 1-5 
Sketch, 3-5 
Text, 3-6 
Thumbtack, 3-23 
Trace, 6-5 
View, 1-18 

To Output command, 2-21 
Trace tool, 6-5 
tracing 

an image file, 6-2 
stop with spacebar, 6-8 

Tracing Options dialog, 6-5 
triangle 

equilateral, 5-23 

u 
Undo command 

using, 2-5 
Undo command, 1-12 

with Plane tool pop-up, 5-4 
Ungroup command, 2-16 
UNTITLED 

starting screen, 1-2 

v 
View menu 

commands in, 2-3 
view size, 1-19 
View tool, 1-18 

w 
workspace, 1-3 

Misc. 
$EM backup file, 1-16 
*.GEM filename extension, 2-10 
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