Remote Annex

Quick Start for UNIX

Read before installing and using Remote Annex
Software Release 4.2

These installation notes contain information specific to this release. This information is not available elsewhere in the Remote Annex documentation.

Part No. 166-024-857  Rev. A
January 1997
Contents

Installing Annex Software on the Windows Platform .......................................................... 2
Installing Annex Software on the UNIX Host ...................................................................... 3
  If You Installed Annex Manager ....................................................................................... 4
  Downloading the Images ................................................................................................. 5
Hardware Setup .................................................................................................................. 5
Network Address ............................................................................................................... 6
Booting the Remote Annex ............................................................................................... 8
Configuring the Remote Annex ......................................................................................... 8
  Using Annex Manager ....................................................................................................... 9
  Using Quick2Config Annex ............................................................................................. 9
  Using the na Utility .......................................................................................................... 10
  Configuring Security ....................................................................................................... 12
Configuring the Remote Annex 6300 ............................................................................... 12
  Initial Setup with na ........................................................................................................ 12
  Setting PRI Channels Using Annex Manager ................................................................. 13
  Setting PRI Channels Using Quick2Config Annex ......................................................... 14
  Configuring Security ....................................................................................................... 15
Remote Annex Quick Start for UNIX

This guide is designed for quick installation and configuration of a Remote Annex with a UNIX host using either Annex Manager on the UNIX host or Quick2Config Annex, a Windows-based Annex management tool. The instructions apply to all Remote Annex models including the Remote Annex 6300.

The instructions in this guide cover:

- Loading Remote Annex software on a Windows system
- Using an installation script to copy the Remote Annex software from CD-ROM onto a UNIX host system (load host)
- Installing the Remote Annex hardware
- Setting the network addresses
- Booting the Remote Annex
- Configuring the Remote Annex using Annex Manager or Quick2Config Annex and the na utility

The sample commands and output that follow the instructions involve a Remote Annex on an Ethernet network with the IP address 192.9.200.62. The host system address is 192.9.200.55. Certain commands may vary depending on the particular UNIX platform you are using for the host.

See the following documents for additional information:

- Remote Annex Administrator's Guide for UNIX
- The appropriate Remote Annex hardware installation guide and installation notes
Installing Annex Software on the Windows Platform

The Annex Software CD-ROM contains a setup program that installs the Quick2Config Annex application and the na command line interface on the following platforms: Windows 95, Windows NT Server 3.51 and 4.0, and Windows NT Workstation 3.51 and 4.0.

The CD-ROM can also be used to install Quick2Config Annex on PC running Windows 3.1 or Windows for Workgroups 3.11.

If you are installing Quick2Config on a Windows 3.1 or Windows for Workgroups 3.11 platform, you may be required to install additional software that is provided on the CD-ROM. See Installing Remote Annex Network Software for Windows for details.

To install Quick2Config Annex and na on a Windows platform:

1. Put the CD-ROM into the system’s CD drive.
2. Use the File Manager to select the CD-ROM disk.
3. Double-click on the \setup.exe file.
4. Follow the dialog box instructions to select Install Software and then NA Command Line Interface and Quick2Config Annex.
5. When prompted for an installation directory, click the Next key to accept the default selection.

Installing Annex Software on the UNIX Host

Remote Annex UNIX software includes operating images that are downloaded to the Annex and utilities, such as the `erpcd` daemon that runs on the UNIX load host and responds to all Annex boot, dump and ACP security requests.

The software installation also includes Annex Manager, a graphical UNIX application for configuring and managing Remote Annexes.

Annex Manager Release 2.3 supports Remote Annex 6300 and 5393 running Release 13.3, and Annex3 and microAnnex XL running Release 10.0. If you are currently using Annex Manager for other Remote Annex models, you should maintain the previous version of Annex Manager in a separate directory.

You install the software on the UNIX load host using an installation script distributed with the software on the CD-ROM. To load the software:

1. Mount the CD-ROM device and access the installation script in the top level directory on the CD. To start the script enter:

```bash
# mkdir /cdrom
# mount /dev/scd0 /cdrom
# cd /cdrom
# ./install
```

The installation script contains two separate sequences, one for installing the Annex software, the other for installing Annex Manager. You can run both sequences in either order in one session, or you can install Annex software and Annex Manager in separate sessions. The script guides you through both installations, providing prompts, explanations and help files.
2. Make selections that are appropriate to the host platform, accepting the defaults as often as possible.

The installation script does the following:

- Extracts host-specific Remote Annex software from the CD, allowing you to choose which images to install
- Creates directories for Remote Annex utilities, operational images and Annex Manager
- If binary files are not available for the host, the script loads source code and allows you to build the images using a resident compiler
- Loads manual pages
- Enables Remote Annex security services
- Starts the Remote Annex erpcd daemon
- Loads Annex Manager
- Exits the script

If You Installed Annex Manager

If you installed Annex Manager using the script, you must now set environment variables. In the following sample commands, the PATH environment variable is set to the default installation directory, /usr/annex/gui_am_R2.3:

1. Set the DISPLAY environment to point to the host on which you want Annex Manager to appear. For example, if you want Annex Manager to be displayed on an X-terminal named tigger, use the following command:

   setenv DISPLAY tigger:0
2. **Put the /user/annex/gui_am_R2.3 directory in your path on the load host:**

   For C-shell:
   
   ```bash
   setenv PATH ${PATH}:/usr/annex/gui_am_R2.3/bin
   ```

   For Bourne and Korn shells:
   
   ```bash
   setenv PATH=$PATH:/usr/annex/gui_am_R2.3/bin
   export PATH
   ```

3. **Set GUI_AM_DIR as follows:**

   ```bash
   setenv GUI_AM_DIR /usr/annex/gui_am_R2.3
   ```

### Downloading the Images

Upon receiving a request from the Remote Annex, the `erpcd` daemon running on the UNIX load host downloads the operational images to the Remote Annex.

If you did not start `erpcd` when you installed the software, start the daemon now by entering:

```bash
/usr/annex/erpcd
```

### Hardware Setup

To set up the Remote Annex hardware:

1. **Connect the power and connect the Remote Annex to the network. If you are setting up a Remote Annex 6300 or 5393, connect DSU (DTE) to the Remote Annex and connect CSU (net) to the PRI line.**
2. **Connect the console cable and terminal.**
   - The Remote Annex 4000, Remote Annex 6100, and Remote 6300 have a dedicated console port.
   - The Remote Annex 2000 uses port 1 as the console port.
   - The Remote Annex 539x uses the service port on the 5000 chassis as the console port.

3. **Set the terminal to 9600 bps, 8 bits, 1 stop bit, no parity and no flow control.**

4. **For the Remote Annex 2000 or Remote Annex 4000, turn on the unit and immediately press the Test button on the front panel. Make sure the Test LED comes on.**

   For the Remote Annex 539x, Remote Annex 6100, or Remote Annex 6300, turn on the unit and immediately press the Setup button. Make sure the Setup LED comes on.

5. **If the LED next to the Test button is not lit, press Test again.**

---

**Network Address**

After the Remote Annex runs a series of hardware diagnostics, the terminal displays the monitor prompt. Enter address information (step 1) and, if you purchased a LAT key, the LAT key value (step 2).

Step 1 procedures are slightly different for the Remote Annex 6300.

For illustration purposes, sample response values indicate a Remote Annex on an Ethernet network with the IP address 192.9.200.62. The host system address is 192.9.200.55.
1. Enter `addr` and answer the prompts as shown in the example. To accept the default shown in brackets, press the key.

```
monitor:: addr
Enter Internet address [<invalid or uninitialized>]:
192.9.200.62
Enter Subnet mask [255.255.255.0]:
Enter preferred load host Internet address [<any host>]: 192.9.200.55
Preferred load host address: 192.9.200.55
Enter Broadcast address [0.0.0.0]:
Preferred dump address [0.0.0.0]:
Select type of IP packet encapsulation (ieee802/ethernet) [<ethernet>]:
Type of IP packet encapsulation: <ethernet>
monitor::
Load Broadcast y/n [y]:
```

1. If you have purchased a LAT key, enter the software key provided by Bay Networks.

```
monitor:: lat
Enter LAT KEY: [<invalid or uninitialized>]:
```
Booting the Remote Annex

At the Remote Annex, enter `boot` at the monitor prompt:

```
monitor:: boot
Enter boot file name [oper.46.enet]::
Requesting boot file "oper.46.enet".
Unanswered requests shown as "?", transmission errors as "*".
Requesting boot from 192.9.200.55 via Ethernet...
Booting from 192.9.200.55
Header received OK. Received data blocks shown as "."
. . . . . . . . . . . . . . .EOF
```

The boot file requested in the example is for a Remote Annex 4000 or 6100. Boot files for other models are:

- Remote Annex 2000 `oper.56.enet`
- Remote Annex 6300 `oper.63.enet`

Configuring the Remote Annex

You can configure Annex ports using either Quick2Config Annex or the `na` utilities. The following examples apply to non-RA 6300 Annexes that have been installed by using default selections. There is a separate configuration procedure for the Remote Annex 6300.

Before configuring the Remote Annex using either Annex Manager or Quick2Config Annex, invoke `na`, configure the Remote Annex to accept and process SNMP command sets, and exit `na`:

```
% na
command: annex 129.9.200.62
command: set annex allow_snmp_sets y
command: boot
command: quit
```
Using Annex Manager

The following instructions assume that you have installed Annex Manager R2.3 and are maintaining a previous version for use with Remote Annexes not running Release 13.3.

To configure Remote Annex Ports using Annex Manager:

1. Reset the GUI_AM_DIR variable and start Annex Manager:
   ```bash
   setenv GUI_AM_DIR /usr/annex/gui_am_R2.3
   $GUI_AM_DIR/bin/gui_am
   ```
2. Enter the name of the Annex or its IP address and click on Setup.
3. Fill out the items in the window and click on Apply.
4. Repeat Step 3 for screen in the Setup Option Menu in the upper right corner of the window.

Using Quick2Config Annex

To configure Remote Annex Ports using Quick2Config Annex:

1. At the Windows system, click on the Quick2Config icon to open the application.
2. Choose File > Add Annex, enter the name or IP address of the Remote Annex in the dialog box, and click on OK. Quick2Config Annex lists the Annex in the tree view on the left and displays a set of tab windows on the right.
3. Select the Annex and use the tab windows to review and modify Annex parameters.
4. Select each Annex port and use the tab windows to configure the port as a terminal or modem port.
5. Choose Help > Contents or click on Help in the dialog box for detailed information on using Quick2Config Annex.

See the on-line help or to Installing Remote Annex Network Software for Windows for configuration examples.

Using the na Utility

You can also configure Remote Annex ports with the na utilities as shown in the following examples involving non-RA 6300 Annexes installed using default selections.

Modems

Annex supports inbound, outbound and inbound/outbound modems. When entering port speed, set the highest speed supported by the modem. Do not select autobaud. Set the port parameters using na:

```
% na
command: annex 192.9.200.62
command: port 6
command: set port speed 115200
command: set port control_lines modem_control
command: set port input_flow_control start/stop
command: set port output_flow_control start/stop
command: set port type dial_in

Inbound Modem
command: set port mode auto_detect

Outbound Modem
command: set port mode slave

Inbound/Outbound
command: set port mode auto_adapt
command: reset port 6
command: quit
```
Serial Printer

Serial printers can be connected to any Annex serial port. In this example the printer is connected to port 12. Print instructions use the address L12.

Set the port parameters using `na` and send data to the printer using `aprint`:

```
% na
command: annex 192.9.200.62
command: port 12
command: set port speed 19200
command: set port type hardwired
command: set port mode slave
command: reset port 12
command: quit
% aprint -A 192.9.200.62 -L12 [filename]
```

Parallel Printer

The Annex parallel ports are configured for a Centronics interface, but can be set for other standards (port 2 in the examples).

Centronics Interface

Send data to the printer using `aprint`:

```
% aprint -A 192.9.200.62 -p1 [filename]
```

Dataproducts Interface

Set the printer type using `na` and send data to the printer using `aprint`:

```
% na
command: annex 192.9.200.62
command: printer 2
command: set printer type dataproducts
command: reset printer
command: quit
% aprint -A 192.9.200.62 -p2 [filename]
```
Configuring Security

By default, the Annex allows unrestricted access. If you want to configure Annex security, please refer to the Remote Annex Administrator’s Guide for UNIX for information on setting up security files such as `acp_passwd` and `acp_userinfo`.

If you have requested dial-up addresses from the `acp_dialup` file or from DHCP, refer to the Remote Annex Administrator’s Guide for UNIX for information on adding users to that file.

Check the Security tab and other Quick2Config tab windows to make sure the selections are appropriate to the configured security regime.

Configuring the Remote Annex 6300

Configuration of a Remote Annex 6300 or Remote Annex 5393 to handle dial-calls from ISDN and analog modems involves using both `na`, and Annex Manager or Quick2Config Annex.

Initial Setup with na

Before you configure the Remote Annex 6300 with Quick2Config Annex:

1. Obtain the following information from the telephone company:
   - Switch type
   - Facilities Data Link (FDL) format (ANSI or ATT)
   - Your phone numbers

   Separate phone numbers are required for V.120 and PPP calls. Asynchronous (voice) calls can be distinguished on either phone number.
2. Modify the following parameters in the external CSU through its front panel:

- FORMAT (FDL) = ANSI (or ATT)
- CLOCK = SLAVE
- DISTANCE = 133 ft.

3. Use na to enable SNMP sets, modify the PRI parameter switch_type if it is other than 5ess (NI-2 or DMS100, for example) and specify the distance between the Annex and the CSU.

```bash
% na
command: annex 129.9.200.62
command: set annex allow_snmp_sets y
command: set pri switch_type dms
command: set pri dsxl_line_length 101-135
command: boot
command: quit
```

**Setting PRI Channels Using Annex Manager**

To configure Remote Annex Ports using Annex Manager:

1. **Start Annex Manager:**
   ```bash
gui_am
   ```
2. **Enter the name of the Annex or its IP address and click on Setup.**
3. **Fill out the items in the window and click on Apply.**
4. **Repeat Step 3 for screen in the Setup Option Menu in the upper right corner of the window.**
Setting PRI Channels Using Quick2Config Annex

To configure PRI channels using Quick2Config Annex:

1. **At the Window system, click on the Quick2Config icon to open the application on the Windows system.**

2. **Choose File > Add Annex, enter the name or IP address of the Remote Annex in the Add Annex dialog box, and click on OK.**

   Quick2Config Annex lists the Annex in the tree view on the left.

3. **Click on the Annex name in the tree view.**

   Quick2Config displays a set of tab windows on the right.

4. **Choose Config > Edit Configuration File to modify Session Parameter Blocks.**

   Quick2Config opens an editor with the default configuration file. The Session Parameter Blocks are listed in the %pri section.

   ```
   %pri
   begin_session sync
called_no 123-555-1212
bearer data
call_action sync
set mode ppp
end_session

begin_session v120
called_no 123-555-1313
bearer data
call_action v120
set mode auto_detect
end_session

begin_session default
call_action modem
set mode auto_detect
end_session
   ```
5. Modify the telephone numbers for the Sync PPP and V120 blocks to reflect the numbers used to dial the Annex.

6. Copy and modify blocks for other telephone numbers.

7. Select the Annex and use the Call Defaults tab window to set parameters not specified in the Session Parameter Blocks.

8. Choose Autodetect in the Mode box and enter the Annex address as the Local address in the Dial-up Address box.


Configuring Security

By default, the Annex allows unrestricted access. If you want to configure Annex security, refer to the Remote Annex 6300 Supplement to the Remote Annex Administrator’s Guide for UNIX for information on setting up security files such as acp_passwd and acp_userinfo.

If you have requested dial-up addresses from the acp_dialup file, see the Remote Annex 6300 Supplement to the Remote Annex Administrator’s Guide for UNIX for information on adding users to that file.

Check the Security tab and other Quick2Config tab windows to make sure the selections are appropriate to the configured security regime.
Remote Annex

Quick Start for UNIX

Read before installing and using Remote Annex
Software Release 4.2

These installation notes contain information specific to this release. This information is not available elsewhere in the Remote Annex documentation.

Part No. 166-024-857    Rev. A
January 1997

Bay Networks
<table>
<thead>
<tr>
<th>Contents</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Installing Annex Software on the Windows Platform</td>
<td>2</td>
</tr>
<tr>
<td>Installing Annex Software on the UNIX Host</td>
<td>3</td>
</tr>
<tr>
<td>If You Installed Annex Manager</td>
<td>4</td>
</tr>
<tr>
<td>Downloading the Images</td>
<td>5</td>
</tr>
<tr>
<td>Hardware Setup</td>
<td>5</td>
</tr>
<tr>
<td>Network Address</td>
<td>6</td>
</tr>
<tr>
<td>Booting the Remote Annex</td>
<td>8</td>
</tr>
<tr>
<td>Configuring the Remote Annex</td>
<td>8</td>
</tr>
<tr>
<td>Using Annex Manager</td>
<td>9</td>
</tr>
<tr>
<td>Using Quick2Config Annex</td>
<td>9</td>
</tr>
<tr>
<td>Using the na Utility</td>
<td>10</td>
</tr>
<tr>
<td>Configuring Security</td>
<td>12</td>
</tr>
<tr>
<td>Configuring the Remote Annex 6300</td>
<td>12</td>
</tr>
<tr>
<td>Initial Setup with na</td>
<td>12</td>
</tr>
<tr>
<td>Setting PRI Channels Using Annex Manager</td>
<td>13</td>
</tr>
<tr>
<td>Setting PRI Channels Using Quick2Config Annex</td>
<td>14</td>
</tr>
<tr>
<td>Configuring Security</td>
<td>15</td>
</tr>
</tbody>
</table>
Contents
Remote Annex Quick Start for UNIX

This guide is designed for quick installation and configuration of a Remote Annex with a UNIX host using either Annex Manager on the UNIX host or Quick2Config Annex, a Windows-based Annex management tool. The instructions apply to all Remote Annex models including the Remote Annex 6300.

The instructions in this guide cover:

- Loading Remote Annex software on a Windows system
- Using an installation script to copy the Remote Annex software from CD-ROM onto a UNIX host system (load host)
- Installing the Remote Annex hardware
- Setting the network addresses
- Booting the Remote Annex
- Configuring the Remote Annex using Annex Manager or Quick2Config Annex and the na utility

The sample commands and output that follow the instructions involve a Remote Annex on an Ethernet network with the IP address 192.9.200.62. The host system address is 192.9.200.55. Certain commands may vary depending on the particular UNIX platform you are using for the host.

See the following documents for additional information:

- Remote Annex Administrator's Guide for UNIX
- The appropriate Remote Annex hardware installation guide and installation notes
Installing Annex Software on the Windows Platform

The Annex Software CD-ROM contains a setup program that installs the Quick2Config Annex application and the na command line interface on the following platforms: Windows 95, Windows NT Server 3.51 and 4.0, and Windows NT Workstation 3.51 and 4.0.

The CD-ROM can also be used to install Quick2Config Annex on PC running Windows 3.1 or Windows for Workgroups 3.11.

If you are installing Quick2Config on a Windows 3.1 or Windows for Workgroups 3.11 platform, you may be required to install additional software that is provided on the CD-ROM. See Installing Remote Annex Network Software for Windows for details.

To install Quick2Config Annex and na on a Windows platform:

1. Put the CD-ROM into the system’s CD drive.
2. Use the File Manager to select the CD-ROM disk.
4. Follow the dialog box instructions to select Install Software and then NA Command Line Interface and Quick2Config Annex.
5. When prompted for an installation directory, click the Next key to accept the default selection.

Installing Annex Software on the UNIX Host

Remote Annex UNIX software includes operating images that are downloaded to the Annex and utilities, such as the *erpcd* daemon that runs on the UNIX load host and responds to all Annex boot, dump and ACP security requests.

The software installation also includes Annex Manager, a graphical UNIX application for configuring and managing Remote Annexes.

Annex Manager Release 2.3 supports Remote Annex 6300 and 5393 running Release 13.3, and Annex3 and microAnnex XL running Release 10.0. If you are currently using Annex Manager for other Remote Annex models, you should maintain the previous version of Annex Manager in a separate directory.

You install the software on the UNIX load host using an installation script distributed with the software on the CD-ROM. To load the software:

1. **Mount the CD-ROM device and access the installation script in the top level directory on the CD. To start the script enter:**

   ```
   # mkdir /cdrom
   # mount /dev/scd0 /cdrom
   # cd /cdrom
   # ./install
   ```

   The installation script contains two separate sequences, one for installing the Annex software, the other for installing Annex Manager. You can run both sequences in either order in one session, or you can install Annex software and Annex Manager in separate sessions. The script guides you through both installations, providing prompts, explanations and help files.
2. Make selections that are appropriate to the host platform, accepting the defaults as often as possible.

   The installation script does the following:
   - Extracts host-specific Remote Annex software from the CD, allowing you to choose which images to install
   - Creates directories for Remote Annex utilities, operational images and Annex Manager
   - If binary files are not available for the host, the script loads source code and allows you to build the images using a resident compiler
   - Loads manual pages
   - Enables Remote Annex security services
   - Starts the Remote Annex erpcd daemon
   - Loads Annex Manager
   - Exits the script

If You Installed Annex Manager

   If you installed Annex Manager using the script, you must now set environment variables. In the following sample commands, the PATH environment variable is set to the default installation directory, /usr/annex/gui_am_R2.3:

   1. Set the DISPLAY environment to point to the host on which you want Annex Manager to appear. For example, if you want Annex Manager to be displayed on an X-terminal named tigger, use the following command:

      setenv DISPLAY tigger:0
2. **Put the /user/annex/gui_am_R2.3 directory in your path on the load host:**
   
   For C-shell:
   ```
   setenv PATH ${PATH}:/usr/annex/gui_am_R2.3/bin
   ```
   
   For Bourne and Korn shells:
   ```
   setenv PATH=$PATH:/usr/annex/gui_am_R2.3/bin
   export PATH
   ```

3. **Set GUI_AM_DIR as follows:**

   ```
   setenv GUI_AM_DIR /usr/annex/gui_am_R2.3
   ```

### Downloading the Images

Upon receiving a request from the Remote Annex, the erpcd daemon running on the UNIX load host downloads the operational images to the Remote Annex.

If you did not start `erpcd` when you installed the software, start the daemon now by entering:

```
/usr/annex/erpcd
```

### Hardware Setup

To set up the Remote Annex hardware:

1. **Connect the power and connect the Remote Annex to the network. If you are setting up a Remote Annex 6300 or 5393, connect DSU (DTE) to the Remote Annex and connect CSU (net) to the PRI line.**
2. Connect the console cable and terminal.
   • The Remote Annex 4000, Remote Annex 6100, and Remote 6300 have a dedicated console port.
   • The Remote Annex 2000 uses port 1 as the console port.
   • The Remote Annex 539x uses the service port on the 5000 chassis as the console port.

3. Set the terminal to 9600 bps, 8 bits, 1 stop bit, no parity and no flow control.

4. For the Remote Annex 2000 or Remote Annex 4000, turn on the unit and immediately press the button on the front panel. Make sure the Test LED comes on.

   For the Remote Annex 539x, Remote Annex 6100, or Remote Annex 6300, turn on the unit and immediately press the button. Make sure the Setup LED comes on.

5. If the LED next to the button is not lit, press again.

Network Address

After the Remote Annex runs a series of hardware diagnostics, the terminal displays the monitor prompt. Enter address information (step 1) and, if you purchased a LAT key, the LAT key value (step 2).

Step 1 procedures are slightly different for the Remote Annex 6300.

For illustration purposes, sample response values indicate a Remote Annex on an Ethernet network with the IP address 192.9.200.62. The host system address is 192.9.200.55.
1. Enter addr and answer the prompts as shown in the example. To accept the default shown in brackets, press the key.

```
monitor:: addr
Enter Internet address [<invalid or uninitialized>]: 192.9.200.62
Enter Subnet mask [255.255.255.0]:
Enter preferred load host Internet address [<any host>]: 192.9.200.55
Preferred load host address: 192.9.200.55
Enter Broadcast address [0.0.0.0]:
Preferred dump address [0.0.0.0]:
Select type of IP packet encapsulation (ieee802/ethernet) [<ethernet>]:
Type of IP packet encapsulation: <ethernet>
monitor::
Load Broadcast y/n [y]:
```

2. If you have purchased a LAT key, enter the software key provided by Bay Networks.

```
monitor:: lat
Enter LAT KEY: [<uninitialized>]:
```
Booting the Remote Annex

At the Remote Annex, enter `boot` at the monitor prompt:

```
monitor:: boot
Enter boot file name [oper.46.enet]::
Requesting boot file "oper.46.enet".
Unanswered requests shown as "?", transmission errors as "*".
Requesting boot from 192.9.200.55 via Ethernet...
Booting from 192.9.200.55
Header received OK. Received data blocks shown as "."
. . . . . . . . . . . . . . . . EOF
```

The boot file requested in the example is for a Remote Annex 4000 or 6100. Boot files for other models are:

- Remote Annex 2000 `oper.56.enet`
- Remote Annex 6300 `oper.63.enet`

Configuring the Remote Annex

You can configure Annex ports using either Quick2Config Annex or the `na` utilities. The following examples apply to non-RA 6300 Annexes that have been installed by using default selections. There is a separate configuration procedure for the Remote Annex 6300.

Before configuring the Remote Annex using either Annex Manager or Quick2Config Annex, invoke `na`, configure the Remote Annex to accept and process SNMP command sets, and exit `na`:

```
% na
command: annex 129.9.200.62
command: set annex allow_snmp_sets y
command: boot
command: quit
```
Using Annex Manager

The following instructions assume that you have installed Annex Manager R2.3 and are maintaining a previous version for use with Remote Annexes not running Release 13.3.

To configure Remote Annex Ports using Annex Manager:

1. **Reset the GUI_AM_DIR variable and start Annex Manager:**
   ```
   setenv GUI_AM_DIR /usr/annex/gui_am_R2.3
   $GUI_AM_DIR/bin/gui_am
   ```
2. **Enter the name of the Annex or its IP address and click on Setup.**
3. **Fill out the items in the window and click on Apply.**
4. **Repeat Step 3. for screen in the Setup Option Menu in the upper right corner of the window.**

Using Quick2Config Annex

To configure Remote Annex Ports using Quick2Config Annex:

1. **At the Windows system, click on the Quick2Config icon to open the application.**
2. **Choose File > Add Annex, enter the name or IP address of the Remote Annex in the dialog box, and click on OK.**
   
   Quick2Config Annex lists the Annex in the tree view on the left and displays a set of tab windows on the right.
3. **Select the Annex and use the tab windows to review and modify Annex parameters.**
4. **Select each Annex port and use the tab windows to configure the port as a terminal or modem port.**
5. Choose Help > Contents or click on Help in the dialog box for detailed information on using Quick2Config Annex.

See the on-line help or to Installing Remote Annex Network Software for Windows for configuration examples.

Using the na Utility

You can also configure Remote Annex ports with the na utilities as shown in the following examples involving non-RA 6300 Annexes installed using default selections.

Modems

Annex supports inbound, outbound and inbound/outbound modems. When entering port speed, set the highest speed supported by the modem. Do not select autobaud. Set the port parameters using na:

```
% na
command: annex 192.9.200.62
command: port 6
command: set port speed 115200
command: set port control_lines modem_control
command: set port input_flow_control start/stop
command: set port output_flow_control start/stop
command: set port type dial_in

Inbound Modem
command: set port mode auto_detect

Outbound Modem
command: set port mode slave

Inbound/Outbound
command: set port mode auto_adapt
command: reset port 6
command: quit
```
Serial Printer

Serial printers can be connected to any Annex serial port. In this example the printer is connected to port 12. Print instructions use the address L12.

Set the port parameters using na and send data to the printer using aprint:

```
% na
command: annex 192.9.200.62
command: port 12
command: set port speed 19200
command: set port type hardwired
command: set port mode slave
command: reset port 12
command: quit
% aprint -A 192.9.200.62 -L12 [filename]
```

Parallel Printer

The Annex parallel ports are configured for a Centronics interface, but can be set for other standards (port 2 in the examples).

Centronics Interface

Send data to the printer using aprint:

```
% aprint -A 192.9.200.62 -p1 [filename]
```

Dataproductions Interface

Set the printer type using na and send data to the printer using aprint:

```
% na
command: annex 192.9.200.62
command: printer 2
command: set printer type dataproductions
command: reset printer
command: quit
% aprint -A 192.9.200.62 -p2 [filename]
```
Configuring Security

By default, the Annex allows unrestricted access. If you want to configure Annex security, please refer to the *Remote Annex Administrator’s Guide for UNIX* for information on setting up security files such as `acp_passwd` and `acp_userinfo`.

If you have requested dial-up addresses from the `acp_dialup` file or from DHCP, refer to the *Remote Annex Administrator’s Guide for UNIX* for information on adding users to that file.

Check the Security tab and other Quick2Config tab windows to make sure the selections are appropriate to the configured security regime.

Configuring the Remote Annex 6300

Configuration of a Remote Annex 6300 or Remote Annex 5393 to handle dial-calls from ISDN and analog modems involves using both `na`, and Annex Manager or Quick2Config Annex.

Initial Setup with na

Before you configure the Remote Annex 6300 with Quick2Config Annex:

1. Obtain the following information from the telephone company:
   
   • Switch type
   
   • Facilities Data Link (FDL) format (ANSI or ATT)
   
   • Your phone numbers

   Separate phone numbers are required for V.120 and PPP calls. Asynchronous (voice) calls can be distinguished on either phone number.
2. Modify the following parameters in the external CSU through its front panel:

- FORMAT (FDL) = ANSI (or ATT)
- CLOCK = SLAVE
- DISTANCE = 133 ft.

3. Use `na` to enable SNMP sets, modify the PRI parameter `switch_type` if it is other than 5ess (NI-2 or DMS100, for example) and specify the distance between the Annex and the CSU.

   ```
   % na
   command: annex 129.9.200.62
   command: set annex allow_snmp_sets y
   command: set pri switch_type dms
   command: set pri dsxl_line_length 101-135
   command: boot
   command: quit
   ```

Setting PRI Channels Using Annex Manager

To configure Remote Annex Ports using Annex Manager:

1. Start Annex Manager:

   `gui_am`

2. Enter the name of the Annex or its IP address and click on `Setup`.

3. Fill out the items in the window and click on `Apply`.

4. Repeat Step 3 for screen in the Setup Option Menu in the upper right corner of the window.
Setting PRI Channels Using Quick2Config Annex

To configure PRI channels using Quick2Config Annex:

1. **At the Window system, click on the Quick2Config icon to open the application on the Windows system.**

2. **Choose** File > Add Annex, **enter the name or IP address of the Remote Annex in the Add Annex dialog box, and click on [OK].**

   Quick2Config Annex lists the Annex in the tree view on the left.

3. **Click on the Annex name in the tree view.**

   Quick2Config displays a set of tab windows on the right.

4. **Choose** Config > Edit Configuration File to **modify Session Parameter Blocks.**

   Quick2Config opens an editor with the default configuration file. The Session Parameter Blocks are listed in the `%pri` section.

```
%pri
begin_session sync
called_no 123-555-1212
bearer data
call_action sync
set mode ppp
end_session

begin_session v120
called_no 123-555-1313
bearer data
call_action v120
set mode auto_detect
end_session

begin_session default
call_action modem
set mode auto_detect
end_session
```
5. Modify the telephone numbers for the Sync PPP and V120 blocks to reflect the numbers used to dial the Annex.

6. Copy and modify blocks for other telephone numbers.

7. Select the Annex and use the Call Defaults tab window to set parameters not specified in the Session Parameter Blocks.

8. Choose Autodetect in the Mode box and enter the Annex address as the Local address in the Dial-up Address box.

9. Choose Help > Contents or click on \[Help\] in the dialog boxes for detailed information on using Quick2Config Annex.

Refer to Installing Remote Annex Network Software for Windows NT for configuration examples.

**Configuring Security**

By default, the Annex allows unrestricted access. If you want to configure Annex security, refer to the Remote Annex 6300 Supplement to the Remote Annex Administrator’s Guide for UNIX for information on setting up security files such as `acp_passwd` and `acp_userinfo`.

If you have requested dial-up addresses from the `acp_dialup` file, see the Remote Annex 6300 Supplement to the Remote Annex Administrator’s Guide for UNIX for information on adding users to that file.

Check the Security tab and other Quick2Config tab windows to make sure the selections are appropriate to the configured security regime.
Remote Annex

Quick Start for UNIX

Read before installing and using Remote Annex
Software Release 4.2

These installation notes contain information specific to this release. This information is not available elsewhere in the Remote Annex documentation.
Contents

Installing Annex Software on the Windows Platform ................................................. 2
Installing Annex Software on the UNIX Host .......................................................... 3
   If You Installed Annex Manager ............................................................................ 4
   Downloading the Images ....................................................................................... 5
Hardware Setup ......................................................................................................... 5
Network Address ....................................................................................................... 6
Booting the Remote Annex ....................................................................................... 8
Configuring the Remote Annex ................................................................................ 8
   Using Annex Manager ............................................................................................ 9
   Using Quick2Config Annex .................................................................................. 9
   Using the na Utility ............................................................................................... 10
   Configuring Security .............................................................................................. 12
Configuring the Remote Annex 6300 ....................................................................... 12
   Initial Setup with na ............................................................................................. 12
   Setting PRI Channels Using Annex Manager ......................................................... 13
   Setting PRI Channels Using Quick2Config Annex ............................................... 14
   Configuring Security .............................................................................................. 15
Remote Annex Quick Start for UNIX

This guide is designed for quick installation and configuration of a Remote Annex with a UNIX host using either Annex Manager on the UNIX host or Quick2Config Annex, a Windows-based Annex management tool. The instructions apply to all Remote Annex models including the Remote Annex 6300.

The instructions in this guide cover:

- Loading Remote Annex software on a Windows system
- Using an installation script to copy the Remote Annex software from CD-ROM onto a UNIX host system (load host)
- Installing the Remote Annex hardware
- Setting the network addresses
- Booting the Remote Annex
- Configuring the Remote Annex using Annex Manager or Quick2Config Annex and the na utility

The sample commands and output that follow the instructions involve a Remote Annex on an Ethernet network with the IP address 192.9.200.62. The host system address is 192.9.200.55. Certain commands may vary depending on the particular UNIX platform you are using for the host.

See the following documents for additional information:

- Remote Annex Administrator’s Guide for UNIX
- The appropriate Remote Annex hardware installation guide and installation notes
Installing Annex Software on the Windows Platform

The Annex Software CD-ROM contains a setup program that installs the Quick2Config Annex application and the na command line interface on the following platforms: Windows 95, Windows NT Server 3.51 and 4.0, and Windows NT Workstation 3.51 and 4.0.

The CD-ROM can also be used to install Quick2Config Annex on PC running Windows 3.1 or Windows for Workgroups 3.11.

If you are installing Quick2Config on a Windows 3.1 or Windows for Workgroups 3.11 platform, you may be required to install additional software that is provided on the CD-ROM. See Installing Remote Annex Network Software for Windows for details.

To install Quick2Config Annex and na on a Windows platform:

1. **Put the CD-ROM into the system’s CD drive.**
2. **Use the File Manager to select the CD-ROM disk.**
3. **Double-click on the setup.exe file.**
4. **Follow the dialog box instructions to select** Install Software and then NA Command Line Interface and Quick2Config Annex.
5. **When prompted for an installation directory, click the Next key to accept the default selection.**

Installing Annex Software on the UNIX Host

Remote Annex UNIX software includes operating images that are downloaded to the Annex and utilities, such as the erpcd daemon that runs on the UNIX load host and responds to all Annex boot, dump and ACP security requests.

The software installation also includes Annex Manager, a graphical UNIX application for configuring and managing Remote Annexes.

Annex Manager Release 2.3 supports Remote Annex 6300 and 5393 running Release 13.3, and Annex3 and microAnnex XL running Release 10.0. If you are currently using Annex Manager for other Remote Annex models, you should maintain the previous version of Annex Manager in a separate directory.

You install the software on the UNIX load host using an installation script distributed with the software on the CD-ROM. To load the software:

1. **Mount the CD-ROM device and access the installation script in the top level directory on the CD. To start the script enter:**

   ```
   # mkdir /cdrom
   # mount /dev/scd0 /cdrom
   # cd /cdrom
   # ./install
   ```

   The installation script contains two separate sequences, one for installing the Annex software, the other for installing Annex Manager. You can run both sequences in either order in one session, or you can install Annex software and Annex Manager in separate sessions. The script guides you through both installations, providing prompts, explanations and help files.
2. Make selections that are appropriate to the host platform, accepting the defaults as often as possible.

The installation script does the following:

- Extracts host-specific Remote Annex software from the CD, allowing you to choose which images to install
- Creates directories for Remote Annex utilities, operational images and Annex Manager
- If binary files are not available for the host, the script loads source code and allows you to build the images using a resident compiler
- Loads manual pages
- Enables Remote Annex security services
- Starts the Remote Annex erpcd daemon
- Loads Annex Manager
- Exits the script

If You Installed Annex Manager

If you installed Annex Manager using the script, you must now set environment variables. In the following sample commands, the PATH environment variable is set to the default installation directory, /usr/annex/gui_am_R2.3:

1. Set the DISPLAY environment to point to the host on which you want Annex Manager to appear. For example, if you want Annex Manager to be displayed on an X-terminal named tigger, use the following command:

```bash
setenv DISPLAY tigger:0
```
2. **Put the /user/annex/gui_am_R2.3 directory in your path on the load host:**
   
   For C-shell:
   ```bash
   setenv PATH ${PATH}:/usr/annex/gui_am_R2.3/bin
   ```
   
   For Bourne and Korn shells:
   ```bash
   setenv PATH=$PATH:/usr/annex/gui_am_R2.3/bin
   export PATH
   ```
   
3. **Set GUI_AM_DIR as follows:**
   ```bash
   setenv GUI_AM_DIR /usr/annex/gui_am_R2.3
   ```

### Downloading the Images

Upon receiving a request from the Remote Annex, the `erpcd` daemon running on the UNIX load host downloads the operational images to the Remote Annex.

If you did not start `erpcd` when you installed the software, start the daemon now by entering:

```bash
/usr/annex/erpcd
```

### Hardware Setup

To set up the Remote Annex hardware:

1. **Connect the power and connect the Remote Annex to the network.** If you are setting up a Remote Annex 6300 or 5393, connect DSU (DTE) to the Remote Annex and connect CSU (net) to the PRI line.
2. Connect the console cable and terminal.
   • The Remote Annex 4000, Remote Annex 6100, and Remote 6300 have a dedicated console port.
   • The Remote Annex 2000 uses port 1 as the console port.
   • The Remote Annex 539x uses the service port on the 5000 chassis as the console port.

3. Set the terminal to 9600 bps, 8 bits, 1 stop bit, no parity and no flow control.

4. For the Remote Annex 2000 or Remote Annex 4000, turn on the unit and immediately press the \text{Test} button on the front panel. Make sure the Test LED comes on.

   For the Remote Annex 539x, Remote Annex 6100, or Remote Annex 6300, turn on the unit and immediately press the \text{Setup} button. Make sure the Setup LED comes on.

5. If the LED next to the \text{Test} button is not lit, press \text{Test} again.

Network Address

After the Remote Annex runs a series of hardware diagnostics, the terminal displays the monitor prompt. Enter address information (step 1) and, if you purchased a LAT key, the LAT key value (step 2).

Step 1 procedures are slightly different for the Remote Annex 6300.

For illustration purposes, sample response values indicate a Remote Annex on an Ethernet network with the IP address 192.9.200.62. The host system address is 192.9.200.55.
1. Enter `addr` and answer the prompts as shown in the example. To accept the default shown in brackets, press the key.

   monitor:: \text{addr}
   Enter Internet address [invalid or uninitialized]:: 192.9.200.62
   Enter Subnet mask [255.255.255.0]::
   Enter preferred load host Internet address [any host]:: 192.9.200.55
   Preferred load host address: 192.9.200.55
   Enter Broadcast address [0.0.0.0]::
   Preferred dump address [0.0.0.0]::
   Select type of IP packet encapsulation (ieee802/ethernet) [ethernet]::
   Type of IP packet encapsulation: ethernet
   monitor::
   Load Broadcast y/n [y]::

2. If you have purchased a LAT key, enter the software key provided by Bay Networks.

   monitor:: \text{lat}
   Enter LAT KEY: [uninitialized]::
Booting the Remote Annex

At the Remote Annex, enter `boot` at the monitor prompt:

```
monitor:: boot
Enter boot file name [oper.46.enet]::
Requesting boot file "oper.46.enet".
Unanswered requests shown as "?", transmission errors as "*".
Requesting boot from 192.9.200.55 via Ethernet...
Booting from 192.9.200.55
Header received OK. Received data blocks shown as "."
..........................EOF
```

The boot file requested in the example is for a Remote Annex 4000 or 6100. Boot files for other models are:

- Remote Annex 2000 oper.56.enet
- Remote Annex 6300 oper.63.enet

Configuring the Remote Annex

- Remote Annex 2000
- Remote Annex 4000
- Remote Annex 539x
- Remote Annex 6100

You can configure Annex ports using either Quick2Config Annex or the `na` utilities. The following examples apply to non-RA 6300 Annexes that have been installed by using default selections. There is a separate configuration procedure for the Remote Annex 6300.

Before configuring the Remote Annex using either Annex Manager or Quick2Config Annex, invoke `na`, configure the Remote Annex to accept and process SNMP command sets, and exit `na`:

```
% na
command: annex 129.9.200.62
command: set annex allow_snmp_sets y
command: boot
command: quit
```
Using Annex Manager

The following instructions assume that you have installed Annex Manager R2.3 and are maintaining a previous version for use with Remote Annexes not running Release 13.3.

To configure Remote Annex Ports using Annex Manager:

1. Reset the GUI_AM_DIR variable and start Annex Manager:
   
   ```
   setenv GUI_AM_DIR /usr/annex/gui_am_R2.3
   $GUI_AM_DIR/bin/gui_am
   ```

2. Enter the name of the Annex or its IP address and click on Setup.

3. Fill out the items in the window and click on Apply.

4. Repeat Step 3 for screen in the Setup Option Menu in the upper right corner of the window.

Using Quick2Config Annex

To configure Remote Annex Ports using Quick2Config Annex:

1. At the Windows system, click on the Quick2Config icon to open the application.

2. Choose File > Add Annex, enter the name or IP address of the Remote Annex in the dialog box, and click on OK.

   Quick2Config Annex lists the Annex in the tree view on the left and displays a set of tab windows on the right.

3. Select the Annex and use the tab windows to review and modify Annex parameters.

4. Select each Annex port and use the tab windows to configure the port as a terminal or modem port.
5. Choose Help > Contents or click on Help in the dialog box for detailed information on using Quick2Config Annex.

See the on-line help or to Installing Remote Annex Network Software for Windows for configuration examples.

Using the na Utility

You can also configure Remote Annex ports with the na utilities as shown in the following examples involving non-RA 6300 Annexes installed using default selections.

Modems

Annex supports inbound, outbound and inbound/outbound modems. When entering port speed, set the highest speed supported by the modem. Do not select autobaud. Set the port parameters using na:

```
% na
command: annex 192.9.200.62
command: port 6
command: set port speed 115200
command: set port control_lines modem_control
command: set port input_flow_control start/stop
command: set port output_flow_control start/stop
command: set port type dial_in
command: set port mode auto_detect
command: set port mode slave
command: set port mode auto_adapt
command: reset port 6
command: quit
```
Serial Printer

Serial printers can be connected to any Annex serial port. In this example the printer is connected to port 12. Print instructions use the address L12.

Set the port parameters using na and send data to the printer using aprint:

```bash
% na
command: annex 192.9.200.62
command: port 12
command: set port speed 19200
command: set port type hardwired
command: set port mode slave
command: reset port 12
command: quit
% aprint -A 192.9.200.62 -L12 [filename]
```

Parallel Printer

The Annex parallel ports are configured for a Centronics interface, but can be set for other standards (port 2 in the examples).

Send data to the printer using aprint:

```bash
% aprint -A 192.9.200.62 -p1 [filename]
```

Set the printer type using na and send data to the printer using aprint:

```bash
% na
command: annex 192.9.200.62
command: printer 2
command: set printer type dataproducts
command: reset printer
command: quit
% aprint -A 192.9.200.62 -p2 [filename]
```
Configuring Security

By default, the Annex allows unrestricted access. If you want to configure Annex security, please refer to the Remote Annex Administrator’s Guide for UNIX for information on setting up security files such as `acp_passwd` and `acp_userinfo`.

If you have requested dial-up addresses from the `acp_dialup` file or from DHCP, refer to the Remote Annex Administrator’s Guide for UNIX for information on adding users to that file.

Check the Security tab and other Quick2Config tab windows to make sure the selections are appropriate to the configured security regime.

Configuring the Remote Annex 6300

Configuration of a Remote Annex 6300 or Remote Annex 5393 to handle dial-calls from ISDN and analog modems involves using both `na`, and Annex Manager or Quick2Config Annex.

Initial Setup with na

Before you configure the Remote Annex 6300 with Quick2Config Annex:

1. **Obtain the following information from the telephone company:**
   - Switch type
   - Facilities Data Link (FDL) format (ANSI or ATT)
   - Your phone numbers

   Separate phone numbers are required for V.120 and PPP calls. Asynchronous (voice) calls can be distinguished on either phone number.
2. Modify the following parameters in the external CSU through its front panel:

   FORMAT (FDL) = ANSI (or ATT)
   CLOCK = SLAVE
   DISTANCE = 133 ft.

3. Use na to enable SNMP sets, modify the PRI parameter switch_type if it is other than 5ess (NI-2 or DMS100, for example) and specify the distance between the Annex and the CSU.

   % na
   command: annex 129.9.200.62
   command: set annex allow_snmp_sets y
   command: set pri switch_type dms
   command: set pri dsxl_line_length 101-135
   command: boot
   command: quit

Setting PRI Channels Using Annex Manager

To configure Remote Annex Ports using Annex Manager:

1. Start Annex Manager:

   gui_am

2. Enter the name of the Annex or its IP address and click on Setup.

3. Fill out the items in the window and click on Apply.

4. Repeat Step 3 for screen in the Setup Option Menu in the upper right corner of the window.
Setting PRI Channels Using Quick2Config Annex

To configure PRI channels using Quick2Config Annex:

1. **At the Window system, click on the Quick2Config icon to open the application on the Windows system.**

2. **Choose File > Add Annex, enter the name or IP address of the Remote Annex in the Add Annex dialog box, and click on **OK**.**

   Quick2Config Annex lists the Annex in the tree view on the left.

3. **Click on the Annex name in the tree view.**

   Quick2Config displays a set of tab windows on the right.

4. **Choose Config > Edit Configuration File to modify Session Parameter Blocks.**

   Quick2Config opens an editor with the default configuration file. The Session Parameter Blocks are listed in the `%pri` section.

   ```
   %pri
   begin_session sync
called_no 123-555-1212
bearer data
call_action sync
set mode ppp
end_session

begin_session v120
called_no 123-555-1313
bearer data
call_action v120
set mode auto_detect
end_session

begin_session default
call_action modem
set mode auto_detect
end_session
   ```
5. Modify the telephone numbers for the Sync PPP and V120 blocks to reflect the numbers used to dial the Annex.

6. Copy and modify blocks for other telephone numbers.

7. Select the Annex and use the Call Defaults tab window to set parameters not specified in the Session Parameter Blocks.

8. Choose Autodetect in the Mode box and enter the Annex address as the Local address in the Dial-up Address box.

9. Choose Help > Contents or click on [Help] in the dialog boxes for detailed information on using Quick2Config Annex.

Refer to Installing Remote Annex Network Software for Windows NT for configuration examples.

Configuring Security

By default, the Annex allows unrestricted access. If you want to configure Annex security, refer to the Remote Annex 6300 Supplement to the Remote Annex Administrator’s Guide for UNIX for information on setting up security files such as acp_passwd and acp_userinfo.

If you have requested dial-up addresses from the acp_dialup file, see the Remote Annex 6300 Supplement to the Remote Annex Administrator’s Guide for UNIX for information on adding users to that file.

Check the Security tab and other Quick2Config tab windows to make sure the selections are appropriate to the configured security regime.